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While Deltek has attempted to verify that the information in this document is accurate and 
complete, some typographical or technical errors may exist. The recipient of this document is 
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The information contained in this publication is effective as of the publication date below and is 
subject to change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are 
reserved. No part of this document may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, or translated into another language, without the prior written 
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This edition published March 2017. 

© Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and 
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Introduction 
This quick start guide is designed to help you learn the basic steps in creating and deploying 
extensibility. Refer to other documentation for deeper or more detail discussion of the subject. 

 Deltek Costpoint Extensibility Designer User Guide — Navigating and using the 
Extensibility Designer to create Costpoint extensions 

 Deltek Costpoint Screen Customization and Business Logic Extensibility — Concepts 
and features of Costpoint extensibility 

 Deltek Costpoint Extensibility Coding Guide — Creating business logic extensions with 
stored procedures and java classes 
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General Steps Overview 
There are 12 general steps for creating and deploying an extension, divided into the following 
categories: 

 Checking requirements and setting up 

 Creating the extension 

 Testing the extension 

 Packaging the extension 

 Deploying the extensibility package to another system 

 Verifying the Deployment to the system 

Check the Requirements and Set Up Extensibility 

Step Description 

1 License Requirement.  

2 Enable System for Extensibility 

3 Enable Costpoint user for Extensibility Designer 

Create the Extension  

Step Description 

4 Log In to Extensibility Designer 

5 Create a project 

6 Create a unit for the project 

7 Create an extension  

Test the Extension  

Step Description 

8 Test the Extension 
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Package the Extension  

Step Description 

9 Run Export Script 

10 Package the Extension 

Deploy the Extensibility Package to Another System 

Step Description 

11 Run DBWizard tool to deploy the extensibility package 

Verify the Deployment to the System 

Step Description 

12 Repeat “Step 8: Test the Extension” to verify the extension was successfully deployed to 
the system in Step 11.  
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Step 1: License Requirement 
You must have the license for Extensibility in order to use the tool.  

To verify that you have the Extensibility license: 

1. In Costpoint, open the View Costpoint License Information application.  

2. In the Licensed Added-On Modules grid, verify that there is an entry for Extensibility. 
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Step 2: Enable System for Extensibility 
To enable the system for extensibility: 

1. Start the Costpoint Configuration Utility by running CPWebConfigUtility.cmd located on 
the application server in the \deltek\costpoint\70\bin folder. 

 

Make sure the server is running before you start this utility. 

2. Select to configure Costpoint Application Configuration.  

3. When the Costpoint Configuration Utility screen displays, perform the following: 

a. From the Displaying System drop-down list, select the appropriate system. 

b. Click the Extensibility tab. 

c.  Click Enabled to enable the system for extensibility. 
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Step 3: Enable Costpoint User for Extensibility 
Designer 
To enable a Costpoint user for the Extensibility Designer tool: 

1. In the Costpoint system selected in Step 2, open the Manage Users application. 

2. Query and select a user that will be using the Extensibility Designer. 

3. On the Authentication tab, select the Allow Access to Extensibility Console check box. 

 
This user can now log in to the Extensibility Designer with their Costpoint user ID and password. 

 

This procedure does not change any security rights for the user within Costpoint. It only allows 
this user to log in to the Extensibility Designer in order to create customization work. 
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Step 4: Log In to Extensibility Designer 
To log in to the Extensibility Designer: 

1. Start the Extensibility Designer by running CPWebExtDesigner.cmd located on the 
application server in the \deltek\costpoint\70\bin folder. 

2. On the Deltek’s J2EE Application Designer – Login dialog box, enter the User ID and 
Password for the user enabled in Step 3. 

 
3. Click Login. 

If the user is not enabled to use the Extensibility Designer, the following message displays. 
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Step 5: Create a Project 
A project is an umbrella under which the units created for the project reside. A project does not 
contain any logic except for tracking and grouping the work done in the Extensibility Designer. A 
project helps differentiate work done by different companies in case you have contracted 
customization work out to third-party companies.  

To create a new project: 

1. Click the New icon, and then click Extensibility Project on the shortcut menu, or click 
Object » New » Extensibility Project. 

 
2. On the New Extensibility Project dialog box, enter the following information: 

 Id — Enter the new project’s ID after the XT_ prefix. All project IDs must start with 
XT_. 

 Name — Enter the name for the new project. 

 Vendor — If needed to further identify the new project, enter the name of the third-
party software integrator doing the customization for a Costpoint customer. 

 Project Version — Enter a version number if you have revision to your 
customization project in the future. 

 
3. Click Ok to save. 
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4. When asked to create the folder to contain the files for this project, click Yes. 

 
The location for the files is not critical as long as the structure starting with \com\ is preserved. In 
this case, the structure is: 

\com\deltek\enterprise\extensions\xt_project_x\dbscripts\admin, where xt_project_x is the 
project ID 

If you develop java classes as part of the extension, the application expects the java package to 
follow this naming convention, so every package will have unique name. 
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Step 6: Create a Unit for the Project 
An Extensibility Unit contains a set of changes to applications, screens, reports, or processes to 
be assigned as a whole to user(s) or user group(s) inside Costpoint. If there are different changes 
to be applied to different users or groups, they should be implemented in separate units.  

To create a new unit for a project:  

1. Click the New icon, and then click Extensibility Unit on the shortcut menu, or click 
Object » New » Extensibility Unit. 

2. On the Select Extension Project dialog box, select the project that will contain this unit, 
and click Next. 

 
3. On the New Extensibility Unit dialog box, enter the Unit Id and Name.  

A unit ID always starts with the Project ID.  

4. In the text field, enter the description of the unit as applicable. 

 
5. Click Ok. 
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Step 7: Create an Extension 
The Extensibility Designer allows you to extend the functionality of an existing result set (a 
subtask within an application), an action (process), or a report. You can also add brand new 
Result Set (subtask), action, report, message text, or constants to be used in the extended result 
set, report, or action. You can even create a brand new custom Application with any number of 
subtasks. 

Each screen in an application is called result set (RS). In any screen, you can change field labels, 
field status text, and/or field position. You can change the behavior of a field such as non-required 
to required, visible to not visible, and so on. You can also add additional data fields to the screen.  

To extend a result set: 

1. Click Extensions » Extend » RS.  

2. Select the project and unit in which to create the extension.  

3. On the Select RS dialog box, select the result set to extend. 

 

 

Use the RS Wild Card field to filter the list of result sets based on the RS ID. Generally, 
the RS ID starts with the application ID. For example SYMUSR_WUSERUGRLIST is 
the top level result set for the SYMUSR application (Manage Users).  

4. Click Next.  
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5. On the Edit Result Set dialog box, customize the result set. 

 
You can use this dialog box to customize the following: (see Extensibility Designer User 
Guide for details) 

 Change RS title 

 Register a stored procedure or additional java classes to be called after Costpoint 
executes the standard logics. You will need to create the stored procedure or java 
classes. 

 Enable email notifications when certain events happen to the data. 

 Add additional data fields 

 Change certain attributes for existing fields such as Visible, Editable, Required, 
Default Value, labels, status text, and so on. 

 

See the Deltek Costpoint Extensibility Designer User Guide for more information. 
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Example 
The following example changes the email ID field in the Maintain User application from Non-
required to Required. 

To create a result set extension: 

1. On the Edit Result Set dialog box, click the RS Description tab. 

2. Browse the Object Id list in the left panel and select U_EMAIL_NAME (the Email Name 
field).  

 

Object IDs on this panel are ordered alphabetically. Object IDs are created by Deltek, 
so they are not changeable. They are usually named after the column name in the 
database. 

 
3. To make sure this is the correct object, complete the following steps: 

a. Click the RS Presentation tab. 

b. In the Object Id list, select U_EMAIL_NAME.  

Objects in this list are generally ordered in the same sequence as the order of 
columns in table view when viewed in Costpoint.  

c. Verify that the Form Label, Table Label, and Status Text fields contain the 
appropriate text.  
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These are the labels and status text displayed for this field when you are in 
Costpoint.  

 
4. Click the RS Description tab.  

5. In the Required drop down list, select Yes.  

6. Click the RS Presentation tab. 

7. Change the Status Text to “Enter the email address. This is a required entry.” 

Notice that any changes you make are highlighted in yellow, so you can quickly identify 
what you have changed. 

 

 
8. Click OK to save and close the result set extension. 
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Step 8: Test the Extension 
To test the extension: 

 

This procedure verifies the result set extension created in the example for the previous step. 

1. Log in to Costpoint as Administrator, and go to the Manage Extensibility Units application. 

2. Verify that the unit is available and the Valid flag is Y, and then click the Applications 
subtask to make sure the application(s) shown is correct. 

 
3. In the Manage User Interface Profile application, create a UI profile.  

4. Each profile must have a different Priority number.  

This number is in case changes are made to the same screen from different units and 
happen to assign to the same user. The system will resolve this by aggregating the 
changes. However, some changes cannot be aggregated if they are made on the same 
object. In such a case, the system will select the changes from the one with the highest 
priority.  

 
5. Assign the profile to a user group or groups or to a particular user as applicable.  

 

The extensibility feature will only be seen and executed for the user(s) assigned to this 
profile. If the profile applies to everyone, assign it to the group EVERYONE. 

6. Click the Extensibility Units subtask, and assign the unit to this profile.  
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7. Save the profile. 

8. Log off and log in to Costpoint with the user ID assigned to the UI profile that contains the 
extensibility changes. 

9. Go to the application that has been customized. In this example, the Manage Users 
application was customized. 

10. Verify that the Email Name field is now marked as required (with the red asterisk) and 
the status text at the bottom has been customized with the additional message.  

Now, when saving a record without an Email Name entry, an error message displays. 
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Step 9: Export Script 
Exporting script is needed if you are creating the extension in a design/development system and 
want to deploy the extension to a second system (for example, QC or production). 

To export the result set extension script for deployment to another system: 

1. From the Extensibility Designer main menu, expand the Extensibility Projects folder, 
and select the appropriate project. 

2. Click Extensions » Export Script.  

3. When a dialog box displays confirming the location of the folder where script files will be 
created, click OK.  

 

This folder was created when you created the project. 

4. When a message displays confirming the data has been exported to a SQL file, click OK. 

 



Step 10: Package the Extension 

 

Extensibility Designer Quick Start Guide 18 

 

Step 10: Package the Extension 
You need to package the extension if you create the extension in a design/development system 
and want to deploy the extension to a second system (for example, QC or production). 

To package an extension for deployment to another system: 

1. From the Extensibility Designer main menu, click Tools » Extensibility Packager.  

The Extensibility Projects Packager dialog box displays with a list of projects created in 
this system.  

 
2. Select the project to package.  

The location and name of the zip file to be created displays at the bottom of the dialog 
box.  

3. Click Pack.  

A progress dialog box displays, showing the log.  

4. Click Close when done. 

5. Navigate the folder where the extension zip file was created and verify that it is there.  
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Step 11: Deploy the Extensibility Package 
To deploy the extensibility package: 

1. On the application server machine for the system where the package is to be deployed, 
launch the DBWizard tool by running CPWebExtDesigner.cmd in the 
\deltek\costpoint\70\bin folder. 

 

 

Presumably, this is the QC or production server that is different from the server used 
for developing the extension.  

2. On the Costpoint DB Wizard screen, click Deploy Extensions. 

 
3. On the Deploy Extension screen, select the system on which to deploy the package  
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4. Browse and select the extensibility zip file created in Step 10.  

  
5. Optional. If your package contains a stored procedure, create tables, views, or other 

database objects SQL scripts to be applied, select the Deploy Custom DB Scripts 
check box.  

6. Click Next » Run to deploy the package. 
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Step 12: Verify the Deployment to the System 
To verify that the extension was successfully deployed, repeat “Step 8: Test the Extension” for 
the system in Step 11. 

When completed, the extension is ready and active. 

 

If you have application Extensions, Deltek recommends deploying the application or system 
hotfixes first to your testing environment where you can verify that the hotfix did not change the 
application in a significant manner, making your Extensions no longer valid or usable. Even 
though the DBWizard has built in logic to check each Extension Unit against the standard 
application, some features like screen layouts or your business Java or Stored Procedure plug-
ins can be verified only by testing. 
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