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Introduction

Deltek ProPricer>»

BOE Pro, an n-tier web application developed with ASP.NET Core, supports various deployment options. The
focus of this guide is deployment on Microsoft Windows servers using Internet Information Services (IIS). It

explains in detail how to install BOE Pro on premises.
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Integration architecture

Deltek ProPricer>»
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Prerequisites

BOE Pro is composed of three websites. You can install all sites on a single Windows server or multiple
servers. All sites must comply with the following requirements.

Enable Web Server (lIS)

1. Open Add Roles and Features.
2. Select Web Server (IIS).
3. Select the following role services:
e Common HTTP Features
o Default Document
o Directory Browsing
o HTTP Errors
o Static Content
e Health and Diagnostics
o HTTP Logging
e Performance
o Static Content Compression
e Security
o Request Filtering
e Management Tools
o |IS Management Console
e Application Development
o WebSockets Protocol
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Install the .NET 8 Windows Server Hosting Bundle

Install the latest .NET 8 Hosting Bundle on the hosting system. The bundle installs the .NET 8 Runtime, .NET
8 Library, and the ASP.NET Core Module. The module allows ASP.NET Core apps to run behind IIS.

1. Go to the Download .NET 8.0 page.
2. Under ASP.NET Core Runtime, download the installer using the Hosting Bundle link.

Run apps - Runtime ©

ASP.NET Core Runtime 8.0.11

The ASP.NET Core Runtime enables you to run existing web/server applications. On
Windows, we recommend installing the Hosting Bundle, which includes the .NET
Runtime and IIS support.

1IS runtime support (ASP.NET Core Module v2)
18.0.24295.11

= I - 4

__

Run the installer on the server.

Restart IS or execute the following commands in a command shell:
net stop w3svc /y
net start w3svc

Install the URL rewrite 2.1 IIS extension

Download the extension at: https://www.iis.net/downloads/microsoft/url-rewrite



https://dotnet.microsoft.com/en-us/download/dotnet/8.0
https://www.iis.net/downloads/microsoft/url-rewrite
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BOE Pro

Minimum requirements

o Microsoft Windows Server 2016 (64 bits).

¢ Internet Information System 8.0.

e Microsoft SQL Server 2016 (13.x) or later.

e Valid SSL certificates for all websites.

o DNS entry to resolve the fully qualified domain name matching the SSL certificates.

o Compatible Authorization Server Pro instance installed.

Upgrade recommendations

e Stop all BOE Pro sites and application pools before upgrading the following:
o Reports
o WebAPI
o WebApp

e Back up a copy of your sites before upgrading them.

e Back up your database before upgrading it.

¢ Go to the Deltek Software Manager (DSM) to download the ZIP package for the new version you
want to upgrade to.

Known limitations

¢ Bookmarking the URL of the Log In page can cause login issues for users. To quickly open BOE Pro
in a browser, users should bookmark the web application start URL instead.

e BOE Pro v3.5.103.3 and newer WebAPI does not support IIS Web Farm.


https://dsm.deltek.com/
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BOE Pro deployment package

The platform-specific and framework-dependent package includes only the application folders and its
dependencies. The .NET runtime is provided by ASP.NET Hosting Bundle. The application folders include a
Windows x64 platform specific executable.

Typically, all folders are deployed to the same Windows server, but you can deploy each to different servers
for performance reasons.

The ZIP package is available in the Deltek Software Manager (DSM).

The file name of the ZIP package is DeltekProPricer_BOEPro_[version]_win-x64.zip.

BOE Pro WebAPI

Back-end BOE Pro web API that receives requests from the BOE Pro web application, provides the
WebSockets implementation for live collaboration updates, communicates with the database to persist the
information, and links BOE Pro with your installation of ProPricer 9. This component requires .NET 8 ASP.NET
Core runtime.

BOE Pro Reports

BOE Pro report engine. Processes reporting requests from the web application and communicates with the
web API to retrieve the information. This component requires .NET 8 ASP.NET Core runtime.


https://dsm.deltek.com/
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BOE Pro WebApp

Front-end BOE Pro web application. This component uses only static files such as JS, HTML, CSS, etc. (the
files are included in the folder).

BOE Pro Database Setup

Console application that creates and upgrades BOE Pro databases. This component uses .NET 8 single .exe
deployment (.NET 8 is included in the .exe).

WebSpellChecker (Optional)

wsc_app_x64_[wsc_version].exe

WebSpellChecker installation package for a Windows-based server. This component (downloaded separately)
provides Spelling, Grammar, and Autocomplete in BOE Pro. It requires CPU with AVX2/AVX512* instructions
support.

*AVX stands for Advanced Vector Extensions. Read more.


https://en.wikipedia.org/wiki/Advanced_Vector_Extensions
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Install BOE Pro

1. Download and extract the BOE Pro zip package.

2. Move the BOEPro folder to the desired site location (for example, C:\inetpub).

| ™ < | BOEPro - O X
Home Share View o
&« v > This PC )IWindows (C) » inetpub » BOEPro I v|®  Search BOEPro »p

~
Name Date modified Type Size
3+ Quick access
DatabaseSetup 2/28/2025 11:15 AM File folder
@ OneDrive - Deltek, Inc Reports 3/31/2025 11:39 AM File folder
v = This PC WebAPI 4/28/2025 4:57 PM File folder
“J 30 Objects WebApp 3/31/2025 10:53 AM File folder
BOEProManager.exe 2/28/2025 11:15 AM Application 35,641 KB
[ Desktop
~ &g configjson 5/13/2025 4:45 PM JSON File 2KB
5| Documents
¥ Downloads
} Music
=] Pictures
B videos

> %39 Windows (C)

The file config.json does not appear for new installations. BOEProManager.exe uses this
file and creates it automatically when it does not exist.
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Create a BOE Pro database

You must begin setting up BOE Pro by creating your BOE Pro database. BOE Pro Database Setup is a
command line tool that allows database administrators to create and upgrade BOE Pro databases.

1. Open a command prompt dialog and go to the folder where BOEProDatabaseSetup.exe is extracted
(for example, C:\inetput\BOEPro\DatabaseSetup).

2. Run the tool with the create command depending on the SQL authentication method.

e To use SQL authentication, run the tool with the create command and follow the prompts:
BOEProDatabaseSetup create

o To use Windows authentication, run the tool with the create command, add the -w parameter,
and follow the prompts:

BOEProDatabaseSetup create -w

See the BOE Pro Database Setup reference section for further guidance.
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Windows authentication for database connection

To use Windows authentication to connect to the BOE Pro database:
1. Create the BOE Pro database (using Windows or SQL Server authentication).
2. Create a Windows service account.
3. Configure the Windows service account as WebAPI Application Pool’'s Identity.
4. Configure BOE Pro WebAPI to use Windows authentication.

The Windows service account must be set as Identity for BOE Pro Web API and Authorization Server
Application Pools at IIS. It must also be configured with the correct permissions before attempting to connect
to the BOE Pro database. To correctly configure the Windows service account:

1. Add the service account to the BOE Pro database with the following permissions.
e Default schema: dbo
e Database role membership: db_owner
2. Add the service account to the Windows server where BOE Pro is installed.
e Set Read & execute permissions as a minimum on the BOE Pro Web API folder.
e Set the Full Control permission on the folder you want to generate log files.
o Set the Read permission on the certificate used to encrypt tokens.

e Alternatively, you can add the service account to the local Administrators group. If the service
account is not intended to be in the local Administrators group, make sure the service account
permissions are properly configured for BOE Pro. It must have minimum Read & execute
permissions at BOE WebAPI site folders.

If log files are stored in a different folder, Full Control permission must be granted for the
service account to that other folder.

10
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Create BOE Pro Reports Server

Prerequisites

Follow all prerequisites before continuing.

Installation

1. Open Internet Information Service (1IS) Manager.

2. Create a new application pool. To create a new pool:

¢ Right-click Application Pools, then select Add Application Pool.

¢ In the Name field, enter BOE Pro Reports App Pool.

¢ Inthe .NET CLR version field, select No Managed Code.
¢ In the Managed pipeline mode field, select Integrated.

e Select Start application pool immediately.

e Click OK to create the application pool.

11
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3.

N o o kA

Create the BOE Pro Reports website.
¢ Right-click the Sites folder, then select Add Website.
¢ In the Site name field, enter BOE Pro Reports.
¢ In the Application pool field, select the pool created in previous steps.

¢ In the Physical path field, enter or select the path where the files will be located. For example,
C:\inetpub\BOEPro\Reports.

¢ Inthe Type field of the Binding section, select https.
¢ Inthe IP address field, select All Unassigned.

¢ In the Port field, enter a valid port number.

When installing all BOE Pro websites on the same server and under the same domain, use
a different port for each website. 44370 is the recommended port for Reports.

Ensure the ports are accessible to the BOE Pro users.

In the Host name field, enter a domain (all letter characters must be lowercase).
Select Require Server Name Indication.

Select a valid SSL certificate for the domain.

Click OK to create the website.

12
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Create BOE Pro WebAPI Server

If you experience any errors during installation, check the Troubleshoot information in this guide for a solution.

Prerequisites

Follow all prerequisites before continuing.

Installation

1. Open Internet Information Service (11S) Manager.

2. Create a new application pool. To create a new pool:

Right-click Application Pools, then select Add Application Pool.

In the Name field, enter BOE Pro WebAPI App Pool.

In the .NET CLR version field, select No Managed Code.

In the Managed pipeline mode field, select Integrated.

Select Start application pool immediately.

Click OK to create the application pool.

Right-click BOE Pro WebAPI App Pool, then select Advanced Settings.
Set Load User Profile to True.

Click OK to save the change.

Right-click BOE Pro WebAPI App Pool, then select Recycle.

13
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3. Verify that the process model identity has the proper permissions. If the default identity of the

© N o 0

app

lication pool (Process Model > Identity) was changed from ApplicationPoolldentity to

something else, then the new identity needs permission to access the application’s folder, database
(when using Trusted Connection for the database connection string), and other required resources.

For

example, the pool needs Read and Write access to folders where the application reads and

writes files.
4. Create the BOE Pro WebAPI| website.

Right-click the Sites folder, then select Add Website.
In the Site name field, enter BOE Pro WebAPI.
In the Application pool field, select the pool created in previous steps.

In the Physical path field, enter or select the path where the files will be located. For example,
C:\inetpub\BOEPro\WebAPI.

In the Type field of the Binding section, select https.
In the IP address field, select All Unassigned.

In the Port field, enter a valid port number.

When installing all BOE Pro websites on the same server and under the same domain, use
a different port for each website. 44360 is the recommended port for WebAPI.

Ensure the ports are accessible to the BOE Pro users.

In the Host name field, enter a domain (all letter characters must be lowercase).

Select the box Require Server Name Indication.

Select a valid SSL certificate for the domain.

Clic

k OK to create the website.

14
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Firewall

Your firewall must allow inbound connections to ProPricer 9 Server from the computer running BOE Pro
WebAPI.

15
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Install WebSpellChecker (Optional)

Download the WebSpellChecker Windows installer from the Deltek Software Manager (DSM).

Prerequisites

WebSpellChecker license. Contact Deltek Customer Support to obtain it.

Hardware requirements

You can install a self-hosted WebSpellChecker Server on a:
e Dedicated server.
¢ Virtual machine (you can enable VMWare virtualization when installing WebSpellChecker) .*
o *Al-based engine is not supported under VM VirtualBox.
e Docker container.

Alternatively, you can install it using a cloud computing platform, such as Amazon Web Services, Google
Cloud, or Microsoft Azure.

Following are the minimum hardware requirements for WebSpellChecker Server with an Al-based engine:
e HDD:2GB
e RAM: 4GB
e CPU: 2 CPU cores with AVX2/AVX512* instructions support
o *AVX stands for Advanced Vector Extensions. Read more.
The preceding minimum requirements vary depending on:
¢ Number of end users who will be proofreading with WebSpellChecker features.
¢ Amount of text to be proofread.
e Type and size of the language.

e Percentage of text errors.

16
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Software requirements

e Operating system: Windows Server 2008 R2 or newer with a 64-bit architecture only.

¢ Internet Information Services (IIS) version 7.0 or newer.

e Java Runtime Environment (JRE) or Java Development Kit (JDK) with Java Virtual Machine (JVM)
version1.8 or newer, 64-bit.

Install the Application Request Routing (ARR) 3.01IS extension

Download the extension at:
https://www.microsoft.com/web/handlers/webpi.ashx?command=getinstallerredirect&appid=ARRv3 0

Installation

1. Open Internet Information Service (IIS) Manager.

2. Create a new application pool. To create a new pool:

Right-click Application Pools, then select Add Application Pool.
In the Name field, enter BOE Pro Spell Pool.

In the .NET CLR version field, select No Managed Code.

In the Managed pipeline mode field, select Integrated.

Select Start application pool immediately.

Click OK to create the application pool.

Verify that the process model identity has the proper permissions. If the default identity of the
application pool (Process Model > Identity) was changed from ApplicationPoolldentity to
something else, then the new identity needs permission to access the application’s folder. For
example, the pool needs Read and Write access to folders where the application reads and
writes files.

3. Create the BOE Pro Spell website.

Right-click the Sites folder, then select Add Website.
In the Site name field, enter BOE Pro Spell.
In the Application pool field, select the pool created in previous steps.

In the Physical path field, enter or select the path where the files will be located. For example,
C:\inetpub\BOEPro\Spell.

In the Type field of the Binding section, select https.
In the IP address field, select All Unassigned.

In the Port field, enter a valid port number.

17
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©® N o o A

When installing all BOE Pro websites on the same server and under the same domain, use a
different port for each website.

In the Host name field, enter a domain.
Select the box Require Server Name Indication.
Select a valid SSL certificate for the domain.
Click OK to create the website.
Install the WebSpellChecker component.
¢ Run the installation package (for example, wsc_app_win_x64_release_5.x.x.x_xx.exe).

e Before proceeding with the installation, read and confirm WebSpellChecker Software License
Agreement.

Select the WebSpellChecker installation location. The default WebSpellChecker installation folder is
C:\Program Files\WebSpellChecker. To specify a different installation location, click Browse.

10. Select the English language for installation. Enter en_US as the language ID, then click Add.

11. Select the following components to install.

o WProofreader add-on
o WebSpellChecker API
o English language model

e English autocomplete model

12. Do not select SCAYT plugin for CKEditor 4.

18



BOE Pro 3.6.101.1 Windows Deployment & Upgrade Guide DEItEI( ProPricer >

13. If Other and Demo samples and documentation are selected, clear the options.

f[*_:’;.’ WebSpellChecker Setup 5.38.1.0 - X

~O

Select Components

Select the components to install and dick Next to continue.

WProofreader add-on (CKEditor, Froala Editor, TinyMCE, Quill A
o In| r r r r .
HTML elements, etc.) 4.5M8
M ¥| WebspellChecker AP 0.1MB
D SCAYT plugin for CKEditor 4 43.5MB
[m] Al language models 1,055.7 MB
- v] English language model 567.0 MB
- /] English autocomplete model 488.7 MB
German language model 1,153.3MB
Spanish language model 1,215.0 MB
[] other 1.3 MB
[[] bemo samples and documentation 1.3MB

=

14. Select the type of protocol to use for communication with the WebSpellChecker service and a web
server or Java application server. The default protocol is HTTPS.

15. Select Internet Information Services (lIS) as a web server and configure its settings.

19
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16. Select the website created previously (for example, BOE Pro Spell).

jb:-‘ Setup - WebSpellChecker — -4

Select I1S Web Site
v/

Select the 115 Web Site which will be used for WebSpellChecker.

(U Default Web Site
@ BOE Pro Spell

17. Define the settings of the selected web server.

Enter a domain name (for example, boepro-spell.mycompany.com).

Enter a port number. The installer will suggest a port number based on the specified protocol
and selected web server. The default port for web servers is 443 for HTTPS protocols.

Enter the name of the virtual directory for the WebSpellChecker service. The default is
wscservice.

20
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18. If you previously selected HTTPS as the protocol type, you will be asked to configure an SSL
connection.

e Select the second option. Later, instead of configuring an SSL certificate for AppSever directly,
set up a reverse proxy on Windows IIS, and use an SSL certificate configured for IIS.

i)

Configure Service 551 Certificate

Select one of the options below to configure the S5L connection:

(®) Export your S50 certificate from Windows Certificate Store {recommended).

0 Skip now and configure later manually in the S5L tag of the AppServerX, xml
configuration file.

Apply a S50 certificate that is used by your Web or Java Application Server (not
recommended). In this case the connection with the service will be configured via
the FastCGI protocal,

Enter the Certificate Common Mame (the fully gualified HostMame):

Choose the Certificate Store Mame:

My o

< Back Mext = Cancel

19. Select the WebSpellChecker Start Menu folder, and enter the program name that will appear as a Start
Menu item.

21
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20. The installer summarizes the information you entered previously. Click Install to proceed or return to
previous steps if you want to make changes. When the installation starts, libraries will be downloaded.

1 WebSpellChecker Setup 5.25.0.0 —

Confirm Installation

Check the WebSpellChecker installation settings and click Install to proceed.

x

~O

Destination location:
C:\Program Files\WebhSpellChecker

Setup type:
Compact installation

Selected componants:

Froducts
WProofreader add-on (CKEditor, Froala Editor, TinyMCE, Quill, HTML elemen
WebSpellChecker AP

Al-based languages
Enalish

Other
English autocomplete

Back | Install

Cancel

Deltek ProPricer>»

22
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21. The Grammar engine requires the 64-bit version of Java 8 or newer. The installation wizard will try to
auto-detect a path to an existing Java Virtual Machine (JVM). If no path is found, you will be asked to
specify the JVM path:

149 WebSpellChecker Setup 5.25.0.0 -

Specify Path to Java Virtual Machine

&

At least Java B is required to use the Grammar engine. Please specify the path to Java
Virtual Machine (JVM).

Path to JVM DLL (jmw.dll);
| | Browse...
[]skip this step

Skip this step and manually add the path to VM in the AppSarver) xml file (the
PathToJavaVirtualMachine tag).

You must specify a path to JVM 64-bit.
For example, C:\Program Files\Java\jre1.8.0_351\bin\server.

23
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22. When the installation is complete, select Activate License if you are installing WebSpellChecker
Server for the first time. Then click Finish to close the installation dialog. You can view the samples
and verify application operability in newly opened web browser tabs, namely the samples page, a page
with status check, and a page with version check.

2 WebSpellChecker Setup 5.25.0.0 —

Complete Installation

WebSpellChecker has been successfully installed on the server.,
The application may be launched from Windows Start Menu
folder,

1. Activate License and Start WebSpellChecker Application
Server (Skip if already done).

2. Check the application version and status to confirm if the
Spell Check and Grammar engines are Active,

3. Open Demo Samples to learn more how integrate and
configure the WebSpellChecker products.

[ Activate License
I\_j Run WebSpellChecker Application Server
[] Check Application Status and Version

‘ Fnish

23. When prompted, enter your WebSpellChecker license to activate it.

B | Co\Prograss Files\WabSpe ICheckn i p per e Aoosa nser e o *

v# The automatic a tion requires the Inter

¢ marual activati stemd, Enter 'y

24
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Verify operability
Check the status and version of AppServer to verify if WebSpellChecker Server works properly. To do so, use
the following links to go to the detailed command and response descriptions:

Check AppServer version: https://localhost/wscservice/api/?cmd=ver or https://boepro-
spell.mycompany.com/wscservice/api/?cmd=ver

Check AppServer status: https://localhost/wscservice/api/?cmd=status or https://boepro-
spell.mycompany.com/wscservice/api/?cmd=status

25
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Create BOE Pro WebApp

Prerequisites

Follow all prerequisites before continuing.

Installation

1. Open Internet Information Service (1IS) Manager.

2. Create a new application pool. To create a new pool:

Right-click Application Pools, then select Add Application Pool.

In the Name field, enter BOE Pro WebApp App Pool.

In the .NET CLR version field, select No Managed Code.
In the Managed pipeline mode field, select Integrated.
Select Start application pool immediately.

Click OK to create the application pool.

Deltek ProPricer>
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3.

N o o kA

Create the BOE Pro WebApp website.
¢ Right-click the Sites folder, then select Add Website.
¢ In the Site name field, enter BOE Pro WebApp.
¢ In the Application pool field, select the pool created in previous steps.

¢ In the Physical path field, enter or select the path where the files will be located. For example,
C:\inetpub\BOEPro\WebApp.

¢ Inthe Type field of the Binding section, select https.
¢ Inthe IP address field, select All Unassigned.

¢ In the Port field, enter a valid port number.

When installing all BOE Pro websites on the same server and under the same domain, use
a different port for each website. 443 is the recommended port for WebApp.

Ensure the ports are accessible to the BOE Pro users.

In the Host name field, enter a domain (all letter characters must be lowercase).
Select the box Require Server Name Indication.

Select a valid SSL certificate for the domain.

Click OK to create the website.
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Configure your installation

The BOE Pro Manger tool helps you configure all sites with a single command line. BOEProManager.exe is in
your site’s location path (for example, C:\inetpub\BOEPTro).

BN Administrator: Command Prompt

C:\inetpub\BOEPro>BOEProManager.exe
BEOE Pro Manager. 3.6.188.1

This tool allows you to mamage BOE Pro.
Usage: BOEProManager [command] [options]

Options:
v|--version Shows the version information.
-?|-h|--help Shows this help information.

Commands :
config Configures BOE Pro.
configai Configures AI setting
configemail Configures all the ings related for sending emails from BOE Pro.
configesi Configures ings related for ESI.
disableai Disables AI settings re
enablefilelogger Configures BOE Pro Log.
testemail Sends an email using the ing rom the appsettings.json.

Run °BOEProManager [command] -?|-h|--help® for more information about a command.

C:%inetpub\BOEPro>_

1. Open a command prompt where the BOE Pro Manger tool is located.

2. At the command prompt, enter: BOEProManager.exe config
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3. For each parameter required, the value shown between parentheses is the current value. You can
press Enter to accept and continue, or you can set a new value. Once all values are set, they are
stored in a file named config.json. This file is in the same folder as the BOE Pro Manager tool. The
next time you run the tool, it will show the information in config.json as default values. This is useful
anytime reconfiguration is required, such as applying an upgrade.

¥ Command Prompt

C:\inetpub\BOEPro>BOEProManager.exe config
16:07:09 INF
BOE Pro Reports Server path (C:\inetpub\boepro\reports):
BOE Pro WebAPI server path (C:\inetpub\boepro\webapi):
BOE Pro Web Application path (C:\inetpub\boepro\webapp):
BOE Pro Web Application URL (https://boepro.mycompany.com):
BOE Pro WebAPI URL Chttps://boeprowebapi.mycompany.com:Uu360):
BOE Pro Reports Server URL (https://boepro.mycompany.com:44370):
PROPRICER Authorization Server URL (https://authpro.mycompany.com:44350):
Database Server Name ((local)):
Database Name (BOEProDb):
Database Windows Authentication (true):
Trust Database Server Certificate (true):
ProPricer Server (propricer.mycompany.com):
ProPricer Port (8092):
16:07:23 INF] Done.

C:\inetpub\BOEPro>|
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Microsoft Clarity (Optional)

Microsoft Clarity is a user behavior analytics tool that helps you understand how users are interacting with your
website through features such as session replays and heatmaps.

Enabling Microsoft Clarity is completely optional. Be aware that BOE Pro and Deltek, Inc. receive no data from
Clarity, and that Microsoft collects all Clarity data. Before enabling, ensure that this is not a security problem
for your organization.

To enable Microsoft Clarity in BOE Pro:

Sign into https://clarity.microsoft.com.

Create a new Clarity project for BOE Pro.
Go to Settings > Overview and copy the Project ID.

At the command prompt, enter: BOEProWebAppManager.exe EnableClarity

ok wh =

When prompted, enter the Project ID.
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Enable logging

1. Open a command prompt where the BOE Pro Manger tool is located.
2. Atthe command prompt, enter: BOEProManager.exe enablefilelogger

3. For each parameter required, the value shown between parentheses is the current value. You can
press Enter to accept and continue, or you can set a new value. Once all values are set, they are
stored in a file named config.json. This file is in the same folder as the BOE Pro Manager tool. The
next time you run the tool, it will show the information in config.json as default values. This is useful
anytime reconfiguration is required, such as applying an upgrade.

<] Command Prompt

C:\inetpub\BOEPro>BOEProManager.exe enablefilelogger
16:45:21 INF
BOE Pro Reports Server path (C:\inetpub\boepro\reports):
BOE Pro WebAPI server path (C:\inetpub\boepro\webapi):
BOE Pro Reports log file path for Reports (C:\inetpub\logs\logfiles\reportslog.txt):
BOE Pro log file path (C:\inetpub\logs\logfiles\webapilog.txt):
Pro log file size limit (104857600):
Pro retained file count limit (31):
Pro log rolling interval (Day):
Pro log roll on file size limit (True):
:45:23 INF] Done.

C:\inetpub\BOEPro>
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Add BOE Pro to Authorization Server Pro

After creating a BOE Pro database and installing and configuring the websites, it needs to be linked with
Authorization Server Pro. Then users and licenses can be added.
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Link BOE Pro to Authorization Server Pro

To link BOE Pro with Authorization Server Pro, use the Authorization Server Pro WebAPI Manager tool in the
AuthorizationServerProWebAPI folder.

Open a command prompt window with Administrator permissions.
Go to the folder where Authorization Server Pro WebAPI is installed.

At the command prompt, enter: AuthorizationServerProWebAPIManager.exe config-
boepro-url

Enter the information requested.

To apply your changes, restart the Authorization Server Pro WebAPI application pool and the
website.
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Enable Management of BOE Pro Roles with Authorization Server
Pro

To enable management of BOE Pro roles with Authorization Server Pro, use the Authorization Server Pro
WebAP| Manager tool in the AuthorizationServerProWebAPI folder.

Open a command prompt window with Administrator permissions.
Go to the folder where Authorization Server Pro WebAPI is installed.

At the command prompt, enter: AuthorizationServerProWebAPIManager.exe config-
boepro-webapi-url

Enter the information requested.

To apply your changes, restart the Authorization Server Pro WebAPI application pool and the
website.
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Add a BOE Pro license

To add a BOE Pro license, log in to Authorization Server Pro as an Administrator user.

N o o ko=

In a web browser, go to the Authorization Server Pro WebApp URL.
On the Log In page, enter the Administrator user credentials.

Click MENU > Licensing.

Click Add License, then enter you BOE Pro license.

Activate your license.

Click MENU > Users.

At a minimum, select an Administrator user, select Manage Licenses, then select BOE Pro in the
products. The Administrator user is required to set BOE Pro roles for users.
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Add BOE Pro users

To add BOE Pro users, log in to Authorization Server Pro as an Administrator user.
1. In a web browser, go to the Authorization Server Pro WebApp URL.
2. On the Log In page, enter the Administrator user credentials.
3. Click MENU > Users.
4. Click Add User, enter the user information, then select BOE Pro in the products.
To assign BOE Pro roles to users, log in to BOE Pro as an Administrator user.
In a web browser, go to the BOE Pro WebApp URL.
On the Log In page, enter the Administrator user credentials.
Click MENU > Administration > Users.

Users with a BOE Pro license will appear with an empty role.

A

Edit the users to assign a proper BOE Pro role.
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Test your installation

After creating a BOE Pro database and completing all required installation procedures, log in to and test BOE
Pro. Testing is highly recommended before attempting to enable Windows authentication.

1.

In your browser, go to your BOE Pro web application URL (for example,
https://boepro.mycompany.com).

Enter the BOE Pro admin credentials used during the database setup.

Enter your registration key.

In BOE Pro, test your connection to ProPricer Contractor Edition by adding a CE proposal.
e At the top of the application, click MENU > Proposals.
¢ On the Proposals page, click Add > Add Proposal From CE.
e Select and log in to your CE data server.

o Enter ProPricer login type credentials.

Make sure ProPricer CE allows ProPricer logins. In the System Options, go to Login Type
and select Choose or ProPricer.

If the connection is successful, all available CE proposals will appear. Select a proposal to add.

In the Build Proposal Breakdown Structure From menu, select the summary field in the CE
proposal that will become the PBS in BOE Pro.

Select Include Estimates to retain the resource and travel estimates entered in the CE proposal’s
tasks.

Click Process. The proposal will appear in BOE Pro.
Test the BOE Pro reports.

¢ On the Proposals page, hover over the proposal added from CE, click More > Reports, then
select a report.

e Set the report parameters, then click Submit. The report will appear on your screen.
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10. Continue testing other application features, such as Active Sessions, Sync, and Submit, to verify that
your installation was successful.

If you experience issues installing BOE Pro, check the Troubleshoot section of this guide for
a solution. For further assistance, contact Deltek Customer Support.
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Enable Al configuration (Optional)

BOE Pro includes artificial intelligence (Al) capabilities that enhance the proposal estimation workflow. When
enabled, the following Al-powered features become available:

- BOE Narrative Scoring: Measures the quality and completeness of text in BOE sections, providing a score
and improvement suggestions to help users write more effective narratives.

- Formula Generation: Assists users in creating cost estimation formulas by analyzing BOE context and
generating formula expressions using natural language processing.

Both features use the same Al service configuration. Enabling Al activates all Al-powered features
simultaneously.

Warning: If enabled, BOE text and estimation context data are sent to the Al service you
specify. For confidentiality and security reasons, a local or private service is highly
recommended. Al-generated results are provided subject to the ProPricer Product terms,
and Deltek does not independently verify the accuracy of each result. Users should
independently review and verify the accuracy of all Al-generated scores and formulas.

To enable Al after installing BOE Pro, complete the following procedure.
1. Open a command prompt where the BOE Pro Manger tool is located.
2. Atthe command prompt, enter: BOEProManager.exe configai
3. Enter values in the parameters that appear. Some parameters depend on the Al type you enter.

e BOE Pro WebAPI server path: The folder where the WebAPI server is installed. The value
shown between parentheses is the current value. You can press Enter to accept and continue,
or you can set a new value.

e AT Type: The Al service type. You can enter azure, openai, or ollama.
e AT Endpoint: The Al service endpoint URL.

v" Azure: Required. Your Azure OpenAl resource endpoint (for example, https://my-
resource.openai.azure.com/).

v' OpenAl: Optional. If left empty, the default OpenAl API endpoint
(https://api.openai.com/v1) is used automatically. Specify a custom endpoint only if
you are using an OpenAl-compatible service hosted at a different URL.

v" Ollama: Required. Your local Ollama service endpoint (for example,
http://localhost:11434).

e AT Api Key: The Al service API key. Not required for the Ollama Al type.
e AT Deployment Name: The Al service deployment name. Only required for the Azure Al type.

e AT Model: The Al service model ID. Only required for the OpenAl and Ollama Al types.
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BN Administrator: Command Prompt

C:\inetpub\BOEPro>BOEProManager.exe ConfigAI -h
Configures AI settings related to BOE Pro.

Usage: BOEProManager configai [options]

Options:
-2|-h|--help Shows this help information.
-sp|--spwebapi <Path> The BOE Pru WebAPI server path (Required).

-at|--aitype o5 AI Servic ype (Azure/openaifollama).
-ae|--aiendpoint <endpoint»> AT 5 Endpulnf

-ak|--aikey <apikey> AI Api Key.

-ad ——aldeplu ment <names AI Deployment Name (only for azure).
-am|--aimodel <id» AI Model Id.

L
li¢]

LA LA

C:\inetpub\BOEPro>g

BN Administrator: Command Prompt

C:\inetpub\BOEPro>BOEProManager.exe ConfigAl

13:26:22 INF

BOE Pro WebAPI server path (C:\inetpub\BOEPro\webapi):
AT Type: Azure
AT Endpoint: https://your-endpoint.openal.azure.com
AT Api Key: Enter-Your-API-Key
AT Deployment MName: Enter-Your-Azure-Deployment-MName

3:28:46 INF| Done.

C:\inetpub\BOEPro>»

EX Administrator: Command Prompt

C:\inetpub\BOEPro>BOEProManager.exe ConfigAl
13:28:19 INF
BOE Pro WebAPI server path (C:\inetpub\BOEPro\webapi):
AT Type {(openai): ollama
AI Endpoint: https://local-1lm.mycompany .com

AL Model Id (model-id): Enter-Your-Model-Id
13:38:57 INF| Done.

C:\inetpub\BOEPro:>»

40



BOE Pro 3.6.101.1 Windows Deployment & Upgrade Guide DEItEk ProPricer >

After configuration, verify Al is working:
1. BOE Narrative Scoring: Open a proposal, navigate to a BOE section with text, and check that the scoring
indicator appears.

2. Formula Generation: Open a proposal, navigate to a task's BOE formulas, and verify the Al-assisted
formula generation option is available.

Note: Al configuration applies globally to all BOE Pro users. There is no option to enable
individual Al features separately — all Al features are enabled or disabled together. To
disable Al, set the Al:Enabled value to false in the WebAPI appsettings.json file.
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Enable Windows authentication (Optional)

BOE Pro allows Windows authentication as a login option. To enable it after installing BOE Pro, complete the
following prerequisites and configurations.

Prerequisites

All sites must be hosted in a reverse proxy configuration with Internet Information Service (11S) on
Windows Server 2016 or later and joined to your Active Directory.

Using the Add Roles and Features wizard, go to the Server Roles page > Web Server (lIS) > Web
Server > Security, select Windows authentication, then click Next.

Enable Windows authentication for Authorization Server Pro.

Add BOE Pro Windows type users in Authorization Server Pro. The Windows Log In value must be
entered in the following format: DomainName\UserName

For more information, see the References at the end of this section of the guide.

BOE Pro settings

1.

In your browser, go to your BOE Pro web application URL (for example,
https://boepro.mycompany.com).

Enter the BOE Pro admin credentials provided during the database setup.
Assign a BOE Pro role to Windows users.

o At the top of the application, click MENU > Administration > Users.

e Hover over the email address of a Windows user, click Edit, then select a role.
Change the ProPricer login type to Windows.

o At the top of the application, click MENU > Administration > Settings.

e In Login Type, select Windows (Active Directory) or Windows (Interactive).
Log in to BOE Pro again to test the settings.

e Log out of BOE Pro, then log in again as a Windows user.

e At the top of the application, click MENU > Proposals.

¢ On the Proposals page, click Add > Add Proposal From CE.

e Select and log in to your ProPricer CE data server.

e |If the connection is successful, all available CE proposals will appear.

42



BOE Pro 3.6.101.1 Windows Deployment & Upgrade Guide DEItEk ProPricer >

BOE Pro WebAPI configuration (Optional)

1. Open Internet Information Service (1IS) Manager.

2. Open the Authentication feature for the BOE Pro WebAPI site.

3. Enable anonymous authentication.

4. Enable Windows authentication. This is required to support ProPricer Contractor Edition logins.

The Windows account of each BOE Pro user can connect to ProPricer CE through BOE Pro. To set this up,
grant Full Control permissions to the following two folders:

o Temp folder of the BOE Pro WebAPI application pool user (for example, C:\Users\BOE Pro WebAPI
App Pool\AppData\Local\Temp). It handles file attachments during the submit process.

¢ Deltek, Inc folder where BOE Pro WebAPI is installed (for example,
C:\inetpub\BOEPro\WebAPI\Deltek, Inc). It handles license management.

You can assign the permissions individually, use an existing Windows group for your BOE Pro users, or create
a Windows group for your BOE Pro users and grant the permissions to it.
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References

e Learn more about Windows authentication and installing it for 11S. https://docs.microsoft.com/en-
us/iis/configuration/system.webServer/security/authentication/windowsAuthentication/

e Configure Windows authentication in an ASP.NET Core app. https://learn.microsoft.com/en-
us/aspnet/core/security/authentication/windowsauth?tabs=visual-studio&view=aspnetcore-6.0
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Enable Azure AD authentication (Optional)

BOE Pro allows Azure AD as a login option. To enable it after installing BOE Pro, complete the following
prerequisites and configurations. Azure AD can be used as well to connect to ProPricer Contractor Edition
through BOE Pro (optional).

Prerequisites

e Your Authorization Server Pro installation has network connectivity to Microsoft services. This is
required to validate login tokens.

e App registration in your Azure Active Directory.

e App reqgistration creation for Authorization Server Pro.

e Client/Desktop platform added to the app registration for Authorization Server Pro.

o (Optional) Azure AD logins enabled to allow BOE Pro to connect to ProPricer CE using Azure AD.

e (Optional) If Azure AD will be used to communicate with ProPricer CE through BOE Pro, the users
that will communicate with ProPricer CE must also exist in ProPricer CE with Login Type set to Azure
AD.

45



BOE Pro 3.6.101.1 Windows Deployment & Upgrade Guide DEItEk ProPricer >

BOE Pro settings

In your browser, go to your BOE Pro WebApp URL (for example, https://boepro.mycompany.com).
Enter the BOE Pro admin credentials provided during the database setup.
Assign a BOE Pro role to Azure AD users.
o At the top of the application, click MENU > Administration > Users.
e Hover over the email address of an Azure AD user, click Edit, then select a role.
4. Change the ProPricer login type to Azure AD.
o At the top of the application, click MENU > Administration > Settings.
e In Login Type, select Azure (Active Directory).
5. Log in to BOE Pro again to test the settings.
e Log out of BOE Pro, then log in again as an Azure AD user.
o At the top of the application, click MENU > Proposals.
¢ On the Proposals page, click Add > Add Proposal From CE.
e Select and log in to your ProPricer CE data server.

o [f the connection is successful, all available CE proposals will appear.
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References

o Register an application with the Microsoft identity platform. https://learn.microsoft.com/en-
us/azure/active-directory/develop/quickstart-register-app

¢ Grant tenant-wide admin consent to an application. https://learn.microsoft.com/en-us/azure/active-
directory/manage-apps/grant-admin-consent
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Remove ProPricer 9 WebAPI

BOE Pro v3.5.100.3 and later implements communication with ProPricer 9 Server in the BOE Pro WebAPI.
This makes the ProPricer 9 WebAPI site no longer necessary. If you have BOE Pro v3.5.100.2 or earlier,
delete the ProPricer 9 WebAPI| website, application pool, and the website’s folder in C:\inetpub. (For example,
C:\inetpub\BOEPro\ProPricer9WebAPI)

ProPricer 9 Server Host Name and ProPricer 9 Server Port settings are now required on
BOE Pro WebAPI configuration settings.
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Remove BOE Pro Authorization Server

BOE Pro version 3.5.105.1 and later use the new Authorization Server Pro website to authenticate user logins.
This makes the BOE Pro Authorization Server website unnecessary. If you have BOE Pro version 3.5.105.0 or
earlier, delete the BOE Pro Authorization Server website, application pool, and the website’s folder in
C:\inetpub. (For example, C:\inetpub\BOEPro\AuthorizationServer)
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Upgrade BOE Pro

To upgrade BOE Pro, download the new version package, upgrade the database, and upgrade all BOE Pro

websites.

Upgrade recommendations

e Plan for some downtime because BOE Pro sites stop during the process.

e Back up a copy of your sites before upgrading them.

e Back up your database before upgrading it.

¢ Go to the Deltek Software Manager (DSM) to download the ZIP package for the new version you
want to upgrade to.

e Download and install the latest .NET 8 Hosting Bundle.

e For versions 3.5.105.0 and earlier: Log in to BOE Pro as an Administrator and deactivate the license.

Upgrade instructions

1. Download and extract the BOE Pro package DeltekProPricerBOEPro_[version]_win-x64.zip.

2. In lIS Manager, stop all sites and application pools.

Stop the BOE Pro WebAPI website.
Stop the BOE Pro WebAPI application pool.
Stop the BOE Pro WebApp website.
Stop the BOE Pro WebApp application pool.
Stop the BOE Pro Reports website.
Stop the BOE Pro Reports application pool.

3. For versions 3.5.105.0 and earlier, migrate existing BOE Pro users to the Authorization Server Pro
system.

Open a command prompt window.
Go to the folder where BOEProDatabaseSetup.exe is extracted.
At the command prompt, enter: BOEProDatabaseSetup.exe migrate-users

To connect using Windows authentication, enter:
BOEProDatabaseSetup.exe migrate-users -w

Enter the information requested.
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4. Upgrade your database.
o Open a command prompt window.
o Go to the folder where BOEProDatabaseSetup.exe is extracted.
e At the command prompt, enter: BOOEProDatabaseSetup.exe upgrade

e To connect using Windows authentication, enter:
BOEProDatabaseSetup.exe upgrade -w

e Enter the information requested.
5. Upgrade the BOE Pro WebAP!I site.
¢ In Windows Explorer, delete the BOE Pro WebAPI site folder.

o Copy the extracted WebAPI folder to the BOE Pro site folder inside C:\inetpub. For example,
C:\inetpub\BOEPro.

6. Upgrade the BOE Pro Reports site.
¢ In Windows Explorer, delete the BOE Pro Reports site folder.

o Copy the extracted Reports folder to the BOE Pro site folder inside C:\inetpub. For example,
C:\inetpub\BOEPro.

7. Upgrade the BOE Pro WebApp site.
¢ In Windows Explorer, delete the BOE Pro WebApp site folder.

o Copy the extracted WebApp folder to the BOE Pro site folder inside C:\inetpub. For example,
C:\inetpub\BOEPro.

8. Reconfigure all sites.

e Open a command prompt with Administrator permissions.

e Go to the folder where BOE Pro is installed.

e At the command prompt, enter BOEProManager.exe config

o Enter the information requested, or press Enter to accept the existing values.
9. In IS Manager:

e Start the BOE Pro WebAPI application pool.

o Start the BOE Pro WebAPI| website.

o Start the BOE Pro Reports application pool.

o Start the BOE Pro Reports website.

e Start the BOE Pro WebApp application pool.

e Start the BOE Pro WebApp website.
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Troubleshoot

Authorization Server Pro, BOE Pro WebAPI Server, and BOE Pro
Reports Server — Fetch error

At the BOE Pro WebApp startup, there is a status check for all required servers. You might receive the Failed
to fetch error message after entering the WebApp URL in your browser (for example,
https://boepro.mycompany.com).

Server Connection Error

Failed to BOE Pro WebAP!: Failed to fetch

Server
BOE Pro WebAPI

Auth Server Pro WebAP!
Eror  Fal

BOE Pro Reports Server o roiiad to connect to BOE Pro Reports Server: Failed to fetch

Retry Connection
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Solution 1

Check your networking. Verify that your firewall is not blocking the authorization server port.

Solution 2

Restart the server website.

Solution 3

1.

For Authorization Server Pro, in your browser enter your server URL followed by /.well-
known/openid-configuration (for example, https:// authserverpro.mycompany.com/.well-
known/openid-configuration). The resulting .json file should look like:

D © N <+

« C a] L&

Pretty-print

en"], "response_modes_supported”:

["c ki
ken_endpoint_ auth_methods_supporte t_ - p _tok 1g_values_supported”:
["RS256" ], "subject_types_supported”:[“public"],"code_challenge_methods_supported” [ “plain”,"5256"], "request_parameter_supported”:true}

If you receive an error instead of the .json file, go to the Authorization Server Pro WebAPI folder
and find the file appsettings.json. Verify that it is a valid .json file containing the correct
configuration.

Install or repair .NET Core hosting bundle and restart 1S service.
If you made updates in appsettings.json, recycle the application pool to apply the changes.

Solution 4

W nh =

Enable logqging in affected server.

Recycle the application pool to apply the changes.
Try logging into BOE Pro again and check the log for the error.

If the log was not created, make sure the application pool has full access to the folder where the log
file is configured to be created. The folder must exist to create the file.

Solution 5

If there is no log file, open Windows Event Viewer, and look for errors with starting your authorization server.
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BOE Pro WebAPI - Common errors

HTTP Error 500.31 - Failed to load ASP.NET Core runtime

Install or repair .NET Core hosting bundle and restart IIS service.

500.119

The application pool identity cannot read appsettings.json. To fix this, assign permissions to the folder where
the website files are located (for example, C:\inetpub\BOEPro\WebAPI).

HTTP Error 503 - The service is unavailable

The service is unavailable when the application pool of the corresponding web application is stopped,
disabled, or paused. It may also be unavailable when the given user identity of the application pool is invalid
due to an expired password or is locked.

https://blogs.msdn.microsoft.com/webtopics/2010/02/17/a-not-so-common-root-cause-for-503-service-
unavailable/

https://stackoverflow.com/questions/13322937/http-error-503-the-service-is-unavailable

Bad Request — Request header too long

“HTTP Error 400. The size of the request header is too long.”

While using Windows authentication, this error may appear instead of the BOE Pro application. It is the result
of the user being a member of many Active Directory user groups.

To fix this:

1. Open Windows Registry Editor and go to:
HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters

2. Increase the settings for the MaxFieldLength and the MaxRequestBytes registry entries on the
server so that the user's request headers do not exceed these values. For example:
"MaxRequestBytes"=dword: 01000000
"MaxFieldLength"=dword:0000fffe

https://docs.microsoft.com/en-us/troubleshoot/iis/http-bad-request-response-kerberos

https://www.grouppolicy.biz/2013/06/how-to-configure-iis-to-support-large-ad-token-with-group-policy
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Cannot access path ‘Deltek, Inc\PROPRICER\9’

You will receive this error if the BOE Pro WebAPI Application Pool Load User Profile is set to False.
To fix this:

Right-click BOE Pro WebAPI App Pool, then select Advanced Settings.

Set Load User Profile to True.

Click OK to save the change.

Right-click BOE Pro WebAPI App Pool, then select Recycle.

e bh =
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Database Setup reference

BOE Pro Database Setup is a command line tool that allows the database administrators to create and
upgrade BOE Pro databases.

Usage
BOEProDatabaseSetup [options] [command]

Options
-v | --version Show version information.
-?|-h|--help Show help information.

Commands

addsysadmin Add a system administrator account to a BOE Pro database.
create Create a new BOE Pro database.

upgrade Upgrade a BOE Pro database to the current version.

56



BOE Pro 3.6.101.1 Windows Deployment & Upgrade Guide

create command

create Create a BOE Pro database.

Usage

BOEProDatabaseSetup create [options]
Options

-?|-h|--help Show help information.

-f|--scripttofile <fileName> Output the scriptto a file.

-s|--server <servername> Name of the database server.

-w|--windowsauth Use Windows authentication.

Deltek ProPricer>

-d| --dbname <databasename> Name of the database. Default value is BOEPro.

-al|--adminlogin <login> BOE Pro admin user email. Default value is sysadmin@propricer.com.

-ap|--adminpass <password> BOE Pro admin user password. Default value is sysadmin.

-an|--adminname <name> BOE Pro admin username. Default value is System Administrator.

-u|--dbauser <dbalogin> Database user login.

-p|--dbapass <dbapassword> Database user password.

-e|--useexistingdb Use an existing database (for example, when using Azure SQL Database).

Examples

Create a BOE Pro database on a on-premises SQL server using Windows authentication:

BOEProDatabaseSetup create -s sqglserver.mycompany.com —-d BOEPro -al
sysadmin@mycompany.com -ap SysAdmin@BOEPro -an "System Administrator" -w

Create a BOE Pro database on an Azure SQL database using SQL authentication:

BOEProDatabaseSetup create -s mycompany.database.windows.net -u myazureuser -p
MyAzurePassword -d BOEPro -al sysadmin@mycompany.com -ap MyStrongPassword4BOEPro

-an "System Administrator" -e

57



BOE Pro 3.6.101.1 Windows Deployment & Upgrade Guide

upgrade command

upgrade Upgrade an existing BOE Pro database.
Usage

BOEProDatabaseSetup upgrade [options]
Options

-?|-h|--help Show help information.

-s|--server <servername> Name of the database server.

-w|--windowsauth Use Windows authentication.
-u|--dbauser <dbalogin> Database user login.

-p|--dbapass <dbapassword> Database user password.

Deltek ProPricer>

-d | --dbname <databasename> Name of the database. Default value is BOEPro.

-f|--scripttofile <fileName> Output the scriptto a file.

Examples

Upgrade a database named BOEPro on a on-premises SQL server using Windows authentication :

BOEProDatabaseSetup upgrade -s sqglserver.mycompany.com -d BOEPro -w

Upgrade a database named BOEPro on an Azure SQL database using SQL authentication:

BOEProDatabaseSetup upgrade -s mycompany.database.windows.net -u myazureuser -p

MyAzurePassword -d BOEPro
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addsysadmin command

addsysadmin Create an administrator-type user in a previously created BOE Pro database. This command
is helpful when there is no access to the BOE Pro system due to forgotten passwords. The command creates
a user with the Admin-only role assigned to it, providing it with access to the BOE Pro system, but only to the
administrative section where Users data can be viewed and modified. Keep in mind that there can only be one
Admin-only user in the system.

Usage

BOEProDatabaseSetup addsysadmin [options]

Options

-?|-h|--help Show help information.

-s|--server <servername> Name of the database server.

-w|--windowsauth Use Windows authentication.

-d| --dbname <databasename> Name of the database. Default value is BOEPro.
-al|--adminlogin <login> BOE Pro admin user email. Default value is sysadmin@propricer.com.
-ap|--adminpass <password> BOE Pro admin user password. Default value is sysadmin.
-an|--adminname <name> BOE Pro admin username. Default value is System Administrator.
-u|--dbauser <dbalogin> Database user login.

-p|--dbapass <dbapassword> Database user password.
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