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Overview 
Standard reports that are provided with Deltek Vantagepoint are designed to meet most of your business 
needs. In addition, you can create custom reports using Microsoft SQL Server® Reporting Service’s SQL 
Server Data Tool — Business Intelligence Report Designer. This report writing tool is also known as 
SSDT-BI Report Designer. 

This guide applies if you use the Vantagepoint cloud or on-premises product.  

What This Guide Covers 
This guide provides information for the following steps, which you must complete to create, deliver, and 
generate Vantagepoint custom reports: 

Step Description 

1 Install SSDT-BI Report Designer on the machines (usually workstations) from which 
you will create or edit Vantagepoint custom reports. 

2 Do one of the following: 

 For the Vantagepoint cloud product: Give the users who will create custom 
reports access to the SSRS report server. 

 For the Vantagepoint on-premises product: Load the Vantagepoint report 
templates on the workstations of the appropriate users who will create custom 
reports with SSDT-BI Report Designer. 

3 Do either of the following to create custom reports: 

 Load the Vantagepoint report templates on the workstation of users who will 
create custom reports. Access the Vantagepoint report templates in SSDT-BI 
Report Designer to create custom reports. 

 Create a custom report from a copy of a Vantagepoint standard report in 
SSDT-BI Report Designer. 

5 Load custom reports into Vantagepoint using the Vantagepoint Report Administration 
utility. 

6 Set up parameters for a custom report in Settings » General » Custom Report 
Options in the desktop application. Parameters allow users to filter report content 
before they generate a report. 

7 In Vantagepoint Role Security Settings, apply role security to give the appropriate 
Vantagepoint users the ability to access the custom reports and print or preview those 
reports from the Vantagepoint Reporting menu.  

Appendix A provides instructions for upgrading custom reports when you migrate from Deltek Vision to 
the Vantagepoint on-premises product. This information also applies for upgrading from Vision any 
custom reports that you will use to generate invoices in Vantagepoint.  

Specific instructions on how to create and design Vantagepoint custom reports is beyond the scope of 
this document. Assistance with creating custom reports is not covered by your Deltek Ongoing Support 
Plan (OSP). If your firm requires custom reports, contact Deltek Global Services for information about the 
custom report services that they provide. 



Overview 

Custom Reports and Microsoft SQL Server® Reporting Services 2 

 

Updates to This Guide 
Guides are revised regularly to provide the most up-to-date technical information and instructions. Visit 
the Deltek Support Center at https://support.deltek.com, to download the most recent copy. 

Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® Reader® X 
provides this ability. If you do not already use Adobe Reader X, you can download it here free from 
Adobe.  

To add a custom note using Adobe Reader X, complete the following steps: 
1. On the Reader toolbar, click Comment at the far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to match the 
button. 

3. Position the cursor at the location in the guide where you want the note to appear, and click. A 
note icon is inserted at the location and a text box pops up. 

4. Enter your information in the text box.  

5. Continue adding notes as needed. 

6. Save the document. 

 
When reading the document, cursor over a note icon to see the information. Double-click a note icon to 
edit the information. 

Note: Deltek recommends that you save the document to a slightly different filename to keep the 
original from being overwritten. 

http://get.adobe.com/reader/
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Supported Report Writing Tool 
The following Microsoft SQL Server® Reporting Services (SSRS) report writing tool is supported for 
creating Vantagepoint custom reports: 

 SQL Server Data Tool — Business Intelligence for Visual Studio 2013 Report Designer  

This tool is known as SSDT-BI 2013 Report Designer. The SSDT-BI version is different from the 
standard SSDT version. The SSDT version does not include the BI templates and is not 
supported for creating Vantagepoint custom reports. SSDT-BI 2013 Report Designer comes with 
SSRS version 2014. 

RDL 2010 Schema 
SSDT-BI 2013 Report Designer produces a report file with the RDL (report definition language) 2010 
schema that Vantagepoint requires. 

If you try to load a custom report into Vantagepoint that was created with an unsupported version of 
SSDT-BI Report Designer, or an unsupported SSRS report writing tool, you will receive a “SQL Report 
Error loading report” error message. 

To determine whether or not a custom report was created with a supported report writing tool and has the 
supported RDL schema, open an .rdl file for a custom report, and look at the header lines. If the report 
has the supported RDL 2010 schema, it will have 2010 in the path. If it has 2008 in the path, it was 
created with BIDS 2008 (which is not supported).  

The following are header line examples: 

 The header line in an .rdl report file that is created with SSDT-BI Report Designer (supported) is: 

<Report xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner" 
xmlns="http://schemas.microsoft.com/sqlserver/reporting/2010/01/reportdefinition"> 

 The header line in an .rdl report file that is created with BIDS 2008 (not supported) is: 

<Report xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner" 
xmlns="http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition"> 

 

Installing SSDT-BI 2013 Report Designer 
Install SSDT-BI Report Designer on the machines (with the appropriate licensing) from which you will 
create or edit Vantagepoint custom reports. These machines are typically workstations, rather than 
Vantagepoint web servers. 

SSDT-BI 2013 Report Designer is provided with SSRS 2014, but it is not installed automatically. 

Use the following Microsoft link to download SSDT-BI: 

http://www.microsoft.com/en-us/download/details.aspx?id=42313 

Note: To support the ability to open, generate, and print custom Vantagepoint reports, the 
Vantagepoint database and report servers must have one of the supported or compatible versions of 
Microsoft SQL Server installed. These include SQL Server 2014, SQL Server 2012, or SQL Server 
2008 R2. For a full list of Microsoft SQL Server releases (R), service packs (SP), and cumulative 
updates (CU) that are supported or compatible with Vantagepoint, see the Deltek Product Support 
Compatibility Matrix. You can download this PDF document at the Deltek Support Center: 
https://support.deltek.com. 

http://schemas.microsoft.com/SQLServer/reporting/reportdesigner
http://schemas.microsoft.com/sqlserver/reporting/2010/01/reportdefinition
http://schemas.microsoft.com/SQLServer/reporting/reportdesigner
http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition
http://www.microsoft.com/en-us/download/details.aspx?id=42313
https://support.deltek.com/


Supported Report Writing Tool 

Custom Reports and Microsoft SQL Server® Reporting Services 4 

 

During the installation, select only the SQL Server Data Tools - Business Intelligence for VS 2013 
check box in the Shared Features section of the setup dialog box. 

 
 

Note: For a full list of Microsoft SQL Server releases (R), service packs (SP), and cumulative updates 
(CU) that are supported or compatible with Vantagepoint, see the Deltek Product Support 
Compatibility Matrix. You can download this PDF document at the Deltek Support Center. 

Deltek can also arrange for implementation services support from your Deltek consultant. 

If you have any additional questions, contact Deltek Customer Care at 877.457.7765. 
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Using SSDT-BI Report Designer 
SSDT-BI Report Designer is a full-featured, advanced report writing tool that lets you create both simple 
and complex reports. 

SSDT-BI Report Designer Reporting Capabilities 
You can do the following with SSDT-BI Report Designer:  

 Create table, matrix, chart, and free-form reports 

 Apply grouping and formulas in reports 

 Apply sorting 

 Apply filtering 

 Apply advanced reporting features, including complex queries, advanced charting, parameters, 
drill downs, sub-reports, and so on 

 Create expressions to specify report data 

 Combine tables, lists, and charts in the same report 

 Include Vantagepoint user-defined fields in reports 

 Access the full Vantagepoint database with the reporting tool 

 Include a Sorting/Grouping tab or Columns tab in Vantagepoint Reporting for custom reports (if 
you modify special tags in SQL statements) 

You cannot do the following: 

 Create ad hoc reports 

 Launch the report writing application within Vantagepoint 

 Create a custom report Options dialog box to display in Vantagepoint Reporting for a custom 
report 

 Deploy custom reports outside of Vantagepoint 

Give Report Writing Users Access to the SSRS Report Server 
To allow report writing users access to the SSRS report server, you must give them the following SSRS 
permissions: 

 At the server level, users must be system users. 

 At the folder level, users must be granted browser and Content Manager access. 

 

Attention: Users who have access to your SSRS report server to create custom reports in SSDT-BI 
Report Designer can access all fields in your Vantagepoint database. Vantagepoint role security does 
not apply when accessing the Vantagepoint database to create custom reports. 
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Non-Domain Clients 
SSRS requires Windows Integrated Authentication. Non-domain clients (clients who do not run Active 
Directory or have a Windows domain) must do the following: 

 Create a local account on the SSRS report server for each user who creates custom reports. 

 Grant the necessary reporting services permissions (see the previous section) to those who 
create custom reports. 

Create a Custom Report Using Vantagepoint Report 
Templates 
Vantagepoint comes with report templates that you can use to create custom reports in SSDT-BI Report 
Designer. The templates provide formatting for custom reports that is similar to the formatting of 
Vantagepoint standard reports. 

You copy the template files from the Reports\Template folder on the Vantagepoint application server to 
the workstation of users who will be creating custom reports. Then, when users launch SSDT-BI Report 
Designer, the Vantagepoint templates display in the list of templates. You can also locate the template 
files directly on your SSRS server instead of copying them to users’ workstations.  

Template Files 
The template files for custom reports are: 

 DVPTemplateAudit.rdl — Use this template to create audit trail summary reports. Hub audit 
reports, such as Firm Audit and Vendor Audit, are examples of this type of report. 

 DVPTemplateAuditDetail.rdl — Use this template to create audit trail detail reports. Hub audit 
detail reports, such as Firm Audit Detail and Vendor Audit Detail, are examples of this type of 
report. 

 DVPTemplateCustomReport.rdl — Use this template to create a custom report without any pre-
defined layout. 

 DVPTemplateLandscape.rdl — Use this template for column selection reports that must be 
printed using the landscape orientation. Report properties are set for this, so you do not need to 
modify them. 

 DVPTemplatePortrait.rdl — Use this template to create column selection reports. 

 DVPTemplatePostingLog.rdl — Use this template to create posting log reports. 

 DVPTemplateSubReport.rdl — Use this only to create a sub-report. Vantagepoint billing 
invoices are examples of reports that use sub-reports. Each section of a single billing invoice 
(report) is created by using sub-reports. 

 DVPTemplateTransactionList.rdl — Use this template to create transaction list reports. 
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Example: DVPTemplatePortrait.rdl file when you open it in Report Designer: 

 

Load the Vantagepoint Report Templates on a Workstation 
To create a custom report on the user’s workstation that has SSDT-BI Report Designer installed, copy the 
.rdl template files (listed in the previous section) from the Reports\Template folder on the Vantagepoint 
application server to the following location on the user’s workstation: 

C:\Program Files\Microsoft Visual Studio 
9.0\Common7\IDE\PrivateAssemblies\ProjectItems\ReportProject  

Access the Report Templates in SSDT-BI Report Designer 
After you copy the .rdl template files to a workstation, when you launch SSDT-BI Report Designer and 
select Business Intelligence Projects, the Vantagepoint templates display in the list of templates as in the 
following screenshot. 
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To access the Vantagepoint report templates to create a custom report, you complete three 
procedures: 

1. Create a solution and report server project. 

2. Create the shared data source. 

3. Select a Vantagepoint template and start to create a custom report. 

To create a solution and report server project: 
1. On your workstation, open the SSDT-BI Report Designer software by clicking Windows Start » 

All Programs » Microsoft SQL Server 2014 » SQL Server Data Tools for Visual Studio 2013.  

2. Click File » New » Project. 
3. Select Business Intelligence Projects. 

4. In the Templates section of the New Project dialog box, click Report Server Project to highlight 
it. 

5. In the Name field, enter a name for the report server project, such as DeltekCustomReports. 

A report server project contains: 

 A data source (information about a connection to a data source for your report). 

 Any custom reports that you create with the data source. 

6. In the Location field, enter the path on your workstation where you want to store the report 
server project. 

7. In the Solution Name field, enter a name for the solution in which this report server project will be 
contained. 

Solutions can contain multiple projects. 

8. Click OK. 

In the Solution Explorer pane, you now see the solution that you just created. (To display the 
Solution Explorer pane, click View » Solution Explorer.) 

To create the shared data source: 
1. In the Solution Explorer pane that is located below your solution, right-click Shared Data 

Sources, and click Add New Data Source on the shortcut menu. 

2. On the General tab of the Shared Data Source dialog box, in the Name field, enter 
DefaultDataSource. 

This is the name of the Vantagepoint data source. 

Note: You cannot use Vantagepoint report templates with the SSDT-BI Report Designer Report 
Wizard. 
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3. In the Type field, select Microsoft SQL Server. 
4. Click the Edit button beside the Connection string text box to open the Connection Properties 

dialog box, on which you can create the connection string to your Vantagepoint database. 

a) Select the server on which your Vantagepoint database resides. 

Deltek recommends that you use Windows authentication to log on to the server. This 
prevents users from accessing information via SSDT-BI Report Designer that they should not 
access. If you use SQL Authentication and save the password, the password is saved as 
plain text and can be seen with Notepad. 

b) Enter the Vantagepoint database name to connect to. 

c) Click OK. 

5. On the Credentials tab of the Shared Data Source dialog box, enter the credential information for 
the data source and then click OK. 

In the Solution Explorer pane, you now see DefaultDataSource.rds in the Shared Data Sources 
folder within the solution. 

6. On the Microsoft Visual Studio toolbar, click File » Save All. 
Save your solution often to prevent losing modifications in the event that SSDT-BI Report 
Designer terminates. 

To select a Vantagepoint template and start to create a custom report: 
1. In the Solution Explorer pane, right-click the Reports folder, and click Add » New Item on the 

shortcut menu. 

On the Add New dialog box, you see the Vantagepoint report templates.  

2. Click a report template to open it and create a custom report with it. 

Specific instruction on how to create and design Vantagepoint custom reports is beyond the 
scope of this document. You can contact CustomServices@Deltek.com for information about the 
custom report services that Deltek provides. 

3. After you create a custom report and it is ready for others to use, load the report into 
Vantagepoint using the Report Administration utility in the Vantagepoint desktop application. 

Vantagepoint does not support the deployment of reports to the SSRS report server directly from 
within the SSDT-BI Report Designer software. Instead, you use the Vantagepoint Report 
Administration utility to load custom reports.  

For more information, see: Load Custom Reports into Vantagepoint. 

Attention: All of the Vantagepoint report templates look at the data source called 
DefaultDataSource. If you name it something else, you will receive an error when you select 
the Data tab of the Design window. When you receive the error, click OK and then modify the 
dataset to use your connection instead. You must do this for each dataset. 

Also, when you rename an existing data source, if you previously used the data source for a 
report, the report will be broken and you need to edit the report query to reference the new 
data source name. 

mailto:CustomServices@Deltek.com
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Multilingual Companies and Report Templates 
You can create custom reports in multiple languages only if you purchase and activate the Vantagepoint 
Multilingual module. 

If you have multilingual companies in your enterprise and you want the ability to generate a report in 
multiple languages from one report design, you must create custom reports with Vantagepoint report 
templates loaded locally on a workstation. When you create a custom report with the Vantagepoint report 
templates directly on your SSRS report server, the report can be generated only for the specific culture 
(language) from which you accessed the report template. 

Create a Custom Report from a Vantagepoint Standard Report 
in SSDT-BI Report Designer 
If the content of a standard report is similar or close to what you need in a custom report, you may want to 
start with a copy of a standard report .rdl file and then modify it in SSDT-BI Report Designer to suit your 
needs. 

Open the Custom Report .Rdl File in SSDT-BI Report Designer 
After you create and save a custom report .rdl file from a standard report, open the custom report .rdl in 
SSDT-BI Report Designer. 

To open the custom report .rdl in SSDT-BI Report Designer: 
1. Open a BI project within SSDT-BI Report Designer. 

2. Select the option to add an existing item to the project, and browse to where you saved the .rdl 
file to open it. 

Verify that the Data Source Is Set for the Query 
For custom reports that you created with a Vantagepoint standard report, you must verify that the data 
source is set for the query. 

To check the data source: 
With the custom report .rdl file open in SSDT-BI Report Designer, click the Data tab. 

If you receive the following dialog box, it means that SSDT-BI Report Designer is not able to connect to a 
valid data source for the selected dataset. You must fix the data source to point to the shared data source 
in your BI project. 

If you do not receive the message, you are ready to modify the report. 
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To fix the data source to point to the shared data source in your BI project: 
1. On the SSDT-BI Report Designer window that indicates the data source was not found, click OK. 

2. On the Data tab, click the  button next to the dataset name to open the following Dataset 
dialog box: 

 
3. From the drop-down list in the Data source field, select the data source that is used within your 

BI Project. 

The data source name typically has “(shared)” as part of its name. 

At this point you are ready to work on the design of the report. 

XML Code that You Must Modify 
When you start with a standard Vantagepoint report to create a custom report, you must modify some of 
the XML code in the report's .rdl file to remove and replace items that are not appropriate for your custom 
report. If you do not make these modifications, your custom report may not function properly. You must 
make these modifications before you use the Report Administration utility in the Vantagepoint desktop 
application to upload the report into Vantagepoint.  

Report Name 

When you create a custom report from a Vantagepoint standard report, the custom report design contains 
the name of the standard report that displays in Vantagepoint Reporting. 

You must replace the standard report name with the custom report name on the Layout tab in SSDT-BI 
Report Designer. 
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Custom Properties 

The XML section of a standard Vantagepoint report's .rdl file contains custom properties for reports that 
are used to: 

 Load the custom report using the Vantagepoint Report Administration utility. 

 Control Vantagepoint report options. 

You must delete and modify some of the existing custom properties that no longer apply for a custom 
report. Your custom report will not function properly if you do not make these modifications. 

You define custom properties between the <CustomProperties> and </CustomProperties> tags in the 
XML code of a report's .rdl file. You modify custom properties in a report on the Properties window of the 
report. 

1. In the Properties list, navigate to CustomProperties.  
2. Click the  ellipsis button to open the Custom Properties dialog box. 

The following sections of this guide identify the custom properties that you must delete or modify. 

ReportBO 

The ReportBO custom property is used for Vantagepoint standard reports. It is not valid for custom 
reports and must be deleted to prevent errors in Vantagepoint. 

Delete the following section of the XML code (this example uses the standard Project List report): 

<CustomProperty> 

<Name>ReportBO</Name> 

<Value>Deltek.Vision.ReportingProject.Server.ProjectList</Value> 

</CustomProperty> 

ResourceFileName 

When Vantagepoint loads the standard reports, the resource file is used to change report labels to the 
appropriate culture. Because the custom report that you are working with already has its labels converted 
to a specific culture, you must delete this ResourceFileName tag. 

Attention: If you do not replace the standard report name with a custom report name, both the 
standard and custom report display in Vantagepoint Reporting, with the same report name. 



Using SSDT-BI Report Designer 

Custom Reports and Microsoft SQL Server® Reporting Services 13 

 

Delete the following from the XML code (this example uses the standard Project List report): 

<CustomProperty> 

<Name>ResourceFileName</Name> 

<Value>Project List</Value> 

</CustomProperty> 

OptionForm 

The OptionForm custom property controls the display of the report Options dialog box in Vantagepoint 
Reporting for the custom report. If you want the report Options dialog box to display, you must replace the 
standard report's OptionForm value with the following Vantagepoint default report value: 

<Value>Deltek.Vision.Report.Client.VisionReportDialog</Value> 
Example: 

The original XML code in the standard Project List report: 

<CustomProperty> 

<Name>OptionForm</Name> 

<Value>Deltek.Vision.ReportingProject.Client.dlgRepOpt_ProjectList</Value> 

</CustomProperty> 

 

Modify the XML code as follows: 

<CustomProperty> 

<Name>OptionForm</Name> 

<Value>Deltek.Vision.Report.Client.VisionReportDialog</Value> 

</CustomProperty> 

 

GroupingType 

The GroupingType custom property controls whether or not the Sorting/Grouping tab displays on the 
report Options dialog box in Vantagepoint Reporting. For custom reports that you create from a standard 
Vantagepoint report, delete this custom property. 

Delete the following from the original XML code (this example uses the Project List report): 

<CustomProperty> 

<Name>GroupingType</Name> 

<Value>Project</Value> 

</CustomProperty> 

Note: For custom reports that are created with a standard Vantagepoint report, the report Options 
dialog box in Deltek Reporting will display a General tab, a Layout tab, and if you have added report 
parameters in Vantagepoint Custom Report Options Settings, a Custom Options tab. 
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UseColumnSelection 

The UseColumnSelection custom property determines whether or not the Column tab displays on the 
report Options dialog box for a custom report in Vantagepoint Reporting. This tab allows you to select the 
columns for a report before you generate it. For custom reports that you create from a standard 
Vantagepoint report, change the UseColumnSelection value from Y to N. 

Example: 

The original XML code in the Project List report, where the value is set to Y: 

<CustomProperty> 

<Name>UseColumnSelection</Name> 

<Value>Y</Value> 

</CustomProperty> 

 

Modify the original XML code as follows: 

<CustomProperty> 

<Name>UseColumnSelection</Name> 

<Value>N</Value> 

</CustomProperty> 

 

Further Instructions 

Further specific instruction on how to create and design Vantagepoint custom reports is beyond the scope 
of this document. You can contact CustomServices@Deltek.com for information about Deltek's 
assistance with custom reports. 

Upload Custom Reports into Vantagepoint 

Vantagepoint does not support the deployment of reports to the Vantagepoint report server directly from 
within the SSDT-BI Report Designer software. Instead, you use the Vantagepoint Report Administration 
utility to load reports onto the Vantagepoint report server and into Vantagepoint. 

For more information, see: Load Custom Reports into Vantagepoint. 

 

Note: To add a Sorting/Grouping tab to the report Options dialog box, you must modify special tags in 
SQL statements. Instruction on how to do this is beyond the scope of this document. 

Note: To add a Columns tab to the report Options dialog box, you must modify special tags in SQL 
statements. Instruction on how to do this is beyond the scope of this document. 

mailto:CustomServices@Deltek.com
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Custom Reports for User-Defined Hubs 

Report Type Custom Property 
For any custom report that you create for a user-defined hub in Vantagepoint, you must add a report type 
custom property to the report design. This identifies the user-defined hub submenu under the 
Vantagepoint Reporting menu in which you want the custom report to display. 

You must enter the value of the report type custom property as follows:  

<Value>UDIC_<specific user-defined hub ID>_<Report name></Value> 

The specific user-defined hub is based on the singular name that you entered for the user-defined hub 
when you set up the new hub in Settings » General » Screen Designer of the browser application. It is 
the singular name, without any spaces between words if you have multiple words in the label. To see the 
singular name for a user-defined hub in Settings » General » Screen Designer, select a user-defined 
hub and then click  Hub Preferences to display the Hub Preferences dialog box. The last portion of the 
database tablename that is specified on this dialog box also displays the singular name (with no spaces). 

If you forget to add the report type custom property to a custom report, the report will not display in the 
Vantagepoint Reporting menu. 

Example: 
You have a user-defined hub named Potential Hires. 

When you created the user-defined hub, you entered Potential Hire as singular label for the user-defined 
hub (the database tablename is UDIC_PotentialHire). 

You created a custom report called Potential Hires for Sales (file name is PotentialHiresSales.rdl). 

You enter the following report type custom property for the report:  

<CustomProperty> 

<Name>ReportType</Name> 

<Value>UDIC_PotentialHire_Potential Hires-Sales</Value> 

</CustomProperty> 

After you upload this report into Vantagepoint using the Report Administration utility, the report displays in 
Reporting » Potential Hires. 

Upload Custom Reports for User-Defined Hubs 
When you upload a user-defined hub custom report into Vantagepoint using the Report Administration 
utility in the desktop application, you must set the Location field to User Defined Hub on the Custom 
Reports tab. 
The next section provides more information about uploading custom reports. 
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Load Custom Reports into Vantagepoint 
Use the Report Administration utility in Utilities in the desktop application to upload custom reports with 
.rdl file extensions to Vantagepoint. On the Custom Reports tab in Report Administration, you can upload 
custom reports from any location on a workstation into Vantagepoint. The custom reports are copied to 
your Vantagepoint report server and added to a submenu under the Reporting menu in the Vantagepoint 
Navigation pane, in the desktop application. 

 

Upload Custom Reports from a Workstation to Vantagepoint 
If you have custom reports (.rdl files) saved on a workstation, follow the instructions in this section to 
upload them into Vantagepoint. During the upload process, custom reports are copied to your 
Vantagepoint report server and Vantagepoint database. They are also added to a submenu under the 
Reporting menu in the Vantagepoint Navigation pane. 

 The copy of the report file on the report server is used when the report is accessed in 
Vantagepoint by users. 

 The copy of the report file in the Vantagepoint database serves as a backup copy that you can 
download in the event that you need a copy and you cannot find the original file on your 
workstation. 

Prerequisites: You use the Custom Reports tab in the Report Administration utility to upload custom 
reports from a workstation to Vantagepoint. A system administrator must have selected the Allow RDL 
files to be uploaded in Report Administration check box on the General tab in the Weblink utility 
before the Custom Reports tab displays in the Report Administration utility. 

To upload a custom report from a workstation into Vantagepoint: 
1. On the Navigation menu in the Vantagepoint desktop application, click Utilities » Report 

Administration. 

2. On the Report Administration form, click the Custom Reports tab. 

3. On the Load Custom Reports grid toolbar, click  Upload. 

4. On the Select Custom Report File to Upload dialog box, select an .rdl file to upload and then click 
Open. 

The report file is added to a row in the Load Custom Reports grid. 

5. In the Load Custom Reports grid, click the Location field in the row for the custom report, and 
select the Vantagepoint Reporting submenu from which you want users to select the report. 

For custom reports for any user-defined hub, select User Defined Hub. See the previous section, 
“Custom Reports for User-Defined Hubs,” for more information about adding the appropriate 
report type custom property to custom reports for user-defined hubs before you upload them into 
Vantagepoint. 

6. In the Load Custom Reports grid, upload more custom reports as needed by repeating the steps 
above. 

If a custom report has subreports, you must add each subreport individually in the grid. 

Attention: Vantagepoint does not support the deployment of reports to your Vantagepoint report 
server directly from within the SSDT-BI Report Designer software. 
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7. Click Save. 

The custom reports are uploaded to your report server and Vantagepoint database when you 
save. You will not see a status bar, and it may take a few minutes for the upload process to 
complete. 

8. When the reports finish uploading, click OK on the dialog box that tells you that the custom 
reports were uploaded. 

In the Load Custom Reports grid, the name of the report now displays in the Name field. The 
Status field displays Synchronized, meaning that the report was successfully uploaded from the 
local machine to the report server and the Vantagepoint database; matching copies exist on the 
report server and in the Vantagepoint database. 

9. Log out and then log back in to Vantagepoint to see the custom reports added to the submenus 
under the Reporting menu in the desktop application. 

The custom reports also display in the Report Name drop-down list in Settings » General » 
Custom Report Options, where you can add parameters to them. For parameter descriptions, 
see Parameters in Custom Reports. 

Status of a Custom Report 
The following are the possible status settings that a custom report can have in the Status field in the 
Load Custom Reports grid on the Custom Reports tab:  

 Synchronized Status: This status displays after you successfully upload a custom report using 
the Upload option on the Load Custom reports grid toolbar. It means that the custom report was 
uploaded successfully to your report server and the Vantagepoint database. 

 Missing in Report Server Status: This status means that the custom report was uploaded to the 
Vantagepoint database (as a backup copy), but it no longer exists on the report server. This could 
happen if you manually deleted the report on the report server or if you migrated to a new report 
server. Because there is a backup copy saved in the Vantagepoint database, you can click the 
Synchronize option on the Load Custom Reports grid menu to re-upload a copy of the backup 
report from the Vantagepoint database to the report server. 

 Missing in Database Status: This status means that a custom report is uploaded to the report 
server, but it does not have a backup copy saved in the Vantagepoint database. This can occur if 
you upgraded to Vantagepoint from Vision and you previously uploaded custom reports to the 
report server in earlier Vision versions, before the custom report status feature was implemented. 
In this scenario, to upload a copy of the report to the Vantagepoint database and change the 
status of the report to Synchronized: delete the report from your report server and upload it 
again using the Upload option on the Load Custom reports grid toolbar on the Custom Reports 
tab of the Report Administration utility in Vantagepoint.  
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Parameters in Custom Reports 
Parameters that you add to a report allow users to filter report content before they generate the report. 
For example, you could add a parameter to a report that allows you to enter a period start and end date 
so that you can include data for only certain periods on the report. 

Parameters that you add to a custom report design in the .rdl file display as options on the Custom 
Options tab of the report's Options dialog box in Vantagepoint Reporting if you complete both of the 
following: 

 In the custom report .rdl file, you must add the prefix "cust" to the parameter name so that it will 
work with Vantagepoint. 

The following example shows two parameters with the names custPeriodStartDate and 
custPeriodEndDate within the XML code of an .rdl file in SSDT-BI Report Designer. 

 
 After you deploy and load the custom report into Vantagepoint with the Vantagepoint Report 

Administration utility, you add the report parameters to the report in Settings » General » 
Custom Report Options, in the Vantagepoint desktop application. 

To add the parameters in Vantagepoint: 
1. On the Navigation menu in the Vantagepoint desktop application, click Settings » General » 

Custom Report Options. 

2. On the Report Custom Options form, select the custom report from the Report Name drop-down 
list. 

On the Options grid toolbar, click  Insert to add a parameter to a blank row in the grid. 

3. In the Option Label field, enter the text that you want to display for the parameter on the Custom 
Options tab on the Report Options dialog box in Vantagepoint Reporting. 

4. In the Parameter Name field, enter the name of the parameter as it is entered in the custom 
report .rdl file but without the prefix "cust." 

5. In the Data Type field drop-down list, select the type, such as Character, CheckBox, Date, and 
so on, that matches the data that the parameter contains. 

6. Complete the remaining fields in the grid as appropriate for your parameter data type. 

7. When you finish, click  Save. 
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To use the parameters before you generate a custom report: 
1. On the Vantagepoint Reporting menu in the desktop application, navigate to the custom report 

location. 

2. On the Report form, click the cell of the custom report's Options column to display and then click 

the  icon. 

 
On the report Options dialog box, click the Custom Options tab to enter parameter options before you 
print or preview the report. 
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Apply Role Security to Custom Reports 
After a custom report is created and loaded into the Vantagepoint software, a Vantagepoint system 
administrator applies Vantagepoint role security to specify who is allowed to access the custom report on 
the Vantagepoint Reporting menu. 

To add a custom report to the list of reports that a role can access: 
1. On the Navigation pane in the Vantagepoint browser application, select Settings » Security » 

Roles. 

2. In the Search field on the Roles form, enter the role for which you want to give access to the 
custom report. 

3. On the Access Rights tab, set the Functional Area option to Reports. 

4. Click + Add/Remove. 

5. On the Reports dialog box, select the type of report in the Report Type field, such as Accounts 
Receivable, Project, and so on, for the custom report to which you are granting access. 

6. In the Custom Type field, select Custom. 

The custom reports for the report type display in the Available Reports list. 

7. Click the appropriate custom report in the Available Reports list and then click Save to add it to 
the Reports for this Role grid in the Roles form. 

Changes to the role settings are saved automatically. After you make changes to role settings, have 
employees in any updated security role profiles log out and then log in again, to ensure that all 
appropriate access changes are applied. 
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SkipProcessing Custom Property 
You can set the SkipProcessing table-level custom property to Y to have the Vantagepoint framework 
bypass the processing of a tablix data region of a report at runtime. The tablix data region will display 
what you see in the report design. This custom property applies to reports that are created with SSDT-BI 
Report Designer. It can be helpful for troubleshooting problems with previewing reports. 
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Appendix A: Custom Reports and Migrating from 
Vision to Vantagepoint On-Premises 
This information applies if you are migrating from the Deltek Vision product to the Deltek Vantagepoint 
on-premises product and you have custom reports that were created with Microsoft SQL Server Reporting 
Services 2005 or 2008. This information also applies for upgrading Vision custom reports that you use to 
generate custom invoices in Vantagepoint. 

RDL 2005 and RDL 2008 Schema Are Not Supported in 
Vantagepoint 
Custom reports that you created with Microsoft SQL Server Reporting Services 2005 or Microsoft SQL 
Server Reporting Services 2008 have RDL 2005 and RDL 2008 schema are not supported in 
Vantagepoint. You must upgrade these custom reports to change the schema to RDL 2010 before you 
can use them in Vantagepoint. You must use SSDT-BI 2013 Report Designer, Report Builder 3.0, or the 
Vantagepoint Report Administration utility to upgrade the reports to the supported RDL 2010 schema. 
See the sections below for instruction. 

Upgrading from Vision Versions Earlier than 7.0 
If you are upgrading to Vantagepoint on-premises from a Vision version earlier than 7.0:  After you 
upgrade the reports, you must update report queries to revise any database table names that were 
changed in Vision 7.0. Database table names that were changed are identified in the “Vision 7.0 
Database Table Name Changes that Affect Custom Reports” section below. 

If a Custom Report Does Not Work Properly 
Other Vantagepoint framework changes that are applied within the report business objects may affect 
your custom reports after you migrate to Vantagepoint, causing them to not work properly. If a custom 
report does not work properly after you upgrade and update any renamed database tables, Deltek 
recommends that you recreate the custom report using Vantagepoint and SSDT-BI 2013 Report Designer 
or Report Builder 3.0. 

Before You Create a Custom Report 
Before you recreate a custom report with SSDT-BI 2013 Report Designer or Report Builder 3.0, consider 
the following questions: 

 Do you still need the custom report? 

 Are there standard reports in Vantagepoint that provide the information that you need? 

 Is the custom report that you created with BIDS 2005, BIDS 2008, or Report Builder versions 1.0 
or 2.0 based on a Vantagepoint standard report? If so, you can start with a standard 
Vantagepoint report and modify it in SSDT-BI 2013 Report Designer or Report Builder 3.0 to 
recreate your custom report. 
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Upgrade Custom Reports Using SSDT-BI 2013 Report 
Designer 
These instructions apply for Vision custom reports that you created with BIDS 2005 or BIDS 2008 that 
need to be upgraded to the RDL 2010 schema. For these upgrade instructions, you start by opening or 
creating a report project (instead of opening the report RDL files). 

Custom Reports that Already Have a Report Project 
If a custom report already has a reporting project, use the following instructions to upgrade the report. 

To upgrade Vision custom reports using SSDT-BI Report Designer to be compatible with 
Vantagepoint: 

1. Use Report Designer to open an existing Vision custom report project. 

2. Complete the wizard that starts automatically. It guides you through upgrading the report project. 

3. Open a custom report in Report Designer. 

4. The following applies if you are upgrading to Vantagepoint from a Vision 6.x version: For any 
Vision database tables included in the report that have new names in Vantagepoint, replace the 
old names with the new names. 

For a list of affected tables and instructions, see Vision 7.0 Database Table Name Changes that 
Affect Custom Reports. 

5. Review the database changes for Vantagepoint and update your custom reports as needed. 

You can access the Vantagepoint Data Dictionary in the Vantagepoint online help by clicking the 
? help icon. In the help Contents pane, scroll to the bottom of the contents and click Data 
Dictionary. The data dictionary is also available from the Deltek Support Center website. 

6. In the Report Property pane, enter a dummy value in InitialPageName property. 

7. Save the report. 

8. Remove the dummy value in the InitialPageName property and save the report again. 

9. Repeat step 3–8 for each custom report in the report project. 

10. Upload the custom reports to Vantagepoint using the Vantagepoint Report Administration utility, 
as described in the “Load Custom Reports into Vantagepoint” section. 

If a report does not run properly, you may need to recreate it with SSDT-BI Report Designer. 

Note: If you need additional assistance with custom reports, contact Deltek Global Services. 

For detailed information and training on how to design a Vantagepoint report with Report Designer or 
Report Builder, Deltek University offers report writing classes. 

For class offerings, see http://www.deltek.com/services/deltekuniversity. 

http://www.deltek.com/services/deltekuniversity/
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Custom Reports that Do Not Have a Reporting Project 
If a custom report does not have a reporting project, you create a reporting project before you upgrade 
the report. 

To create a reporting project and upgrade Vision custom reports to be compatible with 
Vantagepoint using SSDT-BI Report Designer: 

1. Open SQL Server Data Tools for Visual Studio 2013. 

2. On the File menu, click New » Project. 
3. In the Project types pane of the New Project dialog box, select Business Intelligence Projects. 

4. In the Templates pane, select Report Server Project. 

 
5. In the Name field, enter a name for the report project. 

Enter a name that is related to the type of reports that you will add to this project. For example, 
for billing reports, you could name the project “Billing.” 

6. In the Location field, enter the location where the reports will be stored. 

Deltek recommends that you store reports in <your Vantagepoint installation 
path>\Reports\Custom. 

Example: c:\Program Files (x86)\Deltek\Vantagepoint\Reports\Custom 

7. On the New Project dialog box, click OK. 

8. Add the RDL file for existing custom reports to the report project: 

a) In the Solution Explorer pane, right-click the Reports folder, and click Add » Existing Item. 

b) On the Add Existing Item dialog box, navigate to an existing RDL file to add it to the report 
project. 

c) Modify the InitialPageName property of the report and add a dummy value. 

d) Save the report file. 
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The schema of the RDL file is changed from RDL 2005 or RDL 2008 to RDL 2010. 

e) Remove the dummy value in InitialPageName property and save the report again. 

f) Repeat these steps to add RDL files for other custom reports to the report project. 

9. Open a custom report in Report Designer. 

10. For any Vision database tables included in the report that have new names in Vantagepoint, 
replace the old names with the new names. 

This applies if you are upgrading to Vantagepoint from a 6.x version: For a list of affected tables 
and instructions, see Vision 7.0 Database Table Name Changes that Affect Custom Reports. 

11. Save the report. 

12. Repeat step 9 and 10 for each custom report. 

13. Upload the reports to Vantagepoint using the Vantagepoint Report Administration utility as 
described in Load Custom Reports into Vantagepoint. 

If a report does not run properly, you may need to recreate it with SSDT-BI Report Designer. 

Upgrade Custom Reports Using Report Builder 3.0 
These instructions apply for Vision custom reports that you created with Report Builder version 1.0 or 2.0. 
With these instructions, you can update a report’s RDL file directly. 

To upgrade Vision custom reports to the RDL 2010 schema using Report Builder 3.0: 
1. Use Report Builder 3.0 to open a custom report RDL file. 

2. Save the report file. 

Saving the file changes the schema from RDL 2008 or RDL 2005 to RDL 2010. 

3. In Report Builder 3.0, for any Vision database tables included in the report that have new names 
in Vantagepoint, replace the old names with the new names. 

This applies if you are upgrading to Vantagepoint from a Vision 6.x version: For a list of affected 
tables and instructions, see Vision 7.0 Database Table Name Changes that Affect Custom 
Reports. 

4. Save the report. 

5. Upload the report to Vantagepoint using the Vantagepoint Report Administration utility as 
described in Load Custom Reports into Vantagepoint. 

If a report does not run properly, you may need to recreate it with Report Builder 3.0. 

Upgrade Custom Reports Saved in the Vision Database Using 
Report Administrator 
Use these instructions to upgrade custom reports that are already saved in your Vision database, with the 
RDL 2008 schema, to the RDL 2010 schema that Vantagepoint supports. 

 

Note: These instructions apply only if the custom reports in your Vision database have the RDL 2008 
schema. You must use SSDT-BI 2013 Report Designer or Report Builder 3.0 to upgrade reports with 
the RDL 2005 schema. 
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This upgrade process opens all your custom reports, and for each report it upgrades the report schema, 
resaves the report in the Vantagepoint database, and uploads the report to the Vantagepoint report 
server. 

To upgrade custom reports that are saved in your Vision database with the RDL 2008 schema to 
the RDL 2010 schema: 

1. On the Navigation menu in the Vantagepoint desktop application, select Utilities » Report 
Administration. 

2. On the Report Server form, click the Custom Reports tab. 

 
3. On the Custom Reports tab, click the Upgrade option on the toolbar of the Load Custom Reports 

grid. 

 The Upgrade option displays on the grid toolbar only if you have a saved custom report in 
the Vision database. 

 If all your existing custom reports already use the latest RDL 2010 schema, you receive the 
following message: "All existing custom reports stored in your database are already using the 
latest schema." 

4. Click Yes on the dialog box that says: "This will upgrade all existing custom reports currently 
stored in your database to the latest schema. Would you like to continue?" 

 The upgrade starts. 

 During the upgrade, Vision backs up the custom reports that are saved in the Vision 
application server’s Report\Backup folder. 

 When the upgrade finishes, you receive the following message: "All custom reports have 
been successfully upgraded to the latest schema." 
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5. After the upgrade finishes, check the RDLProcessing.log log file that is saved in the Vision 
application server's Report\Backup\<database name> folder.  

The file contains the status for each processed RDL file and will identify any errors. 

Upgrade Custom Reports Saved Locally Using Report 
Administrator 
Use these instructions to upgrade Vison custom reports that are saved on a local machine with the RDL 
2008 schema to the RDL 2010 schema that Vantagepoint supports. These instructions apply for custom 
reports have not been saved in the Vision database. This process is useful if you are currently working on 
or developing custom reports that are still in the old schema and the reports have not been uploaded to 
the Vision database yet. 

 

To upgrade custom reports on a local machine with the RDL 2008 schema to the RDL 2010 
schema: 

1. On the Navigation menu in the Vantagepoint desktop application, select Utilities » Report 
Administration. 

2. On the Report Server form, click the Custom Reports tab. 

 
3. In the Apply Schema Update to Custom Report File section, click the Select Folder button. 

Note: These instructions apply only if the custom reports on a local machine have the RDL 2008 
schema. You must use SSDT-BI 2013 Report Designer or Report Builder 3.0 to upgrade reports with 
the RDL 2005 schema. 
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4. In the Browse for Folder dialog box, scroll to and select the folder in which the custom reports are 
located, and click OK to close the dialog box. 

5. Click the Apply button to update the reports. 

6. Review the RDLProccessing.log log file that is saved in the folder where the custom reports are 
located. 

The file contains the status for each processed RDL file and identifies any errors. 

Vision 7.0 Database Table Name Changes that Affect Custom 
Reports 
Vision database tables used in reports that had a name change in Vision 7.0 are listed below. If you are 
upgrading to Vantagepoint on-premises from a Vision version that is earlier than 7.0, then after you 
upgrade your custom reports, you must replace the old table names with the new names in report queries 
that include the affected tables. For example, if a custom report included the CFGCountry table, you must 
replace CFGCountry with FW_CFGCountry.  

If you do not update the table names, you will receive errors when you run the reports. 

Database table name updates can also occur as newer versions of Vantagepoint are released. Refer to 
the maintenance release notes and the data dictionary as new versions are released. 

Vision 7.0 Table Name Changes that Affect Custom Reports 

Table Name in Vision 6.x Table Name in Vision 7.0 and Later 

CFGCountry FW_CFGCountry 

CFGCurrency FW_CFGCurrency 

CFGPhoneFormat FW_CFGPhoneFormat 

CFGEnabledCurrencies FW_CFGEnabledCurrencies 

InfoCenterTabHeadings FW_InfoCenterTabHeadings 

ReportPrinters FW_ReportPrinters 

To change a table name in either Report Designer or Report Builder: 
1. Open the report in either of the reporting tools. 

2. On the Report Data pane, expand the Datasets folder. 

3. Double-click ReportDataset. 
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4. In the Query text box in the Dataset Properties window, find mention of the old table name, and 

replace it with the new table name.  

 

 
5. Click OK. 

If you receive the following message, click OK. You do not need to refresh the field list; you are 
updating the table name only. 

Note: To quickly determine whether the query contains an affected table, you can copy the 
contents from the Query text box into a word processor. Then use Find in the word processor 
to search for the table name. 
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Custom Invoices Created with Microsoft SQL Server 
Reporting Services 2005 and 2008 
Vision custom invoices are basically reports. Follow the instructions in the previous sections for upgrading 
custom invoices that were created with Microsoft SQL Server Reporting Services 2005 or 2008. When 
you upgrade them, the RDL 2005 or RDL 2008 schema of the report will be upgraded to RDL 2010. 

After you upgrade custom reports to the RDL 2010 schema, review your custom invoice reports and their 
custom templates to make sure everything is working properly. 
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Appendix B: If You Need Assistance 
If you need assistance installing, implementing, or using Vantagepoint, Deltek makes a wealth of 
information and expertise readily available to you. 

Customer Services 
For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems, 
listening to their needs, and getting to know their individual business environments. A full range of 
customer services has grown out of this close contact, including the following: 

 Extensive self-support options through the Deltek Support Center. 

 Phone and email support from Customer Care analysts 

 Technical services 

 Consulting services 

 Custom programming 

 Classroom, on-site, and Web-based training 

 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 
 Search for product documentation, such as release notes, install guides, technical information, 

online help topics, and white papers 
 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 

Deltek Support Center Community 
 Access Cloud-specific documents and forums 
 Download the latest versions of your Deltek products 
 Search Deltek’s knowledge base 
 Submit a support case and check on its progress 
 Transfer requested files to a Customer Care analyst 
 Subscribe to Deltek communications about your products and services 
 Receive alerts of new Deltek releases and hot fixes 
 Initiate a Chat to submit a question to a Customer Care analyst online 

 

Attention: Find out more about these and other services from the Deltek Support Center. 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 
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Access Deltek Support Center 
To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 
 

 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/


 

 

About Deltek 
Better software means better projects. Deltek delivers software and information solutions that enable 
superior levels of project intelligence, management and collaboration. Our industry-focused expertise 
makes your projects successful and helps you achieve performance that maximizes productivity and 
revenue. www.deltek.com 

http://www.deltek.com/
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