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Overview 
Standard reports that are provided with Deltek Vantagepoint are designed to meet most of your business 
needs. In addition, you can create custom reports using Microsoft SQL Server® Reporting Service’s SQL 
Server Data Tool (SSDT) — Report Designer. This report writing tool is also known as Visual Studio 2017 
(SSDT). 

This guide applies if you use the Vantagepoint cloud or on-premises product.  

What’s New 

Vantagepoint 7.0 
We have added the Synchronize Custom Reports during Vantagepoint Migration section in 
Appendix A: Custom Reports and Migrating from Vision to Vantagepoint On-Premises. 

What This Guide Covers 
This guide provides information for the following steps, which you must complete to create, deliver, and 
generate Vantagepoint custom reports: 

Step Description 

1 Install Visual Studio 2017 (SSDT) or a later version on the machines (usually 
workstations) from which you will create or edit Vantagepoint custom reports. 

2 Do either one of the following to create custom reports: 

▪ Load the Vantagepoint report templates on the workstation of users who will 
create custom reports. Access the Vantagepoint report templates in Visual Studio 
2017 (SSDT) or later to create custom reports.  

▪ Create a custom report from a copy of a Vantagepoint standard report in Visual 
Studio 2017 (SSDT) or later. 

3 Load custom reports into Vantagepoint using the Vantagepoint Report Administration 
utility. 

4 Set up parameters for a custom report in Settings » General » Custom Report 
Options in the desktop application. Parameters allow users to filter report content 
before they generate a report. 

5 In Vantagepoint Role Security Settings, apply role security to give the appropriate 
Vantagepoint users the ability to access the custom reports and print or preview those 
reports from the Vantagepoint Reporting menu.  

Appendix A provides instructions for upgrading custom reports when you migrate from Deltek Vision to 
the Vantagepoint on-premises product. This information also applies for upgrading from Vision any 
custom reports that you will use to generate invoices in Vantagepoint.  

Specific instructions on how to create and design Vantagepoint custom reports are beyond the scope of 
this document. Assistance with creating custom reports is not covered by your Deltek Ongoing Support 
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Plan (OSP). If your firm requires custom reports, contact VantagepointConsulting@Deltek.com for 

information about the custom report services that they provide. 

Updates to This Guide 
Guides are revised regularly to provide the most up-to-date technical information and instructions. Visit 
the Deltek Support Center at https://support.deltek.com, to download the most recent copy. 

Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® Reader® X 
provides this ability. If you do not already use Adobe Reader X, you can download it here free from 
Adobe.  

To add a custom note using Adobe Reader X, complete the following steps: 

1. On the Reader toolbar, click Comment at the far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to match the 
button. 

3. Position the cursor at the location in the guide where you want the note to appear and click. A 
note icon is inserted at the location and a text box pops up. 

4. Enter your information in the text box.  

5. Continue adding notes as needed. 

6. Save the document. 

 

When reading the document, cursor over a note icon to see the information. Double-click a note icon to 
edit the information. 

Note: Deltek recommends that you save the document to a slightly different filename to keep the 
original from being overwritten. 

mailto:VantagepointConsulting@Deltek.com
https://support.deltek.com/
http://get.adobe.com/reader/


Supported Report Writing Tool 

Custom Reports and Microsoft SQL Server® Reporting Services 3 

 

Supported Report Writing Tool 
The following versions of the Microsoft SQL Server® Reporting Services (SSRS) report writing tool are 
supported for creating Vantagepoint custom reports: 

▪ Visual Studio 2017 (SQL Server Data Tools) or later 

▪ Report Builder 15.0 

RDL 2016 Schema 
Use Visual Studio 2017 (SSDT), Visual Studio 2019 (SSDT), or Visual Studio 2022 (SSDT) to produce a 
report file with the (Report Definition Language) RDL 2016 Schema that Vantagepoint requires. 

If you try to load a custom report into Vantagepoint that was created with an unsupported version of 
SSDT Report Designer, or an unsupported SSRS report writing tool, you will receive a “SQL Report Error 
loading report” error message. 

To determine whether or not a custom report was created with a supported report writing tool and has the 
supported RDL schema, open an .rdl file for a custom report, and look at the header lines. If the report 
has the supported RDL 2016 Schema, it will have 2016 in the path. The RDL files are not supported in 
Vantagepoint 6.5 if the header lines display these years in the path: 2008, 2010, 2012, or 2014. 

The following are header line examples: 

▪ The header line in an .rdl report file that is created with Visual Studio 2017 (SSDT) or later is: 

<Report xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner" 
xmlns="https://schemas.microsoft.com/sqlserver/reporting/2016/01/reportdefinition"> 

 

 

 

  

Note: To support the ability to open, generate, and print custom Vantagepoint reports, the 
Vantagepoint database and report servers must have one of the supported or compatible versions of 
Microsoft SQL Server installed. For a full list of Microsoft SQL Server releases (R), service packs 
(SP), and cumulative updates (CU) that are supported or compatible with Vantagepoint, see the 
Deltek Product Support Compatibility Matrix. You can download this PDF document at the Deltek 
Support Center: Deltek Support Center. 

https://support.deltek.com/


Supported Report Writing Tool 

Custom Reports and Microsoft SQL Server® Reporting Services 4 

 

Installing Visual Studio 2017 (SSDT) or Later 
Install one of the above-mentioned Visual Studio versions on the machines (with the appropriate 
licensing) from which you will create or edit Vantagepoint custom reports. These machines are typically 
workstations, rather than Vantagepoint web servers. 

1. When you use the following Microsoft link to download the installer: 

https://docs.microsoft.com/en-us/sql/ssdt/download-sql-server-data-tools-ssdt?view=sql-server-
ver15#ssdt-for-visual-studio-2017 

This page displays instructions for installing SSDT for Visual Studio 2022:  

 

IMPORTANT: When you complete the installation of Visual Studio 2017 (SSDT) or a later version, 

you must download and install the Microsoft Reporting Services Projects extension.  

2. Launch Visual Studio 2017 (SSDT) or later. 

  

https://docs.microsoft.com/en-us/sql/ssdt/download-sql-server-data-tools-ssdt?view=sql-server-ver15#ssdt-for-visual-studio-2017
https://docs.microsoft.com/en-us/sql/ssdt/download-sql-server-data-tools-ssdt?view=sql-server-ver15#ssdt-for-visual-studio-2017
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3. On the Extensions menu, click Manage Extensions. 

4. In the Folders pane of the Source Control Explorer dialog, select the tfs.deltek.com\Deltek 
folder. 

 

5. In the Search field at the top right, enter “reporting services”. 

6. Download and install Microsoft Reporting Services Projects. 

 

 

During the installation, select the Install tools for SQL Server Reporting Services checkbox. 
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Note: For a full list of Microsoft SQL Server releases (R), service packs (SP), and cumulative updates 
(CU) that are supported or compatible with Vantagepoint, see the Deltek Product Support 
Compatibility Matrix. You can download this PDF document at the Deltek Support Center. 

Deltek can also arrange for implementation services support from your Deltek consultant. 

If you have any additional questions, contact Deltek Customer Care at 877.457.7765. 

https://support.deltek.com/
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Using Visual Studio 2017 (SSDT) Report Designer 
or later    
Visual Studio 2017 (SSDT), Visual Studio 2019 (SSDT), or Visual Studio 2022 (SSDT) is a full-featured, 
advanced report writing tool that enables you to create both simple and complex reports. 

Reporting Capabilities of Visual Studio 2017 (SSDT) Report 
Designer or later  
You can do the following with Visual Studio 2017 (SSDT) Report Designer or later versions:  

▪ Create table, matrix, chart, and free form reports 

▪ Apply grouping and formulas in reports 

▪ Apply sorting 

▪ Apply filtering 

▪ Apply advanced reporting features, including complex queries, advanced charting, parameters, drill 
downs, sub-reports, and so on 

▪ Create expressions to specify report data 

▪ Combine tables, lists, and charts in the same report 

▪ Include Vantagepoint user-defined fields in reports 

▪ Access the full Vantagepoint database with the reporting tool 

▪ Include a Sorting/Grouping tab or Columns tab in Vantagepoint Reporting for custom reports (if you 
modify special tags in SQL statements) 

You cannot do the following: 

▪ Create ad hoc reports 

▪ Launch the report writing application within Vantagepoint 

▪ Create a custom report Options dialog box to display in Vantagepoint Reporting for a custom report 

▪ Deploy custom reports outside of Vantagepoint 

Give Report Writing Users Access to the SSRS Report Server 
To allow report writing users access to the SSRS report server, you must give them the following SSRS 
permissions: 

▪ At the server level, users must be system users. 

▪ At the folder level, users must be granted browser and Content Manager access. 

 

Attention: Users who have access to your SSRS report server to create custom reports in SSDT-BI 
Report Designer can access all fields in your Vantagepoint database. Vantagepoint role security does 
not apply when accessing the Vantagepoint database to create custom reports. 
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Non-Domain Clients 
SSRS requires Windows Integrated Authentication. Non-domain clients (clients who do not run Active 
Directory or have a Windows domain) must do the following: 

▪ Create a local account on the SSRS report server for each user who creates custom reports. 

▪ Grant the necessary reporting services permissions (see the previous section) to those who create 
custom reports. 
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Create a Custom Report Using Vantagepoint 
Report Templates 
Vantagepoint comes with report templates that you can use to create custom reports using any one of 
these versions of Visual Studio: 2017, 2019, or 2022 (SSDT). The templates provide formatting for 
custom reports similar to the formatting of Vantagepoint standard reports. 

Report Template Files 
The template files for custom reports are: 

▪ DVPTemplateAudit.rdl — Use this template to create audit trail summary reports. Hub audit reports, 
such as Firm Audit and Vendor Audit, are examples of this type of report. 

▪ DVPTemplateAuditDetail.rdl — Use this template to create audit trail detail reports. Hub audit detail 
reports, such as Firm Audit Detail and Vendor Audit Detail, are examples of this type of report. 

▪ DVPTemplateCustomReport.rdl — Use this template to create a custom report without any pre-
defined layout. 

▪ DVPTemplateLandscape.rdl — Use this template for column selection reports that must be printed 
using the landscape orientation. Report properties are set for this, so you do not need to modify them. 

▪ DVPTemplatePortrait.rdl — Use this template to create column selection reports. 

▪ DVPTemplatePostingLog.rdl — Use this template to create posting log reports. 

▪ DVPTemplateSubReport.rdl — Use this only to create a sub-report. Vantagepoint billing invoices 
are examples of reports that use sub-reports. Each section of a single billing invoice (report) is 
created by using sub-reports. 

▪ DVPTemplateTransactionList.rdl — Use this template to create transaction list reports. 

Example: This is an example of a DVPTemplatePortrait.rdl file when you open it in Report Designer: 

 

Load the Vantagepoint Report Templates on a Workstation 
To use the Vantagepoint report templates to create a custom report from a workstation, you first must 
load the report template .rdl files on the workstation. 

To load the Vantagepoint report template files on a workstation that has Visual Studio 2017 
(SSDT) or a later version installed: 

1. Click https://dsm.deltek.com/DocumentationLists/DeltekVantagepoint70GA.html open the Deltek 
Vantagepoint 7.0 Documentation list at the Deltek Support Center.  

https://dsm.deltek.com/DocumentationLists/DeltekVantagepoint70GA.html
https://deltek.custhelp.com/
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2. In the list, click Deltek Vantagepoint 7.0 Custom Report Template Files RDLs to download the 
DeltekVantagepoint70CustomReportTemplateFilesRDLs.zip file with the report templates to the 
workstation. 

3. On the workstation, right-click the.zip file and on the shortcut menu and select Extract All to 
extract the files to a folder on the workstation.  

4. Copy the .rdl files from the unzipped file to the following location on the workstation C: drive: 

C:\Program Files (x86)\Microsoft Visual Studio\2017\SQL\Common7\IDE\ 
CommonExtensions \Microsoft\SSRS\ProjectItems\ReportProject 

Access the Report Templates in Visual Studio 2017 (SSDT) or 
later 
After you copy the .rdl template files to a workstation, when you launch Visual Studio 2017 (SSDT) or a 
later version and select Business Intelligence Projects, the Vantagepoint templates display in the list of 
templates as in the following screenshot. 

  

 

To access the Vantagepoint report templates to create a custom report, you complete three 
procedures: 

1. Create a solution and report server project. 

Note: You cannot use Vantagepoint report templates with the Visual Studio 2017 (SSDT) Report 
Designer Report Wizard. 

file:///C:/Users/junecruzate/AppData/Local/Microsoft/Windows/INetCache/Content.Outlook/PLCLUW57/DeltekVantagepoint65CustomReportTemplateFilesRDLs.zip
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2. Create the shared data source. 

3. Select a Vantagepoint template and start to create a custom report. 

To create a solution and report server project: 

1. On your workstation, open one of the following Visual Studio versions by clicking: 

• Start » Visual Studio 2017 (SSDT) 

• Start » Visual Studio 2019 (SSDT) 

• Start » Visual Studio 2022 (SSDT) 

2. Click File » New » Project. 

3. In the Project Types pane of the New Project dialog box, select Reporting Services. 

4. In the Templates pane, select Report Server Project. 

 

5. In the Name field, enter a name for the report server project, such as DeltekCustomReports. 

A report server project contains: 

▪ A data source (information about a connection to a data source for your report). 

▪ Any custom reports that you create with the data source. 

6. In the Location field, enter the path on your workstation where you want to store the report 
server project. 
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7. In the Solution Name field, enter a name for the solution in which this report server project will be 
contained. 

Solutions can contain multiple projects. 

8. Click OK. 

In the Solution Explorer pane, you now see the solution that you just created. To display the 
Solution Explorer pane, click View » Solution Explorer. 

To create the shared data source: 

1. In the Solution Explorer pane that is located below your solution, right-click Shared Data 
Sources, and click Add New Data Source on the shortcut menu. 

2. On the General tab of the Shared Data Source dialog box, in the Name field, enter 
DefaultDataSource. 

This is the name of the Vantagepoint data source. 

 

3. In the Type field, select Microsoft SQL Server. 

4. Click the Edit button beside the Connection string text box to open the Connection Properties 
dialog box, on which you can create the connection string to your Vantagepoint database. 

a) Select the server on which your Vantagepoint database resides. 

Deltek recommends that you use Windows authentication to log on to the server. This 
prevents users from accessing information via Visual Studio 2017 (SSDT) or later that they 
should not access. If you use SQL Authentication and save the password, the password is 
saved as plain text and can be seen with Notepad. 

b) Enter the Vantagepoint database name to connect to. 

c) Click OK. 

5. On the Credentials tab of the Shared Data Source dialog box, enter the credential information for 
the data source and then click OK. 

In the Solution Explorer pane, you now see DefaultDataSource.rds in the Shared Data Sources 
folder within the solution. 

6. On the Microsoft Visual Studio toolbar, click File » Save All. 

Save your solution often to prevent losing modifications if Visual Studio 2017 (SSDT) Report 
Designer or a later version terminates. 

To select a Vantagepoint template and start to create a custom report: 

1. In the Solution Explorer pane, right-click the Reports folder, and click Add » New Item on the 
shortcut menu. 

On the Add New dialog box, you see the Vantagepoint report templates.  

Attention: All of the Vantagepoint report templates look at the data source called 
DefaultDataSource. If you name it something else, you will receive an error when you select 
the Data tab of the Design window. When you receive the error, click OK and then modify the 
dataset to use your connection instead. You must do this for each dataset. 

Also, when you rename an existing data source, if you previously used the data source for a 
report, the report will be broken, and you need to edit the report query to reference the new 
data source name. 
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2. Click a report template to open it and create a custom report with it. 

Specific instructions on how to create and design Vantagepoint custom reports are beyond the 
scope of this document. You can contact VantagepointConsulting@Deltek.com for information 
about the custom report services that Deltek provides. 

3. After you create a custom report and it is ready for others to use, load the report into 
Vantagepoint using the Report Administration utility in the Vantagepoint desktop application. 

Vantagepoint does not support the deployment of reports to the SSRS report server directly from 
within the Visual Studio 2017 (SSDT) Report Designer or later software versions. Instead, you 
use the Vantagepoint Report Administration utility to load custom reports.  

For more information, see: the “Load Custom Reports into Vantagepoint” section. 

Multilingual Companies and Report Templates 
You can create custom reports in multiple languages only if you purchase and activate the Vantagepoint 
Multilingual module. 

If you have multilingual companies in your enterprise and you want the ability to generate a report in 
multiple languages from one report design, you must create custom reports with Vantagepoint report 
templates loaded locally on a workstation. When you create a custom report with the Vantagepoint report 
templates directly on your SSRS report server, the report can be generated only for the specific culture 
(language) from which you accessed the report template. 

mailto:VantagepointConsulting@Deltek.com
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Create a Custom Report from a Vantagepoint 
Standard Report in Visual Studio 2017 (SSDT) or 
later 
If the content of a standard report is similar or close to what you need in a custom report, you may want to 
start with a copy of a standard report definition (.rdl) file and then modify it in Visual Studio 2017 (SSDT) 
of Report Designer or later versions to suit your needs. 

Open the Custom Report RDL File in Visual Studio 2017 
(SSDT) Report Designer or later 
After you create and save a custom report .rdl file from a standard report, open the custom report .rdl file 
in Visual Studio 2017 (SSDT) Report Designer or later versions. 

To open the custom report .rdl in Visual Studio 2017 (SSDT) Report Designer or later versions: 

1. Open a report project within Visual Studio 2017 (SSDT) Report Designer or later versions. 

2. Select the option to add an existing item to the project and browse to where you saved the .rdl file 
to open it. 

XML Code that You Must Modify 
When you start with a standard Vantagepoint report to create a custom report, you must modify some of 
the XML code in the report's .rdl file to remove and replace items that are not appropriate for your custom 
report. If you do not make these modifications, your custom report may not function properly. You must 
make these modifications before you use the Report Administration utility in the Vantagepoint desktop 
application to upload the report into Vantagepoint.  

Report Name 
When you create a custom report from a Vantagepoint standard report, the custom report design contains 
the name of the standard report that displays in Vantagepoint Reporting. 

You must replace the standard report name with the custom report name on the Layout tab in Visual 
Studio 2017 (SSDT) or later versions. 
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Custom Properties 
The XML section of a standard Vantagepoint report's .rdl file contains custom properties for reports that 
are used to: 

▪ Load the custom report using the Vantagepoint Report Administration utility. 

▪ Control Vantagepoint report options. 

You must delete and modify some of the existing custom properties that no longer apply for a custom 
report. Your custom report will not function properly if you do not make these modifications. 

You define custom properties between the <CustomProperties> and </CustomProperties> tags in the 
XML code of a report's .rdl file. You modify custom properties in a report on the Properties window of the 
report. 

1. In the Properties list, navigate to CustomProperties.  

2. Click the  ellipsis button to open the Custom Properties dialog box. 

The following sections of this guide identify the custom properties that you must delete or modify. 

ReportBO 
The ReportBO custom property is used for Vantagepoint standard reports. It is not valid for custom 
reports and must be deleted to prevent errors in Vantagepoint. 

Delete the following section of the XML code (this example uses the standard Project List report): 

<CustomProperty> 

<Name>ReportBO</Name> 

<Value>Deltek.Vision.ReportingProject.Server.ProjectList</Value> 

</CustomProperty> 

ResourceFileName 
When Vantagepoint loads the standard reports, the resource file is used to change report labels to the 
appropriate culture. Because the custom report that you are working with already has its labels converted 
to a specific culture, you must delete this ResourceFileName tag. 

Delete the following from the XML code (this example uses the standard Project List report): 

<CustomProperty> 

<Name>ResourceFileName</Name> 

<Value>Project List</Value> 

</CustomProperty> 

Attention: If you do not replace the standard report name with a custom report name, both the 
standard and custom report display in Vantagepoint Reporting with the same report name. 
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OptionForm 
The OptionForm custom property controls the display of the report Options dialog box in Vantagepoint 
Reporting for the custom report. If you want the report Options dialog box to display, you must replace the 
standard report's OptionForm value with the following Vantagepoint default report value: 

<Value>Deltek.Vision.Report.Client.VisionReportDialog</Value> 

Example: 

The original XML code in the standard Project List report: 

<CustomProperty> 

<Name>OptionForm</Name> 

<Value>Deltek.Vision.ReportingProject.Client.dlgRepOpt_ProjectList</Value> 

</CustomProperty> 

 

Modify the XML code as follows: 

<CustomProperty> 

<Name>OptionForm</Name> 

<Value>Deltek.Vision.Report.Client.VisionReportDialog</Value> 

</CustomProperty> 

 

GroupingType 
The GroupingType custom property controls whether or not the Sorting/Grouping tab displays on the 
report Options dialog box in Vantagepoint Reporting. For custom reports that you create from a standard 
Vantagepoint report, delete this custom property. 

Delete the following from the original XML code (this example uses the Project List report): 

<CustomProperty> 

<Name>GroupingType</Name> 

<Value>Project</Value> 

</CustomProperty> 

 

UseColumnSelection 
The UseColumnSelection custom property determines whether or not the Column tab displays on the 
report Options dialog box for a custom report in Vantagepoint Reporting. This tab enables you to select 

Note: For custom reports that are created with a standard Vantagepoint report, the report Options 
dialog box in Vantagepoint Reporting will display a Layout tab, and if you have added report 
parameters in Vantagepoint Custom Report Options Settings, a Custom Options tab. 

Note: To add a Sorting/Grouping tab to the report Options dialog box, you must modify special tags in 
SQL statements. Instruction on how to do this is beyond the scope of this document. 
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the columns for a report before you generate it. For custom reports that you create from a standard 
Vantagepoint report, change the UseColumnSelection value from Y to N. 

Example: 

The original XML code in the Project List report, where the value is set to Y: 

<CustomProperty> 

<Name>UseColumnSelection</Name> 

<Value>Y</Value> 

</CustomProperty> 

 

Modify the original XML code as follows: 

<CustomProperty> 

<Name>UseColumnSelection</Name> 

<Value>N</Value> 

</CustomProperty> 

 

Note: To add a Columns tab to the report Options dialog box, you must modify special tags in SQL 
statements. Instruction on how to do this is beyond the scope of this document. 
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Parameters in Custom Reports 
Parameters that you add to a report allow users to filter report content before they generate the report. 
For example, you could add a parameter to a report that enables you to enter a period start and end date 
so that you can include data for only certain periods on the report. 

 

To add the parameters to a report: 

1. On the Report Data Pane, right click Parameters » Add Parameter. 

 

2. Configure the parameter to match your needs. 

 

Recommendation: Use Visual Studio 2017 (SSDT) Report Designer or later versions when adding 
parameters for a custom report.  
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Parameters that you add to a custom report design in the .rdl file display as options on the Custom 
Options tab of the report's Options dialog box in Vantagepoint Reporting if you complete both of the 
following: 

▪ In the custom report .rdl file, you must add the prefix "cust" to the parameter name so that it 
will work with Vantagepoint. 

The following example shows a parameter with the name custStartPeriod within the XML 
code of an .rdl file in Visual Studio 2017 (SSDT) or later versions. 

 

▪ After you deploy and load the custom report into the Vantagepoint desktop application with 
the Vantagepoint Report Administration utility, you add the report parameters to the report in 
Settings » General » Custom Report Options, in the Vantagepoint desktop application. 

3. On the Navigation menu in the Vantagepoint desktop application, click Settings » General » 
Custom Report Options. 

4. On the Report Custom Options form, select the custom report from the Report Name drop-down 
list. 

On the Options grid toolbar, click  Insert to add a parameter to a blank row in the grid. 

5. In the Option Label field, enter the text that you want to display for the parameter on the Custom 
Options tab on the Report Options dialog box in Vantagepoint Reporting. 

6. In the Parameter Name field, enter the name of the parameter as it is entered in the custom 
report .rdl file but without the prefix "cust." 

7. In the Data Type field drop-down list, select the type, such as Character, CheckBox, Date, and 
so on, that matches the data that the parameter contains. 

8. Complete the remaining fields in the grid as appropriate for your parameter data type. 

9. When you finish, click  Save. 

To use the parameters before you generate a custom report: 

1. On the Navigation pane of the Vantagepoint browser application, select My Stuff > Reporting. 

2. On the Reporting form, select the Reports tab to display the list of reports.  

3. Select the custom report you want to use.  

4. On the custom report form, click the Custom Options tab to enter parameter options before you 
print or preview the report. 



Parameters in Custom Reports 

Custom Reports and Microsoft SQL Server® Reporting Services 20 

 

 



SkipProcessing Custom Property 

Custom Reports and Microsoft SQL Server® Reporting Services 21 

 

SkipProcessing Custom Property 
You can set the SkipProcessing table-level custom property to Y to have the Vantagepoint framework 
bypass the processing of a tablix data region of a report at runtime. The tablix data region will display 
what you see in the report design. This custom property applies to reports that are created with Visual 
Studio 2017 (SSDT) or later. It can be helpful for troubleshooting problems with previewing reports. 
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Custom Reports for User-Defined Hubs 

Report Type Custom Property 
For any custom report that you create for a user-defined hub in Vantagepoint Browser application, you 
must add a report type custom property to the report design. This identifies the user-defined hub 
submenu under the Vantagepoint Reporting menu in which you want the custom report to display. 

You must enter the value of the report type custom property as follows:  

<Value>UDIC_<specific user-defined hub ID>_<Report name></Value> 

The specific user-defined hub is based on the singular name that you entered for the user-defined hub 
when you set up the new hub in Settings » General » Screen Designer of the browser application. It is 
the singular name, without any spaces between words if you have multiple words in the label. To see the 
singular name for a user-defined hub in Settings » General » Screen Designer, select a user-defined 

hub and then click  Hub Preferences to display the Hub Preferences dialog box. The last portion of the 
database table name that is specified on this dialog box also displays the singular name (with no spaces). 

If you forget to add the report type custom property to a custom report, the report will not display in the 
Vantagepoint Reporting menu. 

Example 
You have a user-defined hub named Potential Hires. 

When you created the user-defined hub, you entered Potential Hire as singular label for the user-defined 
hub (the database table name is UDIC_PotentialHire). 

You created a custom report called Potential Hires for Sales (file name is PotentialHiresSales.rdl). 

You enter the following report type custom property for the report:  

<CustomProperty> 

<Name>ReportType</Name> 

<Value>UDIC_PotentialHire_Potential Hires-Sales</Value> 

</CustomProperty> 

After you upload this report into Vantagepoint using the Report Administration utility, the report displays in 
Reporting » Potential Hires. 

Upload Custom Reports for User-Defined Hubs 
When you upload a user-defined hub custom report into Vantagepoint using the Report Administration 
utility in the desktop application, you must set the Location field to User Defined Hub on the Custom 
Reports tab. 
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Custom Reports for the Vantagepoint Cloud 
Product 
The information in this section applies if you use the Vantagepoint cloud product with the Flex Cloud 
option or the Custom Report Add-On. 

 

Syntax for Naming Custom Report.rdl Files 
A different naming convention is required for the custom report .rdl file names for Vantagepoint production 
databases versus non-production databases. Non-production databases are sandbox or preview 
databases. 

Use the following syntax to name custom reports for Vantagepoint production and non-production 
databases. 

Reports for Production Databases 
For production reports, use the following syntax to name the report .rdl file, where XXXXX is your 5-digit 
Vantagepoint client ID: 

00000XXXXX_<ReportName>.rdl 

Reports for Non-Production Databases 
For non-production reports, use the following syntax to name the report .rdl file, where XXXXX is your 5-
digit Vantagepoint client ID and <databaseType> is the type of database: 

00000XXXXX_<ReportName>_<databaseType>.rdl 

Examples of file names for non-production (sandbox or preview) databases: 

▪ 00000XXXXX_<ReportName>_Sandbox.rdl 

▪ 00000XXXXX_<ReportName>_Preview.rdl 

If a custom report has sub-reports, you must upload each sub-report and name it using this syntax. 

 

When you are ready to upload a non-production report to your production database, remove the 
appended _<databaseType>. Its removal indicates that the custom report is a production report. 

Note: The Vantagepoint cloud product without the Flex Cloud option or the Custom Report Add-On 
does not include the SSRS Report Builder component. If you want to develop and deploy custom 
reports, you must do so locally using SQL Server Data Tools for Visual Studio. 

Warning: If you do not follow this naming convention, it is possible that a custom report that is 
updated and tested in another database may overwrite the current report in your production 
database. 



Custom Reports for the Vantagepoint Cloud Product 

Custom Reports and Microsoft SQL Server® Reporting Services 24 

 

Reporting Data Source 
To maintain optimal performance, the Deltek Cloud environments leverage a read-only replica as the data 
source for reporting. Any custom reports that write back to the database require that the following 
parameter be set in the .rdl file, so the report does not use the read-only replica as the data source. 

If any custom reports are writing back to the database, set a parameter in the .rdl file as follows: 

▪ The custom property is useTransactionDatabase. 

▪ Set the value to Y in the custom report .rdl file. 

Report Backups 
Be sure to retain backups of all your custom report .rdl files. 

Deltek is not responsible for retaining the .rdl files. Use the Download button on the Custom Reports tab 
in Utilities » Report Administration in the desktop application to download an .rdl file from the database. 
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Load Custom Reports into Vantagepoint 
Use the Report Administration utility in Utilities in the Vantagepoint desktop application to upload custom 
reports with .rdl file extensions to Vantagepoint. On the Custom Reports tab in Report Administration, you 
can upload custom reports from any location on a workstation into Vantagepoint. The custom reports are 
copied to your Vantagepoint report server, which are then added to a submenu under the Reporting menu 
on the Navigation pane in the Vantagepoint desktop application. 

The instructions in this section apply if you use the Vantagepoint on-premises product or the cloud 
product with the Flex Cloud option or the Custom Report Add-On. 

 

Upload Custom Reports from a Workstation to Vantagepoint 
If you have custom reports (.rdl files) saved on a workstation, follow these instructions to upload them to 
Vantagepoint.  

During the upload process:  

▪ The custom report files are copied to your: 

▪ Vantagepoint report server. These copies are accessed when users run the reports in 
Vantagepoint.  

▪ Vantagepoint database. These copies serve as backup copies that you can download if you need 
a report file and cannot find the original on your workstation.  

▪ The custom reports are added to the Reporting application under My Stuff on the Vantagepoint 
Navigation menu. 

If a report has multiple .rdl files (subreports), you must upload each subreport individually. 

Prerequisites:  

A system administrator must select the Allow RDL files to be uploaded in Report Administration 
check box on the General tab in the Weblink utility so the Custom Reports tab displays in the Report 
Administration utility. 

For Cloud Users: Deltek Cloud Operations provides you with RDL file access, therefore, you do not need 
to access RDL files via the Weblink utility. 

To upload a custom report from a workstation into Vantagepoint: 

1. On the Navigation menu in the Vantagepoint desktop application, click Utilities » Report 
Administration. 

Attention:  

▪ Vantagepoint does not support the deployment of reports to your Vantagepoint report server 
directly from within the Visual Studio 2017 (SSDT) Report Designer or later versions of the 
software. 

▪ For custom reports for the cloud product with the Flex Cloud option or the Custom Report 
Add-On: You must use the correct naming convention for the custom report .rdl file names for 
Vantagepoint production databases versus non-production databases. See the “Custom 
Reports for the Vantagepoint Cloud Product” section for more information. 
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2. On the Report Server form, click the Custom Reports tab. 

3. On the Load Custom Reports grid toolbar, click  Upload. 

4. On the Select Custom Report File to Upload dialog box, select a custom report .rdl file to upload 
and then click Open. 

The report file is added to a row in the Load Custom Reports grid. 

5. In the Load Custom Reports grid, click the Location field in the row for the custom report, and 
select the report type for the report, such as Projects, Accounting, Payroll. This groups the 
reports for easier selection in the Vantagepoint Reporting application.  

For custom reports for any user-defined hub, select User Defined Hub. See the previous 
“SkipProcessing Custom Property” section. 

6. Repeat steps 3–5 above to upload each subreport that a custom report has or upload other 
custom reports. If a custom report has subreports, you must add each subreport individually in 
the grid. 

7. Click Save. 

The custom reports are uploaded to your report and database servers and added to the 
Vantagepoint Reporting application. You will not see a status bar, and it may take a few minutes 
for the upload process to complete. 

8. When the reports finish uploading, click OK on the dialog box that tells you that the custom 
reports were uploaded. 

In the Load Custom Reports grid, the name of the report now displays in the Name field. 
Synchronized displays in the Status field, meaning that the report was successfully uploaded 
from the local machine to the Vantagepoint report and database servers. 

9. Log out and then log back in to Vantagepoint to see the custom reports added to the submenus 
under the Reporting menu in the desktop application. 

The custom reports are also displayed in the Report Name drop-down list in Settings » General 
» Custom Report Options, where you can add parameters to them. For parameter descriptions, 
see the “Parameters in Custom Reports” section. 

Status of a Custom Report 
The following are the possible status settings that a custom report can have in the Status field in the 
Load Custom Reports grid on the Custom Reports tab:  

▪ Synchronized Status: This status displays after you successfully upload a custom report using the 
Upload option on the Load Custom reports grid toolbar. It means that the custom report was 
uploaded successfully to your report server and the Vantagepoint database. 

▪ Missing in Report Server Status: This status means that the custom report was uploaded to the 
Vantagepoint database (as a backup copy), but it no longer exists on the report server. This could 
happen if you manually deleted the report on the report server or if you migrated to a new report 
server. Because there is a backup copy saved in the Vantagepoint database, you can click the 
Synchronize option on the Load Custom Reports grid menu to re-upload a copy of the backup report 
from the Vantagepoint database to the report server. 

▪ Missing in Database Status: This status means that a custom report is uploaded to the report 
server, but it does not have a backup copy saved in the Vantagepoint database. This could occur if 
you migrated to Vantagepoint from Vision and you previously uploaded custom reports to the report 
server in earlier Vision versions, before the custom report status feature was implemented. In this 
scenario, to upload a copy of the report to the Vantagepoint database and change the status of the 
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report to Synchronized: delete the report from your report server and upload it again using the 
Upload option on the Load Custom reports grid toolbar on the Custom Reports tab of the Report 
Administration utility in the Vantagepoint desktop application.  
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Apply Role Security to Custom Reports 
After a custom report is created and loaded into the Vantagepoint software, a Vantagepoint system 
administrator applies Vantagepoint role security to specify which security role(s) can access the custom 
report on the Vantagepoint Reporting menu. 

To add a custom report to the list of reports that a role can access: 

1. On the Navigation pane in the Vantagepoint browser application, select Settings » Security » 
Roles. 

2. In the Search field on the Roles form, enter the role for which you want to give access to the 
custom report. 

3. On the Access Rights tab, set the Functional Area option to Reports. 

4. Click + Add/Remove. 

5. On the Reports dialog box, select the type of report in the Report Type field, such as Accounts 
Receivable, Project, and so on, for the custom report to which you are granting access. 

6. In the Custom Type field, select Custom. 

The custom reports for the report type display in the Available Reports list. 

7. Click the appropriate custom report in the Available Reports list and then click Save to add it to 
the Reports for this Role grid in the Roles form. 

Changes to the role settings are saved automatically. After you make changes to role settings, have 
employees in any updated security role profiles log out and then log in again, to ensure that all 
appropriate access changes are applied. 
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Appendix A: Custom Reports and Migrating from 
Vision to Vantagepoint On-Premises 
This information applies if you are migrating from the Deltek Vision product to the Deltek Vantagepoint 
on-premises product and you have custom reports that were created with Microsoft SQL Server Reporting 
Services 2005 or 2008. This information also applies for upgrading Vision custom reports that you use to 
generate custom invoices in Vantagepoint. 

Vantagepoint Supports RDL 2016 Schema Only  
Custom reports that use RDL 2008 and RDL 2010 schema are not supported in Vantagepoint. You must 
upgrade these custom reports to change to the RDL 2016 Schema before you can use them in 
Vantagepoint. You must use Visual Studio 2017 (SSDT) or later, Report Builder 15.0, or the Vantagepoint 
Report Administration utility to upgrade the reports to the supported RDL 2016 Schema. See the sections 
below for instructions. 

Migrating from Vision 7.6 
If you are migrating to Vantagepoint on-premises from Vision 7.6: After you upgrade the reports, you must 
update report queries to revise any database table names that were changed in Vantagepoint. Changed 
database table names are then identified in the Vantagepoint Database Table Name Changes that Affect 
Custom Reports section below. 

If a Custom Report Does Not Work Properly 
Other Vantagepoint framework changes that are applied within the report business objects may affect 
your custom reports after you migrate to Vantagepoint, causing them to not work properly. If a custom 
report does not work properly after you upgrade and update any renamed database tables, Deltek 
recommends that you recreate the custom report using Vantagepoint and Visual Studio 2017 (SSDT) or 
later or Report Builder 15.0. 

Before You Create a Custom Report 
Before you recreate a custom report with Visual Studio 2017 (SSDT) or later, or with Report Builder 15.0, 
consider the following questions: 

▪ Do you still need the custom report? 

▪ Are there standard reports in Vantagepoint that provide the information that you need? 

▪ Is the custom report that you created based on a Vision standard report? If so, you can start with a 
standard Vantagepoint report and modify it in Visual Studio 2017 (SSDT) or later, or in Report Builder 
15.0 to recreate your custom report. 

 

Note: If you need additional assistance with custom reports, contact Deltek Global Services. 

For general information about Deltek University classes, product training, and other learning opportunities, see 
https://www.deltek.com/en/support/deltek-university. 

 

https://www.deltek.com/en/support/deltek-university
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Synchronize Custom Reports during Vantagepoint Migration 
As an option, you can synchronize custom reports between the transaction database and report server 
database with the SyncCustomReports switch. The SyncCustomReports switch is an additional setup 
switch, that you can configure when you install or migrate Vantagepoint. This is a command line version 
of the Synchronize button located on the Custom Reports tab in Utilities » Report Administration in 
the desktop application. 

To synchronize custom reports through the command line, refer to the procedure in the 
SyncCustomReports Switch section in the Vantagepoint Installation and Maintenance guide. 

Upgrade Custom Reports Using Visual Studio 2017 (SSDT) or 
later 
These instructions apply for custom reports that need to be upgraded to the RDL 2016 Schema. For 
these upgrade instructions, you start by opening or creating a report project (instead of opening the report 
RDL files). 

Custom Reports that Already Have a Report Project 
If a custom report already has a reporting project, use the following instructions to upgrade the report. 

To upgrade custom reports using Visual Studio 2017 (SSDT) or later versions to be compatible 
with Vantagepoint: 

1. Use Report Designer to open an existing custom report project. 

2. To enable Report Designer to create a backup of the report project before upgrading, click Yes in 
response to this prompt: 

 

The report project will be automatically upgraded. 

3. Open a custom report in Report Designer. 

4. The following applies if you are migrating to Vantagepoint from a Vision 7.6 version: For any 
Vision database tables included in the report that have new names in Vantagepoint, replace the 
old names with the new names. 

For a list of affected tables and instructions, see the Vantagepoint Database Table Name 
Changes that Affect Custom Reports section in Appendix A. 

5. Review the database changes for Vantagepoint and update your custom reports as needed. 



Appendix A: Custom Reports and Migrating from Vision to Vantagepoint On-Premises 

Custom Reports and Microsoft SQL Server® Reporting Services 31 

 

You can access the Vantagepoint Data Dictionary in the Vantagepoint online help by clicking the 
? help icon. In the help Table of Contents pane, scroll to the bottom of the contents and click 
Data Dictionary. The data dictionary is also available from the Deltek Support Center website. 

6. In the Report Property pane, enter a dummy value in InitialPageName property. 

7. Save the report. 

8. Remove the dummy value in the InitialPageName property and save the report again. 

9. Repeat step 4–9 for each custom report in the report project. 

10. Upload the custom reports to Vantagepoint using the Vantagepoint Report Administration utility, 
as described in the “Load Custom Reports into Vantagepoint” section. 

If a report does not run properly, you may need to recreate it with Visual Studio 2017 (SSDT) or a 
later version. 

Custom Reports that Do Not Have a Reporting Project 
If a custom report does not have a reporting project, you create a reporting project before you upgrade 
the report. 

To create a reporting project and upgrade Vision custom reports to be compatible with 
Vantagepoint using Visual Studio 2017 (SSDT) or a later version: 

1. Open Visual Studio 2017 (SSDT) or later. 

2. On the File menu, click New » Project. 

3. In the Project type pane of the New Project dialog box, select Reporting Services. 

4. In the Templates pane, select Report Server Project. 

https://deltek.custhelp.com/
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5. In the Name field, enter a name for the report project. 

Enter a name that is related to the type of report that you will add to this project. For example, for 
billing reports, you could name the project “Billing.” 

6. In the Location field, enter the location where the reports will be stored. 

Deltek recommends that you store reports in <your Vantagepoint installation 
path>\Reports\Custom. 

Example: c:\Program Files\Deltek\Vantagepoint\Reports\Custom 

7. On the New Project dialog box, click OK. 

8. Add the RDL file for existing custom reports to the report project: 

a. In the Solution Explorer pane, right-click the Reports folder, and click Add » Existing Item. 

b. On the Add Existing Item dialog box, navigate to an existing RDL file to add it to the report 
project. 

The schema of the RDL file is changed to RDL 2016. 

c. Modify the InitialPageName property of the report and add a dummy value. 

d. Save the report file. 

e. Remove the dummy value in InitialPageName property and save the report again. 

f. Repeat these steps to add RDL files for other custom reports to the report project. 
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9. Open a custom report in Report Designer. 

10. For any Vision database tables included in the report that have new names in Vantagepoint, 
replace the old names with the new names. 

This applies if you are migrating to Vantagepoint from Vision 7.6: For a list of affected tables and 
instructions, see the Vantagepoint Database Table Name Changes that Affect Custom Reports 
section in Appendix A. 

11. Save the report. 

12. Repeat steps 9 and 10 for each custom report. 

13. Upload the reports to Vantagepoint using the Vantagepoint Report Administration utility as 
described in the “Load Custom Reports into Vantagepoint” section. 

If a report does not run properly, you may need to recreate it with Visual Studio 2017 (SSDT) or a 
later version, such as Visual Studio 2019 (SSDT) or Visual Studio 2022 (SSDT). 

Upgrade Custom Reports Using Report Builder 15.0 
These instructions apply for custom reports that you created with older versions of Report Builder that 
don’t use the RDL 2016 Schema. With these instructions, you can update a report’s RDL file directly. 

To upgrade Vision custom reports to the RDL 2016 Schema using Report Builder 15.0: 

1. Use Report Builder 15.0 to open a custom report RDL file. 

2. Save the report file. 

Saving the file changes the schema to RDL 2016. 

3. In Report Builder 15.0, for any Vantagepoint database tables included in the report that have new 
names in Vantagepoint, replace the old names with the new names. 

This applies if you are migrating to Vantagepoint from Vision 7.6: For a list of affected tables and 
instructions, see the Vantagepoint Database Table Name Changes that Affect Custom Reports 
section in Appendix A. 

4. Save the report. 

5. Upload the report to Vantagepoint using the Vantagepoint Report Administration utility as 
described in “Load Custom Reports into Vantagepoint” section. 

If a report does not run properly, you may need to recreate it with Report Builder 15.0. 

Upgrade Custom Reports Saved in the Vantagepoint 
Database Using Report Administrator 
Use these instructions to upgrade custom reports in your database from the RDL 2010 Schema to the 
current RDL 2016 Schema that Vantagepoint supports.  

 

This upgrade process opens all your custom reports, and for each report it upgrades the report schema, 
resaves the report in the Vantagepoint database, and uploads the report to the Vantagepoint report 
server. 

Note: These instructions apply only if the custom reports in your database have the RDL 2010 
Schema. 
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To upgrade custom reports that are saved in your Vantagepoint database with the RDL 2010 
Schema to the RDL 2016 Schema: 

1. On the Navigation menu in the Vantagepoint desktop application, select Utilities » Report 
Administration. 

2. On the Report Server form, click the Custom Reports tab. 

 

3. On the Custom Reports tab, click the Upgrade option on the toolbar of the Load Custom Reports 
grid. 

▪ The Upgrade option displays on the grid toolbar only if you have a saved custom report in 
the Vision database. 

▪ If all your existing custom reports already use the latest RDL 2016 Schema, you receive the 
following message: "All existing custom reports stored in your database are already using the 
latest schema." 

4. Click Yes on the dialog box that says: "This will upgrade all existing custom reports currently 
stored in your database to the latest schema. Would you like to continue?" 

▪ The upgrade starts. 

▪ During the upgrade, Vision backs up the custom reports that are saved in the Vision 
application server’s Report\Backup folder. 

▪ When the upgrade finishes, you receive the following message: "All custom reports have 
been successfully upgraded to the latest schema." 

5. After the upgrade finishes, check the RDLProcessing.log log file that is saved in the Vision 
application server's Report\Backup\<database name> folder.  

The file contains the status for each processed RDL file and will identify any errors. 
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Upgrade Custom Reports Saved Locally Using Report 
Administrator 
Use these instructions to upgrade Vantagepoint custom reports that are saved on a local machine to the 
RDL 2016 Schema that Vantagepoint supports. These instructions apply for custom reports that have not 
been saved in the Vision database. This process is useful if you are currently working on or developing 
custom reports that are still in the old schema and the reports have not been uploaded to the 
Vantagepoint database yet. 

 

To upgrade custom reports on a local machine to the RDL 2016 Schema: 

1. On the Navigation menu in the Vantagepoint desktop application, select Utilities » Report 
Administration. 

2. On the Report Server form, click the Custom Reports tab. 

 

3. In the Apply Schema Update to Custom Report File section, click the Select Folder button. 

4. In the Browse for Folder dialog box, scroll to and select the folder in which the custom reports are 
located, and click OK to close the dialog box. 

Note: Steps 4 and 5 apply to on-premises users only. For Vantagepoint Cloud users, please contact 
Deltek Support to get a copy of the backup or log files. 

Note: These instructions apply only if the custom reports on a local machine have the RDL 2010 
Schema.  
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5. Click the Apply button to update the reports. 

6. Review the RDLProccessing.log file that is saved in the custom reports folder location. 

The file contains the status for each processed RDL file and identifies any errors. 

Vantagepoint Database Table Name Changes that Affect 
Custom Reports 
Vision 7.6 database tables used in reports that had a name change in Vantagepoint are listed below. If 
you are migrating to Vantagepoint on-premises from a Vision version that is earlier than 7.6, then after 
you upgrade your custom reports, you must replace the old table names with the new names in report 
queries that include the affected tables.  

If you do not update the table names, you will receive errors when you run the reports. 

Database table name updates can also occur as newer versions of Vantagepoint are released. Refer to 
the maintenance release notes and the data dictionary as new versions are released. 

Vantagepoint Table Name Changes that Affect Custom Reports 

Table Name in Vision 7.6 Table Name in Vantagepoint  

Opportunity PR 

To change a table name in either Report Designer or Report Builder: 

1. Open the report in either of the reporting tools. 

2. On the Report Data pane, expand the Datasets folder. 

3. Double-click ReportDataset. 

 

4. In the Query text box in the Dataset Properties window, find mention of the old table name, and 
replace it with the new table name.  

 

Note: To quickly determine whether the query contains an affected table, you can copy the 
contents from the Query text box into a word processor. Then use Find in the word processor 
to search for the table name. 
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5. Click OK. 

If you receive the following message, click OK. You do not need to refresh the field list; you are 
updating the table name only. 
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Custom Invoices Created with 2010 RDL Schema 
Vantagepoint custom invoices are basically reports. Follow the instructions in the previous sections for 
upgrading custom reports that have 2010 RDL Schema. When you upgrade them, the schema of the 
report will be upgraded to the RDL 2016 Schema. 

After you upgrade custom reports to the RDL 2016 Schema, review your custom invoice reports and their 
custom templates to make sure everything is working properly. 
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Appendix B: If You Need Assistance 
If you need assistance installing, implementing, or using Vantagepoint, Deltek makes a wealth of 
information and expertise readily available to you. 

Customer Services 
For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems, 
listening to their needs, and getting to know their individual business environments. A full range of 
customer services has grown out of this close contact, including the following: 

▪ Extensive self-support options through the Deltek Support Center 

▪ Phone and email support from Customer Success analysts 

▪ Technical services 

▪ Consulting services 

▪ Custom programming 

▪ Classroom, on-site, and Web-based training 

 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 

▪ Search for product documentation, such as release notes, install guides, technical information, online 
help topics, and white papers 

▪ Ask questions, exchange ideas, and share knowledge with other Deltek customers through the Deltek 
Support Center Community 

▪ Access Cloud-specific documents and forums 

▪ Download the latest versions of your Deltek products 

▪ Search Deltek’s knowledge base 

▪ Submit a support case and check on its progress 

▪ Transfer requested files to a Customer Success analyst 

▪ Subscribe to Deltek communications about your products and services 

▪ Receive alerts of new Deltek releases and hot fixes 

▪ Initiate a Chat to submit a question to a Customer Success analyst online 

 

Attention: Find out more about these and other services from the Deltek Support Center. 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 

https://deltek.custhelp.com/
https://deltek.custhelp.com/
https://deltek.custhelp.com/
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Access Deltek Support Center 
To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 

 

 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/


 

 

About Deltek 
Better software means better projects. Deltek delivers software and information solutions that enable 
superior levels of project intelligence, management and collaboration. Our industry-focused expertise 
makes your projects successful and helps you achieve performance that maximizes productivity and 
revenue. www.deltek.com 

http://www.deltek.com/

