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While Deltek has attempted to verify that the information in this document is accurate and 
complete, some typographical or technical errors may exist. The recipient of this document is 
solely responsible for all decisions relating to or use of the information provided herein. 

The information contained in this publication is effective as of the publication date below and is 
subject to change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are 
reserved. No part of this document may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, or translated into another language, without the prior written 
consent of Deltek, Inc. 

This edition published July 2017. 

© Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and 
proprietary information of Deltek, Inc. and its licensors. The Deltek software, and all related 
documentation, is provided for use only in accordance with the terms of the license agreement. 
Unauthorized reproduction or distribution of the program or any portion thereof could result in 
severe civil or criminal penalties. 

All trademarks are the property of their respective owners.  
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Overview 

Welcome to wInsight Analytics Administrator 8.1.1. This installation guide will help you 
successfully install this application on your system and make it work efficiently according to your 
organization’s business structure. 
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Downloading Deltek Products using Deltek 
Software Manager 

You can use Deltek Software Manager (DSM) to download complete Deltek products, hot fixes, 
and sub-releases. You can access DSM directly or through the Deltek Customer Care Connect 
site. You can also use DSM Lite to download Deltek products. 

When you access DSM directly, you will be prompted to log on before you can access the 
application. If you access DSM from within the Deltek Customer Care site, you do not have to log 
on since you are already logged into the Customer Care site. 

Accessing DSM Directly 

To access Deltek Software Manager directly, complete the following steps: 

1. Launch Deltek Software Manager by taking one of the following actions: 

 Click here.  

 On your desktop, click Start » Programs » Deltek Software Manager. 

2. In the Deltek Software Manager logon dialog box, enter your Deltek Customer Care User 
ID and Password, and click Logon. 

3. To select the folder where you want to download Deltek products, click Settings above 
the right pane of Deltek Software Manager. 

 

When you log on for the first time, Deltek Software Manager asks you to select a 
default folder where Deltek products are to be downloaded.  

4. Use the Settings dialog box to specify the folder where you want to download Deltek 
products, and click OK.  

 

You can change this folder anytime in the Settings dialog box.  

5. In the left pane of Deltek Software Manager, expand the Deltek product that you want to 
download, if it is not already expanded.  

 

If you clicked the link in step 1 to access DSM, the application automatically selects 
wInsight Analytics Administrator for you. 

6. Select the product type that you want to download. Your options are Complete, HotFix, 
and Sub-Release. 

7. In the table, select the check box that corresponds to the Deltek product that you want to 
download. The right pane displays a message stating that the product has been added to 
the download queue. 

 

To view the items in the download queue, click View Download Queue at the bottom 

of the left pane.  

https://dsm.deltek.com/DeltekSoftwareManager/DeltekSoftwareManager.application
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8. Click Download at the bottom of the left pane. Deltek Software Manager downloads the 
product to the folder that you selected.  

Accessing DSM from within the Customer Care Connect Site 

To access Deltek Software Manager from within the Customer Care Connect site, complete 
the following steps: 

1. In your Web browser, go to http://support.deltek.com.  

2. Enter your Customer Care Connect Username and Password, and click Log In. 

3. When the Customer Care Connect site displays, click the Product Downloads tab. 

You are automatically logged into Deltek Software Manager. 

4. To select the folder where you want to download Deltek products, click Settings above 
the right pane of Deltek Software Manager. 

 

When you log on for the first time, Deltek Software Manager asks you to select a 
default folder where Deltek products are to be downloaded.  

5. Use the Settings dialog box to specify the folder where you want to download Deltek 
products, and click OK.  

 

You can change this folder anytime in the Settings dialog box.  

6. In the left pane of Deltek Software Manager, expand the Deltek product that you want to 
download, if it is not already expanded.  

7. Select the product type that you want to download. Your options are Complete, HotFix, 
and Sub-Release. 

8. In the table, select the check box that corresponds to the Deltek product that you want to 
download. The right pane displays a message stating that the product has been added to 
the download queue. 

 

To view the items in the download queue, click View Download Queue at the bottom 

of the left pane.  

9. Click Download at the bottom of the left pane. Deltek Software Manager downloads the 
product to the folder that you selected.  

Accessing DSM Lite 

To access Deltek Software Manager Lite, complete the following steps: 

1. In your Web browser, go to https://dsm.deltek.com/DeltekSoftwareManagerLite.  

2. Enter your Customer Care Connect Username and Password, and click Logon. 

3. When the Deltek Software Manager Lite site displays, select a product from the drop-
down list. 

4. Click the product type that you want to download.  

http://support.deltek.com/
https://dsm.deltek.com/DeltekSoftwareManagerLite
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The download behavior and download folder may differ depending on the browser and 

browser settings that you are using. 

DSM Documentation and Troubleshooting 

 To view the online help for Deltek Software Manager, click here. 

 To view a tutorial on how to use Deltek Software Manager, click here.  

 To view more information on troubleshooting Deltek Software Manager, click here. 

 

The above troubleshooting link will only work if you are logged into Deltek Customer 
Care Connect. 

https://dsm.deltek.com/DeltekSoftwareManager/Help/
https://dsm.deltek.com/DeltekSoftwareManager/Tutorial/PubData/Engine/Default.htm?https%3A%2F%2Fdsm.deltek.com%2FDeltekSoftwareManager%2FTutorial%2FPubData%2F
https://deltek.custhelp.com/app/answers/detail/a_id/52469
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Before You Begin Deployment 

Before you begin deployment, it is important to understand the following: 

 Logical Tiers 

 Installation/Deployment Model 

 Hardware and Software Requirements 

Logical Tiers Overview 

The wInsight Analytics product suite uses a multitier (n-tier) architecture. Various parts of a 
wInsight Analytics product are distributed to logical tiers for performance and scalability. The 
logical tiers are as follows: 

 Client/Application Tier — This tier performs wInsight Analytic’s functional process logic 
and provides the user interface layer.  This tier can be a workstation or a Citrix/Terminal 
Server. 

 Database Tier —This tier consists of database servers where the wInsight Analytics data 
is stored and retrieved. 

 

If the wInsight Analytics Module is deployed in a multi-tier mode, the wInsight Analytics 
Administrator and wInsight Analytics Desktop uses a client-server deployment model. 

Installation/Deployment Model 

Stand-Alone Deployment 

Deltek wInsight Analytics Administrator and wInsight Analytics Desktop have a stand-alone 
deployment model. Users who previously operated the legacy wInsight Desktop or Professional 
interface installed on their workstations can continue to use the decentralized deployment model 
with wInsight Analytics. 

Client/Server Deployment  

In the client/server model, you install the client/application tier on workstations that directly 
connect to a database server. However, when a client workstation that is connected to the 
database goes through a WAN or VPN, this type of setup often yields poor performance.  This 
can be deployed in a Citrix/Terminal Server environment to improve performance over a WAN or 
VPN. 
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In addition, the application can be installed such that the application files reside on a network 
share on a machine and a shortcut is created on each workstation. 
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System Requirements 

Your organization has made a substantial commitment to ensure it has a fully integrated earned 
value management (EVM) solution. To support that commitment, Deltek recommends that you 
carefully consider the hardware requirements necessary to run a wInsight Analytics product 
properly. 

Platform Virtualization  

Platform Virtualization is a new technology that allows multiple operating systems and 
platforms to run simultaneously as separate virtual machines on a single set of server hardware.  

Deltek recognizes the growing use of virtual environments by our customers. Virtual environment 
software, such as VMware®, resides in the hardware layer underneath the operating system and 
is used by customers to partition a single server into a multiple server/multiple operating system 
environment. Deltek’s product development makes limited use of virtual environments at this 
time.  

 

For more information, see Virtual Environments Statement on the Deltek Support Center. 

Display Settings 

The recommended display resolution is 1440 x 900 or higher. 

Hardware Sizing Considerations 

There are several factors that go into sizing an appropriate server infrastructure. The number of 
concurrent users accessing the system at any given time, the amount of data being analyzed, 
and growth expectations all have an impact on the initial sizing plans. The hardware profiles 
provided in the previous sections are intended as a starting point for deployment. It is expected 
that our clients will use the product in many different ways, such as planning for future release, 
and client customizations. Further in-depth discussion of the business needs of the solution 
during implementations of application will provide final guidance on hardware requirements. 

The number of elements, records, contracts, and accounting periods analyzed all have an impact 
on the amount of RAM you will need on the server. This data, along with other information, is 
loaded into RAM on the server, which allows for much more rapid analytics and display results. If 
the server does not have enough RAM to store all of the required data, then it will get loaded into 
virtual memory, which has a significantly slower response capability than RAM.  All data used by 
wInsight Analytics for aggregation and display is stored in system memory, so hard drive storage 
does not have a significant impact on server sizing. 

Memory Requirements for a Typical/Average Use 

Below are details on the memory footprint of the product. This can be helpful when sizing a client 
tier that runs in a virtual environment, Citrix®, or Terminal Server. 

Tier Memory* 

Client Tier 2 GB (assuming the wInsight Analytics Module is being run as a 
server application) 

https://deltek.custhelp.com/app/utils/login_form/redirect/home
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Tier Memory* 

Database Tier Database instance memory should be 10%–15% of the database 
size. For example, if database size is expected to be 500 GB, 
then allocate 50 GB–75 GB memory. 

* Per concurrent client instance and in addition to any memory needed for the operating system 
and other applications that may run in parallel with this product. 

Definition of Typical/Average Use 

Sample Details for a Typical Small/Medium Data Sizing: 

 Number of Contracts: 50 

 Number of Element Records: 50,000   

 Number of Earned Value Records: 1,200,000 

 Number of Past and Future Period Records: 75,000,000 

Hardware Requirements 

 

Specific server hardware configurations may have an impact on your overall Deltek product 
licensing requirements. It is recommended you confirm with a Deltek Technical Sales Engineer 
if the server hardware you plan to deploy is in line with your Deltek license agreement and how 
overall server infrastructure expansion in the future may affect your Deltek licensing. 

Stand-Alone Deployment 

The following table lists the recommended minimum hardware and software requirements for a 
deployment in a stand-alone environment. 

Tier Hardware Required Determining Factors 

Client Tier  Intel Core 2.0 Duo or higher 

 4 GB RAM (Depending on data volumes, 
more may be required.) 

 80 GB Hard Drive 

Database Size 

Database Growth 
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Software Requirements 

 

Supported versions are the currently actively tested versions of technologies used to deploy 
wInsight Analytics. Except for the Deltek Integrated Products, these technologies are not 
directly supported by Deltek. Changes to these technologies occur at the discretion of the 
individual technology vendors.  

Compatible versions are the recent previously supported and tested technologies used to 
deploy wInsight Analytics. These are not actively being tested but are believed to be 
compatible with wInsight Analytics. Deltek does not recommend these technologies for new 
deployments but will make its best effort to answer questions concerning these technologies. 
These technologies may not be available for troubleshooting at Deltek. 

For a complete list of the recommended minimum software requirements, see the Deltek 
Product Support Compatibility Matrix document that you can download from the Deltek Support 
Center. 

Stand-Alone and Server Installations 

Supported and Compatible Deployment Technology 

Operating System  Microsoft Windows 7 

 Microsoft Windows 8.1 

 Microsoft Windows 10 

 Microsoft  Windows Server 2008 R2 (x64) (Compatible)   

 Microsoft  Windows Server 2012 

 Microsoft  Windows Server 2012 R2 

Database  Microsoft SQL Server 2008 R2 (Compatible)   

 Microsoft SQL Server 2012 

 Microsoft SQL Server 2014 

 Microsoft SQL Server 2016 

 Microsoft SQL Server Express 

 Microsoft Access 2007 

 Microsoft Access 2010 

 Microsoft Access 2013 

 Microsoft Access 2016 

 Oracle 11.2 

 Oracle 12.1 

 Oracle is also supported in Linux, UNIX, and Exadata 

Database Drivers NOTE: wInsight Analytics Administrator/wInsgight Analytics 
Desktoprequires 32-bit database drivers. 

 Oracle Provider for OLE DB 

 Microsoft SQL Server Native Client 

 Microsoft OLE DB Provider for SQL Server 

https://deltek.custhelp.com/app/utils/login_form/redirect/home
https://deltek.custhelp.com/app/utils/login_form/redirect/home
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Supported and Compatible Deployment Technology 

 Microsoft OLE DB Provider for Jet 

 Microsoft ACE OLEDB 12 

 Microsoft ACE OLEDB 15 

Microsoft Office   Microsoft Excel 2010 

 Microsoft Excel 2013 

 Microsoft Excel 2016 

Embedded 
Technologies 

 Visual C++ 2005 SP1 Redistributable Package (x86) 

 MSXML 6.0 Service Pack 2 (Microsoft XML Core Services) 

Deltek Integrated 
Product 

Deltek Acumen 

 8.0 

Deltek Cobra 

 5.1.3 (Compatible) 

 5.1.4 

 8 

 8.1 

 8.1.1 

Deltek MPM  

 3.4.1 

 3.5 
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Getting Started 

Before you begin to install wInsight Analytics Administrator, you should understand the 
hardware/software requirements. There are also several things you should consider to optimize 
the use of the software. 

Questions to Ask Before You Begin 

You should answer the following questions before installing wInsight Analytics Administrator: 

 Are you upgrading from an earlier version of wInsight Analytics Administrator? For more 
information, see the Upgrade from an Earlier Version of wInsight Analytics Administrator 
section. 

 Are you performing a fresh install of the wInsight Analytics Administrator on a local 
machine? For more information see the Install wInsight Analytics Administrator section. 

 Do your client workstations and servers meet hardware and software requirements? For 
more information, see the System Requirements section. 

 Are you using Microsoft Access, Oracle, or Microsoft SQL as your database platform? 
For more information, see the Set Up and Create a New Database section. 

Installation Steps 

Follow this sequence to successfully install wInsight Analytics Administrator: 

Step Description Refer to These Sections 

1 Make sure that your system meets 
the hardware requirements to install 
the required software. 

System Requirements 

2 Download the wInsight Analytics 
Administrator installer from the 
Deltek support site. 

Downloading Deltek Products using 
Deltek Software Manager 

3 If you are upgrading from an earlier 
version of wInsight Analytics 
Administrator, make sure that you 
have recently backed up your 
wInsight Analytics data. 

Upgrade from an Earlier Version of 
wInsight Analytics Administrator 

Install wInsight Analytics 
Administrator. 

Install wInsight Analytics 
Administrator 

or 

Install wInsight Analytics 
Administrator on a Network Share 
Setup  

4 Run the batch file or scripts to create 
or upgrade database tables. 

Create a Database 

or 
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Step Description Refer to These Sections 

Convert wInsight Analytics 
Administrator 8.1 or Earlier Database 
to 8.1.1 

5 Run the data tool to set up a 
connection to the database used to 
store wInsight data. 

Appendix A: Data Tool 

6 Run the EPM Security Administrator 
to define the security rights for 
wInsight Analytics users. 

Appendix B: EPM Security 
Administrator 
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Upgrade from an Earlier Version of wInsight 
Analytics Administrator 

Installing wInsight Analytics Administrator 8.1.1 automatically removes your wInsight Analytics 
Administrator 8.1 or earlier installation. You can also uninstall the earlier version by using either of 
the following methods: 

 Use Windows’ Programs and Features to remove the wInsight Analytics Administrator 8.1 
or earlier. 

 Run the installer of the earlier version, select the Remove option on the Program 
Maintenance page, and click the Next button to uninstall the program. 

If you are upgrading from an earlier version of wInsight Analytics Administrator, make sure that 
you have recently backed up your wInsight Analytics data, especially if it is stored in the Sample 
data source that uses sample.mdb, which is located in C:\Program Files (x86)\Deltek\wInsight 
Analytics\data. This database is installed by default and might overwrite the existing one, 
thereby deleting your data. 

 

If you are using an Access database and upgrading from 6.5.1 thru 8.0.2 to 8.1.1, the process 
involves creating wInsight backup of contracts and then restoring the .WSA file to an 8.1.1 
database. For more information, see the Back Up 8.1 or Earlier and Restore a .WSA File to an 
8.1.1 Database sections in this document.  

If you are using an Access Database and upgrading from 8.1 to 8.1.1, the process involves 
running the upgrade script against the created database. For more information, see the 
Convert an MS Access Database section in this document. 

If you are using an SQL or Oracle database and upgrading from 8.1 or earlier (from 6.5.1 thru 
8.0.2) to 8.1.1, make sure you run the corresponding upgrade scripts. For more information, 
see the Convert an MS SQL Server Database and Convert an Oracle Database sections in this 
document. 

After uninstalling the earlier version, run the wInsight Analytics Administrator 8.1.1 installer to 
install wInsight Analytics Administrator 8.1.1. 
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Back Up 8.1 or Earlier  

Though an 8.1 or earlier (from 6.5.1 thru 8.0.2) database can be upgraded to 8.1.1, you may want 
to back up your contracts from your 8.1 or earlier database and restore them into an 8.1.1 
database. 

 

For 6.5.1 thru 8.0.2, you can use the backup tool (BackupMDB.exe) after installing 8.1.1. For 

more information, see the Create wInsight Backup of Contracts Automatically in an Access 
Database section in this document.  

Back Up Contracts Manually 

To back up your contracts manually, complete the following steps: 

1. Start wInsight Analytics Administrator 8.1 or earlier. 

2. Click File » Login and select the database with the 8.1 or earlier contract(s) to back up. 

3. Click Utilities » Backup to back up your contract(s). Note the location where the 8.1 or 
earlier archive file (.WSA) was saved. 

4. Exit wInsight Analytics Administrator 8.1 or earlier. 
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Install wInsight Analytics Administrator 

Use the following procedures to install wInsight Analytics Administrator. First-time installation 
options are different from re-installation options. 

 

If you are re-installing wInsight Analytics Administrator, see the Modify, Repair, or Uninstall 
wInsight Analytics Administrator section in this document. 

To install wInsight Analytics Administrator, complete the following steps: 

1. Download the wInsight Analytics Administrator software using the instructions in the 
Downloading Deltek Products using Deltek Software Manager section in this document. 

2. Go to the location where you saved the wInsight Analytics Administrator installer. 

3. Double-click DeltekwInsightAnalyticsAdministrator811.exe to launch the Deltek 
wInsight Analytics Administrator 8.1.1 InstallShield Wizard. 

4. On the Welcome page, click the Next button. 

5. On the License Agreement page, select the I accept the terms in the license 
agreement option and click the Next button. 

6. On the Setup Type page, select one of the following options and click the Next button. 

 Complete — Installs all wInsight Analytics Administrator components. wInsight 
Analytics Administrator will be installed in the C:\Program Files 
(x86)\Deltek\wInsight Analytics\ location by default. Proceed to step 8. 

 Custom — Installs only certain wInsight Analytics Administrator components. This 
option also allows you to change the location where wInsight Analytics Administrator 
is to be installed. If you selected the Custom option, the Custom Setup page 
displays. Proceed to step 7. 

7. On the Custom Setup page, take any of the following actions and click the Next button: 

 Click the Change button if you want to change the directory where wInsight Analytics 
Administrator is to be installed. The default location is is C:\Program Files 
(x86)\Deltek\wInsight Analytics\. 

 Click one of the  icons to change the features installed for any of the following 
components: 

 Program Files — Installs the wInsight Analytics Administrator program files in 
the destination directory and updates essential Windows system files. The 
default location is C:\Program Files (x86)\Deltek\wInsight Analytics. 

 Help Files — Installs online help for wInsight Analytics Administrator. The default 
location is C:\Program Files (x86)\Deltek\wInsight Analytics\help\. 

 Sample Database — Installs the sample MOH-2 contract, contained in the 
sample.mdb database file. The default location is C:\Program Files 
(x86)\Deltek\wInsight Analytics\data. 

 Database Files — Installs database scripts and template files. The default 
location is C:\Program Files (x86)\Deltek\wInsight Analytics. 

 Utility Files — Installs the wInsight Analytics Administrator XML Validator, 
(which is used to test if the XML or document you want to load is valid), 
BackupMDB tool (which is used to create a wInsight backup of all contracts in an 
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Access database formatted for wInsight versions 6.5.1 to 8.0.1), and other utility 
files. The default location is C:\Program Files (x86)\Deltek\wInsight 
Analytics\util. 

 System32Files — Installs the Windows library files. The default location is 
C:\Program Files (x86)\Deltek\wInsight Analytics. 

8. On the Ready to Install the Program page, click the Install button to start the installation 
process. The Installing Deltek wInsight Analytics Administrator page displays the 
installation progress. 

9. On the InstallShield Wizard Completed page, click the Finish button to exit the 
InstallShield Wizard. You can select the check box to launch the application after 
installation is completed.  

Back Up Copies of Existing MDB Files 

This only applies to the 6.5.1 thru 8.0.2 versions of the Access database. 

When performing an upgrade installation, any .MDB files found where 8.1.1 is being installed will 
be moved to the backup folder (which default location is C:\Program Files (x86)\Deltek\wInsight 
Analytics\Backup). 

 

For information on backing up all contracts in an Access database from the 6.5.1 thru 8.0.2 
versions, see the Create wInsight Backup of Contracts Automatically in an Access Database 
section in this document. 
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Install wInsight Analytics Administrator on a 
Network Share Setup 

You can install wInsight Analytics Administrator 8.1.1 files (.exe, .dll, or .htm) and other related 
files on a server and then run from a client PC. The software executes on the client PCs even 
though all wInsight Analytics Administrator files are stored on the server. 

Certain files, however, must reside on the client PC (for example, MDAC 2.5), and certain .DLL 
files must be registered. You should create a shortcut on the client PC to launch wInsight 
Analytics Administrator. 

Use the following procedures to set up wInsight Analytics Administrator to run from a server. This 
setup requires you to install wInsight Analytics Administrator only on the server and not on the 
client PCs. 

To perform a manual installation, complete the following steps: 

1. Install wInsight Analytics Administrator on the server (see Install wInsight Analytics 
Administrator). 

 

Make sure MDAC 2.5 or higher is installed on each client PC. Microsoft Windows 
Server 2003, 2008, and 2008 R2 have MDAC already installed and Microsoft Office 
2000 installs MDAC. If the client PCs have either of these two products, you do not 
need to install MDAC on each client. 

2. From the client PC, locate and run the DoRegAll.bat file in the C:\Program Files 
(x86)\Deltek\wInsight Analytics\ folder on the server. To do this, complete the following 
steps: 

a. Open an Administrative Command Prompt. The location of the command prompt 
varies, depending on the operating system. In Windows 7, for example, click the 
Start button then click All Programs » Accessories. Right-click Command 
Prompt and select Run as Administrator. 

 

b. Use the “net use” command to map the drive (for example, Z:\, but it could be 
any drive available for mapping). This action ensures that you (as an Admin user) 
can see the drive because you are the one mapping it. 
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c. Press Enter. 

 

d. Go to the mapped drive, and run DoRegAll.bat. 

 

e. Press Enter. 



Install wInsight Analytics Administrator on a Network Share Setup 

 

Installation Guide 19 

 

 

f. Click OK until all the .DLL files included in the batch are registered. 

i. If UAC is enabled, go to step #3. 

ii. If UAC is not enabled, skip step #3 and continue with step #4. 

3. If UAC is enabled, on the client PC, create a mapped drive to the wInsight Analytics 8.1.1 
folder (C:\Program Files (x86)\Deltek\wInsight Analytics\) on the server. 

To map a network drive, complete the following steps: 

a. Open My Computer. 

b. On the Tools menu, click Map Network Drive. The Map Network Drive page 
displays. 

c. In the Drive drop-down list, type or select the drive letter to map the shared 
resource (this should be the same drive you selected in Net Use command from 
step #2). 

d. In the Folder drop-down list, type the server name and the share name, for 
example, \\server name\share name. You can also click the Browse button to 
locate the resource. 

e. Click the Finish button. 

After mapping the network drive, continue with step #4. 

4. From the client PC, locate the Wsmde.exe file in the C:\Program Files 
(x86)\Deltek\wInsight Analytics folder on the server, using the mapped drive, and 
create a shortcut on the client PC. 
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Modify, Repair, or Uninstall wInsight Analytics 
Administrator 

wInsight Analytics Administrator provides facilities for changing which features are installed, 
repairing installation errors, and removing wInsight Analytics Administrator. Use the procedure in 
this section to change your wInsight Analytics Administrator installation structure. 

To modify, repair, or remove your wInsight Analytics Administrator installation, complete 
the following steps: 

1. Go to the location where you saved the wInsight Analytics Administrator installer. 

2. Double-click DeltekwInsightAnalyticsAdministrator811.exe to launch the Deltek 
wInsight Analytics Administrator 8.1.1 InstallShield Wizard. 

3. On the Welcome page, click the Next button. 

4. On the Program Maintenance page, select one of the following options, depending on the 
task that you want to do: 

 Modify — Select this option to change your wInsight installation structure. Selecting 
this option displays the Custom Setup page, except that no Change button is 
available. To change the directory where wInsight Analytics Administrator is installed, 
you must first uninstall wInsight Analytics Administrator, then re-install in a different 
directory (see Install wInsight Analytics Administrator). 

 Repair — Select this option to repair installation errors by re-installing the wInsight 
Analytics Administrator components. Selecting this option displays the Ready to 
Repair the Program page. Click Next to continue repairing wInsight Analytics 
Administrator. 

 Remove — Select this option to uninstall wInsight Analytics Administrator from your 
machine. Selecting this option displays the Remove the Program page. Click Next to 
continue uninstalling wInsight Analytics Administrator. 

5. Click Install (for Modify or Repair) or Remove. The installation or uninstallation progress 
displays. 

6. When the process is completed, click the Finish button to exit the InstallShield Wizard. 
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Installation Notes 

This section discusses additional details for installing wInsight Analytics Administrator on a server 
on a Local Area Network (LAN): 

 The Microsoft Windows Installer can perform an administrative installation of an 
application or product to a network for use by a workgroup. Administrators can run an 
administrative installation from the command line by using the “/a” command line option. 
Then, users can install the product from the network to run the application. Users can 
choose to "run-from-source" and the installer will use most of the product's files directly 
from the network. 

 Regardless of where the application files are installed, the wInsight Analytics database 
can be located on a file server accessing a shared MS Access .MDB file or on a 
database server running Oracle or SQL Server. An MS Access .MDB file can even be 
accessed if it resides on the client PC. 

 Users do not need any write privileges on the server, unless they need to create a data 
source. In that case, they need to be able to write to the datasources.dat file stored in 
C:\Program Files (x86)\Deltek\wInsight Analytics by default. However, users need 
Read, Write, Create, and Delete privileges to the directory storing the wInsight MS 
Access (.MDB) database. 

 Users can share the data sources used to access wInsight Analytics data by specifying 
the location of the datasources.dat file (which contains the connection details) in 
config.dat. If you use other Deltek products (such as Cobra and Open Plan) and store all 
of your data in a single database, you can create a single list of database connections in 
one shared datasources.dat file. 

The config.dat file must reside in the wInsight Analytics folder, but the shared 
datasources.dat can be placed in a network shared folder and accessed by all users. 
This allows all users to easily connect to the databases configured by their system 
administrator. 

To update config.dat, open the file in a text editor (such as Notepad, specify the location 
of the shared datasources.dat, and restart the application. 

[SYSTEM] 

DataSources=<path>\<filename> 

 

The config.dat file is installed into C:\Program Files (x86)\Deltek\wInsight 
Analytics by default. 

 For Oracle database, wInsight Analytics no longer supports Microsoft OLE DB Provider 
for Oracle (MSDAORA.DLL). To connect to a database, it now uses Oracle Provider for 
OLE DB (OraOLEDB.Oracle.1). In case Oracle Provider for OLE DB is not included in 
the OLE DB Provider list on the Data Link Properties dialog box, download and install 
Oracle Data Access Components (ODAC), depending on the Oracle database version 
you are using. 

Part of this change is the conversion of the LONG data type into CLOB (or Character 
Large Object) data type. CLOBS allow you to store and manipulate large blocks of 
unstructured data and provide efficient access to the data. In addition, Oracle 
recommends that you use CLOBs over LONG data types. 
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For more information, see 
http://www.oracle.com/technetwork/topics/dotnet/downloads/net-downloads-
160392.html. 

Customize Functions at Startup 

You can customize certain wInsight Analytics Administrator functions at startup. 

 

For information about these options, see the Advanced Set Up Options section in this document. 
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Create wInsight Backup of Contracts 
Automatically in an Access Database 

This only applies to the 6.5.1 thru 8.0.2 versions of the Access database. 

Use the BackupMDB.exe tool to automatically create a wInsight backup of all contracts in an 
Access database formatted for an earlier version of wInsight (version 6.5.1 to v8.0.1). When the 
backup process is complete, a single .WSA file is created and can be easily restored into wInsight 
version 8.1.1.  

 

The BackupMDB.exe tool is installed when you install wInsight Analytics Administrator or 

wInsight Analytics Desktop.  

To create the backup file automatically, complete the following steps: 

1. Open BackupMDB.exe, which is located in C:\Program Files (x86)\Deltek\wInsight 
Analytics\util\BackupMDB by default. Alternatively, you can click Start » All Programs 
» Deltek wInsight Analytics » Deltek wInsight BackupMDB. If you have recently 
accessed the tool, you can also open its shortcut from the main Start menu. 

2. On the wInsight Backup for v6.5.1 to v8.0.1 dialog box, in the File to Backup field, click 

 and navigate to the location where you saved the .MDB file to back up. 

 

3. In the Backup Location field, enter or select the folder where you want to save the file. 
By default, the backup file is saved in C:\Users\<User Name>\My Documents and uses 
the <database name>.wsa file name. 

4. Click OK. 

5. When the backup process is done, a message displays informing you whether the 
backup was successful and asking if you need to back up another database. Clicking Yes 
allows you to perform another backup. Clicking No closes the wInsight Analytics Backup 
for v6.5.1 to v8.0.1 dialog box. 
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When the backup process is complete, the tool creates a log file in the same location where it 
saves the backup file. The log file uses the <database name>.txt format. 

 

As a reminder, all Access .MDB files located under the installation folder are automatically 
backed up during the upgrade installation. For more information, see the Back Up Copies of 
Existing MDB Files section in this document. 
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Set Up and Create a New Database 

The purpose of this chapter is to describe how to set up and create several types of databases. 

Set Up a Database 

To set up a new database, complete the following steps: 

1. Create one of the following types of databases. 

 Microsoft Access®  

 Oracle®  

 Microsoft SQL Server®  

2. Build a data source connection to that database. 

 

You can use wInsight Analytics Administrator to add contracts to the new database 
manually or to add contracts to the new database by importing transfer files. For more 
information about data source connection, see the Appendix A: Data Tool section in 
this document. 

Create a Database 

The wInsight Analytics installer provides batch files to assist with the creation of a new wInsight 
database. The batch files are saved in C:\Program Files (x86)\Deltek\wInsight Analytics\data\ 
and are database-specific. You can also create the wInsight Analytics database by running the 
scripts individually during the installation process. 

Create an MS Access Database 

Whether or not you installed the sample database, wInsight Analytics Administrator installs a 
blank811.mdb database file, which is located in of C:\Program Files (x86)\Deltek\wInsight 
Analytics\data\Access by default. This database file contains no contracts. Use it when you 
want to start a new group of contracts, without having to delete existing ones first. 

Use wInsight Analytics Administrator to add contracts to a new database. 

 

When performing an upgrade installation, wInsight Analytics automatically backs up 
any existing .MDB files (for example, blank*.mdb) it finds in the installation folder. It 
saves these files in the Backup folder, which is located in C:\Program Files 
(x86)\Deltek\wInsight Analytics\Backup by default. 

To create a clean MS Access database, complete the following steps: 

1. Open Windows Explorer and search for blank811.mdb, which is located in C:\Program 
Files (x86)\Deltek\wInsight Analytics\data\Access by default. 

2. Copy the file to a desired location.  

3. In Windows Explorer, rename the copy of blank811.mdb. 
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Create an MS SQL Server Database 

The scripts mentioned in this procedure only create the wInsight Analytics schema. Your 
database administrator (DBA) should have already created the necessary database and 
tablespaces. 

 

By default, the scripts and batch file discussed in this section are located in 
C:\Program Files (x86)\Deltek\wInsight Analytics\data\MSSQL.  

To create a clean Microsoft SQL Server database, complete the following steps: 

1. Make sure that your DBA has created the database and tablespaces that will contain the 
wInsight Analytics objects (user, tables, indexes, and stored procedures) and wInsight 
Analytics database user that will be used to access them. You can check this in the 
Query Analyzer or an equivalent tool. 

2. Connect to the SQL database as the wInsight Analytics user. 

3. Run the following scripts in the order listed in this step (except for the last two scripts, 
which you can run in any order).  

 

Alternatively, you can automatically run the scripts specified in this step using the 
RunAllCreateScripts_SQLServer.bat file from the Windows command line. For more 

information, see the Run the All Create Scripts Batch File section in this document. 

 WST_Tables_SqlServer.sql 

 WST_Upgrade_SqlServer.sql 

 WST_Data_SQLServer.sql 

 WA_Tables_SqlServer.sql 

 WA_Data_SqlServer.sql 

 WA_Procedures_SqlServer.sql 

 

You must run these scripts in the wInsight Analytics database that you created. 

Create an Oracle Database 

The scripts mentioned in this procedure only create the wInsight Analytics schema. Your 
database administrator (DBA) should have already created the necessary database and 
tablespaces. 

 

By default, the scripts and batch file discussed in this section are located in 
C:\Program Files (x86)\Deltek\wInsight Analytics\data\Oracle.  

To create a clean Oracle database, complete the following steps: 

1. Make sure your DBA has created the database and tablespaces that will contain the 
wInsight Analytics objects (user, tables, indexes, and stored procedures) and wInsight 
Analytics database user that will be used to access them. You can check this in the 
Query Analyzer or an equivalent tool. 

2. The wInsight Analytics database user requires the following privileges: 
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 CREATE ANY TABLE  

 CREATE SEQUENCE  

These privileges must be applied directly to the database user. It is not sufficient for 
these privileges to be available through granted roles assigned to the user. You can use 
the WA_User_Oracle.sql script to grant the said privileges. Deltek recommends that 
these privileges are granted before executing any of the wInsight Analytics scripts 
mentioned in step 4. 

3. Connect to the Oracle database as the wInsight Analytics user. 

4. Run the following scripts in the order listed in this step (except for the last two scripts, 
which you can run in any order). 

 

Alternatively, you can automatically run the scripts specified in this step using the 
RunAllCreateScripts_Oracle.bat file from the Windows command line. If you choose 
to run the .bat file, the WST_Oracle_CI_Indexes.sql script is also automatically run. 

This script creates CI and regular indexes for the WST tables in wInsight Analytics. 

For more information on running the batch file, see the Run the All Create Scripts Batch 
File section in this document. 

 WST_Tables_Oracle.sql 

 WST_Oracle_CI_Indexes.sql 

 WST_Upgrade_Oracle.sql 

 WST_Data_Oracle.sql 

 WA_Tables_Oracle.sql 

 WA_Data_Oracle.sql 

 WA_Procedures_Oracle.sql 

 

You must run these scripts in the wInsight Analytics database that you created. 

Run the All Create Scripts Batch File 

The following table describes several ways to run the RunAllCreateScripts_SQLServer.bat (for 
SQL) and RunAllCreateScripts_Oracle.bat (for Oracle) files. 

Method Description Example 

Run the batch file with no 
parameters 

This method runs the scripts 
against the default winst 
database. 

 

C:\<installation 
location>\RunAllCreateScript
s_SqlServer.bat 

C:\<installation 
location>\RunAllCreateScript
s_Oracle.bat ORADB\ORC1  

For Oracle, however, you 
need to include the server 
name\instance name. 
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Method Description Example 

Run the batch file with the 
[database name] [server 
name] parameters 

This method uses Windows 
authentication to log on to 
the database server. This 
could be used to set up a 
database named winst or a 
custom database. 

C:\<installation 
location>\RunAllCreateScript
s_SqlServer.bat WINST81 
SQLDB 

C:\<installation 
location>\RunAllCreateScript
s_Oracle.bat WINST81 
ORADB\ORC1 

Run the batch file with the 
[database name] [server 
name/instance name] 
[database user ID] 
[database password] 
parameters 

This uses the SQL Server 
Authentication or 
Authentication by Oracle 
Database to log on to the 
database server. This could 
be used to set up a database 
named winst or a custom 
database. 

 If SQL authentication is 
being used for the 
connection, users need 
to have been created 
and associated with the 
database with 
appropriate rights to 
create and update the 
tables. 

 For SQL, if you do not 
enter the user name and 
password, the script 
uses winst as the 
default database name 
and Windows 
authentication to log on 
to the database. 

 For Oracle, if you do not 
enter the user name and 
password, the script 
uses winst as the 
default database name, 
and winst/winst as the 
default user 
name/password. 

C:\<installation 
location>\RunAllCreateScript
s_SqlServer.bat WINST81 
SQLDB\MSSQL2012R2 SA 
SAPWD 

C:\<installation 
location>\RunAllCreateScript
s_Oracle.bat ORADB\ORC1 
SA SAPWD 

 

Oracle, however, only uses 
three parameters. 

 

 

By default, the installation location for SQL is C:\Program Files (x86)\Deltek\wInsight 
Analytics\data\MSSQL and for Oracle is C:\Program Files (x86)\Deltek\wInsight 
Analytics\data\Oracle. 
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To run the .bat file when a blank SQL or Oracle database has been created for wInsight 
8.1.1, complete the following steps: 

1. Open Command Prompt as an administrator (right-click Command Prompt and select 
Run as administrator). 

2. If the User Account Control dialog box displays, click Yes. 

3. In the Command Prompt window, type cd/ and press ENTER. 

4. Enter cd followed by the installation location of the .bat file, and press ENTER.  

 

For example: 

 cd Program Files (x86)\Deltek\wInsight Analytics\data\MSSQL 

 cd Program Files (x86)\Deltek\wInsight Analytics\data\Oracle 

5. Enter the .bat file name, and press ENTER. The format, however, varies depending on 
the method you are using.  

 

For example, if you are running it with the [bat file] [database name] [server 
name/instance name] [user ID] [password] parameters, enter one of the following 

depending on your database: 

 RunAllCreateScripts_SQLServer.bat WINST81 SQLDB\MSSQL2012R2 

SA SAPWD 

 RunAllCreateScripts_Oracle.bat ORADB\ORC1 SA SAPWD 
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Convert a wInsight Analytics 8.1 or Earlier 
Database to 8.1.1 

The purpose of this section is to describe how to populate a wInsight Analytics 8.1.1 database 
with your existing wInsight Analytics data, so that you can use wInsight Analytics Administrator 
8.1.1. 

 

In this section, earlier databases cover those from the 6.5.1 thru 8.0.2 versions. 

The instructions in this section are organized by database type: 

 Microsoft Access®  

 Oracle®  

 Microsoft SQL Server®  

The conversion process modifies your existing 8.1 or earlier database and changes it into an 
8.1.1 database. It does not copy data from an earlier database to an 8.1.1 database. 

 

This note only applies to the 6.5.1 thru 8.0.2 versions.  

When you install wInsight Analytics Administrator, the ConvertWSDATA.exe tool is 
also installed in the C:\Program Files (x86)\Deltek\wInsight Analytics folder. This 

tool allows wInsight Analytics Administrator to automatically convert your existing 
wsdata.ini into the new datasources.dat, which contains the list of data sources that 

you see when you log on to wInsight Analytics. After the conversion process, the data 
source [WE:Sample] becomes [Sample]. 

Backing up and restoring your data is an alternative to converting your database. For 
more information, see the Upgrade from an Earlier Version of wInsight Analytics 
Administrator section in this document. 

Convert an MS Access Database or Back Up and Restore Data to 
an Access Database 

For Access database, you either (a) convert an MS Access database or (b) create a backup of 
wInsight contracts and then restore it, depending on which version you are coming from. 

 If you are upgrading 8.1 to 8.1.1, the process involves running the upgrade script 
against the created database.  

 

For more information, see the Convert an MS Access Database section in this 
document. 

 If you are upgrading 6.5.1 thru 8.0.2 to 8.1.1, the process involves creating wInsight 
backup of contracts and then restoring the .WSA file to an 8.1.1 database. 

 

For more information, see the Create wInsight Backup of Contracts Automatically in an 
Access Database and Restore a .WSA File to an 8.1.1 Database sections in this 
document. 
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Convert an MS Access Database 

No one should be using the database during the conversion process. Deltek recommends that 
you back up your wInsight Analytics 8.1 contracts before performing the conversion. 

 

For more information on how to back up contracts, see the Back Up a Contract section of the 
Deltek wInsight Analytics Desktop and wInsight Analytics Administrator Online Help. 

To convert an MS Access database, you need: 

 wInsight Analytics Administrator 8.1.1 installed 

 A fully working or verified operation database 

 A data source connection to that database 

To convert an MS Access Database, complete the following steps: 

1. Using Query Analyzer or the equivalent, connect to an existing wInsight database (the 
default login name is Admin and password is blank). 

2. Click File » Open, and select the WA811_Upgrade_Access.qry script. 

 

By default, the script is located in C:\Program Files (x86)\Deltek\wInsight 
Analytics\data\Access. 

3. Click   to run the convert query. 

Convert an MS SQL Server Database 

No one should be using the database during the conversion process. Deltek recommends that 
you back up your wInsight Analytics 8.1 or earlier contract(s) before performing the conversion. 

To convert an MS SQL database, you need: 

 wInsight Analytics Administrator 8.1.1 installed 

 A fully working or verified operation database 

 A data source connection to that database 

To convert 8.1 or earlier data to 8.1.1 on an MS SQL Server database, have your database 
administrator complete the following steps: 

1. Using Query Analyzer or the equivalent, connect to an existing wInsight database (the 
default login name and password are winst and winstpwd). 

2. Click File » Open to open the corresponding upgrade script, depending on which version 
you are coming from. 

 

By default, the scripts specified in this step are located in C:\Program Files 
(x86)\Deltek\wInsight Analytics\data\MSSQL. 

 If you are upgrading from 8.1, run the WA811_Upgrade_SqlServer.sql script 
against the created database.  

 If you are upgrading an early version (from 6.5.1 thru 8.0.2), complete the 
following steps (a-g): 
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a. Select and run the following scripts (in the order listed in this step) against the 
created database:  

 WST_Tables_SqlServer.sql 

 WST_Upgrade_SqlServer.sql 

 WST_Data_Sql Server.sql 

 WA81_Upgrade_SqlServer.sql 

b. The upgrade script (WA81_Upgrade_SqlServer.sql) reports user or group 
names that exceed 20 characters in the wInsight Analytics table. In this case, 
copy the part of the message with the RENAME lines. 

For example: 

RENAME_USER( 'USERMORETHAN20CHARACTERS', 'NEWUSERNAME', 
fail, invalid ); 

RENAME_OSAUTHUSER( 
'DOMAIN\DOMAINUSERMORETHAN20CHARACTERS', 
'DOMAIN\NEWDOMAINUSERNAME', fail, invalid ); 

RENAME_GROUP( 'GROUPMORETHAN20CHARACTERS', 
'NEWGROUPNAME', fail, invalid );  

c. Open the rename script (WA81_Rename_SqlServer.sql), and paste the lines 
you copied in the previous step below the existing RENAME lines of the rename 
script. 

d. Change the use or group names using not more than 20 characters. In our 
example, NEWUSERNAME, DOMAIN\NEWDOMAINUSERNAME, or 
NEWGROUPNAME. 

e. Run the rename script (WA81_Rename_SqlServer.sql), which now contains the 
renamed user or group names. 

f. After you successfully run the rename script, you need to run the 
WA81_Upgrade_SqlServer.sql script again to upgrade the SQL database from 
8.0.1 or earlier to version 8.1. 

g. Run the WA811_Upgrade_SqlServer.sql script to upgrade the SQL database 
from 8.1 to 8.1.1. 

 

To create a clean wInsight 8.1.1 SQL database, see the Create an MS SQL Server 
Database section in this document. 

Convert an Oracle Database 

No one should be using the database during the conversion process. Deltek recommends that 
you back up your wInsight Analytics 8.1 or earlier contract(s) before performing the conversion. 

To convert an Oracle database, you need the following: 

 wInsight Analytics Administrator 8.1.1 

 A fully working or verified operation database 

 A data source connection to that database 
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To convert 8.1 or earlier data to 8.1.1 on an Oracle database, have your database 
administrator complete the following steps: 

1. Using SQL Plus or the equivalent, connect to an existing wInsight database (the default 
login name and password are winst and winstpwd). 

2. Click File » Open to open the corresponding upgrade script, depending on which version 
you are coming from. 

 

By default, the scripts specified in this step are located in C:\Program Files 
(x86)\Deltek\wInsight Analytics\data\Oracle. 

 If you are upgrading from 8.1, run the WA811_Upgrade_Oracle.sql script against 
the created database.  

 If you are upgrading from an early version (from 6.5.1 thru 8.0.2), complete the 
following steps (a-g): 

a. Open and run the following scripts (in the order listed in this step) against the 
created database:  

 WST_Tables_Oracle.sql 

 WST_Upgrade_Oracle.sql 

 WST_Data_Oracle.sql 

 WA81_Upgrade_Oracle.sql 

b. The upgrade script (WA81_Upgrade_Oracle.sql) reports user or group names 
that exceed 20 characters in the wInsight Analytics table. In this case, copy the 
part of the message with the RENAME lines. 

For example: 

RENAME_USER( 'USERMORETHAN20CHARACTERS', 'NEWUSERNAME', 
fail, invalid ); 

RENAME_OSAUTHUSER( 
'DOMAIN\DOMAINUSERMORETHAN20CHARACTERS', 
'DOMAIN\NEWDOMAINUSERNAME', fail, invalid ); 

RENAME_GROUP( 'GROUPMORETHAN20CHARACTERS', 
'NEWGROUPNAME', fail, invalid );  

c. Open the rename script (WA81_Rename_Oracle.sql), and paste the lines you 
copied in the previous step below the existing RENAME lines of the rename 
script. 

d. Change the use or group names using not more than 20 characters. In our 
example, NEWUSERNAME, DOMAIN\NEWDOMAINUSERNAME, or 
NEWGROUPNAME. 

e. Run the rename script (WA81_Rename_Oracle.sql), which now contains the 
renamed user or group names. 

f. After you successfully run the rename script, you need to run the 
WA81_Upgrade_Oracle.sql script again to upgrade the Oracle database from 
8.0.1 or earlier to version 8.1. 

g. Run the WA811_Upgrade_Oracle.sql script to upgrade the Oracle database 
from 8.1 to 8.1.1. 
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To create a clean wInsight 8.1.1 Oracle database, see the Create an Oracle Database 
section in this document. 

What’s Next? 

Recalculate a Contract 

Deltek recommends that you recalculate a contract to check that the conversion process 
completed successfully. 

 

For more information, see the Recalculate a Contract section of the wInsight Analytics 
Desktop and wInsight Analytics Administrator Online Help. 
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Restore a .WSA File to an 8.1.1 Database 

This section discusses how to restore the contracts that you backed up from your 8.1 or earlier 
(6.5.1 thru 8.0.2) database into an 8.1.1 database. 

 

For all 8.1 databases, it may be easier to convert them to 8.1.1 rather than restore 
archive files. For more information, see the Convert a wInsight Analytics 8.1 or Earlier 
Database to 8.1.1 section in this document. 

Before you can restore the contracts contained in a wInsight archive file (.WSA), you need: 

 A wInsight archive file (.WSA) (see the Backup 8.1 or Earlier and/or Create wInsight 
Backup of Contracts Automatically in an Access Database sections in this document) 

 wInsight Analytics Administrator 8.1.1 installed (see the Install wInsight Analytics 
Administrator section in this document). 

 A wInsight Analytics 8.1.1 database (see the Create a New Database or Convert a 
wInsight Analytics 8.1 or Earlier Databases sections in this document) 

 A data source connection to the 8.1.1 database (see the Appendix A: Data Tool section 
in this document) 

To restore the contracts contained in your wInsight archive file, complete the following 
steps: 

1. Start wInsight Analytics Administrator 8.1.1. 

2. Click File » Login, and select the 8.1.1 database. 

3. Click Utilities » Restore to select your archive file (.WSA) and restore your contract(s). 

4. Recalculate <All Periods> of all contracts. Make sure to select the appropriate options 
for each contract. 

 

For more information, see the Recalculate a Contract section in the wInsight Analytics 
Desktop and wInsight Analytics Administrator Online Help. 
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Advanced Setup Options 

Log Manual Changes 

Use the following procedure to configure wInsight Analytics Administrator to create and log any 
manual changes (input, deletes, and updates) that were made to the data in wInsight Analytics 
Administrator. You can activate this feature via registry keys (under HKEY_LOCAL_MACHINE, 
which means logging will be on or off for any user on that machine). 

The resulting file is a tab-delimited text file that records the following information: 

 what changed 

 who changed It 

 when it changed 

 what the old value was 

 what the new value is 

To create and log manual changes that were made to the data in wInsight Analytics 
Administrator, complete the following steps: 

1. Click Start » Run to display the Run dialog box. 

2. Enter either REGEDIT.EXE or REGEDT32.EXE and click OK to open the Registry Editor. 

3. Create the following key folder depending on your operating system: 

 For 32-bit machines: 

HKEY_LOCAL_MACHINE\SOFTWARE\Deltek\wInsight Administrator 

 For 64-bit machines: 

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Deltek\wInsight 
Administrator 

4. Create a new key, 8.1.1, under wInsight Administrator: 

a. Click wInsight Administrator. 

b. Select Edit » New » Key. A New Key #1 entry is highlighted in the left window of the 
Registry Editor. 

c. Delete New Key #1 and then rename the new key 8.1.1. 

5. Create a new key, Manual Change Log, under 8.1.1: 

a. Click 8.1.1. 

b. Select Edit » New » Key.  A New Key #1 entry is highlighted in the left window of the 
Registry Editor. 

c. Delete New Key #1 and then rename the key Manual Change Log. 

6. Create the Change Log entry: 

a. Click Manual Change Log. 

b. Select Edit » New » DWORD (32-bit) Value or QWORD (64-bit) Value depending 
on your operating system.  A New Value #1 is highlighted in the right window of the 
Registry Editor. 
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c. Delete New Value #1 and rename the value LogChanges. 

7. Set the Change Log entry. 

a. Click LogChanges. 

b. Select Edit » Modify. The Edit DWORD (32-bit) Value or Edit QWORD (64-bit) dialog 
box displays, depending on your operating system. 

c. In the Base group box, select the Decimal option.  

d. Set the Value Data field appropriately: 

 To turn on change logging, enter a 1. 

 To turn off change logging, enter a 0. 

e. Click OK to close the Edit DWORD (32-bit) Value or Edit QWORD (64-bit) dialog box. 
Depending on the entry, either a 1 or a 0 should display at the end of the string of 0’s 
in the Data column on the right side. 

8. Create the Change Log File entry: 

a. Click Manual Change Log. 

b. Select Edit » New » String Value.  A New Value #1 is highlighted in the right 
window of the Registry Editor. 

c. Delete New Value #1 and rename the value LogFile. 

9. Specify the path and filename for the Change Log File that will be created to capture 
changes that are made in wInsight Analytics Administrator: 

a. Click LogFile. 

b. Select Edit » Modify. The Edit String dialog box displays. 

c. In the Value Data field, enter C:\Temp\Change.log (sample path and file name). 

d. Click OK to close the Edit String dialog box.  The path and filename should displays 
in the Data column on the right side. 

10. Select File » Exit to close the Registry Editor. 
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Appendix A: Data Tool 

The Data Tool allows you to add new, edit, and delete data source. If you have more than one 
database, you can specify additional databases using the Data Tool. It is installed when you 
install the wInsight Analytics Desktop or wInsight Analytics Administrator application. 

Add a Data Source 

This procedure allows you to add a data source. 

To add a wInsight Analytics data source, complete the following steps: 

1. Click Start » All Programs » Deltek wInsight Analytics » Deltek wInsight Analytics 
Data Tool. 

2. On the Data Sources dialog box, click Add. 

3. On the Data Link Properties dialog box, select the OLE DB provider that matches the 
database in which your data is stored. The options in this step are provided for 
documentation purposes only. You can select the appropriate driver for your 
environment.  

 MS Access — Microsoft Office 12.0 Access Database Engine OLE DB Provider 
or Microsoft Office 15.0 Access Database Engine OLE DB Provider 

 Oracle —  Oracle Provider for OLE DB 

 MS SQL Server — Microsoft OLE DB Provider for SQL Server or Microsoft SQL 
Server Native Client 

 

For Oracle, in case you cannot find Oracle Provider for OLE DB in the OLE DB 
Provider list, download and install Oracle Data Access Components (ODAC), 
depending on the Oracle database version you are using. For more information, see 
http://www.oracle.com/technetwork/topics/dotnet/downloads/net-downloads-
160392.html. 

4. Click Next or the Connection tab. 

5. On the Connection tab, enter or select appropriate information. The contents of this tab 
vary depending on the database provider. 

6. Select a database: 

 MS Access — Click the ellipses (...) button to browse and select a wInsight .MDB file. 

 Oracle — Obtain the Server Name and Database Name from your IT representative. 

 SQL Server — Obtain the Server Name and Database Name from your IT 
representative. 

7. Enter the corresponding user name and password for a database. 

 MS Access — Enter Admin in the User Name field, leave the Password field blank, 
and select the Blank Password option. 

 Oracle — Obtain the user name and password from your IT representative. If there is 
a password, do not select the Blank Password option. 

 SQL Server — Obtain the user name and password from your IT representative. If 
there is a password, do not select the Blank Password option. 

 

http://www.oracle.com/technetwork/topics/dotnet/downloads/net-downloads-160392.html
http://www.oracle.com/technetwork/topics/dotnet/downloads/net-downloads-160392.html
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Always select the Allow saving password option to encrypt the password and save it 

on disk. 

 

If you use SQL Server Native Client, you must set the Persist Security Info field on the 
All tab of the Data Link Properties dialog box to “True.” To do this, complete the 
following steps: 

 While still on the Data Link Properties dialog box, click the All tab. 

 Scroll down and double-click Persist Security Info. 

 Select True in the Property Value field of the Edit Property Value dialog box. 

8. Deltek recommends that you click the Test Connection option to verify that the 
connection to your database works. The Microsoft Data Link message box displays, 
confirming the database connection. 

9. Click OK to save the information, and close the Data Link Properties dialog box. 

10. On the Edit Data Source dialog box, enter a descriptive name in the Database Name 
field. 

 

The Database is Unicode field is not used by wInsight Analytics. 

11. If you selected a database name on the Connection tab of the Data Link Properties dialog 
box, leave the Database Name (Schema) field blank. 

12. Click OK. The new data source is added to the list on the Data Sources dialog box. 

13. Click OK to close the Data Sources dialog box. 

Edit a Data Source 

This procedure allows you to edit a data source.   

To edit a wInsight Analytics data source, complete the following steps: 

1. Click Start » All Programs » Deltek wInsight Analytics » Deltek wInsight Analytics 
Data Tool. 

2. On the Data Sources dialog box, select a data source, and click Edit. 

3. On the Edit Data Source dialog box, click Data Link Properties. 

 

The Database is Unicode field is not used by wInsight Analytics. 

4. On the Data Link Properties dialog box, use the tabs to enter or select your new 
preferences. 

5. When you are done, click OK to save your modifications and close the Data Link 
Properties dialog box. 

6. Click OK to close the Edit Data Source dialog box. 

7. Click OK to close the Data Sources dialog box. 

  



Appendix A: Data Tool 

 

Installation Guide 40 

 

Delete a Data Source 

This procedure allows you to delete an existing data source. If you delete a data source that is 
being used in wInsight Analytics Administrator or wInsight Analytics Desktop, the wInsight 
Analytics application prompts users to select a different data source the next time they try to 
access the application.   

To delete a wInsight Analytics data source, complete the following steps: 

1. Click Start » All Programs » Deltek wInsight Analytics » Deltek wInsight Analytics 
Data Tool. 

2. On the Data Sources dialog box, select the data source that you want to delete, and click 
Delete. 

3. On the confirmation dialog box, click Yes. 

4. Click OK to close the Data Sources dialog box. 
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Appendix B: EPM Security Administrator 

The EPM Security Administrator (EPM SA) allows you to define the security rights for wInsight 
Analytics users. It also allows you to add a new data source or edit an existing one. 

 

To access EPM SA, click Start » All Programs » Deltek wInsight Analytics » Deltek 
EPM Security Administrator. For more information, see the Deltek EPM Security 

Administrator Online Help. 

Add and Delete Users 

Users are individuals who are given rights to log in to the application's system. Initially, there are 
two default users that can access wInsight Analytics: SYSADMIN (default password is 
PASSWORD) and GUEST (blank password). By default, their primary roles are not defined. 
Make sure that you define the roles for these user IDs (see Define User and Group Roles). 

Use EPM SA to add more users and grant them access to wInsight Analytics. You can also 
delete a user ID. 

 

Make sure that each user is associated with wInsight on the Products tab to indicate 
that the user is permitted to access the wInsight Analytics database. 

To add a user ID, complete the following steps: 

1. On the Explorer pane, click the Users folder or expand the Users folder. 

2. Right-click the Users folder to display a context menu, and click Add. Alternatively, on the 
EPM SA menu bar, click Edit » Add. 

3. Change the value of the User ID field from NEWUSER to a unique name. 

 

The user ID can have a maximum of 20 alphanumeric characters, including spaces. 
You can only change a newly added user ID, not an existing one. 

4. On the User Details form that displays on the Properties pane, enter the information for 
the user. Change the password for the new user from the default PASSWORD to a 
unique password. 

 

You can also import users from an ASCII file, a Microsoft Outlook contacts folder, or 
Windows Active Directory Services. 

To delete a user, complete the following steps: 

1. On the Explorer pane, expand the Users folder then select the user to delete. 

2. In the Users folder, right-click the user then click Delete on the context menu. 
Alternatively, on the EPM SA menu bar, click Edit » Delete. 

3. On the confirmation dialog box, click Yes. 

4. On the Explorer pane, expand the Users folder. 
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Change a User Password 

To change a user password: 

1. On the Explorer pane, expand the Users folder then select a user whose password you 
want to change. Alternatively, you can click the Users folder to display the Users form on 
the right pane, and double-click a user whose password you want to change. 

2. On the General tab, click the Password button. 

3. On the Change Password dialog box, in the New Password field, enter a new password 
for the user. 

 

You can use up to 128 alphanumeric and special characters.  You can also set the 
password to blank if the value of the minimum password length is set to zero (0). If this 
is the case, leave the New Password field blank. 

4. In the Confirm New Password field, re-enter the new password. Leave this field blank if 
you set the new password to blank. 

5. Click OK. The new password takes effect the next time you log on to the EPM Security 
Administrator. 

Create, Delete, and Rename Roles 

Roles define the operations a user can perform. You can define access permissions for each role 
and assign each user to a primary role. 

To create a role, complete the following steps: 

1. On the Explorer pane, click the Roles folder and click Edit » Add on the menu bar. 
Alternatively, you can right-click the Roles folder to display a context menu, and select 
Add. 

2. Change the role ID from NEWROLE to a unique ID for the role, and press ENTER. 

3. On the Role Details form, enter the necessary information for the new role on the General 
tab. 
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4. On the wInsight tab, right-click a menu item in the list and select or clear the Visible and 
Enabled options for that function. Use the table below as a reference: 

Icon Visible? Enabled? Effect 

 

Yes Yes Users and groups assigned the role being 
edited can both see and use the menu item. 

 

Yes No Users and groups assigned the role being 
edited can see the menu item, but cannot 
use it. 

A menu item with this setting is shaded. 

 

No Yes Users and groups assigned the role being 
edited cannot see the item in the menu, but 
they can perform the corresponding action 
via another process (for example, they can 
perform recalculate as part of the import but 
not directly through the menu. 

 

No No Users and groups assigned the role being 

edited can neither see nor use the menu 
item. 

To delete a role, complete the following steps: 

1. On the Explorer pane, expand the Roles folder. 

2. Right-click the role you want to delete and select Delete on the context menu. 
Alternatively, you can click the role and click Edit » Delete on the menu bar. 

3. On the confirmation dialog box, click Yes. 

To rename a role, complete the following steps: 

1. On the Explorer pane, expand the Roles folder and select the role you want to rename. 

2. Click the highlighted role and enter the new role. 

3. Press Enter to apply the new role. 

Create, Delete, and Rename Groups 

Groups represent major programs or projects within an organization, or functional groups, such 
as the project management office. You assign users to groups, which you then assign to data 
objects (such as projects) within the applications. Users can have different roles within a group. 

To add a group: 

1. On the Explorer pane, click the Groups folder and click Edit » Add on the menu bar. 
Alternatively, you can right-click the Groups folder to display a context menu, and select 
Add 

2. Change the Group ID from NEWGROUP to a unique ID for the group. 

3. On the Group Details form, enter the information for the group. 
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To delete a group, complete the following steps: 

1. On the Explorer pane, expand the Groups folder. 

2. Right-click the group you want to delete and select Delete on the context menu. 
Alternatively, you can click the group and click Edit » Delete on the menu bar. 

3. On the confirmation dialog box, click Yes. 

To rename a group, complete the following steps: 

1. On the Explorer pane, expand the Groups folder and select the group you want to 
rename. 

2. Click the highlighted group and enter the new group name. 

3. Press Enter to apply the new group. 

Add and Remove Users to/from a Group 

Follow one of the procedures below to add or remove users from a group. 

To add users to a group using the Groups folder, complete the following steps: 

1. On the Explorer pane, expand the Groups folder and select a group ID. 

2. On the General tab, click Add. 

3. Add Users dialog box, select the user IDs to include in the group. You can hold down 
Shift while you click to select multiple user IDs. 

4. Click Yes to add the selected user IDs to the group. 

To add users to a group using the Users folder, complete the following steps: 

1. On the Explorer pane, expand the Users folder and select a user ID. 

2. Click the Groups tab and click Add. 

3. On the Add Group dialog box, select the group IDs to which to associate this user ID. 
You can hold down Shift while you click to select multiple group IDs. 

4. Click Yes to associate this user ID to the selected group IDs. 

To remove users from a group using the Groups folder, complete the following steps: 

1. On the Explorer pane, expand the Groups folder and select a group ID. 

2. On the General tab, select a user ID from the table window and click Remove. A 
confirmation dialog box displays. 

3. Click Yes to remove the selected user ID from this group. 

To remove users from a group using the Users folder, complete the following steps: 

1. On the Explorer pane, expand the Users folder and select a user ID. 

2. Click the Groups tab and select a group ID from the table window. 

3. Click Remove. A confirmation dialog box displays. 

4. Click Yes to remove the group ID from the table window. 
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Define User and Group Roles 

Follow one of the procedures below to assign a role to a user or group. 

To define a role for a user, complete the following steps: 

1. On the Explorer pane, expand the Users folder and select a user ID. 

2. On the General tab, select a role ID in the Primary Role drop-down list. 

To define a role for a group, complete the following steps: 

1. On the Explorer pane, expand the Groups folder and select a group ID. 

2. On the General tab, select a role ID in the Primary Role drop-down list. 
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Appendix C: For Additional Information 

Customer Care Connect Site 

The Deltek Customer Care Connect site is a support Web site for Deltek customers who 
purchase an Ongoing Support Plan (OSP).  

The following are some of the many options that the Customer Care Connect site provides: 

 Search for product documentation, such as release notes, install guides, technical 
information, online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers 
through the Deltek Connect Customer Forums 

 Access Cloud specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Use Quick Chat to submit a question to a Customer Care analyst online 

 

For more information regarding Deltek Customer Care Connect, refer to the online help available 
from the Web site. 

Access Customer Care Connect 

To access the Customer Care Connect site, complete the following steps:  

1. Go to http://support.deltek.com.  

2. Enter your Customer Care Connect Username and Password. 

3. Click Log In. 

 

If you forget your username or password, you can click the Account Assistance button on the 

login screen for help. 

 

  

http://support.deltek.com/
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Available Documentation for this Release 

The following table lists the Deltek documentation available for this release. Except where noted, 
all the user guides and quick reference guides listed in this table are available for download from 
the Deltek Customer Care Connect site. 

Document Name Description 

Deltek wInsight Analytics Administrator 8.1.1 
Release Notes 

This document contains a summary of the 
technical considerations, major features, 
enhancements, software issues resolved, 
and known issues of the application. 

Deltek wInsight Analytics Desktop and 
wInsight Analytics Administrator 8.1.1 Online 
Help 

This document contains detailed information 
and instructions on how to use various 
features of both applications. 

Deltek wInsight Analytics 8.1.1 Product 
Overview 

This document provides a high-level overview 
of the product together with some guidance 
as to which modules should be installed to 
meet the needs of individual users. Most 
users would not need access to all modules. 
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