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While Deltek has attempted to verify that the information in this document is accurate and complete, 
some typographical or technical errors may exist. The recipient of this document is solely responsible for 
all decisions relating to or use of the information provided herein. 

The information contained in this publication is effective as of the publication date below and is subject to 
change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are reserved. No 
part of this document may be reproduced or transmitted in any form or by any means, electronic or 
mechanical, or translated into another language, without the prior written consent of Deltek, Inc. 

This edition published December 2021. 

© Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and proprietary 
information of Deltek, Inc. and its licensors. The Deltek software, and all related documentation, is 
provided for use only in accordance with the terms of the license agreement. Unauthorized reproduction 
or distribution of the program or any portion thereof could result in severe civil or criminal penalties. 

All trademarks are the property of their respective owners.  
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Before You Begin 

General Recommendations 
Because these processes are only done once a year, Deltek recommends the following as precautionary 
measures: 

 Read this “Year-End Manual” in its entirety before beginning the year end process. 

 Make a full year-end system backup (save a copy on the server and to disk). 

 Copy Live to Practice. 

 After all year-end processes are complete, make a final year-end backup for your archived 
records (save a copy on the server and two copies on two separate disks). 

 If you have any questions during the year-end process, please open a support ticket. 

Using the Practice Company 
If you are unsure about a process in ComputerEase, Deltek recommends that you use your practice 
company to test the process first.  

Copying Your Live Data 
Before you copy your live data to your practice data, everyone should be logged out of ComputerEase. 
However, keep in mind that when you "copy data," you are copying an exact replica of your company’s 
live data. Any data that you previously entered in the practice company will be replaced, and anyone who 
is in the middle of testing a function or feature in the practice company at the time you perform the "copy 
data" function will lose that data. 

To copy your live data to your practice data: 
1. Right-click the Windows Start icon and click Run on the shortcut menu. 

2. On the Run dialog box, enter the following, and click OK: 

<ComputerEase installation folder>\copydata.exe 

For example, if ComputerEase installation folder is C:\CE TEST, you would enter this: 

 

 

Note: If you don’t know the ComputerEase installation folder, log into ComputerEase and 
click Help » About. Make note of the Program Directory. 
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3. On the Copy Data Files dialog box, click OK. 

 
You should see a status bar start to track the progress of the procedure. Once the procedure is 
complete, the window will close. 

 

Tip: Make a shortcut on the desktop to the CopyData file that is in the ComputerEase directory for 
easier access. 
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Finalizing your 2021 Payroll 

Issuing Bonus Checks 
Clear the Labor Distribution for all employees that are to receive a Bonus check. 
Enter the amounts for the bonuses through Enter Labor Distribution or Enter Non-Job Hours, selecting 
Bonus for the pay type. Federal Taxes will be calculated using the default in the Tax Rate for Bonus 
Pay field in the Federal Tax Table Maintenance master file (federal standard is 22%). If you change the 
field to 0%, ComputerEase will use the Employee's tax settings to determine the amount of Federal Tax 
to withhold. 

 

To manually adjust FICA Tax, Medicare Tax, Federal Tax, Earned Income Credit, State Tax, Local 
Tax, Deductions, and/or Fringes: 

1. Select Entry on the top of the Labor Distribution screen and Tax Override or use the $ symbol in 
the middle toolbar. 

2. In the Tax Override dialog box, perform the following: 

 Override: From the drop-down menu, select the field you want to override (for example, 
Federal Tax).  

 Operation: From the drop-down menu, select Change current to. 

 Amount: Enter the amount to change the selected item to. 

 
3. Click OK. 

Any changes made here will be reset to the normal employee setting after the Clear Labor 
Distribution utility is run. 

When processing payroll, the Payroll Period you select will control which deductions or fringes will apply 
to the checks you are creating.  

To set up a payroll period for bonus checks: 
1. From the main menu, select Payroll System » Maintenance Programs » Work on Payroll 

Periods.  

2. Enter a name for your Payroll Period and click OK.  

Note: If you change the rate to 0%, ComputerEase will warn you when you print your payroll register 
that your Federal Tax Table does not agree with the defaults and will ask you if you want to revert 
back to the defaults; make sure you clear the box to update it, or it will reset back to 22%. 
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3. On the Payroll Period BONUS dialog box, select which deductions and/or fringes you want to 
apply to the bonus checks, and click OK. 

 

Issuing Non-Cash Fringes during a Normal Payroll 
Many companies provide their employees with certain non-cash fringe benefits that are considered 
taxable income. An example of this would be a taxable fringe benefit for personal mileage for a company-
provided vehicle. Often, these fringes are not allocated during the year.  

Non-cash fringes should be processed with a normal check run. If you have already run your last 
payroll for the year and are unable to process your non-cash fringe in a normal check run, the Month to 
Date Maintenance screen will be used to manually enter the numbers for changes needed on the W-2 
(see the Issuing Fringes after Year End Payroll Is Complete section). 

 

To set up a fringe: 
1. From the Payroll System main menu, select Maintenance Programs » Fringe Maintenance.  

2. Enter a name for the fringe and click OK.  

Note: For future reference, Deltek recommends that after you have your fringe set up and you have 
completed your final payroll for the year, you enter a "base" amount in the Employee Maintenance to 
be added/deducted each pay period going forward. The taxes will be charged to the employee over 
the annual payroll period instead of only at year end. If you are unsure of the amount to be used for 
each payroll period, check with your CPA. 
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3. On the Fringe Maintenance screen, take the following actions: 

 
 Description: Enter a description for the new fringe. 

 Fringe Type: Review the available choices and select the one that describes the new fringe. 
If none of the specific options are applicable, select Normal. 

 Fringe Calculation: Select one of the following options: 
 Normal Fringe: Select this option if the fringe is an accrued fringe and is not to be paid in 

cash to the employee, nor is the sole purpose of setting up the fringe to charge for 
additional taxes. 

 Cash Fringe: Select this option to designate that the fringe is to be paid in cash to the 
employee. 

 Deduction: Select this option to increase the employee’s taxable wages only. You will 
see the amount listed as "other pay" and also under the Fringe/Deduction name on the 
Payroll Register. 

 Calculate On: Select whether to calculate the fringe on the employee's gross pay or on the 
employee's gross pay after taxes. 

 Credit Account: Enter the appropriate account number from your chart of accounts. 

 Cost Type: Use this field only if the fringe you are setting up will be job costed. It will default 
to cost type Fringes, which is the standard cost type for company paid benefits. 

 Work Location: This field is only applicable if you are setting up a fringe that will be job 
costed. 

 W-2 Box 14 Code: If you are setting this fringe up to charge your employee additional taxes 
for a company paid benefit, enter a code here so that the amount paid and then deducted 
from the employee displays on their W-2. 

 Export ID: This is an additional key field most commonly used when exporting payroll data 
from ComputerEase for use with a payroll service. 

 Taxable Settings: Select the appropriate check boxes that apply to the fringe. If you are 
unsure of which selections to make, please check with your CPA. 
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 Payroll Periods: Select which payroll periods to which you want this fringe to apply. (The 
Payroll Period is selected when you print your Payroll Register.) 

 Expense Accounts: Select the appropriate account numbers from your chart of accounts. 
You will need to fill in account numbers for any department that you have set up in 
ComputerEase even if the employee you will be setting the fringe up for only works in one 
department. 

To use fringe during a normal check run: 
1. From the Payroll System main menu, select Enter Labor Distribution by Employee. From this 

screen, enter the regular payroll information to pay the employee for this payroll period as you 
normally would. 

2. At the top of the screen under the Employee's Name, select Entry and Tax Override. 

3. On the Tax Override dialog box, perform the following: 
 Override: Select Fringe from the drop-down list. 

 Fringe: Select the fringe that was created in the previous procedure. 

 Operation: Select Change Current to from the drop-down list. 

 Amount: Enter the amount that you want added and then deducted from this payroll run. 

 
4. Click OK. 

 
Continue with the normal payroll process, checking the payroll register carefully to verify that the amounts 
of fringes and taxes are correct. 

Note: If you are using this fringe in a normal check run, to charge your employee for taxes only, you 
must make sure that the "gross wages" for the employee are greater than the amount of tax being 
charged. The software will not allow you to create a negative check. If the taxes that are calculated on 
the fringe are greater than the gross wages, you will have to "gross up" your employee’s wages to 
cover the taxes. If you are unsure of how to complete this process, please check with your CPA. 
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Issuing Fringes after Year End Payroll Is Complete 
If you have completed your final payroll check run for the year and need to add information to the 
employee’s wages for tax purposes and you want the amount recorded in the W-2 Box 14, you will need 
to set up a fringe for the additional information and then manually make changes using the Month to Date 
Maintenance utility. 

This utility is used to add information to the W-2 and does not charge the employee for any taxes owed. If 
there are taxes owed, you will need to make arrangements with the employee to collect them. 

To issue fringes after year-end payroll is complete: 
1. Create the Fringe. 

 
2. After creating the Fringe, select Payroll System » Maintenance Programs » Month to Date 

Maintenance. 

3. On the Month to Date Maintenance dialog box, select the Employee and enter the Month for 
which you want to edit the fringe and tax amounts. 

This will normally be December of the year you are currently working in. 

 
4. Click OK. 

5. On the MTD Maintenance screen, click the State tab, and then click the Fringes button at the 
bottom. 

 

Attention: Please see the Issuing Non-Cash Fringes During a Normal Payroll for instructions 
on setting up the Fringe. 
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6. On the MTD Fringes dialog box, enter the amount of the fringe in the Accrued field, and click OK. 

 
7. On the MTD Maintenance screen, click the Federal tab. 

8. In the Federal Tax field, enter the amount of tax that has been calculated for the fringe  

This amount will be supplied to you by your CPA.  

In the example below, the employee had paid $200.55 in federal taxes for the month, the tax on 
the fringe is $175.00, so the new amount of Federal Tax will be $375.55. If the fringe is taxable 
for FICA and Medicare, you will need to edit these fields as well.  

When FICA or Medicare is changed, the Employee and Employer fields will require editing. If the 
fringe is taxable for state income tax or local income taxes, the State Tax Withheld and 
appropriate Local Employee (or Employer Tax, where applicable) fields will require editing on 
the State and Local tabs, respectively. 

 
9. When done making changes, click OK. 

10. On the Save dialog box, enter the date the change became effective, and click OK. 

 

 
Note: If this is a one-time annual adjustment, you can use the last day of the year. 
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The following is screenshot of how an employee's W-2 screen looked before making the above changes 
and a screenshot of how it looks after the changes were made. 

 

 

 

Note: If you choose to use Month to Date Maintenance for increasing taxes and fringe amounts, the 
necessary journal entries for monies paid to you by the employee for any additional tax, or for any 
fringe accrual or expense will need to be made manually. 
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Handling Third-Party Sick Pay 
When an Employee receives a check from a Third-Party sick pay provider, it is sometimes required that 
the Employer record the wages paid by the provider and the taxes paid by the Employee on the 
Employee’s W-2 statement. This would also require the Employer's quarterly 941 to be adjusted as well. 
From the provider’s statements, you will be able to document and adjust the W-2, the 941, and the 940 
(FUTA). 

Quarterly 941 Adjustments 
On the 941, you will adjust all wage and tax amounts (lines 2, 5a, 5c) to include the amounts paid to all 
Employees by the Third-Party Provider for this quarter. As the Employer, if you are also responsible for 
paying the Employer’s portion of the above-mentioned tax, your 941 will need to be adjusted to show the 
taxes paid. Line 8 of the 941 should be completed with the employer taxes for total sick pay provided by 
the third party, for all employees. 

 
 

Editing W-2s for Third Party Sick Pay 
For the employees that have received funds from this provider, you will need to edit their W-2 to reflect 
the compensation and taxes paid. After preparing the W-2’s, you will need to then select Edit W-2s. 
Select the current year and the employee and then click OK. 
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Ending the Payroll Year 
Before closing Payroll for the year, you should read this manual in its entirety and determine dates that 
you can reasonably expect to complete each of the following tasks: 

Review Master Files 
 Confirm that Deduction and Fringe code Types have the appropriate selection for Box 12 on the 

W-2s 

 Confirm that Deduction and Fringes W-2 Box 14 Code have the appropriate information filled in 
to allow the value to print in box 14 on the W-2 

 Check Employee Maintenance master files for accuracy of name, address, and Social Security 
number 

 Confirm that the Company’s name, address, and phone number are correct (this information can 
be verified by choosing Company Name from the Main Menu » Configure » Company Name) 

 Verify Tax Identification numbers by selecting Payroll System » Maintenance Programs » Tax 
Rate Maintenance 

 Check the Federal ID number in Federal Tax Rate Maintenance 

 Check the State ID number in State Tax Rate Maintenance 

 Check the Local Tax Rate Maintenance for the following (if necessary): 

 If the local will not accept a transmittal sheet, and a W-2 is required, make sure the W-2 
Required field is selected 

 Verify the name of the local tax (ComputerEase truncates some of the letters on the W-2 
statements and you may need to change names to accommodate this) 

 The county codes and school district information are required for magnetic media 

Print Reports 
 Complete normal Month-End reporting (after you have completed your final payroll cycle for year 

end and are certain that you will have no further layoff or bonus checks) 

 Run Quarterly and Yearly payroll reports 
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 Print and retain the following reports for your permanent records: 

 Month, Quarter, Year-to-date for Tax Reporting 

 State and Local Taxes Withheld 

 Federal and State Unemployment 

 Workers Comp Worksheet 

 941 Worksheet and Schedule B 

 Deduction and Fringe Reports (if applicable) 

 Union and EEOC reports (if applicable) 

 Employee Master Reports 

In Preparation for the New Year 
 Some items that may need to be reviewed and reset at this time of year: 

 Vacation and Sick time: Accrued and available (please refer to the option in the Payroll 
System Parameters to Expire Accrued Sick and Vacation Hours on a particular month of the 
year, and use the "Edit Accrued Hours" menu option to manage available Sick/Vacation 
time), as well as rules applicable to each employee 

 Deduction and Fringe "Yearly Cap" limits that have been set in your Employee Maintenance 

 ACA information: Gather information on plans, premiums and employee statuses and offer 
codes 
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Working with W-2s 

Preparing W-2s 

 

To prepare W-2s: 
1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s » 

Prepare W-2s. 

2. On the Prepare W-2s dialog box, enter the year. 

 
If you leave the Employee - From and To fields blank, the system will prepare W-2 statements 
for any employees that received a paycheck for that year.  

3. Click OK and ComputerEase will compile the information. 

You will receive a notification letting you know how many W-2s were prepared. 

 
After you have prepared the W-2 statements, you can select the Print W-2s menu option to print the W- 2 
statements on plain paper. This will allow you to verify that the information that will print is correct. You 
can print the statements as many times as needed. 

Editing W-2s 
After the W-2s have been prepared and reviewed, you can make any manual changes if needed. 

To edit W-2s: 
1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s » Work 

on W-2s » Edit W-2s.  

2. On the Edit W-2s dialog box, enter the Tax Year and Employee, and click OK. 

 

Note: It is not necessary to prepare W-2s for 2021 prior to running the first payroll for 2021. The 
Payroll System module is date-sensitive; therefore, you may prepare W-2s at any time after running 
the last payroll for year end. 

Note: If you receive an error while attempting to prepare W-2s that advises you that a tax local, 
deduction, or fringe used during the year has been deleted, you will need to set it back up. If you 
receive this error, note the local, deduction, or fringe code that was deleted and set up that local, 
deduction, or fringe code using the necessary Maintenance Program, in the exact way you noted. 
After the code has been re- established, select Prepare W-2s once more to finish preparing. 
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3. On the employee’s W-2 screen, make any changes as needed. 

 

 
4. If you need to add information for Box 12 or Box 14 on the W-2 statement, enter the information 

in the Code or Other field. 

Printing W-2s 
After you have verified that the information on the W-2s is correct, you are ready to print your W-2 forms.  

To print W-2s: 
1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s » Work 

on W-2s » Print W-2s.  

2. Choose from the following printing options: 

 
3. Only the required boxes/data will be populated for each selection. 

Note: After you edit a W-2, make sure you do not select Prepare W-2s for this employee 
again, or your changes will be overridden by the system information and you will have to edit 
the W-2 again. 
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For example, box 14 is an Employee informational box and will only print on the Employee Copy. 

 Local Wages on W-2s: Each Local Tax Maintenance screen in ComputerEase has options 
that will determine how the Local Wages are reported on the Employee Copy of the W-2. 
Local wages are not reported on the Federal Copy. The W-2 Required box, options for 
reciprocation rules, and taxable questions for “Work” vs “Resident” are all choices that will 
determine what amount is reported in “Local wages, tips, etc.” box (Box 18) of the Employee 
copy. 

 Option 1: If you have the W-2 Required option selected in all of your Local Tax 
Maintenance screens, you will see two locals per W-2 with the tax that was withheld for 
each Local and wages for each Local that should match the “Taxable Wages” for that 
Local in the “Earned Anywhere” section of the Local Tax Withheld Report available in 
ComputerEase. Because of reciprocation rules, and the possibility of the same wages 
being charged for taxes in more than one Local (Work Local and Home Local) it is not 
accurate to report “Taxable Wages” from the “Earned in Local” section. 

 Option 2: If you have the W-2 required option selected in only some Local Tax 
Maintenance screens, you will see the Locals that have the W-2 required option selected 
in the same manner as described above. All other Locals will be grouped together and 
will show a total of Tax Withheld for Locals not getting an individual W-2. Because of the 
available options for calculating Local taxes listed above, it is not possible for the system 
to report the wages for this grouping in any other manner; therefore, it will report the 
same wages that are in Box 1 (Wages, tips, other comp) and will be listed as “Various.” 

 
Count W-2s will generate a report that will give you a total for each copy that needs to be prepared. Local 
copies will be counted using the settings that are selected in the Local Tax Maintenance in the W-2 
required field. 

Note: Because you will be submitting a W-2 for the Locals that you have selected W-2 
required and submitting a Transmittal Sheet by Locality to the Locals that do not require a 
W-2, the “various” wages should not be a concern to your employee or any Local. If your 
employee would like a breakdown of the remaining Locals in which he was charged tax, you 
may print a Transmittal Sheet by Employee. 
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Printing the W-3 
After printing your W-2 forms, you will be ready to print your W-3 form. 

To print the W-3: 
1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s » Work 

on W-2s » Print W-3. 

2. On the Print W-3 dialog box, verify the Tax Year and select Yes or No to Include State and 
Local Totals depending on whether or not you would like state and local totals included on your 
W-3 form. 

 
3. Confirm the information on the Employee Information tab and make any changes necessary.  

 
4. If needed, make changes on the Amounts tab. 

The changed values will output on the printed copy of the W-3. However, if you believe your totals 
are incorrect, you should research and correct the issue within ComputerEase, as these totals are 
the totals from your W-2 forms and should be validated by the totals of your W-2 forms. 
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5. When you have confirmed all your information, click Print. 

 

Generating a Magnetic Media File 
To create a Magnetic Media file for electronic filing of W-2 statements: 

1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s » 
Create Magnetic Media File. 

2. Select the appropriate format: Federal Info, State Info, or City Info. 

 
3. Depending on the option you select, you are prompted for the Tax Year and any additional 

information required for the Magnetic Media file. 

 
4. When finished, click OK. 

The Magnetic Media file will be generated in the clipboard. You can copy this file to disk and/or 
send it to the proper agency. 
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Upload W-2s to Employee Hub 
If you own the Employee Hub module, you can upload W-2s to the Employee Hub website, if needed. 

To upload W-2s to the Employee Hub: 
1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s » 

Upload W-2s to Employee Hub. 

2. On the Upload W-2s to Employee Hub dialog box, enter the Tax Year of the W-2s you want to 
upload, and click OK. 

 
3. When notified that the W-2s were successfully uploaded to the Employee Hub, click OK. 
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Installation of Year End Update 

Auto Update Feature 
To keep your software current and to make sure that you have the Tax Tables for the new year, you will 
need to run the Auto Update Feature that is available in ComputerEase. You can run the update as soon 
as it is available. 

If you have the feature enabled that notifies you automatically when updates are available, you will see an 
Attention message similar to the following when updates are available: 

 
You can click on the notification to see a list of the updates available and the release notes for each 
update. 

To check for updates: 
1. Make sure all other users have logged out of ComputerEase.  

2. Take one of the following actions: 

 Click the Attention message. 

 From the ComputerEase main menu, click Help » Check for New Release. 

 
3. When the information box displays, click Check for Upgrade.  

This instructs the system to check the ComputerEase website for the newest release and version 
of ComputerEase.  

4. If your ComputerEase is not up to date, the Auto Update screen displays, showing how many 
updates are available to download. 
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5. Click View Changes to see a list of revisions and new features that will be installed with this 

update.  

You can also print this list after clicking View Changes. 

To install updates: 
1. Leave the Auto Update window open and log out of ComputerEase.  

2. Click Update.  

A progress bar will display showing the files being installed.  

 
3. When the update installation is complete, click Yes when prompted to Convert the Data Files.  

This completes the update on the server. Each workstation will be updated to this release the 
next time the user attempts to log into ComputerEase. 

Loading Federal & State Tax Tables 
ComputerEase keeps the Federal and State Tax Tables updated for you. To access the newest Tax 
Tables, you must be on the most current release of the version you are on. 

 
You have two options for updating your tax tables: 

 Automatically update the tax tables.  

If you wait until you print your payroll register for the first payroll run of the year, ComputerEase 
will prompt you to update your tables with any Federal or State changes at that time. 

Note: If someone is still logged into any of the ComputerEase companies, you will get an 
error message that there is a user logged in and which company they are logged into. To 
determine the user, sign into the company that the warning pointed to, and click File » Active 
Users on the main menu to view the User Log. 

Attention: Refer to the Auto Update Feature section for help with updating. 
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 Manually update tax table. 

Option 1: Automatically Update Tax Tables 

To automatically load your tax tables for the new year: 
1. Enter and process your first payroll of 2022 as normal.  

2. Run the Print Payroll Register program and choose a Date of Check with a date in 2022. 

The following warning message displays: 

"The following tax table(s) do not agree with the tax tables shipped with this release of the 
software."  

Any tables that have changes for 2022 will be listed with an effective date for the changes.  

3. Leave the check box selected in the Update column for each table in the list and process your 
payroll register. 

ComputerEase will update your tax tables for you. 

 

Option 2: Manually Update Tax Tables 

To load the Default Tax Tables for Federal Taxes: 
1. From the Payroll System main menu, select Maintenance Programs » Tax Rate Maintenance 

» Federal Tax Maintenance.  

2. On the Federal Tax Maintenance dialog box, enter the Tax Year, and click OK. 

 
3. Click File » Load Defaults at the top left to update the tax tables for the year entered. 

4. On the Main tab of the Federal Tax Information screen, make changes as needed to the 
information. 

 

Tip: The payroll register is date-sensitive and will update the tax tables as many times as necessary 
depending on the check date. This means that you can process your first payroll of 2021 during 
December and allow ComputerEase to update the tax tables to 2021 tables for use in that payroll. 
Then run bonus checks for 2021 and allow ComputerEase to update the tax tables back to 2021 for 
use for those checks. The next time you process a 2021 payroll, ComputerEase will update the tables 
back to 2021 again. 

Tip: The only information you may want to change is the Employer's ID Number or the 
Federal Unemployment Rate. 
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5. When finished editing the information, click OK to save your changes. 

 

To load the Default Tax Tables for State Taxes: 
1. From the Payroll System main menu, select Maintenance Programs » Tax Rate Maintenance 

» State Tax Table Maintenance.  

2. On the State Tax Table Maintenance dialog box, select the State and the Tax Year for which you 
want to update the Tax information, and click OK. 

3. On the Tax Settings screen, click File » Load Defaults to update the tax tables for the year 
selected. 
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4. On the Main tab or SUTA tab of the State Tax Information screen, make any changes to the 
information.  

5. When finished editing the information, click OK to save your changes. 

 

  

Note: The SUI and associated rates for applicable states will need to be maintained manually after 
you have received your new rate from the State on the SUTA tab. 

Note: Any rates shown on this page are for demonstration purposes only. Tax rates are subject to 
last-minute legislative change and the rates shown here should not be assumed to be the final rates 
or limits for 2022. 
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Issuing 1099s 

Prepare 1099s 
Verify that the Vendors for which you would like to print 1099s are set up correctly. You can do this using 
the Vendor Maintenance screen. 

To prepare 1099s: 
1. Selecting Accounts Payable » Maintenance Programs » Vendor Maintenance.  

2. On the Add’l Settings tab of the Vendor dialog box, verify that the Print 1099 check box is 
selected.  

3. Optional. Edit the Name field if you if you want a different name to print on the 1099 than what is 
displayed on the tab.  

4. Select how the payments for a Vendor are to be classified. 

 
Unless otherwise selected, payments made to Vendors are considered Nonemployee 
Compensation.  

5. On the Settings tab, verify that the Vendor ID field is properly completed, and click Save.  
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6. Select Accounts Payable » Maintenance Programs » Checking Account Maintenance to 

verify that your Checking Accounts are also set up to properly record payments on 1099s or not, 
as appropriate. 

7. On the Account screen, take one of the following actions, and click Save: 

 To exclude payments from one particular checking account from being reported on the 
1099s, select the Exclude from1099s check box. 

 To include payments for any checking accounts that must be reported on the 1099s, ensure 
the Exclude from 1099s check box is not selected. 

 
8. Select Accounts Payable » Reports » Print 1099s » Prepare 1099s to begin the 1099 process. 

9. On the Prepare 1099s dialog box, take the following actions: 
 Tax Yea: Enter the year for which you would like to prepare your 1099s. 

 Vendor: Select a range of vendors or leave these fields blank to prepare 1099s for all 
vendors. 

 

Note: You can verify the that the Vendor ID is correct for the Vendors that you want to print 
by reviewing the Vendor Mater Report. Select Accounts Payable » Maintenance Programs 
» Vendor Master List to review the report. 

You can also build a Q-Tool report that displays all the set-up information for your vendors in 
one place. 
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10. Click OK.  

The system will report back to you the number of vendors for which it prepared 1099s. 
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Printing the 1099 Report 
To print the 1099 report: 

1. Select Accounts Payable » Reports » Print 1099s » Print 1099 Report. 
2. On the 1099 Report dialog box, take the following actions: 

 
 Year: Enter the year for which you are working on 1099s. 

 Vendor Type: Select one of the following: Supplier, Subcontractor, Other or All.  

 Vendors: Leave this field blank to report all vendors.  

 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 
would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

3. Click OK. 

Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

Your report will be separated into vendors that will be issued a 1099 by type (1099-MISC, 1099-INT, or 
1099- NEC) and vendors that will not be issued a 1099. 

Editing 1099s 
To edit 1099s: 

1. Select Accounts Payable » Reports » Print 1099s » Edit 1099s. 

2. On the Edit 1099s dialog box, take the following actions: 

 
 Year: Select the year for which you need to edit 1099 information. 

 Vendor: Select the vendor for whom you need to edit 1099 information. 

 Form 1099-: Select which form you want to edit:  
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Form Action 

1099-MISC 

 
 Print 1099: Select Default, Yes, or No from the drop-down list. 

Default will defer to the selection in Vendor Maintenance in the 
Print 1099 field. You can override that selection without changing 
it by changing the selection here. 

 Rents, Royalties, Other income, Gross proceeds paid to 
attorney: Payments made to this vendor will be placed into the 
field selected in the Box field in Vendor Maintenance. 

 Federal tax withheld, Fishing boat proceeds, Medical 
payments, Substitute payments, Crop insurance proceeds, 
Excess golden parachute, State Tax withheld, State Income: 
You may manually enter any amounts in these fields (State 
Income will populate automatically if a State Withholding Code is 
assigned to the vendor in Vendor Maintenance). 

 Direct sales > $5000 for resale: Check this box to indicate direct 
sales for resale on the 1099 form. 

 State/Payer's state no.: Enter the state or local tax number if any 
state or local tax payments were made on behalf of the vendor. 

1099-INT 

 
 Print 1099: Select Default, Yes, or No from the drop-down list. 

Default will defer to the selection in Vendor Maintenance in the 
Print 1099 field. You can override that selection without changing 
it by changing the selection here. 

 Interest income, Federal tax withheld, Tax-exempt interest, 
State Tax withheld: You may manually enter any amounts in 
these fields. 

 State/Payer's state no.: Enter the state or local tax number if any 
state or local tax interest payments were made on behalf of the 
vendor. 
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Form Action 

1099-NEC 

 
 Print 1099: Select Default, Yes, or No from the drop-down list. 

Default will defer to the selection in Vendor Maintenance in the 
Print 1099 field. You can override that selection without changing 
it by changing the selection here. 

 Nonemployee compensation, Federal tax withheld, State Tax 
withheld, State Income: You may manually enter any amounts in 
these fields (State Income will populate automatically if a State 
Withholding Code is assigned to the vendor in Vendor 
Maintenance). 

 State/Payer's state no.: Enter the state or local tax number if any 
state or local tax interest payments were made on behalf of the 
vendor. 

3. When finished making the appropriate edits, click OK to save the changes.  

Your changes will be used when printing the 1099s as long as you do not prepare your 1099s 
again. 

 

Printing the 1099s 
After you have edited and generated the 1099 report, you are now ready to print the actual 1099s.  

To print the 1099s: 
1. Select Accounts Payable » Reports » Print 1099s » Print 1099s. 

2. On the 1099s dialog box, take the following actions: 

 
 Year: Enter the year for which you want to print 1099s. 

Note: This only edits the 1099 printing. The vendor information and payment information history will 
not be changed through this process. 
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 For Form 1099-: Select which version of the 1099 you want to print and load the appropriate 
form into your printer. 

 Vendor...To: These fields are used to filter your 1099s by vendor. 

 Federal ID: Your company's federal ID; if entered into your Federal Tax Table in the Payroll 
Module, will automatically populate this field. 

 Truncate SSNs: If you have entered an SSN for the Tax ID for the vendor, select Yes if you 
would like to display only the last 4-digits of the SSN or No if you would like to display the 
entire SSN. 

 Printer: This will default to the printer you have selected as your Forms Printer under 
Configure » Configure User. You can press the F2 key or the ? key to select a different 
printer. 

3. Click OK. 

Printing the 1096 
After you have edited and generated the 1099 files, you will be able to print onto your 1096 form.  

To print the 1096: 
4. Select Accounts Payable » Reports » Print 1099s » Print 1096. 

5. On the Form 1096 dialog box, take the following actions: 

 
 Year: Enter the year for which you wish to print 1099s. 

 For Form 1099-: Select which version of the 1099 you want to print your 1096 to summarize; 
one 1096 form is required per type of 1099. 

 Name of person to contact: Enter the name of the person to contact at your company with 
questions about the return. 

 Telephone number: Enter the phone number of the person to contact at your company with 
questions about the return; this will default from your Company Information. 

 Fax number: Enter the fax number of the person to contact at your company with questions 
about the return; this will default from your Company Information. 

 Email address: Enter the email address of the person to contact at your company with 
questions about the return. 
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 Preaddressed form: Select Yes if you have a preaddressed form; this will prevent your 
company information from printing on the form. 

 Federal ID: Your company's federal ID; if entered into your Federal Tax Table in the Payroll 
Module it, will automatically populate this field. 

 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 
would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

6. Click OK. 

Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

Magnetic Media File 
To create a magnetic media file: 

1. From the Accounts Payable main menu, select Reports » Print 1099s/Magnetic Media File » 
Create Magnetic Media File. 

2. On the Step 1 tab of the Create Media File screen, take the following actions: 

 
 1099 Year: Enter the year for which you are reporting. This field defaults to the current tax 

year. 

 Create a Test File: Select this option only if you want to create a test file. 

3. On the Step 2 tab, take the following actions: 

 
 Federal ID: This field automatically populates with your Tax ID number assigned in your 

Company setup. 

 TCC: Enter your Transmitter Control Code. 

 Payer Name Control: Enter the Payer Name Control assigned to you.  
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 Contact Name: Enter the person's name that is the contact at your business.  

 Contact EMail: Enter the contact person's email address. 

 This is Final Filing: Select this check box if this is the final year for which you will be filing 
1099s. 

4. The Step 3 tab is for viewing only and will only have information in it if this is a revised file. 

 
5. Click Finish to create the magnetic media file. 

Payments by Locality 
To print the Payments by Locality report: 

1. From the Accounts Payable main menu, select Reports » Print 1099s » Payments by Locality 
Report.  
This report uses the Payroll Locality that is assigned in your jobs to generate the information. 

2. On the Payments by Locality dialog box, take the following actions: 

 
 Check Dates: Enter the date or date range for the payments that were issued. 

 Locals: Select the Local Tax Code or a range of Tax Codes. 

 Vendor Type: Select one of the following: Supplier, Subcontractor, Other, or All. 
 Vendors: Select a Vendor or a range of Vendors. 

 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 
would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

3. Click OK. 
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Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

Deleting old 1099s 
If you delete 1099 information for a year, you will have to re-prepare it in order to reprint your 1099 report 
or any 1099s from that year. If you have previously purged any Accounts Payable paid invoice data, you 
will not be able to re-prepare information for that year. 

To delete old 1099s: 
1. From Accounts Payable main menu, select Reports » Print 1099s » Delete old 1099s. 

2. On the Delete old 1099s dialog box, enter the last year in the Delete 1099 Information prior to 
field for which you want to keep information. 

 
The system will delete any prior years' information. 
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Final Processes 

Closing the General Ledger Fiscal Year 
If your fiscal year ends on December 31st, you will want to close your year around this time period. 

After you have completed all postings and journal entries for year end, you will need to close the last 
period. Using the information in the General Ledger System Parameters, ComputerEase will make the 
necessary adjustments to close your year accordingly. As the last period is closed, the balance for the 
following account types will be reset to zero to begin the new fiscal year: 

 Sales 

 Cost of Sales 

 Operating Expense 

 Other Income (Profit and Loss accounts).  

The balances for Assets, Liability, and Equity accounts (Balance Sheet accounts) will carry forward. 
ComputerEase will automatically make the journal entry to transfer the balance in the Current Retained 
Earnings account to the Prior Retained Earnings account. 

 
You can begin posting in the new fiscal year before closing the last year-end period, or you can close the 
year-end period by selecting Close Current Period from the General Ledger main menu and making 
your adjusting journal entries for the year at a later date. 

Reorganizing Files 

Optional Reorganizing of Files 
The following are a few optional tasks you may want to consider performing at the end of the year. These 
are not required functions. If you are unsure as to what the results will be on your company’s data, you 
can perform these functions in the Practice Company first. 

Accounts Payable 
 Clear Invoice Register: Deletes vouchers from the invoice register report. Select Accounts 

Payable » Clear Voucher Register. You can print a copy before clearing. 
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 Clear Check Register: Deletes checks from the check register report. Select Accounts Payable 
» Maintenance Programs » Clear Check Register. You can print a copy before clearing. 

 Delete Paid Vouchers: Deletes vouchers that have been paid prior to a specified date. You must 
first clear the Voucher Register and the Check Register, and the check that was used to pay 
the voucher must be marked as “reconciled” in the Bank Reconciliation Program in the General 
Ledger. Select Accounts Payable » Maintenance Programs » Delete Paid Vouchers. If you 
want to keep a permanent record of payments on vouchers, you can select Accounts Payable » 
Reports » Paid Voucher Report and print the vouchers you are going to delete. 

Accounts Receivable 
 Delete Paid Invoices: Deletes all paid invoices in the customer’s file. Select Accounts 

Receivable » Maintenance Programs » Reorganize Files » Delete paid invoices. You can 
print a Customer Receivable Inquiry if you want to have a permanent record of invoices that have 
been paid. 

 Reorganize Sales Register: Deletes all invoices for a given date range from the Sales Register 
Report. Select Accounts Receivable » Maintenance Programs » Reorganize Files » 
Reorganize Sales Register. If you want to have a permanent record of your Sales Register, 
make sure you have a printed copy of your Sales Register before running this utility. 

 Reorganize Cash Summary Register: Deletes cash receipts from the cash summary register 
report for a given date range. Select Accounts Receivable » Maintenance Programs » 
Reorganize Files » Reorganize Cash Summary Register. If you want to have a permanent 
record of your Cash Receipts, make sure you have a printed copy of your Cash Summary 
Register before running this utility. 

 Reorganize Retention File: Removes paid retention invoices from the system. Select Accounts 
Receivable » Maintenance Programs » Reorganize Files » Select Reorganize Retention 
File. If you want to have a permanent record of your Billed Retention, make sure you have a 
printed a copy of your Retention Due Report before running this utility. 

 Reorganize Freeform Invoice File: Deletes invoice detail of freeform invoices that have been 
billed and paid. Select Accounts Receivable » Maintenance Programs » Reorganize Files » 
Reorganize Freeform Invoice File. You will not be able to reprint any freeform invoices that are 
deleted, so you may want to print copies of any invoices before running this utility. 

Inventory Control 
 Reorganize Inventory Transaction File: Clears inventory transaction history that occurred 

before a given date. Select Inventory Control » Maintenance Programs » Reorganize 
Inventory Transaction File. This will delete all transactions and history as of a specified date. 
Make sure all necessary reports have been generated before performing this step. 

 Reorganize Purchase Order Balance Report: Clears the purchase order balance report for the 
specified date. Select Inventory Control » Maintenance Programs » Reorganize Purchase 
Order Balance Report. 

 Reorganize Purchase Order File: Deletes purchase orders for the specified date. Select 
Inventory Control » Maintenance Programs » Reorganize Purchase Order File. 
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Payroll System 
 Delete Old Data: This screen is used to delete payroll data and can be used to reorganize 

several files at once. 

 
Select the items that you want to delete data for by choosing the Keep For option that applies. 
After you make your selections and click OK, a screen displays that allows you to verify that you 
chose the correct selections for the information you want to delete. 

 

Subcontract Agreements 

This feature should be used with great caution, as once a subcontract agreement is deleted, it 
cannot be restored without restoring from a full backup. Please ensure that you printed or saved a 
hard copy of all agreements and reports before using this feature. It is strongly recommended that 
all relevant subcontracts have no balance remaining before selecting the criteria to permanently 
delete them.  

 Delete Multiple Subcontracts: This feature allows you to delete multiple subcontracts from one 
place without having to access each subcontract individually. Select Subcontract > 
Maintenance Programs > Delete Multiple Subcontracts. 
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Job Costing System 

This feature should be used with great caution, as once a job is deleted, it cannot be restored without 
restoring from a full backup. The job cannot be retrieved without a great deal of time-consuming work 
once it has been deleted. A backup of the data is critical before deleting a job. All pertinent Job Cost 
reports should be generated for future reference before deleting a job. Deleting a job also removes that 
job’s phases, categories and all associated detail. This information will no longer be accessible. 

 Delete Multiple Jobs: This feature allows you to delete multiple jobs from one place without 
having to access each job individually. Select Job Costing System > Job Maintenance > 
Delete Multiple Jobs. 

 
On the left side of the screen, the job(s) that you selected will be listed. A check mark appears 
next to each job that will be deleted if you check it and choose "Delete." Check any items you 
want to delete at this time. You will receive any relevant warnings as you select each job, 
including any that will prevent you from deleting the job (unbilled retention, unposted labor, 
unbilled AIA/Unit invoicing, for example). 

 

Purchasing & Inventory 

You should ensure there are no quantities outstanding for any items or on any POs you want to delete. 
Please ensure that you printed or saved a hard copy of all reports before using this feature. 

 Reorganize Inventory transaction File: This will remove the detailed inventory item 
transactions. Select Purchasing & Inventory > Maintenance Programs > Reorganize 
Inventory Transaction File. 

  
 Reorganize Purchase Order Balance Report: clears the purchase order balance report for the 

specified date. For deleting Purchase Orders, select to Cancel A Purchase Order for each 
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Purchase Order that needs to be deleted. Select Purchasing & Inventory > Maintenance 
Programs >Reorganize Purchase Order Balance Report. 

 Reorganize Purchase Order File: This will remove POs that have been completely received & 
invoiced. Select Purchasing & Inventory > Maintenance Programs >Reorganize Purchase 
Order File. 

Fleet & Assets – Equipment Costing 

The Reorganize Detail option in Equipment Cost Detail Maintenance allows you to reorganize old detail 
records and group similar records together into Monthly Totals. Please ensure that you printed or saved a 
hard copy of all reports before using this feature. If you reorganize detail prior to January 1, 2015, then for 
any month prior to January 1, 2015 that had more than one detail record for a piece of equipment, on 
your detailed cost report you will see a line for the last date of that month with activity and the phrase 
"Month Totals" with the total of all detail entries for that month in lieu of each detail entry. 

 Reorganize Detail: This option in Equipment Cost Detail Maintenance allows you to reorganize 
old detail records and group similar records together into Monthly Totals. Select Fleet & Assets > 
Maintenance Programs > Equipment Cost Detail Maintenance > Reorganize Detail. 

 
 Equipment Cost Detail Maintenance: This program will delete equipment revenue detail 

information. Select Fleet & Assets >Maintenance Programs > Equipment Cost Detail 
Maintenance > Change Detail. Select the applicable equipment code & the applicable revenue 
type codes. Select each applicable transaction & select File > Delete to delete the record.  

 Equipment Code Maintenance: Select to delete any Codes that will not be used in the next year 
and that have no current activity. Select Fleet & Assets >Maintenance Programs > Equipment 
Code Maintenance. Select the applicable Code and select File >Delete to delete the Code.  

 Equipment Maintenance: Select to delete any Equipment that will not be used in the next year 
and that has no current activity. Select Fleet & Assets >Maintenance Programs > Equipment 
Maintenance. Select the applicable Equipment and select File>Delete to delete the Equipment. 

Service Management 

This program will delete completed work orders and service history up to the date specified. Please 
ensure that you printed or saved a hard copy of all reports before using this feature. 

 Delete Completed Word Orders: Choose the first date for which you want to keep completed 
orders. All work orders completed prior to this date will be purged. Select Service Management 
> Maintenance Programs> Delete Completed Work Orders. 

• Remove Service History: This program will delete service history up to the date specified. Select 
Service Management > Maintenance Programs> Remove Service History. Choose the first 
date for which you want to keep service history. Choose a site if you want to remove history just 
for one site. To purge the history for one piece of equipment, choose that equipment or leave 
blank for all. Check the Deleted Work Orders Only box to only remove service history for orders 
that have been deleted. Check the Delete Equipment History box to delete equipment history in 
addition to site history. Check the Delete Non-Equipment History box to delete non-equipment 
history. 
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General Ledger 
Note: This option should be chosen with care. Once you perform this feature, the data for the 
selected period will be irrevocably lost and reports may no longer be run for that period. The only 
time this option should be exercised is if space is needed on your hard drive and/or you are absolutely 
sure that you do not require a period’s data any longer. Even if either of these situations is true, you 
should always perform a backup before choosing to Delete Old Data. It is also recommended that you 
print hard copies of all reports for years for which data will be deleted. 

 Delete Old Data: Select General Ledger > Delete Old Data. 

Running DOCTOR 
Final Steps for Reorganizing Data Files: Once all reorganizing steps are complete, you will need to log 
into DOCTOR from your ComputerEase login screen and select Settings. Check the Remove deleted 
records while testing box. 

 
After selecting OK, select “Check Data Files”, select the appropriate company number, and run for “All 
Systems”. If errors populate, you may “Ignore” all un-linked records and can “Fix” any invalid data errors. 
If any other errors populate, please contact our support department to determine how to proceed. * If you 
choose the wrong option, this could have a negative impact on your data files. * You may need to 
submit a support case to complete this option. 
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Preparing for ACA Reporting 

Preparing Your Data 

Getting Prepared 
To satisfy ACA filing requirements, you may want to start compiling all of the information you will need for 
entering into ComputerEase, making the transition as seamless as possible. 

Firstly, you will need to define your insurance plan or plans. For all offered plan(s), you will need to know 
the start dates, the minimum coverage offered, and the premiums for all levels of coverage for each 
category of coverage. 

Secondly, you will want to define the following: your standard measurement period (when it begins and 
ends) and your standard stability period (when it begins and ends). 

Thirdly, you will need to categorize each employee as full-time, part-time, or variable hourly and the date 
that status took effect. 

In addition to the information you should already have on file for your employees (name, SSN, address, 
and phone number), you will need to know which plan(s) they were offered for each month (this 
information may be the same for all months). This information is reported on form 1095-C on line 14 and 
is categorized by “Offer Code”. 

Lastly, you will need to know the employee share of the lowest cost monthly premium for self-only 
minimum value coverage as well as if any Section 4980H safe harbor codes can be applied in any month 
during the year, for each employee. 

Future Developments 
For the latest information about developments related to Form 1094-C (Transmittal of Employer-Provided 
Health Insurance Offer and Coverage Information Returns), Form 1095-C (Employer-Provided Health 
Insurance Offer and Coverage), and instructions (such as legislation enacted after they were published), 
go to https://www.irs.gov/pub/irs-pdf/i109495c.pdf. 

Entering Your Data 

Creating Categories 
You need to create at least one ACA Category in ComputerEase. The ACA Category is used to track the 
standard measurement period information. If you only have one standard measurement period, which will 
be typical for most companies, then you will only need one ACA category. 

To create an ACA category: 
1. From the Payroll System main menu, select Maintenance Programs » ACA Maintenance » 

Edit ACA Categories. 

2. On the Edit ACA Categories dialog box, enter the Category Code and click OK. 

Enter a category code up to 12 alphanumeric characters to define your ACA category. 

https://www.irs.gov/pub/irs-pdf/i109495c.pdf
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3. On the ACA Cat dialog box, enter a Description for your ACA category. 

 
4. In the Measure Start Date column, double-click the row with (new) to create a new measurement 

period associated with this ACA category. 

5. On the Category Information dialog box, take the following actions: 

 
 Standard Measurement Period Start Date: Enter the start date of your standard 

measurement period. 

 
 Standard Measurement Period Length: Enter the length of your standard measurement 

period in months. 

 
 Standard Measurement Period End Date: This field will automatically populate with the 

calculated end date of your standard measurement period. 

Note: This is the date that you want to start tracking ongoing variable hours employees’ 
hours. An ongoing employee is an employee that has been employed for at least one 
complete standard measurement period. 

Note: The period is used to determine if variable hour or part time employees are full 
time. This is typically 3-12 months. 
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 Standard Administrative Period Length: Enter the length of your standard administrative 
period in months. This is the period of time between the time that your standard 
measurement period ends and your stability period begins. 

 
 Stability Period Start Date: This field will automatically fill with the calculated start date of 

your stability period based on data entered above. 

 
For employees who were full-time during the Standard Measurement Period, the Standard 
Stability Period must be at least six consecutive calendar months and cannot be shorter than 
the Measurement Period. 

For example, if the Standard Measurement Period is 12 months, the Standard Stability Period 
must be at least 12 months. If the Standard Measurement Period is only six months, the 
Standard Stability Period must be at least six months. Even if the Standard Measurement 
Period was only three months, the Standard Stability Period must be at least six months. 

For employees who were part-time during the Measurement Period, the Stability Period 
cannot be longer than the Measurement Period. The six-month and 12-month examples 
above would be the same for both part-time and full-time employees, but if the Standard 
Measurement Period was only three months, the Standard Stability Period for part-time 
employees could not be more than three months. 

 Stability Period End Date: This field will automatically populate with the calculated end date 
of your stability period based on data entered above. 

 Initial Measurement Period Length: Enter the length of your initial measurement period in 
months. 

 
 Initial Administrative Period Length: Enter the length of your initial administrative period in 

months. 

Note: The purpose of the Standard Administrative Period is to allow employers time to 
total and average the hours of service of each employee during the Standard 
Measurement Period, notify eligible employees, explain coverage available under the 
plan, answer questions, collect materials from employees, and enroll employees who 
elect coverage before day one of the Standard Stability Period. The Standard 
Administrative Period may not exceed 90 days, which may in practice be the first of the 
month following two months. It may not cause a gap in coverage, and it may not reduce 
or lengthen the Standard Measurement or Standard Stability Periods. 

Note: Employees who worked on average at least 30 hours per week or at least 130 
hours per month during the Measurement Period (that is, were full time) should be 
offered health coverage for the entire Standard Stability Period, regardless of the hours 
they actually worked during the Standard Stability Period (unless they cease to be 
employed by the employer). 

Note: For newly hired employees who are not reasonably expected to be full-time on the 
date of hire, the initial measurement period applies until they become ongoing employees. 
The initial measurement period begins on the date of hire or the first day of the next 
month. 
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Each time your measurement period is renewed, you need to edit your category and double-click on the 
(new) row to add new information. The information will populate, based on information entered 
previously. (The assumption is that your standard measurement period, stability period and administrative 
period will remain unchanged and your new start dates will be based on the end of the old.) You only 
need to make changes if you decide on administrative changes. 

Creating Plans 
You need to create at least one ACA Plan in ComputerEase. The ACA Plan is used to track the start date 
of your plan and the employee share of the lowest cost monthly premium for self-only minimum value 
coverage. You need to create one plan for each combination of these two that you have. If you have two 
separate plans that you offer to different employee groups even if they begin on the same date, you will 
need to create two plans in ComputerEase. 

To create an ACA plan: 
1. From the Payroll System main menu, select Maintenance Programs » ACA Maintenance » 

Edit ACA Plans. 

2. On the Edit ACA Plans dialog box, enter a Plan Code, and click OK. 

You can enter up to 12 alphanumeric characters to define you ACA Plan. 

 
3. On the ACA Plan dialog box, enter a Description for your plan. 

4. In the Start Date column, double-click on the (new) row to define your plan. 

 
1. On the Plan Information dialog box, take the following actions: 

 
 Beginning on: Enter the start date of the plan. 

Note: The period length cannot exceed 90 days. The total combined time of the Initial 
Administrative Period and the Initial Measurement Period cannot exceed 13 months plus 
a portion of another month. 
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 Employee Share of Lowest Cost Monthly Premium for Self-Only Minimum Value 
Coverage: Enter the amount of the employee share for the lowest-cost, self-only, minimum 
essential coverage providing minimum value that is offered to the employee. 

Each time the plan is renewed, you will need to edit the plan and double-click on the "(new)" row to add a 
renewal to the plan with a new start date and new employee share of premium. 

Entering Employee Information 
If you are an ALE, you will need to enter some additional information for each employee in order to report 
this information from ComputerEase. 

To enter employee information: 
1. From the Payroll System main menu, select Maintenance Programs » ACA Maintenance » 

Edit Employee ACA Information. 

2. On the Edit Employee ACA Information dialog box, select the Employee for whom you want to 
edit ACA Information, and click OK. 

 
3. On the Status and History tab, take the following actions: 

 
 New Employment Status: Click this button to add a new status at any time. If an employee 

changes status from full-time to part-time or vice-versa, select this option to add a new status. 

 New Plan: Click this button to add a new ACA Plan (with a new effective date). 

 New Category: Click this button to add a new ACA Category for this employee (with a new 
effective date). 

 Edit Current Selection: Click this button to edit the highlighted selection in the field above. 
After the update introducing the ACA changes, all employees were set to a status of No ACA 
with an effective date of 1/1/2015. To change this and set their status as of 1/1/2015, either 
double-click on that entry or select this button to display the Initial Setup dialog box. 

 On the Initial Setup dialog box, take the following actions: 
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 Category: Select the category that applies to this employee. This will define the 

stability period and measurement period for your variable hour employees. 

 Plan: Select the plan that applies to this employee. 

 Employment Type: Select the employment type that applies to this employee. If you 
are not an ALE, then No ACA would apply for all; otherwise, select Full-Time, Part-
Time, or Variable Hour. 

 Effective Date: Enter the date on which the information entered above became 
effective. Any time there is a change to the information above, you must enter new 
information here. 

 Look-Back Start: This information displays only if an employee is classified as 
Variable Hour. It is calculated based on the information entered above. This is the 
start date of the look-back period for this employee. It should be one month after the 
effective date. 

 Look-Back End: This information displays only if an employee is classified as 
Variable Hour. It is calculated based on the information entered above. This is the 
end date of the look-back period for this employee. It should be the end date of the 
standard measurement period of the employee's class/category. 

 Look-Back Status: Select what you believe this employee's status to be at this time. 
The choices are Full Time, Part Time, or Unknown. At the end of the Look-Back 
Period, you will be able to use the ACA Variable Hour Employee Status Report to 
help determine the employee's calculated status. 

 Delete Current Selection: Click this button to remove the highlighted status in the field 
above. 

4. On the Offer of Coverage tab, take the following actions: 

 
 Year: This should default to the current year; you can change this to the year for which you 

want to enter data. 
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 OoC Code: Choose the applicable Offer of Coverage code for each month; the code you 
choose for each month will automatically populate each month following. This will populate 
Form 1095-C, line 14 for this employee. 

 Safe Harbor Code: Choose the applicable section 4980H Safe Harbor code for each month; 
the code you choose for each month will automatically populate each month following. This 
will populate Form 1095-C, line 16 for this employee. If you need assistance refer to the 
flowchart. 

 Zip Code: For OoC codes of 1L, 1M or 1N, enter the employee's primary residence zip code. 
For OoC codes of 1O, 1P or 1Q, enter the employee's primary employment zip code 
affordability safe harbor. 

 
5. On the Covered Individuals tab, take the following actions: 

 
 Year: This field defaults to the current year. You can change this to the year for which you 

want to enter data. 

 Employer provided self-insured coverage: Select this check box if you provided self-
insured coverage. Enter the first name, middle name, last name, name suffix, S.S.N., and 
birth date for each individual covered for this employee. Then select the check box(es) 
corresponding to the month(s) they were covered. 

ACA Reports 

ACA FTE Count Report 
The ACA FTE Count Report is designed to help you determine the number of Full Time and Full Time 
Equivalent Employees you employ during a given time period. Each calendar year, this report can help 

Tip: You can use your mouse to navigate and the drop-down to select the code in each 
month. Or you can use the TAB key and/or arrow keys on your keyboard to move between 
the code fields per month and select the applicable codes by selecting the letter 
corresponding to each code. For example, to select the Offer of Coverage code 1B for 
January and February and 1C for all other months, press TAB until January is highlighted and 
press B on your keyboard. Then TAB or arrow to March and press C on your keyboard. In 
order to revert a selection to the code in the field above, press DELETE on your keyboard. 
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you determine your ALE status. It can also help you determine each employee's full-time or part-time 
status. Unlike other payroll reports which are based on pay date, this report is based on work date. If you 
do not enter the date worked (for example, for salaried employees), this will be estimated based on 
payroll ending date. 

To run the ACA FTE Count Report: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » ACA 

FTE Count. 
2. On the ACA FTE Count Report dialog box, take following actions: 

 
 Ending Month: Enter the month through which you want to run the report. 

 Months: Enter the number of months for which you want to report your hours. 

 Detail or Summary: Select Detail if you want to see each employee listed with the number 
of hours worked per month. Select Summary if you just want to see a count of total full time 
and full-time equivalent employees. 

 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 
would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

3. Click OK. 

Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

For the purposes of counting full time employees, the ACA defines any employee who works at least 130 
hours per month as full time. However, when calculating full time equivalent employees, only the first 120 
hours an employee works is used when calculating FTEs. For all employees working less than 130 hours 
in a month, all hours less than 120 per employee are totaled and divided by 120 to determine the number 
of full-time equivalent employees that those employees represent when determining whether or not your 
business is an ALE. 

ACA Variable Hour Employee Status Report 
This report is designed to help you determine the status of any variable hour employees at the end of the 
measurement period. 

To run the ACA Variable Hour Employee Status Report: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » ACA 

Variable Hour Employee Status. 

2. On the ACA Variable Hour Status Report dialog box, take the following actions: 
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 As Of: Enter the date through which you want to report weekly average hours and calculated 

status for each variable hour employee. 

 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 
would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

3. Click OK. 

Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

ACA Employee Type 
This report is used to determine how each employee is currently classified for ACA reporting purposes. 

To run the ACA Employee Type Report: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » ACA 

Employee Type. 

2. On the ACA Employee Type Report dialog box, take the following actions: 

 
 As Of: Enter the date through which you want to report the ACA status for each employee; 

note that employee status can change. 

 Employees: Select an employee or employees to report on or leave blank to report on all 
employees. 

 Status: Select Active, Inactive, or All. 
 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 

would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

3. Click OK. 

Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

Printing the 1094-C Form 
The 1094-C Form is the cover sheet for the 1095-C forms that you furnish to the IRS. 
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To print the 1094-C form: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » Print 

1094-C Form. 

2. On the Print 1094-C dialog box, enter the year for which you want to print the 1094-C, and click 
OK. 

 
This field defaults to the current year. 

3. On the Parts I and II tab, take the following actions: 

 
 Contact Name: Enter the name of the contact for the form 1095-C. 

 Number of Forms 1095-C submitted with this form: This will default to the number of 
forms calculated based on ALE information entered. You can change it if you intend to submit 
a different number of 1095-C forms to the IRS. 

 Is this the authoritative transmittal: Each company must send one authoritative transmittal; 
if you are filing multiple 1094-C forms, you should choose Yes only when the form you are 
printing is the authoritative transmittal. 

 Total Number of Forms 1095-C filed: This will default to the total number of forms 
calculated based on ALE information entered. You can change it if you have filed a different 
number of 1095-C forms. 

 Member of Aggregated ALE Group: Choose Yes if you are a member of an aggregated 
group; that is, if this company is one of multiple companies that are combined and treated as 
one company for the purposes of determining ALE status per the IRS code. 

 Certifications of Eligibility: Check the appropriate boxes as they apply: Qualifying Offer 
Method, Qualifying Offer Method Transition Relief, Section 4980H Transition Relief, 
and/or 98% Offer Method. Used to completed line 22 of Part II of the 1094-C. 
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4. On the Part III tab, take the following actions: 

 
 Minimal Essential Coverage Offer: Choose Yes or No; did you offer minimal essential 

coverage either for "All 12 Months" or the appropriate response for each month if different by 
month. 

 Full-Time Employee Count: This field will populate with the full-time employee count based 
on information entered into ComputerEase. If your data differs (for example, if you did your 
payroll for part of the year outside of ComputerEase), you can change it per month here. 

 Total Employee Count: This field will populate with the total employee count (full and part-
time) based on information entered into ComputerEase. If your data differs (for example, if 
you did your payroll for part of the year outside of ComputerEase), you can change it per 
month here. 

 Aggregated Group Indicator: If you indicated on the first tab that you are a member of an 
aggregated ALE group, you can check the box indicating that you were a member of that 
group either for "All 12 Months" or per month if different by month. 

 Section 4980H Transition Relief Indicator: If you selected on the first tab that you are 
eligible for Section 4980H Transition Relief, enter the appropriate code either for "All 12 
Months" or per month if different by month; applicable codes are A if eligible for the 50 to 99 
Relief or B if eligible for the 100 or More Relief. 

 

Note: Qualifying Offer Method Transition Relief and Section 4980H Transition Relief are 
no longer available for 2017 and 2019. 

Attention: Visit https://www.irs.gov/affordable-care-act/employers/questions-and-answers-
on-reporting-of-offers-of- health-insurance-coverage-by-employers-section-6056 for more 
information on methods of reporting. 

Note: 4980H Transition Relief is no longer available after 2016. 

https://www.irs.gov/affordable-care-act/employers/questions-and-answers-on-reporting-of-offers-of-%20health-insurance-coverage-by-employers-section-6056
https://www.irs.gov/affordable-care-act/employers/questions-and-answers-on-reporting-of-offers-of-%20health-insurance-coverage-by-employers-section-6056
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5. On the Part IV tab, take the following actions: 

 
If you selected that you are a member of an aggregated ALE group on the Parts I & II tab, you 
need to fill out this section. List the other members of the aggregated group in descending order, 
starting with the member with the highest average monthly number of full-time employees. If there 
are more than 30 members of the aggregated ALE group, only enter the 30 with the highest 
monthly average number of full-time employees. 
 Name: Enter the name of the aggregated group member. 

 EIN: Enter the EIN for the aggregated group member. 

Printing the 1095-C Forms 
ComputerEase prints the completed 1095-C forms using information entered into the ACA Maintenance 
programs (with the exception of Part III). 

To print the 1095-C forms: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » Print 

1095-C Forms. 

2. On the 1095-C Forms dialog box, take the following actions: 

 
 Year: Enter the year for which you want to print the 1095-C forms. This field defaults to the 

current year. 

 Include Instructions: Select Yes to print the instructions for each form or select No to print 
only the form. 

 Show S.S.N.: Select Yes to display the full S.S.N. on each 1095-C, or select No to hide the 
first 5-digits of the S.S.N. 

 Employees: Select an employee or employees or leave blank to print forms for all 
employees. 
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 Send Report To: Select Printer, Display, Email, or Clipboard depending on what you 
would like to do with this report.  

 Printer: If you are printing the report, select the appropriate printer in this field.  

3. Click OK. 

Depending on your selection in the Send Report To field, the report will print, display, or 
generate an email or a pdf on the clipboard. 

If any employees with a status other than No ACA during the year indicated are missing any necessary 
information, a page will print indicating any errors (such as missing Offer of Coverage codes). Correct the 
errors prior to printing your forms. Keep in mind when reviewing forms that line 15 will only have a value 
for line 14 values of 1B, 1C, 1D or 1E. 

Upload 1095-C Forms to Employee Hub 
If you own the Employee Hub module, you may wish to upload the 1095-C Forms to the Employee Hub 
website. 

To upload 1095-C forms to the Employee Hub: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » 

Upload 1095-C Forms to Employee Hub. 

2. On the Upload 1095-C Forms dialog box, enter the Year for which you want to upload 1095-C 
forms to the Employee Hub, and click OK. 

 
3. On the 1095-C Forms dialog box, take the following actions: 

 
 Show S.S.N.: Select Yes to display the full S.S.N. on each 1095-C, or select No to hide the 

first 5-digits of the S.S.N. 

 Employees: Select an employee or employees or leave blank to print forms for all 
employees. 

4. Click OK. 

If any employees with a status other than No ACA during the year indicated are missing any necessary 
information, a page will print indicating any errors (such as missing Offer of Coverage codes). Correct the 
errors prior to printing your forms. Keep in mind when reviewing forms that line 15 will only have a value 
for line 14 values of 1B, 1C, 1D or 1E. 

Exporting the 1094-C/1095-C Information 
An employer filing 250 or more Forms 1095-C is required to file forms 1094-C and 1095-C electronically. 
An employer filing fewer than 250 Forms 1095-C may choose to file electronically or on paper. Electronic 
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filers must use the ACA Information Return System (AIR). According to IRS Publication 5164 and 
Publication 5165, an employer should: 

 Determine the responsible individuals and contacts who will handle the electronic filing. 

 Register with e-services. 

 Complete an Application for Transmitter Control Code (TCC) if the employer acts as an issuer, a 
software developer and/or a transmitter. 

 Conduct ACA Assurance Testing System (AATS) testing. 

 

To export your 1094-C/1095-C information: 
1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » 

Export 1094-C/1095-C Information. 

2. On the Export 1094-C/1095-C Information dialog box, enter the Year for which you want to export 
the 1094-C/1095-C information, and click OK. 

 
This field defaults to the current year. 

3. On the dialog box that displays, click the Make Test File button if this is your first tab year to 
electronically file your ACA information. 

 
If you conducted ACA Assurance System (AATS) testing in a previous tax year, you do not need 
to make a test file again. Skip forward to step 6.  

4. On the Export 1094-C/1095-C dialog box, enter the transmitter control code (TCC) you were 
assigned by the IRS. 

 
5. Click OK. 

Two files (a 1094-C manifest file and a 1094-C request file) will be sent to the clipboard. Save 
these two files and upload them to the ACA Information Return System (AIR). 

Note: If you electronically submitted your ACA information the previous tax year, you do not need to 
go through these above steps again. 

https://www.irs.gov/e-file-providers/affordable-care-act-information-returns-air
https://www.irs.gov/e-services
https://www.irs.gov/e-file-providers/affordable-care-act-information-returns-air
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6. Click the Prepare button to prepare your data for export. 

 
7. On the Parts 1 and II tab, take the following actions: 

 
 Contact Name: Enter the name of the contact for the form 1095-C. 

 Number of Forms 1095-C submitted with this form: This will default to the number of 
forms calculated based on ALE information entered. You can change it if you intend to submit 
a different number of 1095- C forms to the IRS. 

 Is this the authoritative transmittal: Each company must send one authoritative transmittal; 
if you are filing multiple 1094-C forms, you should choose Yes only when the form you are 
printing is the authoritative transmittal. 

 Total Number of Forms 1095-C filed: This will default to the total number of forms 
calculated based on ALE information entered. You can change it if you have filed a different 
number of 1095-C forms. 

 Member of Aggregated ALE Group: Choose Yes if you are a member of an aggregated 
group; that is, if this company is one of multiple companies that are combined and treated as 
one company for the purposes of determining ALE status per the IRS code. 

 Certifications of Eligibility: Check the appropriate boxes as they apply: Qualifying Offer 
Method, Qualifying Offer Method Transition Relief, Section 4980H Transition Relief, 
and/or 98% Offer Method. Used to completed line 22 of Part II of the 1094-C. 

 

Note: It will typically take 48 hours or more for the IRS to approve your test file submission 
and move your transmitter control code (TCC) from test status to production status. Do not 
attempt to upload to the production portion of the ACA Information Return System (AIR) until 
this occurs. 

Note: Qualifying Offer Method Transition Relief and Section 4980H Transition Relief are 
no longer available in 2017 and 2019. 

https://www.irs.gov/e-file-providers/affordable-care-act-information-returns-air
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8. On the Part III tab, take the following actions: 

 
 Minimal Essential Coverage Offer: Choose Yes or No; did you offer minimal essential 

coverage either for "All 12 Months" or the appropriate response for each month if different by 
month. 

 Full-Time Employee Count: This field will populate with the full-time employee count based 
on information entered into ComputerEase. If your data differs (for example, if you did your 
payroll for part of the year outside of ComputerEase), you can change it per month here. 

 Total Employee Count: This field will populate with the total employee count (full and part-
time) based on information entered into ComputerEase. If your data differs (for example, if 
you did your payroll for part of the year outside of ComputerEase), you can change it per 
month here. 

 Aggregated Group Indicator: If you indicated on the first tab that you are a member of an 
aggregated ALE group, you can check the box indicating that you were a member of that 
group either for "All 12 Months" or per month if different by month. 

 Section 4980H Transition Relief Indicator: If you selected on the first tab that you are 
eligible for Section 4980H Transition Relief, enter the appropriate code either for "All 12 
Months" or per month if different by month; applicable codes are A if eligible for the 50 to 99 
Relief or B if eligible for the 100 or More Relief. 

 
On the Part IV tab, take the following actions: 

Attention: Visit https://www.irs.gov/affordable-care-act/employers/questions-and-answers-
on-reporting-of-offers-of-health-insurance-coverage-by-employers-section-6056 for more 
information on methods of reporting. 

Note: 4980H Transition Relief is no longer available after 2016. 

https://www.irs.gov/affordable-care-act/employers/questions-and-answers-on-reporting-of-offers-of-health-insurance-coverage-by-employers-section-6056
https://www.irs.gov/affordable-care-act/employers/questions-and-answers-on-reporting-of-offers-of-health-insurance-coverage-by-employers-section-6056


Preparing for ACA Reporting 

2021 Year-End Manual 56 

 

 
If you selected that you are a member of an aggregated ALE group on the Parts I & II tab, you 
need to fill out this section. List the other members of the aggregated group in descending order, 
starting with the member with the highest average monthly number of full-time employees. If there 
are more than 30 members of the aggregated ALE group, only enter the 30 with the highest 
monthly average number of full-time employees. 
 Name: Enter the name of the aggregated group member. 

 EIN: Enter the EIN for the aggregated group member. 

9. Click OK after you've completed the applicable fields in Parts I through IV. 

10. On the dialog box that displays, take the following actions: 

 
 Reprepare: Click this button to reprepare the data. 

 Delete: Click this button to delete the prepared data. 

 Export: Click this button to export the data so it can be submitted.  

On the Export 1094-C/1095-C dialog box, enter the Transmitter Control Code you were 
assigned by the IRS. 

 
Two files will be generated and sent to the clipboard (a 1094-C manifest file and a 1094-C 
request file). Save these two files and upload them to the ACA Information Return System 
(AIR). 

11. After submitting the files to the ACA Information Return System (AIR), click Enter Receipt. 

 

https://www.irs.gov/e-file-providers/affordable-care-act-information-returns-air
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12. On the Enter Receipt ID dialog box, enter the Receipt ID, and click OK. 

 
13. After submitting your manifest and request files, check AIR website to a status update for your 

submission. 

 
14. When you have the status from the AIT website, click Update Status. 

 
15. On the Submission Status dialog box, select the status and click OK. 

 
By default, the submission status will be in processing. The IRS will provide one of three submit 
statuses; Accepted, Accepted with errors, or Rejected. 

Status Result 

Accepted (no errors) If your submission was accepted with no errors, you have completed 
the process and will see following screen when you click OK.  

 
Although you have completed the process, you will still have an 
opportunity to correct the 1094-C and 1095-C(s) if you need to. 

Accepted with errors If your submission was accepted with errors, you will see this screen 
when you click OK. 

Note: It may take a few hours or more for the IRS to provide a status update. 
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Status Result 

 
 View Errors: You can download the error file from the AIR 

website and enter its location on this screen to view the errors. 

 
 Correct 1094: Allows you to make changes to the 1094-C and 

export a corrected file. 

 Correct 1095(s): Allows you to make changes to the 1095-C 
and export a corrected file. 

 

Rejected If you receive a rejected status, you will see this screen after clicking 
OK.  

 
You will need to re-prepare your data and export again. 

 

 

 

 

Note: After the corrected files are uploaded, you will need to 
enter a receipt id and then update the status. 

Note: After the replacement files are uploaded, you will need 
to enter a receipt id and then update the status. 



 

 

About Deltek 
Better software means better projects. Deltek delivers software and information solutions that enable 
superior levels of project intelligence, management and collaboration. Our industry-focused expertise 
makes your projects successful and helps you achieve performance that maximizes productivity and 
revenue. www.deltek.com 

 

http://www.deltek.com/
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