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Introduction

Introduction

This guide explains the steps on how to extend a report. Before reading this guide, refer to the Deltek
Costpoint Extensibility Designer User Guide on how to navigate the Designer and basic steps in
extending a Costpoint component. The extensible components include Result Set, Action, Report,
Messages, Constants, and Application Title. Extending a report involves several interconnected
components.

At a high level, extending a report involves the following steps.

Step | Description

1 Create a report extension using the Extensibility Designer

2 Extend the reporting data result set (if additional data is to be shown in the report)

3 Extend the java classes that populate the reporting data (if data was constructed with
the help of java code)

4 Modify the report template used for such report

5 Deploy the extensibility unit to the system the same way as done for other components

Some of the steps are optional depending on how the report is implemented by Deltek and the extent
of the change.

Extensibility Designer Report Guide 1
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Standard Components of a Costpoint Report

Before you extend or customize a Costpoint report, you must first understand the standard
components of a Costpoint report and how they are linked together. This will help you identify which
components you need to extend for a report.

Report Components

The following are the standard components of a report.

Report application

Report parameter result set

Report definition (and Java classes that populate the data for the report)
Data source result set (with Select SQL)

Report template

Report Application

Report Parameter
Result Set

Report Report Definition Java Class (via
Template Action)

Data Source Result Set Select SOL

Extensibility Designer Report Guide 2
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Report Application

An application is the top level component that acts as the container to the screens inside the
application. It does not contain any logic. Ul and business logics are done entirely in the screens
(result sets) and the java classes that supports them. You can only extend an application by changing
its application name.

To view a list of all available applications in Costpoint, refer to the Apps folder of the
Extensibility Designer’s Object Explorer. These applications are sorted by application ID.

If you know the name of the application but not the application ID, open the application in
Costpoint and then go to the View Help About screen (Administration » System
Administration » System Administration Reports/Inquiries Help » About Costpoint). The
application is listed on the Open Applications table window with its application ID.

Report Parameter Result Set

A report parameter result set is the screen where the user selects various options to run the report. It
is assigned underneath an application. In the example below, CPRCUST_PARAM is the parameter
result set assigned to the Print Customer List application.

Deltek Costpoint Application Extensibility Designer 7.0.1 - CZ01RDO - o] x|
Object Link View Extensions Tools Help
J Dl'lﬁl'}(lsgn xl'l y|| '@l'l"@l"{f” Top Level Fiter Iarrc ﬂ

| Modules =

. Apps (Filtered "harrct’)
& 5L ARRCR ( Frint Cash Receipts Edit Report )

o=
E‘"'

RiEZRCPRCUST PARAM ( Cu
: | Apps

#- | Trees

v Actions

. Reports

&b CPRCUST_RPT ( Customsr List )
- | Messages
{ﬁibiliw Units

- Messages

. RS (Filtered "%cprci'’)

#-EH CPRCUST_DS ( CPRCUST Dats )

Bl CPRCUST_PARAM ( Customer List )

| . Trees ||ﬂ|

If a report application contains more than one subtask, you can locate its parameter result set
under the Trees folder, instead of the RS folder for that application in the Object Explorer.

stomer List )

A parameter result set does not contain logic for the report. It only drives what data should be
gathered for the report. Generally, you do not extend a parameter result set except for cosmetic
changes such as changing the labels on the screen. Options such as adding an additional selection,
filter, or sort option cannot be added since the existing Java class logic for populating the data source
are not extensible (see Data Source Result Set).

Extensibility Designer Report Guide 3
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Report Definition

A report definition (or report list) includes the metadata that describes a report such as title, status
text, Java class action, and the data fields that feed into the report. In the Object explorer, you can
find the report listed directly underneath the parameter result set.

Deltek Costpoint Application Extensibility Designer 7.0.1 - CZ01RDO - |I:I|i|
Object Link View Extensions Tools Help

| Do |8 (B 3 -] o] R[] 28| 3]| vopLevetrimer fare il

. Modules

.. Apps (Filtered "earrct’)

=, ARRCR ( Print Cash Receipts Edit Report )

5L ARRCRREG ( Print Cash Receipts Register Report )
=5 ARRCUST ( Print Gustomer List )

B | Modules
E- L RS
=B8] CPRCUST_PARAM ( Customer List )
&- | Apps
#- || Trees
. Actions

- || Messages

In the example above shows the report definition for CPRCUST_PARAM is CPRCUST_RPT.

Edit report: CPRCUST_RPT - C701RDO =3l x|

Name * |Customer List

Information | Data Sguroesl

Ul
Title |&CPT.CUSTS List Status Text |

r Setftings
Report Category * [ITERNAL (Internal) | Locking* fione =
ROX (template) * Ioummunapp.‘cprcmt.l’cprcmt

Default Locale * IUser locale ﬂ Show Currency Symbol |Never ﬂ

TS

BefnreIN-:lne[ ] ;Iﬂl @
After INune( )] LI ﬂl
PEGE Selp
Orientation ILandscape LI Paper Size ILetter LI Zet from Report |
Margins {inches)
’V Left I Right Top I Bottom r Llways U=e Design Setlings

Apply Ok Cancel

Extensibility Designer Report Guide 4
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Standard Components of a Costpoint Report

The name and location of the original report template is specified in the ROX (template) field on the
Information tab. This path is a sub path underneath the root path where report templates for all
applications reside in the Costpoint server. The root path for all report templates is
C:\deltek\costpoint\70\applications\birt\report\bin. The example above displays the report template for
Customer List at:

C:\deltek\costpoint\70\applications\birt\report\bin\commonapp\cprcust\cprcust.rptdesign

The .rptdesign extension name is omitted in the ROX field since it is implied. If there is any standard
Costpoint action to be run before or after the report is run, they are displayed here.

For more information about an action, see the Deltek Costpoint Extensibility Designer Guide.

On the Data Sources tab, the left pane displays the data source ID and name used inside the report
template. The right pane displays the ID of the data source result set which supplies the data for the
report. In the following example, there is only data source, and the ID is CPRCUST_DS.

Edit report: CPRCUST_RPT - C701RDO - o x|

Report id =

CPRCUST_RPT Name * ICustumer List

Information Data Sources

DS MName Assigned to DS Result Sets I Assigned to DS Variahlesl

CPRCUST::D

Data Source

Source
RS Mame

“PRCUST Data

lews | Edit | Delete Add RE | Hemove RS | Up | Down

Apply | Ok | Cancel |

Click the Assign to DS Variables tab to see all the fields from the data source result set that have
been selected to feed into the report. In the following example, seven columns from the data source
result set are selected to be used on the report.

4 Edit report: CPRCUST_RPT - C701RDO ;IEILI

Report id *

CPRCUST_RPT Mame * |Customer List

Information Data Sources |

DS Name
CPRCUST::DataSo...

Data Source Assigned to DS Result Sets Assigned to DS Variables

ataSource

Variable Variable Name

Cl
Cl
Cl
Cl

LIMIT_AMOUNT

New | Edit | Delete Add Variable | Hemove Variable | Add AIIRS Variables

Apply Ok | Cancel |

Extensibility Designer Report Guide 5
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Standard Components of a Costpoint Report

You can extend a report definition by changing the report title, status text, the report template, action
to be run before or after the report, and the data source columns.

Data Source Result Set

The data source result set acts as a data source for a report. It is like any other result set except there
is no need to design the Ul layout. The data source result set for a report is not displayed directly in
the Object Explorer under the respective application branch. You must take note of the ID of the data
source result set in the Report Definition and find it using the Top Level Filter field, as shown in the
following example.

Deltek Costpoint Application Extensibility Designer 7.0.1 - CZ01RDO o =] 5
Object Link View Bxtensions Tools Help

| ﬁ'v'ﬁ"x'?,g” |- y” =e|v|ag|={s|| Top Level Fiter [SEmatEN

. Modules
. Apps (Filtered "harrc’)
EE, ARRCR ( Print Cash Receipts Edit Report )
EE, ARRCRREG ( Print Cash Receipts Register Report }
ARRCUST ( Print Customer List }
RS (Filtered "CPRCUST%")
H-fE CPRCUST_DS [ CPRCUST Data )
e CPMeUs | _FARAN | CUSomer LISt )
| Trees
| Actions
| Reports (Filtered "cpri’)
 Constants
. Messages
, Extensibility Projects

| []

At the top of the RS list tab, there is usually a SQL Select statement defining where the data for the
report will come from. In the lower half of the Classes tab, there is usually a Java class in the Set
Select field. This Java class defines or refines the SQL statement at run time to filter and sort the
data according to what the user specifies on the parameter result set.

You cannot extend this Java class as it is not an event that is extensible. For this reason, you
generally do not extend the parameter result set to add additional options for filtering as you cannot
extend the set select Java class to cover the additional options. You can, however, add options such
show or hide since this can be done in the report template itself.

Extensibility Designer Report Guide 6
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Edit Result Set - CPRCUST_DS - C701RDO =0| x|
Extension I Select... |

RS List | RS Description | RS Presentation |

d* ICPRCUST_DS Name * ICPRCUST Data Type * |Reporting Data LI

SELECT CUSTOMER AS CUSIOMER, CUSTOMER NAME AS CUSTOMER NAME, CUSTOMER TYPE AS CUSTOMER TYPE, CUSTOMER TERMS AS
CUSTOMER._TERMS, SALES TERRITORY A5 SALES TERRITORY, LIMIT AMOUNT A5 LIMIT AMOUNT,TAX EXEMPTION AS TAX EXEMFTION
FROM VAR CUSTOMER LIST WHERE COMPANY ID =:CP_COMPANY ID ORDER BY SALES TERRITORY, CUSTOMER

S0l Editor Refresh GBI D= Check Sql Map P

Ul Options | System Information C'asses | Extensibility Plug Ins |
" RS Classes
RS Open I

RS Populate |

Set Select Icum.deltek.enterprise.applicatiun.cnmmunapp.cprcust.CprcustSetSelect
Validate Line |

l_ Execute Set Select Gnly Gnce

AL

fo Disable Line Formula |

walidate Line JS |

RS Validate I f{) Dizable RS Formula |

Before Save

RS Close

AL

|
After Save I
|

Verify | Apply | Ok | Cancel |

You can extend the data source result set by adding additional columns to the SQL select statement
in the lower half of the SQL select panel.

Report Template

Costpoint uses Eclipse open source BIRT (Business Intelligence and Report Tools) platform for
reporting. A report template is a layout/design of the report created with Eclipse BIRT IDE.

Refer to the Eclipse IDE Installation section for more information.

All report template files have the .rptdesign extension name. For example, the Customer List report
template file name is cprcust.rptdesign.

You can extend a report template by copying an existing Costpoint template, saving it with a new
name, and then modifying it using the Eclipse IDE. The new template is then placed in the custom

folder (specified in the extended report definition) under the BIRT report main folder on the server, as
shown in the following example.

Extensibility Designer Report Guide 7
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iibwm

[CP_CompanyName]
&CPT.CUSTS List ]
lIee_grgSecFrofile] ]

(CF_Userid]
Parameter TB: 1€F_Pasemeter]
Total # of Fages

wmine_soRT BT co
2nd Sort: SECOND_SORT_BY_CD

Ik S == | e
: |l v |7 e
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Extend a Report in the Extensibility Designer

Extend a Report in the Extensibility Designer

You can extend a report with simple to complex changes. The level of effort depends on how complex
the report is in Costpoint and how many changes are desired for the extended report. Below are
some examples of simple and complex changes:

Change the report title or report status text on the screen (not the report) — This
change only involves extending the report definition in the Extensibility Designer and setting
the new report title or status text to be shown on the screen (not the report).

Change the report title on the report — This change involves extending the report
definition in the Extensibility Designer and a simple change in the report template for the
report title in Eclipse IDE for BIRT report.

Change the labels, column headings, or the layout of the fields on the report — This
change involves extending the report definition and more in-depth changes to the report
template in Eclipse IDE. You need proficient knowledge of how to use Costpoint plug-in
classes and methods for BIRT reports for this change.

Add additional columns from a related table to the main Costpoint report table to the
report — This change involves extending the report definition, making changes to the data
source result set, and making changes to the report template.

Extend a Report Definition

To extend a report definition:

1. Select the Report Definition for the report in the Extensibility Designer.

The Edit Report screen displays. The Information tab contains Deltek’s original settings. The
template location and name in the ROX (template) field is the subfolder under the root path
for all report templates on the server (C:\deltek\costpoint\70\applications\birt\report\bin). The
report template file (rptdesign) is actually a text file, so you can copy and rename it when you
intend to customize it.

The .rptdesign extension name is omitted in the ROX (template) field since it is
implied.

2. Click the Extensibility Information tab. You can make the following modifications:

= Chang the Title and Status Text fields.

= If you want to change the content of the report (report template), specify a new template
name. The path must start with custom/<Unit ID>/<new report template name without
extension>. At run time, Costpoint expects this file to be at the report root path and sub
folder specified here.

= Change the Show Currency Symbol option. The valid options are:

= Never — A currency field in the report template will not print with the currency symbol
at run time.

= Always — A currency field in the report template will always print with the currency
symbol at run time.

= Depends — Printing will depend on the settings in the System Settings application.

= Add before and/or after actions (Additional Extensibility Actions group box) if you need
to run some special process before or after generating the report. These are available for

Extensibility Designer Report Guide 9
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\L Extend a Report in the Extensibility Designer

new actions (not extended actions) you have created for this extensibility unit. These
actions are executed in addition to the standard actions that are set in the Information tab
for this report.

= Change the values in the Page Setup group box, such as Orientation, Paper Size or
Margins. These are defaults only and will display as defaults in the Page Setup option
dialog box when a user prints the report. These settings should match how the report
template is designed. At run time, a user can override these defaults unless you select
the Always Use Design Settings check box.

3. Click the Data Sources tab.

The left pane displays the data source ID and name used inside the report template. The
right pane displays the ID of the data source result set that supplied the data for the report.

4. Click the Assigned to DS Variables tab.

This tab displays the data fields from the data source result set that were selected for the
report.

5. Click Add Variable to add additional fields from the data source result set.

You must first add new fields to the data result set, by extending the data source result
set, before you can select and then add them to the Assigned to DS Variables tab.

Extend a Data Source Result Set

From the report definition, you can get the ID of the data source result set. Then, use the Object
Explorer to find this result set and extend this result set to add more data to the report.

To extend a data source result set:
1. Display the Edit Result Set screen.

The upper text field displays the SQL SELECT statement that selects data for the report. In
the following example, the SELECT statement selects data from a table (or view in this case)
named AR_CUSTOMER_LIST. It selects seven columns which you actually see in the report
definition earlier. To verify, you can select the RS Description tab and those seven columns
should display there.

Extensibility Designer Report Guide 10



y

Extend a Report in the Extensibility Designer

Deltek kowmore

Edit Result Set - CPRCUST_DS - C701RDO =ax]

RS List | RS Description | RS Presentation |

Extension [XT_WN1_ACT1 Select... |

ia* ICPRCUST_DS

Name * ICPRCUST Data Type * |Reporting Data LI

SELECT CUSTOMER AS CUSTOMER, CUSTOMER NAME AS CUSTOMER NAME, CUSTOMER TYPE AS CUSTOMER TYPE, CUSTOMER TERMS AS
CUSTOMER. TERMS, SALES TERRITORY AS SALES TERRITORY, LIMIT RAMOUNT AS LIMIT AMOUNT, TAX EXEMPTION AS TRAX EXEMETION
FROM VAR CUSTOMER LIST WHERE COMPANY ID =:CP COMPANY ID ORDER BY SALES TERRITORY, CUSTOMER

Ul Options | system Information | Classes | Extensibiity Plug ins |

rTitles

SQL Editor Refresh OBJ_IDs Check Sgl Map PK

RS Title * IARRCU ST Data

Extensibiity Title |

Ul Options
View *

Table Style

Override Number Of Buffered New Rows

II:efauIt Form View

INcne
Ovwerride Number Of Buffered Existing Rows

L1

Verify |

Apphy | Ok | Cancel |

RS List RS Description | RS Presentation |

Edit Result Set - CPRCUST_DS - CZ01RDO =10]x]

Extension [XT_WN1_ACT1 Select. . |

Object Id

CUSTOMER_NAME

ObjID [CUSTOMER Name |CUSTOMER

General I Ex'tensibil'rtyl Currency and Repurtl

CUSTOMER_TERMS

DB Options

CUSTOMER_TYPE

Table IVAR_CUSTOMER_LIST Column ICUSTOMER

LIMT_AMOUNT

SALES_TERRTORY

¥ From Select Type * IString ‘I Length‘l 12 Scalel

TAX_EXEMPTION

[~ primary Key. = Alow Editof Pk I |Logical P [T Save Null(FK) = DB read only

" Dynamic Data Type. ... |

— AN Andinan

2. To add additional data for the report, click the RS List tab and use the lower text field to enter
a SELECT statement. Then select other columns from the same table (or from any other
table) where the WHERE clause can be formed with columns selected in the original
SELECT statement. Treat the value of the columns in the original SELECT statement as a
bind variable (represented by the colon followed by the object ID/alias).

In the following example, the key fields to table/view VAR_CUSTOMER_LIST are
CUSTOMER and CP_COMPANY _ID. So the WHERE clause of the extended SELECT is
“VAR_CUSTOMER_LIST.CUSTOMER =: CUSTOMER AND

Extensibility Designer Report Guide
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Extend a Report in the Extensibility Designer

VAR_CUSTOMER_LIST.COMPANY_ID = :CP_COMPANY_ID". The bind variable
:CUSTOMER is the alias for the CUSTOMER column in the original select. It is also the ID of
the resulted object seen in the RS Description tab. :CP_COMPANY _ID is the other bind
variables for the where clause.

B3 kdit Result Set - CPRCUST_DS - C701RDO - O] x|
Extension [XT_VN1_ACT1 Select... |

RS List | RS Descriptinnl RS Presentatinnl

id* ICPRCUST_DS Name = ICPRCUST Data Type* |Reporting Data |

SELECT CUSTOMER AS CUSTOMER, CUSTOMER NAME AS CUSTOMER NRAME, CUSTOMER TYPE AS CUSTOMER TYPE,CUSTOMER TERMS RS
CUSTOMER. TERMS, SALES TERRITORY AS SRLES TERRITORY, LIMIT AMOUNT AS LIMIT RAMOUNT, TAX EXEMPTION AS TAX EXEMETION
FROM VAR CUSTOMER LIST WHERE COMPRANY ID =:CP COMEANY ID ORDER BY SALES TERRITORY, CUSTOMER

SELECT CREDIT_ LIMIT AS XT CREDIT LIMIT

[Enter your Extensibiiity SELECT statement for this RS]

SQL Editor | Refresh OBJ_IDs | Check Sgl | Map PK
Ul Options | System information | Classes Extensibiity Plug ns |
ﬁ Open | D New | Eg Clone | . Delete | 1+ Up | - Down |
I I When I Order I Flug In Type I Plug In Name I Insert I Update I Delete I

At run time, when each row from the original SELECT statement is being retrieved, the
system will execute the extended SELECT statement to get the additional data to add on to
that row before sending it to the report.

You can select additional data from any table as long as the WHERE clause can be
constructed with these bind variables.

For example, instead of adding CREDIT_LIMIT from the VAR_CUSTOMER_LIST, you want
to add the VEND_NAME from the VEND table for the VEND_ID contain in this
VAR_CUSTOMER_LIST. You must join the VEND table with the CUST table. Your extended
SELECT statement would be like this:

SELECT V.VEND_NAME AS XT_VEND_NAME FROM VEND V, CUST C WHERE V.VEND_ID =
C.VEND_ID AND C.CUST_ID = :CUSTOMER AND C.COMPANY_ID = :CP_COMPANY_ID AND
V_COMPANY_ID = :CP_COMPANY_ID

3. Totestif the SQL is valid, click Check Sql, and click Refresh OBJ_IDs. An object with ID =
XT_VEND_NAME displays on the RS Description tab.

4. Click Apply.

This column is now available in the data source result set. You must then make it available
for the report

Click the RS Description tab, and click the Currency and Report tab.
6. Enter the same ID in the Report Variable field, and click Save.

7. Go back to the Report Definition screen, and add this new column to the list of variables for
the report.

Extensibility Designer Report Guide 12
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Edit report: CPRCUST_RPT - C701RDO (=]

Reportld® |CPRCUST_RPT Name * |Customer List

Infnrrnatiunl Extensibility Information Diata Sources |

D5 Name
CPRCUST:DataSo...

Data Source
CPRCUST::DataSource

Aszigned to DS Result Sets  Assigned to DS Variables I

Extensibility Unit IXT_VN1_ACT1

Variable

Variable Name

CUSTOMER

Please enter variable description here

CUSTOMER_NAME

Please enter variable description here

CUSTOMER_TERMS

Please enter variable description here

CUSTOMER_TYPE

Please enter variable dezcription here

LIMIT_AMOUNT

Please enter variable dezcription here

SALES_TERRMORY

Please enter variable description here

TAX_EXEMPTION

Please enter variable description here

=+ IXT VEND MNAME

Please enter variable description here

Extend a Report Template

The report template is not extended in the Extensibility Designer. You must specify the new template
name and location in the Report Definition extension and then use the Eclipse IDE to design the

changes.

To extend areport template:

1. Find the location of the original template.

For example, if the original path is commonapp/cprcust/cprcust, then the file is located at
C:\deltek\costpoint\70\applications\birt\report\bin\commonapp\cprcust\cprcust.rptdesign.

2. Copy the report template file to the new location, and customize it using Eclipse IDE for BIRT.

f the new path is custom/XT_VN1_ACT1/cprcust_xt, then the new file must be copied,

renamed, and placed at

C:\deltek\costpoint\70\applications\birt\report\bin\custom\XT_VN1_ACT1\cpr_cust_xt.rptdesig

n.

See the next section for information on how to install Eclipse IDE for BIRT and how to customize

the report template inside Eclipse.

automatically carry over to the custom version. Unlike all other objects in the Designer where

After a report template is customized, any hot fixes to the Deltek report template will not

you extend it, the extension inherits the changes in the original object. Customizing the report
template is actually an override, not an extension. So when the standard Report template is
changed by Costpoint development, you will need to take new standard report template and

redo your customizations in that file.
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Eclipse IDE for BIRT

Report templates are designed using Eclipse IDE for BIRT. You must install the same version of
Eclipse IDE for BIRT that Costpoint framework uses (currently, version 4.6.0). Contact Deltek if you
cannot find this exact version to download from Eclipse.

Eclipse IDE Installation
You can download the Eclipse IDE for BIRT 4.6.0 using the following link:

http://www.eclipse.org/downloads/download.php?file=/birt/downloads/drops/R-R1-4.6.0-
201606072112/birt-report-designer-all-in-one-4.6.0-20160607-win32.win32.x86 64.zip

You can use the same Java 8 runtime environment that is installed with Costpoint or download latest
Java 8 runtime from Oracle download site.

Deltek recommends that you install Eclipse on the Costpoint server machine so that you can access
the database and deploy the customized template easily. If you would like to install Eclipse IDE on a
machine other than the Costpoint server machine, that machine must be able to connect to the
database/system where the extensibility is being done (Weblogic client, JDBC drivers, and so on) as
well as the toolconnections.properties file which contains the connection information.

After installation, start Eclipse and verify that the BIRT Framework component under Help » About
Eclipse Platform » Installation Details » Installed Software displays version 4.6.0.

< Eclipse Installation Details = @
Installed Software | Installation History | Features | Plug-ins | Configuration
type filker text
Narme Version Id it
L Axis2 Tools 11.301.201410160... erg.eclipse,jstws.axisZtools
> Lt BIRT Framework 4.6.07201606072122  org.eclipse.birt.feature.grou
gt DaliJava Persistence Tools - Common 15.0~201603181811  org.eclipse.jpt.common.fea
. L3 Dali Java Persistence Tools - EclipseLink Cornmon 1.3.200.v201603180... org.eclipsejpt.common.ec
. LJ+ Dali Java Persistence Tools - EclipseLink DBWS Support 1.2.200.201603180... org.eclipse,jpt.dbws.eclipse
. L+ Dali Java Persistence Tools - Eclipselink JAXB Support 1.4.200201603180... org.eclipse,jpt.jaxb.eclipseli| =
. L Dali Java Persistence Tools - Eclipselink JPA Support 3.4.100,201603180... org.eclipse,jpt.jpa.eclipselin
. L&l Nali lava Percictence Tanle - IAYR Sinnnrt 15100 WIMENNRN arn erlines int iavh featire

Under the installation folder for Eclipse (for example, C:\Eclipse), you will see a plugins subfolder. Go
to DSM and download DeltekCostpoint711BIRTInstaller.exe, which will copy two Eclipse plugins (jar
files) to your hard drive. You must add these two jar files to the Eclipse\plugins subfolder:

= com.deltek.enterprise.system.reporting.client.birt.oda.designer_1.0.0.jar
= com.deltek.enterprise.system.reporting.client.birt.oda.runtime_1.0.0.jar

These Deltek-supplied plugins allow Eclipse IDE to interact and design the report according to the
Costpoint framework.
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Start Eclipse

After you install Eclipse, start it by running the eclipse.exe file located under C:\Eclipse. Or, you can
create a batch file under the same folder with the following command line in it:

c:\eclipse\eclipse.exe -vm "C:\oracle\jdk1.8.0 _121\bin\javaw.exe"

The —vm parameter allows you to specify any version of the JRE (Java Runtime Environment) to run
Eclipse (described in previous section). Eclipse will prompt you for the location and name of the
workspace. You can give your workspace any name and any location. The location of the workspace
does not need to be the same location as the report template. It's just a place for Eclipse to store the
workspace settings. If there is a welcome screen, close the screen and proceed to create a report
project in the next step.

Create a Project

To create a project:

1. Click File » New and select Project » Business Intelligence and Reporting Tools »
Report Project.

2. Onthe Report Project page of the New Report Project wizard, enter a name for the project,
and clear the Use default location check box.

3. Click Browse to locate the C:\deltek\costpoint\70\applications\birt\report\bin\custom folder,
and click Finish.

4. If the Open Associated Perspective message box displays, select the Remember my
decision check box, and click Yes. The Report Design perspective displays.

5. If the Navigator view is not displayed, click Window » Show View » Navigator.

You can then expand the Navigator view to locate the report template that you have placed in
the custom folder.

Set Up Report Design Preferences

To set up report design preferences:
1. Click Window » Preferences » Report Design. The Preferences dialog box appears.

2. Select Window » Preferences » Report Design » Resource from the hierarchy tree on the
left, and enter the report folder of the Costpoint server (for example,
C:/Deltek/costpoint/70/applications/birt/lib/report) in the Resource folder field.

3. Select Window » Preferences » Report Design »Template from the hierarchy tree, and
enter the report template folder of the Costpoint server (for example,
C:/Deltek/costpoint/70/applications/birt/lib/report/template) in the Template folder field.

Test Costpoint BIRT Plugins

To test if the settings to Costpoint were correctly configured:

1. In Eclipse, right-click the extension unit in the Navigator view, and click New » Report the
shortcut menu. The New Report wizard appears.

2. Onthe New Report wizard, leave all as defaults, and click Next.
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You should see multiple choices for Costpoint template available.

Report

Choose the type of report you want to create.

Report templates: Preview:

tandard
Blank Report - —
My First Report ===
Simple Listing [ | = =
Grouped Listing

]
w

4

Dual Column Listing

Dual Column Chart & Listing

Side by Side Chart 8 Listing

Chart & Listing

Cross Tab

Costpoint Dashboard Chart
Costpoint Dashboard Listing
Costpoint Landscape Report |
Costpoint Legal Landscape Report
Costpoint Portrait Report

Description:

Costpoint Landscape Report

[] Show Report Creation Cheat Sheet

@ [ <Back | met- |[ Finsh ][ Cancal

3. Click Cancel.

You can now open and customize the report template.
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Customize a Report Template in Eclipse

Report Template Outline

To view the outline of a report template in Eclipse, browse for the report template in the Navigator
view, and open the Outline view.

Tl L LR R T i L s S v s v - ik [T
S Navigator 52 Outfine 17 | (b Palette ¥ 79 8 M bimbiptdeign 1
o [, blemslaptaesign
4 . Daba Soueces =
W CPDutaSeuec
o i Data Sets
. 2 DLEMEIL Data Set
i Data Cobes.
& Heport Parsmeters )
- Vaisbles
« i ody
o B Guid - CP_CoverPagePortrinid
i B Grid « CoverPageDentBontid
Tabie - DataSePorer Tl
[l Grid - CP_NeRowsPortiGrid
« i MatePages
+ 71 Simple aster Page - CP_CoverPage
1 Sermple Mactes Pae - CP_ReponBody

[6P_CompanyName]
Standard Bills

wepTs cune securizy | |CT-CfafecPeofilal

- e :
i imbedded Images ll“
o+ i Lbranes ; Fange
W cpcomponen: & BED Bange
¥ cp_preentation Z —
- gt 7 Sange
7 Sange
an
[t Pesource Explorer &1 =0l =
- Shared Reources
fdasine Uyt | Master Page Scrt| ML Source]
- tanplee
3 cpbudds [ Property Edor - Repert 71 [ fiperter [0
B cpcomponanseeptitbeary ™
epcontraliy.
- cp_peesentationptibrary g
i epLetibje — T
o | Crosed by Eelgrie BIRT Disagner Verson 4.6.0.v201606072122
Usspropuer | |, e, .
Bamed Bxprevsions. | _

As shown in the example above, the following are the main components of a Costpoint report:

= Data Sources: Costpoint report uses its own data source type. The report does not connect
and receive data directly from the database. Rather, it receives data from the Costpoint
application server. This is one reason why you need to have the Costpoint plugins for
Eclipse.

= Data Sets: Refers to the data setup in the report definition. The dataset defines which
columns (fields) are being fed into the report from the data source result set.

= Body: This is the content of the report. Usually, it has two grids: cover page grid and report
content grid. If a report contains multiple reporting sections, then you may see more than one
table object in the Table section.

= MasterPages: Defines report cover page and main report data that repeats on each page,
such as page headers, footers, and page numbers.
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Data Source

On the Outline view, select and expand the Data Sources section.

File Edit Insert Element Data Page MNavigate Search Project RBun  Winc

o j@-la-le -1l o- -

B= Qutline 532 . % Navigatuﬂ & o O K cpreust_xt.rptdesign 52 [

E|--- cprcust_xt.rptdesign | L - T
E-H Data Sources |
58P Datas
=& Data Sets :
- -7 CPRCUST Data Set -
g Data Cubes

—

To change Costpoint data source settings:

1. Right-click CP_DataSource in the Outline view, and click Edit on the shortcut menu. The
Edit Data Source dialog box displays. The data source may register the configuration folder
location that does not exist in your local environment.

2. Change the value in the Configuration Folder Location field to
C:\deltek\costpoint\71\applications\enterprise\properties, where the server’'s
enterprise.properties file is located. This allows Eclipse to get the additional data fields added
to the report (see next step).

Data Set

To view data sets, expand the Data Set folder in the Outline view.

D= Qutline 52 - T Navigatur] e © O
B cpreust.rptdesign
E-[f Data Sources
‘-l CP_DataSource
E--[# Data Sets
(SR CPRCUST Data Set
CPRCUST_DS.CUSTOMER
CPRCUST_DS.CUSTOMER_MAME
CPRCUST_DS.CUSTOMER_TERMS
CPRCUST_DS.CUSTOMER_TYPE
CPRCUST_DS.LIMIT_AMOUMNT
CPRCUST_DS.SALES_TERRITORY
CPRCUST_DS.TAX_EXEMPTION
PRIMARY_SORT

(mffon o o o o o

The Data Set folder displays existing registered data fields that come from the data source result set.
This was done by Deltek when the report was created. You may see additional columns in the folder.
These are additional data fields computed in this report from other columns but not directly from the
data source.

In the example, the extra field for XT_VEND_NAME to the data source and report definition in the
Extensibility Designer is not listed. You must register it here before we can include it in the
customized layout.
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To register an extra field in the Data Sets folder:
1. Right-click the CPRCUST Data Set, and click Edit on the shortcut menu.

2. Onthe Edit Data Set dialog box, select Query from the hierarchy tree on the left, and
complete the following actions in the Select System, Extension, Report, Data Source page.

= From the System Name drop-down list, select the system in which you extended the
report.

= From the Extension drop-down list, select the unit in which the unit was extended.

= From the Report drop-down list, select the report you extended.

= From the Data Source drop-down list, select the data source that you extended.
3. Select Output Columns from the hierarchy tree on the left side.

The additional column that you have added to the data set in the report definition is listed in
the Output Columns page.

4. Click Save.

The additional field is now available for use in the report.

Body

The body contains all the information for the report.

Grid CP_CoverPage

To view the top section of the cover page where the company name, report title, printed by
information, and so on are printed, click Body » CP_CoverPagelLandGrid from the Outline view.

& Report Design - CP70CustomReports/ XT_VNI_ACT1/cproust_xt.rptdesign - Edipse Platform
B Ede jneem Flment (a3 Page Navgate Search Project Run  Window Heb

" = e . FDy n &3

B2 | i Report D=

[CP_CompanyName]
&CPT.CUST& List

CUSTOMER
CUSTOMER_NAME | ™
CUSTOMER_TERMS| . = Dato/Timo:
T CPROUST_DS.CUSTOMER_TYPE
T CPROUST_DS.LIMIT_AMOUNT

T CPROUST_DS.SALES_TERRITORY|
TAX_EXEMFTION _ Parameter ID:

T CPROUST_L
T CPROUST_DS.VEND_NAME ~ usber of Pa
I PRIMARY_SORT *

Report Opticns

& {1 Grid - CoverPageDetiandGrd
= DatasetlandThl
P_NoRowsandGrd

jo REPT.ADCTE WCPT . CUSTE Hame Tpe Terma Tarritory Credit Limit Tax Exespticn 1D

The naming convention for CP_CoverPagelLandGrid refers to the Costpoint cover page grid in
landscape mode. If the report is in portrait mode, the name would be CP_CovePagePortrGrid. These
are objects provided by Deltek in the library. You can browse for all supplied Costpoint BIRT objects
in the Resource Explorer view.

You can add additional info or rearrange the layout of the top section of the cover page. The title of
“Customer List” report is set as &CPT.CUST& List. At run time, the &CPT.CUST& variable is
replaced with the customized term set from the Manage Standard Label application in Costpoint.
There are seven system-wide terms that you can customize. Use these variables instead of the hard
coded English words for them if they are one of these.
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To change the title, click the title on the report, and enter the new title.

& Report Design - CP70CustomReports) XT_VN1_ACT1/cpreust_xt.rptdesion - Ecipse Platform
[ Eot jsert Cament Quta Page Navgate Segrch Project fun Wndow Hel

e e S = R e = o s ]2 raporc o
(i Hovgator [ B Outoe 8 » 7 O O] .

S cperust_xt.ptdesgn

= (i Dats Sources : = — -~ LA 8
8 o_tensource 3
- Data Sets § [CPwCulﬂpanyHam]

= £F CURCUST Data Set
g [ = Tead &CPT.CUST& Customized Report] |
= Date/Tize:

§ CPRCUST_DS.CUSTOMER
0 CPRCUST_DS.CUSTOMER_NAH
[CP_BudldDeteTize] CP_Or 4
ACPTS.GRGR Security 122 Srechratita)

I OPRCUST_DS.CUS TOMER_TER
T CPRCUST_DS.CUS TOMER_TYE

Grid CP_CoverPageDetlLandGrid

To view the selection a user has selected on the parameter page before the report (for example,
selection range, sort, and so on), click Body » Grid — CP_CoverPageDetlLandGrid in the Outline
view.

- Report Design - CPFMCustomReports/XT_VNL_ACTL/cproust strploesign - Eclipes Platborm

Insert Dlement Qats Page Navigate Search Profect B Wndow Heb
3=l (- I s W= e ol e 1| 1 Roport Des
= Mavigator [ B2 2 | (T ————————
S cproust_at.mtdesgn R S ST IR T FEE . 5 ] 7 M ) i
5 Data Sources ' Frinted by: ¥_Useria]
9 & _pamsource g Farameter ID: (CE_Faramezer]
-G Data Sets fa
@& Dats Cubes _ mber of Fages:  Total 4 of Pages
§) Raport Paramaters - Pt ——
(y varables |
E Smlection Ranges |
Yea/Ha Label Tange
sort iy
1 ced ist sort: FRINE_SORT_BY_CD
[l Label - 07 _LabeiCrt) . nd Sorti SECOKD_SORT_BY_{D |
10 Row ‘W1 —_—
-0 Row
23 Row v WCIT.ACCTE WCPT.CUSTE asn Tive Terms Tarritory Credit Limit Tax Ezemplion 10
Tabla - CazaSetlandTal
T Gnd - CP_NoRowsandGrd
B MasterPages i

To edit the grid of the report:

1. Click any of the fields on the Layout view (for example, Yes/No label field), and click
Property Editor view » Properties.

This uses the CP_LabelYesNoCntl Costpoint class.

Report Options

Selection Ranges

—
Yes/No Label

(fes/No Labe B | ge
Sort By
1st Sort: PRIME SORT BY CD
2nd Sort: SECOND SORT BY CD
&CPT.ACCTE &CPT.CUSTE Name Type Terms Territory

Rpsource Expk)reﬂ

General

d Library: | Ct\Delcek) costpoint\7 0\applications\birt\ib\report\cp_components.rptlibrary
er
MOTE: This report item from the library has been modified. To restore the original library item, dick on
L-Zie, 1) B "Restore Properties”
Hyperlink
Page Break I Name: | CP_LabelveshoCnt] | *ement D: [407
Visibiity e o Troeriiom = .. I s | POrey o |

2. Click the Advanced tab in the Properties tab in the Property Editor view to view settings for
this object.
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For this CP_LabelYesNoCntl class, the CP_DataValue points to the data entered in the field
PRIME_SORT_BY_CD (which is the object ID of the field on the parameter Result Set).
CP_DataValues are the possible values for this field. There are four possible values,
separated by a tilde (~) symbol.

CP_DisplayValues are the corresponding text to be displayed on the report according to the
value returned in CP_DataValues. There are four possible text separated by a tilde (~)
symbol. So if the return value is 0, it will display & CPT.CUST& &CPT.ACCT&. If the return
value is 1, it will display & CPT.CUST& Name.

Since you are not likely to customize/extend the parameter result set, there is probably not
much to change in this section.

Properties] Highlight5|
I
Margin Advanced
Hyperlink
W Property | value
| Comments
\hnbﬂrty— Content Yes/MNo Label : Inherited
Localzation Content key
Table of Contents CP_DataValue CP_getParmsString("PRIME_SORT_BY_CD")
Eakea CP_DataValues Orelre2n3
— | CP_DisplayValues &CPT.CUST& &CPT.ACCTR:~&CPT.CUSTA Name:~Sales Territory:~&CPT.CUSTA Type:
Comments
- \.,r’_LuLE'fEAu
User Properties CP_SuppressDuplicates false : Inherited
MNamed Expressions Custom XML
Cnopt Uandlor | Display name
Display name key
prdvanced . Event handler class
r P———

Table

The table is the main component of a report. It is the representation of the data source in visual
format. It contains the detail content of the report. Generally, each table corresponds to a data set
that supplies the data to the table. If you offer users multiple formats for a report (for example, choice
of portrait or landscape), you can add an additional table format, but choose the same data set.

To add a table format in the report:
1. Select atable in the Outline view.

2. Click the Binding tab in the Property Editor view.

The data set assigned to this table displays. All the fields from the data set are listed in the
Data Column Binding grid. Each time you use these fields and place a control on the report
for it, an additional row is listed here for the control. For example, on the first line of the grid,
LIMIT_AMOUNT was shown on the report via the CP_CurrencyCtnl object. LIMIT_AMOUNT
is also shown as an item coming from the data set.
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t—_umnu[m& O opreust _atptdesgn 5
= [ cproust_stuptdesgn e 2R A . R o A B o LB 3 T T T IR N B g % &
= U Data Sources
8 o _vamasource
& 3 Do Seis. GCPT.CUSTE Mazm ECPT.ACCTE Type Terss Territary Credit Limit
4 Data Cubes
‘§) Repor Parameters
5 Variebles - -
3 Body Layiut | Mastes Page | Serpt | ML Saurce | Prigew |
Grid - CP_CoverPageLandGrad B Froparty Edtor - Tabk £ . [T RAESUPCE EXplorar
Grid - CoverPageDetLantikl I srop pyL - ] -
T Prope cmwlm.m:wwlnmi
| @ DagaSet: | CPRCUST Data Set E‘lwm»mm Bodng... |
Report fram: 1=
Data Colurras Binding:
Hame + | Deplay mame 10| Diply Hame | wata Type | Expression | Function | Fear Mw
P _CurrncyCrtl LBIT_AMGUNT | Deciral dataSetRaud "LIMIT_AMDUNT] [T
P _Texmcny CUSTOMER sang darasethow] CUSTOMER'] Wi
€P_Taxncnd_1 CUSTOMER_NA... Sohg datasethow] CUSTOMER_NAME"] i
Grid - P NoRgwsLandGrid P_Tetins_2 CUSTOMER_TY.., | String datasetRow"CUS TOMER_TYRE"] M2
) MasterPagees P_Toxtcntl 3 CUSTOMER_TE... | String dataSetRaw{"CUSTOMER_TERME"] i
Stylis P_Texucnd & SALES_TERUIT... Swing damsetiow]"SALES TERRITORY] Wi
] Ertreddid Trages P_Taxtind 5 TAX_EXEMPTION | Strmg datasetiow] TAX_EXEMPTION] 02 [ Rufresh |
-4 cp_components.cP_Therre CUSTOMER ST1_DS ;| dataSetRow{ "Cus TOMER™] Wi
4 4 Lranes CUSTOMIR, HAME dataSetRowd"CUSTOMER, NAME"] [
di-g Scots CUSTOMER_TE... damsethow] CUSTOMER_TERMS] i
CQUSTOMER_TYPE PROUST_D: strng datasetiow] CUS TOMER_TYPE] 1
LIMIT_AMOUNT CPROUST DS.L... | Dicirul dataSetRaw] "LIMTT_AMOUNT] [T

3. Click the Properties tab, and then Table of Contents.

On the right side is the text that will display at run time when the user selects the Table of
Content on the report preview. CP_TranslateText is used to translate text (to another
language for a Costpoint system that supports multiple languages — coming in version 7.1).
Usually, when the text is set for a CP_Label control, it is automatically translated. When text
is imbedded in another control such as this one, you must indicate that this text needs to be

translated at run time.

Properties | Binding | Groups | Map Highlights| Sorting| Fifters|
ray
Page Break Table of Contents
R V1. o T
Table of Contents:
Table of Contents =
Bookork CP_Transhate Text("&CPT.CUSTE. List")
Comments
User Propertias
Mamed Expressions

Table Header

A table header prints on each page of a report. It is generally used for static text such as column
headings. It does not change from page to page. If there is data in it, it displays the data for the first
row and remains the same for all pages. Only use table headers for static values.

Extensibility Designer Report Guide

22




y

Customize a Report Template in Eclipse

Deltek kowmore

5. Navigator | 5= Outline &2 o 7 50 *cpreust_xt.rptdesign 32

E-E cpreust_xt.rptdesign [ 3 R N T e 9

() Data Sources

/B cP_DataSaurce
& Data Sets
(@ Data Cubes
(¢ Report Parameters
~( Varibles
- Body
-F2 Grid - CP_CoverPageLandGrid
e-f] Grid - CoverPageDetlandrid
B Table - DataSetLandThl
Header
B0 Row
&0 cel
= Grid
O Row
[ Row
:
0 Row k1

&CPT.CUSTE Name Type Terns Territory Credit Limit Tax Exem

TCPT. ACCTE Tipe Terns Territory Tredit Limit 73

Territory &CPT.ACCTE &CPT.CUSTE Name Terns Type Credit Limit Tax Exem—

Territory &CPT.CUST& Name &CPT.ACCT& Terns Type Credit Limit Tax Exem

O3 Row Layout  Master Page | Script] XML Source| Preview|

0 Row —
P Editar - Row 52 . il Re Explon
T Row [EZ Property Editor - Row {ii] Resource Bxplorer|

g 7

[ petail Properties | Map | Highlights|

Footer
[E Sroups General Visibility

-5 Grid - CP_NoRowsLandGrid Border
[ MasterPages Hide Element

-8 Styles base
[ Embedded Images isibility

1
|® For all outputs
¢p_components.CP_Theme

Bookmak

(31 Lbraries User Properties O For specfic outputs...
& Scripts Named Expressions rDetail (All outputs)
1
Event Handler | B [1cP_reportDataFound( ) || CP_getParmString("PRIME_SORT_BY_CD")i=0 | [
Advanced

To view visibility formulas, click Visibility on the Properties tab of the Property Editor view. A visibility
formula controls when the object (in this case, the table row) should be hidden. If the formula returns
true, it is hidden. Otherwise, it is visible.

In the following example, CP_reportDataFound is a Costpoint method that returns true if there is any
row returned to this table. CP_getParmString gets the value of the object on the parameter result set.
If there is no data found or the sort code is not 0, it is hidden. Otherwise, it is visible.

I1CP_reportDataFound( ) || CP_getParmString("'PRIME_SORT_BY_CD'™)!=0

Table Detalil

Table detail prints for each row returned from the data set. You can have multiple rows for the detail if
there are many columns. You generally use a grid to do indentation and spacing within a row. You
can add additional rows to a grid if the additional row shares the same indentation and spacing.
Otherwise, you add a new row and a new grid within it for different indentation.

To extend a table detail:

1. Double-click a control on the Table Detail row (for example, CUSTOMER to display the Edit
Data Binding dialog box.

& Edit Data Binding X|
Colurmn Binding Name: | CP_TextCnt

Display Name ID: | | x |

Display Mame: | CUSTOMER
Data Type: |String LI
Expression: | dataSetRow["CUSTOMER"] Fu |

@:I (oK I Cancel |

2. Click the formula (fx) button.
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The Expression Builder dialog box displays. The pane at the top allows you to build the value
of this field using the fields available in the lower panes. For example, if you want to display
CUSTOMER, then select Available Data Sets in the Category pane, select CPRCUST Data
Set in the Sub-Category pane, and double-click CUSTOMER in the Double Click to insert
pane to set the value of in the top pane.

& Expression Builder (JavaScript) _ IEIILI
Expression Builder

Type an expression in the Expression fizld. Browse the lists of available objects and double-click to copy into your exprassion.

of B R PO HE
1 dataSetRow["CUSTOMER"] =]

4 o

opetors: +| | =| 1] 2] =| <> & 4] (] )]

Category:

Sub-Category:

Double Click to insert: 13

Available Data Sets
Available Column Bindings
Native JavaScript Functions

£ CPRCUST Data Set

E CUSTOMER
El CUSTOMER_MAME
E CUSTOMER_TERMS

BIRT Functions E CUSTOMER_TYPE
Operators E LIMIT_AMOUNT
E SALES_TERRITORY
E TAX_EXEMPTION
El XT_VEND_NAME
El PRIMARY_SORT

@j 0K I Cancel

To add a row for the XT_VEND_NAME (from the data source example):

1. Right-click a grid in the Outline view, and click Insert Row on the shortcut menu. A new row
is added on the Layout view.

2. Select the first cell of the new row, and open the Resource Explorer view. The list of
Costpoint classes available for use as report controls display.
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< Marvigator | 5= Outine & = T T Ol E "corcust_rtrptdessgn 35
U cpreuse vt ratdesign 5 | [ R RO SR B LRI M - 3 L D ST IATES, P RSl T e SN LS
= L Data Sources il - T Tive ECPTACCTE WCPT.CUSTS Wase Teras Territory Tredit Limit Tax Txcsg
%@ Data Sets
i Data Cubes
§¥ Report Pammetess £
5 Varsbls 2 Type ECPT.COSTE Name Teras Territory Credit Limit Tax Exesy
=L Body
Grd - CP_CoverPageLancGnd ]
Grd - CoverPageDetiLandGrd L[SAL JLIMIT AMCOMT] [TAX FXFMEFTIC]
=1 Table - DataSetland TH
=11 Header
=] Detad [CUSTOMER_TERaS] T [ Tan_ExDMETI
o Row - _ -
5.0t T [Tax_punrTid
(i Gnd 5_TEI % ICUSTOMER] [Tax_Exmrrig
= O3 Row
L] Cel ? 5T T 1 OMER_TERMS] HOTHT] [TAX_EXBMGTI]
B OatalP_TemtCndd| Il
el i CUSTCMER TYPE]  [CUST! CMER,_IANE (CUSTOMER] [CUSTOMER_TERMS] [CUSTOMER_T¥RE] (LIMIT_AMOUT] [TaR_EXDMFTIG
“ O ot L I ]
l cal Laygut | Haster Pags| 1 1 I =
] Cel I = = =
cal | Progerty Edror - Cop | 7 Rusource Expiorer. (3
ol & Shared Resourchs |
= Row & (= comman
cal | -6 o
] col = 8 & termplate
cal ep_Puid s
el =il o_components.mtibrey
] col # [y Data Sources
ca & Data Sets
LI cal @ Data Cubes
& LT RepasCammeben
Row
i-C0 Row - TUTROP ORI, .) - CF_CurrencyCrt!
- LR 1 _|—|| § Dat(CP_Curmencybi...) - CP_CumencytioDeccntl

3. Drag and drop CP_LabelCntl to the first cell of the new row, and rename the text of the label

to &CPT.VEND& Name.

4. For the second cell, drag and drop CP_TextCntl from the Resource Explorer tab to the

second cell.

5. On the Edit Data Binding dialog box, click the formula (fx) button.
6. On the Expression Builder dialog box, double-click EX_VEND_NAME in the Double Click to

insert pane, and click OK.

& Expression Builder (JavaScript)

Expression Builder

Type an exprassion in the Expression field. Browse the lists of available objects and double-click to copy into your exprassion.

=15]x]

B & XIS EE

1 dataSetRow["XT_VEND_NAME"]

Kl

opemtorss +| | =| 1| 1] =] <|>]  &| 1] D]

3
vl

| Hint: XT_VEND_NAME

Category: Sub-Category: Double Click to insert: i
Avaiable Data Sets i’ =¥ CPRCUST Data Set E TAX_EXEMPTION a]
Available Column Bindings E XT_VEND_NAME
Mative JavaScript Functions = [El PRIMARY_SORT p
g | a| |
® oK I Cancel |

7. On the Edit Data Binding dialog box, change the Display Name to XT_VEND_NAME.

This display name is not important, but setting it to the same name in the data set helps to

quickly identify the object.

8. Click OK. The new field is added to the report by extending the data source result set, the
report definition, and the report template.
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To set or change the format of the object, click Property Editor — Data » Properties » General. You
can change the font, point size, color, indentation, and so.

= Property Editor - Data &2 fir Resource Exploreﬂ

Properties Binding| Mapl Highlight5|

|

General General

Padding EG RESLUNE FTUPET UES

Bocreg Mame: | CP_TextCntl? | Element 1: [861 |
Margin

Format Mumber Font: | Courier New IEI Size: | 8 EH points El
Format DateTime

- - Black . Auto

Format String Color: -|| El Background color: || |z|
Hyperlink B | I | L} | 5 || I = El EEl El Whitespace: @® auto O Mo Wrapping O MNormal O Preformatted

=

Table Footer

Similar to a table header, a table footer is used to print static data, such as some disclaimer text, and
S0 on. You can also set the static text on the Master Page.

Table Groups

A table group is used to control and display information for data when there is a break in the group. A
group is a key column used for sorting. For example, assume you have data coming in as in the
following table.

ID Line No
A 1
A 2
B 1
B 2

If an ID is chosen as the group key, when the value changes from A to B, there is a break. You can
display the ID once and omit it from the table detail section which will only print Line No.
To add a group:
1. Right-click Groups, and click Insert Group on the shortcut menu.
On the New Group dialog box, enter a descriptive name for this group in the Name field.
In the Group On drop-down list, select a column from the data set as key for this group.

In the Page break group box, set the page breaks.

o &~ o DN

Enter the values to display (usually the same data set column) in the Item Expression field.
This will display as an index on the table of contents for quick jump/navigation.

@ To edit an existing group, right-click the group, and click Edit Group on the shortcut menu.
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Grid CP_NoRowsLandGrid

This control is used to print the text when there is no row found on the report. Click the field to
customize this standard text.

. -3 Groups
=-f3 Grid - CP_NoRowsLandGrid
=00 Row
B-L] cel
Label
[ MasterPages

[NO ROWS FOUND THAT MEET SELECTION CRITERIA]

MasterPages

A MasterPage is a frame where the body information is inserted.

CP_CoverPage

This is the mat for the cover page. A standard Costpoint report does not have any text for the cover
page MasterPage. You can add additional text or add the text directly on the cover page.
CP_ReportBody

This is the mat for the report body. To view the layout of the Master Page in the Layout view, open
the Master Page view.

= Mavigator | H= Outine 2 e w) T =y
=il cpntust_xt.ptdesgn 0 SN O E 4
[ [ Deta Sources - - ’ - - -
3 & Data Sets
@ Data Cubes
(3§ Report Parameters
iy Varablas
& [ oty
rid - CP_CoverPagelandGrd
- CoveePageDetLandGid
bie - DataSetiandThi

[CP_CompanyNama]
ACPT.CUSTE List

[SubTitie]

nd - LP_NoRowslandtind
&0 Row
2 L cal
[ Labed
-0y MasterPages
=[] simple Master Paga - (P_Coveriage

[} Header
= Eanrec

[ 7 L st st g - co_maporesony. |

el Embedded brages
G {4 ep_components.CP_Theme
[ Ly Libranies

" Page facrot]| WML Source | Frepen|
astir Page | 7] Resource Explorer 15 )

Similar to the standard information on the cover page, the placement for company logo, the company
name, the report name, and any extra information is displayed in the SubTitle row.

To change the title of the report, you must make the change in the Master Page view.

[CP_CompanyName]

= &CPT.CUST& Customized Report

[SubTitle]
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Deploy the Extension

You need to make sure the template is copied or located at the correct location at the server. When
you deploy the extension unit to the server, you will be able to see the result of the customization
when you run the report in Costpoint.

FILE LME OPFTIONS PRO L

D.EEEE Pege [ of 10 §|As(3ene'5led = -!ﬁm:]_J

* m Browse Applications Accounting = Accounis Receivable > Chents = Print CUSTOMER List

CUSTOMER Customizad List - 1

Page 1 of 10

CUSTOMER Customized Report p3/ze/12

03:50 PM

ACCOUNT CUSTOMER Hame Typ= Terms Territory Credit Limit Tax Exemptiorn ID

1 END Ergineszi Inc. MG 1 MO CCENTRAL 5,000.00
rlznduz Hame: I
2= e MEE 1 Mo CCENTRAL 5,000.00

lp2ze Dellar Gensral MFG 1 MO CCENTRAL 5,000.00

Verdor Hame

Lz4a3 Elu= Circle COMMERCIAL .5% 15 HET 20 TWEST 99,%9%9,9585.00

Verdor Hame:

1n0P3CPP 1ROEPE0PR COMMERCIAL KET 20 o.00

Terdor Hame: ACME

IMERYL Mary Customer 1 SERVICES 1 Mo HMEW ENGLAND a.00

Verdor Hame: Advanced Research Quest

IMERYZ Mary Customer 2 SEMI-PRIVATE KET 10 o.00

Vendor NHame:

sz 322 GOVERMMENT 1 Mo a.00

Vardor Hames:

L bl (¥ GOVERMMENT K¥ET 20 TD N1
endor NHame: 41l Custom=x

- - GOVERMMENT KET 20 TD a.00

Vardor Hames: 41 Customex

41CUST CLZ 41 CUSICHMER L2 GOVERMMENT KET 20 o Q.00

Verdor Hame: 41 Customexr

21CUST CLOHME 41 CUSTCMER GOVERMMENT KET 20 TD a.00

Verdor Hame: 41 Customex

21LCUSTCLONHZ 41 CUSTCHER GOVERMMENT KET 20 TDO [ 1)

Vendor Hame: 41 Custom=x

24445558 U3MC GOVERMMENT 2k 10 N 20 MID-ATLANTICE a.00

Verdor Hame:

Refer to the Deltek Costpoint Extensibility Designer Guide for more information about deploying
your extension unit.
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Customizing Controls

Only controls from Costpoint BIRT libraries should be used. Controls can be customized in different
ways:

=  Value expression

= BIRT control properties

= Costpoint (CP) control properties
= Visibility (show/hide)

= Scripting (use scripting only when other means for control customization cannot provide the
desired result)

Scripting and Report Event Handlers

BIRT provides a powerful scripting capability that allows a report developer to create custom code to
control various aspects of report creation. Each control or component in BIRT provides scripting
capabilities. When a report runs, it first goes through a generation phase and then goes through a
rendering phase. Therefore, there are event handlers (control scripting methods) that are called at
generation time only and event handlers that are called at rendering time only.

= If you need to customize a control at generation phase, use the onCreate event.

= If you need to customize a control at the presentation phase, use the onRender event.

Jutline 28 | 52 Palette =0 pirproj rptdesign B new_report.rptdesign 22

=

Script: [onPrepare "] ]
Tptdesign - —_onPrepare |
c onRender

JES

Writing Expressions

The BIRT Scripting language derives from Java/JavaScript. A BIRT expression is a statement that
produces a value. An expression can be a numeric, date or literal value, such as:

= 314
=  "abc" + varl

When you drag a field into the report, BIRT Report Designer creates a column binding with the
correct expression for you. An expression can contain any combination of literal values, fields,
operators, variables, and functions as long as it evaluates to a single value:

= "Order Total: " + row["orderTotal"]
= row["orderDate"].getYear()
= row["itemQuantity"] * row["itemPrice"]

You use expressions when you need to change the value dynamically. See the following example.

Extensibility Designer Report Guide 29



’

>

-

Delte Know more.
Do more™
Guidelines and References

o Expression Builder (JavaScript) = I@

Expression Builder

Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your

expression,
BRI B
1("Y".equals(CP_getParmString("LAB_CST_FL")) ? row["LAB_CST_AMT"] : row["LAB_REV_AMT"] ) ,
I v

Or, you use expressions when you need to hide or show the control dynamically as shown in the
following example.

< Expression Builder (JavaScript) = 'Ij
Expression Builder
Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your expression.

2 X 2 =

Lif (row["nSubTotTypeMo"] » =2 || CP_getParmstring("PS_REVENUE_FL").equals("Y"]) {
var nselect = CP_getParmint("PM_SELECT_MNO");

3 if ((nSelect == 3 || nSelect == & || nSelect == 7 || nSelect == 8) &8 row['nSubTotTypeMo"] »= &) {

4 true;

501

6 else if (row["nSubTotTypeMo"] == 5) {

7 var total = Math.abs(row["nColumn2"]) + Math.abs(row["nColumn3"]) + Math.abs{row["nColumn4"]) + Math.abs(row["nCalumi
g if (total == 0) {

9 true;

10 }

11 else {

i -

Or, you use expressions to customize the appearance dynamically as shown in the following
example.

T =5 =R =] = 7 T T

g Report Design

i *pjrproj.rptdesign *new_report.rptdesign &2

Script: [onCreate VI - = @ Data(CP_CurrencyC...) - CP_CurrencyCntl

CP_CurrencyCntlCnCreate (this);

if (this.getValue() > 100) {
this.getS5tyle () .color = "red";

TS R

|

Use scripting only when other means for control customization cannot provide the desired result.

All standard Costpoint controls have CP_ControlINameEventHandler(this) methods. If you override a
control event handler, keep CP_ControINameEventHandler(this) as the very first line of custom code.

Never remove the CP_ControINameEventHandler(this) call.

Naming Conventions

Use a descriptive name for the control display name (for example, PROJ_ID, ACCT_ID, ORG_ID,
PageHeaderProj).
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@ Edit Data Binding (=

Column Binding Mame: | CP_CurrencyCntl

Display Mame ID:

Display Mame: LAB_CST_AMT]

Data Type: [Decimal VI
Expression: row["LAB_CST_AMT"] Fil-
'ﬁ?\" oK ] ’ Cancel

s

Hiding Element

A visibility formula is available for all data controls, grids, tables, grid rows, and table rows.

To engage conditional show/hide:
1. Click Properties » Visibility tab
2. Select the Hide Element check box.

3. Display the Expression Builder, and enter an expression to hide an element.

Layout | Master Page | Script| XML Source Pregiewl
= Property Editor - Data 2 T Properties [£( Problems| Bl Console 55 Progress
Properties | Binding | Map | Highlights

General Visibility

Padding

Border

Margin @ For all outputs

Format Number () For specific outputs...

Format DateTime Detail (All outputs)

Format String
Hyperlink Expression: | true Ful=
Page Break
Visibility

Table of Contents

Banl

Important Note about Hiding a Table Object

If you need to hide a table object, then do not use the table visibility formula. While using the table
visibility formula will hide the table when the report is rendered, the table itself is still executed at
runtime. This means that the table processes all assigned data sources/sets and all grids and
controls that the table contains. Report performance will be impacted badly because of this.

Instead of using a table visibility formula, you need to suppress the table from being executed in the
first place.
To suppress atable from being executed:

1. Display the Report Outline, and locate the top most report element (for example,
pdrmcat.rptdesign).

2. On the Script tab, override the beforeFactory method.
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= Report Design - C:\costpointweb'71\sys\birt\report\bin'pdipdrmcat\pdrmcat.rptdesign - Eclipse

ile Edit Page Mavigate Search Project Run  Window Help
rﬁvflﬁl] (=] @ - %v = 5 v S v ¥ O v o v
Es. Mavigator | o= Outline &% o ¥ = O||fi cp_components.rptlibrary ( pdrmeat.rptdesign &7

pdrmcat.rptdesign
(f Data Sources
[ Data Sets
() Data Cubes

Script: |initialize

V]

Bk @

CF initialize

onPreEare

({3 Report Parameters afterFactory

([ Variables beforeRender

@ Body afterRender

[D MasterPages onPagestart

] styl 9 onPageknd
es

[52] Embedded Images
cp_components.CP_Theme

% Libraries
& Scripts

4

Layout |Master Page | Script| XML Sourcel Pregiew|

[ Resource Explorer &3

& T = EIW (@ Property Editor - Report (ﬁ Properties &3 E_l. Problems} = Console}
L

You may reference only report parameters and/or report constants within the expression that

drives whether or not to remove the table from report execution.

3. Enter the following script:

// remove table object from report build based on params
it (ICP_getParmBoolean(""REPORT_OPTION_CD)) {
CP_RemoveTableFromBuild("'DataSetLandThbl™);

" = T " " "
Edit Page Mavigate Search Project Run  Window Help
4> 5 @ - 28 H r 3l v¥0 O v o v
Mavigator | o= Outline &2 o 7 = O/ cp_components.iptlibrary ( pdrmcatrptdesign 2
E;’g:;t'sr::z?n Script: | beforeFactory - ¥ B®@ | pdrmcat.rptdesign
[ Data Sets // remove table cbject from report build based on params
i ! (CP_getParmBoolean("REPORT_OPTION_CD' CP_getParmBoolean(”REPORT_OPTION_CD1
[ Data Cubes 7 (L g u i = LEry) e @y i . = Len t
CP_RemoveTableFromBuild(“DataSetLandThl™);
{3 Report Parameters

Report Page Settings

Unless it is an external report with a special page size and margins requirements, the guideline is to
keep all margins equal to 0.38". This margin size is the minimum standard that must be followed.
Less than 0.38" will cause the report not to fit properly and look undesirable when switching to A4
paper.

If your report margins are less than 0.38", notify the Design and Architecture teams so the report
margins can be reviewed for the possible need of redesign or rework.
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Possible options:

= Ifitis a Landscape report and C/S left/right margins are less than 0.38", then keeping the C/S
margins on the Web (using less than 0.38") is fine. An alternative would be to decrease the
font size from 8 to 7 in some sections of a report (for example, the detail section) and keep
the standard margins. This alternative is acceptable, but less preferable, compared to
decreasing the margins and keeping the font size standard.

= |fitis a Portrait report and C/S left/right margins are less than 0.38", then, on the web,
margins must be 0.38" and the font size may be decreased from 8 to 7 in some sections of a
report (for example, the detail section) to fit the data.

The Design team must be informed before choosing either approach.

Margins cannot be smaller than 0.25” for Landscape reports and 0.38” for Portrait reports.
Having appropriate margins ensures that a report can be printed without data truncation.
Generally, printers have their own small margins as well.

If you are working on an external form that has specific page size and margins requirements, then
follow these requirements precisely since the only rule is to replicate a special form as close as
possible.

Margins and paper size/orientation in the design tool MUST match margins and paper size in the
* rptdesign file. The system applies the following defaults if margins and/or paper size/orientation are
not specified in the design tool:

= paper size code=Letter
= orientation=landscape
= all margins=0.38

So if a report template falls in this default category, then it is not required to provide page
size/orientation and margins in the design tool. In all other cases, developers are required to enter
page settings in the tool.

If a report is designed for Legal or A4 paper or if a report is a government form, then you should
select the Always Use Design Settings check box on the Enter General Report Info screen in the
design tool. Selecting this check box instructs the system to ignore the system/user page settings and
use the report design time page settings.

Cover Page

All Costpoint reports must have a cover page. A cover page must be one page only. If there are many
options, they should be arranged in columns across the page in order to use up as much space as
possible. If the report has non-contiguous selections, the printing of selections should be limited so
that they do not cause a page break. If necessary, some non-contiguous selections should not be
printed if there is no room for them on the page.

= The cover page is provided by the Costpoint templates as the starting point when creating a
new report.

= The cover page object can be re-inserted from cp_presenation.rptlibrary intothe report
design.
To add a cover page:
1. Inthe Resource Explorer, locate cp_presenation.rptlibrary.

2. Drag the cover page object from the library into the report design.
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Page Header/Footer

All internal reports must have a standard page header and footer. The page header/footer is provided
by the Costpoint templates as the starting point when creating a new report. These objects can be re-
inserted from cp_presentation.rptlibrary into the report design.

To create a page header/footer:

1. On the Master Page tab in the Report Design window, use Outline view to locate the
CP_ReportBody page under the MasterPages component.

2. In Resource Explorer, locate cp_presenation.rptlibrary and drag the page header/footer
objects from the library to the CP_ReportBody » Header/Footer folder in the Outline view.

In case of multiple report sections and different page settings, you may need to create additional
page objects and place standard Costpoint page headers/footers onto new pages.

To create the new page object, right-click MasterPages in the Outline view, and click Insert Element
on the shortcut menu. Rename the new object (via the right-click menu), and change the page
settings (page size, margins, and so on), if needed.

The default height of the standard Costpoint header is 1 inch. You should change the Page Header
default height only when you need to present more data that may not fit vertically. In the following
example, the report title has two lines of text.

Foow o 100% v T [ %5 Debug [} Report Design

5| & syrusraptdesign pjpobt.iptdesign 52 =

o R R R S R R AR EE R R (IR

[CP_CompanyName]

- = alculate Over Budget Transactions Report| Page N of 1
: 'ransactions in Excess of Budgeted Amounts Report] [CP_BuildDate

(CE_BuildTime

n

[Additional Infor...]

“ CP_iTextCntl
. H Grid
g
< |lm
Layout | Master Page | Script| XML Source | Preview
[EZ Property Editor - Label &% .= Properties| B Console| [21 Problems =
Propertics | Highlights
General Advanced (4 ¢
Padding
Border Property Value
T On creste CP_LabelCntlOnCreate(this); : Inherited
rgn On page break CP_LabelCntiOnPageBreakithis); - Inherited
Hyperlink On prepare CP_LabelCntlOnPrepare(this): : Inherited
Page Break On render CP_LabelCntlOnRenderithis); : Inherited
Visibility Overflow Hidden : Inherited

Push down true : Inherited

Lacalization
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You can change the Master Page » CP_ReportBody (page) » Properties » General » Header
Height from 1 inch to 1.24 inches.

=8

-~

Layout | Master Page | Script| XML Socurce | Preview

@ Property Editor - Master Page % = Properties El Console t Problems

Properties
£|| General General
Eomer Mame: CP_ReportBody
Margin
Header/Footer Header height: 1.24 in =~ Background color: || Auto -
Comments . - i .
Eooter height: | 0.6 in ~ | Orientation: Landscape -
Advanced
Width: 1 in | Type US Letter -
Height: 85 in -

= If your report title has 1 line, then the standard page header height should be 1 in - default.
= If your report title has 2 lines, then the standard page header height should be 1.24 in.
= If your report title has 3 lines, then the standard page header height should be 1.48 in.
The default height of the standard Costpoint footer is 0.6 in. You should not change the footer height.

You can insert standard Costpoint page header/footer objects from cp_presenation.rptlibrary into the
new page by dragging page header/footer objects from the library directly into CP_ReportBody page
» Header/Footer in the Outline view.

The new page object should be correctly mapped to your table object in the report design. Switch to
Layout view and in the Body folder of the Outline view, locate the table object that should display
data for different report section. Click Table » Property Editor » Page Break, and change the master
page to the page that you crated. As the result, all data that goes into the above table will be
displayed on a page with possibly different layout margins, headers, and footers.
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REPOTT DRSS - oS pOITWED LSy S DT T Ep T B Sy Y TS Sy TS T TP TaesIg T - ACTUATE BIR T UESIgIEr PTOTESETonal

ile Edit Insert Element Data Page MNavigate Search Project Run  Window Help
G-EB& i g L AT AT AL RS- TH R e
7§ &' Java < Plug-in Development %5 Debug [/ <Report Design>
k5 Navigator 8= Outline £ ¥ =0 *syrusr.rptdesign £2 | §i cp_presentation.rptlibrary
[ syrusrrptdesign - D L S S - S I S
[ Data Sources 3 Email Notificatiom: [CHE_PRC_NOTIFY_FLI
(& Data Sets .
(3 Data Cubes - Workflow Email:
[£3 Report Parameters A = -
([ Variables . Send Work Flaw [EMATL WF_ACTVTY FL]
[ Body - S, E .
@ Grid - CP_CoverPagePortrGrid . Send Workflow Message: |[EMAIL WF_MSG_FL]
i Grid - CoverPageDetlPortGrid . Enail Name [DMAIL NAME]

[ Table - DataSetPortrThl R I
P Grid - CP_NoRowsPortrGrid

Company Information
[} MasterPages

1

12

[7] simple Master Page - CP_CaverPage Company : leompanyld] [COMPANY_N)
[ simple Master Page - CP_ReportBody . Org Security Group [orgSecGroup] [ORE_SEC G|
[ Header N E] Def. Taxable Entity: [dfltTaxEncityl [TAXBLE_EN|
D Footer ) Data Suppression:
[ simple Master Page - CostsExpensesSectionPage
[ Header n Labor [SUPERESS_LABOR]
[E Footer ) Price [SUPPRESS PRICE]
Styles Costk: [SUPPRESS_COST]
Embedded Images i
cp_components.CP_Theme Layout | Master Page | Script| XML Source | Preview | Desktop Viewer (prototype)
2 Libraries — —
L:zf vt - |[E Property Editor - Table &3 | = Properties [£. Problems 5 Progress
I$ Data Explorer | fiij Resource Explorer &2 o ¥ = O || Properties| Binding| Groups| Map | Highlights | Sorting | Filters
. cp_buildjz “ || General Page Break
it cp_compenents - RUN WITH OPEMN SOURCE.rptlibrary
it cp_compenents.rptlibrary Bordey Before: Auto - | Aften Auto
j Margin
£ cp_controljs H Inside: Auto <] Page BreakIntenval: |40
i cp_presentation - - RUN WITH OPEN SOURCE.rptlibrary Page Break
(f Data Sources Visibility Master Page: | CostsExpensesSectionPage - [¥] Repeat Header
|5 Data Sets N
(i Data Cubes Table of Contents C;nCE .
overPage
(43 Report Parameters Bookmark CP:ReortBogd
[ Report kems Comments CostsExpensesSectionPage

[ Grid - CP_CoverPagelandGrid
FH Grid - CP_CoverPagePortrGrid
[ Grid - CP_NoRowsLandGrid

User Properties

m

Named Expressions

To add report abbreviation data in the page footer:

1. On the the Master Page tab in the Report Design window, use the Report Outline view on the
left to locate CP_ReportBody page under the Master Pages component.

2. Scroll to the bottom of the page, and select the page footer grid.
Select the grid row that contains the Enter Report Abbreviation Data Here text.

4. Inthe Row » Property Editor » Visibility section, and click the formula (fx) button beside the
Expression field. The Expr Builder dialog box displays.

5. Set the visibility expression to false, and click Ok.

6. Click the Enter Report Abbreviation Data Here text, and change its value to a report
specific abbreviation text (for example, ACCT: Account; PROJ: Project).

Access DataSet Variables in Page Header

By default, BIRT does not allow access to DataSet variables on the page header. This is the limitation
of BIRT where, for performance reasons, page header/footer objects are static and created only once
for whole report/table section/object.

However, you can display DataSet variables in Page Header » CP_AddReportinfo (CP_iTextCntl)
control by using the BIRT Page Variables.

= The BIRT page variable are only to be used in the page header and only within the
CP_iTextCntl control.

= The BIRT Page Variable will hold the value of the last DataSet row that falls on that page.
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= The variable must be a break group control

To use the BIRT page variables:
1. Add a new page variable in Variables » New Variable » Page Variable.

l= Report Design - C:\costpoil b\70\dev\apps\comideltekenterprise\application\sy\syrustrptisyrusr.rptdesign - Eclipse
File Edit Insert Element Data Page Navigate Search Project Run Window Help

IR (v io A @ e - |8

@ -
5. Navigator | o= Outline & . 42 Pa\ette] @~ -0 syrusrrptdesign £2 pjpobt.rptdesign W
syrusr.rptdesign - I S 2 3o 40 5
(g Data Sources
(= Data Sets

[ Data Cubes
(43 Report Parameters
({5 Variables
[ PV_USER D -
[ Body
@ Grid - CP_CoverPagePortrGrid
[ Grid - CoverPageDetlPortGrid
=] Table - UserTable
=] Table - CompanyUserTable
E] Header
[] Detail
[E Footer
[S Groups
[E] Table Group - CompanyGroup

[CP_CompanyName

& User Report

_—

[CP_AddReportInfol

Edit Variable

[E] Table Group - UserGroup Type: () Report Variable @ Page Variable
[£ Header =
T Row Name: PV_USER_ID|
[ Cel Default Value:
i Grid
O Row —
[ Cell

Grid — —

L o R 4 Property Editor - Variable @ [ o J[ came |

[] Cell Properties

7 Griel |

2. Name the variable using the following naming convention:

= The variable name should be uppercase and should start with PV_ prefix (for example,
PV_USER_ID).

3. Set the value of the page variable by overriding the onPageBreak() method for the control
that displays the DataSet data that you want to use in the page header.

If such a control is not there or should not be in the report by design, you need to
’ create a dummy table/grid row, put a dummy control on that row, set control value, and

make sure that this dummy control's parent row is hidden through:

overridden Row>Scrip>0nRender()
method>this.getStyle().setVisibleFormat("'all'™);

overridden Row>Scrip>OnCreate() method>this.height = "0in";

Do not hide the row or control using the Hide Element check box or set row height to 0. Use
the above setVisibleFormat("all") approach only.

fapvudecd.rptdesign 1

[T

Script: ’unﬁender v] | - | e (D
this.getStyle().setVisibleFormat("all"};
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[ & syrusr.rptdesign | 5 ColumnarReportMewspaperStyle.rptdesign

Script: ’onCreate - ] |

this.height = "Bin";

The control's onPageBreak() method should be overridden to set the page variable value.
For example:

reportContext.setPageVariable("'PV_USER_ID", this.getValue()

it Page Mavigate Search Project Bun  Window Help

HEE® Q- @ -8 oEra~

gator | 5Z Outline &3 % Palette] @~ = 5 pjpobtrptdesign |

Eyrusr.rptdesign - . =

[ Data Sources Script: [anPageBleak v” v| & @
l& Data Sets reportContext.setPageVariable("PV_USER_ID", this.getValue());

gl Data Cubes
{3 Report Parameters
& Variables

[F PV_USERID
[l Body

B Grid . 7D 1] D orteiGricl

CP_TextCntlOnPageBreak(this);

4. Go to Master Page » CP_ReportBodyPage » CP_AddReportinfo » Expression, and
reference the page variable value using the CP_TranslatelTextPageVar(pvName) function

For example:
CP_TranslatelText("'User ID:") + " " + CP_TranslatelTextPageVar("'PV_USER_ID").

syrusr.rptdesign 2 pipobtrptdesign ]

[CP_CompanyName]

[ User Report Page N of

O — [CT_BuildDat
[CP_AddReportInfol =

Expression Builder

Type an expression in the Expression field, Browse the lists of available objects and double-click to copy into your expression,

BAEBXIDBEE

1 CP_TranslatelText("User ID:") + " " + CPfTransIateﬂTextPage\-’ar("PVﬁUSERﬁID") -

| avout | Master Pane | Scrint | X

You can also use the CP_TranslatelTextPageVar(pvName, format) function in case you
need to format data. For example:

CP_TranslatelTextPageVar(*'PV_PSWD_CH_DT", "CP_DateCntl')
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Be sure to add this variable as a break group and set the page break properties so that it will

break on this break group change. Otherwise, you may have a page where the variable has
changed and it will take the value of the last one.

Lines

You must use CP styles in order to provide separation lines for the cover page, report detail, and
page header/footer sections.

Select the row(s) of a grid or a table for which you want to draw a line under. Right-click and click
Styles » Apply Styles. Then choose a line as one of the following styles:

= CP_2ContentLineStyle (double content line) — Use on the cover page.

= CP_ContentLineStyle (single content line and bottom line) — Use on the cover page,
table detail section, and at the bottom of column headers.

= CP_HeaderLineStyle (header line for Page and Group Headers) — Use on page and
group headers.

The line style provides required line width, style, and color.

Column Headers

The column headers must be placed in the table header or group header sections. Use the
CP_ColHdrStyle style for cells where you place column header labels. This style provides the
required background color and minimum white space in-between the headers.

To create column headers:

1. Use table or grid row for placing column headers. Initially, the row should have empty cells.

:| |[[COUNTRY¥] [COUNTRY NAMEZ]

Hold SHIFT, and select all the cells in the row
Apply CP_ColHdrStyle to the cells.

Do not apply the style to the row or to the column header labels. For the right-most
column header cell, you may need to apply CP_ColHdrNoRightBorderStyle.

4. Drag the CP_LabelCntl controls (labels) from the library to the column headers row/cells, and

adjust text alignment if necessary.

5. Adjust the row height setting in Row » Property Editor - Row » General » Height if
necessary.
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For the Right-most Column Header Cell Only

To avoid displaying a tiny vertical line just to the right of the last column header, you may need to
apply CP_ColHdrNoRightBorderStyle .

Error

*** DUPLICATE ***

Select the right-most column header cell, and apply CP_ColHdrNoRightBorderStyle to remove the
right vertical border line.

CHK_FOR_LOOE_DARTS Yes/No Label

nning Option to MERP Planned: | CHE SEL PAET Yes/No Label

|
Deacription Revw Comjor. Error
T | |
[WU_COMD PART DESC] [ASY DART  [COMD LN ) —

NHO ROWS FOUND THAT MEET SELECTION CRITERIA

=~ | Background color: @ RGB(221,221,240) -

- Fi:yle: CP_ColHdrNoRightBarderStyle \
|

CP_ColHdr5tyle
CP Co i
CP DateTimeStvle

The report out will look like this then:

snt
Error

**% DUPLICATE **%*

1

Page Break (Conditional Page Break)

Page Break for a Group

In order to add a page break after the group, click Group properties, and then click Page Break »
After » Always Excluding Last (Always).

= For the top most Group, select Always Excluding Last.
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= For the Nested (Inner) Groups, select Always.

= Edit Group ==
Group Details ‘
MName: Sort direction
Module @ Ascending
Group On: (2) Descending
MODULE - Page break
Interval: Range: Before: ’Auto V]
[No Interval vl After: [Aw ,]
Uze fixed base value for interval: . Auto
Inside:
REEE Avoid
["] Hide Detail Always Excluding Last
Bookmark:
Table of Contents
Item Expression:  row["MODULE"]
Style: ’None VI

Filters and Sorting

Filters Sorting
Filter by: Remove | |Edit..| |MoveUp| | Move Down

Expression Operator Valuel Value 2

Conditional Page Break

A conditional page break can be done through scripting. For example, you have to provide a page
break after a group driven by a report parameter:

1. Goto Outline » Body » Table » Group object

2. Click on script tab, and override the onPrepare method to set a page break driven by a
report parameter.

= For the top most group, use the always-excluding-last value.

= For the nested (inner) groups, use the always value.
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e s P Yy )

svigate Search Project Run  Window Help

CP_CoverPagePortrGrid
CoverPageDetlPortGrid
DataSetPortrThl

der

ail

ter

ups

Table Group - CompanyGroup
Table Group - UserGroup
CP_NoRowsPortrGrid

es

Master Page - CP_CoverPage
Master Page - CP_ReportBody
der

ter

L

@-iQ-igg HH oD
itine &3 - | SYRDD.rptdesign tdesic
" Script: [unPlepale v] ‘ *l E'\“ @ | Table Group - UserGroup
= ".equals(CP_getParmString(" i
< geBreakAfter( "alway:
ameters

For the Top most Group (onPrepare method):

it ("Y' .equals(CP_getParmString(""PAGE_BRK_FL'™))) {
this.setPageBreakAfter('always-excluding-last');

}

For the Inner Groups (onPrepare method):

it ('Y".equals(CP_getParmString("'"PAGE_BRK_FL'™))) {
this.setPageBreakAfter('always™);

}

Page Break between Report Sections (Tables)

In you need to have a page break between report sections (table objects), do not set the page break
at the table level. Instead, drag the CP_PageBreak component from cp_components.rptlibrary and
insert it right after CP_NoRows Grid for each table in report design.

[ -5 @~ W~ A

e Edt Insert Element Deta Page Navigate Search Project Run  Window Help
B r5lvta e

-

 Navigator "Eigm g‘ N

e~ -0

syrusr.rptdesign f piraljnl.rptdesign

fapaexp.rptdesign
1> (5 Data Sources
4 ([ Data Sets
|+ (' FAPAEXP DSL Data Set
b ¢ FAPAEXP DS2 Data Set
(5 Data Cubes
(§3 Report Parameters
(i Variables
[ Bod
¢V, Grid - CP_CoverPagelandGrid
© [ Grid - CoverPageDetiLandGrid
» [ Table - FixedAssetsDetailReport_LandTbl
© ¥ Grid - CP_NoRowsLandGrid
., [, Grid - CP_PageBreak %J
M =] Table - FixedAssetDisposalEdRRpt_PortThl
» %53 Grid - CP_NoRowsPortrGrid
o [ MacterPage
> [ Styles
[za] Embedded Images
& [ cp_components.CP_Theme
b L Libraries
b & Scripts

Fi Resource Explorer 52

@wmi

[ fapaesp.rptdesign 52

Asset No

[HdrGrp RSSET ACC.. .1
[SubGrp ASSET ORG...]

[SubCrp_ASSET_PRO. .1

[EXE_ROW |[ASSET_ID]

[ITEM

(Tag_NO_S] [SHORT_DESC]

Short Description

(FA_TMPLT_ID]
(SubTavall
[SubTotall

[SubTotal]

Asset No

[ASSET_ID]

[ITE H|[[5_]

Gain/Loss
DIS [GWLS_ACCT ID] |[GNLS_ORG_ID]

Report Totals

NO ROWS FOUND THAT MEET SELECTION CRITERIA

Depreciation
[B1_DEFR_ADJ AMT]

[SUM_B1_DEPR_AMT] [SUM_DISE_FRICE_AMT

[DISP_PAICE 2MT]

E Data(CP_DateCntl) - CP_DateCntl
=

>

Layout | Master Page | Script| XML Source | Preview|
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User Report -2

ATi :
JEItEK i. ];::Et:;m:y

Parameter ID:

election Ranges

Selected Companies:
Selected Users:

ort By
Uzer:
Company :
ptions

Show Company Detail:

Humber Of Pages:

Include Deactivated Users:

Show Security Information:

SuperTech, Inc.

User Report

8/25/11 1z:14 BEM
CESUBERUSER

o1 01

a

Report Options

211
211

Suppress Repeated Values

Suppress repeated values is supported for the following controls:

= CP_TextCntl
= CP_LabelCntl

= CP_LabelYesNoCntl

= CP_DateTimeCntl
= CP_DateCntl
=  CP_TimeCntl

Use this feature only for controls that are being placed into the table/table group detail section. In
order to enable Suppress repeated values, go to Control » Properties, and set
CP_SuppressDuplicates to True.
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Preferences this user can change:

Password [CHANGE_PASSWORD]
. Hame [CHANGE_NEME]
ell N Phone [CHANGE_PHONE]
! i Default Company: [CEG_DFLT_COME_FLI
S

&l Label - CP_LabelCntl

ell

& Label - CP_RangeCntlil

&l Label - CP_NCRRangeCntl

Email Notification [CHE_PRC_NOTIFY FL]
WorkElow Email:

Send WorkFlow [EMATL_WF_BCTVTY FL]

= Sand WarkFlamw Massama- | [TMATT. 6% MSZ FT1

Layout | Master Page | Script | XML Source | Preview

v
@ Property Editor - Data | =] Properties £3 [L Problems| & Console

$ 70
Data
Property Value
Data
ary Allow export true : Inherited
Background
pry Bookmark

Bookmark display name
Box

omments

CP_SuppressDuplicates true -
Custom XML false

Data binding reference

Display name
Display name key
Event handler class
Font

Data Suppression (Labor, Cost, Price)

The correct approach to implement data suppression is to identify the suppressed column in the
Extensibility Designer for report data source RS. The framework relies on correct RS metadata when
implementing security filtering for archived reports.

)| =i s yu | LR Ea S T_=IwT RS = e T_ =T
LABE CST N = General Info I C o R nl
5 LAB CST_AMT UPFENCY and Hepo
2 _MATL_B_CST_AMT - DE Opticns
S MATL_CST_AMT Table |Z_INRISTS vWRK2 Column [4_LAE_B_CST_AMT
& MISC1_B_CST_amMT
A MISC! CST AMT Type INumber 'l Precisiu:unl 14 Scalel
A_MISC2_B_CST_&MT [ From select [ Primary ey [ &l Edit ot B | Save Mul (FK) [ DB
£ MISC2_CST_amT
A_SUBCT_B_CST_AMT ~l Options
A_SUBCT_CST_AMT - y ; Iﬁ )

- - = - -
YT _ABBRY CD Wisihle IOn cliert _I _I Editable [ves J Reguired IF
INYT_LOC_ID Ternplate [MNane | Format frore =l W incluge
IM_IMNEP_QTY
IM_MRE_QTY —walue Options —— 00
IN_SHIP_QTY T ) .

= = Clear Of lane keep Orig. Walue Persist If Dizab
ITEM_DESC I done [ Keep Orig -
LAE BURD_CST_AMT Suppressilg “alue I
LAE CST_AMT 3 :
Lz Ty ~Laockup Info i = =
MATL_BURD_CST_AMT Gro & I_ i : Walidate Severity

B ¥ | ¥ nfo Tl =

MATL_CST_aMT ) i
MISC1_BURD_CST_AMT =
MISC_CST_AMT
MISC2_BURD_CST_&MT Ok Il | =] IF walivete lookup | NEEE
MISC2_CST_AMT
OR HAMD QTY Scope IGrDup 'I Walidation Mg I

In addition, you can hide these columns and column headers in *.rptdesign based on the suppression
constants passed to a report at runtime by changing control Visibility formula:

// Hide if user suppress cost flag is Y
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"Y' _equals(CP_getConstantString( "CP_WUSERCOMPANY_SUPPRESSCSTFL™ ) )
// Hide if user suppress labor flag is Y

"Y' _equals(CP_getConstantString( "CP_WUSERCOMPANY_ SUPPRESSLABFL " ) )
// Hide if user suppress price flag is Y

"Y' _equals(CP_getConstantString( "CP_WUSERCOMPANY_ SUPPRESSPRCFL™ ) )
Dynamic Page Layout

You can create page objects of different size, margins, and page layout (lanscape or portrait) and
then assign this page to a table object in Outline » Body » Table » Page Break » Master Page.

For multiple report sections and different page settings, you may need to create additional page
objects and place standard Costpoint page headers/footers onto new pages.

To create a new page object:
1. Right-click Master Pages in the Outline view, and click Insert Element on the shortcut menu.
2. Rename the page object, and change the page settings if needed.

The default height of the standard Costpoint Header is 1 inch. The default height of the
standard Costpoint Footer is 0.6 inch.

Outline &3 = = O | E vertical.rptdesign 5 syrpostrptdesign &2
- IR EEEEE R 2o 3o 4 S 6 T 8ot
Pages .
ple Master Page - CP_CoverPage o
ple Master Page - CP_ReportBody - [CE_CompanyName]
Header .
[, Grid - CP_PageHdiPortrGrid I = Enter Report Title EHere Fage N of :
[ Row N r —_— [CP_BuildDate:
- [CP_AddReportInfe] -
T Row - b =
O cel N
7 Grid .
0 Row o
[ cel -
[ cell .
7 Grid B
0 Row .
O Row -
O cell "
El Data(CPLi || -
1 Cell = -
O -
rer 3 |
L L=
sources
fate .
ild js Layout | Master Page | Script| XML Source | Preview | Desktop Viewer (prototype)
;;fj::m rptioreny [ Property Editor - Master Page £3 | £ Properties | [2 Problems | = Progress| @) Error Log
sentation.rptlibrary Properties
ta Sources
o Sets General General
ta Cubes || Barder MName: CP_ReportBody
port Parameters =l ||ysasrgin
p;:;‘ra’g;’[wgrpEQELEMGM Hezder/Footer Header height: |1 in | Background color: || Auto =3
Grid - CP_CoverPagePortrGrid Comments Footer height: | 0.6 in  ~  Orentation: Portrait -
Grid - CP_NoRowsLandGrid Advanced
Grid - CP_NoRowsPortrGrid Width: 85 in <] Type US Letter -

3. Insert standard Costpoint page header/footer objects from cp_presenation.rptlibrary into the
new page by dragging page header/footer objects from the library directly into Outline »
CP_ReportBody page » Header/Footer.

The new page object should be correctly mapped to your table object in the report design. Switch to
Layout view, and in Outline » Body, locate the table object that should display data for the different
report section. Go to Table » Property Editor » Page Break, and change the master page to the
newly created page. The result is that all data that goes into the above table will be displayed on a
page with possibly different layout margins, headers, and footers.
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ile Edit Insert Element Data Page MNavigate Search Project Run  Window Help
HrEHBEE = - @ B @ Q@ E e o -
= aJ Java <= Plug-in Development %5 Debug

K5 Navigator 8= Outline £ 1 @~ =0 *syrusr.rptdesign 2 1@ cp_presentation.rptlibrary
[ syrusrrptdesign ;_‘ D S S B S - S Y S
[y Data Sources 3 Email Notificatiom: [CHE_PRC_NOTIFY_FLI
[ Data Sets .
(f Data Cubes - Workflow Email:
[£3 Report Parameters )
([ Variables . Send Workflow [EMATL WF_ACTVIY_FL]
[ Body - EO
@ Grid - CP_CoverPagePortrGrid - Send Workflow Message: |[EMAIL WF_MSG_FL]
i Grid - CoverPageDetlPortGrid Enail Name: [DMAIL NAME]
EE] Table - DataSetPortrThl -
P Grid - CP_NoRowsPortrGrid Company Information:

m

[} MasterPages

[) Simple Master Page - CP_CoverPage H Company : leompanyld] [COMPANY_N
D Simple Master Page - CP_ReportBody - Org Security Group: [orgSecGroupl] [ORG_SEC G|
[ Header N E] Def. Taxable Entity: | [dfltTaxEncityl [TAXBLE EN]|
[El Footer .
" . . Data Suppression:
imple Master Page - CostsExpensesSectionPage
[ simple Master Page - CostsExpensesSectionPag
[E] Header g Labor: [SUPPRESS_LABOR]
[E Footer i Drice: [SUPPRESS_PRICE]
B4 Styles i Cost: [SUPBRESS_COST]
[ga] Embedded Images N -
cp_components.CP_Theme | Layogut| Master Page | Script| XML Sourcel Pra!iew‘ Desktop Viewer (prototype]l
Libraries
it - |[E Property Editor - Table &3 I = Proparties| [ Prob\ams| =3 Progress‘
I$ Data Explorer | fiij Resource Explorer &2 & ¥ =0 Propertiesl Binding ‘ Groups| Map‘ High\ights‘ Sorting| F\Itersl
cp_build.js “Nrgoma || P
- General age Break
it cp_components - RUN WITH OPEN SOURCE.rptlibrary e
it cp_components.rptlibrary Bordey Before: Auto - After: Auto
j Margin
cp-control s -] Inside: Auto <] Page BreakIntenval: |40
@ cp_presentation - - RUM WITH OPEN SOURCE.rptlibrary ||| PageBreak
g gata :DUKE; Wisibility Master Page: | CostsExpensesSectionPage - [¥] Repeat Header
ata Sets e |
Mone
I Data Cubes M CP_CoverPage
(43 Report Parameters Bookmark CP_ReportBod
[ Report kems Comments _0stsEx)
[ Grid - CP_CoverPagelandGrid User Properties
% Er\: - (él;_:m:rl’aﬁel’:gr[;nd = Ry ——
rid - CP_NoRowsLandGri - "

Page Numbers (Restart Page #)

The page number control should be displayed at the top right corner of the page. The page number is
a part of the standard Page Header that is provide by the libraries.

= Use CP_PageNofMCntl control to display standard Page N of M text.

= Use CP_TotalPageCntl control to display report total page count.

Restart Page Number

There are cases when you need to restart page numbers within a group (for example, display new
pagination for each voucher or invoice).

Use the following technique/rules to achieve restartable page numbers per break group:
= The break group must have a page break on changing of a group key.

= Call the CP_pageRestartGroupBeforyFactory(tableName) function in report » beforeFactory
script.
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POIT DS - LI W OTRTRE g THESTgIT PIESTIESTAIT page NUMDErTCP_TESTart page NUTDer Mew. T g - ECIIPEE

Edit Page Mavigate Search Project Run  Window Help
hHEE QG & F bt E-

A
Navigator | o= Outline &2 = Palette] ® - ~B «cp_restart page number new.rptdesign &%
cprestart page number new.rptdesign = Script: [befmeFacmq,r V] il EG) | cp_restart page numbe
(f Data Sources
[ Data Sets L cP_pageReftartGroupBeforyFactory(“mytable”);
() Data Cubes 1
({3 Report Parameters
([ Variables
[ Body
A Grid
[E Table
El Header
[F] Detail
[ Row
[ Cell
[ Cell -
T ] »
Resource Explorer E2 7 =08
E Data(CP_DecimalCn...) - CP_DecimalCntl -
E Data(CP_DecimalMe...) - CP_DecimalMoThouCnt
E Data(CP_IntCntl) - CP_IntCntl
E Data(CP_IntMeThou..) - CP_IntMNoThouCntl
E Data(CP_iTextCntl) - CP_iTextCntl
E Data(CP_PercentCn...) - CP_PercentCntl
E Data(CP_RateCntl) - CP_RateCntl
E Data(CP_TextCntl) - CP_TextCntl
E Data(CP_TimeCntl) - CP_TimeCntl
FH Grid - CP_PageBreak
[#] Image - CP_CompanyLogoCntl
[2] Image - CP_DynamiclmageCntl
[a] Image - CP_ImageCntl ) 1
Label - CP_LabelCntl ‘ ‘ Layout ‘Master Page | Script| XML Source‘ Preglaw|
Label - CP_LabelVesMoCntl
[l 1 ahel « ©D Lictrnsl [ Proerty Fditor - Renort 52 1 Pronedies| (3] Problems] Bl Cansolel

= Call the CP_pageRestartGroupOnPageEnd(tableName) function in report » onPageEnd
script.

ign - CiWol portil i 1gn exampl page numbericp_l page number new.| ign - Eclipse
Page Mavigate Search Project Run  Window Help

B i imdr ErE e oo

L(EE Outline &2 % Palette} @~ =0 cp_restart page number new.rptdesign i3

estart page number new.rptdesign - Script: [onPageEnd - - G @ | cp_restart page numl

ata Sources
ata Sets CPipageRestar‘tGmupOnPageEnd(“my‘table“);|
ata Cubes

eport Parameters

m

Variables
ody
M Grid
E Table
[£] Header
[E] Detail
[ Row
[ Cell
] Cell I8
m ] +

E Explorer &2 ¥ =08
Data(CP_DecimalCn...) - CP_DecimalCntl -
Data(CP_DecimalMo...) - CP_DecimalMoThouCnt
Data(CP_IntCntl) - CP_IntCntl
Data(CP_IntNoThou...) - CP_IntMoThouCntl
Data(CP_iTextCntl) - CP_iTextCntl
Data(CP_PercentCn...) - CP_PercentCntl

[ [] [] [ ]

= Call CP_pageRestartGroupSetGroupKey(tableName, groupKey) function in Table » Detail »
Row » onCreate function to set the current group key.
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€sign - CWorkiReporting Biridesign examples Page numbericp_r Page number new.rptdesign - ECpse

Page MNavigate Search Project Run Window Help
1l (SN > N =R 4 - L = -

ltor | BZ Outline 52 L% Palette &~ — 0 cp_restart page number new.rptdesign 2

Data Sets CP_pageRestartGroupSetiiroupKey ("mytable”, this.getRowData().getColumnValue("CUSTOMERNUMEER"));
Data Cubes
Report Parameters L 4
Variables
Body
FH Grid
= Table
D Header
[F] Detail
[ Row
[ Cell
[ Cell -

[ +

restart page number new.rptdesign - 2 —
Script: |onCreate - il = Row
Data Sources = »@

Drag the CP_PageNofMRestartCntl control from the libraries. This control can be used on
both Page Header/Footer or on Report/Group Header/Footer. In CP_PageNofMRestartCntl »
onRender(), override CP_PageNofMRestartCntlOnRender(this, -1,-1); // pass parameters:
(this, pageN, pageOfM). For example:

CP_PageNofMRestartCntlOnRender (this,
CP_pageRestartGroupCntlOnRenderGetCurrentPageNo(""mytable™),
CP_pageRestartGroupCntlOnRenderGetTotalPageNo(""mytable'™)

);

Design - C\Work\Reporting\Birt\design plesirestart page number\cp_restart page number new.rptdesign - Eclipse
Page Mavigate Search Project Run  Window Help
IB@ik-iof- 0-0- 062~
or | 5= Outline &4 +¢ Palette ¢~ =0 cp_restart page number new.rptdesign £3
restart page number new.rptdesign “ || seript: <| [Ew® | Label- CP_PageNofMRestartCntil
Data Sources
Data Sets | CP_PageNofMRestartCntlOnRender(this,
Data Cubes ‘: CPipagERestartﬁruup[ntanRenderGet[urrentPagENS("mytab?:e"), ) -
Report Parameters CP_pageRestartGroupCntlOnRenderGetTotalPageNo("mytable™)); // pass parameters: (this, pageN, pageOfM)
Variables
Body
FH Grid
) Table

] Header

[F] Detail

[0 Row
O cell
[ Cell L
n b

e Explorer i e =|

[E Data(CP_DecimalCn...) - CP_DecimalCntl -

E Data(CP_DecimalNo...) - CP_DecimalNoThouCnt

E Data(CP_IntCntl) - CP_IntCntl

E Data(CP_IntNoThou..) - CP_IntNeThouCntl

E Data(CP_iTextCntl) - CP_iTextCntl

E Data(CP_PercentCn..) - CP_PercentCntl

[E Data(CP_RateCntl) - CP_RateCntl

[E Data(CP_TextCntl) - CP_TextCntl

El_Data(CP TimeCnth - CP TimeCntl

Fonts

The default font is Courier New and the default font size is 8. When you create new controls derived
from the library controls, do not change the default font (and/or size) unless the Design suggests
changes. The smallest allowable font size for Costpoint reports is 7.

At runtime, the system may automatically substitute design time font (Courier New) by a font selected
on the Page Setup dialog box.
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Page Setup X

Identification

Parameter ID Description |

Layout Font
() Porrait g Landscape = Mixed Font  |Courier New v
Courier New
Paper {Inches) Include
Size  |Lefter v ComiArial Narrow
Height 'F Width l“— Page‘?ilnr:es::lew Roman
Logo

Margins {Inches) i@ Mone = Default & Other
Top 0.33 Left |0.38 ~ _ _

|
Bottom |0.38 Right |0.38

oK |  cancer |

For some reports, due to application business logic and report presentation rules, font substitution
should not be allowed. In order to ensure that font substitution does not occur, override the initialize()
function for the top most report component and call CP_keepOrigFont() to prevent the system from
substituting fonts at runtime.

= Report Design - ostpointweb \sys\birt\report\bin\sy\syrusr\syrusr.rptdesig

File Edit Page Mavigate Search Project Run Window Help
M-HBE  @- Q- gf- f-- 0o o

@~ -0 “syrusr.rptdesi
ript: | initialize - < - B&® |syru;r‘rptde;ig

Y
CP_ReportInitialize();

/ syrusr.rptdesign
I g Data Sources

Data Cubes I/ keep UI’I‘]'.giﬂEl report fonts
CP_keepOrigFont();

(3 Report Parameters
([ Variables
[3 @ Body
¢+ [ MasterPages
] Styles
[ia] Embedded Images
I cp_components.CP_Theme
3 % Libraries
3 & Scripts

fiif Resource Explorer 32 =
= Shared Resources

(= template i
(= test Layout | Mastffr Page Script 5ML}mrce| Pre!iew|

cp-build js N— [@ Property EdME PI’DpEI’tiES] E_g Problems] = Conso\e]
cp_components.rptlibrary
=  Pronerties|
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Group Sections and Aggregates

One of the key features of any report is the ability to display summary, or aggregate, information. For
example, a sales report can show the overall sales total; sales subtotals by product type, region, or
sales representatives; average sales figures; or the highest and lowest sales figures.

The aggregates are usually created on a group.

To create a group:
1. Right-click the table, and click Insert Group on the shortcut menu.

2. In athe New Group dialog box, enter a group name, and select a key from the Group On
drop-down list as a simple column, or use the Expression Builder.

3. Ifitis the top most group, enter a Table of Contents (TOC) expression (generally, the same
as group key). If it is the inner group clear, the TOC value as the TOC should be provided at
the top most group level.

i New Group =%
Group Details b
Mame: Sort direction

ACCT_ID_GRP @ Ascending
Group On: () Descending
ACCT ID - Page break
Befare: [Auto v]
CHG_HRS
EMPLID After: | Auto v
ERROR_MSG_DESC
LAB_CST_AMT Inside: |Aute -
LAST_FIRST_MAME
PAY_'_I'YPE - Repeat Header
S_TS TYPE_CD
TAX_FREQ CD
T5.DT
ET5_HDR_SEQ_NO Fe |- |
Table of Contents
Itermn Expression:  row["ACCT_ID"] Felr
Style: ’ ']
Filters and Sorting
Filters | Serting
Filter by: Add...| |Remove | |Edit..| [MoveUp| | Move Down
Expression Operator Valuel Value 2

To create an aggregate:
1. Click the Table Binding tab, and click Add Aggregate.

2. Enter a name in the Column Binding Name field, and select an aggregate function from the
Function drop-down list.
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e | Aggregation Builder IEI
Column Binding Name: | Column2TGA i
Display Mame ID:

Display Name:
Data Type: ’Float v]
Function: [SUM v] 3
Expression: dataSetRow(["nColumn2"] -
Filter Condition: dataSetRow["nSubTotTypeMo"]
Aggregate On: (") Table

@ Group ’sGenBreakGroup v] e
@j [ oK ] [ Cancel ]

Examples of aggregate expressions:
= dataSetRow['nColumn2"]
= dataSetRow['nColumn2"] / dataSetRow["'nColumn3"]

= dataSetRow['nColumn2"] * (CP_getParmint("PN_SELECT_NO")==07?1:0) -
dataSetRow["'nColumn3"]

Examples of filter conditions:
= dataSetRow["'nSubTotTypeNo"] == 10
= dataSetRow['nSubTotTypeNo"] > 1
= dataSetRow['nSubTotTypeNo"] >=2 && dataSetRow['nSubTotTypeNo"] <=5

When you divide aggregates (or any numbers), Deltek recommends that you use CP_safeDivide(n1,
n2, nifn2IsZero).

Handling "No Data Found"

When a report has no data to process, the generic message "NO ROWS FOUND THAT MEET
SELECTION CRITERIA" should be printed on a report page. This is handled by the system libraries
through cp_presentation.rptlibrary » CP_NoRowsPortrGrid and CP_NoRowsLandGrid. The
appropriate (landscape or portrait) CP_NoRows Grid should be used after each report section (table
object) in the report design.

Mastee Page - CP_CoverPage
enile Masher Dage - CF_Repentilcdy
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When the report layout requires you to have a table header (for example, table wide column headers)
and/or table footer (for example, report totals) row(s), these rows should have a Table » Header
(Footer) » Row » Visibility formula set to !ICP_reportDataFound( ). Failure to add the formula will
result in Table Header/Footer Row(s) showing when report has no data.

[ Gnd - CoverPageDetiLandGrid E [ Tl
[ Table- DataSetland bl o
] Header

O Row N
EREE] .
[El Footer :

S Groups ©
723, Grid - CP_NoRowsLandGrid

[ MasterPages
Styles
Embedded Images :
[#] cp_components.CP_Theme - NO ROWS FOUND THAT MEET SELECTION CRITERIA
[2; Libraries
& Seripts

rTaDzne Amounna Ves/Ma Tahel

Line  &CPT.ACCT& &CPT.ORGE &CPT.PROJ&

[S1| rpool Wumber: Bco.. .3
[LIN [ACCOUNT] [ORGANIZATION] (PROJECT] (BASE_UNITS QT¥]

[Totsl for Fool #...] [SUM(BASE UNITS Q. [

ource Explorer 52 ¥ =0

B Data(CP_CurrencyM..) - CP_CurrencyNoDecCrtl || Layout| Master Page  Script| XML Source | Breview
F Data(CP_CurrencyM..) - CP_CurrencyNoDechoSymbCrtl = =
g Data(cp,[unan:;N.‘.) —cp Curran:;NnDa:NnS;thnThnut B Property Editor - Row 2 Properties| (21 Problems | B Console
B Data(CP_CurrencyM..) - CP_CurrencyNoDechoThouCntl Properties | Map| Highlights

B Data(CP_CurrencyN..) - CP_CurrencyNoSymbCrl ——

[ Data(CP_CurrencyN...) - CP_CurrencyNoSymbNoThouCntl | _ || | General U

B Data(CP_CurrencyN..) - CP_CurrencyNoThouCrtl = ||| Border

[ Data(CP_DateCntl) - CP_DateCntl Pagetre [91Hide Element

B Data(CP_DateTimeC...) - CP_DateTimeCrtl Visbity
& Data(CP_DecimalCn...) - CP_DecimalCntl

B Data(CP_DecimalNo...) - CP_DecimalNoThouCnt! st

[ Data(CP_IntCnt]) - CP_IntCntl User Properties

B Data(CP_IntNoThou... - CP_IntNoThouCntl -
B Data(CP_iTextCntl) - CP_iTextCrl

B Data(CP_PercentCn..) - CP_PercentCrl

Bl Data(CP_RateCntl) - CP_RateCnt!
=l _DatalCD TedCatll €D TedCntl

@ For all outputs

() For specific outputs..
Betait AT CUTpULS)

Event Handler Expression: | ICP_reportDataFound( )

Advanced

You add this formula only for Table Header and/or Table Footer rows. If you do not use the Table
Header or Footer rows and, for instance, you have Column Headers placed in a Group Header, then
you don't have to add the formula.

Multiple Report Sections in One Template (Posting Applications)

You can print several tables in a sequence. The processing for a subsequent table starts after the
previous one finishes, and so on. You can build a sequential report by placing multiple tables one
after another.

Table Object

When you insert a new table object in the report, always set the Table » Properties (Advanced) »
Sort By Groups to false. This will disable re-sorting of the data (BIRT default behavior). The
Costpoint data is already pre-sorted through SQL.
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T Grid - CoverPageDetlLandGrid
=] Table - DataSetLandThl

ﬁ Grid - CP_NoRowsLandGrid
MasterPages

Styles

Embedded Images
cp_compenents.CP_Theme
Libraries

Scripts

1st Sort:

-+ Page Break:

Job/JobGroup Label

¥es/No Label

Job: | [sJobId]

[=1

Description:

[=1

Comments -

tern Resources

Flash Object Library
readme. et

ared Resources

template

cp_build.js
cp_components.rptlibrary
cp_control js
cp_presentation.rptlibrary
cp_utils.js

ce Explorer &2 I [$ Data Explorer & 7504

[=1

B
~ [E1

8

Seq

[nSeqtio]

Creator's User ID:

[sModuleName]

Group: [sJobGroupl

[sJobDescription]

[sCraztorUserld]

[sComments]
Module

Application Name

[s2ppHame]

Layout | Master Page ‘ Script| XML Somce| Pm_riew‘ Desktop Viewer {plalolype)|

Property Editor - Table M' E Pmblems| =5 ngl| @ Error Log|

Table

Property Value
Page break interval 40 : Inherited
Push down true : Inherited
Repeat header true : Inherited
Report Item
Section
Shrink false : Inherited
Sort by groups -
Style
Summary

In Table » Property Editor - Table » Properties » Page Break, set Page Break Interval to 0.

Grid - CP_CoverPagePortrGrid

E Table - DataSetPortrThl

I

Grid - CoverPageDetlPortGrid

[E] Header
[ Row
] cCel
i Grid
[ Row
[ Cell
[ee] Label - CP_LabelCntll
[ Cell
[5] Label - CP_LabelCnti2
1 Cell A
e Explorer E@l n;)cn = =0

e Resources

Flash Object Library
eadme.td

ed Resources

kemplate

lcp_build.js
lcp_components.rptlibrary
lcp_contral,js
cp_presentation.rptlibrary
cp_utils.js

Country:

6.
i

[ [State Name]

State/Province

[COUNTR [COUNTRY NAME]

tcicyl

@

NO ROWS FOUND THAT MEET SELECTION CRITERIJ

Layout | Master Page | Script | XML Source Ple‘gi:wl Desktop Viewer (pmtolype}l

= Plapeﬂis‘ [ Pmblems‘ =3 Plaglss‘ Q] Error Lag|
Properties | Binding | Groups Map‘ Highli |Sur|ing‘ Fillels‘

< ‘ After: ‘ Auto

e Page Break
Border Before: | Auto
Margi

2 Inside: [ Auto

- | Page Break Interval: | ] |

Page Break

Visibility Master Page: | CP_ReportBody

- [V]Repeat Header

The appropriate (landscape or portrait) CP_NoRows Grid should be used after each report section
(table object) in the report design. For example, if you have two report sections in the report, then you
must have two table objects and two CP_NoRows Grids following each table object.

When you need to have a page break in between report sections (table objects), do not set the page
break at the table level. Instead drag CP_PageBreak component from cp_components.rptlibrary and
insert it right after CP_NoRows Grid for each table in report design.
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e Edit nsert Element Dsta Page Navigate Search Project Run Window Help
F-EE @i Q- i BAFH e -l
" Navigator ”EFgI ne g N » - -0 syrusr.rptdesign f piralinl.rptdesign f fapaexp.rptdesign &
fapaexp.rptdesign | (B IR R 2000 R 4. S5 6 T R
1> (g Data Sources B
4 (& DataSets
b FAPAEXP DS Data Set
b FAPAEXP DS2 Data Set
() Data Cubes
(§3 Report Parameters
() Variables
4 [0 Bod
¢/ T2, Grid - CP_CoverPagelandGrid
» [ Grid - CoverPageDetlLandGrid
» [ Table - FixedAssetsDetailReport_LandTbl

Row Asset Wo Ttem Tag No Short Description Template No
[HdrGrp RSSET ACC.. .1
[SubGrp_ASSET_ORG...]

[SubCrp_ASSET_PRO. .1

[EXE_ROW |[ASSET_ID] [ITEM |(TAG_NO_S] [SHORT_DESC] [FA_TMPLT_ID]

[SubTotal]

&> B Grid - CP_NoRowsLandGrid [SubTotall

., [, Grid - CP_PageBreak %J
N\ /= Table - FixedAssetDisposalETRRpt_PortTbl
g Grid - CP_NoRowsPortrGrid
» I Mhcterbage
> [ Styles
[za] Embedded Images
o [ cp_components.CP_Theme
b Iy Libraries
b & Scripts

[SubTotal]

Asset No Item No Selec! Gain/Loss Gain/Loss Depraciation Disposal

[ASSET_IDI [TTEM H|[[5_DIS [[GWLS_ACCT_ID] [[GNLS_02C_ID] [B1_DEPR_ADJ_AMT] [DISE_PAICE 2MT]
Report Totals: | [SUM_BS1_DEPR_AMT]  [SUM_DISE_PRICE_AMT

NO ROWS FOUND THAT MEET SELECTION CRITERIA

H Resource Explorer 5 $ ¥ =0
E Data(CP_DateCntl) - CP_DateCntl
=

>

Layout | Master Pagelﬁmpt‘XMLSour:elPre!\ew‘

Go to CP_PageBreak Grid » Properties » Page Break, and assign a master page property to the
same page that is used by the table object just before the CP_PageBreak component.

% G d cp c p L dG d [ERF_FUW TTASSELI _ITT [TIE TIEE_NU_o7
P4 Grid - CP_CoverPagelandGri
Ff Grid - CoverPageDetlLandGrid

[} MasterPages

] styles

[a] Embedded Images

cp_components.CP_Theme

Ly Libraries Rsset Ho Item No Seleci Gain/Loss Gai

& scripts ]| e e =
[RSSET_ID] [ITEM N |[5_DIS [GNLS_ACCT ID] | [GHNLS_J

Rep«

HO ROWS FOUND THAT MEET|

Esource Explorer &%

[E Data(CP_DateCntl) - CP_DateCntl » || Layout | Master Page| §cript‘ XML Source| Pregiew|

[E Data(CP_DateTimeC...) - CP_DateTimeCntl

B Data(CP_DecimalCn..) - CP_DecimalCntl % Property Editor - Grid &2 =] Proper‘tieq E_g Problems} = Console}

[E Data(CP_DecimalNo...) - CP_DecimalMoThouCntl Properties | Binding | Map| Highlight;|

[E Data(CP_IntCntl) - CP_IntCntl -

E Data(CP_IntNoThou...) - CP_IntNoThouCntl General Page Break

[E Data(CP_iTextCntl) - CP_iTextCnitl Border Before: Auto <] After: [Alway
E Data(CP_PercentCn...) - CP_PercentCntl m - ) -

[E Data(CP_RateCntl) - CP_RateCntl Inside: Auto -

E Data(CP_TextCntl) - CP_TextCntl

é;;; Page:  FADetailPage_Land >

El Data(CP TimeCntl - CP TimeCntl Visibility

Page Layout

You can create a page object of different size, margins, and page layout (landscape or portrait) and
then assign this page to a table object in table properties/page break/Master Page.

In case of multiple report sections and different page settings, you may need to create additional
page objects and place standard Costpoint page headers/footers onto new pages.

To create a new object, right-click Master Pages in the Outline view, and click Insert Element on the
shortcut menu. Rename the object, and change the page settings if needed.
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The default height of the standard Costpoint Header is 1 inch. The default height of the standard
Costpoint footer is 0.6 inch.

Outine £ | & 7 = 0|5 verticalrptdesign | 5 syrpostrptdesign £ |

- bl

Pages
mple Master Page - CP_CoverPage
mple Master Page - CP_ReportBody
Header
[ Grid - CP_PageHdrPortrGrid
1 Row
I Row
[ Cel R
] Grid
0 Row
O cell
[ cell
) Grid
I Row
I Row .
[ cal "
 Data(cPi

[CE_CompanyName]

el Enter Report Title Here Page N of }

e — [CB_BuildDate
[CP_hddReportInfo] =

AT

2

1 cCell

o v

= $ T =0

bject Library
€.t

ate

ildjs Layout Master Page | Script| XML Source | Preview | Desktop Viewer (prototype) |
mponents.rptlibrary
troljs

=] Propems‘ [ Pmb\ems‘ = ng.| @] Error Log‘

sentation.rptiibrary Properties

ta Sources e —

12 Sets General General

ta Cubes || Barder Name: CP_ReportBody

port Parameters | Mergin

port Items I

Grid - CP_CoverPageLandGrid eadediooter | Deaderhnelg Backgraund color: @

Grid - CP_NoRowsLandGrid Advanced

Grid - CP_NoRowsPortrérid Width: 35 w T%] Type Slete <

Insert standard Costpoint page header/footer objects from cp_presenation.rptlibrary into the new
page by dragging page header/footer objects from the library directly into Outline » CP_ReportBody
page » Header/Footer.

The new page object should be correctly mapped to your table object in the report design. Switch to
Layout view, and in Outline » Body, locate the table object that should display data for different
report sections. Go to Table » Property Editor » Page Break, and change the master page to the
newly created page. The result is that all data that goes into the above table will be displayed on a
page with possibly different layout margins, headers and footers.
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REPOTT DRSS - oS pOITWED LSy S DT T Ep T B Sy Y TS Sy TS T TP TaesIg T - ACTUATE BIR T UESIgIEr PTOTESETonal

ile Edit Insert Element Data Page MNavigate Search Project Run  Window Help
G-EB& i g L AT AT AL RS- TH R e
7§ &' Java < Plug-in Development %5 Debug [/ <Report Design>
k5 Navigator 8= Outline £ ¥ =0 *syrusr.rptdesign £2 | §i cp_presentation.rptlibrary
[ syrusrrptdesign - D L S S - S I S
[ Data Sources 3 Email Notificatiom: [CHE_PRC_NOTIFY_FLI
(& Data Sets .
(3 Data Cubes - Workflow Email:
[£3 Report Parameters A = -
([ Variables . Send Work Flaw [EMATL WF_ACTVTY FL]
[ Body - S, E .
@ Grid - CP_CoverPagePortrGrid . Send Workflow Message: |[EMAIL WF_MSG_FL]
i Grid - CoverPageDetlPortGrid . Enail Name [DMAIL NAME]

[ Table - DataSetPortrThl R I
P Grid - CP_NoRowsPortrGrid

Company Information
[} MasterPages

1

12

[7] simple Master Page - CP_CaverPage Company : leompanyld] [COMPANY_N)
[ simple Master Page - CP_ReportBody . Org Security Group [orgSecGroup] [ORE_SEC G|
[ Header N E] Def. Taxable Entity: [dfltTaxEncityl [TAXBLE_EN|
D Footer ) Data Suppression:
[ simple Master Page - CostsExpensesSectionPage
[ Header n Labor [SUPERESS_LABOR]
[E Footer ) Price [SUPPRESS PRICE]
Styles Cost [SUPBRESS_COST]
Embedded Images i -
cp_components.CP_Theme Layout | Master Page | Script| XML Source | Preview | Desktop Viewer (prototype)
2 Libraries — —
L:zf vt - |[E Property Editor - Table &3 | = Properties [£. Problems 5 Progress
I$ Data Explorer | fiij Resource Explorer &2 o ¥ = O || Properties| Binding| Groups| Map | Highlights | Sorting | Filters
. cp_buildjz “ || General Page Break
it cp_compenents - RUN WITH OPEMN SOURCE.rptlibrary
it cp_compenents.rptlibrary Bordey Before: Auto - | Aften Auto
j Margin
£ cp_controljs H Inside: Auto <] Page BreakIntenval: |40
i cp_presentation - - RUN WITH OPEN SOURCE.rptlibrary Page Break
(f Data Sources Visibility Master Page: | CostsExpensesSectionPage - [¥] Repeat Header
|5 Data Sets N
. Table of Contents one
[ Data Cubes CP_CoverPage
(43 Report Parameters Bookmark CP_ReportBod
[ Report kems Comments CostsExpensesSectionPage

[ Grid - CP_CoverPagelandGrid
FH Grid - CP_CoverPagePortrGrid
[ Grid - CP_NoRowsLandGrid

User Properties

m

Named Expressions

Presenting Text

A report typically presents most of its information in a textual format. Textual information can be any
of the following:

=  Static text — Labels, column headers, report title. This data is subject to localization,
language translation, and CP terms translation. Use only CP_LabelCntl and
CP_LabelYesNoCntl.

=  Mixture of static text and data values supported by the system — Range text, NCR range
text, text list, page N of M, and total Page Count.... Use specially provided controls such as
CP_RangeCntl, CP_NCRRangeCntl, CP_ListCntl, CP_PageNofMCntl,
CP_PageNofMRestartCntl, and CP_TotalPage.

= Dynamic text data to present Data Set fields: dataSetRow["COMPANY_ID"],
dataSetRow["USER_ID"].... Use CP_TextCntl control.

= Mixture of dynamic data that is subject to localization, language translation and CP terms
translation — [static text] + [text] + [date/time] + [number] + .... For any of these, use
CP_iTextCntl control and CP_...IText functions to present data within the control (for
example, CP_TranslatelText("Project End Date:") +
CP_TranslatelTextDateTime(dataSetRow["PROJ_END_DT"], "CP_DateCnit").

Text wrapping:

By default, all text data is wrapped onto multiple lines in case it does not fit within the control or
grid/table boundaries. The text line breaks by the whitespace and is controlled by the Control »
Properties » Advanced » Text » Whitespace setting. The default value is Normal. You can turn off
text wrapping by changing the setting to No Wrapping.
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Layout Master Page | Script| XML Source| Pre!iew|

@ Property Editor - Label &3 =] Propertieq =2 Con;ola E_( Problams}

Properties| Highlights
General Advanced
Padding
Border Property Value
b Margmi On prepare CP_LabelCntlOnPrepare(this); : Inherited
e On render CP_LabelCntlOnRender{this); : Inherited
Hyperlink Overflow Hidden : Inherited
Page Break Push down true: Inherited
W Report Item
[ Secton
| Shrink false : Inherited
Table of Contents Style
L Bookmark Text
3 Comments Letter spacing MNormal : Inherited
W Line height Mormal : Inherited
| Orphans 2 Inherited
w Text alignment Center: Inherited
Event Handler Text direction Auto
Advanced Tan Mo Transformation : Inherited
Vertical alignment i Tited
L5 Whitespace Marmal -
idows
Mo Wrappin
o Lm_
| ~— |Preformatted |

~

In addition to whitespace wrapping of text, you can use the CP_WrapText(text, nchars) function to
wrap the text based on a number of characters as well as the whitespaces.

= ERprEson BUngE Evaspt] T e |
Expression Builder

Type an expressien in the Expression field, Browse the lists of available objects and double-click to copy inte your expression,

B« @ XS HE
1 CP_wrapText(datasetRow"NOTES ], 25] A

opemons (o] o) ()le] (=lell) BWKE

Display Page Header » Report Title Based on Current DataSet Row Variable

There are a few cases (limited to some reports) when you need to display the report title on the page
header where the text of the report title depends on the value of the current DataSet row variable.

In order to do that, you have to use a BIRT page variable and override the onRender() method for the
Page Header » Report Title label control.

1. Add a new page variable in Outline » Variables » New Variable » Page Variable.
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I& Report Design - C:\costp b\70\dev\apps\comideltek ion\sy\syrusrirpt! ign - Eclipse
Eile Edit Insert Element Data Page Mavigate Search Project Run  Window Help
DERE ries A e |5
@-
25 Navigator | 5= Outline 23 . 4% Pa\ette] @ Y =0 syrusr.rptdesign £2 pjpobt.rptdesign W
syrusrrptdesign - IR S 2. 3o 4o 5
[ Data Sources
(= Data Sets .
(f3 Data Cubes !
({3 Report Parameters - [CP_CompanyName
(5 Variables
. (7 PV_USERID - £l User Report
Bod : —_—
) gnd - CP_CoverPagePortrGrid . - [cE addReportinfol
[ Grid - CoverPageDetiPortGrid -
5] Table - UserTable .
=] Table - CompanyUserTable N
[E] Header .
[] Detail Edit Variable
El Footer
[2 Groups
[E Table Group - CompanyGroup
[E] Table Group - UserGroup Type: () Report Variable @ Page Variable
I8 Heoter ame
O Cel Default Value:
F Grid
O Row [ |
[ Cell | |
& S;dRDW Property Editor - Variable @ [ ok J[ concd | ||
[] Cell Properties
1 Grid |
2. Name the variable using the following naming convention: the variable name should be
uppercase and should start with PV__ prefix (for example, PV_USER_ID).
3. Set the value of the page variable by overriding the onPageBreak() method for the control

that displays the DataSet data that you want to use in the page header.

If such a control is not there or should not be in the report by design, you need to
create a dummy table/grid row, put a dummy control on that row, set control value, and
make sure that this dummy control's parent row is hidden through:

overridden Row>Scrip>OnRender()
method>this.getStyle().setVisibleFormat("all");

overridden Row>Scrip>OnCreate() method>this.height = "0in";

Do not hide the row or control using the Hide Element check box or set the row height to 0'.
Use the setVisibleFormat(“all") approach only.

fapvudcd.rptdesign 1

Script: l onRender

|

this.getStyle().setVisibleFormat("all");

'[& syrusr.rptdesign

| 5 ColumnarReportMewspaperStylerptdesign

Script: ’ oniCreate

|

this.height

"@in"

w
¥
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’ The control's onPageBreak() method should be overridden to set the page variable value.
For example:

reportContext.setPageVariable("'PV_USER_ID", this.getValue());

it Page Mavigate Search Project Bun  Window Help
OEE® @~ :ig - I R =

gator 5= Qutline & w Palette & - — O syrusr.rptdesign &3 pjpobt.rptdesign

yrusrrptdesign
[ Data Sources

e Script: [onPageBreak VI = ENO)]

l& Data Sets reportContext.setPageVariable("PV_USER_ID", this.getValue());
gl Data Cubes
{3 Report Parameters
& Variables

[F PV_USERID
[l Body

EH Geid . 7D D D ortelGricd

CP_TextCntlOnPageBreak(this);

m

4. Goto Master Page » CP_ReportBodyPage » Report Title Label, and override the
onRender() method based on the value of the page variable created in the earlier steps

Inside the onRender() script, access the Page Variable value through the
reportContext.getPageVariable() function. For example:
CP_LabelCntlOnRender(this);

this_.setText(CP_TranslatelText("Data for User ID:") + "™ " +
reportContext.getPageVariable("'PV_USER_ID™));

L syTuserptdesign i
Seript: :enR!nd!r - . w (@ | Labe
CP_LabelCntlOnRender(this);

this.setText(CP_TranslateIText("Data for User I0:") + * " + reportContext.getPageVarisble("PV_USER_I0"));

Always use the CP_TranslatelText() method for static text and labels. You can use
other CP_TranslatelText functions to format:

= Date/time — (CP_TranslatelTextDateTime())

=  Numbers — (CP_Translatel TextNumber())

=  Currencies — (CP_TranslatelTextCurrency).

Localization and 118n

Costpoint reports can be printed in different locales. All localization and i18n processing and
formatting occurs at report rendering (view) time. This allows you to generate the report once, but
render it differently based on different locale rules.

What Is Subject to Localization in Costpoint Reports
= Labels (text, text ranges)

= Date/Time controls

= Numeric controls (Integer, Decimal)
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=  Currency Controls
= TOC labels

Displaying Text

All static text and labels in a report have to be localized and translated. You must use the
CP_LabelCntl control that provides multi-language translation. You always use the standard
CP_TextCntl controls for data that does not require multi-language translation.

Labels can have a single display value or multiple display values; one of which will be picked based
on a condition.

To create a single display value label, drag CP_LabelCntl from the library, and rename the label text.

To create a multiple display values label, drag CP_LabelCntl from the library, and in the Advanced
Properties, set the values for:

= CP_DataValue (expression)
= CP_DataValues (~ separated list of data values)

= CP_DisplayValues (~ separated list of display values)

General Advancea
Padding b Va
Border roperty alue
- Bookmark

jamin Bookmark display name
Hyperlink Box
Page Break Comments

Visibility Content Column 2 Label

Localizati Content key

pealzation CP_DataValue var selection = CP_getParmString("PN_COLUMN2");
[Table of Contents CP_DataValues 0~ln2n3rdn5nlinT ~8~9n10~11~12~13~14~15~16~17~18~19~20~21~22~
Bookmark CP_DisplayValues (Mone)~Current Period Actual~Current Period Budget~Current Period Variz
Comments CP_Localeld

Custom XML
Display name
Display name key
Event Handler Event handler class

Advanced Font

User Properties

Mamed Expressions

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

Dictionary Terms

There are common terms that users would like to customize according to their practice. For example,
a customer would like to use the term Department instead of Organization, Client instead of
Customer, and so on. These terms are scattered throughout the product. They appear on the screen
in labels, menu items, status help text, messages, and so on as well as on reports as titles, headings,
and so on.

There are seven terms—Project, Organization, Account, Vendor, Customer, Employee, and
Warehouse—that are defined with the following term IDs: PROJ, ORG, ACCT, VEND, CUST, EMPL,
and WHSE.

Each term has Singular, Plural, Singular Abbreviation, and Plural Abbreviation forms. For each
occurrence of the term in metadata (display title, status text, messages, and so on) or report labels,
the following syntax is used:

= Singular — &CPT.TERM_ID&
= Plural — &PTP.TERM_ID&
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= Singular Abbreviation — & CPTS.TERM_ID&
=  Plural Abbreviation — &CPTSP.TERM_ID&
For example:
= Old label: “Organization:” — New syntax: “& CPT.ORG&:"
= Old label: "Projects:" — New syntax: "& CPTP.PROJ&:"

Since the very same report can be viewed and printed in different locales and languages, you should
take caution when concatenating and presenting data of different types in one control.

For example, assume you want to show a static text “For Subperiod Ending” concatenated with the
date value 01/01/2000. If you place both items in one control and concatenate them, then at view
time, the text will not be translated properly and the date value will not be formatted according to the
runtime locale.

Use the CP_iTextCntl control to address the above case. The CP_iTextCntl control can combine
static text data with dynamic data. You must use special functions in controls value Expression:

= CP_TranslatelText(text)

= CP_TranslatelTextDateTime(value, format)

= CP_TranslatelTextCurrency(value, format, currencyCd)
= CP_TranslatelTextNumber(value, format)

= CP_TranslatelTextRange(rangeCd, from, to)

= CP_TranslatelTextRange(rangeCd, from, to)

= CP_TranslatelTextCustomRange(rangeCd, from, to, displayValues, dataValues)

- Expression Builder (JavaScript) = @

Expression Builder

Type an expression in the Expression field, Browse the lists of available objects and double-click te copy into your expression,

XYY YE

1 P_TranslatelText("Fiscal vear:") + " " + CP_getParmString("FY_CD") + CP_getLineBreak() + CP_TranslatelTextRange(CP_getParmString("USR_ID_RAMGE"), CP_getParmint("FR") »

openos ][] (][] WEHBE WG]

LCategory: Sub-Category: Double Click to insert: 1%,

Available Column Bindings
Mative JavaScript Functions
BIRT Functions

Operators

(5:\ oK ] I Cancel
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Use the CP_getLineBreak() function to break the new line within a CP_iTextCntl control.

Example:

CP_TranslatelText("'Fiscal Year:'") + " " + CP_getParmString(""FY_CD'™) +
CP_getLineBreak() + CP_TranslatelTextRange(CP_getParmString("'USR_ID_RANGE™),
CP_getParmString("'FR'™), CP_getParmString("'T0™))

Text Ranges

Use CP_RangeCntl and CP_NCRRangeCntl controls to display text ranges. CP_RangeCntl - set
CP_DataValue Expression for Range Code, CP_RangeFrom and CP_RangeTo Expressions to set
Range From and To values. CP_NCRRangeCntl - set CP_NCRResultSetld value to identify NCR
Result Set

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

Displaying Date/Time

The format for dates and times is locale specific. The following controls provide this functionality:
= CP_DateCntl
= CP_DateTimeCntl
= CP_TimeCntl

In addition, you can use CP_DateCntl, CP_DateTimeCntl, and CP_TimeCntl constants as format
masks in conversion functions. For example:

CP_translatelTextDateTime(row[""MY_DATE'™], "CP_DateTimeCntl')

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

Displaying Numbers
The format for numbers is locale specific. The following controls provide this functionality:
=  CP_IntCntl
= CP_IntNoThouCntl
= CP_DecimalCntl
= CP_DecimalNoThouCntl
= CP_PercentCntl
= CP_RateCntl

In addition you cany use CP_IntCntl, CP_IntNoThouCntl, CP_DecimalCntl, CP_DecimalNoThouCntl,
and CP_PercentCntl, CP_RateCntl constants as format masks in conversion functions. Fopr
example:

CP_translatelTextNumber(row["MY_AMT"], "CP_DecimalCntl'™)

For reports where locale is data-driven (coming from RS data), set CP_Localeld expression (for
example, row["LOCALE_ID"].

Within the CP_Format property, you can use custom format masks to override default formatting (for
example, "0.000000", "#,##0.0000000").

Change the CP_DecimalDigits property to override the default formatting in regards to the number of
decimal digits.
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ayout | Master Page | Script | XML Source | Preview

& Property Editor - Data | = Properties &3 [2¢ Problems| B Console

Data
Property Value
a Data
Allow export true : Inherited
- Background

Bookmark
Bookmark display name
» Box
Comments
CP_DecimalDigits g
CP_Format (CP_getParmBoolean("SHOW_AS_PERCENT") ¥ "CP_PercentCntl" : "0.0000000")
CP_Localeld
Custom XML
Data binding reference
Data set
Display name
Display name key
Event handler class
> Font
: Format

Displaying Currency
The format for currency data is locale specific. The following controls provide this functionality:
= CP_CurrencyCntl
= CP_CurrencyNoDecCntl
= CP_CurrencyNoDecNoSymbCntl
= CP_CurrencyNoDecNoSymbNoThouCntl
= CP_CurrencyNoDecNoThouCntl
= CP_CurrencyNoSymbCntl
=  CP_CurrencyNoSymbNoThouCntl
= CP_CurrencyNoThouCntl

In addition you can use CP_CurrencyCntl, CP_CurrencyNoDecCntl,
CP_CurrencyNoDecNoSymbCntl, CP_CurrencyNoDecNoSymbNoThouCntl,
CP_CurrencyNoDecNoThouCntl, CP_CurrencyNoSymbCntl, CP_CurrencyNoSymbNoThouCntl, and
CP_CurrencyNoThouCntl constants as format masks in conversion functions. For example:
CP_translatelTextCurrency(row["'MY_AMT"], "CP_CurrencyCntl'™)
CP_translatelTextCurrency(row[""MY_AMT"], "CP_CurrencyCntl", row[''CURRN_CD"])

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

For reports where currency code is data-driven (coming from RS data), set the CP_CurrencyCd
expression (for example, row["CURRN_CD"]).

Change the CP_DecimalDigits property to override the default formatting in regards to the number of
decimal digits.
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Displaying TOC
For TOC text, use the CP_translateText(text) function. For example:

CP_translateText("'Project Status Report')

Image Controls

The following controls are provided to support images:
= CP_ImageCntl — Basic image control

= CP_DynamiclmageCntl — Image control that allows you to load image files from Costpoint
File Locations.

= CP_CompanyLogoCntl — Image control for displaying a company logo image

The CP_DynamiclmageCntl control allows you to load image files stored in Costpoint File Locations.
Set the CP_AltFileLocation and CP_FileName Expression values.

Advanced

Property Value
4 Image
Allow export true : Inherited
Alternative text
Alternative text key
- Background
Bookmark
Bookmark display name
» Box
Comments
CP_AltFileLocation CP_getParm5tring("FILE_LOC")
CP_FileMame [cP_getParmString("FILE_MAME") [
CP_StopReportOnError false : Inherited
Custorm XML
Data binding reference
Data set
Display name

Report Table of Contents

The Table of Contents (TOC) allows users to proceed directly to a specific report item in Preview
mode.

Follow these rules to code the TOC:
= The Cover Page is not part of the TOC

= The Report Section title is part of the TOC. If there are multiple report sections (for example,
posting reports), then there will be multiple top-level report titles in the TOC.

= Under the Report Section, a developer should look for primary group by/sort by logical keys
and not go for inner groups down the tree requested by Design. A label should not be used at
this level. For example, if the break group key is PROJ_ID, then a developer should use just
the key value in the TOC, but not the key value pre-pended by a label (for example, 1003
instead of Project 1003).

= For hard coded (static) text or CP terms, use the CP_TranslateText(value) function. For
example:
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= CP_TranslateText("Project Status Report")
= CP_TranslateText("& CPT.EMPL& Salary Report")

= For formatted date/time and numbers, use the CP_toString(value, format) function. For
example:

= CP_toString(row['MY_DT"], "CP_DateCntl"),
= CP_toString(row["VOUCHER_NO"], "CP_IntCntl")

= For skipping a TOC level in your report, leave the TOC expression blank for the report
section/group that you need to skip.

E!}:@ E@@]P@e [ =31] of 556 Qol 1| As Genersted Y:,-;Agﬂ:t‘
b [T ErowseApplications  administration = Security > Security Reportsdnguiries = Print User Report
ser Report - 1
= '3 User Heport User Report Page 331 of 556
. Jser Report 10/29/12
@ 1 0l:59 TN
54112 Comgany: 1 Company 1
_ User ID: ZAVIZCLE ZAVIZCAE
L ADA S Employee ID:
LI MERCADOM Thone Number:
2013 Extension:
L Default Company: 1
= L 71BIGBYTE Security Information:
= 01 APPLEJACKZ Deactivation Date:
201 wEeR Date Password Changed:
Notify When Batch Process/Report Is Completed: N
Preferences this user can change:
n o =

Utility functions

The cp_utils.js file contains the list of public functions that can be used by report developers. Check
the cp_utils.js file for complete list of functions and descriptions of each.

Here is a list of the most useful functions:
= CP_getParm... (name) — Returns a parameter value specified by name
= CP_getConstant...(name) — Returns a constant value specified by name

= CP_TranslatelText...(value[, format, currencyCd]) — Concatenates and translates text,
number, and currency date/time values for the CP_iTextCntl control

= CP_RemoveTableFromBuild(tableName) — Removes a Table Object froma report build.
Override *.rptdesign beforyFactory to call this function.

= CP_removeCellStyle(objName, row, column) — Removes cell style dynamically. Override
* rptdesign beforyFactory to call this function.

= CP_TranslateText(value) — Used for TOC text translation.

Do not use inside CP_iTextCntl!

= CP_toString(value, format) — Used to format TOC date/time/number at report execution
time.
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