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While Deltek has attempted to verify that the information in this document is accurate and complete, 

some typographical or technical errors may exist. The recipient of this document is solely responsible for 

all decisions relating to or use of the information provided herein. 

The information contained in this publication is effective as of the publication date below and is subject 

to change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are reserved. 

No part of this document may be reproduced or transmitted in any form or by any means, electronic or 

mechanical, or translated into another language, without the prior written consent of Deltek, Inc. 

This edition published April 2026. 

© Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and 

proprietary information of Deltek, Inc. and its licensors. The Deltek software, and all related 

documentation, is provided for use only in accordance with the terms of the license agreement. 

Unauthorized reproduction or distribution of the program or any portion thereof could result in severe 

civil or criminal penalties. 

All trademarks are the property of their respective owners.  
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Overview 
This Open Plan 8.7 Cumulative Update (CU) 16 release includes all the enhancements and software 

issues resolved from Open Plan 8.7 CU 01 through Open Plan 8.7 CU 16. 

 

Software Requirements (Compatibility Matrix) 

To see the list of the supported and compatible technologies, see “System Requirements” in the Deltek 

Open Plan 8.7 Installation Guide.  

For a complete list of the recommended minimum software requirements, see the Deltek Product 

Support Compatibility Matrix document, which you can download from the Deltek Support Center site. 

Integration with PM Compass 

If you are upgrading from one version of Cobra to another and are using PM Compass, ensure that you 

install the version of the Cobra Integration for PM Compass file that supports the specific versions of 

Cobra and PM Compass you plan to use.  

 For PM Compass 8.4 or earlier, the integration file is typically released prior to or alongside the 

PM Compass Cumulative Update (CU) and must be installed manually.  

 For PM Compass 8.5 or later, the CU installer includes the integration installer, which 

automatically installs the compatible Cobra engine—no separate installation is necessary. 

However, if there is no PM Compass CU release, but a Cobra integration file is available, 

download it from DSM and run the installer manually.  

 

 

 

Important: This note only applies to Open Plan 8.7 CU 05 and earlier users upgrading to later CU 

versions. Before using the latest version of the application, make sure that you run the Open Plan 

upgrade script, which is either OPP87_Upgrade_Oracle.sql or OPP87_Upgrade_SqlServer.sql 

depending on your database.  

Note: A new integration file is not required for every Cobra CU. If no new file is provided, the 

previous version may be used if it remains compatible. 

Attention: For more information on the PM Compass Cumulative Updates and Integration Releases, 

download the related document from the Deltek Support Center site. If you have any questions, 

contact a Deltek Customer Success analyst. 

https://deltek.custhelp.com/app/utils/login_form/redirect/home?p_ptaid=fUsywia8tyvDTTd7I3Ifgga0j3WfGDNG2eegqSdZvLa7IApRaxouzrP_AWI4vHHBWEMuJuxcBYH_ny2HYvIKLm%7Evwq%7EilpK3FFcomF2e98TOSFGwsFIYiafw%21%21
https://support.deltek.com/
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Custom Programming  

Before you upgrade to Open Plan 8.7 Cumulative Update 16: 

 Review all existing custom work at least eight weeks prior to your intended go-live date. 

 Compare your custom work to the new functionality provided in this release. 

 If this new version possesses the functionality contained in your custom work, these custom 

programs may no longer be needed. If the functionality contained in your custom work is not 

provided in this release, you must ensure the custom work remains intact through the upgrade 

process. 

 Identify any hot fixes or patches that you plan to deploy with your Open Plan 8.7 Cumulative 

Update 16 upgrade. Ensure that, following the hot fix or patch deployment, you retain all custom 

functionalities.  

 Deltek strongly recommends that when upgrading, you first deploy an instance of Open Plan 8.7 

Cumulative Update 16 in your test environment. This allows for functional UAT (User Acceptance 

Testing) to ensure that all mission-critical custom features are still available to the user 

community. Typical deployments call for a 30 – 45-day test period before upgrading into your 

production environment. 

 

Note: Deltek’s Technical Services team is available to support you as you plan for this upgrade. We 

offer both technical and custom services, ensuring the best possible Deltek experience. Contact 

DGSCONSULTANTS-PES@Deltek.com. 

mailto:DGSCONSULTANTS-PES@Deltek.com
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Open Plan 8.7 Cumulative Update 16 
Released: April 30, 2026 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Other » Security 

Defect 2629260 

Description: When you switched databases via File > Login, your authentication token was not 

invalidated upon logging out of the current database, causing the token to remain in a valid status on 

the Email tab in the Options dialog box. 

Customers Impacted: This defect affects Open Plan users configured with Open Authorization 

(OAuth). 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.exe 

Defect 2630270 

Description: When you switched databases via File > Login, Open Plan continued to use the OAuth 

token from the first database you logged into when sending email messages, regardless of the 

database you subsequently switched to. The token was not updated to reflect your currently active 

database, causing email messages to be sent using the wrong token. 

Customers Impacted: This defect affects Open Plan users configured with OAuth. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.exe 
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Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 15 
Released: March 24, 2026 

Enhancements 
OAuth 2.0 Support for SMTP Email 

You can now send email messages securely via SMTP using OAuth 2.0, replacing the old, less secure 

method of sharing and storing username and password. You can configure this using the new option 

called OAuth on the Email tab in the Options dialog box. 

Selecting this option displays two tabs, SMTP Settings and Authentication. 

 

Field Description 

Default Sender Email Enter the email address that will display as the sender for emails sent 

from Open Plan (for example., noreply@yourcompany.com).  

Display Name Use this field to enter the display name when sending email from the 

System Email address. 

SMTP Server Use this field to enter a valid host name or IP address of the SMTP 

server that will be used to send emails from Open Plan. 
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Field Description 

Port Use this field to enter a port number for SMTP 

communication. Typically, you use port 587 for secure communication. 

This field accepts values from 0 to 65, 535 

Use TLS Select this option to enable Transport Layer Security (TLS) for 

encrypted communication with the SMTP server. 

 

Field Description 

Flow Type Use this field to specify the OAuth mechanism type. OAuth mechanism types or 

grant types define different ways to obtain access tokens, each suited for 

specific use cases. 

Select from the following options: 

 Authorization Code: This type is typically used by server-side applications. 

It involves the client obtaining an authorization code from the authorization 

server, which is then exchanged for an access token. This flow ensures that 

the client never directly handles the user's credentials. 

 Authorization Code with PKCE (Proof Key for Code Exchange): This type 

is an extension to the authorization code flow to prevent CSRF and 

authorization code injection attacks. The technique involves the client first 

creating a secret on each authorization request and then using that secret 
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Field Description 

again when exchanging the authorization code for an access token. This 

way, if the code is intercepted, it will not be useful since the token request 

relies on the initial secret. 

 

 Client Credentials: This type is used for machine-to-machine 

communication, where the client uses its own credentials to obtain an 

access token. 

Client ID Use this field to specify the ID of the client for the OAuth server 

Client Secret Use this field to specify the character string of the client secret manually 

obtained from the server. This value will be hidden as you enter it. 

Token Endpoint Use this field to specify the endpoint used in the OAuth authorization process 

where a client application exchanges an authorization code for an access token. 

Enter a valid URL.  

Scope Use this field to specify and limit the exact permissions or level of access that 

the client application is requesting from the user. Enter a valid string value or 

URL.  

Auth Endpoint Use this field to specify the endpoint where the user is redirected to grant 

permission. Enter a valid URL.  

Redirect URI  Use this field to specify the URI the OAuth server redirects the user back to 

after authorization is complete. Enter a valid URI.  

The following fields display on both tabs: 

Field Description 

Get OAuth Token Click this button to initiate the OAuth process and retrieve a new 

access token. You need to enter values in the required OAuth fields 

before you can get an access token. 

When you click this button, the application helps you authenticate with 

your email provider and safely saves your access token. If you update 

your SMTP settings afterward, a warning message displays to let you 

Attention: For more information, see Protecting Apps with PKCE. 

https://www.oauth.com/oauth2-servers/pkce/
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Field Description 

know that updating will delete your current OAuth token, requiring you 

to get a new one. 

Token Status This field displays the current state of your token. 

 Valid is in green text. 

 Expired and invalidated are in red text. 

 Not configured means you have not filled in the fields.  

 Not acquired means you have the fields filled in but have not 

gotten a token yet. 

 Invalidated means your token was invalidated by Open Plan due to 

a user logging out.  

Token Expires This field displays the validity period of your current token. The value is 

displayed as a local date/time string in MM-dd-yyyy HH:mm:ss format 

(for example, 03-19-2026 14:30:45). 

 

This update improves security with token-based authentication, enables enhanced permissions, 

supports multi-factor authentication, and ensures compatibility as providers end basic authentication. 

Software Issues Resolved 
Edit » Replan 

Defect 2560206 

Description: When you opened a project in Exclusive mode with a filter applied and right-clicked an 

activity, the Replan Activity option on the context menu was grayed out and could not be selected 

— even for activities that fully met all the required conditions for replanning. 

Customers Impacted: This defect affected Open Plan users using Replan Activity. 

Workaround Before Fix: None. 

Files Updated:  

 xpmhndhie.cpp 

Security Enhancements  

There are no security enhancements in this release. 
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Database Changes  

There are no database changes in this release. 

Documentation Changes 

This section includes details of sections changed in the printed documentation. 

Documentation Module Description of Change 

Deltek Open Plan 8.7 Help Updated the Options Dialog Box Email Tab topic. 
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Open Plan 8.7 Cumulative Update 14 
Released: March 5, 2026 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
File » Import – Export » MSP 

Defect 2523925 

Description: When you exported a project to Microsoft Project Standard (MSP) 2021, the resulting 

MPP file did not contain any activities.  

Customers Impacted: This defect affects Open Plan users exporting projects to MSP 2016 or later. 

Workaround Before Fix: None. 

Files Updated:  

 SharedUtilities.cs 

 Export.cs 

 Project.cs 

Defect 2565733 

Description: When you restored a project file and exported it to Microsoft Project Standard (MSP) 

2021 with all MSP Export options unchecked, the export completed with errors if a calendar was 

labeled "24 hours."  

Customers Impacted: This defect affects Open Plan users exporting projects to MSP 2021. 

Workaround Before Fix: Change the label to "24_hours." 

Files Updated:  

 Export_PWA.cs 

 Export.cs 

 Project.cs 
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Others » PMC Integration 

Defect 2538264 

Description: When you created a workflow in PM Compass and opened the associated project in 

Open Plan in Exclusive mode, undoing multiple activity deletions caused an error upon saving the 

model changes back to PM Compass. 

Customers Impacted: This defect affects all Open Plan users using PM Compass. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Process.dll 

Project » Time Analysis 

Defect 2573066 

Description: When you ran Time Analysis, in-progress activities displayed incorrect Total 

Float values. 

Customers Impacted: This defect affects all Open Plan users. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Process.dll 

Defect 2589059 

Description: When a subproject had a child activity with an actual start date and your ran Time 

Analysis, Open Plan would set the Total Float value incorrectly.  

Customers Impacted: This defect affects all Open Plan users. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Process.dll 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 13 
Released: November 28, 2025 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Others 

Defect 2456643 

Description: Open Plan crashed unexpectedly, sometimes displaying a “Memory Error” message 

before closing. This issue occurred during various actions at random times. 

Customers Impacted: This defect affects all Open Plan users. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.exe 

Others » PMC Integration 

Defect 2498677 

Description: When you created a PM Compass forecast baseline, Open Plan crashed. 

Customers Impacted: This defect affects all Open Plan users using PM Compass. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Engine.dll 

Views 

Defect 2475484 

Description: When you performed the DCMA Critical Path Analysis on activities, Open Plan failed to 

accurately consider in-progress activities. 

Customers Impacted: This defect affects Open Plan users using the DCMA Critical Path Analysis 

feature. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Process.dll 
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Views » Barchart View » Bar Sets 

Defect 2452603 

Description: When you changed the visibility of any Crosstable types to all levels of rollup and 

detail on the Crosstable tab in the Bar Set Preferences dialog box, Open Plan would not display the 

Crosstable bars on the summary lines. 

Customers Impacted: This defect affects Open Plan users using Crosstable views. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Ext.dll 

 OpenPlan.Engine.dll 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 12 
Released: August 27, 2025 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Activity Progress 

Defect 1763768    

Description: When you entered a date without hours and minutes or selected start and end period 

dates for an activity using the popup calendar on the Resources tab of the Activity Progress dialog 

box, Open Plan would not apply the correct time and date. 

Customers Impacted: This defect affects Open Plan users updating activity progress. 

 

Workaround Before Fix: Manually adjust the date after entry to ensure the correct timestamp. 

Files Updated:  

 OpenPlan.exe 

File » Import – Export » IPMDAR 

Defect 2445146 

Description: When you exported data to an IPMDAR file, Open Plan referenced the wrong field—

causing activities with actual start dates to mistakenly display zero float. 

Customers Impacted: This defect affects Open Plan users using the IPMDAR Export functionality. 

 

Workaround Before Fix: None. 

Files Updated:  

 PPM.Integration.IPMDR.dll 
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Tools » User Defined Validations 

Defect 2416295 

Description: When you ran the Import General process using a Transfer.dat file that did not 

list FIELD PROGTYPE and FIELD PROGVALUE as the last entries, the import failed. 

Customers Impacted: This defect affects Open Plan users using the Import General functionality. 

Workaround Before Fix: Change the order of the entries such that the FIELD PROGVALUE is the last 

one. 

Files Updated:  

 OpenPlan.Exe 

Views » Barchart View » Bar Sets 

Defect 2422098 

Description: You could still upload new symbols even though the Symbols preference was disabled 

in EPM Security Administrator and the Symbols button appeared disabled within Open Plan. 

Customers Impacted: This defect affects Open Plan users using Bar Types and Title Block Definition 

dialog boxes. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 11 
Released: July 25, 2025 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
File » Import – Export » Cross Table Export 

Defect 2221404 

Description: When you exported a project using Crosstable Data and the resources exported were 

not associated with availabilities, the exported file omitted the time-phased data. 

Customers Impacted: This defect affects Open Plan users performing the Crosstable Data export. 

Workaround Before Fix: None. 

Files Updated:  

 Openplan.Engine.dll 

File » Open » Shared 

Defect 2394992 

Description: After you opened a project in shared mode and added Activity Type as a 

column, changing the activity type in the corresponding drop-down list would not work properly. 

You had to select the option again for it to take effect.  

Customers Impacted: This defect affects Open Plan users working on a project in shared mode. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Exe 

Ribbon 

Defect 2108655 

Description: When you opened a project in the Resource Crosstable/Barchart (CROSSTAB) view 

and hovered over any table cell, the Assign button in the Resource group flickered intermittently. 

Customers Impacted: This defect affects Open Plan users opening projects in the CROSSTAB view. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 
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Views 

Defect 2393443 

Description: After you pasted text into a cell in a spreadsheet, Open Plan would delete the text as 

soon as you typed a character. 

Customers Impacted: This defect affects Open Plan users editing spreadsheet cells. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Views » Barchart View  

Defect 2416124 

Description:  When you pasted data from Excel that contained a column heading with a single quote 

into a spreadsheet, Open Plan encountered an error and the paste failed. 

Customers Impacted: This defect affects Open Plan users copying column titles with single quotes. 

Workaround Before Fix: Take any of the following actions: 

 Remove the single quote from column title. 

 Replace it with another character, for example, an underscore ("_"). 

Files Updated:  

 OpenPlan.exe 

Views » Barchart View » Bar Sets 

Defect 2367599 

Description: When you changed the Visibility of any crosstable types to All levels of rollup and 

detail on the Crosstable tab in the Bar Set Preferences dialog box, the corresponding view would not 

display the rolled-up data or bars. 

Customers Impacted: This defect affects Open Plan users using Crosstable views. 

Workaround Before Fix: None. 

Files Updated:  

 OpenPlan.Ext.dll 

 OpenPlan.Engine.dll 
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Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 10 
Released: June 30, 2025 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Activity Progress 

Defect 2367591 

Description: When you restored a project in Exclusive mode and reopened a previously completed 

activity, setting its progress type to Remaining Duration (for example, 20 days) and 

clicking Apply failed to retain the change. Instead, the activity remained incorrectly marked 

as Complete. 

Customers Impacted: This defect affects Open Plan users reopening activities 

with Complete status. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Project » Time Analysis 

Defect 2397151 

Description: When you ran Time Analysis with the Actual Date Option enabled, Open Plan would 

calculate Total Float incorrectly in some scenarios. 

Customers Impacted: This defect affects Open Plan users performing Time Analysis. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Process.dll 
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Views 

Defect 2395203 

Description: When you applied grouping in Barchart or Spreadsheet views, Open Plan would not 

display all expected values correctly in some scenarios. 

Customers Impacted: This defect affects Open Plan users using grouping in Barchart or 

Spreadsheet views. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

 OpenPlan.Ext.dll 

 OpenPlan.Engine.dll 

Views » Histogram Views 

Defect 2400299 

Description: When you ran Resource Scheduling on projects and clicked Save, Open Plan would not 

display the Availability bars properly. 

Customers Impacted: This defect affects Open Plan users performing Resource Scheduling. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 09 
Released: May 28, 2025 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Activity Details 

Defect 2347976 

Description: When you switched between Current Plan (Early Dates) and Selected Baseline in the 

Show Time Phase Based On group box on the Resources tab of the Activity Details dialog box, 

the Total Labor Qty fields would not display properly. 

Customers Impacted: This defect affects Open Plan users viewing baseline data in the time-phased 

grid.. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Edit » Activity Progress 

Defect 2361776 

Description: When entering negative values for quantity and cost on the Resource tab in the 

Activity Details dialog box, Open Plan would not save these values to the Resource Cost 

spreadsheet. 

Customers Impacted: This defect affects Open Plan users using negative values for quantity and 

cost. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 
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Edit » Resource Details 

Defect 2347958 

Description: Navigating to a different activity while in Time Phase mode within the Activity 

Details dialog box displayed an Assert message. This occurred because Open Plan tried to access a 

time phased value that was outside the valid range. 

Customers Impacted: This defect affects Open Plan users working with time phased data in the 

Activity Details dialog box. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

File » New File Wizard 

Defect 2329713 

Description: When creating a new project, the Ancillary Files drop-down list on the Preferences tab 

in the Project Properties dialog box did not include the Default option. 

Customers Impacted: This defect affects Open Plan users creating new projects. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Defect 2349304 

Description: When creating a new project, the <None> option in the Resource Definition File drop-

down list did not initially display. However, after clicking Next, then Back, and Finish, an error 

displayed and <None> was applied as if it had been selected. 

Customers Impacted: This defect affects Open Plan users creating new projects. 

Workaround Before Fix: Take the following steps: 

1. When creating a project, make sure to select a valid resource file. 

2. After the project is successfully created, remove the resource file. 

Files Updated: 

 OpenPlan.exe 
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File » Save As 

Defect 2386583 

Description: When you entered an Actual Finish Date (AFDATE) in a project opened in Exclusive 

mode, Open Plan incorrectly logged an error message. This error occurred in the Activity Progress 

dialog box. 

Customers Impacted: This defect affects Open Plan users using actual finish dates. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Ext.dll 

 OpenPlan.Engine.dll 

Project » Time Analysis 

Defect 2382149 

Description: Under certain conditions, locking a project in Shared mode and running Time Analysis 

correctly displayed the early finish dates (EFDATE values). However, after saving, closing, and 

reopening the project, the EFDATE values displayed blank or invalid data. 

Customers Impacted: This defect affects Open Plan users running Time Analysis on projects 

opened in Shared mode. 

Workaround Before Fix: Open the project in Exclusive mode before running Time Analysis. 

Files Updated: 

 OpenPlan.Engine.dll 

Project » Resource Scheduling 

Defect 2310221 

Description: When you updated a baseline and selected the Selected Baseline option in the Show 

Time Phase Based on group box on the Activity Details Resources tab, some month columns 

displayed zero (0) instead of the correct values. 

Customers Impacted: This defect affects Open Plan users displaying time-phased values based on 

the selected baseline. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Process.dll 
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Other 

Defect 2377123 

Description: If an exception occurred while writing to the log file, and Open Plan then tried to log 

that exception, it could trigger an infinite loop that caused the application to crash. 

Customers Impacted: This defect affects Open Plan 8.7 users. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Log.dll 

Other » Upgrade 

Defect 2361190 

Description: The Open Plan 8.7 upgrade script did not include the COBRA_PROGRAM table type. 

Customers Impacted: This defect affects all Open Plan 8.7 users. 

Workaround Before Fix: None. 

Files Updated: 

 OPP87_Upgrade_SqlServer.sql 

 OPP87_Upgrade_Oracle.sql 

Views » Barchart View 

Defect 2377095 

Description: Open Plan could crash after deleting a previously assigned group access record from a 

project that had been restored. This was caused by trying to update the LASTUPDATE field.  

Customers Impacted: This defect affects Open Plan 8.7 users deleting group access records. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 
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Views » Explorer View 

Defect 2335815 

Description: When creating a new code or resource file and selecting the Code/Resource 

Spreadsheet View in the Startup View drop-down list, Open Plan incorrectly displayed 

the Hierarchy View upon file creation. Additionally, after saving the file and reopening it, the 

specified spreadsheet view was not listed under the corresponding Code or Resource Views folder 

in the Open Plan Explorer. 

Customers Impacted: This defect affects Open Plan users creating new code or resource files 

setting the Code or Resource Spreadsheet View as the startup view. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Views » Spreadsheet View 

Defect 2329684 

Description: When creating a resource or code file, selecting a spreadsheet view from the Startup 

View drop-down list did not display the chosen view as expected. 

Customers Impacted: This defect affects Open Plan users setting a spreadsheet view as the startup 

view. 

Workaround Before Fix: Create the resource or code file first, then set the desired spreadsheet 

view. 

Files Updated: 

 OpenPlan.exe 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 
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Documentation Changes 

This CU version uses the updated Deltek documentation template, which aligns with the new marketing 

design standards. The following changes were made: 

 Updated the title page 

 Replaced headers (footers remain unchanged) 

 Applied the FigTree font throughout the document 

 Removed the end page 

 Adjusted the blue tones used in headings and table headers to a slightly darker shade 
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Open Plan 8.7 Cumulative Update 08 
Released: April 7, 2025 

Enhancements 

Deltek has implemented common security table changes in the latest PPM product versions, and this 

Open Plan CU version has been updated to ensure compatibility with those changes. 

Open Plan Engine Update   

This update enhances the Open Plan engine to resolve login issues when accessing databases with 

common security table changes.  

 

Open Plan Data Scripts 

The Open Plan installer includes two new scripts: OPP_Data_SQLServer-PPMA.sql and 

OPP_Data_Oracle-PPMA.sql. These scripts are only necessary if you are setting up databases with 

common security table changes. 

Removal of LASTUPDATE and LASTUPDATE_USR_ID Column and Entry Deletion from Upgrade 
Scripts 

The OPP87_Upgrade SQL and Oracle scripts no longer delete the LASTUPDATE and 

LASTUPDATE_USR_ID columns from the WST_USR table and their corresponding entries from the 

WST_DCT table. 

Find Feature in Column Dialog Boxes 

The Find feature has been improved and now applies to the Add, Edit, and Insert Column dialog boxes, 

making it easier to locate field names in long lists. This enhancement is supported across various views, 

including multi-tables, spreadsheets, and the Project Analysis Barchart. 

Important: Installing this CU updates the value of the INSTALLEDVER_SP field in the WST_PRD 

table to match the current CU version, which is 8 in this case. 
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 Entering character(s) in the Field Name field and pressing Tab or navigating to a different area 
within the dialog box using the mouse displays a new dialog box called Available Matching 
Columns. Open Plan displays all fields that contain the entered text. 

 If Open Plan finds multiple matches, the dialog box displays a list of options to select from. 

 If it finds only one match, the Field Name field populates automatically, and the dialog box 
does not display. 

 Entering character(s) and pressing the Up/Down arrow key navigates to the closest matching 
value without opening the Available Matching Columns dialog box. 

 If Open Plan does not find any matches, an error message displays. 

This enhancement makes finding and selecting field names more intuitive and efficient. 

 

Updated Official Corporate Font 

Deltek has updated its official corporate font to Figtree. Open Plan now incorporates this latest font in 

its brand mark. 

Attention: For more information, see the Available Matching Columns Dialog Box section of the 

Deltek Open Plan 8.7 Help. 
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Latest Supported Milestones Professional Version 

Open Plan now supports connectivity with Kidasa Milestones Professional 2025, allowing users to 

seamlessly integrate the latest version with Open Plan. 

Software Issues Resolved 
Edit » Activity Details 

Defect 2306050 

Description: When opening a project in Exclusive mode, the Last Start date of an activity was later 

than its Late Finish date. 

Customers Impacted: This defect affects Open Plan 8.7 users. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Process.dll 

File » Backup - Restore 

Defect 2338083 

Description: When you tried to create a backup of the master project, the process failed, and an 

error was recorded in the backup log. 

Customers Impacted: This defect affects Open Plan users backing up master projects. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

 OpenPlan.Ext.dll 
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File » Import – Export » IPMDAR 

Defect 2360643 

Description: When trying to export cost data to an IPMDAR file, an error message displayed, 

indicating that the newly created database was not properly configured for IPMDAR export. 

Customers Impacted: This defect affects Open Plan users performing IPMDAR export and using 

database introduced in Open Plan 8.7 CU 06 and later. 

Workaround Before Fix: None. 

Files Updated: 

 OPMASTER.mdb 

File » Open 

Defect 2333732 

Description: Open Plan would randomly crash during various processes, such as updating a progress 

baseline, reviewing logic details, saving files, inputting percentages, and switching views. The server 

logs indicated application errors with OpenPlan.exe and various faulting modules, including 

VCRUNTIME140_1.dll. 

Customers Impacted: This defect affects Open Plan 8.7 users. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Project » Time Analysis 

Defect 2310226 

Description: When you opened a project and added the Out of Sequence Progress field to a view, 

running Time Analysis with the Actual Date 0ption selected in the Time Analysis dialog box resulted 

in the predecessor activity's OOS being set to True, even though the successor activity's Computed 

Status was not yet marked as complete. 

Customers Impacted: his defect affects Open Plan users using the Out of Sequence 

Progress field. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Process.dll 
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Views » Barchart View  

Defect 2322807 

Description When you changed the grouping font size in the Spreadsheet Preference dialog box, 

Open Plan would crash. 

Customers Impacted: This defect affects Open Plan users changing the grouping font size. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

 OpenPlan.Ext.dll 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

This section includes details of sections changed in the printed documentation. 

Documentation Module Description of Change 

Deltek Open Plan 8.7 Help Updated the Add Column Dialog Box, Insert 

Column Dialog Box, and Edit Column Dialog Box 

sections to cover the Find feature. 

Deltek Open Plan 8.7 Installation Guide Updated the System Requirements section to 

cover the latest supported Milestones 

Professional version. 
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Open Plan 8.7 Cumulative Update 07 
Released: February 7, 2025 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Activity Details 

Defect 2060560 

Description: When you accessed the Relationships or Resources tab, or viewed other areas or dialog 

boxes, and remained idle for an extended period, Open Plan would respond slowly or become 

unresponsive. 

Customers Impacted: This defect affects Open Plan users who remained idle for extended periods 

after opening a project and accessing specific tabs or dialog boxes. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

 OpenPlan.Ext.dll 

File » Import – Export » General 

Defect 1692840 

Description: Open Plan would incorrectly import the progress type Expected Finish even though it 

was not a valid option. 

Customers Impacted: This defect affects Open Plan users importing progress types. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Ext.dll 
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Other » PM Compass Integration 

Defect 2312085 

Description: The activity added via a Modeling Session in PM Compass using the copy-and-paste 

function in Open Plan did not display in the Change Log dialog box after clicking Save in PM 

Compass. 

Customers Impacted: This defect affects all Open Plan 8.7 users using PM Compass. 

Workaround Before Fix: Before you begin a Modeling Session, make the changes in the Change 

Details dialog box in PM Compass. 

Files Updated: 

 OpenPlan.exe 

 OpenPlan.Engine.dll 

Tools » Calculated Fields 

Defect 2306051 

Description: When a calculated field expression contained only the date format, Open Plan would 

sometimes return incorrect values for certain activities. 

Customers Impacted: This defect affects users using calculated field expressions. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Ext.dll 

Views » Barchart View » Bar Sets 

Defect 2312599 

Description: When you opened a grouped barchart view, Open Plan would not display the view 

correctly. 

Customers Impacted: This defect affects Open Plan users using a grouped barchart view. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Ext.dll 
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Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 06 
Released: December 12, 2024 

Enhancements 
Support for Deltek EPM Security Administrator 8.5.1  

Open Plan now supports Deltek EPM Security Administrator version 8.5.1.   

 

 

Deltek has implemented common security table changes in the latest PPM product versions, and this 

EPM SA version has been updated to ensure compatibility with those changes. 

 

Upgrading EPM SA to 8.5.1 

The updated EPM SA is installed as it always is with every product CU and is saved in the product’s 

installation folder. Alternatively, you can update it manually using the EPM SA 8.5.1 stand-alone installer. 

The installation details are discussed below: 

Ways to Upgrade to 8.5.1 Description 

Install this CU version When you install this Open Plan CU version, the EPM SA will be 

installed. A warning message displays before installation, notifying 

you that the CU version includes common security table changes 

incompatible with the current EPM SA version. As part of the 

installation, the EPM SA will be upgraded. However, if other PPM 

products share the same database, you must upgrade the EPM SA 

installed in their respective product folders as well. If you are 

installing a product CU that includes the updated EPM SA, this 

upgrade will occur automatically during the CU installation. if you are 

not installing such a CU, you can manually update EPM SA using the 

stand-alone installer. 

Note: All subsequent references to Deltek EPM Security Administrator will be abbreviated as EPM 

SA. 

Attention: For details on enhancements in EPM SA 8.5.1, see the Deltek EPM Security Administrator 

8.5.1 Release Notes. 

Attention: For more information, see the Supported PPM Product Versions section in this document. 
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Ways to Upgrade to 8.5.1 Description 

 

Use the EPM SA 8.5.1 Stand-

Alone Installer 

This Open Plan CU also includes a stand-alone installer for EPM SA 

8.5.1 so you can use that installer to install EPM SA in additional 

locations.  

The stand-alone installer should only be used to update the existing 

EPM SA version for other PPM products not being upgraded at this 

time or for products not in the same database that is being 

upgraded. 

After upgrading at least one PPM product with the common security 

table changes, you must update EPM SA in all locations where it is 

used to manage security. To perform the update, use the stand-

alone installer. 

Download the EPM SA stand-alone installer, DeltekEPMSA851.exe, 

from DSM and then run it. 

 

Supported PPM Product Versions 

The table below lists the PPM product versions that have common security table changes in support of 

EPMSA 8.5.1:  

Product Supported Version 

Cobra  8.5 CU 16 

Open Plan  8.6 CU 11 

 8.7 CU 06 

PM Compass  8.4 CU 14 

wInsight Analytics  8.3.2 CU 05 

Installing these product versions updates the EPM SA to version 8.5.1. 

Attention: For more information, see the Cumulative Update 

Release Notes for each PPM product. 

Attention: For more information, see Deltek EPM Security 

Administrator 8.5.1 Installation Guide. 
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When upgrading to Open Plan 8.7 CU 06, here are the supported versions of other PPM products: 

Product Supported Version 

Acumen Touchstone  8.3 

 8.2 

Cobra  8.5 

 8.4 

PM Compass  8.4 

 8.3 

wInsight Analytics  8.3.3 

 8.3.2 

 8.3.1 

 8.3 

 8.2 

 

When upgrading another PPM product to a version with security table changes but without upgrading 

Open Plan, you can update EPM SA using the EPM SA 8.5.1 stand-alone installer for the following Open 

Plan versions: 

Product Version 

Open Plan  8.7 

 8.6 

 8.5 

 
  

Note: When upgrading to Open Plan 8.7 CU 06, Deltek recommends using the EPM SA stand-alone 

installer to update the EPM SA versions for all other products. While it is only required to update EPM 

SA in locations where it is used to manage security, this proactive step helps ensure a smooth 

upgrade process and prevent any potential issues. 



 

Cumulative Update 16 Release Notes 38 

 

Software Issues Resolved 
Project » Baselines 

Defect 2266889 

Description: When you set a user field to a different activity and updated the baseline and in a fully 

expanded master project, Open Plan would not save all user fields correctly. 

Customers Impacted: This defect affects Open Plan saving user fields and updating baseline in a 

master project. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

This section includes the changes made to the database for this release. 

New Tables 

Table Name 

FW_CFGProcessQueue 

FW_CFGProcessQueueSetup 

FW_DetailJobs 

FW_DetailJobStatus 

FW_DetailProfiles 

FW_MasterJobs 

FW_MasterProfiles 

WST_APPSERVERS 

WST_TAB_PRD_ACTION 

WST_USR_CTRL_COUNTRY 
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New Columns Added 

Table Name Column Name Data Type 

FW_CFGPROCESSQUEUE  QueueID varchar(32) NOT NULL 

FW_CFGPROCESSQUEUE QueueName  nvarchar(40)   NULL 

FW_CFGPROCESSQUEUE QueueStatus smallint DEFAULT ((0)) NOT NULL 

FW_CFGPROCESSQUEUE Priority smallint DEFAULT ((0)) NOT NULL 

FW_CFGPROCESSQUEUE ProcessServerMachineNam

e 

nvarchar(255)  NULL 

FW_CFGPROCESSQUEUE MaxRunningThreads int DEFAULT ((0)) NOT NULL 

FW_CFGPROCESSQUEUE CreateUser nvarchar(20)   NULL 

FW_CFGPROCESSQUEUE CreateDate datetime NULL 

FW_CFGPROCESSQUEUE ModUser nvarchar(20) NULL 

FW_CFGPROCESSQUEUE ModDate datetime NULL 

FW_CFGPROCESSQUEUESETU

P 

Pkey varchar(4) 

FW_CFGPROCESSQUEUESETU

P 

PollingFrequency int 

FW_CFGPROCESSQUEUESETU

P 

RetainHistory varchar(1) 

FW_CFGPROCESSQUEUESETU

P 

DaysToRetainHistory smallint 

FW_CFGPROCESSQUEUESETU

P 

RetainErrors varchar(1) 

FW_CFGPROCESSQUEUESETU

P 

DaysToRetainErrors int 
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Table Name Column Name Data Type 

FW_CFGPROCESSQUEUESETU

P 

CreateUser nvarchar(20) 

FW_CFGPROCESSQUEUESETU

P 

ModUser nvarchar(20) 

FW_CFGPROCESSQUEUESETU

P 

ModDate datetime 

FW_DetailJobs QueueID varchar(32) NOT NULL 

FW_DetailJobs ProcessID varchar(32) NOT NULL 

FW_DetailJobs DetailID varchar(32) NOT NULL 

FW_DetailJobs Seq int DEFAULT ((0)) NOT NULL 

FW_DetailJobs ProgID varchar(200) NULL 

FW_DetailJobs Description nvarchar(250)  NULL 

FW_DetailJobs TimeStarted datetime NULL 

FW_DetailJobs TimeEnded datetime  NULL 

FW_DetailJobs ProcessStatus smallint DEFAULT ((0)) NOT NULL 

FW_DetailJobs AlertPending varchar(1) NULL 

FW_DetailJobs TerminationMessage  nvarchar(max) NULL 

FW_DetailJobs xmlParams nvarchar(max) NULL 

FW_DetailJobs ServerName nvarchar(255) NULL 

FW_DetailJobs Company nvarchar(14)   NULL 

FW_DetailJobs DateTimeFormat nvarchar(max) NULL 

FW_DetailJobs NumberFormat nvarchar(max) NULL 
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Table Name Column Name Data Type 

FW_DetailJobs UICultureName varchar(10) NULL 

FW_DetailJobs ContextState nvarchar(max) NULL 

FW_DetailJobStatus QueueID varchar(32) NOT NULL 

FW_DetailJobStatus ProcessID varchar(32) NOT NULL 

FW_DetailJobStatus DetailID varchar(32) NOT NULL 

FW_DetailJobStatus StatusID varchar(36) NOT NULL 

FW_DetailJobStatus StatusDate datetime NULL 

FW_DetailJobStatus StatusMessage nvarchar(1000) NULL 

FW_DetailProfiles QueueID varchar(32) NOT NULL 

FW_DetailProfiles ProcessID varchar(32) NOT NULL 

FW_DetailProfiles DetailID varchar(32)  NOT NULL 

FW_DetailProfiles Seq int DEFAULT ((0)) NOT NULL 

FW_DetailProfiles ProgID varchar(200 ) NULL 

FW_DetailProfiles Description nvarchar(80) NULL 

FW_DetailProfiles TimeStarted datetime NULL 

FW_DetailProfiles TimeEnded datetime NULL 

FW_DetailProfiles ProcessStatus smallint DEFAULT ((0)) NOT NULL 

FW_DetailProfiles AlertPending varchar(1) NULL 

FW_DetailProfiles TerminationMessage nvarchar(max) NULL 

FW_DetailProfiles xmlParams nvarchar(max) NULL 

FW_DetailProfiles Company nvarchar(14) NULL 
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Table Name Column Name Data Type 

FW_DetailProfiles DateTimeFormat nvarchar(max) NULL 

FW_DetailProfiles NumberFormat nvarchar(max) NULL 

FW_DetailProfiles UICultureName varchar(10) NULL 

FW_DetailProfiles ContextState nvarchar(max) NULL 

FW_DetailProfiles CreateUser nvarchar(20) NULL 

FW_DetailProfiles CreateDate datetime NULL 

FW_DetailProfiles ModUser nvarchar(20) NULL 

FW_DetailProfiles ModDate datetime NULL 

FW_MasterJobs QueueID                varchar(32)  NOT NULL 

FW_MasterJobs ProcessID varchar(32)  NOT NULL 

FW_MasterJobs ProcessStatus          smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs TimeSubmitted          datetime     NULL 

FW_MasterJobs RunAfter datetime     NULL 

FW_MasterJobs TimeStarted            datetime     NULL 

FW_MasterJobs TimeEnded              datetime     NULL 

FW_MasterJobs Submitter nvarchar(20) NULL 

FW_MasterJobs Description            nvarchar(250)NULL 

FW_MasterJobs ProcessAlert           varchar(1)   NULL 

FW_MasterJobs RecurrenceInd          varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrType             nvarchar(20) NULL 
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Table Name Column Name Data Type 

FW_MasterJobs RecurrFreq             int          DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrDailyFreq        smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrDailyWeekDay     varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklyFreq       smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrWeeklySun        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklyMon        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklyTue        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklyWed        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklyThu        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklyFri        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrWeeklySat        varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrMonthlyFreq      smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrMonthlyDay       smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrYearlyMonth      smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrYearlyDay        smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrStartDate        datetime     NULL 
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Table Name Column Name Data Type 

FW_MasterJobs RecurrEndType          varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs RecurrEndDate          datetime     NULL 

FW_MasterJobs RecurrMonthlyOccur     smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrMonthlyOccurFreq smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrMonthlyOccurDay  smallint     DEFAULT ((0)) NOT NULL 

FW_MasterJobs RecurrMonthlyOccurInd  varchar(1)   DEFAULT (''N'') NOT NUL

L 

FW_MasterJobs AppKey                 varchar(32)  NULL 

FW_MasterJobs AppRecordKey           varchar(22)  NULL 

FW_MasterProfiles QueueID               varchar(32) NOT NULL 

FW_MasterProfiles ProcessID             varchar(32) NOT NULL 

FW_MasterProfiles ProcessStatus         smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles TimeSubmitted         datetime    NULL 

FW_MasterProfiles RunAfter              datetime    NULL 

FW_MasterProfiles TimeStarted           datetime    NULL 

FW_MasterProfiles TimeEnded             datetime    NULL 

FW_MasterProfiles Submitter             nvarchar(20)NULL 

FW_MasterProfiles Description           nvarchar(80)NULL 

FW_MasterProfiles ProcessAlert          varchar(1)  NULL 

FW_MasterProfiles RecurrenceInd         varchar(1)  DEFAULT (''N'') NOT NUL

L 
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Table Name Column Name Data Type 

FW_MasterProfiles RecurrType            nvarchar(20)NULL 

FW_MasterProfiles RecurrFreq            int         DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrDailyFreq       smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrDailyWeekDay    varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklyFreq      smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrWeeklySun       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklyMon       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklyTue       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklyWed       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklyThu       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklyFri       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrWeeklySat       varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrMonthlyFreq     smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrMonthlyDay      smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrYearlyMonth     smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrYearlyDay       smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrStartDate       datetime    NULL 
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Table Name Column Name Data Type 

FW_MasterProfiles RecurrEndType         varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles RecurrEndDate         datetime    NULL 

FW_MasterProfiles RecurrMonthlyOccur    smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrMonthlyOccurFre smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrMonthlyOccurDay smallint    DEFAULT ((0)) NOT NULL 

FW_MasterProfiles RecurrMonthlyOccurInd varchar(1)  DEFAULT (''N'') NOT NUL

L 

FW_MasterProfiles AppKey                varchar(32) NULL 

FW_MasterProfiles AppRecordKey          varchar(22) NULL 

FW_MasterProfiles CreateUser            nvarchar(20)NULL 

FW_MasterProfiles CreateDate            datetime    NULL 

FW_MasterProfiles ModUser               nvarchar(20)NULL 

FW_MasterProfiles ModDate               datetime    NULL 

WST_APPSERVERS APPSERVER nvarchar(80)    NOT NULL 

WST_DCT DEL_FOREIGN_ACTION varchar(50)    NULL 

WST_GRP CTRL_COUNTRY  NVARCHAR (40) 

WST_PRD PPM_ADMIN_COMPAT_VE

R 

INT (Default 0, Not Null) 

WST_TAB DATA_OBJ_TYPE_DESCRIP VARCHAR (60) 

WST_TAB_PRD_ACTION PRD_UID int            NOT NULL 

WST_TAB_PRD_ACTION TABLE_TYPE varchar(30)    NOT NULL 
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Table Name Column Name Data Type 

WST_TAB_PRD_ACTION ACTION_TYPE varchar(50)    NOT NULL 

WST_TAB_PRD_ACTION EXEC_PROC varchar(255)   NOT NULL 

WST_ULI FLAGS INT (Default 0, Not Null) 

WST_USR PWD_LASTUPDATE DATE (Not Null) (Default, current 

date) 

WST_USR ACTIVE INT (Default 1, Not Null) 

WST_USR AUTHTYPE INT (Default 0, Not Null) 

WST_USR FAILED_LOGINS INT (Default 0, Not Null) 

WST_USR DELEGATE NVARCHAR (20) 

WST_USR ISOUTOFOFFICE NVARCHAR (1), DEFAULT 'N', NOT 

NULL 

WST_USR_CTRL_COUNTRY CTRL_COUNTRY nvarchar(40) NOT NULL 

Changes to Existing Columns 

Table Name Column Name Data Type 

WST_USR CITY NVARCHAR (40) 

WST_USR STATE NVARCHAR (40) 

WST_USR COUNTRY NVARCHAR (40) 
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Documentation Changes 

This section includes details of sections changed in the printed documentation. 

Documentation Module Description of Change 

Deltek EPM Security Administrator 8.5.1 Help Updated the following topics: 

 Add a Product to a User 

 Add Product Dialog Box 

 Assign a Product License to a User 

 Assign a User to a Product 

 Define Group Profiles Overview 

 General Tab of the Groups Form 

 Manage Products Overview 

Added the following topics: 

 Functionalities Not Supported in the Future 
Versions of EPM Security Administrator 

 AI Account Settings Dialog Box 

Deltek Open Plan 8.7 Developer Guide Updated tables related to EPM SA 8.5.1 

Deltek Open Plan 8.7 Installation Guide Added a note related to running Open Plan 

scripts prior to running scripts for other PPM 

products under the Integrate Open Plan with 

Other PPM Products section 

Deltek Open Plan 8.7 Entity Relationship Diagram Updated tables related to EPM SA 8.5.1 
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Open Plan 8.7 Cumulative Update 05 
Released: November 6, 2024 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Activity Details 

Defect 2248054 

Description: When you selected the Selected Baseline option in the Show Time Phase Based 

On group-box on the Activity Details Resources tab, the first few month columns displayed zero (0) 

instead of the correct values. 

Customers Impacted: This defect affects Open Plan users displaying time-phased values based on 

the selected baseline. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

File » Import – Export » General 

Defect 2257107 

Description:  Importing a project with many activity steps took longer than expected. 

Customers Impacted: This defect affects Open Plan users using General Import. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Defect 2257982 

Description: When importing a .CSV file where the selected format included hours and minutes from 

the Default Date Format drop-down list on the Project Properties Preferences tab, the imported 

dates did not retain the correct format, causing discrepancies with the original .CSV file data. 

Customers Impacted: This defect affects Open Plan users using General Import. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 
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Defect 2256081 

Description: When you tried to import a file using the General Import feature with the Default Data 

Format property set to include %H (Hours), an error message would display. 

Customers Impacted: This defect affects Open Plan users using General Import. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

View » Barchart View » Bar Sets 

Defect 2259397 

Description: When you restored a project and opened it in BARVW, all child activities under a 

subproject displayed zero duration, and the ESDATE matched the EFDATE. However, the blue bars 

next to these child activities displayed a duration equal to the minimum date axis period. The bars 

should have aligned with the actual activity dates. 

Customers Impacted: This defect affects Open Plan users opening a project in BARVW. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no database changes in this release. 

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 04 
Released: October 1, 2024 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Resource Details 

Defect 2179047 

Description: When resources had the Suppress in Lists option selected in the Resource Details 

dialog box, and you navigated to the Resources tab in the Activity Details dialog box, a warning 

message would display, notifying you that the list contained too many items to display. 

Customers Impacted: Open Plan users using resources with the Suppress in Lists option. 

Workaround Before Fix: Take one of the following actions: 

 Ignore the error message and enter the resource ID manually in a cell instead of selecting one 
from the drop-down list on the Resources tab in the Activity Details dialog box. 

 Do not select Suppress in Lists option for all resources on the General tab in the Resource 
Details dialog box. 

Files Updated: 

 OpenPlan.exe 

 

Defect 2220566 

Description: After entering a value (for example, 1) in a cell on the Availability tab in the Resource 

Details dialog box and clicking Apply, the displayed value would display incorrectly (for example, 

100). This issue only occurred when the Windows Regional setting was configured for certain non-

US countries, where commas in numerical values are interpreted as decimal points. 

Customers Impacted: Open Plan users updating resources. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 
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File » Open 

Defect 2242882 

Description: While in the Activity Details dialog box and either the Activity or Resource Description 

drop-down list was loading, you may encounter a memory-related error leading to the application 

crashing. 

Customers Impacted: All Open Plan users. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no changes made to the database for this release.  

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 03 
Released: August 2024 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Other » PMC Integration 

Defect 2179035 

Description: When a PM Compass workflow called Open Plan to respread resources, Open Plan 

would return a Resource Assignment object spanning the entire Activity duration if the requested 

time period had a finish date after the end of the Reporting Calendar. 

Customers Impacted: Open Plan users using PM Compass. 

 

Workaround Before Fix: Make sure that the Reporting Calendar extends beyond the activity finish 

date. 

Files Updated: 

 OpenPlan.Engine.dll 

Defect 2193604 

Description: When calling the PM Compass method CreateSpreadFromASG, the total amount of 

work spread over the reporting calendar periods would not add up to the original amount of work to 

be spread. As a result, the timephase spread between PM Compass and Open Plan would not match. 

Customers Impacted: Open Plan users using PM Compass. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 
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Defect 2198037 

Description: This defect impacted two PM Compass methods: 

 When calling the PM Compass method CreateSpreadFromASG, it would ignore spread objects 
with a duration of zero. 

  When calling the PM Compass method CreateASGFromSpread, the work associated with the 
spread object would spread across the entire activity period if the spread object's end date 
extended beyond the reporting calendar's end date. 

Customers Impacted: Open Plan users using PM Compass. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Tools » Global Edits 

Defect 2181895 

Description: When you hid or disabled the Delete Global Edit item in EPM Security Administrator, 

you could still see the Delete button and delete global edits in Open Plan. 

Customers Impacted: Open Plan users using global edits. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

Project » Baselines 

Defect 2191803 

Description: When trying to restore a backup file, the process would fail because of a missing parent 

baseline activity, displaying OLE DB error messages. 

Customers Impacted: Open Plan users restoring backup files. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

 OpenPlan.Ext.dll 

Security Enhancements  

There are no security enhancements in this release. 
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Database Changes  

There are no changes made to the database for this release.  

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 02 
Released: June 28, 2024 

Enhancements 

There are no enhancements in this release. 

Software Issues Resolved 
Edit » Resource Details 

Defect 2162744 

Description: When you checked out a project to a briefcase database and checked it in, a database 

error would occur due to the presence of unused fields in the data dictionary table.  

Customers Impacted: Open Plan users checking out a project to a briefcase database. 

Workaround Before Fix: Manually delete the two unused fields. 

Files Updated: 

 OpenPlan.Engine.dll 

 OPP_Briefcase.mdb 

File » Import – Export » BK3 

Defect 2123633 

Description: Clicking the Field Mappings button on the Options page of the Open Plan Import 

wizard during an import would cause Open Plan to crash. 

Customers Impacted: Open Plan users importing Open Plan backup files. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.BK3Import.dll 
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File » Import – Export » Primavera 

Defect 2128324 

Description: If you tried to import data from P6 Web with many note categories, the import process 

would fail and display an error message. 

Customers Impacted: Open Plan users importing Oracle Primavera P6 Web projects with many note 

categories. 

Workaround Before Fix: None. 

Files Updated: 

 PPM.Integration.Primavera.dll 

 PPM.P6WebServices.dll 

Other » Performance 

Defect 2162238 

Description: When you opened a project in Shared mode and edited a note either from the notes 

column or the Activity Details dialog box, the project view would refresh but take longer than usual. 

Customers Impacted: Open Plan users editing a note for a project opened in Shared mode. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Project » Schedule Driver Analysis 

Defect 2142436 

Description: When filtering or performing Schedule Driver Analysis on a selected activity in a master 

project, the Open External Subprojects dialog box would display unexpectedly. 

Customers Impacted: Open Plan users using filters or the Schedule Driver Analysis functionality. 

Workaround Before Fix: In the Open External Subprojects dialog box, click OK or Cancel and 

continue. 

Files Updated: 

 OpenPlan.exe 
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Tools » Filters 

Defect 2101056 

Description: When you selected an activity with a User Character Field column value containing an 

apostrophe and selected the Add to Filter option, an error message would display. 

Customers Impacted: Open Plan users using the Add to Filter option. 

Workaround Before Fix: Manually edit the filter. 

Files Updated: 

 OpenPlan.exe 

Views 

Defect 2154823 

Description: When you exported a file to Microsoft Project (MSP) as an update to an existing 

project, this would result in inconsistent values in the Work column between Open Plan and MSP. 

Open Plan was not clearing out existing values in the MSP project before setting updated values. 

Customers Impacted: Open Plan users exporting a file to MSP. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Msp.dll 

 Ppm.Integration.Msp.dll 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no changes made to the database for this release.  

Documentation Changes 

There are no documentation changes in this release. 
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Open Plan 8.7 Cumulative Update 01 
Released: May 24, 2024 

Enhancements 
Ability to Reset Data Source Connection After a Period of Inactivity 

A new System Preference option, _MaxDBDriverIdleMinutesBeforeAutoReset, enables you to specify 

the number of idle minutes allowed before Open Plan automatically resets the data source connection. 

The allowable range for this value is from 10 to 480 minutes, with a default setting of 55 minutes. 

 If _MaxDBDriverIdleMinutesBeforeAutoReset is set within the supported range (for example, 
10), the opwin.log file will display the following message when a long running process like an  
import completes: "Re-initializing data source connection as the connection has been idle for X 
minutes or longer." 

 If _MaxDBDriverIdleMinutesBeforeAutoReset is set to a value outside the supported range (for 
example., 6), the opwin.log file will display the following message: "The value supplied for the 
preference "_MaxDBDriverIdleMinutesBeforeAutoReset" (X) should be in the range (10 - 
480).  Will use the default (55 minutes) instead". 

Software Issues Resolved 
Edit » Activity Details 

Defect 2056893 

Description: When trying to indent some activities under another activity, if you selected the 

activities to indent by dragging over a range of cells (like the values in the Description column) and 

then clicked Indent in the Data menu group on the Edit tab, Open Plan would duplicate and indent 

only the first task among the selected tasks. 

Customers Impacted: Open Plan users using the Indent command. 

Workaround Before Fix: Select the activities to indent by selecting the rows rather than just a few 

cells like the description field. 

Files Updated: 

 OpenPlan.exe 

Defect 2102012 

Description: When you edited and saved a note in an activity, Open Plan would include unnecessary 

characters in the displayed note. 

Customers Impacted: Open Plan users using notes. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 
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Defect 2106750 

Description: If you added activities (for example, Activity 1 and Activity 2) to a BARVW and then 

added a resource assignment to one of the activities (for example, Activity 1), Open Plan would 

display the error message "Attempted an unsupported operation." 

Customers Impacted: Open Plan users adding resource assignments. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

 OpenPlan.Language.409.dll 

Edit » Filters 

Defect 2102276 

Description: When editing a temporary filter, the Foreign Project activity type would not display in 

the drop-down list in the Filter Expression dialog box. 

Customers Impacted: Open Plan users editing temporary filters.  

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.exe 

 OpenPlan.Ext.dll 

File » Import » MSP 

Defect 2103020 

Description: In certain scenarios, Open Plan could filter out a project during a Microsoft Project 

import, resulting in a process failure. 

Customers Impacted: Open Plan users performing a Microsoft Project import. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Msp.dll 

 PPM.Integration.Msp.dll 
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Other » Batch Interface 

Defect 2107777 

Description: Occasionally, when trying to run the Global Backup process, Open Plan might display 

an error message. 

Customers Impacted: Open Plan users using Global Backup. 

 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

Project » Cost Calculations 

Defect 2102256 

Description: Cost Calculations was not rolling up the ETC Other Direct Costs values properly. You 

could see this by adding this column to a spreadsheet. 

Customers Impacted: Open Plan users using ETC Other Direct Costs. 

Workaround Before Fix: None. 

Files Updated: 

 OpenPlan.Engine.dll 

 

Defect 2107146 

Description: In a bar chart view, the Physical % Complete (PPC) column might show a value 

of 1.10 for completed subprojects, even though the Physical % Complete field in the Activity 

Progress window for these subprojects showed 100%. However, for completed child activities, both 

the PPC column and field displayed the correct values. This was due to Cost Calculations using only 

cost values to roll up percent complete and not looking also at the computed status. 

Customers Impacted: Open Plan users updating PPC values. 

 

Workaround Before Fix: Run Progress Calculations or Cost Calculations. 

Files Updated: 

 OpenPlan.Process.dll 
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Project » Baselines 

Defect 2128841 

Description: When a project is open in Read Only mode with _ALLOW_EDIT_READONLY =1, you 

could create a baseline but not select or display it.  

Customers Impacted: Open Plan users creating baselines in Read Only mode. 

 

Workaround Before Fix: Open the project in Exclusive mode. 

Files Updated: 

 OpenPlan.exe 

Security Enhancements  

There are no security enhancements in this release. 

Database Changes  

There are no changes made to the database for this release.  

Documentation Changes 

This section includes details of sections changed in the printed documentation. 

Documentation Module Description of Change 

Deltek Open Plan 8.7 Help Updated the Options Dialog Box Advanced Tab 

section to cover the new system preference. 
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Appendix A: For Additional Information 
Deltek Support Center 

The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing 

Support Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 

 Search for product documentation, such as release notes, install guides, technical information, 

online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 

Deltek Support Center Community 

 Access Cloud-specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Deltek Support Services analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Initiate a Chat to submit a question to a Deltek Support Services analyst online 

 

Access Deltek Support Center 

To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 

 

Attention: For more information regarding Deltek Support Center, refer to the online help available 

from the Web site. 

Note: If you forget your username or password, you can click the Need Help? button on the login 

screen for help. 

https://deltek.custhelp.com/
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