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While Deltek has attempted to verify that the information in this document is accurate and complete, 
some typographical or technical errors may exist. The recipient of this document is solely responsible for 
all decisions relating to or use of the information provided herein. 

The information contained in this publication is effective as of the publication date below and is subject to 
change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are reserved. No 
part of this document may be reproduced or transmitted in any form or by any means, electronic or 
mechanical, or translated into another language, without the prior written consent of Deltek, Inc. 

This edition published December 2023. 

© Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and proprietary 
information of Deltek, Inc. and its licensors. The Deltek software, and all related documentation, is 
provided for use only in accordance with the terms of the license agreement. Unauthorized reproduction 
or distribution of the program or any portion thereof could result in severe civil or criminal penalties. 

All trademarks are the property of their respective owners.  
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Overview 
Deltek ComputerEase 23.3 is proof of Deltek’s commitment to investing in the ComputerEase product. 
Version 23.3 provides your ComputerEase with an updated, more modern look and feel. 

Deltek realizes that changes in your daily processes can be disruptive. First and foremost, the Flow and 
functionality is the same strong, familiar ComputerEase you know and love. 

This document contains before and after visuals so you and your company can be prepared for the 
upcoming changes. 
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Branding 
It has been four years since Deltek acquired ComputerEase; and version 23.3 now proudly represents 
Deltek throughout. 

 The vintage blue and red ComputerEase logo has been replaced with the Deltek ComputerEase 
logo, including the signature Deltek Chevron.  

 The blue and red CE Desktop Shortcuts has been replaced with the Deltek Chevron. 

 The blue and red CE thumbnails have been replaced with the Deltek Chevron within Windows 
File Manager. 

Before After 
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Login Screen 
After you have clicked into your shortcut to initiate your session, your Login screen will reflect the new 
Deltek ComputerEase Logo.  

Notice the Company, User ID, and Password fields are unchanged.  

Before After 

  

First Time Login Workflow Menu 
Once logged into ComputerEase, your menu and options will feel like home.  

 Same menus and custom colors 

 Deltek Branding 

 Updated Taskbars 

Notice the menu options, tabs, and workflow items are the same. Your processes can be found in all the 
same places.  
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Before After 

  

First Time Login Classic View Menu 
The classic menu has not been removed. If you are currently a Classic Menu user, when you log into 
ComputerEase 23.3, your menu will default to the Classic View.  

Before After 
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Main Menu Enhancements 

Dark Mode Theme Toggle 
Introducing the ComputerEase Dark Mode Theme toggle. This new and easily identifiable toggle switch 
makes transitioning to and from the Dark Mode Theme quick and easy (with sun and moon as a visual). 

The lighter screen you are currently accustomed will now be considered Light Mode Theme.  

 
This is the same ComputerEase you depend on to run your day to day, with a new look and feel. 
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Support Dropdown Revisions 
Within the Support dropdown, the option names have been revised slightly for more intuitive selection.  

Before After 

 

 

Help Dropdown Options 
Within the Help dropdown, two new options have been added: 

 Knowledge Base Articles: This is a link to a FAQ library authored by our Customer Care team. 
You can press CTRL+F to find topic-specific advice, suggestions, and resolutions for common 
support questions. 

 ComputerEase Resource Center 

 

ComputerEase Resource Center 
The ComputerEase Resource Center is brand new website, with content to include: 

 Release Notes for current and prior updates 

 Links to the Support Center and Customer Corner 

 Upcoming event information and registration 

 Training videos and Change Management documentation 

Again, the ComputerEase Resource Center can be found within the Help dropdown from inside your 
ComputerEase software. 
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Task Bar Icons 
In version 23.3, taskbars throughout the system have a new look. The functions have new, more modern 
images, but note that they: 

 Have similar images 

 Display in the same order 

 Have the same hover text 

 Have the same functionality 

The follow images show the Main Menu taskbar. 

Before After 

  

Tip: Bookmark this website for quick and easy access. 
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View Dropdown 
For our Classic menu users, now is a perfect time to tryout the Workflow menu.  

To change from Classic to Workflow, click View » Workflow Menu. 

There are many benefits to using the Workflow menu. You can also use the Dark Theme option on the 
View dropdown as an alternative method to toggling between the Light mode theme and Dark mode 
theme. 

 

 

 

Note: You should close your ComputerEase process windows before toggling between Light and 
Dark mode theme. 
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User Profile Icon 
The User Profile Icon can be found in the upper right-hand corner. 

 
Hovering on the User Profile icon displays the Username (or User ID) as it’s entered in password 
maintenance.  

 
Clicking the icon provides a dropdown menu with the following options: 

 Logout: The Logout icon on the taskbar has not been removed. However, adding this option to 
the User Profile dropdown felt intuitive.  

 
 Configure User: Prior to version 23.3, these user settings were found within the Configure Menu.  

 Configure Sending Email: Screen display preferences, printer defaults, and email configuration 
details for the user can be easily accessed using the Configure options. 

 

All Things Deltek 
Next to the User Profile is the new Deltek icon. 

 

Note: Deltek recommends logging out in lieu of closing the program by clicking X so that any active 
processes are properly terminated. 
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Prior to version 23.3, the Deltek options were the four icons in the upper right-hand corner of the Main 
Menu taskbar. These functions have now been combined into a single dropdown accessed by clicking the 
new Deltek icon. 

Before After 

 
 

Main Menu Search 
Highlighted on the left-hand side is the new Menu Search field. 

Before After 

  

Many long-time users did not realize there was a Search tool to assist in finding menu options. So, in 
version 23.3, the Search tool has been visually emphasized. 

To use, type your desired text in the Search field, and ComputerEase filters and displays just those menu 
options that contain your text. 

Removing Search Criteria 
When you want to remove the Search criteria, click the X at the right of the Search field. 

In the following example, “Role” was entered in the Search field, and the menu filtered to display only the 
menu options with “Role” in their name. To remove the search criteria, click the X. 
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Tab Formatting — Optional Images 
Prior to version 23.3, images on tabs were required. These tab images have now been made optional. 
Your current images will follow into 23.3, but you now have the option to remove them.  

 
To remove your tab images, while in Edit Workflow mode, click the tab you want to edit, and then click 
Rename tab.  

 
Notice that No Image is now an option for selection. 

Before After 
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Tab Formatting — Tab Height 
Optional tab images were implemented to simplify the look of the tabs. The height of the tabs is taller if 
one or more tabs have an image. However, if you remove all the tab images, the tabs will automatically 
resize for a more sleek, shorter appearance. 

With Images Without Images 

  

Keyboard Shortcuts 
The order in which the System Menu options display is unchanged. Your existing menu configurations 
and permissions will convert to version 23.3. 

Your existing system may have boxed alphabet letters next to your menu options. These are called 
keyboard shortcuts. In version 23.3, the keyboard shortcuts are hidden by default. For new users, the 
keyboard shortcuts are disabled. 

If you want to reinstate the lettered keyboard shortcuts, click View » Keyboard Shortcuts.  

 

Before After 
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Main Menu — System Menu 
Your existing system has an anchored System Menu, as does version 23.3. 

In 23.3, the Quick Access Menu has been anchored to the top of the System Menu. Quick Access is 
an option you currently have, and it can be found at the bottom of your System Menu.  

Before After 

 

 

Main Menu — Expand, Contract, Hide 
Notice the little arrows by the anchored menu titles. These arrows allow you to expand, contract, and hide 
menu details.  

The left pointing arrow by the Search field hides the entire Main Menu.  

The up and down arrows expand and contract the anchored Quick Access Menu and System Menu, 
showing and hiding details. 

Before After 
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Main Menu — Flexibility in View 
This following example illustrates the power of the Quick Access Menu. In the following example, the 
System Menu has been contracted and the Quick Access Menu expanded. 

 
Because the Quick Access Menus are created by you, you can design your very own Quick Access 
favorites. After you have the perfect Quick Access menu created for yourself, it can be assigned as the 
default within Configure User (in User Profile dropdown). 

If you have created multiple quick Access Menus, you can easily switch between them by using the 
Select Quick Access Menu option. Rather than clicking in and out of menus to find what you want, using 
Quick Access Menus can save you valuable time by going straight to your favorite spots.  

External Workflow Items 
To customize daily flow, enhancements have been made for your custom Workflow items and groups. 
Workflow item images have been updated with a new look and feel. Again, all your existing Workflow 
Items, Groups, and their details will transition to version 23.3. 

 
Version 23.3 now allows you to add external items to your workflow menus by using drag and drop. 
Simply drag your file, shortcut, or URL and drop it onto your Workflow menu. Spreadsheets, Word 
documents, and website URLs are examples of tasks performed outside of ComputerEase that can now 
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be woven into your Workflows. Now you won’t forget to update that spreadsheet or make that website 
entry; your reminder is embedded in your ComputerEase workflow.  

F2 Lookup Image 
There is a new image for the F2 lookup. The question mark has been replaced with a magnifying glass.  

Before After 
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Color Options 

Light Mode Theme Custom Colors 
Many of you have created wonderful color schemes for your Workflow menus, Classic menus, and entry 
screens. Your custom colors will not be lost and will now be considered your Light mode theme colors.  

Your ability to tweak your light mode colors can still be performed through File » Colors.  

 
Many times, color customizations were created so users had a visual reminder of what company they are 
working in. When in light mode, these customizations will still be visible.  

Dark Mode Theme Custom Colors  
You can also define custom colors for your Dark mode theme through File » Colors. The list of 
customizable items is much smaller for dark mode. 

 
Dark mode has a new method for identifying company colors. Individual companies can be assigned 
unique Title Bar colors.  
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Under Configure » Company Name, you can select a Title Bar Background Color and Title Bar Text 
Color for each company, taking colors to a brand-new level. This allows you to easily identify the 
company in which you are working. 

 

 

Dark Mode Examples 
The Main Menu title bar and title bars for working processes will be filled with your selected company 
colors. The prominent colored title bar simplify company identification. For example, Company A will be 
red for all users, Company B will be Green for all users, or whatever colors you choose. These title bar 
colors also flow through to Qtool as well.  

 

Note: Colors assigned in Company Name are for Dark Mode Theme only. 
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Display Reports 
Displayed reports have received Dark Mode Theme color updates. Notice the green horizontal line row 
highlighting in the after screenshot. 

Before After 

 

 

Displayed Reports — Row Highlights 
Prior to version 23.3, the horizontal row highlights were referred to as Simulate Green Bar Paper. In 
23.3, this option was renamed to Row Highlighting, as many of our users are not familiar with the old dot 
matrix green bar paper.  

Before After 
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If you don’t currently see the green row highlighting on your displayed reports, you may want to turn this 
option on as it can simplify reading wide reports (via User Profile icon » Configure User).  
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Qtool 

New Qtool Icon 
Qtool has a new icon on the Main Menu taskbar. Instead of just a Q, the icon is now a Q within a report.  

Before After 

 

 

 

New Qtool Taskbar 
The Qtool taskbar has been updated with: 

 Similar images 

 Same hover text 

 Same order 

 Same functionality 

 The ? (About) button has been removed 

Before After 
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Removed Thumbnail Images 
Your saved Qtool reports will flow through to version 23.3. 

The thumbnail images next to the report options have been removed for a cleaner view.  

Before After 

 
 

“New Report” vs. “None” 
Prior to version 23.3., creating a new report was achieved by clicking (None). In 23.3., creating a new 
report is achieved by clicking on (New Report). 

Before After 
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Time Center Qtool Report 
ComputerEase Field Time entries flow into a new Time Center area for payroll administrators to sort, 
filter, and edit time before exporting it into Labor Distribution. 

 
The new Time Center Qtool report data allows field users to create, save, and send their own Time 
Center Qtool reports.  

The following lists the reportable fields: 
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Centers 

Center Taskbars 
Whether you are on the Workflow or Classic menu, your centers have a new look and feel as well as 
some new features. All of the centers have been updated, along with their taskbars. Two icons on the 
taskbar menus have been removed since their functions can be achieved elsewhere more efficiently.  

The following is new for 23.3: 

 All Centers updated 

 New taskbar icons 

 Same functionality, but with a new look 

 Qtool icon and Main Menu icon removed 

Before After 

  

Center Behaviors 
All of our Centers have learned new behaviors.  

 When large sets of data are being processed, “Calculating” will display in the appropriate area 
while the system is hunting and gathering.  

 If the hunt was unsuccessful in finding data to report, it will display “No Data to Report.” 
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Job Center 
This is the Job Center before and after. Notice the drilldowns are the same, reports are the same, and the 
graphs have beautiful new colors.  

Before After 

 
 

Job Center — Added Job Status 
The ability to view the status if Inactive or Closed is now displayed next to the job name. This is handy if 
a Project Manager is viewing a range of jobs; they will now visibly see the status without having to click 
into the job details.  
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Work in Progress Center 
The is the Work in Progress Center before and after. 

Before After 

 

 

Work in Progress Center — Added Job Status 
The Work in Progress Center also has the Inactive and Closed indicators.  

 

 

Payroll Center — Summary Tab 
This is the Payroll Center Summary tab before and after. 

Before After 
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Payroll Center — Employee Tab 
This is the Payroll Center Employee tab before and after. 

Before After 

 
 

 

Equipment Center 
The Equipment Center before and after. 

Before After 

 
 

Note: Notice that the employee image now displays at the top of the screen next to the employee 
name. 
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Subcontractor Center 
The Subcontract Center before and after. 

Before After 

  

Financial Center 
The Financial Center before and after. 

Before After 
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Cash Center — Cash Flow Tab 
The Flow tab of the Cash Center before and after. 

Before After 

 

 

Cash Center — AR Trends Tab 
The AR Trends tab of the Cash Center before and after. 

Before After 
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Receivables Center 
The Receivables Center before and after. 

Before After 

  

Sales Center 
The Sales Center before and after. 

Before After 
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General Taskbars 
The following sections contain before and after visuals of taskbars that are not module specific.  

 Same functionality 

 Save hover text 

 Updated icon images 

 Workflow and Classic menus display the same icons 

Displayed Reports Taskbar 
The Displayed Reports taskbar before and after. The Qtool icon and the Main Menu icon have been 
removed in version 23.3. 

Before After 

  

Clipboard Taskbar 
The Clipboard Taskbar before and after. 

Before After 

  

Workflow Menu Editing Taskbar 
The Workflow Menu Editing Taskbar before and after. 

Before After 

  



General Taskbars 

Change Management 31 

 

Scan Taskbar 
The Scan Taskbar before and after. 

Before After 
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System Administration 

In App Message Controls 
ComputerEase Notifications are Deltek communications that display at login. Examples of messages 
include notifications that a new release is coming or available, invitations to an upcoming event or 
learning opportunity, or upcoming System Maintenance notifications. 

Controllers and Administrators shared their desire to control who sees these in app messages.In 
response, Deltek reviewed the type of messages typically used to communicate and found there were six 
types:  

 
In version 23.3, you can control the types of messages you want your users to see by adjusting the 
Display ComputerEase Notifications setting in Password Maintenance.  

 Release Available and System Maintenance types are mandatory critical message types, but 
all the other message types are optional.  

 Billing Notices must be visible for at least one user. This is typically the controller or accounting 
lead. 

All of the notification types are enabled for your users when you move to 23.3. Once you’ve settled into 
your new dark mode Workflow, you may want to review your Users Notification settings. 
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Color-Coded Messaging 
Displayed notifications will be color-coded by type and listed in priority order. Each notification is now 
dismissed individually.  
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Payroll 

Enter Labor Distribution 
Some of the entry screens have taskbars embedded in in them that are used for daily processing. These 
taskbars have been updated with the same consistent goal in mind:   

 Similar images 

 Same order 

 Same hover text 

 Same functionality 

The following example is the Enter Labor Distribution by Employee screen. 

Before After 

  

2023 Year End and 2024 Tax Updates 
It is very important to know that version 23.3 contains year-end updates required to generate your 2023 
W2’s and tax forms. The 2024 tax updates are in included in version 23.3 as well. 

Since some states move faster than others in releasing formal tax information, Deltek will continue to add 
as many tax updates as possible in version 23.3.  

Version 23.3 maintenance release is planned for the end of December to catch straggler updates before 
you close your year and start 2024, so keep your eye on our in app notifications for more information.  

Changes include: 

 2024 FICA Wage Base 

 2024 Federal Withholding Tables 

 Various 2024 SUTA Taxable Wage Base Updates 

 Various 2024 State Withholding updates 

 Miscellaneous tax revisions 
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Maximum Sick and Vacation Hours 
In both Vacation and Sick Rule Maintenance, there is a new Maximum Hours Used per Year field. The 
year period can represent a calendar year or employee work year. After the maximum hours are 
established on your rule, you can decide how you want to enforce it: 

 Warning the payroll operator and allowing them to proceed to pay over the max 

 Disallowing the payroll operator to proceed with check printing until the offending hours are 
reclassed or removed.  

This new feature is found in Payroll Maintenance, Sick Rule Maintenance, and Vacation Rule 
Maintenance. 

 

Attention: For a complete list of the changes, please refer to the Release Notes which will be 
published mid-December. These will be found on the ComputerEase Resource Center, which can be 
accessed in ComputerEase through the Help dropdown. 

Note: Always refer to your government resources for verification. 
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Sick/Vacation History Report Daily Summarization 
The Sick/Vacation History Report has been enhanced with an option to Summarize by Day.  

When summarized, all entries for a given day are totaled and presented in a single line. This is handy for 
viewing both Accruals and Expiration activities, making the report much easier to read and understand.  

 

 

 

 

Tip: You may want to set through “Defaults.” 
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Payroll Error Messaging 
The Payroll Register Warning and Error messaging on screen popups has been revised as well as the 
bottom of the printed or displayed Payroll Register. Errors will clearly communicate that they must be 
resolved before proceeding to Check Print and Posting, while warnings allow proceeding “with caution.”  

 Clarified needed actions on the popup screen when generating Payroll Register 

 Added the Exception Type column on the Payroll Register (printed or displayed) to display 
“ERROR” or “Warning” to identify records needing attention 
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Expense  

Desktop Expenses F3 Capabilities 
The F3 function key capabilities are now allowed for repeating a User selection and subsequent fields. 

 

Desktop Expense Creation — Allow Credits 
Credits are now allowed in Desktop Expense Creation for both Reimbursable and Non-Reimbursable 
expense entries. It allows Credits for returns (negatives). 
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Purchase Orders 

Search Center Taskbar 
The Purchase Order taskbar has been updated with new images. 

Before After 
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Service Management 

Search Center Taskbar 
The Service Search Center Taskbar has been updated. 

Before After 

  

Work Order Edit/Entry- Quick Customer/Site Creation 
The Quick Create button has been updated.  

Before After 
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Service Work Order Edit/Entry — No Notes or Attachments 
Empty Notes and Attachment folders will be prefaced with Add.  

Before After 

  

Service Work Order Edit/Entry — With Notes or Attachments 
Notes and Attachment folders with content to view will be prefaced with View.  

Before After 

  

Dispatch Board — Standard 
The standard Dispatch Board taskbar has been updated. 

Before After 
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Dispatch Board — Classic 
The standard Dispatch Board taskbar has been updated. 

Before After 
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Document Management 

Submittal Items Taskbar 
The taskbar menus within Document Management for Submittal tracking have been updated. 

Before After 

  

View Correspondence Log 
The taskbar menus within Document Management for Correspondence Logs have been updated. 

Before After 

  

View Drawing Log 
The taskbar menus within Document Management for the Drawling Log tracking have been updated. 

Before After 
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View Requests for Change Orders 
The taskbar menus within Document Management for Change Order tracking have been updated. 

Before After 

  

Help Screen 
Within the Document Management Help screen, the thumbnail images have been removed. 

Before After 
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CRM 

Search Center TaskBar 
The taskbar menu within the CRM Search Center has been updated. 

Before After 

 
 

Create/Edit an Opportunity 
Various images within CRM Create/Edit an Opportunity have been updated.  

Before After 
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Create/Edit a Company 
Various images within CRM Create/Edit a Company have been updated.  

Before After 

 

 

Export Contacts to Outlook Taskbar 
The CRM Export Contacts to Outlook taskbar has been updated.  

Before After 
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Stay in the Know 

ComputerEase Town Halls 
If you would like to know more about our short- and long-term roadmaps for your Deltek ComputerEase 
product, Deltek suggests that you attend the Quarterly Town Halls. These are free of charge, and a great 
way to learn about what is coming. You can attend Town Halls live or register to watch the recorded 
sessions at your convenience.  
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Customer Advisory Council 
Deltek welcomes users to become members of the Customer Advisory Council, which is a group of users 
who provide feedback to Deltek on the product direction. 

Deltek also has Focus Groups, users who want to be involved in decisions made for specific topics. The 
ComputerEase Field Time and Expense Focus Group has been instrumental in assisting Deltek with the 
modules’ design and flow. There is also the newly formed ProCore Focus Group. These users are 
assisting in the design and flow of the two-way ProCore integration strategy.  

If you are interested in joining any of these groups, send an email to ComputerEaseProduct@Deltek.com. 
Deltek welcomes one and all! 

 

Annual User Conference 
And lastly, mark your calendars for Deltek’s in-person Annual ComputerEase Users Group, ProjectCon. 
The 2023 Annual Users Group was held in Orlando, FL, and the 2024 Annual Users Group will be in 
National Harbor, MD. 

Again, you can find more information by emailing ComputerEaseProduct@Deltek.com, or through the 
ComputerEase Resource Center (in product, under Help).  

 

mailto:ComputerEaseProduct@Deltek.com
mailto:ComputerEaseProduct@Deltek.com


 

 

About Deltek 
Better software means better projects. Deltek delivers software and information solutions that enable 
superior levels of project intelligence, management, and collaboration. Our industry-focused expertise 
makes your projects successful and helps you achieve performance that maximizes productivity and 
revenue. www.deltek.com 

http://www.deltek.com/
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