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Overview 
Standard reports that are provided with Deltek for Professional Services (DPS) are designed to 
meet most of your business needs. In addition, you can create custom reports using Microsoft 
SQL Server® Reporting Service’s SQL Server Data Tool — Business Intelligence Report 
Designer. This report writing tool is also known as SSDT-BI Report Designer. 

This guide applies if you use the DPS cloud or on-premise product.  

What This Guide Covers 
This guide provides information for the following steps, which you must complete to create, 
deliver, and generate DPS custom reports: 

Step Description 

1 Install SSDT-BI Report Designer on the machines (usually workstations) from which 
you will create or edit DPS custom reports. 

2  If you use the DPS cloud product: Give the users who will create custom reports 
access to the SSRS report server. 

 If you use the DPS on-premise product: Load the DPS report templates on the 
workstations of the appropriate users who will create custom reports with SSDT-
BI Report Designer. 

3 Do either of the following to create custom reports: 

 Load the DPS report templates on the workstation of users who will create 
custom reports. Access the DPS report templates in SSDT-BI Report Designer to 
create custom reports. 

 Create a custom report from a copy of a DPS standard report in SSDT-BI Report 
Designer. 

5 Load custom reports into DPS using the DPS Report Administration utility. 

6 Set up parameters for a custom report in DPS Settings » General » Custom Report 
Options. Parameters allow users to filter report content before they generate a report. 

7 In DPS Role Security Settings, apply role security to give the appropriate DPS users 
the ability to access the custom reports and print or preview those reports from the 
DPS Reporting menu.  

Appendix A in this guide provides instructions for upgrading custom reports when you migrate 
from Deltek Vision to the DPS on-premise product. This information also applies for upgrading 
from Vision any custom reports that you will use in DPS to generate invoices. 

Specific instructions on how to create and design DPS custom reports is beyond the scope of this 
document. Assistance with creating custom reports is not covered by your Deltek Ongoing 
Support Plan (OSP). If your firm requires custom reports, contact Deltek Global Services for 
information about the custom report services that they provide. 
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Updates to This Guide 
Guides are revised regularly to provide the most up-to-date technical information and instructions. 
Visit the Deltek Support Center at https://support.deltek.com, to download the most recent copy. 

Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® 
Reader® X or greater provides this ability. If you do not already use Adobe Reader, you can 
download it here free from Adobe.  

To add a custom note using Adobe Reader: 
1. On the Reader toolbar, click Comment at the far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to 
match the button. 

3. Position the cursor at the location in the guide where you want the note to appear, and 
click. A note icon is inserted at the location and a text box pops up. 

4. Enter your information in the text box.   

5. Continue adding notes as needed. 

6. Save the document. 

We recommend that you save the document to a slightly different filename so as to keep 
the original file from being overwritten. 

When you read the document, cursor over a note icon to see the information. Double-click a note 
icon to edit the information. 

http://get.adobe.com/reader/
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If You Need Assistance 
If you need assistance installing, implementing, or using DPS, a wealth of information and 
expertise is readily available to you. 

Deltek Support Center 
The Deltek Support Center gives active Deltek customers access to everything provided with their 
Customer Care Plan from one convenient location.  

The following are some of the many options you have at the Deltek Support Center: 

 Deltek Customer Care case ticketing and reporting system 

 Solutions, FAQs, and product documentation 

 Communities and access to tens of thousands of Deltek world-wide users and real world 
solutions created by expert Deltek users. 

 Integrated search 

 Educational content, including webinars, whitepapers, and multimedia presentations 

 Downloads and updates 

 

If you need assistance using the Deltek Support Center site, the online help available on the site 
provides answers for most questions. 

Access the Deltek Support Center 

To access the Deltek Support Center: 
1. Go to https://support.deltek.com.  

2. Enter your Deltek Support Center Username and Password. 

3. Click Log In.  

 

If you do not have a username and password for the Deltek Support Center site, contact your 
firm’s Deltek administrator. 

If you forget your username or password, you can click the Account Assistance button on the 
login screen for help. 
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Supported Report Writing Tool 
The following Microsoft SQL Server® Reporting Services (SSRS) report writing tool is supported 
for creating DPS custom reports: 

 SQL Server Data Tool — Business Intelligence for Visual Studio 2013 Report Designer 
(known as SSDT-BI 2013 Report Designer) 

The SSDT-BI version is different from the standard SSDT version. The SSDT version does not 
include the BI templates and is not supported for creating DPS custom reports. 

SSDT-BI 2013 Report Designer comes with SSRS version 2014. 

RDL 2010 Schema 
SSDT-BI 2013 Report Designer produces a report file with the RDL (report definition language) 
2010 schema that DPS requires. 

If you try to load a custom report into DPS that was created with an unsupported version of 
SSDT-BI Report Designer or an unsupported SSRS report writing tool, you will receive a “SQL 
Report Error loading report” error message. 

To determine whether or not a custom report was created with a supported report writing tool and 
has the supported RDL schema, open an .rdl file for a custom report, and look at the header 
lines. If the report has the supported RDL 2010 schema, it will have 2010 in the path. If, instead, it 
has 2008 in the path, it was created with BIDS 2008 (not supported). The following are header 
line examples: 

 The header line in an .rdl report file that is created with SSDT-BI Report Designer 
(supported) is: 

<Report xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner" 
xmlns="http://schemas.microsoft.com/sqlserver/reporting/2010/01/reportdefinition"> 

 The header line in an .rdl report file that is created with BIDS 2008 (not supported) is: 

<Report xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner" 
xmlns="http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition"> 

 

To support the ability to open, generate, and print custom DPS reports, the DPS database and 
report servers must have one of the supported or compatible versions of Microsoft SQL Server 
installed. These include SQL Server 2014, SQL Server 2012, or SQL Server 2008 R2. For a full 
list of Microsoft SQL Server releases (R), service packs (SP), and cumulative updates (CU) that 
are supported or compatible with DPS, see the Deltek Product Support Compatibility Matrix. You 
can download this PDF document at the Deltek Support Center: https://support.deltek.com. 

Installing SSDT-BI 2013 Report Designer 
Install SSDT-BI Report Designer on the machines (with the appropriate licensing) from which you 
will create or edit DPS custom reports. These machines are typically workstations, rather than 
DPS web servers. 

SSDT-BI 2013 Report Designer is provided with SSRS 2014, but it is not installed automatically. 

Use the following Microsoft link to download SSDT-BI: 

http://www.microsoft.com/en-us/download/details.aspx?id=42313 

http://schemas.microsoft.com/SQLServer/reporting/reportdesigner
http://schemas.microsoft.com/sqlserver/reporting/2010/01/reportdefinition
http://schemas.microsoft.com/SQLServer/reporting/reportdesigner
http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition
http://www.microsoft.com/en-us/download/details.aspx?id=42313
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During the installation, select only the SQL Server Data Tools - Business Intelligence for VS 
2013 check box in the Shared Features section of the setup dialog box. 

 

For a full list of Microsoft SQL Server releases (R), service packs (SP), and cumulative updates 
(CU) that are supported or compatible with DPS, see the Deltek Product Support Compatibility 
Matrix. You can download this PDF document at the Deltek Support Center. 

Deltek can also arrange for implementation services support from your Deltek consultant. 

If you have any additional questions, please contact Deltek Customer Care at 877.457.7765. 
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Using SSDT-BI Report Designer 
SSDT-BI Report Designer is a full-featured, advanced report writing tool that lets you create both 
simple and complex reports. 

SSDT-BI Report Designer Reporting Capabilities 
You can do the following with SSDT-BI Report Designer:  

 Create table, matrix, chart, and free-form reports 

 Apply grouping and formulas in reports 

 Apply sorting 

 Apply filtering 

 Apply advanced reporting features, including complex queries, advanced charting, 
parameters, drill downs, sub-reports, and so on 

 Create expressions to specify report data 

 Combine tables, lists, and charts in the same report 

 Include DPS user-defined fields in reports 

 Access the full DPS database with the reporting tool 

 Include a Sorting/Grouping tab or Columns tab on the report Options dialog box in DPS 
Reporting for custom reports (if you modify special tags in SQL statements) 

You cannot do the following: 

 Create ad hoc reports 

 Launch the report writing application within DPS 

 Create a custom report Options dialog box to display in DPS Reporting for a custom 
report 

 Deploy custom reports outside of DPS 

Give Report Writing Users Access to the SSRS Report Server 
To allow report writing users access to the SSRS report server, you must give them the following 
SSRS permissions: 

 At the server level, users must be system users. 

 At the folder level, users must be granted browser and Content Manager access. 

 

Users who have access to your SSRS report server to create custom reports in SSDT-BI Report 
Designer can access all fields in your DPS database. DPS role security does not apply when 
accessing the DPS database to create custom reports. 
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Non-Domain Clients 
SSRS requires Windows Integrated Authentication. Non-domain clients (clients who do not run 
Active Directory or have a Windows domain) must do the following: 

 Create a local account on the SSRS report server for each user who creates custom 
reports. 

 Grant the necessary reporting services permissions (see the previous section) to those 
who create custom reports. 

Create a Custom Report Using DPS Report Templates 
DPS comes with report templates that you can use to create custom reports in SSDT-BI Report 
Designer. The templates provide formatting for custom reports that is similar to the formatting of 
DPS standard reports. 

You copy the template files to the workstation of users who will be creating custom reports. Then 
when users launch SSDT-BI Report Designer, the DPS templates display in the list of templates. 
You can also locate the template files directly on your SSRS server instead of copying them to 
users’ workstations.  

Template Files 
The template files for custom reports are: 

 DPSTemplateAudit.rdl — Use this template to create audit trail summary reports. Hub 
audit reports, such as Firm Audit and Vendor Audit, are examples of this type of report. 

 DPSTemplateAuditDetail.rdl — Use this template to create audit trail detail reports. Hub 
audit detail reports, such as Firm Audit Detail and Vendor Audit Detail, are examples of 
this type of report. 

 DPSTemplateCustomReport.rdl — Use this template to create a custom report without 
any pre-defined layout. 

 DPSTemplateLandscape.rdl — Use this template for column selection reports that must 
be printed using the landscape orientation. Report properties are set for this, so you do 
not need to modify them. 

 DPSTemplatePortrait.rdl — Use this template to create column selection reports. 

 DPSTemplatePostingLog.rdl — Use this template to create posting log reports. 

 DPSTemplateSubReport.rdl — Use this only to create a sub-report. DPS billing invoices 
are examples of reports that use sub-reports. Each section of a single billing invoice 
(report) is created by using sub-reports. 

 DPSTemplateTransactionList.rdl — Use this template to create transaction list reports. 
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DPS TemplatePortrait.rdl file when you open it in Report Designer: 

 

Load the DPS Report Templates on a Workstation 
To create a custom report on the user’s workstation that has SSDT-BI Report Designer installed, 
copy the .rdl template files (listed in the previous section) to the following location on the user’s 
workstation: 

C:\Program Files\Microsoft Visual Studio 
9.0\Common7\IDE\PrivateAssemblies\ProjectItems\ReportProject  

Access the Report Templates in SSDT-BI Report Designer 
After you copy the .rdl template files to a workstation, when you launch SSDT-BI Report Designer 
and select Business Intelligence Projects, the DPS templates display in the list of templates as in 
the following screen shot. 
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You cannot use the DPS report templates with the SSDT-BI Report Designer Report Wizard. 

To access the DPS report templates to create a custom report, you complete three 
procedures: 

1. Create a solution and report server project. 

2. Create the shared data source. 

3. Select a DPS template and start to create a custom report. 

To create a solution and report server project: 
1. On your workstation, open the SSDT-BI Report Designer software by clicking Windows 

Start » All Programs » Microsoft SQL Server 2014 » SQL Server Data Tools for 
Visual Studio 2013.  

2. Click File » New » Project. 
3. Select Business Intelligence Projects. 

4. In the Templates section of the New Project dialog box, click Report Server Project to 
highlight it. 

5. In the Name field, enter a name for the report server project. For example, you could 
name it DeltekCustomReports. 

A report server project contains: 

 A data source (information about a connection to a data source for your report). 

 Any custom reports that you create with the data source. 

6. In the Location field, enter the path on your workstation where you want to store the 
report server project. 

7. In the Solution Name field, enter a name for the solution in which this report server 
project will be contained. 

Solutions can contain multiple projects. 

8. Click OK. 

In the Solution Explorer pane, you now see the solution that you just created. (To display 
the Solution Explorer pane, click View » Solution Explorer.) 

To create the shared data source: 
1. In the Solution Explorer pane that is located below your solution, right-click Shared Data 

Sources, and click Add New Data Source on the shortcut menu. 

2. On the General tab of the Shared Data Source dialog box, in the Name field, enter 
DefaultDataSource. 

This is the name of the DPS data source. 
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All of the DPS report templates look at the data source called DefaultDataSource. If 
you name it something else, you will receive an error when you select the Data tab of 
the Design window. When you receive the error, click OK and then modify the dataset 
to use your connection instead. You must do this for each dataset. 

Also, when you rename an existing data source, if you previously used the data source 
for a report, the report will be broken and you need to edit the report query to reference 
the new data source name. 

3. From the Type field drop-down list, select Microsoft SQL Server. 
4. Click the Edit button beside the Connection string text box to open the Connection 

Properties dialog box where you can create the connection string to your DPS database. 

a) Select the server on which your DPS database resides. 

Deltek recommends that you use Windows authentication to log on to the server. 
This prevents users from accessing information via SSDT-BI Report Designer that 
they should not access. If you use SQL Authentication and save the password, the 
password is saved as plain text and can be seen with Notepad. 

b) Enter the DPS database name to connect to. 

c) Click OK. 

5. On the Credentials tab of the Shared Data Source dialog box, enter the credential 
information for the data source, and click OK. 

In the Solution Explorer pane, you now see DefaultDataSource.rds in the Shared Data 
Sources folder within the solution. 

6. On the Microsoft Visual Studio toolbar, click File » Save All. 
Save your solution often to prevent losing modifications in the event that SSDT-BI Report 
Designer terminates. 

To select a DPS template and start to create a custom report: 
1. In the Solution Explorer pane, right-click the Reports folder, and click Add » New Item on 

the shortcut menu. 

On the Add New dialog box, you see the DPS report templates.  

2. Click a report template to open it and create a custom report with it. 

Specific instruction on how to create and design DPS custom reports is beyond the scope 
of this document. You can contact CustomServices@Deltek.com for information about 
the custom report services that Deltek provides. 

3. After you create a custom report and it is ready for others to use, load the report into DPS 
using the Report Administration utility in the DPS desktop application. 

DPS does not support the deployment of reports to the SSRS report server directly from 
within the SSDT-BI Report Designer software. Instead, you use the DPS Report 
Administration utility to load custom reports. See the "Load Custom Reports into DPS" 
section on page 18 for more information. 

Multilingual Companies and Report Templates 
You can create custom reports in multiple languages only if you purchase and activate the DPS 
Multilingual module. 

If you have multilingual companies in your enterprise and you want the ability to generate a report 
in multiple languages from one report design, you must create custom reports with DPS report 

mailto:CustomServices@Deltek.com
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templates loaded locally on a workstation. When you create a custom report with the DPS report 
templates directly on your SSRS report server, the report can be generated only for the specific 
culture (language) from which you accessed the report template. 

Create a Custom Report from a DPS Standard Report in SSDT-BI 
Report Designer 
If the content of a standard report is similar or close to what you need in a custom report, you 
may want to start with a copy of a standard report .rdl file and then modify it in SSDT-BI Report 
Designer to suit your needs. 

Start with an .Rdl File that You Create from within DPS 
One way to create a custom report is to start with an .rdl file that you create when you preview a 
standard report in DPS Reporting. 

To create an .rdl file from a previewed standard report in DPS Reporting: 
1. From the DPS Navigation menu in the desktop application, click Reporting, and then 

click the menu item that contains the standard report from which you want to create a 
custom report. 

2. On the report form, click the cell in the Options column for the report that you want to 

start with, and then click  that displays in the cell. 

3. On the report Options dialog box, select the appropriate report options, and click Apply 
to return to the report form. 

4. On the report form toolbar, click  Preview. 

5. On the toolbar of the report preview screen, double-click the Get Report Information 

 icon on the report preview toolbar. 

 
6. On the Report Information dialog box, select Report Definition (RDL File) from the drop-

down list in the View report information field, and click View. 

The Report Definition (RDL File) option provides you with the exact .rdl file that was 
used to load the report instance as it was rendered on the report server. When you 
preview this .rdl file within SSDT-BI Report Designer, it looks exactly like the one in the 
DPS Reporting preview window. 

7. On the File Download dialog box, click Save to save the .rdl file. 
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This saves the report as a new .rdl file. When you open this .rdl file in SSDT-BI Report 
Designer inside of a BI project, it displays exactly as it does in the DPS Reporting 
preview window. 

 

When you save the .rdl file for the new custom report, give it the .rdl file name that you 
want it to have within a BI project. 

Do not give it the same .rdl file name as the DPS standard report that you created it 
from. 

On the File Download dialog box, you can also click the Open button. This opens the .rdl 
file as XML code within SSDT-BI Report Designer; it does not open in SSDT-BI Report 
Designer as a report within the designer. You can modify the file directly in the SSDT-BI 
Report Designer code view and save it. 

At this point you are ready to modify the report within SSDT-BI Report Designer to create a 
custom report. 

Open the Custom Report .Rdl File in SSDT-BI Report Designer 

After you create and save a custom report .rdl file from a standard report, to open the 
custom report .rdl in SSDT-BI Report Designer: 

1. Open a BI project within SSDT-BI Report Designer. 

2. Select the option to add an existing item to the project, and browse to where you saved 
the .rdl file to open it. 

Verify that the Data Source Is Set for the Query 
For custom reports that you created with a DPS standard report, you must verify that the data 
source is set for the query. 

To check the data source: 
With the custom report .rdl file open in SSDT-BI Report Designer, click the Data tab. 

If you receive the following dialog box, it means that SSDT-BI Report Designer is not able to 
connect to a valid data source for the selected dataset. You must fix the data source to point to 
the shared data source in your BI project. 

If you do not receive the message, you are ready to modify the report. 

 

To fix the data source to point to the shared data source in your BI project: 
1. In the SSDT-BI Report Designer window that indicates that the data source was not 

found, click OK. 

2. On the Data tab, click the  button next to the dataset name to open the following 
Dataset dialog box: 
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3. From the drop-down list in the Data source field, select the data source that is used 

within your BI Project. 

This generally has “(shared)” within the name. 

At this point you are ready to work on the design of the report. 

XML Code that You Must Modify 
When you start with a standard DPS report to create a custom report, you must modify some of 
the XML code in the report's .rdl file to remove and replace items that are no longer appropriate 
for your custom report. If you do not make these modifications, your custom report may not 
function properly. You must make these modifications before you use the Report Administration 
utility in DPS to upload the report into DPS.  

Report Name 
When you create a custom report from a DPS standard report, the custom report design contains 
the name of the standard report that displays on the DPS Reporting menu. 

You must replace the standard report name with the custom report name on the Layout tab in 
SSDT-BI Report Designer. 
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If you do not replace the standard report name with a custom report name, both the standard 
and custom report display on the DPS Reporting menu with the same report name. 

Custom Properties 
The XML section of a standard DPS report's .rdl file contains custom properties for reports that 
are used to: 

 Load the custom report using DPS's Report Administration utility. 

 Control DPS report options. 

You must delete and modify some of the existing custom properties that no longer apply for a 
custom report. Your custom report will not function properly if you do not make these 
modifications. 

Custom properties are defined between the <CustomProperties> and </CustomProperties> tags 
in the XML code of a report's .rdl file. You modify custom properties in a report on the Properties 
window of the report. 

1. In the Properties list, navigate to CustomProperties.  
2. Click the  ellipsis button to open the Custom Properties dialog box. 

The following sections of this guide identify the custom properties that you must delete or modify. 

ReportBO 
The ReportBO custom property is used for DPS standard reports. It is not valid for custom reports 
and must be deleted to prevent errors in DPS. 

Delete the following section of the XML code (this example uses the standard Project List report): 

<CustomProperty> 

<Name>ReportBO</Name> 

<Value>Deltek.Vision.ReportingProject.Server.ProjectList</Value> 

</CustomProperty> 

ResourceFileName 
When DPS loads the standard reports, the resource file is used to change report labels to the 
appropriate culture. Because the custom report that you are working with already has its labels 
converted to a specific culture, you must delete this ResourceFileName tag. 

Delete the following from the XML code (this example uses the standard Project List report): 

<CustomProperty> 

<Name>ResourceFileName</Name> 

<Value>Project List</Value> 

</CustomProperty> 

OptionForm 
The OptionForm custom property controls the display of the report Options dialog box in DPS 
Reporting for the custom report. If you want the report Options dialog box to display, you must 
replace the standard report's OptionForm value with the following DPS default report value: 

<Value>Deltek.Vision.Report.Client.VisionReportDialog</Value> 
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Example: 

The original XML code in the standard Project List report: 

<CustomProperty> 

<Name>OptionForm</Name> 

<Value>Deltek.Vision.ReportingProject.Client.dlgRepOpt_ProjectList</Value> 

</CustomProperty> 

 

Modify the XML code as follows: 

<CustomProperty> 

<Name>OptionForm</Name> 

<Value>Deltek.Vision.Report.Client.VisionReportDialog</Value> 

</CustomProperty> 

 

For custom reports that are created with a standard DPS report, the report Options dialog box in 
Deltek Reporting will display a General tab, a Layout tab, and if you have added report 
parameters in DPS Custom Report Options Settings, a Custom Options tab. 

GroupingType 
The GroupingType custom property controls whether or not the Sorting/Grouping tab displays on 
the report Options dialog box in DPS Reporting. For custom reports that you create from a 
standard DPS report, delete this custom property. 

Delete the following from the original XML code (this example uses the Project List report): 

<CustomProperty> 

<Name>GroupingType</Name> 

<Value>Project</Value> 

</CustomProperty> 

 

To add a Sorting/Grouping tab to the report Options dialog box, you must modify special tags in 
SQL statements. Instruction on how to do this is beyond the scope of this document.  

UseColumnSelection 
The UseColumnSelection custom property determines whether or not the Column tab displays on 
the report Options dialog box for a custom report in DPS Reporting. This tab allows you to select 
the columns for a report before you generate it. For custom reports that you create from a 
standard DPS report, change the UseColumnSelection value from Y to N. 
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Example: 

The original XML code in the Project List report, where the value is set to Y: 

<CustomProperty> 

<Name>UseColumnSelection</Name> 

<Value>Y</Value> 

</CustomProperty> 

 

Modify the original XML code as follows: 

<CustomProperty> 

<Name>UseColumnSelection</Name> 

<Value>N</Value> 

</CustomProperty> 

 

To add a Columns tab to the report Options dialog box, you must modify special tags in SQL 
statements. Instruction on how to do this is beyond the scope of this document.  

Further Instructions 
Further specific instruction on how to create and design DPS custom reports is beyond the scope 
of this document. You can contact CustomServices@Deltek.com for information about Deltek's 
assistance with custom reports. 

Upload Custom Reports into DPS 
DPS does not support the deployment of reports to the DPS report server directly from within the 
SSDT-BI Report Designer software. Instead, you use the DPS Report Administration utility to load 
reports onto the DPS report server and into DPS. For further instructions, see the “Load Custom 
Reports into DPS” section on page 18. 

mailto:CustomServices@Deltek.com
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Custom Reports for User-Defined Hubs 
Report Type Custom Property 
For any custom report that you create for a user-defined hub in DPS, you must add a report type 
custom property to the report design. This identifies the user-defined hub submenu under the 
DPS Reporting menu in which you want the custom report to display. 

You must enter the value of the report type custom property as follows:  

<Value>UDIC_<specific user-defined hub ID>_<Report name></Value> 

The specific user-defined hub is based on the singular name that you entered for the user-defined 
hub when you set up the new hub in Settings » Screen Designer. It is the singular name, 
without any spaces between words if you have multiple words in the label. You can see a user-
defined hub’s singular name on the Hub Preferences dialog box in Settings » Screen Designer 
when you select a user-defined hub and then click  Hub Preferences. The last portion of the 
database tablename that is specified on this dialog box also displays the singular name (with no 
spaces). 

If you forget to add the report type custom property to a custom report, the report will not display 
in the DPS Reporting menu. 

Example: 
You have a user-defined hub named Potential Hires. 

When you created the user-defined hub, you entered Potential Hire as singular label for the user-
defined hub (the database tablename is UDIC_PotentialHire). 

You created a custom report called Potential Hires for Sales (file name is PotentialHiresSales.rdl). 

You enter the following report type custom property for the report:  

<CustomProperty> 

<Name>ReportType</Name> 

<Value>UDIC_PotentialHire_Potential Hires-Sales</Value> 

</CustomProperty> 

After you upload this report into DPS using the Report Administration utility, the report displays in 
Reporting » Potential Hires. 

Upload Custom Reports for User-Defined Hubs 
When you upload a user-defined hub custom report into DPS using the Report Administration 
utility, you must select User Defined Hub in the Location field on the Custom Reports tab. 
The next section “Load Custom Reports into DPS” provides more information about uploading 
custom reports. 
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Load Custom Reports into DPS 
Use the Report Administration utility in DPS Utilities to upload custom reports with .rdl file 
extensions into DPS. On the Custom Reports tab in Report Administration, you upload custom 
reports from any location on a workstation into DPS. The custom reports are copied to your DPS 
report server and added to a submenu under the Reporting menu in the DPS Navigation pane in 
the desktop application. 

 

DPS does not support the deployment of reports onto your DPS report server directly from within 
the SSDT-BI Report Designer software. 

Upload Custom Reports from a Workstation into DPS 
If you have custom reports (.rdl files) saved on a workstation, follow the instructions in this section 
to upload them into DPS. During the upload process, custom reports are copied to your DPS 
report server and DPS database. They are also added to a submenu under the Reporting menu 
in the DPS Navigation pane. 

 The copy of the report file on the report server is used when the report is accessed in 
DPS by users. 

 The copy of the report file in the DPS database serves as a backup copy that you can 
download in the event that you need a copy and you cannot find the original file on your 
workstation. 

Prerequisites: You use the Custom Reports tab in the Report Administration utility to upload 
custom reports from a workstation to DPS. A system administrator must have selected the Allow 
RDL files to be uploaded in Report Administration check box on the General tab in the 
Weblink utility before the Custom Reports tab displays in the Report Administration utility. 

To upload a custom report from a workstation into DPS: 
1. From the Navigation menu in the DPS desktop application, click Utilities » Report 

Administration. 

2. On the Report Administration form, click the Custom Reports tab. 

3. On the Load Custom Reports grid toolbar, click  Upload. 

4. On the Select Custom Report File to Upload dialog box, select an .rdl file to upload and 
then click Open. 

The report file is added to a row in the Load Custom Reports grid. 

5. In the Load Custom Reports grid, click the Location field in the row for the custom report, 
and from the drop-down list, select the DPS Reporting submenu from which you want 
users to select the report. 

For custom reports for any user-defined hub, select User Defined Hub. See the previous 
section, “Custom Reports for User-Defined Hubs,” for more information about adding the 
appropriate report type custom property to custom reports for user-defined hubs before 
you upload them into DPS. 

6. In the Load Custom Reports grid, upload more custom reports as needed by repeating 
the steps above. 

If a custom report has subreports, you must add each subreport individually in the grid. 
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7. Click Save. 

The custom reports are uploaded to your report server and DPS database when you click 
Save. 

You will not see a status bar, and it may take a few minutes to upload. 

8. When the reports have finished uploading, click OK on the dialog box that tells you that 
the custom reports were uploaded. 

In the Load Custom Reports grid, the name of the report now displays in the Name field. 
The Status field displays Synchronized, meaning that the report was successfully 
uploaded from the local machine to the report server and the DPS database; matching 
copies exist on the report server and in the DPS database. 

9. Log out and log back into DPS to see the custom reports added to the submenus under 
the Reporting menu in the desktop application. 

The custom reports also display in the Report Name drop-down list in Settings » 
General » Custom Report Options where you can add parameters to them. Parameters 
are described in the “Parameters in Custom Reports” section on page 20. 

Status of a Custom Report 
The following are the possible statuses that a custom report can have in the Status field in the 
Load Custom Reports grid on the Custom Reports tab:  

 Synchronized Status: This status displays after you successfully upload a custom report 
using the Upload option on the Load Custom reports grid toolbar. It means that the 
custom report was uploaded successfully to your report server and the DPS database. 

 Missing in Report Server Status: This status means that the custom report is uploaded 
to the DPS database (as a backup copy), but it no longer exists on the report server. This 
could happen if you manually deleted the report on the report server or if you migrated to 
a new report server. Because there is a backup copy saved in the DPS database, you 
can click the Synchronize option on the Load Custom Reports grid menu to re-upload a 
copy of the backup report in the DPS database to the report server. 

 Missing in Database Status: This status means that a custom report is uploaded to the 
report server, but it does not have a backup copy saved in the DPS database. This can 
occur if you upgraded to DPS from Vision and you have previously uploaded custom 
reports to the report server in earlier Vision versions—before the custom report status 
feature was implemented in the software. In this scenario, to upload a copy of the report 
to the DPS database and change the status of the report to Synchronized: delete the 
report from your report server and upload it again using the Upload option on the Load 
Custom reports grid toolbar on the Custom Reports tab in the Report Administration utility 
in DPS.  
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Parameters in Custom Reports 
Parameters that you add to a report allow users to filter the report content before they generate 
the report. For example, you could add a parameter to a report that allows you to enter a period 
start and end date so that you can include data for only certain periods on the report. 

Parameters that you add to a custom report design in the .rdl file, display as options on the 
Custom Options tab of the report's Options dialog box in DPS Reporting if you complete both of 
the following: 

 In the custom report .rdl file, you must add the prefix "cust" to the parameter name so that 
it will work with DPS. 

The following example shows two parameters with the names custPeriodStartDate and 
custPeriodEndDate within the XML code of an .rdl file in SSDT-BI Report Designer. 

 
 After you deploy and load the custom report into DPS with DPS's Report Administration 

utility, you add the report parameters to the report in Settings » General » Custom 
Report Options in the DPS desktop application. 

To add the parameters in DPS: 
1. From the Navigation menu in the DPS desktop application, click Settings » General » 

Custom Report Options. 

2. On the Report Custom Options form, select the custom report from the Report Name 
drop-down list. 

 On the Options grid toolbar, click  Insert to add a parameter to a blank row in the 
grid. 

3. In the Option Label field, enter the text that you want to display for the parameter on the 
Custom Options tab on the Report Options dialog box in DPS Reporting. 

4. In the Parameter Name field, enter the name of the parameter as it is entered in the 
custom report .rdl file but without the prefix "cust." 

5. In the Data Type field drop-down list, select the type, such as Character, CheckBox, 
Date, and so on, that matches the data that the parameter contains. 

6. Complete the remaining fields in the grid as appropriate for your parameter data type. 

7. When you finish, click  Save. 
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To use the parameters before you generate a custom report: 
1. On the DPS Reporting menu in the desktop application, navigate to the custom report 

location. 

2. On the Report form, click the cell of the custom report's Options column to display and 

click the  icon. 

 
3. On the report Options dialog box, click the Custom Options tab to enter parameter 

options before you print or preview the report. 
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Apply Role Security to Custom Reports 
After a custom report is created and loaded into the DPS software, a DPS system administrator 
applies DPS role security to allow only the appropriate users to have access to the custom report 
on the DPS Reporting menu. 

To add a custom report to the list of reports that a role can access: 
1. From the Navigation menu in the DPS desktop application, click Settings » Security » 

Roles. 

2. In the Search field on the Roles form, enter the role for which you want to give access to 
the custom report. 

3. Open the Access Rights tab. 

4. In the Functional Area field, select Reports. 

5. In the Report Type field, select the type of report, such as Accounts Receivable, Project, 
and so on, for the custom report that you are giving access to. 

6. In the Custom Type field, select Custom. 

The custom reports for the report type display in the Available Reports pane of the tab. 

7. Click the appropriate custom report in the Available Reports pane, and click the Add 
button to add it to the Reports for this Role pane. 

8. When you finish, click  Save. 
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Get Report Information for Failed Reports 
You use the Get Report Information icon on a previewed DPS standard report to create an .rdl 
file with which to create a custom report. You can also use this tool to obtain information about 
custom reports in general or acquire information about a report if the report fails in DPS. 

If a report fails when you preview it in DPS: 
1. On the toolbar of the report preview screen, double-click the Get Report Information 

 icon. 

 
2. In the Report Information dialog box, select one of the following items in the View report 

Information field, and then click View. 

 Report Query: This returns the query that was executed by the report. Because the 
query is returned in XML format, it can be copied and pasted directly into Microsoft 
SQL Server Management Studio Query window or onto the SSDT-BI Report 
Designer Data tab where it can be executed. Since the SSDT-BI Report Designer 
Data tab and Microsoft SQL Server Management Studio do not execute XML SQL 
directly, you need to make a few edits. It does not matter if you edit the query in your 
favorite XML editor or save it to a file. 

In either case, you will see something that resembles the following when you view the 
query information: 

<Query><![CDATA[SET TRANSACTION ISOLATION LEVEL READ UNCOMMITTED … 
]]></Query> 

To run this query within Microsoft SQL Server Management Studio, you must modify 
the XML to resemble the following: 

SET TRANSACTION ISOLATION LEVEL READ UNCOMMITTED 

After you complete this modification, the query will execute without issue. 

 Report Options: This returns the options that were selected on the DPS report 
Options dialog box when the report was rendered. The options are returned in XML 
format. This XML cannot be placed within the RDL Code. 

 Report Definition (RDLFile): This provides you with the exact .rdl file that was used 
to load the report instance as it was rendered on the SSRS report server. When you 
preview this .rdl file within SSDT-BI Report Designer, it looks exactly like the one in 
the DPS Reporting preview window. 
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SkipProcessing Custom Property 
You can set the SkipProcessing table-level custom property to Y to have the DPS framework 
bypass the processing of a tablix data region of a report at runtime. The tablix data region will 
display what you see in the report design. This custom property applies to reports that are 
created with SSDT-BI Report Designer. It can be helpful for troubleshooting problems with 
previewing reports. 
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Appendix A: Custom Reports and Migrating from 
Vision to DPS On-Premise 
This information applies if you are migrating from the Deltek Vision product to the Deltek DPS on-
premise product and you have custom reports that were created with Microsoft SQL Server 
Reporting Services 2005 or 2008. This information also applies for upgrading Vision custom 
reports that you use to generate custom invoices in DPS. 

RDL 2005 and RDL 2008 Schema Are Not Supported in DPS 
Custom reports that you created with Microsoft SQL Server Reporting Services 2005 or Microsoft 
SQL Server Reporting Services 2008 have RDL 2005 and RDL 2008 schema are not supported 
in DPS. You must upgrade these custom reports to change the schema to RDL 2010 before you 
can use them in DPS. You must use SSDT-BI 2013 Report Designer, Report Builder 3.0, or the 
DPS Report Administration utility to upgrade the reports to the supported RDL 2010 schema. See 
the sections below for instruction. 

Upgrading from Vision Versions Earlier than 7.0 
If you are upgrading to DPS on-premise from a Vision version earlier than 7.0:  After you upgrade 
the reports, you must update report queries to revise any database table names that were 
changed in Vision 7.0. Database table names that were changed are identified in the “Vision 7.0 
Database Table Name Changes that Affect Custom Reports” section below. 

If a Custom Report Does Not Work Properly 
Other DPS framework changes that are applied within the report business objects may affect your 
custom reports after you migrate to DPS, causing them to not work properly. If a custom report 
does not work properly after you upgrade and update any renamed database tables, Deltek 
recommends that you recreate the custom report using DPS and SSDT-BI 2013 Report Designer 
or Report Builder 3.0. 

Before You Create a Custom Report 
Before you recreate a custom report with SSDT-BI 2013 Report Designer or Report Builder 3.0, 
consider the following questions: 

 Do you still need the custom report? 

 Are there standard reports in DPS that provide the information that you need? 

 Is the custom report that you created with BIDS 2005, BIDS 2008, or Report Builder 
versions 1.0 or 2.0 based on a DPS standard report? If so, you can start with a standard 
DPS report and modify it in SSDT-BI 2013 Report Designer or Report Builder 3.0 to 
recreate your custom report. 

 

If you need additional assistance with custom reports, contact Deltek Global Services. 

For detailed information and training on how to design a DPS report with Report Designer or 
Report Builder, Deltek University offers report writing classes. 

For class offerings, see http://www.deltek.com/services/deltekuniversity. 

http://www.deltek.com/services/deltekuniversity/
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Upgrade Custom Reports Using SSDT-BI 2013 Report Designer 
These instructions apply for Vision custom reports that you created with BIDS 2005 or BIDS 2008 
that need to be upgraded to the RDL 2010 schema. For these upgrade instructions, you start by 
opening or creating a report project (instead of opening the report RDL files). 

Custom Reports that Already Have a Report Project 
If a custom report already has a reporting project, use the following instructions to upgrade the 
report. 

To upgrade Vision custom reports using SSDT-BI Report Designer to be compatible with 
DPS: 

1. Use Report Designer to open an existing Vision custom report project. 

2. Complete the wizard that starts automatically. It guides you through upgrading the report 
project. 

3. Open a custom report in Report Designer. 

4. The following applies if you are upgrading to DPS from a Vision 6.x version: For any 
Vision database tables included in the report that have new names in DPS, replace the 
old names with the new names. 

The affected tables and instructions are included in the “Vision 7.0 Database Table Name 
Changes that Affect Custom Reports” section of this guide. 

5. Review the database changes for DPS and update your custom reports as needed. 

You can access the DPS Data Dictionary in the DPS online help by clicking the ? help 
icon. In the help Contents pane, scroll to the bottom of the contents and click Data 
Dictionary. The data dictionary is also available from the Deltek Support Center website. 

6. In the Report Property pane, enter a dummy value in InitialPageName property. 

7. Save the report. 

8. Remove the dummy value in the InitialPageName property and save the report again. 

9. Repeat step 3–8 for each custom report in the report project. 

10. Upload the custom reports to DPS using the DPS Report Administration utility, as 
described in the “Load Custom Reports into DPS” section. 

If a report does not run properly, you may need to recreate it with SSDT-BI Report 
Designer. 

Custom Reports that Do Not Have a Reporting Project 
If a custom report does not have a reporting project, you create a reporting project before you 
upgrade the report. 

To create a reporting project and upgrade Vision custom reports to be compatible with 
DPS using SSDT-BI Report Designer: 

1. Open SQL Server Data Tools for Visual Studio 2013. 

2. On the File menu, click New » Project. 
3. In the Project types pane of the New Project dialog box, select Business Intelligence 

Projects. 

4. In the Templates pane, select Report Server Project. 
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5. In the Name field, enter a name for the report project. 

Enter a name that is related to the type of reports that you will add to this project. For 
example, for billing reports, you could name the project “Billing.” 

6. In the Location field, enter the location where the reports will be stored. 

Deltek recommends that you store reports in <your DPS installation 
path>\Reports\Custom. 

Example: c:\Program Files (x86)\Deltek\DPS\Reports\Custom 

7. On the New Project dialog box, click OK. 

8. Add the RDL file for existing custom reports to the report project: 

a) In the Solution Explorer pane, right-click the Reports folder, and click Add » Existing 
Item. 

b) On the Add Existing Item dialog box, navigate to an existing RDL file to add it to the 
report project. 

c) Modify the InitialPageName property of the report and add a dummy value. 

d) Save the report file. 

When you save it, the schema of the RDL file is changed from RDL 2005 or RDL 
2008 to RDL 2010. 

e) Remove the dummy value in InitialPageName property and save the report again. 

f) Repeat these steps to add RDL files for other custom reports to the report project. 

9. Open a custom report in Report Designer. 

10. For any Vision database tables included in the report that have new names in DPS, 
replace the old names with the new names. 

This applies if you are upgrading to DPS from a 6.x version. The affected tables and 
instructions are included in the “Vision 7.0 Database Table Name Changes that Affect 
Custom Reports” section of this guide. 
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11. Save the report. 

12. Repeat step 9 and 10 for each custom report. 

13. Upload the reports to DPS using the DPS Report Administration utility as described in the 
“Load Custom Reports into DPS” section of this guide. 

If a report does not run properly, you may need to recreate it with SSDT-BI Report 
Designer. 

Upgrade Custom Reports Using Report Builder 3.0 
These instructions apply for Vision custom reports that you created with Report Builder version 
1.0 or 2.0. With these instructions, you can update a report’s RDL file directly. 

To upgrade Vision custom reports to the RDL 2010 schema using Report Builder 3.0: 
1. Use Report Builder 3.0 to open a custom report RDL file. 

2. Save the report file. 

Saving the file changes the schema from RDL 2008 or RDL 2005 to RDL 2010. 

3. In Report Builder 3.0, for any Vision database tables included in the report that have new 
names in DPS, replace the old names with the new names. 

This applies if you are upgrading to DPS from a Vision 6.x version. The affected tables 
and instructions are included in the “Vision 7.0 Database Table Name Changes that 
Affect Custom Reports” section of this guide. 

4. Save the report. 

5. Upload the report to DPS using the DPS Report Administration utility as described in the 
“Load Custom Reports into DPS” section of this guide. 

If a report does not run properly, you may need to recreate it with Report Builder 3.0. 

Upgrade Custom Reports Saved in the Vision Database Using 
Report Administrator 
Use these instructions to upgrade custom reports that are already saved in your Vision database, 
with the RDL 2008 schema, to the RDL 2010 schema that DPS supports. 

 

These instructions apply only if the custom reports in your Vision database have the RDL 2008 
schema. You must use SSDT-BI 2013 Report Designer or Report Builder 3.0 to upgrade reports 
with the RDL 2005 schema. 

This upgrade process opens all your custom reports, and for each report it upgrades the report 
schema, resaves the report in the DPS database, and uploads the report to the DPS report 
server. 

To upgrade custom reports that are saved in your Vision database with the RDL 2008 
schema to the RDL 2010 schema: 

1. In the DPS Navigation pane, select Utilities » Report Administration. 

2. On the Report Server form, click the Custom Reports tab. 
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3. On the Custom Reports tab, click the Upgrade option on the toolbar of the Load Custom 

Reports grid. 

 The Upgrade option displays on the grid toolbar only if you have a saved custom 
report in the Vision database. 

 If all your existing custom reports already use the latest RDL 2010 schema, you 
receive the following message: "All existing custom reports stored in your database 
are already using the latest schema." 

4. Click Yes on the dialog box that says: "This will upgrade all existing custom reports 
currently stored in your database to the latest schema. Would you like to continue?" 

 The upgrade starts. 

 During the upgrade, Vision backs up the custom reports that are saved in the Vision 
application server’s Report\Backup folder. 

 When the upgrade finishes, you receive the following message: "All custom reports 
have been successfully upgraded to the latest schema." 

5. After the upgrade finishes, check the RDLProcessing.log log file that is saved in the 
Vision application server's Report\Backup\<database name> folder.  

The file contains the status for each processed RDL file and will identify any errors. 

Upgrade Custom Reports Saved Locally Using Report 
Administrator 
Use these instructions to upgrade Vison custom reports that are saved on a local machine with 
the RDL 2008 schema to the RDL 2010 schema that DPS supports. These instructions apply for 
custom reports have not been saved in the Vision database. This process is useful if you are 
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currently working on or developing custom reports that are still in the old schema and the reports 
have not been uploaded to the Vision database yet. 

 

 

These instructions apply only if the custom reports on a local machine have the RDL 2008 
schema. You must use SSDT-BI 2013 Report Designer or Report Builder 3.0 to upgrade reports 
with the RDL 2005 schema. 

To upgrade custom reports on a local machine with the RDL 2008 schema to the RDL 2010 
schema: 

1. From the DPS Navigation menu, select Utilities » Report Administration. 

2. On the Report Server form, click the Custom Reports tab. 

 
3. In the Apply Schema Update to Custom Report File section, click the Select Folder 

button. 

4. In the Browse for Folder dialog box, scroll to and select the folder in which the custom 
reports are located, and click OK to close the dialog box. 

5. Click the Apply button to update the reports. 

6. Review the RDLProccessing.log log file that is saved in the folder where the custom 
reports are located. 

The file contains the status for each processed RDL file and will identify any errors. 
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Vision 7.0 Database Table Name Changes that Affect Custom 
Reports 
Vision database tables used in reports that had a name change in Vision 7.0 are listed below. If 
you are upgrading to DPS on-premise from a Vision version that is earlier than 7.0, then after you 
upgrade your custom reports, you must replace the old table names with the new names in report 
queries that include the affected tables. For example, if a custom report included the CFGCountry 
table, you must replace CFGCountry with FW_CFGCountry.  

If you do not update the table names, you will receive errors when you run the reports. 

Vision 7.0 Table Name Changes that Affect Custom Reports 

Table Name in Vision 6.x Table Name in Vision 7.0 and Later 

CFGCountry FW_CFGCountry 

CFGCurrency FW_CFGCurrency 

CFGPhoneFormat FW_CFGPhoneFormat 

CFGEnabledCurrencies FW_CFGEnabledCurrencies 

InfoCenterTabHeadings FW_InfoCenterTabHeadings 

ReportPrinters FW_ReportPrinters 

To change a table name in either Report Designer or Report Builder: 
1. Open the report in either of the reporting tools. 

2. On the Report Data pane, expand the Datasets folder. 

3. Double-click ReportDataset. 

 
4. In the Query text box in the Dataset Properties window, find mention of the old table 

name, and replace it with the new table name.  
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To quickly determine whether the query contains an affected table, you can copy the 
contents from the Query text box into a word processor. Then use Find in the word 
processor to search for the table name. 

 
5. Click OK. 

If you receive the following message, click OK. You do not need to refresh the field list; 
you are updating the table name only. 

 

Custom Invoices Created with Microsoft SQL Server Reporting 
Services 2005 and 2008 
Vision custom invoices are basically reports. Follow the instructions in the previous sections for 
upgrading custom invoices that were created with Microsoft SQL Server Reporting Services 2005 
or 2008. When you upgrade them, the RDL 2005 or RDL 2008 schema of the report will be 
upgraded to RDL 2010. 
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After you upgrade custom reports to the RDL 2010 schema, review your custom invoice reports 
and their custom templates to make sure everything is working properly. 
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