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change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are reserved. No 
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mechanical, or translated into another language, without the prior written consent of Deltek, Inc. 
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Deltek’s software is also protected by copyright law and constitutes valuable confidential and proprietary 
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Overview 
The Cobra 8.3 Cumulative Update 06 release includes all of the enhancements, software issues resolved, 
and database changes that were made in Cobra 8.3 CU 01 through CU 06. 

Custom Programs Affected 
Sometimes an update can cause custom programs and reports to stop working as expected. Before 
applying this update, consider whether you have any custom programs or reports in the application area 
affected by the update. If so, contact Deltek Customer Care at http://support.deltek.com before you install 
the update. 

 

Viewing the Online Help 
If you use Internet Explorer and the online help does not display correctly, you need to turn off 
Compatibility View for the browser. Click Tools » Compatibility View settings, and clear the Display 
intranet sites in Compatibility View check box. Then refresh the browser. Make sure you remove 
deltek.com (if listed) from the Websites you have added to Compatibility View list. You could also elect 
to use hosted help or the FQDN of your server in the URL (for example, server.domain) to bypass this 
issue. Depending on your Internet Explorer security settings, you may be prompted to “Allow blocked 
content” when viewing the online help locally. The Cobra 8.3 Help System URL is 
https://help.deltek.com/Product/Cobra/8.3/GA. 

Depending on your Internet Explorer security settings, you may be prompted to “Allow blocked content” 
when viewing the Cobra Online Help locally. This only affects Internet Explorer.  

You may also access the online help using Chrome and Firefox. 

Attention: For steps to install the cumulative update, see Appendix A: Download and Install the 
Cumulative Update. 

http://support.deltek.com/
https://help.deltek.com/Product/Cobra/8.3/GA
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Cobra 8.3 Cumulative Update 06 
Released: April 30, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

Integration Wizard » Project Data 
Defect 1286665 

Description: When you ran the Integration wizard to load an import file with new or existing control 
accounts and work packages structures and selected the Delete Control Accounts and Work 
Packages no longer in the schedule option on the Change Control page, Cobra would not run the 
Update Total process on EAC during integration if you were not loading resource assignments. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Security 
Defect 1286823 

Description: When you ran Cobra in a Terminal Service or Citrix environment and your Cobra session 
did not close properly, you might encounter orphaned locks or sessions. 

Customers Impacted: This defect affects users who run Cobra in a Terminal Services or Citrix 
environment. 

Workaround Before Fix: Perform one of the following: 

 Delete the lock records manually in the database. 

 Clear the crashed connection using the EPM Security Administrator tool. 

1. Log into the EPMSA tool. 

2. In the Explorer pane on the left, click Cobra. 

3. Click Tools » Clear Connections. 

4. On the Clear Connections dialog box, select the crashed connection and click Clear 
User. 
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Additional Notes: This issue may happen when a user leaves their Terminal Service or Citrix session 
idle and it times out, or when an active user closes their Terminal Service or Citrix window instead of the 
Cobra window. In some cases, this issue may also happen when Cobra terminates unexpectedly. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 EPM.Security.Authentication.dll 

Tools » Update Totals 
Defect 1284093 

Description: When you ran the Integration wizard to load an import file with new or existing control 
accounts and work packages structures, Cobra would run the Update Total process on budget classes 
during integration even if you were not loading resource assignments but you selected Forecast 
(Start/Finish) Date on the Import File Field Mapper page. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Cobra 8.3 Cumulative Update 05 
Released: April 16, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Cost Data Export 
Defect 1279430 

Description: When you ran the Cost Data wizard against a large project with many Control Account and 
Work Package code fields with a code field type of User Field, and generated the Deltek Cost Data 
Exchange (DCDE) file or the Integrated Program Management Data Analysis Report (IPMDAR) file, 
Cobra would crash with a "System.OutofMemoryException" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

File » Integration Wizard — Project Data 
Defect 1279341 

Description: When you ran the Integration wizard to load control accounts from multiple projects without 
loading against a master project, Cobra would display a warning message that the control account was 
locked by another user even though they were not locked. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: This issue was encountered after implementing the Cobra 8.3 CU04 Enhancement: 
Load an Import File with Data from Multiple Projects and the data lock setting was set to Control 
Account. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 
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Defect 1279995 

Description: When you ran the Integration wizard to load records from multiple projects without loading 
against a master project, the process log would display the total cumulative number of records that were 
added, updated, and deleted instead of displaying the total number of added, updated, and deleted 
records for each project separately. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1280954 

Description: When you ran the Integration wizard to load code assignments and the data locking was set 
to control account level, Cobra would update the code values for a control account locked by another user 
instead of displaying a warning message. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1282514 

Description: When you ran the Integration wizard to load resource assignment codes using a single 
activity and resource assignment file, Cobra would encounter the "[Error] File is in use" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: This defect was introduced in Cobra 8.3 CU04 Enhancement: Load an Import File with 
Data from Multiple Projects. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 
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Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation.  

Document Details 

Cobra 8.3 Help System  Updated the description of the following options in the 
Change Control Page of the Integration Wizard topic: 

 Delete items from Cobra that are no longer in the 
schedule  

 Delete Control Accounts and Work Packages no 
longer in the schedule  

 Delete milestones no longer in the schedule  

 Delete resource assignments no longer in the 
schedule  

 Delete only resources with the default or selected 
class  

 Delete only items that match the following criteria  

 Deletion Criteria  

 List deleted items in the process log 

https://help.deltek.com/Product/Cobra/8.3/GA/Change%20Control%20Page%20of%20the%20Integration%20Wizard%20Scheduling%20Tools.html
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Cobra 8.3 Cumulative Update 04 
Released: April 06, 2020 

Enhancements 

Load an Import File with Data from Multiple Projects 
Cobra allows you to load an import file (status file, activity file, resource assignment file, or a single file 
with both activity and resource assignment data) which contains data from multiple projects without 
loading against a master project. With this feature, you do not need to break out an import file for each 
project and run the Integration wizard separately for each project. 

Here is an example of an import file with data from multiple projects. 

 

To support this feature, the following changes were made to the Integration wizard when integrating 
import files. 

The Defined in File check box is added to the Project Selection page. 

 

This check box displays only when you select any of the following options on the Action Selection page: 
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 Control Accounts and Work Packages 

 Code Assignments and User Fields 

 Resource Assignments 

 Status 

When the Defined in File check box is selected, the Cobra Project field is changed to the Use field 
mapping from Project field. Cobra uses the specified file to populate the lookup dialog boxes in the 
wizard and define the number of key fields expected in the field mapper. Otherwise, Cobra displays an 
error in the log. 

 

 

Attention: See the Project Selection Page of the Integration Wizard — Files and Import File with 
Data from Multiple Projects topics in the Cobra Help System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Project%20Selection%20Page%20of%20the%20Integration%20Wizard%20Text%20Files.html
https://help.deltek.com/Product/Cobra/8.3/GA/Import%20File%20with%20Data%20from%20Multiple%20Projects.html
https://help.deltek.com/Product/Cobra/8.3/GA/Import%20File%20with%20Data%20from%20Multiple%20Projects.html
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When you define the fields on the Import File Field Mapper page, make sure to select Project. 

 

All selections on the other pages of the Integration wizard apply to all projects included in the import file. 

 

You must have access to projects included in the import file. Otherwise, the integration skips the project 
with an error. Cobra captures the changes for each project separately in a single process log associated 
with the default project used for mapping. For baseline changes, Cobra captures them with a separate 
transaction ID in the audit log for each project. 

Delete Milestones that are No Longer in the Schedule 
The Delete milestones no longer in the schedule check box is added to the Change Control page of 
the Integration wizard to support deleting of existing milestones no longer found in the schedule.  

Attention: See the Import File Field Mapper Page of the Integration Wizard topic in the Cobra Help 
System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Import%20File%20Field%20Mapper%20Page%20of%20the%20Integration%20Wizard.html
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Software Issues Resolved 

File » Integration Wizard — Project Data 
Defect 1273099 

Description: When you ran the Integration wizard and loaded an existing configuration, the Lookup 
dialog box on the following pages were empty: 

 Load only these budget classes or Load only these forecast classes field on the Resource 
Assignment page 

 Selection field on the Filter page 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.Process.dll 

 Cobra.WinUI.exe 

 Cobra.WinUI.*.dll 

 

Attention: For more information, see the Change Control Page of the Integration Wizard topic in the 
Cobra Help System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Change%20Control%20Page%20of%20the%20Integration%20Wizard%20Scheduling%20Tools.html
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Defect 1273100 

Description: When you ran the Integration wizard and loaded a configuration whose CAM field was set 
to Code (optional), Cobra would not update the CAM value during integration. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Set the CAM field to None before import. Change the value to Optional after 
import. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1273108 

Description: When you ran the Integration wizard and loaded status file with the activity and resource 
files into a project, Cobra would display the "[Error]Field name not found: 'PROJECT'" error in the log. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Load only the status file or the activity and resource file only. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1246387 

Description: When you ran the Integration wizard and connected to a Primavera database with millions 
of user defined field value records, the Lookup dialog boxes in the wizard would take a long time to 
appear. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 
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Defect 1273030 

Description: When you ran the Integration wizard to load schedule data from Primavera, the Schedule 
Field Lookup dialog box on the Schedule Mapping page was empty if there were more than 120 code 
fields. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. 

Document Details 

Cobra 8.3 Help System  Created and updated the following topics for the 
“Load an Import File with Data from Multiple Projects” 
enhancement:  

 Import File Field Mapper Page of the Integration 
Wizard 

 Project Selection Page of the Integration Wizard 
— Files 

 Import File with Data from Multiple Projects 

 Updated the Change Control Page of the Integration 
Wizard topic for the “Delete Milestones that are No 
Longer in the Schedule” enhancement. 
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Cobra 8.3 Cumulative Update 03 
Released: March 31, 2020 

Enhancements 

Renamed the IPMDR Format 
The Integrated Program Management Data Analysis Report (IPMDR), a required government contractor-
reporting format, is renamed to Integrated Program Management Data Analysis Report or IPMDAR. This 
revision impacts the following areas of the Cost Data wizard 

 Project and Format page: The option is updated to IPMDAR —Contract Performance Format. 

 

 Save and Run page: On the Save As dialog box, IPMDR is renamed to “IPMDAR Export 
File(*.zip)” in Save as type. 

 

 

Attention: See the Documentation Changes for the list of updated help topics. 
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Support for the Copy baseline dates to forecast dates option of the 
Reclass Wizard in API and Web Services 
The Copy baseline dates to forecast dates option on the Date Range page of the Reclass wizard is 
now supported in the Reclass API process and Web services through the 
CopyBaselineDatesToForecastDates setting. If value is set to 1, Cobra copies the baseline dates to the 
forecast dates if the following conditions are met: 

 SourceClass is set to a Budget class. 

 TargetClass is set to a Forecast class. 

 Scope is set to All. 

 Criteria is not set to Resource Assignment or Resource. 

Otherwise, Cobra automatically sets the value to 0. 

 

Software Issues Resolved 

API 
Defect 1271064  

Description: When you ran the Reclass process through the API and specified a Control Account Code 
or Work Package Code in the Criteria setting, the Reclass process would fail with the "The method or 
operation is not implemented" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Run the Reclass process using the Reclass wizard. 

Additional Notes: None. 

Files Updated: 

 Cobra.Api.exe 

 Cobra.Model.LoginManager.dll 

 Cobra.Model.dll 

Calendars » Calendar View 
Defect 1262371 

Description: When you moved the TODATE and ATCOMPLETE flags for Calendar Set 18 in the 
Calendar view and selected Yes on "Calendar sets 18 and 19 do not have labels PREVIOUS, TODATE, 
and ATCOMPLETE on the same periods. Do you want to align 19 with 18?" prompt, Cobra would not 
align the ATCOMPLETE flag for Calendar Sets 18 and 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Manually update the ATCOMPLETE flag for Calendar Set 19 to match the flag 
for Calendar Set 18. 

Additional Notes: None. 

Attention: See the Reclass Process topic in the Cobra Help System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Reclass%20Process.html


Cobra 8.3 Cumulative Update 03 

Cumulative Update 06 Release Notes 15 

 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 

Defect 1269024  

Description: When you moved the TODATE flag of a calendar set that was not Calendar Set 18 or 19 
and saved the changes in the Calendar view, Cobra would display the prompt to align Calendar Sets 18 
and 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: Cobra should only display the prompt when you move the TODATE flag for Calendar 
Set 18 or 19. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 

Defect 1269025  

Description: When you moved the ATCOMPLETE flag in the Calendar view for Calendar Set 18 or 19 
and saved the changes, Cobra did not display the prompt to align Calendar Sets 18 and 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 

Defect 1269683  

Description: When you moved the PREVIOUS, TODATE, or ATCOMPLETE flags in the Calendar view 
for Calendar Set 19 and saved the changes, Cobra displayed the following prompt to align the required  
flags for Calendar Set 19 and 18: "Calendar sets 18 and 19 do not have labels PREVIOUS, TODATE, 
and ATCOMPLETE on the same periods. Do you want to align 19 with 18?" when it should be aligning 
Calendar Set 18 with 19. 

Customers Impacted: This defect affects all users. 
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Workaround Before Fix: None. 

Additional Notes: When editing either Calendar Set 18 or 19 and moving the PREVIOUS, TODATE, or 
ATCOMPLETE flags to different a calendar period, Cobra now displays the following prompt: "Calendar 
sets 18 and 19 do not have labels PREVIOUS, TODATE, and ATCOMPLETE on the same periods.  
Calendar sets 18 and 19 do not have labels PREVIOUS, TODATE, and ATCOMPLETE on the same 
periods. Do you want to align 18 and 19?” 

Files Updated: 

 Cobra.Resources.dll 

Documentation 
Defect 1257985 

Description: Information about the OLE database drivers used by the backup/restore and export/import 
features was not documented in the Cobra Installation Guide. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: A note is added to the Software Requirements — Database Driver section of the 
Cobra Installation Guide. 

Files Updated: 

 DeltekCobra83InstallationGuide.pdf 

File » Integration wInsight 
Defect 970578  

Description: When you ran the wInsight Export process, Cobra would not export the actuals if: 

 The project used 3 control account structures. 

 The Code for Control Account level actual costs option was enabled and the costs were captured 
at the control account level but export structure was exported down to the work package level. 

 The project contained several CA entries where CA1 was the same, but CA3 was different (for 
example: CA1/CA2/CA3: 1.1.1.1/1000/1111, 1.1.1.1/1000/2222). 

 The first CA (for example, 1.1.1.1/1000/1111) did not have resource assignments at the control 
account level but at the work package level (for example: 1.1.1.1/1000/1111 WP01). 

 There were actuals at the control account level on any of the other control accounts (for example: 
1.1.1.1/1000/2222).   

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll  

 Cobra.WinUI.exe  

 Cobra.Process.dll 
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File » Integration Wizard — Project Data 
Defect 1238172  

Description: When you ran the Integration wizard to load status from Microsoft Project, Cobra would 
encounter the "Variable 'WORKBAC' is not found" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1262366  

Description: When you ran the Integration wizard to load resource assignments from an import file and 
selected to load forecast dates, Cobra would calculate the EAC total even if the forecast class of the 
imported records were not part of the EAC cost set. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Calculate Forecast 
Defect 1256206  

Description: When you ran the Calculate Forecast process, Cobra incorrectly calculated the forecast if 
any of the following conditions were met: 

 The forecast performance factor level was set to control account or work package. 

 The expression of the prior CA/WP (separated by a slash) was not less than or equal to the 
expression of the CA/WP being processed. For example, "1.1.1.2/1000/ /01" is not less than 
"1.1.1.2.1/1000/ /02". 

 The CA/WP being processed contained earned while the prior CA/WP did not contain earned but 
contained budget and/or actuals resource assignments. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 
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 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Replan 
Defect 1255333  

Description: When you ran the Replan wizard and selected the Create a new Work Package for the 
replanned Budget/Progress/Actuals option on the Options page, Cobra would not move the baseline 
budget to the replanned work package. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll  

 Cobra.WinUI.exe  

 Cobra.Process.dll 

Reports » Reports 
Defect 1271652 

Description: When you generated the 1921-1 report, Cobra would create an incorrect formula for the 
"C.TOTAL" value. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Edit the 1921-1.xlsx report template and change the formula from {=Cell[R,C-
3]+Cell[R,C-2]} to {=Cell[R,C-3]+Cell[R,C-1]}. 

Additional Notes: None. 

Files Updated: 

 ReportTemplates\1921-1.xlsx 

 

Defect 1259993 

Description: When you generated the 1921-1 report and a Functional Data Element only contained 
"Recurring" costs, Cobra would display the costs in the "NonRecurring" column of the generated report. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 
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 Cobra.Model.LoginManager.dll 

 Cobra.ReportLayoutEngine.dll 

Tools » Preferences 
Defect 1251389  

Description: When you selected the Include SQL Statements check box for Clientdebuglog.xml on the 
Data Access tab of the Application Preferences dialog box, saved your changes, and then relaunched 
Cobra, the option was no longer selected. The same problem occurred if the option was already checked 
and then you cleared it. 

Customers Impacted: This defect affects users who run Cobra on a client/server and standalone 
deployments. 

Workaround Before Fix: Modify the IdeaBlade.ibconfig file manually to enable the logging of SQL 
statements. See the Edit IdeaBlade.ibconfig file help topic for more information. 

Additional Notes: For standalone or client/server deployment, this option is now saved in the 
IdeaBlade.ibconfig file used by Cobra. In case Cobra fails to save this option, see the Troubleshoot 
Issues with Saving to the IdeaBlade.ibconfig File in Cobra help topic for more information. 

For n-tier deployment, the behavior of this option has not changed. The selected option will apply to all 
clients of the n-tier server until the n-tier server service is restarted. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.Resources.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 ConfigManager.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. 

Document Details 

Cobra 8.3 Help System  Updated the following help topics for the “Renamed 
the IPMDR Format” enhancements: 

 Cost Data Export 

https://help.deltek.com/Product/Cobra/8.3/GA/Edit%20IdeaBladeibconfig%20File.html
https://help.deltek.com/Product/Cobra/8.3/GA/Troubleshoot%20Issues%20with%20Saving%20to%20the%20IdeaBlade.ibconfig%20File%20in%20Cobra.html
https://help.deltek.com/Product/Cobra/8.3/GA/Troubleshoot%20Issues%20with%20Saving%20to%20the%20IdeaBlade.ibconfig%20File%20in%20Cobra.html
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Document Details 

 Cost Data Wizard 

 Project and Format Page of the Cost Data 
Wizard 

 Codes and Structures Page of the Cost Data 
Wizard 

 Data Options Page of the Cost Data Wizard 

 Save and Run Page of the Cost Data Wizard 

 Export Cost Data 

 Exported Cost Data File 

 Display the Cost Data Wizard 

 General Tab of the Project Properties Dialog Box 

 Contract Information Tab of the Project 
Properties Dialog Box 

 Updated the Reclass Process topic for the “Support 
for the Copy baseline dates to forecast dates option 
of the Reclass Wizard in API and Web Services” 
enhancement. 

 Created the following topics for Defect 1251389: 

 Troubleshoot Issues with Saving to the 
IdeaBlade.ibconfig File in Cobra 

 Clear the Read-only Flag in the 
IdeaBlade.ibconfig File 

 Run Cobra Using a Different IdeaBlade.ibconfig 
File 
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Cobra 8.3 Cumulative Update 02 
Released: February 28, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Cost Data Export 
Defect 1254685 

Description: When you ran the Cost Data Export wizard to generate the Integrated Program 
Management Data Report (IPMDR) file with the Detail data contains options cleared and the Selected 
burdens are NonAdd options selected on the Data Options page, the Summary Performance file of the 
generated JavaScript Object Notation (JSON) files contained duplicate values. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 PPM.CostData.dll 

File » Integration Wizard – Project Data 
Defect 1254659 

Description: When you ran the Integration wizard to load status data from a master project, Cobra would 
encounter the "Could not find Control Account" message. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 
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Installation 
Defect 1241428  

Description: The Database Upgrade wizard would always look for the C:\Program Files 
(x86)\Deltek\Cobra path even if Cobra was installed in an alternate folder other than the C:\ folder. 

Customers Impacted: This defect affects users who install Cobra on a different drive or path other than 
the default installation directory. 

Workaround Before Fix: Copy the Config.dat and DATASOURCES.DAT files to the C:\Program Files 
(x86)\Deltek\<Cobra path>. 

Additional Notes: You may also perform any of these workaround: 

Option 1: Launch the Cobra Database Upgrade wizard using the /configfolder parameter.  

1. Click Start » All Programs » Accessories, right-click the Command Prompt, and select 
Run as administrator. 

2. On the Administrator Command Prompt window, enter the command using the following 
syntax: "<Cobra Installation 
Location>\Support\Utilities\DeltekCobra8xDatabaseUpgradeWizard.exe" 
/configfolder:<Target folder> 

For example: “E:\Program Files 
(x86)\Deltek\Cobra\Support\Utilities\DeltekCobra83DatabaseUpgradeWizard.exe” 
/configfolder:E:\Program Files (x86)\Deltek\Cobra 

 

Option 2: Add a configuration registry option. 

1. Create the following entries in the configuration registry: 
HKEY_CURRENT_USER\Software\Deltek\Cobra\8.3 

2. Create a ProgramFolder String Value with the value set to the location of the Config.dat 
or IdeaBlade.Ibconfig file; for example: "E:\Program Files (x86)\Deltek\Cobra". 

Files Updated: 

 DeltekCobra83DatabaseUpgradeWizard.exe 

Project Processes 
Defect 1247603  

Description: When you ran a process and Cobra logged a warning or error message, Cobra would crash 
instead of displaying the untranslated string ID if the resource ID was not found. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

Note: Use quotes around the location of the exe.file. Do not use quotes around the target folder. See 
the “Run Cobra with Command Line Parameters” topic in the Cobra Help System for more 
information. 

https://help.deltek.com/Product/Cobra/8.3/GA/Run%20Cobra%20with%20Command%20Line%20Parameters_3.html
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 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Cobra 8.3 Cumulative Update 01 
Released: January 31, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Cost Data Export 
Defect 1237415 

Description: When you ran the Cost Data wizard against a large project to generate the Deltek Costa 
Data Exchange (DCDE) file, Cobra would crash with a "System.OutofMemoryException" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 PPM.CostData.dll 

File » Integration Wizard — Project Data 
Defect 1194236  

Description: When you initialized a shared database between Open Plan 8.3 and Cobra 8.3 using the 
Open Plan 8.3 Data Tool, the following error occurred: “Unable to insert data into target table WST_UPF." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.3 on an Oracle or a 
SQL database. 

Workaround Before Fix: None. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.3 Cumulative Update # 04 Defect 
1222654. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 
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Defect 1225665  

Description: When you initialized a shared database between Open Plan 8.2 and Cobra 8.3 using the 
Open Plan 8.2 Data Tool, the following error occurred: “Unable to insert data into target table WST_UPF." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.2 on an Oracle or a 
SQL database. 

Workaround Before Fix: None. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.2 Cumulative Update # 13 Defect 
1225706. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

 

Defect 1225668  

Description: When you initialized a shared database between Open Plan 8.3 and Cobra 8.3 using the 
Open Plan 8.3 Data Tool, the following error occurred: “Unable to insert data into target table WST_DCT." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.3 on a SQL 
database. 

Workaround Before Fix: Re-initialize the Open Plan Data Tool. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.3 Cumulative Update # 04 Defect 
1222654. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

 

Defect 1225670  

Description: When you initialized a shared database between Open Plan 8.2 and Cobra 8.3 using the 
Open Plan 8.2 Data Tool, the following error occurred: "Unable to insert data into target table WST_DCT." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.2 on a SQL 
database. 

Workaround Before Fix: Re-initialize the Open Plan Data Tool. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.2 Cumulative Update # 13 Defect 
1225706. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

Help 
Defect 1237371 
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Description: When you accessed the Cobra Help locally, opened the Data Dictionary topic, and clicked 
the Data Dictionary link, you would encounter the following error: "Cannot find file... Make sure the path or 
internet address is correct."  

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Access the Data Dictionary using the hosted help. 

URL: https://help.deltek.com/Product/Cobra/8.3/GA/DataDictionary/index.htm 

Additional Notes: None. 

Files Updated: 

 DeltekCobra83.exe 

Projects » Project View 
Defect 1179645 

Description: When you modified a control account in the project view and then moved to another control 
account, Cobra would not save the changes automatically if the project audit log was turned on and the 
log level was set to work package or resource assignment. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: Cobra should save the changes automatically after you modify a control account and 
move to another one whether the audit log is enabled or disabled at any level. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

Projects » Calculate Forecast 
Defect 1225384 

Description: When you ran the Calculate Forecast wizard against a forecast class that did not exist as a 
resource assignment, Cobra would create the forecast time-phased data but would not create the 
resource assignment if any of the following conditions applied: 

 The class was the last forecast class processed for each control account or work package. 

 Closed control account or work packages 

 ETC value was 0. 

 Forecast method was Manual Forecast (Retain EAC), actual total was not 0, and existing BAC 
was 0. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

https://help.deltek.com/Product/Cobra/8.3/GA/DataDictionary/index.htm
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 Cobra.Process.dll 

 

Defect 1238441 

Description: When you ran the Calculate Forecast wizard against a forecast class that used the Percent 
Complete Ranges forecast method and more than one control account or work package were being 
calculated, Cobra would calculate the forecast using the PF=1 method if any of the following conditions 
applied: 

 The performance factor level was set to control account or work package and the length of the 
CA/WP ID was longer than the ID of the first control account or work package processed. 

 The control account or work package percent complete did not match the % complete range of 
the first control account or work package processed. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: None. 

Files Updated: 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1237351 

Description: When you ran the Calculate Forecast wizard, Cobra would fail with the "String ID 
ID_COB_PRC_CFCST_MSG88 does not exist" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None: 

Additional Notes: None. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Calculate Progress 
Defect 1228656 

Description: When you ran the Calculate Progress wizard and set the Progress by option on the 
Options page to Budget, the total progress value would exceed the total budget for result(s) if the 
budgeted result(s) contained significant negative values and/or rate reduction. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: Calculated earned value will be adjusted so that by result, its earned value does not 
exceed the BAC.  For each result, Calculate Progress will total the calculated earned value and subtract 
that from BAC. 
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 If the calculated earned value is greater than BAC, Calculate Progress will set earned value to 
equal BAC. 

Exception: If the calculated earned value and BAC are both negative, Calculate Progress will 
use the positive value of both values to compare if Calculated Earned > BAC. 

 This will only affect Progress by method = “Budget”. The behavior for all of the other Progress 
by methods (Dollars, Hours SPI, and Time) will not change. 

 This will be applied to all Progress techniques except for Level of Effort, as LoE should always 
equal budget month by month. 

With exception to LOE, the following example scenarios show how Calculate Progress will now calculate 
when a result’s earned value exceeds its BAC: 

BAC 400 360 -400 -360 400 -400 -1 -400 

Previously 
Calculated 
Earned 

360 400 -360 -400 -360 360 -400 1 

New 
Calculated 
Earned 

360 360 -360 -360 -360 -400 -1 -400 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Appendix A: Download and Install the 
Cumulative Update  

Download the Cumulative Update 
1. From Internet Explorer, go to https://dsm.deltek.com.  

2. Click Run Deltek Software Manager.  

3. Log in using your Deltek Customer Care Connect credentials.  

4. In the left pane of the Deltek Software Manager, expand your Deltek product.  

5. Expand the Cumulative Updates folder for your product, and select the update to download.  

6. Click Download at the bottom of the screen. 

Install the Cumulative Update 
Use the instructions below that apply to the Cobra version you use. 

 

For Cobra 8.x and Higher 
The instructions for installing an update for Cobra 8.x and higher depend on your type of deployment. Use 
the instructions below that apply to your deployment scenario. 

 

If You Use a Deployment Server 

To install on the server: 

1. Verify that Cobra is not running.  

2. Launch the update on the server.  

 

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish.  

Note: You must install the entire update package. If an update addresses more than one defect, you 
cannot fix one defect at a time. 

Note: You must install the entire update package. If an update addresses more than one defect, you 
cannot fix one defect at a time. 

Note: If the update detects that Cobra is already running, you will see a prompt asking if you want to 

close Cobra. Choose Yes to start the installation or choose No to cancel the installation. 

https://dsm.deltek.com/


Appendix A: Download and Install the Cumulative Update 

Cumulative Update 06 Release Notes 30 

 

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish.  

7. Launch the Deltek Cobra shortcut on client workstations to initiate the update. 

To install on a client workstation: 

1. Launch the Deltek Cobra shortcut. Cobra detects that an updated version is available and 
displays the prompt: Do you want to install the upgrade?  

2. Choose Yes to start the installation or choose No to cancel the installation. When the installation 
is completed, the installation wizard closes.  

3. Launch the Deltek Cobra shortcut to log into Cobra. 

If You Have an N-Tier Deployment 

To install on the server: 

1. Verify that Cobra is not running.  

2. Launch the update on the server.  

 

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish. 

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish. 

7. Launch the Deltek Cobra shortcut on n-tier client workstations to initiate the update. 

To install on an n-tier client workstation: 

1. Launch the Deltek Cobra shortcut. Cobra detects that an updated version is available and 
displays the prompt: Do you want to install the upgrade?  

2. Choose Yes to start the installation or choose No to cancel the installation. If you choose Yes, 
the installation wizard copies the updated DeltekCobraWorkstation.exe file locally and 
automatically begins installing files. When the installation is completed, the installation wizard 
closes.  

3. Launch the Deltek Cobra shortcut to log into Cobra. 

If You Have a Terminal Services/Citrix Deployment 

To install on the deployment server: 

1. Verify that Cobra is not running.  

2. Launch the update on the server. 

Note: If the update detects that Cobra is already running, you will see a prompt asking if you want to 

close Cobra. Choose Yes to start the installation or choose No to cancel the installation. 
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3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish. 

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish. 

7. Log on as a Local Administrator on the Terminal Server/Application Server and install the update. 

To install on the Terminal Server/ Application Server (the server on which the Cobra client runs): 

1. Log on to the Terminal Server using an account that has Local Administrator privileges. When the 
setup launches, the installation program installs all necessary files and any registry updates and 
makes these changes available to all users who will subsequently log on to the Terminal Server 
session to run Cobra.  

2. Ensure that no instance of Cobra is running.  

3. Browse to the shared Cobra Workstation folder (usually located on the deployment server, as 
\\{DeploymentServerName}\CobraWorkstation\DeltekCobraWorkstation.exe).  

4. Launch the DeltekCobraWorkstation.exe file to install the update. The Welcome screen displays, 
showing that the update is available.  

5. Click Next to start the installation.  

6. When the installation completes, launch the Deltek Cobra shortcut to log into Cobra and confirm 
that the update is installed, meaning that users can now launch Cobra via Terminal 
Services/Citrix sessions. 

If You Have a Standalone Deployment 

To install on the workstation: 

1. Verify that Cobra is not running.  

2. Launch the update on the server.  

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish.  

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish. 

7. Launch the Deltek Cobra shortcut to log into Cobra. 

Confirm that the Cumulative Update is Installed 

1. Click  » Help » About Deltek Cobra. 

Note: If the update detects that Cobra is already running, you will see a prompt asking if you want to 

close Cobra. Choose Yes to start the installation or choose No to cancel the installation. 
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2. Check that the version number reflects the installation of the update. 
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Appendix B: For Additional Information 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 

 Search for product documentation, such as release notes, install guides, technical information, 
online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 
Deltek Support Center Community 

 Access Cloud-specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Initiate a Chat to submit a question to a Customer Care analyst online 

 

Access Deltek Support Center 

To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 

 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/


 

 

About Deltek 
Better software means better projects. Deltek is the leading global provider of enterprise software and 
information solutions for project-based businesses. More than 23,000 organizations and millions of users 
in over 80 countries around the world rely on Deltek for superior levels of project intelligence, 
management and collaboration. Our industry-focused expertise powers project success by helping firms 
achieve performance that maximizes productivity and revenue. www.deltek.com 

http://www.deltek.com/
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