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Introduction

Introduction

This guide explains the steps on how to extend a report. Before reading this guide, refer to the Deltek

Costpoint 8.0 Extensibility Designer User Guide on how to navigate the Designer and basic steps in
extending a Costpoint component. The extensible components include Result Set, Action, Report,
Messages, Constants, and Application Title. Extending a report involves several interconnected
components.

At a high level, extending a report involves the following steps.

e

1

2

3

4

5

Create a report extension using the Extensibility Designer
Extend the reporting data result set (if additional data is to be shown in the report)

Extend the java classes that populate the reporting data (if data was constructed with the help
of java code)

Modify the report template used for such report

Deploy the extensibility unit to the system the same way as done for other components

Some of the steps are optional depending on how the report is implemented by Deltek and the extent of
the change.

Extensibility Designer Report Guide 1
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Standard Components of a Costpoint Report

Before you extend or customize a Costpoint report, you must first understand the standard components of
a Costpoint report and how they are linked together. This will help you identify which components you
need to extend for a report.

Report Components

The following are the standard components of a report.
= Report application
= Report parameter result set
= Report definition (and Java classes that populate the data for the report)
= Data source result set (with Select SQL)

= Report template

Report Application

Report Parameter
Result Set

Report Report Definition Java Class (via
Action)

Template

Data Source Result Set Select SOL
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Report Application

An application is the top level component that acts as the container to the screens inside the application.
It does not contain any logic. Ul and business logics are done entirely in the screens (result sets) and the
java classes that supports them. You can only extend an application by changing its application name.

Tip: To view a list of all available applications in Costpoint, refer to the Apps folder of the Extensibility
Designer’s Object Explorer. These applications are sorted by application ID.

If you know the name of the application but not the application ID, open the application in Costpoint
and then go to the View Help About screen (Administration » System Administration » System
Administration Reports/Inquiries Help » About Costpoint). The application is listed on the Open
Applications table window with its application ID.

Report Parameter Result Set

A report parameter result set is the screen where the user selects various options to run the report. It is
assigned underneath an application. In the example below, CPRCUST_PARAM is the parameter result
set assigned to the Print Customer List application.

Deltek Costpoint Application Extensibility Designer 7.0.1 - CZ01RDO (=] F
Object Link View Extensions Tools Help
| Dol -] [3a] 3] ir]) B[ <[ 2] %] Top overrimer fare it

, Modules -

. Apps (Filtered "harrct’)
=], ARRCR ( Frint Cash Recsipts Edit Report )
-l ARRCRREG ( Print Cash Receipts Register Report )

'E---EI? ARRCUST ( Print Customer List) |
- Modules

ER:=: CrRCUST PARAM ( Customer List )
, Apps
. Trees
. Actions
. Reports
[+-&=h CPRCUST_RPT { Customer List )
. Messages
Eﬁiibm Units
- . Messages
. RS (Filtered "%cprct’)
-] CPRCUST_DS ( CPRCUST Dats )
Bl CPRCUST_PARAM ( Customer List )
. Trees LI

0

Note: If a report application contains more than one subtask, you can locate its parameter result set
under the Trees folder, instead of the RS folder for that application in the Object Explorer.

A parameter result set does not contain logic for the report. It only drives what data should be gathered
for the report. Generally, you do not extend a parameter result set except for cosmetic changes such as
changing the labels on the screen. Options such as adding an additional selection, filter, or sort option
cannot be added since the existing Java class logic for populating the data source are not extensible (see
Data Source Result Set).

Extensibility Designer Report Guide 3
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Report Definition

A report definition (or report list) includes the metadata that describes a report such as title, status text,
Java class action, and the data fields that feed into the report. In the Object explorer, you can find the
report listed directly underneath the parameter result set.

Deltek Costpoint Application Extensibility Designer 7.0.1 - CZ01RDO - |I:I|i|
Object Link View Extensions Tools Help
| D[~ [e] ¢ [5] 3] -] ] R[] 2|3 vop Levetiter [arc il

. Modules

. Apps (Filtered "harrc%’)
-l ARRGR ( Print Cash Receipts Edit Report )
#-EL ARRGRREG ( Print Cash Receipts Register Report )
=5, ARRCUST ( Print Customer List)

F- | Modules
- | RS
=8 CPRCUST_PARAM ( Customer List )

- | Apps

| Trees

- . Actions

E..

B- | Messages

In the example above shows the report definition for CPRCUST_PARAM is CPRCUST_RPT.

Edit report: CPRCUST_RPT - C701RDO =0l x|

Name * ICustumer List

Report Id *

Information | Data Sﬂurml

-ul
Tile |SCPT.CUSTS List Status Text |

~ Settings
Report Category * [INTERNAL (Internal ) = | Locking* |lione =

ROX (template) * Ionmmnnapplcprcust.rcprcust

Default Locale * IUserIncaIe LI Show Currency Symbol [Never LI

ALLUTES

EefurelNune () Llﬁl @
After INune () j ﬁl
PHGE cep

QOrientation ILandscape LI Paper Size ILetter LI Get from Report |

Margins (inches)
[ Left | Right Top | Bottom

r Always Uze Design Settings

Apply ak Cancel
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The name and location of the original report template is specified in the ROX (template) field on the
Information tab. This path is a sub path underneath the root path where report templates for all
applications reside in the Costpoint server. The root path for all report templates is
C:\deltek\costpoint\80\applications\birt\report\bin. The example above displays the report template for
Customer List at:

C:\deltek\costpoint\80\applications\birt\report\bin\commonapp\cprcust\cprcust.rptdesign

The .rptdesign extension name is omitted in the ROX field since it is implied. If there is any standard
Costpoint action to be run before or after the report is run, they are displayed here.

Attention: For more information about an action, see the Deltek Costpoint 8.0 Extensibility Designer
Guide.

On the Data Sources tab, the left pane displays the data source ID and name used inside the report
template. The right pane displays the ID of the data source result set which supplies the data for the
report. In the following example, there is only data source, and the ID is CPRCUST_DS.

Edit report: CPRCUST_RPT - C701RDO =[of x|

Report id* [CPRCUST_RPT Name * ICustumer List

Information Data Sources |

Data Source DS MName Assigned to DS Result Sets I Assigned to DS Variahlesl

RS Mame

CPRCUST Data

lews | Edit | Delete Add RE | Hemove RS | Up | Down

Apply | Ok | Cancel |

Click the Assign to DS Variables tab to see all the fields from the data source result set that have been
selected to feed into the report. In the following example, seven columns from the data source result set
are selected to be used on the report.

Edit report: CPRCUST_RPT - C701RDO =[of x|

Report id* |[CPRCUST_RPT Mame *

Customer List

Information Data Sources |

DS Name Assigned to DS Result Sets /Assigned to DS Variables

CPRCUS

Data Source

ST::DataSource

Variable Variable Name
Please enter
Please enter
Pleaze enter

Please enter
Please enter variabl ription here
Please enter ] ion here

New | Edit | Delete Add Variable | Hemove Variable | Add AIIRS Variables

Apply Ok | Cancel |
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You can extend a report definition by changing the report title, status text, the report template, action to
be run before or after the report, and the data source columns.

Data Source Result Set

The data source result set acts as a data source for a report. It is like any other result set except there is
no need to design the Ul layout. The data source result set for a report is not displayed directly in the
Object Explorer under the respective application branch. You must take note of the ID of the data source
result set in the Report Definition and find it using the Top Level Filter field, as shown in the following
example.

Deltek Costpoint Application Extensibility Designer 7.0.1 - CZ01RDO (=] 3|
Object Link View Extensions Tools Help

| O]~ |52 22| -] @ 2R]=|2&|2&] TopLevelFiter

; Modules
. Apps (Filtered "earrc’)
---E ARRCR ( Print Cash Receipts Edit Report )
% ARRCRREG ( Print Cash Receiptz Register Report )
ARRCUST ( Print Customner List )
RS (Filtered "%CPRCUST%")

CPRCUST_DS ( CPRCUST Dats )

T CPRCUG T PARAN [ CUSIGmer LISt )

| Trees

| Actions

; Reports (Filtered "hcpri’)

, Constants

; Messages

, Extensibility Projects

| ]

At the top of the RS list tab, there is usually a SQL Select statement defining where the data for the report
will come from. In the lower half of the Classes tab, there is usually a Java class in the Set Select field.
This Java class defines or refines the SQL statement at run time to filter and sort the data according to
what the user specifies on the parameter result set.

You cannot extend this Java class as it is not an event that is extensible. For this reason, you generally
do not extend the parameter result set to add additional options for filtering as you cannot extend the set
select Java class to cover the additional options. You can, however, add options such show or hide since
this can be done in the report template itself.

Extensibility Designer Report Guide 6
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Edit Result Set - CPRCUST_DS - CF01RDO N =]
Extensien I Select... |
RS List | RS Description | RS Presentation |
Id* ICPRCUST_DS Name * |CPRCUST Data Type* |Reporting Data j

SELECT CUSTOMER AS CUSIOMER, CUSTOMER NAME AS CUSTOMER NRME, CUSTOMER TYPE A5 CUSTOMER TYPE, CUSTOMER TERMS AS
CUSTOMER. TERMS, SRLES TERRITORY A5 SALES TERRITORY, LIMIT AMOUNT A5 LIMIT RAMOUNT, TRX EXEMPTION AS TAX EXEMPTION
FROM VAR CUSTOMER LIST WHERE COMPANY ID =:CP_COMPANY ID ORDER BY SALES TERRITORY, CUSTOMER

S0l Editor Refresh GBI D= Check Sql Map P

Ul Options | System Information  Classes | Extensibility Plug Ins |
~ RS Classes
RS Open I

RS Populate |

Set Select Icum.denek.enterprise.applicatiun.cummunapp.cprcust.CprcustSetSelect
Valdate Line |

™ Execute Set Select Onhy Gnce

AL

i Disable Line Formula |

Validate Line J5 |

RS Validate I f() Dizable RS Formula |

Before Save

RS Close

AL

|
After Save I
|

Werify | Apply | Ok | Cancel |

You can extend the data source result set by adding additional columns to the SQL select statement in
the lower half of the SQL select panel.

Report Template

Costpoint uses Eclipse open source BIRT (Business Intelligence and Report Tools) platform for reporting.
A report template is a layout/design of the report created with Eclipse BIRT IDE.

Attention: Refer to the Eclipse IDE Installation section for more information.

All report template files have the .rptdesign extension name. For example, the Customer List report
template file name is cprcust.rptdesign.

You can extend a report template by copying an existing Costpoint template, saving it with a new name,
and then modifying it using the Eclipse IDE. The new template is then placed in the custom folder
(specified in the extended report definition) under the BIRT report main folder on the server, as shown in
the following example.

Extensibility Designer Report Guide 7
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File Edit Insert Element Data Page Navigate Search Project Run Window Help

BrillodtimiriE g e

B

- Navigator (SE Outline xﬂ =0

v [, syrusrrptdesign;
» ®m Data Sources
> @ Data Sets
Data Cubes
& Report Parameters
ariables

> @ Body
MasterPages

> @ Libraries
> @ Scripts

B syrusrrptdesign 5

&= Date/Time:

Printed By:

Parameter ID:

N Number of Pages:

R Selection Ranges

Selected Companies:

. Selected Users:

[CP_CompanyName]

User Report

(C?_BuildDateTine) zgSecErofile
- &CPTS.ORCE Security [e8_oxgSeckzotile]

[CP_UserIa)
[CP_Parameter]

Total # of Pages

Report Options

(Companies
Users

NCR Range - Users

Layout| Master Page| Script| XML Source

Property Editor 23 [Tl Properties (2] Problems

Properties|
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Extend a Report in the Extensibility Designer

You can extend a report with simple to complex changes. The level of effort depends on how complex the
report is in Costpoint and how many changes are desired for the extended report. Below are some
examples of simple and complex changes:

Change the report title or report status text on the screen (not the report): This change only
involves extending the report definition in the Extensibility Designer and setting the new report
title or status text to be shown on the screen (not the report).

Change the report title on the report: This change involves extending the report definition in the
Extensibility Designer and a simple change in the report template for the report title in Eclipse IDE
for BIRT report.

Change the labels, column headings, or the layout of the fields on the report: This change
involves extending the report definition and more in-depth changes to the report template in
Eclipse IDE. You need proficient knowledge of how to use Costpoint plug-in classes and methods
for BIRT reports for this change.

Add additional columns from a related table to the main Costpoint report table to the
report: This change involves extending the report definition, making changes to the data source
result set, and making changes to the report template.

Extend a Report Definition

To extend a report definition:

1.

Select the Report Definition for the report in the Extensibility Designer.

The Edit Report screen displays. The Information tab contains Deltek’s original settings. The
template location and name in the ROX (template) field is the subfolder under the root path for all
report templates on the server (C:\deltek\costpoint\80\applications\birt\report\bin). The report
template file (rptdesign) is actually a text file, so you can copy and rename it when you intend to
customize it.

Note: The .rptdesign extension name is omitted in the ROX (template) field since it is
implied.

2. Click the Extensibility Information tab. You can make the following modifications:

= Chang the Title and Status Text fields.

= If you want to change the content of the report (report template), specify a new template
name. The path must start with custom/<Unit ID>/<new report template name without
extension>. At run time, Costpoint expects this file to be at the report root path and sub folder
specified here.

= Change the Show Currency Symbol option. The valid options are:

= Never: A currency field in the report template will not print with the currency symbol at
run time.

=  Always: A currency field in the report template will always print with the currency symbol
at run time.

= Depends: Printing will depend on the settings in the System Settings application.

Extensibility Designer Report Guide 9
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= Add before and/or after actions (Additional Extensibility Actions group box) if you need to
run some special process before or after generating the report. These are available for new
actions (not extended actions) you have created for this extensibility unit. These actions are
executed in addition to the standard actions that are set in the Information tab for this report.

= Change the values in the Page Setup group box, such as Orientation, Paper Size or
Margins. These are defaults only and will display as defaults in the Page Setup option dialog
box when a user prints the report. These settings should match how the report template is
designed. At run time, a user can override these defaults unless you select the Always Use
Design Settings check box.

Click the Data Sources tab.

The left pane displays the data source ID and name used inside the report template. The right
pane displays the ID of the data source result set that supplied the data for the report.

Click the Assigned to DS Variables tab.
This tab displays the data fields from the data source result set that were selected for the report.

Click Add Variable to add additional fields from the data source result set.

Note: You must first add new fields to the data result set, by extending the data source result
set, before you can select and then add them to the Assigned to DS Variables tab.

Extend a Data Source Result Set

From the report definition, you can get the ID of the data source result set. Then, use the Object Explorer
to find this result set and extend this result set to add more data to the report.

To extend a data source result set:

1.

Display the Edit Result Set screen.

The upper text field displays the SQL SELECT statement that selects data for the report. In the
following example, the SELECT statement selects data from a table (or view in this case) named
AR_CUSTOMER_LIST. It selects seven columns which you actually see in the report definition
earlier. To verify, you can select the RS Description tab and those seven columns should display
there.

Extensibility Designer Report Guide 10
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Edit Result Set - CPRCUST_DS - C701RDO _olx|
Extension [XT_WN1_ACT Select... |

CPRCUST_DS Name * ICPRCUST Data Type * |Reporting Data Ll

RS List | RS Description | RS Presentation |

d*

SELECT CUSTOMER AS CUSTOMER, CUSTOMER NAME AS CUSTOMER NAME, CUSTOMER TYPE AS CUSTOMER TYPE, CUSTOMER TEEMS 43
CUSTOMER TERMS, SALES TERRITORY AS SALES TERRITORY, LIMIT AMOUNT AS LIMIT AMOUNT,TAX EXEMPTION AS TAX EXEMPTION
FROM VAR CUSTOMER 1.IST WHERE COMPANY ID =:CP COMPANY ID ORDER BY SALES TERRITORY,CUSTOMER

S0l Editor Refresh OBJ_IDs Check Sql Map PK

Ul Options | System Information | Classes | Extensibiity Plug ins |

Titles
RS Title * IARRCUST Data
Extensibility Title |

- Ul Options.
View * II:efauIt Form View LI
Table Style [none =l
Owerride Number Of Buffered Existing Rows l—ﬂ
Ovwerride Number Of Buffered New Rows l—ﬂ

Werify | Apphy | 0Ok | Cancel |

Edit Result Set - CPRCUST_DS - C701RDO - ol x]
Extension |)(T_VN1_ACT1 Select... |

RS List RS Description | RS Presentation |

ObjID [CUSTOMER Name |CUSTOMER
General ibil

CUSTOMER, NAME I Ex'tensmllrtyl Currency and Repnrtl

CUSTOMER_TERMS DB Options

CUSTOMER_T¥PE Table I\-’AR_CUSTOMER_LIST Column ICUSTOMER

LIMIT_AMOUNT -

= ¥ FromEelect T * |Strin i Length * 12  Scale
SALES_TERRITORY M b I s | o I I
TAX_EXEMPTION [~ Primany Key | Allow Editof PK [T LogicalPK = Save Null(FK) [~ DB read only
r Dynamic Data Type | ... |

LI Aini,

2. To add additional data for the report, click the RS List tab and use the lower text field to enter a
SELECT statement, and select other columns from the same table (or from any other table)
where the WHERE clause can be formed with columns selected in the original SELECT
statement.

Treat the value of the columns in the original SELECT statement as a bind variable (represented
by the colon followed by the object ID/alias).

Extensibility Designer Report Guide 11
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In the following example, the key fields to table/view VAR_CUSTOMER_LIST are CUSTOMER
and CP_COMPANY_ID. So the WHERE clause of the extended SELECT is
“VAR_CUSTOMER_LIST.CUSTOMER =: CUSTOMER AND
VAR_CUSTOMER_LIST.COMPANY_ID = :CP_COMPANY_ID”. The bind variable : CUSTOMER
is the alias for the CUSTOMER column in the original select. It is also the ID of the resulted object
seen in the RS Description tab. :CP_COMPANY _ID is the other bind variables for the where
clause.

B3 cdit Result Set - CPRCUST_DS - C701RDO _ o] x|
Extension [XT_VN1_ACT1 Select... |

' ICPRCUST_DS Name * ICPRCUST Data Type * [Reporting Data =

R3 List | RS Descrip‘tinnl RS Presentatinnl

SELECT CUSTOMER AS CUSTOMER,CUSTOMER NAME AS CUSTOMER NAME,CUSTOMER TYFE A5 CUSTOMER TYFPE,CUSTOMER TERMS A3
CUSTOMER_TERMS, SALES TERRITORY A5 SALES TERRITORY, LIMIT AMOUNT A3 LIMIT AMOUNT, TAX EXEMFTION A5 TAX EXEMPTION
FROM VAR CUSTOMER LIST WHERE COMPANY ID =:CP COMPFANY ID ORDER BY SALES TERRITORY, CUSTOMER

|_CUSTOMER_LIST.COM _ID = :CP_COMPANY_ID
[Enter your Extensibility SELECT statement for this RS]

SQL Editor | Refresh OBJ_ID= | Check Sql | Map PK
Ul Options | System Information | Classes Extensibiity Plug ins |
ﬁ Open | D New | Eg Clone | X, Delete | 1 Up | - Down |
I I When I Crder I Plug In Type I Plug In Mame I Insert I Update I Delete I

At run time, when each row from the original SELECT statement is being retrieved, the system
will execute the extended SELECT statement to get the additional data to add on to that row
before sending it to the report.

You can select additional data from any table as long as the WHERE clause can be constructed
with these bind variables.

For example, instead of adding CREDIT_LIMIT from the VAR_CUSTOMER_LIST, you want to
add the VEND_NAME from the VEND table for the VEND_ID contain in this
VAR_CUSTOMER_LIST. You must join the VEND table with the CUST table. Your extended
SELECT statement would be like this:

SELECT V.VEND NAME AS XT VEND NAME FROM VEND V, CUST C WHERE V.VEND ID =
C.VEND ID AND C.CUST ID = :CUSTOMER AND C.COMPANY ID = :CP_COMPANY ID AND
V.COMPANY ID = :CP_COMPANY ID

3. Totestif the SQL is valid, click Check Sql, and click Refresh OBJ_IDs.
An object with ID = XT_VEND_NAME displays on the RS Description tab.
4. Click Apply.

This column is now available in the data source result set. You must then make it available for the
report

5. Click the RS Description tab, and click the Currency and Report tab.
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6. Enter the same ID in the Report Variable field, and click Save.

7. Go back to the Report Definition screen, and add this new column to the list of variables for the
report.

Edit report: CPRCUST_RPT - C701RDO (=] F

Reportld * |CPRCUST_RPT Name * |Customer List Extensibilty Unit [XT_VN1_ACT1

Infurmatiunl Extensibility Information [iata Sources I

Data Source DS Name Assigned to DS Result Sets Assigned to DS Variables |

CPRCUST::DataSource CPRCUST::DataSao...
Variable Variable MName
CUSTOMER Please enter variable description here
CUSTOMER_MAME Please enter variable description here
CUSTOMER_TERMS Please enter variable description here
CUSTOMER_TYPE Plzase enter variable description here
LIMIT_AMOUNT Plzase enter variable description here
SALES _TERRMORY Please enter variable description here
TAX_EXEMPTION Please enter variable description here
— |¥T VEND MAME Please enter variable description here

Extend a Report Template

The report template is not extended in the Extensibility Designer. You must specify the new template
name and location in the Report Definition extension and then use the Eclipse IDE to design the changes.
To extend a report template:

1. Find the location of the original template.

For example, if the original path is commonapp/cprcust/cprcust, then the file is located at
C:\deltek\costpoint\80\applications\birt\report\bin\commonapp\cprcust\cprcust.rptdesign.

2. Copy the report template file to the new location, and customize it using Eclipse IDE for BIRT.

If the new path is custom/XT_VN1_ACT1/cprcust_xt, then the new file must be copied, renamed,
and placed at
C:\deltek\costpoint\80\applications\birt\report\bin\custom\XT_VN1_ACT1\cpr_cust_xt.rptdesign.

Attention: See the next section for information on how to install Eclipse IDE for BIRT and how to
customize the report template inside Eclipse.

Warning: After a report template is customized, any hot fixes to the Deltek report template will not
automatically carry over to the custom version. Unlike all other objects in the Designer where you
extend it, the extension inherits the changes in the original object. Customizing the report template is
actually an override, not an extension. So when the standard Report template is changed by
Costpoint development, you will need to take new standard report template and redo your
customizations in that file.
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Eclipse IDE for BIRT

Report templates are designed using Eclipse IDE for BIRT. You must install the same version of Eclipse
IDE for BIRT that Costpoint framework uses (currently, version 4.6.0). Contact Deltek if you cannot find
this exact version to download from Eclipse.

Eclipse IDE Installation

You can download the Eclipse IDE for BIRT 4.6.0 using the following link:

http://www.eclipse.org/downloads/download.php?file=/birt/downloads/drops/R-R1-4.6.0-
201606072112/birt-report-designer-all-in-one-4.6.0-20160607-win32.win32.x86 64.zip

You can use the same Java 8 runtime environment that is installed with Costpoint or download latest
Java 8 runtime from Oracle download site.

Deltek recommends that you install Eclipse on the Costpoint server machine so that you can access the
database and deploy the customized template easily. If you would like to install Eclipse IDE on a machine
other than the Costpoint server machine, that machine must be able to connect to the database/system
where the extensibility is being done (Weblogic client, JDBC drivers, and so on) as well as the
toolconnections.properties file which contains the connection information.

After installation, start Eclipse and verify that the BIRT Framework component under Help » About
Eclipse Platform » Installation Details » Installed Software displays version 4.6.0.

< Eclipse Installation Details = @
Installed Software | Installation History | Features | Plug-ins | Configuration
type filter text
Name Version Id i
L Axis2 Tools 11.301.+201410160... org.eclipse jstws.axis2tools
5 krk BIRT Framework 4.6.0.7v201606072122  org.eclipse.birt.feature.grov
Lyt Dali Java Persistence Tools - Cornmen 1.5.0n201603181811  org.eclipsejpt.common.fea
» kgt DaliJava Persistence Tools - Eclipselink Common 1.3.200,201603180... org.eclipse,jpt.common.ecl
. kgt Dali Java Persistence Tools - Eclipselink DBWS Support 1.2.200.v201603180... org.eclipse,jpt.dbws.eclipse
» it Dali Java Persistence Tools - Eclipselink JAXB Support 1.4.200.:201603180... org.eclipse,jpt.jaxb.eclipseli| =
» kit DaliJava Persistence Tools - Eclipselink JPA Support 3.4.100.v201603180... org.eclipse.jpt.jpa.eclipselin
. Gl Nali lava Dercictence Trnle - IAYE Sonnnrt 1 510N WIMANTIRN e eclines int iavh featire 4

Under the installation folder for Eclipse (for example, C:\Eclipse), you will see a plugins subfolder. Go to
DSM and download DeltekCostpoint711BIRTInstaller.exe, which will copy two Eclipse plugins (jar files) to
your hard drive. You must add these two jar files to the Eclipse\plugins subfolder:

= com.deltek.enterprise.system.reporting.client.birt.oda.designer_1.0.0.jar
= com.deltek.enterprise.system.reporting.client.birt.oda.runtime_1.0.0.jar

These Deltek-supplied plugins allow Eclipse IDE to interact and design the report according to the
Costpoint framework.
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Start Eclipse

After you install Eclipse, start it by running the eclipse.exe file located under C:\Eclipse. Or, you can
create a batch file under the same folder with the following command line in it:

c:\eclipseleclipse.exe -vm "C:\oracle\jdkl.8.0 121\bin\javaw.exe"

The —vm parameter allows you to specify any version of the JRE (Java Runtime Environment) to run
Eclipse (described in previous section). Eclipse will prompt you for the location and name of the
workspace. You can give your workspace any name and any location. The location of the workspace
does not need to be the same location as the report template. It’s just a place for Eclipse to store the
workspace settings. If there is a welcome screen, close the screen and proceed to create a report project
in the next step.

Create a Project

To create a project:

1. Click File » New and select Project » Business Intelligence and Reporting Tools » Report
Project.

2. On the Report Project page of the New Report Project wizard, enter a name for the project, and
clear the Use default location check box.

3. Click Browse to locate the C:\deltek\costpoint\80\applications\birt\report\bin\custom folder, and
click Finish.

4. If the Open Associated Perspective message box displays, select the Remember my decision
check box, and click Yes.

The Report Design perspective displays.
5. If the Navigator view is not displayed, click Window » Show View » Navigator.

You can then expand the Navigator view to locate the report template that you have placed in the
custom folder.

Set Up Report Design Preferences

To set up report design preferences:
1. Click Window » Preferences » Report Design. The Preferences dialog box appears.

2. Select Window » Preferences » Report Design » Resource from the hierarchy tree on the left,
and enter the report folder of the Costpoint server (for example,
C:/Deltek/costpoint/80/applications/birt/lib/report) in the Resource folder field.

3. Select Window » Preferences » Report Design »Template from the hierarchy tree, and enter
the report template folder of the Costpoint server (for example,
C:/Deltek/costpoint/80/applications/birt/lib/report/template) in the Template folder field.

Test Costpoint BIRT Plugins

To test if the settings to Costpoint were correctly configured:

1. In Eclipse, right-click the extension unit in the Navigator view, and click New » Report the
shortcut menu.
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2. On the New Report wizard, leave all as defaults, and click Next.

You should see multiple choices for Costpoint template available.

< Mew Report [ = '@
Report

Choose the type of report you want to create, nln|

Report templates: Preview:

L

tandard
Blank Report - —_—
My First Report —
Simple Listing

Grouped Listing

Dual Column Listing

Dual Column Chart & Listing
Side by Side Chart & Listing
Chart & Listing

Cross Tab

Costpoint Dashboard Chart
Costpoint Dashboard Listing

4

Costpoint Landscape Report
Costpoint Legal Landscape Report

Costpeint Portrait Report D=aiE e

EPEPEIEPEIEPEFEP EIEP EPEFEPED

Costpoint Landscape Report

Show Report Creation Cheat Sheet

@' Mext = Finish l ’ Cancel

3. Click Cancel.

You can now open and customize the report template.
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Customize a Report Template in Eclipse

Report Template Outline

To view the outline of a report template in Eclipse, browse for the report template in the Navigator view,
and open the Outline view.

o : . R R i A v - Quick Acces
%5 Navigator | 0% Outline 72 <% Palette < = B [y birmbilmptdesign 52
4|, birmbil.ptdesign LRI SO I 20 3 4 50 6 T Byt -

4 i DataSources ~|

W CP_DatoSource

4 i Data Sets
S BLRMBIL Data Set N [CP_CompanyName]
i Data Cubes

Standard Bills

& Report Parameters -
= Variables .
x Date/Time. [CP_BuildDateTime] rgSecErofile
4 im Body & - SCPTS.ORGE Secursty O -Or9iecErofilel
1] Grid - CP_CoverPagePortrGrid nera
H Grid - CoverPageDetiPortGrid Printed By (CF_UserTd]
[ Table - DataSetPortThl Faraeter Ip [CP_Perameter]

H Grid - CP_NoRowsPortrGrid
@ MasterPages

[ simple Master Page - CP_CoverPage - Report Options

O Simple Master Page - CP_ReportBody

= Styles . Selection Ranges

i Embedded Images

Humber of Pages:| Total & of Pages

o i Libraries &CPTR . PROJE Range
W cp_components NCR Renge
N cp_presentation Billing Cycles Range
& Scripts : Billing Groups Renge
N CPT.PROJS Managers Range
Invoices Range

Billing Stare Dats [BILL PD_START DT]

Billing End Date (8TLL_pD_=ND_DTI
] Resource Explorer 52 & =0 Billing Currencies Range
s i Shared Resources
& common Layout | Master Page| Script| XML Source
i template
=) cp_build js [ Property Editor - Report 52
B cp_components.rptlibrary Properties
=) cp_controljs
B cp_presentation.ptlibrary. General General
=) cp_utilsjs Description Author
Comments Created by Eclipse BIRT Designer Version 4.6.0.v2016060721.22
User Properties path e Ldeviapp blmbilrptd

Named Expressions

As shown in the example above, the following are the main components of a Costpoint report:

= Data Sources: Costpoint report uses its own data source type. The report does not connect and
receive data directly from the database. Rather, it receives data from the Costpoint application
server. This is one reason why you need to have the Costpoint plugins for Eclipse.

= Data Sets: Refers to the data setup in the report definition. The dataset defines which columns
(fields) are being fed into the report from the data source result set.

= Body: This is the content of the report. Usually, it has two grids: cover page grid and report
content grid. If a report contains multiple reporting sections, then you may see more than one
table object in the Table section.

= MasterPages: Defines report cover page and main report data that repeats on each page, such
as page headers, footers, and page numbers.
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Data Source

On the Outline view, select and expand the Data Sources section.

Fle Edit Insert Element Data Page MNavigate Search Project Run  Winc

s [@-la-los-| /-l o- -

EZ outine 3 . % Navigator] o ~ = O|[E cpreust_xtptdesign 52

=[5 cpreust_xt.rptdesign [ g
E-[f Data Sources |
W5 CP_DataS
=& Data Sets :
- E-EF CPRCUST Data Set -
~{g Data Cubes -

—

To change Costpoint data source settings:

1. Right-click CP_DataSource in the Outline view, and click Edit on the shortcut menu.

The Edit Data Source dialog box displays. The data source may register the configuration folder

location that does not exist in your local environment.

2. Change the value in the Configuration Folder Location field to

C:\deltek\costpoint\80\applications\enterprise\properties, where the server’s enterprise.properties

file is located.

This allows Eclipse to get the additional data fields added to the report (see next step).

Data Set

To view data sets, expand the Data Set folder in the Outline view.

o= OQutline 52 . == Navigator] . 7 =0

E-5 cpreust.rptdesign
E-[F Data Sources
- - cp_pataSource
& Data Sets
SR CPRCUST Data Set
CPRCUST_DS.CUSTOMER
CPRCUST_DS.CUSTOMER_MAME
CPRCUST_DS.CUSTOMER_TERMS
CPRCUST_DS.CUSTOMER_TYPE
CPRCUST_DS.LIMIT_AMOUNT
CPRCUST_DS.SALES_TERRITORY
CPRCUST_DS.TAX_EXEMPTION
PRIMARY_SORT

o o o o W o o

The Data Set folder displays existing registered data fields that come from the data source result set. This
was done by Deltek when the report was created. You may see additional columns in the folder. These
are additional data fields computed in this report from other columns but not directly from the data source.

In the example, the extra field for XT_VEND_NAME to the data source and report definition in the
Extensibility Designer is not listed. You must register it here before we can include it in the customized

layout.
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To register an extra field in the Data Sets folder:
1. Right-click the CPRCUST Data Set, and click Edit on the shortcut menu.

2. On the Edit Data Set dialog box, select Query from the hierarchy tree on the left, and complete
the following actions in the Select System, Extension, Report, Data Source page.

= From the System Name drop-down list, select the system in which you extended the report.
=  From the Extension drop-down list, select the unit in which the unit was extended.
= From the Report drop-down list, select the report you extended.
= From the Data Source drop-down list, select the data source that you extended.
3. Select Output Columns from the hierarchy tree on the left side.

The additional column that you have added to the data set in the report definition is listed in the
Output Columns page.

4. Click Save.

The additional field is now available for use in the report.

Body

The body contains all the information for the report.

Grid CP_CoverPage

To view the top section of the cover page where the company name, report title, printed by information,
and so on are printed, click Body » CP_CoverPageLandGrid from the Outline view.

ile Edit Insert Element Data Page Navigate Search Project Run Window Help

LB 9 o Atk et - 5|

vigator 5= Outline 2 i Palette v=a B cpreust.rptdesign 52
> 1 . 2 . 3 . 4 . 5 . s . 7 . 3 . 5 . 10

S

= Data Cubes of
& Report Parameters. - [CP_CompanyName]

= Variables

&CPT.CUST& List

&CPTS.ORCE Security -

H Grid - CP_NoRowsLandGrid .
&= MasterPages Number of Pages:
= Styles
&= Embedded Images

Report Options

& Libraries
& Scripts

1st Sort:

Type Terns Territory Credit Limit Tax Exemption ID
E

The naming convention for CP_CoverPagelLandGrid refers to the Costpoint cover page grid in landscape
mode. If the report is in portrait mode, the name would be CP_CovePagePortrGrid. These are objects
provided by Deltek in the library. You can browse for all supplied Costpoint BIRT objects in the Resource
Explorer view.

You can add additional info or rearrange the layout of the top section of the cover page. The title of
“Customer List” report is set as &CPT.CUST& List. At run time, the &CPT.CUST& variable is replaced
with the customized term set from the Manage Standard Label application in Costpoint. There are seven
system-wide terms that you can customize. Use these variables instead of the hard coded English words
for them if they are one of these.

To change the title, click the title on the report, and enter the new title.
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file Edit Insert Element Data Page Navigate Search Project Run Window Help

fmife 2 B Q- v~ vl Gy o] 100%

8= Outline 5 i Palette ¥ 7o
~ B cpreustrptdesign ~
i Data Sources .
= Data Sets
& Data Cubes
i Report Parameters
& Variables
~ & Body
~ H Grid - CP_CoverPagelandGrid
5 Row
~ & Row
v O cell
~ H Grid

0 Row
H Grid - CoverPageDetlLandGrid |
[ Table - DataSetLandTbl
B Grid - CP_NoRowsLandGrid
& MasterPages
= Styles
& Embedded Images v

[

B syrusr.ptdesign
) 1 . >

)

M cpreust.rptdesign &

‘

PO L S e S A AT,

[CP_CompanyName]

<CPT.CUST& Lis |

= Date/Time:

Printed By:

Parameter ID:

Number of Pages:

selection Ranges
Yes/No Label
Sort By

1st sort:

2nd sort:

&CPT.ACCTE

Grid CP_CoverPageDetlLandGrid

To view the selection a user has selected on the parameter page before the report (for example, selection
range, sort, and so on), click Body » Grid — CP_CoverPageDetlLandGrid in the Outline view.

(CP_BuildDateTime]
(CP_UsexId]

[CE_Parameter]

Total # of Pages

Range

PRIME_SORT_BY CD

SECOND_SORT_B¥_CD

&CPT.CUST& Name

&CPTS.ORCE Security [C8_OrgSectrotile]

Report Options

Territory Credit Limit Tax Exemption ID

File Edit Insert Element Data Page Navigate Search Project Run Window Help
a- LS E e : [Qoccrcees];
% Navigator 5= Outline 52 | < Palette ¢ v=0 g B, cpreust.rptdesign 52
« B cpreustrptdesign ) 1 - . 2 3 4 El L6 . 7 . 8 - - E] . 10
& Data Sources o
& Data Sets -
i Data Cubes o}
N [CP_CompanyName]
- &CPT.CUST& List
: = Date/Time: [CE_BuildDateTime] rgSecProfile
- - &CPTS.ORG& Security [CF_OroSecEratile]
- Printed By: (CE_user1a)
Grid - CP_NoRowsLandGrid - Parameter ID: [CB_Parameter]
& MasterPages N Number of Pages: | Total §# of Pages
& Styles N
HGrid =, + omt
& Embedded Images -
& Libraries - Selection Ranges
& Scripts -
. Yes/No Label Renge
. Sort By
. 1st Sort: PRIME SORT BY CD
- 2nd Sort: SECOND_SORT_BY_CD
. sceT. ACCTE £CPT.CUSTS Name Type e Territory Creait Limit Tax Exemption ID
<

To edit the grid of the report:

1. Click any of the fields on the Layout view (for example, Yes/No label field), and click Property
Editor view » Properties.

This uses the CP_LabelYesNoCntl Costpoint class.
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- = Body eLCi.wUDle Li>L
Bl Grid - CP_CoverPagelandGrid = Date/Time: [CE_BuildDateTime] [CP_OrgSecProfile]
~ [ Grid - CoverPageDetlLandGrid : [ECETS. ORGE Security -
m
Row Printed By: [CP_UsezId]
~
Row Parameter ID: [CP_Parameter]
v D Cel . . Number of Pages:  Total # of Pages
~ H Grid
« O Row . Report Options
O Cell
v lCal
N . Yes/No Label Raflge
¥ Label - CP_LabelYesNoCntl e e
= o TOTTEY
T Row | 1st Sort: PRIME_SCRT_BY_CD
O Row 2nd Sort: SECOND_SORT BY CD
f Table - DataSetLandTol
T Grid - CP_NoRowsLandGrid &CPT.ACCTE &CPET.CUST& Name Type Terms Territory
& MasterPages v
s v =0
esource Explorer & &

<
# Shared Resources

Layout| Master Page | Script| XML Source

& common
= template [EA Praperty Editor - Label 22 [ Properties [£! Problems
= cp_buildjs . Properties| Highlights
B cp_components.rptlibrary
[ cp_controljs General General
B cp_presentation.rptlibra
> Cllj Stllsjs P v addipg Library: | C\deltek\costpoint\80\applications\birt\lib\report\cp_components.rptlibrar
T Border NOTE: This report item from the library has been modified. To restore the original
Margin librar w click on B _Restore Properties’
Hyperlink Name: | CP_LabelYesNoCntl ement ID: 407
Page Break

Font: Courier New v | Size: 8 v | points v

2. Click the Advanced tab in the Properties tab in the Property Editor view to view settings for this
object.

For this CP_LabelYesNoCntl class, the CP_DataValue points to the data entered in the field
PRIME_SORT_BY_CD (which is the object ID of the field on the parameter Result Set).
CP_DataValues are the possible values for this field. There are four possible values, separated
by a tilde (~) symbol.

CP_DisplayValues are the corresponding text to be displayed on the report according to the value
returned in CP_DataValues. There are four possible text separated by a tilde (~) symbol. So if the
return value is 0, it will display & CPT.CUST& &CPT.ACCT&. If the return value is 1, it will display
&CPT.CUST& Name.

Since you are not likely to customize/extend the parameter result set, there is probably not much
to change in this section.

Properties] Highlight5|
ra

Margin Advanced

Hyperlink
W Property | Value
—_— | Comments
\knbﬂrty— Content Yes/MNo Label : Inherited

Localzation Content key

Table of Contents CP_DataValue CP_getParmsString("PRIME_SORT_BY_CD")
B CP_DataValues Orelre2n3
— | CP_DisplayValues &CPT.CUST& &CPT.ACCTR:~&CPT.CUSTA Name:~Sales Territory:~&CPT.CUSTA Type:

Comments
- \.,r’_LuLE'fEAu

User Properties CP_SuppressDuplicates false : Inherited

MNamed Expressions Custom XML
Cnopt Uandlor | Display name

Display name key
. frdvanced Event handler class
r P———

Table

The table is the main component of a report. It is the representation of the data source in visual format. It
contains the detail content of the report. Generally, each table corresponds to a data set that supplies the
data to the table. If you offer users multiple formats for a report (for example, choice of portrait or
landscape), you can add an additional table format, but choose the same data set.

Extensibility Designer Report Guide 21



Customize a Report Template in Eclipse

Deltek

To add a table format in the report:

1. Select a table in the Outline view.

2. Click the Binding tab in the Property Editor view.

The data set assigned to this table displays. All the fields from the data set are listed in the Data
Column Binding grid. Each time you use these fields and place a control on the report for it, an
additional row is listed here for the control. For example, on the first line of the grid,
LIMIT_AMOUNT was shown on the report via the CP_CurrencyCtnl object. LIMIT_AMOUNT is
also shown as an item coming from the data set.

&5 Navigator | B2 Qutline &% o ¥ =0 *cpreust_xt.rptdesign
=~ cpreust_xt.mtdesign [ e 3 IR S 6 e 7. 8. 9
E-(F Data Sources -
* CP_DataSource - _ =
- Dats Sets ECPT.CUSTL Name ECPT.ACCTE Type Terns Territory Credit Limit
i Data Cubes .
({3 Report Parameters n
i® varables - |
&[0 Body Layout | Master Page | Script| XML Source | Preyiew

*3 Gnid - CP_CoverPageLandGrid Property Editor - Table 2 “._fiii Resource Expvmeﬂ

f Grid - CoverPageDetlLandGrid

e Propemelmdm Groups| Map | Highlights| Sorting| Fitters|

&[] Header

e @ Dats Set: | CPRCUST Data Set [¥]][pats set parameter indng... |
3 Row ST - d
i port Irem: v
| B Row | =
i O Row Data Column Binding:
T Row
[ RE:; Mame ~ [ Display Name ID_| Display Name | Data Type | Expression [ Function [ Fiter [Ag¢ [ ada...

£l petal CP_CurrencyCntl LIMIT_AMOUNT  Decimal dataSetRow["LIMIT_AMOUNT"] [

[El Footer CP_TextCntl CUSTOMER String dataSetRow[ "CUSTOMER"] Nj# | Add Aggregation...

B Groups CP_TextCntl_1 CUSTOMER_NA... String dataSetRow["CUSTOMER_NAME"] N,

3 Grid - CP_NoRowsLandGrid CP_TextCntl_2 CUSTOMER_TY... String dataSetRow["CUSTOMER_TYPE] N/
@[} MasterPages CP_TextCntl_3 CUSTOMER_TE... String dataSetRow["CUSTOMER_TERMS"] NiA
B[ Styles CP_TextCntl 4 SALES_TERRIT... String dataSetRow["SALES_TERRITORY"] N/,

[Ea] Embedded 1mages CP_TextCntl_5 TAX_EXEMPTION  String dataSetRow["TAX_EXEMPTION"] N/,
cp_components.CP_Theme DS.C... String ataSetRow]
&[] t5.CP_Thi CUSTOMER CPRCUST_DS.C... St dataSetRow["CUSTOMER” N
-y Libraries CUSTOMER_NAME CPRCUST_DS.C...  String dataSetRow["CUSTOMER_NAME"] N,
B Sarpts CUSTOMER_TE... CPRCUST_DS.C... String dataSetRow["CUSTOMER_TERMS"] N,
CUSTOMER_TYPE CPRCUST_DS.C...  String dataSetRow[ "CUSTOMER_TYPE"] N,
LIMIT_AMOUNT CPRCUST_DS.L... Decimal dataSetRow["LIMIT_AMOUNT"] N,
PRIMART ST PRTMAR ST TSI TSP R PRTFAR TSI T ™

3. Click the Properties tab, and then Table of Contents.

On the right side is the text that will display at run time when the user selects the Table of Content
on the report preview. CP_TranslateText is used to translate text (to another language for a
Costpoint system that supports multiple languages. Usually, when the text is set for a CP_Label
control, it is automatically translated. When text is imbedded in another control such as this one,
you must indicate that this text needs to be translated at run time.

Property Editor - Table &3 fin Resource Expk}reﬂ

Properties Einding| Groups| Map| Highlight5| Sorting| Fih:er5|

ray
Page Break Table of Contents

\igihi
Table of Contents
Bookmark
Comments

Table of Contents:

CP_Translate Text( "&CPT.CUST& List") N

User Properties

Mamed Expressions

Table Header

A table header prints on each page of a report. It is generally used for static text such as column
headings. It does not change from page to page. If there is data in it, it displays the data for the first row
and remains the same for all pages. Only use table headers for static values.
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5. Navigator | 5= Qutline £3 e - O *cpreust_xt.rptdesign 52 =
E-[5 cpreust_xt.mtdesion | ' 1 i -2 S 3 4 - 5 5 7 S8 - -9
() Data Sources o
/B, cP_DataSource
@ Data Sets &CPT.ACCTE &CPT.CUST& Name Type Terms Territory Credit Limit Tax Exem
-{ Data Cubes
~(§3 Report Parameters
(5 Variables
[ Body HIE TCPT.CUSTE Name TCPT. ACCTE Tipe Terns Territory Tredit Limit B Exem
-FZ Grid - CP_CoverPageLandGrid
@£ Grid - CoverPageDetlLandGrid "
B+ Table - DataSetLandThl -
- Header - Territory &CPT.ACCT& &CPT.CUST& Name Terms Type Credit Limit Tax Exem
L0 Row N
=1 cell .
&1 crid - : o
O Row - Territory &CPT.CUST& Name &CPT.ACCT& Terms Type Credit Limit Tax Exem
| 0 Row ©
- -
IR L L. - JJ
T Row . L
T Row Layout | Master Page | Script| XML Source | Preview |
m " =
. ES:: [ Property Editor - Row 52 . fil Resource Explorer | Rl
5 petail Properties | Map | Highights|
[] Footer e I
-I2 Groups General Visibility
-5 Grid - CP_NoRowsLandGrid Border
[Ty masterpages Page Break Hide Element
1
Styles Visibility
[Z] Embedded Images s @ For zll outputs
cp_components.CP_Theme
5 Lbraries User Properties Q For specific outputs...
& Scripts Named Expressions r Detail (All outputs)
1
Exeqikiandien | B [1cp_reportDataFound( ) || CP_getParmstring("PRIME_SORT_BY_CD")!=0 | [
Advanced

To view visibility formulas, click Visibility on the Properties tab of the Property Editor view. A visibility
formula controls when the object (in this case, the table row) should be hidden. If the formula returns true,
it is hidden. Otherwise, it is visible.

In the following example, CP_reportDataFound is a Costpoint method that returns true if there is any row
returned to this table. CP_getParmString gets the value of the object on the parameter result set. If there
is no data found or the sort code is not 0, it is hidden. Otherwise, it is visible.

!CP_reportDataFound( ) || CP_getParmString ("PRIME SORT BY CD")!=0

Table Detail

Table detail prints for each row returned from the data set. You can have multiple rows for the detail if
there are many columns. You generally use a grid to do indentation and spacing within a row. You can
add additional rows to a grid if the additional row shares the same indentation and spacing. Otherwise,
you add a new row and a new grid within it for different indentation.

To extend a table detail:

1. Double-click a control on the Table Detail row (for example, CUSTOMER to display the Edit Data
Binding dialog box.

Colurmn Binding Name: | CP_TextCntl

x|

Display Mame ID: |

%

Display MName: | CUSTOMER
Data Type: |String LI
Expression: | dataSetRow["CUSTOMER"] Fu

@ 04 I

Cancel |
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2. Click the formula (fx) button.

The Expression Builder dialog box displays. The pane at the top allows you to build the value of
this field using the fields available in the lower panes. For example, if you want to display
CUSTOMER, then select Available Data Sets in the Category pane, select CPRCUST Data Set
in the Sub-Category pane, and double-click CUSTOMER in the Double Click to insert pane to
set the value of in the top pane.

& Expression Builder (JavaScript) ;IEILI

Expression Builder

Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your expression.

o B R DY
1 dataSetRow["CUSTOMER"] =]

4 o

opentors: +| -| =| /| 2| =| <] >]  &] 1] ()]

Category: Sub-Category: Double Click to insert: 12
Available Data Sets & CPRCUST Data Set El CUSTOMER
Available Column Bindings El CUSTOMER_MAME
MNative JavaScript Functions El CUSTOMER_TERMS
BIRT Functions El CUSTOMER_TYPE
Operators El LIMIT_AMOUNT

E SALES_TERRITORY
E TAX_EXEMPTION
E XT_VEND_NAME
E PRIMARY_SORT

@j 0K I Cancel

To add a row for the XT_VEND_NAME (from the data source example):

1. Right-click a grid in the Outline view, and click Insert Row on the shortcut menu. A new row is
added on the Layout view.

2. Select the first cell of the new row, and open the Resource Explorer view. The list of Costpoint
classes available for use as report controls display.
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5. Navigator | 5= Outline 52 A *cpreust_xt.mptdesign £3
= cpreust_xt.mtdesign alllge g 1o 2 e R LR RN D 6 T B i g
@ Data Sources 7 Type &CPT.ACCTE &CPT.CUSTE Name Terms Territory Credit Limit Tax Exem
(55 Data Sets -
(i Data Cubes -
(& Report Parameters N
@ Variables " Type &CPT.CUST& Name &CPT.ACCT& Terms Territery Credit Limit Tax Exem
[0l Body
23 Grid - CP_CoverPageLandGrid [ [ I [ I [ I
[ Grid - coverpageDetiLandGrid [CUSTOMER] [CUSTOMER HAME] [CUSTGMER TVPE] [CUSTOMER TERMS SALES TERRITORY LIMIT AMOUNT]| [TAX EXEMPTIC
[ Table - DataSetLand Tbl I
Bl Header
-] Detal « [CUSTOMER_NAME] [CUSTOMER] [CUSTOMER_TYEE] [CUSTOMER_TERMS] [SALES_TERRITORY] [LIMIT_AMOUNT]| [TAX_EXEMFTIC
mm)
= S“égu [SALES_TERRITORY] [CUSTGMER] [CUSTOMER_NAME] [CUSTOMER_TERMS] [CUSTOMER_TYPE] [LIMIT_AMOUNT] [TAX_EXEMPTI(
=3 Grd [SALES_TERRITORY] | [CUSTCMER NAME] [CUSTOMER] [CUSTOMER_TERMS] [CUSTCMER_TYEE] [LIMIT_AMOUNT]| [TAX EXEMFTI(
E-C0 Row
[ cal [CUSTOMER_T¥PE] [CUSTOMER] [CUSTOMER_NEME] [CUSTOMER_TERMS] [SALES_TERRITORY] [LIMIT_AMOUNT]| [TAX_EXEMPTL
/2, Data(CP_TextCnt! -
O cel " [CUSTOMER_TYFE] [CUSTOMER NAME] [CUSTOMER] [CUSTOMER_TERMS] [CUSTOMER_TYEE] [LIMIT_AMOUNT]| [TAX_EXEMFTIC
[ cel -4l |
[ cell Lsyout | Master Page | Script | XML Source | Preview
O cel
O cel 5 Property Editor - Call| i Resource Explorer 22 | I
S E-0] Cel [=-{= Shared Resourcps
E-00 Row & common
O cel & oe
L Cell fee (= template
[ cel 2 ep_buidJjs
L cell it cp_components.rptibrary
O cell () Data Sources
L el (@ Data Sets
[J Cel (@ Data Cubes
Row - —
0 Row I B} Report Ttems|
0 Row - = DICPCIeyC...) - CP_CurrencyCntl
ol e 1 R -~ Data(cP_currencyN...) - CP_CurrencyhoDecCntl

&CPT.VEND& Name.

cell.

On the Edit Data Binding dialog box, click the formula (fx) button.

On the Expression Builder dialog box, double-click EX_VEND_NAME in the Double Click to
insert pane, and click OK.

& Expression Builder (JavaScript)

Expression Builder

Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your expression.

=12 x]

B EXIDEHE

1 dataSetRow["XT_VEND_NAME"]

Kl
Operators: jjjﬂ

1 5 = |

g
ot

| Hint: XT_VEND_NAME

Category: Sub-Category: Double Click to insert: laz
Avaiable Data Sets i’ =¥ CPRCUST Data Set E TAX_EXEMPTION N
Available Column Bindings [E XT_VEND_NAME
Mative JavaScript Functions — El PRIMARY_SORT p
J | B q| | B
@ [8]4 I Cancel |

Drag and drop CP_LabelCntl to the first cell of the new row, and rename the text of the label to

For the second cell, drag and drop CP_TextCntl from the Resource Explorer tab to the second

7. On the Edit Data Binding dialog box, change the Display Name to XT_VEND_NAME.

This display name is not important, but setting it to the same name in the data set helps to quickly

identify the object.

definition, and the report template.

Click OK. The new field is added to the report by extending the data source result set, the report
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To set or change the format of the object, click Property Editor — Data » Properties » General. You can
change the font, point size, color, indentation, and so.

@ Property Editor - Data &2 fii} Resource Explorer\l
Properties Binding| Map| Highlight5|
|
General General
Padding B RESWNE FTURST Ues
_ Mame: | CP_TextCntz | Element I: [861 |
Margin
Format Mumber Eont: | Courier New |z| Size: | 8 EH points El
Format DateTime
= . Black . At
Format String Color: -|| El Background calor: :||| |ZI
Mwednk || B | f | U | 5 || I = %l EEl El Whitespace: @& Auto O No Wrapping & Mormal O Preformatted
=

Table Footer

Similar to a table header, a table footer is used to print static data, such as some disclaimer text, and so
on. You can also set the static text on the Master Page.

Table Groups

A table group is used to control and display information for data when there is a break in the group. A

group is a key column used for sorting. For example, assume you have data coming in as in the following
table.

Co e

A 1
A 2
B 1
B 2

If an ID is chosen as the group key, when the value changes from A to B, there is a break. You can
display the ID once and omit it from the table detail section which will only print Line No.

To add a group:

Right-click Groups, and click Insert Group on the shortcut menu.

On the New Group dialog box, enter a descriptive name for this group in the Name field.
In the Group On drop-down list, select a column from the data set as key for this group.
In the Page break group box, set the page breaks.

o > w0 D=

Enter the values to display (usually the same data set column) in the Item Expression field. This
will display as an index on the table of contents for quick jump/navigation.

Tip: To edit an existing group, right-click the group, and click Edit Group on the shortcut menu.<Repl
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Grid CP_NoRowsLandGrid

This control is used to print the text when there is no row found on the report. Click the field to customize
this standard text.

i I3 Groups
=-f4 Grid - CP_NoRowsLandGrid
E-CT0 Row
B[ cel )
Label -
[ MasterPages

ROWS FOUND THAT MEET SELECTION CRITERIA

o

MasterPages

A MasterPage is a frame where the body information is inserted.

CP_CoverPage

This is the mat for the cover page. A standard Costpoint report does not have any text for the cover page
MasterPage. You can add additional text or add the text directly on the cover page.

CP_ReportBody

This is the mat for the report body. To view the layout of the Master Page in the Layout view, open the
Master Page view.

- Navigator | B Outine &2 - ¥ = O|[F oreust_xt.mtdesign 33 =0
5B cpreust_xt.mtdesign TR R . 3 \ T \ PR B ]
(8 Data Sources B -
- Data Sets <
(8 Data Cubes .
-~ (g3 Report Parameters o
[ Variables -
2-0 Body
&P Grid - CP_CoverPagelandGrid . 5
(3 61d - CoverpageDett andorid . &= &CPT.CUST& List
(B Table - DataSetland Thl
-7 6rid - CP_NoRowsLandGrid
B~ Row
&-01 Cel
el Label

-0y Masterpages
=[] Simple Master Page - CP_CoverPage
" T[] Header

=] Encrer
-] Simple Master Page - CP_ReportBody |

"

N -
L M ' .
~-[ga] Embedded Images Layolt [f4aster Page [scrit | XML Source | Preview |
= cp_components.CP_Theme = - =
(2, Libraries =2 Proparty Editor - Master Page | fiif Resource Explorer 52 & =)
il

Similar to the standard information on the cover page, the placement for company logo, the company
name, the report name, and any extra information is displayed in the SubTitle row.

T=

[CP_CompanyName]

[SubTitle]

To change the title of the report, you must make the change in the Master Page view.

D R R O O T T O e

|»

[CP_CompanyName ]

" B &CPT.CUST& Customized Report

[SubTitle]
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Deploy the Extension

You need to make sure the template is copied or located at the correct location at the server. When you
deploy the extension unit to the server, you will be able to see the result of the customization when you
run the report in Costpoint.

FILE LUME OPTIONE P Ly

D.EEBE Fggeofm E|AsGene'5led v ﬁm j _l
W [T] | Browse Applicstions Accounting > Accounts Receivable > Ghents > Print CUSTOMER List
CUSTOMER Customized List - 1
CUSTOMER Customized Report B
EGI:SDI M
ACOOUNT CUSTOMER Hame Type Terms Territory Credit Limit Tax Exesption ID
MEE 1 MO CCENTRAL 5,000.00
MEG 1 MO CCENTRAL 5,000.00
Vandor NHama:
lo2z¢4 Dellax General MHEZ 1 Mo CCENTRAL 5,000.00
Verdor Hame:
1243 Elue Circle COMMERCIAL .5% 13 NET 30 TWEST 88,959,955.00
Verdor Hame:
1LAROPSCPP 1RCFSOPF COM{ERCIAL KET 30 Q.00
Vendor Hame: ACQME
IMERYL Mary Customer 1 SERVICES 1 MO MNMEW ENGLAND 0.00
Verdor Hame: Advanced Research Ques=t
IMERYZ Mary Customer 2 SEMI-FRIVATE KET 10 0.00
Vendor Hame:
224 324 GOVERMMENT 1 MO 0.00
Verdor Hame:
L} g [ GOVERMMENT KET 30 o 0.00
‘andor Hame: 4] Cus=tomer
= - GOVERMMENT KET 20 D 0.00
Verdor Hame: 4] Cus=tomexr
€1CUST CLZ 41 CUSTCMER CL2 GOVERNMMENT KET 20 D 0.00
Veandor Name: 4] Cus=tomer
£1CUST CLCNE 41 CUSTCMER GOVERMMENT KET 20 D 0.00
Vendor Hame: 41 Customex
€1CUSTCLONZ 41 CUSTCMER GOVERNMMENT KET 20 D 0.00
Vandor NHama: 4] Cus=tomer
44445555 UM GOVERMMENT 2% 10 W 20 MID-ATLANTICE 0.00
Vendor Hame:

Attention: Refer to the Deltek Costpoint 8.0 Extensibility Designer Guide for more information about
deploying your extension unit.
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Customizing Controls

Only controls from Costpoint BIRT libraries should be used. Controls can be customized in different ways:
= Value expression
= BIRT control properties
= Costpoint (CP) control properties
= Visibility (show/hide)

=  Scripting (use scripting only when other means for control customization cannot provide the
desired result)

Scripting and Report Event Handlers

BIRT provides a powerful scripting capability that allows a report developer to create custom code to
control various aspects of report creation. Each control or component in BIRT provides scripting
capabilities. When a report runs, it first goes through a generation phase and then goes through a
rendering phase. Therefore, there are event handlers (control scripting methods) that are called at
generation time only and event handlers that are called at rendering time only.

= If you need to customize a control at generation phase, use the onCreate event.

= If you need to customize a control at the presentation phase, use the onRender event.

Jutline 8 | 5F Palette = O || [& pirproj.rptdesign |5: new_report.rptdesign &3

=

Script: [onPrepare v] =
Tptdesign - - onPrepare |
5 onRender

OEs

Writing Expressions

The BIRT Scripting language derives from Java/JavaScript. A BIRT expression is a statement that
produces a value. An expression can be a numeric, date or literal value, such as:

= 3.14
= "abc" +var1

When you drag a field into the report, BIRT Report Designer creates a column binding with the correct
expression for you. An expression can contain any combination of literal values, fields, operators,
variables, and functions as long as it evaluates to a single value:

= "Order Total: " + row["orderTotal"]
= row["orderDate"].getYear()
= row["itemQuantity"] * row["itemPrice"]

You use expressions when you need to change the value dynamically. See the following example.
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'qa Expression Builder (JavaScript) = I@

Expression Builder

Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your
EXPrESSION.

B X P98
1 ("¥".equals(CP_getParmString("LAB_CST_FL")) ? row["LAB_CST_AMT"] : row["LAB_REV_AMT"] ) =

Or, you use expressions when you need to hide or show the control dynamically as shown in the following
example.

'qa Expression Builder (JavaScript) = IE

Expression Builder

Type an expression in the Expression field, Browse the lists of available objects and double-click to copy into your expression,

& X 2 =

Lif (row["nSubTotTypeMo"] = =2 || CP_getParmString("PS_REVENUE_FL").equals("Y"]) {
2 var nSelect = CP_getParmiInt("PN_SELECT_NO");
3 if ((nSelect == 3 || nSelect == & || nSelect == 7 || nSelect == 8) && row["nSubTotTypeMo"] == 6) {

4 true;
501

6 else if (row["nSubTotTypeMo"] == 5] {
7 var total = Math.abs{row["nCalumn2"]) + Math.abs({row["'nCalumn3"]) + Math.abs(row["nColumn4"]) + Math.abs(row["nColumt
8 if (total == 0) {
true;
10 1

11 else {

. .

4 Ll 2

Or, you use expressions to customize the appearance dynamically as shown in the following example.

T [E) (B =] = 7 i

lig Report Design

8 *pjrproj.rptdesign *new_report.rptdesign &2

Script: IonCreate vl - % (7 Data(CP_CurrencyC...) - CP_CurrencyCntl

CP CurrencyCntlCnCreate (this);

if (this.getValue() > 100) {
this.getStyle () .coloxr = "red";

oW R

I | - }l

Use scripting only when other means for control customization cannot provide the desired result.

All standard Costpoint controls have CP_ControINameEventHandler(this) methods. If you override a
control event handler, keep CP_ControINameEventHandler(this) as the very first line of custom code.
Never remove the CP_ControINameEventHandler(this) call.

Naming Conventions

Use a descriptive name for the control display name (for example, PROJ_ID, ACCT_ID, ORG_ID,
PageHeaderProj).
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@ Edit Data Binding (==

Column Binding Mame: | CP_CurrencyCntl
Display Mame ID:
Display Mame: LAB_CST_AMT]
Data Type: |Decima| v|
Expression: row["LAB_CST_AMT"] Fil~
':?:' [ oK l | Cancel

Hiding Element

A visibility formula is available for all data controls, grids, tables, grid rows, and table rows.

To engage conditional show/hide:
1. Click Properties » Visibility tab
2. Select the Hide Element check box.
3. Display the Expression Builder, and enter an expression to hide an element.

Layout | Master Page | Script| XML Source | Preview

’E?PropertyEditor-Data i3 & Properties [£( Problems| Bl Console 55 Progress
Properties | Binding | Map | Highlights

e Visibility
Padding

Border

Margin @ For all outputs

Format Number For specific outputs...

Format DateTime Detail (All outputs)

Format String -
T Expression: | true EAE
Page Break
Visibility

Table of Contents
Banlkmarl:

Important Note about Hiding a Table Object

If you need to hide a table object, then do not use the table visibility formula. While using the table
visibility formula will hide the table when the report is rendered, the table itself is still executed at runtime.
This means that the table processes all assigned data sources/sets and all grids and controls that the
table contains. Report performance will be impacted badly because of this.

Instead of using a table visibility formula, you need to suppress the table from being executed in the first
place.
To suppress a table from being executed:

1. Display the Report Outline, and locate the top most report element (for example,
pdrmcat.rptdesign).
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2. On the Script tab, override the beforeFactory method.

= Report Design - Chcostpointweb\71\sys\birt\report\bin'\pd\pdrmcat\ pdrmcat.rptdesign - Eclipse

ile Edit Page Mavigate Search Project Run  Window Help

i~ H B @ Q- @ PG o

£. Navigator o= Outline 52 o 7 = O|[fi cp_components.rptlibrary ( pdrmeat.rptdesign i
pdrmcat.rptdesign

(A Data Sources Seript: |initialize - - B @
CE initialize
& Data Sets onPrepare
B Dot e i —
({3 Report Parameters afterFactory
([ Variables beforeRender
[ Body aft;rRenSder
[y MasterPages onPageStart
cnPageknd
] Styles

[2] Embedded Images
cp_components.CP_Theme

% Libraries
& Scripts
]
Laygut|Master Page | Script| AML Sourcel Pregiew|
E Resource Explorer 52 q§° - = Eq (@ Property Editor - Report (ﬁ Properties &3 Eu Problemq = Console}

You may reference only report parameters and/or report constants within the expression that
drives whether or not to remove the table from report execution.

3. Enter the following script:
// remove table object from report build based on params
if (!CP_getParmBoolean ("REPORT OPTION CD)) {

CP_RemoveTableFromBuild("DataSetLandTbl");

= = mm = L T

Edit Page Mavigate Search Project Run Window Help
s 5 @ - o e 5 v¥D O ow o ow

Mavigator | 5= Outline &3 o 7 7 O/ cp_components.iptlibrary ( pdrmcat.rptdesign £
E.;rgctat.srptdeslgn Script: | beforeFactory hd P B® | pdrmcat.rptdesign
ata Sources
[ Data Sets // remove table object from report build based on params
(% Data Cubes if (!(CP_getParmBooclean("REPORT_OPTION_CD")} &R CP_getParmBoolean("REPORT_OPTION CD1"))) {

CP_RemoveTableFromBuild("DataSetlandThl™);

143 Report Parameters

Report Page Settings

Unless it is an external report with a special page size and margins requirements, the guideline is to keep
all margins equal to 0.38”. This margin size is the minimum standard that must be followed. Less than
0.38" will cause the report not to fit properly and look undesirable when switching to A4 paper.
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If your report margins are less than 0.38", notify the Design and Architecture teams so the report margins
can be reviewed for the possible need of redesign or rework.

Possible options:

= Ifitis a Landscape report and C/S left/right margins are less than 0.38", then keeping the C/S
margins on the Web (using less than 0.38") is fine. An alternative would be to decrease the font
size from 8 to 7 in some sections of a report (for example, the detail section) and keep the
standard margins. This alternative is acceptable, but less preferable, compared to decreasing the
margins and keeping the font size standard.

= [fitis a Portrait report and C/S left/right margins are less than 0.38", then, on the web, margins
must be 0.38" and the font size may be decreased from 8 to 7 in some sections of a report (for
example, the detail section) to fit the data.

The Design team must be informed before choosing either approach.

Note: Margins cannot be smaller than 0.25” for Landscape reports and 0.38” for Portrait reports.
Having appropriate margins ensures that a report can be printed without data truncation. Generally,
printers have their own small margins as well.

If you are working on an external form that has specific page size and margins requirements, then follow
these requirements precisely since the only rule is to replicate a special form as close as possible.

Margins and paper size/orientation in the design tool MUST match margins and paper size in the
*.rptdesign file. The system applies the following defaults if margins and/or paper size/orientation are not
specified in the design tool:

= paper size code=Letter
= orientation=landscape
= all margins=0.38

So if a report template falls in this default category, then it is not required to provide page size/orientation
and margins in the design tool. In all other cases, developers are required to enter page settings in the
tool.

If a report is designed for Legal or A4 paper or if a report is a government form, then you should select
the Always Use Design Settings check box on the Enter General Report Info screen in the design tool.
Selecting this check box instructs the system to ignore the system/user page settings and use the report
design time page settings.

Cover Page

All Costpoint reports must have a cover page. A cover page must be one page only. If there are many
options, they should be arranged in columns across the page in order to use up as much space as
possible. If the report has non-contiguous selections, the printing of selections should be limited so that
they do not cause a page break. If necessary, some non-contiguous selections should not be printed if
there is no room for them on the page.

= The cover page is provided by the Costpoint templates as the starting point when creating a new
report.

= The cover page object can be re-inserted from cp_presenation.rptlibrary intothe report design.
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To add a cover page:
1. In the Resource Explorer, locate cp_presenation.rptlibrary.

2. Drag the cover page object from the library into the report design.

Page Header/Footer

All internal reports must have a standard page header and footer. The page header/footer is provided by
the Costpoint templates as the starting point when creating a new report. These objects can be re-
inserted from cp_presentation.rptlibrary into the report design.

To create a page header/footer:

1. On the Master Page tab in the Report Design window, use Outline view to locate the
CP_ReportBody page under the MasterPages component.

2. In Resource Explorer, locate cp_presenation.rptlibrary and drag the page header/footer objects
from the library to the CP_ReportBody » Header/Footer folder in the Outline view.

In case of multiple report sections and different page settings, you may need to create additional page
objects and place standard Costpoint page headers/footers onto new pages.

To create the new page object, right-click MasterPages in the Outline view, and click Insert Element on
the shortcut menu. Rename the new object (via the right-click menu), and change the page settings (page
size, margins, and so on), if needed.

The default height of the standard Costpoint header is 1 inch. You should change the Page Header
default height only when you need to present more data that may not fit vertically. In the following
example, the report title has two lines of text.

v 100% v e ES 35 Debug (|fl Report Design

5| B syrusraptdesign | 5l pipebt.rptdesign £2 =
EETTRRRE P Ea— PR — f e — F s — . TR

[CP_CompanyName]

- 5| alculate Over Budget Transactions Report| Page W of !
. ransactions in Excess of Budgeted Amounts Report] [CE_BuildDate

[CP_BuildTime

n

[Additional Infor...]

M CP_iTexdCntl
. i Grid
g
|l
Layout | Master Page | Script| XML Source | Preview
[ Property Editor - Label 2 ._[= Properties| Bl Console| [£l Problems B~
Properties | Highlights
General Advanced (A
Padding
—— Property Value
v On create CP_LabelCntlOnCreate(this); : Inherited
argin On page break CP_LabelCntiOnPageBreakithis); - Inherited
Hyperlink On prepare CP_LabelCntlOnPrepare(this); : Inherited
Page Break On render CP_LabelCntlOnRenderfthis); : Inherited
Visibility Overflow Hidden : Inherited

5 Push down true: Inherited
| acalization
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You can change the Master Page » CP_ReportBody (page) » Properties » General » Header Height
from 1 inch to 1.24 inches.

=08

s

Layout | Master Page | Script| XML Scurce | Preview

= Property Editor - Master Page 5 = Properties| Bl Console | [£1 Problems

Properties
=||| General General
Eoy Mame: CP_ReportBody
Margin
Header/Footer Header height: | 1.24 in - | Background color: |[___]|| Aute -
Comments . - . .
Footer height: | 0.6 in = | Orientation: Landscape -
Advanced
Width: 11 in = Type US Letter -
Height: 8.5 in -

= |f your report title has 1 line, then the standard page header height should be 1 in - default.
= |f your report title has 2 lines, then the standard page header height should be 1.24 in.
= If your report title has 3 lines, then the standard page header height should be 1.48 in.
The default height of the standard Costpoint footer is 0.6 in. You should not change the footer height.

You can insert standard Costpoint page header/footer objects from cp_presenation.rptlibrary into the new
page by dragging page header/footer objects from the library directly into CP_ReportBody page »
Header/Footer in the Outline view.

The new page object should be correctly mapped to your table object in the report design. Switch to
Layout view and in the Body folder of the Outline view, locate the table object that should display data for
different report section. Click Table » Property Editor » Page Break, and change the master page to the
page that you crated. As the result, all data that goes into the above table will be displayed on a page with
possibly different layout margins, headers, and footers.
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File Edit Insert Element Data Page Navigate Search
OrE@edliBvyiQyic sy~
5= Outline &2
~ By syrusr.rptdesign
= Data Sources

G

Project Run Wi

ndow Help

»

T = B B *syrusr.rptdesign 32

) - 2

. 3 . —
Password: [CHANGE_FASSHORD]

= Name: CHANGE_NAME
& Data Sets ! R
— Phone: CHANGE_PHONE
& Data Cubes ul L _FACTE]
& Report Parameters Default Company: [CHG_DFLT_COMP_FL]
& Variables Email Notifiecation: [CHG_PRC_NOTTFY_¥L]
~ = Body Workflow Email:
1 Grid - CP_CoverPagePortrGrid
N Send Workflow Activity: [EMATL WF_ACTVTY FL]
H Grid - CoverPageDetIPortGrid w0l
- Send Workflow Message: [EMATL_WF_MSG_FL]
——ETTIT
Email Name: [EMAIL NAME]

T
[ Table - Comp
id - Cp R

v & MasterPages
O simple Master Page - CP_CoverPage

Layout| Master Page | Script| XML Source

[ Property Editor - Table & | ] Properties (2! Problems
Properties| Binding | Groups| Map | Highlights| Sorting| Filters

O Simple Master Page - CP_ReportBody

O Simple Master Page - NewMasterPage General Page Break
= Styles
= E:bedded mages Bordes Before: Auto | After Auto o
= Libraries EIE) Inside Auto v | Page Break Interval: |0
= Scripts Page Break
Visibility Master Page:  NewMasterPage v | [Z] Repeat Header
None
Table of Contents 5 Coverpage
Bookmark CP_ReportBody
£ Resource Explorer &2 $ =g  Comments NewMasterPage
~ @ Shared Resources lseRiopetics
T Narmad Eunraceinne

To add report abbreviation data in the page footer:

1. On the the Master Page tab in the Report Design window, use the Report Outline view on the left
to locate CP_ReportBody page under the Master Pages component.

2. Scroll to the bottom of the page, and select the page footer grid.
Select the grid row that contains the Enter Report Abbreviation Data Here text.

4. Inthe Row » Property Editor » Visibility section, and click the formula (fx) button beside the
Expression field. The Expr Builder dialog box displays.

Set the visibility expression to false, and click Ok.

6. Click the Enter Report Abbreviation Data Here text, and change its value to a report specific
abbreviation text (for example, ACCT: Account; PROJ: Project).

Access DataSet Variables in Page Header

By default, BIRT does not allow access to DataSet variables on the page header. This is the limitation of
BIRT where, for performance reasons, page header/footer objects are static and created only once for
whole report/table section/object.

However, you can display DataSet variables in Page Header » CP_AddReportinfo (CP_iTextCntl)
control by using the BIRT Page Variables.

= The BIRT page variable are only to be used in the page header and only within the CP_iTextCntl
control.

= The BIRT Page Variable will hold the value of the last DataSet row that falls on that page.
=  The variable must be a break group control

To use the BIRT page variables:

1. Add a new page variable in Variables » New Variable » Page Variable.
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File Edit Insert Element Data Page Navigate Search Project Run Window Help

O = G O O G~ 7~ 0

Cow v

-

5. Navigator 5= Outline 23 <% Palette
~ B syrusr.rptdesign

> i Data Sources

> @ Data Sets

Boa

» B Grid - CP_CoverPagePortrGrid

> HI Grid - CoverPageDetlPortGrid

> [ Table - UserTable

> [ Table - CompanyUserTable

> Hl Grid - CP_NoRowsPortrGrid

~ @@ MasterPages
» O3 Simple Master Page - CP_CoverPage
> O Simple Master Page - CP_ReportBody
& Styles
& Embedded Images

> @ Libraries

> @ Scripts

&5 Dnrnsirrn Cunlarne

¥ = 8 | B *syrusrrptdesign 2 B cpreustmpidesign

p) 1 -

[CP_CompanyName]

& New Variable X :E
el
New Variable

Type: (O Report Variable @) Page Variable

Name: [Pv_userao] |

Default Value: |

OK | ‘ Cancel

Layout |Master Page §Cript|XML Source

B2 Pronertv Fditor - None 32 [7] Pronerties [ Problems

2. Name the variable using the following naming convention:

The variable name should be uppercase and should start with PV__ prefix (for example,

PV_USER_ID).

3. Set the value of the page variable by overriding the onPageBreak() method for the control that
displays the DataSet data that you want to use in the page header.

Note: If such a control is not there or should not be in the report by design, you need to
create a dummy table/grid row, put a dummy control on that row, set control value, and make
sure that this dummy control's parent row is hidden through:

overridden Row>Scrip>OnRender ()
method>this.getStyle() .setVisibleFormat ("all");

overridden Row>Scrip>OnCreate () method>this.height = "0in";

Do not hide the row or control using the Hide Element check box or set row height to 0. Use the
above setVisibleFormat("all") approach only.

. |53/ fapvuded.rptdesign 1

Script: ’ onRender

3| | B®

mr

this.getStyle().setVisibleFormat("all");
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| [l syrusrrptdesign | [E ColumnarReportNewspaperStyle.rptdesign

Script: ’ oniCreate - ] |

this.height = "Bin";

The control's onPageBreak() method should be overridden to set the page variable value. For
example:

reportContext.setPageVariable ("PV_USER ID", this.getValue()

=3 T T T T E T T = T

it Page Mavigate Search Project Bun  Window Help
Ilneqvg/fv} v 5l w¥S o ow v

gator 5= Qutline &2 3 Palette} ¢ ¥ =a pjpebtrptdesign 1

rusr.rptdesign -

Data Sources Script: [onPageBreak v] | - | B @

Data Sets reportContext.setPageVariable("PV_USER_ID", this.getValue());
Data Cubes
Report Parameters
Variables

[f PV_USERID
Body

EH Grid - D ruerDaneDarkeErid

CP_TextCntlOnPageBreak(this);

m

4. Go to Master Page » CP_ReportBodyPage » CP_AddReportinfo » Expression, and reference
the page variable value using the CP_TranslatelTextPageVar(pvName) function

For example:

CP _TranslateIText ("User ID:") + " " + CP TranslatelITextPageVar ("PV_USER ID").

SYII.ISI.Ip‘tdSign &3 pipobt.rptdesign ]
RS SRR SRR EE R FE RS TR RS R

[CP_CompanyName]

o User Report Page N of

[CPF_BuildDat

N —

[CP_AddReportInfc]

Expression Builder

Type an expression in the Expression field, Browse the lists of available objects and double-click to copy into your expression.

BAEXIDEE

1 CP_TranslatelText("User ID:") + " " + CP_TranslateﬂTex‘tPageVar("PV_USER_ID") -

Lavout | Master Pane | Scrint | X

You can also use the CP_TranslatelTextPageVar(pvName, format) function in case you need
to format data. For example:

CP_TranslatelITextPageVar ("PV_PSWD _CH DT", "CP_DateCntl")
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Be sure to add this variable as a break group and set the page break properties so that it will
break on this break group change. Otherwise, you may have a page where the variable has
changed and it will take the value of the last one.

Lines

You must use CP styles in order to provide separation lines for the cover page, report detail, and page
header/footer sections.

Select the row(s) of a grid or a table for which you want to draw a line under. Right-click and click Styles
» Apply Styles. Then choose a line as one of the following styles:

= CP_2ContentLineStyle (double content line): Use on the cover page.

= CP_ContentLineStyle (single content line and bottom line): Use on the cover page, table
detail section, and at the bottom of column headers.

= CP_HeaderLineStyle (header line for Page and Group Headers): Use on page and group
headers.

The line style provides required line width, style, and color.

Column Headers

The column headers must be placed in the table header or group header sections. Use the
CP_ColHdrStyle style for cells where you place column header labels. This style provides the required
background color and minimum white space in-between the headers.

To create column headers:

1. Use table or grid row for placing column headers. Initially, the row should have empty cells.

|| [COUNTRY]  [COUNTRY NAME]

Hold SHIFT, and select all the cells in the row
Apply CP_ColHdrStyle to the cells.

Note: Do not apply the style to the row or to the column header labels. For the right-most
column header cell, you may need to apply CP_ColHdrNoRightBorderStyle.

4. Drag the CP_LabelCntl controls (labels) from the library to the column headers row/cells, and
adjust text alignment if necessary.

5. Adjust the row height setting in Row » Property Editor - Row » General » Height if necessary.
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For the Right-most Column Header Cell Only

To avoid displaying a tiny vertical line just to the right of the last column header, you may need to apply
CP_ColHdrNoRightBorderStyle .

File Edit Insert Element Data Page Navigate Search Project Run Window Help

e e : [avccrcee|
2= Outline = v=0 B, *cprcust.rptdesign &2
« @ Row ~ - 1 . 2 . 3 . 4 . 5 . 5 . 7 . 8 . 9 . 10
v Ocel W Sort By
e Row 2nd Sort: SECOND SORT BY CD
0 cell - I I I
~ O Cell
N sCPT.ACCTE CBT.CUSTS Name Type Terns Territo Creait Limkt Tax Exemption I
 Label - CP_LabelYesNoCntl = =
<« | —
O Cell
I Row
o Row . CET.CUSTS Name sceT.AcCTS Type Terns Territory Creait Limit Tax Exemption I
~ [ Table - DataSetLandTbl
v B Header <
~ [ Row Layout| Master Page | Script| XML Source
v Ocel
~ H Grid B Property Editor - Cell 52 (] Properties [2! Problems
~ & Row Properties| Map| Highlights

O Cell

O cell General General A
o Cell Padding Element ID: 441
0 cell Border 000R0
Drop: None Background color: # v

O Cell User Properties Krop: 22k
O Cell Named Expressions Vertical alignment: | Auto v Isme olHdrNoRightBorderStyle v I
0 cell v |

Pa——— | - Font Courier New v| size e v | points v

Select the right-most column header cell, and apply CP_ColHdrNoRightBorderStyle to remove the right
vertical border line.

Page Break (Conditional Page Break)

Page Break for a Group

In order to add a page break after the group, click Group properties, and then click Page Break » After
» Always Excluding Last (Always).

=  For the top most Group, select Always Excluding Last.

=  For the Nested (Inner) Groups, select Always.
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~ Edit Group =3
Group Details
Mame: Sort direction
Module @ Ascending
Group On: (7 Descending
MODULE - Page break
Interval: Range: Before: ’Auto vl
[NoIntervaI "] After: [Al.wa)rs ']
Usze fixed base value for interval: . Auto
Inside:
Repe Avoid
[ Hide Detail Always Excluding Last
Bookmark:
Table of Contents
Item Expression:  row["MODULE"]
Style: [None v]
Filters and Serting
Filters Sorting
Filter by: Bemove | |Edit..| |Move Up| |Move Down
Expression COperator Yaluel Value 2

Conditional Page Break
A conditional page break can be done through scripting. For example, you have to provide a page break
after a group driven by a report parameter.
To provide a page break:
1. Go to Outline » Body » Table » Group object.

2. Click on script tab, and override the onPrepare method to set a page break driven by a report
parameter.

= For the top most group, use the always-excluding-last value.

= For the nested (inner) groups, use the always value.
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File Edit Page MNavigate Search Project Run Window Help
s = ] [ R Ao vy v v oW

. Navigator | 3% Outline 52 | ¢ Palette & T = B  B*syrustptdesign 52 preust.rptdesign

~ [ syrust.rptdesign ~ Script: |onPrepare v & @ Table Group - UserGroup
i Data Sources " T 5 O 0
& Data Sets if (t:"..equ:;s(cgigeiizzmst:lr{g( P':-:\GF,BRK,FL M {
= Dute Cubes , is.setPageBreal er("always");

& Report Parameters
= Variables

~ i Body
T Grid - CP_CoverPagePortrGrid
1l Grid - CoverPageDetlPortGrid
~ [H Table - UserTable
B Header
[ Detail
B Footer
~ [2 Groups

[E Table Group - UserGroup

H] Grid - CP_NoRowsPartrGrid

~ i MasterPages
O Simple Master Page - CP_CoverPage
O Simple Master Page - CP_ReportBody

For the Top most Group (onPrepare method):

if ("Y".equals(CP_getParmString("PAGE BRK FL"))) {
this.setPageBreakAfter ("always-excluding-last");

}

For the Inner Groups (onPrepare method):

if ("Y".equals (CP_getParmString ("PAGE BRK FL"))) {

this.setPageBreakAfter ("always");

Page Break between Report Sections (Tables)

In you need to have a page break between report sections (table objects), do not set the page break at
the table level. Instead, drag the CP_PageBreak component from cp_components.rptlibrary and insert it
right after CP_NoRows Grid for each table in report design.

File Edit Insert Element Data Page Navigate Search Project Run Window Help

SN B~ Qi v v oy >

% Navigator g= Outline 52 <* Palette & Y= 08

~ [ fapaexp.rptdesign
& Data Sources

& Data Sets Overwrive File: Yes/No Label
@ Data Cubes ; Batch ID: [BATCH_ID]
& Report Parameters
& Variables ] £io Asset No Item Tag No Short Description
~ i Body -
t Grid - CP_CoverPagelandGrid : [HdrGrp ASSET ACC...]
1 Grid - CoverPageDetlLandGrid - [SubGrp_ASSET_ORG...]

[ Table - FixedAssetsDetailReport_LandTbl
d Gr!d ——fonclawig o [EXP_ROW ! |[ASSET_ID] [ITEM [TAG_NO_S] [SHORT_DESC]
1 i Grid - CP PageBreak 1 . _Rom_ = | [[TAE_NO_ -
f Table - FixedAssetDisposalEditRpt_PortTbl
H Grid - CP_NoRowsPortrGrid
&= MasterPages
& Styles R
& Embedded Images B

[SUbGTp_ASSET PRO...]

& Libraries

At mATIe mesnm moam o umom enroamTasr smT

& Scripts N \ |
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Suppress Repeated Values

Suppress repeated values is supported for the following controls:

= CP_TextCntl

= CP_LabelCntl

= CP_LabelYesNoCntl
= CP_DateTimeCntl

= CP_DateCntl

= CP_TimeCntl

Use this feature only for controls that are being placed into the table/table group detail section. In order to
enable Suppress repeated values, go to Control » Properties, and set CP_SuppressDuplicates to

True.

Pasaword

Hame:
el Phone
ell

E Label - CP_LabelCntl

ell

E Label - CP_RangeCntll

&l Label - CP_NCRRangeCntl

Default Company

BT T

Emzil Notification

Workflow Email:

Send Workflow
] Send Mork £1om Masaaoa

v

Layout | Master Page | Script | XML Source| Preview

[ Property Editor - Data | =] Properties 2 . [£{ Problems| & Console

$7°=0
Data
Property Value
Data
ary Allow export true : Inherited
Background
ery Bookmark

Bookmark display name

Preferences this user can change:

[CHANGE_PBASSWORD]
[CHANGE NAME]
_—
[CHANGE FHONZ]

[CHE_DFLT_COMP_FL]

[CHE_PRC_NOTIFY_FL]

[EMATL_WF_RCTVIY_FL]

[FMATL ME MSZ BT

Box

omments
CP_SuppressDuplicates true

Custom XML false
Data binding reference

Display name
Display name key

Event handler class
Font

Data Suppression (Labor, Cost, Price)

The correct approach to implement data suppression is to identify the suppressed column in the
Extensibility Designer for report data source RS. The framework relies on correct RS metadata when

implementing security filtering for archived reports.
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&_MISC2_CST_amT
& _SUBCT_E_CST_AT ~Ul Options
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INYT_ABERY_CD Wisihle IOn cliert _I _I Editable [ves _I Reguired IF
INYT_LOC_ID Template [None | Format frore | ¥ incude
IN_NSP_QTY
IN_MRE_QTY ~Walue Options—— 0
IN_SHIP_aTY " . o

= = Heep Crig. Yalue Persist If Dizab
ITEM_DESC I_kesp Orig .
LAE_BURD_CST_AMT i it *alue |
LAE CST_AMT %

LOC_QTY 5 ;
Walidate Severity

MATL_BURD_CST_&MT
MATL_CST_AMT
MISC1_BURD_CST_AMT
MISC! _CST_AMT
MISC2_BURD_CST_AMT Obj1d | =T fanete Loty FEED
MISC2_CST_AMT —

OR HAMD QTY Scope IGrDup 'I Waliddation Mag I

In addition, you can hide these columns and column headers in *.rptdesign based on the suppression
constants passed to a report at runtime by changing control Visibility formula:

% it  iErr.., € Bttt

// Hide if user suppress cost flag is Y

"Y".equals (CP_getConstantString( "CP WUSERCOMPANY SUPPRESSCSTFL" ) )
// Hide if user suppress labor flag is Y

"Y".equals (CP_getConstantString( "CP _WUSERCOMPANY SUPPRESSLABFL " ) )
// Hide if user suppress price flag is Y

"Y".equals (CP_getConstantString( "CP WUSERCOMPANY SUPPRESSPRCFL" ) )
Dynamic Page Layout

You can create page objects of different size, margins, and page layout (lanscape or portrait) and then
assign this page to a table object in Outline » Body » Table » Page Break » Master Page.

For multiple report sections and different page settings, you may need to create additional page objects
and place standard Costpoint page headers/footers onto new pages.
To create a new page object:
1. Right-click Master Pages in the Outline view, and click Insert Element on the shortcut menu.
2. Rename the page object, and change the page settings if needed.

The default height of the standard Costpoint Header is 1 inch. The default height of the standard
Costpoint Footer is 0.6 inch.
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o Row . [CP_AddReportInfo] —
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0 Row o
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I Row
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ate .
ild js Layout | Master Page | Script | XML Source | Preview | Desktop Viewer (prototype)
:Zf;::m rplbrery [ Property Editor - Master Page 73 | =1 Properties | 2/ Problems | = Progress| € Error Log
esentation.rptlibrary Properties
ta Sources
b2 Sets General General
ta Cubes ||| Border Mome: CP_ReportBody
port Parameters =[] Margin
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Grid - CP_CoverPagePortrGrid Comments Footer height: | 0.6 in  ~| Orentation: Portrait -
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3. Insert standard Costpoint page header/footer objects from cp_presenation.rptlibrary into the new
page by dragging page header/footer objects from the library directly into Outline »
CP_ReportBody page » Header/Footer.

The new page object should be correctly mapped to your table object in the report design. Switch to
Layout view, and in Outline » Body, locate the table object that should display data for the different
report section. Go to Table » Property Editor » Page Break, and change the master page to the newly
created page. The result is that all data that goes into the above table will be displayed on a page with
possibly different layout margins, headers, and footers.

File Edit Insert Element Data Page Navigate Search Project Run Window Help
Cri@o:dl B Q-ig 9 iy - O~ »
2= Outline &2 ¥ T O By*syrusriptdesign
« By syrustaptdesign PRI RN RN B e RN 6o T :
= Dota Sources Password: [CHANGE_PASSWORD]
= .
& Data Sets . Name: [CHANGE_NAME]
& Data Cubes ‘n Phone: [CHANGE_FHONE]
&= Report Parameters Default Company: [CHG_DELT_COMP_F1]
& Variables Email Notification: [CHG_PRC_NOTIFY_FL]
~ & Body Workflow Email:
H Grid - CP_CoverPagePortrGrid
Send Workflow Activity: [EMAIL WF _ACTVIY FL]
1 Grid - CoverPageDetlPortGrid ® e =
= Send Workflow Message: [EMATL WF_MSG_FL]
Email Name: [EMAIL NAME]
[ Table - CompanyUserTable y " A SIS =
H crid - Cp Grid ayout| Master Page | Seript| XML Source
v & MasterPages [ Property Editor - Table 32 | [[] Properties [21 Problems
O si -
Simple Master Page - CP_CoverPage Properties| Binding | Groups| Map | Highlights| Sorting| Filters
O Simple Master Page - CP_RepartBody
O Simple Master Page - NewMasterPage General Page Break
& Styles
= So Eopiey Before: Auto v After Auto =
& Embedded Images =
& Libraries . gB . Inside: Auto | page Break Interval: |0
= Scripts age Brea
Visibility Master Page: | NewMasterPage v | [ Repeat Header
None
Table of Contents
CP_CoverPage
Bookmark CP_ReportBody
> = NewMasterPage
£ Resource Explorer & S o Comments )
User Properties

~ & Shared Resources

Namad Evnraccinne

Page Numbers (Restart Page #)

The page number control should be displayed at the top right corner of the page. The page number is a
part of the standard Page Header that is provide by the libraries.

= Use CP_PageNofMCntl control to display standard Page N of M text.
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= Use CP_TotalPageCntl control to display report total page count.

Restart Page Number

There are cases when you need to restart page numbers within a group (for example, display new
pagination for each voucher or invoice).

Use the following technique/rules to achieve restartable page numbers per break group:
= The break group must have a page break on changing of a group key.

= Call the CP_pageRestartGroupBeforyFactory(tableName) function in report » beforeFactory
script.

EPOIT UESIgh - CIWOTKIRED BIFTOESIg PIESTIESTAIT page NUMBEN CP_ESTAIT page NUMmber new.rp - ECIpsE

Edit Page Mavigate Search Project Run  Window Help
iR (S NE =g - Ak == -

A

Navigator | o= Outline &% » Palette ¢ - 0 cp_restart page number new.rptdesign %

cp_restart page number new.rptdesign - Script: [beforeFactory - = B ® ——
[ Data Sets L CP_pagEREbtartGrUupEEforyFactory( "mytable™);

(f Data Sources ‘

() Data Cubes
({3 Report Parameters

([ Variables
[ Body
A Grid
[E Table
El Header
[F] Detail
[ Row
[ Cell
[ Cell -
M b

Resource Explorer B2 7 =08
E Data(CP_DecimalCn...) - CP_DecimalCntl -
E Data(CP_DecimalMe..) - CP_DecimalMoThouCnt
E Data(CP_IntCntl) - CP_IntCntl
E Data(CP_IntMNeThou..) - CP_IntNoThouCntl
E Data(CP_iTextCntl) - CP_iTextCntl
E Data(CP_PercentCn...) - CP_PercentCntl
E Data(CP_RateCntl) - CP_RateCntl
E Data(CP_TextCntl) - CP_TextCntl
E Data(CP_TimeCntl) - CP_TimeCntl

FH Grid - CP_PageBreak

Image - CP_CompanylogoCntl

Image - CP_DynamiclmageCntl

Image - CP_ImageCntl 4
Label - CP_LabelCntl ‘ Layout Master Page | Script| XML Source | Preview
[EB] Label - CP_Label¥esNoCntl

[hl Lahel . CD |ictCntl

= Property Fditar - Renart 52 . =] Pronerties| [2] Problems| B Consale

= Call the CP_pageRestartGroupOnPageEnd(tableName) function in report » onPageEnd script.
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Page Mavigate Search Project Run  Window Help
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r[ B2 Outline 52 22 Palette @ - — 0O cp_restart page number new.rptdesign %
estart page number new. ptdesign pai Script: [onPageEnd A e ENO) cp_restart page numk
ata Sources
ata Sets 5 CP_pageRestartGroupOnPageEnd ("mytable”) ;|
ata Cubes 1
eport Parameters L 4
ariables
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= Explorer &2 ¥ =08

[E Data(CP_DecimalCn...) - CP_DecimalCntl -

[E Data(CP_DecimalMo...) - CP_DecimalNoThouCnt

[E Data(CP_IntCntl) - CP_IntCntl

E Data(CP_IntMoThou...) - CP_IntMNoThouCntl

E Data(CP_iTextCntl) - CP_iTextCntl

[E Data(CP_PercentCn...) - CP_PercentCntl

Call CP_pageRestartGroupSetGroupKey(tableName, groupKey) function in Table » Detail »
Row » onCreate function to set the current group key.

Page MNavigate Search Project Run Window Help

IEE i~ @ #~ s B v¥0 b v v

ftor | BZ Outline %2 L Palette &~ — 0 cp_restart page number new.rptdesign 2

Data Sets CP_pageRestartGroupSetiiroupKey ("mytable”, this.getRowData().getColumnValue("CUSTOMERNUMEER"));
Data Cubes

Report Parameters L 4
Variables

restart page number new.rptdesign - 2 — 2
— || Script: |onCreate - bl = Row
Data Sources pt @

Body
FH Grid
= Table
[E] Header
[F] Detail
[ Row
[ Cell
[ Cell -

1 | 3

Drag the CP_PageNofMRestartCntl control from the libraries. This control can be used on both
Page Header/Footer or on Report/Group Header/Footer. In CP_PageNofMRestartCntl »
onRender(), override CP_PageNofMRestartCntlOnRender(this, -1,-1); // pass parameters: (this,
pageN, pageOfM). For example:

CP_PageNofMRestartCntlOnRender (this,

CP pageRestartGroupCntlOnRenderGetCurrentPageNo ("mytable"),
CP pageRestartGroupCntlOnRenderGetTotalPageNo ("mytable")

)
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Design - C:AWorkh ling'Birt\design pl restart page number\cp_restart page number new.rptdesign - Eclipse
Page Navigste Search Project Run Window Help

IE® Q- i@~ if~5voora~

or | 5= Outline &2 gs Paletta] ® Y =0 cp_restart page number new.rptdesign &3

restart page number new.rptdesign | erpt: [amhendes_____] | @ | Lobel- CP_PageNofMRestariChtil
Data Sources

Data Cubes 3 CP_pageRestartGroupCntloOnRenderGetCurrentPagelo("mytable™),
Repor: Parameters CP_pageRestartGroupCntlOnRenderGetTotalPageNo( "mytable™)); // pass parameters: (this, pageN, pageOfM)
Variables
Body
FH Grid
= Table
[E] Header
[E] Detail
[ Row
[ Cell
[ Cell -

n ] b

Data Sets ‘ CP_PageNofMRestartCntlOnRender (this,

ce Explorer &2 & ¥ =0
Data(CP_DecimalCn...) - CP_DecimalCntl -
Data(CP_DecimalNo...) - CP_DecimalNoThouCnt
Data(CP_IntCntl) - CP_IntCrtl
Data(CP_IntNoThou...) - CP_IntNoThouCritl
Data(CP_iTextCntl) - CP_iTextCntl
Data(CP_PercentCn..) - CP_PercentCrtl
Data(CP_RateCntl) - CP_RateCntl
Data(CP_TextCntl) - CP_TextCntl

Data{CP TimeCntl) - CP TimeCntl

i [ [ [ [

Fonts

The default font is Courier New and the default font size is 8. When you create new controls derived from
the library controls, do not change the default font (and/or size) unless the Design suggests changes. The
smallest allowable font size for Costpoint reports is 7.

At runtime, the system may automatically substitute design time font (Courier New) by a font selected on
the Page Setup dialog box.

Page Setup X

Identification

Parameter ID Description |

Layout Font
() Porrait g Landscape = Mixed Font  |Courier New v

Courier Mew
Paper {Inches) Include —{p
Size  |Lefter v 7] ComjArial Narrow

P Simsun
Height 8.5 Width |11 308 Himes New Roman
Logo

Margins (Inches)

Top 0.38 Left |0.38
Bottom [0.38 Right [0.38

@ Mone (9] Default & Other

ok | canceL |

For some reports, due to application business logic and report presentation rules, font substitution should
not be allowed. In order to ensure that font substitution does not occur, override the initialize() function
for the top most report component and call CP_keepOrigFont() to prevent the system from substituting
fonts at runtime.
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Eile Edit Page Navigate Search Project Run Window Help
@ dl @Gy o3 ~frilrio G-~
2= Outline 82 . @ T 7 0 Mysyrusrrptdesign 52 M *cprcustrptdesign [\ fapaexp.rptdesign
» B syrusrrptdesign ~ Script:  initialize = % @ syrusr.rptdesign
i Data Sources ————
& Data Sets CP_Repor‘tI11ahze();
& Data Cub // keep original fonts
= Uata Lubes CP_keepOrigFont();
& Report Parameters
&= \ariables

~ @@ Body
M Grid - CP_CoverPagePortrGrid
H Grid - CoverPageDetlPortGrid
~ [ Table - UserTable
B Header
[E Detail
B Footer
~ |2 Groups
[E Table Group - UserGroup
[ Table - CompanyUserTable
H Grid - CP_NoRowsPortrGrid
~ @@ MasterPages

Group Sections and Aggregates

One of the key features of any report is the ability to display summary, or aggregate, information. For
example, a sales report can show the overall sales total; sales subtotals by product type, region, or sales
representatives; average sales figures; or the highest and lowest sales figures.

The aggregates are usually created on a group.

To create a group:
1. Right-click the table, and click Insert Group on the shortcut menu.

2. In athe New Group dialog box, enter a group name, and select a key from the Group On drop-
down list as a simple column, or use the Expression Builder.

3. Ifitis the top most group, enter a Table of Contents (TOC) expression (generally, the same as
group key). If it is the inner group clear, the TOC value as the TOC should be provided at the top

most group level.
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i New Group =2
Group Details | b
Mame: Sort direction

ACCT ID_GRP @ Ascending
Group On: () Descending
n Page break
Before: [Auto V]
CHG_HRS
EMPL_ID After: | Auto -
ERROR_MSG_DESC
LAB_CST_AMT Inside: | Auto v
LAST_FIRST_MAME
PAY_'_I'YPE - Repeat Header
5 TS _TYPE_CD
TAX_FREQ CD
TS_DT
ETs_HDR_sEQ MO FAR |
Table of Contents
Item Expression:  row["ACCT_ID"] H
Style: ’ v]
Filters and Sorting
Filters | Sarting
Filter by: Bemove | |Edit..| | MoveUp| | Move Down
Expression Operator Valuel Value 2

To create an aggregate:

1. Click the Table Binding tab, and click Add Aggregate.

2. Enter a name in the Column Binding Name field, and select an aggregate function from the
Function drop-down list.

= Aggregation Builder

Column Binding Mame:
Display Mame ID:
Display Name:

Data Type:

Function:

Expression:

Filter Condition:

Aggregate On:

©)

Column2TGA
|Float -
[sumM -
dataSetRow|"'nColumn2"] -

dataSetRow["nSubTotTypeMo"]

(") Table

@ Group ’sGen BreakGroup

’]

»

Lo

Cancel
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Examples of aggregate expressions:
= dataSetRow["nColumn2"]
= dataSetRow['nColumn2"] / dataSetRow["nColumn3"]

= dataSetRow['nColumn2"] * (CP_getParmInt("PN_SELECT _NO")==071:0) -
dataSetRow["'nColumn3"]

Examples of filter conditions:
= dataSetRow["'nSubTotTypeNo"] == 10
= dataSetRow['nSubTotTypeNo"] > 1
= dataSetRow['nSubTotTypeNo"] >=2 && dataSetRow['nSubTotTypeNo"] <=5

When you divide aggregates (or any numbers), Deltek recommends that you use CP_safeDivide(n1, n2,
nifn2lsZero).

Handling "No Data Found"

When a report has no data to process, the generic message "NO ROWS FOUND THAT MEET
SELECTION CRITERIA" should be printed on a report page. This is handled by the system libraries
through cp_presentation.rptlibrary » CP_NoRowsPortrGrid and CP_NoRowsLandGrid. The appropriate
(landscape or portrait) CP_NoRows Grid should be used after each report section (table object) in the
report design.

File Edit Insert Element Data Page Navigate Search Project Run Window Help

Oy EoidU iBviQeiodvidiy i vOOw > Qu
% Navigator 5= Outline X | =+ Palette ¥ = B B *syrustrptdesign &
~ By syrust.rptdesign _ P B S S B N L A SN N T A SRS = S
& Data Sources Vorkflow Email:
& Data Sets Send Workflow Activity: | |(EMAIL WE ACTVTY FL]
= Data Cubes E [Fona Workziow Wonzage:  |[[mmis we wse_ru1
= Report Parameters Email Name: [EMAIL_NAME]
& Variables
~ & Body N Company Infermation:
H rid - CP_CoverpagePortrGrid Company : [COMPANY_ID] [COMPANY_NAME]
H Grid - CoverPageDetlPortGrid 2
= Org Security Group: [ORG_SEC_GRE_CD] [ORG_SEC_GRF_NAME]
EH Table - UserTable :
Def. Taxable Entity: [DFLT_TAXBLE_ENT_ID] ||[TAXBLE_ENTITY NAME]
I—m“‘“‘u‘ﬂ*'hl Data Suppression:
H Grid - CP_NoRowsPortrGrid -
Labor: [SUBPRESS_LASOR]
- g
Price: SUPPRESS_PRICE
O Simple Master Page - CP_CoverPage m rice L e !
O Simple Master Page - CP_ReportBody ] Cost e )
= Styles 1 N [5UPPRESS SaN1
= Embedded Images . NO ROWS FOUND THAT MEET SELECTION CRITERTA
& Libraries o
& Scripts

Layout| Master Page | Script| XML Source

When the report layout requires you to have a table header (for example, table wide column headers)
and/or table footer (for example, report totals) row(s), these rows should have a Table » Header (Footer)
» Row » Visibility formula set to |CP_reportDataFound( ). Failure to add the formula will result in Table
Header/Footer Row(s) showing when report has no data.
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File Edit Insert Element Data Page Navigate Search Project Run Window Help

iwh S| B Rvic gy

5= Outline

S ERE RS

=0

~ M) fapaexp.rptdesign ~

& Data Sources
&= Data Sets
& Data Cubes
& Report Parameters
& Variables
~ = Body
I Grid - CP_CoverPagelandGrid
H Grid - CoverPageDetilandGrid
~ [ Table - FixedAssetsDetailReport_LandTbl
~ B Header
v [ Row
H Grid
[El Detail
B Footer
[S Groups
H Grid - CP_NoRowsLandGrid
HI Grid - CP_PageBreak
[ Table - FixedAssetDisposalEditRpt_PortTbl
HI Grid - CP_NoRowsPortrGrid
w MasterPages
= Styles v

it Resource Explorer &2 $ v=8

[ fapaexp.rptdesign £2
Fite Name:

Overwrite File: Yes/No Label

Bacon 1o rmaTom Ty

Tag No Short Description

- Row Asset No Ttem
~ o e
. [=1/| (HarGrp_assSET_Acc...]

Temgflate No

|'1=2]rsuporo asser oro...1
Layout| Master Page| Script| XML Source

E¥ Property Editor - Row 2 | [C] Properties [2] Problems
Properties| Map | Highlights

General Visibility
Border
o Bea [ Hide Element
@ Forall outputs
S00K K O For specific outputs...
User Properties etall outputs,

Named Expressions Expression: | ICP_reportDataFound( )
Event Handler

Advanced

i

You add this formula only for Table Header and/or Table Footer rows. If you do not use the Table Header
or Footer rows and, for instance, you have Column Headers placed in a Group Header, then you don't

have to add the formula.

Multiple Report Sections in One Template (Posting

Applications)

You can print several tables in a sequence. The processing for a subsequent table starts after the
previous one finishes, and so on. You can build a sequential report by placing multiple tables one after

another.

Table Object

When you insert a new table object in the report, always set the Table » Properties (Advanced) » Sort
By Groups to false. This will disable re-sorting of the data (BIRT default behavior). The Costpoint data is

already pre-sorted through SQL.
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[ Grid - CoverPageDetlLandGrid
[ Table - DataSetLandThl

% Grid - CP_MoRowsLandGrid
MasterPages

Styles

Embedded Images
cp_components.CP_Theme
Libraries

Scripts

ce Explorer 3 I [8 Data Explorer

tem Resources

Flash Object Library
readme it

ared Resources

template

cp_build.js
cp_compaonents.rptlibrary
cp_control js
cp_presentation.rptlibrary
cp_utils.js

~

15t Sort Job/JobGroup Label
Page Break- Yes/No Label
g1 | 2eb:] [tadeb1a Group: | [sJobGroupl
Description: [=JobDescription]
= Creator's User ID: |[sCreatorUserld]
=1
Commenta: [=Cormenta]
=1 Seq Module Application Hame
El | [tnseqter [=ModuleName] [sApphzme]
=1

Layout | Master Page ‘ Script KMLSour:e| Pra!\ew‘ Desktop Viewer (pmtotype)|

Property Editor - Table w’ 2k Prob\ems| =3 Progrss| @] Error Log |

Table

Property Value
Page break interval 40 : Inherited
Push down true : Inherited
Repeat header true : Inherited
Report Item
Section
Shrink false : Inherited
Sort by groups ad
Style
Summary

In Table » Property Editor - Table » Properties » Page Break, set Page Break Interval to 0.

Grid - CoverPageDetlPortGrid
Table - DataSetPortrThl

% Grid - CP_CoverPagePortrGrid U

[E] Header
[0 Row
[ Cell
iR Grid
L[ Row
] Cell
Label - CP_LabelCntll
] Cell
Label - CP_LabelCntl2
1 el 32
< Explorer 3 | @ ¥ =0

em Resources

Flash Object Library
eadme bt

ed Resources

template

cp_build.js
cp_components.rptlibrary
cp_contral,js
cp_presentation.rptlibrary
cp_utils js

@

B State/Province

[E1] country:

[ [State Name]

T

[COUNTR [COUNIRY NAME]

HO ROWS

FOUND THAT MEET SELECTION CRITERIJ

[City]

Laygut | Master Page | Script| XML Source Pre!\ewl Desktop Viewer (prototype)l

[

=] Propertis‘ Ei Pmblems‘ =3 Progrss‘ @ Error Log|

roperties | Binding | Groups| Map | Highlights | Sarting | Filters

General

Border

Margin

Page Break

Visibility Master Page: | CP_ReportBody

Page Break
Before: | Auto - ‘ After:
Inside: | Auto

52 ‘ Page Break Interval: ‘ |

= ‘ [¥] Repeat Header

The appropriate (landscape or portrait) CP_NoRows Grid should be used after each report section (table
object) in the report design. For example, if you have two report sections in the report, then you must
have two table objects and two CP_NoRows Grids following each table object.

When you need to have a page break in between report sections (table objects), do not set the page
break at the table level. Instead drag CP_PageBreak component from cp_components.rptlibrary and
insert it right after CP_NoRows Grid for each table in report design.

Go to CP_PageBreak Grid » Properties » Page Break, and assign a master page property to the same
page that is used by the table object just before the CP_PageBreak component.
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File Edit Insert Element Data Page Navigate Search Project Run Window Help

m P B e 2 Rt R el o -
©. Navigator & Outline &2 =¥ Palette ® Y= 0O B *gyrusr.rptdesign B\ *cpreust.rptdesign ﬂ,fapaexp.rpldeswgn b9
~ B fapaexp.rptdesign RN 1. 2 3 4 S 6

> i@ Data Sources

> @ Data Sets
i Data Cubes
& Report Parameters .._..
&= Variables

« i Body N ==
» H Grid - CP_CoverPagelandGrid -
» M Grid - CoverPageDetlLandGrid e
: g E::: *CFPI)(:?]QZj?LZ:;EGﬂ:;pDl't_lﬁndTbl Layout| Master Page‘ Script|ZML Source|

[ Grid - CP_PageBreak [ Property Editor - Grid 22 | [ Properties (2] Problems

aA DAME meinm moam wmmm oewmr

» [ Table - FixedAssetDisposalEditRpt_PortTbl Properties Eindlng‘Map|Highlights|
> HI Grid - CP_NoRowsPortrGrid
» @ MasterPages General Page Break
7 = Styles Border Before: ‘Auto v ‘ After: |Always ~

& Embedded Images Maroio R
B Ml it 0 v
> = Scripts Vb

Master Page:  FADetailPage_Land v I

Table of Contents
Bookmark
Comments

- . . & = o= = llzar Pranarties

Page Layout

You can create a page object of different size, margins, and page layout (landscape or portrait) and then
assign this page to a table object in table properties/page break/Master Page.

In case of multiple report sections and different page settings, you may need to create additional page
objects and place standard Costpoint page headers/footers onto new pages.

To create a new object, right-click Master Pages in the Outline view, and click Insert Element on the
shortcut menu. Rename the object, and change the page settings if needed.

The default height of the standard Costpoint Header is 1 inch. The default height of the standard
Costpoint footer is 0.6 inch.

Outline m\ @~ =0 vertical.rptdesign [ syrpost.rptdesign 2@]
Ai\ P I S R R S IR 4 5 6 T 8o
Pages
mple Master Page - CP_CoverPage
mple Master Page - CP_ReportBody [cP_companyName]
Header .
[ Grid - CP_PageHdrPortrGrid - = Enter Report Title Here Page N of 1
O Row B — — [CB_BuildDate
- [CP_AddReportInfo] -
[ Row B B = e
O Cel Al -
] Grid Tl -
0 Row .
[ Cell .
O cell
i Grid
0 Row
71 Row .
O cell "
B Data(CPLi || -
1 cell | I
m » .
o g-en)|:
cources P
bject Library M
et
sources
ate N
ild js Layout | Master Page | Script | XML Source | Preview| Desktop Viewer (prototype) |
;:r:::ms‘rptllb'w = Pmpema;‘ [ Pmb\ams‘ o5 Prngrassl @] Error Log‘
sentation.rptiibrary Properties
ta Sources
o sets General General
e o[ e
port Parameters E{| Margin
“;:;‘_E::_CWHPagﬂmﬁm Header/Footer Header height: |11 lin < Backgoundeoler [1JAwte -]
Grid - CP_CoverPagePortrGrid Comments Footer height: Ojentation:
Grid - CP_NoRowsLand6rid Advanced
Grid - CP_NoRowsPortrGrid Width: |85 [in =] Type (USletter -
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Insert standard Costpoint page header/footer objects from cp_presenation.rptlibrary into the new page by
dragging page header/footer objects from the library directly into Outline » CP_ReportBody page »
Header/Footer.

The new page object should be correctly mapped to your table object in the report design. Switch to
Layout view, and in Outline » Body, locate the table object that should display data for different report
sections. Go to Table » Property Editor » Page Break, and change the master page to the newly
created page. The result is that all data that goes into the above table will be displayed on a page with
possibly different layout margins, headers and footers.

File Edit Insert Element Data Page Navigate Search Project Run Window Help

Oy @e:dU By Qeinfriviy ilvt O v
2= Qutline &2 T T O Bu*syrusriptdesign @
« B\ syrust.rptdesign LR 1 : 2 R 5 7 2
= N Password: [CHANGE_PASSWORD]
& Data Sources =
Nane: CHANGE_NAME
& Data Sets L ]
& Data Cubes ) Phone: [CHANGE_PHONE]
& Report Parameters Default Company: [CHG_DFLT_COMP_FL]
&= Variables Email Notification: [CHG_PRC_NOTIFY FL]
~ i Body Workflow Email:
H Grid - CP_CoverPagePortrGrid
Send Workflow Activity: [EMATL_WF_ACTVTY_FL]

H] Grid - CoverPageDetlPortGrid o
i Send Workelow Message: [EMAIL_WE 145G _F1)
——

T OTeTT

Email Name: DMAIL NAME

[ Table - CompanyUserTable ail Name [EMATL NAME]
id P NORowsD Layout| Master Page | Script| XML Source

El Grid NoRowsPort

~ & MasterPages E# Property Editor - Table 2 | (] Properties (2] Problems
Bsi .
Simple Master Page - CP_CoverPage Properties| Binding | Groups| Map | Highlights| Sorting| Filters
O Simple Master Page - CP_ReportBody

O Simple Master Page - NewMasterPage General Page Break
= Styles
=y Border Before: Auto v| After Auto v
& Embedded Images e
&= Libraries g Inside: Auto v Page Break Interval: | 0
= o Page Break
= Scripts
Visibility Master Page: | NewMasterPage v | [ Repeat Header
None

Table of Contents CP_CoverPage

Bookmark CP_ReportBody
Comments

%
4
1

o

i Resource Explorer &

~ @ Shared Resources User Properties
—_— Narmar £

Presenting Text

A report typically presents most of its information in a textual format. Textual information can be any of the
following:

= Static text: Labels, column headers, report title. This data is subject to localization, language
translation, and CP terms translation. Use only CP_LabelCntl and CP_LabelYesNoCntl.

= Mixture of static text and data values supported by the system: Range text, NCR range text, text
list, page N of M, and total Page Count.... Use specially provided controls such as
CP_RangeCntl, CP_NCRRangeCntl, CP_ListCntl, CP_PageNofMCntl,
CP_PageNofMRestartCntl, and CP_TotalPage.

= Dynamic text data to present Data Set fields: dataSetRow["COMPANY_ID"],
dataSetRow["USER_ID"].... Use CP_TextCntl control.

= Mixture of dynamic data that is subject to localization, language translation and CP terms
translation: [static text] + [text] + [date/time] + [number] + .... For any of these, use CP_iTextCntl
control and CP_...IText functions to present data within the control (for example,
CP_Translatel Text("Project End Date:") +
CP_TranslatelTextDateTime(dataSetRow["PROJ_END_ DT"], "CP_DateCnlt").

Text wrapping:

By default, all text data is wrapped onto multiple lines in case it does not fit within the control or grid/table
boundaries. The text line breaks by the whitespace and is controlled by the Control » Properties »
Advanced » Text » Whitespace setting. The default value is Normal. You can turn off text wrapping by
changing the setting to No Wrapping.
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44 Ui - U _rayeuican

[ Table - FixedAssetDi |EditRot PortTbl Format Number On create CP_TextCntlOnCreate(this); : Inherited
v able - FixedAssetDisposalEdi
B Header P P Format DateTime On page break CP_TextCntlOnPageBreak(this); : Inherited
 Detail Format String On prepare CP_TextCntlOnPrepare(this); : Inherited
~ etai
_ On render CP_TextCntlOnRender(this); : Inherited
0 R Hyperlink
~ ow
Order
~ O Cell
E;G id LegeBrenc Overflow Hidden : Inherited
it Visibility PDF tag type p : Inherited
~ [ Row
e Table of Contents Push down true : Inherited
-
Result set column CP_TextCntl : Inherited
L € Data(CP_TextCntl) - CP_TextCntl_AssetiD I Ecokmark o -
—— Comments ection
= Shrink false : Inherited
O cell v User Properties
Named Expressions. -
[ Resource Explorer 2 & v=08 P ~ Text
& Shared Resources Letter spacing Normal : Inherited
& common Advanced Line height MNormal : Inherited
& template Orphans 2 : Inherited
[ cp_buildjs Text alignment Left : Inherited
B cp_components.rptlibrary Text direction Auto
[£ cp_controljs Text transform No Transformation : Inherited
B cp_presentation.rptlibrary Vertical alignment Middle : Inherited
2 cp_utilsjs Whitespace Normal v
Widows
Word spacing No Wrapping
Theme
Width Preformatted
TRaeX T Imen

In addition to whitespace wrapping of text, you can use the CP_WrapText(text, nchars) function to wrap
the text based on a number of characters as well as the whitespaces.

I EXpEEIOn BUaEr [JEVESEApt]
Expression Builder

4 '.‘ u
| CP_wrapText(dataSetRow["NOTES™], L |

W =

1

Operatars:

Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your expression.

e [EE

S |

—

—
=

ojninin

Display Page Header » Report Title Based on Current DataSet Row

Variable

There are a few cases (limited to some reports) when you need to display the report title on the page
header where the text of the report title depends on the value of the current DataSet row variable.

In order to do that, you have to use a BIRT page variable and override the onRender() method for the
Page Header » Report Title label control.

1.

Add a new page variable in Outline » Variables » New Variable » Page Variable.
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= Report Design - C:\costpointweb\70\dev\apps\com'\deltekienterprise\application\sy\syrusrrpt\syrusr.rptdesign - Eclipse
File Edit Insert Element Data Page Navigate Search Project Run Window Help

O HRE Qo i ooy Nk

@ -
%5 Navigator [ O Qutline £3 ] Pa\ette] @~ °=0 syrusrrptdesign £2 pipobt.rptdesign W
syrusr.rptdesign - I 2 3o 40 5
(g Data Sources
(= Data Sets

[ Data Cubes
(43 Report Parameters
(5 Variables
[fy Py_USERID
[ Body
@ Grid - CP_CoverPagePoertrGrid
[ Grid - CoverPageDetlPortGrid
=] Table - UserTable
= Table - CompanyUserTable
[E] Header
[] Detail
[E Footer
[S Groups
[E] Table Group - CompanyGroup

[cP_CompanyName

& User Report

_—

[CP_AddReportInfo]

Edit Variable

[E] Table Group - UserGroup Type: () Report Variable @ Page Variable
[£ Header -
T Row Name: PV_USER._ID|
[ Cel Default Value:
[ Grid
O Row (|
[ Cell

Grid N -

m o Row Property Editor - Variable @ [ o J[ camcel |

[ Cell Properties
0 friel |

2. Name the variable using the following naming convention: the variable name should be
uppercase and should start with PV__ prefix (for example, PV_USER_ID).

3. Set the value of the page variable by overriding the onPageBreak() method for the control that
displays the DataSet data that you want to use in the page header.

Note: If such a control is not there or should not be in the report by design, you need to
create a dummy table/grid row, put a dummy control on that row, set control value, and make
sure that this dummy control's parent row is hidden through:

= overridden Row>Scrip>OnRender() method>this.getStyle().setVisibleFormat("all");

= overridden Row>Scrip>OnCreate() method>this.height = "0in";

Do not hide the row or control using the Hide Element check box or set the row height to 0’. Use
the setVisibleFormat("all") approach only.

. [= fapvudcd.rptdesign ]

Script: ’onRender v” "| S @
this.getStyle().setVisibleFormat("all");

| &l syrusr.rptdesign | [E] ColumnarReportNewspaperStyle.rptdesign

Script: ’ onCreate - ] |

this.height = "B8in";
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The control's onPageBreak() method should be overridden to set the page variable value. For
example:

reportContext.setPageVariable ("PV_USER ID", this.getValue());

it Page Mavigate Search Project Bun  Window Help
=] LN R =R - v ¥S oo -

gator | o= Outline &2 2 Palette & - O syrusr.rptdesign £ pipobt.rptdesign
yrusr.rptdesign
') Data Sources

e Script: [onPageEreak v] = B @

1= Data Sets reportContext.setPageVariable("PV_USER_ID", this.getValue());
il Data Cubes

{3 Report Parameters
Variables
[F PV_USERID
Body

EH Grid - D ruerDaneDarkeErid

CP_TextCntlOnPageBreak(this);

m

4. Go to Master Page » CP_ReportBodyPage » Report Title Label, and override the onRender()
method based on the value of the page variable created in the earlier steps

Inside the onRender() script, access the Page Variable value through the
reportContext.getPageVariable() function. For example:

CP_LabelCntlOnRender (this);

this.setText (CP_TranslatelIText ("Data for User ID:") + " " +
reportContext.getPageVariable ("PV_USER ID"));

) syruserptdesign L
Seript: [caRender ': - u (@ Label
CP_LabelCntlOnRender(this);

thi'i.s{tTcxt{l‘.P_Trﬂnf.]at{ITﬂct(‘Datﬂ for User ID:") + © ° # r:porttqntnct.gﬂ;?ﬂst'."ariab].g('F'.'._Uﬁf:l_.]n']];

Note: Always use the CP_TranslatelText() method for static text and labels. You can use
other CP_TranslatelText functions to format:

= Date/time: (CP_TranslatelTextDateTime())
= Numbers: (CP_TranslatelTextNumber())

= Currencies: (CP_TranslatelTextCurrency).

Localization and I18n

Costpoint reports can be printed in different locales. All localization and i18n processing and formatting
occurs at report rendering (view) time. This allows you to generate the report once, but render it
differently based on different locale rules.

What Is Subject to Localization in Costpoint Reports

= Labels (text, text ranges)
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= Date/Time controls

= Numeric controls (Integer, Decimal)
= Currency Controls

= TOC labels

Displaying Text

All static text and labels in a report have to be localized and translated. You must use the CP_LabelCntl
control that provides multi-language translation. You always use the standard CP_TextCntl controls for
data that does not require multi-language translation.

Labels can have a single display value or multiple display values; one of which will be picked based on a
condition.

To create a single display value label, drag CP_LabelCntl from the library, and rename the label text.

To create a multiple display values label, drag CP_LabelCntl from the library, and in the Advanced
Properties, set the values for:

= CP_DataValue (expression)
= CP_DataValues (~ separated list of data values)

= CP_DisplayValues (~ separated list of display values)

General AOvancea
Padding p Val
ro
Border perty aue
- Bookmark
harip Bookmark display name
Hyperlink Box
Page Break Comments
Visibility Content Column 2 Label
Localizati Content key
eealzation CP_DataValue var selection = CP_getParmstring("PN_COLUMN2"):
el kConicnis CP_DataValues 0-1-2~3~4~5-6~7-8~9-10~11~12-13~14~15-16~17~18~19-20~21~22-
Bookmark CP_DisplayValues (Mone)~Current Period Actual~Current Period Budget~Current Period Variz
Comments CP_Localeld
User Properties C.ustom AML
- Display name
Mamed Expressions Di
isplay name key
Event Handler Event handler class
Advanced Font

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

Dictionary Terms

There are common terms that users would like to customize according to their practice. For example, a
customer would like to use the term Department instead of Organization, Client instead of Customer,
and so on. These terms are scattered throughout the product. They appear on the screen in labels, menu
items, status help text, messages, and so on as well as on reports as titles, headings, and so on.

There are seven terms—Project, Organization, Account, Vendor, Customer, Employee, and
Warehouse—that are defined with the following term IDs: PROJ, ORG, ACCT, VEND, CUST, EMPL, and
WHSE.

Extensibility Designer Report Guide 59



Deltek

Guidelines and References

Each term has Singular, Plural, Singular Abbreviation, and Plural Abbreviation forms. For each
occurrence of the term in metadata (display title, status text, messages, and so on) or report labels, the
following syntax is used:

= Singular: &CPT.TERM_ID&
=  Plural: &CPTP.TERM_ID&
= Singular Abbreviation: &CPTS.TERM_ID&
=  Plural Abbreviation: &CPTSP.TERM_ID&
For example:
= Old label: “Organization:”: New syntax: “&CPT.ORG&:”
= Old label: "Projects:": New syntax: "&« CPTP.PROJ&:”

Since the very same report can be viewed and printed in different locales and languages, you should take
caution when concatenating and presenting data of different types in one control.

For example, assume you want to show a static text “For Subperiod Ending” concatenated with the date
value 01/01/2000. If you place both items in one control and concatenate them, then at view time, the text
will not be translated properly and the date value will not be formatted according to the runtime locale.

Use the CP_iTextCntl control to address the above case. The CP_iTextCntl control can combine static
text data with dynamic data. You must use special functions in controls value Expression:

= CP_TranslatelText(text)

= CP_TranslatelTextDateTime(value, format)

= CP_TranslatelTextCurrency(value, format, currencyCd)
= CP_TranslatelTextNumber(value, format)

= CP_TranslatelTextRange(rangeCd, from, to)

= CP_TranslatelTextRange(rangeCd, from, to)

= CP_TranslatelTextCustomRange(rangeCd, from, to, displayValues, dataValues)
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= Expression Builder (JavaScript) = @

Expression Builder

Type an expression in the Expression field. Browse the lists of available objects and double-click to copy into your expression.

BxX I BaE
1IP_TranslatelText("Fiscal Year:") + " " + CP_getParmString("FY_CD") + CP_getLineBreak( + CP_TranslatelTextRange(CP_getParmstring("USR_ID_RANGE"), CP_getParmint("FR") =

< . 3

Operators: BB BB mm

Category: Sub-Category: Double Click to insert: 1%

Available Column Bindings
Mative JavaScript Functions
BIRT Functions

Operators

('_):\ [ oK ] I Cancel

Use the CP_getLineBreak() function to break the new line within a CP_iTextCntl control.

Example:

CP_TranslateIText ("Fiscal Year:") + " " + CP getParmString("FY CD") +
CP _getLineBreak () + CP TranslateITextRange (CP getParmString("USR ID RANGE"),
CP_getParmString ("FR"), CP_getParmString("TO"))

Text Ranges

Use CP_RangeCntl and CP_NCRRangeCntl controls to display text ranges. CP_RangeCntl - set
CP_DataValue Expression for Range Code, CP_RangeFrom and CP_RangeTo Expressions to set
Range From and To values. CP_NCRRangeCntl - set CP_NCRResultSetld value to identify NCR Result
Set

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

Displaying Date/Time

The format for dates and times is locale specific. The following controls provide this functionality:
= CP_DateCntl
= CP_DateTimeCntl
=  CP_TimeCntl

In addition, you can use CP_DateCntl, CP_DateTimeCntl, and CP_TimeCntl constants as format masks
in conversion functions. For example:
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CP_translatelITextDateTime (row["MY DATE"], "CP_DateTimeCntl")

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

Displaying Numbers
The format for numbers is locale specific. The following controls provide this functionality:
=  CP_IntCntl
=  CP_IntNoThouCntl
= CP_DecimalCntl
= CP_DecimalNoThouCntl
= CP_PercentCntl
= CP_RateCntl

In addition you cany use CP_IntCntl, CP_IntNoThouCntl, CP_DecimalCntl, CP_DecimalNoThouCntl, and
CP_PercentCntl, CP_RateCntl constants as format masks in conversion functions. Fopr example:

CP_translateITextNumber (row["MY AMT"], "CP DecimalCntl")

For reports where locale is data-driven (coming from RS data), set CP_Localeld expression (for example,
row["LOCALE_ID"].

Within the CP_Format property, you can use custom format masks to override default formatting (for
example, "0.000000", "#,##0.0000000").

Change the CP_DecimalDigits property to override the default formatting in regards to the number of
decimal digits.

ayout | Master Page | Script | XML Source | Preview

& Property Editor - Data | = Properties 23 [£ Problems| Bl Console

Data
Property Value
4 Data
Allow export true : Inherited
- Background
Bookmark

Bookmark display name
. Box
Comments
CP_DecimalDigits g
CP_Format (CP_getParmBoolean("SHOW_AS_PERCENT") 7 "CP_PercentCntl" : "0.0000000")
CP_Localeld
Custom XML
Data binding reference
Data set
Display name
Display name key
Event handler class
- Font
. Format
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Displaying Currency
The format for currency data is locale specific. The following controls provide this functionality:
= CP_CurrencyCntl
= CP_CurrencyNoDecCntl
= CP_CurrencyNoDecNoSymbCntl
= CP_CurrencyNoDecNoSymbNoThouCntl
= CP_CurrencyNoDecNoThouCntl
=  CP_CurrencyNoSymbCntl
=  CP_CurrencyNoSymbNoThouCntl
=  CP_CurrencyNoThouCntl

In addition you can use CP_CurrencyCntl, CP_CurrencyNoDecCntl, CP_CurrencyNoDecNoSymbCntl,
CP_CurrencyNoDecNoSymbNoThouCntl, CP_CurrencyNoDecNoThouCntl, CP_CurrencyNoSymbCntl,
CP_CurrencyNoSymbNoThouCntl, and CP_CurrencyNoThouCntl constants as format masks in
conversion functions. For example:

CP translatelITextCurrency (row["MY AMT"], "CP CurrencyCntl")

CP translateITextCurrency (row["MY AMT"], "CP CurrencyCntl", row["CURRN CD"])

For reports where locale is data-driven (coming from RS data), set the CP_Localeld expression (for
example, row["LOCALE_ID"]).

For reports where currency code is data-driven (coming from RS data), set the CP_CurrencyCd
expression (for example, row["CURRN_CD")).

Change the CP_DecimalDigits property to override the default formatting in regards to the number of
decimal digits.

Displaying TOC
For TOC text, use the CP_translateText(text) function. For example:

CP_translateText ("Project Status Report")

Image Controls

The following controls are provided to support images:
= CP_IlmageCntl: Basic image control

= CP_DynamiclmageCntl: Image control that allows you to load image files from Costpoint File
Locations.

= CP_CompanyLogoCntl: Image control for displaying a company logo image

The CP_DynamiclmageCntl control allows you to load image files stored in Costpoint File Locations. Set
the CP_AltFileLocation and CP_FileName Expression values.
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Advanced

Property
4 Image

Value

Allow export true : Inherited
Alternative text
Alternative text key

. Background

Bookmark

Bookmark display name

. Box

Comments

CP_AltFileLocation CP_getParmS5tring("FILE_LOC")

CP_FileMame [cP_getParmString("FILE_MAME") |:|
CP_StopReportOnErrer false : Inherited

Custom XML

Data binding reference

Data set

Display narme

Report Table of Contents

The Table of Contents (TOC) allows users to proceed directly to a specific report item in Preview mode.

Follow these rules to code the TOC:

The Cover Page is not part of the TOC

The Report Section title is part of the TOC. If there are multiple report sections (for example,
posting reports), then there will be multiple top-level report titles in the TOC.

Under the Report Section, a developer should look for primary group by/sort by logical keys and
not go for inner groups down the tree requested by Design. A label should not be used at this
level. For example, if the break group key is PROJ_ID, then a developer should use just the key
value in the TOC, but not the key value pre-pended by a label (for example, 1003 instead of
Project 1003).

For hard coded (static) text or CP terms, use the CP_TranslateText(value) function. For
example:

= CP_TranslateText("Project Status Report")
= CP_TranslateText("& CPT.EMPL& Salary Report")

For formatted date/time and numbers, use the CP_toString(value, format) function. For
example:

= CP_toString(row["MY_DT"], "CP_DateCntl"),
= CP_toString(row["VOUCHER_NO"], "CP_IntCntl")

For skipping a TOC level in your report, leave the TOC expression blank for the report
section/group that you need to skip.
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Utility functions

The cp_utils.js file contains the list of public functions that can be used by report developers. Check the
cp_ultils.js file for complete list of functions and descriptions of each.

Here is a list of the most useful functions:
= CP_getParm... (name): Returns a parameter value specified by name
= CP_getConstant...(name): Returns a constant value specified by name

= CP_TranslatelText...(value[, format, currencyCd]): Concatenates and translates text, number,
and currency date/time values for the CP_iTextCntl control

= CP_RemoveTableFromBuild(tableName): Removes a Table Object froma report build.
Override *.rptdesign beforyFactory to call this function.

= CP_removeCellStyle(objName, row, column): Removes cell style dynamically. Override
*.rptdesign beforyFactory to call this function.

= CP_TranslateText(value): Used for TOC text translation.

Warning: Do not use inside CP_iTextCntl!

= CP_toString(value, format): Used to format TOC date/time/number at report execution time.
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