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Overview

Overview

Use this guide to learn how to set up MasterSpec styles for your project specification sections in DOCX
format through Microsoft® Word.

You can set up MasterSpec styles in the following ways:

oo

Import MasterSpec Import MasterSpec styles from the template file into Word. This enables you to
Styles replace existing styles in your specification section document with the
MasterSpec styles.

Attach as Document Through developer options, attach the MasterSpec template file as a
Template document template. This enables you to apply these styles to each paragraph
in your specification section document.

Adding Custom Notes to This Guide

If you would like to add custom notes to this guide that are specific to your company, Adobe® Reader® X
provides this ability. If you do not already use Adobe Reader X, you can download it here free from
Adobe.
To add a custom note using Adobe Reader X, complete the following steps:
1. On the Reader toolbar, click Comment at the far right.
2. In the Annotations pane that displays, click Q Sticky Note. The cursor changes to match the
button.

3. Position the cursor at the location in the guide where you want the note to appear, and click. A
note icon is inserted at the location and a text box pops up.

4. Enter your information in the text box.
Continue adding notes as needed.

Save the document.

Note: Deltek recommends that you save the document to a slightly different filename so as to keep
the original from being overwritten.

When reading the document, cursor over a note icon to see the information. Double-click a note icon to
edit the information.
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Option 1: Import MasterSpec Styles from the Template into Word

Option 1: Import MasterSpec Styles from the
Template into Word

Import MasterSpec styles from the MasterSpec template file to use these files in Word, and apply these
styles to your specification section content.

To import MasterSpec style from the template into Word:

1. In Microsoft Word, open a specification section.

2. On the Home tab of the ribbon, click in Styles to open the Styles window.

Add-ins Help BLUEBEAM MW WTools MasterWorks

~
AaBbCcI M AaBbCcLl 4aBbCcl Aa'j AaBbCcC@AaBbCcD AaBbCeD | AaBbCcD: | AaBbCcDt i
Sensitivity TMaormal @7 Mo Spac... Title Subtitle @Subtle Em...l Emphasis @ Intense E... Stron =
=

n  Sensitivity Styles §

3. Inthe Styles window, click to manage styles.

Clear All
ART

CMT
EOS
Header
Heading 1
Hyperlink
P
MNarmal
NUM
OMN
PR1

FR2

FR3

R R R R N - B I I [ ~] [ N R R - B - T I -

Show Preview

Disable lLinkad Stylec

Options...
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Option 1: Import MasterSpec Styles from the Template into Word

4. On the Edit tab of the Manage Styles window, select the Only in this document option.
Aanage Styles ? X
Edit Recommend  Restrict  Set Defaults

Sort order: | As Recommended w |:| Show recommended styles only

Select a style to edit

. wormal A

MNormal

d MUM

T OMN [AutoUpdate)
Ta pR1
Ta pr2

1 PR3
T PR4
9 PRS

Preview of Marmal:

Titmes New Roman g | Modify.. Delete

Font: [Default) Times New Roman, Left
Line spacing: single, Widow/Orphan control, Style: Shaow in the Styles
gallery

HNew Style...

I @ Only in this document OINE’W documents based on this template

Import/Export... Cancel
5. Click Import/Export....

pod

Edit Recommend  Restrict  Set Defaults
Sort order: | As Recommended v |:| Show recommended styles anly

Select a style to edit

MNormal

a NUM

T OMN [AutoUpdate)

Ta PR

7a pR2

T PR3

1 PR4

1 PRS

Ta PRN

T PRT v

wormal

Preview of Normal:

Times New Roman s | Modify.. Delete

Font: [Default) Times Mew Roman, Left
Line spacing: single, Widow/Orphan control, Style: Show in the Styles
gallery

MNew Style..,

@ Only in this document O MNew documents based on this template

Import/Expo Cancel
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Deltek

right column.

6. On the Styles tab of the Organizer window, click Close File for the In Normal list, which is the

Styles Macro Project [tems

In Template instructions:
ART ~ Copy
Balloon Text

CMT
Comment Reference L2l
Comment Subject
Comment Text

Default Paragraph Font
EQS

Styles available in:

Template instructions (Document)

Close File

Description

7. Click Open File....

Styles Macro Project ltems

In Template instructions:

A Copy
Balloon Text

CMT

Comment Reference Delete
Comment Subject
Comment Text

Default Paragraph Font
ECS

Styles available in:

Rename...

Template instructions [Document) e

Clase File

Description

Indent:
Left: O
Hanging: 0.6, Justified, Space

8.

Rename...

In Mormal:

X

ART

Default Paragraph Font
Mo List

Marmal

PR1

Table Normal

Styles available in:

Mormal.dotm [global template)

Close

S
Close File
? e

Styles available in:

In the file dialog box, search for and select the MS Final Word Template file.

e

COpen File...

Close

9. Select the style you want to copy from the In MS Final Word Template list and then click Copy.
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Styles Macro Praject [tems

To Template instructions: In M5 Final Word Template:
ART A A
Balloon Text Balloon Text
CMT CMT
Comment Reference Delete Comment Reference |
Comment Subject Comment Subject
Comment Text Rename... Comment Text
Default Paragraph Font Default Paragraph Font
EQS hd EOS v
Styles available in: es avallable in:
Template instructions [Document) v M5 Final Word Template (Template) ~
Close File Close File
Description
| Indent:
Left: O°

Hanging: 0.6°, Justified, Space

10. Click Close.

Modify Existing Styles

Modify an existing style that your section uses and replace it with a MasterSpec style from the template.
This enables you to format all content that uses a given style.

To modify an existing style:

1. In Microsoft Word, open the specification section.

2. On the Home tab of the ribbon, click in Styles to open the Styles window.

Add-ins Help BLUEBEAM MW WTools MasterWorks

N
AaBbhCcl fj AaBhCcL /{—\ ad B AaBbCcC@AaBbCcD: AaBbCcDi | AaBbCcD: | AaBbCcDt i
Sensitivity THormal @7 Mo Spac... Title Subtitle WSubtle Em...J Empha Intense E... Stron =

la Sensitivity Styles

3. In the Styles window, click to manage styles.
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Clear All
ART

CMT

EOS
Header
Heading 1
Hyperlink
IP
MNaormal

HUM

T
Ia
T
Ia
1a
a
a
T
i
T
Ta
1)
T
kil
kil
Ia
T
T
T
T
T
T
T

Show Preview
Disable ' =t Tiyles

Options...

4. On the Edit tab of the Manage Styles window, select a style to edit.

Edit Becommend  Restrict  Set Defaults

Sort order: | As Recommended ~ D Show recommended styles only

Select a style to edit

"
T4 PR2

T PR3

T PRY

T PRS

T2 PRI

T PRT

T s

T sut

T 181 v

——
Preview of PR1:

A Times New Roman Modify... Delete

11pt
Indent: -
Left: 0.2°
Hanging: 0.4°, Justified, Space
Before: 12 pt, Don't hyphenate, Level 3 b

Mew Style...

(®) Only in this document (O New documents based on this template

Import/Export... Cancel
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5. Click Modify....

T
3
L
m
m
=J

Edit Recommend  Restrict  Set Defaults
Sort order: | As Recommended e |:| Show recommended styles only

Select a style to edit

FR1 ~
T3 pR2
T PR3
T FR4
T PRS
T3 PRN
T PRT
T sCT
T suT
T TB1 v

Preview of PR1:

A Times New Roman 11 pt Delete

Indent: ~
Left: 0.2
Hanging: 0.4°, Justified, Space
Before: 12 pt, Don't hyphenate, Level 3 b
Mew Style...

@ Only in this document CI Mew documents based on this template
Import/Export... Cancel

6. Inthe Modify Style window, select a new style in the Style based on option.

Style ? X

Properties
Mame: PR1

Style based on: T Mormal

Formatting

Times New Romar|~-||11 |~|| B I U Automatic ~

(A1
i
+
1
£
|

! *
+ *

A Sample Text Sample Text Sample Text Sample Text Sample Text Sample Text Sample Text
Sample Text Sample Temt Sample Tent Sample Taxt Sample Text Sample Text Sample Text
Sample Text Sample Text Sample Text Sample Text Sample Tt Sample Text Sample Text

Indent: -
Left: 0.2
Hanging: 047, Justified, Space
Before: 12 pt, Don't hyphenate, Level 3 A

|:| Add to the Styles gallery |:| Automatically update
@ Only in this document O Mew documents based on this template

Format = Cancel
7. Click OK.
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Option 2: Apply MasterSpec Styles through
Document Templates

Use an attached document template to apply styles from the template to your specification section
content.

To apply MasterSpec styles through Document Templates:

1. In Microsoft Word, verify that the Developer tab is available on the ribbon.

Add-ins Help

Sensitivity

Paragraph 3 Sensitivity

To display the Developer tab, see Display the Developer Tab.
2. On the ribbon, click the Developer tab.

On the Developer tab, click Document Template.
Developer Add-ins Help BLUEBEAM WAV W

B K & 4@
ML Mapping
Pane

Block Restrict  Document
Authars ~ Editing Template

Mapping Protect Templates

On the Templates tab of the Templates and Add-ins window, attach a document template:
a. Click Attach.

Templates  MML Schema XML Expansion Packs  Linked C55

Document template

|:| Automatically update document styles

Attach to all new e-mail messages
Global templates and add-ins

Checked items are currently loaded.

MWaorks11.dotm

Add...
Spechgent.dotm
UserSustain.dotrn Remove
[l WT sustain.dotm

Full path: G\ O\Root\Office 16\STARTUPMWorks11.dotm

Organizer... Cancel
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b. Inthe Attach Template dialog box, search for and select the template file.
c. Onthe Templates tab, select Automatically update document styles.
d. Click OK.

This automatically applies the styles and may change the styles in your specification section.

5. On the Home tab of the ribbon, click in Styles to open the Styles window.

Add-ins Help BLUEBEAM MW WTools MasterWorks

~
AaBE AaBbCcht

Sensitivity

Intensze E...

n  Sensitivity
6. Set paragraphs styles.
For each paragraph:

a. Click a paragraph in your specification content.

PART 1 - GENERAL Clear Al
ANT

11 SUMMARY RT
CMT

A____ Section includes historic treatment of wood in the form of repairing wood features as follows

Repairing wood [paneling] [built-in shelving] [mantles] [columns] [railings] [and] pst
[trim] <Insert item:>. EOS

L R ] R - I B R R |

FTR
[trim] <Insert item>_ HOR
3. Repairing, refinishing, and replacing hardware
4
B.  Related Requirements: NAM
. . . . N |
Retain subparagraphs below to cross-reference requirements Contractor might expect to find in this orm
Section but are specified in other Sections. NUM
PRI
1. Section 013591 "Historic Treatment Procedures” for general historic treatment e ]
requirements
2. Section 024296 "Historic Removal and Dismantling” for historic removal and PR3
dismantling work. PR

3. Section 080314 "Historic Treatment of Wood Doors" for historic wood door repairs

b. In the Styles window, click the style that you want to apply.

PART | - GENERAL

m
- T
11 SUMMARY
1a
A Section includes historic treatment of wood in the form of repairing woed features as follows
41 Repainng wood [paneling] [built-in shelving] [mantles] [columns] [railings] [and]
[trim] <Insert item=.
2. Replacing wood [paneling] [built-in shelving] [mantles] [columns] [railings] [and]
[trim] <Insert item=.

3. Repairing, refinishing, and replacing hardware

B.  Related Requirements:

a
T
T
T
T
a
a
T
a

Retain subparagraphs below to cross-reference requirements Contractor might expect to find in this
Section but are specified in other Sections.

1 Section 013591 "Historic Treatment Procedures” for general historic treatment
requirements.

2. Section 024296 "Historic Removal and Dismantling” for historic removal and
dismantling work.

3. Section 080314 "Historic Treatment of Wood Doors" for historic wood door repairs.

1=

-

L]

MasterSpec Styles and Template Guide 9



Deltek

Option 2: Apply MasterSpec Styles through Document Templates

Display the Developer Tab

Display the Developer tab of Word to use the Document Template feature for applying MasterSpec styles
in your project specifications.

To display the Developer tab:
1. In Microsoft Word, click File » Options.

2. In the Word Options window, click Customize Ribbon.

General

E“B' Customize the Ribbon and keyboard shortcuts.

Display
Choose commands from:
Proofinc =
< Popular Commands

>dve

Language Accept Res
dd Table

Acdvanced

Customize Ribbon Sillers

Uuick Access |oolbar
mber Format...

Add-ins o Delete [D omment]

Trust Center

rmat Painter
ont [Increase Font Size]
Comment Add-ins
ection Breaks Help
F= Insert Picture BLUEBEAM
[Z] Insert Text Box
Line and Paragraph Spacing New Tab Mew Group Rename...
Bl ddlalLiypedink) Customizations: Reset =

Keyboard shorteuts: | Custor Import/Export ¥

OK Cancel

3. On the Customize Ribbon tab, select Developer from the Customize the Ribbon list.
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General

Eh Customize the Ribbon and keyboard shortcuts.

Display
ymmands from: Customize the Ribbon:
Proofi
rooting Popular Commands Main Tabs

wooept
wdd Table
Accessibility lign Left
Bullets
enter
hange List Level

Language

Advanced
Customize Ribbon
Quick Access Toolbar

Add-ins
. Draw Table
T EE =] Dray rtical Tex
Email
Find
Fit to Window Width

Font Size
Footnote
Format Painter

BLUEBEAM

Line and Paragraph Spacing Mew Tab Mew Group

Link [Add a Hyperlink]

Customizations: Reset ~

Keyboard shortcuts: | Customize..

Cancel

Note: Ensure that the Customize the Ribbon list is set to Main Tabs.

4. Click OK.
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Appendix: If You Need Assistance

If you need assistance installing, implementing, or using Deltek Specpoint, Deltek makes a wealth of
information and expertise readily available to you.

Customer Services

For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems,
listening to their needs, and getting to know their individual business environments. A full range of
customer services has grown out of this close contact, including the following:

= Extensive self-support options through the Deltek Support Center.

=  Phone and email support from Deltek Customer Success analysts

Attention: Find out more about these and other services from the Deltek Support Center.

Deltek Support Center

The Deltek Support Center is a support website for Deltek customers who purchase an Ongoing Support
Plan (OSP).

The following are some of the many options that the Deltek Support Center provides:

= Search for product documentation, such as release notes, install guides, technical information,
online help topics, and white papers

= Ask questions, exchange ideas, and share knowledge with other Deltek customers through the
Deltek Support Center Community

= Access Cloud-specific documents and forums

= Download the latest versions of your Deltek products

=  Search Deltek’s knowledge base

=  Submit a support case and check on its progress

= Transfer requested files to a Deltek Customer Success analyst

=  Subscribe to Deltek communications about your products and services
= Receive alerts of new Deltek releases and hot fixes

= Initiate a Chat to submit a question to a Deltek Customer Success analyst online

Attention: For more information regarding Deltek Support Center, refer to the online help available
from the website.

Access Deltek Support Center

To access the Deltek Support Center:
1. Go to https://deltek.custhelp.com.

2. Enter your Deltek Support Center Username and Password.
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3. Click Login.

Note: If you forget your username or password, you can click the Need Help? button on the login

screen for help.

Additional Documentation

The following table lists the Deltek documentation available for this release. Except where noted, all the
user guides and quick reference guides listed in this table are available for download from the Deltek

Support Center.

Deltek Specpoint 1.7 Release Notes for A/E
Users

Deltek Specpoint 1.0 Release Notes for A/E
Users

Deltek Specpoint Help for A/E Users

Deltek Specpoint SaaS Administrator Guide

These release notes are cumulative and contain a
summary of the new features, enhancements, and
resolved software issues.

These release notes contain a summary of the
key features for the first release of Specpoint.

This guide contains descriptions of and procedural
information about features included in Specpoint.

You can access this guide from Specpoint’s help
menu.

This guide contains descriptions of and procedural
information about features that are available for
administrators who are responsible for the initial
activation and ongoing management of Specpoint.
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About Deltek

Better software means better projects. Deltek delivers software and information solutions that enable
superior levels of project intelligence, management and collaboration. Our industry-focused expertise
makes your projects successful and helps you achieve performance that maximizes productivity and
revenue. www.deltek.com
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