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Overview

Overview

This document presents frequently asked questions related to year-end processing.

The Year-End Cumulative Update will be released in December 2022. Expect any late-breaking state tax
changes to be included in a second payroll tax update in January or February.

The Deltek ComputerEase Year-End Guide and the Year-End Cumulative Update software will be
available on the Deltek Support Center, https://deltek.custhelp.com.

To access the Year-End Guide:

1.

2.
3.
4

Log on to the website.
Click the Year-End Resources link.
Select the product: Deltek ComputerEase

Click Go.All knowledge base articles related to year-end processing displays.
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Year-End Frequently Asked Questions (FAQs)

Year-End Manual

This is your one-step shop for easy access on how to complete all your year-end tasks. Here are some of
the commonly asked questions that are answered in the Year-End Manual:

How do I do a bonus Payroll—in-house & outsourced? (KB #104481)

Clear the Labor Distribution for all employees that are to receive a Bonus check.

Enter the amounts for the bonuses through Enter Labor Distribution or Enter Non-Job Hours, selecting
Bonus for the pay type. Federal Taxes will be calculated using the default in the Tax Rate for Bonus
Pay field in the Federal Tax Table Maintenance master file (federal standard is 22%). If you change the
field to 0%, ComputerEase will use the Employee's tax settings to determine the amount of Federal Tax
to withhold.

Note: If you change the rate to 0%, ComputerEase will warn you when you print your payroll register
that your Federal Tax Table does not agree with the defaults and will ask you if you want to revert
back to the defaults. Make sure you clear the box to update it or it will reset back to 22%.

To manually adjust FICA Tax, Medicare Tax, Federal Tax, Earned Income Credit, State Tax, Local
Tax, Deductions, and/or Fringes:

1. Select Entry on the top of the Labor Distribution screen and Tax Override or use the $ symbol in
the middle toolbar.

2. In the Tax Override dialog box, perform the following:

a) Override: From the drop-down list, select the field you want to override (for example, Federal
Tax).

b) Operation: From the drop-down list, select Change current to.
c) Amount: Enter the amount to change the selected item to.
3. Click OK.

Any changes made here will be reset to the normal employee setting after the Clear Labor Distribution
utility is run.

When processing payroll, the Payroll Period you select will control which deductions or fringes will apply
to the checks you are creating.
To set up a payroll period for bonus checks:

1. From the main menu, select Payroll System » Maintenance Programs » Work on Payroll
Periods.

Enter a name for your Payroll Period and click OK.

In the Payroll Period BONUS dialog box, select which deductions and/or fringes you want to
apply to the bonus checks, and click OK.
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How do I issue Fringes after last payroll is completed? (KB #107091)

If you have completed your final payroll check run for the year and need to add information to the
employee’s wages for tax purposes, and you want the amount recorded in the W-2 Box 14, you will need
to set up a fringe for the additional information and then manually make changes using the Month to Date
Maintenance utility.

This utility is used to add information to the W-2 and does not charge the employee for any taxes owed. If
there are taxes owed, you will need to make arrangements with the employee to collect them.
To issue fringes after year-end payroll is complete:

1. Create the Fringe.

Attention: Please see “Issuing Non-Cash Fringes During a Normal Payroll” in the Deltek
ComputerEase Year-End Manual for instructions on setting up the Fringe.

2. After creating the Fringe, select Payroll System » Maintenance Programs » Month to Date
Maintenance.

3. On the Month to Date Maintenance dialog box, select the Employee and enter the Month for
which you want to edit the fringe and tax amounts. This will normally be December of the year
you are currently working in.

4. Click OK.

On the MTD Maintenance screen, click the State tab, and then click the Fringes button at the
bottom.

On the MTD Fringes dialog box, enter the amount of the fringe in the Accrued field, and click OK.
On the MTD Maintenance screen, click the Federal tab.

8. In the Federal Tax field, enter the amount of tax that has been calculated for the fringe
This amount will be supplied to you by your CPA.

In the example below, the employee had paid $200.55 in federal taxes for the month, the tax on
the fringe is $175.00, so the new amount of Federal Tax will be $375.55. If the fringe is taxable
for FICA and Medicare, you will need to edit these fields as well.

When FICA or Medicare is changed, the Employee and Employer fields will require editing. If
the fringe is taxable for state income tax or local income taxes, the State Tax Withheld and
appropriate Local Employee (or Employer Tax, where applicable) fields will require editing on
the State and Local tabs, respectively.

9. When you are done making changes, click OK.

10. On the Save dialog box, enter the date the change became effective, and click OK.

Note: If this is a one-time annual adjustment, you can use the last day of the year.

Note: If you choose to use Month to Date Maintenance for increasing taxes and fringe
amounts, the necessary journal entries for monies paid to you by the employee for any
additional tax, or for any fringe accrual or expense, will need to be made manually.
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How do I handle third-party sick pay? (KB #107092)

When an Employee receives a check from a Third-Party sick pay provider, it is sometimes required that
the Employer record the wages paid by the provider and the taxes paid by the Employee on the
Employee’s W-2 statement. This would also require the Employer's quarterly 941 to be adjusted as well.
From the provider’s statements, you will be able to document and adjust the W-2, the 941, and the 940
(FUTA).

Quarterly 941 Adjustments

On the 941, you will adjust all wage and tax amounts (lines 2, 5a, 5c) to include the amounts paid to all
Employees by the Third-Party Provider for this quarter. As the Employer, if you are also responsible for
paying the Employer’s portion of the above-mentioned tax, your 941 will need to be adjusted to show the
taxes paid. Line 8 of the 941 should be completed with the employer taxes for total sick pay provided by
the third party, for all employees.

Editing W-2s for Third Party Sick Pay

For the employees that have received funds from this provider, you will need to edit their W-2 to reflect
the compensation and taxes paid. After preparing the W-2s, you will need to then select Edit W-2s.
Select the current year and the employee, and then click OK.

How do I do ACA Reporting? (KB # 107123)

Preparing Your Data

Getting Prepared

To satisfy ACA filing requirements, you may want to start compiling all of the information you will need for
entering into ComputerEase, making the transition as seamless as possible.

Firstly, you will need to define your insurance plan or plans. For all offered plans, you will need to know
the start dates, the minimum coverage offered, and the premiums for all levels of coverage for each
category of coverage.

Secondly, you will want to define the following: your standard measurement period (when it begins and
ends) and your standard stability period (when it begins and ends).

Thirdly, you will need to categorize each employee as full-time, part-time, or variable hourly and the date
that status took effect.

In addition to the information you should already have on file for your employees (name, SSN, address,
and phone number), you will need to know which plan(s) they were offered for each month (this
information may be the same for all months). This information is reported on form 1095-C on line 14 and
is categorized by “Offer Code”.

Lastly, you will need to know the employee share of the lowest cost monthly premium for self-only
minimum value coverage as well as if any Section 4980H safe harbor codes can be applied in any month
during the year, for each employee.

Future Developments

For the latest information about developments related to Form 1094-C (Transmittal of Employer-Provided
Health Insurance Offer and Coverage Information Returns), Form 1095-C (Employer-Provided Health
Insurance Offer and Coverage), and instructions (such as legislation enacted after they were published),
go to https://www.irs.gov/pub/irs-pdf/i109495c¢.pdf.
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Entering Your Data

Create Categories

You need to create at least one ACA Category in ComputerEase. The ACA Category is used to track the
standard measurement period information. If you have only one standard measurement period, which will
be typical for most companies, then you will need only one ACA category.

To create an ACA category:

1. From the Payroll System main menu, select Maintenance Programs » ACA Maintenance »
Edit ACA Categories.

2. On the Edit ACA Categories dialog box, enter the Category Code and click OK.
Enter a category code up to 12 alphanumeric characters to define your ACA category.
On the ACA Cat dialog box, enter a Description for your ACA category.

In the Measure Start Date column, double-click the row with (new) to create a new measurement
period associated with this ACA category.

5. On the Category Information dialog box, take the following actions:

= Standard Measurement Period Start Date: Enter the start date of your standard
measurement period.

Note: This is the date that you want to start tracking ongoing variable hours employees’
hours. An ongoing employee is an employee that has been employed for at least one
complete standard measurement period.

= Standard Measurement Period Length: Enter the length of your standard measurement
period in months.

Note: The period is used to determine if variable hour or part-time employees are full
time. This is typically 3—12 months.

= Standard Measurement Period End Date: This field will automatically populate with the
calculated end date of your standard measurement period.

= Standard Administrative Period Length: Enter the length of your standard administrative
period in months. This is the period of time between the time that your standard
measurement period ends and your stability period begins.

Note: The purpose of the Standard Administrative Period is to allow employers time to
total and average the hours of service of each employee during the Standard
Measurement Period, notify eligible employees, explain coverage available under the
plan, answer questions, collect materials from employees, and enroll employees who
elect coverage before day one of the Standard Stability Period. The Standard
Administrative Period may not exceed 90 days, which may in practice be the first of the
month following two months. It may not cause a gap in coverage, and it may not reduce
or lengthen the Standard Measurement or Standard Stability Periods.

= Stability Period Start Date: This field will automatically fill with the calculated start date of
your stability period based on data entered above.
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Note: Employees who worked on average at least 30 hours per week or at least 130
hours per month during the Measurement Period (that is, were full time) should be
offered health coverage for the entire Standard Stability Period, regardless of the hours
they actually worked during the Standard Stability Period (unless they cease to be
employed by the employer).

For employees who were full-time during the Standard Measurement Period, the
Standard Stability Period must be at least six consecutive calendar months and cannot
be shorter than the Measurement Period.

For example, if the Standard Measurement Period is 12 months, the Standard Stability
Period must be at least 12 months. If the Standard Measurement Period is only six
months, the Standard Stability Period must be at least six months.

Even if the Standard Measurement Period was only three months, the Standard Stability
Period must be at least six months.

For employees who were part-time during the Measurement Period, the Stability Period
cannot be longer than the Measurement Period. The six-month and 12-month examples
above would be the same for both part-time and full-time employees, but if the Standard
Measurement Period was only three months, the Standard Stability Period for part-time
employees could not be more than three months.

= Stability Period End Date: This field will automatically populate with the calculated end date
of your stability period based on data entered above.

= |nitial Measurement Period Length: Enter the length of your initial measurement period in
months.

Note: For newly hired employees who are not reasonably expected to be full-time on the
date of hire, the initial measurement period applies until they become ongoing
employees. The initial measurement period begins on the date of hire or the first day of
the next month.

= Initial Administrative Period Length: Enter the length of your initial administrative period in
months.

Note: The period length cannot exceed 90 days. The total combined time of the Initial
Administrative Period and the Initial Measurement Period cannot exceed 13 months plus
a portion of another month.

Each time your measurement period is renewed, you need to edit your category and
double-click the (new) row to add new information. The information will populate based
on information entered previously. (The assumption is that your standard measurement
period, stability period, and administrative period will remain unchanged, and your new
start dates will be based on the end of the old.) You only need to make changes if you
decide on administrative changes.

Create Plans

You need to create at least one ACA Plan in ComputerEase. The ACA Plan is used to track the start date
of your plan and the employee share of the lowest cost monthly premium for self-only minimum value
coverage. You need to create one plan for each combination of these two that you have. If you have two
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separate plans that you offer to different employee groups even if they begin on the same date, you will
need to create two plans in ComputerEase.

To create an ACA plan:

1.

From the Payroll System main menu, select Maintenance Programs » ACA Maintenance »
Edit ACA Plans.

On the Edit ACA Plans dialog box, enter a Plan Code, and click OK.
You can enter up to 12 alphanumeric characters to define you ACA Plan.
On the ACA Plan dialog box, enter a Description for your plan.

In the Start Date column, double-click the (new) row to define your plan.
On the Plan Information dialog box, take the following actions:

= Beginning on: Enter the start date of the plan.

= Employee Share of Lowest Cost Monthly Premium for Self-Only Minimum Value
Coverage: Enter the amount of the employee share for the lowest-cost, self-only, minimum
essential coverage providing minimum value that is offered to the employee.

Each time the plan is renewed, you will need to edit the plan and double-click the (new) row
to add a renewal to the plan with a new start date and new employee share of premium.

Enter Employee Information

If you are an ALE, you will need to enter some additional information for each employee in order to report
this information from ComputerEase.

To enter employee information:

1.

From the Payroll System main menu, select Maintenance Programs » ACA Maintenance »
Edit Employee ACA Information.

On the Edit Employee ACA Information dialog box, select the Employee for whom you want to
edit ACA Information, and click OK.

On the Status and History tab, take the following actions:

= New Employment Status: Click this button to add a new status at any time. If an employee
changes status from full-time to part-time or vice-versa, select this option to add a new status.

= New Plan: Click this button to add a new ACA Plan (with a new effective date).

= New Category: Click this button to add a new ACA Category for this employee (with a new
effective date).

= Edit Current Selection: Click this button to edit the highlighted selection in the field above.
After the update introducing the ACA changes, all employees were set to a status of No ACA
with an effective date of 1/1/2015. To change this and set their status as of 1/1/2015, either
double-click that entry or select this button to display the Initial Setup dialog box.

= On the Initial Setup dialog box, take the following actions:

= Category: Select the category that applies to this employee. This will define the
stability period and measurement period for your variable hour employees.

= Plan: Select the plan that applies to this employee.
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= Employment Type: Select the employment type that applies to this employee. If you
are not an ALE, then No ACA would apply for all; otherwise, select Full-Time,
PartTime, or Variable Hour.

= Effective Date: Enter the date on which the information entered above became
effective. Any time there is a change to the information above, you must enter new
information here.

= Look-Back Start: This information displays only if an employee is classified as
Variable Hour. It is calculated based on the information entered above. This is the
start date of the look-back period for this employee. It should be one month after the
effective date.

= Look-Back End: This information displays only if an employee is classified as
Variable Hour. It is calculated based on the information entered above. This is the
end date of the look-back period for this employee. It should be the end date of the
standard measurement period of the employee's class/category.

= Look-Back Status: Select what you believe this employee's status to be at this time.
The choices are Full Time, Part Time, or Unknown. At the end of the Look-Back
Period, you will be able to use the ACA Variable Hour Employee Status Report to
help determine the employee's calculated status.

= Delete Current Selection: Click this button to remove the highlighted status in the
field above.

4. On the Offer of Coverage tab, take the following actions:

= Year: This should default to the current year; you can change this to the year for which you
want to enter data.

= 0oC Code: Choose the applicable Offer of Coverage code for each month. The code you
choose for each month will automatically populate each month following. This will populate
Form 1095-C, line 14 for this employee.

= Safe Harbor Code: Choose the applicable section 4980H Safe Harbor code for each month.
The code you choose for each month will automatically populate each month following. This
will populate Form 1095-C, line 16 for this employee. If you need assistance, refer to the
flowchart.

=  Zip Code: For OoC codes of 1L, 1M, or 1N, enter the employee's primary residence zip
code. For OoC codes of 10, 1P, or 1Q, enter the employee's primary employment zip code
affordability safe harbor.

Tip: You can use your mouse to navigate and the drop-down to select the code in each
month. Or, you can use the TAB key and/or arrow keys on your keyboard to move
between the code fields per month and select the applicable codes by selecting the letter
corresponding to each code. For example, to select the Offer of Coverage code 1B for
January and February and 1C for all other months, press TAB until January is highlighted
and press B on your keyboard. And then, TAB or arrow to March and press C on your
keyboard. In order to revert a selection to the code in the field above, press DELETE on
your keyboard.

5. On the Covered Individuals tab, take the following actions:

= Year: This field defaults to the current year. You can change this to the year for which you
want to enter data.
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= Employer provided self-insured coverage: Select this checkbox if you provided self-
insured coverage. Enter the first name, middle name, last name, name suffix, S.S.N., and
birth date for each individual covered for this employee. And then, select the checkbox(es)
corresponding to the month(s) they were covered.

ACA Reports

ACA FTE Count Report

The ACA FTE Count Report is designed to help you determine the number of Full Time and Full Time
Equivalent Employees you employ during a given time period. Each calendar year, this report can help
you determine your ALE status. It can also help you determine each employee's full-time or part-time
status. Unlike other payroll reports which are based on pay date, this report is based on work date. If you
do not enter the date worked (for example, for salaried employees), this will be estimated based on
payroll ending date.

To run the ACA FTE Count Report:

1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » ACA
FTE Count.

2. Onthe ACA FTE Count Report dialog box, take following actions:
= Ending Month: Enter the month through which you want to run the report.
= Months: Enter the number of months for which you want to report your hours.

= Detail or Summary: Select Detail if you want to see each employee listed with the number
of hours worked per month. Select Summary if you just want to see a count of total full-time
and full-time equivalent employees.

= Send Report To: Select Printer, Display, Email, or Clipboard, depending on what you
would like to do with this report.

= Printer: If you are printing the report, select the appropriate printer in this field.
3. Click OK.

Depending on your selection in the Send Report To field, the report will print, display, or
generate an email or a pdf on the clipboard.

For the purposes of counting full-time employees, the ACA defines any employee who works at least 130
hours per month as full-time. However, when calculating full time equivalent employees, only the first 120
hours an employee works is used when calculating FTEs. For all employees working less than 130 hours
in a month, all hours less than 120 per employee are totaled and divided by 120 to determine the number
of full-time equivalent employees that those employees represent when determining whether or not your
business is an ALE.

ACA Variable Hour Employee Status Report
This report is designed to help you determine the status of any variable hour employees at the end of the
measurement period.

To run the ACA Variable Hour Employee Status Report:

1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » ACA
Variable Hour Employee Status.

2. On the ACA Variable Hour Status Report dialog box, take the following actions:

Year-End Frequently Asked Questions 9
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= As Of: Enter the date through which you want to report weekly average hours and calculated
status for each variable hour employee.

= Send Report To: Select Printer, Display, Email, or Clipboard, depending on what you
would like to do with this report.

= Printer: If you are printing the report, select the appropriate printer in this field.

3. Click OK.

Depending on your selection in the Send Report To field, the report will print, display, or
generate an email or a pdf on the clipboard.

ACA Employee Type

This report is used to determine how each employee is currently classified for ACA reporting purposes.

To run the ACA Employee Type Report:

1.

From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » ACA
Employee Type.

On the ACA Employee Type Report dialog box, take the following actions:

= As Of: Enter the date through which you want to report the ACA status for each employee;
note that employee status can change.

= Employees: Select an employee or employees to report on, or leave blank to report on all
employees.

= Status: Select Active, Inactive, or All.

= Send Report To: Select Printer, Display, Email, or Clipboard, depending on what you
would like to do with this report.

= Printer: If you are printing the report, select the appropriate printer in this field.
Click OK.

Depending on your selection in the Send Report To field, the report will print, display, or
generate an email or a pdf on the clipboard.

Printing the 1094-C Form
The 1094-C Form is the cover sheet for the 1095-C forms that you furnish to the IRS.

To print the 1094-C form:

1.

From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » Print
1094-C Form.

On the Print 1094-C dialog box, enter the year for which you want to print the 1094-C, and click
OK.

This field defaults to the current year.
On the Parts | and Il tab, take the following actions:
= Contact Name: Enter the name of the contact for the form 1095-C.

= Number of Forms 1095-C submitted with this form: This will default to the number of
forms calculated based on ALE information entered. You can change it if you intend to submit
a different number of 1095-C forms to the IRS.
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Is this the authoritative transmittal: Each company must send one authoritative transmittal;
if you are filing multiple 1094-C forms, you should select Yes only when the form you are
printing is the authoritative transmittal.

Total Number of Forms 1095-C filed: This will default to the total number of forms
calculated based on ALE information entered. You can change it if you have filed a different
number of 1095-C forms.

Member of Aggregated ALE Group: Select Yes if you are a member of an aggregated
group, that is, if this company is one of multiple companies that are combined and treated as
one company for the purposes of determining ALE status per the IRS code.

Certifications of Eligibility: Select the appropriate checkboxes as they apply: Qualifying
Offer Method, Qualifying Offer Method Transition Relief, Section 4980H Transition
Relief, and/or 98% Offer Method. Used to completed line 22 of Part Il of the 1094-C.

Note: Qualifying Offer Method Transition Relief and Section 4980H Transition Relief are no
longer available for 2017 and 2019.

Attention: Visit https://www.irs.gov/affordable-care-act/employers/questions-and-answers-
on-reporting-of-offers-of-health-insurance-coverage-by-employers-section-6056 for more

information on methods of reporting.

4. On the Part Il tab, take the following actions:

Minimal Essential Coverage Offer: Select Yes or No; did you offer minimal essential
coverage either for "All 12 Months" or the appropriate response for each month if different by
month.

Full-Time Employee Count: This field will populate with the full-time employee count based
on information entered into ComputerEase. If your data differs (for example, if you did your
payroll for part of the year outside of ComputerEase), you can change it per month here.

Total Employee Count: This field will populate with the total employee count (full- and part-
time) based on information entered into ComputerEase. If your data differs (for example, if
you did your payroll for part of the year outside of ComputerEase), you can change it per
month here.

Aggregated Group Indicator: If you indicated on the first tab that you are a member of an
aggregated ALE group, you can select the checkbox indicating that you were a member of
that group either for "All 12 Months" or per month if different by month.

Section 4980H Transition Relief Indicator: If you selected on the first tab that you are
eligible for Section 4980H Transition Relief, enter the appropriate code either for "All 12
Months" or per month if different by month. Applicable codes are A if eligible for the 50 to 99
Relief, or B if eligible for the 100 or More Relief.

Note: 4980H Transition Relief is no longer available after 2016.

5. On the Part IV tab, take the following actions:
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Note: If you selected that you are a member of an aggregated ALE group on the Parts | & I
tab, you need to fill out this section. List the other members of the aggregated group in
descending order, starting with the member with the highest average monthly number of full-
time employees. If there are more than 30 members of the aggregated ALE group, enter only
the 30 with the highest monthly average number of full-time employees.

= Name: Enter the name of the aggregated group member.

= EIN: Enter the EIN for the aggregated group member.

Printing the 1095-C Forms

ComputerEase prints the completed 1095-C forms using information entered into the ACA Maintenance
programs (with the exception of Part IIl).

To print the 1095-C forms:

1.

From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports » Print
1095-C Forms.

On the 1095-C Forms dialog box, take the following actions:

=  Year: Enter the year for which you want to print the 1095-C forms. This field defaults to the
current year.

= Include Instructions: Select Yes to print the instructions for each form or select No to print
only the form.

= Show S.S.N.: Select Yes to display the full S.S.N. on each 1095-C, or select No to hide the
first 5 digits of the S.S.N.

= Employees: Select an employee or employees, or leave blank to print forms for all
employees.

= Send Report To: Select Printer, Display, Email, or Clipboard, depending on what you
would like to do with this report.

= Printer: If you are printing the report, select the appropriate printer in this field.
Click OK.

Depending on your selection in the Send Report To field, the report will print, display, or
generate an email or a pdf on the clipboard.

If any employees with a status other than No ACA during the year indicated are missing any
necessary information, a page will print indicating any errors (such as missing Offer of Coverage
codes). Correct the errors prior to printing your forms. Keep in mind when reviewing forms that
line 15 will only have a value for line 14 values of 1B, 1C, 1D, or 1E.

Upload 1095-C Forms to Employee Hub

If you own the Employee Hub module, you may wish to upload the 1095-C Forms to the Employee Hub
website.

To upload 1095-C forms to the Employee Hub:

1.

From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports »
Upload 1095-C Forms to Employee Hub.
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2. On the Upload 1095-C Forms dialog box, enter the Year for which you want to upload 1095-Cs to
the Employee Hub, and click OK.

3. On the 1095-C Forms dialog box, take the following actions:

= Show S.S.N.: Select Yes to display the full S.S.N. on each 1095-C, or select No to hide the
first 5 digits of the S.S.N.

= Employees: Select an employee or employees, or leave blank to print forms for all
employees.

4. Click OK.

If any employees with a status other than No ACA during the year indicated are missing any necessary
information, a page will print indicating any errors (such as missing Offer of Coverage codes). Correct the
errors prior to printing your forms. Keep in mind when reviewing forms that line 15 will only have a value
for line 14 values of 1B, 1C, 1D, or 1E.

Exporting the 1094-C/1095-C Information

An employer filing 250 or more Forms 1095-C is required to file forms 1094-C and 1095-C electronically.
An employer filing fewer than 250 Forms 1095-C may choose to file electronically or on paper. Electronic
filers must use the ACA Information Return System (AIR). According to IRS Publication 5164 and
Publication 5165, an employer should:

= Determine the responsible individuals and contacts who will handle the electronic filing.
= Register with e-services.

= Complete an Application for Transmitter Control Code (TCC) if the employer acts as an issuer, a
software developer, and/or a transmitter.

= Conduct ACA Assurance Testing System (AATS) testing.

Note: If you electronically submitted your ACA information the previous tax year, you do not need to
go through these above steps again.

To export your 1094-C/1095-C information:

1. From the Payroll System main menu, select Reports » Tax Reporting » ACA Reports »
Export 1094-C/1095-C Information.

2. On the Export 1094-C/1095-C Information dialog box, enter the Year for which you want to export
the 1094-C/1095-C information, and click OK.

This field defaults to the current year.

3. On the dialog box that displays, click the Make Test File button if this is your first tab year to
electronically file your ACA information.

If you conducted ACA Assurance System (AATS) testing in a previous tax year, you do not need
to make a test file again. Skip forward to step 6.

4. On the Export 1094-C/1095-C dialog box, enter the transmitter control code (TCC) you were
assigned by the IRS.

5. Click OK.

Two files (a 1094-C manifest file and a 1094-C request file) will be sent to the clipboard. Save
these two files and upload them to the ACA Information Return System (AIR).
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Note: It will typically take 48 hours or more for the IRS to approve your test file submission
and move your transmitter control code (TCC) from test status to production status. Do not
attempt to upload to the production portion of the ACA Information Return System (AIR) until
this occurs.

Click the Prepare button to prepare your data for export.

On the Parts 1 and Il tab, take the following actions:

Contact Name: Enter the name of the contact for the form 1095-C.

Number of Forms 1095-C submitted with this form: This will default to the number of
forms calculated based on ALE information entered. You can change it if you intend to submit
a different number of 1095- C forms to the IRS.

Is this the authoritative transmittal: Each company must send one authoritative transmittal,
if you are filing multiple 1094-C forms, you should choose Yes only when the form you are
printing is the authoritative transmittal.

Total Number of Forms 1095-C filed: This will default to the total number of forms
calculated based on ALE information entered. You can change it if you have filed a different
number of 1095-C forms.

Member of Aggregated ALE Group: Choose Yes if you are a member of an aggregated
group; that is, if this company is one of multiple companies that are combined and treated as
one company for the purposes of determining ALE status per the IRS code.

Certifications of Eligibility: Select the appropriate checkboxes as they apply: Qualifying
Offer Method, Qualifying Offer Method Transition Relief, Section 4980H Transition
Relief, and/or 98% Offer Method. Used to completed line 22 of Part Il of the 1094-C.

Note: Qualifying Offer Method Transition Relief and Section 4980H Transition Relief are

no longer available in 2017 and 2019.

Attention: Visit https://www.irs.gov/affordable-care-act/employers/questions-and-answers-
on-reporting-of-offers-of-health-insurance-coverage-by-employers-section-6056 for more
information on methods of reporting.

On the Part Il tab, take the following actions:

= Minimal Essential Coverage Offer: Choose Yes or No; did you offer minimal essential
coverage either for "All 12 Months" or the appropriate response for each month if different
month.

by

= Full-Time Employee Count: This field will populate with the full-time employee count based
on information entered into ComputerEase. If your data differs (for example, if you did your

payroll for part of the year outside of ComputerEase), you can change it per month here.

= Total Employee Count: This field will populate with the total employee count (full and part-

time) based on information entered into ComputerEase. If your data differs (for example, if

you did your payroll for part of the year outside of ComputerEase), you can change it per
month here.

= Aggregated Group Indicator: If you indicated on the first tab that you are a member of an

aggregated ALE group, you can check the box indicating that you were a member of that
group either for "All 12 Months" or per month if different by month.

Year-End Frequently Asked Questions
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= Section 4980H Transition Relief Indicator: If you selected on the first tab that you are
eligible for Section 4980H Transition Relief, enter the appropriate code either for "All 12
Months" or per month if different by month; applicable codes are A if eligible for the 50 to 99
Relief or B if eligible for the 100 or More Relief.

Note: 4980H Transition Relief is no longer available after 2016.

On the Part IV tab, take the following actions:

Note: If you selected that you are a member of an aggregated ALE group on the Parts | & I
tab, you need to fill out this section. List the other members of the aggregated group in
descending order, starting with the member with the highest average monthly number of full-
time employees. If there are more than 30 members of the aggregated ALE group, only enter
the 30 with the highest monthly average number of full-time employees.

= Name: Enter the name of the aggregated group member.

= EIN: Enter the EIN for the aggregated group member.
9. Click OK after you've completed the applicable fields in Parts | through IV.
10. On the dialog box that displays, take the following actions:

= Reprepare: Click this button to reprepare the data.

= Delete: Click this button to delete the prepared data.

= Export: Click this button to export the data so it can be submitted.

On the Export 1094-C/1095-C dialog box, enter the Transmitter Control Code you were
assigned by the IRS.

Two files will be generated and sent to the clipboard (a 1094-C manifest file and a 1094-C
request file). Save these two files and upload them to the ACA Information Return System
(AIR).

11. After submitting the files to the ACA Information Return System (AIR), click Enter Receipt.
12. On the Enter Receipt ID dialog box, enter the Receipt ID, and click OK.

13. After submitting your manifest and request files, check AIR website to a status update for your
submission.

Note: It may take a few hours or more for the IRS to provide a status update.

14. When you have the status from the AIT website, click Update Status.
15. On the Submission Status dialog box, select the status and click OK.

By default, the submission status will be in processing. The IRS will provide one of three submit
statuses: Accepted, Accepted with errors, or Rejected.

Accepted (no errors) If your submission was accepted with no errors, you have completed
the process and will see following screen when you click OK.

Year-End Frequently Asked Questions 15


https://www.irs.gov/e-file-providers/affordable-care-act-information-returns-air

Year-End Frequently Asked Questions (FAQs)

Deltek

Accepted with errors

Rejected

o 2018 - X

The 2015 Original data was accepted.

: Correct 1094 Send a corrected 1094-C

Correct 1085(s) | Send corrected 1095-C(s)

Close

Although you have completed the process, you will still have an
opportunity to correct the 1094-C and 1095-C(s) if you need to.

If your submission was accepted with errors, you will see this screen

when you click OK.

o 2018 - X

The 2018 Original data was accepted with errors, The errors should be
corrected and the corrections submitted.

View which employees need to be corrected

Correct 1094 | Send a corrected 1094-C

Correct 1095(s) | Send corrected 1095-C(s)

Close

= View Errors: You can download the error file from the AIR
website and enter its location on this screen to view the errors.

w: View Errors

Download the error file from the IRS website and enter its location here

*

Conal

= Correct 1094: Allows you to make changes to the 1094-C and

export a corrected file.

= Correct 1095(s): Allows you to make changes to the 1095-C

and export a corrected file.

Note: After the corrected files are uploaded, you will need to
enter a receipt id and then update the status.

If you receive a rejected status, you will see this screen after clicking

OK.
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o 2018 - X

The 2018 Original data was rejected. The errors should be corrected
and resubmitted

Check for errors and prepare the data for export

Close

You will need to re-prepare your data and export again.

Note: After the replacement files are uploaded, you will need
to enter a receipt id and then update the status.

How do I generate a Magnetic Media file? (KB # 107094)

To create a Magnetic Media file for electronic filing of W-2 statements:

1. From the Payroll System main menu, select Reports » Tax Reporting » Work on W-2s »
Create Magnetic Media File.

2. Select the appropriate format: Federal Info, State Info, or City Info.

Depending on the option you select, you are prompted for the Tax Year and any additional
information required for the Magnetic Media file.

4. Click OK.

The Magnetic Media file will be generated in the clipboard. You can copy this file to disk and/or send it to
the proper agency.

How do I go about installing Year End updates? (KB # 107096)

Auto Update Feature

To keep your software current and to make sure that you have the Tax Tables for the new year, you will
need to run the Auto Update Feature that is available in ComputerEase. You can run the update as soon
as it is available.

If you have the feature enabled that notifies you automatically when updates are available, you will see an
Attention message similar to the following when updates are available:

Attention - *

1) Program updates are available. The latest release is 11,12?,120185

You can click the notification to see a list of the updates available and the release notes for each update.

To check for updates:

1. Make sure all other users have logged out of ComputerEase.
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2. Take one of the following actions:

= Click the Attention message.

=  From the ComputerEase main menu, click Help » Check for New Release.
3. When the information box displays, click Check for Upgrade.

This instructs the system to check the ComputerEase website for the newest release for the you
version of ComputerEase.

4. If your ComputerEase is not up-to-date, the Auto Update screen displays, showing how many
updates are available to download.

5. Click View Changes to see a list of revisions and new features that will be installed with this
update.

You can also print this list after clicking View Changes.

To install updates:
1. Leave the Auto Update window open and log out of ComputerEase.
2. Click Update.

A progress bar will display showing the files being installed.

Note: If someone is still logged into any of the ComputerEase companies, you will get an
error message that there is a user logged in and which company they are logged into. To
determine the user, sign into the company that the warning pointed to, and click File » Active
Users on the main menu to view the User Log.

3. When the update installation is complete, click Yes when prompted to Convert the Data Files.

This completes the update on the server. Each workstation will be updated to this release the
next time the user attempts to log into ComputerEase.

How do I load Tax Tables? (KB # 107097)

Loading Federal & State Tax Tables

ComputerEase keeps the Federal and State Tax Tables updated for you. To access the newest Tax
Tables, you must be on the most current release of the version you are on.

Attention: Refer to the Auto Update Feature section for help with updating.

You have two options for updating your tax tables:
= Automatically update the tax tables.

If you wait until you print your payroll register for the first payroll run of the year, ComputerEase
will prompt you to update your tables with any Federal or State changes at that time.

= Manually update tax table.
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Option 1: Automatically Update Tax Tables

To automatically load your tax tables for the new year:
1. Enter and process your first payroll of 2022 as normal.
2. Run the Print Payroll Register program and choose a Date of Check with a date in 2022.
The following warning message displays:

"The following tax table(s) do not agree with the tax tables shipped with this release of the
software."

Any tables that have changes for 2022 will be listed with an effective date for the changes.

3. Leave the check box selected in the Update column for each table in the list and process your
payroll register.

ComputerEase will update your tax tables for you.

Tip: The payroll register is date-sensitive and will update the tax tables as many times as necessary
depending on the check date. This means that you can process your first payroll of 2022 during
December and allow ComputerEase to update the tax tables to 2022 tables for use in that payroll.
And then, run bonus checks for 2022 and allow ComputerEase to update the tax tables back to 2022
for use for those checks. The next time you process a 2022 payroll, ComputerEase will update the
tables back to 2022 again.

Option 2: Manually Update Tax Tables

To load the Default Tax Tables for Federal Taxes:

1. From the Payroll System main menu, select Maintenance Programs » Tax Rate Maintenance
» Federal Tax Maintenance.

2. On the Federal Tax Maintenance dialog box, enter the Tax Year, and click OK.

&+ Federal Ta.. — X

Cancel

Tax Year | ik

Click File » Load Defaults at the top left to update the tax tables for the year entered.

On the Main tab of the Federal Tax Information screen, make changes as needed to the
information.

Tip: The only information you may want to change is the Employer's ID Number or the
Federal Unemployment Rate.
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5. When you are finished editing the information, click OK to save your changes.

o 2020 Federal Tax Information — >
File
Single Table 2(c) Married Table 2(c) Head of Househald Table 2(c)
Main Single Table Married Table Head of Household Table

Employer's ID Mumber I:I
Employer FICARate|  &.2%

Employee FICA Rate

FICA Wage Limit 137,700
Employer Medicare Rate 1.45 (%%
1.45 [%

% above | 200,000

o
ra
=2

Employee Medicare Rate

Additional Employee Medicare Rate | 0.9

Allowance per Exemption 4,300

R:III

E

Tax Rate for Bonus Pay

Federal Unemployment Limit 7,000

3

Federal Unemployment Rate
MNonresident Aliens Wage Adjustment 8100

I:II!

CARES ER Deferred Soc Sec Payment

H

CARES ER. Deferred Soc Sec Account
Deferred Sodal Security Withholding [
Company Liability Account

H

Repayment Deduction Code

< Back QK Cancel

To load the Default Tax Tables for State Taxes:

1. From the Payroll System main menu, select Maintenance Programs » Tax Rate Maintenance
» State Tax Table Maintenance.

2. On the State Tax Table Maintenance dialog box, select the State and the Tax Year for which you
want to update the Tax information, and click OK.

3. On the Tax Settings screen, click File » Load Defaults to update the tax tables for the year
selected.
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@+ 2018 OH Tax Settings - >
File Table
Load Defaults

G/L Account
State Tax ID#
Recrocates with L]

W-2 Wages | Actual v

Taxable wages are Gross Wages

minus Exemption Credits each

Tax is from Tax Tables

Tax Calaulation for Bonus & Regular Pay Pay Period  ~ | 0.00 %
Tax Calculation for only Bonus Pay |Pay Peried  ~ | 0.00 %

< Back oK Cancel

4. On the Main tab or SUTA tab of the State Tax Information screen, make any changes to the
information.

5. When you are finished editing the information, click OK to save your changes.

Note: The SUI and associated rates for applicable states will need to be maintained manually after
you have received your new rate from the State on the SUTA tab.

Note: Any rates shown on this page are for demonstration purposes only. Tax rates are subject to
last-minute legislative change and the rates shown here should not be assumed to be the final rates
or limits for 2022.
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Top Year-End Issues

Purchases and Non-Employee Compensation Not Matching
on the 1099 Report

The purchases reflect what has been invoiced and the non-employee compensation reflects what has
been paid. If the paid amount is wrong, there is a setting on the checking account maintenance window
that allows you to exclude this from the 1099.

2-Up and 4-Up W-2 Printing

The 2-Up W-2 form prints only one W-2 per employee unless they have more than one state and locale.
The 4-Up W-2 prints all four sections as one employee.

941 Report—Medicare over $200,000

If an employee goes over $200,000, ComputerEase calculates both the employee and employer tax for
Medicare. Line 7 of the 941 will show a positive amount to adjust for the employer’s portion that should
not be taxed.
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Appendix: If You Need Assistance

If you need assistance installing, implementing, or using Deltek ComputerEase Deltek makes a wealth of
information and expertise readily available to you.

Customer Services

For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems,
listening to their needs, and getting to know their individual business environments. A full range of
customer services has grown out of this close contact, including the following:

= Extensive self-support options through the Deltek Support Center.
= Phone and email support from Customer Care analysts

= Technical services

= Consulting services

= Custom programming

= Classroom, on-site, and web-based training

Attention: Find out more about these and other services from the Deltek Support Center.

Deltek Support Center

The Deltek Support Center is a support website for Deltek customers who purchase an Ongoing Support
Plan (OSP).

The following are some of the many options that the Deltek Support Center provides:

= Search for product documentation, such as release notes, install guides, technical information,
online help topics, and white papers

= Ask questions, exchange ideas, and share knowledge with other Deltek customers through the
Deltek Support Center Community

= Access Cloud-specific documents and forums

= Download the latest versions of your Deltek products

= Search Deltek’s knowledge base

=  Submit a support case and check on its progress

= Transfer requested files to a Customer Care analyst

=  Subscribe to Deltek communications about your products and services
= Receive alerts of new Deltek releases and hot fixes

= Initiate a Chat to submit a question to a Customer Care analyst online

Attention: For more information regarding Deltek Support Center, refer to the online help available
from the website.
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Access Deltek Support Center

To access the Deltek Support Center:
1. Go to hitps://deltek.custhelp.com.

2. Enter your Deltek Support Center Username and Password.
3. Click Login.

Note: If you forget your username or password, you can click the Need Help? button on the login
screen for help.
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About Deltek

Better software means better projects. Deltek delivers software and information solutions that enable
superior levels of project intelligence, management and collaboration. Our industry-focused expertise
makes your projects successful and helps you achieve performance that maximizes productivity and
revenue. www.deltek.com
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