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While Deltek has attempted to verify that the information in this document is accurate and 
complete, some typographical or technical errors may exist. The recipient of this document is 
solely responsible for all decisions relating to or use of the information provided herein. 

The information contained in this publication is effective as of the publication date below and is 
subject to change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are 
reserved. No part of this document may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, or translated into another language, without the prior written 
consent of Deltek, Inc. 

This edition published August 2013. 

© 2013 Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and 
proprietary information of Deltek, Inc. and its licensors. The Deltek software, and all related 
documentation, is provided for use only in accordance with the terms of the license agreement. 
Unauthorized reproduction or distribution of the program or any portion thereof could result in 
severe civil or criminal penalties. 

All trademarks are the property of their respective owners.  
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Installation Overview 
Welcome to wInsight 6.5.1. This installation and conversion guide will help you successfully install 
wInsight 6.5.1 on your system and make it work efficiently according to your organization’s 
business structure. 

Installation Prerequisites 
You must have administrator rights to install and uninstall wInsight 6.5.1. If you are not sure 
whether you have administrator rights for a machine, check with your system administrator. 

To install and use wInsight, you need the following items: 
 Windows Vista; or Windows XP Professional with SP2; or Windows 7. 

 At least 80MB of memory. 

 For best performance, Deltek recommends that Internet Explorer 7/8 or Firefox 3.0/3.5 be 
installed for viewing and printing of reports. It need not be your default browser. 

 wInsight supports Oracle® 10g/11g, SQL Server™ 2005/2008, or Access 2007 
databases. 

 38MB of free hard disk space for wInsight and the sample database. Space requirements 
for each installable component and for the system files are as follows: 

 Program Files – 16MB 

 Utility Files – 8342KB 

 Help Files – 4600KB 

 Sample Database – 3457KB 

 Automation Samples – 37KB 

 In addition, you may want to purchase wInsight Administrator, which provides contract 
maintenance, import/ export, data recalculation, and database re-indexing functions. 
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Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® 
Reader® X provides this ability. If you do not already use Adobe Reader X, you can download it 
here free from Adobe.  

To add a custom note using Adobe Reader X, complete the following steps: 

1. On the Reader toolbar, click Comment at far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to 
match the button. 

3. Position the cursor at the location in the guide where you want the note to appear, and 
click. A note icon is inserted at the location and a text box pops up. 

4. Enter your information in the text box.   

5. Continue adding notes as needed. 

6. Save the document. 

 

Deltek recommends that you save the document to a slightly different filename so as to keep the 
original from being overwritten. 

When reading the document, cursor over a note icon to see the information. Double-click a note 
icon to edit the information. 

http://get.adobe.com/reader/
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If You Need Assistance 
If you need assistance installing, implementing, or using wInsight, Deltek makes a wealth of 
information and expertise readily available to you. 

Customer Services 
For over 20 years, Deltek has maintained close relationships with client firms, helping with their 
problems, listening to their needs, and getting to know their individual business environments. A 
full range of customer services has grown out of this close contact, including the following: 

 Extensive self-support options through the Customer Care Connect Web portal. 

 Phone and email support from Customer Care analysts 

 Technical services 

 Consulting services 

 Custom programming 

 Classroom, on-site, and Web-based training 

 

Find out more about these and other services from the Customer Care Connect site. 

Customer Care Connect Site 
The Deltek Customer Care Connect site is a support Web portal for Deltek customers who 
purchase an Ongoing Support Plan (OSP).  

The following are some of the many options you have at the Customer Care Connect site: 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers 
through the Deltek Connect Customer Forums 

 Display or download product information, such as release notes, user guides, technical 
information, and white papers 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Use Quick Chat to submit a question to a Customer Care analyst online 

 Subscribe to Deltek communications about your Deltek products and services 

 Receive alerts of new Deltek releases and hot fixes 

 

If you need assistance using the Customer Care Connect site, the online help available on the 
site provides answers for most questions  
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Access Customer Care Connect 

To access the Customer Care Connect site, complete the following steps:  
1. Go to http://support.deltek.com. 

2. Enter your Customer Care Connect Username and Password. 

3. Click Log In. 

 

If you do not have a username and password for the Customer Care Connect site, contact your 
firm’s wInsight Administrator. 

If you forget your username or password, you can click the Account Assistance button on the 
login screen for help. 

Additional Documentation 
The following table lists the additional Deltek documentation available for this release. Except 
where noted, all the user guides and quick reference guides listed in this table are available for 
download from the Deltek Customer Care Connect site. 

Document Name Description 

Deltek wInsight Online Help This document contains detailed information 
and instructions on how to use various 
features of the application. 

Deltek wInsight Release Notes This document contains a summary of the 
technical considerations, major features, 
enhancements, software issues resolved, and 
known issues of the application. 

http://support.deltek.com/
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Downloading Deltek Products using Deltek 
Software Manager 
You can use Deltek Software Manager (DSM) to download complete Deltek products, hot fixes, 
and sub-releases. You can access DSM directly or through the Deltek Customer Care Connect 
site. 

When you access DSM directly, you will be prompted to log on before you can access the 
application. If you access DSM from within the Deltek Customer Care site, you do not have to log 
on since you are already logged into the Customer Care site. 

Accessing DSM Directly 
To access Deltek Software Manager directly, complete the following steps: 

1. Launch Deltek Software Manager by taking one of the following actions: 

 Click here.  

 On your desktop, click Start » All Programs » Deltek Software Manager. 

2. In the Deltek Software Manager logon dialog box, enter your Deltek Customer Care User 
ID and Password, and click Logon. 

3. To select the folder where you want to download Deltek products, click Settings above 
the right pane of Deltek Software Manager. 

 

When you log on for the first time, Deltek Software Manager asks you to select a 
default folder where Deltek products are to be downloaded.  

4. Use the Settings dialog box to specify the folder where you want to download Deltek 
products, and click OK.  

 

You can change this folder anytime on the Settings dialog box.  

5. In the left pane of Deltek Software Manager, expand the Deltek product that you want to 
download, if it is not already expanded.  

 

If you clicked the link in step 1 to access DSM, the application automatically selects 
wInsight for you. 

6. Select the product type that you want to download. Your options are Complete, HotFix, 
and Sub-Release. 

7. In the table, select the check box that corresponds to the Deltek product that you want to 
download. The right pane displays a message stating that the product has been added to 
the download queue. 

 

To view the items in the download queue, click View Download Queue at the bottom 
of the left pane.  

https://dsm.deltek.com/DeltekSoftwareManager/DeltekSoftwareManager.application?ProductVersionID=723D97A4-F10E-4B29-9C0E-6E5FA8B61CE1
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8. Click Download at the bottom of the left pane. Deltek Software Manager downloads the 
product to the folder that you selected.  

Accessing DSM from within the Customer Care Connect Site 
To access Deltek Software Manager from within the Customer Care Connect site, complete 
the following steps: 

1. In your Web browser, go to http://support.deltek.com.  

2. Enter your Customer Care Connect Username and Password, and click Log In. 

3. When the Customer Care Connect site displays, click the Product Downloads tab. 

You are automatically logged into Deltek Software Manager. 

4. To select the folder where you want to download Deltek products, click Settings above 
the right pane of Deltek Software Manager. 

 

When you log on for the first time, Deltek Software Manager asks you to select a 
default folder where Deltek products are to be downloaded.  

5. Use the Settings dialog box to specify the folder where you want to download Deltek 
products, and click OK.  

 

You can change this folder anytime in the Settings dialog box.  

6. In the left pane of Deltek Software Manager, expand the Deltek product that you want to 
download, if it is not already expanded.  

7. Select the product type that you want to download. Your options are Complete, HotFix, 
and Sub-Release. 

8. In the table, select the check box that corresponds to the Deltek product that you want to 
download. The right pane displays a message stating that the product has been added to 
the download queue. 

 

To view the items in the download queue, click View Download Queue at the bottom 
of the left pane.  

9. Click Download at the bottom of the left pane. Deltek Software Manager downloads the 
product to the folder that you selected.  

DSM Documentation and Troubleshooting 
 To view the online help for Deltek Software Manager, click here. 

 To view a tutorial on how to use Deltek Software Manager, click here.  

 To view more information on troubleshooting Deltek Software Manager, click here. 

 

The above troubleshooting link will only work if you are logged into Deltek Customer 
Care Connect. 

http://support.deltek.com/
https://dsm.deltek.com/DeltekSoftwareManager/Help/
https://dsm.deltek.com/DeltekSoftwareManager/Tutorial/PubData/Engine/Default.htm?https%3A%2F%2Fdsm.deltek.com%2FDeltekSoftwareManager%2FTutorial%2FPubData%2F
https://deltek.custhelp.com/app/answers/detail/a_id/52469
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Installing wInsight 
Use the following procedures to install wInsight 6.5.1. First-time installation options are different 
from re-installation options. 

 

If you are re-installing wInsight, see Modifying, Repairing, and Uninstalling wInsight. 

If you are upgrading from an earlier version of wInsight: 

 Make sure you have recently backed up your wInsight data, especially if it is stored in the 
Sample data source, which uses Sample.mdb; the default directory is C:\Program 
Files\Deltek\wInsight 6.5\data. This database is installed by default and might overwrite 
the existing one, thereby deleting your data. 

 You should back up your custom wInsight 6.5 Views, Filters, and Charts using the File 
» Export Custom Items command. This command creates a WSCUSTOM.XML file. 
After installation, use File » Import Custom Items to restore the custom items. 

To install wInsight, complete the following steps: 

1. Download the wInsight software, using the instructions in the Downloading Deltek 
Products using Deltek Software Manager section. 

2. Go to the location where you saved the wInsight installer. 

3. Double-click DeltekwInsight651.exe to launch the Deltek wInsight 6.5.1 InstallShield 
Wizard. 

4. On the Welcome page, click the Next button. 

 
5. On the License Agreement page, select the I accept the terms in the license 

agreement option and click the Next button. 
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6. On the Setup Type page, select one of the following options and then click the Next 

button: 

 
 Complete — Installs all wInsight components. wInsight will be installed in the 

C:\Program Files\Deltek\wInsight 6.5\ directory by default. Skip to step 7. 

 Custom — Installs only certain wInsight components. This option also allows you to 
change the location where wInsight is to be installed. 
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If you selected the Custom option, the Custom Setup page displays. 

 
Click the Change button if you want to change the directory where wInsight is to be 
installed and then click OK. The default directory is C:\Program 
Files\Deltek\wInsight 6.5\. 

 

7. Back to the Custom Setup page, click one of the  icons to change the features 
installed for any of the following components: 

 Program Files — Installs the wInsight 6.5.1 program files in the destination directory 
and updates essential Windows system files. The default directory is C:\Program 
Files\Deltek\wInsight 6.5\winst\. 



Installing wInsight 

 

Installation and Conversion Guide 10 

 

 Utility Files — Installs the wInsight 6.5.1 Convert utility (Convert.exe), which 
converts earlier wInsight contracts into a wInsight 6.5.1 database, and other utilities. 
The default directory is C:\Program Files\Deltek\wInsight 6.5\util\. 

 Help Files — Installs online help for wInsight 6.5.1. The default directory is 
C:\Program Files\Deltek\wInsight 6.5\help\. 

 Sample Database — Installs the sample MOH-2 contract, contained in the 
sample.mdb database file. The default directory is C:\Program 
Files\Deltek\wInsight 6.5\data\. 

 Automation Samples — This option installs a number of Excel spreadsheets 
containing various macros illustrating wInsight's Automation interface. The default 
folder is C:\Program Files\Deltek\wInsight 6.5\util\. 

8. Click the Next button when you finish selecting the components to install and/or 
identifying the installation directory. The Ready to Install the Program page informs you 
that you are ready to start the installation.  

 
9. Click the Install button to start the installation process.The Installing Deltek wInsight 

6.5.1 page displays the installation progress. 
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After successfully installing wInsight, the InstallShield Wizard Completed page displays.  

10. Click the Finish button to exit the InstallShield Wizard. You can select the check box to 
launch the application after installation is completed.  

 

 

The wInsight 6.5.1 database has changed. You must convert your database to the 6.5.1 format 
before you can access data with wInsight 6.5.1. For more information, see Conversion 
Overview. 

If you are upgrading from an earlier version of wInsight, you may need to restore custom views, 
filters, and charts. To do this, click File » Import Custom Items. 
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Upgrading from wInsight 6.5 
Installing wInsight 6.5.1 automatically removes your wInsight 6.5 installation.  

You can also uninstall wInsight 6.5 by using any of the following methods: 

 Use Windows’ Programs and Features to remove wInsight 6.5. 

 Run the wInsight 6.5 installer, select the Remove option on the Program Maintenance 
page, and click the Next button to uninstall the program. 

After uninstalling wInsight 6.5, run the wInsight 6.5.1 installer to install wInsight 6.5.1. 

Using the blank651.mdb Database File 
Whether or not you installed the sample database, wInsight installs a blank651.mdb database 
file (the default directory is C:\Program Files\Deltek\wInsight 6.5\data\Access\. This database 
file contains no contracts. Use it when you want to start a new group of contracts, without having 
to delete existing ones.  

Use wInsight Administrator to add contracts to a new database. For more information on setting 
up a new database and building a data source connection to it, see the Maintaining Databases 
section of the online help. 

Customizing Functions at Startup 
You can customize certain wInsight functions at startup. 

 

For information about these options, see Advanced Set-Up Options. 
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Installing wInsight on a Client/Server Setup 

Installation Procedures 
You can install wInsight 6.5.1 files (.exe, .dll, .htm) and other related files on an application server 
and then run from a client PC. The software executes on the client PCs even though all wInsight 
files are stored on the server. 

However, certain files must reside on the client PC (for example, MDAC 2.5), and certain .DLL 
files must be registered. You should create a shortcut on the client PC to launch wInsight. 

Use the following procedure to set up wInsight to run from an application server. This setup 
requires you to install wInsight only on the application server and not on the client PCs. 

To perform a manual installation, complete the following steps: 
1. Install wInsight on the application server (see Installing wInsight). 

 

Make sure MDAC 2.5 or higher is installed on each client PC. Microsoft Windows 
Server 2003, 2008, and 2008 R2 have MDAC already installed and Microsoft Office 
2000 installs MDAC. If the client PCs have either of these two products, you do not 
need to install MDAC on each client.  

2. On the client PC, create a mapped drive to the wInsight folder (C:\Program 
Files\Deltek\wInsight 6.5) on the application server. 

To map a network drive: 

a. Open My Computer. 

b. On the Tools menu, click Map Network Drive. The Map Network Drive page 
displays. 

c. In the Drive drop-down list, enter or select the drive letter to map the shared 
resource. 

d. In the Folder drop-down list, enter the application server name and the share name, 
for example, \\server name\share name. You can also click Browse to locate the 
resource. 

e. Click Finish. 

3. Download DeltekwInsightClientRequirements.exe from https://support.deltek.com and 
run on the client PC. 

4. From the client PC, locate and run the DoRegAll.bat file in the C:\Program 
Files\Deltek\wInsight 6.5\bin folder on the application server. 

5.  From the client PC, locate the Winst.exe file in the C:\Program Files\Deltek\wInsight 
6.5\winst folder on the application server and create a shortcut on the client PC. 
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Installation Issues 
Installing wInsight on an application server on a Local Area Network (LAN) brings up a number of 
issues: 

 Regardless of where the application files are installed, the wInsight database can be 
located on a file server accessing a shared MS Access .MDB file or on a database server 
running Oracle or SQL Server. An MS Access .MDB file can even be accessed if it 
resides on the client PC. 

 Users do not need any write privileges on the application server, unless they need to 
create a data source. In that case, they need to be able to write to the WSDATA.INI file 
stored in the BIN folder (the default folder is C:\Program Files\Deltek\wInsight 6.5\bin). 
However, users do need Read, Write, Create, and Delete privileges to the directory 
storing the wInsight MS Access (.MDB) database. 

 A metering software that provides the ability to protect the WSMDE.exe file is required. 
This commercially available software protects the file from being used at the same time 
by more than the authorized number of users, so as not to violate your license 
agreement. Windows NT also provides the ability to restrict the number of concurrent 
users given access to the executable file.  

 

For more information, please consult your NT network administrator. 

Installation Notes 
 The Microsoft Windows Installer can perform an administrative installation of an 

application or product to a network for use by a workgroup. Administrators can run an 
administrative installation from the command line by using the “/a” command line option. 
Then, users can install the product from the network to run the application. Users can 
choose to "run-from-source" and the installer will use most of the product's files directly 
from the network. 
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Modifying, Repairing, or Uninstalling wInsight 
wInsight provides facilities for changing which features are installed, repairing installation errors, 
and removing wInsight. Use the procedure in this section to change your wInsight installation 
structure.  

To modify, repair, or remove your wInsight installation, complete the following steps: 

1. Go to the location where you saved the wInsight installer. 

2. Double-click DeltekwInsight651.exe to launch the Deltek wInsight 6.5.1 InstallShield 
Wizard. 

3. On the Welcome page, click the Next button. 

 
4. On the Program Maintenance page, select one of the following options, depending on the 

task that you want to do: 
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 Modify — Select this option to change your wInsight installation structure. Selecting 

this option displays the Custom Setup page, except that no Change button is 
available. To change the directory where wInsight is installed, you must first uninstall 
wInsight, then re-install in a different directory (see Installing wInsight). 

 Repair — Select this option to repair installation errors by re-installing the wInsight 
components. Selecting this option displays the Ready to Repair the Program page. 
Click Next to continue repairing wInsight. 

 Remove — Select this option to uninstall wInsight from your machine. Selecting this 
option displays the Remove the Program page. Click Next to continue uninstalling 
wInsight. 

5. Click Install (for Modify or Repair) or Remove. The installation or uninstallation progress 
displays. 

6. When the process is completed, click the Finish button to exit the InstallShield Wizard. 



Advanced Set-Up Options 

 

Installation and Conversion Guide 17 

 

Advanced Set-Up Options 

Configuring wInsight to Use Long Element Descriptions 
Configuring wInsight to use the Long Description field requires two steps: 

1. For Sort windows, you must insert the Long Description field (LongDesc) into the Sort 
window or a view that uses the Long Description field. For more information, see the 
Sort Windows Overview section of the online help. 

2. For charts and reports, you must create a Registry setting (a task which should be 
performed by someone familiar with the Registry). The following table identifies the 
Registry setting that controls which description is used. 

Description Option Parameter & Settings 

15 character description No Registry Parameter or Setting (default) 

50 character description LongDesc=1 

To create a long description registry setting, complete the following steps: 

1. Click Start » Run to display the Run dialog box. 

2. Enter either regedit.exe or regedt32.exe and then click the OK button to open the 
Registry Editor. 

3. Navigate to the HKEY_CURRENT_USER\Software\Deltek\wInsight\6.5\Settings key 
folder. 

 
4. Click Edit » New » DWORD Value. A New Value #1 entry is highlighted in the right-hand 

window of the Registry Editor. 

5. Type LongDesc and then press ENTER. The name New Value #1 should be replaced 
with LongDesc. 
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6. Double-click the LongDesc item to open the Edit DWORD Value dialog box. 

7. Under the Base group box, select the Decimal option, enter 1 in the Value Data field, 
and click the OK button. 

 
A "1" at the end of the string of 0's should appear in the Data column on the right side. 

 
8. Click File » Exit to close the Registry Editor. 
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Conversion Overview 
The purpose of this chapter is to describe how to populate a 6.5.1 database with your existing 6.5 
data, so that you can use wInsight 6.5.1.  

Use the instructions in this chapter to: 

 Convert 6.5 data to 6.5.1 

 Recalculate a contract, to check the results of the conversion 

 Back up and restore 6.5 data into a 6.5.1 database 

 

If you are upgrading from the previous Hot Fix, you do not need to apply any database 
updates. 

If you are upgrading from a different upgrade path (for example, 6.5.1 Regulatory 
Release 01 and 6.5.1 Regulatory Release 02), refer to the previous Hot Fix ReadMes, 
which you can download from the Documents tab of the specific hot fix in the Deltek 
Software Manager. 

Converting 6.5 Data to 6.5.1 
This conversion process modifies your existing 6.5 database and changes it into a 6.5.1 
database, It does not copy data from an earlier database to a 6.5.1 database. 

 

No one should be using the database during the conversion process. Deltek 
recommends that you back up your wInsight 6.5 contract(s) before performing the 
conversion. 

Overall Process 
Each subsequent version of the wInsight 6.x database has changed slightly. 

Starting with your current version number, you must convert each wInsight 6.x database 
sequentially to the next version before converting to 6.5.1. For example, if you are currently 
running wInsight 6.3, you start by updating the 6.3 database to 6.3.1, then 6.3.1 to 6.4, then 6.4 to 
6.5. 

The conversion instructions in this section are organized by database type: 

 Oracle 

 MS SQL Server 

 MS Access 

Converting an Oracle Database 
The update scripts used in this procedure call other provided scripts, which must be in the same 
folder as the update scripts. The default location is C:\Program Files\Deltek\wInsight 
6.5\data\Oracle\. 

To convert an Oracle database, you need: 

 wInsight Administrator 6.5.1 installed 

 A 6.5 database 

 A data source connection to that database 

https://dsm.deltek.com/
https://dsm.deltek.com/
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Backing up and restoring your data is an alternative to converting your 6.x database.  
For more information, see Backing Up 6.5 and Restoring into 6.5.1. 

To convert 6.5 data to 6.5.1 on an Oracle database, have your database administrator take 
one of the following actions: 

 If you are upgrading from the previous Hot Fix, you do not need to apply any database 
updates. 

 If you are upgrading from a different upgrade path (for example, 6.5.1 Regulatory 
Release 01 and 6.5.1 Regulatory Release 02), refer to the previous Hot Fix ReadMes, 
which you can download from the Documents tab of the specific hot fix in the Deltek 
Software Manager. 

 

To create a clean wInsight 6.5.1 Oracle database, run the build_winst.sql master 
script. This script calls the connect.sql, ws651.sql, cal.sql, cols.sql, maint.sql, 
recalcs_glbls.sql, cd_reclacs.sql, cc_reclacs.sql, and security.sql. All of these 
scripts must be in the same folder when you run build_winst.sql. 

Converting an MS SQL Server Database 
No one should be using the database during the conversion process. Deltek recommends that 
you back up your wInsight 6.5 contract(s) before performing the conversion. The default location 
for all scripts is C:\Program Files\Deltek\wInsight 6.5\data\MSSQL. 

 

For more information, see wInsight Administrator Online Help. 

To convert an MS SQL database, you need: 

 wInsight Administrator 6.5.1 installed 

 A 6.5 database 

 A data source connection to that database 

 

Backing up and restoring your data is an alternative to converting your 6.x database.  
For more information, see Backing Up 6.5 and Restoring into 6.5.1. 

To convert 6.5 data to 6.5.1 on an MS SQL Server database, have your database 
administrator take one of the following actions: 

 If you are upgrading from the previous Hot Fix, you do not need to apply any database 
updates. 

 If you are upgrading from a different upgrade path (for example, 6.5.1 Regulatory 
Release 01 and 6.5.1 Regulatory Release 02), refer to the previous Hot Fix ReadMes, 
which you can download from the Documents tab of the specific hot fix in the Deltek 
Software Manager. 

 

To create a clean wInsight 6.5.1 SQL database, run the ws651.sql, cal.sql, cols.sql, 
maint.sql, and recalc_procs.sql scripts. 

https://dsm.deltek.com/
https://dsm.deltek.com/
https://dsm.deltek.com/
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Converting an MS Access Database 
To convert an MS Access database, you need: 

 wInsight 6.5.1 or wInsight Administrator 6.5.1 installed 

 A 6.5 database 

 A data source connection to that database 

 

Backing up and restoring your data is an alternative to converting your 6.x database.  
For more information, see Backing Up 6.5 and Restoring into 6.5.1. 

To convert 6.5 data to 6.5.1 on an MS Access database, have your database administrator 
take one of the following actions: 

 If you are upgrading from the previous Hot Fix, you do not need to apply any database 
updates. 

 If you are upgrading from a different upgrade path (for example, 6.5.1 Regulatory 
Release 01 and 6.5.1 Regulatory Release 02), refer to the previous Hot Fix ReadMes, 
which you can download from the Documents tab of the specific hot fix in the Deltek 
Software Manager. 

 

To create a clean wInsight 6.5.1 Access database, use blank651.mdb. 

What’s Next? 
Now you should recalculate a contract to check that the conversion process completed 
successfully. 

 

For more information, see Recalculating a Contract. 

 

 

 

https://dsm.deltek.com/
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Recalculating a Contract  
Deltek recommends that you recalculate one of the contracts after the conversion process is 
complete to check that the data converted successfully. 

To recalculate the database, complete the following steps: 

1. Start wInsight 6.5.1. 

2. Click File » Select Database and select the same data source that you used previously. 

3. Click the OK button. 

4. Click Utilities » Recalculate to display the Recalculate dialog box. 

5. In the Contract list, select one of the contracts just converted. 

6. In the Period list, select <All Periods>. 

7. Click Options to display the Recalculate Options dialog box. 

8. Click the OK button. 

Your data is now ready for use with wInsight 6.5.1 or wInsight Administrator 6.5.1. 



Backing Up 6.5 and Restoring into 6.5.1 
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Backing Up 6.5 and Restoring into 6.5.1 
As an alternative to converting your 6.5 database, you can back up your contracts from your 6.5 
database and restore them into a 6.5.1 database. 

To back up your database: 

1. Start wInsight 6.5. 

2. Click File » Select Database and select the database with the 6.5 contract(s) to back up. 

3. Click Utilities » Backup to back up your contract(s). Note the location (folder) where the 
wInsight 6.5 archive file (.WSA) was saved. 

4. Exit wInsight 6.5. 

To restore your 6.5 data into a 6.5.1 database, complete the following steps: 

1. Start wInsight 6.5.1. 

2. Click File » Select Database to select a 6.5.1 data source. 

 

For more information about setting up and connecting to a database, see the Create a 
New (Blank) and Create a wInsight Data Source sections of the wIInsight Online Help. 

3. Click Utilities » Restore to select your wInsight 6.x archive file (.WSA) and restore your 
6.x contract(s). 

What’s Next? 
Deltek recommends that you recalculate a contract to check that the restore process completed 
successfully. 

 

For more information, see Recalculating a Contract. 

 

 

 

 

 



 

 

Deltek is the leading global provider of enterprise software and information solutions for professional 
services firms, government contractors, and government agencies. For decades, we have delivered 
actionable insight that empowers our customers to unlock their business potential. Over 14,000 
organizations and 1.8 million users in approximately 80 countries around the world rely on Deltek to 
research and identify opportunities, win new business, optimize resource, streamline operations, and deliver 
more profitable projects. Deltek – Know more. Do more.®  
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