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Overview 
Welcome to Deltek Vision 7.3 Release Notes: New Features and Enhancements. This guide 
describes the new enhancements available in this release. 

 

For information regarding installation of the software, software issues resolved, known issues, 
and database changes in this release, refer to the Deltek Vision 7.3 Release Notes: Technical 
Considerations. 

Important Information 

Images for Invoice and Purchase Order Templates 
As of Vision 7.2, you can upload images for customizing billing invoices and purchase orders 
directly from Vision. Previously, a system administrator had to upload images on the Vision 
server. 

To upload the images into Vision, click the Image option on the toolbar of the Invoice Template 
Editor form in Billing » Invoice Template Editor or the Purchase Template Editor form in 
Purchasing » Purchase Template Editor. On the Available Images dialog box, select the 
images to upload into Vision. For detailed instructions, see the “Upload Custom Images for 
Invoice Templates” and “Upload Custom Images in Purchase Template Editor” topics in the 
online Help. 

To add uploaded images to an invoice or purchase order template, open the template, and on the 
Images tab on the template editor form, insert the images in the grid. For detailed instructions, 
see the “Use Custom Images on Invoices” and “Use Custom Images on Purchasing Invoices” 
topics in the online Help. 

 

Uploading images directly on the Vision server is no longer supported.  

If you are upgrading to Vision 7.3 from Vision 7.1 or earlier: Existing images that you added 
to Vision in version 7.1 and earlier must be uploaded again into Vision using the Image option 
on the toolbar on either the Invoice Template Editor form or the Purchase Template Editor form. 
Then you must use the Images tab on these template editor forms to associate uploaded images 
with the invoice and purchase order templates that use the images. If you do not re-upload and 
re-insert the images, they will be missing from invoices or purchase orders when you print them. 

Upgrading from an Earlier Vision Version 
If you are upgrading to Vision 7.3 from a version earlier than Vision 7.2, you should read the 
release notes of Vision 7.2, 7.1, 7.0 SP1, 7.0, 6.2, and any prior relevant versions to ensure that 
you understand all of the technology, software changes, and enhancements that have been 
implemented and how these changes may affect you. 

You can download the release notes from the Deltek Customer Care Connect site. 

http://support.deltek.com/


For Additional Information 

 

Release Notes: New Features and Enhancements 2 

 

For Additional Information 

Customer Care Connect Site 
The Deltek Customer Care Connect site is a support Web site for Deltek customers who 
purchase an Ongoing Support Plan (OSP).  

The following are some of the many options that the Customer Care Connect site provides: 

 Search for product documentation, such as release notes, install guides, technical 
information, online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers 
through the Deltek Connect Customer Forums 

 Access Cloud specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Use Quick Chat to submit a question to a Customer Care analyst online 

 

For more information regarding Deltek Customer Care Connect, refer to the online help available 
from the Web site. 

Access Customer Care Connect 

To access the Customer Care Connect site, complete the following steps:  

1. Go to http://support.deltek.com.  

2. Enter your Customer Care Connect Username and Password. 

3. Click Log In. 

 

If you forget your username or password, you can click the Account Assistance button on the 
login screen for help. 

Documentation for this Release 
The table below lists the Deltek documentation available for this release. You can download this 
documentation from the Deltek Customer Care Connect site—on the Product Download page or 
on the Enterprise Search page using the Release Documents search. 

 

Starting with Vision 7.3, the release notes have been split into two separate documents: 

 Deltek Vision 7.3 Release Notes: New Features and Enhancements 

 Deltek Vision 7.3 Release Notes: Technical Considerations  

http://support.deltek.com/
http://support.deltek.com/


For Additional Information 

 

Release Notes: New Features and Enhancements 3 

 

Vision 7.3 Documentation 
*Any document that is not relevant to Deltek Vision Essentials cloud customers is marked with an asterisk. 

Deltek Vision Release Notes 

Deltek Vision Release Notes: New 
Features and Enhancements 

These release notes contain a summary of the enhancements 
introduced in Vision 7.3. 

Deltek Vision Release Notes: 
Technical Considerations 

These release notes describe the installation requirements, 
software issues resolved, known issues, and database changes in 
Vision 7.3. 

Deltek Vision Getting Started and Concepts Guides 

Deltek Vision Getting Started 
Guide 

This guide contains information about the Vision interface and all 
the Vision applications, with tips for navigating through the system, 
using the dashboard, and finding and opening records. 

Deltek Vision Concepts Guide This guide describes the concepts underlying the basic accounting, 
project control, and customer relationship management (CRM) 
functions of the Vision application. 

Deltek Vision Installation and Implementation Guides* 

Deltek Vision Technical 
Installation Guide* 

This guide contains detailed instructions for installing all the 
technical components of Vision, including the servers, the 
database, and the application itself. 

Deltek Vision Advanced Technical 
Administration Guide* 

This guide provides IT staff and system administrators with 
instructions for installing and configuring advanced technical 
components of Vision. 

Deploying Deltek Vision at a 
Hosting Provider* 

This guide contains instructions for deploying Deltek Vision at a 
hosting provider. 

Deltek Vision Implementation 
Guide* 

This guide contains information about configuring and setting up 
Vision applications and features. 

Deltek Vision Migration Guides* 

Deltek Advantage to Deltek Vision 
Migration Guide* 

This guide contains information about migrating from Advantage to 
Vision, including the steps in the migration process and an 
overview of Vision features. 

Deltek FMS to Deltek Vision 
Migration Guide* 

This guide contains information about migrating from FMS to 
Vision, including the steps in the migration process, discussions of 
the key migration decisions, and procedures for verifying the 
converted data. 

Deltek Sema4 to Deltek Vision 
Migration Guide* 

This guide contains information about migrating from Sema4 to 
Vision, including the steps in the migration process and an 
overview of Vision features. 
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Vision 7.3 Documentation 
*Any document that is not relevant to Deltek Vision Essentials cloud customers is marked with an asterisk. 

Deltek Vision Quick Reference Cards 

Deltek Vision Quick Reference 
Cards 

Quick reference cards provide snapshots of specific business 
processes or Vision forms, with tips for entering data and using 
application toolbars. The following quick reference cards are 
available: 

 Accounts Payable (Create a Voucher from a Purchase Order) 

 Create Client from Vendor Utility 

 Dashboard 

 Expense Report 

 Navigation Tree Designer 

 Project Planning 

 Purchasing (Create a Standard Purchase Order) 

 Resource Management (Generic Resource Assignments and 
Resource Utilization) 

 Screen Designer 

 SF330 Proposals 

 Template Based E-mails 

 Timesheet 

 User Options 

 Visualization 

Deltek Vision Document Management Guide* 

Deltek Vision Document 
Management Installation Guide* 

This guide contains detailed information on the necessary 
prerequisites, general configuration, and installation procedures 
required to use the Vision Document Management application. 

Deltek Vision Interface to Microsoft Project Guide* 

Deltek Vision Interface to 
Microsoft Project 2010* 

This guide describes how the manual scheduling feature in 
Microsoft Project 2010 impacts the two-way interface between 
Deltek Vision and Microsoft Project 2010. 

Deltek Vision Performance Management Guides (Analysis Cubes and Performance 
Dashboards)* 

Deltek Vision Installation Guide 
for Performance Management 
(Analysis Cubes and Performance 
Dashboards)* 

This guide provides instructions on how to install and configure the 
following components of the Deltek Vision Performance 
Management module: 

 Analysis Cubes 

 Performance Management Dashboards 
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Vision 7.3 Documentation 
*Any document that is not relevant to Deltek Vision Essentials cloud customers is marked with an asterisk. 

Deltek Vision Performance 
Management Content and 
Functionality Overview* 

This guide provides an overview of Vision Performance 
Management functionality and the pre-built visualizations that are 
included with it. 

Tableau Server 8.1 Administrator 
Guide* 

This administrator guide, produced by Tableau Software, Inc., is a 
complete reference for handling administrative tasks in Tableau 
Server. Use Tableau Server and Tableau Desktop, along with 
Vision Analysis Cubes and Microsoft SQL Server Analysis 
Services components, to create role-based graphical performance 
dashboards. 

Deltek Vision Reporting Guides* 

Deltek Vision Custom Reports 
and Microsoft® SQL Server 
Reporting Services* 

This guide provides instructions to create, deliver, and generate 
Vision custom reports with Microsoft SQL Server Reporting 
Services and its report writing tools. 

Deltek Vision Microsoft SQL 
Server Reporting Services 
Licensing FAQ* 

This guide explains the Microsoft SQL Server Reporting Services 
licensing implications for Vision. 

Deltek Vision Connect for Microsoft Outlook Guides 

Deltek Vision Connect for 
Microsoft Outlook Installation 
Guide 

This guide contains an overview of Vision Connect for Microsoft 
Outlook, as well as technical installation, setup, and maintenance 
information. 

Deltek Vision Customizing 
Configuration Settings for 
Connect for Microsoft Outlook 

The guide is intended for system administrators, IT staff, or custom 
developers. It provides instructions on how to create presets to: 
configure default behavior for converting Microsoft Outlook 
contacts; control the display of the Synchronization Control Panel 
when issues occur during synchronization; and implement default 
and custom synchronization filters. 

Deltek Vision Connect for 
Microsoft Outlook Frequently 
Asked Questions 

This document contains frequently asked questions (FAQs) on 
topics regarding deployment, customization, environment, usage, 
and functionality. 

Deltek VisionXtend Guides 

Deltek VisionXtend Web Services 
and APIs for Deltek Vision 

This guide explains how to use the Deltek VisionXtend platform to 
integrate Vision with other applications, access web services, 
implement data validation routines, and establish workflow 
procedures using the Microsoft .NET Framework. 

Deletk VisionXtend Testing the 
Vision Web APIs / Web Services 

This guide provides basic information about testing Vision APIs 
using soapUI.  
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Vision 7.3 Documentation 

Deltek Vision Project Connect Guides* 

Deltek Vision Project Connect 
Installation and Administration 
Guide* 

This guide contains detailed information on installing and 
administering Project Connect for integrating Microsoft Project with 
Deltek Vision. 

Deltek Vision Project Connect 
User’s Guide for Microsoft Project 
2010* 

This guide contains information for integrating Microsoft Project 
2010 with Deltek Vision. 

Deltek Vision Project Connect 
User’s Guide for Microsoft Project 
2007* 

This guide contains information for integrating Microsoft Project 
2007 with Deltek Vision. 

Deltek Vision Navigator Guides 

Deltek Vision Navigator 1.9 
Release Notes: New Features and 
Enhancements  

These release notes contain a summary of the enhancements 
introduced in Navigator 1.9. 

Deltek Vision Navigator Version 
1.9 Release Notes: Technical 
Considerations 

These release notes describe the installation requirements,  
software issues resolved, known issues, and database changes in 
Navigator 1.9. 

Deltek Vision Navigator Version 
1.9 Installation Guide 

This document describes the server prerequisites, client 
requirements, and installation information for Deltek Vision 
Navigator. 

Deltek Vision Navigator Version 
1.9 Integration Guide  

This guide contains details on how the Vision application integrates 
with Deltek Vision Navigator and provides descriptions of the 
various changes to the Navigator help. Refer to the topics in this 
guide for the most current information. 

Deltek Vision Navigator Version 
1.9 Frequently Asked Questions  

This document contains frequently asked questions about general 
product details on the use and configuration of the Deltek Vision 
Navigator product. 
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New Features and Enhancements 
This section includes summaries of the new features and enhancements included in this release. 

Compensation Breakout Enhancements 
Compensation is defined as the contractual amount that you expect to receive for a given project 
or engagement. In Vision 7.2, the total compensation was represented by the compensation 
(labor and direct expense fee), consultant fee (direct consultant fee), and reimbursable allowance 
amounts.  

In Vision 7.3, total compensation is further broken down into labor, direct expense, direct 
consultant, reimbursable expense, and reimbursable consultants: 

 Compensation — The project's compensation is automatically calculated by summing 
the Direct Expense and Direct Labor fields on the Budget & Revenue tab in the Project 
Info Center. You cannot edit the Compensation field; it is display-only and is updated 
when changes are made to the direct expense and direct labor amounts for the project.  

 Reimbursable Allowance — The project's reimbursable allowance is automatically 
calculated by summing the Reimbursable Expense and Reimbursable Consultants 
fields on the Budget & Revenue tab in the Project Info Center. You cannot edit the 
Reimbursable Allowance field; it is display-only and is updated when changes are 
made to the reimbursable expense and reimbursable consultant amounts for the project.  

 The sum of the amounts in the Compensation (Direct Labor plus Direct Expense), 
Direct Consultant, and Reimbursable Allowance (Reimbursable Expense plus 
Reimbursable Consultant) fields on the Budget & Revenue tab in the Project Info 
Center represent the total amount of fee that you expect to receive over the life of the 
project.  

 

Because the Compensation, Consultant Fee (Direct Consultant Fee), and Reimbursable 
Allowance fields in Vision 7.2 also exist in Vision 7.3, any existing reports or custom items using 
these fields will continue to function as they did prior to Vision 7.3. 

Field Conversion Information 
The following table identifies the new fields and field conversions for compensation that occur 
automatically when you upgrade from an earlier version of Vision to Vision 7.3.  

Fields in 7.3 Field Description 

Compensation  In Vision 7.3, this field is the sum of the values in the Direct 
Labor and Direct Expense fields (both new fields in 7.3). 

In Vision 7.2 and earlier, you manually entered a value in the 
Compensation field.  

Direct Labor This new field in Vision 7.3 displays the value from the Vision 
7.2 or earlier Compensation field. 

Direct Expense This new field in Vision 7.3 is set to 0. 
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Fields in 7.3 Field Description 

Direct Consultant This new field in Vision 7.3 displays the value from the Vision 
7.2 and earlier Consultant Fee field. 

Reimbursable Allowance In Vision 7.3, this field is the sum of the values in the 
Reimbursable Expense and Reimbursable Consultant 
fields (both new fields in 7.3). 

In Vision 7.2 and earlier, you manually entered a value in the 
Reimbursable Allowance field. 

Reimbursable Expense This new field in Vision 7.3 displays the value from the Vision 
7.2 or earlier Reimbursable Allowance field. 

Reimbursable Consultant  This new field in Vision 7.3 is set to 0. 

Configuration 
The following Vision configuration settings affect how you see compensation values in the Project 
Info Center (Budget & Revenue tab and Contract Management tab) and in Project Planning (Cost 
Analysis tab and Billing Analysis tab): 

Software Path Settings/Options 

Configuration » Accounting » 
System Settings » General tab 

 Project Fee Entering Method settings 

 Synchronize Fees from Contract to Plan check 
box 

Configuration » Planning » 
Plan Settings » General tab 

 Synchronize Fees from Contract to Plan check 
box 

 Limit Plan Fees from Contract Totals check box 

 Plan Compensation Values by Row & Period 
check box 

Configuration » Security » 
Roles » Planning tab 

 Allow Changes to Direct Labor Fee check box 

 Allow Changes to Direct Expense Fee check 
box 

 Allow Changes to Direct Consultant Fee check 
box 

 Allow Changes to Reimbursable Expense Fee 
check box 

 Allow Changes to Reimbursable Consultant 
Fee check box 
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Compensation Breakout Changes Throughout the Software 
The compensation breakout changes impact the tabs, fields, calculations, and labels in several 
areas of Vision. Many of these updates are summarized in the following sections. 

Info Center » Projects » Budget and Revenue Tab  

 The Compensation field now accommodates the change in calculation where it is 
display-only and is based on amounts entered in Direct Labor and Direct Expense 
fields. 

 These fields were added under each Currency type: Direct Labor, Direct Expense, 
Reimbursable Labor, Reimbursable Expense. 

 The Consultant Fee field label was changed to Direct Consultant. 

 The Reimbursable Allowance field now accommodates the change in calculation where 
it is display-only and updates based on amounts entered in Reimbursable Labor and 
Reimbursable Expense fields. 

 The Total fields were added. 

Info Center » Project » Contract Management Tab 

 The Compensation field now accommodates the change in calculation where it is 
display-only and is based on amounts entered in Direct Labor and Direct Expense 
fields. 

 The following fields were added: Direct Labor, Direct Expense, Reimbursable Labor, 
Reimbursable Expense. 

 The Consultant Fee field label was changed to Direct Consultant. 

 The Reimbursable Allowance field now accommodates the change in calculation where 
it is display-only and is based on amounts entered in Reimbursable Labor and 
Reimbursable Expense fields. 

 The Total fields were added. 

Accounting » Project Review 

The General tab in Project Review was removed and replaced with the following new tabs to 
accommodate the new compensation breakout fields: 

 Billing 

 Cost 

 

In Vision 7.3, the default entry in the Budget Source field is Planning instead of Budget 
Worksheet, which disables the Update % toolbar button in Project Review. You must change 
the Budget Source to Budget Worksheet to update the percent complete for the selected 
projects. 

Planning » Project Planning » Analysis Tab 

Project Planning was updated to support the compensation breakout changes as well. The 
Analysis tab of Project Planning was removed and replaced with the following new tabs: 

 Cost Analysis  

 Billing Analysis  
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Planning » Project Planning » Summary Tab 

The Compensation grid was removed and two new grids were added: Cost Summary grid and 
Billing Summary grid.  

Planning » Project Planning » Budget Calculator 

This calculator now includes compensation breakout fields. 

Configuration » General » Project Templates and Configuration » General » Project 
Defaults 

The Project Templates and Project Defaults features were updated to support the compensation 
breakout fields. 

Configuration » Security » Roles » Planning Tab 

The Planning tab of Role Security includes a new Analysis section and associated fields.  

Reporting » Project Reports 
You can now add columns to the following Project reports to display the new compensation fields: 

 Contract Management 

 CRM Project Summary 

 Office Earnings 

 Project Earnings 

 Project List 

 Project Summary 

Reporting » Data Export 
You can now add columns to the following Data Export reports to display the new compensation 
fields: 

 Project List Export 

 Project Expense Export 

 Project Labor Export 

 Project Summary Export 

Reporting » Project Planning 
You can now add columns to the Project Planning Analysis report to display the new 
compensation fields. 

The new compensation fields are also available on the Project Planning Schedule report. The 
Options tab on the Options dialog box for the report has additional check boxes that you can use 
to include or exclude those fields. 

Reporting — Advanced Search 
If you add a column for one of the new fields to a report, you can use that as part of your search 
criteria. To do so, preview the report and do an advanced search. 
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Accounting » Budgeting » Project Budgeting 
The Cost Summary tab and Billing Summary tab of the Budget Summary dialog box have been 
redesigned to incorporate the new compensation fields. In addition, calculated amounts and 
percentages on the tabs are now updated automatically as you enter values. The Calculate 
buttons, previously used to recalculate values based on your entries, have been removed. 

Billing » Interactive Approvals 
The new compensation fields now display in the Project Fees section on the General tab of 
Interactive Approvals. 

Utilities » Data Import 
The table formats for the following imports now include the new compensation fields: 

 Projects 

 Projects – Contract Details 

Utilities » Search and Replace 
The new compensation fields are not included among the fields you can update using the Search 
and Replace utility. In addition, the compensation fields that were included previously in the 
Search and Replace utility have been removed. 

Credit Card Feature 
The new Credit Card feature in Vision allows you to reconcile the credit card charges from your 
credit card company with the expenses entered in Vision that were paid with the company-issued 
credit cards.  

After you enable and configure the Credit Card feature: 

 The employees who are responsible for reconciling credit card statements create the 
statements in Vision. They import the credit card charges from a credit card company into 
the statements. 

 On expense reports, employees (the cardholders) add a charge that they made with a 
company-issued credit card by selecting the charge from a list of imported charges on the 
Expense Report form. Only the charges that they made are included in the list. 

 You can set up alerts to notify employees that imported credit card charges that apply to 
them are ready to add to an expense report. 

 When you enter an A/P disbursement, you can specify that the vendor invoice was paid 
with a credit card rather than a check or electronic payment. 

 The employees who are responsible for reconciling credit card statements: clear the 
imported charges that have a matching posted expense report or A/P disbursement 
transaction in Vision; identify and follow up on missing credit card charges; and close the 
statement after all charges are reconciled. 

Configuration 

You enable the Credit Card feature by company for each appropriate company in your enterprise. 
You must select the Allow entry of company paid items check box on the Setup tab in 
Configuration » Time & Expense » Company Expense. Then you turn on the Credit Card 
feature on the General tab in Configuration » Accounting » Company Settings. 
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You set up primary credit cards and their associated secondary credit cards that are issued to 
employees in Configuration » Accounting » Credit Card. You also specify the content and 
formatting information for the credit card charges import file. 

Alerts 
The following alerts in the Expense folder in Configuration » General » Company Alerts can be 
set up to notify employee about the imported charges: 

 New Credit Card Transactions Available — This alert notifies the appropriate 
employees when a new credit card charge that they made has been imported into Vision, 
and is ready to add to an expense report. 

 Past Due Credit Card Transactions — This alert is sent to employees and, optionally, 
their supervisors after a certain number of days has passed without the imported 
expense being posted on an expense report. 

Credit Card Reconciliation 

In Accounting » Credit Cards » Credit Card Reconciliation: 

 You create credit card statements and import charges from your credit card company into 
the statement. 

You can create a credit card statement in Vision before the actual credit card statement is 
finalized by your credit card company. This allows you to import credit card charges into 
Vision on an ongoing, regular basis throughout the month as your credit card company 
posts the charges and makes the information available to you through their website. This 
allows employees to add imported charges to their expense reports in a timelier manner. 

You import charges for a primary credit card, which includes the charges for all the 
associated secondary credit cards that are issued to employees. 

 The imported credit card charges are matched automatically with the credit card charges 
that are posted on employee expense reports and A/P disbursements. 

 The charges that have a matching imported charge and posted Vision expense report or 
A/P disbursement charge can be cleared automatically by Vision, or you can clear them 
manually. 

 You identify the credit card charges that have not yet been entered in Vision, and when 
all charges are reconciled and cleared, you close the statement. 

 If you use cash-basis accounting, you can create a cash-basis journal entry for all the 
cleared company-paid charges on a statement that is completely reconciled. 

Processing Credit Card Expenses in Vision 
You record expenses that are paid with company-issued credit cards in the following places in 
Vision: 

 On an expense report in Time & Expense » Expense Report — If you import credit card 
charges into Vision for a credit card, the charges made by an employee that have been 
imported into Vision display in a list on the Expense Report form. Employees add the 
imported charges from this list to an expense report. After an imported charge is added to 
an expense report, it displays on the Charges tab in Credit Card Reconciliation.  

If you do not import credit card charges into Vision for a credit card, employees enter 
expenses that they pay with company-issued credit cards as they normally would on an 
expense report by specifying that the expense is company paid and which credit card it is 
associated with. 
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 As an A/P disbursement in Transaction Center » Transaction Entry — You enter an 
A/P disbursement and specify that it was paid with a company-issued credit card (rather 
than a check or electronic payment). After the disbursement is posted, it displays on the 
Charges tab in Credit Card Reconciliation. 

Credit Card Review 

In Accounting » Credit Cards » Credit Card Review you can enter criteria to search for and 
view the credit card charges that were imported into Vision from your credit card company and 
the charges that were entered on expense reports and as A/P disbursements. 

Using the Credit Card Reconciliation Application Without Using the Import 
Feature  
It is possible to use the Credit Card feature without importing credit card charges into Vision. In 
this scenario, the posted expense report and A/P disbursement credit card transactions display 
automatically in the Credit Card Reconciliation application. You manually compare and reconcile 
these with your paper credit card statement. 

You choose whether or not to import charges on a credit card by credit card basis. 

Transaction Auto Numbering by Company for Accounts Payable 
Vouchers 
If you have multiple companies in Vision, you can now maintain a separate sequence of 
automatically assigned numbers for A/P vouchers for each of your companies. To support this 
feature, a new Starting Voucher field and Ending Voucher field have been added to the 
Transaction Entry Auto Numbering grid on the Transaction Auto Numbering tab in Configuration 
» Accounting » System Settings. The voucher numbers are automatically assigned when you 
post A/P vouchers, A/P disbursements, and vouchers that you create from purchase orders. 

 

If you currently use transaction auto numbering for A/P vouchers and you are upgrading to 
Vision 7.3: After Vision 7.3 has been installed, you must enter the starting and ending voucher 
numbers in Accounting System Settings before you can post A/P vouchers, A/P disbursements, 
and A/P vouchers created from purchase orders. The posting routine will not proceed until the 
range of numbers has been set up for all your companies.  

AR Invoice Review Dashpart 
A new dashpart type—AR Invoice Review—has been added to Vision. You select this type in the 
Dash Part Type field when you add a system dashpart in Vision. (Click Dashboard on the 
toolbar of the main Vision screen, and then click Configure on the toolbar of the Dashboard 
form.) 

The system dashpart must be made available to a role on the Access Rights tab in Roles Security 
Configuration before it can be used. 

When you configure a AR Invoice Review dashpart, you select the projects whose invoices you 
want to include in the dashpart. 

When the dashpart displays in the Dashboard, click the drop-down arrow beside the title in the 
dashpart heading bar, and select Aging to choose an aging date for the invoices that display in 
the dashpart. 
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The fields at the top of the AR Invoice Review dashpart allow you to filter the invoices and choose 
which invoices display in the Aged Accounts Receivable grid, based on invoice status (all, paid in 
full, or unpaid) and time frame (period, period range, date range, job-to-date, or year-to-date).  

The View Detail option on the Aged Accounts Receivable grid of the dashpart allows you to: 

 View more detail for an invoice. If an invoice was created in Interactive Billing, you can 
view the invoice itself. 

 View information for the last cash receipt received for an invoice. 

 Enter comments for an invoice. 

Dashboard Column Selection for System Dashparts 
You can now select the columns that display for the following system dashpart types: 

 Clients 

 Contacts 

 Employees 

 Leads 

 Marketing Campaigns 

 Opportunities 

 Projects 

 Vendors 

 User-defined Info Centers 

For a system dashpart that displays on your dashboard, click the drop-down  next to the 
dashpart name. From the shortcut menu, select Select Fields to add or remove columns for a 
dashpart. 

WBS 2 and WBS 3 for Project Dashparts 
For project type system dashparts, Phase Number, Phase Short Name, Task Number, and 
Task Short Name have been added to the drop-down list in the Search Field, in the grid on the 
Advanced Project Lookup dialog box. You access this dialog box when you click Add in the 
Dashpart Configuration dialog box. These new fields allow you to search by phases and tasks 
(WBS 2 and WBS 3) when you add project records to be displayed on a project dashpart. 

View Supporting Documents in Project Review 
In Accounting » Project Review, you can now view supporting documents that have been 
attached to expenses on employee expense reports and A/P vouchers.  

 You upload and attach the documents to employee expense reports in Time & Expense 
and on the Expenses tab in Interactive Billing.  

 You upload and attach the documents to A/P vouchers in A/P Vouchers Transaction 
Entry and on the Expenses tab in Interactive Billing. 
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To view supporting documents in Project Review, complete the following steps: 

1. On the Project Review form, click either the Cost tab or Billing tab. 

2. Click the blue, underlined amount in one of the following fields—Direct Consultant, 
Direct Expense, Reimbursable Consultant, Other Reimbursable. 

3. On the drill-down dialog box that opens, click the blue, underlined amount in the Amount 
field in the grid for the employee or vendor whose supporting documents you want to 
view. 

4. On the next drill-down dialog box, click the  icon with the green check mark in the 
Document field in the grid for the specific expense item whose supporting document you 
want to view.  

5. On the Supporting Document dialog box, select the document to view, and click  View 
to open and view the document. 

Default Currencies for Projects Created from Opportunities 
If you use the Multicurrency feature, when you create a new project from an opportunity, Vision 
determines the default project and billing currencies as follows: 

 Project currency — This is the cost currency from the Service Estimate tab of the 
Opportunity Info Center or, if service estimates are not enabled, the currency from the 
General tab of the Opportunity Info Center (if one was specified) or the company's 
functional currency. 

 Billing currency — If service estimates are enabled, this is the billing currency from the 
Service Estimate tab of the Opportunity Info Center (if specified) or the cost currency 
from the Service Estimate tab of the Opportunity Info Center (if specified) or the 
company's functional currency. If service estimates are not enabled, the default currency 
is the currency from the General tab of the Opportunity Info Center (if specified) or the 
company's functional currency. 

When you create a new project from an opportunity and a project template, Vision determines the 
default project and billing currencies as follows: 

 Project currency — This is the project currency from the template, if one was specified. 
Otherwise, the defaulting behavior is the same as described above for creating a project 
from an opportunity. 

 Billing currency — This is the billing currency from the template, if one was specified. 
Otherwise, the defaulting behavior is the same as described above for creating a project 
from an opportunity. 

Closed Reason and Closed Notes Fields in the Opportunity Info 
Center 
A new Closed Reason field and Closed Notes field have been added to the General tab of the 
Opportunity Info Center. This new information is also displayed as columns for the following 
reports: 

 Opportunity Forecast 

 Opportunity Summary 

 Opportunity List 

 Opportunity Hit Rate List 
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The drop-down list in the Closed Reason field includes pre-defined reasons that you can select 
that best categorize why the opportunity is closed. The options in the list are defined for the 
Opportunity Closed Reason table in Configuration » General » Code Tables. 

The Closed Notes field is a memo field that you can use to enter any description that relates to 
the closing of the opportunity. 

Look Up an Account Based on Company in the Account Info 
Center 
In Info Center » Accounts » Chart of Accounts, you can now search for an account based on 
the company, in the advanced search of the account lookup. This applies if you have multiple 
companies in Vision. When you use the Advanced display type on the Account Lookup, you can 
now select the Company option in the Search Field drop-down list in the Search Criteria grid to 
conduct a search based on a company. 

Activity Grid in Activity Manager and Info Centers Now Editable 
You can now edit the fields directly in the Activities grid that is located on the Activity Manager 
form in Calendar/Activities » Activity Manager and on the Activities tab in the various Info 
Centers. Previously, the fields in the grid were display-only. You could edit them only on the 
Activities dialog box, by clicking the  Edit option on the grid toolbar. 

The Start Date and End Date fields in the grid remain display-only. You can edit them only on 
the Activities dialog box. 

Text Editor with New Spell Checker 
All memo (text-box) fields in Vision now use a new text editor with features such as spell check as 
you type and custom dictionaries. The icons for the formatting options also changed but their 
function remains the same. The process for creating tables also changed with the new Insert 
Table dialog box. 

Known Issue: In Vision 7.3, when you open the text editor in any memo field in which indented 
text was entered in the field in versions earlier than Vision 7.3, the text is no longer indented. You 
can reapply the indenting using the text editor. This issue will be fixed in a future release. (Deltek 
Defect 412726) 

Enhanced Support for Custom Invoices in Invoice Template 
Editor 
Previously, edited invoices and invoices generated by Batch Billing always used the standard 
.DLL file, so even if you developed a custom .DLL for invoicing and referenced it in the .RDL file, 
it was not used for those invoices. That restriction has been removed. 

Use an Image as a Signature in Purchase Template Editor 
On the Signature tab in Purchasing » Purchase Template Editor, you can now select an image 
that was uploaded to Vision as a signature on the Electronic Signature File Name drop-down 
field. Click the Electronic Signature File Name drop-down to select an image from the list that 
will be used as the signature for the invoice.  



New Features and Enhancements 

 

Release Notes: New Features and Enhancements 17 

 

HTML Formatting for the Detailed Timesheet Reports 
On the Setup tab in Configuration » Time & Expense » Company Timesheet, a new HTML 
Formatting check box was added under the Include comments check box in the Detailed 
Timesheet Report Options section. The HTML Formatting check box is enabled if you select the 
Include comments check box. By default, the HTML Formatting check box is selected. Clear 
the HTML Formatting check box to disable HTML formatting on the detailed timesheet report. 

Timesheet Audit Label Change in Company Timesheet 
Configuration 

On the Timesheet Audit tab in Configuration » Time & Expense » Company Timesheet, the 
label for the Require after initial save option under the Enable revision explanation check box 
was changed to Require for updates prior to current day to more accurately indicate the 
purpose of the option. 

There is no change in what this option does. As in Vision 7.2, select this option to require that, 
after saving a timesheet for the first time, employees and timesheet administrators enter an 
explanation each time that they make revisions to a timesheet for a date that is earlier than the 
current date. 

Work Week Number in Company Timesheet Configuration 
A common practice in European countries is to have weekly timesheets and refer to them by the 
week number within the year rather than by period start and end dates. Vision now provides the 
option to display a work week number with timesheet information. (Although it is expected that 
most companies that use this feature will use it for work weeks, you also have the option to use it 
to number timesheet periods other than weekly periods.) 

To implement this feature, select the Enable timesheet period number check box on the 
Calendar tab in Configuration » Time & Expense » Company Timesheet. In the Label field, 
choose whether you want the label for the period number to be Week Number or Timesheet 
Period Number, and assign numbers to timesheet periods in the grid on that tab. 

When you enter or review timesheet information, the work week number displays, along with 
other period information on the Timesheet Hours tab of the Timesheet form, on related dialog 
boxes, and on the Detailed Timesheet report, Summarized Timesheet report, and Timesheet 
Audit Detail report. You can also sort the Timesheet Audit Detail report by work week. 

Print Supporting Documents in Expense Report 
In Time & Expense » Expense Report, when you print or display an expense report using either 
the Detailed Expense Report or the Summarized Expense Report, you now have the option to 
view or print supporting documents with the report. 

On the Expense Report form, click Print on the toolbar and select Print Supporting Documents 
on the menu before you select the report that you want to print. You can also do this on the 
Select Expense Report dialog box to print multiple expense reports with their supporting 
documents. 

Supporting documents display in the order of the expense rows they are linked to. (If the same 
document is linked to more than one expense row, only one copy of it is included with the report.) 
If the report includes any supporting documents, the report displays in the application that you 
use to view .PDF files rather than in the standard report Preview window. 
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You can print supporting documents only if the Enable FILESTREAM option is selected on the 
General tab of the Weblink utility. If Enable FILESTREAM is not selected, the Supporting 
Documents option is not available on the Print menu. 

Remove Orphaned Documents on Submit for Expense Reports 
Previously, if you uploaded a document into Vision for an expense report and later cleared the 
Select check box on the Supporting Documents dialog box for that document for all expense 
report rows, the “orphaned” document was removed from Vision as soon as you saved the 
expense report. 

In Vision 7.3, orphaned documents are instead retained until you submit the expense report. At 
that point, Vision displays a message that lists all "orphaned" documents and notifies you that 
they will be deleted from Vision when you submit the expense report. You then have the option 
either to submit the report and delete the documents or to postpone the submission so you can 
review the documents to determine if they should be associated with the expense report. 

Status Report Option Moved on the Select Expense Report 
Dialog Box 
In Time & Expense » Expense Report, the Select Expense Report dialog box opens when you 
click Employees » Select Employees on the Expense Report form toolbar. The Select Expense 
Report dialog box grid toolbar was streamlined by moving the Status Report option to the Print 
drop-down list as an option. 

Additional Sorting Options for AR Aged and AR Ledger Reports 
The Client info to Display field on the AR Aged and AR Ledger reports can now sort by Billing 
Contact or Primary Contact. For example, if you chose Billing Client and then Project Number 
in your sorting/grouping, the contact information for all the project’s contacts will show with the 
client. If you choose Billing Client, Project Number and then Billing Contact, the contact 
information will show with each project. 

New Posting Date Column on the Account Analysis Report 
On the Account Analysis report in Reporting » General Ledger, you can now include a Posting 
Date column to display the dates on which the transactions were posted. 

Opportunity Forecast Report Based on Fiscal Year 
The Fiscal Year and Year Determined by fields have been added to the General tab of 
Opportunity Forecast Report options. Use these fields to create an Opportunity Forecast report 
based on a fiscal year. These fields are enabled if you select Yearly or Quarterly in the Display 
Period field. 

 Use the Fiscal Year field to identify the start and end month of your fiscal year.  

 Use the Year Determined by field to select whether the year of the start month or the 
year of the end month is used as the year for the Fiscal Year. 
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User Account Report Column Updates 
The Windows Authentication, Domain, and Reset Password at Next Login columns were 
added to the User Account Report. The Reset Password at Next Login column header was 
shortened from the Force User to Reset Password at Next Login header to maximize the 
header space. 

Custom Report Administration: Uploading, Downloading, 
Synchronizing, and Report Status  
The following enhancements have been made on the Custom Reports tab in the Report 
Administration utility (Utilities » Report Administration): 

 The Upload option has been enhanced to upload a custom report to your Vision 
database as well as to your report server. The copy of the report on the report server is 
used when users access the report in Vision. The copy of the report in the Vision 
database serves as a backup copy that you can download in the event that you need a 
copy and you cannot find the original file on your workstation.  

 In the Load Custom Reports grid on the Custom Reports tab, a new Status column 
displays the status for each custom report. The column can display the following 
statuses: 

 Synchronized — This status displays after you successfully upload a custom report 
using the Upload option on the Load Custom reports grid toolbar. It signifies that the 
custom report was uploaded successfully to your report server and the Vision 
database. 

 Missing in report server — This status signifies that the custom report is uploaded 
to the Vision database (as a backup copy), but it no longer exists on the report 
server. This could happen if you manually deleted the report on the report server or if 
you migrated to a new report server. Because there is a backup copy saved in the 
Vision database, you can click the Synchronize option on the Load Custom Reports 
grid menu to re-upload a copy of the backup report in the Vision database to your 
report server.  

 Missing in database — This status signifies that a custom report is uploaded to the 
report server, but it does not have a backup copy saved in the Vision database. This 
can occur if you are upgrading to Vision 7.3 and you have already uploaded custom 
reports to the report server in earlier Vision versions—before the custom report status 
was implemented in the software. In this scenario, to upload a copy of the report to 
the Vision database and change the status of the report to Synchronized, you must 
delete the report from your report server and upload it again using the Upload option 
on the Load Custom reports grid toolbar.   

 The toolbar on the Load Custom Reports grid on the Custom Reports tab has the 
following new options: 

 Download – Use this option to download a copy of a custom report that is saved in 
the Vision database. 

 Synchronize – Use this option to reload a custom report that is missing from the 
report server and there is a copy in the Vision database (the report has a status of 
Missing in report server). The backup copy in Vision will be reloaded to your report 
server. 
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Change an Event Sequence in Workflow Configuration 
When you create a workflow (Configuration » Workflow » User Initiated Workflow), you can 

click  Move Up or  Move Down on the toolbar of the User Initiated Workflows grid to 
move the event to where you want it in the event sequence. Events are executed based on the 
order in the grid. 

User Initiated Workflows that Fire when You Create a Project 
from a Plan 
User initiated workflows that are configured for the Project application with a workflow type of 
Insert/Associate now fire whenever you create a project  from a plan in the Project Info Center 
(you click New » Create Project from Plan on the toolbar of the Projects form). 

Open and Close Periods by Company 
If you use the Multicompany feature, opening or closing an accounting period in previous versions 
affected all of your companies, whether or not those companies all operated under the same 
external requirements or internal policies. For example, some European countries require 
companies to close an accounting period immediately after the period end date, while US 
companies do not have that restriction. 

In version 7.3, however, you have the option in the Open New Period utility to open a new 
accounting period for the currently active company only or to open it for all companies, as before. 
If you only open the period for the active company, you can later use the Period Setup utility to 
open it for the others. You can also use the Period Setup utility to close an accounting period for 
individual companies or for all companies. 

Track User Login Activity 
On the Audit Trail tab in Configuration » General » System Settings, a new Log User Activity 
check box added to the Info Center/User Activity Audit Trail section allows you to enable user 
login activity tracking. Select this check box to track user log in and log out times in the User 
Activity utility, in the Utilities application. 

When you select this check box: 

 The User Activity grid in the User Activity utility displays the Log In and Log Out columns 
in place of the Application and Last Activity columns. 

 The Last Activity field below the User Activity grid is replaced with the Logout Time 
field. 

 All existing application activity logs are cleared from the system.  

User Activity Utility 
In Utilities » User Activity, the Email Users option in the Actions drop-down list on the toolbar 
of the User Activity form was changed to Email Logged In Users. When you select Email 
Logged In Users, an email message is sent only to users who are currently logged into Vision. 
The email addresses of the logged in users will be entered in the BCC field of the Send Email 
dialog box. 

In the User Activity utility, you can now delete activity logs based on a date range by clicking the 
Purge button on the User Activity grid toolbar. 



New Features and Enhancements 

 

Release Notes: New Features and Enhancements 21 

 

Web Service Timeout Value Is Now Configurable 
On the Miscellaneous tab in Configuration » General » System Settings, a new Web Service 
Timeout (seconds) field was added to the Workflow section so that you can prolong or shorten 
the duration before web service timeout. 

Performance Management Configuration 
You can now configure the settings of the Tableau workbooks, apply KPIs, modify workbook 
settings, upload, and reload workbooks in Vision. With this addition, functionality from the 
Performance Management tab of the Vision Resource Kit is now available from within Vision. 

Configuration » General » Performance Management » Configuration Tab 
On the Configuration tab, you can specify settings related to the Tableau workbooks that contain 
the Vision performance dashboards.  

Configuration » General » Performance Management » Workbooks Tab  
Organization levels can now also be configured by using the Organization Level to Use settings. 

On the Workbooks tab, you can use the new Upload button on the Workbooks grid toolbar to 
upload custom workbooks. When you upload a custom workbook, it is published to the Tableau 
server and is made available on the Vision dashboard.  

After you upload a custom report, verify role security settings to ensure that the appropriate users 
have access to the newly uploaded reports. Contact your Vision administrator to verify and 
update the role security settings for the custom report. 

You can also find new Reload and Reload All buttons on the Workbooks grid toolbar. Use these 
buttons to reload one workbook or all workbooks respectively to publish the latest version of your 
workbook in Vision. It is recommended that you reload a workbook if changes were made to it. 
Examples of changes are: changes made to the KPIs, selecting the Show Sheets as Tab check 
box in the Workbooks grid, or changing the Organization Level to Use settings. 

If a required measure is not properly configured in the Analysis Cubes configuration when the 
workbooks reload process is initiated, a corresponding message will display. You must properly 
configure the Analysis Cubes measures before you can successfully reload the workbooks. 

Configuration » General » Performance Management » Apply KPIs Tab 
Use the Apply KPIs tab to select a workbook file and apply system labels and key performance 
indicators (KPIs) to it. 

Configuration Enhancements that Support the Navigator 
Application 
The following enhancements were made to Vision Configuration to support the Navigator 
application. 

Configuration » Security » Roles  
The Navigator Access section on the Navigator tab in Roles Security has a new Invoices Tab 
check box. Select this check box to grant a role access to the Invoices tab in Vision Navigator. 

This tab also includes Additional Planning Security options that display when the Resource 
Planning module is not licensed in Vision. Use the Allow Changes to Budget Type and Allow 
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Changes to Overhead % options to enable a role to change the Navigator plan’s budget type 
and overhead percent in Navigator’s Plan Settings. 

The Vision Role Summary Report displays the new Invoices Tab setting for a role in the 
Navigator section of the report. For applications where the Resource Planning module is not 
installed, the Allow Changes to Budget Type and Allow Changes to Overhead % options are 
also displayed on the report.  

Configuration » Planning » Plan Settings  
The existing Budget Type field in Vision Plan Settings Configuration now also serves as the 
default for the billing and cost amounts in Navigator projects.  

 If you are using the Vision Resource Planning module, the Budget Type field is on the 
Rates tab of Project Planning form. 

 If you are not using the Vision Resource Planning module, the Budget Type field is on 
the Plan Settings form.  

When you create a new plan in Navigator, the Budget Type setting in Vision is applied as the 
budget type in Navigator. If you have multiple companies in Vision, the default budget type for the 
project’s company applies in Navigator.  

When you access the plan in Navigator, you can use Navigator Plan Settings to change the 
plan’s budget type. If you have the appropriate access rights, the Budget Type setting in 
Navigator Plan Settings will override the Vision Budget Type default settings. 

Navigator and Invoice Approval Process Alerts 
If invoice approval process alerts are configured in Vision (Configuration » Billing » Invoice 
Approval Process), and you are the approver of a project’s invoices, you will receive an email or 
dashboard alert when an invoice is ready to approve. When a URL is entered in the Navigator 
URL field on the Email tab in Configuration » General » System Settings, the email or 
dashboard alert will now contain links to both Vision and Navigator, so you can quickly access the 
approval process in either application. 

New Kona Log In and Log Out Procedure 
The Misc tab on the User Options dialog box now has a different procedure for connecting your 
Kona account to Vision. To open the User Options dialog box, click Options on the Vision 
toolbar.  

To connect to Kona, click the Connect button on the Misc tab of the User Options dialog box to 
open the new Kona dialog box and enter your Kona credentials. After you are connected to Kona, 
the Connect button on the Misc tab changes to the Connected button.  

To log out of Kona, click the Connected button to open the Kona dialog box. Click OK on the 
Kona dialog box to disconnect. 

GovWin IQ: Enhanced Integration with Vision 
Integration of GovWin IQ with Vision has been enhanced in the following ways: 

 To facilitate communication about the opportunities that your firm pursues, a new Added 
by grid on the IQ Info tab of the Opportunity Info Center displays all employees who 
initiated the downloading of the opportunity from GovWin IQ to Vision. The employee 
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name serves as a link to the employee’s record in the Employee Info Center so, for 
example, you have quick access to their contact information. 

 The Web Service Calls – Log grid on the General tab of the GovWin IQ Web Service 
utility now includes a Message column. If any errors or warning conditions occur during 
the data transfer, they display in that column. If the transfer finishes without errors or 
warnings, that column displays Import completed successfully. 

Diary Auto Numbering Tab in Accounting System Settings 
All the diary auto numbering-related fields and grids that were previously located on the 
Transaction Auto Numbering tab in Configuration » Accounting » System Settings were 
moved to the new Diary Auto Numbering tab in Accounting System Settings. 

New Posting Date Column on the Diary Report 
On the Diary report in Reporting » General Ledger, you can now include a Posting Date 
column to display the dates that the transactions were posted. 

Bank Account Number Fields Expanded in the Employee and 
Vendor Info Centers 
On the Accounting tab of the Employee Info Center, the Account Number column in the Direct 
Deposit grid now allows up to 32 characters. This change is to accommodate non-US bank 
account numbers, which frequently exceed the 17-character maximum in prior versions. 

For the same reason, the Account Number field in the EFT group box on the Accounting tab of 
the Vendor Info Center has also been changed to allow 32 characters. 

Transaction Date Validation 
For companies operating in some countries, transaction dates must fall within the currently active 
accounting period. In Vision 7.3, you can set up Vision to enforce this type of date validation. If 
you implement this feature, you can require that transaction dates be in the currently active 
period, or you can just require them to be in the current fiscal year. In addition to controlling the 
dates that users can enter for transactions, Vision also ensures that posting and other batch 
processes enforce your transaction date requirements. 

Companies not subject to regulatory requirements like those mentioned above may nevertheless 
want to implement transaction date validation as a transaction entry control measure. 

What Happens in Transaction Entry 
If you do not implement transaction date validation, Vision displays a warning message for a date 
not in the current accounting period, but you can save the transaction without changing the date. 
This is the standard behavior for versions prior to 7.3. 

If you implement transaction date validation for the fiscal year but not for the accounting period, 
Vision displays an error message for a transaction date outside the current fiscal year, and the 
transaction cannot be saved unless either the date or the fiscal year is changed. For a date in the 
current fiscal year but not in the current period, Vision displays a warning message, but you can 
save the transaction without changing the date.  
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If you implement transaction date validation for the accounting period, Vision displays an error 
message for a transaction date outside the current accounting period, and the transaction cannot 
be saved unless either the date or the period is changed.  

Transaction Dates Not Affected 
For some types of transactions, some dates associated with the transactions are not affected by 
transaction date validation. Two examples are all dates on timesheets and expense dates on 
employee expense reports. 

Prerequisite 

 

Deltek strongly recommends that you post all open transaction files and payment processing 
runs before you enable transaction date validation. If you do not, you may find that you cannot 
open a transaction file in the current period and you cannot change the transaction dates when 
you open the file in a prior period. 

Implement Transaction Date Validation 
To implement transaction date validation, do one of the following on the General tab of 
Accounting Company Settings:  

 To require that transaction dates be within the currently active fiscal year, select Require 
Transaction Dates to be Within the Active Fiscal Year. 

 To require that transaction dates be within the currently active accounting period, select 
both Require Transaction Dates to be Within the Active Fiscal Year and Require 
Transaction Dates to be Within the Active Accounting Period. 

Related Form and Dialog Box Changes 
A Transaction Date field was added to the following forms, tabs, and dialog boxes so you can 
enter transaction dates for the journal entries they generate: 

 Consultant Accruals form 

 Intercompany Billing: Posting Information tab 

 Revenue Generation form 

 Labor Cross Charge form 

 Bank Reconciliation: Post Cleared Items dialog box 

 Key Conversion utility » Projects’ Organization: Convert Projects’ Organization form  

 Transaction Posting: Timesheets tab 

These fields are only available if you implement transaction date validation. 

FEC File Generation 
Periodically, companies doing business in France must submit their accounting entries in Fichier 
d'Ecritures Comptables (FEC) files to the taxing authorities. The FEC files have precise structure 
and format requirements. Starting with Vision 7.3, you can use the FEC File Generation form 
(Accounting » FEC File Generation) to generate the two FEC files: a description file and a data 
file containing the accounting entries. 

Prerequisite: A valid FEC Data file requires that all transactions have diary numbers. The FEC 
file entries are numbered sequentially by diary. Therefore, if you generate an FEC Data file that 
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contains transactions posted prior to implementing diaries, those transactions will have 
incomplete data. The FEC Data file will only contain complete entries for transactions that are 
posted after you implement diaries. 

About Dialog Box 
The Vision About dialog box that displays when you click Help » About on the toolbar for the 
main Vision screen was updated. It now provides a more organized layout of the Vision 
application, client, database, and system information, installed components, and terms. 

Learning Portal 
Click Help » Learning Portal on the toolbar for the main Vision screen to open the Vision 
Essentials Plus learning portal where you can access video resources on using Vision. 

This new option is available only if the SaaS/Hosted Instance check box on the General tab of 
the Weblink is selected. 

Closed Setting for Opportunity Stages in Code Tables 
Configuration 
The Opportunity Stage code table (Configuration » General » Code Tables » Opportunity 
Stage) now includes a Closed Stage check box. Although you can select and clear this check 
box, it is non-functional in Vision 7.3. It is reserved for possible future use. 
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