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» Post Intercompany Receivables 

Accounting » Process » Post » Post 
Intercompany Receivables 

Sales and Value Added Tax Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » Sales and 
Value Added Tax Processing Client/Server Web 

Update Tax Report Tables 
Accounting » General Ledger » Sales and 
Value Added Tax Reporting » Update Tax 
Report Tables 

Not in Costpoint Web 

Print Sales/Value Added Tax Report 
Accounting » General Ledger » Sales and 
Value Added Tax Reporting » Sales/VAT 
Reporting 

Accounting » Review » Sales and Value 
Added Tax » Value Added Tax Report 

Print Intra European Community Trade 
Statistics Report 

Accounting » General Ledger » Sales and 
Value Added Tax Reporting » Intra EC Trade 
Statistics Report 

Not in Costpoint Web 
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View Tax Reporting Status by Tax Account 
Accounting » General Ledger » Sales and 
Value Added Tax Reporting » Tax Reporting 
Status by Tax Account 

Not in Costpoint Web 

View Tax Reporting Status by Transaction 
Accounting » General Ledger » Sales and 
Value Added Tax Reporting » Tax Reporting 
Status by Transaction 

Accounting » Review » Sales and Value 
Added Tax » Tax Status by Transaction 
Report 

General Ledger Beginning Balances 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » General 
Ledger Beginning Balances Client/Server Web 

Update General Ledger Beginning Balances Accounting » General Ledger » Month-End 
Processing » Update G/L Beginning Balances  Not in Costpoint Web 

Manage Non-Project Beginning Balances 
Accounting » General Ledger » Beginning 
Balances » Maintain Non-Project Beginning 
Balances 

Accounting » Utilities » General Ledger 
Tools » Non-Project Beginning Balances 

Manage PY Non-Project Comparative Balances 
Accounting » General Ledger » Beginning 
Balances » Maintain Prior Year Non-Project 
Comparative Balances 

Not in Costpoint Web 

Manage Prior Year Project Comparative 
Balances 

Accounting » General Ledger » Beginning 
Balances » Maintain Prior Year Project 
Comparative Balances 

Not in Costpoint Web 

Manage Project Beginning Balances 
Accounting » General Ledger » Beginning 
Balances » Maintain Project Beginning 
Balances 

Not in Costpoint Web 

Manage Reference Beginning Balances 
Accounting » General Ledger » Beginning 
Balances » Maintain Reference Beginning 
Balances 

Not in Costpoint Web 
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General Ledger Budgets 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » General 
Ledger Budgets Client/Server Web 

Manage Budget Revisions Accounting » General Ledger » Budgets » 
Maintain Budget Revisions Not in Costpoint Web 

Manage Organization/Account Budgets Accounting » General Ledger » Budgets » 
Maintain Org/Account Budgets Not in Costpoint Web 

Print General Ledger Budgets Accounting » General Ledger » Budgets » Print 
G/L Budgets Not in Costpoint Web 

Financial Statement Configuration 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » Financial 
Statement Configuration Client/Server Web 

Manage Equity Override Accounts Accounting » General Ledger » Controls » 
Equity Accounts Override Not in Costpoint Web 

Manage Cash Flow Account Types 
Accounting » General Ledger » Financial 
Statement Setup » Set Up Cash Flows Account 
Types 

Accounting » Maintain » Financial 
Statements » Cash Flow Account Types 

Manage Financial Statements 
Accounting » General Ledger » Financial 
Statement Setup » Set Up Financial 
Statements 

Accounting » Maintain » Financial 
Statements » Financial Statement Mappings 
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Print Financial Statement Setup  
Accounting » General Ledger » Financial 
Statement Setup » Print Financial Statement 
Setup 

Not in Costpoint Web 

Print Unassigned/Duplicate Account Report 
Accounting » General Ledger » Financial 
Statement Setup » Print Unassigned/Duplicate 
Accounts 

Not in Costpoint Web 

General Ledger Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » General 
Ledger Reports/Inquiries Client/Server Web 

Create General Ledger Report Tables Accounting » General Ledger » Reports » 
Create General Ledger Report Tables 

Accounting » Process » General Ledger » 
Create General Ledger Report Tables 

Create Preliminary Cash Flow Statements Accounting » General Ledger » Reports » 
Create Preliminary Cash Flows Statement Not in Costpoint Web 

Manage Preliminary Cash Flow Statements Accounting » General Ledger » Reports » Edit 
Preliminary Cash Flows Statement 

Accounting » Transactions » Cash Flow » 
Edit Preliminary Cash Flows Statement 

Print Financial Statements Accounting » General Ledger » Reports » Print 
Financial Statements 

Accounting » Review » General Ledger » 
Financial Statements Report 

Print Financial Statement Detail Report Accounting » General Ledger » Reports » Print 
Financial Statement Detail 

Accounting » Review » General Ledger » 
Financial Statement Detail Report 

Print YTD Comparative Financial Statements Not in Costpoint Client/Server Not in Costpoint Web 

Print General Ledger Detail Report Accounting » General Ledger » Reports » Print 
General Ledger Detail 

Accounting » Review » General Ledger » 
General Ledger Detail Report 

Print General Ledger Posting Summary Report Accounting » General Ledger » Reports » Print 
General Ledger Posting Summary 

Accounting » Review » General Ledger » 
General Ledger Posting Summary Report 
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Print Project Ledger Detail Report Accounting » General Ledger » Reports » Print 
Project Ledger Detail 

Accounting » Review » General Ledger » 
Project Ledger Detail Report 

Print Project Trial Balance Report Accounting » General Ledger » Reports » Print 
Project Trial Balance 

Accounting » Review » General Ledger » 
Project Trial Balance Report 

Print Trial Balance Report Accounting » General Ledger » Reports » Print 
Trial Balance 

Accounting » Review » General Ledger » 
Trial Balance Report 

Compare General Ledger Actual to Budget 
Activity 

Accounting » General Ledger » Inquiry » G/L 
Inquiry-Budget and Prior Year Comparison 

Accounting » Review » General Ledger » 
G/L Budget and Prior Year Comparison 
Inquiry 

View Account Activity Accounting » General Ledger » Inquiry » 
Account Activity Inquiry 

Accounting » Review » General Ledger » 
Account Activity Inquiry 

View General Ledger Activity Accounting » General Ledger » Inquiry » G/L 
Inquiry 

Accounting » Review » General Ledger » 
General Ledger Inquiry 

General Ledger Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » General 
Ledger Utilities Client/Server Web 

Defer Unposted Transactions Accounting » General Ledger » Utilities » Defer 
Unposted Transactions Not in Costpoint Web 

Print Labor History to General Ledger 
Comparison Report 

Accounting » General Ledger » Utilities » Labor 
History to General Ledger Comparison 

Accounting » Utilities » General Ledger 
Tools » Labor History to General Ledger 
Comparison 

Purge Intercompany Receivables Accounting » General Ledger » Utilities » Purge 
Intercompany Receivables Not in Costpoint Web 

Purge Journal Entry History Accounting » General Ledger » Utilities » Purge Not in Costpoint Web 
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JE History 

Update Financial Statement Summary 
Balances 

Accounting » General Ledger » Utilities » 
Update Financial Statement Summary 
Balances 

Accounting » Utilities » General Ledger 
Tools » Update Financial Statement 
Summary Balances 

Update Reference Summary Balances Accounting » General Ledger » Utilities » 
Update Reference Summary Balances Not in Costpoint Web 

General Ledger Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » General 
Ledger Interfaces Client/Server Web 

Manage Journal Entry Preprocessor Settings Others » Product Interfaces » Preprocessors » 
Journal Entry Suspense Setup Not in Costpoint Web 

Import Journal Entries Others » Product Interfaces » Preprocessors » 
Journal Entry Preprocessor 

Accounting » Utilities » Import » Import 
Journal Entries 

Corporate Planner Others » Product Interfaces » Corporate 
Planner Interface Not in Costpoint Web 

General Ledger Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » General Ledger » General 
Ledger Controls Client/Server Web 

Configure General Ledger Settings Accounting » General Ledger » Controls » G/L 
Settings Not in Costpoint Web 

Configure Company Information Accounting » General Ledger » Organizations » Accounting » Configure » General Ledger » 
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Set Up Company Info Company Taxable Entity Information 

Multicurrency 

Exchange Rates 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Multicurrency » Exchange 
Rates Client/Server Web 

Manage Exchange Rate Sources Accounting » Multicurrency » Exchange Rates 
» Maintain Exchange Rate Sources 

Administration » Maintain » Multicurrency » 
Exchange Rate Sources 

Manage Exchange Rate Groups Accounting » Multicurrency » Exchange Rates 
» Maintain Exchange Rate Groups Not in Costpoint Web 

Manage Exchange Rates by Date Accounting » Multicurrency » Exchange Rates 
» Maintain Exchange Rates by Date 

Administration » Maintain » Multicurrency » 
Exchange Rates by Date 

Manage Daily Exchange Rates Accounting » Multicurrency » Exchange Rates 
» Enter Daily Rates 

Administration » Maintain » Multicurrency » 
Daily Exchange Rates 

Import Daily Exchange Rates Accounting » Multicurrency » Exchange Rates 
» Upload Daily Exchange Rates Not in Costpoint Web 

Manage Exchange Rates by Period Accounting » Multicurrency » Exchange Rates 
» Maintain Exchange Rates by Period 

Administration » Maintain » Multicurrency » 
Exchange Rates by Period 

Manage Period Exchange Rates Accounting » Multicurrency » Exchange Rates 
» Enter Period Rates 

Administration » Maintain » Multicurrency » 
Period Exchange Rates 

Print Exchange Rates Report Accounting » Multicurrency » Exchange Rates 
» Print Exchange Rates Report Not in Costpoint Web 
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Gains/Losses Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Multicurrency » Gains/Losses 
Processing Client/Server Web 

Update Open Accounts Payable Exchange 
Rates 

Accounting » Multicurrency » Gains/Losses » 
Update Open A/P Exchange Rates Not in Costpoint Web 

Update Open Accounts Receivable Exchange 
Rates 

Accounting » Multicurrency » Gains/Losses » 
Update Open A/R Exchange Rates 

Administration » Process » Multicurrency » 
Update Open A/R Exchange Rates 

Compute/Post Unrealized Gains/Losses 
Accounting » Multicurrency » Gains/Losses 
Processing » Compute/Post Unrealized 
Gains/Losses 

Accounting » Process » Post » 
Compute/Post Unrealized Gains/Losses 

Multicurrency Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Multicurrency » Multicurrency 
Utilities Client/Server Web 

Compute Future Value of Money Accounting » Multicurrency » Utilities » 
Currency/Units Converter Not in Costpoint Web 

Update Currency Codes for Current Version 
Accounting » Multicurrency » Utilities » 
Miscellaneous Toolkits » Initialize Currency 
Codes for Version 6.1* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Multicurrency Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Multicurrency » Multicurrency 
Controls Client/Server Web 

Configure Multicurrency Settings Accounting » Multicurrency » Controls » 
Multicurrency Settings Not in Costpoint Web 

Manage Multicurrency Accounts Accounting » Multicurrency » Controls » 
Multicurrency Accounts 

Administration » Maintain » Multicurrency » 
Multicurrency Accounts 

Currency Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Multicurrency » Currency 
Controls Client/Server Web 

Manage Currencies Accounting » Multicurrency » Currencies » 
Maintain Currencies 

Administration » Maintain » Multicurrency » 
Currencies 

Manage Currency Status Accounting » Multicurrency » Currencies » 
Currency Status 

Administration » Maintain » Multicurrency » 
Currency Status 

Accounts Payable 

Vendors 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Vendors Client/Server Web 

Manage Vendors Accounting » Accounts Payable » Vendor Info Accounting » Maintain Vendors » Vendor 
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» Maintain Vendors User Flow 

Approve Vendors Accounting » Accounts Payable » Vendor Info 
» Approve Vendors 

Accounting » Maintain » Vendors » Approve 
Vendors 

Print Vendor List Accounting » Accounts Payable » Vendor 
Reports » Print Vendor Listing Not in Costpoint Web 

Print Vendor Information Report Accounting » Accounts Payable » Vendor 
Reports » Print Vendor Information Reports Not in Costpoint Web 

Voucher Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Voucher 
Processing Client/Server Web 

Manage Accounts Payable Vouchers Accounting » Accounts Payable » Vouchers » 
Enter A/P Vouchers 

Accounting » Transactions » Vouchers » 
Enter A/P Vouchers 

Create Recurring Accounts Payable Vouchers Accounting » Accounts Payable » Vouchers » 
Create Recurring A/P Vouchers Not in Costpoint Web 

Manage Purchase Order Vouchers Accounting » Accounts Payable » Vouchers » 
Enter PO Vouchers 

Accounting » Transactions » Vouchers » 
Enter PO Vouchers 

Create PO Vouchers from POs/Receipts Accounting » Accounts Payable » Vouchers » 
Create PO Vouchers from POs/Receipts Not in Costpoint Web 

Create Subcontract Purchase Order Vouchers Accounting » Accounts Payable » Vouchers » 
Create Subcontract PO Vouchers Not in Costpoint Web 

Create Debit Memos Accounting » Accounts Payable » Vouchers » 
Create Debit Memos 

Accounting » Transactions » Vouchers » 
Create Debit Memos 

Print Debit Memos Accounting » Accounts Payable » Vouchers » Accounting » Transactions » Vouchers » 
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Print Debit Memos Print Debit Memos 

Print Voucher Edit Report Accounting » Accounts Payable » Vouchers » 
Print Voucher Edit 

Accounting » Review » Vouchers » Voucher 
Edit Report 

Print Duplicate Invoices Accounting » Accounts Payable » Vouchers » 
Print Duplicate Invoices Not in Costpoint Web 

Recompute and Print Discrepancies Accounting » Accounts Payable » Vouchers » 
Recompute and Print Discrepancies 

Accounting » Process » Vouchers » 
Recompute PO Voucher Discrepancies 

Print Pending Vouchers Report 
Accounting » Accounts Payable » Voucher 
Approvals & Posting » Print Pending Vouchers 
Report 

Accounting » Review » Vouchers » Pending 
Vouchers Report 

Approve Vouchers Accounting » Accounts Payable » Voucher 
Approvals & Posting » Approve Vouchers 

Accounting » Transactions » Vouchers » 
Approve Vouchers 

Print Approved Voucher List 
Accounting » Accounts Payable » Voucher 
Approvals & Posting » Print Approved Voucher 
Listing 

Accounting » Review » Vouchers » 
Approved Voucher List 

Post Vouchers Accounting » Accounts Payable » Voucher 
Approvals & Posting » Post Vouchers 

Accounting » Process » Post » Post 
Vouchers 

Reverse Posted Vouchers Accounting » Accounts Payable » Vouchers » 
Reverse Posted Vouchers 

Accounting » Transactions » Vouchers » 
Reverse Posted Vouchers 

Payment Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Payment 
Processing Client/Server Web 

Update Pay When Paid Voucher History Accounting » Accounts Payable » 
Prepare/Approve Checks » Update Pay When 

Not in Costpoint Web 
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Paid Voucher History 

Select Vouchers For Payment Accounting » Accounts Payable » 
Prepare/Approve Checks » Select Vouchers 

Accounting » Process » Pay » Select 
Vouchers 

Edit Voucher Payment Status 
Accounting » Accounts Payable » 
Prepare/Approve Checks » Edit Payment 
Status by AP Account 

Accounting » Process » Pay » Edit Voucher 
Payment Status 

Approve Checks Accounting » Accounts Payable » 
Prepare/Approve Checks » Approve Checks 

Accounting » Transactions » Checks » 
Approve Checks 

Print Prepayment Edit Report 
Accounting » Accounts Payable » 
Prepare/Approve Checks » Print Prepayment 
Edit 

Accounting » Process » Pay » Prepayment 
Edit Report 

Print/Void Checks Accounting » Accounts Payable » Print Checks 
» Print/Void Checks 

Accounting » Process » Pay » Print/Void 
A/P Checks 

Manage Manual Checks Accounting » Accounts Payable » Print Checks 
» Record Manual Checks 

Accounting » Transactions » Checks » 
Record Manual Checks 

Manage Unusable Checks Accounting » Accounts Payable » Print Checks 
» Record Unusable Checks Not in Costpoint Web 

Post Cash Disbursements Accounting » Accounts Payable » Print Checks 
» Post Cash Disbursements 

Accounting » Process » Post » Post Cash 
Disbursements 

Print EFT Pre-Transfer Edit Report Accounting » Accounts Payable » EFT » Print 
EFT Pre-Transfer Edit Report 

Accounting » Process » Pay » EFT Pre-
Transfer Edit Report 

Create EFT File Accounting » Accounts Payable » EFT » 
Create EFT File Not in Costpoint Web 

Print EFT Edit Report Accounting » Accounts Payable » EFT » Print 
EFT Edit Report 

Accounting » Process » Pay » EFT Edit 
Report 

Manage CIS Voucher History Accounting » Accounts Payable » CIS Not in Costpoint Web 
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Vouchers » Maintain CIS Voucher History 

Manage Spoilt CIS Vouchers Accounting » Accounts Payable » CIS 
Vouchers » Record Spoilt CIS Vouchers Not in Costpoint Web 

Year-End Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Year-End 
Processing Client/Server Web 

Create 1099 Information Accounting » Accounts Payable Year-End 
Processing » Create 1099 Information Not in Costpoint Web 

Print 1099 Edit Report Accounting » Accounts Payable Year-End 
Processing » Print 1099 Edit Report Not in Costpoint Web 

Edit 1099 Information Accounting » Accounts Payable Year-End 
Processing » Edit 1099 Information Not in Costpoint Web 

Print/Create 1099s and Magnetic Media 
Accounting » Accounts Payable Year-End 
Processing » Print 1099s/Create Magnetic 
Media 

Not in Costpoint Web 

Accounts Payable Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries Client/Server Web 

Print Accounts Payable History Report Accounting » Accounts Payable » Reports » 
Print AP History Report 

Accounting » Review » Accounts Payable » 
A/P History Report 
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Print Cash Requirements Report Accounting » Accounts Payable » Reports » 
Cash Requirements Report 

Accounting » Review » Accounts Payable » 
Cash Requirements Report 

Print Check Register Report Accounting » Accounts Payable » Reports » 
Check Register 

Accounting » Review » Accounts Payable » 
Check Register 

Print Open Accounts Payable Report Accounting » Accounts Payable » Reports » 
Open A/P Report 

Accounting » Review » Accounts Payable » 
Open A/P Report 

Print Subcontractor Information Report 
Accounting » Accounts Payable » Vendor 
Reports » Print Subcontractor Information 
Report 

Not in Costpoint Web 

Print Vendor Bank Information Report Accounting » Accounts Payable » Vendor 
Reports » Print Vendor Bank Info Report Not in Costpoint Web 

Print Voucher Register Report Accounting » Accounts Payable » Reports » 
Voucher Register 

Accounting » Review » Vouchers » Voucher 
Register 

View Check History Inquiry Accounting » Accounts Payable » Inquiry » 
Check History Inquiry 

Accounting » Review » Accounts Payable » 
A/P Check History Inquiry 

View Vendor History Inquiry Accounting » Accounts Payable » Inquiry » 
Vendor History Inquiry 

Accounting » Review » Vendors » Vendor 
History Inquiry 

View Voucher History Inquiry Accounting » Accounts Payable » Inquiry » 
Voucher History Inquiry 

Accounting » Review » Vouchers » Voucher 
History Inquiry 

Accounts Payable Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Accounts 
Payable Utilities Client/Server Web 

Manage Vendor History Accounting » Accounts Payable » Utilities » 
Maintain Vendor History Not in Costpoint Web 
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Manage Check History Accounting » Accounts Payable » Utilities » 
Maintain Check History 

Accounting » Utilities » Transaction History 
» Initialize Check History 

Convert EFT File to Non-US Format 
Accounting » Accounts Payable » Utilities » 
Miscellaneous Toolkits » Electronic Funds 
Transfer (EFT) File Conversion* 

Not in Costpoint Web 

Purge Vouchers Accounting » Accounts Payable » Utilities » 
Purge Vouchers Not in Costpoint Web 

Update Discount Method for Posted Vouchers 
Accounting » Accounts Payable » Utilities » 
Miscellaneous Toolkits » Update Discount 
Method for Posted Vouchers* 

Not in Costpoint Web 

Update Vendor Address Line Information 
Accounting » Accounts Payable » Utilities » 
Miscellaneous Toolkits » Reorder Vendor 
Address Line Information* 

Not in Costpoint Web 

Update Vendor Default Account Descriptions 
Accounting » Accounts Payable » Utilities » 
Miscellaneous Toolkits » Update Vendor 
Default Account Descriptions* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

Accounts Payable Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Accounts 
Payable Interfaces Client/Server Web 

Import Vendors Others » Product Interfaces » Preprocessors » 
Vendor Master Preprocessor Not in Costpoint Web 

Manage Accounts Payable Voucher Suspense Others » Product Interfaces » Preprocessors » 
A/P Voucher Suspense Setup Not in Costpoint Web 
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Import Accounts Payable Vouchers Others » Product Interfaces » Preprocessors » 
A/P Voucher Preprocessor Not in Costpoint Web 

Import Accounts Payable Multicurrency 
Vouchers 

Others » Product Interfaces » Preprocessors » 
Multicurrency A/P Voucher Preprocessor Not in Costpoint Web 

Import Purchase Order Vouchers Others » Product Interfaces » Preprocessors » 
PO Vouchers Preprocessor Not in Costpoint Web 

Import Company Credit Card Transactions Accounting » Accounts Payable » Utilities » 
Company Credit Card Transaction Upload Not in Costpoint Web 

Configure TE Suspense Settings Others » Product Interfaces » Preprocessors » 
TE Suspense Setup Not in Costpoint Web 

Import TE Expenses/Advances Others » Product Interfaces » Preprocessors » 
TE Expense Report Preprocessor Not in Costpoint Web 

Configure TE Commitments Suspense Settings Not in Costpoint Client/Server Not in Costpoint Web 

Import TE Expense Commitments Not in Costpoint Client/Server Not in Costpoint Web 

Accounts Payable Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Accounts 
Payable Controls Client/Server Web 

Configure Accounts Payable Settings Accounting » Accounts Payable » Controls » 
A/P Settings 

Administration » Configure » Accounting » 
A/P Settings 

Configure Check Settings Accounting » Accounts Payable » Controls » 
Check Settings Not in Costpoint Web 

Manage Accounts Payable Accounts Accounting » Accounts Payable » Controls » 
A/P Accounts Not in Costpoint Web 
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Manage Cash Accounts Accounting » Accounts Payable » Controls » 
Cash Accounts 

Accounting » Maintain » Accounts » Cash 
Accounts Accounting » Maintain » Accounts 
» Cash Accounts 

Manage Cash Requirements Rpt Supplemental 
Amounts 

Accounting » Accounts Payable » Reports » 
Cash Requirements Report Supplemental 
Amounts 

Not in Costpoint Web 

Configure Accounts Payable Voucher Settings Accounting » Accounts Payable » Controls » 
A/P Voucher Settings 

Administration » Configure » Accounting » 
A/P Voucher Settings 

Configure Purchase Order Voucher Settings Accounting » Accounts Payable » Controls » 
PO Voucher Settings Not in Costpoint Web 

Configure Approver Settings Accounting » Accounts Payable » Controls » 
Approver Settings 

Administration » Configure » Accounting » 
A/P Approver Settings 

Manage Recurring A/P Voucher Codes Accounting » Accounts Payable » Controls » 
Recurring AP Voucher Codes Not in Costpoint Web 

Manage Credit Card Import Information Accounting » Accounts Payable » Controls  » 
Maintain Credit Card Upload Info Not in Costpoint Web 

Manage Insurance Carrier Information Accounting » Accounts Payable » Controls » 
Maintain Insurance Carrier Information 

Accounting » Configure » Vendors » 
Insurance Carrier Information 

Manage Construction Industry Scheme Codes Others » System Administration » System 
Codes » Maintain CIS Codes Not in Costpoint Web 
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Lien Waiver Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Lien 
Waiver Controls Client/Server Web 

Manage Lien Waiver Document Names 
Accounting » Accounts Payable » Lien Waiver 
Processing and Information » Maintain Lien 
Waiver Document Names 

Not in Costpoint Web 

Manage Project Waiver Information 
Accounting » Accounts Payable » Lien Waiver 
Processing and Information » Maintain Project 
Waiver Information 

Not in Costpoint Web 

Print Lien Waivers 
Accounting » Accounts Payable » Lien Waiver 
Processing and Information » Print Lien 
Waivers 

Not in Costpoint Web 

Manage Lien Waiver Information 
Accounting » Accounts Payable » Lien Waiver 
Processing and Information » Maintain Lien 
Waiver Information 

Not in Costpoint Web 

Vendor and Subcontractor Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Payable » Vendor 
and Subcontractor Controls Client/Server Web 

Configure Vendor Settings Accounting » Accounts Payable » Controls » 
Vendor Settings Not in Costpoint Web 

Manage Vendor Terms Accounting » Accounts Payable » Controls » 
Vendor Terms Not in Costpoint Web 
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Configure Vendor Approver Settings Accounting » Accounts Payable » Controls » 
Vendor Approver Settings 

Administration » Configure » Accounting » 
Vendor Approver Settings 

Manage Vendor User-Defined Labels Accounting » Accounts Payable » Controls » 
Vendor User-Defined Labels Not in Costpoint Web 

Manage Subcontractor Insurance Types Accounting » Accounts Payable » Controls » 
Maintain Subcontractor Insurance Types 

Accounting » Configure » Vendors » 
Subcontractor Insurance Types 

Manage Subcontractor Bond Types Accounting » Accounts Payable » Controls » 
Maintain Subcontractor Bond Types 

Accounting » Configure » Vendors » 
Subcontractor Bond Types 

Accounts Receivable 

Customers 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Customers Client/Server Web 

Manage Customers Accounting » Accounts Receivable » Customer 
Info » Maintain Customer 

Accounting » Maintain » Customers » 
Customers 

Manage Customer User-Defined Information Accounting » Accounts Receivable » Customer 
Info » Customer User-Defined Info 

Accounting » Maintain » Customers » 
Customer User-Defined Information 

Print Customer List Accounting » Accounts Receivable » Customer 
Info » Print Customer Listing Not in Costpoint Web 

 

 



Accounting  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
25 

 

Cash Receipts Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » Cash 
Receipts Processing Client/Server Web 

Manage Cash Receipts Accounting » Accounts Receivable » Cash 
Receipts » Enter Cash Receipts 

Accounting » Transaction » Cash Receipts 
» Enter Cash Receipts 

Copy/Reverse Cash Receipts Accounting » Accounts Receivable » Cash 
Receipts » Restore Cash Receipts Not in Costpoint Web 

Print Cash Receipts Edit Report Accounting » Accounts Receivable » Cash 
Receipts » Print Cash Receipts Edit Report 

Accounting » Review » Cash Receipts » 
Cash Receipts Edit Report 

Post Cash Receipts Accounting » Accounts Receivable » Cash 
Receipts » Post Cash Receipts 

Accounting » Process » Post » Post Cash 
Receipts 

Print Cash Receipts Register Report Accounting » Accounts Receivable » Cash 
Receipts » Print Cash Receipts Register 

Accounting » Review » Cash Receipts » 
Cash Receipts Register 

Edit/Manage A/R Underpayment Amounts Accounting » Accounts Receivable » Cash 
Receipts » Adjust A/R Underpayment Amounts 

Accounting » Transactions » Cash Receipts 
» Adjust A/R Underpayment Amounts 

Lien Waiver Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » Lien 
Waiver Controls Client/Server Web 

Manage Lien Waiver Document Names 
Accounting » Accounts Receivable » Lien 
Waiver Processing and Information » Maintain 
Lien Waiver Document Names 

Not in Costpoint Web 
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Manage A/R Project Waiver Information 
Accounting » Accounts Receivable » Lien 
Waiver Processing and Information » Maintain 
Project Waiver Information 

Not in Costpoint Web 

Print A/R Lien Waiver Forms 
Accounting » Accounts Receivable » Lien 
Waiver Processing and Information » Print Lien 
Waivers 

Not in Costpoint Web 

Manage A/R Lien Waiver Information 
Accounting » Accounts Receivable » Lien 
Waiver Processing and Information » Maintain 
Lien Waiver Information 

Not in Costpoint Web 

Finance Charges 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Finance Charges Client/Server Web 

Compute Customer Finance Charges Accounting » Accounts Receivable » Finance 
Charges » Compute Finance Charges Not in Costpoint Web 

Accounts Receivable Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Accounts Receivable Reports/Inquiries Client/Server Web 

Print Accounts Receivable Aging Report Accounting » Accounts Receivable » Reports » 
Print Accounts Receivable Aging Report 

Accounting » Review » Accounts 
Receivable » A/R Aging Report 

Print Accounts Receivable History Report Accounting » Accounts Receivable » Reports » 
Print Accounts Receivable History Report 

Accounting » Review » Accounts 
Receivable » A/R History Report 
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Print Customer Statements Accounting » Accounts Receivable » Reports » 
Print Customer Statement 

Accounting » Review » Cash Receipts » 
Customer Statement 

View Receivables and Collections Accounting » Accounts Receivable » Inquiry » 
Analyze Receivables and Collections 

Accounting » Review » Accounts 
Receivable » Receivables and Collections 
Inquiry 

Accounts Receivable Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Accounts Receivable Utilities Client/Server Web 

Manage Accounts Receivable History Accounting » Accounts Receivable » Beginning 
Balances » Maintain A/R History 

Accounting » Utilities » Transaction History 
»  Initialize A/R History 

Accounts Receivable Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Accounts Receivable Interfaces Client/Server Web 

Manage Cash Receipts Preprocessor Settings Others » Product Interfaces » Preprocessors » 
Cash Receipt Preprocessor Settings Not in Costpoint Web 

Import Cash Receipts Others » Product Interfaces » Preprocessors » 
Cash Receipt Preprocessor Not in Costpoint Web 
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Accounts Receivable Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Accounts Receivable Controls Client/Server Web 

Configure Accounts Receivable Settings Accounting » Accounts Receivable » Controls » 
A/R Settings 

Administration » Configure » Accounting » 
A/R Settings 

Configure System Assigned Cash Receipt 
Number 

Accounting » Accounts Receivable » Controls » 
Set System Assigned Cash Receipt Number Not in Costpoint Web 

Manage Transfer Accounts Accounting » Accounts Receivable » Controls » 
Maintain Transfer Accounts 

Accounting » Maintain » Accounts » Transfer 
Accounts 

Manage Customer Terms Accounting » Accounts Receivable » Customer 
Controls » Customer Terms Not in Costpoint Web 

Manage Customer User-Defined Labels Accounting » Accounts Receivable » Customer 
Controls » Customer User-Defined Labels Not in Costpoint Web 

Manage Customer Types Accounting » Accounts Receivable » Customer 
Controls » Customer Types 

Accounting » Configure » Customers » 
Customer Types 

Materials » Configure » Customers » 
Customer Types 

Manage Customer Credit Limits Accounting » Accounts Receivable » Customer 
Controls » Credit Limits 

Accounting » Configure » Customers » 
Customer Credit Limits 

Materials » Configure » Customers » 
Customer Credit Limits 

Manage Customer Credit Ratings Accounting » Accounts Receivable » Customer 
Controls » Credit Ratings 

Accounting » Configure » Customers » 
Customer Credit Ratings 

Materials » Configure » Customers » 
Customer Credit Ratings 
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Manage Sales Territories Accounting » Accounts Receivable » Customer 
Controls » Sales Territories 

Accounting » Configure » Customers » Sales 
Territories 

Materials » Configure » Customers » Sales 
Territories 

Manage Shipping Methods Accounting » Accounts Receivable » Customer 
Controls » Shipping Methods 

Accounting » Configure » Customers » 
Shipping Methods 

Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Accounts Receivable » 
Administrative Utilities Client/Server Web 

Purge Cash Receipts History Accounting » Accounts Receivable » Utilities » 
Purge Cash Receipts History Not in Costpoint Web 

Purge Customers Accounting » Accounts Receivable » Utilities » 
Purge Customers Not in Costpoint Web 

Cash Management 

Bank Account Management 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Cash Management » Bank 
Account Management Client/Server Web 

Manage Company Bank Accounts (US Banks) 
Accounting » Cash Management » Bank 
Account Management » Maintain Company 
Bank Accounts 

Not in Costpoint Web 
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Manage Company Bank Accounts (Non-US 
Banks) 

Accounting » Cash Management » Bank 
Account Management » Maintain Company 
Bank Accounts 

Not in Costpoint Web 

Adjust Currency Balances 
Accounting » Cash Management » Bank 
Account Management » Currency Balance and 
Adjustments 

Not in Costpoint Web 

Update Cash Accounts Accounting » Cash Management » Bank 
Account Management » Update Cash Accounts Not in Costpoint Web 

Manage Bank Statement Information  
Accounting » Cash Management » Bank 
Account Management » Maintain Bank 
Statement Info 

Not in Costpoint Web 

Print Bank Statement Report 
Accounting » Cash Management » Bank 
Account Management » Print Bank Statement 
Report 

Not in Costpoint Web 

Create Bank Transactions History 
Accounting » Cash Management » Bank 
Account Management » Create Bank 
Transactions History 

Not in Costpoint Web 

Accept Bank Transactions 
Accounting » Cash Management » Bank 
Account Management » Accept Bank 
Transactions 

Not in Costpoint Web 

Process Bank Transactions Acceptances 
Accounting » Cash Management » Bank 
Account Management » Process Batch Bank 
Transactions 

Not in Costpoint Web 

 

 

 



Accounting  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
31 

 

Cash Forecasting 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Cash Management » Cash 
Forecasting Client/Server Web 

Create Preliminary Cash Forecasts 
Accounting » Cash Management » Cash 
Forecasting » Create Preliminary Cash 
Forecasts 

Not in Costpoint Web 

Manage Preliminary Cash Forecasts Accounting » Cash Management » Cash 
Forecasting » Edit Preliminary Cash Forecasts Not in Costpoint Web 

Print Cash Forecasts Report Accounting » Cash Management » Cash 
Forecasting » Print Cash Forecasts Not in Costpoint Web 

Cash Management Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Cash Management » Cash 
Management Reports/Utilities Client/Server Web 

Print Bank Reconciliation Detail Reports 
Accounting » Cash Management » Bank 
Account Management » Bank Reconciliation 
Detail Reports 

Not in Costpoint Web 

Print Bank Reconciliation Summary Report 
Accounting » Cash Management » Bank 
Account Management » Bank Reconciliation 
Summary Report 

Not in Costpoint Web 

View Bank Reconciliation Summary 
Accounting » Cash Management » Bank 
Account Management » Bank Reconciliation 
Inquiry 

Not in Costpoint Web 
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Cash Management Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Cash Management » Cash 
Management Utilities  Client/Server Web 

Purge Bank Transaction History 
Accounting » Cash Management » Bank 
Account Management » Purge Bank 
Transactions History 

Not in Costpoint Web 

Update Beginning Bank Statement Balances 
Accounting » General Ledger » Utilities » 
Miscellaneous Toolkits » Update Beginning 
Bank Statement Balances * 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

Cash Management Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Cash Management » Cash 
Management Controls Client/Server Web 

Manage Banks (US) Accounting » Cash Management » Bank 
Account Management » Maintain Banks Not in Costpoint Web 

Manage Banks (Non-US) Accounting » Cash Management » Bank 
Account Management » Maintain Banks Not in Costpoint Web 

Manage Intermediary Banks Not in Costpoint Client/Server Not in Costpoint Web 

Manage Cash Forecast Templates 
Accounting » Cash Management » Cash 
Forecasting » Maintain Cash Forecast 
Templates 

Not in Costpoint Web 
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Manage Cash Forecast Accounts Accounting » Cash Management » Cash 
Forecasting » Cash Forecast Accounts Not in Costpoint Web 

Fixed Assets 

Fixed Assets Calendar 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Fixed Assets 
Calendar Client/Server Web 

Manage Fixed Assets Fiscal Years Accounting » Fixed Assets » FA FY/PD 
Settings » Maintain FA Fiscal Years Not in Costpoint Web 

Manage Fixed Assets Accounting Periods Accounting » Fixed Assets » FA FY/PD 
Settings » Maintain FA Accounting Periods Not in Costpoint Web 

Update FA FY/Pd Information from GL FY/Pd 
Information 

Accounting » Fixed Assets » FA FY/PD 
Settings » Update FA FY/PD Info from GL 
FY/PD Info 

Not in Costpoint Web 

Asset Master Records 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Asset Master 
Records Client/Server Web 

Manage Asset Template Information Accounting » Fixed Assets » Asset Template » 
Maintain Asset Template Info Not in Costpoint Web 

Manage Asset Template User-Defined 
Information 

Accounting » Fixed Assets » Asset Template » 
Maintain Template User-Defined Info Not in Costpoint Web 
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Print Asset Template List Accounting » Fixed Assets » Asset Template » 
Print Asset Template List Not in Costpoint Web 

Print Asset Template Detail Report Accounting » Fixed Assets » Asset Template » 
Print Asset Template Detail Report Not in Costpoint Web 

Manage Asset Master Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Master Info Not in Costpoint Web 

Manage Asset Description Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Desc Info Not in Costpoint Web 

Manage Asset Purchase Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Purchase Info Not in Costpoint Web 

Manage Asset Cost Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Cost Info Not in Costpoint Web 

Manage Asset Location Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Location Info Not in Costpoint Web 

Manage Asset Account Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Account Info Not in Costpoint Web 

Manage Asset General Ledger Book 
Information 

Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset G/L Book Info Not in Costpoint Web 

Manage Asset Other Books Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Other Books Info Not in Costpoint Web 

Manage Asset Disposal Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Disposal Info Not in Costpoint Web 

Manage Asset Government Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset Government Info Not in Costpoint Web 
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Manage Asset User-Defined Information Accounting » Fixed Assets » Asset Master 
Recorder » Maintain Asset User-Defined Info Not in Costpoint Web 

Print Asset Master List Accounting » Fixed Assets » Asset Master 
Recorder » Print Asset Master List Not in Costpoint Web 

Print Asset Master Detail Report Accounting » Fixed Assets » Asset Master 
Recorder » Print Asset Master Detail Not in Costpoint Web 

Create Autocreation Transactions 
Accounting » Fixed Assets » Autocreation of 
Asset Records » Create Autocreation 
Transactions 

Not in Costpoint Web 

Manage Autocreation Transactions 
Accounting » Fixed Assets » Autocreation of 
Asset Records » Edit Autocreation 
Transactions 

Not in Costpoint Web 

Print Autocreation Transactions Edit Report 
Accounting » Fixed Assets » Autocreation of 
Asset Records » Print Autocreation 
Transactions Edit Report 

Not in Costpoint Web 

Create Asset Master Records 
Accounting » Fixed Assets » Autocreation of 
Asset Records » Process Autocreation 
Transactions  

Not in Costpoint Web 

Inventory Records 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Inventory 
Records Client/Server Web 

Manage Asset Inventory Transactions Accounting » Fixed Assets » Inventory Records 
» Maintain Inventory Info Not in Costpoint Web 

Create Asset Inventory Transactions Accounting » Fixed Assets » Inventory Records 
» Create Inventory Transactions Not in Costpoint Web 
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Edit Asset Inventory Transactions Accounting » Fixed Assets » Inventory Records 
» Edit Inventory Transactions Not in Costpoint Web 

Create Asset Inventory Information Accounting » Fixed Assets » Inventory Records 
» Process Inventory Transactions Not in Costpoint Web 

Print Asset Inventory Information Report Accounting » Fixed Assets » Inventory Records 
» Print Inventory Info Not in Costpoint Web 

Maintenance Records 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Maintenance 
Records Client/Server Web 

Manage Asset Maintenance Information Accounting » Fixed Assets » Maintenance 
Records » Maintain Maintenance Info Not in Costpoint Web 

Create Asset Maintenance Transactions Accounting » Fixed Assets » Maintenance 
Records » Create Maintenance Transactions Not in Costpoint Web 

Manage Asset Maintenance Transactions Accounting » Fixed Assets » Maintenance 
Records » Edit Maintenance Transactions Not in Costpoint Web 

Create Asset Maintenance Information Accounting » Fixed Assets » Maintenance 
Records » Process Maintenance Transactions Not in Costpoint Web 

Print Asset Maintenance Information Report Accounting » Fixed Assets » Maintenance 
Records » Print Maintenance Info Not in Costpoint Web 
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Transfer Records 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Transfer 
Records Client/Server Web 

Manage Asset Transfer Information Accounting » Fixed Assets » Transfer Records 
» Maintain Transfer Info Not in Costpoint Web 

Create Asset Transfer Transactions Accounting » Fixed Assets » Transfer Records 
» Create Transfer Transactions Not in Costpoint Web 

Manage Asset Transfer Transactions Accounting » Fixed Assets » Transfer Records 
» Edit Transfer Transactions Not in Costpoint Web 

Create Asset Transfer Information Accounting » Fixed Assets » Transfer Records 
» Process Transfer Transactions Not in Costpoint Web 

Print Asset Transfer Information Report Accounting » Fixed Assets » Transfer Records 
» Print Transfer Info Not in Costpoint Web 

Fixed Assets Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Fixed Assets 
Processing Client/Server Web 

Compute Depreciation Accounting » Fixed Assets » Depreciation » 
Compute Depreciation Not in Costpoint Web 

View Other Books Depreciation History Accounting » Fixed Assets » Depreciation » 
Others Books Depr History Inquiry Not in Costpoint Web 

Print Current Period Depreciation Report Accounting » Fixed Assets » Depreciation » 
Print Current Period Depreciation Rpt Not in Costpoint Web 
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Print Sequential Other Books Depreciation 
History Rpt 

Accounting » Fixed Assets » Depreciation » 
Print Sequential Other Bks Depr History Not in Costpoint Web 

Manage Disposal Transactions Accounting » Fixed Assets » Disposals » 
Maintain Single Disposal Transactions Not in Costpoint Web 

Create Multiple Disposal Transactions Accounting » Fixed Assets » Disposals » 
Create Multiple Disposal Transactions Not in Costpoint Web 

Print Disposal Transactions Edit Report Accounting » Fixed Assets » Disposals » Print 
Disposal Transactions Edit Report Not in Costpoint Web 

Post Fixed Assets Journal Accounting » Fixed Assets » Post Depreciation 
and Disposals » Post Fixed Assets Journal Not in Costpoint Web 

Reverse Posted Fixed Assets Entry 
Accounting » Fixed Assets » Post Depreciation 
and Disposals » Reverse Posted Fixed Assets 
Entry 

Not in Costpoint Web 

Print Posted Transactions Detail Report 
Accounting » Fixed Assets » Post Depreciation 
and Disposals » Print Posted Transactions 
Detail 

Not in Costpoint Web 

Print Sequential Posted Depreciation History 
Report 

Accounting » Fixed Assets » Post Depreciation 
and Disposals » Print Sequential Posted Depr 
History 

Not in Costpoint Web 

Close Fixed Assets Accounting Period 
Accounting » Fixed Assets » Close Fixed 
Assets Acctng PD » Close Fixed Assets Acctng 
PD 

Not in Costpoint Web 
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Projections 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Projections Client/Server Web 

Compute Projected Depreciation Accounting » Fixed Assets » Projections » 
Compute Projected Depreciation Not in Costpoint Web 

View Projected Depreciation Expense Accounting » Fixed Assets » Projections » 
Projected Depreciation Expense Inquiry Not in Costpoint Web 

Print Projected Depreciation Report Accounting » Fixed Assets » Projections » Print 
Projected Depreciation Not in Costpoint Web 

Manage Projected Asset Purchases Accounting » Fixed Assets » Projections » 
Maintain Projected Asset Purchases Not in Costpoint Web 

Print Projected Asset Purchases Report Accounting » Fixed Assets » Projections » Print 
Projected Asset Purchases Not in Costpoint Web 

Manage Projected Asset Disposals Accounting » Fixed Assets » Projections » 
Maintain Projected Asset Disposals Not in Costpoint Web 

Print Projected Asset Disposals Report Accounting » Fixed Assets » Projections » Print 
Projected Asset Disposals Not in Costpoint Web 

Fixed Assets Reports 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Fixed Assets 
Reports Client/Server Web 

Print Asset Book Value Report Accounting » Fixed Assets » Reports » Print 
Asset Book Value Report Not in Costpoint Web 
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Print Asset Location Report Accounting » Fixed Assets » Reports » Print 
Asset Location Report Not in Costpoint Web 

Print Comparative Book Data Report Accounting » Fixed Assets » Reports » Print 
Comparative Book Data Not in Costpoint Web 

Print Depreciation Component Information by 
Book Report 

Accounting » Fixed Assets » Reports » Print 
Depr Component Info by Book Not in Costpoint Web 

Print Fixed Assets/General Ledger 
Reconciliation Report 

Accounting » Fixed Assets » Reports » Print 
FA/GL Reconciliation Report Not in Costpoint Web 

Print Schedule of Accumulated Depr Activity 
Report 

Accounting » Fixed Assets » Reports » Print 
Schedule of Accum Depr Activity Not in Costpoint Web 

Print Schedule of Asset Activity Report Accounting » Fixed Assets » Reports » Print 
Schedule of Asset Activity Not in Costpoint Web 

Fixed Assets Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Fixed Assets 
Utilities Client/Server Web 

Compute/Update Depreciation Computation 
Data 

Accounting » Fixed Assets » Utilities » 
Verify/Update Depr Computation Data Not in Costpoint Web 

Compute/Update Amount Taken Purchase 
Year-To-Date 

Accounting » Fixed Assets » Utilities » 
Verify/Update Amt Taken Purchase YTD Not in Costpoint Web 

Compute/Update Fiscal Year-To-Date Amount 
Accounting » Fixed Assets » Utilities » 
Miscellaneous Toolkits » Compute/Update 
FYTD Amount* 

Not in Costpoint Web 
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Copy Transfer Data to Asset Audit Log 
Accounting » Fixed Assets » Utilities » 
Miscellaneous Toolkits » Copy Transfer Data to 
Asset Audit Log* 

Not in Costpoint Web 

Update Current Depreciation Yr & Days/Pds 
Remaining 

Accounting » Fixed Assets » Utilities » 
Miscellaneous Toolkits » Modify Current Depr 
Yr & Days/Pds Remaining* 

Not in Costpoint Web 

Update Current Period Depreciation Amount 
Accounting » Fixed Assets » Utilities » 
Miscellaneous Toolkits » Update Current Pd 
Depr Amount* 

Not in Costpoint Web 

Update FY, Pd, and Subpd for Manual 
Disposals 

Accounting » Fixed Assets » Utilities » 
Miscellaneous Toolkits » Update FY, Pd, and 
Subpd for Manual Disposals* 

Not in Costpoint Web 

Update the JE Required Flag in the Asset Audit 
Log 

Accounting » Fixed Assets » Utilities » 
Miscellaneous Toolkits » Update the JE Req'd 
Flag in the Asset Audit Log* 

Not in Costpoint Web 

Configure Asset/Template Change Settings Accounting » Fixed Assets » Asset/Template 
Changes » Asset/Template Change Settings Not in Costpoint Web 

Manage Template Global Changes Accounting » Fixed Assets » Asset/Template 
Changes » Template Info Global Changes Not in Costpoint Web 

Manage Template User-Defined Global 
Changes 

Accounting » Fixed Assets » Asset/Template 
Changes » Template UDF Info Global Changes Not in Costpoint Web 

Manage Asset Master Global Changes Accounting » Fixed Assets » Asset/Template 
Changes » Asset Master Info Global Changes Not in Costpoint Web 

Manage Asset Master User-Defined Global 
Changes 

Accounting » Fixed Assets » Asset/Template 
Changes » Asset Master UDF Info Global 
Changes 

Not in Costpoint Web 
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View Template Change History Accounting » Fixed Assets » Asset/Template 
Changes » Template Change History Inquiry Not in Costpoint Web 

View Asset Change History Accounting » Fixed Assets » Asset/Template 
Changes » Asset Change History Inquiry Not in Costpoint Web 

Print Asset/Template Change History Report Accounting » Fixed Assets » Asset/Template 
Changes » Print Change History Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

Fixed Assets Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Fixed Assets 
Interfaces Client/Server Web 

Import Asset Records Not in Costpoint Client/Server Not in Costpoint Web 

Export Asset Records Not in Costpoint Client/Server Not in Costpoint Web 

Import Asset Disposals Not in Costpoint Client/Server Not in Costpoint Web 

Export Asset Disposals Not in Costpoint Client/Server Not in Costpoint Web 

Export Bar Code Scanner Settings Accounting » Fixed Assets » Bar Code 
Interface » Bar Code Settings Not in Costpoint Web 

Import Asset Locations Accounting » Fixed Assets » Bar Code 
Interface » Asset Location Preprocessor Not in Costpoint Web 

Manage Asset Location Exceptions Accounting » Fixed Assets » Bar Code 
Interface » Maintain Asset Location Exceptions Not in Costpoint Web 
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Fixed Assets Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Fixed Assets 
Controls Client/Server Web 

Configure Fixed Assets Settings Accounting » Fixed Assets » Controls » Fixed 
Assets Settings Not in Costpoint Web 

Configure Posting Settings Accounting » Fixed Assets » Controls » Posting 
Settings Not in Costpoint Web 

Manage Property Types Accounting » Fixed Assets » Controls » 
Property Types Not in Costpoint Web 

Manage Classification Codes Accounting » Fixed Assets » Controls » 
Classification Codes Not in Costpoint Web 

Manage Subclass Codes Accounting » Fixed Assets » Controls » 
Subclass Codes Not in Costpoint Web 

Manage Depreciation Methods Accounting » Fixed Assets » Controls » Depr 
Methods - Basic Setup Not in Costpoint Web 

Manage Accumulated Depreciation Account 
Codes 

Accounting » Fixed Assets » Controls » Accum 
Depr Acct Codes Not in Costpoint Web 

Manage Depreciation Expense Acct Allocation 
Codes 

Accounting » Fixed Assets » Controls » Depr 
Exp Acct Alloc Codes Not in Costpoint Web 

Manage Asset Master Field Labels Accounting » Fixed Assets » Controls » Asset 
Master Field Labels Not in Costpoint Web 

Manage Tracking Field Labels Accounting » Fixed Assets » Controls » 
Tracking Field Labels Not in Costpoint Web 
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Manage Asset Master User-Defined Labels Accounting » Fixed Assets » Controls » User-
Defined Labels Not in Costpoint Web 

Manage Location 1 Codes Accounting » Fixed Assets » Controls » 
Location 1 Codes Not in Costpoint Web 

Manage Location 2 Codes Accounting » Fixed Assets » Controls » 
Location 2 Codes Not in Costpoint Web 

Manage Location 3 Codes Accounting » Fixed Assets » Controls » 
Location 3 Codes Not in Costpoint Web 

Manage Location Groups Accounting » Fixed Assets » Controls » 
Location Groups Not in Costpoint Web 

Manage Disposal Types Accounting » Fixed Assets » Controls » 
Disposal Types Not in Costpoint Web 

Configure Autocreation Settings 
Accounting » Fixed Assets » Autocreation of 
Asset Records » Autocreation Settings for 
PO/Rcvng Data 

Not in Costpoint Web 

Configure Default Autocreation Asset 
Numbering 

Accounting » Fixed Assets » Autocreation of 
Asset Records » Default Autocreation Asset 
Numbering 

Not in Costpoint Web 

Manage Autocreation Accounts Accounting » Fixed Assets » Autocreation of 
Asset Records » Autocreation Accounts Not in Costpoint Web 
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Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Fixed Assets » Administrative 
Utilities Client/Server Web 

Purge All Asset Information Accounting » Fixed Assets » Purge Fixed 
Assets Info » Purge All Asset Info Not in Costpoint Web 

Purge Posted Transactions Detail Accounting » Fixed Assets » Purge Fixed 
Assets Info » Purge Posted Transactions Detail Not in Costpoint Web 

Purge Other Books Depreciation History Accounting » Fixed Assets » Purge Fixed 
Assets Info » Purge Other Books Depr History Not in Costpoint Web 

Purge Asset/Template Change History 
Accounting » Fixed Assets » Purge Fixed 
Assets Info » Purge Asset/Template Change 
History 

Not in Costpoint Web 

Consolidations 

Consolidations Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Consolidations » 
Consolidations Processing Client/Server Web 

Create Consolidation Entries Accounting » Consolidations » Create 
Consolidation Entry Not in Costpoint Web 

Manage Consolidation Transfer History Accounting » Consolidations » Consolidation 
Transfer History Not in Costpoint Web 
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Create Project Summary Balances Accounting » Consolidations » Create Project 
Data Not in Costpoint Web 

Import Consolidation Data Accounting » Consolidations » Import 
Consolidation Data Not in Costpoint Web 

Copy Imported Consolidation Data to 
Permanent Tables 

Accounting » Consolidations » Consolidation 
Preprocessor Not in Costpoint Web 

Manage Consolidation Suspense Entries Accounting » Consolidations » Maintain 
Consolidation Suspense Not in Costpoint Web 

Create Elimination Entries Accounting » Consolidations » Create 
Elimination Entry Not in Costpoint Web 

Consolidations Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Consolidations » 
Consolidations Utilities Client/Server Web 

Update Consolidation Beginning Balances Accounting » Consolidations » Update 
Consolidation Beginning Balances Not in Costpoint Web 

Consolidations Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Accounting » Consolidations » 
Consolidations Controls Client/Server Web 

Configure Consolidation Settings Accounting » Consolidations » Controls » 
Consolidation Settings Not in Costpoint Web 
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Manage Consolidation Equity Accounts 
Override 

Accounting » Consolidations » Controls » 
Consolidation Equity Accounts Override Not in Costpoint Web 

Manage Consolidation Acct/Org Mappings Accounting » Consolidations » Controls » 
Consolidation Acct/Org Mappings Not in Costpoint Web 

Manage Transfer Locations Accounting » Consolidations » Controls » 
Maintain Transfer Locations Not in Costpoint Web 

Link Consolidation Locations Accounting » Consolidations » Controls » Link 
Consolidation Locations Not in Costpoint Web 
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Projects 

Project Setup 

Project Master 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project Master Client/Server Web 

Manage Project User Flow 

Projects » Project Setup » Project Master » 
Maintain Project Master 

Projects » Project Setup » Project Master » 
Basic Info 

Projects » Maintain » Project » Project User 
Flow 

Mass Add Project Master Data Projects » Project Setup » Project Master » 
Mass Add Project Info 

Projects » Maintain » Project » Mass Add 
Project Information 

Manage Modifications Projects » Project Setup » Project Master » 
Modifications 

Projects » Transactions » Project » Enter 
Project Modifications 

Manage Change Orders Projects » Project Setup » Project Master » 
Enter Change Orders 

Projects » Transactions » Project » Enter 
Project Change Orders 

Manage User-Defined Information Projects » Project Setup » Project Master » 
User-Defined Info 

Projects » Maintain » Project » Project User-
Defined Information 

Manage Government Contract Information Projects » Project Setup » Project Master » 
Government Contract Info 

Projects » Maintain » Project » Project User 
Flow 

Manage Standard Text Projects » Project Setup » Project Master » 
Assign Standard Text 

Projects » Maintain » Project » Project 
Standard Text Assignment 

Manage Deliverables Projects » Project Setup » Project Master » 
Deliverables 

Projects » Transactions » Project » Enter 
Project Deliverables 
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Print Project Setup Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Project Setup Report Not in Costpoint Web 

Print Project Master Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Project Master Reports 

Projects » Review » Initialization Reports » 
Project Master Reports 

Print Project Exception Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Exception Reports Not in Costpoint Web 

Manage Project Templates Not in Costpoint Client/Server Projects » Configure » Project » Quick 
Project Setup Template 

Manage Project Master Data Not in Costpoint Client/Server Projects » Maintain » Project » Quick 
Project Setup 

Create Projects Not in Costpoint Client/Server Projects » Maintain » Project » Generate 
Quick Project WBS 

Approve Projects Not in Costpoint Client/Server Projects » Maintain » Project » Approve 
Quick Projects 

Import Project Master Data Not in Costpoint Client/Server Projects » Maintain » Project » Import Quick 
Project Information 

Revenue 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Revenue Client/Server Web 

Manage Revenue Information Projects » Project Setup » Revenue Setup » 
Basic Revenue Info 

Projects » Maintain » Revenue » Revenue 
Information 

Manage Revenue Formulas Projects » Project Setup » Revenue Setup » 
Maintain Revenue Formulas 

Projects » Maintain » Revenue » Revenue 
Formulas 
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Print Project Revenue and Billing Formulas Projects » Inquiry and Reporting » Initialization 
Reports » Print Project Formulas Not in Costpoint Web 

Manage Rate Sequence Orders Projects » Project Setup » Revenue Setup » 
Define Rate Sequence 

Projects » Maintain » Revenue » Define 
Rate Sequence 

Manage Cost of Goods Sold Projects » Project Setup » Revenue Setup » 
Cost of Goods Sold 

Projects » Maintain » Project » Cost of 
Goods Sold 

Project Ceilings 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project Ceilings Client/Server Web 

Manage Total Ceilings Projects » Project Setup » Project Ceilings » 
Project Total Ceilings 

Projects » Maintain » Project » Project User 
Flow 

Manage Burden Cost Ceilings Projects » Project Setup » Project Ceilings » 
Project Burden Cost Ceilings 

Projects » Maintain » Ceilings and 
Overrides » Burden Cost Ceilings 

Manage Direct  Cost Ceilings Projects » Project Setup » Project Ceilings » 
Project Direct Cost Ceilings 

Projects » Maintain » Ceilings and 
Overrides » Direct Cost Ceilings 

Manage Burden Fee Overrides Projects » Project Setup » Revenue Setup » 
Maintain Burden Fee Overrides 

Projects » Maintain » Ceilings and 
Overrides » Burden Fee Overrides 

Manage Cost Fee Overrides Projects » Project Setup » Revenue Setup » 
Maintain Cost Fee Overrides 

Projects » Maintain » Ceilings and 
Overrides » Cost Fee Overrides 

Manage Multiplier Overrides Projects » Project Setup » Revenue Setup » 
Maintain Multiplier Overrides 

Projects » Maintain » Ceilings and 
Overrides » Multiplier Overrides 

Manage Hour Ceilings Projects » Project Setup » Project Ceilings » 
Project Hours Ceilings 

Projects » Maintain » Ceilings and 
Overrides » Direct Hour Ceilings 
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Manage Employee Hour Ceilings Projects » Project Setup » Project Ceilings » 
Project Employee Hours Ceilings 

Projects » Maintain » Ceilings and 
Overrides » Employee Hour Ceilings 

Manage Vendor Hour Ceilings Projects » Project Setup » Project Ceilings » 
Project Vendor Hours Ceilings 

Projects » Maintain » Ceilings and 
Overrides » Vendor Hour Ceilings 

Project Labor 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project Labor Client/Server Web 

Manage Project Labor Categories (PLC) Projects » Project Setup » Project Labor » Set 
Up Project Labor Categories (PLC) 

Projects » Maintain » Labor Categories » 
Project Labor Categories (PLCs) 

Link Project Labor Categories to Projects Projects » Project Setup » Project Labor » 
Assign PLC to Projects 

Projects » Maintain » Labor Categories » 
Assign PLCs 

Link Project Labor Category Rates to Projects Projects » Project Setup » Project Labor » 
Project PLC Rates 

Projects » Maintain » Labor Categories » 
Project PLC Rates 

Manage Employee Work Force Projects » Project Setup » Project Labor » 
Project Employee Work Force 

Projects » Maintain » Labor Categories » 
Employee Work Force 

Manage Vendor Work Force Projects » Project Setup » Project Labor » 
Project Vendor Work Force 

Projects » Maintain » Labor Categories » 
Vendor Work Force 

Manage Vendor Employee Work Force Projects » Project Setup » Project Labor » 
Project Vendor Employee Work Force Not in Costpoint Web 

Link PLC Rates to Employee/Vendor Projects » Project Setup » Project Labor » 
Project PLC Rates by Employee/Vendor 

Projects » Maintain » Project » Project User 
Flow 

Print Project Work Force Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Project Work Force 

Projects » Review » Initialization Reports » 
Project Work Force Report 
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Alternate Projects 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Alternate 
Projects Client/Server Web 

Manage Alternate Projects Projects » Project Setup » Alternate Reporting Not in Costpoint Web 

Charging Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Charging 
Information Client/Server Web 

Link Projects/Accounts Projects » Project Setup » Controls » Maintain 
Project/Account Validation 

Projects » Maintain » Project » 
Project/Account Links 

Link Projects/Accounts/Organizations Projects » Project Setup » Project Master » 
Maintain Valid Project/Account/Orgs 

Projects » Maintain » Project » 
Project/Account/Organization Links 

Mass Link Projects/Accounts/Organizations Projects » Project Setup » Project Master » 
Mass Link Projects/Accounts/Organizations 

Projects » Maintain » Project » Mass Link 
Projects/Accounts/Organizations 

Link Projects/Organizations Projects » Project Setup » Controls » Maintain 
Project/Organization Validation 

Projects » Maintain » Project » 
Project/Organization Links 
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Unit Pricing Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Unit Pricing 
Information Client/Server Web 

Manage CLIN Information Projects » Project Setup » Unit Pricing » CLIN 
Information Projects » Maintain » Project » CLINs 

Project History 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project History Client/Server Web 

Manage Project Labor History Projects » Project Setup » Project History » 
Maintain Labor Summary 

Projects » Configure » Project History » 
Maintain Labor Summary 

Manage Prior Year Cost and Revenue Projects » Project Setup » Project History » 
Prior Year Cost and Revenue Not in Costpoint Web 

Manage Prior Year Cobra Costs Others » Product Interfaces » Cobra Interface » 
Maintain Prior Year Cobra Costs Not in Costpoint Web 

Manage Prior Year Time and Materials 
Revenue 

Projects » Project Setup » Project History » 
Prior Year T&M Revenue Not in Costpoint Web 

Manage Prior Year Billable Value Projects » Project Setup » Project History » 
Prior Year Billable Value Amounts Not in Costpoint Web 

Manage Prior Year Unit Revenue Projects » Project Setup » Project History » 
Prior Year Unit Revenue Not in Costpoint Web 
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Project Setup Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project Setup 
Utilities Client/Server Web 

Activate/Inactive Projects 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » 
Activate/Inactivate Project* 

Not in Costpoint Web 

Update Project Contract and Funded Values 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Update 
Contract and Funded Values* 

Not in Costpoint Web 

Update Project Period of Performance 
8Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Update 
Period of Performance* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

Project Setup Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project Setup 
Interfaces Client/Server Web 

Import Project Master Data Projects » Project Setup » Project Master » 
Upload Project Information 

Projects » Utilities » Import » Import Project 
Information 
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Project Setup Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Project Setup 
Controls Client/Server Web 

Configure Project Settings Projects » Project Setup » Controls » Project 
Settings 

Administration » Configure » Project » 
Project Settings 

Manage Project Account Groups Projects » Project Setup » Controls » Project 
Account Groups 

Projects » Configure » Project » Project 
Account Groups 

Print Project Account Group Setup Report 
Projects » Inquiry and Reporting » Initialization 
Reports » Print Project Account Group Setup 
Report 

Not in Costpoint Web 

Manage Project Types Projects » Project Setup » Controls » Maintain 
Project Types 

Projects » Configure » Project » Project 
Types 

Manage User-Defined Labels Projects » Project Setup » Controls » Project 
User-Defined Labels Not in Costpoint Web 

Manage Change Order Status Projects » Project Setup » Controls » Maintain 
Change Order Statuses 

Projects » Configure » Project » Project 
Change Order Statuses 

Manage Project Account Group Mappings Not in Costpoint Client/Server Projects » Configure » Project » Quick 
Project Account Group Mapping 

Manage Project Organization Mappings Not in Costpoint Client/Server Projects » Configure » Project » Quick 
Project Organization Mapping 

Manage Project Approver Settings Not in Costpoint Client/Server Projects » Configure » Project » Quick 
Project Approver Settings 
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Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Setup » Administrative 
Utilities Client/Server Web 

Check and/or Rebuild Project Segment IDs 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Check 
and/or Rebuild Project Segment IDs* 

Not in Costpoint Web 

Purge Project and Billing Information Projects » Cost and Revenue Processing » 
Utilities » Purge Project and Billing Information Not in Costpoint Web 

Set Project Level Correctly in Project Master 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Set Level 
Correctly in Project Master* 

Not in Costpoint Web 

Synchronize Project Master Data and Project 
Edit Data 

Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Synchronize 
Project Master and Project Edit Tables* 

Not in Costpoint Web 

Update POA Table with Valid Links/Reference 
Numbers 

Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Update POA 
table with valid Links/Reference Numbers* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Advanced Project Budgeting 

Burden Templates 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Advanced Project Budgeting » 
Burden Templates Client/Server Web 

Manage Burden Templates Projects » Advanced Project Budgeting » 
Controls » Maintain Burden Templates Not in Costpoint Web 

Import Pools to Burden Templates Projects » Advanced Project Budgeting » 
Controls » Import Pools to Burden Template Not in Costpoint Web 

Build Budget Composite Rates  Projects » Advanced Project Budgeting » 
Controls » Build Budget Composite Rates Not in Costpoint Web 

Project Budget and Estimate To Complete 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Advanced Project Budgeting » 
Project Budget and Estimate To Complete Client/Server Web 

Manage Project Budget Revisions Projects » Advanced Project Budgeting » 
Controls » Maintain Project Budget Revisions Not in Costpoint Web 

Manage Change Orders Projects » Project Setup » Project Master » 
Enter Change Orders 

Projects » Transactions » Project » Enter 
Project Change Orders 

Manage Project Budgets and ETC 
Projects » Advanced Project Budgeting » 
Project Budget and ETC Master » Maintain 
Project Budgets and ETC 

Not in Costpoint Web 
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Mass Add Project Budgets 
Projects » Advanced Project Budgeting » 
Project Budget and ETC Master » Mass Add 
Project Budgets 

Not in Costpoint Web 

Update Incurred Costs for Project Budgets 
Projects » Advanced Project Budgeting » 
Project Budget and ETC Master » Update 
Incurred Costs for Project Budgets 

Not in Costpoint Web 

Update Project Budgets 
Projects » Advanced Project Budgeting » 
Project Budget and ETC Master » Project 
Budget Recalculation 

Not in Costpoint Web 

Compute Estimate to Complete 
Projects » Advanced Project Budgeting » 
Project Budget and ETC Master » Revise 
Estimate to Complete 

Not in Costpoint Web 

Create PSR Budget Report Tables 
Projects » Advanced Project Budgeting » 
Project Budget and ETC Master » Create PSR 
Budget Report Tables 

Not in Costpoint Web 

Project Budget Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Advanced Project Budgeting » 
Project Budget Reports/Inquiries Client/Server Web 

Print Earned Value Report Projects » Advanced Project Budgeting » 
Project Budget Reporting » Print Earned Value Not in Costpoint Web 

Print Estimate To Complete Report 
Projects » Advanced Project Budgeting » 
Project Budget Reporting » Print Estimate to 
Complete 

Not in Costpoint Web 

Print Labor Estimate To Complete Report 
Projects » Advanced Project Budgeting » 
Project Budget Reporting » Print Labor 
Estimate to Complete 

Not in Costpoint Web 
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Print Project Budget Detail Report 
Projects » Advanced Project Budgeting » 
Project Budget Reporting » Print Project 
Budget Detail 

Not in Costpoint Web 

Print Project Budget Summary Report 
Projects » Advanced Project Budgeting » 
Project Budget Reporting » Print Project 
Budget Summary 

Not in Costpoint Web 

View ETC and Earned Value 
Projects » Advanced Project Budgeting » 
Project Budget Inquiry » ETC and Earned 
Value 

Not in Costpoint Web 

View Project Budgets Projects » Advanced Project Budgeting » 
Project Budget Inquiry » Project Budgets Not in Costpoint Web 

Advanced Project Budget Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Advanced Project Budgeting » 
Advanced Project Budget Controls Client/Server Web 

Configure Project Budget Settings Projects » Advanced Project Budgeting » 
Controls » Maintain Project Budget Settings Not in Costpoint Web 

Manage Average Cost GLC Rates Projects » Advanced Project Budgeting » 
Controls » Maintain Average Cost GLC Rates Not in Costpoint Web 

Manage Average Cost PLC Rates Projects » Advanced Project Budgeting » 
Controls » Maintain Average Cost PLC Rates Not in Costpoint Web 

Manage Period Days Projects » Advanced Project Budgeting » 
Controls » Maintain Period Days Not in Costpoint Web 
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Budgeting and ETC 

Total Budgets 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » Total 
Budgets Client/Server Web 

Manage Project Total Budget 
Projects » Budgeting and ETC » Total Budgets 
» Project Total Budget Not in Costpoint Web 

Manage PLC Total Budget 
Projects » Budgeting and ETC » Total Budgets 
» PLC Total Budget Not in Costpoint Web 

Manage GLC Total Budget 
Projects » Budgeting and ETC » Total Budgets 
» GLC Total Budget Not in Costpoint Web 

Update Budget Report Tables 
Projects » Budgeting and ETC » Total Budgets 
» Maintain Budget Report Tables 

Projects » Process » Budgets and ETCs » 
Create Budget Report Tables 

Period Budgets 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » Period 
Budgets Client/Server Web 

Manage Budget Revisions Projects » Budgeting and ETC » Period 
Budgets » Maintain Budget Revisions Not in Costpoint Web 

Manage Project Budgets By Period Projects » Budgeting and ETC » Period 
Budgets » Project Budgets by Period Not in Costpoint Web 

Manage PLC Budgets By Period Projects » Budgeting and ETC » Period 
Budgets » PLC Budgets by Period Not in Costpoint Web 
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Manage GLC Budgets By Period Projects » Budgeting and ETC » Period 
Budgets » GLC Budgets by Period Not in Costpoint Web 

Manage Project Unit Budgets By Period Projects » Budgeting and ETC » Period 
Budgets » Project Unit Budgets by Period Not in Costpoint Web 

Apply Indirect Costs to Budgets Projects » Budgeting and ETC » Period 
Budgets » Apply Indirect Costs to Budgets Not in Costpoint Web 

Update Project Total Budget Projects » Budgeting and ETC » Period 
Budgets » Update Project Total Budget Not in Costpoint Web 

Estimate To Complete 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » Estimate To 
Complete Client/Server Web 

Manage Estimate To Complete Amounts 
Projects » Budgeting and ETC » Estimate to 
Complete » Maintain Estimate-to-Complete 
Amounts 

Not in Costpoint Web 

Update Incurred Cost for ETC Projects » Budgeting and ETC » Estimate to 
Complete » Update Incurred Cost for ETC Not in Costpoint Web 

Compute Estimate To Complete Projects » Budgeting and ETC » Estimate to 
Complete » Revise ETC Not in Costpoint Web 

Manage Estimate to Complete PLC Hours 
Projects » Budgeting and ETC » Estimate to 
Complete » Maintain Estimate-to-Complete 
PLC Hours 

Not in Costpoint Web 

Manage Estimate To Complete GLC Hours 
Projects » Budgeting and ETC » Estimate to 
Complete » Maintain Estimate-to-Complete 
GLC Hours 

Not in Costpoint Web 
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Encumbrance Tracking 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » 
Encumbrance Tracking Client/Server Web 

Manage Project Budget Line Item Revisions 
Projects » Budgeting and ETC » Encumbrance 
Tracking » Maintain Project Budget Line Item 
Revisions 

Not in Costpoint Web 

Manage Project Line Item Budgets Projects » Budgeting and ETC » Encumbrance 
Tracking » Maintain Project Line Item Budgets Not in Costpoint Web 

Compute Over Budget Transactions Projects » Budgeting and ETC » Encumbrance 
Tracking » Calculate Over Budget Transactions 

Projects » Process » Encumbrance 
Tracking » Calculate Over-Budget 
Transactions 

Cost Schedule Status Report 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » Cost 
Schedule Status Report Client/Server Web 

Manage CSSR Information Projects » Budgeting and ETC » Maintain 
C/SSRs » Maintain C/SSR Information Not in Costpoint Web 

Manage CSSR Budgets Projects » Budgeting and ETC » Maintain 
C/SSRs » Maintain C/SSR Budgets Not in Costpoint Web 

Import CSSR Budgets Projects » Budgeting and ETC » Maintain 
C/SSRs » Upload C/SSR Budgets Not in Costpoint Web 

Create CSSR Report Tables Projects » Budgeting and ETC » Maintain 
C/SSRs » Create C/SSR Report Tables Not in Costpoint Web 
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Print Cost Schedule Status Report Projects » Budgeting and ETC » Maintain 
C/SSRs » Print C/SSR Not in Costpoint Web 

Estimate To Complete Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » Estimate To 
Complete Reports/Inquiries Client/Server Web 

Create Estimate To Complete Report Tables 
Projects » Budgeting and ETC » Estimate to 
Complete Reporting & Inquiry » Create ETC 
Report Tables 

Projects » Process » Budgets and ETCs » 
Create Estimate-to-Complete Report Tables 

Print Estimate To Complete Hours Report 
Projects » Budgeting and ETC » Estimate to 
Complete Reporting & Inquiry » Print ETC 
Hours Report 

Not in Costpoint Web 

Print Estimate To Complete Report 
Projects » Budgeting and ETC » Estimate to 
Complete Reporting & Inquiry » Print ETC 
Report 

Not in Costpoint Web 

View Estimate To Complete Projects » Budgeting and ETC » Estimate to 
Complete Reporting & Inquiry » ETC Inquiry Not in Costpoint Web 

Budget Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC » Budget 
Interfaces Client/Server Web 

Configure Interface Settings* Others » Product Interfaces » Project Planner 
Interface » Interface Configuration Not in Costpoint Web 
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Configure Project Planner Mapping Definitions* Others » Product Interfaces » Project Planner 
Interface » Interface Configuration Not in Costpoint Web 

Import Project Budgets Others » Product Interfaces » Project Planner 
Interface » Import Project Budgets Not in Costpoint Web 

Retrieve Labor Rates 

Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Retrieve Labor Rates 

Others » Product Interfaces » Project Planner 
Interface » Retrieve Labor Rates 

Not in Costpoint Web 

* In Costpoint 7.0, the Interface Configuration screen was split into two screens: Interface Configuration and Configure Project Planner Mapping 
Definitions. 

Budget Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Budgeting and ETC »Budget 
Controls Client/Server Web 

Manage Average GLC Rates Projects » Budgeting and ETC » Budget Setup 
» Maintain Average GLC Rates Not in Costpoint Web 

Manage Average PLC Rates Projects » Budgeting and ETC » Budget Setup 
» Maintain Average PLC Rates Not in Costpoint Web 
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Cost and Revenue Processing 

Cost Pools 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Cost Pools Client/Server Web 

Manage Cost Pools Projects » Cost and Revenue Processing » 
Cost Pool Setup » Cost Pools 

Projects » Maintain » Allocations » Cost 
Pools 

Manage Base Creation Setups Projects » Cost and Revenue Processing » 
Cost Pool Setup » Base Creation Setup 

Projects » Maintain » Allocations » Pool 
Base Creation 

Manage Cost Creation Setups Projects » Cost and Revenue Processing » 
Cost Pool Setup » Cost Creation Setup 

Projects » Maintain » Allocations » Pool 
Cost Creation 

Create Pool Links Projects » Cost and Revenue Processing » 
Cost Pool Setup » Create Pool Links 

Projects » Process » Allocations » Create 
Pool Links 

Print Cost Pool Rates Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Pool Rate Listing 

Projects » Review » Initialization Reports » 
Pool Rate Listing Report 

Print Cost Pool Setup Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Pool Setup 

Projects » Review » Initialization Reports » 
Pool Setup Report 

Print Service Center Setup Report Projects » Inquiry and Reporting » Initialization 
Reports » Print Service Center Setup Not in Costpoint Web 

 

 

 



Projects  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
66 

 

Cost Pool Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Cost Pool Processing Client/Server Web 

Build Rate Application Table 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Build Rate 
Application Table 

Projects » Process » Allocations » Build 
Rate Application Table 

Compute/Print Pool Rates 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Compute 
& Print Pool Rates 

Projects » Process » Allocations » Compute 
and Print Pool Rates 

Import Allocation Basis Journals 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Upload 
Allocation Basis Journal 

Projects » Utilities » Import » Import 
Allocation Basis Journal 

Manage Allocation Journals 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Maintain 
Allocation Journal 

Projects » Transactions » Allocations » 
Maintain Allocation Journal 

Print Allocation Journal Edit Report 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Print 
Allocation Journal Edit Report 

Projects » Review » Allocations » Allocation 
Journal Edit Report 

Print Service Center Cost Allocation Report 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Print 
Service Center Cost Allocation Report 

Not in Costpoint Web 

Post Pool Journals 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Post Pool 
Journal 

Projects » Process » Post » Post Pool 
Journal 

Reverse Posted Pool and Revenue Journals 
Projects » Cost and Revenue Processing » 
Utilities » Reverse Posted Pool and Revenue 
Journals 

Not in Costpoint Web 
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Multi-Job Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Multi-Job Processing Client/Server Web 

Manage Multi-Job Allocation Information Projects » Cost and Revenue Processing » 
Cost Pool Setup » Multi-Job Allocation Setup 

Projects » Maintain » Allocations » Multi-Job 
Allocation Setup 

Import Multi-Job Allocation Percentage Basis 
Projects » Cost and Revenue Processing » 
Cost Pool Setup » Upload Multi-Job Allocation 
Percentage Basis 

Not in Costpoint Web 

Create Multi-Job Allocation Entries 
Projects » Cost and Revenue Processing » 
Project Cost Processing » Compute Multi-Job 
Allocations 

Projects » Process » Allocations » Compute 
Multi-Job Allocations 

Manage Multi-Job Allocation Cost History 
Projects » Cost and Revenue Processing » 
Cost Pool History » Multi-Job Allocation Cost 
History 

Projects » Configure » Allocations » Multi-
Job Allocation Cost History 

Manage Multi-Job Allocation Labor History 
Projects » Cost and Revenue Processing » 
Cost Pool History » Multi-Job Allocation Labor 
History 

Projects » Configure » Allocations » Multi-
Job Allocation Labor History 

Project Cost Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Project Cost Processing Client/Server Web 

Process Organization Changes Projects » Cost and Revenue Processing » 
Utilities » Process Organization Changes 

Projects » Process » Project » Process 
Organization Changes 
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Create Cost of Goods Sold Entries 
Projects » Cost and Revenue Processing » 
Project Cost Processing » Compute Cost of 
Goods Sold Entry 

Projects » Process » Project » Compute 
Cost of Goods Sold Entry 

Compute Burden Costs 
Projects » Cost and Revenue Processing » 
Project Cost Processing » Compute Burden 
Cost 

Projects » Process » Project » Compute 
Burden Cost 

Compute Cobra Burden Costs Others » Product Interfaces » Cobra Interface » 
Compute Cobra Burden Cost Not in Costpoint Web 

Compute Inventory Burden Rates 
Projects » Cost and Revenue Processing » 
Cost Pool Processing & Reporting » Compute 
Inventory Burden Rates 

Projects » Process » Allocation » Compute 
Inventory Burden Rates 

Revenue Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Revenue Processing Client/Server Web 

Load Labor Rates 

Projects » Cost and Revenue Processing » 
Revenue Processing » Load Labor Rates 

Projects » Billing » Prepare Billings » Load 
Labor Rates 

Projects » Process » Billing » Load Labor 
Rates 

Compute Revenue Projects » Cost and Revenue Processing » 
Revenue Processing » Compute Revenue 

Projects » Process » Revenue » Compute 
Revenue 

Redistribute Revenue Projects » Cost and Revenue Processing » 
Revenue Processing » Redistribute Revenue 

Projects » Process » Revenue » 
Redistribute Revenue 

Redistribute Revenue by Project 
Projects » Cost and Revenue Processing » 
Revenue Processing » Redistribute Revenue 
by Project 

Projects » Process » Revenue » 
Redistribute Revenue by Project 
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Post Revenue Projects » Cost and Revenue Processing » 
Revenue Processing » Post Revenue Projects » Process » Post » Post Revenue 

Reverse Posted Pool and Revenue Journals 
Projects » Cost and Revenue Processing » 
Utilities » Reverse Posted Pool and Revenue 
Journals 

Not in Costpoint Web 

Create Cost Transfer Journal Entries 
Projects » Cost and Revenue Processing » 
Revenue Processing » Create Cost Transfer 
Journal Entry 

Projects » Process » Project » Create Cost 
Transfer Journal Entry 

Project Transfer Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Project Transfer Processing Client/Server Web 

Manage Project Transfer Information Projects » Cost and Revenue Processing » 
Project Transfer » Project Transfer Setup 

Projects » Maintain » Allocations » Project 
Transfer Setup 

Create Project Transfer Journal Entries Projects » Cost and Revenue Processing » 
Project Transfer » Compute Project Transfer 

Projects » Process » Allocations » Compute 
Project Transfer 

Update Project Transfer History Tables 
Projects » Cost and Revenue Processing » 
Project Transfer » Update Project Transfer 
History Tables 

Projects » Process » Project » Update 
Project Transfer History Tables 
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Goal Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Goal Processing Client/Server Web 

Compute Billing Value of Cost Incurred 
Projects » Cost and Revenue Processing » 
Revenue Processing » Compute Billing Value 
of Cost Incurred 

Projects » Process » Revenue » Compute 
Billing Value of Cost Incurred 

Cost and Revenue Processing Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Cost and Revenue Processing Utilities Client/Server Web 

Copy Pools Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Copy Pools* Not in Costpoint Web 

Purge Allocation Basis Journal History 
Projects » Cost and Revenue Processing » 
Utilities » Purge Allocation Basis Journal 
History 

Projects » Utilities » Purge » Purge 
Allocation Basis Journal History 

Validate Pool Acct/Org Setups 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Check Pool 
Acct/Org Setups* 

Not in Costpoint Web 

View Invalid Pools in Project Ledger 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Display 
Invalid Pools in Project Ledger* 

Not in Costpoint Web 

Repair Invalid Pools in Project Ledger 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Fix Invalid 
Pools in Project Ledger* 

Not in Costpoint Web 
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Assign Account Function Codes 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Assign 
Account Function Codes* 

Not in Costpoint Web 

Change Period Report Parameters 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Change 
Period Report Parameters* 

Not in Costpoint Web 

Check for Unposted Journals 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Check for 
Unposted Journals* 

Not in Costpoint Web 

Compare Project Ledger to General Ledger 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Compare 
Project Ledger to General Ledger* 

Not in Costpoint Web 

Summarize Project Goal Detail Projects » Cost and Revenue Processing » 
Utilities » Summarize Project Goal Detail 

Projects » Utilities » Project Toolkits » 
Summarize Project Goal Detail 

Summarize Project Ledger Projects » Cost and Revenue Processing » 
Utilities » Summarize Project Ledger Not in Costpoint Web 

Apply Indirect Costs to Summarized Project 
Ledger 

Projects » Cost and Revenue Processing » 
Utilities » Apply Indirect Costs 

Projects » Utilities » Project Toolkits » Apply 
Indirect Costs to Summarized Project 
Ledger 

Update Prior Year History Projects » Project Setup » Project History » 
Update Prior Year History 

Projects » Utilities » Project Toolkits » 
Update Project Prior Year History 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Cost and Revenue Processing Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Cost and Revenue Processing Interfaces Client/Server Web 

Manage Microframe EOC Mappings Others » Product Interfaces » Microframe 
Interface » Microframe EOC Mappings Not in Costpoint Web 

Manage Microframe OBS Mappings Others » Product Interfaces » Microframe 
Interface » Microframe OBS Mappings Not in Costpoint Web 

Manage Microframe WBS Mappings Others » Product Interfaces » Microframe 
Interface » Microframe WBS Mappings Not in Costpoint Web 

Manage Microframe Resource Mappings Others » Product Interfaces » Microframe 
Interface » Microframe Resource Mappings Not in Costpoint Web 

Create Microframe Transfer Files Others » Product Interfaces » Microframe 
Interface » Microframe Transfer Not in Costpoint Web 

Cost Pool Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Cost Pool Controls Client/Server Web 

Manage Allocation Groups Projects » Cost and Revenue Processing » 
Cost Pool Setup » Allocation Groups 

Projects » Configure » Allocations » 
Allocation Groups 

Manage Pool Processing Sequence Numbers 
Projects » Cost and Revenue Processing » 
Cost Pool Setup » Set Pool Processing 
Sequence 

Projects » Maintain » Allocations » Pool 
Processing Sequence 
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Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Cost and Revenue Processing » 
Administrative Utilities Client/Server Web 

Group Duplicates in Labor History 
Projects » Cost and Revenue Processing » 
Utilities » Miscellaneous Toolkits » Group 
Duplicates in Labor History* 

Not in Costpoint Web 

Rebuild Labor History Projects » Cost and Revenue Processing » 
Utilities » Rebuild Labor History Not in Costpoint Web 

Synchronize Project Performance Tables 
Projects » Cost and Revenue Processing » 
Utilities » Synchronize Project Performance 
Tables 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

Project Inquiry and Reporting 

Report Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Inquiry and Reporting » 
Report Processing Client/Server Web 

Compute/Print Purchasing Commitments Projects » Inquiry and Reporting » Report 
Processing » Compute and Print Commitments 

Projects » Process » Project » Compute and 
Print Purchasing Commitments 

Update Project Status Report Tables 
Projects » Inquiry and Reporting » Report 
Processing » Update Project Status Report 
Table 

Projects » Process » Project » Update 
Project Status Report Table 
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Create Project Report Tables Projects » Inquiry and Reporting » Report 
Processing » Create Project Report Tables 

Projects » Process » Project » Update Other 
Project Report Tables 

Project Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Project Inquiry and Reporting » 
Project Reports/Inquiries Client/Server Web 

Print Organization Cost Summary Report Projects » Inquiry and Reporting » Project 
Reporting » Print Organization Cost Summary 

Projects » Review » Project » Organization 
Cost Summary Report 

Print Project Labor Summary Report Projects » Inquiry and Reporting » Project 
Reporting » Print Project Labor Summary 

Projects » Review » Project » Project Labor 
Summary Report 

Print Project Non-Labor Detail Report Projects » Inquiry and Reporting » Project 
Reporting » Print Project Non-Labor Detail 

Projects » Review » Project » Project Non-
Labor Detail Report 

Print Project Status Report Projects » Inquiry and Reporting » Project 
Reporting » Print Project Status Report 

Projects » Review » Project » Project Status 
Report 

Print Revenue Summary Report Projects » Inquiry and Reporting » Project 
Reporting » Print Revenue Summaries 

Projects » Review » Project » Revenue 
Summary Report 

Print Revenue Worksheet Projects » Inquiry and Reporting » Project 
Reporting » Print Revenue Worksheet 

Projects » Review » Project » Revenue 
Worksheet 

Print T&M Analysis Report Projects » Inquiry and Reporting » Project 
Reporting » Print T&M Analysis 

Projects » Review » Project » T&M Analysis 
Report 

View Project Activity Projects » Inquiry and Reporting » Inquiry » 
Project Inquiry 

Projects » Review » Project » Project 
Inquiry 

View Project Activity by Level Projects » Inquiry and Reporting » Inquiry » 
Project Inquiry by Level 

Projects » Review » Project » Project 
Inquiry by Level 
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View Project Ledger Activity Projects » Inquiry and Reporting » Inquiry » 
Project Ledger Inquiry 

Projects » Review » Project » Project 
Ledger Inquiry 

Billing 

Billing Formats 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Billing Formats Client/Server Web 

Manage Generic Billing Formats Projects » Billing » Formats » Generic Billing 
Formats 

Projects » Maintain » Billing » Generic 
Billing Formats 

Manage Supporting Schedule Formats Projects » Billing » Formats » Supporting 
Schedule Formats 

Projects » Maintain » Billing » Supporting 
Schedule Formats 

Billing Master 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Billing Master Client/Server Web 

Manage Project Billing Information Projects » Billing » Billing Master » Project 
Billing Info 

Projects » Maintain » Billing » Project Billing 
Information 

Manage ACRN Bills Projects » Billing » Billing Master » Maintain 
ACRN Bills 

Projects » Maintain » Billing » Maintain 
ACRN Bills 

Manage Project Sales Tax Setups Projects » Billing » Billing Master » Project 
Sales Tax Setup Not in Costpoint Web 

Manage Account Discounts Projects » Billing » Billing Master » Maintain 
Account Discounts 

Projects » Maintain » Billing » Account 
Discounts 
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Manage Customer Volume Discounts Projects » Billing » Billing Master » Maintain 
Customer Volume Discounts 

Projects » Maintain » Billing » Customer 
Volume Discounts 

Manage Project Volume Discounts Projects » Billing » Billing Master » Maintain 
Project Volume Discounts 

Projects » Maintain » Billing » Project 
Volume Discounts 

Manage Project WAWF Information Projects » Billing » Billing Master » Maintain 
Project WAWF Information 

Projects » Maintain » Billing » Project 
WAWF Information 

Units Usage Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Units Usage Processing Client/Server Web 

Manage Unit Usage Projects » Billing » Units Usage » Enter Unit 
Usage 

Projects » Transactions » Units » Enter 
Units Usage 

Import Units Usage Files Projects » Billing » Units Usage » Upload Unit 
Usage Data 

Projects » Utilities » Import » Import Units 
Usage Data 

Print Usage Edit Report Projects » Billing » Units Usage » Print Usage 
Edit Report 

Projects » Transactions » Units » Units 
Usage Edit Report 

Post Unit Usage Projects » Billing » Units Usage » Post Unit 
Usage 

Projects » Process » Post » Post Units 
Usage 

Manage Units Usage History Projects » Billing » Units Usage » Maintain 
Units Usage History Not in Costpoint Web 

Print Units Usage History Report Projects » Billing » Units Usage » Print Units 
Usage History Report 

Projects » Configure » Units History » Units 
Usage History Report 
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Standard Bill Adjustments 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Standard Bill 
Adjustments Client/Server Web 

Manage Open Billing Detail Projects » Billing » Prepare Billings » Maintain 
Open Billing Detail 

Projects » Maintain » Billing » Open Billing 
Detail 

Adjust Open Billing Detail Records Projects » Billing » Prepare Billings » 
Adjustments in Open Billing Detail 

Projects » Process » Billing » Adjust Open 
Billing Detail 

Standard Bills Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Standard Bills 
Processing Client/Server Web 

Load Labor Rates 

Projects » Cost and Revenue Processing » 
Revenue Processing » Load Labor Rates 

Projects » Billing » Prepare Billings » Load 
Labor Rates 

Projects » Process » Billing » Load Labor 
Rates 

Load Multicurrency Transaction Amounts Not in Costpoint Client/Server Not in Costpoint Web 

Update Cash Basis Information Projects » Billing » Prepare Billings » Update 
Cash Basis Information 

Projects » Process » Billing » Update Cash 
Basis Bills 

Calculate Standard Bills Projects » Billing » Calculate Billings » 
Calculate Billings Projects » Process » Billing » Calculate Bills 

Manage Standard Bills Projects » Billing » Edit Billings » Edit Standard 
Bills 

Projects » Transactions » Billing » Edit 
Standard Bills 
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Select Bills for Posting Projects » Billing » Edit Billings » Select Bills for 
Posting 

Projects » Transactions » Billing » Select 
Bills for Posting 

Calculate ACRN Bills Projects » Billing » Calculate Billings » 
Calculate ACRN Billings 

Projects » Process » Billing » Calculate 
ACRN Bills 

Print ACRN Billing Edit Report Projects » Billing » Print Billings » Print ACRN 
Billing Edit Report 

Projects » Transactions » Billing » Print 
ACRN Billing Edit Report 

Print Standard Bills Projects » Billing » Print Billings » Print 
Standard Bills 

Projects » Transactions » Billing » Print 
Standard Bills 

Print Form 1034 Projects » Billing » Print Billings » Print Form 
1034 

Projects » Transactions » Billing » Print 
Form 1034 

Print Indirect Rate Retroactive Billing Schedule Not in Costpoint Client/Server Not in Costpoint Web 

Create WAWF Billing Files Projects » Billing » Print Billings » Create 
WAWF Billing Files 

Projects » Process » Billing » Create WAWF 
Billing Files 

Post Standard Bills Projects » Billing » Post Billings » Post 
Standard Bills 

Projects » Process » Post » Post Standard 
Bills 

Reverse Previous Bills Projects » Billing » Calculate Billings » Reverse 
Previous Billings 

Projects » Process » Billing » Reverse 
Previous Bills 

Calculate Retroactive Bills Projects » Billing » Calculate Billings » 
Calculate Retroactive Billings 

Projects » Process » Billing » Calculate 
Retroactive Bills 

Print Retroactive Billing Worksheet Projects » Billing » Print Billings » Print 
Retroactive Billing Worksheets 

Projects » Transactions » Billing » Print 
Retroactive Bill Worksheets 
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Progress Payment Bills Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Progress Payment Bills 
Processing Client/Server Web 

Load Labor Rates 

Projects » Cost and Revenue Processing » 
Revenue Processing » Load Labor Rates 

Projects » Billing » Prepare Billings » Load 
Labor Rates 

Projects » Process » Billing » Load Labor 
Rates 

Update Subcontractor Progress Payments Projects » Billing » Prepare Billings » Update 
Subcontractor Progress Payments Not in Costpoint Web 

Calculate Progress Payment Bills Projects » Billing » Calculate Billings » 
Calculate Progress Payment Billings 

Projects » Process » Billing » Calculate 
Progress Payment Bills 

Manage Progress Payment Bills Projects » Billing » Edit Billings » Edit Progress 
Payment Billings 

Projects » Transactions » Billing » Edit 
Progress Payment Bills 

Print Progress Payment Bills Projects » Billing » Print Billings » Print 
Progress Payment Bills 

Projects » Transactions » Billing » Print 
Progress Payment Bills 

Post Progress Payment Bills Projects » Billing » Post Billings » Post 
Progress Payment Bills 

Projects » Process » Post » Post Progress 
Payment Bills 

Milestone Percent Complete Bills Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Milestone Percent 
Complete Bills Processing Client/Server Web 

Manage Milestone Percent Complete Bills Projects » Billing » Edit Billings » Edit 
Milestone/Percent Complete Bills 

Projects » Transactions » Billing » Enter 
Milestone/Percent Complete Bills 
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Print Milestone Percent Complete Bills Projects » Billing » Print Billings » Print 
Milestone/Percent Complete Bills 

Projects » Transactions » Billing » Print 
Milestone/Percent Complete Bills 

Post Milestone Percent Complete Bills Projects » Billing » Post Billings » Post 
Milestone/Percent Complete Bills 

Projects » Process » Post » Post 
Milestone/Percent Complete Bills 

Project Product Bills Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Project Product Bills 
Processing Client/Server Web 

Manage Project Product Bills Projects » Billing » Edit Billings » Edit Project 
Product Bills 

Projects » Transactions » Billing » Enter 
Project Product Bills 

Print Project Product Bills Projects » Billing » Print Billings » Print Project 
Product Bills 

Projects » Transactions » Billing » Print 
Project Product Bills 

Post Project Product Bills Projects » Billing » Post Billings » Post Project 
Product Bills 

Projects » Process » Post » Post Project 
Product Bills 

Manual Bills Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Manual Bills Processing Client/Server Web 

Manage Manual Bills Projects » Billing » Edit Billings » Edit Manual 
Bills 

Projects » Transactions » Billing » Enter 
Manual Bills 

Post Manual Bills Projects » Billing » Post Billings » Post Manual 
Bills 

Projects » Process » Post » Post Manual 
Bills 
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Customer Product Bills Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Customer Product Bills 
Processing Client/Server Web 

Manage Customer Product Bills Projects » Billing » Edit Billings » Edit Customer 
Product Bills 

Projects » Transactions » Billing » Enter 
Customer Product Bills 

Print Customer Product Bills Projects » Billing » Print Billings » Print 
Customer Product Bills 

Projects » Transactions » Billing » Print 
Customer Product Bills 

Post Customer Product Bills Projects » Billing » Post Billings » Post 
Customer Product Bills 

Projects » Process » Post » Post Customer 
Product Bills 

Unbilled Receivables 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Unbilled Receivables Client/Server Web 

Manage Unbilled Reason Codes Projects » Billing » Unbilled Receivables » 
Maintain Unbilled Reason Codes 

Projects » Transactions » Unbilled 
Receivables » Assign Unbilled Reason 
Codes 

Create Unbilled Analysis Report Tables Projects » Billing » Unbilled Receivables » 
Create Unbilled Analysis Report 

Projects » Process » Unbilled Receivables » 
Update Unbilled Analysis Report Tables 

Edit Unbilled Reason Codes Projects » Billing » Unbilled Receivables » Edit 
Unbilled Reason Codes 

Projects » Transactions » Unbilled 
Receivables » Assign Unbilled Reason 
Codes 

Print Unbilled Analysis Report Projects » Billing » Unbilled Receivables » Print 
Unbilled Analysis 

Projects » Review » Unbilled Receivables » 
Unbilled Analysis Report 
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EDI Billing Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » EDI Billing Processing Client/Server Web 

Create EDI Files Projects » Billing » EDI Billing » Create EDI 
Files 

Projects » Process » Billing » Create Billing 
EDI Files 

Billing History 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Billing History Client/Server Web 

Manage Billing History Projects » Billing » Billing History » Maintain 
Billing History Not in Costpoint Web 

Manage Closed Billing Detail Projects » Billing » Billing History » Maintain 
Closed Billing Detail 

Projects » Configure » Billing History » 
Posted Billing Detail 

Manage Project Bill Summary Projects » Billing » Billing History » Maintain 
Project Bill Summary Not in Costpoint Web 

Manage Closed Progress Billing Detail Projects » Billing » Billing History » Maintain 
Closed Progress Billing Detail Not in Costpoint Web 

Manage Subcontractor Progress Payments Projects » Billing » Billing History » Maintain 
Subcontractor Progress Payments 

Projects » Configure » Billing History » 
Subcontractor Progress Payments 
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Billing Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Billing Reports/Inquiries Client/Server Web 

Print Billing Register Projects » Billing » Inquiry and Reporting » 
Print Billing Register 

Projects » Review » Billing » Billing Register 
Report 

Print Open Billing Detail Report Projects » Billing » Inquiry and Reporting » 
Print Open Billing Detail 

Projects » Review » Billing » Open Billing 
Detail Report 

View Standard Billing History Projects » Billing » Inquiry and Reporting » 
Standard Billing History Inquiry Not in Costpoint Web 

Open Billing Detail Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Open Billing Detail 
Utilities Client/Server Web 

Update Open Billing Detail Records Projects » Billing » Utilities » Update Open 
Billing Detail 

Projects » Utilities » Project Toolkits » 
Update Open Billing Detail 

Purge Open Billing Detail Records Projects » Billing » Utilities » Purge Open 
Billing Detail Not in Costpoint Web 

Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Billing Controls Client/Server Web 

Configure Billing Settings Projects » Billing » Controls » Billing Settings Not in Costpoint Web 
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Manage Billing Accounts Projects » Billing » Controls » Maintain Billing 
Accounts Not in Costpoint Web 

Manage Billing Cycles Projects » Billing » Controls » Billing Cycle Projects » Configure » Billing » Billing 
Cycles 

Manage Billing Standard Text Projects » Billing » Controls » Billing Standard 
Text Not in Costpoint Web 

Manage Billing User Groups Projects » Billing » Controls » Billing User 
Groups 

Projects » Configure » Billing » Billing User 
Groups 

Manage Contractor Addresses Projects » Billing » Controls » Contractor 
Addresses Not in Costpoint Web 

Manage Government Payment Offices Projects » Billing » Controls » Govt. Payment 
Offices Not in Costpoint Web 

Manage Other Charges Projects » Billing » Controls » Maintain Other 
Charges 

Projects » Configure » Billing » Other Billing 
Charges 

Manage Remittance Addresses Projects » Billing » Controls » Remittance 
Addresses 

Projects » Configure » Billing » Remittance 
Addresses 

Manage Taxable Sales Accounts Projects » Billing » Controls » Taxable Sales 
Account Not in Costpoint Web 

Configure WAWF Billing Settings Projects » Billing » Controls » Maintain WAWF 
Billing Settings 

Administration » Configure » Projects » 
WAWF Billing Settings 

Configure Billing EDI Settings Projects » Billing » EDI Billing » Maintain Billing 
EDI Settings 

Administration » Configure » Projects » 
Billing EDI Settings 

Manage Project EDI Information Projects » Billing » EDI Billing » Maintain 
Project EDI Information Not in Costpoint Web 
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Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Billing » Administrative Utilities Client/Server Web 

Update Billing Currency Amounts Projects » Billing » Utilities » Miscellaneous 
Toolkits » Update Billing Currency Amounts* Not in Costpoint Web 

Update Billing Tables for Cumulative Tax 
Projects » Billing » Utilities » Miscellaneous 
Toolkits » Update Billing Tables for Cumulative 
Tax* 

Not in Costpoint Web 

Update Billing Tables Bill Labor Category 
Description 

Projects » Billing » Utilities » Miscellaneous 
Toolkits » Update Billing Tables 
BillLabCatDescr* 

Not in Costpoint Web 

Validate Open Billing Detail Account Function 
Codes 

Projects » Billing » Utilities » Miscellaneous 
Toolkits » Open Billing Detail Account Function 
Code Toolkit* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

NASA 533s 

NASA 533 Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » NASA 533s » NASA 533 
Processing Client/Server Web 

Manage NASA 533 Formats Projects » NASA 533s » Formats Not in Costpoint Web 

Manage NASA 533 Project Information Projects » NASA 533s » Project Info Not in Costpoint Web 
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Create NASA 533 Report Tables Projects » NASA 533s » Create NASA 533s Not in Costpoint Web 

Print NASA 533 Report Projects » NASA 533s » Print NASA 533s Not in Costpoint Web 

NASA 533 Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » NASA 533s » NASA 533 Controls Client/Server Web 

Configure NASA 533 Fiscal Years Projects » NASA 533s » Map Fiscal Years for 
Reporting Not in Costpoint Web 

Configure NASA 533 Accounting Periods Projects » NASA 533s » Map Accounting 
Periods for Reporting Not in Costpoint Web 

Inter-Company Work Orders 

Inter-Company Work Orders Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Inter-Company Work Orders » 
Inter-Company Work Orders Processing Client/Server Web 

Manage IWO Expense Mappings Projects » Inter-Company Work Orders » 
Controls » IWO Expense Mapping Not in Costpoint Web 

Manage IWO Projects Projects » Inter-Company Work Orders » 
Controls » IWO Project Setup Not in Costpoint Web 

Create IWO Allocations Projects » Inter-Company Work Orders » 
Create IWO Allocations Not in Costpoint Web 
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Manage IWO Allocations Projects » Inter-Company Work Orders » 
Controls » Maintain IWO Allocations Not in Costpoint Web 

Post IWO Journal Projects » Inter-Company Work Orders » Post 
IWO Journal Not in Costpoint Web 

Inter-Company Work Orders Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Inter-Company Work Orders » 
Inter-Company Work Orders Interfaces Client/Server Web 

Export IWO Allocations Projects » Inter-Company Work Orders » 
Export IWO Allocations Not in Costpoint Web 

Import IWO Allocations Projects » Inter-Company Work Orders » 
Import IWO Allocations Not in Costpoint Web 

Validate IWO Allocations  Projects » Inter-Company Work Orders » IWO 
Allocation Preprocessor Not in Costpoint Web 

Validate IWO Suspense Transactions Projects » Inter-Company Work Orders » 
Maintain IWO Suspense Not in Costpoint Web 

Inter-Company Work Orders Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Projects » Inter-Company Work Orders » 
Inter-Company Work Orders Controls Client/Server Web 

Configure Transfer Locations Projects » Inter-Company Work Orders » 
Controls » Maintain Transfer Locations Not in Costpoint Web 
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People 

Employee 

Basic Employee Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Basic Employee 
Information Client/Server Web 

Manage Employee Information 

People » Employee » Basic Employee Setup » 
Maintain Employee Master 

People » Employee » Basic Employee Setup » 
Basic Employee Info 

People » Maintain » Employee » Employee 
User Flow 

Manage Employee Salary Information People » Employee » Basic Employee Setup » 
Salary Info and History 

People » Maintain » Employee » Employee 
Salary Information 

Update Salaries for Compensation Plan 
Changes 

People » Employee » Mass Updates » Update 
Employees for Compensation Plan Changes Not in Costpoint Web  

Update Employees for Manager Change People » Employee » Mass Updates » Update 
Employees for Manager Change Not in Costpoint Web 

Update Employee Affirmative Action Plan People » Employee » Mass Updates » Update 
Employee Affirmative Action Plan Not in Costpoint Web 

Manage Employee Allowances People » Employee » Basic Employee Setup » 
Maintain Employee Allowances 

People » Maintain » Employee » Employee 
Allowances 

Manage Employee User-Defined Information People » Employee » Basic Employee Setup » 
Employee User-Defined Info 

People » Maintain » Employee » Employee 
User-Defined Information 
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Manage Employee Life Events People » Employee » Basic Employee Setup » 
Employee Life Events Not in Costpoint Web 

Assign GLCs to Employees People » Employee » Basic Employee Setup » 
Authorized Labor Categories 

People » Maintain » Employee » Assign 
GLCs to Employees 

Manage Employee Photo File Locations People » Employee » Employee HR Setup » 
Employee Photo Not in Costpoint Web 

Manage Employee U.S. and ITAR Data Not in Costpoint Client/Server Not in Costpoint Web 

Employee Leave Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Leave 
Information Client/Server Web 

Manage Leave Beginning Balances People » Employee » Basic Employee Setup » 
Maintain Leave Beginning Balances 

People » Maintain » Employee » Employee 
Leave Beginning Balances 

Manage Employee Leave People » Employee » Basic Employee Setup » 
Employee Leave 

People » Maintain » Employee » Employee 
Leave  

Employee Payroll Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Payroll 
Information Client/Server Web 

Manage Employee Taxes People » Employee » Employee Payroll Setup 
» Employee Taxes Not in Costpoint Web 

Manage Employee Deductions People » Employee » Employee Payroll Setup 
» Employee Deductions Not in Costpoint Web 
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Manage Employee Contributions People » Employee » Employee Payroll Setup 
» Employee Contributions Not in Costpoint Web 

Update Employee Deductions/Contributions People » Employee » Mass Update » Update 
Employee Deduction/Contributions Not in Costpoint Web 

Manage Employee Bank Information People » Employee » Employee Payroll Setup 
» Maintain Employee Bank Info Not in Costpoint Web 

Manage Employee Savings Bonds People » Employee » Employee Payroll Setup 
» Employee Bond Table Not in Costpoint Web 

Manage Employee Garnishments People » Employee » Employee Payroll Setup 
» Employee Garnishments Not in Costpoint Web 

Employee Benefit Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Benefit 
Information Client/Server Web 

Manage Employee Benefit Elections People » Employee » Employee Benefit Setup 
» Employee Benefit Elections Not in Costpoint Web 

Manage Employee Dependents/Beneficiaries People » Employee » Employee Benefit Setup 
» Employee Dependents/Beneficiaries Not in Costpoint Web 

Assign Dependents to Benefit Plans People » Employee » Employee Benefit Setup 
» Assign Dependents to Benefit Plans Not in Costpoint Web 

Assign Beneficiaries to Benefit Plans People » Employee » Employee Benefit Setup 
» Assign Beneficiaries  to Benefit Plans Not in Costpoint Web 
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Employee FSA Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee FSA 
Information Client/Server Web 

Manage Employee Dependent Care FSA 
Elections 

People » Employee » Employee FSA Setup » 
Employee Dependent Care FSA Elections Not in Costpoint Web 

Manage Dependent Care Reimbursement People » Employee » Employee FSA Setup » 
Request Dependent Care Reimbursement Not in Costpoint Web 

Manage Dependent Care FSA History People » Employee » Employee FSA Setup » 
Maintain Dependent Care History Not in Costpoint Web 

Manage Employee Medical Care FSA Elections People » Employee » Employee FSA Setup » 
Employee Medical Care FSA Elections Not in Costpoint Web 

Manage Medical Care Reimbursement People » Employee » Employee FSA Setup » 
Request Medical Care Reimbursement Not in Costpoint Web 

Manage Medical Care FSA History People » Employee » Employee FSA Setup » 
Maintain Medical Care History Not in Costpoint Web 

Employee HR Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee HR 
Information Client/Server Web 

Manage Employee I-9 Data People » Employee » Employee HR Setup » I-9 
Data Not in Costpoint Web 

Manage Employee Drug Testing Results People » Employee » Employee HR Setup » 
Employee Drug Testing Results Not in Costpoint Web 
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Manage Employee Medical Surveillance Log People » Employee » Employee HR Setup » 
Employee Medical Surveillance Not in Costpoint Web 

Manage Education, Skills & Training Data People » Employee » Employee HR Setup » 
Education, Skills & Training Data Not in Costpoint Web 

Update Employee Training People » Employee » Mass Updates » Update 
Employee Training Not in Costpoint Web 

Manage Employee Awards People » Employee » Employee HR Setup » 
Maintain Employee Awards Not in Costpoint Web 

Update Employee Service Awards People » Employee » Mass Updates » Update 
Employee Service Awards Not in Costpoint Web 

Manage Employee Security Status  People » Employee » Employee HR Setup » 
Security Status by Employee Not in Costpoint Web 

Manage Company Issued Documents People » Employee » Employee HR Setup » 
Company Issued Documents by Employee Not in Costpoint Web 

Manage Company Issued Property People » Employee » Employee HR Setup » 
Company Property Issued to Employee Not in Costpoint Web 

Manage Company Issued Vehicles People » Employee » Employee HR Setup » 
Company Vehicles by Employee Not in Costpoint Web 

Manage Employee State Driver's License People » Employee » Employee HR Setup » 
State Driver’s License by Employee Not in Costpoint Web 
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Employee Deferred Compensation Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Deferred 
Compensation Information Client/Server Web 

Manage Employee Deferred Compensation  
People » Employee » Employee Deferred 
Comp Setup » Employee Deferred 
Compensation Info 

Not in Costpoint Web 

Update  Employee Deferred Compensation Info People » Employee » Mass Updates » Auto 
Load Employee Deferred Compensation Info Not in Costpoint Web 

Performance Review Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Performance Review 
Processing Client/Server Web 

Print Review Form Template People » Employee » Employee Performance 
Reviews » Print Review Form Template Not in Costpoint Web 

Manage Employee Review People » Employee » Employee Performance 
Reviews » Maintain Employee Review Info Not in Costpoint Web 

Print Completed Review Forms People » Employee » Employee Performance 
Reviews » Print Completed Review Form Not in Costpoint Web 

Update Employee Salary Based on Review 
People » Employee » Employee Performance 
Reviews » Update Employee Salary Based On 
Review 

Not in Costpoint Web 

Print Performance Review Statistics People » Employee » Employee Performance 
Reviews » Print Review Statistics by Employee Not in Costpoint Web 
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Termination Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Termination 
Processing Client/Server Web 

Print Exit Interview Form Template People » Employee » Termination Processing » 
Print Exit Interview Form Template Not in Costpoint Web 

Manage Employee Exit Interviews People » Employee » Termination Processing » 
Maintain Employee Exit Interview Info Not in Costpoint Web 

Print Completed Exit Interview Form People » Employee » Termination Processing » 
Print Completed Exit Interview Form Not in Costpoint Web 

Employee Reports 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Reports Client/Server Web 

Print Employee Awards List People » Employee » Employee Reports » 
Print Employee Awards Not in Costpoint Web 

Print Employee Basic Report People » Employee » Employee Reports » 
Print Employee Basic Report 

People » Review » Employee » Basic 
Employee Information Report 

Print Employee Job Title Report People » Employee » Employee Reports » 
Print Employees by Job Title Not in Costpoint Web 

Print Employee Medical Surveillance Data 
Report 

People » Employee » Employee Reports » 
Print Employee Medical Surveillance Data Not in Costpoint Web 

Print Employee Salary Information Report People » Employee » Employee Reports » 
Print Employee Salary Info and History Rpt 

People » Review » Employee » Employee 
Salary Information Report 
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Print Employee Setup Report People » Employee » Employee Reports » 
Print Employee Setup Report 

People » Review » Employee » Employee 
Setup Report 

Print FLSA Status Report People » Employee » Employee Reports » 
FLSA Status Report Not in Costpoint Web 

Print New Hire Report People » Employee » Employee Reports » 
Print New Hire Report Not in Costpoint Web 

Employee Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Utilities Client/Server Web 

Change Employee Address Line Order 
People » Labor » Utilities » Miscellaneous 
Functions » Reorder Employee Address Line 
Information* 

Not in Costpoint Web 

Convert Race/Ethnicity Codes to New Race 
Codes 

People » Labor » Utilities » Miscellaneous 
Functions » Convert Race/Ethnicity Codes* Not in Costpoint Web 

Update Employee Telephone Types 
People » Labor » Utilities » Miscellaneous 
Functions » Update Employee Telephone 
Types* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Functions screen have been broken out into standalone applications in Costpoint 7. 

Employee Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Interfaces Client/Server Web 

Manage Employee Import User-Defined Format Others » Product Interfaces » Preprocessors » 
Employee Basic Preprocessor Setup Not in Costpoint Web 



People  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
96 

 

Import Employee Data Others » Product Interfaces » Preprocessors » 
Employee Basic Preprocessor Not in Costpoint Web 

Import Employee Leave and Deductions Others » Product Interfaces » Preprocessors » 
Deduction and Leave Preprocessor Not in Costpoint Web 

Transfer Silkroad Data Not in Costpoint Client/Server Not in Costpoint Web 

Configure ESS Global Settings Others » Product Interfaces » Employee Self 
Service » ESS Global Settings Not in Costpoint Web 

Manage ESS Company Settings Others » Product Interfaces » Employee Self 
Service » ESS Company Settings Not in Costpoint Web 

Manage ESS Company Links Others » Product Interfaces » Employee Self 
Service » ESS Company Links Not in Costpoint Web 

Configure  ESS Life Events Others » Product Interfaces » Employee Self 
Service » ESS Life Event Setup Not in Costpoint Web 

Configure ESS State Tax Settings Others » Product Interfaces » Employee Self 
Service » ESS State Tax Settings Not in Costpoint Web 

Approve Employee Life Events Others » Product Interfaces » Employee Self 
Service » Approve Employee Life Events Not in Costpoint Web 

Manage Life Event User Flow Status Others » Product Interfaces » Employee Self 
Service » Life Event User Flow Status Not in Costpoint Web 

Manage ESS Life Event Benefit Elections Others » Product Interfaces » Employee Self 
Service » ESS Life Event Benefit Elections Not in Costpoint Web 

Update Benefit Option/Election Tables 
Others » Product Interfaces » Employee Self 
Service » Populate Open Enrollment Benefit 
Options 

Not in Costpoint Web 
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Manage ESS Open Enrollment Elections Others » Product Interfaces » Employee Self 
Service » ESS Open Enrollment Elections Not in Costpoint Web 

Approve ESS Benefit Elections By Plan 
Others » Product Interfaces » Employee Self 
Service » Approve ESS Benefit Elections by 
Plan 

Not in Costpoint Web 

Activate Pending ESS Benefit Elections Others » Product Interfaces » Employee Self 
Service » Activate Pending Benefit Elections Not in Costpoint Web 

Manage ESS Retirement Benefit Elections 
Others » Product Interfaces » Employee Self 
Service » Maintain ESS Retirement Benefit 
Elections 

Not in Costpoint Web 

Activate ESS Retirement Benefit Changes 
Others » Product Interfaces » Employee Self 
Service » Maintain ESS Retirement Benefit 
Elections 

Not in Costpoint Web 

Purge ESS Data Others » Product Interfaces » Employee Self 
Service » Purge ESS Data Not in Costpoint Web 

Employee Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Employee » Employee Controls Client/Server Web 

Manage Employee Class Codes People » Employee » Employee Controls » 
Employee Class 

People » Configure » Employee » Employee 
Class Codes 

Manage Employee User-Defined Labels People » Employee » Employee Controls » 
Employee User-Defined Labels Not in Costpoint Web 

Manage Life Event Codes People » Employee » Employee Controls » Life 
Event Codes Not in Costpoint Web 

Manage Locator Codes Not in Costpoint Client/Server Not in Costpoint Web 
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Manage Race and Ethnicity Codes People » Employee » Employee Controls » 
Race/Ethnicity Codes Not in Costpoint Web 

Manage Visa Types People » Employee » Employee Controls » 
Visa Types Not in Costpoint Web 

Manage Citizen Status Codes Not in Costpoint Client/Server Not in Costpoint Web 

Labor 

Timesheet Defaults 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Timesheet Defaults Client/Server Web 

Manage Timesheet Line Type Defaults People » Labor » Timesheet Default Setup » 
Timesheet Line Type Default Settings 

People » Maintain » Timesheet Defaults » 
Timesheet Line Type Defaults 

Manage Employee Timesheet Line Type 
Defaults 

People » Labor » Timesheet Default Setup » 
Employee Timesheet Line Type Defaults 

People » Maintain » Timesheet Defaults » 
Employee Timesheet Line Type Defaults 

Manage Employee Project Timesheet Defaults People » Labor » Timesheet Default Setup » 
Employee Project TS Defaults Not in Costpoint Web 

Manage Employee Proj-Acct-Group Timesheet 
Defaults 

People » Labor » Timesheet Default Setup » 
Employee Project-Acct-Grp TS Defaults 

People » Maintain » Timesheet Defaults » 
Employee Project/Account Group 
Timesheet Defaults 

Manage Labor-Group Proj-Acct-Group 
Timesheet Defaults 

People » Labor » Timesheet Default Setup » 
Labor-Grp Project-Acct-Grp TS Defaults Not in Costpoint Web 

Manage Project Timesheet Defaults People » Labor » Timesheet Default Setup » 
Project TS Defaults 

People » Maintain » Timesheet Defaults » 
Project Timesheet Defaults 
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Timesheet Entry/Creation 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Timesheet Entry/Creation Client/Server Web 

Manage Timesheet Periods People » Labor » Labor Controls » Timesheet 
Periods Not in Costpoint Web 

Manage Work Schedules Not in Costpoint Client/Server Not in Costpoint Web 

Manage Timesheet Batches Not in Costpoint Client/Server Not in Costpoint Web 

Manage Timesheets People » Labor » Timesheets » Enter 
Timesheets 

People » Transactions » Timesheets » 
Enter Timesheets 

Manage Correcting Timesheets People » Labor » Timesheets » Enter 
Correcting Timesheets 

People » Transactions » Timesheets » 
Enter Correcting Timesheets 

Create Auto-Pay Timesheets People » Labor » Auto Generation of 
Timesheets » Create Auto-Pay Timesheets Not in Costpoint Web 

Create Retroactive Timesheet Adjustments 
People » Labor » Auto Generation of 
Timesheets » Create Retroactive Timesheet 
Adjustments 

People » Process » Timesheets » Create 
Retroactive Pay Timesheets 

Create Reversing Timesheets People » Labor » Auto Generation of 
Timesheets » Create Reversing Timesheets 

People » Process » Timesheets » Create 
Reversing Timesheets 

Create Leave Payout Timesheets People » Labor » Auto Generation of 
Timesheets » Create Leave Payout Timesheets 

People » Process » Timesheets » Create 
Leave Payout Timesheets 

Delete Retroactive Timesheet Adjustments 
People » Labor » Auto Generation of 
Timesheets » Delete Retroactive Timesheet 
Adjustments 

People » Utilities » Timesheet » Delete 
Retroactive Timesheet Adjustments 

Delete Leave Payout Timesheets People » Labor » Auto Generation of 
Timesheets » Delete Leave Payout Timesheets  Not in Costpoint Web 
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Timesheet Adjustments 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Timesheet Adjustments Client/Server Web 

Auto-Adjust Timesheets 
People » Labor » Auto Generation of 
Timesheets » Auto-Adjust Timesheets in Batch 
Mode 

Not in Costpoint Web 

Apply Weighted Average Rates to Timesheets People » Labor » Overtime Processing of 
Timesheets » Apply Weighted Average Rates Not in Costpoint Web 

Recast Overtime Premium to Timesheet Lines People » Labor » Overtime Processing of 
Timesheets » Recast Overtime Premium 

People » Process » Timesheets » Recast 
Overtime Premium 

Allocate Compensated Overtime Across 
Timesheet Lines 

People » Labor » Overtime Processing of 
Timesheets » Alloc Comp OT Across TS Lines Not in Costpoint Web 

Create Employee Allowance Timesheet  Lines 
People » Labor » Auto Generation of 
Timesheets » Create Employee Allowance TS 
Lines 

Not in Costpoint Web 

Delete Recasted Overtime Premium from 
Timesheet Lines 

People » Labor » Overtime Processing of 
Timesheets » Delete Recasted Overtime 
Premium 

People » Utilities » Timesheet » Delete 
Recasted Overtime Premium 

Delete Allocated Compensation OT from 
Timesheet Lines 

People » Labor » Overtime Processing of 
Timesheets » Delete Allocated Comp OT 

People » Utilities » Timesheet » Delete 
Allocated Compensated Overtime  

Delete Employee Allowance Timesheet Lines 
People » Labor » Auto Generation of 
Timesheets » Delete Employee Allowance TS 
Lines 

People » Utilities » Timesheet » Delete 
Employee Allowance Timesheet Lines 
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Timesheet Reporting 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Timesheet Reporting Client/Server Web 

Print Missing Timesheet Report People » Labor » Timesheets » Print Missing 
Timesheet Rpt 

People » Transactions » Timesheets » Print 
Missing Timesheet List 

Print Timesheet Information Report by 
Employee 

People » Labor » Timesheets » Print TS Edit by 
Empl Rpt 

People » Transactions » Timesheets » Print 
Timesheet Information by Employee 

Print Timesheet Information Report by Account People » Labor » Timesheets » Print TS Edit by 
Acct Rpt 

People » Transactions » Timesheets » Print 
Timesheet Information by Account 

Timesheet Posting 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Timesheet Posting Client/Server Web 

Post Timesheets People » Labor » Timesheets » Post Labor 
Distribution People » Process » Post » Post Labor 

Labor Reports and Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Labor Reports and 
Inquiries Client/Server Web 

Print Employee Labor Summary Report People » Labor » Labor Reports » Print 
Employee Labor Summary Rpt 

People » Review » Labor » Employee Labor 
Summary Report 

Print Labor Utilization Report People » Labor » Labor Reports » Print Labor 
Utilization Report 

People » Review » Labor » Labor Utilization 
Report 



People  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
102 

 

Print Timesheet History Report People » Labor » Timesheets » Print 
Timesheet History Rpt Not in Costpoint Web 

View Employee Labor Inquiry People » Labor » Inquiries » Employee Labor 
Inquiry 

People » Review » Labor » Employee Labor 
Inquiry 

View Timesheet History Inquiry People » Labor » Inquiries » Timesheet History 
Inquiry 

People » Review » Labor » Timesheet 
History Inquiry 

Timesheet Interface 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Timesheet  Interface Client/Server Web 

Manage Deltek Time and Expense Account 
Types 

People » Labor » Deltek T&E / Project 
Manufacturing » Time Collection Account 
Types 

Not in Costpoint Web 

Manage Accounts for Export People » Labor » Deltek T&E / Project 
Manufacturing » Manage Accounts for Export Not in Costpoint Web 

Manage Projects for Export People » Labor » Deltek T&E / Project 
Manufacturing » Manage Projects for Export Not in Costpoint Web 

Manage Deltek Time and Expense Org 
People » Labor » Deltek T&E / Project 
Manufacturing » Manage Organizations for 
Export 

Not in Costpoint Web 

Export Data To Deltek Time and Expense 
People » Labor » Deltek T&E / Project 
Manufacturing » Export Data to Deltek Time & 
Expense 5.X 

Not in Costpoint Web 

Export Used Leave to Deltek Time and 
Expense 

People » Labor » Utilities » Miscellaneous 
Functions » Export Used Leave to Deltek Time 
& Expense* 

Not in Costpoint Web 
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Import Work Schedules from  Deltek Time and 
Expense Not in Costpoint Client/Server Not in Costpoint Web 

Import Timesheets from Deltek Time and 
Expense 

People » Labor » Deltek T&E / Project 
Manufacturing » Upload  from Time Collection 
(ET) 

Not in Costpoint Web 

Configure Timesheet Suspense Values Others » Product Interfaces » Preprocessors » 
Timesheet Suspense Setup Not in Costpoint Web 

Import Timesheets Others » Product Interfaces » Preprocessors » 
Timesheet Preprocessor Not in Costpoint Web 

Export Project Manufacturing Data Not in Costpoint Client/Server People » Utilities » Interfaces » Export 
Project Manufacturing Data 

Project Manufacturing Export Status History Not in Costpoint Client/Server People » Utilities » Interfaces » Project 
Manufacturing Export Status History 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.1. 

ADP Interface 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » ADP Interface Client/Server Web 

Manage ADP Mapping Values Others » Product Interfaces » ADP Interface » 
ADP Mappings Not in Costpoint Web 

Manage ADP 2.5 Mapping Values Others » Product Interfaces » ADP Interface » 
ADP 2.5 Mappings Not in Costpoint Web 

Export Timesheets to ADP Others » Product Interfaces » ADP Interface » 
ADP Timesheet Transfer Not in Costpoint Web 
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Ceridian Interface 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Ceridian Interface Client/Server Web 

Manage Ceridian Configuration Others » Product Interfaces » Ceridian 
Interface » Maintain Ceridian Configuration Not in Costpoint Web 

Export Timesheet to Ceridian Others » Product Interfaces » Ceridian 
Interface » Download Timesheets to Ceridian Not in Costpoint Web 

Labor Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Labor Controls Client/Server Web 

Configure Labor Settings People » Labor » Labor Controls » Labor 
Settings Not in Costpoint Web 

Manage General Labor Categories People » Labor » Labor Controls » General 
Labor Categories 

People » Configure » Labor » General 
Labor Categories 

Manage Workers' Compensation Codes People » Labor » Labor Controls » Workers’ 
Comp Codes 

People » Configure » Work-Related Injuries-
Illnesses » Workers’ Compensation Codes 

Labor Rate Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Labor Rate Controls Client/Server Web 

Manage Pay Types People » Labor » Labor Controls » Pay Types People » Configure » Labor » Pay Types 
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Manage Pay Type Restrictions People » Labor » Labor Rate Controls » Pay 
Type Restrictions 

People » Configure » Labor » Pay Type 
Restrictions 

Manage Labor Groups/Unions People » Labor » Labor Rate Controls » Labor 
Groups/Unions 

People » Configure » Labor » Labor 
Groups/Unions 

Manage Labor Locations/Locals People » Labor » Labor Rate Controls » Labor 
Locations/Locals 

People » Configure » Labor » Labor 
Locations/Locals 

Manage Wage Determination Rates People » Labor » Labor Rate Controls » Wage 
Determination Rates 

People » Configure » Labor » Wage 
Determination Rates 

Manage Wage Determination Fringe Charge 
Codes 

People » Labor » Labor Rate Controls » WD 
Fringe Handling Not in Costpoint Web 

Manage Allowance Codes People » Labor » Labor Rate Controls » 
Allowances People » Configure » Payroll » Allowances 

Manage Allowance Account Mapping People » Labor » Labor Rate Controls » Map 
Allowance Accounts 

People » Configure » Payroll » Allowance 
Account Mappings 

Overtime Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Overtime Controls Client/Server Web 

Manage Overtime Premium Recast Charge 
Codes 

People » Labor » Overtime Controls » Overtime 
Premium Recast 

People » Configure » Overtime » Overtime 
Premium Recast 

Configure Weighted Average Overtime Settings People » Labor » Overtime Controls » 
Weighted Average Overtime Setup Not in Costpoint Web 

Manage Overtime Rules by Location People » Labor » Overtime Controls » Overtime 
Rules by Location 

People » Configure » Overtime » Overtime 
Rules by Location 
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Manage Overtime Rules by State People » Labor » Overtime Controls » Overtime 
Rules by State 

People » Configure » Overtime » Overtime 
Rules by State 

Union Information Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Union Information 
Controls Client/Server Web 

Manage Fringe Codes People » Labor » Union Info » Fringe Code 
Setup 

People » Configure » Labor » Union Fringe 
Codes 

Manage Fringe Modify Codes People » Labor » Union Info » Fringe Modify 
Code 

People » Configure » Labor » Union Fringe 
Modify Codes 

Manage Assignment of Employees to Crews People » Labor » Union Info » Crew 
Assignment Not in Costpoint Web 

Manage Union Profile Setup People » Labor » Union Info » Union Profile Not in Costpoint Web 

Update Fringe Table in Union Profile People » Labor » Union Info » Mass Update of 
Fringes Not in Costpoint Web 

Manage Fringe Ceilings by Local People » Labor » Union Info » Union Fringe 
Ceilings by Local Not in Costpoint Web 

Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Labor » Administrative Utilities Client/Server Web 

Purge Labor History Tables People » Labor » Utilities » Miscellaneous 
Functions » Purge Labor History Table* Not in Costpoint Web 
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Purge Timesheet History People » Labor » Utilities » Purge Timesheet 
History Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Functions screen have been broken out into standalone applications in Costpoint 7. 

Leave 

Leave Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Leave » Leave Processing Client/Server Web 

Manage Leave Periods People » Leave » Leave Controls » Leave 
Periods 

People » Configure » Leave » Leave 
Periods 

Print Employee Leave Report People » Leave » Leave Processing » Print 
Employee Leave Report 

People » Transactions » Leave » Print 
Employee Leave List 

Compute Leave Accruals People » Leave » Leave Processing » 
Compute Leave Accruals 

People » Transactions » Leave » Compute 
Leave Accruals 

Print Leave Edit Report People » Leave » Leave Processing » Print 
Leave Edit Report 

People » Transactions » Leave » Print 
Leave Edit Accruals 

Manage Leave Edit Table People » Leave » Leave Processing » Maintain 
Leave Edit Table 

People » Transactions » Leave » Edit 
Employee Leave Accruals 

Print Employee Leave Statements People » Leave » Leave Processing » Print 
Employee Leave Statements 

People » Transactions » Leave » Print 
Employee Leave Statements 

Post Leave Accruals People » Leave » Leave Processing » Post 
Leave Accruals People » Process » Post » Post Leave 

Print Leave Accrual Report People » Leave » Leave Processing » Print 
Accrued Leave Report 

People » Transactions » Leave » Print 
Accrued Leave  Balances 
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Close Leave Period People » Leave » Leave Processing » Close 
Leave Period 

People » Process » Close » Close Leave 
Period 

Year-End Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Leave » Year-End Processing Client/Server Web 

Close Leave Year People » Leave » Leave Processing » Close 
Leave Year 

People » Transactions » Calendar-Year End 
» Close Leave Year 

Leave Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Leave » Leave Inquiries Client/Server Web 

View Leave History People » Leave » Inquiries » Leave History 
Inquiry 

People » Review » Leave » Leave History 
Inquiry 

Leave Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Leave » Leave Utilities Client/Server Web 

Trade-Up Leave History Table to Last 
Reconciliation Not in Costpoint Client/Server Not in Costpoint Web 

Reconcile Leave Balances Not in Costpoint Client/Server Not in Costpoint Web 

Purge Leave History People » Leave » Utilities » Purge Leave 
History 

People » Utilities » Purge » Purge Leave 
History 
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Leave Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Leave » Leave Controls Client/Server Web 

Configure Leave Settings People » Leave » Leave Controls » Leave 
Settings 

Administration » Configure » People » 
Leave Settings 

Manage Leave Types People » Leave » Leave Controls » Leave 
Types People » Configure » Leave » Leave Types 

Manage Leave Codes People » Leave » Leave Controls » Leave 
Tables People » Configure » Leave » Leave Codes 

Manage Leave Modify Codes People » Leave » Leave Controls » Leave 
Modifier Codes Not in Costpoint Web 

Payroll 

Payroll Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll Processing Client/Server Web 

Manage Pay Periods People » Payroll » Payroll Controls » Pay 
Periods Not in Costpoint Web 

Update Excess Life Deductions People » Payroll » Payroll Processing » Set 
Excess Life Deductions Not in Costpoint Web 

Update Employee Package Deductions People » Payroll » Payroll Processing » Mass 
Update Employee Package Deductions Not in Costpoint Web 
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Compute Payroll People » Payroll » Payroll Processing » 
Compute Payroll Not in Costpoint Web 

Print Payroll Edit Report People » Payroll » Payroll Processing » Print 
Payroll Edit Report Not in Costpoint Web 

Manage Payroll Records People » Payroll » Payroll Processing » 
Maintain Payroll Edit Table Not in Costpoint Web 

Activate Pending Employee Bank Information People » Payroll » Direct Deposit Processing » 
Activate Pending Employee Bank Info Not in Costpoint Web 

Create ACH Bank File People » Payroll » Direct Deposit Processing » 
Create Direct Deposit File Not in Costpoint Web 

Print Bank ACH File Report People » Payroll » Direct Deposit Processing » 
Print Direct Deposit Edit Rpt Not in Costpoint Web 

Print Employee Bank Information Report People » Payroll » Direct Deposit Processing » 
Print Employee Bank Info Rpt Not in Costpoint Web 

Print Payment Advices People » Payroll » Direct Deposit Processing » 
Print/Reprint Payment Advices Not in Costpoint Web 

Print Paychecks People » Payroll » Payroll Processing » 
Print/Reprint Paychecks Not in Costpoint Web 

Close Pay Period People » Payroll » Payroll Closing » Close Pay 
Period Not in Costpoint Web 

Payroll Closing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll Closing Client/Server Web 



People  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
111 

 

Post Payroll Journal People » Payroll » Payroll Closing » Post 
Payroll Journal Not in Costpoint Web 

Print Certified Payroll Report People » Payroll » Employee Payroll History 
and Reporting » Print Certified Payroll Rpt Not in Costpoint Web 

Create Accounts Payable Vouchers People » Payroll » Payroll Closing » Create A/P 
Vouchers Not in Costpoint Web 

Print Accounts Payable Voucher Status Report People » Payroll » Payroll Closing » A/P 
Voucher Status Report Not in Costpoint Web 

Payroll History 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll History Client/Server Web 

Print Employee Earnings Report People » Payroll » Employee Payroll History 
and Reporting » Print Employee Earnings Rpt Not in Costpoint Web 

Manage Employee Earnings History People » Payroll » Employee Payroll History 
and Reporting » Maintain Employee Earnings Not in Costpoint Web 

U.S. Treasury Savings Bonds 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » U.S. Treasury Savings 
Bonds Client/Server Web 

Manage Savings Bonds Treasury File Data People » Payroll » U.S. Treasury Savings 
Bonds » Savings Bond Info by Taxable Entity Not in Costpoint Web 

Create U.S. Treasury File People » Payroll » U.S. Treasury Savings 
Bonds » Create U.S. Treasury File Not in Costpoint Web 
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View Savings Bond File History People » Payroll » U.S. Treasury Savings 
Bonds » Savings Bond File History Inquiry Not in Costpoint Web 

Tax Reporting 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Tax Reporting Client/Server Web 

Create EFTPS Payroll Tax Deposit File People » Payroll » Tax Reporting » Create 
EFTPS Payroll Tax Deposit File Not in Costpoint Web 

Print Soc Sec and Medicare Reconciliation 
Report 

People » Payroll » Tax Reporting » Print Soc 
Sec and Med Reconciliation Rpt Not in Costpoint Web 

Print Quarterly Federal Payroll Tax Report People » Payroll » Tax Reporting » Print 
Federal Qtrly PR Tax Rpt Not in Costpoint Web 

Create Monthly SUTA Tax File Not in Costpoint Client/Server Not in Costpoint Web 

Create Quarterly EFTPS FUTA Tax File People » Payroll » Tax Reporting » Create 
EFTPS FUTA Qtrly Tax Dep File Not in Costpoint Web 

Print State Withholding Report People » Payroll » Tax Reporting » Print State 
Withholding Rpt Not in Costpoint Web 

Print Local Withholding Report People » Payroll » Tax Reporting » Print Local 
Withholding Rpt Not in Costpoint Web 

Print Quarterly State Unemployment Report People » Payroll » Tax Reporting » Print State 
Qtrly Unemployment Rpt Not in Costpoint Web 

Create Quarterly SUTA Tax File People » Payroll » Tax Reporting » Create 
State Qtrly Unempl Mag Media Not in Costpoint Web 

Print Workers' Compensation Accrual Report People » Payroll » Tax Reporting » Print 
Worker's Comp Accrual Rpt Not in Costpoint Web 
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Year-End Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Year-End Processing Client/Server Web 

Close Payroll Year People » Payroll » Year-End Processing » 
Close Payroll Year Not in Costpoint Web 

Create W-2 Table People » Payroll » Year-End Processing » 
Create W-2 Table Not in Costpoint Web 

Manage W-2s People » Payroll » Year-End Processing » Edit 
W-2s Not in Costpoint Web 

Print W-2s People » Payroll » Year-End Processing » Print 
W-2s Not in Costpoint Web 

Print W-2 Summary Report People » Payroll » Year-End Processing » Print 
W-2 Summary Report Not in Costpoint Web 

Manage Tax File Data People » Payroll » Year-End Processing » 
Maintain Mag Media Reporting Not in Costpoint Web 

Update Tax File Country Code People » Payroll » Utilities » Update Mag 
Media Country Code Not in Costpoint Web 

Create Federal W-2 File People » Payroll » Year-End Processing » 
Create Federal Mag Media Not in Costpoint Web 

Create State W-2 File People » Payroll » Year-End Processing » 
Create State Mag Media Not in Costpoint Web 

 

 



People  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
114 

 

Payroll Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll Utilities Client/Server Web 

Delete Payment Advices from Payroll Edit 
Table 

People » Payroll » Utilities » Clear Payment 
Advice Info from Payroll Edit Not in Costpoint Web 

Delete Paychecks from Payroll Edit Table People » Payroll » Utilities » Clear Paycheck 
Info from Payroll Edit Not in Costpoint Web 

Delete Timesheet Payroll Computed Flags People » Payroll » Utilities » Clear Timesheet 
PR Computed Flags Not in Costpoint Web 

Recompute Taxable Wages People » Payroll » Utilities » Recompute 
Taxable Wages Not in Costpoint Web 

Suspend/Restore Direct Deposits People » Payroll » Direct Deposit Processing » 
Suspend/Restore Direct Deposit Not in Costpoint Web 

Update Dummy Check Numbers People » Payroll » Utilities » Set Dummy PR 
Check Numbers Not in Costpoint Web 

Void/Replace Posted Paychecks People » Payroll » Utilities » Void/Replace 
Posted Paychecks Not in Costpoint Web 

Payroll Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll Interfaces Client/Server Web 

Configure Payroll Tax Export Settings Not in Costpoint Client/Server Not in Costpoint Web 

Export Payroll Taxes Not in Costpoint Client/Server Not in Costpoint Web 
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Payroll Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll Reports/Inquiries Client/Server Web 

Print Deduction Summary Report People » Payroll » Employee Payroll History 
and Reporting » Print Deduction Summary Rpt Not in Costpoint Web 

Print Deduction/Benefit Report by Local 
People » Payroll » Employee Payroll History 
and Reporting » Print Deduction/Benefit Rpt by 
Local 

Not in Costpoint Web 

Print Weekly Fringe Stamp Report 
People » Payroll » Employee Payroll History 
and Reporting » Print Weekly Fringe Stamp 
Report 

Not in Costpoint Web 

View Bank Information People » Payroll » Audit Inquiries » Employee 
Bank Info Inquiry Not in Costpoint Web 

View Basic Information People » Payroll » Audit Inquiries » Basic 
Employee Info Inquiry Not in Costpoint Web 

View Bond Information People » Payroll » Audit Inquiries » Employee 
Bond Info Inquiry Not in Costpoint Web 

View Contributions People » Payroll » Audit Inquiries » Employee 
Contributions Inquiry Not in Costpoint Web 

View Deductions People » Payroll » Audit Inquiries » Employee 
Deductions Inquiry Not in Costpoint Web 

View Employee Earnings People » Payroll » Audit Inquiries » Employee 
Earnings Inquiry Not in Costpoint Web 

View Employee Taxes People » Payroll » Audit Inquiries » Employee 
Taxes Inquiry Not in Costpoint Web 
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View Garnishments People » Payroll » Audit Inquiries » Employee 
Garnishments Inquiry Not in Costpoint Web 

View Payroll Edit Table People » Payroll » Audit Inquiries » Payroll Edit 
Table Inquiry Not in Costpoint Web 

View Salary Information and History People » Payroll » Audit Inquiries » Salary Info 
and History Inquiry Not in Costpoint Web 

Deductions 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Deductions Client/Server Web 

Manage Deduction Modify Codes People » Payroll » Payroll Controls » Setup 
Modify Codes Not in Costpoint Web 

Manage Deductions People » Payroll » Payroll Controls » 
Deductions Not in Costpoint Web 

Manage Deduction Schedules People » Payroll » Payroll Controls » Deduction 
Schedules Not in Costpoint Web 

Garnishments 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Garnishments Client/Server Web 

Manage Garnishment Recipients People » Payroll » Garnishment Control » 
Court Remittance Identification Not in Costpoint Web 

Manage Federal Tax Levy Exemptions People » Payroll » Garnishment Control » 
Federal Tax Levy Exemptions Not in Costpoint Web 
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Manage Minimum Wage People » Payroll » Garnishment Control » State 
Minimum Wage Not in Costpoint Web 

Manage State Support Order Rules Not in Costpoint Client/Server Not in Costpoint Web 

Federal Taxes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Federal Taxes Client/Server Web 

Manage Federal Taxes People » Payroll » Payroll Tax Controls » 
Federal Taxes Not in Costpoint Web 

Manage Federal Tax Tables People » Payroll » Payroll Tax Controls » 
Federal Tax Tables Not in Costpoint Web 

Manage Advance Earned Income Credit Tables People » Payroll » Payroll Tax Controls » 
Advance EIC and Nonresident Alien Tables Not in Costpoint Web 

State Taxes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » State Taxes Client/Server Web 

Manage State Taxes People » Payroll » Payroll Tax Controls » State 
Taxes Not in Costpoint Web 

Manage State Tax Override by Taxable Entity People » Payroll » Payroll Tax Controls » State 
Tax Override by Taxable Entity Not in Costpoint Web 

Manage State Tax Allowances and Credits People » Payroll » Payroll Tax Controls » State 
Tax Allowances and Credits Not in Costpoint Web 
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Manage State Standard Deductions People » Payroll » Payroll Tax Controls » State 
Standard Deductions Not in Costpoint Web 

Manage State Tax Tables People » Payroll » Payroll Tax Controls » State 
Tax Tables Not in Costpoint Web 

Manage Reciprocal State Taxes People » Payroll » Payroll Tax Controls » 
Reciprocal State Taxes Not in Costpoint Web 

Manage SUTA Tax File Data  People » Payroll » Payroll Tax Controls » State 
Mag Media Settings (SUTA) Not in Costpoint Web 

Manage SUTA Quarterly Reporting Data People » Payroll » Payroll Tax Controls » 
SUTA Quarterly Reporting Data Not in Costpoint Web 

Manage SUTA "Weeks Worked" Override People » Payroll » Payroll Tax Controls » State 
Mag Media Weeks Worked Exceptions Not in Costpoint Web 

Local Taxes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Local Taxes Client/Server Web 

Manage Local Taxes People » Payroll » Payroll Tax Controls » Local 
Taxes Not in Costpoint Web 

Manage Local Tax Override by Taxable Entity People » Payroll » Payroll Tax Controls » Local 
Tax Override by Taxable Entity Not in Costpoint Web 

Manage Local Standard Deductions People » Payroll » Payroll Tax Controls » Local 
Standard Deductions Not in Costpoint Web 

Manage Local Tax Tables People » Payroll » Payroll Tax Controls » Local 
Tax Tables Not in Costpoint Web 



People  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
119 

 

Payroll Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Payroll Controls Client/Server Web 

Configure Direct Deposit Settings People » Payroll » Payroll Controls » Direct 
Deposit Setup Not in Costpoint Web 

Configure Paycheck Settings People » Payroll » Payroll Controls » Pay 
Check Setup Not in Costpoint Web 

Configure Payroll Settings People » Payroll » Payroll Controls » Payroll 
Settings Not in Costpoint Web 

Manage Pay Type Taxability People » Payroll » Payroll Controls » Pay Type 
Taxability Not in Costpoint Web 

Manage Bank Routings People » Payroll » Payroll Processing » 
Maintain Direct Deposit Banks Not in Costpoint Web 

Print Bank Routing Report  People » Payroll » Payroll Processing » Print 
Direct Deposit Banks Rpt Not in Costpoint Web 

Manage Workers' Compensation Modify Codes People » Payroll » Payroll Controls » Worker's 
Comp Modify Codes Not in Costpoint Web 

Manage Workers' Compensation State Rates People » Payroll » Payroll Controls » Worker's 
Comp State Rates Not in Costpoint Web 
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Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Payroll » Administrative Utilities Client/Server Web 

Purge Audit File Data People » Payroll » Audit Inquiries » Purge Audit 
File Data Not in Costpoint Web 

Compensation 

Compensation Plans 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Compensation 
Plans Client/Server Web 

Manage Compensation Grades People » Compensation » Compensation 
Controls » Grades Not in Costpoint Web 

Manage Compensation Plans People » Compensation » Compensation Plan 
Setup » Compensation Plans Not in Costpoint Web 

Manage Compensation Plan Defaults People » Compensation » Compensation Plan 
Setup » Compensation Plan Defaults Not in Costpoint Web 

Manage Compensation Plan Salary Ranges People » Compensation » Compensation Plan 
Setup » Compensation Plan Salary Ranges Not in Costpoint Web 
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Job Titles 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Job Titles Client/Server Web 

Manage Summary Job Titles People » Compensation » Job Titles » 
Summary Job Titles Not in Costpoint Web 

Manage Functional Job Titles People » Compensation » Job Titles » 
Functional Job Titles Not in Costpoint Web 

Manage Functional Position Descriptions People » Compensation » Job Titles » 
Functional Position Descriptions Not in Costpoint Web 

Manage Detail Job Titles People » Compensation » Job Titles » Detail 
Job Titles Not in Costpoint Web 

Manage Detail Position Descriptions People » Compensation » Job Titles » Detail 
Position Descriptions Not in Costpoint Web 

Print Job Title Report People » Compensation » Job Titles » Print Job 
Titles Report Not in Costpoint Web 

Print Job Title Position Description Report People » Compensation » Job Titles » Print 
Position Descriptions Not in Costpoint Web 

Performance Reviews 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Performance 
Reviews Client/Server Web 

Manage Performance Ratings People » Compensation » Performance Review 
Setup » Performance Ratings Not in Costpoint Web 
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Manage Performance Ratings by Plan People » Compensation » Compensation Plan 
Setup » Performance Rating Percent by Plan Not in Costpoint Web 

Manage Performance Ratings by Plan and 
Grade 

People » Compensation » Compensation Plan 
Setup » Performance Rating Percent by Plan 
by Grade 

Not in Costpoint Web 

Print Review Rating Statistics Report by 
Manager  

People » Compensation » Performance Review 
Setup » Print Review Statistics by Manager Not in Costpoint Web 

Manage Performance Review Forms People » Compensation » Performance Review 
Setup » Review Form Setup Not in Costpoint Web 

Manage Performance Review Form Defaults People » Compensation » Performance Review 
Setup » Review Form Employee Defaults Not in Costpoint Web 

Print Performance Review Schedule People » Compensation » Performance Review 
Setup » Print Performance Review Schedule Not in Costpoint Web 

Print/Send Performance Review Schedule by 
Manager 

People » Compensation » Performance Review 
Setup » Print/Send Performance Review 
Schedule 

Not in Costpoint Web 

Compensation Budgeting 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Compensation 
Budgeting Client/Server Web 

Manage Compensation Budgets By 
Organization 

People » Compensation » Compensation 
Budgeting » Compensation Budget by 
Organization 

Not in Costpoint Web 

Manage Non-Budgeted Compensation Pay 
Types 

People » Compensation » Compensation 
Budgeting » Non-Budgeted Compensation Pay 
Types 

Not in Costpoint Web 
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Manage Projected Performance Ratings 
People » Compensation » Compensation 
Budgeting » Projected Performance Rating 
Percent 

Not in Costpoint Web 

Print Budgeted/Actual Compensation 
Comparison Report 

People » Compensation » Compensation 
Budgeting » Print Budgeted Vs. Actual 
Compensation Report 

Not in Costpoint Web 

Print Increase Pool Report People » Compensation » Compensation 
Budgeting » Print Increase Pool Report Not in Costpoint Web 

Salary Surveys 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Salary Surveys Client/Server Web 

Manage Survey Companies People » Compensation » Salary Survey » 
Basic Survey Company Info Not in Costpoint Web 

Manage Survey Job Title Mappings People » Compensation » Salary Survey » 
Maintain Survey Job Titles to Func Job Titles Not in Costpoint Web 

Manage Survey Region Mappings People » Compensation » Salary Survey » 
Maintain Survey Regions to Comp Plan Codes Not in Costpoint Web 

Import Salary Survey Data People » Compensation » Salary Survey » 
Upload Salary Survey Data Not in Costpoint Web 

Manage Salary Survey Data People » Compensation » Salary Survey » 
Maintain Salary Survey Data Not in Costpoint Web 

Print Compensation/Survey Comparison Report 
People » Compensation » Salary Survey » 
Print Compensation to Survey Data 
Comparison 

Not in Costpoint Web 
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Compensation Reports 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Compensation 
Reports Client/Server Web 

Print Compa-ratio Report People » Compensation » Compensation 
Reports » Print Compa-ratio Not in Costpoint Web 

Print Employee Compensation Plan Report People » Compensation » Compensation 
Reports » Print Employees by Plan by Grade Not in Costpoint Web 

Compensation Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Compensation » Compensation 
Controls Client/Server Web 

Configure Compensation Settings People » Compensation » Compensation 
Controls » Compensation Settings Not in Costpoint Web 

Personnel 

Personnel Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Personnel » Personnel Information Client/Server Web 

Manage Required Forms List People » Personnel » Personnel Actions » 
Required Forms List Not in Costpoint Web 
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Manage Personnel Actions People » Personnel » Personnel Actions » 
Personnel Actions Not in Costpoint Web 

Print Required Forms Listing by Personnel 
Action 

People » Personnel » Personnel Actions » Print 
Required Forms Listing by Personnel Action Not in Costpoint Web 

Manage Exit Interview Form  People » Personnel » Exit Interview Setup » 
Exit Interview Form Setup Not in Costpoint Web 

Security and Company Property 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Personnel » Security and 
Company Property Client/Server Web 

Manage Federal Security Codes People » Personnel » Security and Company 
Property » Federal Security Identifiers Not in Costpoint Web 

Manage Internal Security Codes People » Personnel » Security and Company 
Property » Internal Security Identifiers Not in Costpoint Web 

Manage Company Documents People » Personnel » Security and Company 
Property » Company Documents Not in Costpoint Web 

Manage Company Property People » Personnel » Security and Company 
Property » Company Property Not in Costpoint Web 

Manage Company Vehicles People » Personnel » Security and Company 
Property » Company Vehicles Not in Costpoint Web 
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Position Requirements 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Personnel » Position 
Requirements Client/Server Web 

Manage Position Requisition Approvers People » Personnel » Personnel Requisitions » 
Requisition Approvers Not in Costpoint Web 

Manage Position Requisition Request People » Personnel » Personnel Requisitions » 
Position Requisition Request Not in Costpoint Web 

Approve Position Requisitions People » Personnel » Personnel Requisitions » 
Approve Position Requisitions Not in Costpoint Web 

Education, Skills and Training 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Personnel » Education, Skills and 
Training Client/Server Web 

Manage Areas of Study Codes People » Personnel » Training » Areas of Study Not in Costpoint Web 

Manage Course Codes People » Personnel » Training » Courses Not in Costpoint Web 

Manage Degree Codes People » Personnel » Training » Degrees Not in Costpoint Web 

Manage Professional Organization Codes People » Personnel » Training » Professional 
Organizations Not in Costpoint Web 

Manage Skill Codes People » Personnel » Training » Skills Not in Costpoint Web 

Manage Skill Level Codes People » Personnel » Training » Skill Levels Not in Costpoint Web 

Manage Training Codes People » Personnel » Training » Training Not in Costpoint Web 
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Manage Training Location Codes People » Personnel » Training » Training 
Location Not in Costpoint Web 

Manage Training Source Codes People » Personnel » Training » Training 
Source Not in Costpoint Web 

Manage Training Program Schedules People » Personnel » Training » Training 
Program Schedules Not in Costpoint Web 

Print Training Program Schedule People » Personnel » Training » Print Program 
Schedules Not in Costpoint Web 

Work-Related Injuries/Illnesses 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Personnel » Work-Related 
Injuries/Illnesses Client/Server Web 

Manage Anatomy Codes People » Personnel » OSHA/Worker’s Comp » 
Anatomy Description Not in Costpoint Web 

Manage Injury/Illness Codes People » Personnel » OSHA/Worker’s Comp » 
Injury/Illness Description Not in Costpoint Web 

Manage Accident Processing Steps People » Personnel » OSHA/Worker’s Comp » 
Accident Processing Steps Not in Costpoint Web 

Manage Workers' Compensation Filing 
Reasons 

People » Personnel » OSHA/Worker’s Comp » 
Worker's Comp Filing Reasons Not in Costpoint Web 

Manage Accident Information People » Personnel » OSHA/Worker’s Comp » 
Accident Info Not in Costpoint Web 

Print Worker's Compensation Incident Report People » Personnel » OSHA/Worker’s Comp » 
Print Worker's Comp Incident Report Not in Costpoint Web 
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Manage Accident Case History People » Personnel » OSHA/Worker’s Comp » 
Accident Case History Not in Costpoint Web 

Print Accident Case History Report People » Personnel » OSHA/Worker’s Comp » 
Print Accident Case History Report Not in Costpoint Web 

Print OSHA Report People » Personnel » OSHA/Worker’s Comp » 
Print OSHA Report Not in Costpoint Web 

Print Wage History Report People » Personnel » OSHA/Worker’s Comp » 
Print Wage History Report Not in Costpoint Web 

Personnel Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Personnel » Personnel Controls Client/Server Web 

Configure Personnel Settings People » Personnel » Personnel Controls » 
Personnel Settings Not in Costpoint Web 

Manage Award Codes People » Personnel » Personnel Controls » 
Award Codes Not in Costpoint Web 

Manage Drug Test Codes People » Personnel » Personnel Controls » 
Drug Tests Not in Costpoint Web 

Manage I-9 Codes People » Personnel » Personnel Controls » I-9 
Codes Not in Costpoint Web 

Manage Managers/HR Reps by HR 
Organization 

People » Personnel » Personnel Controls » 
Managers/HR Reps by HR Org Not in Costpoint Web 

Manage Managers/HR Reps by Organization People » Personnel » Personnel Controls » 
Managers/HR Reps by Org Not in Costpoint Web 
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Manage Medical Surveillance Codes People » Personnel » Personnel Controls » 
Medical Surveillance Codes Not in Costpoint Web 

Affirmative Action 

Affirmative Action Plan Information 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Affirmative Action » Affirmative 
Action Plan Information Client/Server Web 

Manage Affirmative Action Plans People » Affirmative Action » Affirmative Action 
Plan Setup » Affirmative Action Plans Not in Costpoint Web 

Manage Affirmative Action Census Data People » Affirmative Action » Affirmative Action 
Plan Setup » Census Data Not in Costpoint Web 

Manage Applicant Data People » Affirmative Action » Applicant 
Information » Applicant Data Not in Costpoint Web 

Affirmative Action Reports 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Affirmative Action » Affirmative 
Action Reports Client/Server Web 

Print Employee Roster  People » Affirmative Action » Employee 
Reports » Employee Roster Not in Costpoint Web 

Print New Hire Analysis Report People » Affirmative Action » Employee 
Reports » New Hire Analysis Not in Costpoint Web 
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Print Personnel Action Analysis Report People » Affirmative Action » Employee 
Reports » Personnel Action Analysis Not in Costpoint Web 

Print Promotion Report People » Affirmative Action » Employee 
Reports » Promotion Report Not in Costpoint Web 

Print Termination Report People » Affirmative Action » Employee 
Reports » Termination Report Not in Costpoint Web 

Print Training Report People » Affirmative Action » Employee 
Reports » Training Report Not in Costpoint Web 

Print Transfer Report People » Affirmative Action » Employee 
Reports » Transfer Report Not in Costpoint Web 

Print Availability/Utilization Report People » Affirmative Action » Affirmative Action 
Planning » Availability/Utilization Report Not in Costpoint Web 

Print EEO-1 Report People » Affirmative Action » Affirmative Action 
Planning » EEO-1 Report Not in Costpoint Web 

Print Job Group Analysis Report People » Affirmative Action » Affirmative Action 
Planning » Job Group Analysis Report Not in Costpoint Web 

Print Lines of Progression Report People » Affirmative Action » Affirmative Action 
Planning » Lines of Progression Not in Costpoint Web 

Print Organizational Profile Report People » Affirmative Action » Affirmative Action 
Planning » Organizational Profile Not in Costpoint Web 

Print VETS-100 Report People » Affirmative Action » Affirmative Action 
Planning » Print VETS-100 Report Not in Costpoint Web 

Print Workforce Analysis Report People » Affirmative Action » Affirmative Action 
Planning » Workforce Analysis Report Not in Costpoint Web 
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Affirmative Action Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Affirmative Action » Affirmative 
Action Controls Client/Server Web 

Configure Affirmative Action Settings People » Affirmative Action » Affirmative Action 
Controls » Affirmative Action Settings Not in Costpoint Web 

Manage Functional Job Title Hierarchy People » Affirmative Action » Affirmative Action 
Controls » Feeder Positions Not in Costpoint Web 

Manage Job Groups People » Affirmative Action » Affirmative Action 
Controls » Job Groups Not in Costpoint Web 

Deferred Compensation Admin 

Deferred Compensation Plan Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Deferred Compensation Admin » 
Deferred Compensation Plan Controls Client/Server Web 

Manage Deferred Compensation Plans People » Deferred Compensation Admin » Plan 
Controls » Plan Setup Not in Costpoint Web 

Manage Deferred Compensation Deductions People » Deferred Compensation Admin » Plan 
Controls » Deduction Code Assignment Not in Costpoint Web 
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Benefits 

Benefit Entry and Creation 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Benefits » Benefit Entry and 
Creation Client/Server Web 

Manage Benefit Plans People » Benefits » Benefit Information » 
Benefit Plan Setup Not in Costpoint Web 

Manage Benefit Packages People » Benefits » Benefit Information » 
Benefit Packages Not in Costpoint Web 

Manage Benefit Package Defaults People » Benefits » Benefit Information » 
Benefit Package Defaults Not in Costpoint Web 

Manage Dependent Care FSA Plan Year People » Benefits » Benefit Information » 
Dependent Care FSA Setup Not in Costpoint Web 

Manage Medical Care FSA Plan Year People » Benefits » Benefit Information » 
Medical Care FSA Setup Not in Costpoint Web 

Benefit Reports 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Benefits » Benefit Reports Client/Server Web 

Print Census Report People » Benefits » Reports » Print Census 
Report Not in Costpoint Web 

Print Coverage Report People » Benefits » Reports » Print Coverage 
Report Not in Costpoint Web 
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Print Employee FSA Report People » Benefits » Reports » Print Employee 
FSA Report Not in Costpoint Web 

Print Life Insurance Beneficiaries Report People » Benefits » Reports » Print Life 
Insurance Beneficiaries Report Not in Costpoint Web 

Print Medical Dependents Report People » Benefits » Reports » Print Medical 
Dependents Report Not in Costpoint Web 

Benefit Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

People » Benefits » Benefit Controls Client/Server Web 

Configure Benefit Settings People » Benefits » Benefit Controls » Benefit 
Settings Not in Costpoint Web 

Manage Benefit Providers People » Benefits » Benefit Controls » 
Providers Not in Costpoint Web 

Manage Benefit Types  People » Benefits » Benefit Controls » Benefit 
Types Not in Costpoint Web 

Manage Coverage Options People » Benefits » Benefit Controls » 
Coverage Options Not in Costpoint Web 

Manage Coverage Amounts by Age People » Benefits » Premium and Coverage 
Tables » Coverage Amounts by Age Not in Costpoint Web 

Manage Coverage Amounts by Salary People » Benefits » Premium and Coverage 
Tables » Coverage Amounts by Salary Not in Costpoint Web 

Manage Premium Rates by Age People » Benefits » Premium and Coverage 
Tables » Premium Rates by Age Not in Costpoint Web 
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Manage Premiums by Salary People » Benefits » Premium and Coverage 
Tables » Premium Amounts by Salary Not in Costpoint Web 
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Materials 

Product Definition 

Items 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Items Client/Server Web 

Manage Parts 

Materials » Product Definition » Part Master » 
Maintain Parts 

Materials » Product Definition » Part Master » 
Basic Part Data 

Materials » Maintain » Items » Parts User 
Flow 

Manage Services Materials » Product Definition » Services Materials » Maintain » Items » Services 
User Flow 

Manage Goods Materials » Product Definition » Goods Materials » Maintain » Items » Goods User 
Flow 

Assign Vendors to Items Materials » Product Definition » Assign 
Vendors 

Materials » Maintain » Items » Item Vendor 
Assignment 

Manage Alternate Parts Materials » Product Definition » Part Master » 
Alternate Parts 

Materials » Maintain » Items » Alternate 
Parts 

Manage Part Project Data Materials » Product Definition » Part Master » 
Part Project Data 

Materials » Maintain » Items » Part Project 
Data 

Manage Item Costs Materials » Product Definition » Maintain Item 
Cost Materials » Maintain » Items » Item Costs 

Manage Project Item Costs Materials » Product Definition » Maintain 
Project Item Cost 

Materials » Maintain » Items » Project Item 
Costs 
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Provisional Parts 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Provisional 
Parts Client/Server Web 

Manage Provisional Parts Materials » Product Definition » Provisional 
Parts » Maintain Provisional Parts Not in Costpoint Web 

Convert Provisional Parts to Standard Parts 
Materials » Product Definition » Provisional 
Parts » Convert Provisional Parts to Standard 
Parts 

Not in Costpoint Web 

Documents 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Documents Client/Server Web 

Manage Documents Materials » Product Definition » Documents » 
Maintain Documents Not in Costpoint Web 

Release Documents Materials » Product Definition » Documents » 
Release Documents Not in Costpoint Web 

Product Billing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Product 
Billing Client/Server Web 

Manage Warranty Information Materials » Product Definition » Product Billing 
» Set Up Warranty Info Not in Costpoint Web 



Materials  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
137 

 

Manage Item Billings Materials » Product Definition » Product Billing 
» Set Up Item Billings Materials » Maintain » Items » Item Billings 

Manage Price Catalogs Materials » Product Definition » Product Billing 
» Set Up Price Catalogs 

Materials » Maintain » Price  Catalogs » 
Price Catalogs 

Manage Product Price Catalogs Materials » Product Definition » Product Billing 
» Set Up Product Price Catalogs 

Materials » Maintain » Price  Catalogs » 
Price Catalogs Items 

Manage Product Options Materials » Product Definition » Product Billing 
» Set Up Product Options Not in Costpoint Web 

Product Definition Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Product 
Definition Reports/Inquiries Client/Server Web 

Print Assigned Vendor Report Materials » Product Definition » Reports » Print 
Assigned Vendor Report Not in Costpoint Web 

Print Item Catalog Report Materials » Product Definition » Reports » Print 
Item Catalog Not in Costpoint Web 

Print Item Cost Report Materials » Product Definition » Reports » Print 
Item Cost Info Not in Costpoint Web 

Print Item Master Audit Report Materials » Product Definition » Reports » Print 
Master File Audit Report Not in Costpoint Web 

Print Item Master Listing Report Materials » Product Definition » Reports » Print 
Master File Listing Not in Costpoint Web 

Print Item Text Report Materials » Product Definition » Reports » Print 
Item Text Report Not in Costpoint Web 
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Print Manufacturer Catalog Report Materials » Product Definition » Reports » Print 
Manufacturer Catalog Not in Costpoint Web 

Print Part Planning Exception  Report Materials » Product Definition » Reports » Print 
Part Planning Exception Report Not in Costpoint Web 

Print Part Project Report Materials » Product Definition » Reports » Print 
Part Project Info Not in Costpoint Web 

Print Substitute Part Report Materials » Product Definition » Reports » Print 
Substitute Part Report Not in Costpoint Web 

View Items Materials » Product Definition » Inquiries » Item 
Inquiry Materials » Review » Items » Item Inquiry 

View Alternate Parts Materials » Product Definition » Inquiries » 
Alternate Part Inquiry 

Materials » Review » Items » Alternate Part 
Inquiry 

Product Definition Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Product 
Definition Interfaces Client/Server Web 

Import Items Others » Product Interfaces » Preprocessors » 
Item Preprocessor Not in Costpoint Web 
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Product Definition Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Product 
Definition Controls Client/Server Web 

Configure Product Definition Settings Materials » Product Definition » Product 
Definition Controls » Product Definition Settings 

Administration » Configure » Materials » 
Product Definition Settings 

Manage Security Groups Not in Client/Server Administration » Configure » Materials » 
Security Groups 

Manage Commodity Codes Materials » Product Definition » Product 
Definition Controls » Commodity Codes 

Materials » Configure » Items » Commodity 
Codes 

Manage Industry Classifications Materials » Product Definition » Product 
Definition Controls » Industry Classifications Not in Costpoint Web 

Manage Item User-Defined Labels Materials » Product Definition » Product 
Definition Controls » Item User-Defined Labels Not in Costpoint Web 

Manage Manufacturers Materials » Product Definition » Product 
Definition Controls » Manufacturers 

Materials » Maintain » Manufacturers » 
Manufacturers 

Manage Part Preference Types  Materials » Product Definition » Product 
Definition Controls » Part Preference Types Not in Costpoint Web 

Manage Product Classifications Materials » Product Definition » Product 
Definition Controls » Product Classifications 

Materials » Configure » Items » Product 
Classifications 

Manage Product Types Materials » Product Definition » Product 
Definition Controls » Product Types Not in Costpoint Web 

Manage Provisional Part Types  Materials » Product Definition » Product 
Definition Controls » Provisional Part Types Not in Costpoint Web 
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Manage Standard Text  Materials » Product Definition » Product 
Definition Controls » Standard Text 

Materials » Configure » Standard Text » 
Standard Text 

Manage Units of Measure Materials » Product Definition » Product 
Definition Controls » Units of Measure Not in Costpoint Web 

Manage Document Media Materials » Product Definition » Product 
Definition Controls » Document Media Not in Costpoint Web 

Manage Document Sizes Materials » Product Definition » Product 
Definition Controls » Document Sizes Not in Costpoint Web 

Manage Document Types Materials » Product Definition » Product 
Definition Controls » Document Types Not in Costpoint Web 

Manage Document Maintenance Groups Not in Costpoint Client/Server Not in Costpoint Web 

Pard Data Security 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Product Definition » Product 
Data Security Client/Server Web 

Manage United States Munitions List Not in Costpoint Client/Server Not in Costpoint Web 

Manage Export Control Classification Numbers Not in Costpoint Client/Server Not in Costpoint Web 

Manage Security User-Defined Labels Not in Costpoint Client/Server Not in Costpoint Web 

Manage License/Agreement Types Not in Costpoint Client/Server Not in Costpoint Web 

Manage License/Agreements Not in Costpoint Client/Server Not in Costpoint Web 

Manage Security Groups Not in Costpoint Client/Server Not in Costpoint Web 
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View Part Data Security Audit Log Not in Costpoint Client/Server Not in Costpoint Web 

Purge Part Security Log Not in Costpoint Client/Server Not in Costpoint Web 

Bills of Material 

Bills of Material 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Bills of 
Material Client/Server Web 

Manage Manufacturing Bills of Material Materials » Bills of Material » Manufacturing 
Bills of Material » Maintain MBOM Not in Costpoint Web 

Release Manufacturing Bills of Material Materials » Bills of Material » Manufacturing 
Bills of Material » Release MBOM Not in Costpoint Web 

Release Multiple Manufacturing Bills of Material 
Materials » Bills of Material » Manufacturing 
Bills of Material » Release Multiple 
Manufacturing BOMs 

Not in Costpoint Web 

Manage Engineering Bills of Material Materials » Bills of Material » Engineering Bills 
of Material » Maintain EBOM Not in Costpoint Web 

Release Engineering Bills of Material Materials » Bills of Material » Engineering Bills 
of Material » Release EBOM Not in Costpoint Web 

Release Multiple Engineering Bills of Material 
Materials » Bills of Material » Engineering Bills 
of Material » Release Multiple Engineering 
BOMs 

Not in Costpoint Web 

Manage End Item Configurations 
Materials » Bills of Material » Manufacturing 
Bills of Material » Maintain End Item 
Configurations 

Not in Costpoint Web 
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Copy Bills of Material  Materials » Bills of Material » Documents » 
Copy Bills of Material Not in Costpoint Web 

Apply Mass Component Changes to Bills of 
Material 

Materials » Bills of Material » Documents » 
Perform Mass Component Change Not in Costpoint Web 

Compute Costed Bills of Material Materials » Bills of Material » Reports » Print 
Costed BOM Report Not in Costpoint Web 

Documents 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Documents Client/Server Web 

Manage Documents Materials » Bills of Material » Documents » 
Maintain Documents Not in Costpoint Web 

Release Documents Materials » Bills of Material » Documents » 
Release Documents Not in Costpoint Web 

Work Centers 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Work Centers Client/Server Web 

Manage Work Centers Materials » Bills of Material » Bills of Material 
Controls » Work Centers Not in Costpoint Web 
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Bills of Material Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Bills of 
Material Reports/Inquiries Client/Server Web 

Print Bills of Material Where-Used Report Materials » Bills of Material » Reports » Print 
Where-Used Report Not in Costpoint Web 

Print Indented Bills of Material Report Materials » Bills of Material » Reports » Print 
Indented BOM Report Not in Costpoint Web 

Print Summarized Bills of Material Report Materials » Bills of Material » Reports » Print 
Summarized BOM Report Not in Costpoint Web 

Print Summarized Bills of Material Comparison 
Report 

Materials » Bills of Material » Reports » Print 
Compare Summarized BOM Report Not in Costpoint Web 

View Bills of Material Materials » Bills of Material » Inquiries » BOM 
Inquiry Not in Costpoint Web 

View Where-Used Bills of Material Materials » Bills of Material » Inquiries » 
Where-Used Inquiry Not in Costpoint Web 

Bills of Material Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Bills of 
Material Utilities Client/Server Web 

Update Low-Level Codes Materials » Bills of Material » Utilities » Update 
Low-Level Codes Not in Costpoint Web 
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Convert  Reference Designators from Short to 
Long 

Materials » Bills of Material » Utilities » 
Miscellaneous Toolkits » Convert reference 
designators from standard to extended length 
format* 

Not in Costpoint Web 

Convert  Reference Designators from Long to 
Short 

Materials » Bills of Material » Utilities » 
Miscellaneous Toolkits » Convert reference 
designators from extended length  to standard 
format* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 

Bills of Material Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Bills of 
Material Interfaces Client/Server Web 

Import Bills of Material Others » Product Interfaces » Preprocessors » 
Bills of Materials Preprocessor Not in Costpoint Web 

Bills of Material Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Bills of Material » Bills of 
Material Controls Client/Server Web 

Configure Bills of Material Settings Materials » Bills of Material » Bills of Material 
Controls » BOM Settings Not in Costpoint Web 

Manage Configuration Identifiers Materials » Bills of Material » Bills of Material 
Controls » Configuration Identifiers Not in Costpoint Web 
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Manage Document Maintenance Groups Materials » Bills of Material » Bills of Material 
Controls » Document Maintenance Groups Not in Costpoint Web 

Manage Document Media Materials » Bills of Material » Bills of Material 
Controls » Document Media Not in Costpoint Web 

Manage Document Sizes Materials » Bills of Material » Bills of Material 
Controls » Document Sizes Not in Costpoint Web 

Manage Document Types Materials » Bills of Material » Bills of Material 
Controls » Document Types Not in Costpoint Web 

Routings 

Work Centers 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Routings » Work Centers Client/Server Web 

Manage Work Centers Materials » Routings » Maintain Work Centers Not in Costpoint Web 

Operations 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Routings » Operations Client/Server Web 

Manage Labor Operations Materials » Routings » Operations » Maintain 
Labor Operations Not in Costpoint Web 

Manage Subcontractor Operations Materials » Routings » Operations » Maintain 
Subcontractor Operations Not in Costpoint Web 
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Routings 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Routings » Routings Client/Server Web 

Manage Routings Materials » Routings » Routings » Maintain 
Routings 

Materials » Maintain » Routings » Maintain 
Routings 

Release Routings Materials » Routings » Routings » Release 
Routings Not in Costpoint Web 

Routings Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Routings » Routings 
Reports/Inquiries Client/Server Web 

Print Routings Report Materials » Routings » Reports » Print Routings Not in Costpoint Web 

View Routings Materials » Routings » Inquiries » Routing 
Inquiry Not in Costpoint Web 

Routings Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Routings » Routings Controls Client/Server Web 

Configure Routing Settings Materials » Routings » Routings Controls » 
Routings Settings Not in Costpoint Web 

Manage Work Center Types Materials » Routings » Routings Controls » 
Work Center Types Not in Costpoint Web 
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Manage Operation Types Materials » Routings » Routings Controls » 
Operation Types Not in Costpoint Web 

Manage Process Types Materials » Routings » Routings Controls » 
Process Types Not in Costpoint Web 

Manage Resource Types Materials » Routings » Routings Controls » 
Resource Types Not in Costpoint Web 

Manage Key Resources Materials » Routings » Routings Controls » Key 
Resources Not in Costpoint Web 

Manage Labor Classifications Materials » Routings » Routings Controls » 
Labor Classifications Not in Costpoint Web 

Manage Maintenance Types  Materials » Routings » Routings Controls » 
Maintenance Types Not in Costpoint Web 

Manage Equipment Materials » Routings » Routings Controls »  
Equipment Not in Costpoint Web 

Engineering Change Notices 

Engineering Change Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Engineering Change Notices » 
Engineering Change Processing Client/Server Web 

Manage Engineering Change Notices Materials » Engineering Change Notices » 
Engineering Change Notices » Maintain ECNs Not in Costpoint Web 

Approve Engineering Change Notices  Materials » Engineering Change Notices » 
Engineering Change Notices » Approve ECNs Not in Costpoint Web 
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Update Approved Engineering Change Notices  
Materials » Engineering Change Notices » 
Engineering Change Notices » Maintain 
Approved ECNs 

Not in Costpoint Web 

Apply Engineering Change Notices 
Materials » Engineering Change Notices » 
Engineering Change Notices » Implement ECN 
Changes 

Not in Costpoint Web 

Print Engineering Change Notice Travelers  
Materials » Engineering Change Notices » 
Engineering Change Notices » Print ECN 
Traveler 

Not in Costpoint Web 

Engineering Change Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Engineering Change Notices » 
Engineering Change Reports/Inquiries Client/Server Web 

Print Engineering Change Notice Impact Report Materials » Engineering Change Notices » ECN 
Reports » Print ECN Impact Report Not in Costpoint Web 

View Engineering Change Notice Status Materials » Engineering Change Notices » ECN 
Inquiries » ECN Status Inquiry Not in Costpoint Web 

View Items Materials » Engineering Change Notices » ECN 
Inquiries » Item Inquiry Materials » Review » Items » Item Inquiry 
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Engineering Change Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Engineering Change Notices » 
Engineering Change Controls Client/Server Web 

Configure Engineering Change Notice Settings Materials » Engineering Change Notices » ECN 
Controls » EC Settings Not in Costpoint Web 

Configure Engineering Change Report Print 
Options 

Materials » Engineering Change Notices » ECN 
Controls » EC Report Print Options Not in Costpoint Web 

Configure Engineering Change User-Defined 
Labels 

Materials » Engineering Change Notices » ECN 
Controls » EC User-Defined Labels Not in Costpoint Web 

Manage Engineering Change Reasons Materials » Engineering Change Notices » ECN 
Controls » EC Reasons Not in Costpoint Web 

Manage Engineering Change Priorities Materials » Engineering Change Notices » ECN 
Controls » EC Priorities Not in Costpoint Web 

Manage Engineering Change Rejection 
Reason Codes 

Materials » Engineering Change Notices » ECN 
Controls » EC Rejection Reason Codes Not in Costpoint Web 

Manage EC Impacted Functional Groups Materials » Engineering Change Notices » ECN 
Controls » EC Impacted Functional Groups Not in Costpoint Web 

Manage Engineering Change Types Materials » Engineering Change Notices » ECN 
Controls » EC Types Not in Costpoint Web 

Manage Engineering Change Approval Titles Materials » Engineering Change Notices » ECN 
Controls » EC Approval Titles Not in Costpoint Web 

Manage Engineering Change Project 
Approvers 

Materials » Engineering Change Notices » ECN 
Controls » EC Project Approvers Not in Costpoint Web 
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Manage Engineering Change Approval 
Processes 

Materials » Engineering Change Notices » ECN 
Controls » EC Approval Processes Not in Costpoint Web 

Procurement Planning 

Purchase Requisitions 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Procurement Planning » 
Purchase Requisitions Client/Server Web 

Manage Simple Purchase Requisitions Not in Costpoint Client/Server Not in Costpoint Web 

Manage Purchase Requisitions Materials » Procurement Planning » 
Requisitions » Enter Requisitions 

Materials » Transactions » Purchase 
Requisitions » Enter Purchase Requisitions 

Approve Purchase Requisitions Materials » Procurement Planning » 
Requisitions » Approve Purchase Requisitions 

Materials » Transactions » Purchase 
Requisitions » Approve Purchase 
Requisitions 

Approve Purchase Requisition Lines 
Materials » Procurement Planning » 
Requisitions » Approve Purchase Requisition 
Lines 

Materials » Transactions » Purchase 
Requisitions » Approve Purchase 
Requisition Lines 

Assign Purchase Requisitions to Buyers Materials » Procurement Planning » 
Requisitions » Assign Requisitions to Buyers 

Materials » Transactions » Purchase 
Requisitions » Assign Purchase 
Requisitions to Buyers 

Assign Purchase Requisition Lines to Buyers 
Materials » Procurement Planning » 
Requisitions » Assign Requisition Lines to 
Buyers 

Materials » Transactions » Purchase 
Requisitions » Assign Purchase Requisition 
Lines to Buyers 

Apply PO Info to Purchase Requisitions Materials » Procurement Planning » 
Requisitions » Requisition Processing 

Materials » Transactions » Purchase 
Requisitions » Process Purchase 
Requisitions 
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Apply PO Info to Purchase Requisitions by Line Materials » Procurement Planning » 
Requisitions » Requisition Processing by Line 

Materials » Transactions » Purchase 
Requisitions » Process Purchase 
Requisitions by Line 

Print Purchase Requisitions Materials » Procurement Planning » 
Requisitions » Print Requisitions 

Materials » Transactions » Purchase 
Requisitions » Print Purchase Requisitions 

Manage Purchase Order Header Information Materials » Procurement Planning » 
Requisitions » Set Up PO Header Info Not in Costpoint Web 

Create Purchase Orders Materials » Procurement Planning » 
Requisitions » Create Purchase Orders 

Materials » Transactions » Purchase 
Requisitions » Create Purchase Orders 

Vendor Quotes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Procurement Planning » Vendor 
Quotes Client/Server Web 

Manage Request for Quotes By Item Materials » Procurement Planning » Request 
for Quotes » Enter RFQs by Item 

Materials » Transactions » Vendor Quotes » 
Enter RFQs by Item 

Manage Request for Quotes By Vendor Materials » Procurement Planning » Request 
for Quotes » Enter RFQs by Vendor 

Materials » Transactions » Vendor Quotes » 
Enter RFQs by Vendor 

Print Request for Quotes Materials » Procurement Planning » Request 
for Quotes » Print RFQs 

Materials » Transactions » Vendor Quotes » 
Print RFQs 

Manage Vendor Quotes By Item Materials » Procurement Planning » Request 
for Quotes » Enter Quotes by Item 

Materials » Transactions » Vendor Quotes » 
Enter Quotes by Item 

Manage Vendor Quotes By Vendor Materials » Procurement Planning » Request 
for Quotes » Enter Quotes by Vendor 

Materials » Transactions » Vendor Quotes » 
Enter Quotes by Vendor 

View Vendor Quotes Materials » Procurement Planning » Inquiries » 
Vendor Quote Inquiry Not in Costpoint Web 



Materials  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
152 

 

Vendors 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Procurement Planning » 
Vendors Client/Server Web 

Manage Vendors Materials » Procurement Planning » Vendor 
Info » Maintain Vendors 

Materials » Maintain » Vendors » Vendor 
User Flow 

Compute Vendor Performance Materials » Procurement Planning » 
Performance » Calculate Vendor Performance 

Materials » Process » Vendors » Calculate 
Vendor Performance 

View Vendor Performance Materials » Procurement Planning » 
Performance » Vendor Performance Inquiry 

Materials » Review » Vendors » Vendor 
Performance Inquiry 

Print Vendor List Materials » Procurement Planning » Vendor 
Info » Print Vendor Listing Not in Costpoint Web 

Print Vendor Information Report Materials » Procurement Planning » Vendor 
Info » Print Vendor Information Reports Not in Costpoint Web 

Procurement Planning Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Procurement Planning » 
Procurement Planning Reports/Inquiries Client/Server Web 

Print Purchase Requisition Approval Status 
Report 

Materials » Procurement Planning » Reports » 
Print Requisition Approval Status Report Not in Costpoint Web 

Print Purchase Requisition Commitment Report Materials » Procurement Planning » Reports » 
Print Requisition Commitments Detail Not in Costpoint Web 

View Item Purchasing Information Materials » Procurement Planning » Inquiries » 
Item Purchasing Information Inquiry 

Materials » Review » Purchase Orders » 
Item Purchasing Information Inquiry 
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View Items Materials » Procurement Planning » Inquiries » 
Item Inquiry Materials » Review » Items » Item Inquiry 

View Purchase Requisition Status Materials » Procurement Planning » Inquiries » 
Requisition Status Inquiry 

Materials » Review » Purchase Requisitions 
» Purchase Requisition Status Inquiry 

Procurement Planning Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Procurement Planning » 
Procurement Planning Interfaces Client/Server Web 

Import Purchase Requisitions Others » Product Interfaces » Preprocessors » 
Purchase Requisition Preprocessor Not in Costpoint Web 

Import Vendor Quotes Others » Product Interfaces » Preprocessors » 
Vendor Quote Preprocessor Not in Costpoint Web 

Procurement Planning Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Procurement Planning » 
Procurement Planning Controls Client/Server Web 

Configure Purchase Requisition Settings Materials » Procurement Planning » Requisition 
Controls » Requisition Settings 

Administration » Configure » Materials » 
Requisition Settings 

Configure Purchase Requisition Print Options Materials » Procurement Planning » Requisition 
Controls » Requisition Print Options 

Administration » Configure » Materials » 
Requisition Print Options 

Configure Vendor Quote Settings Materials » Procurement Planning » Requisition 
Controls » RFQ Settings 

Administration » Configure » Materials » 
RFQ Settings 
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Manage Procurement Types Materials » Procurement Planning » Requisition 
Controls » Procurement Types 

Materials » Configure » Purchasing » 
Procurement Types 

Manage Purchase Requisition Approval Titles Materials » Procurement Planning » Requisition 
Controls » Requisition Approval Titles 

Materials » Configure » Purchase 
Requisitions » Purchase Requisition 
Approval Titles 

Manage Purchase Requisition Approval 
Processes 

Materials » Procurement Planning » Requisition 
Controls » Requisition Approval Processes 

Materials » Configure » Purchase 
Requisitions » Purchase Requisition 
Approval Processes 

Manage Purchase Requisition Cost Types Materials » Procurement Planning » Requisition 
Controls » Requisition Cost Types Not in Costpoint Web 

Manage Purchase Requisition Rejection 
Reasons 

Materials » Procurement Planning » Requisition 
Controls » Requisition Rejection Reasons 

Materials » Configure » Purchase 
Requisitions » Purchase Requisition 
Rejection Reasons 

Manage Purchase Requisition Types Not in Costpoint Client/Server Materials » Configure » Purchase 
Requisitions » Purchase Requisition Types  

Manage Vendor Quote Types Materials » Procurement Planning » Requisition 
Controls » Quote Types Not in Costpoint Web 

Manage Vendor Quote Award Reasons Materials » Procurement Planning » Requisition 
Controls » Vendor Quote Award Reasons 

Materials » Configure » Purchasing » 
Vendor Quote Award Reasons 
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Purchasing 

Purchase Orders 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Purchase Orders Client/Server Web 

Manage Purchase Orders Materials » Purchasing » Purchase Orders » 
Enter POs 

Materials » Transactions » Purchase Orders 
» Enter Purchase Orders 

Approve Pending Purchase Orders Materials » Purchasing » Purchase Orders » 
Open Pending POs 

Materials » Transactions » Purchase Orders 
» Open Pending POs 

Create Blanket Purchase Order Releases Materials » Purchasing » Purchase Orders » 
Create Blanket Releases 

Materials » Transactions » Purchase Orders 
» Create Blanket PO Releases 

Expedite Purchase Orders Materials » Purchasing » Purchase Orders » 
Expedite Purchase Orders 

Materials » Transactions » Purchase Orders 
» Expedite Purchase Orders 

Manage Purchase Order Expediting Notes Materials » Purchasing » Purchase Orders » 
Maintain PO Expediting Notes 

Materials » Transactions » Purchase Orders 
» Enter PO Expediting Notes 

Create Purchase Order Change Orders Materials » Purchasing » Purchase Orders » 
Create PO Change Orders 

Materials » Transactions » Purchase Orders 
» Create PO Change Orders 

Print Purchase Orders Materials » Purchasing » Purchase Orders » 
Print POs 

Materials » Transactions » Purchase Orders 
» Print Purchase Orders 

Print Purchase Order Change Orders Materials » Purchasing » Purchase Orders » 
Print Purchase Change Orders 

Materials » Transactions » Purchase Orders 
» Print PO Change Orders 

Update Subcontract Purchase Order Status Materials » Purchasing » Purchase Orders » 
Update Subcontract PO Status 

Materials » Transactions » Purchase Orders 
» Update Subcontract PO Status 
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Vendors 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Vendors Client/Server Web 

Manage Vendors Materials » Purchasing » Vendor Info » 
Maintain Vendors 

Materials » Maintain » Vendors » Vendor 
User Flow 

Print Vendor List Materials » Purchasing » Vendor Info » Print 
Vendor Listing Not in Costpoint Web 

Print Vendor Information Reports Materials » Purchasing » Vendor Info » Print 
Vendor Information Reports Not in Costpoint Web 

Purchasing Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Purchasing 
Reports/Inquiries Client/Server Web 

Compute/Print Purchasing Commitments Materials » Purchasing » Reports » Compute 
and Print Commitments 

Materials » Process » Purchasing 
Commitments » Compute and Print 
Purchasing Commitments 

Print Purchase Order Activity Report Materials » Purchasing » Reports » Print PO 
Activity Report 

Materials » Review » Purchase Orders » PO 
Activity Report 

Print Purchase Order Expediting Report Materials » Purchasing » Reports » Print PO 
Expediting Report 

Materials » Review » Purchase Orders » PO 
Expediting Report 

Print Purchase Order Register Report Materials » Purchasing » Reports » Print PO 
Register 

Materials » Review » Purchase Orders » PO 
Register Report 

View Item Purchasing Information Materials » Purchasing » Inquiries » Item 
Purchasing Information Inquiry 

Materials » Review » Purchase Orders » 
Item Purchasing Information Inquiry 
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View Items Materials » Purchasing » Inquiries » Item 
Inquiry Materials » Review » Items » Item Inquiry 

View Purchase Order Change Orders Materials » Purchasing » Inquiries » PO 
Change Order Inquiry 

Materials » Review » Purchase Orders » PO 
Change Order Inquiry 

View Purchase Order Commitments Summary Materials » Purchasing » Inquiries » PO 
Commitments Summary Inquiry 

Materials » Review » Purchase Orders » PO 
Commitments Summary Inquiry 

View Purchase Order Status Materials » Purchasing » Inquiries » PO Status 
Inquiry 

Materials » Review » Purchase Orders » PO 
Status Inquiry 

View Vendor Performance Materials » Procurement Planning » 
Performance » Vendor Performance Inquiry 

Materials » Review » Vendors » Vendor 
Performance Inquiry 

View Vendor Quotes Materials » Purchasing » Inquiries » Vendor 
Quote Inquiry Not in Costpoint Web 

Purchasing Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Purchasing 
Utilities Client/Server Web 

Archive Purchase Orders Materials » Purchasing » Utilities » Archive 
Purchase Orders Not in Costpoint Web 

Reconcile Purchase Orders Materials » Purchasing » Utilities » Reconcile 
Purchase Orders Not in Costpoint Web 
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Purchasing Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Purchasing 
Interfaces Client/Server Web 

Import Purchase Orders Others » Product Interfaces » Preprocessors » 
PO Preprocessor Not in Costpoint Web 

Import Subcontract PO Status Updates Others » Product Interfaces » Preprocessors » 
Subcontract PO Status Update Preprocessor Not in Costpoint Web 

Export eProcurement Addresses Others » Product Interfaces » eProcurement » 
Download Addresses Not in Costpoint Web 

Export eProcurement PO Receipts Others » Product Interfaces » eProcurement » 
Download PO Receipt Information Not in Costpoint Web 

Export eProcurement Proj/Acct/Org Others » Product Interfaces » eProcurement » 
Download Project/Account/Org Information Not in Costpoint Web 

Export eProcurement Vendors Others » Product Interfaces » eProcurement » 
Download Vendor Information Not in Costpoint Web 

Export eProcurement Inventory Abbreviations Others » Product Interfaces » eProcurement » 
Download Inventory Abbreviations Not in Costpoint Web 

Export eProcurement Items and Line Charge 
Types 

Others » Product Interfaces » eProcurement » 
Download Items and Line Charge Types Not in Costpoint Web 

Export eProcurement Requisitions Others » Product Interfaces » eProcurement » 
Download Requisition Information Not in Costpoint Web 
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Purchasing Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Purchasing 
Controls Client/Server Web 

Configure Purchasing Settings Materials » Purchasing » Purchasing Controls » 
PO Settings 

Administration » Configure » Materials » 
Purchasing Settings 

Configure Purchase Order Print Options Materials » Purchasing » Purchasing Controls » 
PO Print Options 

Administration » Configure » Materials » PO 
Print Options 

Purchasing Codes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Purchasing » Purchasing Codes Client/Server Web 

Manage Branch Locations Materials » Purchasing » Purchasing Controls » 
Branch Locations Not in Costpoint Web 

Manage Buyers Materials » Purchasing » Purchasing Controls » 
Buyers 

Materials » Configure » Purchasing » 
Buyers 

Manage Commodity Codes Materials » Purchasing » Purchasing Controls » 
Commodity Codes 

Materials » Configure » Items » Commodity 
Codes 

Manage Industry Classifications Materials » Purchasing » Purchasing Controls » 
Industry Classifications Not in Costpoint Web 

Manage Line Charge Types Materials » Purchasing » Purchasing Controls » 
PO Line Charge Types Not in Costpoint Web 

Manage Procurement Types Materials » Purchasing » Purchasing Controls » 
Procurement Types Not in Costpoint Web 
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Manage Standard Text Materials » Purchasing » Purchasing Controls » 
PO Standard Text Not in Costpoint Web 

Manage Units of Measure Materials » Purchasing » Purchasing Controls » 
Units of Measure Not in Costpoint Web 

View Ship IDs Materials » Purchasing » Purchasing Controls » 
Display Ship IDs 

Materials » Configure » Purchasing » 
Display Ship IDs 

Receiving 

Receiving 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Receiving » Receiving Client/Server Web 

Manage Purchase Order Receipts Materials » Receiving » Receiving » Receive 
Purchase Order 

Materials » Transactions » Receipts » 
Receive Purchase Orders 

Print Receipt Traveler Materials » Receiving » Reports » Print Receipt 
Traveler 

Materials » Transactions » Receipts » Print 
Receipt Traveler 

Manage Quality Control Inspections Materials » Receiving » Inspections » Enter QC 
Inspections 

Materials » Transactions » Receipts » Enter 
QC Inspections 

Manage Vendor Returns Materials » Receiving » Inspections » Enter 
Vendor Returns 

Materials » Transactions » Receipts » Enter 
Vendor Returns 

Enter Miscellaneous Inventory Receipts Materials » Receiving » Receiving » Receive 
Miscellaneous Not in Costpoint Web 
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Receiving Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Receiving » Receiving 
Reports/Inquiries Client/Server Web 

Print Pending Inspection Report Materials » Receiving » Reports » Print 
Pending Inspections Report Not in Costpoint Web 

Print Receiving Log Materials » Receiving » Reports » Print 
Receiving Log Not in Costpoint Web 

View Purchase Order Status Materials » Receiving » Inquiries » PO Status 
Inquiry 

Materials » Review » Purchase Orders » PO 
Status Inquiry 

Receiving Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Receiving » Receiving Interfaces Client/Server Web 

Import Purchase Order Receipts Others » Product Interfaces » Preprocessors » 
PO Receipts Preprocessor Not in Costpoint Web 

Receiving Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Receiving » Receiving Controls Client/Server Web 

Configure Receiving Settings Materials » Receiving » Receiving Controls » 
Receiving Settings 

Administration » Configure » Materials » 
Receiving Settings 

Manage Vendor Rejection Reasons Materials » Receiving » Receiving Controls » 
Vendor Rejection Reasons Not in Costpoint Web 
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Inventory 

Issues 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Issues Client/Server Web 

Enter Manufacturing Order Issues Materials » Inventory » Issues » Enter 
Manufacturing Order Issues 

Materials » Transactions » Inventory » Enter 
Manufacturing Order Issues 

Enter Issues to Project/Account/Org or PO Materials » Inventory » Issues » Enter Issues Not in Costpoint Web 

Manage Sales Order Inventory Issues Materials » Inventory » Issues » Enter Sales 
Order Inventory Issues Not in Costpoint Web 

Adjustments 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Adjustments Client/Server Web 

Enter Cost Adjustments Materials » Inventory » Adjustments » Enter 
Cost Adjustments Not in Costpoint Web 

Enter Quantity Adjustments Materials » Inventory » Adjustments » Enter 
Quantity Adjustments Not in Costpoint Web 

Enter Scrap Adjustments Materials » Inventory » Adjustments » Enter 
Scrap Adjustments Not in Costpoint Web 
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Transfers 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Transfer Client/Server Web 

Enter Inventory Transfers Materials » Inventory » Transfers » Enter 
Inventory Transfers Not in Costpoint Web 

Enter Location Transfers Materials » Inventory » Transfers » Enter 
Location Transfers Not in Costpoint Web 

Create Mass Inventory Transfers Materials » Inventory » Transfers » Perform 
Mass Inventory Transfers Not in Costpoint Web 

Receipts 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Receipts Client/Server Web 

Enter Miscellaneous Inventory Receipts Materials »Receiving » Receiving » Receive 
Miscellaneous Not in Costpoint Web 

Reservations 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Reservations Client/Server Web 

Manage Inventory Requests Materials » Inventory » Reservations » Enter 
Inventory Requests Not in Costpoint Web 

Manage Inventory Reservations Materials » Inventory » Reservations » Enter 
Reservations Not in Costpoint Web 
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Manage PO/Req Inventory Reservations Materials » Inventory » Reservations » Enter 
PO/Req Inventory Reservations Not in Costpoint Web 

Physical Counts 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Physical Counts Client/Server Web 

Update ABC Classifications Materials » Inventory » Physical Counts » 
Perform ABC Analysis Not in Costpoint Web 

Create Physical Counts Materials » Inventory » Physical Counts » Set 
Up Physical Count Not in Costpoint Web 

Manage Physical Counts Materials » Inventory » Physical Counts » 
Maintain Physical Count List Not in Costpoint Web 

Print Physical Count Sheets Materials » Inventory » Physical Counts » Print 
Physical Count Sheets Not in Costpoint Web 

Manage Actual Counts Materials » Inventory » Physical Counts » Enter 
Actual Counts Not in Costpoint Web 

Create Physical Count Adjustments Materials » Inventory » Physical Counts » Print 
Discrepancy Report and Create Adjustments Not in Costpoint Web 

Inventory Closing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Inventory Closing Client/Server Web 

Post Inventory Journal Materials » Inventory » Post Inventory Journal Not in Costpoint Web 
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Inventory Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Inventory 
Reports/Inquiries Client/Server Web 

Print Inventory Reorder Report Materials » Inventory » Reports » Print 
Inventory Reorder Report Not in Costpoint Web 

Print Inventory Transaction History Materials » Inventory » Reports » Print 
Inventory Transaction History Report Not in Costpoint Web 

Print Reservation Pick Lists Materials » Inventory » Reports » Print 
Reservation Pick Lists Not in Costpoint Web 

Print Stock Status Report Materials » Inventory » Reports » Print Stock 
Status Report Not in Costpoint Web 

Print Shelf Life Report Not in Costpoint Client/Server Not in Costpoint Web 

View Inventory Transaction History Materials » Inventory » Inquiries » Inventory 
Transaction History Inquiry Not in Costpoint Web 

View Items Materials » Inventory » Inquiries » Item Inquiry Materials » Review » Items » Item Inquiry 

View Part Inventory Materials » Inventory » Inquiries » Part 
Inventory Inquiry Not in Costpoint Web 

View Serial/Lot Information Materials » Inventory » Inquiries » Serial/Lot 
Inquiry Not in Costpoint Web 
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Inventory Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Inventory Interfaces Client/Server Web 

Import Inventory Transactions Others » Product Interfaces » Preprocessors » 
Inventory Transaction Preprocessor 

Materials » Utilities » Import » Import 
Inventory Transactions 

Inventory Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Inventory Utilities Client/Server Web 

Close Inventory Fiscal Year Materials » Inventory » Utilities » Close 
Inventory Fiscal Year Not in Costpoint Web 

Create UID Print File Not in Costpoint Client/Server Not in Costpoint Web 

Manage Serial/Lot Information Materials » Inventory » Utilities » Serial/Lot 
Maintenance Not in Costpoint Web 

Reconcile Inventory Balances Materials » Inventory » Utilities » Reconcile 
Transactions Not in Costpoint Web 

Inventory Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Inventory » Inventory Controls Client/Server Web 

Configure Inventory Settings Materials » Inventory » Inventory Controls » 
Inventory Settings Not in Costpoint Web 



Materials  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
167 

 

Configure Serial/Lot Settings Materials » Inventory » Inventory Controls » 
Serial/Lot Settings Not in Costpoint Web 

Configure Inventory Accounts Materials » Inventory » Inventory Controls » 
Inventory Accounts Not in Costpoint Web 

Configure Default Project Inventory Accounts Materials » Inventory » Inventory Controls » 
Default Project Inventory Accounts Not in Costpoint Web 

Configure Back Order Processing Settings Materials » Inventory » Inventory Controls » 
Back Order Processing Settings Not in Costpoint Web 

Manage Serial/Lot User-Defined Labels Materials » Inventory » Inventory Controls » 
Serial/Lot User-Defined Labels Not in Costpoint Web 

Manage Inventory Projects Materials » Inventory » Inventory Controls » 
Inventory Projects Not in Costpoint Web 

Manage Plants Not in Client/Server Materials » Configure » Inventory » Plants 

Manage Warehouses Materials » Inventory » Inventory Controls » 
Warehouses Not in Costpoint Web 

Manage Locations Materials » Inventory » Inventory Controls » 
Locations Not in Costpoint Web 

Manage Adjustment Reasons Materials » Inventory » Inventory Controls » 
Adjustment Reasons Not in Costpoint Web 

Manage Scrap Reasons Materials » Inventory » Inventory Controls » 
Scrap Reasons Not in Costpoint Web 
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Production Control 

Materials Planning 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Production Control » Materials 
Planning Client/Server Web 

Compute Material Requirements Materials » Production Controls » Production 
Controls » Process Material Requirements Not in Costpoint Web 

Manufacturing Orders 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Production Control » 
Manufacturing Orders Client/Server Web 

Manage Manufacturing Orders 
Materials » Production Controls » 
Manufacturing Orders » Enter Manufacturing 
Orders 

Not in Costpoint Web 

Expedite Manufacturing Orders 
Materials » Production Controls » 
Manufacturing Orders » Expedite 
Manufacturing Orders 

Not in Costpoint Web 

Print Manufacturing Order Documentation 
Materials » Production Controls » 
Manufacturing Orders » Print Manufacturing 
Order Documentation 

Not in Costpoint Web 

Enter Manufacturing Order Issues 
Materials » Production Controls » 
Manufacturing Orders » Enter Manufacturing 
Order Issues 

Not in Costpoint Web 
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Create MO Subcontractor Requisitions 
Materials » Production Controls » 
Manufacturing Orders » Create MO 
Subcontractor Requisitions 

Not in Costpoint Web 

Enter Manufacturing Order Reliefs 
Materials » Production Controls » 
Manufacturing Orders » Relieve Manufacturing 
Orders 

Not in Costpoint Web 

Manage MO Operation Completions Materials » Production Controls » Shop Floor 
Control » Enter MO Operation Completions 

Materials » Transactions » Manufacturing 
Orders » Enter MO Operation Completions 

Manage MO Quality Control Inspection Results Materials » Production Controls » Shop Floor 
Control » Enter MO QC Inspection Results 

Materials » Transactions » Manufacturing 
Orders » Enter MO QC Inspection Results 

Create MO WIP Variance Journal Entry 
Materials » Production Controls » Shop Floor 
Control » Create MO WIP Variance Journal 
Entry 

Not in Costpoint Web 

Production Control Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Production Control » Production 
Control Reports/Inquiries Client/Server Web 

Print Manufacturing Order Component 
Shortage Report 

Materials » Production Controls » Reports » 
Print Component Shortage Report Not in Costpoint Web 

Print Manufacturing Order Cost Report Materials » Production Controls » Reports » 
Print MO Cost Report Not in Costpoint Web 

View Manufacturing Order Status Materials » Production Controls » Inquiries » 
Manufacturing Order Status Inquiry Not in Costpoint Web 

View Part Inventory Materials » Production Controls » Inquiries » 
Part Inventory Inquiry Not in Costpoint Web 
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Production Control Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Production Control » Production 
Control Utilities Client/Server Web 

Update Manufacturing Order Costs Materials » Production Controls » Utilities » 
Modify MO Costs Not in Costpoint Web 

Update Manufacturing Order Labor Costs Materials » Production Controls » Utilities » 
Modify MO Labor Costs Not in Costpoint Web 

Production Control Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Production Control » Production 
Control Interfaces Client/Server Web 

Configure Advanced Planning and Scheduling 
Parameters 

Others » Product Interfaces » Advanced 
Planning and Scheduling » Advanced Planning 
and Scheduling Parameters 

Not in Costpoint Web 

Export Work Centers 
Others » Product Interfaces » Advanced 
Planning and Scheduling » Download Work 
Centers 

Not in Costpoint Web 

Export Manufacturing Orders 
Others » Product Interfaces » Advanced 
Planning and Scheduling » Download 
Manufacturing Orders 

Not in Costpoint Web 

Import Manufacturing Order Status Updates 
Others » Product Interfaces » Advanced 
Planning and Scheduling » Upload MO Status 
Updates 

Not in Costpoint Web 
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Production Control Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Production Control » Production 
Control Controls Client/Server Web 

Configure Production Control Settings Materials » Production Controls » Production 
Controls » Production Control Settings Not in Costpoint Web 

Configure Manufacturing Order Costing 
Options 

Materials » Production Controls » Production 
Controls » MO Costing Options Not in Costpoint Web 

Configure Shop Floor Calendar Materials » Production Controls » Production 
Controls » Shop Floor Calendar Not in Costpoint Web 

Configure MO Documentation Print Options Materials » Production Controls » Production 
Controls » MO Documentation Print Options Not in Costpoint Web 

Manage Employee Project Manufacturing 
Status Not in Costpoint Client/Server Not in Costpoint Web 

Manage Inventory Abbreviation Peggings Materials » Production Controls » Production 
Controls » Inventory Abbreviation Peggings Not in Costpoint Web 

Manage Manufacturing QC Rejection Reasons Materials » Production Controls » Production 
Controls » Manufacturing Rejection Reasons Not in Costpoint Web 

Manage Netting Groups Materials » Production Controls » Production 
Controls » Netting Groups Not in Costpoint Web 

Manage Planners Materials » Production Controls » Production 
Controls » Planners Not in Costpoint Web 

Manage Supervisors Materials » Production Controls » Production 
Controls » Supervisors Not in Costpoint Web 
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Sales Order Entry 

Customers 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Customers Client/Server Web 

Manage Customers Materials » Sales Order Entry » Customer Info 
» Maintain Customer 

Materials » Maintain » Customers » 
Customers 

Print Customer List Materials » Sales Order Entry » Customer Info 
» Print Customer Listing Not in Costpoint Web 

Sales Orders 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales 
Orders Client/Server Web 

Manage Sales Orders Materials » Sales Order Entry » Sales Order » 
Enter Sales Orders Not in Costpoint Web 

Approve Sales Orders Materials » Sales Order Entry » Sales Order » 
Approve Sales Orders Not in Costpoint Web 

Manage Sales Orders Supervisor Screen Materials » Sales Order Entry » Sales Order » 
Sales Order Supervisor Screen Not in Costpoint Web 

Print Sales Order Acknowledgements Materials » Sales Order Entry » Sales Order » 
Print Sales Order Acknowledgments Not in Costpoint Web 

Manage Sales Order User-Defined Information Materials » Sales Order Entry » Sales Order » 
Sales Order User-Defined Info Not in Costpoint Web 
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Sales Order Material Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Material Processing Client/Server Web 

Create Purchase Requisitions from Sales 
Orders 

Materials » Sales Order Entry » Sales Order » 
Create Requisitions from Sales Orders Not in Costpoint Web 

Print Sales Order Pick Lists 
Materials » Sales Order Entry » Sales Order 
Material Processing » Print Sales Order Pick 
Lists 

Not in Costpoint Web 

Manage Sales Order Inventory Issues 
Materials » Sales Order Entry » Sales Order 
Material Processing » Enter Sales Order 
Inventory Issues 

Not in Costpoint Web 

Manage Sales Order Non-Inventory Issues 
Materials » Sales Order Entry » Sales Order 
Material Processing » Enter Sales Order Non-
Inventory Issues 

Not in Costpoint Web 

Sales Order Shipping 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Shipping Client/Server Web 

Manage Shipping Transactions Materials » Sales Order Entry » Shipping 
Transactions » Enter Shipping Transactions Not in Costpoint Web 

Print Shipping Labels Materials » Sales Order Entry » Shipping 
Transactions » Print Shipping Labels Not in Costpoint Web 

Print Sales Order Packing Slips Materials » Sales Order Entry » Shipping 
Transactions » Print Packing Slips Not in Costpoint Web 
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Print DD250 Packing Slips Materials » Sales Order Entry » Shipping 
Transactions » Print DD250 Packing Slips Not in Costpoint Web 

Sales Order Invoices 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Invoices Client/Server Web 

Create Invoices Materials » Sales Order Entry » Invoices » 
Create Invoices Not in Costpoint Web 

Manage Invoices Materials » Sales Order Entry » Invoices » 
Maintain Invoices Not in Costpoint Web 

Select Invoices Ready for Use/Acceptance Materials » Sales Order Entry » Invoices » 
Ready for Use/Acceptance Not in Costpoint Web 

Manage Invoices Supervisor Screen Materials » Sales Order Entry » Invoices » 
Invoice Supervisor Screen Not in Costpoint Web 

Print Sales Order Invoices Materials » Sales Order Entry » Invoices » Print 
Invoices Not in Costpoint Web 

Print DD250 Invoices Materials » Sales Order Entry » Invoices » Print 
DD250 Invoices Not in Costpoint Web 

Create WAWF Files Materials » Sales Order Entry » Invoices » 
Create WAWF Files Not in Costpoint Web 
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Sales Order Posting 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Posting Client/Server Web 

Post Sales Order Journal Materials » Sales Order Entry » Invoices » Post 
Sales Order Journal Not in Costpoint Web 

Sales Order Entry Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Entry Reports/Inquiries Client/Server Web 

Print Sales Order Approval Status Report Materials » Sales Order Entry » Reports » Print 
Sales Order Approval Status Report Not in Costpoint Web 

Print Sales Order Backlog Report Materials » Sales Order Entry » Reports » Print 
Sales Order Backlog Report Not in Costpoint Web 

View Sales Analysis Information Materials » Sales Order Entry » Inquiries » 
Sales Analysis Inquiry Not in Costpoint Web 

View Sales Order Status Information Materials » Sales Order Entry » Inquiries » 
Sales Order Status Inquiry Not in Costpoint Web 

View Serial/Lot Information Materials » Sales Order Entry » Inquiries » 
Serial/Lot Inquiry Not in Costpoint Web 
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Sales Order Entry Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Entry Utilities Client/Server Web 

Create EDI Invoice File Materials » Sales Order Entry » Utilities » 
Create EDI Invoice File Not in Costpoint Web 

Create RFID Print File Not in Costpoint Client/Server Not in Costpoint Web 

Create UID Print File Not in Costpoint Client/Server Not in Costpoint Web 

Manage Serial/Lot Information Materials » Sales Order Entry » Utilities » 
Serial/Lot Maintenance Not in Costpoint Web 

Sales Order Entry Interfaces 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Entry Interfaces Client/Server Web 

Import Sales Orders Others » Product Interfaces » Preprocessor » 
Sales Order Preprocessor  

Materials » Utilities » Import » Import Sales 
Orders 
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Sales Order Entry Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Sales Order Entry » Sales Order 
Entry Controls Client/Server Web 

Configure Sales Order Entry Settings Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Settings Not in Costpoint Web 

Configure Sales Order Defaults Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Defaults Not in Costpoint Web 

Configure Serial/Lot Settings Materials » Sales Order Entry » Sales Order 
Entry Controls » Serial/Lot Settings Not in Costpoint Web 

Configure Sales Order Print Options Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Print Options Not in Costpoint Web 

Manage Sales Order Catalog Defaults Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Catalog Settings Not in Costpoint Web 

Manage Sales Order Project Defaults Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Project Settings Not in Costpoint Web 

Manage Order User-Defined Labels 
Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order User-Defined 
Labels 

Not in Costpoint Web 

Manage Serial/Lot User-Defined Labels Materials » Sales Order Entry » Sales Order 
Entry Controls » Serial/Lot User-Defined Labels Not in Costpoint Web 

Manage Contractor Addresses Materials » Sales Order Entry » Sales Order 
Entry Controls » Contractor Addresses Not in Costpoint Web 
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Manage Deferred Revenue Amortization 
Schedules 

Materials » Sales Order Entry » Sales Order 
Entry Controls » Deferred Revenue 
Amortization Schedules 

Not in Costpoint Web 

Manage Issued By Addresses Materials » Sales Order Entry » Sales Order 
Entry Controls » Issued by Addresses Not in Costpoint Web 

Manage Sales Group Abbreviations Materials » Product Definition » Product Billing 
» Set Up Sales Group Abbreviations Not in Costpoint Web 

Manage Sales Order Approval Titles Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Approval Titles Not in Costpoint Web 

Manage Sales Order Approval Processes 
Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Approval 
Processes 

Not in Costpoint Web 

Manage Sales Order Cost Types Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Cost Types Not in Costpoint Web 

Manage Line Charge Types 
Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Line Charge 
Types 

Not in Costpoint Web 

Manage Sales Order Rejection Reasons 
Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Rejection 
Reasons 

Not in Costpoint Web 

Manage Standard Text Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Order Standard Text Not in Costpoint Web 

Manage Sales Representatives Materials » Sales Order Entry » Sales Order 
Entry Controls » Sales Representatives Not in Costpoint Web 

Manage Shipment Modes Materials » Sales Order Entry » Sales Order 
Entry Controls » Shipment Modes Not in Costpoint Web 
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Master Production Scheduling 

Master Production Schedules 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Master Production Scheduling » 
Master Production Schedules Client/Server Web 

Update Master Production Schedules 
Materials » Master Production Scheduling » 
Master Production Scheduling » Generate 
Master Production Schedules 

Not in Costpoint Web 

Manage Master Production Schedules 
Materials » Master Production Scheduling » 
Master Production Scheduling » Edit Master 
Production Schedule 

Not in Costpoint Web 

Copy Master Production Schedules 
Materials » Master Production Scheduling » 
Master Production Scheduling » Copy Master 
Production Schedules 

Not in Costpoint Web 

Manage Master Production Schedule Action 
Messages 

Materials » Master Production Scheduling » 
Master Production Scheduling » Edit MPS 
Action Messages 

Not in Costpoint Web 

Print Master Production Schedule Action 
Message Report 

Materials » Master Production Scheduling » 
Master Production Scheduling » Print MPS 
Action Message Report 

Not in Costpoint Web 

Firm Master Production Schedule Planned 
Orders 

Materials » Master Production Scheduling » 
Master Production Scheduling » Firm  Planned 
Orders 

Not in Costpoint Web 



Materials  

Costpoint 7.1 to Costpoint 6.1 Menu Mapping 
180 

 

Planning Routings 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Master Production Scheduling » 
Planning Routings Client/Server Web 

Create/Update Planning Routings 
Materials » Master Production Scheduling » 
Planning Routings » Calculate Planning 
Routings 

Not in Costpoint Web 

Manage Planning Routings 
Materials » Master Production Scheduling » 
Planning Routings » Maintain Planning 
Routings 

Not in Costpoint Web 

Rough-Cut Capacity Plan 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Master Production Scheduling » 
Rough-Cut Capacity Plan Client/Server Web 

Create/Update Rough-Cut Capacity Plan  
Materials » Master Production Scheduling » 
Master Production Scheduling » Generate 
Rough-Cut Capacity Plan 

Not in Costpoint Web 

View Rough-Cut Capacity Plan Materials » Master Production Scheduling » 
Inquiries » Rough-Cut Capacity Plan Inquiry Not in Costpoint Web 
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Material Production Scheduling Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Master Production Scheduling » 
Material Production Scheduling 
Reports/Inquiries 

Client/Server Web 

Print Master Production Schedule Report 
Materials » Master Production Scheduling » 
Reports » Print Master Production Schedule 
Report 

Not in Costpoint Web 

Print Production Backlog Report Materials » Master Production Scheduling » 
Reports » Print Production Backlog Report Not in Costpoint Web 

View Items Materials » Master Production Scheduling » 
Inquiries » Item Inquiry Materials » Review » Items » Item Inquiry 

View Part Inventory Materials » Master Production Scheduling » 
Inquiries » Part Inventory Inquiry Not in Costpoint Web 

Master Production Scheduling Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Master Production Scheduling » 
Master Production Scheduling Controls Client/Server Web 

Configure Master Production Scheduling 
Settings 

Materials » Master Production Scheduling » 
MPS Controls » MPS Settings Not in Costpoint Web 

Manage Master Production Schedules Planning 
Codes 

Materials » Master Production Scheduling » 
MPS Controls » MPS Planning Codes Not in Costpoint Web 

Manage Resource Types Materials » Master Production Scheduling » 
MPS Controls » Resource Types Not in Costpoint Web 
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Manage Key Resources Materials » Master Production Scheduling » 
MPS Controls » Key Resources Not in Costpoint Web 

Material Requirements Planning 

Material Requirements Planning 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Material Requirements Planning 
» Material Requirements Planning Client/Server Web 

Update Material Requirements Plan  
Materials » Material Requirements Planning » 
Material Requirements Planning » Update 
Material Requirements Plan 

Not in Costpoint Web 

Expedite Manufacturing Orders 
Materials » Material Requirements Planning » 
Material Requirements Planning » Expedite 
Manufacturing Orders 

Not in Costpoint Web 

Manage Detailed Part Schedule 
Materials » Material Requirements Planning » 
Material Requirements Planning » Detailed Part 
Schedule 

Not in Costpoint Web 

Manage MRP Action Messages  
Materials » Material Requirements Planning » 
Material Requirements Planning » Maintain 
MRP Action Messages 

Not in Costpoint Web 

Print MRP Action Message Report Materials » Material Requirements Planning » 
Reports » Print MRP Action Message Report Not in Costpoint Web 

Firm Material Requirements Planning Planned 
Orders 

Materials » Material Requirements Planning » 
Material Requirements Planning » Firm 
Planned Orders 

Not in Costpoint Web 
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Material Requirements Planning Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Material Requirements Planning 
» Material Requirements Planning 
Reports/Utilities 

Client/Server Web 

Print Detailed Part Availability Report Materials » Material Requirements Planning » 
Reports » Print Detailed Part Availability Report Not in Costpoint Web 

Print Summary Part Availability Report 
Materials » Material Requirements Planning » 
Reports » Print Summary Part Availability 
Report 

Not in Costpoint Web 

Print Bills of Material MRP Action Message 
Report 

Materials » Material Requirements Planning » 
Reports » Print BOM MRP Action Message 
Report 

Not in Costpoint Web 

View Items Materials » Material Requirements Planning » 
Inquiries » Item Inquiry Materials » Review » Items » Item Inquiry 

View Part Inventory Materials » Material Requirements Planning » 
Inquiries » Part Inventory Inquiry Not in Costpoint Web 

View Summary Part Availability Materials » Material Requirements Planning » 
Inquiries » Summary Part Availability Inquiry Not in Costpoint Web 
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Material Requirements Planning Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Material Requirements Planning 
» Material Requirements Planning Utilities Client/Server Web 

Update Low-Level Codes 
Materials » Material Requirements Planning » 
Material Requirements Planning » Update Low-
Level Codes 

Not in Costpoint Web 

Convert MO Status from Planned to Firmed 
Planned 

Materials » Material Requirements Planning » 
Utilities » Toolkits » Change MO Status from 
Planned to Firm Planned* 

Not in Costpoint Web 

Update Netting Flags for MRB Locations  
Materials » Material Requirements Planning » 
Utilities » Toolkits » Change Netting Flags for 
MRB Locations* 

Not in Costpoint Web 

Assign Planning Warehouses to Inventory 
Projects 

Materials » Material Requirements Planning » 
Utilities » Toolkits » Assign Planning 
Warehouses to Inventory Projects* 

Not in Costpoint Web 

Assign Project Planning Warehouses to Req 
and PO Lines 

Materials » Material Requirements Planning » 
Utilities » Toolkits » Assign Project Planning 
Warehouses to Req and PO Lines* 

Not in Costpoint Web 

Create Reservations for Pending Sales Orders 
Materials » Material Requirements Planning » 
Utilities » Toolkits » Create Reservations for 
Pending Sales Orders* 

Not in Costpoint Web 

Create MRP Detail Report Table  
Materials » Material Requirements Planning » 
Utilities » Toolkits » Populate MRP Report 
Detail Table* 

Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Material Requirements Planning Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Material Requirements Planning 
» Material Requirements Planning Controls Client/Server Web 

Configure Materials Requirements Planning 
Settings 

Materials » Material Requirements Planning » 
MRP Controls » MRP Settings Not in Costpoint Web 

Configure MRP Report Print Options Materials » Material Requirements Planning » 
MRP Controls » MRP Report Print Options Not in Costpoint Web 

Manage Inventory Abbreviation Peggings 
Materials » Material Requirements Planning » 
MRP Controls » Inventory Abbreviation 
Peggings 

Not in Costpoint Web 

Materials Estimating 

Proposals 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Materials Estimating » Proposals Client/Server Web 

Manage Proposals Materials » Materials Estimating » Materials 
Estimating Controls » Maintain Proposal Master Not in Costpoint Web 
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Proposal Bills of Material 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Materials Estimating » Proposal 
Bills of Material Client/Server Web 

Manage Proposal Bills of Material Materials » Materials Estimating » Proposals 
Bills of Material » Maintain Proposal BOM Not in Costpoint Web 

Copy Proposal Bills of Material Materials » Materials Estimating » Proposals 
Bills of Material » Copy Proposal BOM Not in Costpoint Web 

Apply Mass Component Changes to Proposal 
BOMs 

Materials » Materials Estimating » Proposals 
Bills of Material » Perform PBOM Mass 
Component Change 

Not in Costpoint Web 

Manage Provisional Parts 
Materials » Materials Estimating » Materials 
Estimating Controls » Maintain Provisional 
Parts 

Not in Costpoint Web 

Proposal Item Costing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Materials Estimating » Proposal 
Item Costing Client/Server Web 

Compute Proposal Item Costs Materials » Materials Estimating » Proposal 
Item Costing » Compute Proposal Item Costs Not in Costpoint Web 

Manage Proposal BOM Cost Estimates - 
Indented 

Materials » Materials Estimating » Proposal 
Item Costing » Maintain PBOM Cost Estimates 
- Indented 

Not in Costpoint Web 
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Manage Proposal BOM Cost Estimates - 
Summarized 

Materials » Materials Estimating » Proposal 
Item Costing » Maintain PBOM Cost Estimates 
- Summarized 

Not in Costpoint Web 

Request for Quotes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Materials Estimating » Request 
for Quotes Client/Server Web 

Select Request for Quotes from Proposals Materials » Materials Estimating » Request for 
Quotes » Select RFQs from Proposals Not in Costpoint Web 

Create Request for Quotes for Proposals Materials » Materials Estimating » Request for 
Quotes » Create RFQs for Proposals Not in Costpoint Web 

Materials Estimating Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries Client/Server Web 

View Item Purchasing Information Materials » Materials Estimating » Inquiries » 
Item Purchasing Information Inquiry 

Materials » Review » Purchase Orders » 
Item Purchasing Information Inquiry 

Print Proposal Bills of Material Exception 
Report 

Materials » Materials Estimating » Reports » 
Print PBOM Exception Report Not in Costpoint Web 

Print Proposal Item Cost History Report Materials » Materials Estimating » Reports » 
Print Proposal Item Cost History Report Not in Costpoint Web 

View Proposal BOM Where-Used Information Materials » Materials Estimating » Inquiries » 
Proposal BOM Where-Used Inquiry Not in Costpoint Web 
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View Vendor Performance Materials » Materials Estimating » Inquiries » 
Vendor Performance Inquiry 

Materials » Review » Vendors » Vendor 
Performance Inquiry 

View Vendor Quotes Materials » Materials Estimating » Inquiries » 
Vendor Quote Inquiry Not in Costpoint Web 

Materials Estimating Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Materials » Materials Estimating » Materials 
Estimating Controls Client/Server Web 

Configure Materials Estimating Settings 
Materials » Materials Estimating » Materials 
Estimating Controls » Materials Estimating 
Settings 

Not in Costpoint Web 

Manage Materials Estimating Cost Source 
Types 

Materials » Materials Estimating » Materials 
Estimating Controls » ME Cost Source Types Not in Costpoint Web 

Manage Provisional Part Types Materials » Materials Estimating » Materials 
Estimating Controls » Provisional Part Types Not in Costpoint Web 
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Administration 

System Administration 

File Management 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
File Management Client/Server Web 

Manage Alternate File Locations Not in Costpoint Client/Server Administration » Maintain » Files » Alternate 
File Locations 

Export Files Not in Costpoint Client/Server Administration » Utilities » Files » File 
Download Manager 

Printing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
Printing Client/Server Web 

Manage Report Archive Categories Not in Costpoint Client/Server Administration » Maintain » Reports » 
Report Archive Categories 

Manage Report Categories Not in Costpoint Client/Server Administration » Maintain » Reports » 
Report Categories 

Manage Report Fonts Not in Costpoint Client/Server Administration » Maintain » Reports » 
Report Fonts 

Manage Report Groups Not in Costpoint Client/Server Administration » Maintain » Reports » 
Report Groups 
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Manage System Printers Others » Process Management » Setup » 
Maintain Printer IDs 

Administration » Maintain » Printers » 
System Printers 

Workspace Customization 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
Workspace Customization Client/Server Web 

Manage Standard Label Customizations Not in Costpoint Client/Server Not in Costpoint Web 

Manage User Interface Profiles Not in Costpoint Client/Server Not in Costpoint Web 

Manage Extensibility Units Not in Costpoint Client/Server Not in Costpoint Web 

System Administration Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
System Administration Reports/Inquiries Client/Server Web 

Print Application Table Information Report Not in Costpoint Client/Server Administration » Review » Database » 
Application Table Information Report 

Print Archived Reports Not in Costpoint Client/Server Administration » Review » Archived Reports 
» Archived Reports 

Print Data Dictionary Report Others » System Administration » System 
Utilities » Print Data Dictionary Report 

Administration » Review » Database » Data 
Dictionary Report 

Print Extensibility Unit Report Not in Costpoint Client/Server Not in Costpoint Web 

Print Menu Report Others » System Administration » System 
Utilities » Print Menu Report 

Administration » Review » System 
Administration » Menu Report 
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Print My Menu Report Others » System Administration » System 
Security » Print MyMenu Report Not in Costpoint Web 

Print Postal Codes Report Others » System Administration » System 
Codes » Print Postal Codes Report Not in Costpoint Web 

Print Sales/Value Added Tax Report Others » System Administration » System 
Codes » Print Sales/Value Added Tax Report Not in Costpoint Web 

View Costpoint License Information From the Help menu, select About Costpoint. Administration » Review » Licenses » 
Costpoint License Information 

View Help About From the Help menu, select About Costpoint. Administration » Review » Help » About 
Costpoint 

View Action and Report Status Not in Costpoint Client/Server Not in Costpoint Web 

System Administration Interfaces  

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
System Administration Interfaces Client/Server Web 

Manage Interface Configuration and Scheduler 
Others » Product Interfaces » Interface 
Controls » Interface Configuration and 
Scheduler 

Not in Costpoint Web 

Activate Instance Control Others » Product Interfaces » Interface 
Controls » Instance Activation Control Not in Costpoint Web 

Manage Interface Elements Others » Product Interfaces » Interface 
Controls » Maintain Interface Elements Not in Costpoint Web 

Manage Element Value Mappings Others » Product Interfaces » Interface 
Controls » Maintain Element Value Mappings Not in Costpoint Web 
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Configure Cobra Interface Settings Others » Product Interfaces » Cobra Interface » 
Cobra Interface Settings Not in Costpoint Web 

Manage Cobra Charge Templates Others » Product Interfaces » Cobra Interface » 
Maintain Cobra Charge Templates Not in Costpoint Web 

Manage Cobra Budget Element Templates Others » Product Interfaces » Cobra Interface » 
Maintain Cobra Budget Element Templates Not in Costpoint Web 

Manage Cobra Cost Templates Others » Product Interfaces » Cobra Interface » 
Maintain Cobra Cost Templates Not in Costpoint Web 

Manage Cobra Program Mapping Others » Product Interfaces » Cobra Interface » 
Cobra Program Mapping Not in Costpoint Web 

Manage Cobra Extraction Parameters Others » Product Interfaces » Cobra Interface » 
Cobra Extraction Parameters Not in Costpoint Web 

Compute Cobra Burden Costs Others » Product Interfaces » Cobra Interface » 
Compute Cobra Burden Cost Not in Costpoint Web 

Manage Prior Year Cobra Costs Others » Product Interfaces » Cobra Interface » 
Maintain Prior Year Cobra Costs Not in Costpoint Web 

Transfer GovWin Capture Management Data Not in Costpoint Client/Server Not in Costpoint Web 

Configure Customer Options 
Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Customer 
Options 

Not in Costpoint Web 

Configure Employee Options 
Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Employee 
Options 

Not in Costpoint Web 

Configure Organization Options 
Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Organization 
Options 

Not in Costpoint Web 
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Configure Project Options Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Project Options Not in Costpoint Web 

Configure Vendor Options Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Vendor Options Not in Costpoint Web 

Manage Project Level Mapping 
Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Maintain Project Level 
Mapping 

Not in Costpoint Web 

Configure Client Upload Options 
Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Client Upload 
Options 

Not in Costpoint Web 

Configure Project Upload Options 
Others » Product Interfaces » CRM/Gov 
Win/RP Integration » Configure Project Upload 
Options 

Not in Costpoint Web 

System Administration Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
System Administration Controls Client/Server Web 

Configure System Settings Others » System Administration » System 
Settings 

Administration » Configure » System » 
System Settings 

Manage Locales Not in Costpoint Client/Server Administration » Maintain » Reports » 
Report Locales 

Set Up Company Others » System Administration » Set Up 
Company Not in Costpoint Web 

Configure User Preferences 
Open the Options menu on the toolbar. Select 
Preferences,  then Maintain General 
Preferences. 

Administration » Maintain » Users » User 
Preferences 
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Manage Construction Industry Scheme Codes Others » System Administration » System 
Codes » Maintain CIS Codes Not in Costpoint Web 

Manage Countries Others » System Administration » System 
Codes » Maintain Countries 

Administration » Maintain » Codes » 
Countries 

Manage Customs Declaration Point Others » System Administration » System 
Codes » Maintain Customs Declaration Point Not in Costpoint Web 

Manage Customs Traffic Direction Codes 
Others » System Administration » System 
Codes » Maintain Customs Traffic Direction 
Codes 

Not in Costpoint Web 

Manage European Union Commodity Codes Others » System Administration » System 
Codes » Maintain EC Commodity Codes Not in Costpoint Web 

Manage European Union Correction Codes Others » System Administration » System 
Codes » Maintain EC Correction Codes Not in Costpoint Web 

Manage European Union Countries Others » System Administration » System 
Codes » Maintain EC Countries Not in Costpoint Web 

Manage European Union Mode of 
Transportation 

Others » System Administration » System 
Codes » Maintain EC Mode of Transportation Not in Costpoint Web 

Manage EU Nature of Transaction Codes 
(NOTC) 

Others » System Administration » System 
Codes » Maintain EC Nature of Transaction 
Codes (NOTC) 

Not in Costpoint Web 

Manage Postal Codes Others » System Administration » System 
Codes » Maintain Postal Codes 

Administration » Maintain » Codes » Postal 
Codes 

Manage Sales or Value Added Taxes Others » System Administration » System 
Codes » Maintain Sales/Value Added Tax Not in Costpoint Web 

Manage States and Provinces Others » System Administration » System 
Codes » Maintain States and Provinces 

Administration » Maintain » Codes » States 
and Provinces 
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Manage Tax Types Others » System Administration » System 
Codes » Maintain Tax Types Not in Costpoint Web 

Manage Value Added Tax Supply Codes Others » System Administration » System 
Codes » Maintain VAT Supply Codes Not in Costpoint Web 

System Administration Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
System Administration Utilities Client/Server Web 

Activate/Inactivate Costpoint Usage Others » System Administration » System 
Utilities » Enable/Disable Costpoint Usage Not in Costpoint Web 

Clear Users Others » System Administration » System 
Utilities » Clear User(s) 

Administration » Utilities » System 
Administration » Clear Users 

Purge Report Table Data Others » System Administration » DBA Utilities 
» Purge Report Table Data Not in Costpoint Web 

Rebuild Global Settings Not in Costpoint Client/Server Administration » Utilities » System 
Administration » Reload Global Settings 

Rebuild Upgraded Tables Others » System Administration » Utilities » 
Miscellaneous Toolkits » Upgrade Clean-up* Not in Costpoint Web  

Resize Dynamic Tables and Indexes Others » System Administration » DBA Utilities 
» Size Dynamic Tables and Indexes Not in Costpoint Web 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Content Management 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » System Administration » 
Content Management Client/Server Web 

Manage Content Types Not in Costpoint Client/Server Not in Costpoint Web 

Manage Application/Content Links Not in Costpoint Client/Server Not in Costpoint Web 

Security 

System Security 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Security » System Security Client/Server Web 

Manage User Groups Others » System Administration » System 
Security » Maintain User Groups 

Administration » Maintain » Users » User 
Groups 

Manage Users Others » System Administration » System 
Security » Maintain Users Administration » Maintain » Users » Users 

Organizational Security 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Security » Organizational 
Security Client/Server Web 

Activate/Inactivate Organization Security by 
Module  

Others » System Administration » Organization 
Security » Enable/Disable Org Security for 
Modules 

Administration » Maintain » Organizational 
Security » Module Organization Security 
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Manage Organization Security Profiles Others » System Administration » Organization 
Security » Maintain Org Security Profiles Not in Costpoint Web 

Manage Organization Security Groups Others » System Administration » Organization 
Security » Maintain Org Security Groups Not in Costpoint Web 

Update Organization Security Profiles Others » System Administration » Organization 
Security » Update Org Security Profiles Not in Costpoint Web 

Segregation of Duties 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Security » Segregation of 
Duties Client/Server Web 

Manage Segregation of Duties Conflict Types Not in Costpoint Client/Server 
Administration » Maintain » Segregation of 
Duties » Segregation of Duties Conflict 
Types 

Manage Application Conflicts Not in Costpoint Client/Server Administration » Maintain » Segregation of 
Duties » Conflicting Applications 

Identify Segregation of Duties Conflicts Not in Costpoint Client/Server 
Administration » Process » Segregation of 
Duties » Identify Segregation of Duties 
Conflicts 

Manage Segregation of Duties Conflict 
Overrides Not in Costpoint Client/Server 

Administration » Process » Segregation of 
Duties » Override Segregation of Duties 
Conflicts 
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Archived Report Security 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Security » Archived Report 
Security Client/Server Web 

Manage Archived Report Security Rights Not in Costpoint Client/Server Administration » Review » Archived Reports 
» Archived Reports 

Security Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Security » Security 
Reports/Inquiries Client/Server Web 

Print Effective User Rights Report Others » System Administration » System 
Security » Print User Effective Rights Report 

Administration » Review » Users » Effective 
User Rights Report 

Print User Report Others » System Administration » System 
Security » Print User Report 

Administration » Review » Users » User 
Report 

Print User Group Rights Report Others » System Administration » System 
Security » Print User Group Rights Report 

Administration » Review » Users » User 
Group Rights Report 

View Costpoint License Information From the "Help" menu, select "About Costpoint" Administration » Review » Licenses » 
Costpoint License Information 
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Job Management 

Job Management Codes 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Job Management » Job 
Management Codes Client/Server Web 

Manage Job Groups Others » Process Management » Design » 
Maintain Process Groups 

Administration » Maintain » Job 
Management » Job Groups 

Manage Jobs Others » Process Management » Design » 
Maintain Processes 

Administration » Maintain » Job 
Management » Jobs 

Manage Job Queues Others » Process Management » Setup » 
Maintain Queues 

Administration » Maintain » Job 
Management » Job Queues 

Job Management Processing 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Job Management » Job 
Management Processing Client/Server Web 

Start/Stop Job Server  Others » Process Management » Manage » 
Change  Server Status 

Administration » Transactions » Job 
Management » Start/Stop Job Server 

Submit Job to Queue Others » Process Management » Initiate » 
Submit Process to Queue 

Administration » Transactions » Job 
Management » Submit Job to Queue 

Update Job Queue Status Not in Costpoint Client/Server 
Administration » Transactions » Job 
Management » Update Job Queue List 
Status 
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Update Job Status Others » Process Management » Manage » 
Change/Monitor Process Status 

Administration » Transactions » Job 
Management » Monitor Job Status 

Job Management Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Job Management » Job 
Management Reports/Inquiries Client/Server Web 

Print Job Report Others » Process Management » Design » 
Print Process Report 

Administration » Review » Job Management 
» Job Report 

View Action and Report Status Not in Costpoint Client/Server Administration » Review » Job Management 
» Process and Report Status Inquiry 

Job Management Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Job Management » Job 
Management Utilities Client/Server Web 

Print/Purge Job History Others » Process Management » Manage » 
Print/Purge Process History 

Administration » Utilities » Job Management 
» Print/Purge Job History 

Job Management Controls 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Job Management » Job 
Management Controls Client/Server Web 

Configure Application Batch Job Settings Not in Costpoint Client/Server Administration » Maintain » Job 
Management » Application Batch Job Rules 
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Workflow 

Workflow Models 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Workflow » Workflow 
Models Client/Server Web 

Manage Workflow Case Labels Others » Workflow » Design » Define Case 
Labels Not in Costpoint Web 

Manage Workflow Roles Others » Workflow » Design » Define Roles Administration » Maintain » Workflow » 
Workflow Roles 

Manage Workflow Role Filters Others » Workflow » Design » Define Role 
Filtering Not in Costpoint Web 

Manage Workflow Models Others » Workflow » Design » Define Workflow 
Models Not in Costpoint Web 

Print Workflow Definition Report Others » Workflow » Design » Print Workflow 
Definition Report Not in Costpoint Web 

Workflow Cases 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Workflow » Workflow 
Cases Client/Server Web 

Manage Workflow Cases Others » Workflow » Monitor » Maintain Case Administration » Transactions » Workflow » 
Edit Workflow Case 

Monitor Workflow Status Others » Workflow » Monitor » Monitor Status Administration » Transactions » Workflow » 
Monitor Workflow Status 
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Monitor Activities and Messages Others » Workflow » Monitor » Activity and 
Message Inboxes 

Administration » Transactions » Workflow » 
Workflow Activity and Message Inboxes 

Escalate Workflow Activities Others » Workflow » Monitor » Escalate 
Activities Not in Costpoint Web 

Print Workflow Status Report Others » Workflow » Monitor » Print Workflow 
Status Report Not in Costpoint Web 

Workflow Reports/Inquiries 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Workflow » Workflow 
Reports/Inquiries Client/Server Web 

Print Workflow Audit Report Others » Workflow » Monitor » Print Audit 
Report Not in Costpoint Web 

View Workflow Audit Information Others » Workflow » Monitor » Audit Inquiry Not in Costpoint Web 

Administrative Utilities 

Costpoint 7.1 Menu Location Costpoint 6.1 Menu Locations  

Administration » Workflow » Administrative 
Utilities Client/Server Web 

Rebuild Workflow Data Others » Workflow » Utilities » Miscellaneous 
Toolkits » Upgrade Clean-up* Not in Costpoint Web 

Import Predefined Workflows Others » Workflow » Utilities » Miscellaneous 
Toolkits » Upload Predefined Workflows* Not in Costpoint Web 

Purge Workflow Data Others » Workflow » Conclude » Purge 
Historical Data Not in Costpoint Web 
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* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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