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While Deltek has attempted to verify that the information in this document is accurate and 
complete, some typographical or technical errors may exist. The recipient of this document is 
solely responsible for all decisions relating to or use of the information provided herein. 

The information contained in this publication is effective as of the publication date below and is 
subject to change without notice. 

This publication contains proprietary information that is protected by copyright. All rights are 
reserved. No part of this document may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, or translated into another language, without the prior written 
consent of Deltek, Inc. 

This edition published September 2014. 

© 2014 Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and 
proprietary information of Deltek, Inc. and its licensors. The Deltek software, and all related 
documentation, is provided for use only in accordance with the terms of the license agreement. 
Unauthorized reproduction or distribution of the program or any portion thereof could result in 
severe civil or criminal penalties. 

All trademarks are the property of their respective owners.  
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Overview 
This guide provides instructions for downloading and installing GovWin Opportunity Manager to 
Vision CRM Integration.  

After you download and install GovWin Opportunity Manager to Vision CRM Integration, you will 
have access to the Opportunity Manager Web Service utility and the Opp Manager tab in the 
Opportunity Info Center in Vision.  

The information in this guide applies both to the installation of GovWin Opportunity Manager to 
Vision CRM Integration on customers’ on-premise servers and to installation on Deltek Cloud 
Operations servers for access by customers who have a Vision SaaS Subscription. 

Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® 
Reader® X provides this ability. If you do not already use Adobe Reader X, you can download it 
here free from Adobe.  

To add a custom note using Adobe Reader X, complete the following steps: 

1. On the Reader toolbar, click Comment at far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to 
match the button. 

3. Position the cursor at the location in the guide where you want the note to appear, and 
click. A note icon is inserted at the location and a text box pops up. 

4. Enter your information in the text box.   

5. Continue adding notes as needed. 

6. Save the document. 

 

Deltek recommends that you save the document to a slightly different filename so as to keep the 
original from being overwritten. 

When reading the document, cursor over a note icon to see the information. Double-click a note 
icon to edit the information. 

http://get.adobe.com/reader/
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If You Need Assistance 
If you need assistance installing, implementing, or using GovWin Opportunity Manager to Vision 
CRM Integration, Deltek makes a wealth of information and expertise readily available to you. 

Customer Services 
For over 20 years, Deltek has maintained close relationships with client firms, helping with their 
problems, listening to their needs, and getting to know their individual business environments. A 
full range of customer services has grown out of this close contact, including the following: 

 Extensive self-support options through the Customer Care Connect Web portal. 

 Phone and email support from Customer Care analysts 

 Technical services 

 Consulting services 

 Custom programming 

 Classroom, on-site, and Web-based training 

 

Find out more about these and other services from the Customer Care Connect site. 

Customer Care Connect Site 
The Deltek Customer Care Connect site is a support Web portal for Deltek customers who 
purchase an Ongoing Support Plan (OSP).  

The following are some of the many options you have at the Customer Care Connect site: 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers 
through the Deltek Connect Customer Forums 

 Display or download product information, such as release notes, user guides, technical 
information, and white papers 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Use Quick Chat to submit a question to a Customer Care analyst online 

 Subscribe to Deltek communications about your Deltek products and services 

 Receive alerts of new Deltek releases and hot fixes 

 

If you need assistance using the Customer Care Connect site, the online help available on the 
site provides answers for most questions  
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Access Customer Care Connect 

To access the Customer Care Connect site, complete the following steps:  

1. Go to http://support.deltek.com. 

2. Enter your Customer Care Connect Username and Password. 

3. Click Log In. 

 

If you do not have a username and password for the Customer Care Connect site, contact your 
firm’s Vision system administrator. 

If you forget your username or password, you can click the Account Assistance button on the 
login screen for help. 

Additional Documentation 
The following table lists the additional Deltek documentation available for this release. Except 
where noted, all the user guides and quick reference guides listed in this table are available for 
download from the Deltek Customer Care Connect site. 

Document Name Description 

GovWin Opportunity Manager to Vision 
CRM Integration User Guide 

This guide provides information about setting up and 
using GovWin Opportunity Manager to Vision CRM 
Integration. 

 

 

http://support.deltek.com/
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Downloading GovWin Opportunity Manager to 
Vision CRM Integration Using Deltek Software 
Manager 
You can use Deltek Software Manager (DSM) to download complete Deltek products, hot fixes, 
and sub-releases. You can access DSM directly or through the Deltek Customer Care Connect 
site. 

When you access DSM directly, you will be prompted to log on before you can access the 
application. If you access DSM from within the Deltek Customer Care site, you do not have to log 
on since you are already logged into the Customer Care site. 

Accessing DSM Directly 
To access Deltek Software Manager directly, complete the following steps: 

1. On your desktop, click Start » Programs » Deltek » Vision » Deltek Software 
Manager. 

2. In the Deltek Software Manager logon dialog box, enter your Deltek Customer Care User 
ID and Password, and click Logon. 

3. To select the folder where you want to download Deltek products, click Settings above 
the right pane of Deltek Software Manager. 

 

When you log on for the first time, Deltek Software Manager asks you to select a 
default folder where Deltek products are to be downloaded.  

4. Use the Settings dialog box to specify the folder where you want to download Deltek 
products, and click OK.  

 

You can change this folder anytime in the Settings dialog box.  

5. In the left pane of Deltek Software Manager, expand Vision, if it is not already expanded.  

6. Expand your version of Vision. 

7. If you are doing a complete download of Vision, expand Complete and select the 
product. Then, in the right pane, click the Sub-Releases tab and confirm that GovWin 
Opportunity Manager to Vision CRM Integration is selected for downloading. 

If you are just downloading GovWin Opportunity Manager to Vision CRM Integration, 
expand Sub-Release, and select the check box for GovWin Opportunity Manager to 
Vision CRM Integration in the table. 

 

To view the items in the download queue, click View Download Queue at the bottom 
of the left pane.  

8. Click Download at the bottom of the left pane. Deltek Software Manager downloads the 
product to the folder that you selected.  
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Accessing DSM from within the Customer Care Connect Site 
To access Deltek Software Manager from within the Customer Care Connect site, complete 
the following steps: 

1. In your Web browser, go to http://support.deltek.com.  

2. Enter your Customer Care Connect Username and Password, and click Log In. 

3. When the Customer Care Connect site displays, click the Product Downloads tab. 

You are automatically logged into Deltek Software Manager. 

4. To select the folder where you want to download Deltek products, click Settings above 
the right pane of Deltek Software Manager. 

 

When you log on for the first time, Deltek Software Manager asks you to select a 
default folder where Deltek products are to be downloaded.  

5. Use the Settings dialog box to specify the folder where you want to download Deltek 
products, and click OK.  

 

You can change this folder anytime in the Settings dialog box.  

6. In the left pane of Deltek Software Manager, expand Vision, if it is not already expanded.  

7. Expand your version of Vision. 

8. If you are doing a complete download of Vision, expand Complete and select the 
product. Then, in the right pane, click the Sub-Releases tab and confirm that GovWin 
Opportunity Manager to Vision CRM Integration is selected for downloading. 

If you are just downloading GovWin Opportunity Manager to Vision CRM Integration, 
expand Sub-Release, and select the check box for GovWin Opportunity Manager to 
Vision CRM Integration in the table. 

 

To view the items in the download queue, click View Download Queue at the bottom 
of the left pane.  

9. Click Download at the bottom of the left pane. Deltek Software Manager downloads the 
product to the folder that you selected.  

DSM Documentation and Troubleshooting 
 To view the online help for Deltek Software Manager, click here. 

 To view a tutorial on how to use Deltek Software Manager, click here.  

 To view more information on troubleshooting Deltek Software Manager, click here. 

 

The above troubleshooting link will only work if you are logged into Deltek Customer 
Care Connect. 

http://support.deltek.com/
https://dsm.deltek.com/DeltekSoftwareManager/Help/
https://dsm.deltek.com/DeltekSoftwareManager/Tutorial/PubData/Engine/Default.htm?https%3A%2F%2Fdsm.deltek.com%2FDeltekSoftwareManager%2FTutorial%2FPubData%2F
https://deltek.custhelp.com/app/answers/detail/a_id/52469
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Prerequisites for Installing and Using GovWin 
Opportunity Manager to Vision CRM Integration 
Before you can install and use GovWin Opportunity Manager to Vision CRM Integration, you must 
do the following: 

 Install Vision 7.1 or a later version. 

 Configure Microsoft IIS Web server. (Use the applicable set of instructions in the two 
sections that follow: “Configure Microsoft IIS Web Server Configuration on Windows 
2012/2012 R2 Server” or “Configure Microsoft IIS Web Server Configuration on Windows 
2008/2008 R2 Server” below.) 

 Have a subscription to GovWin Enterprise. 

To obtain the account information required to log in as an Opportunity Manager member, 
contact your GovWin IQ account manager, and they can assist you. 

Configure Microsoft IIS Web Server Configuration on Windows 
2012/2012 R2 Server 
Perform this procedure if you are going to install Opportunity Manager integration on Windows 
Server 2012/2012 R2. The integration installer verifies that Microsoft Internet Information 
Services (IIS) is already installed before proceeding with the installation. The installation 
terminates if IIS is not yet installed. 

To configure Microsoft IIS Web server on Windows 2012/2012 R2 Server, complete the 
following steps: 

1. From the desktop view, do either of the following to display the Charm Bar: 

 Move the mouse pointer to the lower right corner of the screen. 

 Press the Windows key + C. 

 

For more information about Charm Bar, see the following: 
http://windows.about.com/od/windowsforbeginners/a/Get-To-Know-The-New-Windows-
8-Start-Menu.htm. 

2. Click Start » Administrative Tools » Server Manager. 

3. In the left pane, click IIS. 

4. In the right pane, scroll down to display the ROLES and FEATURES section. 

5. From the Tasks drop-down list, select Add Roles and Features. The Add Roles and 
Feature Wizard displays. 

6. Click Next. 

7. Select the Role-based or feature-based installation option. 

8. On the Select Destination Server page, verify that Select a server from the server pool 
option is selected, and click Next. 

9. On the Select server roles page,  

 Expand Web Server (IIS) » Web Server » Application Development, and select 
CGI and ISAPI extensions. 

http://windows.about.com/od/windowsforbeginners/a/Get-To-Know-The-New-Windows-8-Start-Menu.htm
http://windows.about.com/od/windowsforbeginners/a/Get-To-Know-The-New-Windows-8-Start-Menu.htm
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 Expand Web Server (IIS) » Web Server » Management Tools, and select IIS 
Management Scripts and Tools. 

 Expand Web server (IIS) » Web Server » Management Tools » IIS 6 Management 
Compatibility » IIS 6 Metabase Compatibility. 

10. Click Next, and click Next on the Select features page. 

11. Click Install. 

Configure Microsoft IIS Web Server Configuration on Windows 
2008/2008 R2 Server 
Perform this procedure if you are going to install Opportunity Manager integration on Windows 
Server 2008/2008 R2. The Opportunity Manager installer verifies that Microsoft Internet 
Information Services (IIS) is already installed before proceeding with the installation. The 
installation terminates if IIS is not yet installed. 

To configure Microsoft IIS Web server on Windows 2008/2008 R2 Server, complete the 
following steps: 

1. Click Start » Administrative Tools » Server Manager. 

2. Expand the Roles tree in the left pane, and click Web Server (IIS). 

3. When the Web Server (IIS) screen displays, click Add Role Services in the lower right 
pane. 

4. On the Select Role Services screen, do the following: 

 Click Web Server » Application Development, and select ISAPI Extensions and 
CGI. 

 Click Web Server » Management Tools, and select IIS Management Scripts and 
Tools. 

 Click Web Server » Management Tools » IIS 6 Management Compatibility, and 
select IIS 6 Metabase Compatibility. 

5. Click Next. 

6. Click Install. 

7. Click Close when the installation completes. 

8. Expand the Web Server (IIS) tree in the left pane, and click Internet Information 
Services (IIS) Manager. 

9. On the Internet Information Services (IIS) Manager screen, expand the IIS computer 
name icon in the left pane.  

10. Right-click the IIS computer name icon, and click Stop on the shortcut menu. 

11. Right-click the IIS computer name icon again, and click Start on the shortcut menu. 

12. Close the Services Manager window. 
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Install GovWin Opportunity Manager to Vision 
CRM Integration 
A complete GovWin Opportunity Manager to Vision CRM Integration installation requires three 
primary steps: 

1. Install the integration application on the Web/application server. 

2. Apply the OppMgrTabCreate7x.sql script to your database. 

3. Create the Opp Manager Web Service link in the Navigation pane in Vision. 

Install the Integration Application on the Web/Application Server 
When you install Opportunity Manager integration, the setup log automatically defaults to 
C:\Users\<User>\AppData\Local\Deltek\ and creates a temporary shortcut on your desktop.  
When the installation is finished, the completed log is copied to the <integration installation 
folder>\Databases\InstallLogs\ folder. (The default installation location is C:\Program Files 
(x86)\Deltek\Opportunity Manager\.) 

To install GovWin Opportunity Manager to Vision CRM Integration, complete the following 
steps: 

1. After you download the GovWin Opportunity Manager to Vision CRM Integration 
installation file (DeltekOpportunityManager10.exe) from DSM, log on to your application 
server as a local administrator. 

2. Run the installation file on the application server to launch the Opportunity Manager 
integration installation program. 

3. On the Welcome page of the wizard, click Next. 

 
4. On the License Agreement page, review the license agreement, select the I accept the 

terms of the license agreement option, and click Next. 
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5. On the Choose Destination Location page, if you will not be using the defaults, click the 

Change button and select the folder in which you want to install files, and click Next. 

 
6. On the Customer Experience Improvement Program (CEIP) page, specify if you want to 

participate and click Next.  

 
The installer begins installing the files and adding configuration settings in IIS. The 
process creates a new Opportunity Manager application pool in IIS and configures it with 
the same Default local account that the Vision core installer created.  
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Deltek Security Best Practices recommend that after installation the default account 
usernames and/or passwords be modified for security reasons. If you have made any 
such changes, you must perform the following in IIS after the installation: 

• Configure the Opportunity Manager application pool with the same Identity 
account that is running the Vision application pool. 

• Ensure that the account has at least Modify NTFS rights to the Config and 
Logs folders located in the installation path for GovWin Opportunity Manager 
to Vision CRM Integration. 

• If you configure your Opportunity Manager application in IIS with Windows 
Authentication, end users may be prompted for their credentials when they 
click the Opp Manager Web Service link in the Navigation pane in Vision. To 
avoid the prompts, they must choose the option to save their credentials when 
prompted. In some cases, they may have to add the server to the Trusted 
Sites in Internet Explorer (if that option is available).   

7. When the message below displays, click OK to continue. 

 
8. When the Installation Complete page displays, review the note at the bottom of that 

page before you click OK to finish. 

Apply the OppMgrTabCreate7x.sql Script on your Database 
After the integration application is installed, apply the OppMgrTabCreate7x.sql script to your 
database. That script updates the database for the new Opp Manager tab in the Opportunity Info 
Center. You only have to apply it once on your database.  

OppMgrTabCreate7x.sql is located in <Deltek Vision installation folder>\Databases\Scripts. (The 
default location is C:\Program Files (x86)\Deltek\Vision\Databases\Scripts\.) You may need to 
copy it to a central location if you are not going to perform the steps below from the Web server. 

 

Deltek recommends making a backup of your database before applying any database script 
changes 

You can apply the script in either of two ways: 

 Using Weblink (recommended) 

 Using SQL Management Studio 

To apply the database script using Weblink, complete the following steps: 

1. Launch Weblink. 

2. Click the Database List View tab. 
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3. Select the Select check box for the databases you want to update. 

4. Click Insert on the toolbar for the Scripts grid in the lower part of the window, and insert 
the OppMgrTabCreate7x.sql script name. 

5. Click Run Scripts on the toolbar to apply the scripts. 

To apply the database script using SQL Management Studio, complete the following steps: 

1. On a computer that has a supported version of Microsoft SQL Server, launch SQL Server 
Management Studio. 

2. Enter valid credentials to connect to your database server. 

3. Expand the Databases folder. 

4. Left-click your Vision database to select it. 

5. On the File menu of SQL Management Studio, select Open » File. 

6. Browse to and select the OppMgrTabCreate7x.sql file, and click Open to load it in the 
query window. 

7. Verify that your Vision database is selected in the upper left, and click Execute (the 
toolbar button with the red exclamation point) to apply the script. 

8. Click on the Messages tab in the lower half of the screen, and review the results to verify 
that there are no errors. 

Create the Opp Manager Web Service Navigation Pane Link in 
Vision 
The Opportunity Manager Web Service utility in Vision is used to configure the integration and to 
run or schedule the opportunity import process. To provide access to the utility, you need to add a 
link for it in the Navigation pane in Vision.  

 

The security features of the Web service require periodic changes to the passwords and will only 
accept connections from your firm’s Web server IP address. Before performing the steps below, 
make sure that your IP address has been submitted to GovWin IQ Product Management to allow 
the connections. 

To create the Opp Manager Web Service navigation link, complete the following steps: 

1. Log in to Vision. 

2. Click the Navigation Tree Designer icon in the bottom-right corner of the Navigation pane. 
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3. In the Navigation Tree Designer dialog box, expand Utilities and Advanced Utilities. 

   
4. Right-click one of the utilities under Advanced Utilities, and click Insert After on the 

shortcut menu. 

  
5. In Menu Label, enter Opp Manager Web Service. 

6. If you want to assign an icon to the link, select the icon in Icon. 

7. In Action, select HTTP. 

8. In Open under Action Options, enter the URL for displaying the Opportunity Manager 
Web Service utility. 

This entry must be in the following format: 

http://<servername[:port]>/<installation folder>/DisplayLogs.aspx?NID=<encrypted 
Opportunity Manager network ID> 

Example:  

http://server1/OpportunityManager/DisplayLogs.aspx?NID=<encrypted Opportunity 
Manager network ID> 
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The default port number in http traffic is 80. When you enter the URL in NavTree 
Designer, you do not need to include the port number if you are using the default, as in 
the example above. 

Be sure you include your network ID. 

 
9. Click OK. 

10. Close and restart Vision, and verify that GovWin Opportunity Manager to Vision CRM 
Integration is installed, as described on page 14. 

11. In the Navigation pane in Vision, click Configuration » Security » Roles. 

12. On the General tab of the Roles form, verify that all roles for users who will use the 
Opportunity Manager Web Service utility have access to the new Navigation pane link 
that you just created. 

 

The implementation is not complete and the integration cannot be used until you specify the 
settings on the Configuration tab of the Opportunity Manager Web Service utility.  

For information on how to fill out the fields on the Configuration tab, refer to the GovWin 
Opportunity Manager to Vision CRM Integration User Guide. 

If you have any questions, contact Deltek Customer Care. 
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Verify that GovWin Opportunity Manager to Vision 
CRM Integration Is Installed 
To verify that GovWin Opportunity Manager to Vision CRM Integration is installed, 
complete the following steps: 

1. Click Help » About on the Vision toolbar. 

2. Click the Details button on the About dialog box. 

3. Verify that Vision Opportunity Manager Integration is displayed in the Additional 
Components Installed list. 

4. Click Utilities » Advanced Utilities » Opp Manager Web Service. 

5. Verify that the GovWin Opportunity Manager Integration form displays. 

 

The implementation is not complete and the integration cannot be used until you specify the 
settings on the Configuration tab of the Opportunity Manager Web Service utility.  

For information on how to fill out the fields on the Configuration tab, refer to the GovWin 
Opportunity Manager to Vision CRM Integration User Guide. 

If you have any questions, contact Deltek Customer Care. 

 

 



 

 

 

Deltek is the leading global provider of enterprise software and information solutions for professional 
services firms, government contractors, and government agencies. For decades, we have delivered 
actionable insight that empowers our customers to unlock their business potential. Over 14,000 
organizations and 1.8 million users in approximately 80 countries around the world rely on Deltek to 
research and identify opportunities, win new business, optimize resource, streamline operations, and deliver 
more profitable projects. Deltek – Know more. Do more.®  

deltek.com 
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