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Overview 
The Costpoint to Cobra Integration automates the loading of actual costs from Costpoint to Cobra. Deltek 
currently only supports the integration using Cobra web services. Prior to the implementation of this 
method, the integration process used the legacy CostpointCobra.exe API. 

Cobra Web Services 
The integration supports two versions of web services to post valid transactions from Costpoint to Cobra. 
Use the following web services depending on your Costpoint and Cobra versions: 

 Standard Cobra Web Service (Cobra.WebService.Host.exe) — This version of the web 
service can be leveraged by multiple Deltek products for data integration. The Standard Cobra 
Web Service added the support for the Costpoint to Cobra Integration in Cobra 8.2 Cumulative 
Update #14 or higher. If you have Costpoint 7.1.1 with System JAR 054 or higher, you must 
use the Standard Cobra Web Service. 

 Cobra Costpoint Web Service (Cobra.Costpoint.WebService.Host.exe) — This is the initial 
version of the web service which only supports the Costpoint to Cobra Integration. Deltek 
provides this web service in Cobra 5.1 (SP1) HotFix #11 or higher; and Cobra 8 or higher. The 
Cobra Costpoint Web Service is no longer supported in the Costpoint 7.1.1 System JAR 054 or 
higher. 

Costpoint 7.0.1 Users 
If you have configured your system for integration using CostpointCobra.exe API (legacy API) prior to 
upgrading to Cobra 5.1 SP1 HotFix #11/Cobra 8 and you want to use the Cobra web services for 
integration, you do not need to modify/remove your existing settings. You only need to install the required 
hotfixes for using Cobra web services and complete the procedures for enabling the use of Cobra web 
services. 

 

Existing integration users can refer to the following sections for more information on enabling 
Cobra Web Service for integration: 

 Hot Fix Requirements for Integration Using Cobra Web Service 

 Deploy the Cobra Costpoint Web Service (Cobra.Costpoint.WebService.Host.exe) 

 Enter the Connection Settings on the Costpoint Configuration Utility 

CostpointCobra.exe API (Legacy API) 
Using the CostpointCobra.exe API is the legacy approach of running the Costpoint to Cobra integration. 
Prior to the release of integration through the Cobra web services, this process was only possible through 
the use of CostpointCobra.exe API. 

 

 

Warning: Integration through CostpointCobra.exe is no longer supported in Costpoint 7.1.1. In 
addition, this method of integration was de-supported in Costpoint 7.0.1 as of December 1, 2014. 

Tip: Only use CostpointCobra.exe API if you integrate with Cobra 5.1 SP1 HotFix 10 or earlier. Deltek 
recommends that you use Cobra Web Service if you integrate with Cobra 5.1 SP1 HotFix 11 or 
higher; and Cobra 8 or higher. 
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Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® Reader® X 
provides this ability. If you do not already use Adobe Reader X, you can download it here free from 
Adobe.  

To add a custom note using Adobe Reader X, complete the following steps: 
1. On the Reader toolbar, click Comment at the far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to match the 
button. 

3. Position the cursor at the location in the guide where you want the note to appear, and click. A 
note icon is inserted at the location and a text box pops up. 

4. Enter your information in the text box.   

5. Continue adding notes as needed. 

6. Save the document. 

 
When reading the document, cursor over a note icon to see the information. Double-click a note icon to 
edit the information. 

Note: Deltek recommends that you save the document to a slightly different filename so as to keep 
the original from being overwritten. 

http://get.adobe.com/reader/
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Downloading Deltek Products using Deltek 
Software Manager 
You can use Deltek Software Manager (DSM) to download complete Deltek products, hot fixes, 
cumulative updates, and sub-releases. You can access DSM through the Deltek Support Center or use 
Deltek Software Manager Lite to download Deltek products. 

Accessing DSM from within the Deltek Support Center 
To access DSM from within the Deltek Support Center: 

1. In your Web browser, go to https://deltek.custhelp.com.  

2. Enter your Deltek Support Center Username and Password, and click Login. 
3. When the Deltek Support Center page displays, click Product Downloads. 

4. On the Deltek Software Manager screen, click Launch Deltek Software Manager. 
5. Click Settings at the top right of the dialog box to use the Settings dialog box to specify the folder 

where you want to download Deltek products, and click OK.  

 
6. In the left pane, expand the Deltek product that you want to download, if it is not already 

expanded.  

7. Select the product type that you want to download.  

Options include: 

 Complete 
 Cumulative Updates 
 HotFixes 
 Sub-Release 

8. In the table, select the check box that corresponds to the Deltek product that you want to 
download.  

The right pane displays a message stating that the product has been added to the download 
queue. 

 
9. Click Download at the bottom of the left pane to download the product to the folder that you 

selected.  

Note: When you log on for the first time, DSM asks you to select a default folder where 
Deltek products are to be downloaded. 

You can change this folder anytime in the Settings dialog box. 

Note: To view the items in the download queue, click View Download Queue at the bottom 
of the left pane. 

https://deltek.custhelp.com/
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Accessing DSM Lite 
To access Deltek Software Manager Lite: 

1. In your Web browser, go to https://dsm.deltek.com/DeltekSoftwareManagerLite.  

2. Enter your Deltek Support Center Username and Password, and click Logon. 
3. When the Deltek Software Manager Lite page displays, select a product from the drop-down list. 

4. Click the product type that you want to download.  

 

DSM Documentation and Troubleshooting 
 To view the online help for Deltek Software Manager, click here. 

 To view a tutorial on how to use Deltek Software Manager, click here.  

 To view more information on troubleshooting Deltek Software Manager, click here. 

 

Note: The download behavior and download folder may differ depending on the browser and 
browser settings that you are using. 

Note: When you click a link, you will be asked to log into DSM if you aren’t already logged in. 

https://dsm.deltek.com/DeltekSoftwareManagerLite
https://dsm.deltek.com/DeltekSoftwareManager/Help/
https://deltek.custhelp.com/app/answers/detail/a_id/50668
https://deltek.custhelp.com/app/answers/detail/a_id/52469
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Minimum System Requirements 
Before performing your installation, make sure the following are installed, configured, and running in your 
system: 

Supported Costpoint Versions 

Costpoint Version Compatible Cobra Version 

Deltek Costpoint 7.1.1 
with System JAR 054 or 
higher 

Deltek Cobra 8.2 with Cumulative Update #14 or higher 

 

Deltek Costpoint 7.1.1 
with System JAR 053 or 
lower 

Deltek Cobra 8 or higher 

Deltek Cobra 5.1 (SP1 HotFix #11 or higher) 

Deltek Costpoint 7.0.1 Deltek Cobra 8 or higher 

Deltek Cobra 5.1 (SP1 HotFix #11 or higher) 

Deltek Costpoint 7.0 Deltek Cobra 8 or higher 

Deltek Cobra 5.1 (SP1 HotFix #11 or higher) 

Supported Cobra Versions 

Cobra Version Compatible Costpoint Version 

Deltek Cobra 8 or higher Deltek Costpoint 7.1.1 

Deltek Costpoint 7.0.1 

Deltek Costpoint 7.0 

Deltek Cobra 5.1 (SP1 
HotFix #11 or higher) 

Deltek Costpoint 7.1.1 

Deltek Costpoint 7.0.1 

Deltek Costpoint 7.0 

HotFix Requirements for Integration Using Cobra Web 
Service  
To use the Cobra Web Service for integration between Costpoint and Cobra, you must apply the hotfixes 
and files listed in this section in your Costpoint and Cobra systems. Refer to the following table for the 
required hotfixes for your Costpoint and Cobra versions: 

Warning: If you upgrade your Costpoint installation to 
System JAR 054 (June 2019 release), you must upgrade 
to Cobra version 8.2 with Cumulative Update #14 or 
higher in order for the integration to function. 
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Product Name HotFix Information 

Costpoint 7.1.1 No required hotfixes. However, Deltek recommends to keep your 
Costpoint 7.1.1 hotfix installations up to date. 

Costpoint 7.0.1 Install the following hotfixes for Costpoint 7.0.1: 

 AOMCBEXT (Manage Cobra Extraction Parameters) — 
cp701_aomcbext_001.zip (or higher) 

 AOPCBLAB (Compute Cobra Burden Costs) — 
cp701_aopcblab_004.zip (or higher) 

 Deltek Costpoint 7.0.1 Framework Update — 
DeltekCostpoint701FrameworkUpdate_009.exe (or higher) 

 SYSTEM.ZIP - Costpoint Version 7.0.1 — 
cp701_sys_023.zip (or higher) 

Cobra 8 No required hotfixes. However, Deltek recommends to keep your 
Cobra 8 hotfix installations up to date. 

Cobra 5.1 (GA) Cobra 5.1 (SP1) HotFix #11 (or higher) – Build 5.01.1752 — 
DeltekCobra51SP1HotFix11.zip (or higher) 

 

Note: Each of the hotfix package in this list includes installation/deployment instructions for various 
deployment types. You must use the instructions that apply to your deployment scenario. 
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Set Up the Integration to Use Cobra Web Services 

 
This section provides a step-by-step overview of the entire process to successfully set up and run the 
Costpoint to Cobra integration process. 

Note: This section is applicable only if you are using the following Costpoint and Cobra versions: 

 Costpoint 7.1.1, or 7.0.1 

 Cobra 8 or later; or Cobra 5.1 SP1 HotFix 11 or later 

Set up the Integration Connection Settings

See the "Enter the Connection Settings on the Costpoint Configuration Utility" section.

Deploy the (a) "Standard Cobra Web Service" OR the (b) "Cobra Costpoint Web Service."

(a) See the "Deploy Standard Cobra Web Service 
(Cobra.WebService.Host.exe)" section.

(b) See the "Deploy the Costpoint Cobra Web 
Service (Cobra.Costpoint.WebService.Host.exe)" 

section.

Restore and Test the Integration Configuration File

See the "Restore and Test the Integration Configuration File in Cobra" section.

Enable JDBC Distributed Transactions.

See the "Enable JDBC Distributed Transactions through JTA and XA Transactions" section.

Ensure all the required sofware and hotfixes are installed and operational.

See the "Minimum System Requirements" section.
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Enable JDBC Distributed Transactions through JTA and XA 
Transactions 
This section provides instructions for enabling your Cobra Microsoft SQL Server (MSS) database to 
support Java Database Connectivity (JDBC) distributed transactions through the Java Transaction 
Application Programming Interface (JTA). Your Cobra server must support JDBC distributed transactions 
to communicate with your Costpoint system. This procedure also enables your Cobra database to support 
XA transactions. Perform these procedures on the server that hosts your Cobra MSS database. 

You must perform these steps if: 
 Your Cobra database uses a Microsoft SQL Server; OR 

 Your Costpoint MSS database and Cobra MSS database use different servers. 

 

To enable JDBC distributed transactions and XA transactions, complete the following steps: 
1. Make a backup of your MSS master database. 

2. Download the Costpoint 7.1.1/7.0.1 Database Tier installation file to your Cobra MSS database 
server. 

 
3. Click Start » Run and enter the following command: 

<File Directory>\<Costpoint Database Tier File Name> /enableXA  

Where: 

<File Directory> is the folder that contains the installation file. For example, C:\. 
<Costpoint Database Tier File Name> is the name of the Costpoint Database tire 
installation file. For example, DeltekCostpoint711DatabaseTier.exe 

4. On the Microsoft SQL Server for Deltek Costpoint 7.1.1/7.0.1 Database Information screen, 
perform the following: 

 Port — Enter the port that your Cobra database server software uses to listen for requests. 
The default port for Microsoft SQL Server is 1433. 

Note: You can skip this procedure if your Cobra database uses an Oracle server or if both your 
Costpoint MSS database and Cobra MSS database use the same server. 

Note: The file name of the Costpoint Database Tier installation may vary depending on the latest 
version available for download on DSM for your Costpoint version.  

Costpoint 7.1.1 File Name Examples: 

 DeltekCostpoint711DatabaseTier.exe 

 DeltekCostpoint711DatabaseTier_Build05.exe 

Costpoint 7.0.1 File Name Examples: 

 DeltekCostpoint701DatabaseTier.exe 

 DeltekCostpoint701DatabaseTier_Build04.exe 

For more information on downloading the Deltek Costpoint 7.1.1/7.0.1 Database Tier installation file, 
please refer to the Downloading Deltek Products using Deltek Software Manager section. You can find 
the installation file under the available downloads for Costpoint 7.1.1/7.0.1.  
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 Instance Name — Enter the name of your Cobra database instance.  

 SA User — Enter the name of your Microsoft SQL Server SA user. The default is sa. 

 SA Password — Enter the password for your Microsoft SQL Server SA user. 

5. Click Test Connection. If you enter the proper database connection information, the “Connection 
Successful. Click Next.” message displays. If this message does not display, correct the 
information entered and click Test Connection again. After the messages appears, click Next > 
to begin the installation. 

 
6. When the installation has completed, the “Successfully configured XA transactions.” message 

displays. Click OK. 

Restore and Test the Integration Configuration File in Cobra 
The integration between Costpoint and Cobra relies on an integration configuration file which comes with 
the Cobra installation. This configuration file must be restored into Cobra before using the integration. 

Cobra uses the configuration as a template during the loading of actual costs. Certain values, such as the 
project name and actual cost transaction file, are supplied by Costpoint at runtime. Other settings in the 
configuration can be used to control how you want the actual costs to be loaded.  

 

Restore the Costpoint Integration Configuration File 
You must restore the CostpointConfig.icd file using the Restore Integration Configuration dialog box in 
Cobra. 

To configure the Costpoint to Cobra Integration tool, complete the following steps: 
1. Log on to the Cobra application. 

2. Open the Restore Integration Configuration dialog box. 

 For Cobra 8, click the Cobra button » Manage » Restore. 

 For Cobra 5, on the Cobra menu bar, click File » Manage Files » Restore File.  

3. Select the CostpointConfig.icd file from the <Cobra Installation Directory> Samples\Backups\ 
directory. If the CostpointConfig.icd file does not appear, change the file type to Integration 
Configuration Definition Backups (*.icd). 

 
4. On the Restore Integration Configuration dialog box, make sure that the CostpointConfig.icd file is 

selected and then click Restore. 

Note: This install could take a long time to complete. Please do not interrupt it. It will display 
the following: “Restarting the Distributed Transaction Coordinator (MSDTC) Service...” 

Attention: For more information, refer to the Importing Actual Costs into Cobra topic in the Cobra 
online help. 

Note: The Costpoint to Cobra process uses this configuration as a template. The main 
options in the configuration are not used by the process (Project name, fields, and so on). 
Performing the following steps confirms that the configuration exists, and the options that are 
not overwritten are set correctly. 



Set Up the Integration to Use Cobra Web Services 

Technical Guide 10 

 

Test the Costpoint Integration Configuration 
After restoring the integration configuration file, you should test the configuration by loading a valid Actual 
Cost file to a valid Project. 

To test the configuration, complete the following steps: 
1. On Cobra, open the Integration Wizard for loading actual costs. 

 For Cobra 8, click Integration tab » Actual Costs. 

 
 For Cobra 5.1, click File » Integration to display the Integration Wizard. Select the Actual 

costs option, and click Next. 
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2. On the Integration Configuration page, select the Open an existing configuration option, and 
choose the restored CostpointConfig configuration file, and click Next. 
 Cobra 8: Integration Wizard, Integration Configuration Page 

 
 Cobra 5.1: Integration Wizard, Integration Configuration Page 
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3. On the File Selection page, select a Project and an Actual cost file, and click Next. 
 Cobra 8: Integration Wizard, File Selection Page 

 
 Cobra 5.1: Integration Wizard, File Selection Page 

 

 

Note: Make sure to select a valid project and actual cost file because these options are 
overwritten during the Costpoint to Cobra integration. You can locate the actual cost file in 
the following location: <Cobra Installation Directory> Samples\Transaction Files. 
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4. On the Field Mapper page, select the File contains header row option, and click Next.  
 Cobra 8: Integration Wizard, Field Mapper Page 

 
 Cobra 5.1: Integration Wizard, Field Mapper Page 

 

 
 

Note: If you encounter errors, set the invalid columns to <Ignore>. The field definitions 
selected are also overwritten. These definitions are not used when the tool runs. 
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5. On the Class and Results page, select options based on the actual costs being loaded and then 
click Next. 
 Cobra 8: Integration Wizard, Class and Results Page 

 
 Cobra 5.1: Integration Wizard, Class and Results Page 
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6. On the Included Costs page, select options based on the actual costs being loaded and then click 
Next. 
 Cobra 8: Integration Wizard, Included Costs Page 

 
 Cobra 5.1: Integration Wizard, Included Costs Page 
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7. On the Options page, select options based on the actual costs being loaded and then click Next. 
 For Cobra 8: Integration Wizard, Options Page 

 
 For Cobra 5.1: Integration Wizard, Options Page 
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8. On the Save and Load page, select the Save your configuration? check box, leave the 
configuration name as it appears and then click Next. 
 For Cobra 8: Integration Wizard, Save and Load Page 

 
 For Cobra 5.1: Integration Wizard, Save and Load Page 

 

 
9. On the Access Control page, enable users or groups to access the integration configuration that 

you are creating and then click Next. 

Note: When prompted to overwrite the existing configuration, click Yes. 
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10. Click Finish. Cobra will run the integration process and will load actual costs from the specified 
field into the specified Cobra project. 

Deploy the Standard Cobra Web Service (Cobra.WebService. 
Host.exe) 

 
The Standard Cobra Web Service (Cobra.WebService.Host.exe) is a windows service-hosted web 
service that you must install on a machine that has a Cobra installation. If you use an n-tier deployment, 
Deltek recommends that you deploy the web service on the n-tier application server. 

Obtain the Cobra Web Server Authentication Certificate Information 
The Costpoint integration with the Standard Cobra Web Service requires the use of HTTPS. You must: 

 Obtain the Server Authentication Certificate Thumbprint. 

 Obtain the Server Authentication Certificate Subject. 

 Export the associated root and intermediate certificates for later import into the Costpoint Java 
Trust Keystore. 

To obtain the Subject and Thumbprint details, complete the following steps: 
1. Open the Certificates MMC Snap-In and go to the following folder location: Certificates (Local 

Computer) » Personal » Certificates.  

2. Open the Windows Server Certificate intended for Server Authentication.  

 
3. On the Details tab of the certificate, copy the following:  

 Thumbprint — Remove all spaces and save this information for the binding steps. 

 Subject — This is usually the fully qualified name of the server. Save this information for the 
Costpoint configuration. 

 
4. Click the Certification Path tab, select the root certificate at the top of the path, and click View 

Certificate.  

Warning: Perform this procedure if you have Costpoint 7.1.1 with System JAR 054 or higher.  
You must upgrade to at least Cobra 8.2 Cumulative Update #14 or higher to use the Standard 
Cobra Web Service for the data integration from Costpoint to Cobra. 

Attention: For more information, refer to: https://docs.microsoft.com/en-
us/dotnet/framework/wcf/feature-details/how-to-view-certificates-with-the-mmc-snap-in. 

If your server does not have a certificate, you need to obtain one before continuing this 
procedure. For more information, refer to: https://docs.microsoft.com/en-
us/dotnet/framework/wcf/feature-details/how-to-obtain-a-certificate-wcf. 

Attention: For more information, refer to: https://docs.microsoft.com/en-
us/dotnet/framework/wcf/feature-details/how-to-retrieve-the-thumbprint-of-a-certificate. 

https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-view-certificates-with-the-mmc-snap-in
https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-view-certificates-with-the-mmc-snap-in
https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-obtain-a-certificate-wcf
https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-obtain-a-certificate-wcf
https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-retrieve-the-thumbprint-of-a-certificate
https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-retrieve-the-thumbprint-of-a-certificate
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5. On the root certificate window, click the Details tab and then click Copy to File. Save a file using 
the DER encoded binary X.509 (.CER) format. This file will be used for Costpoint connection 
configuration. 

6. Perform similar steps (step 4-5) for any intermediate certificates that may be in the path between 
the root and the server. 

Bind the Windows Server Certificate to the Cobra Web Service Port 

You must bind the Server Authentication Certificate to the Cobra Web Service HTTPS port. 

 

To bind the certificate to the port, complete the following steps: 
1. Click Start » All Programs » Accessories, right-click Command Prompt, and click Run as 

administrator. The command prompt opens with administrative rights. 

2. Enter the following command: 
netsh http add sslcert ipport=0.0.0.0:<port> certhash=<server certificate 
thumbprint> appid={857f24c8-58fc-4102-98d7-d11ecaa9be39} 

Where: 
 <port> is the HTTPS port on which you choose to run the Cobra Web Service. For example, 

8122, which is the default Cobra Web Service HTTPS port as shown in the next section. 

 <server certificate thumbprint> is the Server Authentication Certificate Thumbprint saved 
earlier. For example, 69dbb276109a62d90c0d1d436ddc2278ea56d86e. 

Edit the Standard Web Service Configuration File  
You must change the Standard Cobra Web Service URL value from localhost to the name of your Cobra 
application server name in the Cobra.WebService.Host.exe.config file. 

To edit the Standard Cobra Web Service configuration file, complete the following steps: 
1. On your Cobra application server, go to the Cobra installation directory. For example, 

C:\Program Files\Deltek\Cobra 5, or C:\Program Files\Deltek\Cobra. 

2. Locate the Cobra.WebService.Host.exe.config file and then open the file in Notepad or another 
text editor. 

3. In the Cobra.WebService.Host.exe.config file, locate the <baseAddresses> tags, change 
localhost to the name of your Cobra application server, and set the correct TCP port number. 

For example: 
Change the following text: 
<baseAddresses> 

<add baseAddress="http://localhost:8116/CobraWebService" /> 

<add baseAddress="https://localhost:8122/CobraWebService" /> 

</baseAddresses> 

Attention: For more information, refer to: https://docs.microsoft.com/en-
us/dotnet/framework/wcf/feature-details/how-to-configure-a-port-with-an-ssl-certificate. 

https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-configure-a-port-with-an-ssl-certificate
https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-configure-a-port-with-an-ssl-certificate
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To: 
<baseAddresses> 

<add baseAddress="http://<certificate subject>:8116/CobraWebService" /> 

<add baseAddress="https://<certificate subject>:8122/CobraWebService" /> 

</baseAddresses> 

Where:  

 <certificate subject> is the Server Authentication Certificate Subject saved 
earlier. For example, cobrawebserver.company.com. 

 Port 8116 is the default HTTP port for Cobra web service and you can change this 
setting to avoid conflicts. 

 Port 8122 is the default HTTPS port for Cobra web service and you can change this 
setting to avoid conflicts. 

 
4. Save your changes and close the file. 

Install the Standard Cobra Web Service 
After editing the configuration file, you must install the Standard Cobra Web Service 
(Cobra.WebService.Host.exe) as an administrator. 

To install the Standard Cobra Web Service, complete the following steps: 
3. Click Start » All Programs » Accessories, right-click Command Prompt, and click Run as 

administrator. The command prompt opens with administrative rights. 

4. Enter the following command: 
<Cobra Install Directory>\Cobra.WebService.Host.exe –install  

Where: 
<Cobra Install Directory> is the location of Cobra on your machine. For example, 
C:\Program Files\Deltek\Cobra 5 or C:\Program Files\Deltek Cobra. 

5. Go to Start » Control Panel » Administrative Tools, and open Services. 

6. From the list of services, right-click Cobra Web Service and then click Restart. 

7. Open a web browser and enter the Standard Cobra Web Service URL (<baseAddress> value 
from the Cobra.WebService.Host.exe.config file) in the address bar. The following page should 
display: 

Warning: If you use PM Compass-specific services on the same server, you must use a 
different port for the Cobra web service for Costpoint integration. Running PM Compass-
specific services and the Costpoint-specific services on the same port will cause conflicts. 
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Deploy the Cobra Costpoint Web Service (Cobra.Costpoint. 
WebService.Host.exe) 

 
The Cobra Costpoint Web Service (Cobra.Costpoint.WebService.Host.exe) is the initial version of Cobra 
web service which only supports integration with Costpoint. This is a windows service-hosted web service 
which you must install on a machine that has a Cobra installation. If you use an n-tier deployment, Deltek 
recommends that you deploy the web service on the n-tier application server. 

Warning: If you get a “Page not found” error, and you are running PM Compass-specific 
services and the Costpoint-specific services on the same server, you may be encountering 
conflicting ports. To correct this issue, complete the following steps: 

1. Ensure that the Cobra web service for Costpoint integration is using a different port. 
For more information on changing the port number in the 
Cobra.WebService.Host.exe.config file, see the Edit the Standard Cobra Web 
Service Configuration File section. 

2. Restart the Costpoint Web Service. 

Warning: The Cobra Costpoint Web Service is not supported in Costpoint 7.1.1 with System JAR 
054 or higher. If you have this Costpoint version, you must deploy the Standard Cobra Web Service 
instead. For more information refer to Deploy the Standard Cobra Web Service (Cobra.WebService. 
Host.exe).  
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Edit the Cobra Costpoint Web Service Configuration File  
You must change the Cobra Costpoint Web Service URL value from localhost to the name of your Cobra 
application server name in the Cobra.Costpoint.WebService.Host.exe.config file. 

To edit the Cobra Costpoint Web Service configuration file, complete the following steps: 
5. On your Cobra application server, go to the Cobra installation directory. For example, 

C:\Program Files\Deltek\Cobra 5, or C:\Program Files\Deltek\Cobra. 

6. Locate the Cobra.Costpoint.WebService.Host.exe.config file and open the file in Notepad or 
another text editor. 

7. In the Cobra.Costpoint.WebService.Host.exe.config file, locate the <baseAddresses> tags, 
change localhost to the name of your Cobra application server, and set the correct TCP port 
number. 

For example: 
Change the following text: 

<baseAddresses> 

 <add baseAddress="http://localhost:8000/CobraWebService/service" /> 

</baseAddresses> 

To: 
<baseAddresses> 

 <add baseAddress="http://COBRAMACHINENAME:8000/CobraWebService/service" 
/> 

</baseAddresses> 

Where:  

 COBRAMACHINENAME is the name of your Cobra application server. 

 Port 8000 is the default port for Cobra Costpoint Web Service and you can change this 
setting to avoid conflicts. 

 
8. Save your changes and close the file. 

Install the Cobra Costpoint Web Service 
After editing the configuration file, you must install the Cobra Costpoint Web Service 
(Cobra.Costpoint.WebService.Host.exe) as an administrator. 

To install the Cobra Costpoint Web Service, complete the following steps: 
1. Click Start » All Programs » Accessories, right-click Command Prompt, and click Run as 

administrator. The command prompt opens with administrative rights. 

2. Enter the following command: 
<Cobra Install Directory>\Cobra.Costpoint.WebService.Host.exe –install  

Where: 

Warning: If you use PM Compass-specific services on the same server, you must use a 
different port for the Cobra Web Service for Costpoint integration. Running PM Compass-
specific services and the Costpoint-specific services on the same port will cause conflicts. 
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<Cobra Install Directory> is the location of Costpoint on your machine. For example, 
C:\Program Files\Deltek\Cobra 5 or C:\Program Files\Deltek Cobra. 

3. Go to Start » Control Panel » Administrative Tools, and open Services. 

4. From the list of services, right-click Cobra Costpoint Web Service and then click Restart. 

5. Open a Web browser and enter the Cobra Costpoint Web Service URL (<baseAddress> value 
from the Cobra.Costpoint.WebService.Host.exe.config file) in the address bar. The following page 
should display: 

 

 

Configure the Costpoint Connections to Cobra 
The connectivity information for Costpoint integrations need to be set up in the Costpoint Configuration 
Utility. Use the Costpoint Configuration Utility to create a Cobra database connection and also to enable 
integration using the Cobra Web Service. 

Import the Root and Intermediate Certificates into the Trust Keystores  
In order for Costpoint to verify the Cobra Web Server Authentication Certificate, the Root and 
Intermediate certificates (certificate chain) must be accessible in the following trust keystores:  

 Java Standard Trust Keystore for the Costpoint Configuration Utility  

Warning: If you get a “Page not found” error, and you are running PM Compass-specific 
services and the Costpoint-specific services on the same server, you may be encountering 
conflicting ports. To correct this issue, complete the following steps: 

1. Ensure that the Cobra web service for Costpoint integration is using a different port. 
For more information on changing the port number in the 
Cobra.Costpoint.WebService.Host.exe.config file, see the Edit the Cobra Costpoint 
Web Service Configuration File section. 

2. Restart the Cobra Costpoint Web Service. 
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 Configured Trust Keystore for WebLogic 

 

To import the certificates into the trust keystores, complete the following steps:  
1. Click Start » All Programs » Accessories, right-click Command Prompt, and click Run as 

administrator. The command prompt opens with administrative rights.  

2. Enter the following command to set the environment for using keytool:  
<Costpoint Install Directory>\71\bin\CPWebSetEnv.cmd 

3. Enter the following command to import the root certificate into the Standard Java Trust Keystore:  
keytool -import -v -noprompt -trustcacerts -alias <server_domain>_root -file 
<root_cert_file>.cer -keystore 
D:\oracle\jdk1.8.0_212\jre\lib\security\cacerts -storepass changeit 

4. Enter the following command to import the intermediate certificate(s) into the Standard Java Trust 
Keystore:  

keytool -import -v -noprompt -trustcacerts -alias 
<server_domain>_intermediate -file <intermediate_cert_file>.cer -keystore 
D:\oracle\jdk1.8.0_212\jre\lib\security\cacerts -storepass changeit 

5. Enter the following command to import the root certificate into the Demo Trust Keystore:  
keytool -import -v -noprompt -trustcacerts -alias <server_domain>_root -file 
<root_cert_file>.cer -keystore 
D:\Oracle\Middleware12.2.1.3\wlserver\server\lib\DemoTrust.jks -storepass 
DemoTrustKeyStorePassPhrase 

6. Enter the following command to import the intermediate certificate(s) into the Demo Trust 
Keystore:  

keytool -import -v -noprompt -trustcacerts -alias 
<server_domain>_intermediate -file <intermediate_cert_file>.cer -keystore 
D:\Oracle\Middleware12.2.1.3\wlserver\server\lib\DemoTrust.jks -storepass 
DemoTrustKeyStorePassPhrase 

Where: 

 <server_domain> is the Active Directory Domain of your Costpoint application server. 

 <root_cert_file> is the name you assigned the root certificate file when exporting. 

 <intermediate_cert_file> is the name you assigned the intermediate certificate file when 
exporting. 

 

Configure Connection to Cobra Database 
When configuring the integration in Costpoint, you need to identify the Cobra project that is linked your 
Costpoint data. If you want to use the Lookup function in Costpoint to select the Cobra project, you must 

Tip: The default Trust Keystore for WebLogic is the Demo Trust Keystore. If your Costpoint 
installation is using a different Trust Keystore for WebLogic, you need to modify the 
references to the DemoTrust.jks file in the commands below. You will also need to ensure 
you are using the correct path to your JDK and WebLogic keystore files. 

Note: You will need to restart all WebLogic servers for the changes in certificates to take effect. 
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connect Costpoint to the Cobra database. If you do not create a Cobra database connection, you have to 
manually enter the Cobra project name. 

 

To configure the Cobra Interface connection, complete the following steps: 
1. Click Start » All Programs » Costpoint 7.1.1 (or 7.0.1) » Start Costpoint 7.1.1 (or 7.0.1) 

Config Utility to launch the Costpoint Configuration Utility.  

 
2. On the Costpoint Configuration Utility startup screen (where you are asked to select your 

configuration options), select the Costpoint Application Configuration check box and then click 
Next. The available tabs in the utility displays. 

3. Click Costpoint tab » System Integrations tab » Cobra tab. 

4. Click the Use DB Cobra Integration with Costpoint check box and then enter the connection 
information for Cobra database in the following fields in the Cobra DB Connection Information 
group box: 

 Database Vendor — Select Oracle® or Microsoft® SQL Server®, depending on the database 
vendor you are using.  

 Host — Enter the host name or IP address for the database server.  
 Port — Enter the port number where the database server is listening. 

 User — Enter the database user name. 
 Password and Confirm Pas — Enter and confirm the database password associated with 

the user name entered in the User field. 
 URL — This field displays the resulting JDBC URL that will be used to connect to the 

database server. 

5. Click Test to verify the information you entered. This performs a simple database connection test. 

 

Configure Costpoint Connection to Cobra Web Service 
To use the Cobra Web Service for Costpoint to Cobra Integration, you must enter the correct settings in 
the Cobra tab on the Costpoint Configuration Utility. 

Warning: Creating a Cobra database connection is not applicable if you have Costpoint 7.1.1 with 
System JAR 054 or higher. 
Since the validation of the Cobra project name only occurs when the integration runs, manually 
entering the Cobra project name may cause errors during integration if you misspell the project and 
reference a project that does not exist. 

The Cobra database connection will only work if both Costpoint and Cobra are installed in the same 
network (On-premise). It will not work on Costpoint Cloud. 

Attention: You can also open the utility by running the CPWebConfigUtility.cmd batch file in 
the Costpoint installation directory (for example, C:\Deltek\Costpoint\71\bin). 

Note: The utility creates two JDBC Connection pools that appear on the Weblogic tab, click 
Save. Please make sure you have successfully tested the custom database connection 
before saving. Restart the WebLogic servers for the changes to take effect. 
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To change settings in the Costpoint Configuration Utility, complete the following steps: 
1. Click Start » All Programs » Costpoint 7.1.1 (or 7.0.1) » Start Costpoint 7.1.1 (or 7.0.1) 

Config Utility to launch the Costpoint Configuration Utility. 

 
2. On the Costpoint Configuration Utility startup screen (where you are asked to select your 

configuration options), select the Costpoint Application Configuration check box, and click 
Next. The available tabs in the utility displays. 

3. Click Costpoint tab » System Integrations tab » Cobra tab and then use the following settings 
in the Cobra Integration Connection Information group box: 

 Use Cobra Integration — Select this check box to enable Costpoint to Cobra integration. 

 Cobra Web Service URL — Enter the URL for the Cobra Web Service.  
For example:  
Costpoint 7.1.1 with System JAR 054 or higher: 

https://<certificate subject>:8122/CobraWebService/Costpoint 

Where: 

<certificate subject> is the Server Authentication Certificate Subject saved 
earlier. For example, cobrawebserver.company.com. 

 
Costpoint 7.1.1 with System JAR 053 or lower: 

http://COBRAMACHINENAME:8000/CobraWebService/Service 

Where: 
COBRAMACHINENAME is the name of your Cobra application server. 

 User — Enter the Cobra user name. You may use the SYSADMIN user. If you choose 
another user, make sure that that user has administrative rights in Cobra. 

 Password and Confirm Password — Enter the Cobra password. 
 Data Source Key — Use the default setting. 
 Configuration Name — Enter CostpointConfig. 
 Integration Owner — Enter the owner of the restored Costpoint Integration Configuration file 

(CostpointConfig.icd) in Cobra.  

 
4. Click Test to verify the information you entered. This performs a simple connection test. 

Attention: You can also open the utility by running the CPWebConfigUtility.cmd batch file in 
the Costpoint installation directory (for example, C:\Deltek\Costpoint\71\bin). 

Attention: For more information, see the Restore the Costpoint Integration Configuration File 
section. 

If you restore the backup configuration that ships with Cobra, the owner will be SYSADMIN. If 
you connect as the SYSADMIN user (in the User and Password fields), you do not need to 
specify a value in this field. 
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5. Save your changes and exit the Costpoint Configuration Utility. 

 
 

Note: You will need to restart all WebLogic servers or run the Rebuild Global Settings (SYPSTNG) 
application for your Cobra integration connection information changes to take effect. 
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Costpoint to Cobra Integration Process 
This section provides an overview of the process of loading actual costs from Costpoint to Cobra. 

 

Cobra Configuration 
The following procedure must be performed in the Cobra application server. 

Rename Cost Class and Project ID in Cobra 
Before you can import actual costs from Costpoint, you will need to adjust the cost class and project ID 
values in Cobra. Since Costpoint only supports two characters for cost class and eight characters for 
project ID, you need to perform the following: 

 Limit the Actuals cost class length to two characters. 

 Limit project ID length to eight characters or less. 

 Rename Actual cost class to AC. 

A set of SQL scripts has been included with Cobra which enable this process. The RenameClass.SQL 
script is located in the following folder: <Cobra Installation Directory>\Samples\Scripts. 

 

To rename cost class and project ID in Cobra, complete the following steps: 
1. Locate the RenameClass.SQL script in the following folder: <Cobra Installation 

Directory>\Samples\Scripts folder.  

2. Open in RenameClass.SQL in a text editor (for example, Notepad), and edit the three SET 
statements near the top of the SQL script file. The variables for the SET statements are: 

SET vpcOldClass='Actual'; 

SET vpcNewClass='AC'; 

SET vpcProgram='Cobra v5 project name'; 

3. Save and close the RenameClass.SQL file. 

4. Start Cobra, and click Tools » SQL Command Utility from the main menu. 

5. On the SQL Command Utility window, click Open. You are prompted to locate for a .SQL file. 

6. Browse for the RenameClass.SQL, and click Open. 

7. Click Execute. 

Note: This section provides a general overview of the Costpoint to Cobra Integration. For more 
information about the available options in each of the screens mentioned in this section, please refer 
to the Online Help available in Costpoint and Cobra. 

Before performing the steps in this section, you need to follow the instructions in the previous 
sections to ensure that your system is configured properly for integration with between Costpoint and 
Cobra. 

Note: <Cobra Installation Directory> represents the folder where the Cobra application is installed. 
For example, C:\Program Files\Deltek\Cobra\Samples\Scripts folder. 
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Costpoint Configuration 
The following procedures must be performed in Costpoint. 

Set the Correct Mapping Mode Options 
The Manage Cobra Charge Templates screen is used to initialize and define mapping of default and/or 
project-specific Costpoint fields or charge elements to Cobra charge element code values. On this 
screen, you need to select the Sample Cobra Project option in the Mapping Mode group box if there is 
a link to the Cobra database. If there is no link available, select the Manual Mode option. 

 
These mapping settings must be consistent with the settings on the Manage Project User Flow, Manage 
Organization Elements, and Manage Cobra Resource Templates screens. 

Select the Correct Options for the Transaction File 
The Costpoint to Cobra Integration creates a .csv transaction file using the settings on the Manage Cobra 
Extraction Parameters screen. You will need to set the correct import options on this screen for the 
transaction file.  

To set the correct option for the transaction file, complete the following steps: 
1. Go to the Manage Cobra Extraction Parameters screen in Costpoint (Administration » System 

Administration » System Administration Interfaces). 

2. Clear the Advance Calendar check box in the Cobra Import/File Settings group box. 

3. Select the Generate File Only check box. 

4. Select the remaining extraction parameters as required by the Cobra project that is interfacing 
with Costpoint. 

When you run the Cobra extraction, the format of the .csv file should resemble the following: 

Cobra Fields 
Project 
Name 

Key 
Field 1 

Key 
Field 2 

Key 
Field 
3 

Resource Cost 
Class 

Cost 
Date 

Hours Direct COMG
A 

COMOH GANDA FEE 

ProjName 4K18B.0
00.100 

  103A1 AC 01/15/2
009 

18 319 0.53 3.23 126 400 

ProjName 4K18B.0
00.100 

  106A2 AC 01/15/2
009 

59.5 1509 2.5 15.2 593 1894 

ProjName 4K18B.0
00.100 

  107A1 AC 01/15/2
009 

109.5 1838 2.54 17.4 676 2293 

Project Names are only required if the .CSV file will be imported into a master project in Cobra. The 
previous Cobra Import/File settings mentioned is used when setting up the interface with a Master 
Project. 

Note: Only the key fields for the project will be enabled in the Cobra Key Fields column when you 
select the Sample Cobra Project option. No validation of field names will occur if you select the 
Manual Mode option. 
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At least one Key Field must exist in the .csv file, with use of the additional Key Fields optional based on 
Cobra project requirements. Use of the Class and Cost Date fields are also optional based on Cobra 
project requirements. 

Integration Process Overview 

Step 1: Create the Default Charge, Resource, and Cost Templates 
The purpose of these templates is to map the Costpoint structures to the Cobra structures. The structure 
of each Cobra project is highly configurable by a user. You can use a key data field such as work 
package or WBS in one Cobra project in a different way (or not at all) in another Cobra project. In order to 
load actual costs from Costpoint to Cobra, the information must be defined or linked to the Cobra data. 
These templates make it easy to replicate linking across projects. 

 Charge Templates — These templates are initialized and maintained in the Manage Cobra 
Charge Templates screen and identify how the Costpoint project/organization information is 
linked to the Cobra control account or work package. You can link the Project ID, Project ID less 
Level 1, Project Abbreviation, Project/Organization ID combination, Project User-defined fields, or 
Project less Level 1/Organization ID combination in Costpoint to a work package or work package 
code (if you are collecting costs at the work package level in Cobra) or to the WBS, WBS and 
OBS combination, or a code on the control account in Cobra. Create as many charge templates 
as you need to establish the linkages for all Costpoint projects and Cobra projects. 

 Resource Templates — These templates are initialized and maintained in the Manage Cobra 
Resource Templates screen and are used to establish the relationship between Costpoint labor 
and non-labor information and Cobra resources. Using this template, you create a labor rule for 
mapping Costpoint labor charge information to Cobra resources using PLCs, GLCs, Employee 
ID, Project Labor Category User-Defined fields, or an Advanced SQL definition. Skill-based bid 
codes used to determine average labor rates for estimating in Cobra are examples of Cobra 
resources that can be linked to Costpoint GLCs or PLCs. 

You should consider using GLCs to link resources if you are a first time user. Under most 
circumstances you must avoid using employee ID to link resources as you must adjust the budget 
or explain variances each time there is a staff change. For non-labor accounts, Cobra does not 
generally require the same level of detail for non-labor accounts as is required in Costpoint. You 
can link most Costpoint non-labor accounts to one Cobra resource. However, you must address 
the needs of each Cobra project and Costpoint project individually. 

 
 Cost Templates — These templates are initialized and maintained on the Manage Cobra Cost 

Templates screen and are used to map Costpoint hours, direct costs, indirect cost pools, and 
Cost of Money (COM) to Cobra results. The Hours and Direct cost elements in Costpoint cannot 
be edited but can be mapped to the same Cobra result, if available, or another Cobra result that 
serves the same function. Most companies have multiple fringe, overhead, and general and 
administrative pools in Costpoint. Generally this level of detail is not necessary in Cobra and 
many fringe and overhead pools can be mapped to one Cobra result. 

Note: You can use wildcard characters to link Costpoint non-labor accounts to Cobra 
resources. 
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Step 2: Set the Software Location, Output File Location, and Default 
Templates 
On the Configure Cobra Interface Settings screen, you need to specify the location of your Cobra 
Software Location and your output file folders. The location of your Cobra software and output folders 
must be already be set up in Manage Alternate File Location screen. 

 
You can also select default charge, resource, and cost templates on the Configure Cobra Interface 
Settings screen after you create them in their respective screens (see Step 1: Create the Default Charge, 
Resource, and Cost Templates). 

Step 3: Create the Cobra to Costpoint Project Map 
This optional step links the Costpoint projects to the Cobra projects. You can perform this step on the 
Manage Cobra Project Mapping screen. It is only required if the Cobra project is different from the 
Costpoint top-level project number and/or you want to send the project data at a level above the level 
where the data is recorded in Costpoint. See the online help on Manage Cobra Project Mapping screen 
for more information. 

Step 4: Create Extractions 
You can create extractions on the Manage Cobra Extraction Parameters screen in Costpoint. The 
parameter IDs that you enter when you create the extractions are used in the Compute Cobra Burden 
Cost screen. Use the extraction parameter tool to associate the templates and other options to Costpoint 
projects and Cobra run-time options. You can create as many parameters as you need for all Costpoint 
projects and Cobra projects. 

In addition to the templates, there are several other features that you can use to load data into Cobra: 

 Values — Use this feature to establish the values to be used in the extraction: Hours Only, Hours 
and Labor Dollars, Hours and Direct Dollars, and Hours and Total Dollars. 

 Rates — Use this feature to choose whether to use target or actual rates for the burden costs to 
be loaded into Cobra. 

 Timeframe — Use this feature to choose the timeframe for which you want to collect actual costs 
in Costpoint. The options are sub-period, period, and inception-to-date. Use the sub-period 
feature to extract actual costs for the sub-period to analyze the progress of the project. 

 Calendar — Use this feature to specify whether or not to automatically advance the Cobra 
calendar. 

 Post Valid Transactions — Use this feature to specify whether or not to load data for valid 
records only. Records containing errors are automatically written to the error log and can be 
reprocessed at a later time.  

 Use Cobra Web Service — This check box is only available in Costpoint 7.0.1. Select this 
check box if you want to use Cobra Web services to transfer data when your run the 
Compute Cobra Burden Cost process. If this check box is not selected, the Compute Cobra 
Burden Cost process uses the locally installed Costpoint to Cobra application 
(CostpointCobra.exe) to transfer data. 

Note: If you are integrating using Cobra Web Service, the specified output folders must also be 
accessible from the Cobra server by the login account associated with the "Cobra Web Service” 
service. 
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 Use Asynchronous Call —Select this check box if you want the invocation of the Cobra 

Web service to be asynchronous. In this case, the Compute Cobra Burden Cost process will 
not wait for the Cobra Web service to finish the transaction. When the request is sent, the 
Compute Cobra Burden Cost process continues to run and not wait for responses from Cobra 
Web services.  

If this check box is not selected, the invocation of the Cobra Web service will be 
synchronous. This means the Compute Cobra Burden Cost process waits for the Cobra Web 
Services to be done with transactions. The Cobra Burden Cost process receives responses 
from the Web service before continuing to run. 

 Replace Cost Classes — Use this feature to generate forecasts based on booked actual costs. 
You can replace a single class or all classes to run special extractions. 

 Create a CSV File — Use this feature to save the extractions in CSV format. 

Step 5: Initialize the Maintain Prior Year Cobra Costs 
You must initialize the Manage Prior Year Cobra Costs screen before you run the extraction process to 
extract inception-to-date actual costs from Costpoint. This allows you to archive prior year costs. 

 

Step 6: Run the Compute Cobra Burden Costs Process 
Costpoint calculates burden at the project/account/organization level but Cobra requires burden at the 
resource level (employee/PLC/GLC). The Compute Cobra Burden Cost screen process uses the Manage 
Project labor History (LAB_HS table for labor and PROJ_SUM for non-labor) to calculate burden at the 
resource level for projects that have been identified as Cobra projects. 

 
The Compute Cobra Burden Cost process performs following functions: 

 Computes burden at the resource level using the data on the Manage Project Labor History 
screen 

 Updates the Cobra Direct and Indirect tables in Costpoint with the sub-period, period, fiscal year, 
year-to-date labor, non-labor, and indirect costs and updates prior year information if the copy 
prior flag is checked. 

 Updates the fiscal year, period, and sub-period in the Cobra Interface Settings screen. 

Note: For Costpoint 7.0.1 users: If you are not setup to use the CostpointCobra.exe for 
integration, ensure that the Use Cobra Web Service check box is also selected when 
the Post Valid Transactions check box is selected. Otherwise, an error will occur when 
you run the Cobra Extraction process for the extraction parameter ID. 

Note: This step is only necessary when you are implementing the interface in the middle of a 
project’s performance. It is not needed for new projects. 

Note: You can establish a project as a Cobra project on the Manage Project User Flow screen by 
selecting the Cobra Project check box. Please refer to the Manage Project User Flow online help for 
more information. 
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Step 7: Run the Cobra Extraction 
You can run the Cobra extraction on the Compute Cobra Burden Costs screen by selecting the Compute 
Cobra Burden and Run Cobra Extraction option in the Extraction group box. You will need to enter a 
Cobra Extraction Parameter ID that you create on Manage Cobra Extraction Parameter screen. The 
Cobra extraction process runs after computing burden costs. 
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Integration Troubleshooting 
You can access log files that were created after the Costpoint to Cobra data integration process and then 
use the information to troubleshoot issues. 

View Cobra Log Information 
The integration stores warnings and errors encountered during the process in a file in the Cobra log 
directory. You can view the information in these logs by accessing the Process Logs dialog box in Cobra. 

To view the Process Logs in Cobra, complete the following steps: 
1. Launch Cobra and open Process Logs.  

 For Cobra 8, click Tools tab » Process Logs. 

 For Cobra 5.1, click Tools » Process Logs. 

2. From the Process drop-down list, select Integration Actual Costs to filter Costpoint to Cobra 
integration-related logs. 

  
3. Click a log entry from the list and click View Log. 

Cobra Log File Location 
In case a corresponding log entry is not listed in the Cobra Process Log dialog box, you can try to access 
the log files created by the Cobra Web Services in the Cobra log directory (For example, 
C:\Deltek\Cobra\Logs\ServerDebuglog.xml).  
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Appendix A: If You Need Assistance 
If you need assistance installing, implementing, or using the Costpoint to Cobra integration, Deltek makes 
a wealth of information and expertise readily available to you. 

Customer Services 
For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems, 
listening to their needs, and getting to know their individual business environments. A full range of 
customer services has grown out of this close contact, including the following: 

 Extensive self-support options through the Deltek Support Center. 

 Phone and email support from Customer Care analysts 

 Technical services 

 Consulting services 

 Custom programming 

 Classroom, on-site, and Web-based training 

 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 
 Search for product documentation, such as release notes, install guides, technical information, 

online help topics, and white papers 
 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 

Deltek Support Center Community 
 Access Cloud-specific documents and forums 
 Download the latest versions of your Deltek products 
 Search Deltek’s knowledge base 
 Submit a support case and check on its progress 
 Transfer requested files to a Customer Care analyst 
 Subscribe to Deltek communications about your products and services 
 Receive alerts of new Deltek releases and hot fixes 
 Initiate a Chat to submit a question to a Customer Care analyst online 

 

Attention: Find out more about these and other services from the Deltek Support Center. 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 



Appendix A: If You Need Assistance 

Technical Guide 36 

 

Access Deltek Support Center 
To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 
 

 

 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/


 

 

About Deltek 
Better software means better projects. Deltek is the leading global provider of enterprise software and 
information solutions for project-based businesses. More than 23,000 organizations and millions of users 
in over 80 countries around the world rely on Deltek for superior levels of project intelligence, 
management and collaboration. Our industry-focused expertise powers project success by helping firms 
achieve performance that maximizes productivity and revenue. www.deltek.com 

http://www.deltek.com/
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