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Create/Delete Intercompany Receivables 

Accounting » General Ledger » Multi-Company 
Processing » Create/Delete Intercompany 
Receivables 

Print Intercompany Receivable Edit Report Not in Costpoint Web 
Accounting » General Ledger » Multi-Company 
Processing » Print Intercompany Receivable Edit 
Report 

Post Intercompany Receivables Accounting » Process » Post » Post Intercompany 
Receivables 

Accounting » General Ledger » Multi-Company 
Processing » Post Intercompany Receivables 

Journal Entries (JEs) 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » Journal Entries (JEs) 

Maintain Recurring JE Templates Not in Costpoint Web 
Accounting » General Ledger » Journal Entry 
Processing » Manage Recurring Journal Entry 
Templates 

Create Recurring JEs Accounting » Process » General Ledger » Create 
Recurring Journal Entries 

Accounting » General Ledger » Journal Entry 
Processing » Create Recurring Journal Entries 
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Enter JEs Accounting » Transactions » Journal Entries » 
Enter Journal Entries 

Accounting » General Ledger » Journal Entry 
Processing » Manage Journal Entries 

Create Purchase Order Accruals Accounting » Process » General Ledger » Create 
Purchase Order Accruals 

Accounting » General Ledger » Journal Entry 
Processing » Create Purchase Order Accruals 

Create Subcontract PO Retention Accruals Accounting » Process » General Ledger » Create 
Subcontract PO Retention Accruals 

Accounting » General Ledger » Journal Entry 
Processing » Create Subcontract Purchase Orders 
Retention Accruals 

Create Travel Commitment Accruals Accounting » Process » General Ledger » Create 
Travel Commitment Accruals Not in Costpoint 7.0 

Create Revaluation Entry Not in Costpoint Web Accounting » General Ledger » Journal Entry 
Processing » Create Revaluation Entry 

Print JE Edit Reports Accounting » Review » General Ledger » Journal 
Entry Edit Report 

Accounting » General Ledger » Journal Entry 
Processing » Print Journal Entry Edit Report 

Reverse Posted JE Accounting » Process » General Ledger » Reverse 
Posted Journal Entry 

Accounting » General Ledger » Journal Entry 
Processing » Reverse Posted Journal Entry 

JE Approvals & Posting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » JE Approvals & Posting 

Print Pending JEs Report Accounting » Review » General Ledger » Pending 
Journal Entries Report 

Accounting » General Ledger » Journal Entry 
Processing » Print Pending Journal Entries Report 

Approve Journal Entries Accounting » Transactions » Journal Entries » 
Approve Journal Entries 

Accounting » General Ledger » Journal Entry 
Processing » Approve Journal Entries 

Print Approved JE Listing Accounting » Review » General Ledger » Approved 
JE Listing 

Accounting » General Ledger » Journal Entry 
Processing » Print Approved Journal Entries Report 
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Post JEs Accounting » Process » Post » Post Journal Entries Accounting » General Ledger » Journal Entry 
Processing » Post Journal Entries 

Print JE Posting Summaries Accounting » Review » General Ledger » Journal 
Entry Posting Summary Report 

Accounting » General Ledger » Journal Entry 
Processing » Print Journal Entry Posting Summary 
Report 

Budgets 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » Budgets 

Maintain Budget Revisions Not in Costpoint Web Accounting » General Ledger » General Ledger 
Budgets » Manage Budget Revisions 

Maintain Org/Account Budgets Not in Costpoint Web 
Accounting » General Ledger » General Ledger 
Budgets » Manage Organization/Account 
Budgets 

Print G/L Budgets Not in Costpoint Web Accounting » General Ledger » General Ledger 
Budgets » Print General Ledger Budgets 

Inquiry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » Inquiry 

Account Activity Inquiry Accounting » Review » General Ledger » Account 
Activity Inquiry 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » View Account Activity 

G/L Inquiry Accounting » Review » General Ledger » General 
Ledger Inquiry 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » View General Ledger Activity 
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G/L Inquiry-Budget and Prior Year Comparison Accounting » Review » General Ledger » G/L 
Budget and Prior Year Comparison Inquiry 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Compare General Ledger 
Actual to Budget Activity 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » Reports 

Create General Ledger Report Tables Accounting » Process » General Ledger » Create 
General Ledger Report Tables 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Create General Ledger Report 
Tables 

Create Preliminary Cash Flows Statement Not in Costpoint Web 
Accounting » General Ledger » General Ledger 
Reports/Inquiries » Create Preliminary Cash Flow 
Statements 

Edit Preliminary Cash Flows Statement Accounting » Transactions » Cash Flow » Edit 
Preliminary Cash Flows Statement 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Manage Preliminary Cash Flow 
Statements 

Print Financial Statements Accounting » Review » General Ledger » Financial 
Statements Report 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print Financial Statements 

Print Financial Statement Detail Accounting » Review » General Ledger » Financial 
Statement Detail Report 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print Financial Statement Detail 
Report 

Print Trial Balance Accounting » Review » General Ledger » Trial 
Balance Report 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print Trial Balance Report 

Print Project Trial Balance Accounting » Review » General Ledger » Project 
Trial Balance Report 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print Project Trial Balance 
Report 

Print General Ledger Posting Summary Accounting » Review » General Ledger » General Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print General Ledger Posting 
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Ledger Posting Summary Report Summary Report 

Print General Ledger Detail Accounting » Review » General Ledger » General 
Ledger Detail Report 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print General Ledger Detail 
Report 

Print Project Ledger Detail Accounting » Review » General Ledger » Project 
Ledger Detail Report 

Accounting » General Ledger » General Ledger 
Reports/Inquiries » Print Project Ledger Detail 
Report 

Sales and Value Added Tax Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » Sales And Value Added Tax Reporting 

Update Tax Report Tables Not in Costpoint Web Accounting » General Ledger » Sales and Value 
Added Tax Processing » Update Tax Report Tables 

Sales/VAT Reporting Accounting » Review » Sales and Value Added Tax 
» Value Added Tax Report 

Accounting » General Ledger » Sales and Value 
Added Tax Processing » Print Sales/Value Added 
Tax Report 

Intra EC Trade Statistics Report Not in Costpoint Web 
Accounting » General Ledger » Sales and Value 
Added Tax Processing » Print Intra European 
Community Trade Statistics Report 

Tax Reporting Status by Transaction Accounting » Review » Sales and Value Added Tax 
» Tax Status by Transaction Report 

Accounting » General Ledger » Sales and Value 
Added Tax Processing » View Tax Reporting 
Status by Transaction 

Tax Reporting Status by Tax Account Not in Costpoint Web 
Accounting » General Ledger » Sales and Value 
Added Tax Processing » View Tax Reporting 
Status by Tax Account 
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Month-End Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger » Month-End Processing 

Close Periods Not in Costpoint Web Accounting » General Ledger » Company Calendar 
» Close Periods 

Update G/L Beginning Balances Not in Costpoint Web 
Accounting » General Ledger » General Ledger 
Beginning Balances » Update General Ledger 
Beginning Balances 

Beginning Balances 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger »  Beginning Balances 

Maintain Non-Project Beginning Balances Accounting » Utilities » General Ledger Tools » 
Non-Project Beginning Balances 

Accounting » General Ledger » General Ledger 
Beginning Balances » Manage Non-Project 
Beginning Balances 

Maintain Project Beginning Balances Not in Costpoint Web 
Accounting » General Ledger » General Ledger 
Beginning Balances » Manage Project Beginning 
Balances 

Maintain Reference Beginning Balances Not in Costpoint Web 
Accounting » General Ledger » General Ledger 
Beginning Balances » Manage Reference 
Beginning Balances 

Maintain Prior Year Non-Project Comparative 
Balances Not in Costpoint Web 

Accounting » General Ledger » General Ledger 
Beginning Balances » Manage PY Non-Project 
Comparative Balances 

Maintain Prior Year Project Comparative Balances Not in Costpoint Web Accounting » General Ledger » General Ledger 
Beginning Balances » Manage Prior Year Project 
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Comparative Balances 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » General Ledger »  Utilities 

Update Financial Statement Summary Balances Accounting » Utilities » General Ledger Tools » 
Update Financial Statement Summary Balances 

Accounting » General Ledger » General Ledger 
Utilities » Update Financial Statement Summary 
Balances 

Update Reference Summary Balances Not in Costpoint Web Accounting » General Ledger » General Ledger 
Utilities » Update Reference Summary Balances 

Labor History to General Ledger Comparison Accounting » Utilities » General Ledger Tools » 
Labor History to General Ledger Comparison 

Accounting » General Ledger » General Ledger 
Utilities » Print Labor History to General Ledger 
Comparison Report 

Purge Intercompany Receivables Not in Costpoint Web Accounting » General Ledger » General Ledger 
Utilities » Purge Intercompany Receivables 

Purge JE History Not in Costpoint Web Accounting » General Ledger » General Ledger 
Utilities » Purge Journal Entry History 

Defer Unposted Transactions Not in Costpoint Web Accounting » General Ledger » General Ledger 
Utilities » Defer Unposted Transactions 

Miscellaneous Toolkits » Update Beginning Bank 
Statement Balances* Not in Costpoint Web 

Accounting » Cash Management » Cash 
Management Utilities » Update Beginning Bank 
Statement Balances 

* The function formerly available in the Miscellaneous Toolkits screen has been broken out into a standalone application in Costpoint 7.0. 
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Accounts Payable 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable »  Controls 

A/P Settings Administration » Configure » Accounting » A/P 
Settings 

Accounting » Accounts Payable » Accounts 
Payable Controls » Configure Accounts Payable 
Settings 

Check Settings Not in Costpoint Web Accounting » Accounts Payable » Accounts 
Payable Controls » Configure Check Settings 

A/P Accounts Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Controls » Manage Accounts Payable 
Accounts 

Cash Accounts Accounting » Maintain » Accounts » Cash Accounts Accounting » Accounts Payable » Accounts 
Payable Controls » Manage Cash Accounts 

Vendor Settings Not in Costpoint Web 
Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Configure Vendor 
Settings 

Vendor Terms Not in Costpoint Web Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Manage Vendor Terms 

Maintain Credit Card Upload Info Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Controls » Manage Credit Card Import 
Information 

Maintain Subcontractor Insurance Types Accounting » Configure » Vendors » Subcontractor 
Insurance Types 

Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Manage Subcontractor 
Insurance Types 

Maintain Subcontractor Bond Types Accounting » Configure » Vendors » Subcontractor Accounting » Accounts Payable » Vendor and 
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Bond Types Subcontractor Controls » Manage Subcontractor 
Bond Types 

Maintain Insurance Carrier Information Accounting » Configure » Vendors » Insurance 
Carrier Information 

Accounting » Accounts Payable » Accounts 
Payable Controls » Manage Insurance Carrier 
Information 

A/P Voucher Settings Administration » Configure » Accounting » A/P 
Voucher Settings 

Accounting » Accounts Payable » Accounts 
Payable Controls » Configure Accounts Payable 
Voucher Settings 

PO Voucher Settings Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Controls » Configure Purchase Order 
Voucher Settings 

Approver Settings Administration » Configure » Accounting » A/P 
Approver Settings 

Accounting » Accounts Payable » Accounts 
Payable Controls » Configure Approver Settings 

Vendor Approver Settings Administration » Configure » Accounting » Vendor 
Approver Settings 

Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Configure Vendor 
Approver Settings 

Recurring AP Voucher Codes Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Controls » Manage Recurring A/P Voucher 
Codes 

Vendor User-Defined Labels Not in Costpoint Web 
Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Manage Vendor User-
Defined Labels 
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Vendor Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Vendor Info 

Maintain Vendors Materials » Maintain » Vendors » Vendor User Flow Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Maintain Vendor EFT Info Accounting » Maintain » Vendors » Vendor EFT 
Info 

Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Maintain Vendor Employees Materials » Maintain » Vendors » Vendor User Flow Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Maintain Vendor Credit Card Info Accounting » Maintain » Vendors » Vendor Credit 
Card Information 

Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Vendor User-Defined Info Accounting » Maintain » Vendors » Vendor User-
Defined Information 

Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Approve Vendors Accounting » Maintain » Vendors » Approve 
Vendors 

Accounting » Accounts Payable » Vendors » 
Approve Vendors 

Maintain Subcontractor Insurance Accounting » Maintain » Vendors » Subcontractor 
Insurance 

Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Maintain Subcontractor Bonds Accounting » Maintain » Vendors » Subcontractor 
Bonds 

Accounting » Accounts Payable » Vendors » 
Manage Vendors 

Maintain Subcontractor Liens Accounting » Maintain » Vendors » Subcontractor 
Liens 

Accounting » Accounts Payable » Vendors » 
Manage Vendors 
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Vendor Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Vendor Reports 

Print Vendor Listing Not in Costpoint Web Accounting » Accounts Payable » Vendors » Print 
Vendor List 

Print Vendor Information Reports Not in Costpoint Web Accounting » Accounts Payable » Vendors » Print 
Vendor Information Report 

Print Vendor Bank info Report Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Vendor Bank 
Information Report 

Print Subcontractor Information Report Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Subcontractor 
Information Report 

Vouchers 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Vouchers 

Create Recurring A/P Vouchers Not in Costpoint Web 
Accounting » Accounts Payable » Voucher 
Processing » Create Recurring Accounts Payable 
Vouchers 

Enter A/P Vouchers Accounting » Transactions » Vouchers » Enter A/P 
Vouchers 

Accounting » Accounts Payable » Voucher 
Processing » Manage Accounts Payable Vouchers 

Enter PO Vouchers Accounting » Transactions » Vouchers » Enter PO 
Vouchers 

Accounting » Accounts Payable » Voucher 
Processing » Manage Purchase Order Vouchers 

Create PO Vouchers from POs/Receipts Not in Costpoint Web Accounting » Accounts Payable » Voucher 
Processing » Create PO Vouchers from 
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POs/Receipts 

Create Subcontract PO Vouchers Not in Costpoint Web 
Accounting » Accounts Payable » Voucher 
Processing » Create Subcontract Purchase Order 
Vouchers 

Reverse Posted Vouchers Accounting » Transactions » Vouchers » Reverse 
Posted Vouchers 

Accounting » Accounts Payable » Voucher 
Processing » Reverse Posted Vouchers 

Print Voucher Edit Accounting » Review » Vouchers » Voucher Edit 
Report 

Accounting » Accounts Payable » Voucher 
Processing » Print Voucher Edit Report 

Print Duplicate Invoices Not in Costpoint Web Accounting » Accounts Payable » Voucher 
Processing » Print Duplicate Invoices 

Create Debit Memos Accounting » Transactions » Vouchers » Create 
Debit Memos 

Accounting » Accounts Payable » Voucher 
Processing » Create Debit Memos 

Print Debit Memos Accounting » Transactions » Vouchers » Print Debit 
Memos 

Accounting » Accounts Payable » Voucher 
Processing » Print Debit Memos 

Recompute and Print Discrepancies Accounting » Process » Vouchers » Recompute PO 
Voucher Discrepancies 

Accounting » Accounts Payable » Voucher 
Processing » Recompute and Print Discrepancies 

Voucher Approvals & Posting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Voucher Approvals & Posting 

Print Pending Vouchers Report Accounting » Review » Vouchers » Pending 
Vouchers Report 

Accounting » Accounts Payable » Voucher 
Processing » Print Pending Vouchers Report 

Approve Vouchers Accounting » Transactions » Vouchers » Approve 
Vouchers 

Accounting » Accounts Payable » Voucher 
Processing » Approve Vouchers 

Print Approved Voucher Listing Accounting » Review » Vouchers » Approved Accounting » Accounts Payable » Voucher 
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Voucher List Processing » Print Approved Voucher List 

Post Vouchers Accounting » Process » Post » Post Vouchers Accounting » Accounts Payable » Voucher 
Processing » Post Vouchers 

Prepare/Approve Checks 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Prepare/Approve Checks 

Update Pay When Paid Voucher History Not in Costpoint Web 
Accounting » Accounts Payable » Payment 
Processing » Update Pay When Paid Voucher 
History 

Select Vouchers Accounting » Process » Pay » Select Vouchers Accounting » Accounts Payable » Payment 
Processing » Select Vouchers For Payment 

Edit Payment Status by AP Account Accounting » Process » Pay » Edit Voucher 
Payment Status 

Accounting » Accounts Payable » Payment 
Processing » Edit Voucher Payment Status 

Edit Payment Status by Vendor Accounting » Process » Pay » Edit Voucher 
Payment Status 

Accounting » Accounts Payable » Payment 
Processing » Edit Voucher Payment Status 

Approve Checks Accounting » Transactions » Checks » Approve 
Checks 

Accounting » Accounts Payable » Payment 
Processing » Approve Checks 

Print Prepayment Edit Accounting » Process » Pay » Prepayment Edit 
Report 

Accounting » Accounts Payable » Payment 
Processing » Print Prepayment Edit Report 
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EFT 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » EFT 

Print EFT Pre-Transfer Edit Report Accounting » Process » Pay » EFT Pre-Transfer 
Edit Report 

Accounting » Accounts Payable » Payment 
Processing » Print EFT Pre-Transfer Edit Report 

Create EFT File Not in Costpoint Web Accounting » Accounts Payable » Payment 
Processing » Create EFT File 

Print EFT Edit Report Accounting » Process » Pay » EFT Edit Report Accounting » Accounts Payable » Payment 
Processing » Print EFT Edit Report 

Print Checks 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Print Checks 

Print/Void Checks Accounting » Process » Pay » Print/Void A/P 
Checks 

Accounting » Accounts Payable » Payment 
Processing » Print/Void Checks 

Record Manual Checks Accounting » Transactions » Checks » Record 
Manual Checks 

Accounting » Accounts Payable » Payment 
Processing » Manage Manual Checks 

Record Unusable Checks Not in Costpoint Web Accounting » Accounts Payable » Payment 
Processing » Manage Unusable Checks 

Post Cash Disbursements Accounting » Process » Post » Post Cash 
Disbursements 

Accounting » Accounts Payable » Payment 
Processing » Post Cash Disbursements 
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Lien Waiver Processing and Information 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Lien Waiver Processing and Information 

Maintain Lien Waiver Document Names Not in Costpoint Web 
Accounting » Accounts Payable » Lien Waiver 
Controls » Manage Lien Waiver Document 
Names 

Maintain Project Waiver Information Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Manage Project Waiver Information 

Print Lien Waivers Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Print Lien Waivers 

Maintain Lien Waiver Information Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Manage Lien Waiver Information 

CIS Vouchers 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » CIS Vouchers 

Maintain CIS Voucher History Not in Costpoint Web Accounting » Accounts Payable » Payment 
Processing » Manage CIS Voucher History 

Record Spoilt CIS Vouchers Not in Costpoint Web Accounting » Accounts Payable » Payment 
Processing » Manage Spoilt CIS Vouchers 
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Inquiry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Inquiry 

Vendor History Inquiry Accounting » Review » Vendors » Vendor History 
Inquiry 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » View Vendor History 
Inquiry 

Check History Inquiry Accounting » Review » Accounts Payable » A/P 
Check History Inquiry 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » View Check History 
Inquiry 

Voucher History Inquiry Accounting » Review » Vouchers » Voucher History 
Inquiry 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » View Voucher History 
Inquiry 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Reports 

Voucher Register Accounting » Review » Vouchers » Voucher 
Register 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Voucher Register 
Report 

Open A/P Report Accounting » Review » Accounts Payable » Open 
A/P Report 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Open Accounts 
Payable Report 

Cash Requirements Report Supplemental Amounts Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Controls » Manage Cash Requirements 
Rpt Supplemental Amounts 

Cash Requirements Report Accounting » Review » Accounts Payable » Cash Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Cash 
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Requirements Report Requirements Report 

Check Register Accounting » Review » Accounts Payable » Check 
Register 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Check Register 
Report 

Print AP History Report Accounting » Review » Accounts Payable » A/P 
History Report 

Accounting » Accounts Payable » Accounts 
Payable Reports/Inquiries » Print Accounts Payable 
History Report 

Year-End Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Year-End Processing 

Create 1099 Information Not in Costpoint Web Accounting » Accounts Payable » Year-End 
Processing » Create 1099 Information 

Print 1099 Edit Report Not in Costpoint Web Accounting » Accounts Payable » Year-End 
Processing » Print 1099 Edit Report 

Edit 1099 Information Not in Costpoint Web Accounting » Accounts Payable » Year-End 
Processing » Edit 1099 Information 

Print 1099s/Create Magnetic Media Not in Costpoint Web 
Accounting » Accounts Payable » Year-End 
Processing » Print/Create 1099s and Magnetic 
Media 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Payable » Utilities 

Maintain Vendor History Not in Costpoint Web Accounting » Accounts Payable » Accounts 
Payable Utilities » Manage Vendor History 

Maintain Check History Accounting » Utilities » Transaction History » 
Initialize Check History 

Accounting » Accounts Payable » Accounts 
Payable Utilities » Manage Check History 

Purge Vouchers Not in Costpoint Web Accounting » Accounts Payable » Accounts 
Payable Utilities » Purge Vouchers 

Company Credit Card Transaction Upload Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Import Company Credit 
Card Transactions 

Miscellaneous Toolkits » Initialize 1099 Line Types* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Reorder Vendor Address 
Line Information* Not in Costpoint Web 

Accounting » Accounts Payable » Accounts 
Payable Utilities » Update Vendor Address Line 
Information 

Miscellaneous Toolkits » Electronic Funds Transfer 
(EFT) File Conversion* Not in Costpoint Web 

Accounting » Accounts Payable » Accounts 
Payable Utilities » Convert EFT File to Non-US 
Format 

Miscellaneous Toolkits » Update Vendor Default 
Account Descriptions* Not in Costpoint Web 

Accounting » Accounts Payable » Accounts 
Payable Utilities » Update Vendor Default Account 
Descriptions 

Miscellaneous Toolkits » Update Discount Method 
for Posted Vouchers* Not in Costpoint Web 

Accounting » Accounts Payable » Accounts 
Payable Utilities » Update Discount Method for 
Posted Vouchers 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 
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Accounts Receivable 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Controls 

A/R Settings Administration » Configure » Accounting » A/R 
Settings 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Configure Accounts 
Receivable Settings 

Set System Assigned Cash Receipt Number Not in Costpoint Web 
Accounting » Accounts Receivable » Accounts 
Receivable Controls » Configure System Assigned 
Cash Receipt Number 

Maintain Transfer Accounts Accounting » Maintain » Accounts » Transfer 
Accounts 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Transfer Accounts 

Customer Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Customer Controls 

Customer Terms Not in Costpoint Web Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Customer Terms 

Customer User-Defined Labels Not in Costpoint Web 
Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Customer User-
Defined Labels 

Customer Types 
Accounting » Configure » Customers » Customer 
Types 

Materials » Configure » Customers » Customer 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Customer Types 
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Types 

Credit Limits 

Accounting » Configure » Customers » Customer 
Credit Limits 

Materials » Configure » Customers » Customer 
Credit Limits* 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Customer Credit 
Limits 

Credit Ratings 

Accounting » Configure » Customers » Customer 
Credit Ratings 

Materials » Configure » Customers » Customer 
Credit Ratings* 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Customer Credit 
Ratings 

Sales Territories 

Accounting » Configure » Customers » Sales 
Territories 

Materials » Configure » Customers » Sales 
Territories 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Sales Territories 

Shipping Methods Accounting » Configure » Customers » Shipping 
Methods 

Accounting » Accounts Receivable » Accounts 
Receivable Controls » Manage Shipping Methods 

Customer Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Customer Info 

Maintain Customer   Accounting » Maintain » Customers » Customers Accounting » Accounts Receivable » Customers » 
Manage Customers 

Customer User-Defined Info Accounting » Maintain » Customers » Customer 
User-Defined Information 

Accounting » Accounts Receivable » Customers » 
Manage Customer User-Defined Information 

Print Customer Listing Not in Costpoint Web Accounting » Accounts Receivable » Customers » 
Print Customer List 
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Cash Receipts 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Cash Receipts 

Enter Cash Receipts Accounting » Transaction » Cash Receipts » Enter 
Cash Receipts 

Accounting » Accounts Receivable » Cash 
Receipts Processing » Manage Cash Receipts 

Restore Cash Receipts Not in Costpoint Web 
Accounting » Accounts Receivable » Cash 
Receipts Processing » Copy/Reverse Cash 
Receipts 

Print Cash Receipts Edit Report Accounting » Review » Cash Receipts » Cash 
Receipts Edit Report 

Accounting » Accounts Receivable » Cash 
Receipts Processing » Print Cash Receipts Edit 
Report 

Post Cash Receipts Accounting » Process » Post » Post Cash Receipts Accounting » Accounts Receivable » Cash 
Receipts Processing » Post Cash Receipts 

Print Cash Receipts Register Accounting » Review » Cash Receipts » Cash 
Receipts Register 

Accounting » Accounts Receivable » Cash 
Receipts Processing » Print Cash Receipts 
Register Report 

Adjust A/R Underpayment Amounts Accounting » Transactions » Cash Receipts » 
Adjust A/R Underpayment Amounts 

Accounting » Accounts Receivable » Cash 
Receipts Processing » Edit/Manage A/R 
Underpayment Amounts 

Finance Charges 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Finance Charges 

Compute Finance Charges Not in Costpoint Web Accounting » Accounts Receivable » Finance 
Charges » Compute Customer Finance Charges 
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Lien Waiver Processing and Information 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Lien Waiver Processing and Information 

Maintain Lien Waiver Document Names Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Manage Lien Waiver Document Names 

Maintain Project Waiver Information Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Manage A/R Project Waiver Information 

Print Lien Waivers Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Print A/R Lien Waiver Forms 

Maintain Lien Waiver Information Not in Costpoint Web Accounting » Accounts Payable » Lien Waiver 
Controls » Manage A/R Lien Waiver Information 

Inquiry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Inquiry 

Analyze Receivables and Collections Accounting » Review » Accounts Receivable » 
Receivables and Collections Inquiry 

Accounting » Accounts Receivable » Accounts 
Receivable Reports/Inquiries » View Receivables 
and Collections 

Project Receivable Inquiry Not in Costpoint Web Not in Costpoint 7.0 

Customer Receivable Inquiry Not in Costpoint Web Not in Costpoint 7.0 
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Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Reports 

Print Customer Statement Accounting » Review » Cash Receipts » Customer 
Statement 

Accounting » Accounts Receivable » Accounts 
Receivable Reports/Inquiries » Print Customer 
Statements 

Print Accounts Receivable Aging Report Accounting » Review » Accounts Receivable » A/R 
Aging Report 

Accounting » Accounts Receivable » Accounts 
Receivable Reports/Inquiries » Print Accounts 
Receivable Aging Report 

Print Accounts Receivable History Report Accounting » Review » Accounts Receivable » A/R 
History Report 

Accounting » Accounts Receivable » Accounts 
Receivable Reports/Inquiries » Print Accounts 
Receivable History Report 

Beginning Balances 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Beginning Balances 

Maintain A/R History Accounting » Utilities » Transaction History »  
Initialize A/R History 

Accounting » Accounts Receivable » Accounts 
Receivable Utilities » Manage Accounts Receivable 
History 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Accounts Receivable » Utilities 

Purge Cash Receipts History Not in Costpoint Web Accounting » Accounts Receivable » Administrative 
Utilities » Purge Cash Receipts History 

Purge Customers Not in Costpoint Web Accounting » Accounts Receivable » Administrative 
Utilities » Purge Customers 

Miscellaneous Toolkits Not in Costpoint Web Not in Costpoint 7.0 
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Cash Management 

Bank Account Management 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Cash Management » Bank Account Management 

Maintain Banks Not in Costpoint Web 

Accounting » Cash Management » Cash 
Management Controls » Manage Banks (US) 

Accounting » Cash Management » Cash 
Management Controls » Manage Banks (Non-US) 

Maintain Company Bank Accounts Not in Costpoint Web 

Accounting » Cash Management » Bank Account 
Management » Manage Company Bank Accounts 
(US Banks) 

Accounting » Cash Management » Bank Account 
Management » Manage Company Bank Accounts 
(Non-US Banks) 

Currency Balance and Adjustments Not in Costpoint Web Accounting » Cash Management » Bank Account 
Management » Adjust Currency Balances 

Update Cash Accounts Not in Costpoint Web Accounting » Cash Management » Bank Account 
Management » Update Cash Accounts 

Maintain Bank Statement Info Not in Costpoint Web 
Accounting » Cash Management » Bank Account 
Management » Manage Bank Statement 
Information 

Print Bank Statement Report Not in Costpoint Web Accounting » Cash Management » Bank Account 
Management » Print Bank Statement Report 

Create Bank Transactions History Not in Costpoint Web Accounting » Cash Management » Bank Account 
Management » Create Bank Transactions History 

Accept Bank Transactions Not in Costpoint Web Accounting » Cash Management » Bank Account 
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Management » Accept Bank Transactions 

Process Batch Bank Transactions Not in Costpoint Web 
Accounting » Cash Management » Bank Account 
Management » Process Bank Transactions 
Acceptances 

Bank Reconciliation Inquiry Not in Costpoint Web 
Accounting » Cash Management » Cash 
Management Reports/Inquiries » View Bank 
Reconciliation Summary 

Bank Reconciliation Summary Report Not in Costpoint Web 
Accounting » Cash Management » Cash 
Management Reports/Inquiries » Print Bank 
Reconciliation Summary Report 

Bank Reconciliation Detail Reports Not in Costpoint Web 
Accounting » Cash Management » Cash 
Management Reports/Inquiries » Print Bank 
Reconciliation Detail Reports 

Purge Bank Transactions History Not in Costpoint Web 
Accounting » Cash Management » Cash 
Management Utilities » Purge Bank Transaction 
History 

Cash Forecasting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Cash Management » Cash Forecasting 

Maintain Cash Forecast Templates Not in Costpoint Web 
Accounting » Cash Management » Cash 
Management Controls » Manage Cash Forecast 
Templates 

Cash Forecast Accounts Not in Costpoint Web 
Accounting » Cash Management » Cash 
Management Controls » Manage Cash Forecast 
Accounts 

Create Preliminary Cash Forecasts Not in Costpoint Web Accounting » Cash Management » Cash 
Forecasting » Create Preliminary Cash Forecasts 
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Edit Preliminary Cash Forecasts Not in Costpoint Web Accounting » Cash Management » Cash 
Forecasting » Manage Preliminary Cash Forecasts 

Print Cash Forecasts Not in Costpoint Web Accounting » Cash Management » Cash 
Forecasting » Print Cash Forecasts Report 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Cash Management » Utilities 

Miscellaneous Toolkits Not in Costpoint Web Not in Costpoint 7.0 
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Fixed Assets 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Controls 

Fixed Assets Settings Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Configure Fixed Assets Settings 

Posting Settings Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Configure Posting Settings 

Property Types Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Property Types 

Classification Codes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Classification Codes 

Subclass Codes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Subclass Codes 

Depr Methods - Basic Setup Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Depreciation Methods 

Accum Depr Acct Codes Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Accumulated Depreciation Account 
Codes 

Depr Exp Acct Alloc Codes Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Depreciation Expense Acct Allocation 
Codes 

Asset Master Field Labels Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Asset Master Field Labels 
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Tracking Field Labels Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Tracking Field Labels 

User-Defined Labels Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Asset Master User-Defined Labels 

Location 1 Codes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Location 1 Codes 

Location 2 Codes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Location 2 Codes 

Location 3 Codes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Location 3 Codes 

Location Groups Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Location Groups 

Disposal Types Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Disposal Types 

FA FY/Pd Settings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » FA FY/Pd Settings 

Maintain FA Fiscal Years Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Calendar 
» Manage Fixed Assets Fiscal Years 

Maintain FA Accounting Periods Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Calendar 
» Manage Fixed Assets Accounting Periods 

Update FA FY/PD Info from GL FY/PD Info Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets Calendar 
» Update FA FY/Pd Information from GL FY/Pd 
Information 
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Autocreation of Asset Records 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Autocreation of Asset Records 

Autocreation Settings for PO/Rcvng Data Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Configure Autocreation Settings 

Default Autocreation Asset Numbering Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Configure Default Autocreation Asset Numbering 

Autocreation Accounts Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Controls 
» Manage Autocreation Accounts 

Create Autocreation Transactions Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Create Autocreation Transactions 

Edit Autocreation Transactions Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Autocreation Transactions 

Print Autocreation Transactions Edit Report Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Print Autocreation Transactions Edit Report 

Process Autocreation Transactions Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Create Asset Master Records 

Asset Templates 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Asset Templates 

Maintain Asset Template Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Template Information 

Maintain Template User-Defined Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
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» Manage Asset Template User-Defined 
Information 

Print Asset Template List Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Print Asset Template List 

Print Asset Template Detail Report Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Print Asset Template Detail Report 

Asset Master Records 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Asset Master Records 

Maintain Asset Master Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Master Information 

Maintain Asset Desc Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Description Information 

Maintain Asset Purchase Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Purchase Information 

Maintain Asset Cost Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Cost Information 

Maintain Asset Location Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Location Information 

Maintain Asset Account Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Account Information 

Maintain Asset G/L Book Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset General Ledger Book Information 

Maintain Asset Other Books Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
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» Manage Asset Other Books Information 

Maintain Asset Disposal Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Disposal Information 

Maintain Asset Government Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset Government Information 

Maintain Asset User-Defined Info Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Manage Asset User-Defined Information 

Print Asset Master List Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Print Asset Master List 

Print Asset Master Detail Not in Costpoint Web Accounting » Fixed Assets » Asset Master Records 
» Print Asset Master Detail Report 

Inventory Records 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Inventory Records 

Maintain Inventory Info Not in Costpoint Web Accounting » Fixed Assets » Inventory Records » 
Manage Asset Inventory Transactions 

Create Inventory Transactions Not in Costpoint Web Accounting » Fixed Assets » Inventory Records » 
Create Asset Inventory Transactions 

Edit Inventory Transactions Not in Costpoint Web Accounting » Fixed Assets » Inventory Records » 
Edit Asset Inventory Transactions 

Process Inventory Transactions Not in Costpoint Web Accounting » Fixed Assets » Inventory Records » 
Create Asset Inventory Information 

Print Inventory Info Not in Costpoint Web Accounting » Fixed Assets » Inventory Records » 
Print Asset Inventory Information Report 
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Maintenance Records 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Maintenance Records 

Maintain Maintenance Info Not in Costpoint Web Accounting » Fixed Assets » Maintenance Records 
» Manage Asset Maintenance Information 

Create Maintenance Transactions Not in Costpoint Web Accounting » Fixed Assets » Maintenance Records 
» Create Asset Maintenance Transactions 

Edit Maintenance Transactions Not in Costpoint Web Accounting » Fixed Assets » Maintenance Records 
» Manage Asset Maintenance Transactions 

Process Maintenance Transactions Not in Costpoint Web Accounting » Fixed Assets » Maintenance Records 
» Create Asset Maintenance Information 

Print Maintenance Info Not in Costpoint Web Accounting » Fixed Assets » Maintenance Records 
» Print Asset Maintenance Information Report 

Transfer Records 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Transfer Records 

Maintain Transfer Info Not in Costpoint Web Accounting » Fixed Assets » Transfer Records » 
Manage Asset Transfer Information 

Create Transfer Transactions Not in Costpoint Web Accounting » Fixed Assets » Transfer Records » 
Create Asset Transfer Transactions 

Edit Transfer Transactions Not in Costpoint Web Accounting » Fixed Assets » Transfer Records » 
Manage Asset Transfer Transactions 

Process Transfer Transactions Not in Costpoint Web Accounting » Fixed Assets » Transfer Records » 



Accounting  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 38 

 

Create Asset Transfer Information 

Print Transfer Info Not in Costpoint Web Accounting » Fixed Assets » Transfer Records » 
Print Asset Transfer Information Report 

Depreciation 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Depreciation 

Compute Depreciation Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Processing » Compute Depreciation 

Print Current Period Depreciation Rpt Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » Print Current Period Depreciation 
Report 

Print Sequential Other Bks Depr History Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » Print Sequential Other Books 
Depreciation History Rpt 

Others Books Depr History Inquiry Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » View Other Books Depreciation 
History 

Disposals 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Disposals 

Maintain Single Disposal Transactions Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Processing » Manage Disposal Transactions 

Maintain Multiple Disposal Transactions Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
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Processing » Manage Disposal Transactions 

Create Multiple Disposal Transactions Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Processing » Create Multiple Disposal Transactions 

Print Disposal Transactions Edit Report Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » Print Disposal Transactions Edit 
Report 

Post Depreciation and Disposals 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Post Depreciation and Disposals 

Post Fixed Assets Journal Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Processing » Post Fixed Assets Journal 

Reverse Posted Fixed Assets Entry Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Processing » Reverse Posted Fixed Assets Entry 

Print Posted Transactions Detail Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » Print Posted Transactions Detail 
Report 

Print Sequential Posted Depr History Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » Print Sequential Posted Depreciation 
History Report 
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Close Fixed Assets Acctng PD 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7. 1 Menu Location 

Close Fixed Assets Acctng PD 

Close Fixed Assets Acctng PD Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets 
Processing » Close Fixed Assets Accounting 
Period 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7. 1 Menu Location 

Accounting » Fixed Assets » Reports 

Print Asset Book Value Report Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Reports 
» Print Asset Book Value Report 

Print Asset Location Report Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Reports 
» Print Asset Location Report 

Print Depr Component Info by Book Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets Reports 
» Print Depreciation Component Information by 
Book Report 

Print Comparative Book Data Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Reports 
» Print Comparative Book Data Report 

Print FA/GL Reconciliation Report Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets Reports 
» Print Fixed Assets/General Ledger Reconciliation 
Report 

Print Schedule of Asset Activity Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Reports 
» Print Schedule of Asset Activity Report 

Print Schedule of Accum Depr Activity Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Reports 
» Print Schedule of Accumulated Depr Activity 
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Report 

Projections 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Projections 

Compute Projected Depreciation Not in Costpoint Web Accounting » Fixed Assets » Projections » 
Compute Projected Depreciation 

Print Projected Depreciation Not in Costpoint Web Accounting » Fixed Assets » Projections » Print 
Projected Depreciation Report 

Maintain Projected Asset Purchases Not in Costpoint Web Accounting » Fixed Assets » Projections » Manage 
Projected Asset Purchases 

Print Projected Asset Purchases Not in Costpoint Web Accounting » Fixed Assets » Projections » Print 
Projected Asset Purchases Report 

Maintain Projected Asset Disposals Not in Costpoint Web Accounting » Fixed Assets » Projections » Manage 
Projected Asset Disposals 

Print Projected Asset Disposals Not in Costpoint Web Accounting » Fixed Assets » Projections » Print 
Projected Asset Disposals Report 

Projected Depreciation Expense Inquiry Not in Costpoint Web Accounting » Fixed Assets » Projections » View 
Projected Depreciation Expense 
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Asset/Template Changes 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Asset/Template Changes 

Asset/Template Change Settings Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
Configure Asset/Template Change Settings 

Template Info Global Changes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
Manage Template Global Changes 

Template UDF Info Global Changes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
Manage Template User-Defined Global Changes 

Asset Master Info Global Changes Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
Manage Asset Master Global Changes 

Asset Master UDF Info Global Changes Not in Costpoint Web 
Accounting » Fixed Assets » Fixed Assets Utilities » 
Manage Asset Master User-Defined Global 
Changes 

Print Change History Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
Print Asset/Template Change History Report 

Asset Change History Inquiry Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
View Asset Change History 

Template Change History Inquiry Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 
View Template Change History 
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Bar Code Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Bar Code Interface 

Bar Code Settings Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Interfaces » Export Bar Code Scanner Settings 

Asset Location Preprocessor Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Interfaces » Import Asset Locations 

Maintain Asset Location Exceptions Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets 
Interfaces » Manage Asset Location Exceptions 

Purge Fixed Assets Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Purge Fixed Assets Info 

Purge All Asset Info Not in Costpoint Web Accounting » Fixed Assets » Administrative Utilities 
» Purge All Asset Information 

Purge Posted Transactions Detail Not in Costpoint Web Accounting » Fixed Assets » Administrative Utilities 
» Purge Posted Transactions Detail 

Purge Other Books Depr History Not in Costpoint Web Accounting » Fixed Assets » Administrative Utilities 
» Purge Other Books Depreciation History 

Purge Asset/Template Change History Not in Costpoint Web Accounting » Fixed Assets » Administrative Utilities 
» Purge Asset/Template Change History 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Fixed Assets » Utilities 

Verify/Update Depr Computation Data Not in Costpoint Web Accounting » Fixed Assets » Administrative Utilities 
» Compute/Update Depreciation Computation Data 

Verify/Update Amt Taken Purchase YTD Not in Costpoint Web 
Accounting » Fixed Assets » Administrative Utilities 
» Compute/Update Amount Taken Purchase Year-
To-Date 

Miscellaneous Toolkits » Modify Current Depr Yr & 
Days/Pds Remaining * Not in Costpoint Web 

Accounting » Fixed Assets » Fixed Assets Utilities » 
Update Current Depreciation Yr & Days/Pds 
Remaining 

Miscellaneous Toolkits » Update Current Pd Depr 
Amount * Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 

Update Current Period Depreciation Amount 

Miscellaneous Toolkits » Maintain Bar Code 
Scanner Settings * Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Update the JE Req’d Flag 
in the Asset Audit Log * Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 

Update the JE Required Flag in the Asset Audit Log 

Miscellaneous Toolkits » Update FY, Pd, and 
Subpd for Manual Disposals * Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 

Update FY, Pd, and Subpd for Manual Disposals 

Miscellaneous Toolkits » Compute/Update FYTD 
Amount* Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 

Compute/Update Fiscal Year-To-Date Amount 

Miscellaneous Toolkits » Copy Transfer Data to 
Asset Audit Log * Not in Costpoint Web Accounting » Fixed Assets » Fixed Assets Utilities » 

Copy Transfer Data to Asset Audit Log 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Travel 
The Travel module has been de-supported in Costpoint 7.0. 
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Consolidations 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Consolidations » Controls 

Consolidation Settings Not in Costpoint Web Accounting » Consolidations » Consolidations 
Controls » Configure Consolidation Settings 

Consolidation Equity Accounts Override Not in Costpoint Web 
Accounting » Consolidations » Consolidations 
Controls » Manage Consolidation Equity Accounts 
Override 

Consolidation Acct/Org Mappings Not in Costpoint Web 
Accounting » Consolidations » Consolidations 
Controls » Manage Consolidation Acct/Org 
Mappings 

Maintain Transfer Locations Not in Costpoint Web Accounting » Consolidations » Consolidations 
Controls » Manage Transfer Locations 

Link Consolidation Locations Not in Costpoint Web Accounting » Consolidations » Consolidations 
Controls » Link Consolidation Locations 

Consolidations 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Consolidations  

Create Consolidation Entry Not in Costpoint Web Accounting » Consolidations » Consolidations 
Processing » Create Consolidation Entries 

Consolidation Transfer History Not in Costpoint Web 
Accounting » Consolidations » Consolidations 
Processing » Manage Consolidation Transfer 
History 
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Create Project Data Not in Costpoint Web Accounting » Consolidations » Consolidations 
Processing » Create Project Summary Balances 

Import Consolidation Data Not in Costpoint Web Accounting » Consolidations » Consolidations 
Processing » Import Consolidation Data 

Consolidation Preprocessor Not in Costpoint Web 
Accounting » Consolidations » Consolidations 
Processing » Copy Imported Consolidation Data to 
Permanent Tables 

Maintain Consolidation Suspense Not in Costpoint Web 
Accounting » Consolidations » Consolidations 
Processing » Manage Consolidation Suspense 
Entries 

Create Elimination Entry Not in Costpoint Web Accounting » Consolidations » Consolidations 
Processing » Create Elimination Entries 

Update Consolidation Beginning Balances Not in Costpoint Web 
Accounting » Consolidations » Consolidations 
Utilities » Update Consolidation Beginning 
Balances 
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Multicurrency 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Multicurrency » Controls 

Multicurrency Settings Not in Costpoint Web Accounting » Multicurrency » Multicurrency 
Controls » Configure Multicurrency Settings 

Multicurrency Accounts Administration » Maintain » Multicurrency » 
Multicurrency Accounts 

Accounting » Multicurrency » Multicurrency 
Controls » Manage Multicurrency Accounts 

Currencies 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Multicurrency » Currencies 

Maintain Currencies Administration » Maintain » Multicurrency » 
Currencies 

Accounting » Multicurrency » Currency Controls » 
Manage Currencies 

Currency Status Administration » Maintain » Multicurrency » 
Currency Status 

Accounting » Multicurrency » Currency Controls » 
Manage Currency Status 

Exchange Rates 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Multicurrency » Exchange Rates 

Maintain Exchange Rate Sources Administration » Maintain » Multicurrency » 
Exchange Rate Sources 

Accounting » Multicurrency » Exchange Rates » 
Manage Exchange Rate Sources 
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Maintain Exchange Rate Groups Not in Costpoint Web Accounting » Multicurrency » Exchange Rates » 
Manage Exchange Rate Groups 

Maintain Exchange Rates by Date Administration » Maintain » Multicurrency » 
Exchange Rates by Date 

Accounting » Multicurrency » Exchange Rates » 
Manage Exchange Rates by Date 

Enter Daily Rates Administration » Maintain » Multicurrency » Daily 
Exchange Rates 

Accounting » Multicurrency » Exchange Rates » 
Manage Daily Exchange Rates 

Upload Daily Exchange Rates Administration » Maintain » Multicurrency » Daily 
Exchange Rates 

Accounting » Multicurrency » Exchange Rates » 
Import Daily Exchange Rates 

Maintain Exchange Rates by Period Administration » Maintain » Multicurrency » 
Exchange Rates by Period 

Accounting » Multicurrency » Exchange Rates » 
Manage Exchange Rates by Period 

Enter Period Rates Administration » Maintain » Multicurrency » Period 
Exchange Rates 

Accounting » Multicurrency » Exchange Rates » 
Manage Period Exchange Rates 

Print Exchange Rates Report Not in Costpoint Web Accounting » Multicurrency » Exchange Rates » 
Print Exchange Rates Report 

Gains/Losses 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Multicurrency » Gains/Losses 

Update Open A/P Exchange Rates Not in Costpoint Web 
Accounting » Multicurrency » Gains/Losses 
Processing » Update Open Accounts Payable 
Exchange Rates 

Update Open A/R Exchange Rates Administration » Process » Multicurrency » Update 
Open A/R Exchange Rates 

Accounting » Multicurrency » Gains/Losses 
Processing » Update Open Accounts Receivable 
Exchange Rates 

Compute/Post Unrealized Gains/Losses Accounting » Process » Post » Compute/Post 
Unrealized Gains/Losses 

Accounting » Multicurrency » Gains/Losses 
Processing » Compute/Post Unrealized 
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Gains/Losses 

Voucher Unrealized Gain/Loss Report Accounting » Review » Vouchers » Voucher 
Unrealized Gain/Loss Report Not in Costpoint 7.0 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Accounting » Multicurrency » Utilities 

Currency/Units Converter Not in Costpoint Web Accounting » Multicurrency » Multicurrency Utilities 
» Compute Future Value of Money 

Miscellaneous Toolkits » Initialize Currency Codes 
for Version 6.1* Not in Costpoint Web Accounting » Multicurrency » Multicurrency Utilities 

» Update Currency Codes for Current Version 

Miscellaneous Toolkits » Change Voucher 
Currency Codes Not in Costpoint Web Not in Costpoint 7.0 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 
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Projects 

Project Setup 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Controls 

Project Settings Administration » Configure » Project » Project 
Settings 

Projects » Project Setup » Project Setup Controls » 
Configure Project Settings 

Project Account Groups Projects » Configure » Project » Project Account 
Groups 

Projects » Project Setup » Project Setup Controls » 
Manage Project Account Groups 

Maintain Project/Account Validation Projects » Maintain » Project » Project/Account 
Links 

Projects » Project Setup » Charging Information » 
Link Projects/Accounts 

Maintain Project/Organization Validation Projects » Maintain » Project » Project/Organization 
Links 

Projects » Project Setup » Charging Information » 
Link Projects/Organizations 

Maintain Project Types Projects » Configure » Project » Project Types Projects » Project Setup » Project Setup Controls » 
Manage Project Types 

Project User-Defined Labels Not in Costpoint Web Projects » Project Setup » Project Setup Controls » 
Manage User-Defined Labels 

Maintain Change Order Statuses Projects » Configure » Project » Project Change 
Order Statuses 

Projects » Project Setup » Project Setup Controls » 
Manage Change Order Status 
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Project Master 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Project Master 

Maintain Project Master Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Master » 
Manage Project User Flow 

Basic Info Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Master » 
Manage Project User Flow 

Mass Link Projects/Accounts/Organizations Projects » Maintain » Project » Mass Link Projects/ 
Accounts/Organizations 

Projects » Project Setup » Charging Information » 
Mass Link Projects/Accounts/Organizations 

Maintain Valid Project/Account/Orgs Projects » Maintain » Project » 
Project/Account/Organization Links 

Projects » Project Setup » Charging Information » 
Link Projects/Accounts/Organizations 

Modifications Projects » Transactions » Project » Enter Project 
Modifications 

Projects » Project Setup » Project Master » 
Manage Modifications 

Enter Change Orders Projects » Transactions » Project » Enter Project 
Change Orders 

Projects » Project Setup » Project Master » 
Manage Change Orders 

Deliverables Projects » Transactions » Project » Enter Project 
Deliverables 

Projects » Project Setup » Project Master » 
Manage Deliverables 

Government Contract Info Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Master » 
Manage Government Contract Information 

User-Defined Info Projects » Maintain » Project » Project User-
Defined Information 

Projects » Project Setup » Project Master » 
Manage User-Defined Information 

Assign Standard Text Projects » Maintain » Project » Project Standard 
Text Assignment 

Projects » Project Setup » Project Master » 
Manage Standard Text 

Mass Add Project Info Projects » Maintain » Project » Mass Add Project 
Information 

Projects » Project Setup » Project Master » Mass 
Add Project Master Data 
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Upload Project Information Projects » Utilities » Import » Import Project 
Information 

Projects » Project Setup » Project Setup Interfaces 
» Import Project Master Data 

Project Labor 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Project Labor 

Set Up Project Labor Categories (PLC) Projects » Maintain » Labor Categories » Project 
Labor Categories (PLCs) 

Projects » Project Setup » Project Labor » Manage 
Project Labor Categories (PLC) 

Assign PLC to Projects Projects » Maintain » Labor Categories » Assign 
PLCs 

Projects » Project Setup » Project Labor » Link 
Project Labor Categories to Projects 

Link GLC to Project PLC Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Master » 
Manage Project User Flow 

Project PLC Rates Projects » Maintain » Labor Categories » Project 
PLC Rates 

Projects » Project Setup » Project Labor » Link 
Project Labor Category Rates to Projects 

Project Employee Work Force Projects » Maintain » Labor Categories » Employee 
Work Force 

Projects » Project Setup » Project Labor » Manage 
Employee Work Force 

Project Vendor Work Force Projects » Maintain » Labor Categories » Vendor 
Work Force 

Projects » Project Setup » Project Labor » Manage 
Vendor Work Force 

Project Vendor Employee Work Force Not in Costpoint Web Projects » Project Setup » Project Labor » Manage 
Vendor Employee Work Force 

Assign PLC to Employee Work Force Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Labor » Manage 
Employee Work Force 

Assign PLC to Vendor Work Force Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Labor » Manage 
Vendor Work Force 

Assign PLC to Vendor Employee Work Force Not in Costpoint Web Projects » Project Setup » Project Labor » Manage 
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Vendor Employee Work Force 

Project PLC Rates by Employee/Vendor Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Labor » Link PLC 
Rates to Employee/Vendor 

Unit Pricing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Unit Pricing 

CLIN Information Projects » Maintain » Project » CLINs Projects » Project Setup » Unit Pricing Information 
» Manage CLIN Information 

Project Unit Pricing Projects » Maintain » Project » CLINs Projects » Project Setup » Unit Pricing Information 
» Manage CLIN Information 

Revenue Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Revenue Setup 

Basic Revenue Info Projects » Maintain » Revenue » Revenue 
Information 

Projects » Project Setup » Revenue » Manage 
Revenue Information 

Maintain Revenue Formulas Projects » Maintain » Revenue » Revenue 
Formulas 

Projects » Project Setup » Revenue » Manage 
Revenue Formulas 

Project Billing Info Projects » Maintain » Billing » Project Billing 
Information 

Projects » Billing » Billing Master » Manage Project 
Billing Information 

Define Rate Sequence Projects » Maintain » Revenue » Define Rate 
Sequence 

Projects » Project Setup » Revenue » Manage Rate 
Sequence Orders 

Maintain Cost Fee Overrides Projects » Maintain » Ceilings and Overrides » Cost Projects » Project Setup » Project Ceilings » 
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Fee Overrides Manage Cost Fee Overrides 

Maintain Burden Fee Overrides Projects » Maintain » Ceilings and Overrides » 
Burden Fee Overrides 

Projects » Project Setup » Project Ceilings » 
Manage Burden Fee Overrides 

Maintain Multiplier Overrides Projects » Maintain » Ceilings and Overrides » 
Multiplier Overrides 

Projects » Project Setup » Project Ceilings » 
Manage Multiplier Overrides 

Cost of Goods Sold Projects » Maintain » Project » Cost of Goods Sold Projects » Project Setup » Revenue » Manage Cost 
of Goods Sold 

Project Ceilings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Project Ceilings 

Project Total Ceilings Projects » Maintain » Project » Project User Flow Projects » Project Setup » Project Ceilings » 
Manage Total Ceilings 

Project Direct Cost Ceilings Projects » Maintain » Ceilings and Overrides » 
Direct Cost Ceilings 

Projects » Project Setup » Project Ceilings » 
Manage Direct  Cost Ceilings 

Project Burden Cost Ceilings Projects » Maintain » Ceilings and Overrides » 
Burden Cost Ceilings 

Projects » Project Setup » Project Ceilings » 
Manage Burden Cost Ceilings 

Project Hours Ceilings Projects » Maintain » Ceilings and Overrides » 
Direct Hour Ceilings 

Projects » Project Setup » Project Ceilings » 
Manage Hour Ceilings 

Project Employee Hours Ceilings Projects » Maintain » Ceilings and Overrides » 
Employee Hour Ceilings 

Projects » Project Setup » Project Ceilings » 
Manage Employee Hour Ceilings 

Project Vendor Hours Ceilings Projects » Maintain » Ceilings and Overrides » 
Vendor Hour Ceilings 

Projects » Project Setup » Project Ceilings » 
Manage Vendor Hour Ceilings 
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Project History 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Project History 

Prior Year Cost and Revenue Not in Costpoint Web Projects » Project Setup » Project History » 
Manage Prior Year Cost and Revenue 

Prior Year Billable Value Amounts Not in Costpoint Web Projects » Project Setup » Project History » 
Manage Prior Year Billable Value 

Prior Year T&M Revenue Not in Costpoint Web Projects » Project Setup » Project History » 
Manage Prior Year Time and Materials Revenue 

Prior Year Unit Revenue Not in Costpoint Web Projects » Project Setup » Project History » 
Manage Prior Year Unit Revenue 

Maintain Labor Summary Projects » Configure » Project History » Maintain 
Labor Summary 

Projects » Project Setup » Project History » 
Manage Project Labor History 

Update Prior Year History Projects » Utilities » Project Toolkits » Update 
Project Prior Year History 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Update Prior 
Year History 

Alternate Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Project Setup » Alternate Reporting 

Alternate Reporting Not in Costpoint Web Projects » Project Setup » Alternate Projects » 
Manage Alternate Projects 
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Budgeting and ETC 

Budget Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Budget Setup 

Maintain Average GLC Rates Not in Costpoint Web Projects » Budgeting and ETC »Budget Controls » 
Manage Average GLC Rates 

Maintain Average PLC Rates Not in Costpoint Web Projects » Budgeting and ETC »Budget Controls » 
Manage Average PLC Rates 

Total Budgets 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Total Budgets 

Project Total Budget Not in Costpoint Web Projects » Budgeting and ETC »Total Budgets » 
Manage Project Total Budget 

PLC Total Budget Not in Costpoint Web Projects » Budgeting and ETC »Total Budgets » 
Manage PLC Total Budget 

GLC Total Budget Not in Costpoint Web Projects » Budgeting and ETC »Total Budgets » 
Manage GLC Total Budget 

Maintain Budget Report Tables Projects » Process » Budgets and ETCs » Create 
Budget Report Tables 

Projects » Budgeting and ETC »Total Budgets » 
Update Budget Report Tables 
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Period Budgets 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Period Budgets 

Maintain Budget Revisions Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Manage Budget Revisions 

Project Budgets by Period Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Manage Project Budgets By Period 

Apply Indirect Costs to Budgets Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Apply Indirect Costs to Budgets 

PLC Budgets by Period Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Manage PLC Budgets By Period 

GLC Budgets by Period Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Manage GLC Budgets By Period 

Project Unit Budgets by Period Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Manage Project Unit Budgets By Period 

Update Project Total Budget Not in Costpoint Web Projects » Budgeting and ETC »Period Budgets » 
Update Project Total Budget 

Maintain C/SSRs 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Maintain C/SSRs 

Maintain C/SSR Information Not in Costpoint Web Projects » Budgeting and ETC »Cost Schedule 
Status Report » Manage CSSR Information 

Maintain C/SSR Budgets Not in Costpoint Web Projects » Budgeting and ETC »Cost Schedule 
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Status Report » Manage CSSR Budgets 

Upload C/SSR Budgets Not in Costpoint Web Projects » Budgeting and ETC »Cost Schedule 
Status Report » Import CSSR Budgets 

Create C/SSR Report Tables Not in Costpoint Web Projects » Budgeting and ETC »Cost Schedule 
Status Report » Create CSSR Report Tables 

Print C/SSR Not in Costpoint Web Projects » Budgeting and ETC »Cost Schedule 
Status Report » Print Cost Schedule Status Report 

Encumbrance Tracking 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Encumbrance Tracking 

Maintain Project Budget Line Item Revisions Not in Costpoint Web 
Projects » Budgeting and ETC » Encumbrance 
Tracking » Manage Project Budget Line Item 
Revisions 

Maintain Project Line Item Budgets Not in Costpoint Web Projects » Budgeting and ETC » Encumbrance 
Tracking » Manage Project Line Item Budgets 

Calculate Over Budget Transactions Projects » Process » Encumbrance Tracking » 
Calculate Over-Budget Transactions 

Projects » Budgeting and ETC » Encumbrance 
Tracking » Compute Over Budget Transactions 
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Estimate to Complete 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Estimate to Complete 

Maintain Estimate-to-Complete Amounts Not in Costpoint Web 
Projects » Budgeting and ETC » Estimate to 
Complete » Manage Estimate To Complete 
Amounts 

Update Incurred Cost for ETC Not in Costpoint Web Projects » Budgeting and ETC » Estimate to 
Complete » Update Incurred Cost for ETC 

Revise ETC Not in Costpoint Web Projects » Budgeting and ETC » Estimate to 
Complete » Compute Estimate To Complete 

Maintain Estimate-to-Complete PLC Hours Not in Costpoint Web 
Projects » Budgeting and ETC » Estimate to 
Complete » Manage Estimate to Complete PLC 
Hours 

Maintain Estimate-to-Complete GLC Hours Not in Costpoint Web 
Projects » Budgeting and ETC » Estimate to 
Complete » Manage Estimate to Complete GLC 
Hours 

Estimate to Complete Reporting & Inquiry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Budgeting and ETC » Estimate to Complete Reporting & Inquiry 

Create ETC Report Tables Projects » Process » Budgets and ETCs » Create 
Estimate-to-Complete Report Tables 

Projects » Budgeting and ETC » Estimate To 
Complete Reports/Inquiries » Create Estimate To 
Complete Report Tables 

ETC Inquiry Not in Costpoint Web 
Projects » Budgeting and ETC » Estimate To 
Complete Reports/Inquiries » View Estimate To 
Complete 
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Print ETC Report Not in Costpoint Web 
Projects » Budgeting and ETC » Estimate To 
Complete Reports/Inquiries » Print Estimate To 
Complete Report 

Print ETC Hours Report Not in Costpoint Web 
Projects » Budgeting and ETC » Estimate To 
Complete Reports/Inquiries » Print Estimate To 
Complete Hours Report 
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Advanced Project Budgeting 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Advanced Project Budgeting » Controls 

Maintain Project Budget Settings Not in Costpoint Web 
Projects » Advanced Project Budgeting » Advanced 
Project Budget Controls » Configure Project Budget 
Settings 

Maintain Project Budget Revisions Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Manage 
Project Budget Revisions 

Maintain Burden Templates Not in Costpoint Web Projects » Advanced Project Budgeting » Burden 
Templates » Manage Burden Templates 

Import Pools to Burden Template Not in Costpoint Web Projects » Advanced Project Budgeting » Burden 
Templates » Import Pools to Burden Templates 

Build Budget Composite Rates Not in Costpoint Web Projects » Advanced Project Budgeting » Burden 
Templates » Build Budget Composite Rates 

Maintain Average Cost GLC Rates Not in Costpoint Web 
Projects » Advanced Project Budgeting » Advanced 
Project Budget Controls » Manage Average Cost 
GLC Rates 

Maintain Average Cost PLC Rates Not in Costpoint Web 
Projects » Advanced Project Budgeting » Advanced 
Project Budget Controls » Manage Average Cost 
PLC Rates 

Maintain Period Days Not in Costpoint Web Projects » Advanced Project Budgeting » Advanced 
Project Budget Controls » Manage Period Days 
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Project Budget and ETC Master 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Advanced Project Budgeting » Project Budget and ETC Master 

Maintain Project Budgets and ETC Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Manage 
Project Budgets and ETC 

Mass Add Project Budgets Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Mass Add 
Project Budgets 

Update Incurred Costs for Project Budgets Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Update 
Incurred Costs for Project Budgets 

Project Budget Recalculation Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Update 
Project Budgets 

Revise Estimate to Complete Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Compute 
Estimate to Complete 

Create PSR Budget Report Tables Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget and Estimate To Complete » Create PSR 
Budget Report Tables 

Project Budget Inquiry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Advanced Project Budgeting » Project Budget Inquiry 

Project Budgets Not in Costpoint Web Projects » Advanced Project Budgeting » Project 
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Budget Reports/Inquiries » View Project Budgets 

ETC and Earned Value Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget Reports/Inquiries » View ETC and Earned 
Value 

Project Budget Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Advanced Project Budgeting » Project Budget Reporting 

Print Project Budget Summary Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget Reports/Inquiries » Print Project Budget 
Summary Report 

Print Project Budget Detail Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget Reports/Inquiries » Print Project Budget 
Detail Report 

Print Estimate to Complete Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget Reports/Inquiries » Print Estimate To 
Complete Report 

Print Labor Estimate to Complete Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget Reports/Inquiries » Print Labor Estimate To 
Complete Report 

Print Earned Value Not in Costpoint Web 
Projects » Advanced Project Budgeting » Project 
Budget Reports/Inquiries » Print Earned Value 
Report 
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Cost and Revenue Processing 

Cost Pool Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Cost Pool Setup 

Allocation Groups Not in Costpoint Web Projects » Cost and Revenue Processing » Cost 
Pool Controls » Manage Allocation Groups 

Cost Pools Projects » Maintain » Allocations » Cost Pools Projects » Cost and Revenue Processing » Cost 
Pools » Manage Cost Pools 

Base Creation Setup Projects » Maintain » Allocations » Pool Base 
Creation 

Projects » Cost and Revenue Processing » Cost 
Pools » Manage Base Creation Setups 

Cost Creation Setup Projects » Maintain » Allocations » Pool Cost 
Creation 

Projects » Cost and Revenue Processing » Cost 
Pools » Manage Cost Creation Setups 

Create Pool Links Projects » Process » Allocations » Create Pool 
Links 

Projects » Cost and Revenue Processing » Cost 
Pools » Create Pool Links 

Set Pool Processing Sequence Projects » Maintain » Allocations » Pool Processing 
Sequence 

Projects » Cost and Revenue Processing » Cost 
Pool Controls » Manage Pool Processing 
Sequence Numbers 

Multi-Job Allocation Setup Projects » Maintain » Allocations » Multi-Job 
Allocation Setup 

Projects » Cost and Revenue Processing » Multi-
Job Processing » Manage Multi-Job Allocation 
Information 

Upload Multi-Job Allocation Percentage Basis Not in Costpoint Web 
Projects » Cost and Revenue Processing » Multi-
Job Processing » Import Multi-Job Allocation 
Percentage Basis 
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Cost Pool History 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Cost Pool History 

Multi-Job Allocation 
Cost History 

Projects » Configure » Allocations » Multi-Job 
Allocation Cost History 

Projects » Cost and Revenue Processing » Multi-
Job Processing » Manage Multi-Job Allocation Cost 
History 

Multi-Job Allocation 
Labor History 

Projects » Configure » Allocations » Multi-Job 
Allocation Labor History 

Projects » Cost and Revenue Processing » Multi-
Job Processing » Manage Multi-Job Allocation 
Labor History 

Cost Pool Processing & Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Cost Pool Processing & Reporting 

Build Rate Application Table Projects » Process » Allocations » Build Rate 
Application Table 

Projects » Cost and Revenue Processing » Cost 
Pool Processing » Build Rate Application Table 

Compute & Print Pool Rates Projects » Process » Allocations » Compute and 
Print Pool Rates 

Projects » Cost and Revenue Processing » Cost 
Pool Processing » Compute/Print Pool Rates 

Compute Inventory Burden Rates Projects » Process » Allocation » Compute 
Inventory Burden Rates 

Projects » Cost and Revenue Processing » Project 
Cost Processing » Compute Inventory Burden 
Rates 

Maintain Allocation Journal Projects » Transactions » Allocations » Maintain 
Allocation Journal 

Projects » Cost and Revenue Processing » Cost 
Pool Processing » Manage Allocation Journals 

Upload Allocation Basis Journal Projects » Utilities » Import » Import Allocation 
Basis Journal 

Projects » Cost and Revenue Processing » Cost 
Pool Processing » Import Allocation Basis Journals 

Print Allocation Journal Edit Report Projects » Review » Allocations » Allocation Journal Projects » Cost and Revenue Processing » Cost 
Pool Processing » Print Allocation Journal Edit 
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Edit Report Report 

Print Service Center Cost Allocation Report Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
Pool Processing » Print Service Center Cost 
Allocation Report 

Post Pool Journal Projects » Process » Post » Post Pool Journal Projects » Cost and Revenue Processing » Cost 
Pool Processing » Post Pool Journals 

Project Transfer 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Project Transfer 

Project Transfer Setup Projects » Maintain » Allocations » Project Transfer 
Setup 

Projects » Cost and Revenue Processing » Project 
Transfer Processing » Manage Project Transfer 
Information 

Compute Project Transfer Projects » Process » Allocations » Compute Project 
Transfer 

Projects » Cost and Revenue Processing » Project 
Transfer Processing » Create Project Transfer 
Journal Entries 

Update Project Transfer History Tables Projects » Process » Project » Update Project 
Transfer History Tables 

Projects » Cost and Revenue Processing » Project 
Transfer Processing » Update Project Transfer 
History Tables 

Project Cost Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Project Cost Processing 

Compute Cost of Goods Sold Entry Projects » Process » Project » Compute Cost of 
Goods Sold Entry 

Projects » Cost and Revenue Processing » Project 
Cost Processing » Create Cost of Goods Sold 
Entries 
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Compute Burden Cost Projects » Process » Project » Compute Burden 
Cost 

Projects » Cost and Revenue Processing » Project 
Cost Processing » Compute Burden Costs 

Compute Multi-Job Allocations Projects » Process » Allocations » Compute Multi-
Job Allocations 

Projects » Cost and Revenue Processing » Multi-
Job Processing » Create Multi-Job Allocation 
Entries 

Revenue Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Revenue Processing 

Load Labor Rates Projects » Process » Billing » Load Labor Rates Projects » Cost and Revenue Processing » 
Revenue Processing » Load Labor Rates 

Compute Revenue Not in Costpoint Web Projects » Cost and Revenue Processing » 
Revenue Processing » Compute Revenue 

Redistribute Revenue Projects » Process » Revenue » Compute Revenue Projects » Cost and Revenue Processing » 
Revenue Processing » Redistribute Revenue 

Redistribute Revenue by Project Projects » Process » Revenue » Redistribute 
Revenue by Project 

Projects » Cost and Revenue Processing » 
Revenue Processing » Redistribute Revenue by 
Project 

Post Revenue Projects » Process » Post » Post Revenue Projects » Cost and Revenue Processing » 
Revenue Processing » Post Revenue 

Compute Billing Value of Cost Incurred Projects » Process » Revenue » Compute Billing 
Value of Cost Incurred 

Projects » Cost and Revenue Processing » Goal 
Processing » Compute Billing Value of Cost 
Incurred 

Create Cost Transfer Journal Entry Projects » Process » Project » Create Cost 
Transfer Journal Entry 

Projects » Cost and Revenue Processing » 
Revenue Processing » Create Cost Transfer 
Journal Entries 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Cost and Revenue Processing » Utilities 

Miscellaneous Toolkits » Assign Account Function 
Codes* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Assign Account 
Function Codes 

Miscellaneous Toolkits » Check Pool Acct/Org 
Setups* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Validate Pool 
Acct/Org Setups 

Miscellaneous Toolkits » Update Contract and 
Funded Values* Not in Costpoint Web Projects » Project Setup » Project Setup Utilities » 

Update Project Contract and Funded Values 

Miscellaneous Toolkits » Update Period of 
Performance* Not in Costpoint Web Projects » Project Setup » Project Setup Utilities » 

Update Project Period of Performance 

Miscellaneous Toolkits » Compare 
Project Ledger to General Ledger* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Compare 
Project Ledger to General Ledger 

Miscellaneous Toolkits » Update Prior Years Units 
Columns* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Set Up Validations Using 
POA* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Display Invalid Pools in 
Project Ledger* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » View Invalid 
Pools in Project Ledger 

Miscellaneous Toolkits » Fix Invalid Pools in Project 
Ledger* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Repair Invalid 
Pools in Project Ledger 

Miscellaneous Toolkits » Synchronize Project 
Master and Project Edit Tables* Not in Costpoint Web Projects » Project Setup » Administrative Utilities » 

Synchronize Project Master Data and Project Edit 
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Data 

Miscellaneous Toolkits » Check and/or Rebuild 
Project Segment IDs* Not in Costpoint Web Projects » Project Setup » Administrative Utilities » 

Check and/or Rebuild Project Segment IDs 

Miscellaneous Toolkits » Copy Pools* Not in Costpoint Web Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Copy Pools 

Miscellaneous Toolkits » Fix Vendor Employee ID 
in Labor History* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Set Level Correctly in 
Project Master* Not in Costpoint Web Projects » Project Setup » Administrative Utilities » 

Set Project Level Correctly in Project Master 

Miscellaneous Toolkits » Check for Unposted 
Journals* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Check for 
Unposted Journals 

Miscellaneous Toolkits » Change Period Report 
Parameters* Not in Costpoint Web 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Change Period 
Report Parameters 

Miscellaneous Toolkits » Delete Duplicate 
Project/Account Combinations* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Update POA Table with 
Valid Links/Reference Numbers* Not in Costpoint Web 

Projects » Project Setup » Administrative Utilities » 
Update POA Table with Valid Links/Reference 
Numbers 

Miscellaneous Toolkits » Activate/Inactivate 
Project* Not in Costpoint Web Projects » Project Setup » Project Setup Utilities » 

Activate/Inactive Projects 

Miscellaneous Toolkits » Group Duplicates in Labor 
History* Not in Costpoint Web 

Projects » Cost and Revenue Processing » 
Administrative Utilities » Group Duplicates in Labor 
History 

Miscellaneous Toolkits » Compute Account Org 
Burden Rates* Not in Costpoint Web Not in Costpoint 7.0 

Process Organization Changes Projects » Process » Project » Process 
Organization Changes 

Projects » Cost and Revenue Processing » Project 
Cost Processing » Process Organization Changes 
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Reverse Posted Pool and Revenue Journals Not in Costpoint Web 
Projects » Cost and Revenue Processing » 
Revenue Processing » Reverse Posted Pool and 
Revenue Journals 

Reverse Posted Journal Entry Not in Costpoint Web Accounting » General Ledger » Journal Entry 
Processing » Reverse Posted Journal Entry 

Rebuild Labor History Not in Costpoint Web Projects » Cost and Revenue Processing » 
Administrative Utilities » Rebuild Labor History 

Summarize Project Ledger Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Summarize 
Project Ledger 

Summarize Project Goal Detail Projects » Utilities » Project Toolkits » Summarize 
Project Goal Detail 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Summarize 
Project Goal Detail 

Apply Indirect Costs Projects » Utilities » Project Toolkits » Apply 
Indirect Costs to Summarized Project Ledger 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Apply Indirect 
Costs to Summarized Project Ledger 

Purge Project and Billing Information Not in Costpoint Web Projects » Project Setup » Administrative Utilities » 
Purge Project and Billing Information 

Purge Allocation Basis Journal History Projects » Utilities » Purge » Purge Allocation Basis 
Journal History 

Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Utilities » Purge 
Allocation Basis Journal History 

Synchronize Project Performance Tables Not in Costpoint Web 
Projects » Cost and Revenue Processing » 
Administrative Utilities » Synchronize Project 
Performance Tables 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 



Projects  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 72 

 

Inquiry and Reporting 

Report Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Inquiry and Reporting » Report Processing 

Compute and Print Commitments Projects » Process » Project » Compute and Print 
Purchasing Commitments 

Projects » Project Inquiry and Reporting » Report 
Processing » Compute/Print Purchasing 
Commitments 

Update Project Status Report Table Projects » Process » Project » Update Project 
Status Report Table 

Projects » Project Inquiry and Reporting » Report 
Processing » Update Project Status Report Tables 

Create Project Report Tables Projects » Process » Project » Update Other 
Project Report Tables 

Projects » Project Inquiry and Reporting » Report 
Processing » Create Project Report Tables 

Inquiry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Inquiry and Reporting » Inquiry 

Project Inquiry Projects » Review » Project » Project Inquiry Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » View Project Activity 

Project Inquiry by Level Projects » Review » Project » Project Inquiry by 
Level 

Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » View Project Activity by Level 

Project Ledger Inquiry Projects » Review » Project » Project Ledger 
Inquiry 

Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » View Project Ledger Activity 
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Project Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Inquiry and Reporting » Project Reporting 

Print Project Status Report Projects » Review » Project » Project Status Report Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print Project Status Report 

Print Revenue Summaries Projects » Review » Project » Revenue Summary 
Report 

Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print Revenue Summary Report 

Print Project Labor Summary Projects » Review » Project » Project Labor 
Summary Report 

Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print Project Labor Summary 
Report 

Print Project Non-Labor Detail Projects » Review » Project » Project Non-Labor 
Detail Report 

Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print Project Non-Labor Detail 
Report 

Print T&M Analysis Projects » Review » Project » T&M Analysis Report Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print T&M Analysis Report 

Print Revenue Worksheet Projects » Review » Project » Revenue Worksheet Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print Revenue Worksheet 

Print Organization Cost Summary Projects » Review » Project » Organization Cost 
Summary Report 

Projects » Project Inquiry and Reporting » Project 
Reports/Inquiries » Print Organization Cost 
Summary Report 
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Initialization Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Inquiry and Reporting » Initialization Reports 

Print Project Setup Report Not in Costpoint Web Projects » Project Setup » Project Master » Print 
Project Setup Reports 

Print Project Master Reports Projects » Review » Initialization Reports » Project 
Master Reports 

Projects » Project Setup » Project Master » Print 
Project Master Reports 

Print Project Work Force Projects » Review » Initialization Reports » Project 
Work Force Report 

Projects » Project Setup » Project Labor » Print 
Project Work Force Report 

Print Pool Setup Projects » Review » Initialization Reports » Pool 
Setup Report 

Projects » Cost and Revenue Processing » Cost 
Pools » Print Cost Pool Setup Report 

Print Service Center Setup Not in Costpoint Web Projects » Cost and Revenue Processing » Cost 
Pools » Print Service Center Setup Report 

Print Pool Rate Listing Projects » Review » Initialization Reports » Pool 
Rate Listing Report 

Projects » Cost and Revenue Processing » Cost 
Pools » Print Cost Pool Rates Report 

Print Exception Reports Not in Costpoint Web Projects » Project Setup » Project Master » Print 
Project Exception Report 

Print Project Account Group Setup Report Not in Costpoint Web Projects » Project Setup » Project Setup Controls » 
Print Project Account Group Setup Report 

Print Project Formulas Not in Costpoint Web Projects » Project Setup » Revenue » Print Project 
Revenue and Billing Formulas 
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Billing 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Controls 

Billing Settings Not in Costpoint Web Projects » Billing » Billing Controls » Configure 
Billing Settings 

Maintain WAWF Billing Settings Administration » Configure » Projects » WAWF 
Billing Settings 

Projects » Billing » Billing Controls » Configure 
WAWF Billing Settings 

Maintain Other Charges Projects » Configure » Billing » Other Billing 
Charges 

Projects » Billing » Billing Controls » Manage Other 
Charges 

Maintain Billing Accounts Not in Costpoint Web Projects » Billing » Billing Controls » Manage Billing 
Accounts 

Remittance Addresses Projects » Configure » Billing » Remittance 
Addresses 

Projects » Billing » Billing Controls » Manage 
Remittance Addresses 

Govt. Payment Offices Not in Costpoint Web Projects » Billing » Billing Controls » Manage 
Government Payment Offices 

Contractor Addresses Not in Costpoint Web Projects » Billing » Billing Controls » Manage 
Contractor Addresses 

Billing Cycle Projects » Configure » Billing » Billing Cycles Projects » Billing » Billing Controls » Manage Billing 
Cycles 

Billing User Groups Projects » Configure » Billing » Billing User Groups Projects » Billing » Billing Controls » Manage Billing 
User Groups 

Billing Standard Text Not in Costpoint Web Projects » Billing » Billing Controls » Manage Billing 
Standard Text 
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Taxable Sales Account Not in Costpoint Web Projects » Billing » Billing Controls » Manage 
Taxable Sales Accounts 

Formats 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Formats 

Generic Billing Formats Projects » Maintain » Billing » Generic Billing 
Formats 

Projects » Billing » Billing Formats » Manage 
Generic Billing Formats 

Supporting Schedule Formats Projects » Maintain » Billing » Supporting Schedule 
Formats 

Projects » Billing » Billing Formats » Manage 
Supporting Schedule Formats 

Billing Master 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Billing Master 

Project Billing Info Projects » Maintain » Billing » Project Billing 
Information 

Projects » Billing » Billing Master » Manage Project 
Billing Information 

Maintain ACRN Bills Projects » Maintain » Billing » Maintain ACRN Bills Projects » Billing » Billing Master » Manage ACRN 
Bills 

Maintain Project WAWF Information Projects » Maintain » Billing » Project WAWF 
Information 

Projects » Billing » Billing Master » Manage Project 
WAWF Information 

Project Sales Tax Setup Not in Costpoint Web Projects » Billing » Billing Master » Manage Project 
Sales Tax Setups 

Maintain Account Discounts Projects » Maintain » Billing » Account Discounts Projects » Billing » Billing Master » Manage 
Account Discounts 
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Maintain Customer Volume Discounts Projects » Maintain » Billing » Customer Volume 
Discounts 

Projects » Billing » Billing Master » Manage 
Customer Volume Discounts 

Maintain Project Volume Discounts Projects » Maintain » Billing » Project Volume 
Discounts 

Projects » Billing » Billing Master » Manage Project 
Volume Discounts 

Units Usage 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Units Usage 

Enter Unit Usage Projects » Transactions » Units » Enter Units 
Usage 

Projects » Billing » Units Usage Processing » 
Manage Unit Usage 

Upload Unit Usage Data Projects » Utilities » Import » Import Units Usage 
Data 

Projects » Billing » Units Usage Processing » 
Import Units Usage Files 

Print Usage Edit Report Projects » Transactions » Units » Units Usage Edit 
Report 

Projects » Billing » Units Usage Processing » Print 
Usage Edit Report 

Post Unit Usage Projects » Process » Post » Post Units Usage Projects » Billing » Units Usage Processing » Post 
Unit Usage 

Maintain Units Usage History Not in Costpoint Web Projects » Billing » Units Usage Processing » 
Manage Units Usage History 

Print Units Usage History Report Projects » Configure » Units History » Units Usage 
History Report 

Projects » Billing » Units Usage Processing » Print 
Units Usage History Report 
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Prepare Billings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Prepare Billings 

Maintain Open Billing Detail Projects » Maintain » Billing » Open Billing Detail Projects » Billing » Standard Bill Adjustments » 
Manage Open Billing Detail 

Adjustments in Open Billing Detail Projects » Process » Billing » Adjust Open Billing 
Detail 

Projects » Billing » Standard Bill Adjustments » 
Adjust Open Billing Detail Records 

Update Cash Basis Information Projects » Process » Billing » Update Cash Basis 
Bills 

Projects » Billing » Standard Bills Processing » 
Update Cash Basis Information 

Update Subcontractor Progress Payments Not in Costpoint Web 
Projects » Billing » Progress Payment Bills 
Processing » Update Subcontractor Progress 
Payments 

Load Labor Rates Projects » Process » Billing » Load Labor Rates 

Projects » Billing » Progress Payment Bills 
Processing » Load Labor Rates 

Projects » Billing » Standard Bills Processing » 
Load Labor Rates 

Calculate Billings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Calculate Billings 

Calculate Billings Projects » Process » Billing » Calculate Bills Projects » Billing » Standard Bills Processing » 
Calculate Standard Bills 

Calculate ACRN Billings Projects » Process » Billing » Calculate ACRN Bills Projects » Billing » Standard Bills Processing » 
Calculate ACRN Bills 

Calculate Progress Payment Billings Projects » Process » Billing » Calculate Progress Projects » Billing » Progress Payment Bills 
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Payment Bills Processing » Calculate Progress Payment Bills 

Calculate Retroactive Billings Projects » Process » Billing » Calculate Retroactive 
Bills 

Projects » Billing » Standard Bills Processing » 
Calculate Retroactive Bills 

Reverse Previous Billings Projects » Process » Billing » Reverse Previous 
Bills 

Projects » Billing » Standard Bills Processing » 
Reverse Previous Bills 

Edit Billings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Edit Billings 

Edit Standard Bills Projects » Transactions » Billing » Edit Standard 
Bills 

Projects » Billing » Standard Bills Processing » 
Manage Standard Bills 

Edit Progress Payment Billings Projects » Transactions » Billing » Edit Progress 
Payment Bills 

Projects » Billing » Progress Payment Bills 
Processing » Manage Progress Payment Bills 

Select Bills for Posting Projects » Transactions » Billing » Select Bills for 
Posting 

Projects » Billing » Standard Bills Processing » 
Select Bills for Posting 

Edit Customer Product Bills Projects » Transactions » Billing » Enter Customer 
Product Bills 

Projects » Billing » Customer Product Bills 
Processing » Manage Customer Product Bills 

Edit Project Product Bills Projects » Transactions » Billing » Enter Project 
Product Bills 

Projects » Billing » Project Product Bills Processing 
» Manage Project Product Bills 

Edit Manual Bills Projects » Transactions » Billing » Enter Manual 
Bills 

Projects » Billing » Manual Bills Processing » 
Manage Manual Bills 

Edit Milestone/Percent Complete Bills Projects » Transactions » Billing » Enter 
Milestone/Percent Complete Bills 

Projects » Billing » Milestone Percent Complete 
Bills Processing » Manage Milestone Percent 
Complete Bills 
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Print Billings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Print Billings 

Print ACRN Billing Edit Report Projects » Transactions » Billing » Print ACRN 
Billing Edit Report 

Projects » Billing » Standard Bills Processing » 
Print ACRN Billing Edit Report 

Print Standard Bills Projects » Transactions » Billing » Print Standard 
Bills 

Projects » Billing » Standard Bills Processing » 
Print Standard Bills 

Print Form 1034 Projects » Transactions » Billing » Print Form 1034 Projects » Billing » Standard Bills Processing » 
Print Form 1034 

Print Progress Payment Bills Projects » Transactions » Billing » Print Progress 
Payment Bills 

Projects » Billing » Progress Payment Bills 
Processing » Print Progress Payment Bills 

Print Customer Product Bills Projects » Transactions » Billing » Print Customer 
Product Bills 

Projects » Billing » Customer Product Bills 
Processing » Print Customer Product Bills 

Print Project Product Bills Projects » Transactions » Billing » Print Project 
Product Bills 

Projects » Billing » Project Product Bills Processing 
» Print Project Product Bills 

Print Retroactive Billing Worksheets Projects » Transactions » Billing » Print Retroactive 
Bill Worksheets 

Projects » Billing » Standard Bills Processing » 
Print Retroactive Billing Worksheet 

Print Milestone/Percent Complete Bills Projects » Transactions » Billing » Print 
Milestone/Percent Complete Bills 

Projects » Billing » Milestone Percent Complete 
Bills Processing » Print Milestone Percent 
Complete Bills 

Create WAWF Billing Files Projects » Process » Billing » Create WAWF Billing 
Files 

Projects » Billing » Standard Bills Processing » 
Create WAWF Billing Files 
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Post Billings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Post Billings 

Post Standard Bills Projects » Process » Post » Post Standard Bills Projects » Billing » Standard Bills Processing » 
Post Standard Bills 

Post Progress Payment Bills Projects » Process » Post » Post Progress 
Payment Bills 

Projects » Billing » Progress Payment Bills 
Processing » Post Progress Payment Bills 

Post Customer Product Bills Projects » Process » Post » Post Customer Product 
Bills 

Projects » Billing » Customer Product Bills 
Processing » Post Customer Product Bills 

Post Project Product Bills Projects » Process » Post » Post Project Product 
Bills 

Projects » Billing » Project Product Bills Processing 
» Post Project Product Bills 

Post Manual Bills Projects » Process » Post » Post Manual Bills Projects » Billing » Manual Bills Processing » Post 
Manual Bills 

Post Milestone/Percent Complete Bills Projects » Process » Post » Post Milestone/Percent 
Complete Bills 

Projects » Billing » Milestone Percent Complete 
Bills Processing » Post Milestone Percent 
Complete Bills 

Inquiry and Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Inquiry and Reporting 

Standard Billing History Inquiry Not in Costpoint Web Projects » Billing » Billing Reports/Inquiries » View 
Standard Billing History 

Print Open Billing Detail Projects » Review » Billing » Open Billing Detail 
Report 

Projects » Billing » Billing Reports/Inquiries » Print 
Open Billing Detail Report 
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Print Billing Register Projects » Review » Billing » Billing Register Report Projects » Billing » Billing Reports/Inquiries » Print 
Billing Register 

Billing History 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Billing History 

Maintain Billing History Not in Costpoint Web Projects » Billing » Billing History » Manage Billing 
History 

Maintain Project Bill Summary Not in Costpoint Web Projects » Billing » Billing History » Manage Project 
Bill Summary 

Maintain Closed Billing Detail Projects » Configure » Billing History » Posted 
Billing Detail 

Projects » Billing » Billing History » Manage Closed 
Billing Detail 

Maintain Closed Progress Billing Detail Not in Costpoint Web Projects » Billing » Billing History » Manage Closed 
Progress Billing Detail 

Maintain Subcontractor Progress Payments Projects » Configure » Billing History » 
Subcontractor Progress Payments 

Projects » Billing » Billing History » Manage 
Subcontractor Progress Payments 

Unbilled Receivables 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Unbilled Receivables 

Maintain Unbilled Reason Codes Projects » Transactions » Unbilled Receivables » 
Assign Unbilled Reason Codes 

Projects » Billing » Unbilled Receivables » Manage 
Unbilled Reason Codes 

Create Unbilled Analysis Report Projects » Process » Unbilled Receivables » 
Update Unbilled Analysis Report Tables 

Projects » Billing » Unbilled Receivables » Create 
Unbilled Analysis Report Tables 
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Edit Unbilled Reason Codes Projects » Transactions » Unbilled Receivables » 
Assign Unbilled Reason Codes 

Projects » Billing » Unbilled Receivables » Edit 
Unbilled Reason Codes 

Print Unbilled Analysis Projects » Review » Unbilled Receivables » 
Unbilled Analysis Report 

Projects » Billing » Unbilled Receivables » Print 
Unbilled Analysis Report 

EDI Billing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » EDI Billing 

Maintain Billing EDI Settings Administration » Configure » Projects » Billing EDI 
Settings 

Projects » Billing » Billing Controls » Configure 
Billing EDI Settings 

Maintain Project EDI Information Not in Costpoint Web Projects » Billing » Billing Controls » Manage 
Project EDI Information 

Create Billing EDI Files Projects » Process » Billing » Create Billing EDI 
Files 

Projects » Billing » EDI Billing Processing » Create 
EDI Files 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Billing » Utilities 

Update Open Billing Detail Projects » Utilities » Project Toolkits » Update Open 
Billing Detail 

Projects » Billing » Open Billing Detail Utilities » 
Update Open Billing Detail Records 

Purge Open Billing Detail Not in Costpoint Web Projects » Billing » Open Billing Detail Utilities » 
Purge Open Billing Detail Records 

Miscellaneous Toolkits » Assign Source Project 
IDs* Not in Costpoint Web Not in Costpoint 7.0.1  

Miscellaneous Toolkits » Open Billing Detail 
Account Function Code Toolkit* Not in Costpoint Web Projects » Billing » Administrative Utilities » 
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Validate Open Billing Detail Account Function 
Codes 

Miscellaneous Toolkits » Manual Bill Edit Serial No 
Fix* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Billing Sum Item Key Fix* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Open Billing Detail Item 
Key Fix* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Project Product Invoice 
Line Item Key Fix* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Open Billing Detail Labor 
Toolkit* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Billing Detail History Item 
Key Fix* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Validate Units Transaction 
Type Records* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Update Billing Tables 
BillLabCatDescr* Not in Costpoint Web Projects » Billing » Administrative Utilities » Update 

Billing Tables Bill Labor Category Description 

Miscellaneous Toolkits » Update Billing Tables for 
Cumulative Tax* Not in Costpoint Web Projects » Billing » Administrative Utilities » Update 

Billing Tables for Cumulative Tax 

Miscellaneous Toolkits » Update Billing Currency 
Amounts* Not in Costpoint Web Projects » Billing » Administrative Utilities » Update 

Billing Currency Amounts 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 
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NASA 533s 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » NASA 533s 

Map Fiscal Years for Reporting Not in Costpoint Web Projects » NASA 533s » NASA 533 Controls » 
Configure NASA 533 Fiscal Years 

Map Accounting Periods for Reporting Not in Costpoint Web Projects » NASA 533s » NASA 533 Controls » 
Configure NASA 533 Accounting Periods 

Formats Not in Costpoint Web Projects » NASA 533s » NASA 533 Processing » 
Manage NASA 533 Formats 

Project Info Not in Costpoint Web Projects » NASA 533s » NASA 533 Processing » 
Manage NASA 533 Project Information 

Create NASA 533s Not in Costpoint Web Projects » NASA 533s » NASA 533 Processing » 
Create NASA 533 Report Tables 

Print NASA 533s Not in Costpoint Web Projects » NASA 533s » NASA 533 Processing » 
Print NASA 533 Report 
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Inter-Company Work Orders 

Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Inter-Company Work Orders » Controls 

IWO Expense Mapping Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Processing » Manage IWO 
Expense Mappings 

Maintain Transfer Locations Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Controls » Configure 
Transfer Locations 

IWO Project Setup Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Processing » Manage IWO 
Projects 

Inter-Company Work Orders 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Projects » Inter-Company Work Orders 

Create IWO Allocations Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Processing » Create IWO 
Allocations 

Maintain IWO Allocations Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Processing » Manage IWO 
Allocations 

Post IWO Journal Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Processing » Post IWO 
Journal 
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Export IWO Allocations Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Interfaces » Export IWO 
Allocations 

Import IWO Allocations Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Interfaces » Import IWO 
Allocations 

IWO Allocation Preprocessor Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Interfaces » Validate IWO 
Allocations 

Maintain IWO Suspense Not in Costpoint Web 
Projects » Inter-Company Work Orders » Inter-
Company Work Orders Interfaces » Validate IWO 
Suspense Transactions 
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People 

Employee 

Employee Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee Controls 

Employee Class People » Configure » Employee » Employee Class 
Codes 

People » Employee » Employee Controls » Manage 
Employee Class Codes 

Life Event Codes Not in Costpoint Web People » Employee » Employee Controls » Manage 
Life Event Codes 

VISA Types Not in Costpoint Web People » Employee » Employee Controls » Manage 
Visa Types 

Employee User-Defined Labels Not in Costpoint Web People » Employee » Employee Controls » Manage 
Employee User-Defined Labels 

Race/Ethnicity Codes Not in Costpoint Web People » Employee » Employee Controls » Manage 
Race and Ethnicity Codes 

Basic Employee Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee »  Basic Employee Setup 

Maintain Employee Master People » Maintain » Employee » Employee User 
Flow 

People » Employee » Basic Employee Information 
» Manage Employee Information 

Basic Employee Info People » Maintain » Employee » Employee User People » Employee » Basic Employee Information 
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Flow » Manage Employee Information 

Salary Info and History People » Maintain » Employee » Employee Salary 
Information 

People » Employee » Basic Employee Information 
» Manage Employee Salary Information 

Employee User-Defined Info People » Maintain » Employee » Employee User-
Defined Information 

People » Employee » Basic Employee Information 
» Manage Employee User-Defined Information 

Maintain Leave Beginning Balances People » Maintain » Employee » Employee Leave 
Beginning Balances 

People » Employee » Employee Leave Information 
» Manage Leave Beginning Balances 

Employee Leave People » Maintain » Employee » Employee Leave People » Employee » Employee Leave Information 
» Manage Employee Leave 

Employee Life Events Not in Costpoint Web People » Employee » Basic Employee Information 
» Manage Employee Life Events 

Maintain Employee Allowances People » Maintain » Employee » Employee 
Allowances 

People » Employee » Basic Employee Information 
» Manage Employee Allowances 

Authorized Labor Categories People » Maintain » Employee » Assign GLCs to 
Employees 

People » Employee » Basic Employee Information 
» Assign GLCs to Employees 

Employee Payroll Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee Payroll Setup 

Employee Taxes Not in Costpoint Web People » Employee » Employee Payroll Information 
» Manage Employee Taxes 

Employee Deductions Not in Costpoint Web People » Employee » Employee Payroll Information 
» Manage Employee Deductions 

Employee Contributions Not in Costpoint Web People » Employee » Employee Payroll Information 
» Manage Employee Contributions 



People  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 90 

 

Maintain Employee Bank Info Not in Costpoint Web People » Employee » Employee Payroll Information 
» Manage Employee Bank Information 

Employee Bond Table Not in Costpoint Web People » Employee » Employee Payroll Information 
» Manage Employee Savings Bonds 

Employee Government Mandated Orders Not in Costpoint Web Not in Costpoint 7.0 

Employee Garnishments Not in Costpoint Web People » Employee » Employee Payroll Information 
» Manage Employee Garnishments 

Employee HR Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee HR Setup 

I-9 Data Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Employee I-9 Data 

Employee Drug Testing Results Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Employee Drug Testing Results 

Employee Medical Surveillance Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Employee Medical Surveillance Log 

Education, Skills & Training Data Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Education, Skills & Training Data 

Maintain Employee Awards Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Employee Awards 

Employee Photo Not in Costpoint Web People » Employee » Basic Employee Information 
» Manage Employee Photo File Locations 

Security Status by Employee Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Employee Security Status 
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Company Issued Documents by Employee Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Company Issued Documents 

Company Property Issued to Employee Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Company Issued Property 

Company Vehicles by Employee Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Company Issued Vehicles 

State Driver's License by Employee Not in Costpoint Web People » Employee » Employee HR Information » 
Manage Employee State Driver's License 

Employee Deferred Comp Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee Deferred Comp Setup 

Employee Deferred Compensation Info Not in Costpoint Web 
People » Employee » Employee Deferred 
Compensation Information » Manage 
Employee Deferred Compensation 

Deferred Comp Beneficiary Info Not in Costpoint Web Not in Costpoint 7.0 

Employee Related Parties Not in Costpoint Web Not in Costpoint 7.0 
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Employee Benefit Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee Benefit Setup 

Employee Benefit Elections Not in Costpoint Web People » Employee » Employee Benefit Information 
» Manage Employee Benefit Elections 

Employee Dependents/Beneficiaries Not in Costpoint Web People » Employee » Employee Benefit Information 
» Manage Employee Dependents/Beneficiaries 

Assign Dependents to Benefit Plans Not in Costpoint Web People » Employee » Employee Benefit Information 
» Assign Dependents to Benefit Plans 

Assign Beneficiaries to Benefit Plans Not in Costpoint Web People » Employee » Employee Benefit Information 
» Assign Beneficiaries to Benefit Plans 

Employee FSA Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee FSA Setup 

Employee Dependent Care FSA Elections Not in Costpoint Web People » Employee » Employee FSA Information » 
Manage Employee Dependent Care FSA Elections 

Employee Medical Care FSA Elections Not in Costpoint Web People » Employee » Employee FSA Information » 
Manage Employee Medical Care FSA Elections 

Request Dependent Care Reimbursement Not in Costpoint Web People » Employee » Employee FSA Information » 
Manage Dependent Care Reimbursement 

Maintain Dependent Care History Not in Costpoint Web People » Employee » Employee FSA Information » 
Manage Dependent Care FSA History 

Request Medical Care Reimbursement Not in Costpoint Web People » Employee » Employee FSA Information » 
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Manage Medical Care Reimbursement 

Maintain Medical Care History Not in Costpoint Web People » Employee » Employee FSA Information » 
Manage Medical Care FSA History 

Employee Performance Reviews 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee Performance Reviews 

Print Review Form Template Not in Costpoint Web People » Employee » Performance Review 
Processing » Print Review Form Template 

Maintain Employee Review Info Not in Costpoint Web People » Employee » Performance Review 
Processing » Manage Employee Review 

Print Completed Review Form Not in Costpoint Web People » Employee » Performance Review 
Processing » Print Completed Review Forms 

Update Employee Salary Based on Review Not in Costpoint Web 
People » Employee » Performance Review 
Processing » Update Employee Salary Based on 
Review 

Print Review Statistics by Employee Not in Costpoint Web People » Employee » Performance Review 
Processing » Print Performance Review Statistics 
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Employee Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Employee Reports 

Print Employee Setup Report People » Review » Employee » Employee Setup 
Report 

People » Employee » Employee Reports » Print 
Employee Setup Report 

Print Employee Basic Report People » Review » Employee » Basic Employee 
Information Report 

People » Employee » Employee Reports » Print 
Employee Basic Report 

Print Employee Salary Info and History Rpt People » Review » Employee » Employee Salary 
Information Report 

People » Employee » Employee Reports » Print 
Employee Salary Information Report 

Print Remittance of Government Mandated Orders Not in Costpoint Web Not in Costpoint 7.0 

Print Employee Medical Surveillance Data Not in Costpoint Web People » Employee » Employee Reports » Print 
Employee Medical Surveillance Data Report 

Print Employees by Job Title Not in Costpoint Web People » Employee » Employee Reports » Print 
Employee Job Title Report 

Print Employee Awards Not in Costpoint Web People » Employee » Employee Reports » Print 
Employee Awards List 

FLSA Status Report Not in Costpoint Web People » Employee » Employee Reports » Print 
FLSA Status Report 

Print New Hire Report Not in Costpoint Web People » Employee » Employee Reports » Print 
New Hire Report 
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Mass Updates 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Mass Updates 

Update Employee Deduction/Contributions Not in Costpoint Web People » Employee » Employee Payroll Information 
» Update Employee Deductions/Contributions 

Auto Load Employee Government Orders Not in Costpoint Web Not in Costpoint 7.0 

Auto Load Employee Deferred Compensation Info Not in Costpoint Web 
People » Employee » Employee Deferred 
Compensation Information » Update  Employee 
Deferred Compensation Info 

Update Employees for Compensation Plan 
Changes Not in Costpoint Web People » Employee » Basic Employee Information 

» Update Salaries for Compensation Plan Changes 

Update Employees for Manager Change Not in Costpoint Web People » Employee » Basic Employee Information 
» Update Employees for Manager Change 

Update Employee Training Not in Costpoint Web People » Employee » Employee HR Information » 
Update Employee Training 

Update Employee Affirmative Action Plan Not in Costpoint Web People » Employee » Basic Employee  Information 
» Update Employee Affirmative Action Plan 

Update Employee Service Awards Not in Costpoint Web People » Employee » Employee HR Information » 
Update Employee Service Awards 
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Termination Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Employee » Termination Processing 

Print Exit Interview Form Template Not in Costpoint Web People » Employee » Termination Processing » 
Print Exit Interview Form Template 

Maintain Employee Exit Interview Info Not in Costpoint Web People » Employee » Termination Processing » 
Manage Employee Exit Interviews 

Print Completed Exit Interview Form Not in Costpoint Web People » Employee » Termination Processing » 
Print Completed Exit Interview Form 

Employee COBRA Dependents People » Transactions » Employee Termination » 
Enter COBRA Employee Dependents Not in Costpoint 7.0 

Track COBRA Elections People » Transactions » Employee Termination » 
Enter Employee COBRA Elections Not in Costpoint 7.0 

Print Notification Letters People » Transactions » Employee Termination » 
Print COBRA Notification Letters Not in Costpoint 7.0 

Print Coupon Book/Create Invoice People » Transactions » Employee Termination » 
Print COBRA Coupons/Create Invoice Not in Costpoint 7.0 
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Labor 

Labor Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Labor Controls 

Labor Settings Not in Costpoint Web People » Labor » Labor Controls » Configure Labor 
Settings 

Timesheet Periods Not in Costpoint Web People » Labor » Timesheet Entry/Creation » 
Manage Timesheet Periods 

Pay Types People » Configure » Labor » Pay Types People » Labor » Labor Rate Controls » Manage 
Pay Types 

General Labor Categories People » Configure » Labor » General Labor 
Categories 

People » Labor » Labor Controls » Manage 
General Labor Categories 

Worker's Comp Codes People » Configure » Work-Related Injuries-
Illnesses » Workers’ Compensation Codes 

People » Labor » Labor Controls » Manage 
Workers' Compensation Codes 

Labor Rate Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Labor Rate Controls 

Labor Groups/Unions People » Configure » Labor » Labor Groups/Unions People » Labor » Labor Rate Controls » Manage 
Labor Groups/Unions 

Labor Locations/Locals People » Configure » Labor » Labor 
Locations/Locals 

People » Labor » Labor Rate Controls » Manage 
Labor Locations/Locals 

Wage Determination Rates People » Configure » Labor » Wage Determination People » Labor » Labor Rate Controls » Manage 
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Rates Wage Determination Rates 

WD Fringe Handling Not in Costpoint Web People » Labor » Labor Rate Controls » Manage 
Wage Determination Fringe Charge Codes 

Allowances People » Configure » Payroll » Allowances People » Labor » Labor Rate Controls » Manage 
Allowance Codes 

Map Allowance Accounts People » Configure » Payroll » Allowance Account 
Mappings 

People » Labor » Labor Rate Controls » Manage 
Allowance Account Mapping 

Pay Type Restrictions People » Configure » Labor » Pay Type 
Restrictions 

People » Labor » Labor Rate Controls » Manage 
Pay Type Restrictions 

Overtime Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Overtime Controls 

Overtime Settings Administration » Configure » People » Overtime 
Settings 

People » Labor » Labor Controls » Configure Labor 
Settings  

Overtime Premium Recast People » Configure » Overtime » Overtime 
Premium Recast 

People » Labor » Overtime Controls » Manage 
Overtime Premium Recast Charge Codes 

Weighted Average Overtime Setup Not in Costpoint Web People » Labor » Overtime Controls » Configure 
Weighted Average Overtime Settings 

Overtime Rules by Location People » Configure » Overtime » Overtime Rules 
by Location 

People » Labor » Overtime Controls » Manage 
Overtime Rules by Location 

Overtime Rules by State People » Configure » Overtime » Overtime Rules 
by State 

People » Labor » Overtime Controls » Manage 
Overtime Rules by State 
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Union Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Union Info 

Fringe Code Setup People » Configure » Labor » Union Fringe Codes People » Labor » Union Information Controls » 
Manage Fringe Codes 

Fringe Modify Code People » Configure » Labor » Union Fringe Modify 
Codes 

People » Labor » Union Information Controls » 
Manage Fringe Modify Codes 

Crew Assignment Not in Costpoint Web People » Labor » Union Information Controls » 
Manage Assignment of Employees to Crews 

Union Profile Not in Costpoint Web People » Labor » Union Information Controls » 
Manage Union Profile Setup 

Mass Update of Fringes Not in Costpoint Web People » Labor » Union Information Controls » 
Update Fringe Table in Union Profile 

Union Fringe Ceilings by Local Not in Costpoint Web People » Labor » Union Information Controls » 
Manage Fringe Ceilings by Local 

Timesheet Default Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Timesheet Default Setup 

Timesheet Line Type Default Settings People » Maintain » Timesheet Defaults » 
Timesheet Line Type Defaults 

People » Labor » Timesheet Defaults » Manage 
Timesheet Line Type Defaults 

Employee Timesheet Line Type Defaults People » Maintain » Timesheet Defaults » 
Employee Timesheet Line Type Defaults 

People » Labor » Timesheet Defaults » Manage 
Employee Timesheet Line Type Defaults 

Employee Project TS Defaults Not in Costpoint Web People » Labor » Timesheet Defaults » Manage 
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Employee Project Timesheet Defaults 

Employee Project-Acct-Grp TS Defaults 
People » Maintain » Timesheet Defaults » 
Employee Project/Account Group Timesheet 
Defaults 

People » Labor » Timesheet Defaults » Manage 
Employee Proj-Acct-Group Timesheet Defaults 

Labor-Grp Project-Acct-Grp TS Defaults Not in Costpoint Web People » Labor » Timesheet Defaults » Manage 
Labor-Group Proj-Acct-Group Timesheet Defaults 

Project TS Defaults People » Maintain » Timesheet Defaults » Project 
Timesheet Defaults 

People » Labor » Timesheet Defaults » Manage 
Project Timesheet Defaults 

Timesheets 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Timesheets 

Enter Timesheets People » Transactions » Timesheets » Enter 
Timesheets 

People » Labor » Timesheet Entry/Creation » 
Manage Timesheets 

Enter Correcting Timesheets People » Transactions » Timesheets » Enter 
Correcting Timesheets 

People » Labor » Timesheet Entry/Creation » 
Manage Correcting Timesheets 

Enter Crew Timesheets Not in Costpoint Web Not in Costpoint 7.0 

Conversion of Crew Timesheets Not in Costpoint Web Not in Costpoint 7.0 

Print Missing Timesheet Rpt People » Transactions » Timesheets » Print 
Missing Timesheet List 

People » Labor » Timesheet Reporting » Print 
Missing Timesheet Report 

Print TS Edit by Empl Rpt People » Transactions » Timesheets » Print 
Timesheet Information by Employee 

People » Labor » Timesheet Reporting » Print 
Timesheet Information Report by Employee 

Print TS Edit by Acct Rpt People » Transactions » Timesheets » Print 
Timesheet Information by Account 

People » Labor » Timesheet Reporting » Print 
Timesheet Information Report by Account 
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Print TS Edit by Crew Rpt Not in Costpoint Web Not in Costpoint 7.0 

Post Labor Distribution People » Process » Post » Post Labor People » Labor » Timesheet Posting » Post 
Timesheets 

Print Timesheet History Rpt Not in Costpoint Web People » Labor » Labor Reports and Inquiries » 
Print Timesheet History Report 

Auto-Generation of Timesheets  
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Auto-Generation of Timesheets 

Create Auto-Pay Timesheets Not in Costpoint Web People » Labor » Timesheet Entry/Creation » 
Create Auto-Pay Timesheets 

Create Reversing Timesheets People » Process » Timesheets » Create 
Reversing Timesheets 

People » Labor » Timesheet Entry/Creation » 
Create Reversing Timesheets 

Create Leave Payout Timesheets People » Process » Timesheets » Create Leave 
Payout Timesheets 

People » Labor » Timesheet Entry/Creation » 
Create Leave Payout Timesheets 

Delete Leave Payout Timesheets Not in Costpoint Web People » Labor » Timesheet Entry/Creation » 
Delete Leave Payout Timesheets 

Create Retroactive Timesheet Adjustments People » Process » Timesheets » Create 
Retroactive Pay Timesheets 

People » Labor » Timesheet Entry/Creation » 
Create Retroactive Timesheet Adjustments 

Delete Retroactive Timesheet Adjustments People » Utilities » Timesheet » Delete Retroactive 
Timesheet Adjustments 

People » Labor » Timesheet Entry/Creation » 
Delete Retroactive Timesheet Adjustments 

Create Employee Allowance TS Lines Not in Costpoint Web People » Labor » Timesheet Adjustments » Create 
Employee Allowance Timesheet  Lines 

Delete Employee Allowance TS Lines People » Utilities » Timesheet » Delete Employee 
Allowance Timesheet Lines 

People » Labor » Timesheet Adjustments » Delete 
Employee Allowance Timesheet Lines 
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Auto-Adjust Timesheets in Batch Mode Not in Costpoint Web People » Labor » Timesheet Adjustments » Auto-
Adjust Timesheets 

Overtime Processing of Timesheets 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Overtime Processing of Timesheets 

Apply Weighted Average Rates Not in Costpoint Web People » Labor » Timesheet Adjustments » Apply 
Weighted Average Rates to Timesheets 

Recast Overtime Premium People » Process » Timesheets » Recast Overtime 
Premium 

People » Labor » Timesheet Adjustments » Recast 
Overtime Premium to Timesheet Lines 

Delete Recasted Overtime Premium People » Utilities » Timesheet » Delete Recasted 
Overtime Premium 

People » Labor » Timesheet Adjustments » Delete 
Recasted Overtime Premium from Timesheet Lines 

Alloc Comp OT Across TS Lines Not in Costpoint Web 
People » Labor » Timesheet Adjustments » 
Allocate Compensated Overtime Across Timesheet 
Lines 

Delete Allocated Comp OT People » Utilities » Timesheet » Delete Allocated 
Compensated Overtime 

People » Labor » Timesheet Adjustments » Delete 
Allocated Compensation OT from Timesheet Lines 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Inquiries 

Employee Labor Inquiry People » Review » Labor » Employee Labor Inquiry People » Labor » Labor Reports and Inquiries » 
View Employee Labor Inquiry 

Timesheet History Inquiry People » Review » Labor » Timesheet History 
Inquiry 

People » Labor » Labor Reports and Inquiries » 
View Timesheet History Inquiry 

Labor Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Labor Reports 

Print Employee Labor Summary Rpt People » Review » Labor » Employee Labor 
Summary Report 

People » Labor » Labor Reports and Inquiries » 
Print Employee Labor Summary Report 

Print Labor Utilization Report People » Review » Labor » Labor Utilization Report People » Labor » Labor Reports and Inquiries » 
Print Labor Utilization Report 

Print Tiered Fringe Analysis Report People » Review » Labor » Tiered Fringe Analysis 
Report Not in Costpoint 7.0 

Deltek T&E / Project Manufacturing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Deltek T&E / Project Manufacturing 

Time Collection Account Types Not in Costpoint Web People » Labor » Timesheet Interface » Manage 
Deltek Time & Expense Account Types 
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Time Collection Accounts Not in Costpoint Web People » Labor » Timesheet Interface » Manage 
Accounts for Export 

Time Collection Projects Not in Costpoint Web People » Labor » Timesheet Interface » Manage 
Projects for Export 

Time Collection Organizations Not in Costpoint Web People » Labor » Timesheet Interface » Manage 
Deltek Time and Expense Org 

Export Data to Deltek Time & Expense 5.x Not in Costpoint Web People » Labor » Timesheet Interface » Export 
Data to Deltek Time and Expense 

Export Data to Deltek Time Collection 3.x Not in Costpoint Web Not in Costpoint 7.0 

Export Data to Deltek ET 2.x Not in Costpoint Web Not in Costpoint 7.0 

Upload from Time Collection (ET) Not in Costpoint Web People » Labor » Timesheet Interface » Import 
Timesheets from Deltek Time and Expense 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Labor » Utilities 

Purge Timesheet History Not in Costpoint Web People » Labor » Administrative Utilities » Purge 
Timesheet History 

Purge Crew Timesheets Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Version 1.1 Timesheet 
Data Conversion* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Version 1.1 Fix Earnings 
SUTA Taxable Wages* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Reorder Employee 
Address Line Information* Not in Costpoint Web People » Employee » Employee Utilities » Change 

Employee Address Line Order 
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Miscellaneous Functions » Update Employee 
Telephone Types* Not in Costpoint Web People » Employee » Employee Utilities » Update 

Employee Telephone Types 

Miscellaneous Functions » Update 
Dependent/Beneficiary ID's* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Purge Labor History 
Table* Not in Costpoint Web People » Labor » Administrative Utilities » Purge 

Labor History Tables 

Miscellaneous Functions » Update Job Group 
Codes* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Update Salary Info and 
History* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Update TC 
Timesheet/Work Schedule* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Update Reference 
Paycheck Type* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Encrypt ESS PIN* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Update Life Event 
Change Period End Date* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Assign Benefit Package 
Defaults to Taxable Entities* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Update Missouri Filing 
Statuses and Allowance Amounts* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Export Used Leave to 
Deltek Time & Expense* Not in Costpoint Web 

People » Labor » Deltek Time and Expense 
Interface » Export Used Leave to Deltek Time & 
Expense 

Miscellaneous Functions » Convert Race/Ethnicity 
Codes* Not in Costpoint Web People » Employee » Employee Utilities » Convert 

Race/Ethnicity Codes to New Race Codes 

Miscellaneous Functions » Convert Employee Gov't  
Mandated Orders  to Employee Garnishments* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Update EEO-1 Codes* Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Functions » Create Leave Modifier 
Codes* Not in Costpoint Web Not in Costpoint 7.0 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 
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Leave 

Leave Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Leave » Leave Controls 

Leave Settings Administration » Configure » People » Leave 
Settings 

People » Leave » Leave Controls » Configure 
Leave Settings 

Leave Periods People » Configure » Leave » Leave Periods People » Leave » Leave Processing » Manage 
Leave Periods 

Leave Types People » Configure » Leave » Leave Types People » Leave » Leave Controls » Manage Leave 
Types 

Leave Modifier Codes Not in Costpoint Web People » Leave » Leave Controls » Manage Leave 
Modify Codes 

Leave Tables People » Configure » Leave » Leave Codes People » Leave » Leave Controls » Manage Leave 
Codes 

Leave Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Leave » Leave Processing 

Print Employee Leave Report People » Transactions » Leave » Print Employee 
Leave List 

People » Leave » Leave Processing » Print 
Employee Leave Report 

Compute Leave Accruals People » Transactions » Leave » Compute Leave 
Accruals 

People » Leave » Leave Processing » Compute 
Leave Accruals 

Maintain Leave Edit Table People » Transactions » Leave » Edit Employee People » Leave » Leave Processing » Manage 
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Leave Accruals Leave Edit Table 

Print Leave Edit Report People » Transactions » Leave » Print Leave Edit 
Accruals 

People » Leave » Leave Processing » Print Leave 
Edit Report 

Print Employee Leave Statements People » Transactions » Leave » Print Employee 
Leave Statements 

People » Leave » Leave Processing » Print 
Employee Leave Statements 

Post Leave Accruals People » Process » Post » Post Leave People » Leave » Leave Processing » Post Leave 
Accruals 

Print Accrued Leave Report People » Transactions » Leave » Print Accrued 
Leave  Balances 

People » Leave » Leave Processing » Print Leave 
Accrual Report 

Close Leave Period People » Process » Close » Close Leave Period People » Leave » Leave Processing » Close Leave 
Period 

Close Leave Year People » Transactions » Calendar-Year End » 
Close Leave Year 

People » Leave » Year-End Processing » Close 
Leave Year 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Leave » Inquiries 

Leave History Inquiry People » Review » Leave » Leave History Inquiry People » Leave » Leave Inquiries » View Leave 
History 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Leave » Utilities 

Purge Leave History People » Utilities » Purge » Purge Leave History People » Leave » Leave Utilities » Purge Leave 
History 
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Payroll 

Payroll Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Payroll Controls 

Payroll Settings Not in Costpoint Web People » Payroll » Payroll Controls » Configure 
Payroll Settings 

Payroll Reference Number Settings Not in Costpoint Web Not in Costpoint 7.0 

Pay Periods Not in Costpoint Web People » Payroll » Payroll Processing » Manage 
Pay Periods 

Pay Check Setup Not in Costpoint Web People » Payroll » Payroll Controls » Configure 
Paycheck Settings 

Direct Deposit Setup Not in Costpoint Web People » Payroll » Payroll Controls » Configure 
Direct Deposit Settings 

Deductions Not in Costpoint Web People » Payroll » Deductions » Manage 
Deductions 

Deduction Schedules Not in Costpoint Web People » Payroll » Deductions » Manage Deduction 
Schedules 

Pay Type Taxability Not in Costpoint Web People » Payroll » Payroll Controls » Manage Pay 
Type Taxability 

Setup Modify Codes Not in Costpoint Web People » Payroll » Deductions » Manage Deduction 
Modify Codes 

Worker's Comp State Rates Not in Costpoint Web People » Payroll » Payroll Controls » Manage 
Workers' Compensation State Rates 
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Worker's Comp Modify Codes Not in Costpoint Web People » Payroll » Payroll Controls » Manage 
Workers' Compensation Modify Codes 

Payroll Tax Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Payroll Tax Controls 

Federal Taxes Not in Costpoint Web People » Payroll » Federal Taxes » Manage 
Federal Taxes 

Federal Tax Tables Not in Costpoint Web People » Payroll » Federal Taxes » Manage 
Federal Tax Tables 

Advance EIC and Nonresident Alien Tables Not in Costpoint Web People » Payroll » Federal Taxes » Manage 
Advance Earned Income Credit Tables 

State Taxes Not in Costpoint Web People » Payroll » State Taxes » Manage State 
Taxes 

State Tax Override by Taxable Entity Not in Costpoint Web People » Payroll » State Taxes » Manage State 
Tax Override by Taxable Entity 

State Tax Allowances and Credits Not in Costpoint Web People » Payroll » State Taxes » Manage State 
Tax Allowances and Credits 

State Standard Deductions Not in Costpoint Web People » Payroll » State Taxes » Manage State 
Standard Deductions 

State Tax Tables Not in Costpoint Web People » Payroll » State Taxes » Manage State 
Tax Tables 

Reciprocal State Taxes Not in Costpoint Web People » Payroll » State Taxes » Manage 
Reciprocal State Taxes 

State Mag Media Settings (SUTA) Not in Costpoint Web People » Payroll » State Taxes » Manage SUTA 
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Tax File Data 

SUTA Quarterly Reporting Data Not in Costpoint Web People » Payroll » State Taxes » Manage SUTA 
Quarterly Reporting Data 

State Mag Media Weeks Worked Exceptions Not in Costpoint Web People » Payroll » State Taxes » Manage SUTA 
"Weeks Worked" Override 

Local Taxes Not in Costpoint Web People » Payroll » Local Taxes » Manage Local 
Taxes 

Local Tax Override by Taxable Entity Not in Costpoint Web People » Payroll » Local Taxes » Manage Local 
Tax Override by Taxable Entity 

Local Standard Deductions Not in Costpoint Web People » Payroll » Local Taxes » Manage Local 
Standard Deductions 

Local Tax Tables Not in Costpoint Web People » Payroll » Local Taxes » Manage Local 
Tax Tables 

Garnishment Control 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Garnishment Control 

Court Remittance Identification Not in Costpoint Web People » Payroll » Garnishments » Manage 
Garnishment Recipients 

Federal Tax Levy Exemptions Not in Costpoint Web People » Payroll » Garnishments » Manage 
Federal Tax Levy Exemptions 

Disposable Income Calculations Setup Not in Costpoint Web Not in Costpoint 7.0 

State Minimum Wage Not in Costpoint Web People » Payroll » Garnishments » Manage 
Minimum Wage 
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Child Support Garnishment Setup Not in Costpoint Web Not in Costpoint 7.0 

Creditor Debt Garnishment Setup Not in Costpoint Web Not in Costpoint 7.0 

Payroll Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Payroll Processing 

Set Excess Life Deductions Not in Costpoint Web People » Payroll » Payroll Processing » Update 
Excess Life Deductions 

Mass Update Employee Package Deductions Not in Costpoint Web People » Payroll » Payroll Processing » Update 
Employee Package Deductions 

Compute Payroll Not in Costpoint Web People » Payroll » Payroll Processing » Compute 
Payroll 

Print Payroll Edit Report Not in Costpoint Web People » Payroll » Payroll Processing » Print 
Payroll Edit Report 

Maintain Payroll Edit Table Not in Costpoint Web People » Payroll » Payroll Processing » Manage 
Payroll Records 

Print/Reprint Paychecks Not in Costpoint Web People » Payroll » Payroll Processing » Print 
Paychecks 

Direct Deposit Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Direct Deposit Processing 

Maintain Direct Deposit Banks Not in Costpoint Web People » Payroll » Payroll Controls » Manage Bank 
Routings 
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Print Direct Deposit Banks Rpt Not in Costpoint Web People » Payroll » Payroll Controls » Print Bank 
Routing Report 

Print Employee Bank Info Rpt Not in Costpoint Web People » Payroll » Payroll Processing » Print 
Employee Bank Information Report 

Create Direct Deposit File Not in Costpoint Web People » Payroll » Payroll Processing » Create 
ACH Bank File 

Print Direct Deposit Edit Rpt Not in Costpoint Web People » Payroll » Payroll Processing » Print Bank 
ACH File Report 

Print/Reprint Payment Advices Not in Costpoint Web People » Payroll » Payroll Processing » Print 
Payment Advices 

Suspend/Restore Direct Deposit Not in Costpoint Web People » Payroll » Payroll Utilities » 
Suspend/Restore Direct Deposits 

Activate Pending Employee Bank Info Not in Costpoint Web People » Payroll » Payroll Processing » Activate 
Pending Employee Bank Information 

Payroll Closing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Payroll Closing 

Post Payroll Journal Not in Costpoint Web People » Payroll » Payroll Closing » Post Payroll 
Journal 

Close Pay Period Not in Costpoint Web People » Payroll » Payroll Processing » Close Pay 
Period 

Create A/P Vouchers Not in Costpoint Web People » Payroll » Payroll Closing » Create 
Accounts Payable Vouchers 

A/P Voucher Status Report Not in Costpoint Web People » Payroll » Payroll Closing » Print Accounts 
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Payable Voucher Status Report 

Employee Payroll History and Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Employee Payroll History and Reporting 

Maintain Employee Earnings Not in Costpoint Web People » Payroll » Payroll History » Manage 
Employee Earnings History 

Print Employee Earnings Rpt Not in Costpoint Web People » Payroll » Payroll History » Print Employee 
Earnings Report 

Print Deduction Summary Rpt Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » Print 
Deduction Summary Report 

Print Certified Payroll Rpt Not in Costpoint Web People » Payroll » Payroll Closing » Print Certified 
Payroll Report 

Print Deduction/Benefit Rpt by Local Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » Print 
Deduction/Benefit Report by Local 

Print Weekly Fringe Stamp Report Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » Print 
Weekly Fringe Stamp Report 

U.S. Treasury Savings Bonds 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » U.S. Treasury Savings Bonds 

Savings Bond Info by Taxable Entity Not in Costpoint Web People » Payroll » U.S. Treasury Savings Bonds » 
Manage Savings Bonds Treasury File Data 

Create U.S. Treasury File Not in Costpoint Web People » Payroll » U.S. Treasury Savings Bonds » 
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Create U.S. Treasury File 

Savings Bond File History Inquiry Not in Costpoint Web People » Payroll » U.S. Treasury Savings Bonds » 
View Savings Bond File History 

Tax Reporting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Tax Reporting 

Create EFTPS Payroll Tax Deposit File Not in Costpoint Web People » Payroll » Tax Reporting » Create EFTPS 
Payroll Tax Deposit File 

Print Federal Qtrly PR Tax Rpt Not in Costpoint Web People » Payroll » Tax Reporting » Print Quarterly 
Federal Payroll Tax Report 

Create EFTPS FUTA Qtrly Tax Dep File Not in Costpoint Web People » Payroll » Tax Reporting » Create 
Quarterly EFTPS FUTA Tax File 

Print Soc Sec and Med Reconciliation Rpt Not in Costpoint Web People » Payroll » Tax Reporting » Print Soc Sec 
and Medicare Reconciliation Report 

Print State Qtrly Unemployment Rpt Not in Costpoint Web People » Payroll » Tax Reporting » Print Quarterly 
State Unemployment Report 

Create State Qtrly Unempl Mag Media Not in Costpoint Web People » Payroll » Tax Reporting » Create 
Quarterly SUTA Tax File 

Print State Withholding Rpt Not in Costpoint Web People » Payroll » Tax Reporting » Print State 
Withholding Report 

Print Local Withholding Rpt Not in Costpoint Web People » Payroll » Tax Reporting » Print Local 
Withholding Report 

Print Worker's Comp Accrual Rpt Not in Costpoint Web People » Payroll » Tax Reporting » Print Workers' 
Compensation Accrual Report 
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Year-End Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Year-End Processing 

Close Payroll Year Not in Costpoint Web People » Payroll » Year-End Processing » Close 
Payroll Year 

Create W-2 Table Not in Costpoint Web People » Payroll » Year-End Processing » Create 
W-2 Table 

Edit W-2s Not in Costpoint Web People » Payroll » Year-End Processing » Manage 
W-2s 

Print W-2s Not in Costpoint Web People » Payroll » Year-End Processing » Print W-
2s 

Print W-2 Summary Report Not in Costpoint Web People » Payroll » Year-End Processing » Print W-
2 Summary Report 

Maintain Mag Media Reporting Not in Costpoint Web People » Payroll » Year-End Processing » Manage 
Tax File Data 

Create Federal Mag Media Not in Costpoint Web People » Payroll » Year-End Processing » Create 
Federal W-2 File 

Create State Mag Media Not in Costpoint Web People » Payroll » Year-End Processing » Create 
State W-2 File 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Utilities 

Void/Replace Posted Paychecks Not in Costpoint Web People » Payroll » Payroll Utilities » Void/Replace 
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Posted Paychecks 

Set Dummy PR Check Numbers Not in Costpoint Web People » Payroll » Payroll Utilities » Update 
Dummy Check Numbers 

Clear Timesheet PR Computed Flags Not in Costpoint Web People » Payroll » Payroll Utilities » Delete 
Timesheet Payroll Computed Flags 

Clear Paycheck Info from Payroll Edit Not in Costpoint Web People » Payroll » Payroll Utilities » Delete 
Paychecks from Payroll Edit Table 

Clear Payment Advice Info from Payroll Edit Not in Costpoint Web People » Payroll » Payroll Utilities » Delete 
Payment Advices from Payroll Edit Table 

Recompute Taxable Wages Not in Costpoint Web People » Payroll » Payroll Utilities » Recompute 
Taxable Wages 

Update Mag Media Country Code Not in Costpoint Web People » Payroll » Year-End Processing » Update 
Tax File Country Code 

Audit Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Payroll » Audit Inquiries 

Basic Employee Info Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Basic Information 

Salary Info and History Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Salary Information and History 

Employee Taxes Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Employee Taxes 

Employee Deductions Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Deductions 
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Employee Contributions Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Contributions 

Employee Garnishments Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Garnishments 

Employee Bank Info Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Bank Information 

Payroll Edit Table Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Payroll Edit Table 

Employee Earnings Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Employee Earnings 

Employee Bond Info Inquiry Not in Costpoint Web People » Payroll » Payroll Reports/Inquiries » View 
Bond Information 

Purge Audit File Data Not in Costpoint Web People » Payroll » Administrative Utilities » Purge 
Audit File Data 
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Compensation 

Compensation Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Compensation Controls 

Compensation Settings Not in Costpoint Web People » Compensation » Compensation Controls 
» Configure Compensation Settings 

Grades Not in Costpoint Web People » Compensation » Compensation Plans » 
Manage Compensation Grades 

Job Titles 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Job Titles 

Summary Job Titles Not in Costpoint Web People » Compensation » Job Titles » Manage 
Summary Job Titles 

Functional Job Titles Not in Costpoint Web People » Compensation » Job Titles » Manage 
Functional Job Titles 

Detail Job Titles Not in Costpoint Web People » Compensation » Job Titles » Manage 
Detail Job Titles 

Print Job Titles Report Not in Costpoint Web People » Compensation » Job Titles » Print Job 
Title Report 

Functional Position Descriptions Not in Costpoint Web People » Compensation » Job Titles » Manage 
Functional Position Descriptions 

Detail Position Descriptions Not in Costpoint Web People » Compensation » Job Titles » Manage 
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Detail Position Descriptions 

Print Position Descriptions Not in Costpoint Web People » Compensation » Job Titles » Print Job 
Title Position Description Report 

Compensation Plan Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Compensation Plan Setup 

Compensation Plans Not in Costpoint Web People » Compensation » Compensation Plans » 
Manage Compensation Plans 

Compensation Plan Salary Ranges Not in Costpoint Web People » Compensation » Compensation Plans » 
Manage Compensation Plan Salary Ranges 

Compensation Plan Defaults Not in Costpoint Web People » Compensation » Compensation Plans » 
Manage Compensation Plan Defaults 

Performance Rating Percent by Plan Not in Costpoint Web People » Compensation » Performance Reviews » 
Manage Performance Ratings by Plan 

Performance Rating Percent by Plan by Grade Not in Costpoint Web People » Compensation » Performance Reviews » 
Manage Performance Ratings by Plan and Grade 

Performance Review Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Performance Review Setup 

Performance Ratings Not in Costpoint Web People » Compensation » Performance Reviews » 
Manage Performance Ratings 

Review Form Setup Not in Costpoint Web People » Compensation » Performance Reviews » 
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Manage Performance Review Forms 

Review Form Employee Defaults Not in Costpoint Web People » Compensation » Performance Reviews » 
Manage Performance Review Form Defaults 

Print Performance Review Schedule Not in Costpoint Web People » Compensation » Performance Reviews » 
Print Performance Review Schedule 

Print/Send Performance Review Schedule Not in Costpoint Web 
People » Compensation » Performance Reviews » 
Print/Send Performance Review Schedule by 
Manager 

Print Review Statistics by Manager Not in Costpoint Web People » Compensation » Performance Reviews » 
Print Review Rating Statistics Report by Manager 

Compensation Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Compensation Reports 

Print Employees by Plan by Grade Not in Costpoint Web People » Compensation » Compensation Reports » 
Print Employee Compensation Plan Report 

Print Compa-ratio Not in Costpoint Web People » Compensation » Compensation Reports » 
Print Compa-ratio Report 

Compensation Budgeting 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Compensation Budgeting 

Compensation Budget by Organization Not in Costpoint Web 
People » Compensation » Compensation 
Budgeting » Manage Compensation Budgets By 
Organization 
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Projected Performance Rating Percent Not in Costpoint Web 
People » Compensation » Compensation 
Budgeting » Manage Projected Performance 
Ratings 

Non-Budgeted Compensation Pay Types Not in Costpoint Web 
People » Compensation » Compensation 
Budgeting » Manage Non-Budgeted Compensation 
Pay Types 

Print Budgeted Vs. Actual Compensation Report Not in Costpoint Web 
People » Compensation » Compensation 
Budgeting » Print Budgeted/Actual Compensation 
Comparison Report 

Print Increase Pool Report Not in Costpoint Web People » Compensation » Compensation 
Budgeting » Print Increase Pool Report 

Salary Survey 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Compensation » Salary Survey 

Basic Survey Company Info Not in Costpoint Web People » Compensation » Salary Surveys » 
Manage Survey Companies 

Maintain Survey Regions to Comp Plan Codes Not in Costpoint Web People » Compensation » Salary Surveys » 
Manage Survey Region Mappings 

Maintain Survey Job Titles to Func Job Titles Not in Costpoint Web People » Compensation » Salary Surveys » 
Manage Survey Job Title Mappings 

Upload Salary Survey Data Not in Costpoint Web People » Compensation » Salary Surveys » Import 
Salary Survey Data 

Maintain Salary Survey Data Not in Costpoint Web People » Compensation » Salary Surveys » 
Manage Salary Survey Data 

Print Compensation to Survey Data Comparison Not in Costpoint Web People » Compensation » Salary Surveys » Print 
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Compensation/Survey Comparison Report 
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Personnel 

Personnel Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » Personnel Controls 

Personnel Settings Not in Costpoint Web People » Personnel » Personnel Controls » 
Configure Personnel Settings 

Drug Tests Not in Costpoint Web People » Personnel » Personnel Controls » 
Manage Drug Test Codes 

Medical Surveillance Codes Not in Costpoint Web People » Personnel » Personnel Controls » 
Manage Medical Surveillance Codes 

Award Codes Not in Costpoint Web People » Personnel » Personnel Controls » 
Manage Award Codes 

I-9 Codes Not in Costpoint Web People » Personnel » Personnel Controls » 
Manage I-9 Codes 

Managers/HR Reps by Org Not in Costpoint Web People » Personnel » Personnel Controls » 
Manage Managers/HR Reps by Organization 

Managers/HR Reps by HR Org Not in Costpoint Web People » Personnel » Personnel Controls » 
Manage Managers/HR Reps by HR Organization 
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Personnel Actions 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » Personnel Actions 

Personnel Actions Not in Costpoint Web People » Personnel » Personnel Information » 
Manage Personnel Actions 

Required Forms List Not in Costpoint Web People » Personnel » Personnel Information » 
Manage Required Forms List 

Req'd Forms by Personnel Action Reason Not in Costpoint Web People » Personnel » Personnel Information » 
Manage Personnel Actions 

Print Required Forms Listing by Personnel 
Action Not in Costpoint Web People » Personnel » Personnel Information » Print 

Required Forms Listing by Personnel Action 

Position Requisitions 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » Position Requisitions 

Requisition Approvers Not in Costpoint Web People » Personnel » Position Requirements » 
Manage Position Requisition Approvers 

Position  Requisition Request Not in Costpoint Web People » Personnel » Position Requirements » 
Manage Position Requisition Request 

Approve Position Requisitions Not in Costpoint Web People » Personnel » Position Requirements » 
Approve Position Requisitions 
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Training 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » Training 

Degrees Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Degree Codes 

Courses Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Course Codes 

Areas of Study Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Areas of Study Codes 

Skills Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Skill Codes 

Skill Levels Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Skill Level Codes 

Professional Organizations Not in Costpoint Web 
People » Personnel » Education, Skills and 
Training » Manage Professional Organization 
Codes 

Training Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Training Codes 

Training Location Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Training Location Codes 

Training Source Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Training Source Codes 

Training Program Schedules Not in Costpoint Web People » Personnel » Education, Skills and 
Training » Manage Training Program Schedules 

Print Program Schedules Not in Costpoint Web People » Personnel » Education, Skills and 
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Training » Print Training Program Schedule 

Security and Company Property 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » Security and Company Property 

Federal Security Identifiers Not in Costpoint Web People » Personnel » Security and Company 
Property » Manage Federal Security Codes 

Internal Security Identifiers Not in Costpoint Web People » Personnel » Security and Company 
Property » Manage Internal Security Codes 

Company Documents Not in Costpoint Web People » Personnel » Security and Company 
Property » Manage Company Documents 

Company Property Not in Costpoint Web People » Personnel » Security and Company 
Property » Manage Company Property 

Company Vehicles Not in Costpoint Web People » Personnel » Security and Company 
Property » Manage Company Vehicles 

OSHA/Workers’ Comp 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » OSHA/Workers’ Comp 

Injury/Illness Description Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Manage Injury/Illness  Codes 

Anatomy Description Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Manage Anatomy Codes 

Accident Processing Steps Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Manage Accident Processing 
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Steps 

Worker's Comp Filing Reasons Not in Costpoint Web 
People » Personnel » Work-Related 
Injuries/Illnesses » Manage Workers' 
Compensation Filing Reasons 

Accident Info Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Manage Accident Information 

Accident Case History Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Manage Accident Case History 

Print Worker's Comp Incident Report Not in Costpoint Web 
People » Personnel » Work-Related 
Injuries/Illnesses » Print Worker's Compensation 
Incident Report 

Print OSHA Report Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Print OSHA Report 

Print Accident Case History Report Not in Costpoint Web 
People » Personnel » Work-Related 
Injuries/Illnesses » Print Accident Case History 
Report 

Print Wage History Report Not in Costpoint Web People » Personnel » Work-Related 
Injuries/Illnesses » Print Wage History Report 

Exit Interview Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Personnel » Exit Interview Setup 

Exit Interview Form Setup Not in Costpoint Web People » Personnel » Personnel Information » 
Manage Exit Interview Form 
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Affirmative Action 

Affirmative Action Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Affirmative Action » Affirmative Action Controls 

Affirmative Action Settings Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Controls » Configure Affirmative Action Settings 

EEO Setup Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Controls » Configure Affirmative Action Settings 

Job Groups Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Controls » Manage Job Groups 

Affirmative Action Race Codes Not in Costpoint Web Not in Costpoint 7.0 

Affirmative Action Plan Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Affirmative Action » Affirmative Action Plan Setup 

Affirmative Action Plans Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Plan Information » Manage Affirmative Action Plans 

Census Data Not in Costpoint Web 
People » Affirmative Action » Affirmative Action 
Plan Information » Manage Affirmative Action 
Census Data 

Feeder Positions Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Controls » Manage Functional Job Title Hierarchy 
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Applicant Information 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Affirmative Action » Applicant Information 

Applicant Data Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Plan Information » Manage Applicant Data 

Employee Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Affirmative Action » Employee Reports 

Employee Roster Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Employee Roster 

Personnel Action Analysis Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Personnel Action Analysis Report 

New Hire Analysis Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print New Hire Analysis Report 

Transfer Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Transfer Report 

Promotion Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Promotion Report 

Training Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Training Report 

Termination Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Termination Report 
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Affirmative Action Planning 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Affirmative Action » Affirmative Action Planning 

EEO-1 Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print EEO-1 Report 

Print VETS-100 Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print VETS-100 Report 

Workforce Analysis Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Workforce Analysis Report 

Organizational Profile Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Organizational Profile Report 

Lines of Progression Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Lines of Progression Report 

Job Group Analysis Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Job Group Analysis Report 

Availability/Utilization Report Not in Costpoint Web People » Affirmative Action » Affirmative Action 
Reports » Print Availability/Utilization Report 

Equal Opportunity Survey Not in Costpoint Web Not in Costpoint 7.0 
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Deferred Compensation Admin 

Plan Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Deferred Compensation Admin » Plan Controls 

Plan Setup Not in Costpoint Web 
People » Deferred Compensation Admin » Deferred 
Compensation Plan Controls » Manage Deferred 
Compensation Plans 

Plan Tax Information Not in Costpoint Web 
People » Deferred Compensation Admin » Deferred 
Compensation Plan Controls » Manage Deferred 
Compensation Plans 

Deduction Code Assignment Not in Costpoint Web 
People » Deferred Compensation Admin » Deferred 
Compensation Plan Controls » Manage Deferred 
Compensation Deductions 

Plan Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Deferred Compensation Admin » Plan Reports 

Print New Eligible Employees Not in Costpoint Web Not in Costpoint 7.0 

Print Vesting Percents by Employee Not in Costpoint Web Not in Costpoint 7.0 

Print ADP Report Not in Costpoint Web Not in Costpoint 7.0 

Print ACP Report Not in Costpoint Web Not in Costpoint 7.0 

Print High Comp Analysis Rpt Not in Costpoint Web Not in Costpoint 7.0 
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Print Annual Additions (415) Rpt Not in Costpoint Web Not in Costpoint 7.0 

Financial Institution Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Deferred Compensation Admin » Financial Institution Interface 

Generate Fund Deductions Mag Media Not in Costpoint Web Not in Costpoint 7.0 
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Benefits 

Benefit Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Benefits » Benefit Controls 

Benefit Settings Not in Costpoint Web People » Benefits » Benefit Controls » Configure 
Benefit Settings 

Benefit Types Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
Benefit Types 

Providers Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
Benefit Providers 

Coverage Options Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
Coverage Options 

Premium and Coverage Tables 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Benefits » Premium and Coverage Tables 

Premium Rates by Age Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
Premium Rates by Age 

Coverage Amounts by Age Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
Coverage Amounts by Age 

Coverage Amounts by Salary Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
Coverage Amounts by Salary 

Premium Amounts by Salary Not in Costpoint Web People » Benefits » Benefit Controls » Manage 
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Premiums by Salary 

Benefit Information 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Benefits » Benefit Information 

Benefit Plan Setup Not in Costpoint Web People » Benefits » Benefit Entry and Creation » 
Manage Benefit Plans 

Benefit Packages Not in Costpoint Web People » Benefits » Benefit Entry and Creation » 
Manage Benefit Packages 

Benefit Package Defaults Not in Costpoint Web People » Benefits » Benefit Entry and Creation » 
Manage Benefit Package Defaults 

Dependent Care FSA Setup Not in Costpoint Web People » Benefits » Benefit Entry and Creation » 
Manage Dependent Care FSA Plan Year 

Medical Care FSA Setup Not in Costpoint Web People » Benefits » Benefit Entry and Creation » 
Manage Medical Care FSA Plan Year 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

People » Benefits » Reports 

Print Coverage Report Not in Costpoint Web People » Benefits » Benefit Reports » Print 
Coverage Report 

Print Employee FSA Report Not in Costpoint Web People » Benefits » Benefit Reports » Print 
Employee FSA Report 

Print Medical Dependents Report Not in Costpoint Web People » Benefits » Benefit Reports » Print Medical 
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Dependents Report 

Print Life Insurance Beneficiaries Report Not in Costpoint Web People » Benefits » Benefit Reports » Print Life 
Insurance Beneficiaries Report 

Print Census Report Not in Costpoint Web People » Benefits » Benefit Reports » Print Census 
Report 
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COBRA Administration 
The Cobra Administration module has been de-supported in Costpoint 7.0. 
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Materials 

Product Definition 

Product Definition Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Product Definition Controls 

Product Definition Settings Administration » Configure » Materials » Product 
Definition Settings 

Materials » Product Definition » Product Definition 
Controls » Configure Product Definition Settings 

Commodity Codes Materials » Configure » Items » Commodity Codes Materials » Product Definition » Product Definition 
Controls » Manage Commodity Codes 

Product Types Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Product Types 

Product Classifications Materials » Configure » Items » Product 
Classifications 

Materials » Product Definition » Product Definition 
Controls » Manage Product Classifications 

Units of Measure Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Units of Measure 

Standard Text Materials » Configure » Standard Text » Standard 
Text 

Materials » Product Definition » Product Definition 
Controls » Manage Standard Text 

Part Preference Types Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Part Preference Types 

Manufacturers Materials » Maintain » Manufacturers » 
Manufacturers 

Materials » Product Definition » Product Definition 
Controls » Manage Manufacturers 

Item User-Defined Labels Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Item User-Defined Labels 
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Industry Classifications Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Industry Classifications 

Document Media Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Document Media 

Document Sizes Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Document Sizes 

Document Types Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Document Types 

Provisional Part Types Not in Costpoint Web Materials » Product Definition » Product Definition 
Controls » Manage Provisional Part Types 

Part Master 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Part Master 

Maintain Parts Materials » Maintain » Items » Parts User Flow Materials » Product Definition » Items » Manage 
Parts 

Basic Part Data Materials » Maintain » Items » Parts User Flow Materials » Product Definition » Items » Manage 
Parts 

Planning Part Data Materials » Maintain » Items » Parts User Flow Materials » Product Definition » Items » Manage 
Parts 

Alternate Parts Materials » Maintain » Items » Alternate Parts Materials » Product Definition » Items » Manage 
Alternate Parts 

Substitute Parts Materials » Maintain » Items » Parts User Flow Materials » Product Definition » Items » Manage 
Parts 

Part Project Data Materials » Maintain » Items » Part Project Data Materials » Product Definition » Items » Manage 
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Part Project Data 

Services, Goods 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » 

Services Materials » Maintain » Items » Services User Flow Materials » Product Definition » Items » Manage 
Services 

Goods Materials » Maintain » Items » Goods User Flow Materials » Product Definition » Items » Manage 
Goods 

Provisional Parts 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Provisional Parts 

Maintain Provisional Parts Not in Costpoint Web Materials » Product Definition » Provisional Parts » 
Manage Provisional Parts 

Convert Provisional Part to Standard Part Not in Costpoint Web Materials » Product Definition » Provisional Parts » 
Convert Provisional Parts to Standard Parts 
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Documents 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Documents 

Maintain Documents Not in Costpoint Web Materials » Product Definition » Documents » 
Manage Documents 

Release Documents Not in Costpoint Web Materials » Product Definition » Documents » 
Release Documents 

Product Billing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Product Billing 

Set Up Sales Group Abbreviations Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Group Abbreviations 

Set Up Warranty Info Not in Costpoint Web Materials » Product Definition » Product Billing » 
Manage Warranty Information 

Set Up Price Catalogs Materials » Maintain » Price  Catalogs » Price 
Catalogs 

Materials » Product Definition » Product Billing » 
Manage Price Catalogs 

Set Up Item Billings Materials » Maintain » Items » Item Billings Materials » Product Definition » Product Billing » 
Manage Item Billings 

Set Up Product Price Catalogs Materials » Maintain » Price  Catalogs » Price 
Catalogs Items 

Materials » Product Definition » Product Billing » 
Manage Product Price Catalogs 

Set Up Product Options Not in Costpoint Web Materials » Product Definition » Product Billing » 
Manage Product Options 
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Assign Standard Text, Assign Vendors, Maintain Item Cost, Maintain Project Item Cost, User-Defined Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition »  

Assign Standard Text Projects » Maintain » Project » Project Standard 
Text Assignment 

Materials » Product Definition » Product Definition 
Controls » Manage Standard Text 

Assign Vendors Materials » Maintain » Items » Item Vendor 
Assignment 

Materials » Product Definition » Items » Assign 
Vendors to Items 

Maintain Item Cost Materials » Maintain » Items » Item Costs Materials » Product Definition » Items » Manage 
Item Costs 

Maintain Project Item Cost Materials » Maintain » Items » Project Item Costs Materials » Product Definition » Items » Manage 
Project Item Costs 

User-Defined Info Projects » Maintain » Project » Project User-
Defined Information 

Projects » Project Setup » Project Master » 
Manage User-Defined Information 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Inquiries 

Item Inquiry Materials » Review » Items » Item Inquiry Materials » Product Definition » Product Definition 
Reports/Inquiries » View Items 

Alternate Part Inquiry Materials » Review » Items » Alternate Part Inquiry Materials » Product Definition » Product Definition 
Reports/Inquiries » View Alternate Parts 

Part Query Not in Costpoint Web Not in Costpoint 7.0 

Item Query Not in Costpoint Web Not in Costpoint 7.0 
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Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Product Definition » Reports 

Print Master File Listing Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Item Master Listing Report 

Print Master File Audit Report Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Item Master Audit Report 

Print Item Catalog Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Item Catalog Report 

Print Manufacturer Catalog Not in Costpoint Web 
Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Manufacturer Catalog 
Report 

Print Part Project Info Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Part Project Report 

Print Substitute Part Report Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Substitute Part Report 

Print Part Planning Exception Report Not in Costpoint Web 
Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Part Planning Exception  
Report 

Print Assigned Vendor Report Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Assigned Vendor Report 

Print Item Cost Info Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Item Cost Report 

Print Item Text Report Not in Costpoint Web Materials » Product Definition » Product Definition 
Reports/Inquiries » Print Item Text Report 
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Bills of Material 

Bills of Material Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Bills of Material Controls 

BOM Settings Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Controls » Configure Bills of Material Settings 

Configuration Identifiers Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Controls » Manage Configuration Identifiers 

Work Centers Not in Costpoint Web Materials » Bills of Material » Work Centers » 
Manage Work Centers 

Document Media Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Controls » Manage Document Media 

Document Sizes Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Controls » Manage Document Sizes 

Document Types Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Controls » Manage Document Types 

Document Maintenance Groups Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Controls » Manage Document Maintenance Groups 
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Manufacturing Bills of Material 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Manufacturing Bills of Material 

Maintain MBOM Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Manage Manufacturing Bills of Material 

Release MBOM Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Release Manufacturing Bills of Material 

Release Multiple Manufacturing BOMs Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Release Multiple Manufacturing Bills of Material 

Maintain End Item Configurations Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Manage End Item Configurations 

Engineering Bills of Material 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Engineering Bills of Material 

Maintain EBOM Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Manage Engineering Bills of Material 

Release EBOM Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Release Engineering Bills of Material 

Release Multiple Engineering BOMs Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Release Multiple Engineering Bills of Material 
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Documents 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Documents 

Maintain Documents Not in Costpoint Web Materials » Bills of Material » Documents » Manage 
Documents 

Release Documents Not in Costpoint Web Materials » Bills of Material » Documents » Release 
Documents 

Copy Bills of Material, Perform Mass Component Change 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material »  

Copy Bills of Material Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Copy Bills of Material 

Perform Mass Component 
Change Not in Costpoint Web 

Materials » Bills of Material » Bills of Material » 
Apply Mass Component Changes to Bills of 
Material 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Inquiries 

BOM Inquiry Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Reports/Inquiries » View Bills of Material 

Where-Used Inquiry Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Reports/Inquiries » View Where-Used Bills of 
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Material 

Part Query Not in Costpoint Web Not in Costpoint 7.0 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Reports 

Print Indented BOM Report Not in Costpoint Web 
Materials » Bills of Material » Bills of Material 
Reports/Inquiries » Print Indented Bills of Material 
Report 

Print Summarized BOM Report Not in Costpoint Web 
Materials » Bills of Material » Bills of Material 
Reports/Inquiries » Print Summarized Bills of 
Material Report 

Print Where-Used Report Not in Costpoint Web 
Materials » Bills of Material » Bills of Material 
Reports/Inquiries » Print Bills of Material Where-
Used Report 

Print Costed BOM Report Not in Costpoint Web Materials » Bills of Material » Bills of Material » 
Compute Costed Bills of Material 

Print Compare Summarized BOM Report Not in Costpoint Web 
Materials » Bills of Material » Bills of Material 
Reports/Inquiries » Print Summarized Bills of 
Material Comparison Report 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Bills of Material » Utilities 

Update Low-Level Codes Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Utilities » Update Low-Level Codes 

Miscellaneous Toolkits » Convert reference 
designators from standard to extended length 
format* 

Not in Costpoint Web 
Materials » Bills of Material » Bills of Material 
Utilities » Convert  Reference Designators from 
Short to Long 

Miscellaneous Toolkits » Convert reference 
designators from extended length  to standard 
format* 

Not in Costpoint Web 
Materials » Bills of Material » Bills of Material 
Utilities » Convert  Reference Designators from 
Long to Short 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 
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Routings 

Routing Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Routings » Routing Controls 

Routings Settings Not in Costpoint Web Materials » Routings » Routings Controls » 
Configure Routing Settings 

Work Center Types Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Work Center Types 

Operation Types Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Operation Types 

Process Types Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Process Types 

Resource Types Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Resource Types 

Key Resources Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Key Resources 

Labor Classifications Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Labor Classifications 

Maintenance Types Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Maintenance Types 

Equipment Not in Costpoint Web Materials » Routings » Routings Controls » Manage 
Equipment 
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Maintain Work Centers 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Routings » 

Maintain Work Centers Not in Costpoint Web Materials » Routings » Work Centers » Manage 
Work Centers 

Operations 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Routings » Operations 

Maintain Labor Operations Not in Costpoint Web Materials » Routings » Operations » Manage Labor 
Operations 

Maintain Subcontractor Operations Not in Costpoint Web Materials » Routings » Operations » Manage 
Subcontractor Operations 

Routings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Routings » Routings 

Maintain Routings Materials » Maintain » Routings » Maintain 
Routings 

Materials » Routings » Routings » Manage 
Routings 

Release Routings Not in Costpoint Web Materials » Routings » Routings » Release 
Routings 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Routings » Inquiries 

Routing Inquiry Not in Costpoint Web Materials » Routings » Routings Reports/Inquiries » 
View Routings 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Routings » Reports 

Print Routings Not in Costpoint Web Materials » Routings » Routings Reports/Inquiries » 
Print Routings Report 
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Engineering Change Notices 

ECN Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Engineering Change Notices » ECN Controls 

EC Settings Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Configure 
Engineering Change Notice Settings 

EC Reasons Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
Engineering Change Reasons 

EC Priorities Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
Engineering Change Priorities 

EC Rejection Reason Codes Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
Engineering Change Rejection Reason Codes 

EC Impacted Functional Groups Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage EC 
Impacted Functional Groups 

EC Types Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
Engineering Change Types 

EC Approval Titles Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
Engineering Change Approval Titles 

EC Project Approvers Not in Costpoint Web Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
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Engineering Change Project Approvers 

EC Approval Processes Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Manage 
Engineering Change Approval Processes 

EC User-Defined Labels Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Configure 
Engineering Change User-Defined Labels 

EC Report Print Options Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Controls » Configure 
Engineering Change Report Print Options 

Engineering Change Notices 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Engineering Change Notices » Engineering Change Notices 

Maintain ECNs Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Processing » Manage 
Engineering Change Notices 

Approve ECNs Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Processing » Approve 
Engineering Change Notices 

Maintain Approved ECNs Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Processing » Update 
Approved Engineering Change Notices 

Implement ECN Changes Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Processing » Apply 
Engineering Change Notices 

Print ECN Traveler Not in Costpoint Web Materials » Engineering Change Notices » 
Engineering Change Processing » Print 
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Engineering Change Notice Travelers 

ECN Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Engineering Change Notices » ECN Inquiries 

ECN Status Inquiry Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Reports/Inquiries » View 
Engineering Change Notice Status 

Item Inquiry Materials » Review » Items » Item Inquiry Materials » Engineering Change Notices » 
Engineering Change Reports/Inquiries » View Items 

Part Query Not in Costpoint Web Not in Costpoint 7.0 

ECN Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Engineering Change Notices » ECN Reports 

Print ECN Impact Report Not in Costpoint Web 
Materials » Engineering Change Notices » 
Engineering Change Reports/Inquiries » Print 
Engineering Change Notice Impact Report 
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Procurement Planning 

Requisition Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Requisition Controls 

Requisition Settings Administration » Configure » Materials » 
Requisition Settings 

Materials » Procurement Planning » Procurement 
Planning Controls » Configure Purchase 
Requisition Settings 

RFQ Settings Administration » Configure » Materials » RFQ 
Settings 

Materials » Procurement Planning » Procurement 
Planning Controls » Configure Vendor Quote 
Settings 

Procurement Types Materials » Configure » Purchasing » Procurement 
Types 

Materials » Procurement Planning » Procurement 
Planning Controls » Manage Procurement Types 

Quote Types Not in Costpoint Web Materials » Procurement Planning » Procurement 
Planning Controls » Manage Vendor Quote Types 

Requisition Rejection Reasons Materials » Configure » Purchase Requisitions » 
Purchase Requisition Rejection Reasons 

Materials » Procurement Planning » Procurement 
Planning Controls » Manage Purchase Requisition 
Rejection Reasons 

Vendor Quote Award Reasons Materials » Configure » Purchasing » Vendor Quote 
Award Reasons 

Materials » Procurement Planning » Procurement 
Planning Controls » Manage Vendor Quote Award 
Reasons 

Requisition Cost Types Not in Costpoint Web 
Materials » Procurement Planning » Procurement 
Planning Controls » Manage Purchase Requisition 
Cost Types 

Requisition Approval Titles Materials » Configure » Purchase Requisitions » 
Purchase Requisition Approval Titles 

Materials » Procurement Planning » Procurement 
Planning Controls » Manage Purchase Requisition 
Approval Titles 
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Requisition Approval Processes Materials » Configure » Purchase Requisitions » 
Purchase Requisition Approval Processes 

Materials » Procurement Planning » Procurement 
Planning Controls » Manage Purchase Requisition 
Approval Processes 

Requisition Print Options Administration » Configure » Materials » 
Requisition Print Options 

Materials » Procurement Planning » Procurement 
Planning Controls » Configure Purchase 
Requisition Print Options 

Vendor Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Vendor Controls 

Vendor Settings Not in Costpoint Web 
Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Configure Vendor 
Settings 

Vendor Terms Not in Costpoint Web Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Manage Vendor Terms 

Vendor Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Vendor Info 

Maintain Vendors Materials » Maintain » Vendors » Vendor User Flow Materials » Procurement Planning » Vendors » 
Manage Vendors 

Vendor User-Defined Info Not in Costpoint Web Materials » Procurement Planning » Vendors » 
Manage Vendors 

Print Vendor Listing Not in Costpoint Web Materials » Procurement Planning » Vendors » 
Print Vendor List 
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Print Vendor Information Reports Not in Costpoint Web Materials » Procurement Planning » Vendors » 
Print Vendor Information Report 

Request for Quotes 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Request for Quotes 

Enter RFQs by Item Materials » Transactions » Vendor Quotes » Enter 
RFQs by Item 

Materials » Procurement Planning » Vendor Quotes 
» Manage Request for Quotes By Item 

Enter RFQs by Vendor Materials » Transactions » Vendor Quotes » Enter 
RFQs by Vendor 

Materials » Procurement Planning » Vendor Quotes 
» Manage Request for Quotes By Vendor 

Enter Quotes by Item Materials » Transactions » Vendor Quotes » Enter 
Quotes by Item 

Materials » Procurement Planning » Vendor Quotes 
» Manage Vendor Quotes By Item 

Enter Quotes by Vendor Materials » Transactions » Vendor Quotes » Enter 
Quotes by Vendor 

Materials » Procurement Planning » Vendor Quotes 
» Manage Vendor Quotes By Vendor 

Print RFQs Materials » Transactions » Vendor Quotes » Print 
RFQs 

Materials » Procurement Planning » Vendor Quotes 
» Print Request for Quotes 

Requisitions 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Requisitions 

Enter Requisitions Materials » Transactions » Purchase Requisitions » 
Enter Purchase Requisitions 

Materials » Procurement Planning » Purchase 
Requisitions » Manage Purchase Requisitions 

Approve Purchase Requisitions Materials » Transactions » Purchase Requisitions » 
Approve Purchase Requisitions 

Materials » Procurement Planning » Purchase 
Requisitions » Approve Purchase Requisitions 
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Approve Purchase Requisition Lines Materials » Transactions » Purchase Requisitions » 
Approve Purchase Requisition Lines 

Materials » Procurement Planning » Purchase 
Requisitions » Approve Purchase Requisition Lines 

Assign Requisitions to Buyers Materials » Transactions » Purchase Requisitions » 
Assign Purchase Requisitions to Buyers 

Materials » Procurement Planning » Purchase 
Requisitions » Assign Purchase Requisitions to 
Buyers 

Assign Requisition Lines to Buyers Materials » Transactions » Purchase Requisitions » 
Assign Purchase Requisition Lines to Buyers 

Materials » Procurement Planning » Purchase 
Requisitions » Assign Purchase Requisition Lines 
to Buyers 

Requisition Processing Materials » Transactions » Purchase Requisitions » 
Process Purchase Requisitions 

Materials » Procurement Planning » Purchase 
Requisitions » Apply PO Info to Purchase 
Requisitions 

Requisition Processing by Line Materials » Transactions » Purchase Requisitions » 
Process Purchase Requisitions by Line 

Materials » Procurement Planning » Purchase 
Requisitions » Apply PO Info to Purchase 
Requisitions by Line 

Set Up PO Header Info Not in Costpoint Web 
Materials » Procurement Planning » Purchase 
Requisitions » Manage Purchase Order Header 
Information 

Create Purchase Orders Materials » Transactions » Purchase Requisitions » 
Create Purchase Orders 

Materials » Procurement Planning » Purchase 
Requisitions » Create Purchase Orders 

Print Requisitions Materials » Transactions » Purchase Requisitions » 
Print Purchase Requisitions 

Materials » Procurement Planning » Purchase 
Requisitions » Print Purchase Requisitions 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Inquiries 

Requisition Status Inquiry Materials » Review » Purchase Requisitions » 
Purchase Requisition Status Inquiry 

Materials » Procurement Planning » Procurement 
Planning Reports/Inquiries » View Purchase 
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Requisition Status 

Vendor Quote Inquiry Not in Costpoint Web Materials » Purchasing » Vendor Quotes» View 
Vendor Quotes 

Item Purchasing Information Inquiry Materials » Review » Purchase Orders » Item 
Purchasing Information Inquiry 

Materials » Procurement Planning » Procurement 
Planning Reports/Inquiries » View Item Purchasing 
Information 

Item Inquiry Materials » Review » Items » Item Inquiry Materials » Procurement Planning » Procurement 
Planning Reports/Inquiries » View Items 

Item Query Not in Costpoint Web Not in Costpoint 7.0.1  

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Reports 

Print Requisition Commitments Detail Not in Costpoint Web 
Materials » Procurement Planning » Procurement 
Planning Reports/Inquiries » Print Purchase 
Requisition Commitment Report 

Print Requisition Approval Status Report Not in Costpoint Web 
Materials » Procurement Planning » Procurement 
Planning Reports/Inquiries » Print Purchase 
Requisition Approval Status Report 
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Performance 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Procurement Planning » Performance 

Calculate Vendor Performance Materials » Process » Vendors » Calculate Vendor 
Performance 

Materials » Procurement Planning » Vendors » 
Compute Vendor Performance 

Vendor Performance Inquiry Materials » Review » Vendors » Vendor 
Performance Inquiry 

Materials » Procurement Planning » Vendors » 
View Vendor Performance 

 

  



Materials  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 161 

 

Purchasing 

Purchasing Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Purchasing Controls 

PO Settings Administration » Configure » Materials » 
Purchasing Settings 

Materials » Purchasing » Purchasing Controls » 
Configure Purchasing Settings 

Buyers Materials » Configure » Purchasing » Buyers Materials » Purchasing » Purchasing Codes » 
Manage Buyers 

PO Line Charge Types Not in Costpoint Web Materials » Purchasing » Purchasing Codes » 
Manage Line Charge Types 

PO Standard Text Not in Costpoint Web Materials » Purchasing » Purchasing Codes » 
Manage Standard Text 

Branch Locations Not in Costpoint Web Materials » Purchasing » Purchasing Codes » 
Manage Branch Locations 

Units of Measure Not in Costpoint Web Materials » Purchasing » Purchasing Codes » 
Manage Units of Measure 

Commodity Codes Materials » Configure » Items » Commodity Codes Materials » Purchasing » Purchasing Codes » 
Manage Commodity Codes 

Procurement Types Not in Costpoint Web Materials » Purchasing » Purchasing Codes » 
Manage Procurement Types 

PO Print Options Administration » Configure » Materials » PO Print 
Options 

Materials » Purchasing » Purchasing Controls » 
Configure Purchase Order Print Options 

Display Ship IDs Materials » Configure » Purchasing » Display Ship 
IDs 

Materials » Purchasing » Purchasing Codes » View 
Ship IDs 
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Industry Classifications Not in Costpoint Web Materials » Purchasing » Purchasing Codes » 
Manage Industry Classifications 

Vendor Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Vendor Controls 

Vendor Settings Not in Costpoint Web 
Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Configure Vendor 
Settings 

Vendor Terms Not in Costpoint Web Accounting » Accounts Payable » Vendor and 
Subcontractor Controls » Manage Vendor Terms 

Vendor Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Vendor Info 

Maintain Vendors Materials » Maintain » Vendors » Vendor User Flow Materials » Purchasing » Vendors » Manage 
Vendors 

Vendor User-Defined Info Not in Costpoint Web Materials » Purchasing » Vendors » Manage 
Vendors 

Print Vendor Listing Not in Costpoint Web Materials » Purchasing » Vendors » Print Vendor 
List 

Print Vendor Information Reports Not in Costpoint Web Materials » Purchasing » Vendors » Print Vendor 
Information Report 
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Purchase Orders 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Purchase Orders 

Enter POs Materials » Transactions » Purchase Orders » 
Enter Purchase Orders 

Materials » Purchasing » Purchase Orders » 
Manage Purchase Orders 

Create Blanket Releases Materials » Transactions » Purchase Orders » 
Create Blanket PO Releases 

Materials » Purchasing » Purchase Orders » Create 
Blanket Purchase Order Releases 

Open Pending POs Materials » Transactions » Purchase Orders » 
Open Pending POs 

Materials » Purchasing » Purchase Orders » 
Approve Pending Purchase Orders 

Expedite Purchase Orders Materials » Transactions » Purchase Orders » 
Expedite Purchase Orders 

Materials » Purchasing » Purchase Orders » 
Expedite Purchase Orders 

Maintain PO Expediting Notes Materials » Transactions » Purchase Orders » 
Enter PO Expediting Notes 

Materials » Purchasing » Purchase Orders » 
Manage Purchase Order Expediting Notes 

Create PO Change Orders Materials » Transactions » Purchase Orders » 
Create PO Change Orders 

Materials » Purchasing » Purchase Orders » Create 
Purchase Order Change Orders 

Update Subcontract PO Status Materials » Transactions » Purchase Orders » 
Update Subcontract PO Status 

Materials » Purchasing » Purchase Orders » 
Update Subcontract Purchase Order Status 

Print POs Materials » Transactions » Purchase Orders » Print 
Purchase Orders 

Materials » Purchasing » Purchase Orders » Print 
Purchase Orders 

Print Purchase Change Orders Materials » Transactions » Purchase Orders » Print 
PO Change Orders 

Materials » Purchasing » Purchase Orders » Print 
Purchase Order Change Orders 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Inquiries 

PO Status Inquiry Materials » Review » Purchase Orders » PO Status 
Inquiry 

Materials » Purchasing » Purchasing 
Reports/Inquiries » View Purchase Order Status 

Item Purchasing Information Inquiry Materials » Review » Purchase Orders » Item 
Purchasing Information Inquiry 

Materials » Purchasing » Purchasing 
Reports/Inquiries » View Item Purchasing 
Information 

Vendor Quote Inquiry Not in Costpoint Web Materials » Purchasing » Purchasing 
Reports/Inquiries » View Vendor Quotes 

PO Change Order Inquiry Materials » Review » Purchase Orders » PO 
Change Order Inquiry 

Materials » Purchasing » Purchasing 
Reports/Inquiries » View Purchase Order Change 
Orders 

PO Commitments Summary 
Inquiry 

Materials » Review » Purchase Orders » PO 
Commitments Summary Inquiry 

Materials » Purchasing » Purchasing 
Reports/Inquiries » View Purchase Order 
Commitments Summary 

Item Inquiry Materials » Review » Items » Item Inquiry Materials » Purchasing » Purchasing 
Reports/Inquiries » View Items 

Item Query Not in Costpoint Web Not in Costpoint 7.0 
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Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Reports 

Print PO Register Materials » Review » Purchase Orders » PO 
Register Report 

Materials » Purchasing » Purchasing 
Reports/Inquiries » Print Purchase Order Register 
Report 

Print PO Expediting Report Materials » Review » Purchase Orders » PO 
Expediting Report 

Materials » Purchasing » Purchasing 
Reports/Inquiries » Print Purchase Order 
Expediting Report 

Compute and Print Commitments Materials » Process » Purchasing Commitments » 
Compute and Print Purchasing Commitments 

Materials » Purchasing » Purchasing 
Reports/Inquiries » Compute/Print Purchasing 
Commitments 

Print PO Activity Report Materials » Review » Purchase Orders » PO 
Activity Report 

Materials » Purchasing » Purchasing 
Reports/Inquiries » Print Purchase Order Activity 
Report 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Purchasing » Utilities 

Archive Purchase Orders Not in Costpoint Web Materials » Purchasing » Purchasing Utilities » 
Archive Purchase Orders 

Reconcile Purchase Orders Not in Costpoint Web Materials » Purchasing » Purchasing Utilities » 
Reconcile Purchase Orders 

Miscellaneous Toolkits » Update Shipping Name 
with Customer/Vendor Long Name Not in Costpoint Web Not in Costpoint 7.0 
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Receiving 

Receiving Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Receiving » Receiving Controls 

Receiving Settings Administration » Configure » Materials » Receiving 
Settings 

Materials » Receiving » Receiving Controls » 
Configure Receiving Settings 

Vendor Rejection Reasons Not in Costpoint Web Materials » Receiving » Receiving Controls » 
Manage Vendor Rejection Reasons 

Receiving 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Receiving » Receiving 

Receive Purchase Order Materials » Transactions » Receipts » Receive 
Purchase Orders 

Materials » Receiving » Receiving » Manage 
Purchase Order Receipts 

Receive Miscellaneous Not in Costpoint Web Materials » Receiving » Receiving » Enter 
Miscellaneous Inventory Receipts 

Inspections 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Receiving » Inspections 

Enter QC Inspections Materials » Transactions » Receipts » Enter QC 
Inspections 

Materials » Receiving » Receiving » Manage 
Quality Control Inspections 
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Enter Vendor Returns 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Receiving »  

Enter Vendor Returns Materials » Transactions » Receipts » Enter Vendor 
Returns 

Materials » Receiving » Receiving » Manage 
Vendor Returns 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Receiving » Inquiries 

PO Status Inquiry Materials » Review » Purchase Orders » PO Status 
Inquiry 

Materials » Receiving » Receiving Reports/Inquiries 
» View Purchase Order Status 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Receiving » Reports 

Print Receipt Traveler Materials » Transactions » Receipts » Print Receipt 
Traveler 

Materials » Receiving » Receiving » Print Receipt 
Traveler 

Print Receiving Log Not in Costpoint Web Materials » Receiving » Receiving Reports/Inquiries 
» Print Receiving Log 

Print Pending Inspections Report Not in Costpoint Web Materials » Receiving » Receiving Reports/Inquiries 
» Print Pending Inspection Report 
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Inventory 

Inventory Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Inventory Controls 

Inventory Settings Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Configure Inventory Settings 

Serial/Lot Settings Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Configure Serial/Lot Settings 

Serial/Lot User-Defined Labels Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Manage Serial/Lot User-Defined Labels 

Inventory Accounts Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Configure Inventory Accounts 

Default Project Inventory Accounts Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Configure Default Project Inventory Accounts 

Warehouses Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Manage Warehouses 

Locations Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Manage Locations 

Scrap Reasons Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Manage Scrap Reasons 

Adjustment Reasons Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Manage Adjustment Reasons 

Inventory Projects Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Manage Inventory Projects 
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Back Order Processing Settings Not in Costpoint Web Materials » Inventory » Inventory Controls » 
Configure Back Order Processing Settings 

Issues 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Issues 

Enter Issues Not in Costpoint Web Materials » Inventory » Issues » Enter Issues to 
Project/Account/Org or PO 

Enter Sales Order Inventory Issues Not in Costpoint Web Materials » Inventory » Issues » Manage Sales 
Order Inventory Issues 

Enter Manufacturing Order Issues Materials » Transactions » Inventory » Enter 
Manufacturing Order Issues 

Materials » Inventory » Issues » Enter 
Manufacturing Order Issues 

Adjustments 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Adjustments 

Enter Quantity Adjustments Not in Costpoint Web Materials » Inventory » Adjustments » Enter 
Quantity Adjustments 

Enter Scrap Adjustments Not in Costpoint Web Materials » Inventory » Adjustments » Enter Scrap 
Adjustments 

Enter Cost Adjustments Not in Costpoint Web Materials » Inventory » Adjustments » Enter Cost 
Adjustments 
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Transfers 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Transfers 

Enter Location Transfers Not in Costpoint Web Materials » Inventory » Transfers » Enter Location 
Transfers 

Enter Inventory Transfers Not in Costpoint Web Materials » Inventory » Transfers » Enter Inventory 
Transfers 

Perform Mass Inventory Transfers Not in Costpoint Web Materials » Inventory » Transfers » Create Mass 
Inventory Transfers 

Reservations 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Reservations 

Enter Inventory Requests Not in Costpoint Web Materials » Inventory » Reservations » Manage 
Inventory Requests 

Enter Reservations Not in Costpoint Web Materials » Inventory » Reservations » Manage 
Inventory Reservations 

Enter PO/Req Inventory Reservations Not in Costpoint Web Materials » Inventory » Reservations » Manage 
PO/Req Inventory Reservations 
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Physical Counts 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Physical Counts 

Perform ABC Analysis Not in Costpoint Web Materials » Inventory » Physical Counts » Update 
ABC Classifications 

Set Up Physical Count Not in Costpoint Web Materials » Inventory » Physical Counts » Create 
Physical Counts 

Maintain Physical Count List Not in Costpoint Web Materials » Inventory » Physical Counts » Manage 
Physical Counts 

Print Physical Count Sheets Not in Costpoint Web Materials » Inventory » Physical Counts » Print 
Physical Count Sheets 

Enter Actual Counts Not in Costpoint Web Materials » Inventory » Physical Counts » Manage 
Actual Counts 

Print Discrepancy Report and Create Adjustments Not in Costpoint Web Materials » Inventory » Physical Counts » Create 
Physical Count Adjustments 

Post Inventory Journal 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » 

Post Inventory Journal Not in Costpoint Web Materials » Inventory » Inventory Closing » Post 
Inventory Journal 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Inquiries 

Part Inventory Inquiry Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» View Part Inventory 

Inventory Transaction History Inquiry Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» View Inventory Transaction History 

Serial/Lot Inquiry Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» View Serial/Lot Information 

Item Inquiry Materials » Review » Items » Item Inquiry Materials » Inventory » Inventory Reports/Inquiries 
» View Items 

Part Query Not in Costpoint Web Not in Costpoint 7.0 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Reports 

Print Stock Status Report Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» Print Stock Status Report 

Print Reservation Pick Lists Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» Print Reservation Pick Lists 

Print Inventory Transaction History Report Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» Print Inventory Transaction History 

Print Inventory Reorder Report Not in Costpoint Web Materials » Inventory » Inventory Reports/Inquiries 
» Print Inventory Reorder Report 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Inventory » Utilities 

Reconcile Transactions Not in Costpoint Web Materials » Inventory » Inventory Utilities » 
Reconcile Inventory Balances 

Serial/Lot Maintenance Not in Costpoint Web Materials » Inventory » Inventory Utilities » Manage 
Serial/Lot Information 

Close Inventory Fiscal Year Not in Costpoint Web Materials » Inventory » Inventory Utilities » Close 
Inventory Fiscal Year 
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Production Control 

Production Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » Production Controls 

Production Control Settings Not in Costpoint Web Materials » Production Control » Production Control 
Controls » Configure Production Control Settings 

MO Costing Options Not in Costpoint Web 
Materials » Production Control » Production Control 
Controls » Configure Manufacturing Order Costing 
Options 

Planners Not in Costpoint Web Materials » Production Control » Production Control 
Controls » Manage Planners 

Supervisors Not in Costpoint Web Materials » Production Control » Production Control 
Controls » Manage Supervisors 

Netting Groups Not in Costpoint Web Materials » Production Control » Production Control 
Controls » Manage Netting Groups 

Inventory Abbreviation Peggings Not in Costpoint Web 
Materials » Production Control » Production Control 
Controls » Manage Inventory Abbreviation 
Peggings 

MO Documentation Print Options Not in Costpoint Web 
Materials » Production Control » Production Control 
Controls » Configure MO Documentation Print 
Options 

Shop Floor Calendar Not in Costpoint Web Materials » Production Control » Production Control 
Controls » Configure Shop Floor Calendar 

Manufacturing Rejection Reasons Not in Costpoint Web 
Materials » Production Control » Production Control 
Controls » Manage Manufacturing QC Rejection 
Reasons 
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Process Material Requirements 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » 

Process Material Requirements Not in Costpoint Web Materials » Production Control » Materials Planning 
» Compute Material Requirements 

Manufacturing Orders 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » Manufacturing Orders 

Enter Manufacturing Orders Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Manage Manufacturing Orders 

Expedite Manufacturing Orders Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Expedite Manufacturing Orders 

Enter Manufacturing Order Issues Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Enter Manufacturing Order Issues 

Create MO Subcontractor Requisitions Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Create MO Subcontractor Requisitions 

Print Manufacturing Order Documentation Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Print Manufacturing Order Documentation 
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Relieve Manufacturing Orders 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » 

Relieve Manufacturing Orders Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Enter Manufacturing Order Reliefs 

Shop Floor Control 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » Shop Floor Control 

Enter MO Operation Completions Materials » Transactions » Manufacturing Orders » 
Enter MO Operation Completions 

Materials » Production Control » Manufacturing 
Orders » Manage MO Operation Completions 

Enter MO QC Inspection Results Materials » Transactions » Manufacturing 
Orders » Enter MO QC Inspection Results 

Materials » Production Control » Manufacturing 
Orders » Manage MO Quality Control Inspection 
Results 

Create MO WIP Variance Journal Entry 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » 

Create MO WIP Variance Journal Entry Not in Costpoint Web Materials » Production Control » Manufacturing 
Orders » Create MO WIP Variance Journal Entry 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » Inquiries 

Manufacturing Order Status Inquiry Not in Costpoint Web 
Materials » Production Control » Production Control 
Reports/Inquiries » View Manufacturing Order 
Status 

Part Inventory Inquiry Not in Costpoint Web Materials » Production Control » Production Control 
Reports/Inquiries » View Part Inventory 

Part Query Not in Costpoint Web Not in Costpoint 7.0 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » Reports 

Print Component Shortage Report Not in Costpoint Web 
Materials » Production Control » Production Control 
Reports/Inquiries » Print Manufacturing Order 
Component Shortage Report 

Print MO Cost Report Not in Costpoint Web 
Materials » Production Control » Production Control 
Reports/Inquiries » Print Manufacturing Order Cost 
Report 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Production Control » Utilities 

Modify MO Costs Not in Costpoint Web Materials » Production Control » Production Control 
Utilities » Update Manufacturing Order Costs 

Modify MO Labor Costs Not in Costpoint Web Materials » Production Control » Production Control 
Utilities » Update Manufacturing Order Labor Costs 

Miscellaneous Toolkits » Add Stop Explosion Flag 
to MO Requirements Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Add Stop Explosion Flag 
to Reservation Lines Not in Costpoint Web Not in Costpoint 7.0 

Miscellaneous Toolkits » Load MO WIP Accounts Not in Costpoint Web Not in Costpoint 7.0 
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Sales Order Entry 

Sales Order Entry Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Sales Order Entry Controls 

Sales Order Settings Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Configure Sales Order Entry Settings 

Sales Order Defaults Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Configure Sales Order Defaults 

Sales Order Project Settings Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Order Project Defaults 

Sales Order Catalog Settings Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Order Catalog Defaults 

Contractor Addresses Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Contractor Addresses 

Issued by Addresses Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Issued By Addresses 

Sales Order Rejection Reasons Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Order Rejection Reasons 

Sales Order Cost Types Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Order Cost Types 

Sales Order Approval Titles Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Order Approval Titles 

Sales Order Approval Processes Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Order Approval 
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Processes 

Sales Order Print Options Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Configure Sales Order Print Options 

Sales Representatives Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Sales Representatives 

Sales Order Line Charge Types Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Line Charge Types 

Sales Order Standard Text Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Standard Text 

Sales Order User-Defined Labels Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Order User-Defined Labels 

Serial/Lot Settings Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Configure Serial/Lot Settings 

Serial/Lot User-Defined Labels Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Serial/Lot User-Defined Labels 

Deferred Revenue Amortization Schedules Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Deferred Revenue Amortization 
Schedules 

Shipment Modes Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Controls » Manage Shipment Modes 

Customer Info 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Customer Info 

Maintain Customer Materials » Maintain » Customers » Customers Materials » Sales Order Entry » Customers » 
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Manage Customers 

Customer User-Defined Info Accounting » Maintain » Customers » Customer 
User-Defined Information 

Accounting » Accounts Receivable » Customers » 
Manage Customer User-Defined Information 

Print Customer Listing Not in Costpoint Web Materials » Sales Order Entry » Customers » Print 
Customer List 

Sales Orders 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Sales Orders 

Enter Sales Orders Not in Costpoint Web Materials » Sales Order Entry » Sales Orders » 
Manage Sales Orders 

Approve Sales Orders Not in Costpoint Web Materials » Sales Order Entry » Sales Orders » 
Approve Sales Orders 

Print Sales Order Acknowledgments Not in Costpoint Web Materials » Sales Order Entry » Sales Orders » 
Print Sales Order Acknowledgements 

Sales Order Supervisor Screen Not in Costpoint Web Materials » Sales Order Entry » Sales Orders » 
Manage Sales Orders Supervisor Screen 

Sales Order User-Defined Info Not in Costpoint Web Materials » Sales Order Entry » Sales Orders » 
Manage Sales Order User-Defined Information 

Create Requisitions from Sales Orders Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order 
Material Processing » Create Purchase 
Requisitions from Sales Orders 

 
  



Materials  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 182 

 

Sales Order Material Processing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Sales Order Material Processing 

Print Sales Order Pick Lists Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Material Processing » Print Sales Order Pick Lists 

Enter Sales Order Inventory Issues Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order 
Material Processing » Manage Sales Order 
Inventory Issues 

Enter Sales Order Non- Inventory Issues Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order 
Material Processing » Manage Sales Order Non-
Inventory Issues 

Shipping Transactions 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Shipping Transactions 

Enter Shipping Transactions Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Shipping » Manage Shipping Transactions  

Print Shipping Labels Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Shipping » Print Shipping Labels 

Print Packing Slips Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Shipping » Print Sales Order Packing Slips 

Print DD250 Packing Slips Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Shipping » Print DD250 Packing Slips 
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Invoices 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Invoices 

Create Invoices Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Invoices » Create Invoices 

Maintain Invoices Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Invoices » Manage Invoices 

Ready for Use/Acceptance Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order 
Invoices » Select Invoices Ready for 
Use/Acceptance 

Invoice Supervisor Screen Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Invoices » Manage Invoices Supervisor Screen 

Print Invoices Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Invoices » Print Sales Order Invoices 

Print DD250 Invoices Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Invoices » Print DD250 Invoices 

Create WAWF Files Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Invoices » Create WAWF Files 

Post Sales Order Journal Not in Costpoint Web Materials » Sales Order Entry » Sales Order 
Posting » Post Sales Order Journal 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Inquiries 

Sales Order Status Inquiry Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order Entry 
Reports/Inquiries » View Sales Order Status 
Information 

Sales Analysis Inquiry Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Reports/Inquiries » View Sales Analysis Information 

Serial/Lot Inquiry Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Reports/Inquiries » View Serial/Lot Information 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Reports 

Print Sales Order Approval Status Report Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order Entry 
Reports/Inquiries » Print Sales Order Approval 
Status Report 

Print Sales Order Backlog Report Not in Costpoint Web 
Materials » Sales Order Entry » Sales Order Entry 
Reports/Inquiries » Print Sales Order Backlog 
Report 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Sales Order Entry » Utilities 

Create EDI Invoice File Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Utilities » Create EDI Invoice File 

Serial/Lot Maintenance Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Utilities » Manage Serial/Lot Information 

Miscellaneous Toolkits » Reset Period Sequence 
Keys for Unposted Amortization Schedules Not in Costpoint Web Not in Costpoint 7.0 
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Master Production Scheduling 

MPS Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Master Production Scheduling » MPS Controls 

MPS Settings Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Scheduling Controls » Configure Master 
Production Scheduling Settings 

MPS Planning Codes Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Scheduling Controls » Manage Master 
Production Schedules Planning Codes 

Resource Types Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Scheduling Controls » Manage 
Resource Types 

Key Resources Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Scheduling Controls » Manage Key 
Resources 

Planning Routings 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Master Production Scheduling » Planning Routings 

Calculate Planning Routings Not in Costpoint Web 
Materials » Master Production Scheduling » 
Planning Routings » Create/Update Planning 
Routings 

Maintain Planning Routings Not in Costpoint Web Materials » Master Production Scheduling » 
Planning Routings » Manage Planning Routings 



Materials  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 187 

 

Master Production Scheduling 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Master Production Scheduling » Master Production Scheduling 

Generate Master Production Schedules Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Schedules » Update Master Production 
Schedules 

Edit Master Production Schedule Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Schedules » Manage Master Production 
Schedules 

Copy Master Production Schedules Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Schedules » Copy Master Production 
Schedules 

Edit MPS Action Messages Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Schedules » Manage Master Production 
Schedule Action Messages 

Generate Rough-Cut Capacity Plan Not in Costpoint Web 
Materials » Master Production Scheduling » Rough-
Cut Capacity Plan » Create/Update Rough-Cut 
Capacity Plan 

Firm Planned Orders Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Schedules » Firm Master Production 
Schedule Planned Orders 
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Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Master Production Scheduling » Inquiries 

Rough-Cut Capacity Plan Inquiry Not in Costpoint Web Materials » Master Production Scheduling » Rough-
Cut Capacity Plan » View Rough-Cut Capacity Plan 

Part Inventory Inquiry Not in Costpoint Web 
Materials » Master Production Scheduling » 
Material Production Scheduling Reports/Inquiries » 
View Part Inventory 

Item Inquiry Not in Costpoint Web 
Materials » Master Production Scheduling » 
Material Production Scheduling Reports/Inquiries » 
View Items 

Part Query Not in Costpoint Web Not in Costpoint 7.0 

Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Master Production Scheduling » Reports 

Print Master Production Schedule Report Not in Costpoint Web 
Materials » Master Production Scheduling » 
Material Production Scheduling Reports/Inquiries » 
Print Master Production Schedule Report 

Print MPS Action Message Report Not in Costpoint Web 
Materials » Master Production Scheduling » Master 
Production Schedules » Print Master Production 
Schedule Action Message Report 

Print Rough-Cut Capacity Plan Report Not in Costpoint Web Not in Costpoint 7.0 

Print Production Backlog Report Not in Costpoint Web Materials » Master Production Scheduling » 
Material Production Scheduling Reports/Inquiries » 
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Print Production Backlog Report 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Master Production Scheduling » Utilities 

Import Forecasted Demand Not in Costpoint Web Not in Costpoint 7.0 

Calculate Cumulative Lead Time Not in Costpoint Web Not in Costpoint 7.0 
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Material Requirements Planning 

MRP Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Material Requirements Planning » MRP Controls 

MRP Settings Not in Costpoint Web 

Materials » Material Requirements Planning » 
Material Requirements Planning Controls » 
Configure Materials Requirements Planning 
Settings 

Inventory Abbreviation Peggings Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Controls » Manage 
Inventory Abbreviation Peggings 

MRP Report Print Options Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Controls » 
Configure MRP Report Print Options 

Material Requirements Planning 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Material Requirements Planning » Material Requirements Planning 

Update Low-Level Codes Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Utilities » Update 
Low-Level Codes 

Update Material Requirements Plan Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning » Update Material 
Requirements Plan 

Expedite Manufacturing Orders Not in Costpoint Web Materials » Material Requirements Planning » 
Material Requirements Planning » Expedite 
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Manufacturing Orders 

Detailed Part Schedule Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning » Manage Detailed 
Part Schedule 

Maintain MRP Action Messages Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning » Manage MRP 
Action Messages 

Firm Planned Orders Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning » Firm Material 
Requirements Planning Planned Orders 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Material Requirements Planning » Inquiries 

Summary Part Availability Inquiry Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Reports/Utilities » 
View Summary Part Availability 

Part Inventory Inquiry Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Reports/Utilities » 
View Part Inventory 

Item Inquiry Materials » Review » Items » Item Inquiry 
Materials » Material Requirements Planning » 
Material Requirements Planning Reports/Utilities » 
View Items 

Part Query Not in Costpoint Web Not in Costpoint 7.0 
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Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Material Requirements Planning » Reports 

Print MRP Action Message Report Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning » Print MRP Action 
Message Report 

Print Detailed Part Availability Report Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Reports/Utilities » 
Print Detailed Part Availability Report 

Print Summary Part Availability Report Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Reports/Utilities » 
Print Summary Part Availability Report 

Print BOM MRP Action Message Report Not in Costpoint Web 
Materials » Material Requirements Planning » 
Material Requirements Planning Reports/Utilities » 
Print Bills of Material MRP Action Message Report 

Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Material Requirements Planning » Utilities 

Miscellaneous Toolkits » Change MO Status from 
Planned to Firm Planned* Not in Costpoint Web 

Materials » Material Requirements Planning » 
Material Requirements Planning Utilities » Convert 
MO Status from Planned to Firmed Planned 

Miscellaneous Toolkits » Change Netting Flags for 
MRB Locations* Not in Costpoint Web 

Materials » Material Requirements Planning » 
Material Requirements Planning Utilities » Update 
Netting Flags for MRB Locations 

Miscellaneous Toolkits » Assign Planning 
Warehouses to Inventory Projects* Not in Costpoint Web Materials » Material Requirements Planning » 

Material Requirements Planning Utilities » Assign 
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Planning Warehouses to Inventory Projects 

Miscellaneous Toolkits » Assign Project Planning 
Warehouses to Req and PO Lines* Not in Costpoint Web 

Materials » Material Requirements Planning » 
Material Requirements Planning Utilities » Assign 
Project Planning Warehouses to Req and PO Lines 

Miscellaneous Toolkits » Create Reservations for 
Pending Sales Orders* Not in Costpoint Web 

Materials » Material Requirements Planning » 
Material Requirements Planning Utilities » Create 
Reservations for Pending Sales Orders 

Miscellaneous Toolkits » Populate MRP Report 
Detail Table* Not in Costpoint Web 

Materials » Material Requirements Planning » 
Material Requirements Planning Utilities » Create 
MRP Detail Report Table 
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Materials Estimating 

Materials Estimating Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating » Materials Estimating Controls 

Materials Estimating Settings Not in Costpoint Web 
Materials » Materials Estimating » Materials 
Estimating Controls » Configure Materials 
Estimating Settings 

ME Cost Source Types Not in Costpoint Web 
Materials » Materials Estimating » Materials 
Estimating Controls » Manage Materials Estimating 
Cost Source Types 

Provisional Part Types Not in Costpoint Web 
Materials » Materials Estimating » Materials 
Estimating Controls » Manage Provisional Part 
Types 

Maintain Provisional Parts, Maintain Proposal Master 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating »  

Maintain Provisional Parts Not in Costpoint Web Materials » Product Definition » Provisional Parts » 
Manage Provisional Parts 

Maintain Proposal Master Not in Costpoint Web Materials » Materials Estimating » Proposals » 
Manage Proposals 
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Proposal Bills of Material 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating » Proposal Bills of Material 

Maintain Proposal BOM Not in Costpoint Web Materials » Materials Estimating » Proposal Bills of 
Material » Manage Proposal Bills of Material 

Copy Proposal BOM Not in Costpoint Web Materials » Materials Estimating » Proposal Bills of 
Material » Copy Proposal Bills of Material 

Perform PBOM Mass Component Change Not in Costpoint Web 
Materials » Materials Estimating » Proposal Bills of 
Material » Apply Mass Component Changes to 
Proposal BOMs 

Proposal Item Costing 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating » Proposal Item Costing 

Compute Proposal Item Costs Not in Costpoint Web Materials » Materials Estimating » Proposal Item 
Costing » Compute Proposal Item Costs 

Maintain PBOM Cost Estimates - Indented Not in Costpoint Web 
Materials » Materials Estimating » Proposal Item 
Costing » Manage Proposal BOM Cost Estimates - 
Indented 

Maintain PBOM Cost Estimates - Summarized Not in Costpoint Web 
Materials » Materials Estimating » Proposal Item 
Costing » Manage Proposal BOM Cost Estimates - 
Summarized 
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Requests for Quotes 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating » Requests for Quotes 

Select RFQs from Proposals Not in Costpoint Web 
Materials » Materials Estimating » Request for 
Quotes » Select Request for Quotes from 
Proposals 

Create RFQs for Proposals Not in Costpoint Web Materials » Materials Estimating » Request for 
Quotes » Create Request for Quotes for Proposals 

Inquiries 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating » Inquiries 

Proposal BOM Where-Used Inquiry Not in Costpoint Web 
Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries » View Proposal BOM 
Where-Used Information 

Item Purchasing Information Inquiry Materials » Review » Purchase Orders » Item 
Purchasing Information Inquiry 

Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries » View Item 
Purchasing Information 

Vendor Quote Inquiry Not in Costpoint Web Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries » View Vendor Quotes 

Vendor Performance Inquiry Materials » Review » Vendors » Vendor 
Performance Inquiry 

Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries » View Vendor 
Performance 
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Reports 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Materials » Materials Estimating » Reports 

Print Proposal Item Cost History Report Not in Costpoint Web 
Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries » Print Proposal Item 
Cost History Report 

Print PBOM Exception Report Not in Costpoint Web 
Materials » Materials Estimating » Materials 
Estimating Reports/Inquiries » Print Proposal Bills 
of Material Exception Report 
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Others 

Process Management 

Design 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Process Management » Design 

Maintain Process Groups Administration » Maintain » Job Management » Job 
Groups 

Administration » Job Management » Job 
Management Codes » Manage Job Groups 

Maintain Processes Administration » Maintain » Job Management » 
Jobs 

Administration » Job Management » Job 
Management Codes » Manage Jobs 

Print Process Report Administration » Review » Job Management » Job 
Report 

Administration » Job Management » Job 
Management Reports/Inquiries » Print Job Report 

Setup 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Process Management » Setup 

Maintain Printer IDs Administration » Maintain » Printers » System 
Printers 

Administration » System Administration » Printing » 
Manage System Printers 

Maintain Queues Administration » Maintain » Job Management » Job 
Queues 

Administration » Job Management » Job 
Management Codes » Manage Job Queues 
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Initiate 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Process Management » Initiate 

Execute Process Not in Costpoint Web Not in Costpoint 7.0 

Submit Process to Queue Administration » Transactions » Job Management » 
Submit Job to Queue 

Administration » Job Management » Job 
Management Processing » Submit Job to Queue 

Manage 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Process Management » Manage 

Change/Monitor Process Status Administration » Transactions » Job Management » 
Monitor Job Status 

Administration » Job Management » Job 
Management Processing » Update Job Status 

Print/Purge Process History Administration » Utilities » Job Management » 
Print/Purge Job History 

Administration » Job Management » Job 
Management Utilities » Print/Purge Job History 

Change Server Status Administration » Transactions » Job Management » 
Start/Stop Job Server 

Administration » Job Management » Job 
Management Processing » Start/Stop Job Server 
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Product Interfaces 

ADP Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » ADP Interface 

ADP Mappings Not in Costpoint Web People » Labor » ADP Interface » Manage ADP 
Mapping Values 

ADP 2.5 Mappings Not in Costpoint Web People » Labor » ADP Interface » Manage ADP 2.5 
Mapping Values 

ADP Timesheet Transfer Not in Costpoint Web People » Labor » ADP Interface » Export 
Timesheets to ADP 

Ceridian Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Ceridian Interface 

Maintain Ceridian Configuration Not in Costpoint Web People » Labor » Ceridian Interface » Manage 
Ceridian Configuration 

Maintain Ceridian ID Format Not in Costpoint Web People » Labor » Ceridian Interface » Manage 
Ceridian Configuration 

Maintain Ceridian Mappings Not in Costpoint Web People » Labor » Ceridian Interface » Manage 
Ceridian Configuration 

Download Timesheets to Ceridian Not in Costpoint Web People » Labor » Ceridian Interface » Export 
Timesheets to Ceridian  
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Ceridian Tax Services 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Ceridian Tax Services 

CTS Settings Not in Costpoint Web People » Payroll » Payroll Interfaces » Configure 
CTS Settings 

CTS Tax File Data Not in Costpoint Web People » Payroll » Payroll Interfaces » Manage 
CTS Tax File Data 

Create CTS Tax File Not in Costpoint Web People » Payroll » Payroll Interfaces » Create CTS 
Tax File Data 

CTS W-2 Settings Not in Costpoint Web People » Payroll » Payroll Interfaces » Manage 
CTS W-2 File Data 

Create CTS W-2 File Not in Costpoint Web People » Payroll » Payroll Interfaces » Create CTS 
W-2 File 

Cobra Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Cobra Interface 

Cobra Interface Settings Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Cobra 
Interface Settings 

Maintain Cobra Charge Templates Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Cobra Charge 
Templates 

Maintain Cobra Budget Element Templates Not in Costpoint Web Administration » System Administration » System 
Administration Interfaces » Manage Cobra Budget 
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Element Templates 

Maintain Cobra Cost Templates Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Cobra Cost 
Templates 

Cobra Program Mapping Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Cobra Program 
Mapping 

Cobra Extraction Parameters Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Cobra 
Extraction Parameters 

Compute Cobra Burden Cost Not in Costpoint Web 

Administration » System Administration » System 
Administration Interfaces » Compute Cobra Burden 
Costs 

Projects » Cost and Revenue Processing » Project 
Cost Processing » Compute Cobra Burden Costs 

Maintain Prior Year Cobra Costs Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Prior Year 
Cobra Costs 

Corporate Planner Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Corporate Planner Interface 

Corporate Planner Interface Not in Costpoint Web Accounting » General Ledger » General Ledger 
Interfaces » Corporate Planner 
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CRM/Gov Win/RP Integration 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » CRM/Gov Win/RP Integration  

Configure Account Options Not in Costpoint Web Not in Costpoint 7.0 

Configure Cost and Revenue Options Not in Costpoint Web Not in Costpoint 7.0 

Configure Customer Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Customer 
Options 

Configure Employee Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Employee 
Options 

Configure Organization Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Organization 
Options 

Configure Project Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Project 
Options 

Configure Rate Table Options Not in Costpoint Web Not in Costpoint 7.0 

Configure Vendor Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Vendor 
Options 

Maintain Account Mapping Not in Costpoint Web Not in Costpoint 7.0 

Maintain Chart of Accounts Not in Costpoint Web Not in Costpoint 7.0 

Maintain Project Level Mapping Not in Costpoint Web Administration » System Administration » System 
Administration Interfaces » Manage Project Level 
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Mapping 

Retrieve Labor Rates Not in Costpoint Web Not in Costpoint 7.0 

Configure Client Upload Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Client Upload 
Options 

Configure Project Upload Options Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Configure Project 
Upload Options 

Employee Expense Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Employee Expense Interface 

Employee Expense Interface Not in Costpoint Web Not in Costpoint 7.0 

Employee Self Service 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Employee Self Service  

ESS Global Settings Not in Costpoint Web People » Employee » Employee Interfaces » 
Configure ESS Global Settings 

ESS Company Settings Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage ESS Company Settings 

ESS Company Links Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage ESS Company Links 

ESS Life Event Setup Not in Costpoint Web People » Employee » Employee Interfaces » 
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Configure  ESS Life Events 

Activate ESS Users Not in Costpoint Web Not in Costpoint 7.0.1   

ESS State Tax Settings Not in Costpoint Web People » Employee » Employee Interfaces » 
Configure ESS State Tax Settings 

Approve Employee Life Events Not in Costpoint Web People » Employee » Employee Interfaces » 
Approve Employee Life Events 

Life Event User Flow Status Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage Life Event User Flow Status 

ESS Life Event Benefit Elections Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage ESS Life Event Benefit Elections 

Populate Open Enrollment Benefit Options Not in Costpoint Web People » Employee » Employee Interfaces » 
Update Benefit Option/Election Tables 

ESS Open Enrollment Elections Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage ESS Open Enrollment Elections 

Approve ESS Benefit Elections by Plan Not in Costpoint Web People » Employee » Employee Interfaces » 
Approve ESS Benefit Elections By Plan 

Activate Pending Benefit Elections Not in Costpoint Web People » Employee » Employee Interfaces » 
Activate Pending ESS Benefit Elections 

Maintain ESS Retirement Benefit Elections Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage ESS Retirement Benefit Elections 

Upload Retirement Benefits Changes Not in Costpoint Web People » Employee » Employee Interfaces » 
Activate ESS Retirement Benefit Changes 

Set/Reset Login Info Not in Costpoint Web Not in Costpoint 7.0.1 

Print Login Info Not in Costpoint Web Not in Costpoint 7.0.1 
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Purge ESS Data Not in Costpoint Web People » Employee » Employee Interfaces » Purge 
ESS Data 

Expedition Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Expedition Interface 

Expedition Interface Not in Costpoint Web Not in Costpoint 7.0.1 

ERMS Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » ERMS Interface  

ERMS Customer Terms Mapping Not in Costpoint Web Not in Costpoint 7.0.1 

Export to ERMS Not in Costpoint Web Not in Costpoint 7.0.1 

Import ERMS Invoices Not in Costpoint Web Not in Costpoint 7.0.1 

Synchronize ERMS Mirror Tables Not in Costpoint Web Not in Costpoint 7.0.1 

Interface Controls 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Interface Controls  

Interface Configuration and Scheduler Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Interface 
Configuration and Scheduler 
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Instance Activation Control Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Activate Instance 
Control 

Maintain Interface Elements Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Interface 
Elements 

Maintain Element Value Mappings Not in Costpoint Web 
Administration » System Administration » System 
Administration Interfaces » Manage Element Value 
Mappings 

Microframe Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Microframe Interface  

Microframe EOC Mappings Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Interfaces » Manage 
Microframe EOC Mappings 

Microframe OBS Mappings Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Interfaces » Manage 
Microframe OBS Mappings 

Microframe WBS Mappings Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Interfaces » Manage 
Microframe WBS Mappings 

Microframe Resource Mappings Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Interfaces » Manage 
Microframe Resource Mappings 

Microframe Transfer Not in Costpoint Web 
Projects » Cost and Revenue Processing » Cost 
and Revenue Processing Interfaces » Create 
Microframe Transfer File 
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PDS Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » PDS Interface  

PDS Timesheet Mappings Not in Costpoint Web Not in Costpoint 7.0.1 

PDS Timesheet Transfer Not in Costpoint Web Not in Costpoint 7.0.1 

Preprocessors   
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Preprocessors  

A/P Voucher Suspense Setup Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Manage Accounts Payable 
Voucher Suspense 

A/P Voucher Preprocessor Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Import Accounts Payable 
Vouchers 

Multicurrency A/P Voucher Preprocessor Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Import Accounts Payable 
Multicurrency Vouchers 

Bills of Material Preprocessor Not in Costpoint Web Materials » Bills of Material » Bills of Material 
Interfaces » Import Bills of Material 

Cash Receipt Preprocessor Settings Not in Costpoint Web 
Accounting » Accounts Receivable » Accounts 
Receivable Interfaces » Manage Cash Receipts 
Preprocessor Settings 

Cash Receipt Preprocessor Not in Costpoint Web Accounting » Accounts Receivable » Accounts 
Receivable Interfaces » Import Cash Receipts 



Others  

 

Costpoint 6.1 to Costpoint 7.1 Menu Mapping 209 

 

Deduction and Leave Preprocessor Not in Costpoint Web People » Employee » Employee Interfaces » Import 
Employee Leave and Deductions 

Employee Basic Preprocessor Setup Not in Costpoint Web People » Employee » Employee Interfaces » 
Manage Employee Import User-Defined Format 

Employee Basic Preprocessor Not in Costpoint Web People » Employee » Employee Interfaces » Import 
Employee Data 

Item Preprocessor Not in Costpoint Web Materials » Product Definition » Product Definition 
Interfaces » Import Items 

Inventory Transaction Preprocessor Materials » Utilities » Import » Import Inventory 
Transactions 

Materials » Inventory » Inventory Interfaces » 
Import Inventory Transactions 

Journal Entry Suspense Setup Not in Costpoint Web 
Accounting » General Ledger » General Ledger 
Interfaces » Manage Journal Entry Preprocessor 
Settings 

Journal Entry Preprocessor Accounting » Utilities » Import » Import Journal 
Entries 

Accounting » General Ledger » General Ledger 
Interfaces » Import Journal Entries 

PO Preprocessor Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Import Purchase Orders 

PO Receipts Preprocessor Not in Costpoint Web Materials » Receiving » Receiving Interfaces » 
Import Purchase Order Receipts 

PO Vouchers Preprocessor Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Import Purchase Order 
Vouchers 

Purchase Requisition Preprocessor Not in Costpoint Web Materials » Procurement Planning » Procurement 
Planning Interfaces » Import Purchase Requisitions 

Sales Order Preprocessor Not in Costpoint Web Materials » Sales Order Entry » Sales Order Entry 
Interfaces » Import Sales Orders 
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Subcontract PO Status Update Preprocessor Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Import Subcontract PO Status Updates 

TE Suspense Setup Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Configure TE Suspense 
Settings 

TE Expense Report Preprocessor Not in Costpoint Web 
Accounting » Accounts Payable » Accounts 
Payable Interfaces » Import TE 
Expenses/Advances 

Timesheet Suspense Setup Not in Costpoint Web People » Labor » Timesheet Import Interface » 
Configure Timesheet Suspense Values 

Timesheet Preprocessor Not in Costpoint Web People » Labor » Timesheet Import Interface » 
Import Timesheets 

Vendor Master Preprocessor Not in Costpoint Web Accounting » Accounts Payable » Accounts 
Payable Interfaces » Import Vendors 

Vendor Quote Preprocessor Not in Costpoint Web Materials » Procurement Planning » Procurement 
Planning Interfaces » Import Vendor Quotes 

Primavera Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Primavera Interface 

Primavera Interface Not in Costpoint Web Not in Costpoint 7.0.1 
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Project Planner Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Project Planner Interface  

Interface Configuration Not in Costpoint Web Projects » Budgeting and ETC » Budget Interfaces 
» Configure Interface Settings 

Import Project Budgets Not in Costpoint Web Projects » Budgeting and ETC » Budget Interfaces 
» Import Project Budgets 

Retrieve Labor Rates Not in Costpoint Web Projects » Budgeting and ETC » Budget Interfaces 
» Retrieve Labor Rates 

MS Project Interface 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » MS Project Interface  

MS Project Interface Not in Costpoint Web Not in Costpoint 7.0.1 

eProcurement 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » eProcurement  

Download Addresses Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Export eProcurement Addresses 

Download Vendor Information Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Export eProcurement Vendors 

Download Project/Account/Org Information Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
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Export eProcurement Proj/Acct/Org 

Download Inventory Abbreviations Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Export eProcurement Inventory Abbreviations 

Download Items and Line Charge Types Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Export eProcurement Items and Line Charge Types 

Download Requisition Information Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Export eProcurement Requisitions 

Download PO Receipt Information Not in Costpoint Web Materials » Purchasing » Purchasing Interfaces » 
Export eProcurement PO Receipts 

Deltek Contract Manager (Powered by Prolog) 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Deltek Contract Manager (Powered by Prolog)  

Download Requisition Information Not in Costpoint Web Not in Costpoint 7.0.1 

Configure Cost Commitment Options Not in Costpoint Web Not in Costpoint 7.0.1 

Configure Subcontract Status Update Options Not in Costpoint Web Not in Costpoint 7.0.1 

Configure General Invoice Options Not in Costpoint Web Not in Costpoint 7.0.1 

Configure Commitment & Invoice Reconciliation 
Options Not in Costpoint Web Not in Costpoint 7.0.1 
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Advanced Planning and Scheduling 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Product Interfaces » Advanced Planning and Scheduling  

Advanced Planning and Scheduling Parameters Not in Costpoint Web 
Materials » Production Control » Production Control 
Interfaces » Configure Advanced Planning and 
Scheduling Parameters 

Download Work Centers Not in Costpoint Web Materials » Production Control » Production Control 
Interfaces » Export Work Centers 

Download Manufacturing Orders Not in Costpoint Web Materials » Production Control » Production Control 
Interfaces » Export Manufacturing Orders 

Upload MO Status Updates Not in Costpoint Web 
Materials » Production Control » Production Control 
Interfaces » Import Manufacturing Order Status 
Updates 
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System Administration 

System Settings, Set Up Company 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » System Administration »  

System Settings Administration » Configure » System » System 
Settings 

Administration » System Administration » 
System Administration Controls » Configure 
System Settings 

Set Up Company Not in Costpoint Web 
Administration » System Administration » 
System Administration Controls » Set Up 
Company 

System Security 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » System Administration » System Security 

Maintain User Groups Administration » Maintain » Users » User Groups Administration » Security » System Security » 
Manage User Groups 

Maintain Users Administration » Maintain » Users » Users Administration » Security » System Security » 
Manage Users 

Maintain User Override Rights Not in Costpoint Web Administration » Security » System Security » 
Manage Users 

Change Effective User Password Not in Costpoint Web Not in Costpoint 7.0.1 

Print User Report Administration » Review » Users » User Report Administration » Security » Security 
Reports/Inquiries » Print User Report 
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Print MyMenu Report Not in Costpoint Web 
Administration » System Administration » System 
Administration Reports/Inquiries » Print My Menu 
Report 

Print User Group Rights Report Administration » Review » Users » User Group 
Rights Report 

Administration » Security » Security 
Reports/Inquiries » Print User Group Rights Report 

Print User Override Rights Report Not in Costpoint Web Not in Costpoint 7.0.1 

Print User Effective Rights Report Administration » Review » Users » Effective User 
Rights Report 

Administration » Security » Security 
Reports/Inquiries » Print Effective User Rights 
Report 

Organizational Security 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » System Administration » Organizational Security 

Maintain Org Security Profiles Not in Costpoint Web Administration » Security » Organizational 
Security » Manage Organization Security Profiles 

Maintain Org Security Groups Not in Costpoint Web Administration » Security » Organizational 
Security » Manage Organization Security Groups 

Enable/Disable Org Security for Modules Administration » Maintain » Organizational Security 
» Module Organization Security 

Administration » Security » Organizational 
Security » Activate/Inactivate Organization Security 
by Module 

Update Org Security Profiles Not in Costpoint Web Administration » Security » Organizational 
Security » Update Organization Security Profiles 
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System Codes 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » System Administration » System Codes 

Maintain Countries Administration » Maintain » Codes » Countries Administration » System Administration » System 
Administration Controls » Manage Countries 

Maintain States and Provinces Administration » Maintain » Codes » States and 
Provinces 

Administration » System Administration » System 
Administration Controls » Manage States and 
Provinces 

Maintain Postal Codes Administration » Maintain » Codes » Postal Codes Administration » System Administration » System 
Administration Controls » Manage Postal Codes 

Maintain Tax Types Not in Costpoint Web Administration » System Administration » System 
Administration Controls » Manage Tax Types 

Maintain Sales/Value Added Tax Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage Sales or Value 
Added Taxes 

Maintain EC Countries Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage European Union 
Countries 

Maintain Customs Traffic Direction Codes Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage Customs Traffic 
Direction Codes 

Maintain Customs Declaration Point Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage Customs 
Declaration Point 

Maintain EC Mode of Transportation Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage European Union 
Mode of Transportation 
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Maintain EC Nature of Transaction Codes (NOTC) Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage EU Nature of 
Transaction Codes (NOTC) 

Maintain EC Correction Codes Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage European Union 
Correction Codes 

Maintain EC Commodity Codes Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage European Union 
Commodity Codes 

Maintain VAT Supply Codes Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage Value Added 
Tax Supply Codes 

Maintain CIS Codes Not in Costpoint Web 
Administration » System Administration » System 
Administration Controls » Manage Construction 
Industry Scheme Codes 

Print Postal Codes Report Not in Costpoint Web 
Administration » System Administration » System 
Administration Reports/Inquiries » Print Postal 
Codes Report 

Print Sales/Value Added Tax Report Not in Costpoint Web 
Administration » System Administration » System 
Administration Reports/Inquiries » Print Sales/Value 
Added Tax Report 

DBA Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » System Administration » DBA Utilities 

Purge Report Table Data Not in Costpoint Web Administration » System Administration » System 
Administration Utilities » Purge Report Table Data 
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Size Dynamic Tables and Indexes Not in Costpoint Web 
Administration » System Administration » System 
Administration Utilities » Resize Dynamic Tables 
and Indexes 

Clean Up Dynamic Tables Not in Costpoint Web Not in Costpoint 7.0.1 

Print/Purge Costpoint Process/Report Log Not in Costpoint Web Not in Costpoint 7.0.1 

System Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » System Administration » System Utilities 

Enable/Disable Costpoint Usage Not in Costpoint Web 
Administration » System Administration » System 
Administration Utilities » Activate/Inactivate 
Costpoint Usage 

Clear User(s) Administration » Utilities » System Administration » 
Clear Users 

Administration » System Administration » System 
Administration Utilities » Clear Users 

Print Data Dictionary Report Administration » Review » Database » Data 
Dictionary Report 

Administration » System Administration » System 
Administration Reports/Inquiries » Print Data 
Dictionary Report 

Print Menu Report Administration » Review » System Administration » 
Menu Report 

Administration » System Administration » System 
Administration Reports/Inquiries » Print Menu 
Report 

Miscellaneous Toolkits » Upgrade Clean-up* Not in Costpoint Web Administration » System Administration » System 
Administration Utilities » Rebuild Upgraded Tables 

Miscellaneous Toolkits » Report Parameters Fix Not in Costpoint Web Not in Costpoint 7.0.1 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7. 
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Workflow 

Design 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Workflow » Design 

Define Case Labels Not in Costpoint Web Administration » Workflow » Workflow Models » 
Manage Workflow Case Labels 

Define Role Filtering Not in Costpoint Web Administration » Workflow » Workflow Models » 
Manage Workflow Role Filters 

Define Roles Administration » Maintain » Workflow » Workflow 
Roles 

Administration » Workflow » Workflow Models » 
Manage Workflow Roles 

Define Workflow Models Not in Costpoint Web Administration » Workflow » Workflow Models » 
Manage Workflow Models 

Print Workflow Definition Report Not in Costpoint Web Administration » Workflow » Workflow Models » 
Print Workflow Definition Report 

Initiate 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Workflow » Initiate 

Initiate Case Not in Costpoint Web Not in Costpoint 7.0.1 
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Monitor 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Workflow » Monitor 

Maintain Case Administration » Transactions » Workflow » Edit 
Workflow Case 

Administration » Workflow » Workflow Cases » 
Manage Workflow Cases 

Monitor Status Administration » Transactions » Workflow » Monitor 
Workflow Status 

Administration » Workflow » Workflow Cases » 
Monitor Workflow Status 

Escalate Activities Not in Costpoint Web Administration » Workflow » Workflow Cases » 
Escalate Workflow Activities 

Activity and Message Inboxes Administration » Transactions » Workflow » 
Workflow Activity and Message Inboxes 

Administration » Workflow » Workflow Cases » 
Monitor Activities and Messages 

Print Workflow Status Report Not in Costpoint Web Administration » Workflow » Workflow Cases » 
Print Workflow Status Report 

Audit Inquiry Not in Costpoint Web 
Administration » Workflow » Workflow 
Reports/Inquiries » View Workflow Audit 
Information 

Print Audit Report Not in Costpoint Web Administration » Workflow » Workflow 
Reports/Inquiries » Print Workflow Audit Report 

Conclude 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Workflow » Conclude 

Purge Historical Data Not in Costpoint Web Administration » Workflow » Administrative Utilities 
» Purge Workflow Data 
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Utilities 
Costpoint 6.1 Client Server Menu Location Costpoint 6.1 Web Menu Location Costpoint 7.1 Menu Location 

Others » Workflow » Utilities 

Miscellaneous Toolkits » Upgrade Clean-up* Not in Costpoint Web Administration » Workflow » Administrative Utilities 
» Rebuild Workflow Data 

Miscellaneous Toolkits » Upload Pre-Defined 
Workflows* Not in Costpoint Web Administration » Workflow » Administrative Utilities 

» Import Predefined Workflows 

* The functions formerly available in the Miscellaneous Toolkits screen have been broken out into standalone applications in Costpoint 7.0. 
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Web Only Screens 
People » Utilities » Interfaces 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

People » Utilities » Interfaces 

Project Manufacturing Export Status History Not in Client/Server People » Labor » Timesheet Interface » 
Project Manufacturing Export Status History 

Export Project Manufacturing Data Not in Client/Server People » Labor » Timesheet  Interface » 
Export Project Manufacturing Data 

Projects » Configure » Project 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Projects » Configure » Project 

Quick Project Account Group Mapping Not in Client/Server 
Projects » Project Setup » Project Setup 
Controls » Manage Project Account Group 
Mappings 

Quick Project Organization Mapping Not in Client/Server 
Projects » Project Setup » Project Setup 
Controls » Manage Project Organization 
Mappings 

Quick Project Setup Template  Projects » Project Setup » Project Master » 
Manage Project Templates 

Quick Project Approver Settings  Projects » Project Setup » Project Setup 
Controls » Manage Project Approver Settings 
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Projects » Maintain » Project 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Projects » Maintain » Project 

Generate Quick Project WBS Not in Client/Server Projects » Project Setup » Project Master » 
Create Projects 

Quick Project Setup Not in Client/Server Projects » Project Setup » Project Master » 
Manage Project Master Data 

Approve Quick Projects Not in Client/Server Projects » Project Setup » Project Master » 
Approve Projects 

Import Quick Project Information Not in Client/Server Projects » Project Setup » Project Master » 
Import Project Master Data 

Materials » Configure » Inventory 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Materials » Configure » Inventory 

Plants Not in Client/Server Materials » Inventory » Inventory Controls » 
Manage Plants 

Administration » Configure » Materials 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Materials » Configure » Inventory 

Security Groups Not in Client/Server Materials » Product Definition » Product 
Definition Controls » Manage Security Groups 
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Administration » Maintain » Files 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Administration » Maintain » Files 

Alternate File Locations Not in Client/Server 
Administration » System Administration » File 
Management » Manage Alternate File 
Locations 

Administration » Maintain » Reports  
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Administration » Maintain » Reports 

Report Fonts Not in Client/Server Administration » System Administration » 
Printing » Manage Report Fonts 

Report Categories Not in Client/Server Administration » System Administration » 
Printing » Manage Report Categories 

Report Archive Categories Not in Client/Server Administration » System Administration » 
Printing » Manage Report Archive Categories 

Report Groups Not in Client/Server Administration » System Administration » 
Printing » Manage Report Groups 

Report Archive Security Rights Not in Client/Server Not in Costpoint Web 

Report Locales Not in Client/Server 
Administration » System Administration » 
System Administration Controls » Manage 
Locales 
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Administration » Review » Archived Reports 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Administration » Review » Archived Reports 

Archived Reports Not in Client/Server 
Administration » System Administration » 
System Administration Reports/Inquiries »Print 
Archived Reports 

Administration » Review » Database 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Administration » Review » Database 

Application Table Information Report Not in Client/Server 
Administration » System Administration » 
System Administration Reports/Inquiries » 
Print Application Table Information Report 

 

Administration » Utilities » Files 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Administration » Utilities » Files 

File Download Manager Not in Client/Server Administration » System Administration » File 
Management » Export Files 
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Administration » Utilities » System Administration 
Costpoint 6.1 Web Menu Location Costpoint Client/Server Menu Location Costpoint 7.1 Menu Location 

Administration » Utilities » System Administration 

Reload Global Settings Not in Client/Server 
Administration » System Administration » 
System Administration Utilities » Rebuild 
Global Settings 
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