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Welcome to ComputerEase
This manual is designed to walk you through basic functions

This manual will be a useful tool as you explore
ComputerEase desktop software. 

If you have upgraded from a previous version of the software,
please be sure to reference our "What's New" Manual.
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1 Service Management

Managing information is key in the Service Management Module. During Work Order entry, information on
customer history, including all prior work performed is at your fingertips. This information can then be used for
planning for peak periods in your business. 

No more missed service calls. Preventative Maintenance can automatically schedule Work Orders for service to be
performed on as often as necessary. Once Work Orders have been generated you can schedule them at your
convenience. 

Service Contract billings can be generated automatically for monthly, quarterly, or yearly invoicing. Service
Management will track contract renewals, billings and history. Using a combination of Contracts and Job Cost,
profitability by contract can be obtained.

Service Management module is an easy to use, intuitive system designed to be used by contractors with service
departments. The Service Management module is fully integrated with Accounts Receivable and optionally with Job
Costing and/or Payroll.

1.1 What is the Service Management Module?

1.1.1 Other Modules and Service Management

Service Management is fully integrated with Accounts Receivable. All invoices generated in Service Management
are posted to the Accounts Receivable module, including all A/R reports. Service Management can also optionally
be integrated with Job Costing, allowing you to track your profitability on service orders in job costing. You also
have the option of interfacing Service Management with Payroll, so that hours entered against work orders in
Service can be posted directly to payroll, eliminating the need for double-entry of hours. In addition, employee
hours entered in Payroll through Enter Labor Distribution can be linked to Service Management work tickets to
provide you with a true labor cost on your Service Management profitability reports.

1.1.2 Features in Service Management

The Service Management module contains a number of tools for you to use to manage your service department.

Some of these features include:

· Easy searching for a customer site by Customer, Name, Phone Number, Address or Job Number.

· Each customer may have multiple sites or locations, and each site can have it own labor, material and
sales tax coding.

· The equipment you service can be tracked at each site, storing model numbers, serial numbers, warranty
information and service schedules.

· Users can define Priority Codes to assist in scheduling and Map Codes to assist in route planning.

· Date and time requested and promised can be tracked to assist you with scheduling.

· The schedule Board provides a graphical user definable dispatch grid, and allows different configurations for
unassigned and assigned work orders.

· New Work Orders scheduled at creation or at a later time.
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· Work Orders can be reassigned on the schedule board with the click of the mouse.

· With a click of the mouse, you can change the schedule board to reflect all technician calls for one day,
one week for a specific tech or all calls for a specific tech.

· Each service technician can be assigned to a unique inventory location, such as his or her service truck.

· Service Instruction codes allow for expanded Work Ticket and service instructions and easy entry.

· Each work order can have multiple tickets assigned to it, in case you have more than one technician
assigned to an order or if work spans multiple days.

1.1.3 Reports in Service Management

Below are some of the reports available in the ComputerEase Service Management Module:

· Work Order Proof Listing - Contract Billing Proof
Listing

· Unscheduled Work Order List

· Open Work Tickets · Work Schedules

· Scheduled Services Report · Contract Expiration Report

· Site History Report · Equipment History Report

· Work Order List · Completed Work Order Report

· Contract Master List · Equipment Master List

· PO Status by Work Order · Profitability Reports

· Billings by Department · Warranty Report by Site

· Payroll Hours vs Billed Hours Report · Customer Master List

1.2 How Do I Set Up Service in ComputerEase?

1.2.1 Creating Site Sequences

You may want ComputerEase to automatically number your sites for you. If so, you will need to create at least
one site numbering sequence.

Select Service Management > Maintenance Programs > Site Sequence Maintenance
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New - Click here to add a new site numbering sequence.

Code - Enter a code or ID for this site numbering sequence, up to 8 alphanumeric characters.

Description - Enter a description of this site numbering sequence.

Next ID - Enter the next number site number you want to use for this site numbering sequence. When
you are finished, press OK to save.

Edit - Highlight a numbering sequence you want to make changes to and click here to edit a site numbering
sequence.

Up - Highlight a sequence and click here to move it higher on the list. Site sequences will be listed in the
order listed here when you create a site and are asked to choose the site sequence to which the site
belongs.

Down - Highlight a sequence and click here to move it lower on the list. Site sequences will be listed in the
order listed here when you create a site and are asked to choose the site sequence to which the site
belongs.

Delete - Highlight a numbering sequence you want to remove to and click here to delete a site numbering
sequence.

When you have finished maintaining your site numbering sequences, click OK to save or Cancel to exit the
screen without saving any changes.

1.2.2 Site Maintenance

Sites are used by the system to manage customer service locations. A customer may have multiple
sites. Each site in the system is linked to a customer for billing.

Select Service Management > Maintenance Programs > Site Maintenance.

At the prompt, enter the code you would like to use for this site in the Site field or, if you are using automatic site
numbering, press the arrow immediately to the right of the question mark or F9 on your keyboard to generate the
next site number. If you have multiple site numbering sequences, choose the site sequence to use to number this
site. Then press OK and answer Yes when prompted to create the site.

Tip: To import sites from a file, click on File, then Import Sites in the upper left corner.
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Main Tab 

Site Code - This field displays the site code and is not editable.

Status – Choose Active or Inactive. Once you are no longer actively performing work at a site, you may
change its status to Inactive.

Customer – Choose the customer who will be billed for work performed at this site. 

Can override - Selecting this option will allow the user entering a work order for this site to override the
customer on a one time basis. Overriding the customer at the work order level will not change the default
customer listed in Site Maintenance.

Same as Customer - Check this box to indicate that the remaining information is the same as the
information in the customer master record. Changes made to the customer record will automatically update
the site. If any of the information listed is different for this site, uncheck this box and change the necessary
information.

Site Name – Type in the site name.

Address – This field contains 2 lines that are 30 characters per line. This address prints on reports and can
print on invoices. Enter the site address.

City - Enter the site city.

Tip: If you enter a valid US zip code into the "City" field and press your Tab key, ComputerEase will automatically
fill in the correct city, state and zip code.

State - Enter the site 2-character state postal abbreviation.

Zip - Enter the site zip code.

Phone – Enter the site phone number.

Department – This is a required field if you are using A/R departments.

Sales Rep – Enter the sales representative that is assigned to this site.

Cost Code – This is optional for each site. If you want to handle all work performed at a site as a job, enter a
cost code here. Activity for this site will be posted to this cost code.
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Work Order Notes - Work order notes are for internal use. They are displayed on the work order entry screen
and can serve as a reminder for your entry person.

Email – Enter the site's email address. If you select the stamped envelope icon after information is entered in
this field ComputerEase will open a new email message to this address.

Last Service Date - The last date service was performed at this site is displayed here for informational
purposes.

Map Code - Enter or choose the map code that applies to this site. Map codes are optional and are used to
assist with route planning and scheduling.

Ticket Format - Choose the format to use when printing work tickets for orders placed for this site. This
format can be overridden per work order or by the format chosen for the assigned tech.

Customer Info - The customer name, current balance, last payment and credit limit are all displayed her for
informational purposes.

Billing Tab

Invoice Address

Use - Choose to use the Customer Address (which will use the customer billing address), Site Address or
Other Address for address to which to send invoices for this site. If you choose Other Address, you will
have the opportunity to enter the Address, City, State and Zip to which to send invoices.

Email Invoices - Check this box if you would like to automatically email service invoices to this site rather
than printing them. Once you check this field, you will have the opportunity to enter an email address to
which to send invoices; the email address field will automatically populate with the email address from the
Main tab, if entered, but can be changed.

Labor Price Code – Select the price code to apply for items with a billing class of Labor.

Other Price Code – Select the price code to apply for items with a billing class of Material, Service or Other.

Tax Code – Enter the sales tax code you want to apply to this site's invoices.

Trade Discount – Enter the percentage by which you would like to discount each invoice that is prepared for
this site.
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Finance Discount – Enter the percentage by which you would like to discounts each invoice that is prepared
for this site if payment is made according to the terms entered into the next field.

Terms -  Enter the credit terms you want to extend to this customer for this site. The selection made in this
field will print on invoices for this site and be used for aging purposes.

Net - Selecting this option from the drop-down and entering a number (xx) in the second field will use a
due date xx days after the invoice date for all invoices created for this site.

COD - Selecting this option from the drop-down will use the invoice date for the due date and print "COD"
for the terms on the site's invoices.

Cash - Selecting this option from the drop-down will use the invoice date for the due date and print "Cash"
for the terms on the site's invoices.

None - Selecting this option from the drop-down will use the invoice date for the due date and no terms
will print on the site's invoices.

Day - Selecting this option from the drop-down and entering a number (xx) in the second field will use a
due date that falls on the next xxth of the month that occurs. For xx of 10, an invoice dated 04/01 will be
due 04/10 and an invoice dated 04/11 will be due 05/10.

Bill Type - Select the bill type that applies to this site, if applicable. Bill Types allow the ability to mark up
items for a particular site in lieu of using price codes.

Group Level – This option allows you to select how you want work tickets grouped on invoices if a customer
or site has multiple work tickets billed at once.

Default – Work tickets will be grouped based on the settings in Service Management Parameters.

Work Order – Work tickets for the same work order will be billed on one invoice unless different invoice
numbers were entered for each ticket.

Site - Work tickets for the same site will be billed on one invoice, unless different invoice numbers, cost
codes or tax codes apply.

Customer - Work tickets for the same customer will be billed on one invoice, unless different invoice
numbers, cost codes or tax codes apply.
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Notes Tab

Enter any site notes here. These may optionally be printed on work orders and can be viewed when creating work
orders.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for sites that were setup in the
Parameters for Service Management. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Service Management Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the site file. This tab only appears if you have created at least one site attachment folder under Configure >
System Parameters > Service Management Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or  Cancel to exit the screen without saving your changes.

1.2.3 Creating Customer Sequences

You may want ComputerEase to automatically number your sites for you. If so, you will need to create at least
one site numbering sequence.

Select Service Management > Maintenance Programs > Customer Sequence Maintenance
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New - Click here to add a new customer numbering sequence.

Code - Enter a code or ID for this customer numbering sequence, up to 8 alphanumeric characters.

Description - Enter a description of this customer numbering sequence.

Next ID - Enter the next number customer number you want to use for this customer numbering
sequence. When you are finished, press OK to save.

Edit - Highlight a numbering sequence you want to make changes to and click here to edit a customer
numbering sequence.

Up - Highlight a sequence and click here to move it higher on the list. Customer sequences will be listed in
the order listed here when you create a customer and are asked to choose the customer sequence to which
the customer belongs.

Down - Highlight a sequence and click here to move it lower on the list. Customer sequences will be listed in
the order listed here when you create a customer and are asked to choose the customer sequence to which
the customer belongs.

Delete - Highlight a numbering sequence you want to remove to and click here to delete a customer
numbering sequence.

When you have finished maintaining your customer numbering sequences, click OK to save or Cancel to exit
the screen without saving any changes.
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1.2.4 Customer Maintenance

Customers may be created from either the Accounts Receivable module or from Service Management. Entries into
either location are stored in the same place. You may want to review the Accounts Receivable module of the
Accounting Tools manual for information on assigning customer numbers to assist you with choosing your
customer numbers.

Select Service Management > Maintenance Programs > Customer Maintenance.

Customer  - Enter the alphanumeric code (up to eight characters) you want to assign to the new customer
and click on OK, or, if you are using automatic customer numbering, press the arrow immediately to the right
of the question mark or F9 on your keyboard to generate the next customer number. If you have multiple
customer numbering sequences, choose the customer sequence to use to number this customer. Then
press OK and answer Yes when prompted to create the customer.

Name and Address Tab

Number - This field displays the customer number and cannot be edited.

Status – The system defaults to Active, you may use the space bar to change to Inactive.  Active means the
customer is actively being used and will print on all AR reports. Inactive prevents the customer from printing
on most reports, yet holds the account in the system for possible future reference. Hold puts the customer on
hold and warns you they are on hold if you try to use them.

Name – Type in the customer's name.

Address – This field contains 2 lines that are 30 characters per line. This address prints on reports and
invoices. Enter the customer's address.
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City - Enter the customer's city.

Tip: If you enter a valid US zip code into the "City" field and press your Tab key, ComputerEase will automatically
fill in the correct city, state and zip code.

State - Enter the customer's 2-character state postal abbreviation.

Zip - Enter the customer's zip code.

Contact – Enter the name of the billing contact at this customer.

Phone – Enter the customer's phone number.

Fax – Enter the customer's fax number.

Email – Enter the customer's email address. If you select the stamped envelope icon after information is
entered in this field ComputerEase will open a new email message to this address.

Web – Enter this customer's website address. If you select the arrow icon after information is entered in this
field ComputerEase will open an internet window to this website.

Short Notes – The notes section consists of three 30-character fields. Enter any pertinent information you
may want to keep on file for this customer.

Department – This is a required field if you are using A/R departments.

Sales Rep – Enter the sales representative that is assigned to this customer.



Other Tools12

Deltek+ComputerEase

Billing Tab

Separate Invoice Address - Check this box if the customer has an address to which to send billings that is
separate from their physical address listed on the previous tab. Once you check this field, you will have the
opportunity to enter the Address, City, State and Zip to which to send invoices.

Email Invoices - Check this box if you would like to automatically email freeform and service invoices to the
customer rather than printing them. Once you check this field, you will have the opportunity to enter an email
address to which to send invoices; the email address field will automatically populate with the email address
from the Main tab, if entered, but can be changed.

Price Code – Select the price code to apply when selling items from your inventory to this customer.

Tax Code – Enter the sales tax code you want to apply to this customer's invoices.

Tax Exempt No – Enter this customer’s tax exempt number if this customer is tax exempt.

Trade Discount – Enter the percentage by which you would like to discount each invoice that is prepared for
this customer.

Finance Discount – Enter the percentage by which you would like to discounts each invoice that is prepared
for this customer if payment is made according to the terms entered into the next field.

If Paid - Select within and enter the number of days past the invoice date for which the discount is valid or
by the and enter the day of the month that the discount will expire.

Retention - Enter a default retention percentage for this customer that will be used on all invoices.

Terms -  Enter the credit terms you want to extend to this customer. The selection made in this field will print
on invoices for this customer and be used for aging purposes.

Net - Selecting this option from the drop-down and entering a number (xx) in the second field will use a
due date xx days after the invoice date for all invoices created for this customer.

COD - Selecting this option from the drop-down will use the invoice date for the due date and print "COD"
for the terms on the customer's invoices.
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Cash - Selecting this option from the drop-down will use the invoice date for the due date and print "Cash"
for the terms on the customer's invoices.

None - Selecting this option from the drop-down will use the invoice date for the due date and no terms
will print on the customer's invoices.

Day - Selecting this option from the drop-down and entering a number (xx) in the second field will use a
due date that falls on the next xxth of the month that occurs. For xx of 10, an invoice dated 04/01 will be
due 04/10 and an invoice dated 04/11 will be due 05/10.

Credit Limit - Enter the amount of credit you are willing to extend to this customer. ComputerEase will warn
you during invoice entry when this customer’s open balance exceeds the amount entered in this field. This is
an optional field and may be left at 0.00 indicating the customer does not have a limit.

Credit Rating - Select Good or Bad to indicate this customer’s credit rating.

Freeform Format - Select the freeform invoice format you would like to use by default when preparing
freeform invoices for this customer.

Service Format – Select the service invoice format you would like to use by default when preparing service
invoices for this customer.

Print Statement - Check this box if you want to print statements for this customer when they have activity
on their account.

Past Due Notices - Check this box if you would like the customer to be included when printing past due
notices.

Service Charges - Check this box if you want to charge service charges to this customer on any late unpaid
balances.

Balance – The customer's current balance is reported here for informational purposes only.

Last Payment was…on – The customer's last payment amount and date are reported here for informational
purposes only.
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Notes Tab

The notes tab allows you to enter notes concerning this customer. These notes are for your use only and may be
viewed from displayed reports.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for customers that were setup in the
Parameters for Accounts Receivable. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Accounts Receivable Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the customer file. This tab only appears if you have created at least one customer attachment folder under 
Configure > System Parameters > Accounts Receivable Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or  Cancel to exit the screen without saving your changes.



Service Management 15

ComputerEase User Manual

1.2.5 Equipment Maintenance

If you service specific equipment at your customer sites, you may want to track that equipment in ComputerEase.

Select Service Management > Maintenance Programs > Equipment Maintenance.

Site – Choose the site for which you want to enter equipment.

Equipment – Enter a name for the equipment, up to eight alphanumeric characters, and press OK.

Main Tab

Description – Enter a description of the equipment.

Model – Enter the equipment model number, if applicable.

Serial Number – Enter the serial number(s) of the equipment, if applicable.

Quantity – Enter the quantity of this equipment at the site.

Location – Enter the physical location at the site of the equipment, if known.

Contact – Enter the name of the contact for questions regarding this equipment.

Phone – Enter the phone number to contact regarding this equipment.

Type – Enter a type to group this equipment for reporting purposes.

Install Date - Enter the date the equipment was installed, if known.

Department - If all work orders generated for this equipment are to be assigned to a department other than
the department assigned for the site, enter the department here. Otherwise, leave this field empty and work
orders generated for this equipment will be assigned to the department assigned in the site maintenance. If
you do not use Accounts Receivable departments, this field will be inactive.
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In the lower half of the screen you can enter information about services that are scheduled to be periodically
performed. Work orders are generated according to this schedule using the Generate Scheduled Work Orders
feature.

Service – Enter or choose the service to be performed.

Date – Enter the date that this service must next be performed. A work order will be generated based on this
date when the Generate Scheduled Work Orders feature is run.

Repeat Every – Enter how often this service should be repeated. A work order will be generated for each
instance. You can repeat the service every number of Days, Weeks, or Months.

Until – If this scheduled service will only be performed through a certain date, enter it here. If this service
scheduled is open-ended, leave this field empty.

Dispatch Group - Enter the optional Dispatch Group to which to assign the order generated for this service.

Person - Enter the optional service person to whom to assign the order generated for this service.

Comb. - Enter a one or two character combination code in order to combine this service with another
scheduled service onto one work order. Services must be for the same site, date, board/group, person, and
department in order to combine.

Department - If all work orders generated for this service are to be assigned to a department other than the
department assigned for the site or equipment, enter the department here. Otherwise, leave this field empty
and work orders generated for this service will be assigned to the department assigned for the equipment or
the site. If you do not use Accounts Receivable departments, this field will be inactive.

Est Time - Enter the optional estimated time that will populate on the Estimated Time field of the work order
when the service is generated.

Notes Tab

Enter any notes about this equipment here.
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User Fields Tab

The user fields tab allows you to enter information into the user defined fields for equipment that were setup in the
Parameters for Service Management. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Service Management Parameters.

Click on Save to save your entry or  Cancel to exit the screen without saving your changes.

1.2.6 Service Person Maintenance

You must have at least on service person in order to use the work order entry and billing process.

Select Service Management > Maintenance Programs > Service Person Maintenance.

Person – Enter the service person's ID number or name, up to eight alphanumeric characters, and press OK.

Main Tab

Name – Enter the service person's name.

Status - Select Active or Inactive.
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Inventory Location – Choose the inventory location from which materials used on work tickets assigned to
this person will be pulled.

Primary Group – Choose the group that this service person will be assigned to, if applicable (at least 1
group must be added to the groups tab in order to choose the primary group).

Schedule by - Choose how work orders for this person will be scheduled, either by Priority or by Time.

Employee - If you have selected to interface you service to Payroll, assign this service person to en
employee from payroll in order to post this person's time to payroll.

Tablet User - If you are using FieldEase for Tablets for Work Orders, choose the FieldEase User that
represents this service person in order to send work orders assigned to this person to them for use in
FieldEase.

FieldEase User - If you are using FieldEase for the Web for Work Orders, enter the web user ID that this
service person uses in order to send work orders assigned to this person to the web.

Labor Cost Rate - If you want to specify the labor cost rate to be used for this service person, enter it here.
This will be used to calculate profitability.

Ticket Format - Choose the format to use by default when printing work tickets for orders assigned for this
person. This format will override the work ticket format chosen for a site or a work order. This format can be
overridden at the time of printing.

Email - Enter the service person's email address. 

Phone - Enter the service person's phone number.
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Assigned Map Codes Tab

This is where you can link this service person to one or more map codes in which this person normally works. By
doing so, when you schedule a work order for which the site has a map code assigned, any service person(s)
assigned to that map code with automatically populate the assignment field.

Add - Click to add a map code. Select the map code you wish to add.

Remove - Click to remove the selected map code.
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Groups Tab

Dispatch groups are assigned to a user here. The groups assigned here allow a primary group to be assigned on
the Main tab. The Service Person will also be visible in all groups assigned here when viewing the dispatch board.

Add - Click here to add a group.

Remove - Click here to remove the selected group.
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Notes Tab

Enter any notes about this service person here.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for service people that were setup in
the Parameters for Service Management. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Service Management Parameters.

Click on Save to save your entry or  Cancel to exit the screen without saving your changes.

1.2.7 Service Instruction Maintenance

You have the ability to pre-define service instructions for services that you perform often, allowing you to save work
when creating work orders. Service instructions are also used for to create scheduled work orders that can be
periodically generated.

Select Service Management > Maintenance Programs > Service Instruction Maintenance.
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Add - Click here to add new service instructions

Description - Enter a brief description of this set of instructions.

Instructions – Enter detailed instructions for what is to be done with this service. These instructions will
print on the work order. After you have completed entering your detail, press OK.

Edit - Highlight service instructions and click here to make changes.

Find - Click here to search for service instructions if you have a long list of instructions.

Delete - Highlight service instructions and click here to delete.

When you have finished making changes, press Close to exit the screen.

1.2.8 Bill Type Maintenance

Bill types can be used to determine markup for items on work orders by item billing class. Remember that
markups are used in combination with price codes.

Select Service Management > Maintenance Programs > Bill Type Maintenance.

Bill Type - Enter a code for your bill type, up to eight alphanumeric characters, and press OK.
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Main Tab

Description - Enter a description of your bill type markup code.

Markups - You can establish step-style thresholds for your markups. In the Under field, enter the highest
value for which you want your first markup % to apply and then enter the percentage by which you want to
mark items up in the Markup % field.

Markup Labor/Markup Material/Markup Services/Markup Other - Check the box next to each item type
you want to be marked up using this bill type. The item type corresponds to the item billing class in Inventory
Item Maintenance.

Item Rates Tab

You have the option to set rates per item for a bill type. To do so, choose the item and enter the price to charge for
that item when that bill type is applied.

Once you have made your selections, press Save to save and close your changes or Cancel to exit the screen
without saving your changes.
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1.2.9 Work Order Priority Maintenance

Priority levels establish scheduling and dispatch priorities. Priorities are used in Priority-type dispatch board to
determine the order in which orders are listed for each tech and can also be used to change how a work order is
displayed.

Select Service Management > Maintenance Programs > Work Order Priority Maintenance.

New - Click here to add a new priority level to the list.

Name - Enter a description of the priority code.

Box Color - Check the box to color the entire work order box.

Default Text Color - If you chose to color the priority code text, choose the color to use here.

Field Background Color - If you chose to color the priority code field, choose the color to use here.

Field Text Color - If you chose to color the text of the priority code field choose the color to use here.

Tip: A sample of what the priority code box color/text and priority code field background/text will look like on the
dispatch board is shown to the right of each option.

Once you have made your selections, press OK to save and close your priority level or Cancel to exit the screen
without saving your changes.

Edit - Highlight a priority and click here to make changes to it.

Delete - Highlight a priority and click here to delete it.

Higher - Highlight a priority and click here to move it higher on the list. Work orders will be sorted on Priority-
style dispatch boards based on the position of the priority assigned to it.
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Lower - Highlight a priority and click here to move it lower on the list. Work orders will be sorted on Priority-
style dispatch boards based on the position of the priority assigned to it.

Once you have made your selections, press Save to save and close your changes or Cancel to exit the screen
without saving your changes.

1.2.10 Sales Rep Maintenance

Sales reps may be created from either the Accounts Receivable module or from Service Management. Entries into
either location are stored in the same place.

Sales Reps may be set up to track sales for performance-based pay or reviews.

Select Service Management > Maintenance Programs > Sales Rep Maintenance.

Sales Rep - Enter or choose a sales rep code and click OK to create or edit.

Main Tab

Name – Type in the sales rep's name.

Address – This field contains 2 lines that are 30 characters per line. Enter the sales rep's address.

City - Enter the sales rep's city.

Tip: If you enter a valid US zip code into the "City" field and press your Tab key, ComputerEase will automatically
fill in the correct city, state and zip code.

State - Enter the sales rep's 2-character state postal abbreviation.

Zip - Enter the sales rep's zip code.

Phone – Enter the sales rep's phone number.

Fax – Enter the sales rep's fax number.

Email – Enter the sales rep's email address. If you select the stamped envelope icon after information is
entered in this field ComputerEase will open a new email message to this address.
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Employee - For informational purposes only, choose the employee ID for this sales rep.

Notes Tab

The notes tab allows you to enter notes concerning this sales rep. These notes are for your use only.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for sales reps that were setup in the
Parameters for Accounts Receivable. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Accounts Receivable Parameters.
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1.2.11 Warranty Type Maintenance

You must define the types of warranties you offer before setting up any site-specific warranties you want to track.

Select Service Management > Maintenance Programs > Warranty Type Maintenance.

Warranty Type – Enter a name for your warranty type, up to eight alphanumeric characters.

Description – Enter a description of this warranty type.

Duration – Enter the length of time for which the warranty is good in days.

Coverage % – Enter the percentage of coverage offered by this warranty; this will display on your warranty
report to assist you in billing.

Notes - Enter any notes about this warranty type, such as inclusions or exclusions.

Once you have made your selections, press OK to save and close your warranty type or Cancel to exit the screen
without saving your changes.
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1.2.12 Warranty Maintenance

The actual warranties that apply to each site and/or equipment are entered and tracked under Warranty
Maintenance.

Select Service Management > Maintenance Programs > Warranty Maintenance.

Warranty – Enter a name or number for your warranty, up to eight alphanumeric characters.

Description – Enter a description of this specific warranty.

Type – Choose the warranty type; remember that the duration is determined by the type.

Site – Choose the site covered by this warranty.

Equipment – Choose the equipment covered by this warranty, if applicable.

Effective Date – Enter the starting date of the warranty. The expiration date of the warranty will be calculated
by ComputerEase using this and the duration of the warranty type.

Notes - Enter any notes about this specific warranty.

Once you have made your selections, press OK to save and close your warranty or Cancel to exit the screen
without saving your changes.

1.2.13 Dispatch Group Maintenance

You have the ability in ComputerEase to have more than one Dispatch board if you have different locations or
departments.

Select Service Management > Maintenance Programs > Dispatch Group Maintenance.
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Group - Select an existing group to modify or type in an 8 digit alphanumeric code to create a new group and
click OK. When prompted, click Yes or No to create the new group.

ID - The code will be listed here and is editable.

Description - Enter a description of the dispatch group.

Style - Choose Priority if orders on this board are to be scheduled and sorted by priority for each service
person. Choose Time if orders on this board are to be scheduled by time slot for each service person. The
next four entries are only applicable to Time style boards.

Intervals - Choose the length of time you would like between displayed time slots. If you enter 30
minutes here, you will see time slots defined on your board for every hour and half hour. You can
choose intervals ranging from 5 to 30 minutes.

Start Time - Enter the time when the first order of the day can be scheduled.

End Time - Enter the time when the last order of the day can be scheduled.

Default Length - Enter the default length of time orders will be scheduled for if no estimated time
entry is made on the order.

Order Sequence - If you are using multiple order numbering sequences, choose the default order
numbering sequence to use for orders created from this board.

Edit - Highlight a board and click here to make changes to it.

Delete - Highlight a board and click here to delete it.

Once you have made your selections, press Close exit the screen.
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1.2.14 Off Time Maintenance

You have the ability to set days or time slots as "Off Time" either for a Person, for a Group or for Everybody.

Select Service Management > Maintenance Programs > Off Time Maintenance. To set off time for just one
person, select for a Person and choose the person for whom you want to set off time; to set off time for everyone
assigned to a group, select for a Group and choose the group for which you want to set off time; to set off time for
all techs and groups, select for Everybody.

Add - Click here to add an off time entry.

Unavailable/Available - Check the box if this entry is to be used to make a tech or board unavailable or
available.

Date - If the time entry you are making is for a date, enter that date here.

Recurring - Checking this box if the date selected will be marked off every year (such as a holiday).

Day(s) - If the time entry you are making is for a recurring day of the week, choose that day here. This
entry will set the off time for Every (day).

All Day - If the entire day is to be set to off time, choose this option.

Times - If only a portion of the day is to be set to off time, enter the time range here.

Reason - Enter a reason the time is being blocked out (optional).

Edit - Highlight an off time entry and click here to make changes to it.

Delete - Highlight an off time entry and click here to delete it.

Once you have made your selections, press OK to save and close your entry or Cancel to exit the screen without
saving your changes.
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1.2.15 Order Number Sequence Maintenance

You may want to use different order numbering sequences for different types of orders or for different departments.

Select Service Management > Maintenance Programs > Order Number Sequence Maintenance.

Sequence - Enter the sequence name, up to eight alphanumeric characters. The default numbering
sequence (AUTO) is already created.

Description - Enter a description for this order numbering sequence to help you identify when it is to be
used.

Type - Choose Automatic to indicate that ComputerEase should number work orders assigned to this
sequence automatically or Manual to indicate that you want to manually number work orders assigned to this
sequence.

Next Number - Enter the next number to use for Automatic sequences.

Set as default sequence - Check this box to make this the default sequence that will be used for orders if a
default sequence is not set per dispatch board. There can be only one default sequence.

Once you have made your selections, press OK to save and close your entry or Cancel to exit the screen without
saving your changes.
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1.2.16 Map Code Maintenance

Map codes are used to change the appearance of work orders on the dispatch board to assist you with route
planning. Knowing that work orders with the same appearance are in the same service area can help you when
scheduling and planning routes for your techs for the day.

Select Service Management > Maintenance Programs > Map Code Maintenance.

Map Code - Enter a map code up to ten alphanumeric characters and press OK. 

Description - Enter a description of this map code service area.

Box Color - Check this box if you want to color the map code box (only used on Standard Dispatch Board).

Field Background Color - Check this box if you want to color the background of the map code field.

Field Text Color - Check this box if you want to color the text of the map code field.

Once you have made your selections, press OK to save and close your new map code or Cancel to exit the
screen without saving your changes.

1.2.17 FieldEase Items

There are several items under the service management module that are for use strictly with FieldEase. If you use
FieldEase for work orders, these optional items can assist your service techs when completing work orders in the
field.

1.2.17.1 Using FieldEase Work Order Descriptions

You have the ability to pre-define work order descriptions for services that you perform often, allowing your service
techs in the field to save work when completing work tickets. These predefined work descriptions can easily be
added to the work ticket resolution field as the service person completes the ticket.

Select Service Management > Maintenance Programs > FieldEase Work Order Descriptions.

Description/Index - Enter a brief description of this work order description and select OK to create.
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Long Description - Enter the text that will print out for the work order resolution when this description is
used. 

When you are finished, press OK to save.

1.2.17.2 Service Group Maintenance

Service groups allow you to create a group of service codes to address when completing work orders and specify
whether addressing those codes is required and/or whether they are equipment-specific.
Select Service Management > Maintenance Programs > Service Group Maintenance.

Group - Enter a group ID for the service group you want to create and press OK.

Description - Enter a description for the service group.

Sequence - If you want your groups to be ordered other than in alphanumeric order by Group ID on work
orders, use the sequence number to do so. Service groups will be ordered in sequence number order if this
field is used.

Required Entry - Check this box if service codes in this group are required entries when completing work
orders. Only orders marked "PM Only" in the field will allow completion of the work order without addressing
service codes in a required group.

Equipment Specific - Check this box if service codes in this group are equipment-specific.

Once you have made your selections, press Save to save and close your new service group or Cancel to exit the
screen without saving your changes.

1.2.17.3 Service Code Maintenance

Service codes are different service action items that can be used by service people in the field when completing
work orders. They can be used as reminders so that your service techs never leave a site without completing
certain action items.
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Select Service Management > Maintenance Programs > Service Code Maintenance.

Code - Enter a code ID for the service code you want to create and press OK.

Description - Enter a description of this service code.

Multi Group - Check this box if this service code belongs to multiple groups; then choose the groups it
belongs to under the Groups button.

Group - If this service group belongs to only one group, choose that group here.

Sequence - If you want your service codes to be listed other than in alphanumeric order by Code ID in
service group lists, use the sequence number to do so. Service codes will be ordered in sequence number
order if this field is used.

Default Entry - This item is for future use.

Entry Required - Check this box if the service person is required to make an entry for this service item when
completing service logs.

Quantity Required - Check this box if a quantity is required for this item when completing service logs.

Type - Choose the type of code: Labor, Material, Other, Data or Checkbox. 

Once you have made your selections, press Save to save and close your new service code or Cancel to exit the
screen without saving your changes.

1.2.17.4 Work Ticket Status Code Maintenance

Work Ticket Status codes allow your service people to update the status of a work ticket in live
time if they are using the FieldEase Work Order module. There are four pre-defined statuses, and
you can create your own user-defined statuses to meet your specific needs. When your service
people change the status of a work ticket using FieldEase in conjunction with the ComputerEase
Live Service, you can see the status of the ticket update in real time on the dispatch board in the
office. For more information about FieldEase and the ComputerEase Live Services, contact your
dealer.
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Select Service Management > Maintenance Programs > FieldEase Status Code Maintenance.

Code - Enter a field status code up to two alphanumeric characters and press OK.

Description - Enter a description of this field status code.

Box Color - If you chose to color the box (only used on Standard Dispatch Board), choose the color here.

Field Background Color - If you chose to color the field status code background, choose the color to use
here.

Field Text Color - If you chose to color the field status code text, choose the color to use here.

Once you have made your selections, press OK to save and close your new field status code or Cancel to exit
the screen without saving your changes.
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1.3 How Do I Use Work Orders in ComputerEase?

1.3.1 Search Center

The Search Center allows you to view and organize work orders in one central location.  When work orders are
imported from FieldEase, they are accessible here.

Select Service Management > Search Center.

 New Search - Click to start a new search.

 Save Search- Click to save the current search. Once a search is saved it will be available in the Saved
Searches dropdown list.

 Save Search As - Click to save the current search and be prompted to enter a new Search Name.

 Delete Search - Click to delete a saved search. When a search is deleted it will be removed from the
Saved Searches dropdown list.

 Export Results - Click to export the current search results to an Excel spreadsheet. You will be prompted
for a file name and location.

 Choose Columns - Click to select which columns display in the Search Center. You can set columns for
each individual search or you can set your default columns using this option. You can also select your
preferred Date Format. 
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 Advanced Search Filters - Click to select additional search options.

Print - Click to print the selected purchase order.

1.3.2 Creating Work Orders

1.3.2.1 Create a Work Order

When you receive the initial order request from the customer, you can create your work order from the main menu under Enter a Work Order or from within the dispatch board. The work order is tracked in the system from the initial service call through printing the customer invoice. A work order may have more than one work ticket attached to it in the event that more than one service person and/or more than one service call is required to complete the work. 
Select Service Management > Enter a Work Order.
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Main Tab

Sequence - Choose the order numbering sequence to use to assign this work order number, if using more
than one numbering sequence.

Site - Choose the site at which work will be performed.

 Quick Customer/Site Creation - Create a customer/site on the fly. Fields not available on the quick
creation screens can be accessed through customer and site maintenance.
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Customer - If the Can override option is activated in Site Maintenance, the Customer field will activate and the
Customer can be changed for this work order. Changing the customer at the work order level will not override
the default customer listed in Site Maintenance.

Cost Code - Enter the cost code where this order's billings will be posted, if applicable.

P.O. Number - Enter the customer's purchase order number, if applicable.

Ordered By - Enter the name of the person who placed the call.

Description – Enter a description of the work to be performed. If you have predefined services, press F2 and
select a service. The service description will be inserted here.

Date/Time Requested – Choose the date and time (if applicable) that the person placing the order requested
that work be performed. You can check the ASAP box to indicate that it was requested as soon as possible.

Date/Time Promised – Choose the date and time (if applicable) that a visit was promised. You can also
check the ASAP box to indicate that the person was promised a visit as soon as possible.

Promised By - This populates with the name of the person who entered the order but can be changed if
necessary.

Priority - Choose the priority level of the call if necessary. If your dispatch board is a Priority-style board, this
can be used to sort orders for each service person.

Estimated Time – Enter an estimate of how much time the order should take, if applicable.

Department - If using A/R departments, this is the department to which the invoice will be billed.

Dispatch Group - Choose the dispatch group to assign the order to, if known.

Tax Code – Choose the sales tax code that will apply to the invoice for this order.

Sales Account - Choose the revenue account to credit with the revenue from this order if it is other than the
default.

Labor/Other Price Code – Choose the labor and other prices codes to apply to this order, if you want to
override the price levels set for the site.

Bill Type - Choose the bill type to apply to this order, if you want to override the bill type set for the site.

Sales Rep – Choose the sales rep to credit with this order, if applicable.

Ticket Format -  If you want to use a different printing format when you print work tickets for this order than
the default based on the order's site, choose it here.

Order Received – Enter the date the order was received; this defaults to the log-in date.

Order Received at – Enter the time the order was received; this defaults to the current system time.

Site Information Section

This section displays the site name, address, phone number, email address, map code, work order notes,
site notes and site attachments.

Customer Information Section
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This section displays the customer number, name, address, phone number, balance, credit limit, last
payment, customer notes and customer attachments.

FieldEase Customer Hardcopy - Choose to print or not print labor/material.

Tip: You can copy the notes from a Quote into either the Description field or onto the Notes tab of a work order;
to do so, place your cursor into the field into which you want to copy the notes and choose Order, then Insert
notes from Quote. This option is only active when you cursor is in one of those two fields.

Equipment Tab

The equipment tab is where you will assign equipment to the work order. If the work order is a generated work
order, equipment will automatically be assigned.

Equipment - Enter or choose the site equipment to be service with this work order. You can enter additional
equipment in the rows below after you enter your first equipment row.

Description - The equipment description will populate here for your reference.

Instructions - Enter instructions for this equipment.
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Notes Tab

Enter any site notes here. These may optionally be printed on work orders and can be viewed when creating work
orders.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for sites that were setup in the
Parameters for Service Management. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Service Management Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the work order file. This tab only appears if you have created at least one work order attachment folder under 
Configure > System Parameters > Service Management Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

As you enter a work order, you may need to review relevant reports to accurately assess and schedule the order.
In the upper left corner of the work order entry screen, click on Reports to gain access to the following reports:

· Customer Receivables Inquiry

· Aged Trial Balance

· Site History Report

· Equipment History Report

· Contract Master List
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· Equipment Master List

· Unscheduled Work Order List

· Open Work Tickets

· Work Order List

· Warranty Report by Site

· Completed Work Order Report

Tip: If you need to quickly set up a new customer and/or site, select Order in the upper left corner, then Quick
Entry. This will take you to the Customer Maintenance screen; after either adding a customer or selecting an
existing one you will immediately be take to the Site Maintenance screen to create the site. This option
consolidates multiple steps and allows you to quickly enter new information.

You have six additional options under Order in the upper left corner.

Insert Notes from Quote - When your cursor is either in the Description section or in the Notes tab, you can
insert notes from a quote.

Site Notes – Select this option to view and/or edit site notes.

Site Map – If you internet access you can select this option to open your internet browser to a map of the
site address (using Yahoo! maps by default or Bing or Google maps as an alternative).

Create PO - Select this option to create a PO associated with this work order on the fly.

Edit PO - Select this option to edit a PO on the fly.

Delete this Work Order – If you need to delete a work order, select this option.

Once the information has been entered and saved an additional screen will prompt you to schedule the work order.
It is not required that the work order be scheduled at this time. The work order can be scheduled from the dispatch
board, by editing the work order or by using the Schedule a Work Order menu option.

The top of the screen will show the Work Order number that has been assigned.
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Person – Choose the service person to whom the order will be assigned. If more than one person is required,
enter one per row.

Date – Choose the date that the order will be assigned to for this tech. If more than one visit will be required,
enter one per row.

Depending on your settings, you may be prompted to print work ticket(s) at this time. You can print your ticket(s)
at a later date if you select No here.

1.3.2.2 Editing Work Orders

You can make changes to any open work order. Note that work orders can be edited from the main Service
Management menu or from the dispatch board.

Select Service Management > Edit a Work Order.

Work Order – Choose the work order you want to edit and press OK.

If the order is not open you will see a warning and will not be able to edit the order. If the order is open, only the
work order number and order received date and time cannot be changed.
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1.3.2.3 Generating Scheduled Work Orders

If you have assigned scheduled services for your site equipment, the work orders for those scheduled services are
generated using the Generate a Scheduled Work Order feature. You may want to review your Scheduled Services
report to see what orders will be generated when you run this feature.

Select Service Management > Generate Scheduled Work Orders.

Generate Work Orders for services due by - Enter the date through which you want to create work orders
for services due.

Groups - Choose whether to generate orders for all groups or for just one group. If you choose to generate
orders for one group, you will need to select the group for which you want to generate orders.

People - Choose whether to generate orders for all techs or for just one tech. If you choose to generate
orders for one tech, you will need to select the tech for whom you want to generate orders.

Order Sequence - Choose the order numbering sequence to use, if applicable, when numbering the orders
to be generated.

A message will tell you how many orders were generated.

1.3.3 Scheduling Work Orders

1.3.3.1 Using the Standard Dispatch Board

The Standard Dispatch Board is a user interface that allows the user to manage work order by time
or priority on the same board. The Standard Dispatch Board is activated through Configure >
Configure User.

Select Service Management > Dispatch Boards.

Dispatch Board Views

The Daily and Weekly Views displays techs on the left with time slots at the top. 
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To change the displayed day, simply click the date you wish to display on the calendar in the
upper left portion of the screen. In weekly view the entire week will be highlighted on the calendar
and you can scroll through the week.

Tickets can be assigned to a tech and dropped into the unscheduled for a tech column (see
screenshot below) or into a time slot for a tech.

The unscheduled for a tech column will not actually display a work ticket, it will display a number representing the
number of work tickets assigned to that tech for the day that aren't in a time slot.
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Clicking on the number will display those tickets in the Unscheduled column on the far right. The "Unscheduled"
header will change to "Unscheduled for (Tech Name)." To turn the column back into an unscheduled list of work
orders not assigned to any tech simply click the X.

The Unscheduled column can be sorted by right clicking on the Unscheduled tile, selecting Sort and then
choosing the desired sort order. The Default order is Priority/Group/Work Order. To change the sort, select the
desired sort field. Subsequent selections will retain previous order. For example, if a user wanted to sort by
Priority/Map Code/Group they would first select Group, then Map Code and then Priority. Work Order is a unique
number so it will always be the final sort parameter.
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The time slot bar can be set to different intervals by right clicking on the time bar and choosing
the desired interval. The interval you select will effect the range of time you can see on the
screen without scrolling.

The availability bar shows if a particular day and time slot has availability or is completely
scheduled. If there's any availability, the bar will be gray. If completely scheduled the bar will be
blue.

The two small boxes on the left side of the ticket identify the map code (top box) and work ticket status code
(bottom box). To update the work ticket status code from the board, right click on the work ticket you wish to
update and select the new status from the Change Ticket Status option.

The All Scheduled View shows all tickets scheduled for selected techs. The left side of the board
is sorted by date (oldest to newest from top down).
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The Priority View shows techs on the top with tickets assigned to that tech sorted by priority.
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Dispatch Board Shortcuts

  Click here to create a new work order. Also available through File/New Work Order.

 Click here to open the Search Center. Also available through File/Search Center.

 Click here to access the Daily View on the dispatch board. Also available through View/Daily View.

 Click here to access the Weekly View on the dispatch board. Also available through View/Weekly View.

 Click here to access the All Scheduled View. Also available through View/All Scheduled.

 Click here to access the Priority View. Also available through View/Priority View.

 Click here to open a map of the site address in your Internet Browser. By default, ComputerEase will open
the map in Google Maps.

Configuring Work Order Layout

How work orders appear in the dispatch board (what information you see and how large the boxes can be) depends
on how your have configured your layout.

To configure your layout, select File in the upper left corner, then Configure/Layouts.
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New - Click here to create a new layout. You will need to name your layout; when you press Enter you will
have the opportunity to design your layout.

To the left are the fields available to view. To add items to your layout so that you will see them in the work order
box, simply drag and drop them into the grid to the right. The grid can be resized if necessary. There is additionally
a field called (text) that can be used as often as you want; it allows you to enter your own headings and labels in
the layout.

Once you have designed your layout, select File then Save.

Edit - Click here to edit a selected layout.

Copy - Click here to create a new layout and begin with a copy of the selected layout.

Delete - Click her to delete a selected layout.

You can have as many layouts as you want, but you must define which layout you want to use for unscheduled
items, which layout you want to use for scheduled items and which layout you want to use when you hover your
mouse over scheduled items.

Unscheduled Items - Choose the layout to use for unscheduled orders.

Scheduled Items - Choose the layout to use for scheduled orders.

Sched. Items (Hover) - Choose the layout you want to use when you hover the mouse over scheduled
orders.

Working With Work Orders in the Dispatch Board

When orders are created and not immediately scheduled, they will appear in the Unscheduled column to the right
on the dispatch board. To schedule an order, you can drag and drop the order to the column under the tech for
whom the order is scheduled. If the ticket must be split to several work tickets, hold down the Ctrl key on your
keyboard and drag the order under additional service people or dates. You can unschedule a work order by simply
dragging it back to the Unscheduled column.
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You can double-click on any work order to edit it. Or you can select an order right-click and choose Edit Work
Order or even select File in the upper left corner of the dispatch board and then Edit Work Order. 

Likewise, you can view or edit Work Order Notes, Print a Work Order, Print a Work Ticket (for a scheduled order
only), Enter Work (also only for a scheduled order) or even Schedule and Unschedule Work Orders by either right-
clicking on a selected work order and selecting the appropriate menu option of by selecting File in the upper left
corner of the dispatch board followed by the appropriate option. 

To find a Work Order on the board select File in the upper left corner and select Find Work Order. When
prompted select the work order you are trying to find and you'll be taken to that work order on the board.

The dispatch board will remember settings per user. When you close the dispatch board after you have set the
display settings how you want them, the next time you open the dispatch board it will open using those settings.
Keep in mind that these settings are per user, so each person who uses the dispatch board can customize its
display for himself or herself.

1.3.3.1.1  My Dispatch Boards

This option allows you to configure one or more dispatch boards that you can set to automatically open into the
monitor of your choice when you select "Dispatch Boards" each day.

Select Service Management > My Dispatch Boards.

Open Board - Highlight a board and click here or double-click a board to open a dispatch board.

New Board - Click here to create a new dispatch board.

Edit - Highlight a board and click here to edit a board.

Name - Enter the name for your board; this can be your name, the location, or anything to identify it to
you.

Auto-Open - Check this box if you want this board to automatically open when you select "Dispatch
Boards" from the Service Management menu.

Auto-Save - Check this box if you want this board to automatically save its settings when you close it.
This includes which monitor it was last opened in when you work working with it.

Work Week - Choose the From and To days of the week that will display on the Dispatch Board.
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Delete - Highlight a board and click here to delete a board. You must have at least one board, so this option
is only active if you have two or more boards.

1.3.3.2 Using the Classic Dispatch Board

The Classic Dispatch Board, is a user interface that allows you to schedule your orders in a
calendar-like display. Many of the actions that can be performed from the main menu of the
Service Management module, from creating and editing work orders to scheduling work orders to
billing for work completed, can be performed using the dispatch board.

Select Service Management > Dispatch Boards.

There are two types of dispatch boards: priority style and time style. You may only have one dispatch board or you
may have several; if you use more than one for any reason, one or more may be priority-based while another might
be time-based or you may use the same style for all. Flexibility is the key to the dispatch board's user-friendly
capabilities.

A time-based board allows you to schedule work orders by time slot, allowing you to plan out your service persons'
day and see at a glance where they should be at any given time. A sample time-based board:

A priority-based board allows you to schedule work orders by person, with the option of using priorities to sort and
order your work orders for each person. A sample priority based-board:
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Dispatch Board Shortcuts

Regardless of which version of the classic dispatch board you are using, there are certain features which are
universal. In the toolbar at the top of the board are certain options.

From left to right, these icons are shortcuts that perform the following actions:

 - Click here to create a new work order. Refer to Create a Work Order  for instructions on completing
a new work order. You can also select File in the upper left corner, then New Work Order to create a new
work order.

 - Click here to mark a selected work order finished. This does not bill the work order, it is simply to let
you know the order is finished. You can also select File in the upper left corner, then Mark as Finished to
do this or select a work order and right-click and choose Mark as Finished.

 - Click here to mark a selected work order canceled. This does not delete, void or close a work order, it
is simply to let you know the order is no longer wanted. You can also select File in the upper left corner,
then Mark as Canceled to do this or select a work order and right-click and choose Mark as Canceled.

 - Click here to mark a selected work order as having a service person on site. You can also select File
in the upper left corner, then Mark as On Site to do this or select a work order and right-click and choose
Mark as On Site.

 - Click here to mark a selected work order as having a service person en route. You can also select File
in the upper left corner, then Mark as En Route to do this or select a work order and right-click and choose
Mark as En Route.

37
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 - Click here to choose a different service board.

 - Click here to select a different tech.

 - Click here to change the date currently being displayed.

 - Click here to view all techs for one day. You can also select View in the upper left corner, then All
Techs for one Day to do this.

 - Click here to view one week for a tech. If you want to view all techs for one week, change the tech
drop-down to choose to display all time or priority techs. You can also select View in the upper left corner,
then One Week for a Tech to do this or select a work order assigned to a service person and choose View
week for (tech name).

 - Click here to view all days with an order scheduled for one service person. You can also select View
in the upper left corner, then All Scheduled for a Tech to do this or select a work order assigned to a
service person and choose View all scheduled for (tech name).

 - Click here if you have internet access to open your internet browser and display a map of the site
address. By default, this option will use Yahoo! maps; in order to use either Google maps or Bing maps, use
the command line option "mapserver=google" or "mapserver=bing", respectively.

 - Click here to view a bar graph with details from scheduled orders.

 - Click here to toggle completed orders on or off. You can also select View in the upper left corner,
then View Finished Tickets to do this.

 - Click here to toggle canceled orders on or off. You can also select View in the upper left corner, then
View Canceled Tickets to do this.

 - Click here to toggle open orders on or off. You can also select View in the upper left corner, then
View Open Tickets to do this.

 - Click here to toggle empty columns on or off. You can also select View in the upper left corner, then
Show Empty Columns to do this.

 - Click here to toggle unavailable columns (based on off time entries) on or off. Note that unavailable
columns will have a grid pattern through them, signalling that they should not be scheduled. You can also
select View in the upper left corner, then Show Unavailable Columns to do this.

Configuring Work Order Layout

How work orders appear in the dispatch board (what information you see and how large the boxes can be) depends
on how your have configured your layout.
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To configure your layout, select File in the upper left corner, then Configure.

New - Click here to create a new layout. You will need to name your layout; when you press Enter you will
have the opportunity to design your layout.

To the left are the fields available to view. To add items to your layout so that you will see them in the work order
box, simply drag and drop them into the grid to the right. The grid can be resized if necessary. There is additionally
a field called (text) that can be used as often as you want; it allows you to enter your own headings and labels in
the layout.

Once you have designed your layout, select File then Save.

Edit - Click here to edit a selected layout.

Copy - Click here to create a new layout and begin with a copy of the selected layout.

Delete - Click her to delete a selected layout.

You can have as many layouts as you want, but you must define which layout you want to use for unscheduled
items, which layout you want to use for scheduled items and which layout you want to use when you hover your
mouse over scheduled items.

Unscheduled Items - Choose the layout to use for unscheduled orders.

Scheduled Items - Choose the layout to use for scheduled orders.

Sched. Items (Hover) - Choose the layout you want to use when you hover the mouse over scheduled
orders.
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Working With Work Orders in the Dispatch Board

When orders are created and not immediately scheduled, they will appear in the Unscheduled column to the left
on the dispatch board. To schedule an order, you can drag and drop the order to the column under the tech for
whom the order is scheduled. If the ticket must be split to several work tickets, hold down the Ctrl key on your
keyboard and drag the order under additional service people or dates. You can unschedule a work order by simply
dragging it back to the Unscheduled column.

When you schedule orders in a priority-based board, you will see beneath each tech's name for each date an entry
showing how many hours that tech is scheduled for that day. This is based on the estimated time entry in the
work order entry screen. If you are scheduling orders on a time-based board, the order will be sized to span a time
slot fitting that estimate.

You can double-click on any work order to edit it. Or you can select an order right-click and choose Edit Work
Order or even select File in the upper left corner of the dispatch board and then Edit Work Order. 

Likewise, you can view or edit Work Order Notes, Print a Work Order, Print a Work Ticket (for a scheduled order
only), Enter Work (also only for a scheduled order) or even Schedule and Unschedule Work Orders by either right-
clicking on a selected work order and selecting the appropriate menu option of by selecting File in the upper left
corner of the dispatch board followed by the appropriate option.

The dispatch board will remember settings per user. When you close the dispatch board after you have set the
display settings how you want them, the next time you open the dispatch board it will open using those settings.
Keep in mind that these settings are per user, so each person who uses the dispatch board can customize its
display for himself or herself.

1.3.3.2.1  My Schedule Boards_2

This option allows you to configure one or more schedule boards that you can set to automatically open into the
monitor of your choice when you select "Schedule Board" each day.

Select Service Management > My Schedule Boards.

Open Board - Highlight a board and click here or double-click a board to open a schedule board.

New Board - Click here to create a new schedule board.

Edit - Highlight a board and click here to edit a board.

Name - Enter the name for your board; this can be your name, the location, or anything to identify it to
you.
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Auto-Open - Check this box if you want this board to automatically open when you select "Schedule
Board" from the Service Management menu.

Auto-Save - Check this box if you want this board to automatically save its settings when you close it.
This includes which monitor it was last opened in when you work working with it.

Delete - Highlight a board and click here to delete a board. You must have at least one board, so this option
is only active if you have two or more boards.

1.3.3.3 Scheduling Work Orders

Work orders can also be scheduled using the Schedule a Work Order menu option.

Select Service Management > Schedule a Work Order.

Work Order - Choose the work order you want to schedule and press OK.

Person – Choose the service person to whom the order will be assigned. If more than one person is required,
enter one per row.

Date – Choose the date that the order will be assigned to for this tech. If more than one visit will be required,
enter one per row.

Depending on your settings, you may be prompted to print work ticket(s) at this time. You can print your ticket(s)
at a later date if you select No here.
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1.3.3.4 Rescheduling Unfinished Tickets

If at the end of the day you have several work tickets for which work was not performed, you have the option to
reschedule all unfinished work tickets to another day so that you do not have to individually rescheduled each
ticket to another day. Only tickets for which work has not been entered and which have not been marked
completed will be moved. This option is only available if you have selected it in your user settings.

Select Service Management > Reschedule Unfinished Tickets.

Move unfinished tickets from - This defaults to your log-in date but may be changed if necessary.

To - This defaults to the following day but may be changed if necessary.

When you press OK you will be prompted to confirm the rescheduling. The confirmation will tell you how many
tickets are being moved and give you a chance to review the date to which you are rescheduling them.

1.3.3.5 Printing a Work Ticket

Work tickets might be printed when orders are scheduled, depending on your selection in the Service Management
Parameters. If you need to print a work ticket after this time, you can do so from the main Service Management
menu or from the dispatch board.

Select Service Management > Print Work Tickets.

Work Order...To - Choose an order or range of orders for which to print work tickets or leave blank for all that
meet other specifications.

New or All Tickets – Choose New to only print tickets that have not been previously printed or All to print all
tickets that meet other chosen specifications.

Person...To – Choose a service person or persons for whom to print work tickets or leave blank for all that
meet other specifications.

Schedule Date...To – Choose a scheduled order date for which to print tickets or leave blank to print all that
meet other specifications.

Send To - Select Display, Printer, Email or Clipboard depending on what you would like to do with this
report. If you are printing the report, select the appropriate printer in the next field. Click OK and the report will
print, display, create a PDF file on the clipboard or generate an email depending on your choice in this field.
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Format - If you want to use a different printing format than the default format for that ticket (based on site,
work order or tech), choose the printing format you would like to use here.

1.3.3.6 Assigning Equipment to a Work Ticket

When site equipment can be assigned to a work order, that assignment is passed to each work ticket assignment
for that work order. However, you can also assign site equipment by work ticket rather than to the entire work
order. There are three ways to assign equipment to a work ticket once it has been assigned:

· Right-click on the work ticket in the schedule board and choose View/Edit Equipment; this will bring up
the equipment entry screen

· Right-click on the work ticket in the schedule board and choose Schedule Work Order, then select the
row to which you would like to assign the equipment and click on the Equipment button

· From the Service Management menu, choose Schedule Work Order, then select the row to which you
would like to assign the equipment and click on the Equipment button

Equipment - Enter or choose the site equipment to be service with this work ticket. You can enter additional
equipment in the rows below after you enter your first equipment row.

Description - The equipment description will populate here for your reference.

Instructions - Enter instructions for this equipment.
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1.3.4 Exporting Work Tickets to FieldEase

If you have FieldEase, you will need to export work tickets to your techs once they are scheduled. This can be
done directly from the schedule board on an individual basis or in bulk.

In order to export a work ticket to a tech, the tech to whom the ticket is assigned must be configured for FieldEase
use. Enter the FieldEase User in Service Person Maintenance.

To export a work ticket from the schedule board, right click on the work ticket on the schedule board and choose 
Export to FieldEase. As long as the ticket is assigned to a tech who is set to receive orders in FieldEase, the
order will export automatically.

To export work tickets in bulk, select Service Management > Export Work Orders to FieldEase.

Service Person - Enter a service person to filter work orders/tickets by service person or leave blank for all.

Work Order - Enter a work order number to filter work orders/tickets by order or leave blank for all.

Customer - Enter a customer to filter work orders/tickets by customer or leave blank for all.

Site - Enter a site to filter work orders/tickets by site or leave blank for all.

Department - Enter a department to filter work orders/tickets by department or leave blank for all.

From Date... To Date - Enter a date range to filter work orders/tickets by date or leave blank for all.

Show Sent - Check this box to show work tickets marked sent.

Show Returned - Check this box to show work tickets marked returned.

Send Site Attachments - Check this box to send site attachments in the "ToFieldEase" folder with your
work tickets. This box defaults to checked or unchecked depending on your selections in your parameters.

Send W/O Attachments - Check this box to send work order attachments in the "ToFieldEase" folder with
your work tickets. This box defaults to checked or unchecked depending on your selections in your
parameters.

Once you have made any changes above, click Reload to reload the screen with work orders/tickets meeting the
selected criteria. Use the Select All button to select all work orders/tickets or Select None to deselect all and
individually select orders/tickets to export. When you are ready to export your tickets to FieldEase, click the 
Send button.
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1.3.5 Completing Work Orders

1.3.5.1 Entering Work from a Work Ticket

Enter Work from a Work Ticket is the menu selection used to complete your billing for work orders. A work ticket
must be assigned to a service person prior entering the billing. All work, including the service person's resolution,
must be entered here.

Select Service Management > Enter Work from a Work Ticket.

Work Order  – Choose the work order for which you want to enter work completed.

Work Order - The work order number is displayed here. If you need to edit it, press the Edit button.

Site - The site for the work order is listed here. If you need to change it, you must edit the work order.

Department - Depending on your selections in the Service Management Parameters, you may have the
option to change the department for the invoice here.

Labor Price - Depending on your selections in the Service Management Parameters, you may have the
option to change the labor price level for the invoice here. The new code will only apply to work that has not
yet been entered.

Other Price - Depending on your selections in the Service Management Parameters, you may have the
option to change the other price level for the invoice here. The new code will only apply to work that has not
yet been entered.

Bill Type - Depending on your selections in the Service Management Parameters, you may have the option
to change the sales tax code for the invoice here. The new code will only apply to work that has not yet been
entered.

Discount % - Depending on your selections in the Service Management Parameters, you may have the option
to change the discount % for the invoice here. The new bill type will only apply to work that has not yet been
entered.

Sales Tax - Depending on your selections in the Service Management Parameters, you may have the option
to change the sales tax code for the invoice here.
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Once you have made your selections, choose the ticket for which you want to enter work. If you only scheduled
one ticket, only one will be listed here. If you scheduled tickets for more than one service person and/or day, each
ticket will be listed here. You must complete the work entry process for each ticket, even if you will not be entering
charges for one.

Ticket Information Tab

Work Order - The work order number and site name is displayed here for your information.

Service Person - The service person is displayed here for your information and cannot be changed here.

Ticket Number - If you have not selected the option to allow ComputerEase to assign ticket numbers, enter
the work ticket number here.

Inventory Location – Choose the inventory location from which materials added to this invoice will be pulled.

Completed – Enter the date work on the ticket was complete.

Down Payment – If the customer has paid a portion of the invoice, depending on your selections in the
Service Management Parameters, you might be able to enter that payment here instead of in the A/R module.

Payment Type - Choose the type of payment.

Check Number –  Enter the check number of the payment, if applicable.

Payment Date – Enter the payment date, if applicable.

Post To – Choose the G/L period to which to post the payment.

Invoice Number – Enter the invoice number you want to use if you do not want ComputerEase to assign the
invoice number automatically.
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Keep Order Open - Check this box to keep the order open. You can schedule another ticket place the order
back into the unscheduled list at that time. 

Schedule Another Ticket - Check this box to scheduled another work ticket for this order at this time. You
will have the opportunity to select the service person and date for the new ticket(s).

Show on Board - If you selected to keep the order open, check this box to have the order show up on the
dispatch board (as unscheduled).

Invoicing on Hold - Check this box to prevent this order from being invoiced without reopening it. This option
will have to be changed when you are ready to bill the order.

Items Tab

Add - Click here to add charges to the work ticket.

Equipment – If this charge is associated with site equipment, choose it here.

Item – Enter or choose an item from your inventory, if applicable. If you are not adding an inventory item to
your invoice, simply skip this field.

Location – Choose the location from which your inventory item was pulled, if different than the default.

Quantity – Enter a quantity; the quantity must not be zero.
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Payroll Hours - If you have chosen to interface your service to payroll and the item is a labor item (Billing
Class of Labor) and the service person has a Payroll Employee assigned to him or her, enter the payroll
hours to post to payroll for this entry.

Work Performed – Enter a description of the charge. If you chose an item from your inventory, that item's
description will show up here. You may add to or change that description.

Bill Amount – Enter the unit price of the charge. If you chose an item from your inventory, the price
associated with the bill type and/or price code will be used.

Service Date – Enter the date this work was performed or the date the item was used.

Taxable – Check this box if the item is taxable and you have selected a sales tax code for this order.
Any items marked taxable will have an asterisk (*) next to them in the T column on the Items screen.

Sales Account – Choose the revenue account to credit with the billing amount for this item, if different
than the one defaulted.

Unit Cost – If this is an inventory item, this is the unit cost that will be used to relieve your inventory. This
will also be used for profitability reports, so if the item is a non-inventory item, you should enter the cost
here.

Cost Code – If this billing is to be posted to a cost code, enter it here.

When the screen is completed, click OK to add the line item to the Work Ticket and you will be prompted for
additional line items if needed. After all line items are entered, clicking on SAVE will post the Work Ticket to the
Work Order Proof Listing, or give you the option to post the invoice (depending on how you have your parameters
setup.) Before clicking on Save you will have the following options.

Insert - Click here to insert a new line item above the current line item.

Change - Click here to change a highlighted line item.

Delete - Click here to delete a highlighted line item.

Assign Pos – If any purchase orders have been issued in ComputerEase for this order, you must address the
charges before you can bill the order. When you select the purchase order, the items from it will be added to
the items screen. You can edit or delete those as necessary.

Copy Quote - Click here to copy items from an Accounts Receivable Quote. You will be able to select the
quote from which you want to copy items, and you can perform this action more than once, allowing you to
copy items from multiple quotes if necessary.

Ticket Total - The running billable amount for this work ticket will be shown here.

Order Total - The total billable amount entered thus far for all tickets on the order will be shown here.

Est Tax - If sales tax is charged, the estimated invoice sales tax will be shown here.
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Resolution Tab

The resolution is a description of the work performed to resolve the Work Order. Depending you selection in the
Service Management Parameters, the resolution and/or description can print on the invoice.

From Description – Click here to insert the description of the work order into the resolution field.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the work ticket file. This tab only appears if you have created at least one work ticket attachment folder under 
Configure > System Parameters > Service Management Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for work tickets that were setup in
the Parameters for Service Management. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Service Management Parameters.
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Equipment Tab

The equipment tab allows you to enter the resolution and recommendations for site equipment. Each piece of
equipment might have its own recommendations and resolution, so you would enter those here, with the general
resolution going on the Resolution tab.

Equipment - Each piece of site equipment assigned to this work ticket will show up here. If equipment not
assigned to the ticket was serviced, it can be manually added here by entering or choosing that equipment.

Description - The equipment description populates here for reference.

Instructions/Resolution/Recommendation - In the first box the instructions for the service tech appear or
are entered. In the middle box, enter the resolution. In the third box, enter any optional recommendations for
the site equipment.

Click on Save to save your entry or Cancel to exit the screen without saving your changes.

Depending on your selections in the Service Management Parameters, you might be prompted to create the
invoice at this time.

Invoice Now - Check this box to invoice at this time.
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Invoice Date - This will default to the date entered on the work order proof listing. You can change it if
necessary.

Post To – Choose the G/L period corresponding to your invoice date.

Print Invoices – Choose No if you do not want to print a copy of your invoice(s) at this time, Print to print
invoices or Email to email copies of invoices to any customers with the option enabled in customer
maintenance.

Format –  If you want to use a different printing format than the default format for the customer, choose the
printing format you would like to use here.

Printer - Choose the printer to use if printing your invoice(s).

1.3.5.2 Running the Work Order Proof Listing

The Work Order Proof Listing provides you with the opportunity to review any billings that are ready to be billed.
The Work Order Proof Listing must be reviewed before service invoices can be created. If you find any errors, you
should make necessary changes through Edit Work from a Work Ticket and reprint your proof listing.

Select Service Management > Work Order Proof Listing.

Department...to - Choose a department or range of department for which you want to bill or leave blank for all
that meet additional criteria.

Work Order...to - Choose a work order or range of work orders you want to bill or leave blank for all that meet
additional criteria.

Customer...to – Choose a customer or range of customers for whom you want to bill or leave blank for all
that meet additional criteria.

Site...to – Choose a site or range of sites for which you want to bill or leave blank for all that meet additional
criteria.

Invoice Date – Enter the date to assign to invoices.

Order Created by - Choose the order created by date.

Work Completed by - Choose the work completed by date.
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Detail or Summary – Choose Detail which displays individual billing line items or Summary which does not.

Send Report To - Select Display, Printer, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display, create a PDF file on the clipboard or generate an email depending on your choice in
this field.

1.3.5.3 Create Work Order Invoices

Once you have reviewed your Work Order Proof Listing and all billing amounts have been approved, you can create
your invoices. When you create your invoices, they are automatically posted to Accounts Receivable and cannot
be reviewed again without undoing them.

Select Service Management > Create Work Order Invoices.

Invoice Date - This will default to the date entered on the work order proof listing. You can change it if
necessary.

Post To – Choose the G/L period corresponding to your invoice date.

Print Invoices – Check this box to print a copy of the invoice(s) created.

Enable Email - Select No if you do not want to email invoices when the "Email Invoices" option is enabled
by customer in lieu of printing; select Edit emails if you want to email invoices when the "Email Invoices"
option is enabled by customer in lieu of printing and want to be able to edit the emails before sending; or
choose Send emails immediately if you want to email invoices when the "Email Invoices" option is enabled
by customer in lieu of printing and want the email to send immediately with no interaction on your part. Note
that when emailing multiple invoices choosing the "Edit emails" option will bring each email up individually
and you must send that email before the next will be created.

Format –  If you want to use a different printing format than the default format for the customer, choose the
printing format you would like to use here.

Printer - Choose the printer to use if printing your invoice(s).
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1.3.5.4 Undoing a Work Order Invoice

This program will allow you to undo a service Invoice if it is for a single Work Ticket. It will post a credit invoice
automatically to the customer. This will reopen the Work Order, you must go back in to Enter Work From a Work
Ticket and edit this to make changes

Select Service Management > Undo an Invoice.

Customer – Choose the customer for whom you want to undo the invoice.

Original Invoice – Choose the invoice you want to undo.

Credit Invoice – Enter the number you want to assign to the credit invoice or leave blank to allow
ComputerEase to assign the credit invoice number. It can be helpful to use the original invoice number
followed by a "C" or some other pattern to help identify that the invoices are related when reviewing reports.

Date – The date of the credit invoice for aging purposes. This defaults to your log-in date but may be changed
if necessary.

Post to – Select the G>L period corresponding to the credit invoice date.

Note: Once you undo a service invoice, the order is reopened to allow you to make any changes to the billing
information.

1.3.5.5 Reprinting a Work Order Invoice

You can reprint any service invoice that has not been undone.

Select Service Management > Reprint an Invoice.

Customer – Enter or choose the customer for whom you want to reprint an invoice.

Invoice – Enter or choose the invoice to reprint.

Send To – Select Display, Printer, Email or Clipboard depending on what you would like to do with this
invoice. If you are printing the invoice, select the appropriate printer in the next field. Click OK and the invoice
will print, display, create a PDF file on the clipboard or generate an email depending on your choice in this
field.

Format –  If you want to use a different printing format than the default format for the customer, choose the
printing format you would like to use here.
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1.4 How Do I Use Contracts in ComputerEase?

Contracts are used in ComputerEase to produce periodic bills for a site or piece of equipment. Each site can have
one or multiple contracts. Although the billings for contracts are generated in Service Management, the invoices
are maintained through Work on Freeform Invoices. For more information on editing, printing and posting
Freeform Invoices, refer to the Accounts Receivable section of your Accounting Tools Manual.

1.4.1 Creating Contracts

Select Service Management > Work on Contracts.

Site – Enter or choose the site for which you are entering a contract.

Contract – This field will default to "(new)". If you are creating a new contract and want the system to
automatically assign the next contract number do not enter anything here. If you want to manually assign a
contract number,  enter it here.

Main Tab

Description - Enter a description of the contract.

Customer Order – Enter the customer's purchase order number, if applicable. This will populate the PO
Number field on the freeform invoice generated.

Bill Type – Choose the bill type to use for this contract, if applicable.

Contract From - Enter the starting date for the contract.
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to - Enter the ending date of the contract. The contract can optionally be renewed at its end.

Cost Code – If the billings for this contract are to be posted to a cost code in Job Costing, choose that cost
code here.

Sales Account – Enter or choose the revenue account to which to credit the invoices for this contract if you
want to post billings for this contract to a revenue account other than the default for this department

Sales Rep – The sales rep is defaulted from the site, but may be changed here if necessary.

Tax Code – The sales tax code defaults from the site, but may be changed if this contract is subject to
another sales tax code. If no tax code is entered, items on the invoice will default to not taxable.

Terms – The terms are defaulted from the site, but may be changed here if necessary.

Department - Enter or choose the department under which to bill this contract.

Produce bill days in advance – Enter the number of days in advance of the bill date that you want to
produce an invoice. This will be used when selecting which invoices to generate.

Invoice Notes – These are predefined notes that can be selected to be placed at the bottom of the invoice.
Pressing F2 will allow you to select from the notes that already exist or you can click on Maintenance after
pressing F2 to setup an additional note.

Equipment Covered – If any equipment at the site is covered by this contract, choose it here. You may
assign more than one piece of equipment by making additional selections as new rows become available.

Rates Tab

Current Cycle

Starting On – Enter the first date to produce a bill.

Bill – Enter the amount to bill per billing.
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Per – Choose whether the amount to bill is to be billed per Month, Quarter or Year.

In...installments – Choose the number of installments to bill per unit.

Amount - If you need to distribute this billing to more than one sales account and>or category, enter the
first portion to be distributed here.

Sales Account - If you need to distribute this billing to more than one sales account and/or category,
enter sales account for the first portion to be distributed here.

Category -  If you need to distribute this billing to more than one sales account and/or category, enter the
job category to which to post first portion to be distributed here.

Date/Amount – These fields automatically populate with the dates and amounts of bills to be produced
according to your entries above. The amount remaining to be billed is displayed for your information.

Next Cycle - Check the Same as current cycle box to use the same settings for the next billing cycle as are
used for the Current Cycle. Uncheck this box and make changes if your next billing cycle will differ for any
reason.

Note: Enter [PERIOD] on the second line of description in order to have the billing period print on the contract
billing.

Notes Tab

Enter any optional notes about this contract. If you want the notes to print on the invoice, check Print notes on
invoice. The notes will populate the Notes tab of the Freeform Invoice generated when this contract is billed.
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User Fields Tab

The user fields tab allows you to enter information into the user defined fields for contracts that were setup in the
Parameters for Service Management. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Service Management Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the site file. This tab only appears if you have created at least one contracts attachment folder under 
Configure > System Parameters > Service Management Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or  Cancel to exit the screen without saving your changes.

1.4.2 Running the Contract Billing Proof List

When you are ready to periodically bill your contracts, you will do so by first generating and reviewing the Contract
Billing Proof Listing. This report must be printed to a printer before the invoices can be created.

Select Service Management > Contract Billing Proof Listing.

Departments  - Select the department or range of departments that you want to include.

Report all Billings due on or before - Enter the date through which you want to bill your contracts. All
contracts with next invoice dates on or before this day will be included. 

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.
Remember that you cannot complete the next step until you select Printer here.
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1.4.3 Creating Contract Invoices

Once you have reviewed your Contract Billing Proof Listing, you are ready to create your contract invoices.
Remember that this process generates unposted freeform invoices that can be edited before they are printed and
posted.

Select Service Management > Create Contract Invoices.

Period Ending Date – The date through which your generated the contract billing proof listing will be
displayed here.

Invoice Date – Enter the date you want to use for your invoice date. The due date of the invoices will be
based on the invoice date and contract terms.

For your convenience, the Work on Freeform Invoices menu is available from the Service Management menu to
allow you to easily review, print and post your contract invoices.

1.5 How Do I Use Reports in Service Management?

Below are some of the reports available in the ComputerEase Service Management Module:

· Work Order Proof Listing - Contract Billing Proof
Listing

· Unscheduled Work Orders

· Open Work Tickets · Work Schedules

· Scheduled Services Report · Contract Expiration Report

· Site History Report · Equipment History Report

· Work Order List · Completed Work Order List

· Contract Master List · Equipment Master List

· PO Status by Work Order · Profitability Reports

· Billings by Department · Warranty Report by Site

· Payroll Hours vs Billed Hours · Customer Master List

Most of the reports in Service Management may be accessed by selecting the Reports sub-menu of the main
Service Management menu. When you have selected the report you want to run, that report’s informational screen
will display. Below is an explanation of fields you will commonly find on these screens. Which fields are displayed
on a report’s informational screen will vary by report.

Site...To – Enter the site or range of sites you would like included in the report.

Work Order...To – Enter the work order or range of work orders you want included in the report.

Person...To – Enter the service person or range of service people you want to include in the report.
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Schedule Date...To – Enter the date or the range of dates you want to include in the report.

Open or All Orders -Select if you want all orders or just open orders included in the report.

Scheduled Date...To – Enter the scheduled date or range of dates you want to include in this report.

Contract...To – Use this field to enter the contract or range of contracts you want included in the report.

Date...To – Enter the date or range of dates you want included in the report.

Equipment...To – Enter or choose the equipment you want included in the report.

Creation Date...To – Use this field to enter the date or range of dates for creation of the original work order.

Detail or Summary – This is used to select whether to print detailed entries or just a summary report.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

1.6 How Do I Use the Other Features in Service Management?

1.6.1 Changing a Work Order's Status

The Service Management Program moves a Work Order through various stages automatically as the work
progresses. Change a Work Order’s Status allows you to change the system-defined status if the need arises. A
work order can have any one of five statuses: Open, Open/Hold, Ready/Hold, Ready and Invoiced.

Select Service Management > Maintenance Programs > Change a Work Order's Status.

Order – Enter or choose the order for which you want to change the status.

Current Status – The order's current status is displayed here for your information.

Change To – Choose the status you want to assign to the order.

Open - A work order is open as soon as it is created in the system. The work order stays in the open
status until you begin entering work.

Open/Hold - A work order is in Open/Hold status if you have begun entering work and selected both the 
Keep Order Open and the Invoicing on Hold boxes. The order is still considered open and cannot be
invoiced until removed from this status.

Ready/Hold - A work order is in Ready/Hold status if you have begun entering work and selected the 
Invoicing on Hold box. The order is ready to be billed but cannot be invoiced until removed from this
status.

Ready - A work order is in Ready status if you have entered work and the order is ready to be billed.

Invoiced - A work order is in Invoiced status only after it has been billed.

Tip: If you change the status of an Invoiced order it is important to know that any changes made in the Enter Work
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from a Work Ticket screen will not change the amount billed. 

Once you have confirmed your selection, press Change to complete the status change or Cancel to exit the
screen without saving your changes.

1.6.2 Purging Data

From time to time you may find it useful to purge old data from the system. It is never required that you purge your
Service Management data, although after several years your may find that you have a large amount of unused data
in your database.

Note: Remember to confirm that you have a good backup of your data and/or print out a hard copy of any reports
prior to performing this function. Once purged, these are your only options for retrieving this information.

1.6.2.1 Delete Completed Work Orders

Select Service Management > Maintenance Programs > Delete Completed Work Orders.

Delete Orders Invoiced before – Choose the first date for which you want to keep completed orders. All
work orders completed prior to this date will be purged.

Site – Choose a site to delete work orders just for one site or leave empty to delete all work orders completed
prior to the date listed above.

1.6.2.2 Remove Service History

Select Service Management > Maintenance Programs > Remove Service History.

Delete History before - Choose the first date for which you want to keep service history.

Site – Choose a site if you want to remove history just for one site.

Equipment – To purge the history for one piece of equipment, choose that equipment here.

For Deleted Work Orders Only - Check this box to only remove service history for orders that have been
deleted.

Delete Equipment History - Check this box to delete equipment history in addition to site history.

Delete Non-Equipment History – Check this box to delete non-equipment history.



Part

II

Fleet & Assets
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2 Fleet & Assets

The Fleet & Assets module allows you to track your Equipment-related expenses. It can be used independently,
with all entries entered directly into the Fleet & Assets module. Or it can be used in conjunction with the Accounts
Payable, Payroll, Job Costing and/or General Ledger modules to allow you to fully integrate your equipment
costing with the other ComputerEase modules.

The Fleet & Assets module has been designed to track your company’s equipment usage, post cost to your Job
Cost and General Ledger, and keep you informed of both normal and abnormal services done on the equipment.
"Equipment" includes any item you desire. Equipment such as bulldozers, backhoes, and trucks are obvious
examples of this. You might also use this module to track other office equipment. The module includes multiple
reports, both on the screen and on paper, that keep you completely informed as to the costs of operating any
given piece of equipment, as well as tracking of future service schedules and special servicing instructions.

2.1 What is the Fleet & Assets Module?

2.1.1 Other Modules and Fleet & Assets

ComputerEase's Fleet & Assets module may be used independently of other modules. However, it may also be
integrated with other modules, allowing you to make entries against your equipment usage and cost with ease.
When entering payroll, an employee's time may also include time spent operating or servicing a piece of
equipment. This entry is posted directly from Payroll to the Fleet & Assets module and, if applicable, Job Costing
and the General Ledger. When invoices are received against a piece of equipment, they can be entered directly
into Accounts Payable, which will in turn post to Fleet & Assets and, if applicable, Job Costing and the General
Ledger. When you use items from your inventory for a piece of equipment, adjustments in the Purchasing &
Inventory module allow you to post the cost of an item directly to your Fleet & Assets.

Finally, if you rent your equipment to third parties or even if you want to track where and when your equipment is
used, Fleet & Assets can be integrated with the Tool & Equipment Tracking module, allowing you to track all
equipment moves.

2.1.2 Features in Fleet & Assets

The Fleet & Assets module provides your company with all the tools required to track the cost to own and operate
your fleet & assets.

Some of its features are:

· Interface to Payroll. Fleet & Assets entries may be posted through Payroll, which will then post to Equipment
Cost and ultimately Job Cost and General Ledger.

· Interface to Accounts Payable. Equipment costing invoices may be entered into Accounts Payable, which will
then post to Equipment Cost and ultimately Job Cost and General Ledger.

· Service Schedules are tracked by piece of equipment. You can inquire at any time into the service history
and future service scheduling of your equipment.

· Cost to own, cost to operate, and revenue equipment costs are tracked simultaneously, allowing you to
easily see when maintenance costs are exceeding revenues.
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· ComputerEase keeps all licenses, serial number, model number, and other pertinent equipment registration
information.

· Equipment Service Work Order can be generated in order to issue service tickets and charge labor and
materials to a specific piece of equipment.

· Interface to Tool & Equipment Tracking. Equipment items can be rented to third parties or tracked to internal
jobs or other types of destinations.

2.1.3 Reports In Fleet & Assets

The Fleet & Assets Module contains four main reports you will use to track your equipment usage, service, and
costs. These reports are designed to help you track your equipment cost, usage and/or service and maintenance
schedules to help you make important decisions about your equipment. These reports are:

· Equipment List · Equipment Center

· Equipment Cost Report (Detail and Summary) · Scheduled Services Report

· Equipment Usage Report · Service History Report

2.2 Fleet & Assets Setup

2.2.1 How Do I Set Up Equipment in ComputerEase?

Before you can start entering equipment cost or usage into ComputerEase, you must create your equipment
master files. Once you have a numbering scheme for identifying your equipment it is a good idea to have them all
numbered and the vital information ready before entering them into the system. The equipment "number" may be
alphanumeric and is a maximum of 8 characters long.

Select Fleet & Assets > Maintenance Programs > Equipment Maintenance.

Equipment - Enter the alphanumeric code (up to eight characters) you want to assign to the new equipment
and click on OK.

Tip: To import equipment from a file, click on File, then Import Equipment in the upper left corner.
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Main Tab

Description – Enter the description for this piece of equipment.

Status - This field has two options, active and inactive. Active means this equipment is an active piece of
equipment currently in use. Inactive means that you are no longer using this equipment. If an equipment item
is marked as inactive you will not be able to enter activity against it. Inactive does not delete the equipment it
just prevents future detail from being posted to its account.

Serial Number – Enter in the serial number for this piece of equipment. This is an informational field. It is
used for reference for insurance or warranty or other misc uses. This field can hold two lines of information.

Fleet Code - This field is used to group equipment together in order to filter various lists and reports. For
example, if you want to keep all track loaders together for reporting purposes you could use the first two
letters of the code "TL" for Track Loaders.

Purchase Date - Enter the date the equipment was purchased.

Model Number - Enter the equipment model number.

License Number - Enter the License number for this piece of equipment.

Expires - Enter the date the license will expire.

Current Location – Enter the current location of this piece of equipment. This is an informational field only
and may be left blank if the equipment moves around frequently.

Mileage - If you will be performing scheduled maintenance based on mileage, this information is used to
calculate the next service due. It is not necessary to enter this data initially. It can be updated through the
mileage update program at a later time.

At Time of Purchase - Enter the mileage at the time you purchased this piece of equipment.

Hours of use - If you will be performing scheduled maintenance based on hours of use, this information is
used to calculate the next service due.
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At Time of Purchase - Enter the total hours of use for this equipment at the time you purchased it.

Unposted Operating Hours - ComputerEase automatically accrues certain costs based on operating hours
posted in the labor distribution program. This field is only updated when a Revenue code is used against all
costs.

Unposted Idle Hours - ComputerEase automatically accrues certain costs based on idle hours posted in the
labor distribution program. This field is only updated when a Revenue code is used against costs to own.

Payroll Override - This field allows you to set payroll overrides for this piece of equipment. If your
employee's worker class and/or worker's compensation code changes when they operate this piece of
equipment, you can assign a payroll override here so that ComputerEase will automatically make the change
for you when entering labor distribution if you select this piece of equipment.

Billing Class - Enter or choose the billing class to which this piece of equipment belongs, if applicable. See
Billing Class Maintenance  for more information on Billing Classes.

Bar Code - Enter a bar code for this piece of equipment; this is used by bar code scanning applications to
identify transactions.

Notes Tab

The notes tab allows you to enter notes concerning this piece of equipment. These notes are for your use only and
may be viewed from certain displayed reports.

88
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User Fields Tab

The user fields tab allows you to enter information into the user defined fields for equipment that were setup in the
Parameters for Equipment Costing. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Fleet & Assets Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the equipment file. This tab only appears if you have created at least one equipment attachment folder under 
Configure > System Parameters > Fleet & Assets Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or  Cancel to exit the screen without saving your changes.

Rental Information Tab

You have the ability to rent or track your equipment through the Tool & Equipment Tracking module. If you doing
so, you must complete this tab in order to track this piece of equipment through that module.

Allow Rental - Check this box to make this equipment available to be rented.  

Inventory Loc - Depending on your selections in the Rental Parameters, you might select the inventory
location to use for posting your rental cost to the G/L. 

Home Location - Depending on your selections in the Rental Parameters, you might select the equipment
home location to use for posting your rental cost to the G/L. 
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Group Code - Select the group to which this piece of equipment belongs.

SubGroup Code - Enter an option subgroup description for this item; informational only at this time.

Rental Pricing By - Choose Price Code to use a price table or choose Individual to create a unique price
table for this item.

Price Code - The price code table to use, if selected above.

Purchase Cost - Enter the purchase cost for this item.

Buyout/Loss Cost - Enter the cost should this item become lost or no longer available for rent.

Max Is Per Order - Check this box if the maximum charge for any item is per order rather than for the item
across its lifetime.

Lifetime Max - Enter the maximum to be charged against this item for cost on rental orders.

Total Charged - Enter the total amount charged to date against the lifetime max.

Override Daily Rate - Check this box to charge a different percentage of lifetime maximum cost than that
found in the Rental Parameters for this item per day.

Daily Rate % - Enter the percentage of lifetime maximum cost to expense per day for this item.

Rental Cost/Day - Enter a flat daily cost to expense for this item in lieu of using the daily rate %.

Subject to Minimum - Check this box if this item's pricing is subject to a minimum price code.

Min Code - If you have a minimum price code in effect for this item, choose the appropriate code here.

Use Detail Pricing Table - Check this box if you want to use the detailed pricing table instead of the daily/
weekly/monthly rates.

Daily - Enter your daily rental charge for this item.

Weekly - Enter your weekly rental charge, if applicable.

Monthly - Enter the monthly rental charge, if applicable.

Default Choice on Rental - If selected, this equipment will be displayed as a default choice on each new
rental ticket created.

Reminder - Additional text you wish to appear when this equipment is entered onto a new rental ticket.

Retired - Check this box if your item is no longer available for rental. This box will automatically be checked
when an item is marked as "Lost" on a rental order.

Reason - Enter the reason for retiring this item from your rental fleet.

Date - Enter the date this item is retired. This field will automatically be populated when an item is marked as
"Lost" on a rental order.

Last Assign - Enter the option last known assignment for this item. This field will automatically be populated
when an item is marked as "Lost" on a rental order.
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Check-In/Repair/Hold - Check this box if the item is unavailable because it is on hold; this requires that the
item be "checked in" prior to becoming available for use in Tool & Equipment Tracking. This field will
automatically be checked when items are returned if you have selected the option to hold items for check-in
in your Rental Parameters.

Status - Enter an option reason that the item is on hold.

To delete this piece of equipment click on File in the upper left corner and select Delete this Equipment.

2.2.2 Editing Equipment Codes

There are three types of equipment codes: Revenue, Cost to Own and Cost to Operate. Equipment codes are used
to post cost against a piece of equipment. For each piece of equipment that you plan to post code or usage time
against, you must create at least one revenue code and at least one cost code.

Select Fleet & Assets > Maintenance Programs > Edit Equipment Codes.

Code - Enter a code you want to create, up to eight alphanumeric characters.

Description – Enter a description for this code.

Type - There are three types of codes, you can use the space bar to toggle or type in the first letter of the
code you wish to work with. The three types of codes are:

Revenue – Used to post usage time for a piece of equipment and to record billable time against jobs.

Cost to Own – Used to accrue and post the costs that are associated with owning a piece of equipment
and are not dependent on usage, such as interest and depreciation.

Cost to Operate – Used to accrue and post the costs that are associated with operating a piece of
equipment and are dependent on usage, such as repairs.

Equipment Cost Account - Enter or choose the General Ledger account that will be debited when costs are
posted for this cost type.

Equipment Contra Account – Enter or choose the General Ledger account that will be credited when costs
are posted for this cost type. If this code will be used to post actual cost to the equipment (through Accounts
Payable, for instance), you may use the same account number here that you used for the cost entry above
so that no additional posting is made to the General Ledger when your costs are accrued.
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2.2.3 Editing Equipment Costs

After you have built the equipment files and the applicable cost codes, you need to assign rates to these codes for
each piece of equipment.

Remember, equipment cost codes have a dual purpose. One is to post estimated hourly costs to the job costing
module. The second purpose is to use these codes to collect the actual costs that are incurred on each piece of
equipment. These actual costs are posted from accounts payable, payroll and inventory. It is important for
reporting true profitability that you track both revenue and cost for each piece of equipment.

Select Fleet & Assets > Maintenance Programs > Edit Equipment Costs.

Equipment - Enter or choose the code for a piece of equipment for which you want to enter equipment costs
and press OK.

Revenue Tab

If you want to track revenue earned for a piece of equipment, you must add at least one revenue code to this tab
for this equipment.

Code/Description - Select a revenue code that will apply to this piece of equipment. If you have more than
one revenue code for a piece of equipment, you will be able to continue to add additional codes on new rows
beneath.

Hourly Rate - If you want to set your revenue rate per piece of equipment (rather than by billing class), enter
the hourly rate for this piece of equipment here.

Costs - Select All or Own:

All - Choosing to accrue all costs when this revenue code is selected serves two purposes. First, it
identifies this revenue code as an operating code; when it is selected any hours posted will accrue as
operating hours. Second, it includes both hourly costs to own and hourly costs to operate when posting
cost against any job on which the equipment is used.
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Own - Choosing to accrue only costs to own when this revenue code is selected serves two purposes.
First, it identifies this revenue code as an idle code; when it is selected any hours posted will accrue as
idle hours. Second, it includes hourly costs to own when posting cost against any job on which the
equipment is used.

Costs to Own Tab

Code/Description - Select a cost to own code that will apply to this piece of equipment. If you have more
than type of cost to own for a piece of equipment, you will be able to continue to add additional codes on new
rows beneath. If you select a cost to operate here, you will have the opportunity to move the code to the
correct tab:

Type - Select the appropriate cost type that defines how this cost will be used:

Actual - Actual costs are used to post costs directly to a piece of equipment through Accounts Payable,
Inventory Control or Job Entry. If a code is not set to Actual, then it may not be used to post cost directly
to a piece of equipment through any other module. Even if a cost is set to Actual, you can still post an
estimated hourly or monthly rate so that these costs are included when posting to jobs.

Hourly - Hourly costs are costs that accrue and post to a piece of equipment based on hours of use.

Monthly - Monthly costs are costs that accrue and post to a piece of equipment at a set monthly rate
regardless of that equipment's activity or use.

Hourly Rate – Enter the hourly rate to accrue for this piece of equipment. If the cost is set to hourly, then
when you post your accrued costs periodically, the cost posted to this piece of equipment will be based on
the hours it was used. You will notice that when you enter an hourly rate, ComputerEase will automatically
calculate and populate the Monthly Rate field.

Monthly Rate – Enter the monthly rate to accrue for this piece of equipment. If the cost is set to monthly,
then when you post your accrued costs periodically, the cost posted to this piece of equipment will be based
the time elapsed since accrued costs were last posted. You will notice that when you enter a monthly rate,
ComputerEase will automatically calculate and populate the Hourly Rate field.
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Costs to Operate Tab

Code/Description - Select a cost to operate code that will apply to this piece of equipment. If you have more
than type of cost to operate for a piece of equipment, you will be able to continue to add additional codes on
new rows beneath. If you select a cost to own here, you will have the opportunity to move the code to the
correct tab:

Type - Select the appropriate cost type that defines how this cost will be used:

Actual - Actual costs are used to post costs directly to a piece of equipment through Accounts Payable,
Inventory Control or Job Entry. If a code is not set to Actual, then it may not be used to post cost directly
to a piece of equipment through any other module. Even if a cost is set to Actual, you can still post an
estimated hourly or monthly rate so that these costs are included when posting to jobs.

Hourly - Hourly costs are costs that accrue and post to a piece of equipment based on hours of use.

Monthly - Monthly costs are costs that accrue and post to a piece of equipment at a set monthly rate
regardless of that equipment's activity or use.

Hourly Rate – Enter the hourly rate to accrue for this piece of equipment. If the cost is set to hourly, then
when you post your accrued costs periodically, the cost posted to this piece of equipment will be based on
the hours it was used. You will notice that when you enter an hourly rate, ComputerEase will automatically
calculate and populate the Monthly Rate field.

Monthly Rate – Enter the monthly rate to accrue for this piece of equipment. If the cost is set to monthly,
then when you post your accrued costs periodically, the cost posted to this piece of equipment will be based
the time elapsed since accrued costs were last posted. You will notice that when you enter a monthly rate,
ComputerEase will automatically calculate and populate the Hourly Rate field.

Above the tabs, you will see a running tally of Hourly Costs to Own, Hourly Cost to Operate and the total of the
two. These are based on the hourly rate you enter (or that are calculated by ComputerEase). Based on your
selection  of All or Own for each code entered on the Revenue tab, either the Hourly Costs to Own or the total
will be used when posting costs when that revenue code is selected.
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To delete a code from a tab, highlight the line you wish to delete and hit Alt and Delete simultaneously.

2.2.4 Billing Class Maintenance

Billing classes are used to group your equipment together for Time & Material billing purposes. For each revenue
code, you can set your billing rates by billing class. So if you charge the same rate for all of your large equipment,
then you would want a billing class called Large Equipment or something similar. If instead you charge one rate for
your large loaders and another for your large bulldozers, then you would have two separate billing classes for those
items. Note that use of billing classes and billing rates for equipment is optional and is an alternative to setting
billing rates per item under Edit Equipment Costs.

Select Fleet & Assets > Maintenance Programs > Billing Class Maintenance.

Billing Class - Enter a code for your billing class up to ten alphanumeric characters and click OK.

Description - Enter a description for this billing class.

Click on OK to save this billing class or Cancel to close the screen without saving your changes.

2.2.5 Billing Rate Maintenance

Once you have created your billing classes, billing rates are used to set the billing rates for Time & Material billing
purposes. For each revenue code, you can set your billing rates by billing class. Note that use of billing classes
and billing rates for equipment is optional and is an alternative to setting billing rates per item under Edit
Equipment Costs.

Select Fleet & Assets > Maintenance Programs > Billing Rate Maintenance.

Billing Rate - Enter a code for this set of billing rates, up to ten alphanumeric characters, and click OK.

Description - Enter a description of this set of billing rates.
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Billing Class - In this column you will see each billing class you have created, with both the code and
description.

Revenue Code - In this column you will see each revenue-type equipment code you have created, with both
the code and description.

Bill Rate - For each billing class and each revenue code, enter the billing rate you charge for items in that
billing class.

2.2.6 Service Type Maintenance

Service types are used to create and schedule service schedules and/or orders for your equipment.

Select Fleet & Assets > Maintenance Programs > Service Type Maintenance.

Service Code - Enter a code for this type of service, up to eight alphanumeric characters and press OK.

Description - Enter a description of this service type.

2.2.7 Home Location Maintenance

Home Locations are optional and are used to determine the General Ledger account postings for rental billings or
simply where it is stored when not in use. It is a good idea to discuss these posting with your ComputerEase
trainer to determine how you want your postings to be determined.

Select Fleet & Assets > Maintenance Programs > Home Location Maintenance.

Home Location - Enter a code for this home location, up to eight alphanumeric characters and press OK.

Description - Enter a longer description for this location.

Contra Acct - Enter or choose the General Ledger account to be credited with an equipment's rental cost
when equipment rental or tracking orders are billed.
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2.3 Editing Equipment Cost Detail

Equipment Cost Detail Maintenance can be used to add, remove and/or change actual detail and cost against a
piece of equipment.

2.3.1 Add Detail

You may have a need to post cost or usage directly to your equipment cost reports. Equipment Cost Detail
Maintenance allows you to make that posting for your equipment cost reports only. It is important to know that
only your equipment cost reports will be affected using this feature.

Select Fleet & Assets > Maintenance Programs > Equipment Cost Detail Maintenance > Add Detail.

Equipment – Enter or choose the equipment against which to post this entry.

Code – Enter or choose the equipment code against which to post this entry.

Service Order - Enter or choose the service order against which to post this entry, if applicable.

Description – Enter an optional brief description of the entry.

Employee/Vendor - Enter the name of the employee or vendor associated with this entry.

Date – Enter or choose the date to which to post this entry.

Posted To - Enter or choose the General Ledger period against which to post this entry.

Hours - Enter the hours to record for this entry, if applicable.

Cost - Enter the cost to record for this entry.

Revenue - Enter the revenue to record for this entry, if applicable.
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2.3.2 Change Detail

You may find that a piece of equipment was posted to the wrong piece of equipment, or that some other part of a
posting is incorrect. Equipment Cost Detail Maintenance allows you to edit and change that posting for your
equipment cost reports only. It is important to know that only your equipment cost reports will be changed using
this feature.

Select Fleet & Assets > Maintenance Programs > Equipment Cost Detail Maintenance > Change Detail.

Equipment - Enter or choose the equipment for which you want to change a detail entry.

Code - Enter or choose the code for which you want to change a detail entry.

All detail entries posted for the selected equipment and code will be listed. Find the entry you want to review and/
or change and press OK.

Equipment – The equipment against which the detail entry was originally posted. It may be changed if
necessary.

Code – The equipment code against which the detail entry was originally posted. It may be changed if
necessary.
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Service Order - If the entry was for a service order, that order will be listed here. It may be changed if
necessary.

Description – The description of the entry. It may be changed if necessary.

Employee/Vendor - If a vendor or employee was associated with the original entry, that name will be listed
here. It may be changed if necessary.

Date – The date of the posting. It may be changed if necessary.

Posted To - The General Ledger period to which the entry is posted. It may be changed if necessary.

Hours - The hours posted in the original entry. It may be changed if necessary.

Cost - The cost posted in the original entry. It may be changed if necessary.

Revenue - The revenue posted in the original entry. It may be changed if necessary.

If you need to delete a detail entry entirely from your Equipment reports, click on File in the upper left corner of the
detail entry screen, then select Delete this record. You will be prompted to confirm the deletion:

2.3.3 Reorganize Detail

As each record is posted to your equipment costing, it is posted in detail. While you have the ability to view your
reports in detail or in summary and you also have the ability to view your reports by date range, you may decide
that you no longer have need to see prior records in detail. The Reorganize Detail option in Equipment Cost Detail
Maintenance allows you to reorganize old detail records and group similar records together into Monthly Totals. If
you reorganize detail prior to January 1, 2005, then for any month prior to January 1, 2005 that had more than one
detail record for a piece of equipment, on your detailed cost report you will see a line for the last date of that month
with activity and the phrase "Month Totals" with the total of all detail entries for that month in lieu of each detail
entry.

Select Fleet & Assets > Maintenance Programs > Equipment Cost Detail Maintenance > Reorganize
Detail.

Reorganize detail dated before - Enter or choose date before which all detail records will be organized and
replace with subtotals.

Note: It is recommended that you have a good backup of your data prior to removing any information/records from
your system and print hard copies of all reports that will be affected. This will ensure if you should require the data
again you can load the information from your backup.
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2.4 How Do I Use the Other Features In Fleet & Assets?

2.4.1 Service Orders

You can use service orders in ComputerEase to track services performed on your equipment. This allows you to
track all relevant information about your equipment in one convenient location.

2.4.1.1 Enter New Service Order

Select Fleet & Assets > Service Orders > Enter New Service Order.

Main Tab

Equipment - Enter or choose the equipment to be serviced.

Service Type - Enter or choose the service type to be performed.

Service Order - Leave this field empty to allow ComputerEase to automatically number your order or enter a
number of your choosing. If you press the right-pointing arrow, you will see the number that ComputerEase
will assign.

Notes - Enter in any information that you want to appear on the service order when printed out.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for service orders that were setup in
the Parameters for Equipment Costing. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Fleet & Assets Parameters.

When you have completed entering the order, press Save to save your work and close the screen.
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2.4.1.2 Edit a Service Order

Select Fleet & Assets > Service Orders > Edit Service Order.

Service Order - Enter or choose the number of the service order you want to change and press OK.

You can change the service type, notes or user field entries here. To delete the service order, click on File in the
upper left corner and select Delete this Service Order. When you have completed your changes, press Save.

2.4.1.3 Edit Scheduled Services

Maintaining your equipment is essential to protecting its value. Scheduled services allow you to set a schedule for
performing services on your equipment. This allows you to keep track of certain services that must be performed at
certain intervals and ensures you never miss an important service.

Select Fleet & Assets > Service Orders > Edit Scheduled Services.

Equipment - Enter or choose the equipment for which you want to create a service schedule.
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Code/Description - Choose the service type to be performed. You can add multiple services here, all with
different schedules. After you add one service type, you can enter additional services on rows beneath.

Next Maintenance - Enter information about when this service will next be due. You can use any
combination of the three options; for example a service might be due at 500 hours or on June 1.

Miles – Enter the number of miles at which this service will be due, if applicable.

Hours - Enter the number of hours at which this service will be due, if applicable.

Date – Enter the date when this service will be due, if applicable.

Plus Every - Enter information about how much usage should occur or time should pass between services.
You can use any combination of the three options; for example a service might be due every 500 hours or 12
months.

Miles - Enter the number of miles after which this service will be due again once performed, if applicable.

Hours – Enter the number of hours of use after which this service will be due again once performed, if
applicable.

Days - Enter the number of days after which this service will be due again once performed, if applicable.

Notes - The option allows you to enter notes and instructions for performing this maintenance. It will be
printed with the scheduled services.

2.4.1.4 Create Scheduled Service Orders

You can automatically generate service orders when your services become due based on mileage, hours of use or
date.

Select Fleet & Assets > Service Orders > Create Scheduled Work Orders.

Due by - Enter a date by which any equipment with a scheduled service due before this date will have a work
order generated.

Hours Remaining - Enter the maximum number of hours remaining on equipment before services are due.
Any equipment with this many or fewer hours remaining before a scheduled service is due will have a work
order generated.

Miles Remaining - Enter the maximum number of miles remaining on equipment before services are due.
Any equipment with this many or fewer miles remaining before a scheduled service is due will have a work
order generated.

Equipment Status - Select Active, Inactive or All.



Other Tools96

Deltek+ComputerEase

2.4.1.5 Print Service Orders

You can print hard copies of service orders to give to the person(s) to perform them. 

Select Fleet & Assets > Service Orders > Print Service Orders.

Service Order...To - Choose a service order or range of orders to print or leave blank to print all orders that
meet additional criteria.

Equipment...To - Choose a piece of equipment or range of equipment to print orders for or leave blank to
print orders for all that meet additional criteria.

Service...To - Choose a service code or range of codes to report or leave blank to report all that meet
additional criteria.

New or All - Choose New to print only new orders not previously printed or All to print all orders that meet
additional criteria.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

Format - Choose the format to use to print this order. The service order allows you to use a Word template to
produce a form.

2.4.1.6 Update Service History

Once work is completed, you will want to update your service history to reflect that the service has been
completed.

Select Fleet & Assets > Service Orders > Update Service History.

Order - Enter or choose the service order for which work was performed. If you are not using service orders,
leave empty.
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Equipment - Enter or choose the equipment for which to update service history.

Service - Enter or choose the service type that was performed.

Equipment - For display purposes only; this is the equipment on which the service was performed.

Service - For display purposes only; this is the service that was performed.

Order Number - If there was an order created for this service, it will be displayed here. If not, you may leave
empty to automatically number the order or enter a number of your choosing.

Serviced On - Enter the date on which the service was performed.

Hours of use - Enter the current hours of use at the time of the service, if applicable.

Mileage -  Enter the current mileage at the time of the service, if applicable.

Notes - Enter notes about the work performed.

Next Scheduled Service - If you have a service schedule, it should default to the next date service will be
due. You can enter or change this information manually.

Close this Order - Leave this box checked to close the order or uncheck it if work remains to be done
against this order.

2.4.1.7 Update Equipment Mileage

Your equipment mileage can be updated conveniently in one place.

Select Fleet & Assets > Service Orders > Update Equipment Mileage.

Equipment - Enter or choose a piece of equipment for which to update mileage or leave blank to choose all.
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Fleet Code - Enter a fleet code if you are updating only equipment in a specific fleet or leave blank to choose
all.

Active Only - Leave this box checked to update mileage for only active equipment items.

Equipment/Description - Your equipment codes and descriptions that you selected in the previous step will
be listed here.

Previous Reading - The previous mileage reading is displayed here.

Current Reading - Enter your current mileage for each item.

Once all data has been entered, press Close to save your work and close the screen.

2.4.1.8 Posting Accrued Costs

As hours of use are recorded for each piece of equipment, these hours are accrued so that any costs identified as
hourly accrual costs can be posted based on those hours. Any costs identified as monthly accrual costs will of
course accrue based on the passage of time. In order to actually post those accrued costs to your Equipment
Costing reports and the General Ledger, you must perform the Post Accrued Costs task.

This process may be performed as often as you want; you may want to perform this task at least once a month so
that your costs accrue monthly in your General Ledger. The date from which costs will be accrued is stored in
your Equipment Costing Parameters.

Select Fleet & Assets > Post Accrued Costs.

Type - Choose Proof to review the postings that will be made or Final to finalize the posting. If you choose
Final, you will not be able to edit the posting.

Accrue as of - Enter the date through which you want to post accrued costs.

Post To - Choose the General Ledger period to which to post the accrual entry.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.
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2.4.1.9 Equipment Job Entry

While equipment usage on a job can be tracked and entered either using the Payroll or Tool & Equipment Tracking
modules, you may want or need to post equipment usage cost directly to a job directly. Job Entry allows you to
simultaneously post cost to both Job Costing and your Fleet & Assets modules.

Select Fleet & Assets > Job Entry.

Equipment - Enter or choose the equipment used.

Code - Enter or choose the equipment cost code to use for this posting.

Order - If these costs are associated with a service order, choose that order here.

Date - Enter the date of the cost; this defaults to the current log-in date.

Period - Chose the General Ledger period to which to post the cost; this should correspond to your date
above.

Description - Enter a brief description of the cost.

Cost Code - Enter the Job Costing cost code to which to post the equipment usage.

Cost

Hours – Enter the number of hours of use on the job.

Rate - This defaults to the rate for this code for this equipment. You can change it if necessary. The total
cost amount is calculated using this rate and the number of hours entered above.

Amount - This is calculated using the fields above. This is the cost that will be posted to your cost code.

Bill

Hours - This defaults to the number of hours entered in the Cost Hours field. If you want to bill for a
different number of hours than you are costing, type in the correct number of billable hours.

Rate - This defaults to the rate set for the revenue code selected. If you want to use a different bill rate for
this entry type in the new billing rate.

Amount - This is calculated using the fields above. This is the total billable amount that will be posted to
your cost code.

Once you have entered all information, press OK. You may continue making additional entries. Once you have
finished, press Cancel on a new entry screen. You will be returned to the Job Entry review screen.
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Add – Click here to add another entry.

Change – Highlight an entry and click here to make changes to it.

Delete – Highlight an entry and click here to delete the entry.

Once you are ready to post your entries, press OK. You may review a Proof List by selecting File in the upper
left corner and then Proof List. You can also import entries from a flat file by selecting File then Import. Contact
your ComputerEase Dealer Support team for more information on importing entries.

2.4.2 How Do I Use Reports in ComputerEase?

There are various reports that can be utilized to review your equipment list, costs and usage. Each report is
designed to give you different information. Whether you are interested in how usage of a particular piece of
equipment has increased or declined over time or how cost for a piece of equipment have been trending, you can
find the information you need in one convenient location. The reports listed below are all included in the Fleet &
Assets Module:

· Equipment List · Equipment Center

· Equipment Cost Report (Detail and Summary) · Scheduled Services Report

· Equipment Usage Report · Service History Report

You might not use all of the reports in the equipment costing module. However, each of these reports is available
for your use and may be printed, emailed or simply displayed for quick reference. Many reports are date-sensitive,
allowing you to run the report only for a specific date range, and any of them can be run for all equipment items, a
fleet of items or just one piece of equipment.

2.4.2.1 Equipment Cost Report

The Equipment Cost Report can be ran in either Detail or Summary depending on the amount of information that
you require.
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Select Fleet & Assets > Reports > Equipment Cost Report. Then choose Detail or Summary depending on how
whether you want to see detailed entries or simply totals per piece of equipment and code.

Equipment...To - Choose a piece of equipment or range of equipment to report or leave blank to report all.

Status - Choose Active, Inactive or All.

Fleet Codes Matching - To report just equipment in one fleet code, enter that code here. This field accepts
the wildcard feature (*), allowing you combine fleet codes depending on structure or leave the wildcard (*) to
report all.

Code...To - Choose a cost code or range of codes to report or leave blank to report all.

Date...To - Choose a date or date range to report or leave blank to report all.

Period...To - Choose a General Ledger period or range of periods to report or leave blank to report all.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

2.4.2.2 Equipment Usage Reports

Within the Equipment Usage Report you have various options when it comes to running the reports.

Select Fleet & Assets  > Reports > Equipment Usage Report. Then choose by Equipment/Code, by
Equipment/Employee, by Equipment/Job or by Equipment/Customer depending on how you would like your
report sorted, grouped and subtotaled.

Note: The prompts you see will vary slightly depending on which report option you selected. The report by
Equipment/Code is shown above. The others will include an additional prompt as appropriate.

Equipment...To - Choose a piece of equipment or range of equipment to report or leave blank to report all.
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Status - Choose Active, Inactive or All.

Fleet Codes Matching - To report just equipment in one fleet code, enter that code here. This field accepts
the wildcard feature (*), allowing you combine fleet codes depending on structure or leave the wildcard (*) to
report all.

Code...To - Choose a cost code or range of codes to report or leave blank to report all.

Date...To - Choose a date or date range to report or leave blank to report all.

Period...To - Choose a General Ledger period or range of periods to report or leave blank to report all.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

2.4.2.3 Equipment List Report

The Equipment List Report will retrieve general overall information in regards to your equipment.

Select Fleet & Assets > Reports > Equipment List.

Equipment...To - Choose a piece of equipment or range of equipment to report or leave blank to report all.

Status - Choose Active, Inactive or All.

Fleet Codes Matching - To report just equipment in one fleet code, enter that code here. This field accepts
the wildcard feature (*), allowing you combine fleet codes depending on structure or leave the wildcard (*) to
report all.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

2.4.2.4 Scheduled Service Reports

The Scheduled Service Report details all pieces of equipment due in for service and what services are to be
performed.

Select Fleet & Assets > Service Orders > Scheduled Services Report. Then choose either Currently Due or
Date Range.
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Note: The prompts you see will vary slightly depending on which report option you selected. The report by date
range is shown above.

Equipment...To - Choose a piece of equipment or range of equipment to report or leave blank to report all.

Status - Choose Active, Inactive or All.

Fleet Codes Matching - To report just equipment in one fleet code, enter that code here. This field accepts
the wildcard feature (*), allowing you combine fleet codes depending on structure or leave the wildcard (*) to
report all.

Service...To - Choose a service code or range of codes to report or leave blank to report all.

Date...To - Choose a date or date range to report or leave blank to report all.

Hours Remaining...To - Enter a range of hours remaining to restrict only items with limited hours remaining
or leave blank to report all.

Detail or Summary - Choose detail or summary depending on the level of detail you want to see.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

2.4.2.5 Service History Report

The Service History Report allows you the ability to pull up the past services that have been conducted on your
equipment.

Select Fleet & Assets > Service Orders > Service History Report.

Equipment...To - Choose a piece of equipment or range of equipment to report or leave blank to report all.

Date...To - Choose a date or date range to report or leave blank to report all.
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Status - Choose Active, Inactive or All.

Fleet Codes Matching - To report just equipment in one fleet code, enter that code here. This field accepts
the wildcard feature (*), allowing you combine fleet codes depending on structure or leave the wildcard (*) to
report all.

Service...To - Choose a service code or range of codes to report or leave blank to report all.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

2.4.2.6 Open Service Order Report

To view what Service Orders are still open and outstanding you can use the Open Service Order Report.

Select Fleet & Assets > Service Orders > Open Service Order Report.

Service Order...To - Choose a service order or range of orders to report or leave blank to report all.

Service...To - Choose a service code or range of codes to report or leave blank to report all.

Equipment...To - Choose a piece of equipment or range of equipment to report or leave blank to report all.

Show Order Notes - Select Yes if you want to see the order notes displayed on the report.

Send Report To - Select Printer, Display, Email or Clipboard depending on what you would like to do with
this report. If you are printing the report, select the appropriate printer in the next field. Click OK and the
report will print, display or generate an email or a pdf on the clipboard depending on your choice in this field.

2.4.3 Using the Equipment Center

The Equipment Center allows for a quick look at all the detail for a single piece of equipment. From
this screen you can view summary and detail information for this piece of equipment and you have
the ability to update and change information. The information can be viewed or edited by double
clicking on any links in blue.

Select Fleet & Assets > Equipment Center

Equipment - Enter or choose the equipment you want to review.
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Show Equipment Picture - You can show an actual picture of the piece of equipment in the center. To
display the piece of equipment, save the picture as a bitmap file (.bmp). Name the file using the equipment
code as such: (equipcode).bmp. For example, if the equipment’s code is DOZER, you would name the file
"DOZER.bmp". Save this file in the following directory inside the main ComputerEase directory on your server:
DATA/[cmpy]/FILES/EQUIPMENT. Note that "cmpy" is the number to the left of the company name that
appears when you log into ComputerEase.

Cost/Hr vs Fleet - The cost for this piece of equipment for the month, year and overall will be displayed here,
along with comparisons to other equipment in the same fleet code.

Maintenance - Double-click on any of the links to view your Schedules Services Report, access and modify
your Service Schedule or update your Equipment Mileage.

Utilities - Double-click on any of the links to access your Equipment Maintenance, Equipment Cost Detail
Maintenance or Job Entry screens.

Usage - Double-click on any of the usage reports in blue to view that report for this piece of equipment.

Reports - Double-click on any of the cost reports in blue to view that report for this piece of equipment.

You can also click on Management Centers in the upper-right corner to access any of the other Management
Centers to which you have access.



Part

III

Tool & Equipment Tracking Files
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3 Tool & Equipment Tracking Files

ComputerEase Tool & Equipment Tracking is a tracking and billing system for rental of equipment and small
items. Items in inventory and/or equipment in the equipment master file may be designated as available for
racking, which allows them to be tracked in the Tool & Equipment Tracking module.  

Pricing is very flexible. Individual items may be given their own pricing matrix or use a group matrix for similar
items. Each price matrix may be a flat per unit/per day rate, a weekly rate, monthly rate, or a tabled rate for any
time period. Pricing can be overridden for individual items at order entry time, and also at billing. Charges for
miscellaneous services, delivery and pick up, labor, and “buy out” for lost items can be billed on the same invoice
with rental charges. The system also supports minimum charges for groups of items regardless of quantity or time,
and also flat pricing per order.

Exchanges of rented equipment are also tracked. An equipment item may be exchanged at any time on a rental
order for another equipment item of the same class (price code). This allows a defective item to be tracked and
replaced, but the customer will be billed as if it were a continuous rental of a single item at the proper rate for the
period of time. Exchange information is archived to keep track of overall performance of the equipment.

The system produces a detailed rental out (on-rent) ticket form, a return form, exchange form and both detailed
and summary invoices and credits. An individual invoice can be customized by combining and summarizing items,
additional charges and comments. The system also supports sales of ordinary inventory items in combination with
a rental billing. This allows for seamless order entry and billing when a customer rents equipment and also
purchases related supplies along with the job.

Detailed status inquiry and reporting is provided for both inventory items and equipment items. Multiple warehouse
locations are supported. The status report for items shows the quantity on hand in each warehouse and lists all
outstanding rentals, with customer and site information, quantity, and optional due-back date. Equipment status
shows the exact location of a particular piece of equipment. History reports show the billed history of equipment,
exchanges if any, and amounts billed. The Pending report shows outstanding rentals that have not been billed. The
Recurring report shows items that have had at least one interim billing.  

Inventory items used for rental remain as “on hand” inventory until they are disposed via buy out or adjustment. A
buy out is when a rented item is purchased by the customer, either for outright purchase or because it was lost or
destroyed. The rental in and out tracking is done entirely within the Tool & Equipment Tracking Module, so
inventory book value is not affected by the item’s location.

The Tool & Equipment Tracking Module provides many tools to easily obtain the status of an order or item. The
item inquiry screen gives an instant snapshot of an item – how many are on hand and where, how many are on
rent, and how many are available. This may be expanded to show detail by order similar to the status report.
Formatting of the invoice may be done using standard forms or a Microsoft Word document template. Orders can
be browsed with the Order Lookup screen with many filtering options.

The Tool & Equipment Tracking Module is fully integrated with the ComputerEase General Ledger, Accounts
Receivable, Purchasing & Inventory, Equipment Costing, and Job Costing modules.
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3.1 What is the Tool & Equipment Tracking Module?

3.1.1 Other Modules and Tool & Equipment Tracking

ComputerEase is an integrated system. This means the various modules in ComputerEase can "talk" to each
other. The advantages of this are numerous; for example, an invoice is entered one time in the Tool & Equipment
Tracking module and, once posted, will optionally post a receivable into Accounts Receivable and, if applicable, to
the Job Costing and General Ledger modules as well. Essentially, if the first entry is correct, you are guaranteed
that all subsequent postings will be correct.

3.1.2 Features in Tool & Equipment Tracking

The Tool & Equipment Tracking Module offers a separate tracking and billing system for equipment and/or
inventory items. Features include: 

· Optionally utilizes ComputerEase inventory module

· Optionally utilizes ComputerEase equipment module

· Tracking and reporting on rented items – current status and history

· Partial or recurring billing for long term rentals

· Exchange/replacement of equipment items tracked

· Billing for rental charges

· Billing for buyouts of rental items, or lost/damaged rental items

· Billing for sales directly from inventory

· Billing for services, delivery/pick up charges, emergency/after hours, other charges

· Computation of minimum charges

· Multiple pricing methods

· Fully integrated to ComputerEase accounting systems:

· Purchasing & Inventory

· Equipment

· Accounts Receivable

· General Ledger

· Job Costing
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3.1.3 Reports in Tool & Equipment Tracking

The available reports in the Tool & Equipment Tracking module vary depending on whether you have configured
ComputerEase to rent inventory, equipment or both.

* Available only when tracking Equipment Items

** Available only when tracking Inventory Items

· Equipment Status Report · Equipment Status Report by Job*

· Equipment History Report · Equipment Status Report by Other Destination*

· Equipment Exchange Report       · Equipment Transfer Log*

· Recurring Rental Report      · Equipment Billing Preview*

· Pending Rental Invoice Report · Equipment Charges by Job*

· Invoice History Report · Equipment Charges by Other Destination*

· Unposted Batch Invoice Report · Equipment Transfer Report*

· Master Price Table · Retired Equipment Report*

· Rental Item Status Summary/Detail** · Expired G/L Certificates Report

· Inventory Rental Transaction Report** · A/P Expenses by G/L Account

3.2 Getting Started

3.2.1 Destination Maintenance

Destinations are used to track items when they are not rented to a customer or "rented" out on an internal job.
Destinations allow you to track when an item is in an employee's possession, when it is in the repair shop, when it
is in storage, or when it is subject to any other type of use that makes the item unavailable.

Select Tool & Equipment Tracking > Maintenance Programs > Destination Maintenance.

Destination Code - Enter a destination code up to 8 characters.

Description - Enter a description of this "destination" location.
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Type - Choose whether this destination is an Employee, Repair Shop, Storage, or Other location.

Charge - Choose Cost, Price or None to determine how this destination is charged when items are "rented"
out here.

Account - Choose the G/L account to be debited with the item's price or cost when an item is billed to this
destination.

Bar Code - Enter the bar code used to represent this destination if you are using a bar code scanner to track
equipment moves.

3.2.2 Minimum Price Code Maintenance

This option allows you to set minimum pickup and delivery charges for set quantities for your rental items. You are
able to create different minimum tables for different rental items or groups.

Select Tool & Equipment Tracking > Maintenance Programs > Minimum Price Code Maintenance.

Minimum Code - Enter a price code up to 8 characters for this minimum price table.

Description - Enter a description of this table.

Quantity - Enter the maximum quantity for which your first minimum price grouping applies.

P/U Min - Enter a minimum price to charge for orders that are picked up.

Del Min - Enter a minimum price to charge for orders that are delivered.

3.2.3 Price Table Maintenance

This option allows you to create pre-defined pricing tables if numerous items share the same pricing.

Select Tool & Equipment Tracking > Maintenance Programs > Price Table Maintenance.
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Price Code - Enter a code up to 8 characters for this pricing table.

Description – Enter a description for this price table.

Min Code - If applicable, select the minimum price code that applies to items priced using this table. If not,
leave this field empty.

Price Table – Choose Simple if your prices are Daily, Weekly and/or Monthly. Choose Detail to build your
pricing table following the instructions below (under Detail Pricing Table).

Calculation - Choose how you want to bill items when doing recurring billing. 

Each billing starts with day 1 - This method will calculate the price for an item based on how long the
item has been on rent, subtracting any previously billed days. If using detailed pricing, then this method
will always start with the first pricing bracket. If your first pricing bracket is for 30 days, even if an item has
been on rent for 180 days, if you bill every 30 days, the first bracket will always be used.

Price for all days minus calculated price for previous days - This method will calculate the price for
the total days an item has been "on rent", then subtract the price for any days already billed. If using
detailed pricing, then this method will always use the correct pricing bracket according to how many days
the item has been on rent.

Simple Pricing Table

Daily – Enter the daily charge for these items, if applicable.

Weekly – Enter the weekly charge for these items, if applicable.

Monthly - Enter the monthly charge for these items, if applicable.

Detail Pricing Table - For each price level, set the Number of Days the level is good for, the Price, and
check the Flat box if it applies. If you charge an ongoing daily rate after a specific length of time, enter that
rate into the Plus field after your last bracket or price level. Check the Use marginal brackets box if you use
recurring billing depending on how you want your extra days between brackets to bill. If you check this box,
then when you bill all days will be billed according to the bracket in which they fall. If you do not check this
box, all days will be billed according to the bracket in which the last day falls. For example, if your pricing
brackets are different for every 10 days, and you bill at 15 days, then checking this box would result in the
first 10 days being billed at the first rate and the next 5 days being billed at the second rate. Leaving this box
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unchecked will result in all 15 days being billed at the second rate. Marginal brackets do not apply to flat rate
pricing.

3.2.4 Group Code Maintenance

You must set up at least one group. The group code has multiple uses; it is used like departments in other
modules in that can direct postings to the G/L and it is also used like the class field in other modules because it
can be used to filter reports.

Select Tool & Equipment Tracking > Maintenance Programs > Group Code Maintenance.

Group Code - Enter a group code 8 characters or less; the group code is used to group items together for
reporting and can also be used to determine how billings will post to your G/L.

Description - Enter a description for this group of items.

Single Unit Equipment - If you are tracking items from your Inventory Control system, check this box to
identify whether items in this group are to be treated as individual, distinct items. Checking this box
determines whether your Inventory Items appear on the Equipment or Item Reports in this module. If you are
tracking items from your Equipment Costing module, checking this box is not necessary, as all equipment
has an implied quantity of 1.

3.2.5 Location/Group Account Maintenance

One of the options for determining how postings from the Tool & Equipment Tracking module will post to the G/L is
to use the Location/Group Account Maintenance option to define revenue and cost accounts. "Location" here
refers to Inventory Locations.

Select Tool & Equipment Tracking > Maintenance Programs > Location/Group Code Maintenance.

Location - Enter or choose the inventory location for which you want to define revenue and cost accounts for
a group.

Group Code - Enter or choose the group code for which you want to define revenue and cost accounts for
the selected location. Each group code must have G/L accounts defined for revenue, cost and inventory in
sales, rental, buyout and job cost.
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Description - Enter a description for the combination.

Sales - Select the Revenue account to be credited when items in this group are sold out of this location; then
select the Cost account to be debited for the cost of this item when items in this group are sold out of this
location; and finally the inventory account to be credited with the cost of the item when items in this group are
sold out of this location.

Rental - Select the Revenue account to be credited when items in this group are rented out of this location;
then select the Cost account to be debited for the cost of this item when items in this group are rented out of
this location; and finally the inventory account to be credited with the cost of the item when items in this
group are rented out of this location.

Buyout - Select the Revenue account to be credited when items in this group are subject to buyout (due to
loss) out of this location; then select the Cost account to be debited for the cost of this item when items in
this group are subject to buyout (due to loss) out of this location; and finally the inventory account to be
credited with the cost of the item when items in this group are subject to buyout (due to loss) out of this
location.

Rental items are not removed from inventory unless they are sold. When a rental billing is issued, the revenue is
posted to the appropriate revenue account for each item, depending on whether the item is sold directly from
inventory, rented and returned, subject to buyout (a rental item bought or lost), or applied to an internal job. The
cost for each item for rental is defined for each individual item; this may be left zero if this tracking is not desired.

3.2.6 Miscellaneous Charge Maintenance

You have the ability to set standard charges and revenue accounts to be credited for those charges for special
services. These entries are simply defaults that can be overridden for individual orders during the billing process.

Select Tool & Equipment Tracking > Maintenance Programs > Miscellaneous Charge Maintenance.

Freight - Choose the revenue account to be credited when you add freight to a rental billing.

Emergency Charge - Enter your default standard charge for emergency orders and the default revenue
account to be credited when you identify a rental order as an emergency.

After Hours Charge - Enter your default standard charge for after hours orders and the default revenue
account to be credited when you identify a rental order as an after hours order.
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3.2.7 Holiday Maintenance

Holidays are used to prevent charges for items on those days.

Select Tool & Equipment Tracking > Maintenance Programs > Holiday Maintenance.

Date - Enter or choose the date or Lookup a date you have previously defined as a holiday.

Description - Enter a description or name of the holiday.

3.2.8 Inventory Items

Inventory items which are to be available for use in the Tool & Equipment Tracking module must be set up in
Inventory Control under Inventory Maintenance and additional information must be provided on the “Rental
Information” tab of the Inventory Maintenance program.

Select Inventory Control > Maintenance Programs > Inventory Maintenance. 

Then select the Tracking Information Tab.

Inactive - Check this box to prevent the item from being rented or available for rent once it is no longer
available for tracking.

Group Code - Enter the group code for this item.
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Price Code - Select the price code for this item.

Rental Cost/Day - The per unit/per day cost (not the selling price) to be booked to the General Ledger when
this item is rented or tracked. This may be left at zero if you do not want to track costs on this item.

Rental Cost/Week - The per unit/per week cost (not the selling price) to be booked to the General Ledger
when this item is rented or tracked. This may be left at zero if you do not want to track costs on this item.

Rental Cost/Month - The per unit/per month cost (not the selling price) to be booked to the General Ledger
when this item is rented or tracked. This may be left at zero, if you do not want to track costs on this item.

Buyout Cost - Enter the unit cost that would be booked against inventory if the item were sold as a buyout
(see below).

Buyout Sell Price - Enter the per unit price that a customer would be charged for this item if they were to
purchase it, or if it was lost or destroyed.

New/Used - All rental items must be set to Used. If the same item is to be offered both for sale and as a
rental, separate item numbers should be established. When new items are assigned to the rental pool, they
become “used” and must be transferred with the inventory adjustment entry.

Default Choice on Rental - When entering a new rental ticket, frequently rented items may be marked as
defaults to speed entry. Check this box to include the item on the initial rental ticket. This item will
automatically populate all rental orders; if it is not to be used, the quantity can simply be left at 0.

Reminder - Enter an optional short phrase that will "pop up" whenever a rental quantity is entered for this
item. This can be used to serve as a suggestion or reminder when renting out an item if additional related
items are needed. For example when renting out barrels, the reminder might be “Need Lights?” which would
prompt the user to follow up with the additional rental of lights.

3.2.9 Equipment

Equipment items which are to be available for use in the Tool & Equipment Tracking module must be set up in
Equipment Costing under Equipment Maintenance and additional information must be provided on the “Rental
Information” tab of the Equipment Maintenance program.
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Select Equipment Costing > Maintenance Programs > Equipment Maintenance. 

Then select the Tracking Information Tab.

Allow Rental - Check this box to make this equipment available to be tracked.  

Inventory Loc - Depending on your selections in the Rental Parameters, you might select the inventory
location to use for posting your tracking cost to the G/L. 

Home Location - Depending on your selections in the Rental Parameters, you might select the equipment
home location to use for posting your tracking cost to the G/L. 

Group Code - Select the group to which this piece of equipment belongs.

SubGroup Code - Enter an option subgroup description for this item; informational only at this time.

Price By - Choose Code to use a price table or choose Individual to create a unique price table for this
item.

Price Code - The price code table to use, if selected above.

Purchase Cost - Enter the purchase cost for this item.

Buyout/Loss Cost - Enter the cost should this item become lost or no longer available for tracking.

Max Is Per Order - Check this box if the maximum charge for any item is per order rather than for the item
across its lifetime.

Lifetime Max - Enter the maximum to be charged against this item for cost on tracking orders.

Total Charged - Enter the total amount charged to date against the lifetime max.

Override Daily Rate - Check this box to charge a different percentage of lifetime maximum cost than that
found in the Rental Parameters for this item per day.
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Daily Rate % - Enter the percentage of lifetime maximum cost to expense per day for this equipment if
you selected the option to Override Daily Rate.

Rental Cost/Day - Enter a flat daily cost to expense for this item in lieu of using the daily rate %.

Rental Cost/Week - Enter a flat weekly cost to expense for this item in lieu of using the daily rate %.

Rental Cost/Month - Enter a flat monthly cost to expense for this item in lieu of using the daily rate %.

Default Choice on Rental - If selected, this equipment will be displayed as a default choice on each new
tracking ticket created.

Min Code -  If applicable, select the minimum price code that applies to this item. If not, leave this field
empty.

The following fields are used if you selected Individual for Price by

Price Table – Choose Simple if your prices are Daily, Weekly and/or Monthly. Choose Detail to build
your pricing table following the instructions below (under Detail Pricing Table).

Calculation - Choose how you want to bill this item when doing recurring billing. 

Each billing starts with day 1 - This method will calculate the price for an item based on how long the
item has been on rent, subtracting any previously billed days. If using detailed pricing, then this method
will always start with the first pricing bracket. If your first pricing bracket is for 30 days, even if an item
has been on rent for 180 days, if you bill every 30 days, the first bracket will always be used.

Price for all days minus calculated price for previous days - This method will calculate the price for
the total days an item has been "on rent", then subtract the price for any days already billed. If using
detailed pricing, then this method will always use the correct pricing bracket according to how many
days the item has been on rent.

Simple Pricing Table

Daily – Enter the daily charge for this equipment, if applicable.

Weekly – Enter the weekly charge for this equipment, if applicable.

Monthly - Enter the monthly charge for this equipment, if applicable.

Detail Pricing Table - For each price level, set the Number of Days the level is good for, the Price, and
check the Flat box if it applies. If you charge an ongoing daily rate after a specific length of time, enter
that rate into the Plus field after your last bracket or price level. Check the Use marginal brackets box if
you use recurring billing depending on how you want your extra days between brackets to bill. If you check
this box, then when you bill all days will be billed according to the bracket in which they fall. If you do not
check this box, all days will be billed according to the bracket in which the last day falls. For example, if
your pricing brackets are different for every 10 days, and you bill at 15 days, then checking this box would
result in the first 10 days being billed at the first rate and the next 5 days being billed at the second rate.
Leaving this box unchecked will result in all 15 days being billed at the second rate. Marginal brackets do
not apply to flat rate pricing.

Reminder - Additional text you wish to appear when this equipment is entered onto a new rental ticket.

Retired - Check this box if your item is no longer available for rental. This box will automatically be checked
when an item is marked as "Lost" on a rental order.

Reason - Enter the reason for retiring this item from your rental fleet.
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Date - Enter the date this item is retired. This field will automatically be populated when an item is marked as
"Lost" on a rental order.

Last Assign - Enter the option last known assignment for this item. This field will automatically be populated
when an item is marked as "Lost" on a rental order.

Check-In/Repair/Hold - Check this box if the item is unavailable because it is on hold; this requires that the
item be "checked in" prior to becoming available for use in Tool & Equipment Tracking. This field will
automatically be checked when items are returned if you have selected the option to hold items for check-in
in your Rental Parameters.

Status - Enter an option reason that the item is on hold.

3.3 Entering Orders

The Tool & Equipment Tracking order entry screen combines all steps in a rental process into one main screen.
Not only is the order information entered here, but all processes affecting the order can be accomplished from this
screen.

Order Information

Select Tool & Equipment Tracking > Enter a New Rental Order.

Order Number – Depending on your selections in the Rental Parameters, order numbers may be
automatically or manually assigned.

Order Date – Enter the order date.

Contact – Enter the contact person for questions about items on this order.

Site Address – Enter the address where the equipment will be located

Call Back # - Enter the contact number for questions about items on this order.
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Taken By – This field is the individual who has taken this order.

Order Type - Choose Customer for a rental to a customer, Internal/Job for tracking items at a
ComputerEase job site, or Other for tracking items in other destinations.

Customer Number – If your order type is Customer, choose the customer to be billed for this order. The
remaining fields below will automatically populate with information from the customer's master file. Any of
these selections can be changed at this time, but it will affect any invoices on this order.

Destination Code - If your order type is Other, choose the destination for this order. The destination name
will appear below.

Customer PO # - Enter your customer’s purchase order number for this order.

Customer Job # - Enter your customer's job number.

Job – If your order type is either Customer or Internal/Job, choose the cost code for this order; this field is
not required if the order type is Customer.

Credit Card – Enter a 2-character credit card type if this order is secured with a credit card.

Number – Enter the credit card number to be billed for the order.

Expiration – Enter the expiration date of the credit card to be billed for the order.

Card Holder – Enter the name on the credit card to be billed for the order.

Order Status - This field is automatically updated as the ticket flows through the billing process. The Closed
selection can be manually selected if your ComputerEase ID access permits. An order should not be marked 
Closed until all items have been returned.

User Fields Tab

The user fields tab allows you to enter information into the user defined fields for orders that were setup in the
Parameters for Tool & Equipment Tracking. This tab only appears if you have created at least one user field under 
Configure > System Parameters > Tool & Equipment Tracking Parameters.

3.3.1 Rental

To add items to a rental order, click on the Rental... button. Keep in mind that each rental order can have multiple
rental out tickets. You will want to enter one ticket for each date that items are sent out on an order.
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New – Click here to create a new rental out ticket. The entry date and time will default to your system date
and time, and the rental items which are designated as default rental items will appear, if applicable. 

Date Req/Time - This will also default to the current date, but if the rental is to be picked up at a different
date/time, you should change it accordingly. This date is used to calculate the rental charges for billing. The
time does not impact the billing, it is just for information purposes.

Customer Pick-Up, Delivery or Third Party – Choose the delivery method for the items on the order.
Delivery or Third Party allow you to charge a delivery charge.

Call Out After Hrs and Emergency – Select these items if applicable; if you have set charges for these
services under "Miscellaneous Charge Maintenance" charges will apply but may be changed during billing.

Lump Sum Billing – In the case of a contract rental, you may wish to bill the customer a quoted, flat charge
in equal installments. If you know the total amount and the number of installments, you may check this box
and enter this information here.

Factor - For a single lump sum billing, enter 1. If the lump sum is to be billed in multiple installments, enter
the number of installments. If a factor of 4 is entered for instance, each recurring billing will be 1/4 of the lump
sum amount. 

Difference Account – Choose the General Ledger account to post the difference between the lump sum
amount and the actual calculated price of this ticket if applicable.

Locked/Billed - This box is checked if this rental has been billed; the rental ticket will be locked to editing
once it has been billed.

Out – This box must be checked to mark the items as unavailable and out on this order. No billing may be
done unless this box is checked.

Initials – Enter the initials of the individual responsible for managing this ticket.

Reserve Items - Check this box if the items are not required until a future date; the items will show as
reserved and will not be available for rental on other orders.

Print... - Click here to print a rental ticket worksheet.

Notes - Enter additional notes or instructions to be printed on the rental out ticket.
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Your default rental items, if any, will be listed below the Notes. To select from the default items, simply choose the
location and enter the quantity to assign to the order. If you do not enter a quantity, the item will not be assigned
to this order. You may enter additional items by scrolling to the bottom and choosing the item number, location,
and quantity. Items that are to be rented are checked for availability, which is the current quantity on hand less
any outstanding rentals. In the case of equipment items, the quantity available is always 1 or 0. You will see an
error message if no items are available for rent.

Click the down arrow button next to the Quantity to reveal the following special fields:

Override Price - Check this box to override the item price. Enter the price per unit/per day, or check the Flat
box for a flat rate price.

Override Cost - Check this box to override the item cost. Enter the cost per unit/per day, or check the Flat
box for a flat rate cost.

Estimated Return - Enter the estimated return date for the item. If entered, this information will print on
certain reports.

Use the < and > buttons to scroll between multiple rental tickets.

3.3.2 Return

To return items from a rental order, click on the Return... button. Keep in mind that each rental order can have
multiple rental return tickets. You will want to enter one ticket for each date that items are returned from an order.

New – Click here to create a new rental return ticket. The entry date and time will default to your system date
and time, and the rental items which are currently rented out on the order will appear. 

Return Date/Time - This will also default to the current date, but if the item(s) were returned at a different
date/time, you should change it accordingly. This date is used to calculate the rental charges for billing. The
time does not impact the billing, it is just for information purposes.

Customer Pick-Up, Delivery or Third Party – Choose the delivery method for the items on the order.
Delivery or Third Party allow you to charge a delivery charge.



Other Tools122

Deltek+ComputerEase

Final Return - Check this box if this is the final return for this order. After the final billing, the order will be
Closed by the system automatically.

Locked/Billed - This box is checked if this return has been billed; the return ticket will be locked to editing
once it has been billed.

Returned – This box must be checked to mark the items as available and back from this order. No final
billing may be done unless this box is checked.

Initials – Enter the initials of the individual responsible for managing this ticket.

Print... - Click here to print a rental return ticket or worksheet.

Notes - Enter additional notes or instructions to be printed on the rental return ticket.

Your items rented out on the order will be listed below the Notes. Next to each item returned, enter the quantity
returned in the Back field, or if the items were lost or destroyed enter the quantity in the Lost field with an optional
Reason for the buyout/loss. You may use the Return All button to assist you in marking all items returned.

Use the < and > buttons to scroll between multiple rental tickets.

3.3.3 Exchange

The rental program provides a separate entry screen for equipment items which are exchanged for like items at
some point during the rental period. An exchange allows you to bill the customer as though they kept the same
item for the entire period. 

To record an exchange on a rental order, click on the Exchange... button. Keep in mind that each rental order can
have multiple exchange tickets. You will want to enter one ticket for date items are exchanged on an order.

The items to be exchanged must be of the same group code. Since items can be returned, and different items
rented at any point in the duration of a rental period, the exchange screen is not used in that case. It is only for
tracking when an item is defective or, for some other reason, the customer exchanges it for the same type of item.
This logs the reason for the return, which becomes part of an item’s history, and it preserves the continuity of the
rental period for items priced differently over longer periods of time.

Only equipment may be exchanged. The item returned must have been previously rented out on the order. The
replacement item must be the same type and price code.

New – Click here to create a new rental exchange ticket. The entry date and time will default to your system
date and time. 

Exchg Date/Time - This will also default to the current date, but if the item(s) were exchanged at a different
date/time, you should change it accordingly.



Tool & Equipment Tracking Files 123

ComputerEase User Manual

Customer Pick-Up, Delivery or Third Party – Choose the delivery method for the items on the order.
Delivery or Third Party allow you to charge a delivery charge.

Final Return - Check this box if this is the final return for this order. After the final billing, the order will be
Closed by the system automatically.

Locked/Billed - This box is checked if this exchange has been billed; the exchange ticket will be locked to
editing once it has been billed.

Out – This box must be checked to mark the returned item as available and back from this order and the
replacement item as out and unavailable.

Reason – Enter an optional reason for the exchange.

Item Returned/Replaced With - Choose the item returned in exchange for another like item in the first field
and the item sent out to replace it below.

Location - Choose the location to which the item is being returned and from which the new item is being sent
out.

Description - This is the item's description.

Qty - All exchanges have a quantity of 1.

Print... - Click here to print a rental return ticket or worksheet.

Use the < and > buttons to scroll between multiple rental tickets.

3.3.4 Sales

The sale ticket allows inventory items to be sold and billed along with rentals. For example, a customer might
purchase consumable supplies while renting items. The sale screen should not be used when a customer
purchases a rental item due to loss or damage, but only for the purchase of non-rental inventory items in
conjunction with a rental.

To record a sale on a rental order, click on the Sale... button. Keep in mind that each rental order can have
multiple sales tickets. You will want to enter one ticket for each date that items are sold on an order.
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New – Click here to create a new sales ticket. The entry date and time will default to your system date and
time. 

Date Req/Time - This will also default to the current date, but if the sale was completed at a different date/
time, you should change it accordingly.

Customer Pick-Up, Delivery or Third Party – Choose the delivery method for the items sold. Delivery or
Third Party allow you to charge a delivery charge.

Call Out After Hrs and Emergency – Select these items if applicable; if you have set charges for these
services under "Miscellaneous Charge Maintenance" charges will apply but may be changed during billing.

Out – This box must be checked to mark the items as unavailable and sold. No billing may be done unless
this box is checked.

Initials – Enter the initials of the individual responsible for managing this ticket.

Print... - Click here to print a sale ticket worksheet.

Notes - Enter additional notes or instructions to be printed on the rental out ticket.

Below the notes field you will enter the items sold. Enter as many items as you need; one per line.

Item – Enter or choose the item you are selling or leave empty if the item is not from your inventory.

Location – Choose the location from which the item is being sold.

MI –  Check this box if the item is a miscellaneous item, not inventoried.

Description – The description automatically populates if the item is from your inventory; if this is a sale of a
miscellaneous item, enter a description here.

Quantity – Enter the quantity sold.

OV – Check this box to override the price of the item.

Price – This field will contain the price for the listed item.

FL – Check this box if the price is a flat charge and not per-unit.

Sales – Enter or choose the G/L account to be credited with the revenue for this sale.

Use the < and > buttons to scroll between multiple rental tickets.

3.3.5 Billing

To bill a rental order, click on the Billing... button. Keep in mind that each rental order can have multiple billing
tickets. You will want to enter one ticket for each date and type of billing for an order.
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On the billing screen, click New to create a new billing.

Billing Type - Choose the type of billing. 

Final – The final billing may only be completed after all items have been returned and/or accounted for. The
final bill may be the only invoice, or the last of multiple billings.

Recurring - An item can be billed on a recurring basis for long-term rentals. When a recurring (partial) billing
is created, the rental charges are computed from the time of the previous billing, if any, or the rental out
date(s) up until the cutoff date selected for the billing.

Credit - If issuing a credit, choose whether this credit is a Reversal of either None (an independent credit)
or Prior Invoices or Credits.

Misc - Miscellaneous billings are used to bill outside the other three bill types. Normally additional charges
are added to the recurring or final bill, but if a separate billing is necessary this option allows it. Unlike the
Final and Recurring billings, it does not require any outstanding items or final returns, nor does it
automatically compute any charges. It simply provides a “blank slate” from which to bill.

Cutoff Date - Choose the date through which you want to bill the order.

Once you have selected the billing type and cutoff date, you will complete the fields necessary to generate the
invoice.

Order Number - Displays the order number for your information.

Ticket Number - Displays the billing ticket number.

Entry Date/Time - Automatically populated with the system date and time when the billing is entered.

Sales Tax Cd - Choose the sales tax code to apply to customer charges.

Terms - These default to the customer terms but may be changed if necessary.
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Invoice Date – The invoice date for posting and aging.

Rental Period/Through – For recurring or final billings, these dates identify the rental period for which items
are being billed.

Invoice Notes - Enter or select any optional invoice notes to print on the printed copy of the invoice.

Comments – Enter any optional comments for the invoice.

Total – The total of the amount column of all detail lines except “Freight” type, computed automatically.

Freight – The total of all “Freight” detail lines, computed automatically.

Tax – Sales tax, if any, computed automatically. If the customer is flagged as taxable, tax is computed for all
taxable line items.

Payment – Enter any payment the customer has made here.

Due – The invoice total less any payments, computed automatically.

Billing Type – This is shown here but cannot be changed; it must be specified at the time the invoice is
created.

Invoice # - This is assigned automatically when the invoice is printed.

Posted – This flag is checked automatically once the invoice has been posted. Posted invoices can be
reprinted and viewed, but may not be changed.

Printed – This flag is checked automatically once the invoice has been printed to a printer device. Print to
display does not flag it as printed.

Lump Sum - Click here to view or change the lump sum entry made when the order was created.

Summarize - Click here to customize the appearance of the invoice; this is used to include or omit details.
This is especially useful for a lump sum billing when you do not wish to show the detail charges for each
item, but they must still be detailed for posting purposes.

Each line item from your invoice will be listed here. To combine items, highlight the items to combine
and click on Combine. If you need to, you can Undo Combine, Undo All, Edit or Start Over with
your selections here.
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Enter a description for the charge that will appear on the invoice. You can choose whether the detail
will print beneath the combination. Additionally, you can choose how much information (such as
dates) will print on the invoice.

Print - Click here to print the invoice.

The billing detail is in the lower portion of the screen.

Type – Set automatically for line items derived from tickets. Choose one of the following:

Rental – Charge for any item rented.

Sale – Items sold directly from non-rental stock.

Buyout – Items sold from rental stock, usually a charge for lost/damaged items.

Service – Any additional charges not tied to inventory related to labor or services provided, on-site service or
setup, etc, which is to be billed by the unit – quantity, hours, etc.

Misc – Other charges not covered above, may be used to adjust the total invoice up or down, issue a credit
against a previous billing, etc. Misc charges are simple flat amounts (no quantity).

Freight – Pickup and/or delivery charge, or charges billed by a third party carrier.

Item/Account – This field is used for item number for a Rental, Sale, or Buyout type. For all other types, the
G/L account to be credited for revenue must be specified.

Location – Warehouse location must be specified for rental, sale, or buyout items.

MI - Item is a miscellaneous item not in inventory. 

Ex – This is called the “Exchange” flag. It indicates an item that was exchanged for another, and the item will
show on the invoice but all of the charges will record under the replacement item below. This is handled
automatically when a new billing is created that includes an exchange within the billing period.

Description – Description of the item or charge which will appear on the invoice.

Qty – The quantity of the item or service. Quantity can be entered for all types except misc and freight.

Days – For rentals only, the number of days the item was rented. This is computed automatically for a final or
recurring billing. Begin date is either the date the item was rented, or the day after the last recurring billing;
return date is either the date the item was returned, or the cutoff date if the item has not been returned, or has
been returned after the cutoff date. You can click on the ? to view the rental period date range. On an item
that is a replacement for an exchange, it will show the full date range being billed including the exchanged
item.
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Price – The unit price to be extended by the quantity, or by quantity and days for rental items.  Price for
rentals, sales, and buyouts is automatically picked up from the price code table for the specific item.

ov – Check this box to enter a new unit price. Un-checking this box will cause it to change back to the table
price. If the price was previously overridden on the rental entry or sale entry screen, this box will be checked
automatically when the billing is created.

Amount – This is the extended amount of the rental charge. This is computed for rental items based on the
price table matrix, whether it is simple per unit/per day, or one of the other methods.

ov – Check this box to override the amount and enter a specific amount. This also allows you to override the
quantity and/or days.

nt – Check this box if this item is non-taxable. This is not necessary if no sales tax code is used. Use it to
make a specific charge or item non-taxable for a customer that is otherwise taxable.

Click OK once you have finalized and proofed your billing.

Use the < and > buttons to scroll between multiple rental tickets.

3.3.6 List

To view all items for a rental order, click on the List... button.

Each transaction for the order will be displayed here. If you want to view the actual ticket associated with any
transaction, simply highlight the transaction and click on Go To... The associated ticket will open up for review/
edit.

3.4 Equipment Transfer

The Equipment Transfer program allows you to transfer items from one order to another or back to your rental pool
without editing your existing order to create a return ticket and/or creating or editing another order to enter a rental
ticket. This program creates the relevant tickets for you, consolidating multiple steps into one.

Select Tool & Equipment Tracking > Equipment Transfer.
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Transfer by Item - Check this box to transfer one item at a time rather than multiple items.

From Order Number - If transferring multiple items, choose the existing order on which the items are
currently rented out.

Item Number - If transferring by item, choose the item to transfer.

Location - If transferring by item, the item's location.

Return Date - The date to mark the item returned from the existing order.

Order Type - Informational display only; this is the order type if transferring by order.

From Cost Code - Informational display only; this is the cost code if transferring by "Internal/Job" order type.

Destination - Informational display only; this is the destination if transferring by "Other" order type.

Transfer To - Choose New Order, Existing Order or Return to Home depending on what you want to do
with the item(s).

Hold for Check-In - Check this box to hold the item(s) for check-in if returning home.

To Order Number - If transferring to an existing order, choose the order to which to transfer the item(s).

Out Date - Enter the date as of which to mark the item(s) out on the new order.

Initials - Enter your initials for the rental tickets that will be created.

Order Type - If you choose to transfer to a new order, choose the order type; otherwise this is informational
only and will display the order type of the existing order to which you are transferring your item(s).

To Cost Code - If you choose to transfer to a new Internal/Job order, choose the cost code; otherwise this is
informational only and will display the cost code for the existing order to which you are transferring your
item(s).

Destination - If you choose to transfer to a new Other type order, choose the destination; otherwise this is
informational only and will display the destination for the existing order to which you are transferring your
item(s).
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Notes - Enter any optional notes about the transfer; these notes will be posted to any rental/return tickets
created as a result of the transfer.

Once you have made your selections, the item(s) that meet the criteria listed above will be displayed below. You
will see the Item number, Location, Description and Available Qty; simply enter the quantity of each item to
transfer and click Transfer. You may use the All or None buttons above the item list to choose to transfer all of
none of the items listed. Once this step is complete, new tickets will have been created on any orders affected.

3.5 Batch Equipment Transfer

The Batch Equipment Transfer program allows you to transfer items in batches from one order to another or back
to your rental pool without editing your existing order to create a return ticket and/or creating or editing another
order to enter a rental ticket. This program creates the relevant tickets for you for each and every transaction you
enter, consolidating multiple steps into one, allowing for the simplest entry when you have multiple transactions.

Select Tool & Equipment Tracking > Batch Equipment Transfer.

Item - Choose the item you are transferring; this program allows for both equipment and inventory item
transfers.

Location - Choose the location to use for the transfer.

Find - Click this button to find the item(s); for inventory items you will see a display of all available quantities
of the item and where each of those is located to assist you with the transfer.

Order - Enter the order from which you want to transfer the item, if you are transferring the item from an
existing order. If not, leave this field empty.

Type - The order type of the order you chose in the previous field will populate here.

Cust/Job/Dest - The customer/job/destination of the order you chose previously will populate here, if
applicable.

Quantity - The quantity of the item available to transfer will populate here.

Date - Enter the date you want to transfer the item; this defaults to the login date.
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Notes - Click here to enter any notes; any notes you enter here will populate the notes on the rental return
and transfer tickets that are created.

To - Check this box if you are transferring the item(s) to a new order. If you are transferring them to an
existing order leave this box unchecked.

Order - Choose the order you are transferring the item(s) to if you are transferring them to an existing order.

Type - Choose the order type if you are transferring the item(s) to a new order or Warehouse if you are
returning the item(s) to the warehouse. If you chose an order in the previous field, this field will populate for
you and you will not be able to edit it.

Cust/Job/Dest - Choose the Customer, job or destination for the new order you are creating if you are
transferring the item(s) to a new order. If you chose an order previously, this field will populate for you and you
will not be able to edit it.

Quantity - Choose the quantity you want to transfer to this order. The quantity must be less than or equal to
the quantity available on the row above and greater than 0.

Date - Choose the date you want to transfer the items to the new order.

Hold - Check this box if you want to hold items being transferred back into the warehouse for check-in.

Once you have completed a section of two rows representing one transaction, continue to enter additional
transactions until you have entered all transfers. When you are finished, select Post. You will be prompted to enter
your initials, which will be used to create any rental out and rental return tickets.  An equipment transfer log will be
printed and your transfers will be complete. If you need to edit any of the transactions you posted, you can do so
by editing the individual orders and editing the appropriate rental out or rental return tickets that were created as a
result of the transactions posted here.

3.6 Order Lookup

This option allows you to search for rental orders using a variety of search options.

Select Tool & Equipment Tracking > Rental Order Lookup.

Open/Unbilled – Search for open orders that have not been billed.

Pending from Prior - Search for orders with billings pending.

Partial Billed – Search for open orders that have been billed at least once.

Closed – Search for closed orders that have been final billed.

Rental – Search for orders which have at least one rental ticket.

Sales – Search for orders which have at least one sales ticket.
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Service - Search for orders with at least one service billing.

All Orders – Check this box to search all orders.

Customer – Filter orders by customer.

Job – Filter orders by job or cost code.

Entry Date – Filter orders based on order entry date.

Out Date – Filter orders based on item rental out date.

Return Date – Filter orders based on item return date.

Once you have made your selections, click on the Search button to search for orders matching your selections.
For each matching order, you will see the following informational fields displayed:

Order – The order number.

Date – The order entry date.

Job – If applicable, the ComputerEase job associated with the order.

Customer – If applicable, the customer associated with the order.

Site Location – The site description for the order.

Type – The type of order, either R for rental or S for sales or RS for a combination order.

Status - The order status; either Pending, Partial Billed, Final Billed or Closed.

Billed – Total billed to date for the order.

Pending – Any pending unbilled charges to date.

Select the Go button to take you to the order main screen for any order on the display.

3.7 Item Inquiry

This option allows you to view the current status and location of any rental item.

Select Tool & Equipment Tracking > Rental Item Inquiry.

Item - Enter or choose the item whose status you want to review.

Location/Home Location - Select the inventory location or equipment home location for which you want to
review available quantities; if location is not specified then all locations will be shown.
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The quantities displayed are as follows:

Available - The quantity of this item currently available for rent. For equipment, this will be 0 or 1.

Check-In - The quantity of this item on hold and unavailable for rent until it is checked in.

On Rent - The quantity currently out on rental orders.

Reserved - Quantity reserved for future rentals but not yet marked out.

In entry - Quantity requested in new orders that is neither marked out nor reserved.

Lost - Items that have been marked lost but not yet billed as a buyout.

Total - Total of the fields above; for equipment this should always be 1, for inventory this should match the
inventory on hand quantity.

Click on Show Detail to show all outstanding rental transactions for the item, or Hide Detail to go back to the
summary view.

3.8 Bill Multiple Orders

This option allows you to bill multiple Rental orders at once, rather than having to edit and bill each order
individually.

Select Tool & Equipment Tracking > Bill Multiple Rental Orders.

Billing Type – Select Final or Recurring depending on the types of billing you would like to do.

Order Type - Select Customer, Internal/Job or Other depending on what order types you want to bill.

Sort By - Choose to sort your orders by Order number, Job number or Customer name.

Cutoff Date – Enter the cutoff date for your billing.

Invoice Date – Enter the invoice date for your billing.

Skip Orders Billed After – Enter a date after which orders with billings will be skipped.

Customer – Filter orders by customer.

Job – Filter orders by job or cost code.

Once you have made your selections, click on the Search button to search for orders matching your selections.
For each matching order, you will see the following informational fields displayed:

Order – The order number.

Date – The order entry date.
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Job – If applicable, the ComputerEase job associated with the order.

Customer/Destination – If applicable, the customer or destination associated with the order.

Site Location – The site description for the order.

Type – The type of order, either R for rental or S for sales or RS for a combination order.

Status - The order status; either Pending or Partial Billed.

Last Bill Date – Last date the order was billed.

Prev. Billed – Total billed to date for the order.

Amount to Bill - Amount that will be billed using the criteria entered above.

Check the Sel box next to each order you would like to bill or use the Select All or Select None buttons to
assist you in making selections. You can click on the Edit button next to an order to take you to the order main
screen for any order on the display.

Once you click Save the invoices will be created for the orders you have selected to bill. You may now print and/or
post those invoices.

3.9 Print Multiple Invoices

This option allows you to print multiple Rental Invoices at once; it is similar to the Print Multiple Freeform Invoice
option in Accounts Receivable.

Select Tool & Equipment Tracking > Print Multiple Rental Invoices.

Initially, you will see all unposted rental invoices listed here for selection. Use the filters to expand the selection or
to restrict the selection. 

Billing Type – Select Final or Recurring depending on the types of billing you would like to do.

Order Type - Select Customer, Internal/Job or Other depending on what order types you want to bill.

Cutoff Date – Enter the cutoff date for your billing.

Invoice Date – Enter the invoice date to assign to your invoices.

Skip Orders Billed After – Enter a date after which orders with billings will be skipped.

Customer – Filter orders by customer.

Job – Filter orders by job or cost code.
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Once you have made selections in any or all of the filters, click on Reload to apply the filters and see your list of
invoices. For each matching order, you will see the following informational fields displayed:

Customer – If applicable, the customer associated with the order.

Invoice - The invoice number, or Internal if no customer is to be billed. 

Order – The order number.

Ticket - The billing ticket number associated with the invoice.

Date – The invoice date.

Amount - The amount of the invoice.

Status - POSTED if invoice has been posted, otherwise blank.

Check the Print box next to each invoice you would like to print or use the Select All or Select None buttons to
check or uncheck the box for all invoices.

3.10 Post Multiple Invoices

This option allows you to post multiple Rental Invoices at once; it is similar to the Post Multiple Freeform Invoice
option in Accounts Receivable. Posting the invoices here will post them to your Accounts Receivable aging, if
applicable, and allow them to post to the General Ledger with your next batch posting of invoices from Accounts
Receivable.

Select Tool & Equipment Tracking > Post Multiple Rental Invoices.

G/L Period - Select "Automatic" to post each invoice into the General Ledger period that corresponds to the
invoice date or "Manual" to select the General Ledger period into which all invoices will be posted.

Batch - If you used the option to bill multiple orders at once, select the batch you want to post.

Find the invoice(s) you want to post. To help you identify the invoices, the Customer, Invoice, Order, Ticket, Date
and Amount are all displayed here.

Post - To the right of each invoice, uncheck the invoices that you do not want to post at this time; leave
checked any invoices you do want to post.

Select All - Click here to select all invoices to post.

Unselect All - Click here to uncheck all invoices so that you can individually select which invoices to post.

Once you click OK your invoices will be posted to Accounts Receivable and cannot be edited or deleted.
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3.11 Change Invoice Type

Occasionally you may find it necessary to change the billing type for an invoice; for instance, you might have
selected "Recurring" as the invoice type when it was in fact the "Final" invoice for that order. This function allows
you to change the invoice type without crediting and reposting any billings. This option should only be used to
correct a billing issued under the wrong type.

Select Tool & Equipment Tracking > Change Invoice Type.

Order – Enter or choose the rental order for which the billing in question was posted.

Billing Ticket # - Enter or choose the billing ticket # corresponding to the invoice you want to change.

Billing Type – This will display the current type for the invoice selected.

Change To – Choose the invoice type you want to assign to the invoice in question.

Click on Change to complete the change.

3.12 Equipment Check-In

If you have selected the option in your Rental Parameters to require returned items to be checked in, use this
option to remove items from hold after they have been checked in.

Select Tool & Equipment Tracking > Equipment Check-In.

All items on hold will be listed for check-in. Uncheck the Hold box next to any item that has been checked in to
make it available for new orders or use the Hold All or Free All buttons to assist you in making your selections.
Once you have selected all items to be returned to available status, click on the Update button.
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4 CRM

The CRM (Customer Relationship Management) module is fully integrated with the rest of ComputerEase and
includes all of the features that you need to manage your customers, create leads, and win jobs. The CRM module
makes it easy to set up and track companies, contacts, and opportunities throughout the sales process. Once
your prospects become customers they will already be entered in the system thanks to the module's full
integration with the rest of ComputerEase.

4.1 Features in CRM

The CRM module contains several features that you will use to manage your customers and keep track of where
you are in the sales process. Some of these features are:

· Creating and Editing Companies. This allows you to enter and organize all of your customers and prospects.

· Creating and Editing Contacts. This allows you to enter and track all of your contacts within companies.

· Creating and Editing Opportunities. This allows you to enter and monitor your sales opportunities. 

· Search Center provides a convenient way to search for companies, contacts, opportunities, and tasks. 

· Sales Center makes it easy to see where you are with your sales opportunities. 

· Adding and Editing Tasks. This allows you to create and assign tasks to users and then notify them through
email and Outlook calendars. 

4.2 Maintenance Programs

4.2.1 User Settings Maintenance

Before you begin using CRM, you will want to ensure that your CRM users are set up correctly in order to
effectively use all of the available features.

Select CRM > Maintenance Programs > User Settings Maintenance.

User - Enter or choose the ComputerEase user and then click Edit.
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First Name - Enter the user's first name.

Last Name - Enter the user's last name.

Address - Enter the user's address.

City/St/Zip - Enter the user's city, state, and zip code.

Phone - Enter the user's primary phone number and Ext.

Other Phone - Enter the user's secondary phone number and Ext. if needed.

Email - Enter the user's email address. If you chose to enable Auto Email Notifications, this is the email
address where the notifications will be sent for this user.

Group - Select the user group. Groups are configured using User Group Maintenance.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.

4.2.2 Business Type Maintenance

Business Type Maintenance allows you to track customers and prospects by grouping them by business type.

Select CRM > Maintenance Programs > Business Type Maintenance.

Business Type - Enter or choose the Business Type and click Edit.

Description - Enter a description of the Business Type.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.
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4.2.3 Product Maintenance

Product Maintenance allows you to set up sales goals for your company. These goals can be set for the company
as a whole, or for specific product/service lines or users. Once you set your goals you will be able to use the
reporting features to track how your sales team is performing.

Select CRM > Maintenance Programs > Product Maintenance.

Product - Enter or choose the Product and click Edit.

Main Tab
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Description – Type in the description of the department or product/service for which this goal will be set.

Business Types - Type in the business types of the department or product/service. Business types can also
be selected on the Business Types tab.

Year - Type in the year for which you are setting the goal.

Company Goal - In this column, enter the sales goal for each month for the company. The Total will populate
as you enter your monthly goals. The User Totals and Difference columns will populate when you fill in the
Goals by User tab.

Set Company Goals to User Totals - Clicking this button will set the Company Goals column to display
the User Totals. 

Business Types Tab
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Business Types - Select the business types of the department or product/service. These selected business
types will display in the Business Types field on the Main tab. The items available on this tab are set through
Business Type Maintenance. 

Goal by User Tab

Year - Enter the year for which you are setting the goals.

Users Table - This table will be automatically populated with all of your CRM users, therefore the User and
Name columns will not be editable. For each user there is a field to enter their sales goal for each month of
the year. The Total column will automatically populate as you enter the monthly sales goals. The total goals
for all users will display in the User Totals column on the Main tab.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.



CRM 143

ComputerEase User Manual

4.2.4 Title Maintenance

Title Maintenance allows you to build a list of job titles for contacts with whom you will be working. You will then
be able to select the titles that you set up here when you are entering a new contact.

Select CRM > Maintenance Programs > Title Maintenance.

Title - Enter or choose the title and click Edit.

Description - Enter a description of the title.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.

4.2.5 Position Maintenance

Position Maintenance allows you to build relationships for a job. These relationships may not be the ultimate
decision maker, but they may have a direct influence on whether or not you win a job. Once you build your list of
positions, you can assign companies or contacts to a position for an opportunity. 

Select CRM > Maintenance Programs > Position Maintenance.

Position - Enter or choose the position and click Edit.

Description - Enter a description of the position.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.
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4.2.6 Lead Source Maintenance

Lead Source Maintenance allows you to build a list of lead sources so that you can track where your leads are
coming from. You will then be able to select these lead sources when you are entering a new opportunity. 

Select CRM > Maintenance Programs > Lead Source Maintenance.

Lead Source - Enter or choose the lead source and click Edit.

Description - Enter a description of the lead source.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.

4.2.7 Opportunity Status Maintenance

Opportunity Status Maintenance allows you to create a sequence for your sales process. You will then be able to
select from the statues that you set up here when you are entering or updating an opportunity.

Select CRM > Maintenance Programs > Opportunity Status Maintenance.

Opportunity Status - Enter or choose the opportunity status and click Edit.

Description - Enter a description of the opportunity status.

Sequence - Enter the sequence number for the opportunity status. You may want to leave space between
your sequence numbers in case you want to add new opportunity statuses in the future.

Is Closed - Select this checkbox if this particular opportunity status is the final status in your sales process.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.
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4.2.8 Task Type Maintenance

Task Type Maintenance allows you to build a list of task types. You will then be able to select from these task
types when you add or edit a task.

Select CRM > Maintenance Programs > Task Type Maintenance.

Task Type - Enter or choose the task type and click Edit.

Description - Enter a description of the task type.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.
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4.2.9 Change Ownership

Change Ownership allows you to easily reassign companies, contacts, opportunities, and tasks to a different user.
This allows you to quickly reassign these items if, for instance, you have an employee leave your company or
move to a different position.

Select CRM > Maintenance Programs > Change Ownership.

Owner - Enter or choose the current owner of the companies, contacts, opportunities, or tasks that you want
to reassign and click Edit.
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Owner - The current owner of the companies, contacts, opportunities, or tasks. This field is not editable.

New Owner - Enter or choose the user to whom you want to reassign the companies, contacts,
opportunities, or tasks.

Companies - Select this checkbox to display companies assigned to the current owner.

Contacts - Select this checkbox to display contacts assigned to the current owner.

Opportunities - Select this checkbox to display opportunities assigned to the current owner.

Tasks - Select this checkbox to display tasks assigned to the current owner.

Type - For each item, this column will contain either Company, Contact, Opportunity, or Task.

ID - This column contains the unique ID number assigned to the item.

Description - The column contains a description of the item.

Each item can be selected individually in the grid using the checkboxes or you can use the Select All or
Unselect All buttons. Once you have selected the items to reassign, press Change to assign the items to the
new owner or Cancel to leave the screen without saving your changes.

4.2.10 User Group Maintenance

User Group Maintenance allows you to create a way to group multiple users across your company. These groups
can then be used to track performance as a group instead of by an individual. Users are assigned to these groups
in User Settings Maintenance.

Select CRM > Maintenance Programs > User Group Maintenance.

Group - Enter or choose the group and click Edit.

Description - Enter a description of the group.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.



Other Tools148

Deltek+ComputerEase

4.2.11 Import CRM Companies

Import CRM Companies allows you to import companies from an Excel spreadsheet into the system.

Select CRM > Maintenance Programs > Import CRM Companies.

Import From - Enter or choose the location of your Excel spreadsheet containing the companies that you
want to import.

Use Layout - Enter or choose the layout that you want to use to import your companies. 

When you are finished, press Import to import your data, Preview to view your data, or Cancel to leave the
screen without saving your changes.

4.2.12 Import CRM Contacts

Import CRM Contacts allows you to import contacts from an Excel spreadsheet into the system.

Select CRM > Maintenance Programs > Import CRM Contacts.

Import From - Enter or choose the location of your Excel spreadsheet containing the contacts that you want
to import.

Use Layout - Enter or choose the layout that you want to use to import your contacts. 

When you are finished, press Import to import your data, Preview to view your data, or Cancel to leave the
screen without saving your changes.
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4.2.13 Merge Companies or Contacts

Merge Companies or Contacts allows you to search for and merge duplicate records. 

Select CRM > Maintenance Programs > Merge Companies or Contacts.

Search for Duplicates - Select to search for either duplicate Companies or Contacts.

Match On - Select to match the duplicate companies or contacts based on Name, Phone, or Email.

Click Search to display the list of duplicate companies or contacts based on your selected search criteria.
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Merge From - Left click on the company or contact in the list or enter or choose the company/contact
number that you want to merge from.

Delete After Merging - Select this checkbox if you want the company or contact selected to merge from to
be deleted after the merge.

Merge Into - Right click on the company or contact in the list or enter or choose the company/contact
number that you want to merge into.

Press Merge to merge the selected companies or contacts or Cancel to leave the screen without merging.

4.2.14 Tag Maintenance

Tag Maintenance allows you to create tags that can be assigned to companies, contacts, or opportunities. You
can use these tags to search in the Search Center.

Select CRM > Maintenance Programs > Tag Maintenance.

Tag - Enter or choose the tag and click Edit.

Description - Enter a description of the tag.

When you are finished, press OK to save your changes or Cancel to leave the screen without saving your
changes.

4.3 CRM Companies, Contacts, & Opportunities

4.3.1 How Do I Set Up Companies in ComputerEase?

Select CRM > Create/Edit A Company.

Company - Enter or choose the company number and click Edit to edit an existing company. Leave blank
and click New to add a new company when auto-numbering companies; when manually assigning company
number, enter the number you want to assign to your company and click Edit. Then choose Yes when
prompted to Create a new company.
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Main Tab
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Status - The system defaults to Active, but you may also select Inactive. Active means the company is
currently in use and Inactive will hold the entry for possible future reference.

Type - Choose the type of customer that you are adding. The available options are:

Prospect - The system defaults to Prospect. Choose this option if the company you are entering is a
potential customer or sales lead.

Customer - Selecting this option will allow you to either select a customer that already exists in the
Accounts Receivable module or add this customer to the Accounts Receivable module in addition to the
CRM module. 

Vendor - Selecting this option will allow you to either select a vendor that already exists in the Accounts
Payable module or add this vendor to the Accounts Payable module in addition to the CRM module.

Internal - Choose this option if you are adding an internal company.

Other - Choose this option if the company you are adding does meet the criteria for any other selections.

Customer - When Customer is selected for Type, this field becomes active and you can either enter or
choose a customer that exists in Accounts Receivable or you can click Create Customer to add the
customer to the Accounts Receivable module as well as the CRM module. 

Vendor - When Vendor is selected for Type, this field becomes active and you can either enter or choose a
vendor that exists in Accounts Payable or you can click Create Vendor to add the vendor to the Accounts
Payable module as well as the CRM module. 

Name - Type in the name of the company.

Address - Enter the company's address.

City - Enter the company's city.

State - Enter the company's two character state postal abbreviation.

Zip - Enter the company's zip code.

Phone - Enter the company's phone number.

Fax - Enter the company's fax number.

Cell - Enter the company's cell phone number.

Other Phone - Enter an additional phone number for the company and a description. 

Email - Enter the company's email address. If you select the stamped envelope icon after information is
entered in this field, ComputerEase will open a new email message to this address.

Web - Enter the company's website address. If you select the arrow icon after information is entered in this
field, ComputerEase will open this website in a browser window.

Entered By - Enter or choose the user that entered this company. This field defaults to the logged in user.

Owner - Enter or choose the owner of this company. This field defaults to the logged in user.

DUNS Number - Enter the company's DUNS number.

SIC Code - Enter the company's SIC code.
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Business Types - Business Types that are selected on the Business Types tab will be displayed here.

Tags - Tags that are selected on the Tags tab will be displayed here.

Contacts Tab

Contacts that have been added to this company will be displayed on this tab. Contacts can either be added from
the Contacts tab or from Create/Edit A Contact.  Click Add to create a new contact or Edit to edit an existing
contact. Setting up contacts will be discussed in further detail in the How Do I Set Up Contacts? section.
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Opportunities Tab

Opportunities that have been added to this company will be displayed on this tab. Opportunities can either be
added from the Opportunities tab or from Create/Edit An Opportunity. Click Add to create a new opportunity or
Edit to edit an existing opportunity. Setting up opportunities will be discussed in further detail in the the How Do I
Set Up Opportunities? section.

Sites Tab
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Sites that have been added to this company will be displayed on this tab.  Click Add to create a new site or Edit
to edit an existing site. Sites added here will also be added to the Service Management module.

Business Types Tab

Select the company's business type(s). The business types selected on this tab will appear in the Business
Types field on the Main tab. The Business Types that display on this tab are created in Business Type
Maintenance.
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Tags Tab

Select the tags that you would like to use to track the company. The tags selected on this tab will appear in the 
Tags field on the Main tab. The tags that display on this tab are created in Tag Maintenance. 

Tasks Tab
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Tasks that have been added to this company will be displayed on this tab. Tasks can either be added from the
Tasks tab or from the Tasks menu. Click Add to create a new task or Edit to edit an existing task. Setting up
tasks will be discussed in further detail in the the How Do I Set Up Tasks? section.

History Tab

Tasks for this company that have been marked as completed will be displayed on this tab. Once a task has been
completed it will be moved from the Tasks tab to the History tab. Click Add to create a new task or Edit to edit an
existing task. Setting up tasks will be discussed in further detail in the How Do I Set Up Tasks? section.
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Notes Tab

This tab allows you to enter any notes you may want to track concerning this customer.

User Fields Tab

The user fields tab allows you to enter information into the user-defined fields for companies that were setup in the
Parameters for CRM. This tab only appears if you have created at least one user field under Configure > System
Parameters > CRM Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the company file. This tab only appears if you have created at least one CRM attachment folder under 
Configure > System Parameters > CRM Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or Cancel to exit the screen without saving your changes.
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4.3.2 How Do I Set Up Contacts in ComputerEase?

Select CRM > Create/Edit A Contact.

Contact - Enter or choose the contact number and click Edit to edit an existing contact. Leave blank and
click New to add a new contact.

Contacts can also be added and edited from the Contacts tab of Create/Edit A Company.

Main Tab
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Status - The system defaults to Active, but you may also select Inactive. Active means the contact is
currently in use and Inactive will hold the entry for possible future reference.

Employee - Select this option if the contact is an internal employee of your company.

Employee ID - This field will only be active if the Employee checkbox is selected. Enter or choose the
Employee ID. Selecting Sync Employee Info will sync the employee information in the CRM module with the
employee information in the Payroll module. 

First Name - Enter the contact's first name.

Last Name - Enter the contact's last name.

Sync With PM - Select this option if you want to sync this contact with an existing contact in the Project
Management module. If you are adding a new contact, the contact will be added to the Project Management
module as well as the CRM module.

PM Contact - This field will only be active if the Sync With PM checkbox is selected. Enter or choose the
Project Management contact. You can also click Find to search for the contact information stored in the
Project Management module. Select the New checkbox if this a new contact that you would like to add to the
Project Management module.

PM Type - This field will also only be active if the Sync With PM checkbox is selected. Enter or choose the
Project Management contact type.

Title - Enter or choose the contact's title. The titles that are available here are set up in Title Maintenance. 

Company - Enter or choose the contact's company. Selecting a company that has been set up in the CRM
module will add this contact to the Contacts tab of Create/Edit A Company for that company.

Use Co. Addr - Select this option if you want to populate the address and phone fields with the information
contained in the company record.

Address - Enter the contact's address.

City - Enter the contact's city.

State - Enter the contact's two character state postal abbreviation.

Zip - Enter the contact's zip code.

Phone - Enter the contact's phone number.

Fax - Enter the contact's fax number.

Cell - Enter the contact's cell phone number.

Other Phone - Enter an additional phone number for the contact and a description. 

Email - Enter the contact's email address. If you select the stamped envelope icon after information is entered
in this field, ComputerEase will open a new email message to this address.

Web - Enter the contact's website address. If you select the arrow icon after information is entered in this
field, ComputerEase will open this website in a browser window.

Facebook - Enter the address to the contact's Facebook profile.

Twitter - Enter the address to the contact's Twitter profile.
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LinkedIn - Enter the address to the contact's LinkedIn profile.

Entered By - Enter or choose the user that entered this contact. This field defaults to the logged in user.

Owner - Enter or choose the owner of this contact. This field defaults to the logged in user.

Business Types - Business Types that are selected on the Business Types tab will by displayed here.

Tags - Tags that are selected on the Tags tab will be displayed here.

Opportunities Tab

Opportunities that have been added to this contact will be displayed on this tab. Opportunities can either be added
from the Opportunities tab or from Create/Edit An Opportunity. Click Add to create a new opportunity or Edit to
edit an existing opportunity. Setting up opportunities will be discussed in further detail in the the How Do I Set Up
Opportunities? section.
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Business Types Tab

Select the contact's business type(s). The business types selected on this tab will appear in the Business Types
field on the Main tab. The Business Types that display on this tab are created in Business Type Maintenance.
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Tags Tab

Select the tags that you would like to use to track the contact. The tags selected on this tab will appear in the 
Tags field on the Main tab. The Tags that display on this tab are created in Tag Maintenance. 
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Tasks Tab

Tasks that have been added to this contact will be displayed on this tab. Tasks can either be added from the
Tasks tab or from the Tasks menu. Click Add to create a new task or Edit to edit an existing task. Setting up
tasks will be discussed in further detail in the the How Do I Set Up Tasks? section.
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History Tab

Tasks for this contact that have been marked as completed will be displayed on this tab. Once a task has been
completed it will be moved from the Tasks tab to the History tab. Click Add to create a new task or Edit to edit an
existing task. Setting up tasks will be discussed in further detail in the How Do I Set Up Tasks? section.
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Notes Tab

This tab allows you to enter any notes you may want to track concerning this contact.

User Fields Tab

The user fields tab allows you to enter information into the user-defined fields for contacts that were setup in the
Parameters for CRM. This tab only appears if you have created at least one user field under Configure > System
Parameters > CRM Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the contact file. This tab only appears if you have created at least one CRM attachment folder under 
Configure > System Parameters > CRM Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or Cancel to exit the screen without saving your changes. 
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4.3.3 How Do I Set Up Opportunities in ComputerEase?

Select CRM > Create/Edit An Opportunity.

Opportunity - Enter or choose the opportunity number and click Edit to edit an existing opportunity. Leave
blank and click New to add a new opportunity.

Opportunities can also be added and edited from the Opportunities tab of Create/Edit A Company and Create/
Edit A Contact.

Main Tab
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Status - Enter or choose the status of the opportunity. The statuses that are available here are set up in
Opportunity Status Maintenance. 

Company - Enter or choose the company that the opportunity is for. Selecting a company that has been set
up in the CRM module will add this opportunity to the Opportunities tab of Create/Edit A Company.

Contact - Enter or choose the contact that the opportunity is for. Selecting a contact that has been set up in
the CRM module will add this opportunity to the Opportunities tab of Create/Edit A Contact.

Lead Source - Enter of choose the lead source. The lead sources that are available here are set up in Lead
Source Maintenance. 

Lead Source Notes - Enter any notes you may have about the lead source.

Job - Enter or choose the job that the opportunity is for. Once you select a job, you may click the Edit Job
button to edit the job in the Job Costing module. You can also click the New Job button to add a new job for
the opportunity and to create the job in the Job Costing module at the same time. Clicking Duplicate Job will
allow you to copy an existing job to a new job.

Site - Enter or choose the site that the opportunity is for. Once you select a site, you may click the Edit Site
button to edit the site in the Service Management module. You can also click the New Site button to add a
new site for the opportunity and create the site in the Service Management module at the same time.

Quote Number - Enter or choose the quote number that the opportunity is for. Once you select a quote
number, you may click the Edit Quote button to edit the quote in the Service Management module. You can
also click the New Quote button to add a new quote for the opportunity and create the quote in the Service
Management module at the same time.

Work Order - Enter or choose the work order that the opportunity is for. Once you select a work order, you
may click the Edit WO button to edit the work order in the Service Management module. You can also click
the New WO button to add a new work order for the opportunity and create the work order in the Service
Management module at the same time.

Lead Date - Enter or select the date that the lead was received. This field default to the current date.

Entered By - Enter or choose the user that entered this opportunity. This field defaults to the logged in user.

Owner - Enter or choose the owner of this opportunity. This field defaults to the logged in user.

Target Move Date - Enter or choose the date targeted to move the opportunity to the next opportunity status.

Est Close Date - Enter or choose the date estimated to close the opportunity.

Actual Close Date - Enter or choose the date the opportunity was actually closed.

Estimated Amt and Cost - Enter the estimated sales amount and cost.

Actual Amt and Cost - Enter the actual sales amount and cost.

Description - Enter a description of the opportunity.

Tags - Tags that are selected on the Tags tab will be displayed here.

Products - Products that are selected on the Products tab will be displayed here.

 - Use the new item icon to create new CRM companies and contacts, jobs, quotes and work orders on the
fly.
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Tags Tab

Select the tags that you would like to use to track the opportunity. The tags selected on this tab will appear in the 
Tags field on the Main tab. The tags that display on this tab are created in Tag Maintenance. 
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Products Tab

Select the products that the opportunity is for. The products selected on this tab will appear in the Products field
on the Main tab. The products that display on this tab are created in Product Maintenance.

Relationships Tab
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Relationships can be added, edited, or deleted from an opportunity on this tab. To add a new relationship, click
the Add button. This will open the Assign Relationship screen:

Position - Enter or choose the position of the person that the relationship is with. The positions that are
available here are set up in Position Maintenance. 

Description - This field will automatically populate with a description of the selected position.

Type - Choose the type of relationship that you are adding. The options are User, Company, or Contact.

ID - Enter or choose the ID of the user, company, or contact that the relationship is with.

Name - This field will automatically populate with the name corresponding to the selected ID.

Click on OK to add your entry or Cancel to exit the screen without saving your changes.

Tasks Tab

Tasks that have been added to this opportunity will be displayed on this tab. Tasks can either be added from the
Tasks tab or from the Tasks menu. Click Add to create a new task or Edit to edit an existing task. Setting up
tasks will be discussed in further detail in the the How Do I Set Up Tasks? section.
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History Tab

Tasks for this opportunity that have been marked as completed will be displayed on this tab. Once a task has
been completed it will be moved from the Tasks tab to the History tab. Click Add to create a new task or Edit to
edit an existing task. Setting up tasks will be discussed in further detail in the How Do I Set Up Tasks? section.
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Notes Tab

This tab allows you to enter any notes you may want to track concerning this opportunity.

User Fields Tab

The user fields tab allows you to enter information into the user-defined fields for opportunities that were setup in
the Parameters for CRM. This tab only appears if you have created at least one user field under Configure >
System Parameters > CRM Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the opportunity file. This tab only appears if you have created at least one CRM attachment folder under 
Configure > System Parameters > CRM Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or Cancel to exit the screen without saving your changes.
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4.4 Tasks

4.4.1 How Do I Add Tasks?

Select CRM > Tasks > Add Tasks.

Type - Select the type of task. The options are Company, Contact, or Opportunity, depending on your
selections in the parameters.

Company/Contact/Opportunity - The Company, Contact, or Opportunity field is determined by the selected
type. Enter or choose the Company, Contact, or Opportunity.

Start Time - Enter the date and time the task is going to start.

End Time - Enter the date and time the task is going to end.

Click Add to continue adding a new task.

Main Tab
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Company - This is a non-editable field that will contain the selected company number and name if Company
was selected as the task type.

Contact - This is a non-editable field that will contain the selected contact number and name if Contact was
selected as the task type.

Opportunity - This is a non-editable field that will contain the selected opportunity number and name if
Opportunity was selected as the task type.

Task Date - Enter or choose the date of the task. This field defaults to the current date.

Task Time - Enter the time of the task. This field defaults to the current time.

Entered By - Enter or choose the user that entered this task. This field defaults to the logged in user.

Owner - Enter or choose the owner of this task. This field defaults to the logged in user.

Type - Enter or choose the type of task. The types that are available here are set up in Task Type
Maintenance. 

Description - Enter a description of the task.

Notes - Enter notes about the task.

Task Completed - Select this checkbox if the task has been completed.

Task Canceled - Select this checkbox if the task has been canceled. 

Email Notification Tab
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Email Notification - Select this checkbox to send an email notification.

Notify on Save - Select this checkbox to send the email notification when the task is saved. This checkbox
becomes active when the Email Notification checkbox is selected.

Notify in Advance - Select this checkbox to send the email notification in advance of the task date and time.
You can then enter the number of days, hours, or minutes before the task date and time that you want to send
the email notification. This checkbox becomes active when the Email Notification checkbox is selected.

Specify Date/Time - Select this checkbox to send the email notification at a specified date and time. You
can then enter the date and time that you want the email notification to be sent. This checkbox becomes
active when the Email Notification checkbox is selected.

Recurring - Select this checkbox to send a recurring email notification. You can then select the number of
days, hours, minutes, or number of times that you want the email notification to be sent. This checkbox
becomes active when the Notify in Advance or Specify Date/Time checkbox is selected.

Select the CRM users that to whom you want the email notification to be sent. If you want to send the notification
to a user that is not included in the grid, you can enter their email address in the Email Address field and click
Add.

Notification Schedule Tab

The dates and times that the email notifications will be sent will be be listed on this tab.
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User Fields Tab

The user fields tab allows you to enter information into the user defined fields for tasks that were setup in the
Parameters for CRM. This tab only appears if you have created at least one user field under Configure > System
Parameters > CRM Parameters.

Attachments Tab

The Attachments tab gives you the option to add files, scan documents, and drag existing saved documentation
into the task file. This tab only appears if you have created at least one CRM attachment folder under Configure >
System Parameters > CRM Parameters.

For instructions on adding attachments, refer to "How Do I Work With Attachments" in the "System Setup"
chapter of your manual.

Click on Save to save your entry or Cancel to exit the screen without saving your changes. On Save, the task
will be added to the task owner's Outlook calendar. You can also click Save & Add Another Task to save the
current task and open a new task for the selected Company, Contact, or Opportunity. 

4.4.2 How Do I Edit Tasks?

Select CRM > Tasks > Browse/Edit Tasks.

Task Number - Enter or choose the task number and click Edit to edit an existing task.
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4.5 Search Center

4.5.1 How Do I Use the Search Center

Select CRM > Search Center.
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 New Search - Click to start a new search.

 Save Search- Click to save the current search. Once a search is saved it will be available in the Saved
Searches dropdown list.

 Delete Search - Click to delete a saved search. When a search is deleted it will be removed from the
Saved Searches dropdown list.

 Save Search As - Click to save the current search and be prompted to enter a new Search Name.

 Export Results - Click to export the current search results to an Excel spreadsheet. You will be prompted
for a file name and location.

 Choose Columns - Click to select which columns display in the Search Center. You can set columns for
each individual search or you can set your default columns using this option. You can also select your
preferred Date Format. 

 Create A Document - Click to create a document using information from the selected row.

 Advanced Search Filters - Click to select additional search options. 
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Saved Searches - Click the dropdown list to select a previously saved search. 

Record Count - The non-editable field contains the number of records that were returned by the search.

Companies - Select to search companies.

Contacts - Select to search contacts.

Opportunities - Select to search opportunities.

Tasks - Select to search tasks.

Click Search to display search results. Hovering over an item with the mouse in the search results will display the
contact information. Double-clicking on the item will open it for viewing or editing.

Click Close to close the Search Center.

4.6 Sales Center

4.6.1 How Do I Use the Sales Center?

Select CRM > Sales Center.
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Owner - Enter or choose the owner. This field can also be left blank to show all owners.

Company - Enter or choose the company. This field can be left blank to show all companies.

Business Type - Enter or choose the business type. This field can also be left blank to show all business
types.

Product Type - Enter or choose the product type. This field can also be left blank to show all product types.

Graph Lead Source By - Select either Quantity or Dollars to use for the Lead Source graph.

Graph Opportunity Stage By - Select either Dollars or Quantity to use for the Opportunity Stage Graph.

Lead Date - Enter or choose a lead date range. These fields can also be left blank to show all lead dates.

Estimated Closed Date - Enter or choose the estimated closed date range. These fields can also be left
blank to show all estimated closed dates.

Actual Closed Date - Enter or choose the actual closed date range. These fields can also be left blank to
show all actual closed dates.

Send Report To - Select where you want to send the report. The options are Display, Printer, Email, and
Clipboard.
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Quick Links - The following CRM items can be opened from the Sales Center:

Search Center - Double-click to open the Search Center.

Create/Edit Companies - Double-click to open Create/Edit Companies.

Create/Edit Contacts - Double-click to open Create/Edit Contacts.

Create/Edit Opportunities - Double-click to open Create/Edit Opportunities. 

Tasks - Double-click to open Add Tasks or Browse/Edit Tasks.

Reports - Double-click to open the CRM Company List report.

My Opportunities - Double-click to open the list of opportunities in the Search Center for the selected
owner.

Closed Opportunities - This chart shows you where you are with meeting your sales goal for the selected
dates.

Quantity by Lead Source - This charts shows you which sources are generating the most leads. Double-
clicking on a section of the chart will open the list of opportunities in the Search Center.

Pipeline by Opportunity Stage - This chart show you how many opportunities you have in each stage of
sales process. Double-clicking on a bar will open the list of opportunities in the Search Center.

4.7 Reports

4.7.1 How Do I Run the Company Listing Report?

Select CRM > Company Listing.
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Type - Select a company type. The options are All, Prospect, Customer, Vendor, Internal, or Other.

Companies - Enter or choose a single company or a range of companies. 

Status - Select a status. The options are All, Active, or Inactive.

Entered By - Enter or choose the user that entered the company. 

Entry Dates - Enter or choose the date range that the companies were entered. 

Lead Source - Enter or choose a lead source. 

Business Type - Enter or choose a business type.

Tag - Enter or choose a tag.

Print Contacts - Select Yes to include contacts in the report or No to not include them.

Sent Report To - Select where you want to send the report. The options are Display, Printer, E-Mail, or
Clipboard.

Click OK to run the report.

4.7.2 How Do I Create a Company Document

You can create and send documents for any company in your company directory.
Select CRM > Reports > Create a Document > Company.

Company - Select a company or companies to which you want to send a letter or document.

Send to - Select where you want to send the report. The options are Display, Printer, E-Mail, or Clipboard.

Format - Choose the format for the report.

Save to History? - Check here if you want to create a task and save a copy of the document in the
attachments folder for this task.
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4.7.3 How Do I Create a Contact Document

You can create and send documents to any contact in your contact directory.
Select CRM > Reports > Create a Document > Contact.

Contact - Select a contact or contacts to which you want to send a letter or document.

Send to - Select where you want to send the report. The options are Display, Printer, E-Mail, or Clipboard.

Format - Choose the format for the report.

Save to History? - Check here if you want to create a task and save a copy of the document in the
attachments folder for this task.

4.7.4 How Do I Create an Opportunity Document

You can create and send documents regarding any opportunity in your opportunity directory.
Select CRM > Reports > Create a Document > Opportunity.

Opportunity - Select a opportunity or opportunities about which you want to send a letter or document.

Send to - Select where you want to send the report. The options are Display, Printer, E-Mail, or Clipboard.

Format - Choose the format for the report.

Save to History? - Check here if you want to create a task and save a copy of the document in the
attachments folder for this task.
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5 Additional Features

There are several optional features available that allow you to customize how you use ComputerEase. Throughout
ComputerEase, there are various reports that can be customized by the user using either Excel or Word
templates. There are also various spots in the software that allow you to import data from either a flat file or an xml
file.

5.1 Excel Templates

There are various Excel template versions for existing system reports in the system. The Excel templates allow
you to determine which columns appear in a report and in what order. Excel templates give you access to data not
available in the associated system report, such as user-defined fields. Additionally, reporting your data in Excel
gives you access to all of the advanced reporting functions available in Excel.

Each Excel template was inserted into ComputerEase as a blank canvas. It is up to you to determine how you
would like your Excel templates formatted. You also have the ability to create multiple layouts for each template,
allowing you to expand your reporting options to meet different reporting needs.

To begin working with your Excel templates, select File > User Reports... and choose the Excel Templates tab.

Select the module that contains the template you want to work with and either double-click on it or click on the +
next to it to expand the selection. Under each module you will see at least one report from which to choose.
Expand that report by either double-clicking on it or clicking on the + next to it. You should see just one option
initially, called EXCEL, with additional report information listed next to that code. If you have not worked with your
Excel templates yet, you will have to highlight the template you want to work with click on the Create Template
button to the right.
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You will be given an option to create the template for all companies or for this company only.

Your selection here depends on whether you have multiple companies set up in ComputerEase and, if so, whether
this template is to be shared by all companies. If you choose to create the template for all companies, the
template will be stored in your ComputerEase "Data" directory; if you choose to create the template for this
company only, the template will be stored inside the current company's numbered directory inside your "Data"
directory.

Once you have selected how you would like this template to be shared and clicked on OK, your template should
open in Microsoft Excel. The picture below was taken in Excel 2016; you can use any version of Excel that
supports XML (2003 and later, dependent upon edition purchased). You will know if your version of Excel supports
XML if you see the "XML Source" pane on the right side of the Excel window, as pictured below.
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Now it is time to design your report. From the "XML Source" pane on the right side of the window, pick the field
that you would like to see in the first column of your report. For example, if Job Number was the first column you
wanted to add, you would scroll down and find the field called "jobnum" in the list. Add it to your report by either
dragging and dropping it to a cell in the column where you want it to appear or select the field you want to add,
then select a cell where you would like to place it and double-click in that cell. Continue adding columns to your
report. Once you have finished adding columns, you report should look something like the one pictured below; the
number of columns and which columns you choose will vary.
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The first row, in darker blue above, is the header row. When you use the Excel template to generate a report, the
header row will always print in the current location so you know what data is contained in each column. You can
rename any of these columns by simply selecting the cell and typing over the column header name; this will not
remove the mapping of the data. The data output always begins in the row right beneath the header row. In the
sample below, "jobnum" has been renamed "Job #" and so on. When the report is generated, these will be the
column headings used. The ability to rename my column headings gives you flexibility to match your company's
terminology in reports.
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At the top of the XML field list, you will see a section called "prompts" which allows you to add information to the
report so you will know what selections were made when generating the report. For example, when the Job
Costing Work In Progress reports are generated, you can choose to include only certain jobs or job classes, only
certain dates or all dates, etc. These are called the prompts and when you print a hard copy of a report in
ComputerEase, these print across the top of the page so you will know what selections you made when you
generated the report. You may want to add these prompts to your Excel template so that you will have the same
information when generating Excel reports. You can add the prompts anywhere that data is not currently mapped.
If you want to add them to the top of your report, above your header row, after you have already configured your
report (as in the example above), simply insert one or more rows above the header row to give you the space you
need. When you add prompt fields to your report, there is no heading inserted with the field. For that reason, you
may choose to add your own text next to or above the fields you insert for informational purposes.
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In the sample above, text has been added next to each of the prompt fields added so that the user knows what
information is being reported. Notice that the cells to which prompt fields were added are simply outlined in blue.

If you don't know what field was mapped to a particular cell, simply place your cursor in that cell; the field mapped
to it in the "XML Source" pane will be selected.

Once you have completed your template, save the template. You have now created an Excel Template. The default
name of the template will be the standard report name.

You might find that you have need for more than one format or layout for a specific report. To create another
format, highlight the existing format and click on Copy Format.
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Format - Enter a name for your format. Existing formats are all named "EXCEL" but you can choose any
name up to 12 characters.

Description - Enter a description of the format to help you differentiate it from other formats.

Template - Choose either Use Existing and choose a different template if necessary or Create New and
name your template and select whether it will be used for all companies or for the current company only.

To view your template in a report format, log into ComputerEase, access the module and the standard report
selection for the template. (Example: Job Cost, Reports, Work in Progress, Normal) Change your Format option to
Excel and send the report to the Display to view as it will appear. In the sample below, report format "EXCEL2" has
been created as an alternate format for the existing "EXCEL" WIP template. To modify or make changes to this or
any template, highlight it and click on Edit Template.

When it is time to use your template, simply go to the menu selection where the system report associated with
the template in question is normally printed. For any report for which there is an available Excel template, there is
a prompt that allows you to choose the format.
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When you select F2 or click on the ? in this field, you will see a "NORMAL" format, which is the standard system
report, along with any other formats you created for your Excel templates. In this sample, two Excel formats
("EXCEL" and "EXCEL2") were created and are available for selection.

Additional formats are always created under User Reports.

To use the template you have created, simply make your report selections as you normally would and choose one
of your Excel formats. The output will be produced in Excel.



Other Tools194

Deltek+ComputerEase

5.2 Word Templates

There are various Word template versions for existing forms in the system. The Word templates allow you to
design your forms as you would like for them to look. Word templates give you access to data not available in the
associated system form, such as user-defined fields. Additionally, reporting your data in Word gives you access to
all of the advanced formatting and design functions available in Word.

Each Word template was inserted into ComputerEase in some sort of pre-defined format. It is up to you to
determine how you would like your Word templates formatted; you can use the existing templates as they were
created, modify them to your liking, or simply begin fresh with an entirely new form. You also have the ability to
create multiple format for each report, allowing you to expand your reporting options to meet different reporting
needs.

You will want to have a Word template (and not just a document) saved in your ComputerEase directory on your
server. To use a template for all companies, it must be saved in the "Data" directory; to use a template for just one
company, it must be saved inside the current company's numbered directory inside your "Data" directory. Once
you have a template you want you use saved in the appropriate location, you can begin working with it in
ComputerEase.

The first step in working with a Word template in ComputerEase is making sure that you have a format that links to
your template. The most typical way this is done is by going to the place in the system from where the form is
printed. For example, to work with your Freeform Invoice format, go to Accounts Receivable > Work on
Freeform Invoices > Print a Freeform Invoice. There will always be an option to choose the format; how it is
presented will differ depending on the form you are working with (for example, the Account Payable Waiver of Lien
format is actually edited under Accounts Payable > Maintenance Programs > Edit Waiver of Lien text). If
you require assistance editing or creating a format for a report, contact your ComputerEase dealer support team.
For this example, the Freeform Invoice format will be used.

To create a new format click on F2 or the ? next to the Format field. Any pre-existing formats will be listed. Click
on Maintenance.
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Format - Enter the name of a new format or choose an existing format and click OK.

Code - The code you entered previously to name the format.

Description - Enter a description that will help you identify this format.

Report - Click on the F2 or ? and choose WORD from the selections. Depending on the report/form, there
may be more than one report type available.

Template - This is where the template is linked to the format. Click on the F2 or ? and choose the template
you want to use for this form. Any Word template saved into your ComputerEase data or company directory
will be available here for selection. You never want to link the same template to formats for different reports.
Each template must be used only once in the system.

Once you have entered the information, click on OK to save your format. Now you are ready to use and/or modify
your template in ComputerEase

To begin modifying with your Word templates, select File > User Reports... and choose the Word Templates
tab.
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Every template linked to an existing format will be listed here for you to review and/or modify. Choose the template
you want to edit, highlight it and click Edit. If you do not remember the file name of your Word template, you can
use the Description field to help you identify your template. If the template is currently shared between all
companies, you will have the option to modify the template for either all companies or for this company only.

Your selection here depends on whether you have multiple companies set up in ComputerEase and, if so, whether
this template is to be shared by all companies. If you choose to modify the template for all companies, the
template will be stored in your ComputerEase "Data" directory; if you choose to modify the template for this
company only, a copy of the template will be stored inside the current company's numbered directory inside your
"Data" directory with the changes you make here. The unchanged copy will be available for modification in other
companies.

What you will see in your template depends on whether you began with a pre-existing template or whether you
chose to begin with a blank slate. You will build or modify your template using all of the tools available in Word.
Depending on your level of expertise with Word, you can insert watermarks or logos and format the form to your
liking. You may find that using tables makes formatting easier. The template below is pictured in Word 2010. You
can use Word templates in any version of Word currently supported by Microsoft. Older editions of Word may not
be compatible.
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Every template has a pre-defined set of fields available. These fields are used to map the data from ComputerEase
into the Word form when it is printed. The list of fields depends on where the template will print from in the
software. To fields available for use in your template are listed in the "Merge fields" listing. In Word 2007 and later,
this list is located on the "Mailings" tab in the "Write & Insert Fields" group; click on "Insert Merge Field" to see
the fields available for insertion in the template.

To insert a field, simply position your cursor wherever you would like to insert the field and then select the field
from the list and double-click on it. Field appear in the following format on your template: << name >>. In the invoice
template pictured above, much of the data is organized into tables. For any field or group of fields for which more
than one data result might be returned, Word will return those fields in rows. For example, you might have only one
item on a freeform invoice or you might have many. In the case where you have many items, they will print on your
invoice form in rows (one item per row). In the template pictured above, the item number, quantity, description
price, and total will print on one row for each item.

For any data where more than one row might be returned, the use of bookmarks is required to tell Word what to do
with the data when there is more than one value returned. Bookmarks are also sometimes used for conditional
output. To insert a bookmark, select the fields that will be contained in that bookmark, and add the bookmark. In
Word 2007 and later, the bookmark item is located on the "Insert" tab in the "Links" group; click on "Bookmark" to
add a bookmark. Notice below that the row containing all of the item fields is highlighted.
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Any pre-existing bookmarks will be listed here. To add the bookmark, type the name of the bookmark (in the
format "New_name") and click on Add. The bookmark names are programmed into the report. If you need any
assistance with bookmark names, you can review the bookmark list in the system template for the same form or
contact your dealer support team for assistance.

Once you have completed your modifications, save your template. Now, when you print your form using the
template format, the template you created will be used to format your forms. Notice that the coloring has been
changed from the original coloring in the table header rows. Of course, many more modifications are possible
using Word.
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5.3 Importing XML Files

ComputerEase offers the ability to import files formatted in the Extensible Markup Language, or XML, format. The
ability to import files formatted using XML rules can save you time when importing your General Ledger budgets or
can even allow you to import invoices from vendors.

It is important that any XML file you want to import meets the specifications, or schema, for that file type. The
schema for any XML import file dictates the elements that can be included in the XML file, including which
elements are required. ComputerEase has provided you with a schema file for every XML file that can be imported.
Those schema, or XSD files, can be found in the directory called "xmlspecs" inside your ComputerEase directory
on your server; refer to the System Setup chapter of the Accounting Tools Manual for instructions on finding your
ComputerEase directory.

There are eleven places in ComputerEase to which data can be imported from XML files. The items that can be
imported and the schema file associated with each of them follows:
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· Accounts Payable Invoices (apinvoices.xsd)

· Accounts Payable Single Invoice (aponeinvoice.xsd)

· Accounts Receivable Batch Entry Invoices (batchinvoices.xsd)

· Accounts Receivable Customers (customer.xsd)

· Accounts Receivable AIA Schedule of Values (aiaitems.xsd)

· Accounts Receivable Unit Billing Schedule of Values (unitbillitems.xsd)

· Accounts Receivable Freeform Invoices (freeform.xsd)

· Payroll Union Rates (unionrates.xsd)

· General Ledger Accounts and Account Information (glaccounts.xsd)

· Job Costing Jobs (job.xsd)

· Job Costing RFC's (rfc.xsd)

· Job Costing RFC budgets (rfcbudgetsall.xsd and rfcbudgetsbytype.xsd)

· Inventory Control Items (inventoryitems.xsd)

· Inventory Control Pull Lists (pulllist.xsd)

Creating an XML file can range from simple (in the case of General Ledger Accounts, for instance) to complex.
While Excel can be used in some cases to generate an XML file, in the case of many of the items listed above,
Excel simply does not have the capability to produce the XML file. In any file that requires a list of lists, for
example, an XML editor would be required to produce the XML file to import. In cases like these, XML schemas are
most often used by third parties who produce files that ComputerEase users can import. For example, a third-party
estimating software might use the XML schema for jobs and/or RFC's to allow the end user to export an estimate
for a job or a change order and import it into ComputerEase.

As a general rule, any single list of data can be easily turned from an Excel spreadsheet into an XML file. This
process does require any version of Microsoft Excel that supports XML. Contact your ComputerEase Dealer
support team for questions about specific import files.

5.4 Importing Flat Files

There are several places throughout ComputerEase where you can import data from a flat file; the file types
accepted in these places are Tab-Delimited, Comma-Separated or Fixed-Width files. Any of these files can be
created with a simple spreadsheet program like Excel. In a flat file, each row of data represents one entry. So in a
list of vendors, each vendor would be listed in one row. Each column represents a different field or piece of
information. So in a list of vendors, the vendor's name might be in one column, the address in another and the
phone number in another.

There are twelve places in ComputerEase to which data can be imported from flat files. The list of items that can
be imported follows:

· Accounts Payable Vendors

· Job Costing Phases & Categories

· Job Costing Detail

· Job Costing/Document Control Contacts

· CRM Companies
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· CRM Contacts

· Payroll Labor Distribution

· Payroll Employees (limited fields)

· Payroll Employee Direct Deposit Info

· Payroll Employee Deduction and Fringe Rates

· Payroll Vacation and Sick Accrued Hours

· General Ledger Postings

· General Ledger Cleared Checks (Reconcile Account)

· Accounts Receivable Customers

· Accounts Receivable Payments

· Inventory Control Items & Assemblies

· Inventory Control Purchase Orders

· Inventory Control Purchase Order Receipts

· Inventory Control Pull Lists

· Inventory Control Inventory Adjustments

· Inventory Control Vendor Pricing

· Equipment Costing Equipment

· Equipment Costing Job Entry

· Service Management Sites

· Service Management Work Ticket Items

Any time that you choose to import data from a flat file, you must first identify a layout format for the file. The
layout format tells ComputerEase what type of file you will be using to import data and what order the information
is in that you will import. While the fields that are available for import differ depending on what you will be
importing, the process for creating and using your import layout format is the same.

Access the file import function wherever you will import data. In some cases the file import function is simply a
menu option (vendor, customer, inventory items, inventory purchase orders, payroll vacation/sick accrued hours,
employee deduction and fringe rates, and service management work ticket items). In others it is within an entry
screen under File, Import.. (job costing phases & categories, job cost detail, payroll labor distribution, general
ledger postings, inventory pull lists, inventory adjustments, inventory vendor pricing and equipment costing job
entry). In others it is at the maintenance screen under File, Import.. (payroll employees, direct deposit info,
service management sites, job costing/document control contacts and equipment costing equipment).

In the menu bar of the import screen it will name what you are importing; however, the two fields in which you must
make entries will be the same.
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Import From - Browse to the file from which you will be saving data. You may have saved it on your
workstation or you may need to browse to another location on your network. As long as you can access the
file through windows, you can access it here.

Use Layout - This is where you will choose the layout format that tells ComputerEase how the file should be
imported. You might have multiple layouts if you import the same information from multiple sources.

If you have not previously created a layout or if you simply need to create a new one, press the ? next to Use
Layout or select F2 on your keyboard when you cursor is positioned in that field.

New - Click here to create a new layout.

While the sample above is specifically for importing inventory items, only the fields listed will differ.

Description - Enter a description of this layout to make it easier to identify.

Type - Choose the file type that you will be importing, either Tab Delimited, Fixed Length or Comma
Delimited.

Skip First Row - Check this box if the first row of your file contains headers so that when you import the
file, your headers will not be imported as a record.

Field - The fields available for mapping are listed here.

Load Sample - In order to make mapping your fields easier, you may want to load a sample file. Press
this button and browse to the file you want to use to help you align the mapping. The sample file data will
appear in the bottom portion of the screen in the numbered columns.

Assign to Field - Now you are ready to begin mapping your fields. To map a field, simply click once on
the field name in the top portion of the screen and then click once on the column that contains that data in
the bottom portion of the screen. Then press the Assign to Field button.
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Remove Value - As you map your fields, if you make a mistake, select Remove Value to undo your
mapping.

Constant Value - If the value for a field will be the same for all rows, you can assign a constant value in
lieu of mapping it to a column in the file. For example, if the classnum field for all items imported using
this layout will be "WIRE" you would select the classnum field by clicking once on it, then select the
Constant Value button. Your cursor will appear next to the classnum field under the Value column.

Where your cursor is flashing, type in the constant value to use for all items being imported and press the 
Enter key on your keyboard to save the entry.

Runtime Value - If you want to be prompted to enter the value for all items being imported at the time of
the import, assign the runtime value to that field. Select a field, then press Runtime Value; where your
cursor appears type in a prompt that will let the user who is importing the file know what information is
expected to be entered. When the file is imported, the user will be prompted to enter the value to be used
for all rows of data being imported in that file. For example, if the primary vendor number will differ with
every file of inventory items being imported, you could enter a prompt "Vendor #" for the runtime value for
the vendor field. When the user imports a file, the following prompt would prompt the user to enter the
vendor number to use for all rows imported in that file:
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When you have finished mapping the fields in the layout, press Save and then Close.

Once you have created at least one layout, there will be several other options available.

Edit - Select a layout and press here to make changes to it.

Copy - Select a layout and press here to create a new layout that is a copy of the selected layout.

Delete - Select a layout and press here to delete that layout if it is no longer in use.

Use - Select a layout and press here to use that layout when importing your file.

Close - Press here to close the screen without making a selection.

Once you have selected both the file that will be imported and the layout to be used, you can preview the data that
will be imported, proceed with the import at that time, or cancel if you are not ready.

It is a good idea to preview the import before proceeding. Once the import is complete, the item(s) in the file will be
imported into ComputerEase for use.
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