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Overview 
The Cobra 8.3 Cumulative Update 11 release includes all of the enhancements, software issues resolved, 
and database changes that were made in Cobra 8.3 CU 01 through CU 11. 

Custom Programs Affected 
Sometimes an update can cause custom programs and reports to stop working as expected. Before 
applying this update, consider whether you have any custom programs or reports in the application area 
affected by the update. If so, contact Deltek Customer Care at http://support.deltek.com before you install 
the update. 

 

Viewing the Online Help 
If you use Internet Explorer and the online help does not display correctly, you need to turn off 
Compatibility View for the browser. Click Tools » Compatibility View settings, and clear the Display 
intranet sites in Compatibility View check box. Then refresh the browser. Make sure you remove 
deltek.com (if listed) from the Websites you have added to Compatibility View list. You could also elect 
to use hosted help or the FQDN of your server in the URL (for example, server.domain) to bypass this 
issue. Depending on your Internet Explorer security settings, you may be prompted to “Allow blocked 
content” when viewing the online help locally. The Cobra 8.3 Help System URL is 
https://help.deltek.com/Product/Cobra/8.3/GA. 

Depending on your Internet Explorer security settings, you may be prompted to “Allow blocked content” 
when viewing the Cobra Online Help locally. This only affects Internet Explorer.  

You may also access the online help using Chrome and Firefox. 

Attention: For steps to install the cumulative update, see Appendix A: Download and Install the 
Cumulative Update. 

http://support.deltek.com/
https://help.deltek.com/Product/Cobra/8.3/GA
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Cobra 8.3 Cumulative Update 11 
Released: September 10, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Wizard — Project Data 
Defect 1345266  

Description: When you ran the Integration wizard to load forecast or budget data and selected the 
Delete Control Accounts and Work Packages no longer in the schedule option on the Change 
Control page, Cobra did not delete the work packages that were no longer in the schedule if they had 
resource assignments with a different class type than that being loaded. 

Customers Impacted: This defect affects customers who integrate budget or forecast data. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Cobra 8.3 Cumulative Update 10 
Released: August 31, 2020 

Enhancements 

Remove the Limit Memory Setting During Integration 
Previously, you needed to run the Cobra_Enable_LimitMemoryForIntegrationProcess.sql script to 
limit the amount of memory consumed by Cobra when running the integration. Beginning Cobra 8.3 
CU10, you no longer need to run this script as the Cobra integration has been updated to use the same 
memory limit applied to other processes. 

Update to the CWS Gateway Configuration Tool 
When the Cobra Gateway establishes a connection to the Cobra Web Service (CWS), the CWS usually 
sends the Service Principal Name (SPN) declared on the machine, known as Identity, to the Cobra 
Gateway. If the CWS is located on a remote machine which runs on the Windows Domain Account that 
does not have access to the Service Principal Name (SPN), the CWS sends the User Principal Name 
(UPN) instead. The Cobra Gateway, which expects the SPN Identity from the CWS receives the UPN 
Identity instead. This results in the Cobra Gateway rejecting the connection with the error "The server was 
unable to process the request due to an internal error." 

Previously, you needed to manually add the UPN values to the 
Cobra.WebService.Gateway.Host.exe.config file in order to resolve the connection issue. Beginning 
Cobra 8.3 CU10, you can use the CWS Gateway Configuration Tool to define the UPN of each CWS 
endpoint. The UPN details are also saved in the Cobra.WebService.Host.Gateway.exe.config file upon 
saving. 

 

 

Attention: This enhancement applies to customers who use the concurrency feature. 

https://help.deltek.com/Product/Cobra/8.3/GA/Process%20Server%20Received%20an%20Internal%20Error.html
https://help.deltek.com/Product/Cobra/8.3/GA/Process%20Server%20Received%20an%20Internal%20Error.html
https://help.deltek.com/Product/Cobra/8.3/GA/Cobra%20Web%20Service%20Gateway%20Configuration%20Tool.html
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Change the Default Level of Output to Work Package When Exporting a 
DCDE File 
When you run the Cost Data process to generate the Deltek Common Data Exchange (DCDE) file, the 
Export data by option on the Data Options page now defaults to Work Package instead of Control 
Account. 

 

 

Software Issues Resolved 

File » Integration Wizard — Project Data 
Defect 1187554  

Description: When you ran the Integration wizard to load a status file with milestones forecast finish 
dates and selected the Change Cobra actual dates to match the schedule option on the Status page, 
Cobra did not update the forecast finish dates for in-progress work packages. 

Customers Impacted: This defect affects customers who use status integration. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

Note: The Export data by option still defaults to Control Account when you generate the Integrated 
Program Management Data Analysis Report (IPMDAR) file. 



Cobra 8.3 Cumulative Update 10 

Cumulative Update 11 Release Notes 5 

 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1319980  

Description: When you ran the Integration wizard to load a status file and cleared the Change Cobra 
actual dates to match the schedule option on the Status page, Cobra updated the dates for the 
completed control accounts and work packages. 

Customers Impacted: This defect affects customers who use status integration. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Replan 
Defect 1193739  

Description: When you ran the Replan wizard, Cobra added zero time-phased records to the actual and 
earned classes. 

Customers Impacted: This defect affects customers who use the Replan wizard. 

Workaround Before Fix: None. 

Additional Notes: Defect 1283140 has been fixed along with this defect. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Tools » Configure 
Defect 389714  

Description: When you updated the Budget project terminology on the General tab of the Application 
Preferences dialog box to a different term and then added a new cost set name called "Budget", you 
could not rename the Budget project terminology back to "Budget". 

Customers Impacted: This defect affects all customers. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 



Cobra 8.3 Cumulative Update 10 

Cumulative Update 11 Release Notes 6 

 

 Cobra.Resources.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation.  

Document Details 

Cobra 8.3 Installation Guide  Removed the “Limit the Cobra Memory Usage during 
Integration” section. 

Cobra 8.3 Online Help  Updated the following topics for the “Update to the 
CWS Gateway Configuration Tool” enhancement: 

 Cobra Web Service Gateway Configuration Tool 

 The server was unable to process the request 
due to an internal error 

 Updated the description of Export data by field in the 
Data Options Page of the Cost Data Wizard topic for 
the “Change the Default Level of Output to Work 
Package When Exporting a DCDE File” 
enhancement. 
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Cobra 8.3 Cumulative Update 09 
Released: August 19, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

API » Web Services 
Defect 1333038 

Description: When you developed an application to move a work package using the Cobra Web Service, 
you could not define log comments, change number, and significant values. 

Customers Impacted: This defect affects customers who use the Cobra Web Service. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WebService.dll 

 Cobra.WebService.Host.exe 

 Cobra.WebService.ClientAPI.dll 

 Cobra.Model.dll 

 Cobra.Model.WebService.dll 

 

Defect 1337016 

Description: When you encountered a login failure, the Cobra Web Service always returned an "Invalid 
Windows user" error message instead of the actual message. 

Customers Impacted: This defect affects customers who use the Cobra Web Service. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WebService.dll 

 Cobra.WebService.Host.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

File » Integration Wizard — Ancillary Data 
Defect 1324987 

Description: When you sent a process with multiple jobs to the PM Compass Process server, some jobs 
in the Cobra queue might display a "Failed" status on the Process Queue Manager form in PM Compass 
without any corresponding entry in Cobra's process log. 
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Customers Impacted: This defect affects customers who use the Send to process option when running 
a process. 

Workaround Before Fix: None. 

Additional Notes: This update resolves a specific cause of "Failed" jobs. Please note that jobs may fail to 
execute for other reasons. 

Files Updated: 

 CobraWebServices.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 ClrHost.dll 

 wwDotNetBridge.dll 

File » Integration Wizard — Project Data 
Defect 1316892  

Description: When you loaded budget data with exact changes included in the project, Cobra would 
update the baseline finish dates with the first date of the status date if: 

 The Apply historical budget changes as an adjusting entry in the current status period 
option on the Integration Wizard Preferences tab of the Project Properties dialog box was 
selected. 

 The baseline finish date was earlier than the status date. 

 The schedule finish date was earlier than the status date. 

Customers Impacted: This defect affects customers who are integrating budget data. 

Workaround Before Fix: Clear the Apply historical budget changes as an adjusting entry in the 
current status period option on the Integration Wizard Preferences tab of the Project Properties dialog 
box. 

Additional Notes: Defect 1305435 has been fixed along with this defect. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Projects » Project View 
Defect 1284720 

Description: When you clicked Expand All on the Edit tab of the Project view and scrolled down in the 
Time-phased pane using the mouse wheel, the values in the Time-phased pane were updated. 

Customers Impacted: This defect affects customers who are accessing the Project view. 

Workaround Before Fix: Use the Page Up and Page Down keys or the scroll bar to scroll up and down 
in the Time-phased pane. 
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Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation.  

Document Details 

Cobra 8.3 Technical Overview 
and System Requirements 
Guide 

 Added the “Concurrency Feature System 
Requirements” section. 

 Added the “Open Source Software Included with 
Cobra” section. 

Cobra 8.3 Installation Guide  Added the “Concurrency Feature System 
Requirements” section. 
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Cobra 8.3 Cumulative Update 08 
Released: July 13, 2020 

Enhancements 

Leveraging PMC’s Process Server to Support Running of Concurrent 
Processes 
Cobra leverages the Process server of PM Compass to support concurrency when running the following 
Cobra processes: 

 Integration of a single import with multiple projects 

 Apportionment calculations on batches of control accounts 

 

Ability to Load an Import File with Multiple Projects Concurrently During Integration 

You can load a single import file with data from multiple projects concurrently instead of sequentially 
when using Integration » File. This means if there are 10 projects in the import file, Cobra will load these 
projects all at the same time.  

Cobra creates a single-project integration for each project, and submits that integration job to PM 
Compass's Process server. PM Compass then distributes each integration job to a Cobra Web Service.  

 

Ability to Run Apportionment Calculation Concurrently 

Cobra leverages the Process server of PM Compass to support concurrency in running apportionment 
calculations on batches of control accounts. You can implement this feature if the apportionment mapping 
target is set to Same as Source for all control accounts in the apportionment mapping definition. 

 

The concurrency feature is available only if you are running Cobra and PM Compass on your 
environment. Each Cobra Web Service can process 4 jobs concurrently. You may deploy and configure 
multiple Cobra Web Services to scale the number of concurrent jobs the solution can handle. You may 
deploy multiple Cobra Web Services on a single machine provided the machine has sufficient resources. 

For detailed steps on how to set up your environment to support concurrency, see the following topics in 
the Cobra Help System: 

 Concurrency in Cobra 

Note: To use this concurrency feature, you must install Cobra 8.3 Cumulative Update 08, PM 
Compass 8.1 Cumulative Update 25, and Cobra 8.3 Integration for PM Compass 8.1, at the 
minimum.  

Attention: See the “Multi-Project Concurrency Integration” and the “Load an Import File with Multiple 
Projects Concurrently” topics in the Cobra Help System for more details. 

Attention: See the “Concurrent Apportionment Calculations” and the “Run Concurrent Apportionment 
Calculations” topics in the Cobra Help System for more details. 

https://help.deltek.com/Product/Cobra/8.3/GA/Concurrency%20in%20Cobra.html
https://help.deltek.com/Product/Cobra/8.3/GA/Multi-Project%20Concurrent%20Integration.html
https://help.deltek.com/Product/Cobra/8.3/GA/Load%20an%20Import%20File%20with%20Multiple%20Projects%20Concurrently.html
https://help.deltek.com/Product/Cobra/8.3/GA/Load%20an%20Import%20File%20with%20Multiple%20Projects%20Concurrently.html
https://help.deltek.com/Product/Cobra/8.3/GA/Concurrent%20Apportionment%20Calculations.html
https://help.deltek.com/Product/Cobra/8.3/GA/Run%20Concurrent%20Apportionment%20Calculations.html
https://help.deltek.com/Product/Cobra/8.3/GA/Run%20Concurrent%20Apportionment%20Calculations.html
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 Implementing Concurrency 

wInsight Export Process Improvement 
The wInsight Export performance has improved when running the process against very large projects by:  

 Reducing the data that Cobra processes. 

 Excluding unnecessary whitespaces before each XML element in the exported file. 

Software Issues Resolved 

File » Integration Wizard — Project Data 
Defect 1091205  

Description: When you ran the Integration wizard to import status data, and selected the Change Cobra 
actual dates to match the schedule option on the Status page, Cobra would not integrate the actual 
dates for the mapped activities if the schedule start dates were empty. 

Customers Impacted: This defect affects customers who are integrating status data with empty start 
dates. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1178071  

Description: When you ran the Integration wizard to import schedule data, and selected the Change 
Cobra actual dates to match the schedule and the Allow percent complete reduction options on the 
Status page, Cobra would not decrease the percent complete based on the amount in the schedule if 
milestones had actual finish date. 

Customers Impacted: This defect affects customers who are integrating schedule data that contains 
milestones. 

Workaround Before Fix: Manually update the milestones in Cobra. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1320158 

Description: When you ran the Integration wizard to load a single import file with multiple projects, Cobra 
would use the classes of the first processed project to filter the time-phased tables for all projects in the 
import file. 

https://help.deltek.com/Product/Cobra/8.3/GA/Implementing%20Concurrency.html
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Customers Impacted: This defect affects customers who are integrating a single import file with multiple 
projects. 

Workaround Before Fix. None. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1320110 

Description: When you ran the Integration wizard to load a single import file with multiple projects, and 
then selected the Delete items from Cobra that are no longer in the schedule option on the Change 
Control page, and the time-phased data size for the second or subsequent processed projects exceeded 
the 2 GB limit, Cobra would fail which resulted in a crash. 

Customers Impacted: This defect affects customers who are integrating a single import file with multiple 
projects. 

Workaround Before Fix. Clear the Delete items from Cobra that are no longer in the schedule option 
on the Change Control page of the Integration wizard. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Tools » Validity Check 
Defect 1151457  

Description: When you ran the Validity Check wizard against a project with frozen forecast values prior 
to the forecast start date, and selected the Work Package dates correctly span resource assignment 
dates option on the Business Validation page, Cobra would check the frozen forecast values instead of 
ignoring them and would display the “Forecast start date does not span forecast data for Work Package” 
error message. 

Customers Impacted: This defect affects customers who run the Validity Check wizard against a project 
with frozen forecast values prior to the forecast start date. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Security-Related Software Issues Resolved 
Additional security fixes are included in this release. 
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Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. 

Document Details 

Cobra 8.3 Help System  Created/updated the following topics for the 
“Leveraging PMC’s Process Server to Support 
Running of Concurrent Processes” enhancement: 

 Multi-Project Concurrent Integration 

 Concurrent Apportionment Calculations 

 Concurrency in Cobra 

 Implementing Concurrency 

Cobra 8.3 Installation Guide  Added “Open Source Software Included with Cobra” 
on page 19. 
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Cobra 8.3 Cumulative Update 07 
Released: June 2, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

API 
Defect 1293435  

Description: When you ran multiple API processes at the same time on a single machine, Cobra would 
fail and encounter the "sub-directory or file already exists" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

API » Web Services 
Defect 1293710  

Description: When you used the Cobra Web Services Client API and called the GetProjectProperties 
method to retrieve a large number of projects including their properties, the Cobra Web Service would 
return the projects and their properties longer than expected. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

File » Integration » Project Data 
Defect 1291388 

Description: When you ran the Integration wizard to load status file with the Allow percent complete 
reduction option selected on the Status page, Cobra did not allow units complete reduction and ignored 
the option. 

Customers Impacted: This defect affects all users. 
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Workaround Before Fix: None. 

Files Updated: 

 Cobra.Process.dll 

 Cobra.WinUI.exe 

 Cobra.WinUI.*.dll 

 

Defect 1293381 

Description: When you ran the Integration wizard against a project whose Apply historical budget 
changes as an adjusting entry in the current status period option on the Integration Preferences tab 
of the Project Preferences dialog box was selected, Cobra would not delete the milestones no longer in 
the schedule for those with baseline finish date prior to the status date even if the Delete milestones no 
longer in the schedule option on the Change Control page was selected. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.Process.dll 

 Cobra.WinUI.exe 

 Cobra.WinUI.*.dll 

File » Integration wInsight 
Defect 1297252  

Description: When you ran the wInsight Export process against a project that included many structures 
and a large volume of time-phased data, the process would run very slow. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1276143 

Description: When you ran the wInsight wizard and opened an existing configuration for which you had 
read only access, the Export file field on the Save and Run page was disabled. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: This issue is also encountered when you run the Cost Data wizard. 

Files Updated:  

 Cobra.WinUI.*.dll 



Cobra 8.3 Cumulative Update 07 

Cumulative Update 11 Release Notes 16 

 

 Cobra.WinUI.exe 

Project Processes » Calculate Progress 
Defect 1297267  

Description: When you ran the Calculate Progress against a large project that contained many work 
packages with the Calculated Apportionment progress technique, the process would take longer than 
expected. 

Customers Impacted: This defect affects users who run Cobra on an Oracle database. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Project Audit 
Defect 1276265  

Description: When you ran a process (for example, Integration) which loaded or updated budget data 
that resulted in no changes in the time-phased data, and the Log time phased changes option on the 
Log Operation page of the Project Audit wizard was selected, Cobra would create a zero baselog entry. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Cobra 8.3 Cumulative Update 06 
Released: April 30, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Wizard » Project Data 
Defect 1286665 

Description: When you ran the Integration wizard to load an import file with new or existing control 
accounts and work packages structures and selected the Delete Control Accounts and Work 
Packages no longer in the schedule option on the Change Control page, Cobra would not run the 
Update Total process on EAC during integration if you were not loading resource assignments. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Security 
Defect 1286823 

Description: When you ran Cobra in a Terminal Service or Citrix environment and your Cobra session 
did not close properly, you might encounter orphaned locks or sessions. 

Customers Impacted: This defect affects users who run Cobra in a Terminal Services or Citrix 
environment. 

Workaround Before Fix: Perform one of the following: 

 Delete the lock records manually in the database. 

 Clear the crashed connection using the EPM Security Administrator tool. 

1. Log into the EPMSA tool. 

2. In the Explorer pane on the left, click Cobra. 

3. Click Tools » Clear Connections. 

4. On the Clear Connections dialog box, select the crashed connection and click Clear 
User. 

Additional Notes: This issue may happen when a user leaves their Terminal Service or Citrix session 
idle and it times out, or when an active user closes their Terminal Service or Citrix window instead of the 
Cobra window. In some cases, this issue may also happen when Cobra terminates unexpectedly. 



Cobra 8.3 Cumulative Update 06 

Cumulative Update 11 Release Notes 18 

 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 EPM.Security.Authentication.dll 

Tools » Update Totals 
Defect 1284093 

Description: When you ran the Integration wizard to load an import file with new or existing control 
accounts and work packages structures, Cobra would run the Update Total process on budget classes 
during integration even if you were not loading resource assignments but you selected Forecast 
(Start/Finish) Date on the Import File Field Mapper page. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Cobra 8.3 Cumulative Update 05 
Released: April 16, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Cost Data Export 
Defect 1279430 

Description: When you ran the Cost Data wizard against a large project with many Control Account and 
Work Package code fields with a code field type of User Field, and generated the Deltek Cost Data 
Exchange (DCDE) file or the Integrated Program Management Data Analysis Report (IPMDAR) file, 
Cobra would crash with a "System.OutofMemoryException" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

File » Integration Wizard — Project Data 
Defect 1279341 

Description: When you ran the Integration wizard to load control accounts from multiple projects without 
loading against a master project, Cobra would display a warning message that the control account was 
locked by another user even though it was not locked. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: This issue was encountered after implementing the Cobra 8.3 CU04 Enhancement: 
Load an Import File with Data from Multiple Projects and the data lock setting was set to Control 
Account. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 
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Defect 1279995 

Description: When you ran the Integration wizard to load records from multiple projects without loading 
against a master project, the process log would display the total cumulative number of records that were 
added, updated, and deleted instead of displaying the total number of added, updated, and deleted 
records for each project separately. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1280954 

Description: When you ran the Integration wizard to load code assignments and the data locking was set 
to control account level, Cobra would update the code values for a control account locked by another user 
instead of displaying a warning message. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1282514 

Description: When you ran the Integration wizard to load resource assignment codes using a single 
activity and resource assignment file, Cobra would encounter the "[Error] File is in use" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: This defect was introduced in Cobra 8.3 CU04 Enhancement: Load an Import File with 
Data from Multiple Projects. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 



Cobra 8.3 Cumulative Update 05 

Cumulative Update 11 Release Notes 21 

 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation.  

Document Details 

Cobra 8.3 Help System  Updated the description of the following options in the 
Change Control Page of the Integration Wizard topic: 

 Delete items from Cobra that are no longer in the 
schedule  

 Delete Control Accounts and Work Packages no 
longer in the schedule  

 Delete milestones no longer in the schedule  

 Delete resource assignments no longer in the 
schedule  

 Delete only resources with the default or selected 
class  

 Delete only items that match the following criteria  

 Deletion Criteria  

 List deleted items in the process log 

https://help.deltek.com/Product/Cobra/8.3/GA/Change%20Control%20Page%20of%20the%20Integration%20Wizard%20Scheduling%20Tools.html
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Cobra 8.3 Cumulative Update 04 
Released: April 06, 2020 

Enhancements 

Load an Import File with Data from Multiple Projects 
Cobra allows you to load an import file (status file, activity file, resource assignment file, or a single file 
with both activity and resource assignment data) which contains data from multiple projects without 
loading against a master project. With this feature, you do not need to break out an import file for each 
project and run the Integration wizard separately for each project. 

Here is an example of an import file with data from multiple projects. 

 

To support this feature, the following changes were made to the Integration wizard when integrating 
import files. 

The Defined in File check box is added to the Project Selection page. 

 

This check box displays only when you select any of the following options on the Action Selection page: 
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 Control Accounts and Work Packages 

 Code Assignments and User Fields 

 Resource Assignments 

 Status 

When the Defined in File check box is selected, the Cobra Project field is changed to the Use field 
mapping from Project field. Cobra uses the specified file to populate the lookup dialog boxes in the 
wizard and define the number of key fields expected in the field mapper. Otherwise, Cobra displays an 
error in the log. 

 

 

Attention: See the Project Selection Page of the Integration Wizard — Files and Import File with 
Data from Multiple Projects topics in the Cobra Help System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Project%20Selection%20Page%20of%20the%20Integration%20Wizard%20Text%20Files.html
https://help.deltek.com/Product/Cobra/8.3/GA/Import%20File%20with%20Data%20from%20Multiple%20Projects.html
https://help.deltek.com/Product/Cobra/8.3/GA/Import%20File%20with%20Data%20from%20Multiple%20Projects.html
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When you define the fields on the Import File Field Mapper page, make sure to select Project. 

 

All selections on the other pages of the Integration wizard apply to all projects included in the import file. 

 

You must have access to projects included in the import file. Otherwise, the integration skips the project 
with an error. Cobra captures the changes for each project separately in a single process log associated 
with the default project used for mapping. For baseline changes, Cobra captures them with a separate 
transaction ID in the audit log for each project. 

Delete Milestones that are No Longer in the Schedule 
The Delete milestones no longer in the schedule check box is added to the Change Control page of 
the Integration wizard to support deleting of existing milestones no longer found in the schedule.  

Attention: See the Import File Field Mapper Page of the Integration Wizard topic in the Cobra Help 
System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Import%20File%20Field%20Mapper%20Page%20of%20the%20Integration%20Wizard.html
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Software Issues Resolved 

File » Integration Wizard — Project Data 
Defect 1273099 

Description: When you ran the Integration wizard and loaded an existing configuration, the Lookup 
dialog box on the following pages were empty: 

 Load only these budget classes or Load only these forecast classes field on the Resource 
Assignment page 

 Selection field on the Filter page 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.Process.dll 

 Cobra.WinUI.exe 

 Cobra.WinUI.*.dll 

 

Defect 1273100 

Description: When you ran the Integration wizard and loaded a configuration whose CAM field was set 
to Code (optional), Cobra would not update the CAM value during integration. 

Attention: For more information, see the Change Control Page of the Integration Wizard topic in the 
Cobra Help System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Change%20Control%20Page%20of%20the%20Integration%20Wizard%20Scheduling%20Tools.html
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Customers Impacted: This defect affects all users. 

Workaround Before Fix: Set the CAM field to None before import. Change the value to Optional after 
import. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1273108 

Description: When you ran the Integration wizard and loaded status file with the activity and resource 
files into a project, Cobra would display the "[Error]Field name not found: 'PROJECT'" error in the log. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Load only the status file or the activity and resource file only. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1246387 

Description: When you ran the Integration wizard and connected to a Primavera database with millions 
of user defined field value records, the Lookup dialog boxes in the wizard would take a long time to 
appear. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1273030 

Description: When you ran the Integration wizard to load schedule data from Primavera, the Schedule 
Field Lookup dialog box on the Schedule Mapping page was empty if there were more than 120 code 
fields. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 
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 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. 

Document Details 

Cobra 8.3 Help System  Created and updated the following topics for the 
“Load an Import File with Data from Multiple Projects” 
enhancement:  

 Import File Field Mapper Page of the Integration 
Wizard 

 Project Selection Page of the Integration Wizard 
— Files 

 Import File with Data from Multiple Projects 

 Updated the Change Control Page of the Integration 
Wizard topic for the “Delete Milestones that are No 
Longer in the Schedule” enhancement. 
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Cobra 8.3 Cumulative Update 03 
Released: March 31, 2020 

Enhancements 

Renamed the IPMDR Format 
The Integrated Program Management Data Analysis Report (IPMDR), a required government contractor-
reporting format, is renamed to Integrated Program Management Data Analysis Report or IPMDAR. This 
revision impacts the following areas of the Cost Data wizard 

 Project and Format page: The option is updated to IPMDAR —Contract Performance Format. 

 

 Save and Run page: On the Save As dialog box, IPMDR is renamed to “IPMDAR Export 
File(*.zip)” in Save as type. 

 

 

Attention: See the Documentation Changes for the list of updated help topics. 
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Support for the Copy baseline dates to forecast dates option of the 
Reclass Wizard in API and Web Services 
The Copy baseline dates to forecast dates option on the Date Range page of the Reclass wizard is 
now supported in the Reclass API process and Web services through the 
CopyBaselineDatesToForecastDates setting. If value is set to 1, Cobra copies the baseline dates to the 
forecast dates if the following conditions are met: 

 SourceClass is set to a Budget class. 

 TargetClass is set to a Forecast class. 

 Scope is set to All. 

 Criteria is not set to Resource Assignment or Resource. 

Otherwise, Cobra automatically sets the value to 0. 

 

Software Issues Resolved 

API 
Defect 1271064  

Description: When you ran the Reclass process through the API and specified a Control Account Code 
or Work Package Code in the Criteria setting, the Reclass process would fail with the "The method or 
operation is not implemented" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Run the Reclass process using the Reclass wizard. 

Files Updated: 

 Cobra.Api.exe 

 Cobra.Model.LoginManager.dll 

 Cobra.Model.dll 

Calendars » Calendar View 
Defect 1262371 

Description: When you moved the TODATE and ATCOMPLETE flags for Calendar Set 18 in the 
Calendar view and selected Yes on "Calendar sets 18 and 19 do not have labels PREVIOUS, TODATE, 
and ATCOMPLETE on the same periods. Do you want to align 19 with 18?" prompt, Cobra would not 
align the ATCOMPLETE flag for Calendar Sets 18 and 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Manually update the ATCOMPLETE flag for Calendar Set 19 to match the flag 
for Calendar Set 18. 

Files Updated: 

 Cobra.Model.dll 

Attention: See the Reclass Process topic in the Cobra Help System. 

https://help.deltek.com/Product/Cobra/8.3/GA/Reclass%20Process.html
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 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 

Defect 1269024  

Description: When you moved the TODATE flag of a calendar set that was not Calendar Set 18 or 19 
and saved the changes in the Calendar view, Cobra would display the prompt to align Calendar Sets 18 
and 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: Cobra should only display the prompt when you move the TODATE flag for Calendar 
Set 18 or 19. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 

Defect 1269025  

Description: When you moved the ATCOMPLETE flag in the Calendar view for Calendar Set 18 or 19 
and saved the changes, Cobra did not display the prompt to align Calendar Sets 18 and 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 

Defect 1269683  

Description: When you moved the PREVIOUS, TODATE, or ATCOMPLETE flags in the Calendar view 
for Calendar Set 19 and saved the changes, Cobra displayed the following prompt to align the required  
flags for Calendar Set 19 and 18: "Calendar sets 18 and 19 do not have labels PREVIOUS, TODATE, 
and ATCOMPLETE on the same periods. Do you want to align 19 with 18?" when it should be aligning 
Calendar Set 18 with 19. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: When editing either Calendar Set 18 or 19 and moving the PREVIOUS, TODATE, or 
ATCOMPLETE flags to different a calendar period, Cobra now displays the following prompt: "Calendar 
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sets 18 and 19 do not have labels PREVIOUS, TODATE, and ATCOMPLETE on the same periods.  
Calendar sets 18 and 19 do not have labels PREVIOUS, TODATE, and ATCOMPLETE on the same 
periods. Do you want to align 18 and 19?” 

Files Updated: 

 Cobra.Resources.dll 

Documentation 
Defect 1257985 

Description: Information about the OLE database drivers used by the backup/restore and export/import 
features was not documented in the Cobra Installation Guide. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: A note is added to the Software Requirements — Database Driver section of the 
Cobra Installation Guide. 

Files Updated: 

 DeltekCobra83InstallationGuide.pdf 

File » Integration wInsight 
Defect 970578  

Description: When you ran the wInsight Export process, Cobra would not export the actuals if: 

 The project used 3 control account structures. 

 The Code for Control Account level actual costs option was enabled and the costs were captured 
at the control account level but export structure was exported down to the work package level. 

 The project contained several CA entries where CA1 was the same, but CA3 was different (for 
example: CA1/CA2/CA3: 1.1.1.1/1000/1111, 1.1.1.1/1000/2222). 

 The first CA (for example, 1.1.1.1/1000/1111) did not have resource assignments at the control 
account level but at the work package level (for example: 1.1.1.1/1000/1111 WP01). 

 There were actuals at the control account level on any of the other control accounts (for example: 
1.1.1.1/1000/2222).   

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll  

 Cobra.WinUI.exe  

 Cobra.Process.dll 

File » Integration Wizard — Project Data 
Defect 1238172  

Description: When you ran the Integration wizard to load status from Microsoft Project, Cobra would 
encounter the "Variable 'WORKBAC' is not found" error. 
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Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1262366  

Description: When you ran the Integration wizard to load resource assignments from an import file and 
selected to load forecast dates, Cobra would calculate the EAC total even if the forecast class of the 
imported records were not part of the EAC cost set. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Calculate Forecast 
Defect 1256206  

Description: When you ran the Calculate Forecast process, Cobra incorrectly calculated the forecast if 
any of the following conditions were met: 

 The forecast performance factor level was set to control account or work package. 

 The expression of the prior CA/WP (separated by a slash) was not less than or equal to the 
expression of the CA/WP being processed. For example, "1.1.1.2/1000/ /01" is not less than 
"1.1.1.2.1/1000/ /02". 

 The CA/WP being processed contained earned while the prior CA/WP did not contain earned but 
contained budget and/or actuals resource assignments. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Replan 
Defect 1255333  
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Description: When you ran the Replan wizard and selected the Create a new Work Package for the 
replanned Budget/Progress/Actuals option on the Options page, Cobra would not move the baseline 
budget to the replanned work package. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll  

 Cobra.WinUI.exe  

 Cobra.Process.dll 

Reports » Reports 
Defect 1271652 

Description: When you generated the 1921-1 report, Cobra would create an incorrect formula for the 
"C.TOTAL" value. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Edit the 1921-1.xlsx report template and change the formula from {=Cell[R,C-
3]+Cell[R,C-2]} to {=Cell[R,C-3]+Cell[R,C-1]}. 

Files Updated: 

 ReportTemplates\1921-1.xlsx 

 

Defect 1259993 

Description: When you generated the 1921-1 report and a Functional Data Element only contained 
"Recurring" costs, Cobra would display the costs in the "NonRecurring" column of the generated report. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.ReportLayoutEngine.dll 

Tools » Preferences 
Defect 1251389  

Description: When you selected the Include SQL Statements check box for Clientdebuglog.xml on the 
Data Access tab of the Application Preferences dialog box, saved your changes, and then relaunched 
Cobra, the option was no longer selected. The same problem occurred if the option was already checked 
and then you cleared it. 
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Customers Impacted: This defect affects users who run Cobra on a client/server and standalone 
deployments. 

Workaround Before Fix: Modify the IdeaBlade.ibconfig file manually to enable the logging of SQL 
statements. See the Edit IdeaBlade.ibconfig file help topic for more information. 

Additional Notes: For standalone or client/server deployment, this option is now saved in the 
IdeaBlade.ibconfig file used by Cobra. In case Cobra fails to save this option, see the Troubleshoot 
Issues with Saving to the IdeaBlade.ibconfig File in Cobra help topic for more information. 

For n-tier deployment, the behavior of this option has not changed. The selected option will apply to all 
clients of the n-tier server until the n-tier server service is restarted. 

Files Updated: 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 Cobra.Resources.dll 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 ConfigManager.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. 

Document Details 

Cobra 8.3 Help System  Updated the following help topics for the “Renamed 
the IPMDR Format” enhancements: 

 Cost Data Export 

 Cost Data Wizard 

 Project and Format Page of the Cost Data 
Wizard 

 Codes and Structures Page of the Cost Data 
Wizard 

 Data Options Page of the Cost Data Wizard 

 Save and Run Page of the Cost Data Wizard 

 Export Cost Data 

 Exported Cost Data File 

https://help.deltek.com/Product/Cobra/8.3/GA/Edit%20IdeaBladeibconfig%20File.html
https://help.deltek.com/Product/Cobra/8.3/GA/Troubleshoot%20Issues%20with%20Saving%20to%20the%20IdeaBlade.ibconfig%20File%20in%20Cobra.html
https://help.deltek.com/Product/Cobra/8.3/GA/Troubleshoot%20Issues%20with%20Saving%20to%20the%20IdeaBlade.ibconfig%20File%20in%20Cobra.html
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Document Details 

 Display the Cost Data Wizard 

 General Tab of the Project Properties Dialog Box 

 Contract Information Tab of the Project 
Properties Dialog Box 

 Updated the Reclass Process topic for the “Support 
for the Copy baseline dates to forecast dates option 
of the Reclass Wizard in API and Web Services” 
enhancement. 

 Created the following topics for Defect 1251389: 

 Troubleshoot Issues with Saving to the 
IdeaBlade.ibconfig File in Cobra 

 Clear the Read-only Flag in the 
IdeaBlade.ibconfig File 

 Run Cobra Using a Different IdeaBlade.ibconfig 
File 
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Cobra 8.3 Cumulative Update 02 
Released: February 28, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Cost Data Export 
Defect 1254685 

Description: When you ran the Cost Data Export wizard to generate the Integrated Program 
Management Data Report (IPMDR) file with the Detail data contains options cleared and the Selected 
burdens are NonAdd options selected on the Data Options page, the Summary Performance file of the 
generated JavaScript Object Notation (JSON) files contained duplicate values. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 PPM.CostData.dll 

File » Integration Wizard – Project Data 
Defect 1254659 

Description: When you ran the Integration wizard to load status data from a master project, Cobra would 
encounter the "Could not find Control Account" message. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Installation 
Defect 1241428  

Description: The Database Upgrade wizard would always look for the C:\Program Files 
(x86)\Deltek\Cobra path even if Cobra was installed in an alternate folder other than the C:\ folder. 
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Customers Impacted: This defect affects users who install Cobra on a different drive or path other than 
the default installation directory. 

Workaround Before Fix: Copy the Config.dat and DATASOURCES.DAT files to the C:\Program Files 
(x86)\Deltek\<Cobra path>. 

Additional Notes: You may also perform any of these workaround: 

Option 1: Launch the Cobra Database Upgrade wizard using the /configfolder parameter.  

1. Click Start » All Programs » Accessories, right-click the Command Prompt, and select 
Run as administrator. 

2. On the Administrator Command Prompt window, enter the command using the following 
syntax: "<Cobra Installation 
Location>\Support\Utilities\DeltekCobra8xDatabaseUpgradeWizard.exe" 
/configfolder:<Target folder> 

For example: “E:\Program Files 
(x86)\Deltek\Cobra\Support\Utilities\DeltekCobra83DatabaseUpgradeWizard.exe” 
/configfolder:E:\Program Files (x86)\Deltek\Cobra 

 

Option 2: Add a configuration registry option. 

1. Create the following entries in the configuration registry: 
HKEY_CURRENT_USER\Software\Deltek\Cobra\8.3 

2. Create a ProgramFolder String Value with the value set to the location of the Config.dat 
or IdeaBlade.Ibconfig file; for example: "E:\Program Files (x86)\Deltek\Cobra". 

Files Updated: 

 DeltekCobra83DatabaseUpgradeWizard.exe 

Project Processes 
Defect 1247603  

Description: When you ran a process and Cobra logged a warning or error message, Cobra would crash 
instead of displaying the untranslated string ID if the resource ID was not found. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Note: Use quotes around the location of the exe.file. Do not use quotes around the target folder. See 
the “Run Cobra with Command Line Parameters” topic in the Cobra Help System for more 
information. 

https://help.deltek.com/Product/Cobra/8.3/GA/Run%20Cobra%20with%20Command%20Line%20Parameters_3.html
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Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Cobra 8.3 Cumulative Update 01 
Released: January 31, 2020 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 

File » Integration Cost Data Export 
Defect 1237415 

Description: When you ran the Cost Data wizard against a large project to generate the Deltek Costa 
Data Exchange (DCDE) file, Cobra would crash with a "System.OutofMemoryException" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Model.dll 

 Cobra.Model.LoginManager.dll 

 PPM.CostData.dll 

File » Integration Wizard — Project Data 
Defect 1194236  

Description: When you initialized a shared database between Open Plan 8.3 and Cobra 8.3 using the 
Open Plan 8.3 Data Tool, the following error occurred: “Unable to insert data into target table WST_UPF." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.3 on an Oracle or a 
SQL database. 

Workaround Before Fix: None. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.3 Cumulative Update # 04 Defect 
1222654. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

 

 

 

Defect 1225665  
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Description: When you initialized a shared database between Open Plan 8.2 and Cobra 8.3 using the 
Open Plan 8.2 Data Tool, the following error occurred: “Unable to insert data into target table WST_UPF." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.2 on an Oracle or a 
SQL database. 

Workaround Before Fix: None. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.2 Cumulative Update # 13 Defect 
1225706. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

 

Defect 1225668  

Description: When you initialized a shared database between Open Plan 8.3 and Cobra 8.3 using the 
Open Plan 8.3 Data Tool, the following error occurred: “Unable to insert data into target table WST_DCT." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.3 on a SQL 
database. 

Workaround Before Fix: Re-initialize the Open Plan Data Tool. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.3 Cumulative Update # 04 Defect 
1222654. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

 

Defect 1225670  

Description: When you initialized a shared database between Open Plan 8.2 and Cobra 8.3 using the 
Open Plan 8.2 Data Tool, the following error occurred: "Unable to insert data into target table WST_DCT." 

Customers Impacted: This defect affects users who use Cobra 8.3 with Open Plan 8.2 on a SQL 
database. 

Workaround Before Fix: Re-initialize the Open Plan Data Tool. 

Additional Notes: This defect is tracked in Deltek Open Plan 8.2 Cumulative Update # 13 Defect 
1225706. 

Files Updated: 

 OpenPlanDataTool.exe 

 SQL\Access\OPMaster82.mdb 

Help 
Defect 1237371 

Description: When you accessed the Cobra Help locally, opened the Data Dictionary topic, and clicked 
the Data Dictionary link, you would encounter the following error: "Cannot find file... Make sure the path or 
internet address is correct."  



Cobra 8.3 Cumulative Update 01 

Cumulative Update 11 Release Notes 41 

 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: Access the Data Dictionary using the hosted help. 

URL: https://help.deltek.com/Product/Cobra/8.3/GA/DataDictionary/index.htm 

Files Updated: 

 DeltekCobra83.exe 

Projects » Project View 
Defect 1179645 

Description: When you modified a control account in the project view and then moved to another control 
account, Cobra would not save the changes automatically if the project audit log was turned on and the 
log level was set to work package or resource assignment. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: Cobra should save the changes automatically after you modify a control account and 
move to another one whether the audit log is enabled or disabled at any level. 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

Projects » Calculate Forecast 
Defect 1225384 

Description: When you ran the Calculate Forecast wizard against a forecast class that did not exist as a 
resource assignment, Cobra would create the forecast time-phased data but would not create the 
resource assignment if any of the following conditions applied: 

 The class was the last forecast class processed for each control account or work package. 

 Closed control account or work packages 

 ETC value was 0. 

 Forecast method was Manual Forecast (Retain EAC), actual total was not 0, and existing BAC 
was 0. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1238441 

Description: When you ran the Calculate Forecast wizard against a forecast class that used the Percent 
Complete Ranges forecast method and more than one control account or work package were being 

https://help.deltek.com/Product/Cobra/8.3/GA/DataDictionary/index.htm
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calculated, Cobra would calculate the forecast using the PF=1 method if any of the following conditions 
applied: 

 The performance factor level was set to control account or work package and the length of the 
CA/WP ID was longer than the ID of the first control account or work package processed. 

 The control account or work package percent complete did not match the % complete range of 
the first control account or work package processed. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Files Updated: 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

 

Defect 1237351 

Description: When you ran the Calculate Forecast wizard, Cobra would fail with the "String ID 
ID_COB_PRC_CFCST_MSG88 does not exist" error. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None: 

Files Updated:  

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Project Processes » Calculate Progress 
Defect 1228656 

Description: When you ran the Calculate Progress wizard and set the Progress by option on the 
Options page to Budget, the total progress value would exceed the total budget for result(s) if the 
budgeted result(s) contained significant negative values and/or rate reduction. 

Customers Impacted: This defect affects all users. 

Workaround Before Fix: None. 

Additional Notes: Calculated earned value will be adjusted so that by result, its earned value does not 
exceed the BAC.  For each result, Calculate Progress will total the calculated earned value and subtract 
that from BAC. 

 If the calculated earned value is greater than BAC, Calculate Progress will set earned value to 
equal BAC. 

Exception: If the calculated earned value and BAC are both negative, Calculate Progress will 
use the positive value of both values to compare if Calculated Earned > BAC. 

 This will only affect Progress by method = “Budget”. The behavior for all of the other Progress 
by methods (Dollars, Hours SPI, and Time) will not change. 

 This will be applied to all Progress techniques except for Level of Effort, as LoE should always 
equal budget month by month. 
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With exception to LOE, the following example scenarios show how Calculate Progress will now calculate 
when a result’s earned value exceeds its BAC: 

BAC 400 360 -400 -360 400 -400 -1 -400 

Previously 
Calculated 
Earned 

360 400 -360 -400 -360 360 -400 1 

New 
Calculated 
Earned 

360 360 -360 -360 -360 -400 -1 -400 

Files Updated: 

 Cobra.WinUI.*.dll 

 Cobra.WinUI.exe 

 Cobra.Process.dll 

Database Changes 
This section includes changes made to the database. There are no database changes in this release. 

Data Changes 
This section includes changes to the data applied by script. There are no data changes in this release. 

Documentation Changes 
This section includes details of section changes in the printed documentation. There are no 
documentation changes in this release. 
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Appendix A: Download and Install the 
Cumulative Update  

Download the Cumulative Update 
1. From Internet Explorer, go to https://dsm.deltek.com.  

2. Click Run Deltek Software Manager.  

3. Log in using your Deltek Customer Care Connect credentials.  

4. In the left pane of the Deltek Software Manager, expand your Deltek product.  

5. Expand the Cumulative Updates folder for your product, and select the update to download.  

6. Click Download at the bottom of the screen. 

Install the Cumulative Update 
Use the instructions below that apply to the Cobra version you use. 

 

For Cobra 8.x and Higher 
The instructions for installing an update for Cobra 8.x and higher depend on your type of deployment. Use 
the instructions below that apply to your deployment scenario. 

 

If You Use a Deployment Server 

To install on the server: 

1. Verify that Cobra is not running.  

2. Launch the update on the server.  

 

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish.  

Note: You must install the entire update package. If an update addresses more than one defect, you 
cannot fix one defect at a time. 

Note: You must install the entire update package. If an update addresses more than one defect, you 
cannot fix one defect at a time. 

Note: If the update detects that Cobra is already running, you will see a prompt asking if you want to 

close Cobra. Choose Yes to start the installation or choose No to cancel the installation. 

https://dsm.deltek.com/
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6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish.  

7. Launch the Deltek Cobra shortcut on client workstations to initiate the update. 

To install on a client workstation: 

1. Launch the Deltek Cobra shortcut. Cobra detects that an updated version is available and 
displays the prompt: Do you want to install the upgrade?  

2. Choose Yes to start the installation or choose No to cancel the installation. When the installation 
is completed, the installation wizard closes.  

3. Launch the Deltek Cobra shortcut to log into Cobra. 

If You Have an N-Tier Deployment 

To install on the server: 

1. Verify that Cobra is not running.  

2. Launch the update on the server.  

 

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish. 

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish. 

7. Launch the Deltek Cobra shortcut on n-tier client workstations to initiate the update. 

To install on an n-tier client workstation: 

1. Launch the Deltek Cobra shortcut. Cobra detects that an updated version is available and 
displays the prompt: Do you want to install the upgrade?  

2. Choose Yes to start the installation or choose No to cancel the installation. If you choose Yes, 
the installation wizard copies the updated DeltekCobraWorkstation.exe file locally and 
automatically begins installing files. When the installation is completed, the installation wizard 
closes.  

3. Launch the Deltek Cobra shortcut to log into Cobra. 

If You Have a Terminal Services/Citrix Deployment 

To install on the deployment server: 

1. Verify that Cobra is not running.  

2. Launch the update on the server. 

Note: If the update detects that Cobra is already running, you will see a prompt asking if you want to 

close Cobra. Choose Yes to start the installation or choose No to cancel the installation. 



Appendix A: Download and Install the Cumulative Update 

Cumulative Update 11 Release Notes 46 

 

 

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish. 

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish. 

7. Log on as a Local Administrator on the Terminal Server/Application Server and install the update. 

To install on the Terminal Server/ Application Server (the server on which the Cobra client runs): 

1. Log on to the Terminal Server using an account that has Local Administrator privileges. When the 
setup launches, the installation program installs all necessary files and any registry updates and 
makes these changes available to all users who will subsequently log on to the Terminal Server 
session to run Cobra.  

2. Ensure that no instance of Cobra is running.  

3. Browse to the shared Cobra Workstation folder (usually located on the deployment server, as 
\\{DeploymentServerName}\CobraWorkstation\DeltekCobraWorkstation.exe).  

4. Launch the DeltekCobraWorkstation.exe file to install the update. The Welcome screen displays, 
showing that the update is available.  

5. Click Next to start the installation.  

6. When the installation completes, launch the Deltek Cobra shortcut to log into Cobra and confirm 
that the update is installed, meaning that users can now launch Cobra via Terminal 
Services/Citrix sessions. 

If You Have a Standalone Deployment 

To install on the workstation: 

1. Verify that Cobra is not running.  

2. Launch the update on the server.  

3. The Welcome screen displays the current build, along with the new build being installed by the 
update. Click Next to begin the installation.  

4. The installation wizard installs all necessary files and displays the Update Complete form.  

5. Click Finish.  

6. Depending on the type of update, a reboot may be required. If the option to reboot your computer 
is enabled, select it and click Finish. 

7. Launch the Deltek Cobra shortcut to log into Cobra. 

Confirm that the Cumulative Update is Installed 

1. Click  » Help » About Deltek Cobra. 

Note: If the update detects that Cobra is already running, you will see a prompt asking if you want to 

close Cobra. Choose Yes to start the installation or choose No to cancel the installation. 
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2. Check that the version number reflects the installation of the update. 
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Appendix B: For Additional Information 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 

 Search for product documentation, such as release notes, install guides, technical information, 
online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 
Deltek Support Center Community 

 Access Cloud-specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Initiate a Chat to submit a question to a Customer Care analyst online 

 

Access Deltek Support Center 

To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 

 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/


 

 

About Deltek 
Better software means better projects. Deltek delivers software and information solutions that enable 
superior levels of project intelligence, management and collaboration. Our industry-focused expertise 
makes your projects successful and helps you achieve performance that maximizes productivity and 
revenue. www.deltek.com 

 

http://www.deltek.com/
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