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Overview 
Welcome to wInsight Analytics Module 8.2. This installation guide will help you successfully install this 
application on your system and make it work efficiently according to your organization’s business structure. 

QlikView Documentation 
For the wInsight Analytics system administrator, additional documentation is available on QlikView®, QlikView Server, 
QlikView Publisher, the QlikView automation interface, and the QlikView API. Documentation is located in 
C:\ProgramData\QlikTech\QlikView Documentation and in C:\ProgramData\QlikTech\QlikView Server Documentation 
on the wInsight Analytics Module server or on the standalone computer running the wInsight Analytics Module. 

Adding Custom Notes to This Guide 
If you would like to add custom notes to this guide that are specific to your company, Adobe® Reader® X provides this 
ability. If you do not already use Adobe Reader X, you can download it here free from Adobe.  

To add a custom note using Adobe Reader X: 
1. On the Reader toolbar, click Comment at the far right. 

2. In the Annotations pane that displays, click  Sticky Note. The cursor changes to match the button. 

3. Position the cursor at the location in the guide where you want the note to appear, and click. A note icon is 
inserted at the location and a text box pops up. 

4. Enter your information in the text box.   

5. Continue adding notes as needed. 

6. Save the document. 

Note: Deltek recommends that you save the document to a slightly different filename so as to keep the original from 
being overwritten. 

When reading the document, cursor over a note icon to see the information. Double-click a note icon to edit the 
information. 

http://get.adobe.com/reader/
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Downloading Deltek Products using Deltek Software 
Manager 
You can use Deltek Software Manager (DSM) to download complete Deltek products, hot fixes, cumulative updates, 
and sub-releases. You can access DSM through the Deltek Support Center or use Deltek Software Manager Lite to 
download Deltek products. 

Accessing DSM from within the Deltek Support Center 
To access DSM from within the Deltek Support Center: 

1. In your Web browser, go to http://support.deltek.com.  

2. Enter your Deltek Support Center Username and Password, and click Login. 
3. When the Deltek Support Center page displays, click Product Downloads. 

4. On the Deltek Software Manager screen, click Launch Deltek Software Manager. 
5. Click Settings at the top right of the dialog box to use the Settings dialog box to specify the folder where you 

want to download Deltek products, and click OK.  

Note: When you log on for the first time, DSM asks you to select a default folder where Deltek products are to 
be downloaded.  

You can change this folder anytime in the Settings dialog box. 

6. In the left pane, expand the Deltek product that you want to download, if it is not already expanded.  

7. Select the product type that you want to download.  

Options include: 

 Complete 
 Cumulative Updates 
 HotFixes 
 Sub-Release 

8. In the table, select the check box that corresponds to the Deltek product that you want to download.  

The right pane displays a message stating that the product has been added to the download queue. 

Note: To view the items in the download queue, click View Download Queue at the bottom of the left pane. 
9. Click Download at the bottom of the left pane to download the product to the folder that you selected.  

Accessing DSM Lite 
To access Deltek Software Manager Lite: 

1. In your Web browser, go to https://dsm.deltek.com/DeltekSoftwareManagerLite.  

2. Enter your Deltek Support Center Username and Password, and click Logon. 
3. When the Deltek Software Manager Lite page displays, select a product from the drop-down list. 

4. Click the product type that you want to download.  

http://support.deltek.com/
https://dsm.deltek.com/DeltekSoftwareManagerLite
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Note: The download behavior and download folder may differ depending on the browser and browser settings 
that you are using. 

DSM Documentation and Troubleshooting 
 To view the online help for Deltek Software Manager, click here. 

 To view a tutorial on how to use Deltek Software Manager, click here.  

 To view more information on troubleshooting Deltek Software Manager, click here. 

Note: When you click a link, you will be asked to log into DSM if you aren’t already logged in. 

https://dsm.deltek.com/DeltekSoftwareManager/Help/
https://deltek.custhelp.com/app/answers/detail/a_id/50668
https://deltek.custhelp.com/app/answers/detail/a_id/52469
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Before You Begin Deployment 
Before you begin deployment, it is important to understand the following: 

 Logical Tiers 

 Deployment Models 

 Hardware and Software Requirements 

Logical Tiers Overview 
The wInsight Analytics product suite uses a multitier (n-tier) architecture. Various parts of a wInsight Analytics product 
are distributed to logical tiers for performance and scalability. The logical tiers are as follows: 

 Client Tier — This tier performs wInsight Analytic’s functional process logic and provides the user interface 
layer. This tier can be a workstation or a Citrix/Terminal Server.  

 Web/Application Tier — The Web tier, which contains no business logic, passes requests from browser to 
server and vice versa, while also packaging and unpackaging data. The application tier, built around QlikView 
Server, maintains both user sessions and manages application transactions. 

 Database Tier — This tier consists of database servers where the wInsight Analytics data is stored and 
retrieved. 

Deployment Models 

Stand-Alone Deployment 

Deltek wInsight Analytics has a stand-alone deployment model. Users who previously operated the legacy wInsight 
Desktop or wInsight Professional applications installed on their workstations can continue to use the wInsight Analytics 
versions of those applications deployed locally on their workstations. 

N-Tier Deployment  

In an n-tier installation, the processing occurs on the application server. It is recommended that the database tier reside 
on a different computer than the application server. The connection between the application server and the database 
should limit the number of routers and firewalls that can adversely affect data traffic. 

Attention: For detailed instructions about the installation process, see the individual component installation guides 
specified in the Additional Documentation section. 
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Unsupported Scenarios 
The wInsight Analytics Module installation does not support installing any tiers on any of the following servers:  

 Domain Controller  

 Microsoft® Exchange Server  

 Proxy, Firewall, or ISA Server  

 Microsoft SharePoint Portal Server  

 Small Business/Essential Business Server  

Using these services/servers can cause significant issues in the performance, reliability, and functionality of the 
application and other applications on your network. 
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System Requirements 
Your organization has made a substantial commitment to ensure it has a fully integrated earned value management 
(EVM) solution. To support that commitment, Deltek recommends that you carefully consider the hardware 
requirements necessary to run a wInsight Analytics product properly. 

Platform Virtualization  
Platform Virtualization is a technology that allows multiple operating systems and platforms to run simultaneously as 
separate virtual machines on a single set of server hardware.  

Deltek recognizes the growing use of virtual environments by our customers. Virtual environment software, such as 
VMware®, resides in the hardware layer underneath the operating system and is used by customers to partition a 
single server into a multiple server/multiple operating system environment. Deltek’s product development makes limited 
use of virtual environments at this time.  

Attention: For more information, see Virtual Environments Statement on the Deltek Support Center. 

Display Settings 
The recommended display resolution is 1440 x 900 or higher. 

Hardware Sizing Considerations 
There are several factors that go into sizing an appropriate server infrastructure. The number of concurrent users 
accessing the system at any given time, the amount of data being analyzed, and growth expectations all have an 
impact on the initial sizing plans. The hardware profiles are intended as a starting point for deployment. It is expected 
that our clients will use the product in many different ways, such as planning for future release, and client 
customizations. Further in-depth discussion of the business needs of the solution during implementation will provide 
final guidance on hardware requirements. 

The number of elements, records, contracts, and accounting periods analyzed all have an impact on the amount of 
RAM you will need in the application server. This data, along with other information, is loaded into RAM on the 
application server, which allows for much more rapid analytics and display results. If the application server does not 
have enough RAM to store all of the required data, then it will get loaded into virtual memory, which has a significantly 
slower response capability than RAM.  All data used by wInsight Analytics for aggregation and display is stored in 
system memory, so hard drive storage does not have a significant impact on server sizing. 

Memory Requirements for a Typical/Average Use 
Below are details on the memory footprint of the product. This can be helpful when sizing a client tier that runs in a 
virtual environment, Citrix®, or Terminal Server. 

Tier Memory* 

Client Tier 2 GB (assuming the wInsight Analytics Module is being run as a server application). 

Web/Application Tier The memory of the server should be approximately 10% – 20% of the database size (for 
example, 1- 2GB for a 10 GB database) plus 10% for each concurrent user. This would 
mean that for an Oracle or SQL Server where the data size is 10 GB and where you 
expect 20 concurrent users, you should allow 2GB plus 20 x 200 MB, for example, 6 GB 
of memory for the wInsight Analytics Module. 

Database Tier Database instance memory should be 10%–15% of the database size. For example, if 
database size is expected to be 500 GB, then allocate 50 GB–75 GB memory. 

https://deltek.custhelp.com/app/utils/login_form/redirect/home
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* Per concurrent client instance and in addition to any memory needed for the operating system and other applications 
that may run in parallel with this product. 

Definition of Typical/Average Use 

Sample Details for a Typical Small/Medium Data Sizing: 

 Number of Contracts: 50 

 Number of Element Records: 50,000   

 Number of Earned Value Records: 1,200,000 

 Number of Past and Future Period Records: 75,000,000 

Hardware Requirements 
Note: Specific server hardware configurations may have an impact on your overall Deltek product licensing 
requirements. It is recommended you confirm with a Deltek Technical Sales Engineer if the server hardware you plan to 
deploy is in line with your Deltek license agreement and how overall server infrastructure expansion in the future may 
affect your Deltek licensing. 

Stand-Alone Deployment 

The following table lists the recommended minimum hardware and software requirements for a deployment in a stand-
alone environment: 

Tier Hardware Required Determining Factors 

Client Tier  Intel Core 2.0 Duo or higher 
 4 GB RAM (Depending on data 

volumes, more may be required.) 

 80 GB Hard Drive 

 Database Size 

 Database Growth 

N-Tier Installation for 1 to 10 Concurrent Users 

Tier Hardware Required Determining Factors 

Web/ Application Tier Server Class Machine 
 1 x Six-core x64 2.86+ GHz or 

faster CPU 

 32+ GB Physical memory (adjust 
as needed based on the RAM 
discussion below) 

 RAID 1 Disk array (for fault 
tolerance and performance, also 
consider adding an additional hard 
drive to perform as a hot spare for 
the RAID set) 

 100/1000 Mb Network card 

 Number of contracts 

 Contract size 

 Number of elements and records 
analyzed 

 Number of accounting periods 
used (# of months & sub-periods) 

 Configuration of QVW 

 Concurrent Users 
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N-Tier Installation for 11 to 25 Concurrent Users 

Tier Hardware Required Determining Factors 

Web/ Application Tier Server Class Machine 
 2 x Six-core x64 2.86+ GHz or 

faster CPU 

 64+ GB Physical memory (adjust 
as needed based on above RAM 
discussion) 

 RAID 1 Disk array (for fault 
tolerance and performance, also 
consider adding an additional hard 
drive to perform as a hot spare for 
the RAID set) 

 100/1000 Mb Network card 

 Number of contracts 

 Contract size 

 Number of elements and records 
analyzed 

 Number of accounting periods 
used (# of months & sub-periods) 

 Configuration of QVW 

 Concurrent Users 

N-Tier Installation for 26+ Concurrent Users 

Tier Hardware Required Determining Factors 

Web/ Application Tier Server Class Machine 
 2 x Six-core x64 2.86+ GHz or 

faster CPU 

 64+ GB Physical memory (adjust 
as needed based on the RAM 
discussion below) 

 RAID 1 Disk array (for fault 
tolerance and performance, also 
consider adding an additional hard 
drive to perform as a hot spare for 
the RAID set) 

 100/1000 Mb Network card 

 Number of contracts 

 Contract size 

 Number of elements and records 
analyzed 

 Number of accounting periods 
used (# of months & sub-periods) 

 Configuration of QVW 

 Concurrent Users 

Software Requirements 
Note: Supported versions are the currently actively tested versions of technologies used to deploy wInsight Analytics. 
Except for the Deltek Integrated Products, these technologies are not directly supported by Deltek. Changes to these 
technologies occur at the discretion of the individual technology vendors.  

Compatible versions are the recent previously supported and tested technologies used to deploy wInsight Analytics. 
These are not actively being tested but are believed to be compatible with wInsight Analytics. Deltek does not 
recommend these technologies for new deployments but will make its best effort to answer questions concerning these 
technologies. These technologies may not be available for troubleshooting at Deltek. 
For a complete list of the recommended minimum software requirements, see the Deltek Product Support Compatibility 
Matrix document that you can download from the Deltek Support Center. 

https://deltek.custhelp.com/app/utils/login_form/redirect/home
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Stand-Alone Installation 

Supported and Compatible Deployment Technology 

Operating System  Microsoft Windows® 7 

 Microsoft Windows 8.1 

 Microsoft Windows 10 

 Microsoft  Windows Server® 2008 R2 (x64) (Compatible)   

 Microsoft  Windows Server 2012 

 Microsoft  Windows Server 2012 R2 

 Microsoft  Windows Server 2016 

Citrix  XenApp 6.* (Windows Server 2008 R2) (Compatible)   

 XenApp 7.* (Windows Server 2008 R2) (Compatible)   

 XenApp 7.* (Windows Server 2012) 

 XenApp 7.* (Windows Server 2012 R2) 

 XenApp 7.* (Windows Server 2016) 

Database  Microsoft SQL Server 2012 

 Microsoft SQL Server 2014 

 Microsoft SQL Server 2016 

 Microsoft SQL Server 2017 

 Microsoft SQL Server 2017 is also supported on Linux and Unix 

 Microsoft SQL Server Express 2012 

 Microsoft SQL Server Express 2014 

 Microsoft SQL Server Express 2016 

 Microsoft SQL Server Express 2017 

 Microsoft Access 2010 

 Microsoft Access 2013 

 Microsoft Access 2016 

 Oracle 11.2 

 Oracle 12.2 

 Oracle is also supported in Linux, Unix, and Exadata.  

Database Drivers Note: wInsight Analytics Module requires 64-bit database drivers. 

 Oracle Provider for OLE DB 

 Microsoft SQL Server Native Client 

 Microsoft OLE DB Provider for SQL Server 
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Supported and Compatible Deployment Technology 
 Microsoft OLE DB Provider for Jet 

 Microsoft ACE OLEDB 12 

 Microsoft ACE OLEDB 15 

Microsoft Office Note: The 64-bit Access drivers are not compatible with 32-bit versions of MS Office. If 
are using Access on the server, you need to install 64-bit versions of Excel (and other 
Office products). 

 Microsoft Excel 2010 (Compatible)   

 Microsoft Excel 2013 

 Microsoft Excel 2016 

 Microsoft Excel 365 (ProPlus)   

Embedded 
Technologies 

 Visual C++ 2015 Redistributable Package (x86) 

 MSXML 6.0 Service Pack 2 (Microsoft XML Core Services) 

.NET Framework  Microsoft .Net Framework 4.5.2 

 Microsoft .Net Framework 4.6 

 Microsoft .Net Framework 4.6.1 

 Microsoft .Net Framework 4.6.2 

 Microsoft .Net Framework 4.7 

 Microsoft .Net Framework 4.7.1 

 Microsoft .Net Framework 4.7.2 

Attention: You can download the Microsoft.NET Framework from Microsoft’s Web site at 
http://www.microsoft.com/en-us/download/details.aspx?id=17718. For instructions for 
adding it using Server Manager, see your Microsoft Windows documentation. 

Client/Server and IIS Installation 

Supported and Compatible Deployment Technology 

Web Server  Internet Information Services 7.5 (Compatible)   

 Internet Information Services 8 

 Internet Information Services 8.5 

 Internet Information Services 10 

 QlikView Web Server 12.2 SR2 

Note: When installing IIS, make sure to install the IIS Management Scripts and Tools, 
ASP.NET 4.5, and Windows Authentication components. For information on how to install 
these components, refer to the Microsoft documentation at https://docs.microsoft.com/en-
us/iis/install/installing-iis-85/installing-iis-85-on-windows-server-2012-r2.  

http://www.microsoft.com/en-us/download/details.aspx?id=17718
https://docs.microsoft.com/en-us/iis/install/installing-iis-85/installing-iis-85-on-windows-server-2012-r2
https://docs.microsoft.com/en-us/iis/install/installing-iis-85/installing-iis-85-on-windows-server-2012-r2
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Supported and Compatible Deployment Technology 

Citrix  XenApp 6.* (Windows Server 2008 R2) (Compatible)   

 XenApp 7.* (Windows Server 2008 R2) (Compatible)   

 XenApp 7.* (Windows Server 2012) 

 XenApp 7.* (Windows Server 2012 R2) 

 XenApp 7.* (Windows Server 2016) 

Database  Microsoft SQL Server 2012 

 Microsoft SQL Server 2014 

 Microsoft SQL Server 2016 

 Microsoft SQL Server 2017 

 Microsoft SQL Server 2017 is also supported on Linux and Unix 

 Microsoft SQL Server Express 2012 

 Microsoft SQL Server Express 2014 

 Microsoft SQL Server Express 2016 

 Microsoft SQL Server Express 2017 

 Microsoft Access 2010 

 Microsoft Access 2013 

 Microsoft Access 2016 

 Oracle 11.2 

 Oracle 12.2 

 Oracle is also supported in Linux, Unix, and Exadata 

Database Drivers Note: wInsight Analytics Module requires 64-bit database drivers.  

 Oracle Provider for OLE DB 

 Microsoft SQL Server Native Client 

 Microsoft OLE DB Provider for SQL Server 

 Microsoft OLE DB Provider for Jet 

 Microsoft ACE OLEDB 12 

 Microsoft ACE OLEDB 15 

Microsoft Office  Microsoft Excel 2010 (Compatible)   

 Microsoft Excel 2013 

 Microsoft Excel 2016 

 Microsoft Excel 365 (ProPlus)   

Browsers  Internet Explorer 11 
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Supported and Compatible Deployment Technology 
 Microsoft Edge 

 Chrome© 

 Safari® 

 Firefox© 

Embedded 
Technologies 

 Visual C++ 2015 Redistributable Package (x86) 

 MSXML 6.0 Service Pack 2 (Microsoft XML Core Services) 

.NET Framework  Microsoft .Net Framework 4.5.2 

 Microsoft .Net Framework 4.6 

 Microsoft .Net Framework 4.6.1 

 Microsoft .Net Framework 4.6.2 

 Microsoft .Net Framework 4.7 

 Microsoft .Net Framework 4.7.1 

 Microsoft .Net Framework 4.7.2 

Attention: You can download the Microsoft.NET Framework from Microsoft’s web site at 
http://www.microsoft.com/en-us/download/details.aspx?id=17718. For instructions for 
adding it using Server Manager, see your Microsoft Windows® documentation. 

http://www.microsoft.com/en-us/download/details.aspx?id=17718
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Types of Installations 
You can install the wInsight Analytics Module on a server for use by multiple users, on a standalone computer for use 
by a single user, or run it under Internet Information Services (IIS). This guide contains instructions and related 
information for all types of installations. 

 Server installation - For information on how to install the wInsight Analytics Module on a server, see Server 
Installation. 

 Standalone Installation - For information on how to install the wInsight Analytics Module on a standalone 
computer, see Standalone Installation. 

 Internet information Services (IIS) Installation - You can install the wInsight Analytics Module on a server for 
use by multiple users, on a standalone computer for use by a single user, or run it under Internet Information 
Services (IIS) with self-signed Secure Sockets Layer (SSL) certificate. For information on how to install the 
wInsight Analytics Module to run under Internet Information Services (IIS), see Internet Information Services 
(IIS Installation). 

 Upgrade installation - You may also upgrade your existing wInsight Analytics Module installation. For more 
information, see Upgrade Installation. 

Attention: It is crucial that you read this entire document as there are a number of important steps that you must 
complete, including steps both before and after the actual installation. You will need to log on with the QlikView service 
account that the setup creates (DeltekAnalytics is the default) or that you specify during the installation and perform 
various tasks outlined below. It is very important that you perform these tasks while logged on to the account specified 
in the instructions. 
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Upgrade Installation 
If you are currently using an earlier version of the wInsight Analytics Module and are upgrading to 8.2, read the 
important notes below before you begin the 8.2 installation. 

Prepare Your Existing Server / Standalone Computer for Upgrade 
If you are upgrading to 8.2 on your existing production wInsight Analytics Module server or standalone computer, you 
must follow the steps below, uninstall the wInsight Analytics Module, and then follow the installation steps for a new 
installation.  

To prepare your existing wInsight Analytics Module server or standalone computer for 8.2 installation, 
complete the following steps: 

1. Back up your current wInsight Analytics folders. On the server or standalone computer, make backup copies of 
the following wInsight Analytics installation folders and their sub-folders:  

 Admin 

 Setup 

 Final 

Note: By default, these folders are located in C:\ProgramData\Deltek\Analytics for server installation and 
C:\Users\<User name>\<Documents>\Deltek\Analytics for standalone installation. 

This is crucial if you want to restore your configuration settings following the installation.  

2. Verify the validity of your QlikView License. 

Attention: This release includes updating the QlikView application to version 12.2 and may require an update 
to your QlikView license. For more information, see the  Appendix E: Check QlikView License Validity section. 

3. Uninstall your existing wInsight Analytics Module.  

If you reinstall wInsight Analytics Module 8.2 on top of an existing 8.2 installation, the installer displays the 
following message: 

               
4. Uninstall QlikView. For more information, see Appendix C: Uninstall QlikView.  

Note: If you want to install 8.2 in a different location, you must first uninstall it and then follow the installation steps for a 
new installation. 
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Server Installation 
The information in this section applies to server installations only.  

 If you are performing an installation on a standalone computer, see Standalone Installation. 

 If you plan to install wInsight Analytics Module to run under IIS with self-signed Secure Sockets Layer (SSL) 
certificate, see Internet Information Services (IIS) Installation.  

Attention: The person installing the wInsight Analytics Module should be familiar with MS SQL, Oracle, and MS 
Access databases, domain accounts, Windows Authentication, IIS Manager, EPM Security Administrator, and wInsight 
Analytics Administrator. 

Preinstallation Checklist 
Steps Related Topics 

1. Make sure all the prerequisites are installed. System Requirements 

2.  To complete the wInsight Analytics Module server 
installation, you must have the following: 

 Logon credentials with administrative rights 

 Service account  

 Serial number and control number for the QlikView 
Server 

 

3. Verify the validity of your QlikView License. 

This release includes updating the QlikView application to 
version 12.2. It may require an update to your QlikView 
license as licenses with a validity date prior to the release of 
version 12.2 (November 2017) will not work with this version.  

Appendix E: Check QlikView License 
Validity 

4.  Deltek recommends that you install wInsight Analytics 
Administrator 8.2. This includes the EPM Security 
Administrator installation. 

For information on installing the wInsight 
Analytics Administrator, see the Deltek 
wInsight Analytics Administrator 8.2 
Installation Guide. 

Your Service Account 
The wInsight Analytics Module requires one service account which you specify during the installation process. The 
account can be a local account or domain account. If you plan to use domain accounts, it is crucial that you read the 
requirements and recommendations in the next section.  

Requirements for Using Domain Accounts as the Service Accounts 
If you are going to use domain accounts, it is very important that you do the following before you begin the wInsight 
Analytics installation: 

 Create the domain accounts in Active Directory, or your LDAP. 
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 Set up the account as a member of the local administrators group. Make sure that the server is a member of 
the domain. 

 Make sure you are logged on to that domain, with Administrative rights to the server/client, when you install the 
wInsight Analytics Module. 

Obtain Your QlikView Serial and Control Numbers 
If you have never received your QlikView serial and control numbers, complete the Preinstallation Upgrade Checklist 
which is downloaded with the application, and contact your Deltek Account Manager. If you have lost your QlikView 
serial and control numbers, contact Hq-Distribution@deltek.com. 

Server Installation Procedures 
The installation procedures that follow are for installing the wInsight Analytics Module on a server.  

Step 1: Install the wInsight Analytics Module 

To install the wInsight Analytics Module, complete the following steps: 
1. Log on to the server with an administrator account. 

2. Double-click DeltekwInsightAnalytics82.exe. 

3. On the Welcome page of the Deltek wInsight Analytics Module Installation Wizard, click Next.  
4. On the License Agreement page, review the license agreement, select I accept the terms of the license 

agreement, and click Next. 
5. On the Setup Type page, select Server, and click Next. 
6. On the Choose Destination Location page, select folders where you want to install files, and click Next. 

By default, wInsight Analytics Module files are installed in the following locations: 

 QlikView Application — C:\Program Files\QlikView 

 wInsight Application — C:\Program Files\Deltek\wInsight Analytics 

 wInsight Data — C:\ProgramData\Deltek\Analytics  

Note: You have the option to install the files to a different location by clicking Change.  

 The QlikView Application folder contains the Directory Service Connector, Distribution Service, Examples, 
Management Service, QvPlugin, QvProtocol, Server, Support Tools, Themes, and Web sub-folders and 
corresponding files. 

 The wInsight Application folder contains the bin and WSWebSvc subfolders and corresponding files.  

 The wInsight Data folder contains the admin, Database, datapull, extension, final, Logs, publish, qvds, 
setup, Support, and translate sub-folders and corresponding files. 

The installation sets registry key – HKEY_LOCAL_MACHINE\SOFTWARE\QlikTech\QlikViewServer\Settings 
7\DocumentDirectory = <installation location>\publish. By default, the location is 
C:\ProgramData\Deltek\Analytics\publish. 

In addition, make sure that the <installation location> folder is not marked as Hidden. Otherwise, you might 
encounter problems in locating the files in the translate folder. 

7. Specify the QlikView service account by taking one of the following actions: 

mailto:Hq-Distribution@deltek.com
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 Specify an existing domain account using the <DOMAIN>\<USER NAME> format and corresponding 
password. 

 Create a local account. 

Note: You have the option to enter a different local account name. It can be an existing account or account that 
does not yet exist. In the latter case, the installation process creates the account. 

Instead of using a local account, you can specify an existing domain user name and password. 

If you do not specify a domain account or an existing local account as the QlikView service account, the 
installation creates a local user with the name you specified (DeltekAnalytics is the default). It adds that user to 
the local administrators group and to the “Log On as Service” policy. 

Before proceeding, make sure you read and complete the prerequisite tasks described in Requirements for 
Using Domain Accounts as the Service Accounts. 

If you are upgrading from an earlier version of wInsight Analytics Module and you have not deleted the local 
account from the previous installation, the following message displays: 

 
Click OK. 

8. On the Add Administrator Users page, select the users who can configure wInsight Analytics and run data load, 
and click Next. By default, the user running the installation displays in the list. 

 If you need to add a user, click Add. In the Select User dialog box, enter the domain and user name using 
the <DOMAIN>\<USER NAME> format, and then click OK. 

Note: The users that you add on this page are added automatically to the following groups by the 
installation: 

 QlikView Administrators — This group has full access rights to QlikView Management Console and 
authenticates communication between QlikView services, if Windows Authentication is used. 

 wInsight Administrator — This group has full access rights to the wInsight Analytics Data folder. 

If you still need to add users to these groups after the installation, you can add them manually to the Local 
Users and Groups/Users folder on Windows Computer Management. For more information on adding data 
loading accounts, see Appendix A: Set Up User Accounts for Loading Data in this document. 

 If you need to delete a user from the list, click Remove. 

9. If the server where wInsight Analytics Module is being installed has running Web sites other than the default, 
the Select Web Site page that contains a drop-down list of available Web sites displays. Select the Web site 
that you want to use for this installation, and click Next. 

10. On the Customer Experience Improvement Program page, if you want to participate in the program, leave 
Send installation data to Deltek selected, and click Next. 
If you participate, the data listed on the page is sent to Deltek automatically during the installation process. 
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11. On the Start Copying Files page, click Next to start the installation process. The Setup Status page displays 
the status of the process. 

12. When the Installation Complete page displays, click Finish. 

Note: By default, the Yes, I want to restart my computer now option is selected. You must restart your 
computer before continuing with the remaining steps in the installation process. 

13. After restarting your computer, log on to the server using any account (using the <DOMAIN>\<USER NAME> 
format) added to the QlikView Administrators group. 

Step 2: License QlikView Server 
This procedure allows you to license QlikView Server so that you can access wInsight Analytics Module from the 
QlikView AccessPoint URL. In addition, this procedure assumes that you are logged on as the QlikView administrator 
account identified during the installation. If you have a capped license, your login account must also have access to the 
QlikView Server. 

Important: This release includes updating the QlikView application to version 12.2. It may require an update to your 
QlikView license as licenses with a validity date prior to the release of version 12.2 (November 2017) will not work with 
this version. For details on how to check your license and how to request an update if required, see the  Appendix E: 
Check QlikView License Validity section. 

The administrator account that you associate with the QlikView for Windows (QV.exe) license is the only account that 
can be used to access QlikView for Windows and wInsight Analytics Module on this computer. 

No Internet Access 

If you are installing wInsight Analytics on a computer with no Internet access, you need a copy of your QlikView 
License Enabler File (LEF). To request your LEF, contact CCOps@deltek.com. If you have someone in your company 
who has Internet access, you may get the LEF from this link: http://lef1.qliktech.com/manuallef/default.aspx. 

To license QlikView Server, complete the following steps: 
1. Make sure that all QlikView services are running by clicking Start » Control Panel » Administrative Tools » 

Services and checking the status of the QlikView services. 

2. If there is any service that does not run automatically after restart, run the service manually by selecting it and 
clicking Start. 

3. Launch the QlikView Management Console in one of the following ways: 

 Click Start » All Programs » Deltek wInsight Analytics » QlikView Management Console. 

Or 

 Run Internet Explorer and go to http://localhost:4780/qmc/default.htm. 

Note: If you are asked to log on when you run QlikView Management Console, log on with the user name and 
password for the service account that you entered during the installation. 

Select Remember my credentials, and click OK. 

4. If you see the following message in the browser window, click the message bar and then select Enable 
Intranet Settings: 

“Intranet settings are now turned off by default. Intranet settings are less secure than Internet options. Click for 
options…” 

Click Yes to confirm that you want to turn on intranet security settings. 

5. In the QlikView Management Console, click the System tab, and then click the Licenses sub-tab. 

mailto:CCOps@deltek.com
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6. Under Type, select QlikView OEM Server. 

  
7. Click the QlikView Server License tab in the right pane. 

8. In the Serial number field, enter your QlikView Server serial number.  

9. In the Control field, enter your QlikView Server control number. 

10. In the Name and Organization fields, enter your name and your firm’s name. 

11. Scroll down until the Apply License button is visible, and click Apply License.  

12. A message displays stating that the QlikView Server will be restarted. Click OK.  

If the license information is accepted, information displays in Paste the contents of the LEF file here 
(optional).  
Note: To check if the license was applied correctly, click the Status tab in the QlikView Management Console, 
then click Services. The Status column for the Service Name should display Running.  If the Status column 
displays Off Duty, there is a problem with the license. 

13. This step is optional and applies only if you have a capped license. Use the directories linked to the QlikView 
server if you need to give other users access to the server. For more information, see Appendix B: Add Users 
to the QlikView Server from a Directory (For Capped Licenses). 

14. Still in QlikView Management Console, click the Setup sub-tab on the System tab. 

15. Expand Management Service, and expand QlikView Web Servers. 

16. Select QVWS@servername. 

17. Click the General tab in the right pane. 

18. If the default QlikView Web server port specified in the Port field under Communication is already being used 
for another process, enter another suitable port number. For more information, see the Change the TCP Port 
section. 

19. Click Apply and proceed to the next step.   
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Step 3: Create Tasks for Loading Projects Using QlikView AccessPoint 

To create tasks for loading projects using QlikView AccessPoint, complete the following steps: 
1. In QlikView Management Console, click the Documents tab and click User Documents. 

2. Expand QVS@servername. 

3. Expand the DataPull folder, and then expand the qvs folder. 

  
4. Select wInsight.qvw, and then click the Reload tab in the right pane. 

5. On the Reload tab, mark the On an External Event option, and then click Apply. 

6. Expand the Translate folder and apply the On an External Event option to the following QVWs, as well: 

 Data_Model_wInsight.qvw 

 Transform_wInsight.qvw 

 wInsight_Analytics.qvw 

 wInsight_Analytics_MultiProject.qvw 

 wInsight_Metrics.qvw 

7. Click the Status tab and expand ReloadEngine@servername. 

8. Expand the Default folder and confirm that it contains the QVWs that you marked the On an External Event 
option for.   

9. Proceed to the next step. 

Step 4: Clear the Allow Session Recovery Check Box 
1. In QlikView Management Console, click the System tab and the Setup sub-tab. 

2. Expand QlikView Servers and select your QlikView server. 
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3. In the right pane, click the Documents tab. 

4. Make sure that the Allow Session Recovery check box is not marked. 

  
5. Click Apply. 

6. Close the QlikView Management Console.  

Step 5: Launch and License QlikView for Windows  

 
The procedure you use to license QlikView for Windows depends on the type of license you have: 

 Capped license - This process licenses the client version of QlikView by leasing a license from your server 
installation. 

 Uncapped license 
If you are not sure what type of license you have, contact your Deltek Account Manager. 

No Internet Access 

If you are installing wInsight Analytics on a computer with no Internet access, you need a copy of your QlikView 
License Enabler File (LEF). To request your LEF, contact CCOps@deltek.com. If you have someone in your company 
who has Internet access, you may get the LEF from this link: http://lef1.qliktech.com/manuallef/default.aspx. 

Capped License 

If you are not sure what type of license you have, contact your Deltek Account Manager.  

To launch and license QlikView for Windows if you have a capped license, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

Note: The following steps assume that you are logged on as the QlikView Administrator account identified during the 
installation. If you have a capped license, your login account must also have access to the QlikView Server. 

mailto:CCOps@deltek.com
http://lef1.qliktech.com/manuallef/default.aspx


Server Installation 

Installation Guide 22 

 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. Click Settings » User Preferences. 
3. On the General tab of the User Preferences dialog box, click Change Interface Language. 

4. On the Select Interface Language dialog box, select English if it is not already selected, and click OK. 

 
5. Click OK to close the User Preferences dialog box. 

6. On the QlikView File menu, click Open in Server. 
7. In the Server field, enter qvp://localhost and click Connect. 

The list below the Server field displays localhost. 

  
8. Select wInsight_Analytics.qvw from the bottom list, and click Open. 

9. If the Module Security for Document dialog box displays, select Allow any Macro (only for trusted 
documents), and click OK. Mark the Always use this option for documents from this QlikView Server 
check box to prevent this dialog box from displaying in the future.  
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10. Close QlikView. If a message displays asking if you want to save changes to wInsight_Analytics.qvw, click Yes. 

This process licensed the Client version of QlikView by leasing a license from your server installation.  

Uncapped License  

If you have an uncapped license, you have two keys initially: 

 A server license key  

 A standalone license key 

Note: QlikView for Windows always requires a standalone license key even if it is installed on a server. This allows you 
to access wInsight Analytics Module from the server to perform general maintenance, customizations, and data load 
process. 

The administrator account that you associate with the QlikView for Windows license is the only account that can be 
used to access QlikView for Windows and the wInsight Analytics Module on this computer. 

To launch and license QlikView for Windows if you have an uncapped license, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. From the Settings menu, click User Preferences. 

3. In the User Preferences dialog box, click the License tab. 

4. Click the Change button. 

5. Enter your QlikView for Windows standalone license key and control number, and click Next. 
6. Read the User License Agreement, and click I Agree.  

7. Take one of the following actions: 

 If you are installing on a computer with an Internet connection, a dialog box displays informing you that 
your license key has been validated. Click Continue in this dialog box and proceed to step 8.  

 If you are installing on a computer that does not have an Internet connection, a dialog box containing three 
options displays. Perform the following actions on that dialog box: 

a. Select Enter my License Information manually (LEF), and click Continue. 

b. Copy the contents of your License Enabler File (LEF) and paste it into the box under Enter your 
license enabling information. 

c. Click Next. A dialog box displays informing you that your license key has been validated. 

Note: If Next is grayed out, that means you pasted an invalid LEF. Contact CCOps@deltek.com 

d. When the license key has been validated successfully, click Continue. 

8. In the User Preferences dialog box, click OK. 

mailto:CCOps@deltek.com
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Step 6: Configure the Database Connection for wInsight Analytics Module 
If you are installing wInsight Analytics Module for the first time, Deltek recommends that you first test the analytics load 
process using the Sample.mdb database file (which is included in the installation) before you configure it to run against 
your own database.  

Attention: If you plan to use an MS SQL Server or Oracle database, see the Configure the Database Connection and 
wInsight Web Service Data Source Using an MS SQL Server or Oracle Database section. 

If you choose to load or restore your own projects into Sample.mdb to test the load process and dashboards, make 
sure you load multiple periods of those projects. 

Note: The wInsight database must contain at least one contract with more than one period of data. 

To configure the database connection for wInsight Analytics Module, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. On the File menu, click Open.  

3. In the Open dialog box, browse to the location of the Connection_Setup.qvw file, select the file, and click 
Open. 

By default, Connection_Setup.qvw is saved in C:\ProgramData\Deltek\Analytics\admin\. This .qvw file allows 
you to configure the connection information for QlikView component of wInsight Analytics. It also allows you to 
configure the data source for the wInsight Web Services used by the QlikView extension objects by clicking 
Select wInsight Datasource on the wInsight Analytics – Connection Setup tab. 

4. If the Module Security for Document dialog box displays, select Allow any Macro (only for trusted 
documents), and click OK. 

5. On the File menu, click Edit Script, or press CTRL+E.  

6. On the Data tab of the Edit Script dialog box, select OLE DB from the Database drop-down list, and click 
Connect. 

7. On the Provider tab of the Data Link Properties dialog box, select Microsoft Office 12.0 Access Database 
Engine OLE DB Provider or Microsoft Office 15.0 Access Database Engine OLE DB Provider, and click 
Next 
If your OLE DB provider is not listed, install and configure it before proceeding. 

Note: The server installation requires 64-bit drivers. Deltek recommends SQL Server and Oracle databases for 
production use. For more information, see the Configure the Database Connection and wInsight Web Service 
Data Source Using an MS SQL Server or Oracle Database section. 

8. On the Connection tab of the Data Link Properties dialog box, do the following: 

a. Enter the location path of the database. For example, C:\ProgramData\Deltek\Analytics\data\Sample.mdb. 

b. Enter your user name and password (if applicable). For Access databases, the default user name is 
“Admin” and there is no password required.  

c. Select Allow saving password. 

9. Click Test Connection to check your connections.  

10. If the connection test is successful, click OK. 
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11. In the text box on the Main tab, scroll horizontally to the right end of the text area, and confirm that something 
similar to the text shown below displays (it will not be exactly the same). Verify that the password in the 
XPassword statement is encrypted. 

Note: If the password is not encrypted, click OK to close the Edit Script dialog box. In the main QlikView 
window, click Settings » User Preferences » General Tab, mark the Scramble Connect User Credentials 
check box, and repeat steps 5 – 9. 

 
12. From the File menu, click Export to Script File.  

If the Export to Script File option on the File menu is disabled, copy the entire CONNECT TO line (CTRL+C), 
open <installation location>\setup\Connection_wInsight.qvs in Notepad, paste (CTRL+V), and save the file.  

13. On the Save Script dialog box, browse to the location of the Connection_wInsight.qvs file, select the file, and 
click Save. By default, Connection_wInsight.qvw is saved in C:\ProgramData\Deltek\Analytics\setup\. 

14. When asked to replace the existing Connection_wInsight.qvs file, click Yes.  

15. Click OK to close the Edit Script dialog box. 

Do not close QlikView as you still need to configure the wInsight data source in the next step.  

Step 7: Configure the wInsight Web Service Data Source 
This procedure assumes that you have configured an MS Access database connection in the previous step. 

Note: If you have configured an MS SQL Server or Oracle database connection in the previous step, see the Configure 
the Database Connection and wInsight Web Service Data Source Using an MS SQL Server or Oracle Database for 
more details. 

To configure the data source used by the wInsight Analytics Web service, complete the following steps: 
1. In the main QlikView window, click Select wInsight Datasource.  

2. On the Data Sources dialog box, click Add. 

3. On the Provider tab of the Data Link Properties dialog box, select Microsoft Office 12.0 Access Database 
Engine OLE DB Provider or Microsoft Office 15.0 Access Database Engine OLE DB Provider, and click 
Next. 
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4. On the Connection tab, perform the following actions: 

a. Enter the location path of the database. For example, C:\ProgramData\Deltek\Analytics\data\Sample.mdb. 

b. Enter your user name and password (if applicable). The default user name is “Admin” and there is no 
password required. 

c. Select Allow saving password. 

5. Click Test Connection to check your connections. 

6. If the connection test is successful, click OK. 
7. On the Edit Data Source dialog box, enter a name for the data source and click OK.  
8. On the Data Sources dialog box, make sure that the newly added data source is selected, and click OK.  

9. Close QlikView.  

10. When asked to save the changes to Connection_Setup.qvw, click Yes. 

Note: These steps update both the WSDATA.ini and App.config files with the selected data source. 

Step 8: Configure Data Load Settings and Perform Data Load 
After you perform this task, make sure you copy any customizations that you did from the old QVW files (which are 
located in the <installation location>\Backups folders) into their new respective <installation location> folders. 

Note: If you are upgrading from a previous version of the wInsight Analytics Module, you have the option to apply your 
previous configuration settings. For more information, see Appendix D: Apply Previous Configuration Settings. 

The installation process backs up existing QVW files (under the final, admin, and setup folders) prior to installing 
updated ones. These files are backed up to the <installation location>\Backups folder.  

To configure data load settings by manually launching wInsight_Analytics_Config.qvw and perform data load 
using batch files, complete the following steps: 

1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. On the File menu, click Open. 

3. On the Open dialog box, navigate to the wInsight_Analytics_Config.qvw file, select the file, and click Open. By 
default, wInsight_Analytics_Config.qvw is in C:\ProgramData\Deltek\Analytics\admin\. 

4. On the Tools menu, click Edit Module. 

5. If Requested Module Security does not contain System Access in the Edit Module dialog box, select that 
option. 

6. If Current Local Security does not contain Allow System Access in the Edit Module dialog box, select that 
option. 

7. Click OK and save the file. 

8. Under wInsight Database on the wInsight Analytics Configuration tab, select Access. 

9. Click Update from wInsight Database. The Script Execution Progress dialog box displays the progress of the 
update. 
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10. If you have used the Element Type field to identify which elements represent control accounts (CAs) and work 
packages (WPs), the codes you used will be under the Element Type column as element types. You need to 
mark each element type as C if it is a control account or W if it is a work package.  

 
Attention: For more information about CAs and WPs, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 

11. Update the information for the following project fields: 

 Current Period 
 Historical Data 
 Forecast Data Load 
 Unit Used as Element of Cost  
Attention: For more information about these fields, see the Configuration section of the wInsight Analytics 
Module 8.2 Administration Guide. 

12. Mark the WBS OBS Link check box, if it is not already marked. 

Attention: For more information about the WBS OBS Link, see the Configuration section of the wInsight 
Analytics Module 8.2 Administration Guide. 



Server Installation 

Installation Guide 28 

 

13. Click Save Settings for wInsight Analytics. If this process is successful, a “Configuration settings have been 
saved…” message displays. Click OK in the message. 

14. Click Run Data Load Batch File to start the data load. The Script Execution Progress dialog box displays the 
progress of the data load. When the processes are completed, the command window closes. 

 
Note: You have the option to run the Load_wInsight_Data.bat file manually. In Windows Explorer, go to \admin 
folder and double-click the Load_wInsight_Data.bat file. If QlikView asks if you approve the application for 
launch, click Yes. This batch file runs a number of processes in a command window. 

Step 9: Make the wInsight Analytics Module Server a Trusted Site 
To avoid a variety of problems that can occur due to browser internet/intranet security, all wInsight Analytics Module 
users, regardless of how they access the product, should add the wInsight Analytics Module server (http://<server 
name>) to their list of trusted sites on the Security tab of the Internet Options dialog box in Microsoft Internet Explorer.  

Step 10: Test the QlikView Access Point 
1. Launch your browser and enter the URL for your QlikView Server Access Point: 

http://servername/QlikView/index.htm.  

2. Open wInsight_Analytics.qvw. 

http://servername/QlikView/index.htm
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3. Click the Web Services Test tab, and click Test Web Services.    

 
4. If that succeeds, click the Project Load tab. 

5. Select the Load All Projects check box, if it is not yet selected.  

6. In the wInsight Database field, select the type of database used to store your wInsight data (MS Access, 
Oracle, or MS SQL Server). 

7. Click Update from wInsight Database. The Data Load Status pane displays the progress of the configuration 
update. 

8. When the configuration update is complete, press F5 to refresh the page. 

9. If you have used the Element Type field to identify which elements represent control accounts (CAs) and work 
packages (WPs), the codes you used will be in the Work Package Control Account section as element types. 
You need to mark each element type as C if it is a control account or W if it is a work package.  
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Attention: For more information about CAs and WPs, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 

10. Update the information for the following project fields: 

 Current Period 
 Historical Data 
 Forecast Data Load 

 Unit Used as Element of Cost (click  to specify the units that represent Element of Cost). 

Attention: For more information about these fields, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 

11. Mark the WBS OBS Link check box, if it is not already marked. 

Attention: For more information about the WBS OBS Link, see the Configuration section of the wInsight 
Analytics Module 8.2 Administration Guide. 

12. In the No. of Levels of WBS to Support field, specify the number of hierarchical levels of the work breakdown 
structure that you want to include in the data load. Use this field to select the amount of detail that is loaded 
into wInsight Analytics Module if your wInsight database is very large. 

13. Leave the Load Metrics check box unmarked.  

14. If this is your first time to load data for all projects, leave the Delete QVDs check box unmarked. Otherwise, 
always select the check box if you select Load All Projects.   

15. Click Save Settings. If this process is successful, a “Configuration settings have been saved…” message 
displays.  

16. Click Run Data Load. You must perform a full data load before you can run single-project data loads. If this 
process is successful, a “Backed up QVWs from \publish folder…” message displays and your wInsight 
Analytics is up and running. 

Step 11: Security for wInsight Analytics Module 
The wInsight Analytics Module uses the security information in Deltek EPM Security Administrator (EPM SA) to 
determine who can use the module and which contracts they have access to. The EPM SA tool is installed when you 
install wInsight Analytics Administrator. 
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Specify EPM Security Administrator and IIS Server Security Options 

Depending on whether or not you will use wInsight Analytics Module security, you must specify security options in EPM 
Security Administrator and in the IIS server. 

 If you are using wInsight Analytics Module security: 
 In EPM Security Administrator, set the Authentication Mode to Windows. For more information, see the 

EPM Security Administrator online help. 
 In the IIS server under the WSWebSvc web site, enable Windows Authentication and disable 

Anonymous Authentication. For more information, see the Microsoft Internet Information Services (IIS) 
documentation 
(https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication) 

 If you are not using wInsight Analytics Module security: 
 In EPM Security Administrator, set the Authentication Mode to None. For more information, see the EPM 

Security Administrator online help. 
 In the IIS server under the WSWebSvc web site, enable Anonymous Authentication. For more 

information, see the Microsoft Internet Information Services (IIS) documentation 
(https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication). 

Enable the wInsight Analytics Module Security 

Security in the wInsight Analytics Module is based on the security set up in EPM SA. If you are not using wInsight 
Analytics modeul security, you can skip this section. 

Attention: For more information about the security model, see the Deltek EPM Security Administrator Online Help. 

To enable security in the wInsight Analytics Module, you must complete the following steps: 
1. Log on to EPM SA. 

2. In the Explorer pane, expand the Products folder and select wInsight. 
3. On the menu bar, click Tools » Authentication Options. 

4. On the Authentication Options dialog box, select Windows in the Authentication Mode drop-down list and 
Windows Domain\User Name in the Authentication Type drop-down list. This setting requires users to use 
Windows Authentication when logging on to the application, which is the supported authentication by wInsight 
Analytics Module.  

5. Click OK. 

Add QlikView Service Account as a New User 

 
In the EPM Security Administrator: 

 Add the QlikView service account as a new user. Make sure to set the domain name (if domain user) or 
machine name (if local user) in the Domain field. 

 Add QlikView service account in the SYSADMIN Group.   

Note: This step is only applicable if wInsight Analytics Module security is enabled. 

https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication
https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication
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Add New wInsight Analytics Users to EPM Security Administrator 

Any wInsight Analytics user who will access QlikView AccessPoint must be added to the EPM Security Administrator, 
regardless of whether that user will perform data loads or not. Deltek recommends that the user performing data load 
be added to the SYSADMIN group in EPM Security Administrator. 

Note: If security is enabled for the wInsight Analytics Module, the data load process loads all wInsight Analytics users 
who are set up for Windows authentication, whether those users are domain users or are set up for Windows 
authentication on the wInsight Analytics server. The wInsight Analytics Module does not support access for users who 
are not set up for Windows authentication. 

To add a new module user, set that person up in wInsight Analytics as a Windows authentication user, and give them 
the appropriate access to contracts. Then, run the data load process to add their access information to the analytics 
data model. 

Attention: For more information, see the Deltek EPM Security Administrator Online Help. 

User Authentication 

When a user runs the wInsight Analytics Module, Windows authentication determines whether they gain access to the 
module. 

Access to Contracts 

A wInsight Analytics user is granted access to contracts either individually or through a user group. The data load 
process loads that access information into the wInsight Analytics data model. In most cases, a user automatically has 
access to data for the same set of contracts in the wInsight Analytics Module as he or she does in wInsight Analytics 
Desktop/wInsight Analytics Administrator. 

Users Created During Installation 

The two administrative users created during the installation process (DeltekAnalytics and DelteAnalyticsCW) are not 
automatically users within the wInsight Analytics database and have no automatic access to projects within the 
database. If security is turned on in wInsight Analytics, then a person logged in using one of these user names would 
not see any projects after loading data. These users can either be added to the wInsight Analytics database or wInsight 
Analytics security can be turned off in EPM SA while the initial data load is run and checked before being turned back 
on for production purposes. 

Security for wInsight Analytics Configuration 

wInsight Analytics provides no internal security for the configuration applications and related administrative files. Be 
sure that only the appropriate persons have access to the network or standalone computer folders in which you 
installed wInsight Analytics. 

If you are loading data using wInsight_Analytics_Config.qvw, the Apply Security setting in the Security section on the 
wInsight Analytics Configuration tab indicates whether you want to use wInsight Analytics Module security and saves 
the security status (whether you set Apply Security to Yes), which wInsight_Analytics.qvw uses in the authentication 
process. 
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Standalone Installation 
The information in this section applies only to standalone installations.  

 If you are performing an installation on a server, see Server Installation. 

 If you plan to install wInsight Analytics Module to run under IIS with self-signed Secure Sockets Layer (SSL) 
certificate, see Internet Information Services (IIS) Installation. 

Note: The person installing the wInsight Analytics Module should be familiar with MS SQL, Oracle, and MS Access 
databases, domain accounts, Windows Authentication, IIS Manager, EPM Security Administrator, and wInsight 
Analytics Administrator. 

Preinstallation Checklist 
Steps  Related Topics 

1. Make sure all the prerequisites are installed. System Requirements 

2.  To complete the wInsight Analytics Module standalone 
installation, you must have the following: 

 Logon credentials with administrative rights 

 Serial number and control number for QlikView for 
Windows 

 

3. Verify the validity of your QlikView License. 

This release includes updating the QlikView application to 
version 12.2. It may require an update to your QlikView 
license as licenses issued prior to the release of version 
12.2 (November 2017) will not work with this version. 

Appendix E: Check QlikView License Validity 

4.  Deltek recommends that you install wInsight Analytics 
Administrator 8.2. This includes the EPM Security 
Administrator installation. 

For information on installing the wInsight 
Analytics Administrator, see the Deltek wInsight 
Analytics Administrator 8.2 Installation Guide. 

Obtain Your Serial Number and Control Number for the Installation 
If you have never received your QlikView serial and control numbers fill out the Preinstallation Upgrade Checklist, 
which is downloaded with the application, and contact your Deltek Account Manager.  If you have lost your QlikView 
serial and control numbers, contact Hq-Distribution@deltek.com. 

Standalone Installation Procedures 
The installation procedures that follow are for installing the wInsight Analytics Module on a standalone computer. 

Step 1: Install the wInsight Analytics Module 

To install the wInsight Analytics Module for the first time, complete the following steps: 
1. Log on to the standalone computer with an administrator account. 

mailto:Hq-Distribution@deltek.com
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2. Double-click DeltekwInsightAnalytics82.exe. 

3. On the Welcome page of the Deltek wInsight Analytics Module Installation Wizard, click Next.  
4. On the License Agreement page, review the license agreement, select I accept the terms of the license 

agreement, and click Next. 
5. On the Setup Type page, select Stand-Alone, and click Next. 
6. On the Choose Destination Location page, select the folders where you want to install files, and click Next. By 

default, wInsight Analytics Module files are installed in the following locations: 

 QlikView Application files — C:\Program Files\QlikView 

 wInsight Data files — C:\Users\<User name>\<Documents>\Deltek\Analytics  

Note: <Documents> refers to Documents in Windows 8/8.1 and My Documents in Windows 7. 

If you want to install the files to a different location, click Change. 

7. On the Customer Experience Improvement Program page, if you want to participate in the program, leave 
Send installation data to Deltek selected, and click Next. 
If you participate, the data listed on the page is sent to Deltek automatically during the installation process. 

8. On the Start Copying Files page, click Next to start the installation process. 

The Setup Status page displays the status of the process. 

9. When the Installation Complete page displays, click Finish. 

Note: By default, the Yes, I want to restart my computer now option is selected. You must restart your computer 
before continuing with the remaining steps in the installation process. 

Step 2: Launch and License QlikView for Windows (Standalone Installation) 
Important: This release includes updating the QlikView application to version 12.2. It may require an update to your 
QlikView license as licenses with a validity date prior to the release of version 12.2 (November 2017) will not work with 
this version. For details on how to check your license and how to request an update if required, see the  Appendix E: 
Check QlikView License Validity section. 

If you are installing wInsight Analytics on a computer with no Internet access, you also need a copy of your QlikView 
License Enabler File (LEF). To request your LEF, contact CCOps@deltek.com. If you have someone in your company 
who has Internet access, you may get the LEF from this link: http://lef1.qliktech.com/manuallef/default.aspx. 

The administrator account that you associate with the QlikView for Windows license is the only account that can be 
used to access QlikView for Windows and the wInsight Analytics Module on this computer. 

This procedure requires your QlikView standalone license key and control number, allowing you to access wInsight 
Analytics Module from the server to perform general maintenance, customizations, and data load process. 

To launch and license QlikView for Windows, complete the following steps: 
1. Log onto your computer using the administrator user account that you want associated with the QlikView for 

Windows license. 

2. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

3. Click Settings » User Preferences. 

4. On the General tab of the User Preferences dialog box, click Change Interface Language. 

mailto:CCOps@deltek.com
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5. On the Select Interface Language dialog box, select English if it is not already selected, and click OK. 

 
6. Click the License tab. 

 
7. Click Change. 

8. In the License Key and Control Number fields, enter your QlikView for Windows license key and control 
number. 
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9. In the User Name and Organization fields, enter your name and your firm’s name. 

 
10. Click Next. 
11. Read the QlikView license agreement, and click I Agree. 

12. Take one of the following actions: 

 If you are installing on a computer with an Internet connection, a dialog box displays informing you that 
your license key has been validated. Click Continue in this dialog box and proceed to step 13.  

 If you are installing on a computer that does not have an Internet connection, a dialog box containing three 
options displays. Perform the following actions on that dialog box: 

a. Select Enter my License Information manually (LEF), and click Continue. 

b. Copy the contents of your License Enabler File (LEF) and paste it into the box under Enter your 
license enabling information. To request your LEF, contact CCOps@deltek.com. If you have 
someone in your company who has Internet access, you may get the LEF from this link: 
http://lef1.qliktech.com/manuallef/default.aspx. 

c. Click Next. A dialog box displays informing you that your license key has been validated. 

Note: If Next is grayed out, that means you pasted an invalid LEF. Contact CCOps@deltek.com.   

 
d. Click Continue and proceed to the next step. 

13. On the User Preferences dialog box, click OK.  

mailto:CCOps@deltek.com
http://lef1.qliktech.com/manuallef/default.aspx
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Step 3: Configure the Database Connection for wInsight Analytics Module 
If you are installing wInsight Analytics Module for the first time, Deltek recommends that you first test the analytics load 
process using the Sample.mdb database file (which is included in the installation) before you configure it to run against 
your own database. 

Attention: If you plan to use an MS SQL Server or Oracle database, see the Configure the Database Connection and 
wInsight Web Service Data Source Using an MS SQL Server or Oracle Database. 

If you choose to load or restore your own projects into Sample.mdb to test the load process and dashboards, make 
sure you load multiple periods of those projects. 

Note: The wInsight database must contain at least one contract with more than one period of data. 

To configure the database connection for wInsight Analytics Module, complete the following steps: 
1. On QlikView’s File menu, click Open.  

2. In the Open dialog box, navigate to your Documents library. 

3. In your Documents library, click Deltek » Analytics » admin, and select the Connection_Setup.qvw file.    

Note: <Documents> refers to Documents in Windows 8/8.1 and My Documents in Windows 7. 

4. Click Open. 

5. If the Module Security for Document dialog box displays, select Allow any Macro (only for trusted 
documents), and click OK. 

Note:  If the Edit Module dialog box displays, make sure that you set the Requested Module Security field to 
System Access and the Current Local Security field to Allow System Access. 

6. On the File menu, click Edit Script, or press CTRL+E.  

7. In the Data tab of the Edit Script dialog box, select OLE DB from the Database drop-down list, and click 
Connect. 

8. On the Provider tab of the Data Link Properties dialog box, select Microsoft Office 12.0 Access Database 
Engine OLE DB Provider or Microsoft Office 15.0 Access Database Engine OLE DB Provider, and click 
Next. 
If your OLE DB provider is not listed, install and configure it before proceeding. 

9. On the Connection tab of the Data Link Properties dialog box, do the following: 

a. Enter the location path of the database. For example, 
C:\Users\<UserName>\Documents\Deltek\Analytics\data\Sample.mdb. 

b. Enter your user name and password (if applicable). The default user name is “Admin” and there is no 
password required. 

c. Select Allow saving password. 

10. Click Test Connection to check your connections. 
11. If the connection test is successful, click OK. 

12. In the text box on the Main tab, scroll horizontally to the right end of the text area, and confirm that something 
similar to the text shown below displays (it will not be exactly the same). If you specified a password, verify that 
the password in the XPassword statement is encrypted. 

Note: If the password is not encrypted, click OK to close the Edit Script dialog box. In the main QlikView 
window, click Settings » User Preferences » General Tab, mark the Scramble Connect User Credentials 
check box, and repeat steps 5 – 10 in this procedure. 
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13. On the File menu, click Export to Script File. 

If the Export to Script File option on the File menu is disabled, copy the entire CONNECT TO line (CTRL+C), 
open the Connection_Setup.qvw file in Notepad (Documents » Deltek » Analytics » setup), paste (CTRL+V), 
and save the file.  

Note: <Documents> refers to Documents in Windows 8/8.1 and My Documents in Windows 7. 

14. In the File name field of the Save Script dialog box, browse to the location of the Connection_wInsight.qvw file, 
select the file, and click Save. By default, Connection_wInsight.qvw is saved in C:\Users\<User 
name>\<Documents>\Deltek\Analytics\setup. 

15. When asked to replace the existing file, click Yes.  

16. Click OK to close the Edit Script dialog box. 

17. Close QlikView. When asked to save the changes to Connection_wInsight.qvw, click Yes.  

Step 4: Configure Data Load Settings and Perform Data Load 
Before you perform this task, you must be logged on with the user name associated with your QlikView for Windows 
standalone license key to run the data load process. 

After you perform this task, make sure you copy any customizations that you did from the old QVW files (which are 
located in the <installation location>\Backups folders) into their new respective <installation location> folders. 

Note: If you are upgrading from a previous version of the wInsight Analytics Module, you have the option to apply your 
previous configuration settings. For more information, see Appendix D: Apply Previous Configuration Settings. 

The installation process backs up existing QVW files (under the final, admin, and setup folders) prior to installing 
updated ones. These files are backed up to the <installation location>\Backups folder.  

Before performing a data load, make sure that the Authentication Mode in EPM Security Administrator is set to None. 
For information, see the Enable Security section. 

To configure data load settings and perform data load, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 
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a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. On the File menu, click Open. 

3. On the Open dialog box, navigate to the wInsight_Analytics_Config.qvw file (Documents » Deltek » Analytics » 
admin), select the file, and click Open.  

Note: <Documents> refers to Documents in Windows 8/8.1 and My Documents in Windows 7. 

4. On the Tools menu, click Edit Module. 

5. If Requested Module Security does not contain System Access in the Edit Module dialog box, select that 
option. 

6. If Current Local Security does not contain Allow System Access in the Edit Module dialog box, select that 
option. 

7. Click OK and save the file. 

8. Under wInsight Database on the wInsight Analytics Configuration tab, select Access. 

9. Click Update from wInsight Database. The Script Execution Progress dialog box displays the progress of the 
update. 

10. If you have used the Element Type field to identify which elements represent control accounts (CAs) and work 
packages (WPs), the codes you used will be under the Element Type column as element types. You need to 
mark each element type as C if it is a control account or W if it is a work package. 

 
Attention: For more information about CAs and WPs, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 

11. Update the information for the following project fields: 

 Current Period 
 Historical Data 
 Forecast Data Load 
 Unit Used as Element of Cost  
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Attention: For more information about these fields, see the Configuration section of the wInsight Analytics 
Module 8.2 Administration Guide. 

12. Mark the WBS OBS Link check box, if it is not already marked. 

Attention: For more information about the WBS OBS Link, see the Configuration section of the wInsight 
Analytics Module 8.2 Administration Guide. 

13. In the No. of Levels of WBS to Support field, specify the number of hierarchical levels of the work breakdown 
structure that you want to include in the data load. Use this field to select the amount of detail that is loaded 
into wInsight Analytics Module if your wInsight database is very large. 

14. Click Save Settings for wInsight Analytics. If this process is successful, a “Configuration settings have been 
saved…” message displays. Click OK in the message. 

15. Click Run Data Load Batch File to start the data load. The Script Execution Progress dialog box displays the 
progress of the data load. When the processes are completed, the command window closes. 

 
Note: You have the option to run the Load_wInsight_Data.bat file manually. In Windows Explorer, go to Documents 
» Deltek » Analytics » admin and double-click the Load_wInsight_Data.bat file. This batch file runs a number of 
processes in a command window. 
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Internet Information Services (IIS) Installation 
If you plan to install wInsight Analytics Module to run under IIS with self-signed Secure Sockets Layer (SSL) certificate, 
follow the procedures in this section. Deltek recommends that you initially disable the wInsight Analytics Module 
security until the full functionality of wInsight Analytics Module has been tested under IIS with SSL before enabling the 
security. 

 If you are performing an installation on a standalone computer, see Standalone Installation. 

 If you are performing an installation on a server, see Server Installation.  

Attention: The person installing the wInsight Analytics Module should be familiar with MS SQL, Oracle, and MS 
Access databases, domain accounts, Windows Authentication, IIS Manager, EPM Security Administrator, and wInsight 
Analytics Administrator. 

Preinstallation Checklist 
Steps Related Topics 

1. Make sure all the prerequisites are installed. System Requirements 

2.  To complete the wInsight Analytics Module server 
installation, you must have the following: 

 Logon credentials with administrative rights 

 Service account  

 Serial number and control number for the QlikView 
Server 

 

3. Verify the validity of your QlikView License. 

This release includes updating the QlikView application to 
version 12.2. It may require an update to your QlikView 
license as licenses with a validity date prior to the release of 
version 12.2 (November 2017) will not work with this version.  

Appendix E: Check QlikView License 
Validity 

4.  Deltek recommends that you install wInsight Analytics 
Administrator 8.2. This includes the EPM Security 
Administrator installation. 

For information on installing the wInsight 
Analytics Administrator, see the Deltek 
wInsight Analytics Administrator 8.2 
Installation Guide. 

5. Ensure that the Website to be used has been created.  

Your Service Account 
The wInsight Analytics Module requires one service account which you specify during the installation process. The 
account can be a local account or domain account. If you plan to use domain accounts, it is crucial that you read the 
requirements and recommendations in the next section.  



Internet Information Services (IIS) Installation 

Installation Guide 42 

 

Requirements for Using Domain Accounts as the Service Accounts 
If you are going to use domain accounts, it is very important that you do the following before you begin the wInsight 
Analytics installation: 

 Create the domain accounts in Active Directory, or your LDAP. 

 Set up the account as a member of the local administrators group. Make sure that the server is a member of 
the domain. 

 Make sure you are logged on to that domain, with Administrative rights to the server/client, when you install the 
wInsight Analytics Module. 

Obtain Your QlikView Serial and Control Numbers 
If you have never received your QlikView serial and control numbers, complete the Preinstallation Upgrade Checklist 
which is downloaded with the application, and contact your Deltek Account Manager. If you have lost your QlikView 
serial and control numbers, contact Hq-Distribution@deltek.com. 

Server Installation Procedures 
The installation procedures that follow are for installing the wInsight Analytics Module to run under IIS with self-signed 
Secure Sockets Layer (SSL) certificate.  

Step 1: Install the wInsight Analytics Module  

To install the wInsight Analytics Module, complete the following steps: 
1. Log on to the server with an Administrator account. 

2. Double-click DeltekwInsightAnalytics82.exe. 

3. On the Welcome page of the Deltek wInsight Analytics Module Installation Wizard, click Next.  
4. On the License Agreement page, review the license agreement, select I accept the terms of the license 

agreement, and click Next. 
5. On the Setup Type page, select Server, and click Next. 
6. On the Choose Destination Location page, select the folder where you want to install the files, and click Next. 

Warning: Make sure that the <installation location> folder is not marked as Hidden otherwise you might 
encounter problems in locating the files in the translate folder.  

By default, wInsight Analytics Module files are installed in the following locations: 

 QlikView Application — C:\Program Files\QlikView 

 wInsight Application — C:\Program Files\Deltek\wInsight Analytics 

 wInsight Data — C:\ProgramData\Deltek\Analytics  

Note: You have the option to install the files to a different location by clicking Change.  

 The QlikView Application folder contains the Directory Service Connector, Distribution Service, Examples, 
Management Service, QvPlugin, QvProtocol, Server, Support Tools, Themes, and Web sub-folders and 
corresponding files. 

 The wInsight Application folder contains the bin and WSWebSvc subfolders and corresponding files.  

mailto:Hq-Distribution@deltek.com
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 The wInsight Data folder contains the admin, Database, datapull, extension, final, Logs, publish, qvds, 
setup, Support, and translate sub-folders and corresponding files. 

The installation sets registry key – HKEY_LOCAL_MACHINE\SOFTWARE\QlikTech\QlikViewServer\Settings 
7\DocumentDirectory = <installation location>\publish. By default, the location is 
C:\ProgramData\Deltek\Analytics\publish. 

7. Specify the QlikView service account by taking one of the following actions: 

 Specify an existing domain account using the <DOMAIN>\<USER NAME> format and corresponding 
password. 

 Create a local account. 
Note: You have the option to enter a different local account name. It can be an existing account or account that 
does not yet exist. In the latter case, the installation process creates the account. 

Instead of using a local account, you can specify an existing domain user name and password. 

If you do not specify a domain account or an existing local account as the QlikView service account, the 
installation creates a local user with the name you specified (DeltekAnalytics is the default). It adds that user to 
the local administrators group and to the “Log On as Service” policy. 

Before proceeding, make sure you read and complete the prerequisite tasks described in Requirements for 
Using Domain Accounts as the Service Accounts. 

If you are upgrading from an earlier version of wInsight Analytics Module and you have not deleted the local 
account from the previous installation, the following message displays: 

 
Click OK. 

8. On the Add Administrator Users page, select the users who can configure wInsight Analytics and run data load, 
and click Next. By default, the user running the installation displays in the list. 

 If you need to add a user, click Add. In the Select User dialog box, enter the domain and user name using 
the <DOMAIN>\<USER NAME> format, and then click OK. 
Note: The users that you add on this page are added automatically to the following groups: 

 QlikView Administrators — This group has full access rights to QlikView Management Console and 
authenticates communication between QlikView services, if Windows Authentication is used. 

 wInsight Administrator — This group has full access rights to the wInsight Analytics Data folder. 

If you still need to add users to these groups after the installation, you can add them manually to the Local 
Users and Groups/Users folder on Windows Computer Management. For more information on adding data 
loading accounts, see Appendix A: Set Up User Accounts for Loading Data in this document. 

 If you need to delete a user from the list, click Remove. 

9. If the server where wInsight Analytics Module is being installed has running Web sites other than the default, 
the Select Web Site page that contains a drop-down list of available Web sites displays. Select the Web site 
where you want to publish wInsight Analytics Web Services, and click Next. 
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10. On the Customer Experience Improvement Program page, if you want to participate in the program, leave 
Send installation data to Deltek selected, and click Next. 
If you participate, the data listed on the page is sent to Deltek automatically during the installation process. 

11. On the Start Copying Files page, click Next to start the installation process. The Setup Status page displays 
the status of the process. 

12. When the Installation Complete page displays, select the No, I will start my computer later. option and click 
Finish. 

Step 2: Uninstall QlikView 
When you install the wInsight Analytics module, the installer also installs QlikView. For an IIS installation, you need 
QlikView Server with IIS Support; therefore, you must uninstall the default version of QlikView Server and install the 
QlikView Server with IIS Support version. 

To uninstall QlikView, navigate to the Windows Control Panel and uninstall QlikView Server November 2017. 

Step 3: Install QlikView Server with Internet Information Services (IIS) Support 
1. Open the Windows Command Prompt with Administrator privileges (right-click Command Prompt and select 

Run as Administrator). 
2. Navigate to the wInsight Analytics Data folder where the QlikView Server installer is located. The default is: 

<wInsight Analytics Data Folder>\Support\QlikView\Server.  

3. Install the QlikView Server to include IIS support by running the following command.  
msiexec /i QlikViewServerx64.msi ADDLOCAL="all" DEFAULTWEBSITE="<NAME OF DEFAULT 
WEBSITE>" 

 
Note: The DEFAULTWEBSITE parameter is the name of the web site where QlikView Server will be deployed. 
In this example, the web site name is WAMIIS. 
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4. On the Profiles page, select Full Installation, Single machine with QlikView Webserver and click the Config 
button. 

 
5. On the Custom Setup page: 

a. Click Microsoft IIS Support.  
b. Select This feature and all subfeatures will be installed on local hard drive. 
c. Click Next. 
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6. On the IIS Website page, select the website where you want to install QlikView and click Next. 

 
7. On the Logon Information page, enter the QlikView Service account user name and password and click Next. 
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8. On the Server Authentication page, select Use QlikView Administrators Group and click Next. 

 
9. When the installation completes, restart the server. 

10. Log on to the server using any account (using the <DOMAIN>\<USER NAME> format) that is a member of the 
QlikView Administrators group.  

Note: By default, the user who installed wInsight Analytics Module is added as part of the QlikView 
Administrators group. You can see the Administrator by navigating to Control Panel » Administrative Tools » 
Computer Management » Local Users and Groups » Groups » QlikView Administrators. 

11. Open the Internet Information Services (IIS) Manager by clicking Control Panel » All Control Panel Items » 
Administrative Tools. 

12. In the Connections panel (left), click Sites and select the website where QlikView is installed. 

13. In the center panel, double-click Authentication. 

14. In the Authentication section, select and enable Windows Authentication (if not yet enabled) by right-clicking 
its status and selecting Enabled. 

 
15. In the Actions panel (right), click Providers. 
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16. On the Providers dialog box, select NTLM and click the Move Up button to move NTLM to the top of the list 
and click OK. 

 

Step 4: License QlikView Server 
Use this procedure to license QlikView Server so that you can access wInsight Analytics Module from the QlikView 
AccessPoint URL.  

This procedure assumes that you are logged on as the QlikView administrator account identified during the installation. 
If you have a capped license, your login account must also have access to the QlikView Server. 

Important: This release includes updating the QlikView application to version 12.2. It may require an update to your 
QlikView license as licenses with a validity date prior to the release of version 12.2 (November 2017) will not work with 
this version. For details on how to check your license and how to request an update if required, see the  Appendix E: 
Check QlikView License Validity section. 

The administrator account that you associate with the QlikView for Windows (QV.exe) license is the only account that 
can be used to access QlikView for Windows and wInsight Analytics Module on this computer. 

No Internet Access 

If you are installing wInsight Analytics on a computer with no Internet access, you need a copy of your QlikView 
License Enabler File (LEF). To request your LEF, contact CCOps@deltek.com. If you have someone in your company 
who has Internet access, you may get the LEF from this link: http://lef1.qliktech.com/manuallef/default.aspx. 

To license QlikView Server, complete the following steps: 
1. Make sure that all QlikView services are running by clicking Start » Control Panel » Administrative Tools » 

Services and checking the status of the QlikView services. 

2. If there is any service that does not run automatically after restart, run the service manually by selecting it and 
clicking Start. 

mailto:CCOps@deltek.com
http://lef1.qliktech.com/manuallef/default.aspx
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3. Launch the QlikView Management Console in one of the following ways: 

 Click Start » All Programs » Deltek wInsight Analytics » QlikView Management Console. 

Or 

 Run Internet Explorer and go to http://localhost:4780/qmc/default.htm. 

Note: If you are asked to log on when you run QlikView Management Console, log on with the user name and 
password for the service account that you entered during the installation, select Remember my credentials, 
and click OK. 

4. If you see the following message in the browser window, click the message bar and select Enable Intranet 
Settings: 

“Intranet settings are now turned off by default. Intranet settings are less secure than Internet options. Click for 
options…” 

Click Yes to confirm that you want to turn on intranet security settings. 

5. In the QlikView Management Console, click the System tab, and then click the Licenses sub-tab. 

6. Under Type, select QlikView OEM Server. 

  
7. Click the QlikView Server License tab in the right pane. 

8. In the Serial number field, enter your QlikView Server serial number.  

9. In the Control field, enter your QlikView Server control number. 

10. In the Name and Organization fields, enter your name and your firm’s name. 

11. Scroll down until the Apply License button is visible, and click Apply License.  

http://localhost:4780/qmc/default.htm
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12. A message displays stating that the QlikView Server will be restarted. Click OK.  

If the license information is accepted, information displays in Paste the contents of the LEF file here 
(optional).  
Note: To check if the license was applied correctly, click the Status tab in the QlikView Management Console, 
then click Services. The Status column for the Service Name should display Running.  If the Status column 
displays Off Duty, there is a problem with the license. 

13. This step is optional and applies only if you have a capped license. Use the directories linked to the QlikView 
server if you need to give other users access to the server. For more information, see Appendix B: Add Users 
to the QlikView Server from a Directory (For Capped Licenses). 

14. Still in QlikView Management Console, click the Setup sub-tab on the System tab. 

15. Expand Management Service, and expand QlikView Web Servers. 

16. Select QVWS@servername. 

17. Click the General tab in the right pane. 

18. If the default QlikView Web server port specified in the Port field under Communication is already being used 
for another process, enter another suitable port number. For more information, see the Change the TCP Port 
section. 

19. Click Apply and proceed to the next step.   

Step 5: Create Tasks for Loading Projects Using QlikView AccessPoint 

To create tasks for loading projects using QlikView AccessPoint, complete the following steps: 
1. In QlikView Management Console, click the Documents tab and click User Documents. 

2. Expand QVS@servername. 

3. Expand the DataPull folder, and then expand the qvs folder. 

  
4. Select wInsight.qvw, and then click the Reload tab in the right pane. 
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5. On the Reload tab, mark the On an External Event option, and then click Apply. 

6. Expand the Translate folder and apply the On an External Event option to the following QVWs, as well: 

 Data_Model_wInsight.qvw 

 Transform_wInsight.qvw 

 wInsight_Analytics.qvw 

 wInsight_Analytics_MultiProject.qvw 

 wInsight_Metrics.qvw 

7. Click the Status tab and expand ReloadEngine@servername. 

8. Expand the Default folder and confirm that it contains the QVWs that you marked the On an External Event 
option for.   

9. Remain in the QlikView Management Console and continue to the next step. 

Step 6: Clear the Allow Session Recovery Check Box 
1. In QlikView Management Console, click the System tab and the Setup sub-tab. 

2. Expand QlikView Servers and select your QlikView server. 

3. In the right pane, click the Documents tab. 

4. Make sure that the Allow Session Recovery check box is not marked. 

  
5. Click Apply. 

6. Close the QlikView Management Console.  
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Step 7: License QlikView for Windows 

 
The procedure you use to license QlikView for Windows depends on the type of license you have: 

 Capped license - This process licenses the client version of QlikView by leasing a license from your server 
installation. 

 Uncapped license 
If you are not sure what type of license you have, contact your Deltek Account Manager. 

No Internet Access 

If you are installing wInsight Analytics on a computer with no Internet access, you need a copy of your QlikView 
License Enabler File (LEF). To request your LEF, contact CCOps@deltek.com. If you have someone in your company 
who has Internet access, you may get the LEF from this link: http://lef1.qliktech.com/manuallef/default.aspx. 

Capped License 

To launch and license QlikView for Windows using a capped license, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. Click Settings » User Preferences. 
3. On the General tab of the User Preferences dialog box, click Change Interface Language. 

4. On the Select Interface Language dialog box, select English if it is not already selected, and click OK. 

5. Click OK to close the User Preferences dialog box. 

6. On the QlikView File menu, click Open in Server. 
7. In the Server field, enter qvp://localhost and click Connect. 

The list below the Server field displays localhost. 

  

Note: The following steps assume that you are logged on as the QlikView Administrator account identified during the 
installation. If you have a capped license, your login account must also have access to the QlikView Server. 

mailto:CCOps@deltek.com
http://lef1.qliktech.com/manuallef/default.aspx
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8. Select wInsight_Analytics.qvw from the bottom list, and click Open. 

9. If the Module Security for Document dialog box displays, select Allow any Macro (only for trusted 
documents), and click OK. Mark the Always use this option for documents from this QlikView Server 
check box to prevent this dialog box from displaying in the future.  

10. Close QlikView. If a message displays asking if you want to save changes to wInsight_Analytics.qvw, click Yes. 

Uncapped License  

If you have an uncapped license, you have two keys initially: 

 A server license key  

 A standalone license key 

Note: QlikView for Windows always requires a standalone license key even if it is installed on a server. This allows you 
to access wInsight Analytics Module from the server to perform general maintenance, customizations, and data load 
process. 

The administrator account that you associate with the QlikView for Windows license is the only account that can be 
used to access QlikView for Windows and the wInsight Analytics Module on this computer. 

To launch and license QlikView for Windows using an uncapped license, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. From the Settings menu, click User Preferences. 

3. In the User Preferences dialog box, click the License tab. 

4. Click the Change button. 

5. Enter your QlikView for Windows standalone license key and control number, and click Next. 
6. Read the User License Agreement, and click I Agree.  

7. Take one of the following actions: 

 If you are installing on a computer with an Internet connection, a dialog box displays informing you that 
your license key has been validated. Click Continue in this dialog box and proceed to step 8.  

 If you are installing on a computer that does not have an Internet connection, a dialog box containing three 
options displays. Perform the following actions on that dialog box: 

a. Select Enter my License Information manually (LEF), and click Continue. 

b. Copy the contents of your License Enabler File (LEF) and paste it into the box under Enter your 
license enabling information. 

c. Click Next. A dialog box displays informing you that your license key has been validated. 

Note: If Next is grayed out, that means you pasted an invalid LEF. Contact CCOps@deltek.com 

d. When the license key has been validated successfully, click Continue. 

8. In the User Preferences dialog box, click OK. 

mailto:CCOps@deltek.com
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Step 8: Configure the wInsight Analytics Module 

Configure the Database Connection for wInsight Analytics Module 

If you are installing wInsight Analytics Module for the first time, Deltek recommends that you first test the analytics load 
process using the Sample.mdb database file (which is included in the installation) before you configure it to run against 
your own database.  

Attention: If you plan to use an MS SQL Server or Oracle database, see the Configure the Database Connection and 
wInsight Web Service Data Source Using an MS SQL Server or Oracle Database section. 

If you choose to load or restore your own projects into Sample.mdb to test the load process and dashboards, make 
sure you load multiple periods of those projects. 

Note: The wInsight database must contain at least one contract with more than one period of data. 

To configure the database connection for wInsight Analytics Module, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. On the File menu, click Open.  

3. In the Open dialog box, browse to the location of the Connection_Setup.qvw file, select the file, and click 
Open. 

 
4. If the Module Security for Document dialog box displays, select Allow any Macro (only for trusted 

documents), and click OK. 

5. On the File menu, click Edit Script, or press CTRL+E.  

6. On the Data tab of the Edit Script dialog box, select OLE DB from the Database drop-down list, and click 
Connect. 

7. On the Provider tab of the Data Link Properties dialog box, select Microsoft Office 12.0 Access Database 
Engine OLE DB Provider or Microsoft Office 15.0 Access Database Engine OLE DB Provider, and click 
Next 
If your OLE DB provider is not listed, install and configure it before proceeding. 

Note: The server installation requires 64-bit drivers. Deltek recommends SQL Server and Oracle databases for 
production use. For more information, see the Configure the Database Connection and wInsight Web Service 
Data Source Using an MS SQL Server or Oracle Database section. 

8. On the Connection tab of the Data Link Properties dialog box, do the following: 

a. Enter the location path of the database. For example, C:\ProgramData\Deltek\Analytics\data\Sample.mdb. 

b. Enter your user name and password (if applicable). For Access databases, the default user name is 
“Admin” and there is no password required.  

c. Select Allow saving password. 

9. Click Test Connection to check your connections.  

Note: By default, Connection_Setup.qvw is saved in C:\ProgramData\Deltek\Analytics\admin\. This .qvw file 
allows you to configure the connection information for QlikView component of wInsight Analytics. It also allows 
you to configure the data source for the wInsight Web Services used by the QlikView extension objects by 
clicking Select wInsight Datasource on the wInsight Analytics – Connection Setup tab. 
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10. If the connection test is successful, click OK. 

11. In the text box on the Main tab, scroll horizontally to the right end of the text area, and confirm that something 
similar to the text shown below displays (it will not be exactly the same). Verify that the password in the 
XPassword statement is encrypted. 

Note: If the password is not encrypted, click OK to close the Edit Script dialog box. In the main QlikView 
window, click Settings » User Preferences » General Tab, mark the Scramble Connect User Credentials 
check box, and repeat steps 5 – 9. 

 
12. From the File menu, click Export to Script File.  

If the Export to Script File option on the File menu is disabled, copy the entire CONNECT TO line (CTRL+C), 
open <installation location>\setup\Connection_wInsight.qvs in Notepad, paste (CTRL+V), and save the file.  

13. On the Save Script dialog box, browse to the location of the Connection_wInsight.qvs file, select the file, and 
click Save. By default, Connection_wInsight.qvw is saved in C:\ProgramData\Deltek\Analytics\setup\. 

14. When asked to replace the existing Connection_wInsight.qvs file, click Yes.  

15. Click OK to close the Edit Script dialog box. 

Do not close QlikView as you still need to configure the wInsight data source in the next step.  

Configure the wInsight Web Service Data Source 

This procedure assumes that you have configured an MS Access database connection in the previous step. 

Note: If you have configured an MS SQL Server or Oracle database connection in the previous step, see the Configure 
the Database Connection and wInsight Web Service Data Source Using an MS SQL Server or Oracle Database for 
more details. 

To configure the data source used by the wInsight Analytics Web service, complete the following steps: 
1. In the main QlikView window, click Select wInsight Datasource.  

2. On the Data Sources dialog box, click Add. 
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3. On the Provider tab of the Data Link Properties dialog box, select Microsoft Office 12.0 Access Database 
Engine OLE DB Provider or Microsoft Office 15.0 Access Database Engine OLE DB Provider, and click 
Next. 

4. On the Connection tab, perform the following actions: 

a. Enter the location path of the database. For example, C:\ProgramData\Deltek\Analytics\data\Sample.mdb. 

b. Enter your user name and password (if applicable). The default user name is “Admin” and there is no 
password required. 

c. Select Allow saving password. 

5. Click Test Connection to check your connections. 

6. If the connection test is successful, click OK. 
7. On the Edit Data Source dialog box, enter a name for the data source and click OK.  
8. On the Data Sources dialog box, make sure that the newly added data source is selected, and click OK.  

9. Close QlikView.  

10. When asked to save the changes to Connection_Setup.qvw, click Yes. 

Note: These steps update both the WSDATA.ini and App.config files with the selected data source. 

Step 9: Configure Data Load Settings and Perform Data Load 
After you perform this task, make sure you copy any customizations that you did from the old QVW files (which are 
located in the <installation location>\Backups folders) into their new respective <installation location> folders. 

Note: If you are upgrading from a previous version of the wInsight Analytics Module, you have the option to apply your 
previous configuration settings. For more information, see Appendix D: Apply Previous Configuration Settings. 

The installation process backs up existing QVW files (under the final, admin, and setup folders) prior to installing 
updated ones. These files are backed up to the <installation location>\Backups folder.  

To configure data load settings and perform data load, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. On the File menu, click Open. 

3. On the Open dialog box, navigate to the wInsight_Analytics_Config.qvw file, select the file, and click Open.  

By default, wInsight_Analytics_Config.qvw is in C:\ProgramData\Deltek\Analytics\admin\. 

4. On the Tools menu, click Edit Module. 

5. If Requested Module Security does not contain System Access in the Edit Module dialog box, select that 
option. 

6. If Current Local Security does not contain Allow System Access in the Edit Module dialog box, select that 
option. 

7. Click OK and save the file. 

8. Under wInsight Database on the wInsight Analytics Configuration tab, select Access. 
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9. Click Update from wInsight Database. The Script Execution Progress dialog box displays the progress of the 
update. 

10. If you have used the Element Type field to identify which elements represent control accounts (CAs) and work 
packages (WPs), the codes you used will be under the Element Type column as element types. You need to 
mark each element type as C if it is a control account or W if it is a work package.  

 
Attention: For more information about CAs and WPs, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 

11. Update the information for the following project fields: 

 Current Period 
 Historical Data 
 Forecast Data Load 
 Unit Used as Element of Cost  
Attention: For more information about these fields, see the Configuration section of the wInsight Analytics 
Module 8.2 Administration Guide. 

12. Mark the WBS OBS Link check box, if it is not already marked. 

Attention: For more information about the WBS OBS Link, see the Configuration section of the wInsight 
Analytics Module 8.2 Administration Guide. 
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13. Click Save Settings for wInsight Analytics. If this process is successful, a “Configuration settings have been 
saved…” message displays. Click OK in the message. 

14. Click Run Data Load Batch File to start the data load. The Script Execution Progress dialog box displays the 
progress of the data load. When the processes are completed, the command window closes. 

 
Note: You have the option to run the Load_wInsight_Data.bat file manually. In Windows Explorer, go to \admin 
folder and double-click the Load_wInsight_Data.bat file. If QlikView asks if you approve the application for 
launch, click Yes. This batch file runs a number of processes in a command window. 

Step 10: Test the QlikView AccessPoint 
1. Launch your browser and enter the URL for your QlikView Server Access Point: 

https://servername/QlikView/index.htm.  

2. Open wInsight_Analytics.qvw. 

  

https://servername/QlikView/index.htm
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3. Click the Web Services Test tab, and click Test Web Services.    

 
4. If that succeeds, click the Project Load tab. 

5. Select the Load All Projects check box, if it is not yet selected.  

6. In the wInsight Database field, select the type of database used to store your wInsight data (MS Access, 
Oracle, or MS SQL Server). 

7. Click Update from wInsight Database. The Data Load Status pane displays the progress of the configuration 
update. 

8. When the configuration update is complete, press F5 to refresh the page. 

9. If you have used the Element Type field to identify which elements represent control accounts (CAs) and work 
packages (WPs), the codes you used will be in the Work Package Control Account section as element types. 
You need to mark each element type as C if it is a control account or W if it is a work package.  

 
Attention: For more information about CAs and WPs, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 
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10. Update the information for the following project fields: 

 Current Period 
 Historical Data 
 Forecast Data Load 

 Unit Used as Element of Cost (click  to specify the units that represent Element of Cost). 

Attention: For more information about these fields, see the Configuration section of the Deltek wInsight 
Analytics Module 8.2 Administration Guide. 

11. Mark the WBS OBS Link check box, if it is not already marked. 

Attention: For more information about the WBS OBS Link, see the Configuration section of the wInsight 
Analytics Module 8.2 Administration Guide. 

12. In the No. of Levels of WBS to Support field, specify the number of hierarchical levels of the work breakdown 
structure that you want to include in the data load. Use this field to select the amount of detail that is loaded 
into wInsight Analytics Module if your wInsight database is very large. 

13. Leave the Load Metrics check box unmarked.  

14. If this is your first time to load data for all projects, leave the Delete QVDs check box unmarked. Otherwise, 
always select the check box if you select Load All Projects.   

15. Click Save Settings. If this process is successful, a “Configuration settings have been saved…” message 
displays.  

16. Click Run Data Load. You must perform a full data load before you can run single-project data loads. If this 
process is successful, a “Backed up QVWs from \publish folder…” message displays and your wInsight 
Analytics is up and running. 

Step 11: Configure IIS to use Self-Signed Certificate 
1. Open the Internet Information Services (IIS) Manager, which you can access by clicking Control Panel » All 

Control Panel Items » Administrative Tools. 

2. In the Connections panel (left), click the server at the top of the list. 

3. In the center panel, under the IIS section, double-click Server Certificates. 

 
4. In the Actions panel (right), click Create Self-Signed Certificate. 
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5. On the Specify Friendly Name page, specify the certificate name of your preference, and click OK. In the 
following example, the certificate name is WAMSSL: 

 

6. In the Server Certificates panel (center), the newly created certificate displays. Take note of the value in the 
Issued To column of the certificate. It indicates the host name registered with the SSL certificate, and will be 
used in the URL to browse QlikView AccessPoint in the secured Website. 

 

7. In the Connections panel (left), select the Web site. 

8. In the Actions panel (right), under the Edit Site section, click Bindings…. 

9. On the Site Bindings dialog box, click Add. 

10. On the Add Site Binding dialog box, select https in the Type drop-down list. 

11. In the Host name field, enter the host name registered with the SSL certificate (see step 6) and then select the 
Require Server Name Indication option. 

12. In the SSL certificate drop-down list, select the self-signed certificate that has been created for the website, 
and click OK. 
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13. In Internet Explorer, click Tools » Internet Options.  

14. On the Internet Options, on the Content tab, click the Clear SSL State button, and click OK. 

 
15. Close Internet Explorer. 

16. Open Internet Explorer again, and browse through the secured QlikView AccessPoint Web site using the URL 
https://<host name>/qlikview. 

17. If Windows Security prompts for credentials, enter your Windows domain account credentials. 

18. Check if the secured page icon shows up in the address bar. 

 
19. Make sure you can only browse QlikView AccessPoint using the secured URL. To do this, take the following 

steps: 

a. Open the IIS Manager. 

b. In the Connections panel (left), select the Web site. 

c. In the center panel, double-click SSL Settings. 

d. In the SSL Settings panel, select the Require SSL option and the Ignore option under Client 
Certificates. 

 
e. In the Actions panel (right), click Apply. 

20. In the \admin sub-folder of the wInsight Analytics Module data folder, select Config.dat and open it in a text 
editor. 
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21. Change the WebServiceURL and HelpFQDN values to the secured URL. 

 

22. Run the SetWebServicesURL.bat file to set the Web services URL. 

Step 12: Make the wInsight Analytics Module Server a Trusted Site 
To avoid a variety of problems that can occur due to browser internet/intranet security, all wInsight Analytics Module 
users, regardless of how they access the product, should add the wInsight Analytics Module server (https://<host 
name>) to their list of trusted sites on the Security tab of the Internet Options dialog box in Microsoft Internet Explorer.  

Step 13: Install the Self-Signed Certificate on a Client Machine 
1. In your Internet Explorer browser, open the secured QlikView AccessPoint Web site https://<host 

name>/qlikview. 

2. An error page related to a security certificate displays. Click the Continue to this website (not 
recommended). option to open the QlikView AccessPoint page. 

 

3. On the QlikView AccessPoint page, a certificate icon error displays in the address bar. Click the certificate icon. 
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4. On the Untrusted Certificate message, click the View Certificates link. 

 

5. Click the Install Certificates button to launch the Certificate Import Wizard, and click Next. 
6. On the Certificate Store page, select the Place all certificates in the following store option, and then click 

the Browse button to select the Trusted Root and Certification Authorities option. 

 
7. Click Next, and click Finish. 

8. If a security warning displays to confirm the installation of the certificate, click Yes. 

9. Close the Certificate dialog box. 

10. In your Internet Explorer browser, click Tools » Internet Options.  

11. On the Content tab, click the Clear SSL State button, and click OK. 

12. Close Internet Explorer. 

13. Open Internet Explorer again, and browse through the secured QlikView AccessPoint Web site using the URL 
https://<host name>/qlikview. 

14. If Windows Security prompts for credentials, enter your Windows domain account credentials. 

15. Check if the secured page icon shows up in the address bar. 
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Step 14: Add QlikView EDX User Accounts 

 
Add to QlikView EDX local security group the QlikView service account and all AccessPoint users that will be given 
access to the Project Load page of wInsight_Analytics.qvw. 

Add User Accounts to the QlikView EDX Local Security Group 

1. Open the Computer Management, which you can access by clicking Control Panel » All Control Panel Items 
» Administrative Tools. 

2. In the left panel, click System Tools » Local Users and Groups » Groups. 

3. In the middle panel, right-click the QlikView EDX name and select Add to Group…. 

 
4. On the Users Properties dialog box, click Add. 

5. On the Select Users, Computers, Services Accounts, or Groups dialog box, enter the name of users you want 
to add. 

6. Click OK. 

Step 15: Security for wInsight Analytics Module 
The wInsight Analytics Module uses the security information in Deltek EPM Security Administrator (EPM SA) to 
determine who can use the module and which contracts they have access to. The EPM SA tool is installed when you 
install wInsight Analytics Administrator. 

Specify EPM Security Administrator and IIS Server Security Options 

Depending on whether or not you will use wInsight Analytics Module security, you must specify security options in EPM 
Security Administrator and in the IIS server. 

 If you are using wInsight Analytics Module security: 
 In EPM Security Administrator, set the Authentication Mode to Windows. For more information, see the 

EPM Security Administrator online help. 

Note: This step is only applicable if wInsight Analytics Module Security is enabled. 
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 In the IIS server under the WSWebSvc web site, enable Windows Authentication and disable 
Anonymous Authentication. For more information, see the Microsoft Internet Information Services (IIS) 
documentation 
(https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication) 

 If you are not using wInsight Analytics Module security: 
 In EPM Security Administrator, set the Authentication Mode to None. For more information, see the EPM 

Security Administrator online help. 
 In the IIS server under the WSWebSvc web site, enable Anonymous Authentication. For more 

information, see the Microsoft Internet Information Services (IIS) documentation 
(https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication). 

Enable the wInsight Analytics Module Security 

Security in the wInsight Analytics Module is based on the security set up in EPM SA. If you are not using wInsight 
Analytics modeul security, you can skip this section. 

Attention: For more information about the security model, see the Deltek EPM Security Administrator Online Help. 

To enable security in the wInsight Analytics Module, you must complete the following steps: 
1. Log on to EPM SA. 

2. In the Explorer pane, expand the Products folder and select wInsight. 
3. On the menu bar, click Tools » Authentication Options. 

4. On the Authentication Options dialog box, select Windows in the Authentication Mode drop-down list and 
Windows Domain\User Name in the Authentication Type drop-down list. This setting requires users to use 
Windows Authentication when logging on to the application, which is the supported authentication by wInsight 
Analytics Module.  

5. Click OK. 

Add QlikView Service Account as a New User 

 
In the EPM Security Administrator: 

 Add the QlikView service account as a new user. Make sure to set the domain name (if domain user) or 
machine name (if local user) in the Domain field. 

 Add QlikView service account in the SYSADMIN Group.   

Add New wInsight Analytics Users to EPM Security Administrator 

Any wInsight Analytics user who will access QlikView AccessPoint must be added to the EPM Security Administrator, 
regardless of whether that user will perform data loads or not. Deltek recommends that the user performing data load 
be added to the SYSADMIN group in EPM Security Administrator. 

Note: If security is enabled for the wInsight Analytics Module, the data load process loads all wInsight Analytics users 
who are set up for Windows authentication, whether those users are domain users or are set up for Windows 
authentication on the wInsight Analytics server. The wInsight Analytics Module does not support access for users who 
are not set up for Windows authentication. 

Note: This step is only applicable if wInsight Analytics Module security is enabled. 

https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication
https://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication
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To add a new module user, set that person up in wInsight Analytics as a Windows authentication user, and give them 
the appropriate access to contracts. Then, run the data load process to add their access information to the analytics 
data model. 

Attention: For more information, see the Deltek EPM Security Administrator Online Help. 

User Authentication 

When a user runs the wInsight Analytics Module, Windows authentication determines whether they gain access to the 
module. 

Access to Contracts 

A wInsight Analytics user is granted access to contracts either individually or through a user group. The data load 
process loads that access information into the wInsight Analytics data model. In most cases, a user automatically has 
access to data for the same set of contracts in the wInsight Analytics Module as he or she does in wInsight Analytics 
Desktop/wInsight Analytics Administrator. 

Users Created During Installation 

The two administrative users created during the installation process (DeltekAnalytics and DelteAnalyticsCW) are not 
automatically users within the wInsight Analytics database and have no automatic access to projects within the 
database. If security is turned on in wInsight Analytics, then a person logged in using one of these user names would 
not see any projects after loading data. These users can either be added to the wInsight Analytics database or wInsight 
Analytics security can be turned off in EPM SA while the initial data load is run and checked before being turned back 
on for production purposes. 

Security for wInsight Analytics Configuration 

wInsight Analytics provides no internal security for the configuration applications and related administrative files. Be 
sure that only the appropriate persons have access to the network or standalone computer folders in which you 
installed wInsight Analytics. 

If you are loading data using wInsight_Analytics_Config.qvw, the Apply Security setting in the Security section on the 
wInsight Analytics Configuration tab indicates whether you want to use wInsight Analytics Module security and saves 
the security status (whether you set Apply Security to Yes), which wInsight_Analytics.qvw uses in the authentication 
process. 
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Post Installation 

Multiple wInsight Databases 
If your core wInsight Analytics data is divided among multiple databases, Deltek strongly recommends that you 
consolidate those databases into one to take full advantage of the capabilities of the wInsight Analytics Module. 
Existing wInsight functionality is available to accomplish the consolidation. Contact Customer Care if you have 
questions about how to do that. 

A given instance of the wInsight Analytics Module can only be connected to one core wInsight database. If you want to 
retain multiple databases and you want to use the wInsight Analytics Module to perform data analysis on the 
databases, you must set up one instance of the wInsight Analytics Module for each core wInsight database. 

Configure the Database Connection and wInsight Web Service Data 
Source Using an MS SQL Server or Oracle Database 
Use the procedures in configuring the database connection and wInsight Web service data source discussed in this 
section if you plan to use an MS SQL Server or Oracle database. 

Configure the Database Connection 

To configure the database connection for wInsight Analytics Module, complete the following steps: 
1. Launch QlikView for Windows by doing one of the following: 

a. Start » All Programs » Deltek wInsight Analytics » QlikView. 

b. Navigate to C:\Program Files\QlikView\Qv.exe. 

2. On the File menu, click Open.  

3. In the Open dialog box, browse to the location of the Connection_Setup.qvw file, select the file, and click 
Open. This .qvw file allows you to configure the connection information for QlikView component of wInsight 
Analytics. It also allows you to configure the data source for the wInsight Web Services used by the QlikView 
extension objects by clicking Select wInsight Datasource on the wInsight Analytics – Connection Setup tab. 

 For server installation, by default, Connection_Setup.qvw is saved in 
C:\ProgramData\Deltek\Analytics\admin\. 

 For standalone installation, navigate to your Documents library, click Deltek » Analytics » admin, and 
select Connection_Setup.qvw, and click Open. 

Note: <Documents> refers to Documents in Windows 8/8.1 and My Documents in Windows 7. 

4. If the Module Security for Document dialog box displays, select Allow any Macro (only for trusted 
documents), and click OK. 

5. On the File menu, click Edit Script, or press CTRL+E.  

6. On the Data tab of the Edit Script dialog box, select OLE DB from the Database drop-down list, and click 
Connect. 

7. On the Provider tab of the Data Link Properties dialog box, do one of the following: 

 If your wInsight Analytics database is Microsoft SQL Server, select Microsoft OLE DB Provider for SQL 
Server or SQL Server Native Client, depending on your setup, and click Next. 
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Note: If you use SQL Server Native Client, you must set the Persist Security Info field on the All tab of 
the Data Link Properties dialog box to “True.”  To do this, complete the following steps: 

a. While still In the Data Link Properties dialog box, click the All tab. 

b. Scroll down and double-click Persist Security Info. 

c. Select True in the Property Value field of the Edit Property Value dialog box. 

 If your wInsight Analytics database is Oracle, select Oracle Provider for OLE DB, and click Next. 
 If your OLE DB provider is not listed, install and configure it before proceeding. 

Note: The server installation requires 64-bit drivers. Deltek recommends SQL Server and Oracle databases for 
production use. 

8. On the Connection tab of the Data Link Properties dialog box, do the following: 

Microsoft SQL Server: 
a. In Select or enter a server name, enter your wInsight Analytics database server name. 

b. Select Use a specific user name and password, and enter your user name and password.  

This was the user name you created when you set up the wInsight database using the Deltek wInsight 
Analytics Administrator.  

c. Select Allow saving password. 
d. In Select the database on the server, select your wInsight Analytics database. 

Oracle: 
a. In Data Source, enter the TNS names ID for the Oracle connection. 

b. Under Use a specific user name and password, enter your user name and password. 

This was the user name you created when you set up the wInsight database using the Deltek wInsight 
Analytics Administrator.  

c. Select Allow saving password. 

9. Click Test Connection to check your connections.  

10. If the connection test is successful, click OK. 

11. In the text box on the Main tab, scroll horizontally to the right end of the text area, and confirm that something 
similar to the text shown below displays (it will not be exactly the same). Verify that the password in the 
XPassword statement is encrypted. 

Note: If the password is not encrypted, click OK to close the Edit Script dialog box. In the main QlikView 
window, click Settings » User Preferences » General Tab, mark the Scramble Connect User Credentials 
check box, and repeat steps 5 – 9. 
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Microsoft SQL Server 

  
Oracle 

 
12. On the File menu, click Export to Script File.  

If the Export to Script File option on the File menu is disabled, copy the entire CONNECT TO line (CTRL+C), 
open <installation location>\setup\Connection_wInsight.qvs in Notepad, paste (CTRL+V), and save the file.  

13. In the File name field of the Save Script dialog box, browse to the location of the Connection_wInsight.qvs 
file, select the file, and click Save.  

 For the server installation, Connection_wInsight.qvw is saved in C:\ProgramData\Deltek\Analytics\setup\ 
by default. 

 For the standalone installation, it is saved in C:\Users\<User name>\<Documents>\Deltek\Analytics\setup 

14. When asked to replace the existing Connection_wInsight.qvs file, click Yes.  
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15. Click OK to close the Edit Script dialog box. 

Attention: For the server installation, do not close QlikView as you still need to configure the wInsight Web service 
data source. For the standalone installation, close QlikView and then click Yes when asked to save the changes to 
Connection_wInsight.qvw. Proceed to Step 4: Configure Data Load Settings and Perform Data Load. 

Configure the wInsight Web Service Data Source 

To configure the data source used by the wInsight Analytics Web service, complete the following steps: 
1. In the main QlikView window, click Select wInsight Datasource.  

2. In the Data Sources dialog box, click Add. 

3. On the Provider tab of the Data Link Properties dialog box, select the appropriate database provider for your 
database, and click Next. 
 If your wInsight Analytics database is Microsoft SQL Server, select Microsoft OLE DB Provider for SQL 

Server or SQL Server Native Client, depending on your setup.  

Note: If you use SQL Server Native Client, you must set the Persist Security Info field on the All tab of 
the Data Link Properties dialog box to “True.”  To do this, complete the following steps: 

a. While still In the Data Link Properties dialog box, click the All tab. 

b. Scroll down and double-click Persist Security Info. 

c. Select True in the Property Value field of the Edit Property Value dialog box. 

 If your wInsight Analytics database is Oracle, select Oracle Provider for OLE DB. 

4. On the Connection tab, perform the following actions: 

Microsoft SQL Server: 
a. In Select or enter a server name, enter your wInsight Analytics database server name. 

b. Select Use a specific user name and password, and enter your user name and password.  

This was the user name you created when you set up the wInsight database using the Deltek wInsight 
Analytics Administrator.  

c. Select Allow saving password. 

d. In Select the database on the server, select your wInsight Analytics database. 

Oracle:  
a. In Data Source, enter the TNS names ID for the Oracle connection. 

b. Under Use a specific user name and password, enter your user name and password. 

This was the user name you created when you set up the wInsight database using the Deltek wInsight 
Analytics Administrator.  

c. Select Allow saving password. 

5. Click Test Connection to check your connections. 

6. If the connection test is successful, click OK. 
7. In the Edit Data Source dialog box, enter a name for the data source and click OK.  
8. In the Data Sources dialog box, make sure that the newly added data source is selected, and click OK.  

9. Close QlikView.  
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10. When asked to save the changes to Connection_Setup.qvw, click Yes. 

Note: These steps update both the WSDATA.ini and App.config files with the selected data source. 

You can now configure data load settings and perform data load either via wInsight_Analytics_Config.qvw or QlikView 
AccessPoint. 

Attention: For more information, see the Step 8: Configure Data Load Settings and Perform Data Load section. 

Change the TCP Port 
For server / IIS installations, if you need to change the TCP Port used by the QlikView Web Server Service, perform the 
following procedure: 

To change the port number, complete the following steps: 
1. Go to the <installation location>\Server\Web Server folder. By default, the Server\Web Server folder is in 

C:\Program Files\QlikView\. 

2. Back up QVWebServer.exe.config. 

3. Open QVWebServer.exe.config in a Text editor and change the port value to the desired port as shown below 
in the value= area. 
"<!-- The port the service listens to. --> 

<add key="WebservicePort" value="4750"/>" 

4. Save the file 

5. Restart the Web Server Service (QlikView Web Server) or the Settings Service (IIS Web server) 

6. Open the QlikView Management Console. 

7. Click System » Setup » QlikView Web Servers. 

8. Click the Edit button. 

9. Change the default TCP port of 4750 to the port specified in step 3 (for example, 
http://<servername>:4750/QVWS/Service). 

10. Click Apply. 

11. Click Status » Services to verify the QVWS resource is online. 
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Appendix A: Set Up User Accounts for Loading Data 
The user performing the data load must be a member of the SYSADMIN group. Below are some of the requirements 
for this user: 

 The user must have Administrator access to the server hosting the wInsight Analytics Module. 

 This applies to server installations only. The user must be a member of the QlikView Administrator and 
wInsight Administrator groups.  

 To perform data loading from a Standalone PC or a Server, the user needs a licensed QlikView for Windows 
account. 

 This applies to server installations only. To perform data loading from the QlikView AccessPoint, the user 
needs a license in the QlikView Management Console. 

Note: In the event that data load will be performed by a user who is not a member of the SYSADMIN group and 
wInsight security is enabled, that user must have access to at least one contract in the database. That user must also 
have a role in the Deltek EPM Security Administrator that allows him/her to perform project loads. 

The installer automatically creates wInsight Analytics Administrator and QlikView Administrator groups that have full 
control rights to wInsight Data and QlikView folders. The next steps should only be done if you need to add new user 
who will perform data loads and that user was not added during the installation of the wInsight Analytics Module. 

Add a New User Account to wInsight Analytics Module 
The System Administrator can add a new user who will be responsible for loading data to the wInsight Analytics 
Module.  

To add a new user account to wInsight Analytics Module, complete the following steps:  
1. Click Start » Control Panel » Administrative Tools » Computer Management. 
2. On the Computer Management screen, click Local Users and Groups » Groups. 

3. Add the user to the following groups:  

 QlikView Administrators  

 wInsight Administrator  
Note: Make sure the From this location field on the Select Users, Computers, Service Accounts, or Groups 
dialog box is for the domain or local machine, depending on which user(s) you are adding. Click Locations to 
change between domain and local machine names. 
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Adding the user to these groups gives full control permission to the following files: 

 QlikView Application files — C:\Program Files\QlikView 

 wInsight Application files — C:\Program Files\Deltek\wInsight Analytics 

 wInsight Data files — C:\ProgramData\Deltek\Analytics 

Attention: Any wInsight Analytics user who will access QlikView AccessPoint must be added to the EPM Security 
Administrator, regardless of whether that user will perform data loads or not. For more information, see the Security for 
wInsight Analytics Module section. 

For additional information on loading data from the wInsight database to the wInsight Analytics Module see the 
Configuration and Data Load chapters of the Deltek wInsight Analytics Module 8.2 Administration Guide. 
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Appendix B: Add Users to the QlikView Server from a 
Directory (For Capped Licenses) 
By linking QlikView to a directory, you can easily add users to the QlikView Server for capped licenses, which allow 
them to access wInsight Analytics Module from the QlikView AccessPoint URL. 

Link a Directory to the QlikView Server 

To link a Directory to the QlikView Server, complete the following steps: 
1. Launch the QlikView Management Console in one of the following ways: 

 Click Start » All Programs » Deltek wInsight Analytics » QlikView Management Console. 

 Run Internet Explorer and go to http://localhost:4780/qmc/default.htm. 

Note: If you are asked to log on when you run QlikView Management Console, log on with the user name and 
password for the service account that you entered during the installation. 

Select Remember my credentials and click OK. 

2. If you see the following message in the browser window, click the message bar and select Enable Intranet 
Settings: 

“Intranet settings are now turned off by default. Intranet settings are less secure than Internet options. Click for 
options…” 

Click Yes to confirm that you want to turn on intranet security settings. 

3. In the QlikView Management Console, click the System tab, and then click the Setup sub-tab. 

4. Expand the Directory Service Connectors folder. 

5. Expand DSC@machinename and select a directory type. 

    

6. In the right pane, click . 

7. Configure the following text boxes: 

http://localhost:4780/qmc/default.htm
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 Path – Enter the LDAP path to the directory service. You may also click  (Get Default) to get the default 
LDAP path. The default path corresponds to the domain of the account that you used in installing wInsight 
Analytics Module.  

Attention: For more information, see Requirements for Using Domain Accounts as the Service Accounts.    

 User Name – Enter the user name for the account used to access the directory service using this format: 
<DOMAIN>\<USER NAME>. 

 Password – Enter the password for the account used to access the directory service. 

8. Click Apply. 

Add Users from a Directory to the QlikView Server 

To add users from a Directory to the QlikView Server, complete the following steps: 
1. In the QlikView Management Console, click the System tab, and then click the Licenses sub-tab. 

2. Under Type, select QlikView OEM Server. 
3. Click the Client Access Licenses (CALs) tab in the right pane, and click the Assigned CALs sub-tab. 

 

4. Click  (Manage Users). 

5. In the Manage Users dialog box, use the Default Scope field to select the directory that you want to use. You 
may select any of the directories that you linked to the QlikView Server using the procedure in Link an Active 
Directory to the QlikView Server.  

You may also use the default value (All Directories) to display all directories linked to the QlikView Server.  
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6. In the Search for Users and Groups field, enter the name of the user that you want to add to the QlikView 
Server followed by an asterisk. For example: johndoe*. 

Attention: For more information about the supported search criteria for adding user names to the QlikView 
Server using directories, see the “Search Functions” topic in the QlikView Management Console online help. 

7. Click . The Search Result column is populated by user names that matched your search criteria. 

8. Select the users that you want to add to the QlikView Server and click Add.  

You may select multiple users simultaneously by using Shift + Left Click or Ctrl + Left Click.  

For user names that do not exist in the selected directory, use the Manual Input of User Names field. 

9. After adding users to the Selected Users column, click OK. 

10. On the Assigned CALs sub-tab, click Apply. 
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Appendix C: Uninstall QlikView 
If you need to upgrade your QlikView version, use these steps to uninstall your current version before you install the 
new version. 

To uninstall QlikView and prepare for the new installation, complete the following steps: 
1. In Windows Control Panel, uninstall any of the following that appear in your list of installed programs: 

 QlikView x64 

 QlikView Server x64 (server installations only) 

 QlikView Plugin (server installations with cache warming implemented only) 

2. In Windows Explorer, delete the following folders: 

 C:\Program Files\QlikView 

 C:\ProgramData\QlikTech 

3. This step applies to server installations only. In Computer Management, navigate to the Local Users and 
Groups/Users folder and delete the user DeltekAnalytics. 

4. This step applies to server installations only. Still in Computer Management, navigate to the Local Users and 
Groups/Groups folder, double-click the QlikView Administrators group, and remove the DeltekAnalytics user. 

5. In Task Scheduler, delete all jobs that begin with DeltekwInsightAnalytics. There could be up to three of 
those jobs. 

6. Restart the server or standalone computer. 
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Appendix D: Apply Previous Configuration Settings 
The information in this section applies only if you are upgrading from a previous version of the wInsight Analytics 
Module and you want to use your previous configuration settings in the new version. 

Note: The installation process backs up existing QVW files (under the final, admin, and setup folders) prior to installing 
updated ones. These files are backed up to the <installation location>\Backups folder. If you have customized the 
dashboards, you can access your changes by opening the backup files in the folder indicated above and then copying 
the changes to the new QVW files. 

To upgrade from a previous version of the wInsight Analytics Module and apply your previous configuration 
settings, complete the following steps:  
Note: If you have extended the wInsight Analytics Module by modifying the standard analytics or data models, you may 
also need to reapply those changes. 

1. From the backup you made of your wInsight Analytics Module installation folder and subfolders, copy the 
connection_wInsight.qvs from the <backup location>\setup folder into the <new installation location>\setup 
folder. 

2. If wInsight_Analytics_Config.qvw has been updated and you want to apply the previous wInsight Analytics 
Module configuration settings to the new version, do the following: 

a. Double-click the newly installed copy of wInsight_Analytics_Config.qvw. 

b. Click Update from wInsight Database. 
c. From your backup, go to the <backup location>\admin folder and run the old version of 

wInsight_Analytics_Config.qvw to display your previous configuration settings. 

d. Duplicate those settings in the new version of wInsight_Analytics_Config.qvw. 

e. Click Save Settings for wInsight Analytics. 

f. On the QlikView toolbar, click  to save your configuration. 
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Appendix E: Check the QlikView License Validity 
Use the procedures in this section to check your license (for QlikView Server and QlikView for Windows) and request 
an update if required.  

Important: This release includes updating the QlikView application to version 12.2. It may require an update to your 
QlikView license as licenses with a validity date prior to the release of version 12.2 (November 2017) will not work with 
this version.  

To check the validity of your QlikView license, complete the following steps: 
1. In your browser, open the following link: 

http://lef1.qliktech.com/manuallef/default.aspx  

2. In the License Key field, enter your license key (QlikView Server or QlikView for Windows). 

3. Click the Request LEF button. 

4. Verify the LEF. In the following example, the date in the PRODUCTLEVEL line indicates the validity of your 
license.  

    
5. If the date indicated is prior to NOV 2017, send an email to Hq-Distribution@deltek.com with the expired/invalid 

license key before installing wInsight Analytics Module 8.2 to have your license updated. 

When you get your updated license, you can proceed to install the wInsight Analytics Module. 

 Server installation - For information on how to install the wInsight Analytics Module on a server, see Server 
Installation. 

 Standalone Installation - For information on how to install the wInsight Analytics Module on a standalone 
computer, see Standalone Installation. 

 Internet information Services (IIS) Installation - For information on how to install the wInsight Analytics 
Module to run under Internet Information Services (IIS), see Internet Information Services (IIS Installation). 

No Internet Access 
If you are installing wInsight Analytics on a computer with no Internet access, you need a copy of your QlikView 
License Enabler File (LEF). To request your LEF, contact CCOps@deltek.com. If you have someone in your company 
who has Internet access, you may get the LEF from this link: http://lef1.qliktech.com/manuallef/default.aspx. 

  

http://lef1.qliktech.com/manuallef/default.aspx
mailto:Hq-Distribution@deltek.com?subject=Request%20to%20Update%20QlikView%20License
mailto:CCOps@deltek.com
http://lef1.qliktech.com/manuallef/default.aspx
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Appendix F: If You Need Assistance 
If you need assistance installing, implementing, or using wInsight Analytics Module, Deltek makes a wealth of 
information and expertise readily available to you. 

Customer Services 
For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems, listening to 
their needs, and getting to know their individual business environments. A full range of customer services has grown 
out of this close contact, including the following: 

 Extensive self-support options through the Deltek Support Center. 

 Phone and email support from Customer Care analysts 

 Technical services 

 Consulting services 

 Custom programming 

 Classroom, on-site, and Web-based training 

Attention: Find out more about these and other services from the Deltek Support Center. 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 
 Search for product documentation, such as release notes, install guides, technical information, online help 

topics, and white papers 
 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the Deltek Support 

Center Community 
 Access Cloud-specific documents and forums 
 Download the latest versions of your Deltek products 
 Search Deltek’s knowledge base 
 Submit a support case and check on its progress 
 Transfer requested files to a Customer Care analyst 
 Subscribe to Deltek communications about your products and services 
 Receive alerts of new Deltek releases and hot fixes 
 Initiate a Chat to submit a question to a Customer Care analyst online 

Attention: For more information regarding Deltek Support Center, refer to the online help available from the Web site. 
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Access Deltek Support Center 

To access the Deltek Support Center:  
1. Go to http://support.deltek.com.  

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

Note: If you forget your username or password, you can click the Need Help? button on the login screen for help. 

Additional Documentation 
The following table lists the Deltek documentation available for this release. Except where noted, all the user guides 
and quick reference guides listed in this table are available for download from the Deltek Support Center. 

Document Name Description 

Deltek wInsight Analytics Module 8.2 
Administration Guide 

This guide describes how to configure the wInsight Analytics Module, 
how to set up security, and how to import data. 

Deltek wInsight Analytics 8.2 Product 
Overview 

This document provides a high-level overview of the product together 
with some guidance as to which modules should be installed to meet 
the needs of individual users. Most users would not need access to all 
modules. 

Deltek wInsight Analytics 8.2 Release 
Notes for the wInsight Analytics Module 

This document contains a summary of the technical considerations, 
new features, and enhancements of the application. 
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Deltek is the leading global provider of enterprise software and information solutions for government 
contractors, professional services firms and other project- and people-based businesses. For decades, we 
have delivered actionable insight that empowers our customers to unlock their business potential. 20,000 
organizations and millions of users in over 80 countries around the world rely on Deltek to research and identify 
opportunities, win new business, recruit and develop talent, optimize resources, streamline operations and deliver 
more profitable projects. Deltek – Know more. Do more.® 
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